Restrictions:
- Unlike in XE, in XR we need ospfv2 for IPv4 and ospfv3 for IPv6. Also Ospfv2(in XR) cannot form neighborship with ospfv3(ipv4 in XE/IOS)
- OSPF stub routing on XRv (virtual) does not work
- OSPFv3 IPv4 nssa does not work in XE/ IOS. Use ospfv2 for ipv4 nssa
- For Stub routing to work on any one router to work, that router must have atleast one interface in area0 i.e. connected to backbone area (Hint: Use loopbacks)
- When configuring passive interface using OPSFv3 in IOS/ XE, network prefixes unlike in XR by default won't get advertised with LSA, on top of that we don't have specific command to advertise passive interface in OSPFv3 for IOS and XE. We can use tools like redistribute connected with route-maps.
Configurations IPv4
IOS/XE
router ospf 200
router-id 200.0.0.23
network 0.0.0.0
0.0.0.0 area 0
OR
router ospf 200
router-id 200.0.0.23
!
interface
Ethernet0/0
ip ospf network point-to-point
ip ospf 200 area
0
!
OR
router ospfv3 10
router-id
2.2.2.2
!
address-family ipv4 unicast
passive-interface
Loopback0
exit-address-family
!
address-family ipv6
unicast
passive-interface
Loopback0
exit-address-family
!
interface
GigabitEthernet3
ospfv3 10 network point-to-point
ospfv3 10
ipv4 area 0
ospfv3 10 ipv6 area 0
!
interface
GigabitEthernet4
ospfv3 10 network point-to-point
ospfv3 10
ipv4 area 0
ospfv3 10 ipv6 area 0
!
XRv
router ospf 10
log adjacency changes
router-id
6.6.6.6
area 0
interface Loopback0
passive
enable
!
interface GigabitEthernet0/0/0/0
network point-to-point
!
interface
GigabitEthernet0/0/0/2
network point-to-point
!
!
!
Configurations IPv6
IOS/XE
ipv6 router ospf 200
router-id 200.0.0.23
!
interface
Ethernet0/0
ipv6 ospf 200 area 0
ipv6 ospf network
point-to-point
!
OR
router ospfv3 10
router-id
2.2.2.2
!
address-family ipv4 unicast
passive-interface
Loopback0
exit-address-family
!
address-family ipv6
unicast
passive-interface
Loopback0
exit-address-family
!
interface
GigabitEthernet3
ospfv3 10 network point-to-point
ospfv3 10
ipv4 area 0
ospfv3 10 ipv6 area 0
!
interface
GigabitEthernet4
ospfv3 10 network point-to-point
ospfv3 10
ipv4 area 0
ospfv3 10 ipv6 area 0
!
router ospfv3 10
router-id 6.6.6.6
log adjacency
changes
area 0
interface Loopback0
passive
!
interface GigabitEthernet0/0/0/0
network point-to-point
!
interface
GigabitEthernet0/0/0/2
network point-to-point
!
!
!