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Configuring	the	Image	Navigator
To	configure	the	Image	Navigator,	choose	Options»Configure.



Category	File	Path
Normally,	this	field	should	be	blank,	which	causes	the	Image	Navigator	to	look
for	the	category	(*.cat)	files	in	the	same	directory	as	the	Image	Navigator
program.	If	your	category	files	are	stored	in	a	separate	location,	you	may	specify
that	directory	in	this	field.	Relative	paths	such	as	\symbols	are	supported.	Click
Browse	to	select	a	folder.



Always	on	top
Check	this	box	to	make	the	Image	Navigator	stay	on	top	of	other	windows.



Automatically	minimize	after	copying
Check	this	box	to	automatically	minimize	the	Image	Navigator	after	copying	a
symbol	to	the	clipboard.



Do	not	tile	textures
Normally,	when	a	texture	is	copied	to	the	clipboard,	a	large	bitmap	consisting	of
many	tiles	is	copied.	If	this	box	is	checked,	then	only	a	single	tile	is	copied.



Always	copy	as	picture
This	setting	controls	the	default	behavior	of	the	Copy	button	on	the	main	Image
Navigator	screen.	When	this	box	is	unchecked,	clicking	the	Copy	button	does
the	same	thing	as	choosing	Copy	to	Clipboard	from	the	Edit	menu.	When	this
box	is	checked,	clicking	the	Copy	button	does	the	same	thing	as	choosing	Copy
as	Picture	(wmf)	Only	from	the	Edit	menu.



Thumbnail	size
This	determines	the	size	of	the	symbol	thumbnails,	in	pixels.	Enter	a	number
between	26	and	256.



Picture	optimization
This	determines	the	amount	of	picture	optimization	that	is	performed
automatically.	Optimization	occurs	automatically	for	all	symbol	operations
including	exporting,	loading	from	the	hard	drive,	copying	to	the	clipboard,	and
adding	your	own	symbols.
No	optimization Pictures	will	not	be	optimized.

Lossless	optimization Picture	data	size	will	be	reduced	moderately,	but	image	quality	will	not	be	harmed.

Maximum
optimization

Picture	data	size	will	be	reduced	as	much	as	possible,	with	a	slight	loss	of	picture	quality.

Picture	optimization	is	important	because	it	results	in	smaller,	leaner	metafiles,	which	usually	load	and	draw
faster.	Optimization	has	no	effect	on	bitmaps	or	textures.



Defaults	Button
Click	this	button	to	return	all	configuration	settings	to	their	default	values.



Image	Navigator	Limitations
Supported	Drawing	Programs
The	Image	Navigator	was	specifically	designed	to	properly	handle	metafiles
created	by	CorelDRAW	5,	7,	or	10,	or	Adobe	Illustrator	9.	If	you	are	having
trouble	adding	your	own	metafiles	to	the	Image	Navigator,	try	copying	your
metafiles	into	one	of	these	drawing	programs	first,	then	paste	them	into	the
Image	Navigator.



Metafile	Limitations
Not	all	metafiles	are	supported	by	the	Image	Navigator.	Metafiles	vary	widely
according	to	the	drawing	program	used	to	create	them—some	drawing	programs
create	metafiles	that	are	compatible	with	many	other	applications;	some	do	not.
Windows	metafiles	can	contain	a	rich	set	of	commands,	most	of	which	are	not
used	by	clipart	today.	The	Image	Navigator	supports	the	subset	of	metafile
commands	that	is	used	by	the	majority	of	clipart	vendors.	The	drawing	objects
supported	include	line,	polyline,	polygon,	polypolygon,	rectangle,	and	ellipse.



Number	of	Categories
There	is	no	set	limit	on	the	number	of	categories	that	you	can	have.	However,	a
large	number	of	categories	will	slow	the	performance	of	the	Image	Navigator
main	screen.



Symbol	Size
There	is	no	set	limit	on	the	size	(in	bytes)	of	a	symbol	that	the	Image	Navigator
can	contain.	However,	the	larger	a	symbol	is,	the	slower	the	Image	Navigator
will	respond	when	drawing,	resizing,	deleting,	or	moving	that	symbol.



Accuracy	of	Symbols
The	Image	Navigator	symbols	and	their	descriptions	are	provided	"as-is"—there
is	no	warranty	or	guarantee	with	regard	to	their	accuracy,	correctness,	or
completeness	with	respect	to	the	actual	objects	that	they	represent.	The	library
may	contain	symbols	that	deviate	from	industry	standards	or	symbols	that	have
non-standard	or	erroneous	descriptions.



Image	Format	Conversion
When	converting	image	files	from	one	format	to	another,	there	may	be	slight
distortions,	degradations,	or	minor	differences	due	to	the	inherent	complexities
and	limitations	of	image	conversion.



LabVIEW	and	Lookout	Instructions
Using	Image	Navigator	with	Lookout

1.	 Select	a	symbol	in	the	Image	Navigator.
2.	 Export	the	selected	symbol	from	the	File»Export	menu.	Save	the	file

into	the	Lookout\Graphics	directory.
3.	 Switch	to	Lookout	and	import	the	symbol	from	the	Import»Graphic

menu.



Using	Image	Navigator	with	LabVIEW
Select	a	symbol	in	the	Image	Navigator	and	drag	it	onto	the	LabVIEW	front
panel.	You	can	also	copy	the	symbol	in	the	Image	Navigator	then	select
Edit»Paste	in	LabVIEW.



Preview	Window
Resizing	the	Preview	Window
To	resize	the	Preview	window,	drag	the	splitter	bars	that	are	on	the	right	and
bottom	side	of	the	Preview	window.



Full	Screen	Preview
To	create	a	full-screen	preview,	choose	View»Full	Screen	Preview.	To	close	the
full-screen	preview,	click	the	Close	button.



Finding	a	Symbol
To	display	the	Find	dialog,	choose	Edit»Find.



Find	what
Type	in	a	word	or	phrase	that	you	want	to	find.



Find	Next
Click	this	button	to	find	the	next	symbol	whose	description	contains	the	search
phrase.	The	search	begins	with	the	currently-selected	symbol,	and	the	search
wraps	around	to	the	first	category	once	you	reach	the	end	of	the	symbols.



Match	case
If	this	box	is	checked,	then	the	case	of	search	phrase	must	match	the	case	of	the
symbol's	description.	If	unchecked,	then	case	does	not	matter.



Exporting	Symbols
Exporting	Bitmaps	and	Textures
To	export	a	Bitmap	or	Texture	from	the	Image	Navigator:

1.	 Select	a	symbol	to	be	exported.
2.	 Choose	File»Export	As	Bitmap.
3.	 Choose	a	filename	for	the	bitmap	or	texture.

Bitmaps	and	Textures	are	exported	at	the	same	color	depth	as	the	current	display
driver.	For	example,	if	your	computer	is	in	256-color	mode,	exported	bitmaps
will	contain	a	256-color	palette.
A	Texture	is	normally	exported	at	the	size	of	the	Preview	window.	If	you	want	to
export	only	a	single	tile	of	the	texture,	then	check	the	Do	Not	Tile	Textures	box
on	the	Configure	Image	Navigator	dialog	box.



Exporting	Pictures
A	Picture	may	be	exported	in	any	of	the	following	formats:
Metafile	(*.wmf) This	is	a	standard	vector-based	image	format	that	can	be	read	by	most	Windows-

based	graphics	programs.

Bitmap	(*.bmp) This	is	a	standard	pixel-based	image	format	that	can	be	read	by	most	Windows-based
graphics	programs.

PNG	(*.png) This	is	a	compressed	pixel-based	format	designed	for	the	internet.

SVG	(*.svg) This	is	a	standard	vector-based	format	that	is	used	to	display	graphics	on	World	Wide
Web	browsers.	Currently,	SVG	files	can	be	displayed	using	Adobe's	SVG	Viewer
plug-in	for	Microsoft	Internet	Explorer.

SVG	Compressed	(*.svgz) This	is	a	compressed	version	of	the	SVG	format.	Typically,	an	SVGZ	file	is	25%	of
the	size	of	the	corresponding	SVG	file,	which	makes	for	a	very	quick	download	on
the	internet.

The	metafile	format	is	generally	preferred	over	the	bitmap	format.	A	metafile	will	stretch	to	any	size	much	better
than	a	bitmap.	A	Picture	exported	as	a	bitmap	is	approximately	the	size	of	the	Preview	window	on	the	main	Image
Navigator	screen.

To	export	a	Picture	from	the	Image	Navigator:
1.	 Select	a	symbol	to	be	exported.
2.	 Choose	File»Export	Symbol.
3.	 Select	Metafile,	Bitmap,	or	Scalable	Vector	Graphic	from	the	Save	as

type	drop-down	box.
4.	 Choose	a	filename	for	the	picture.

When	Picture	symbols	are	exported	as	bitmaps,	they	are	exported	at	the	size	of
the	Preview	window.	To	resize	the	Preview	window,	drag	the	splitter	bars	at	its
right	or	bottom	side.
The	background	color	of	a	Picture	exported	as	a	bitmap	can	be	changed	from	the
Symbol	Options	screen.	This	feature	can	be	used	to	match	symbols	to	the
background	in	your	application.



Symbol	Types
There	are	four	types	of	symbols	that	the	Image	Navigator	can	contain:



Picture
A	Picture	is	a	vector-based	drawing	that	can	be	stretched	without	distortion.
Pictures	are	implemented	using	a	Windows	metafile	(*.wmf).



Simple	Picture
A	Simple	Picture	is	a	Picture	that	has	only	one	fill	color	and	one	line	color.



Bitmap
A	Bitmap	is	a	pixel-based	drawing	that	looks	best	at	its	original	size.	Stretching
a	Bitmap	can	result	in	a	jagged,	distorted	image.



Texture
A	Texture	is	similar	to	a	Bitmap,	except	you	can	tile	it	to	form	a	never-ending
pattern.



Symbol	Properties
To	view	or	change	a	symbol's	properties,	right-click	the	symbol	and	choose
Properties.



Symbol	Description
Type	in	a	symbol	description,	up	to	80	characters.



Data	Size
Displays	the	size,	in	kilobytes,	of	the	metafile	or	bitmap	image	data.



Type
Displays	the	type	of	symbol.



Handle
This	is	a	unique	number	assigned	to	every	symbol.



Symbol	Options
To	display	the	Symbol	Options	dialog	box,	click	Options	in	the	main	Image
Navigator	window	or	select	Options»Symbol	Options.



Fill	Color	Mode
Original Fill	colors	are	not	changed.

Shaded Fill	colors	are	shaded	according	to	the	selected	fill	color.

Solid Fill	colors	are	solid	according	to	the	selected	fill	color.

Hollow Fill	colors	are	removed.



Fill	Color
Click	on	this	box	to	change	the	fill	color.	The	Fill	color	box	is	enabled	only	if
the	Fill	Color	Mode	is	set	to	Shaded	or	Solid.



Flip
None Picture	will	not	be	flipped.

Horizontal Picture	will	be	flipped	horizontally.

Vertical Picture	will	be	flipped	vertically.

Both Picture	will	be	flipped	horizontally	and	vertically.



Rotation
0 Picture	will	not	be	rotated.

90 Picture	will	be	rotated	90	degrees.

180 Picture	will	be	rotated	180	degrees.

270 Picture	will	be	rotated	270	degrees.



Background	Color
Click	on	this	box	to	change	the	background	color	for	exporting	metafiles	as
bitmaps.



Defaults	Button
Click	on	this	button	to	return	all	symbol	options	to	their	default	values.



Copying,	Moving,	and	Deleting	Symbols
To	copy	a	symbol	to	the	clipboard:
Select	a	symbol	and	do	one	of	the	following:

Click	the	Copy	button.
Choose	Edit»Copy	to	Clipboard.
Press	<Ctrl-C>.
Double-click	the	symbol's	thumbnail.

Pictures	will	be	copied	to	the	clipboard	in	both	metafile	and	bitmap
formats.

To	copy	a	Picture	to	the	clipboard	as	a	metafile:
Select	a	symbol	and	do	one	of	the	following:

Click	the	Copy	button	while	holding	down	the	<Shift>	key.
Choose	Edit»Copy	as	Picture	(wmf)	Only.
Press	<Ctrl-Shift-C>.
Double-click	the	symbol's	thumbnail	while	holding	down	the	<Shift>	key.

This	will	copy	the	picture	to	the	clipboard	as	a	metafile,	but	not	as	a	bitmap.



To	move	a	symbol	within	the	same	category:
Drag	the	symbol's	thumbnail	to	the	desired	location.



To	copy	a	symbol	into	another	category:
Drag	the	symbol's	thumbnail	onto	a	category	in	the	Category	listbox.



To	move	a	symbol	into	another	category:
Drag	the	symbol's	thumbnail	onto	a	category	in	the	Category	listbox	while
holding	down	the	<Shift>	key.



To	delete	a	symbol:
Select	a	symbol	and	choose	Edit»Delete.



Adding	Your	Own	Symbols
You	can	add	your	own	symbols	to	the	Image	Navigator	in	several	ways:	pasting,
importing,	or	dragging.



Pasting	Graphics	from	the	Clipboard
You	can	copy	graphic	objects	from	other	Windows	programs	and	add	them	to	the
Image	Navigator	as	follows:

1.	 Switch	to	another	graphics	application	such	as	CorelDRAW	or	Adobe
Illustrator.

2.	 Select	an	object.
3.	 Select	Edit»Copy.
4.	 Switch	back	to	the	Image	Navigator.
5.	 Choose	Edit»Paste	from	clipboard.
6.	 Type	in	an	optional	description	for	the	symbol	(80	characters	maximum).
7.	 Select	an	available	symbol	type.
8.	 Select	the	category	into	which	you	want	to	add	the	symbol,	or	create	a

new	category	by	clicking	Create	New	Category.
9.	 Click	OK.	The	symbol	is	added	to	the	end	of	the	selected	category.



Importing	a	Graphics	File
You	can	import	graphics	files	and	add	them	as	follows:

1.	 Choose	File»Import	Symbol.
2.	 Select	a	file	to	import.	Picture	files	(*.wmf)	and	bitmap	files	(*.bmp)	are

supported.
3.	 Type	in	an	optional	description	for	the	symbol	(80	characters	maximum).
4.	 Select	an	available	symbol	type.
5.	 Select	the	category	into	which	you	want	to	add	the	symbol,	or	create	a

new	category	by	clicking	Create	New	Category.
6.	 Click	OK.	The	symbol	is	added	to	the	end	of	the	selected	category.



Using	Drag-And-Drop
Many	graphics	programs	support	drag-and-drop,	which	allows	you	to	drag	a
graphic	from	one	program	and	drop	it	in	another.	To	add	a	graphic	using	drag-
and-drop:

1.	 Drag	a	graphic	from	another	program	and	drop	it	onto	the	Image
Navigator.

2.	 Type	in	an	optional	description	for	the	symbol	(80	characters	maximum).
3.	 Select	an	available	symbol	type.
4.	 Select	the	category	into	which	you	want	to	add	the	symbol,	or	create	a

new	category	by	clicking	the	Create	New	Category	button.
5.	 Click	OK.	The	symbol	is	added	to	the	end	of	the	selected	category.



Category	Properties
To	view	or	change	a	category's	properties,	right-click	the	category	and	choose
Properties.



Description
Type	in	a	description	for	the	category,	up	to	40	characters.



Symbol	count
This	is	the	total	number	of	symbols	in	the	category.	Maximum	is	32,767.



Filename
This	is	the	full	path	of	the	category	file	(*.cat)	that	contains	all	of	the	symbol
data	for	this	category.	These	files	can	be	freely	copied	or	moved	to	other
computers.



File	size
This	is	the	size	of	the	category	file,	in	kilobytes.



Category	version
This	is	the	version	number	for	this	category.	Currently,	all	categories	are	version
1.



Read-only
This	displays	whether	or	not	the	category	file	is	read-only.	This	can	be	changed
using	Windows	Explorer.



Creating	a	New	Category
To	display	the	Create	New	Category	dialog,	choose	File»Create	New	Category.



Category	Description
Enter	a	description	for	the	new	category,	up	to	40	characters.	Spaces	and
symbols	are	allowed.



Filename
Type	in	a	valid	filename	for	the	new	category.	The	file	extension	must	be	.cat.
Long	filenames	are	supported,	but	short	filenames	can	be	used	to	maintain
compatibility	with	older	versions	of	the	Image	Navigator.	Do	not	include	a	path
or	drive	letter	in	the	filename.	The	new	category	is	created	in	the	directory
specified	by	the	Category	File	Path	field	in	the	Configure	Image	Navigator
dialog	box.



Deleting	a	Category
To	delete	an	entire	category,	use	Windows	Explorer	to	delete	the	category	(*.cat)
file.	To	determine	a	category's	filename,	right-click	the	category	and	choose
Properties.



Making	a	Category	Read-Only
You	may	want	to	make	a	category	read-only	so	that	users	can	use	the	symbols
without	deleting	or	rearranging	them.	To	make	a	category	read-only,	set	the	read-
only	file	attribute	for	the	category	file	using	Windows	Explorer.	To	determine
the	filename	of	a	category,	right-click	the	category	and	choose	Properties.
When	a	category	is	set	as	read-only,	users	cannot	delete,	move,	rename,	or	add	to
its	symbols.



Repairing	a	Category
To	repair	a	category,	right-click	a	category	and	choose	Repair	Category.
Rarely,	a	category	may	become	corrupt,	perhaps	from	adding	and	deleting	many
symbols.	Repairing	a	category	restores	a	category	back	to	regular	function.	For
categories	that	are	not	corrupted,	this	is	a	harmless	procedure.



Important	Information
Conventions
Warranty
Copyright
Trademarks
Warning	Regarding	Use	of	NI	Products



Conventions
This	help	file	uses	the	following	conventions:
<	> Angle	brackets	that	contain	numbers	separated	by	an	ellipsis	represent	a	range	of	values	associated

with	a	bit	or	signal	name—for	example,	DBIO<3..0>.

» The	»	symbol	leads	you	through	nested	menu	items	and	dialog	box	options	to	a	final	action.	The
sequence	File»Page	Setup»Options	directs	you	to	pull	down	the	File	menu,	select	the	Page	Setup
item,	and	select	Options	from	the	last	dialog	box.

This	icon	denotes	a	note,	which	alerts	you	to	important	information.

bold Bold	text	denotes	items	that	you	must	select	or	click	on	in	the	software,	such	as	menu	items	and
dialog	box	options.	Bold	text	also	denotes	parameter	names,	emphasis,	or	an	introduction	to	a	key
concept.

green Underlined	text	in	this	color	denotes	a	link	to	a	help	topic,	help	file,	or	Web	address.

monospace Text	in	this	font	denotes	text	or	characters	that	you	should	enter	from	the	keyboard,	sections	of	code,
programming	examples,	and	syntax	examples.	This	font	is	also	used	for	the	proper	names	of	disk
drives,	paths,	directories,	programs,	subprograms,	subroutines,	device	names,	functions,	operations,
variables,	filenames	and	extensions,	and	code	excerpts.



Warranty
The	media	on	which	you	receive	National	Instruments	software	are	warranted
not	to	fail	to	execute	programming	instructions,	due	to	defects	in	materials	and
workmanship,	for	a	period	of	90	days	from	date	of	shipment,	as	evidenced	by
receipts	or	other	documentation.	National	Instruments	will,	at	its	option,	repair
or	replace	software	media	that	do	not	execute	programming	instructions	if
National	Instruments	receives	notice	of	such	defects	during	the	warranty	period.
National	Instruments	does	not	warrant	that	the	operation	of	the	software	shall	be
uninterrupted	or	error	free.
A	Return	Material	Authorization	(RMA)	number	must	be	obtained	from	the
factory	and	clearly	marked	on	the	outside	of	the	package	before	any	equipment
will	be	accepted	for	warranty	work.	National	Instruments	will	pay	the	shipping
costs	of	returning	to	the	owner	parts	which	are	covered	by	warranty.
National	Instruments	believes	that	the	information	in	this	document	is	accurate.
The	document	has	been	carefully	reviewed	for	technical	accuracy.	In	the	event
that	technical	or	typographical	errors	exist,	National	Instruments	reserves	the
right	to	make	changes	to	subsequent	editions	of	this	document	without	prior
notice	to	holders	of	this	edition.	The	reader	should	consult	National	Instruments
if	errors	are	suspected.	In	no	event	shall	National	Instruments	be	liable	for	any
damages	arising	out	of	or	related	to	this	document	or	the	information	contained
in	it.
Except	as	specified	herein,	National	Instruments	makes	no	warranties,
express	or	implied,	and	specifically	disclaims	any	warranty	of
merchantability	or	fitness	for	a	particular	purpose.	Customer's	right	to
recover	damages	caused	by	fault	or	negligence	on	the	part	of	National
Instruments	shall	be	limited	to	the	amount	theretofore	paid	by	the
customer.	National	Instruments	will	not	be	liable	for	damages	resulting
from	loss	of	data,	profits,	use	of	products,	or	incidental	or	consequential
damages,	even	if	advised	of	the	possibility	thereof.	This	limitation	of	the
liability	of	National	Instruments	will	apply	regardless	of	the	form	of	action,
whether	in	contract	or	tort,	including	negligence.	Any	action	against	National
Instruments	must	be	brought	within	one	year	after	the	cause	of	action	accrues.
National	Instruments	shall	not	be	liable	for	any	delay	in	performance	due	to
causes	beyond	its	reasonable	control.	The	warranty	provided	herein	does	not
cover	damages,	defects,	malfunctions,	or	service	failures	caused	by	owner's



failure	to	follow	the	National	Instruments	installation,	operation,	or	maintenance
instructions;	owner's	modification	of	the	product;	owner's	abuse,	misuse,	or
negligent	acts;	and	power	failure	or	surges,	fire,	flood,	accident,	actions	of	third
parties,	or	other	events	outside	reasonable	control.



Copyright
Under	the	copyright	laws,	this	publication	may	not	be	reproduced	or	transmitted
in	any	form,	electronic	or	mechanical,	including	photocopying,	recording,
storing	in	an	information	retrieval	system,	or	translating,	in	whole	or	in	part,
without	the	prior	written	consent	of	National	Instruments	Corporation.



Trademarks
LabVIEW™,	Lookout™,	National	Instruments™,	and	ni.com™	are	trademarks
of	National	Instruments	Corporation.
Product	and	company	names	mentioned	herein	are	trademarks	or	trade	names	of
their	respective	companies.



WARNING	REGARDING	USE	OF	NATIONAL
INSTRUMENTS	PRODUCTS
(1)	National	Instruments	products	are	not	designed	with	components	and
testing	for	a	level	of	reliability	suitable	for	use	in	or	in	connection	with
surgical	implants	or	as	critical	components	in	any	life	support	systems
whose	failure	to	perform	can	reasonably	be	expected	to	cause	significant
injury	to	a	human.
(2)	In	any	application,	including	the	above,	reliability	of	operation	of	the
software	products	can	be	impaired	by	adverse	factors,	including	but	not
limited	to	fluctuations	in	electrical	power	supply,	computer	hardware
malfunctions,	computer	operating	system	software	fitness,	fitness	of
compilers	and	development	software	used	to	develop	an	application,
installation	errors,	software	and	hardware	compatibility	problems,
malfunctions	or	failures	of	electronic	monitoring	or	control	devices,
transient	failures	of	electronic	systems	(hardware	and/or	software),
unanticipated	uses	or	misuses,	or	errors	on	the	part	of	the	user	or
applications	designer	(adverse	factors	such	as	these	are	hereafter
collectively	termed	"system	failures").	Any	application	where	a	system
failure	would	create	a	risk	of	harm	to	property	or	persons	(including	the
risk	of	bodily	injury	and	death)	should	not	be	reliant	solely	upon	one	form
of	electronic	system	due	to	the	risk	of	system	failure.	To	avoid	damage,
injury,	or	death,	the	user	or	application	designer	must	take	reasonably
prudent	steps	to	protect	against	system	failures,	including	but	not	limited	to
back-up	or	shut	down	mechanisms.	Because	each	end-user	system	is
customized	and	differs	from	National	Instruments'	testing	platforms	and
because	a	user	or	application	designer	may	use	National	Instruments
products	in	combination	with	other	products	in	a	manner	not	evaluated	or
contemplated	by	National	Instruments,	the	user	or	application	designer	is
ultimately	responsible	for	verifying	and	validating	the	suitability	of	National
Instruments	products	whenever	National	Instruments	products	are
incorporated	in	a	system	or	application,	including,	without	limitation,	the
appropriate	design,	process	and	safety	level	of	such	system	or	application.



Technical	Support	and	Professional	Services
Visit	the	following	sections	of	the	National	Instruments	Web	site	at	ni.com	for
technical	support	and	professional	services:

Support—Online	technical	support	resources	include	the	following:
Self-Help	Resources—For	immediate	answers	and	solutions,	visit
our	extensive	library	of	technical	support	resources	available	in
English,	Japanese,	and	Spanish	at	ni.com/support.	These	resources
are	available	for	most	products	at	no	cost	to	registered	users	and
include	software	drivers	and	updates,	a	KnowledgeBase,	product
manuals,	step-by-step	troubleshooting	wizards,	conformity
documentation,	example	code,	tutorials	and	application	notes,
instrument	drivers,	discussion	forums,	a	measurement	glossary,
and	so	on.
Assisted	Support	Options—Contact	NI	engineers	and	other
measurement	and	automation	professionals	by	visiting
ni.com/support.	Our	online	system	helps	you	define	your	question
and	connects	you	to	the	experts	by	phone,	discussion	forum,	or
email.

Training—Visit	ni.com/custed	for	self-paced	tutorials,	videos,	and
interactive	CDs.	You	also	can	register	for	instructor-led,	hands-on	courses
at	locations	around	the	world.
System	Integration—If	you	have	time	constraints,	limited	in-house
technical	resources,	or	other	project	challenges,	NI	Alliance	Program
members	can	help.	To	learn	more,	call	your	local	NI	office	or	visit
ni.com/alliance.

If	you	searched	ni.com	and	could	not	find	the	answers	you	need,	contact	your
local	office	or	NI	corporate	headquarters.	You	can	also	visit	the	Worldwide
Offices	section	of	ni.com/niglobal	to	access	the	branch	office	Web	sites,	which
provide	up-to-date	contact	information,	support	phone	numbers,	email	addresses,
and	current	events.
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Branch	Offices
Office Telephone	Number

Australia 03	9879	5166

Austria 0662	45	79	90	0

Belgium 02	757	00	20

Brazil 55	11	3262	3599

Canada	(Calgary) 403	274	9391

Canada	(Montreal) 514	288	5722

Canada	(Ottawa) 613	233	5949

Canada	(Québec) 514	694	8521

Canada	(Toronto) 905	785	0085

China 86	21	6555	7838

Czech	Republic 02	2423	5724

Denmark 45	76	26	00

Finland 09	725	725	11

France 01	48	14	24	24

Germany 089	741	31	30

Greece 01	42	96	427

Hong	Kong 2645	3186

India 91	80	4190000

Israel 03	6393737

Italy 02	413091

Japan 03	5472	2970

Korea 02	3451	3400

Malaysia 603	9596711

Mexico 001	800	010	0793

Netherlands 0348	433466

New	Zealand 09	914	0488

Norway 32	27	73	00

Poland 22	3390	150

Portugal 210	311	210

Russia 095	238	7139

Singapore 65	6	226	5886

Slovenia 3	425	4200

South	Africa 11	805	8197

Spain 91	640	0085



Sweden 08	587	895	00

Switzerland 056	200	51	51

Taiwan 02	2528	7227

United	Kingdom 01635	523545

United	States	(Corporate) 512	683	0100
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