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About jQuery
Getting started with jQuery can be easy or challenging, depending
on your experience with JavaScript, HTML, CSS, and programming
concepts in general.
How jQuery Works
Additional jQuery Support

How jQuery Works
jQuery: The Basics
This is a basic tutorial, designed to help you get started using
jQuery. If you don't have a test page setup yet, start by creating the
following HTML page:
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<!doctype html>
<html>
<head>
<meta charset="utf-8">
<title>Demo</title>
</head>
<body>
<a href="http://jquery.com/">jQuery</a>
<script src="jquery.js"></script>
<script>
// Your code goes here
</script>
</body>
</html>

The src attribute in the <script> element must point to a copy of
jQuery. Download a copy of jQuery from the Downloading jQuery
page and store the jquery.js file in the same directory as your
HTML file.

Launching Code on Document Ready
To ensure that their code runs after the browser finishes loading the
document, many JavaScript programmers wrap their code in an
onload function:
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window.onload = function() {
alert("welcome");
}

Unfortunately, the code doesn't run until all images are finished
downloading, including banner ads. To run code as soon as the
document is ready to be manipulated, jQuery has a statement known
as the ready event :
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$( document ).ready( function() {
// Your code here
});

For example, inside the
the link:
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ready

event, you can add a click handler to

$( document ).ready(function() {
$("a").click(function( event ) {
alert("Thanks for visiting!");
});
});

Save your HTML file and reload the test page in your browser.
Clicking the link should now first display an alert pop-up, then
continue with the default behavior of navigating to
http://jquery.com/.
For click and most other events, you can prevent the default
behavior by calling event.preventDefault() in the event handler:
1
2
3
4

$( document ).ready(function() {
$("a").click(function( event ) {
alert("As you can see, the link no longer took you t
event.preventDefault();

5
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});
});

Complete Example
The following example illustrates the click handling code discussed
above, embedded directly in the HTML <body> . Note that in
practice, it is usually better to place your code in a separate JS file
and load it on the page with a <script> element's src attribute.
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<!doctype html>
<html>
<head>
<meta charset="utf-8">
<title>Demo</title>
</head>
<body>
<a href="http://jquery.com/">jQuery</a>
<script src="jquery.js"></script>
<script>
$( document ).ready(function() {
$("a").click(function( event ) {
alert("The link will no longer take you to jq
event.preventDefault();
});
});
</script>
</body>
</html>

Adding and Removing an HTML Class
Important: You must place the remaining jQuery examples inside
the ready event so that your code executes when the document is

ready to be worked on.
Another common task is adding or removing a
First, add some style information into the
like this:
1
2
3
4
5

class .

<head>

of the document,

<style>
a.test {
font-weight: bold;
}
</style>

Next, add the addClass() call to the script:
1
All

a

$("a").addClass("test");
elements are now bold.

To remove an existing
1

class ,

use removeClass():

$("a").removeClass("test");

Special Effects
jQuery also provides some handy effects to help you make your
web sites stand out. For example, if you create a click handler of:
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$("a").click(function( event ){
event.preventDefault();
$( this ).hide("slow");
});

then the link slowly disappears when clicked.
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Callbacks and Functions
Unlike many other programming languages, JavaScript enables you
to freely pass functions around to be executed at a later time. A
callback is a function that is passed as an argument to another
function and is executed after its parent function has completed.
Callbacks are special because they patiently wait to execute until
their parent finishes. Meanwhile, the browser can be executing
other functions or doing all sorts of other work.
To use callbacks, it is important to know how to pass them into their
parent function.

Callback without Arguments
If a callback has no arguments, you can pass it in like this:
1

$.get( "myhtmlpage.html", myCallBack );

When $.get finishes getting the page myhtmlpage.html , it executes
the myCallBack function. Note that the second parameter here is
simply the function name (but not as a string and without
parentheses).

Callback with Arguments
Executing callbacks with arguments can be tricky.
Wrong
This code example will not work:
1

$.get( "myhtmlpage.html", myCallBack(param1, param2) );

The reason this fails is that the code executes myCallBack( param1,
param2 ) immediately and then passes the myCallBack's return

value as the second parameter to $.get . We actually want to pass
in myCallBack the function, not myCallBack 's return value (which
might or might not be a function). So, how to pass in myCallBack
and include its arguments?
Right
To defer executing myCallBack with its parameters, you can use an
anonymous function as a wrapper. Note the use of function() { .
The anonymous function does exactly one thing: calls myCallBack ,
with the values of param1 and param2 .
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$.get( "myhtmlpage.html", function() {
myCallBack( param1, param2 );
});

When $.get finishes getting the page myhtmlpage.html , it executes
the anonymous function, which executes myCallBack( param1,
param2 ) .

POWERED BY HERONOTE

Additional jQuery Support
While we hope to cover most jQuery-related topics on this site, you
may need additional or more immediate support. The following
resources can prove useful.

Official Forums
http://forum.jquery.com/
There are many subforums where you can discuss jQuery, ask
questions, talk about JavaScript, or announce your plugins.
Getting Started
This is the best place to post if you are brand new to
jQuery and JavaScript.
Using jQuery
This is the best place to post if you have general questions
or concerns.
If you've built a site that uses jQuery, or would like to
announce a new plugin, this is the place to do it.
Using jQuery Plugins
If you are a plugin author or user and you wish to discuss
specific plugins, plugin bugs, new features, or new plugins.
Using jQuery UI
This is the place to discuss use of jQuery UI Interactions,
Widgets, and Effects
jQuery Mobile
This is the place to discuss jQuery Mobile.
Developing jQuery Core
This forum centers around development of the jQuery
library itself.
Post here if you have questions about certain bugs,
development with jQuery, features, or anything in the bug
tracker or Git.

Developing jQuery Plugins
This forum covers development of jQuery plugins.
Developing jQuery UI
This is the place to discuss development of jQuery UI itself
- including bugs, new plugins, and how you can help.
All jQuery UI svn commits are posted to this list to facilitate
feedback, discussion, and review.
Also note that a lot of the development and planning of
jQuery UI takes place on the jQuery UI Development and
Planning Wiki.
Developing jQuery Mobile
This forum covers issues related to the development of
jQuery Mobile.
QUnit and Testing
This is the place to discuss JavaScript testing in general
and QUnit in particular
At the bottom of each of the forums is an RSS feed you can
subscribe to.
To ensure that you'll get a useful answer in no time, please consider
the following advice:
Ensure your markup is valid.
Use Firebug/Developer Tools to see if you have an exception.
Use Firebug/Developer Tools to inspect the html classes, css.
etc.
Try expected resulting html and css without javascript/jQuery
and see if the problem could be isolated to those two.
Reduce to a minimal test case (keep removing things until the
problem goes away, etc.)
Provide that test case as part of your mail. Either upload it
somewhere or post it on jsbin.com.
In general, keep your question short and focused and provide only
essential details - others can be added when required.

Mailing List Archives
The mailing list existed before the forums were created. The mailing
lists were closed in early 2010.
There are two different ways of browsing the mailing list archives.
1

The official mailing list archives can be found here:
jQuery General Discussion Archives
jQuery Dev List Archives
jQuery UI General Discussion Archives
jQuery UI Dev List Archives
jQuery Plugins List Archives

Also, an interactive, browsable, version of the General Discussion
mailing list can be found on Nabble (a forum-like mailing list mirror).

Chat / IRC Channel
jQuery also has a very active IRC channel, #jquery, hosted by
freenode.
The IRC Channel is best if you need quick help with any of the
following:
JavaScript
jQuery syntax
problem solving
strange bugs.
If your problem is more in-depth, we may ask you to post to the
mailing list, or the bug tracker, so that we can help you in a moresuitable environment.
Connect info:
Server: irc.freenode.net
Room: #jquery

You can also connect at http://webchat.freenode.net/?
channels=#jquery.
Additionally we have #jquery-es and #jquery-de if you want to
speak your native language.
If you wish to post code snippets to the channel, you should use a
paste site, like http://jsfiddle.net/ or http://jsbin.com/

StackOverflow
There is an active and well-informed support community at
StackOverflow. You can likely find an answer for whatever issue
you're experiencing. If your question isn't addressed, you can ask a
new question and often receive a quick response.

JavaScript 101

Introduction
So you want to unlock the power of jQuery to make the web a
better place? Awesome, but there are a few things you should know
about JavaScript first.
Introduced at the dawn of the web, JavaScript is a powerful and
expressive language that runs inside the browser in conjunction
with HTML and CSS. Based on an open standard called
ECMAScript, JavaScript has quickly become the "programming
language of the web". All the power of jQuery is accessed via
JavaScript, so needless to say, it's an important language to learn.
Having a basic knowledge of JavaScript will go a long way in
understanding, structuring and debugging your code.
This guide covers the foundational concepts of JavaScript, as well
as frequent pitfalls developers fall into during their first foray into the
language. When possible, we'll relate the JavaScript you learn here
to how it's applied in jQuery.
If you have experience with other programming languages, good for
you! If not, don't worry. We'll take it slow and teach you everything
you need to know to unlock the power of jQuery with JavaScript.
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Getting Started

Anatomy of a Web Page
Before diving into JavaScript, it helps to understand how it aligns
with the other web technologies.

HTML is for Content
HTML is a markup language used to define and describe content.
Whether it be a blog post, a search engine result or an e-commerce
site, the core content of a web page is written in HTML. A semantic
markup, HTML is used to describe content in universal terms
(headers, paragraphs, images, etc.).

CSS is for Presentation
CSS is a supplemental language that applies style to HTML
documents. CSS is all about making content look better by defining
fonts, colors and other visual aesthetics. The power of CSS comes
from the fact that styling is not intermingled with content. This
means you can apply different styles to the same piece of content,
which is critical when building responsive websites that look good
across a range of devices.

JavaScript is for Interactivity
In the browser, JavaScript adds interactivity and behavior to HTML
content. Without JavaScript, web pages would be static and boring.
JavaScript helps bring a web page to life.
Look at this simple HTML page that includes CSS and JavaScript to
see how it all fits together:
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<!DOCTYPE HTML>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<title>Hello World</title>
<!-- CSS for presentation -->
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<style type="text/css">
h1 { font-size: 14px; color: hotpink; }
button { color: red; }
</style>
</head>
<body>
<h1>Hello World</h1>
<button>Click Me!</button>
<!-- JavaScript for interactivity -->
<script>
// get a handle on the first button element
// in the document.
var button = document.querySelector('button'
// if a user clicks on it, say hello!
button.addEventListener('click', function(ev) {
alert('Hello');
}, false);
</script>
</body>
</html>

In the example above, HTML is used to describe the content. The
"Hello World" text is described as a heading with the <h1> tag and
"Click Me!" is described as a button with the <button> tag. The
<style> block contains CSS that changes the font-size and color of
the header text. The <script> block contains JavaScript that adds
interactivity to the button. When a user clicks on the button, an alert
message will appear that says "Hello!".

A Scripting Language for the Web
JavaScript was originally designed to add interactivity to web
pages, not to be a general programming language, which makes it
a scripting language. Scripting languages are regarded to be more
productive than general languages because they are optimized for
their specific domain (in this case, the web browser). However,
recent advancements have brought JavaScript to the server-side
(via Node.js) so it can now be used in place of languages like PHP,
Ruby or ASP. This guide will focus exclusively on JavaScript
running in the browser with jQuery.
The name "JavaScript" is a bit misleading. Despite the similarity in
name, JavaScript has no relationship with Java), a general purpose
language. JavaScript is based on an Open Web standard called
ECMAScript. Standards-based languages are not controlled by any
one entity or corporation - instead, developers work together to
define the language, which is why JavaScript will run in every web
browser regardless of the operating system or device.
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What You Need to Get Started with
JavaScript and jQuery
1
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Web Browser
Text Editor
Developer Tools (optional)

One of JavaScript's greatest strengths is its simplicity. It can be
written and run on any operating system, and the only requirements
are a web browser and a text editor. There are also numerous tools
that can make JavaScript development more productive, but they
are completely optional.

Developer Tools
Commonly referred to as "developer tools," many browsers ship
with built-in features that provide better insight into JavaScript and
jQuery while they run in the browser. Although they aren't required,
you may find developer tools helpful when it comes to debugging
errors in your code. Check out these browsers' developer tools:
Apple Safari
Google Chrome Developer Tools
Microsoft Internet Explorer
Mozilla Firefox Web Development Tools
Opera Dragonfly
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Running Code
External
The first and recommended option is to write code in an external file
(with a ".js" extension), which can then be included on our web
page using an HTML <script> tag and pointing the src attribute to
the file's location. Having JavaScript in a separate file will reduce
code duplication if you want to reuse it on other pages. It will also
allow the browser to cache the file on the remote client's computer,
decreasing page load time.
1
2

<!--Code is written in a .js file, then included via the
<script src="/path/to/example.js"></script>

Inline
The second option is to inline the code directly on the web page.
This is also achieved using HTML <script> tags, but instead of
pointing the src attribute to a file, the code is placed between the
tags. While there are use cases for this option, the majority of the
time it is best to keep our code in an external file as described
above.
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<!--Embed code directly on a web page using script tags.
<script type="text/javascript">
alert("Hello World!");
</script>

Attributes
The last option is to use the event handler attributes of HTML

elements. This method is strongly discouraged:
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<!--Inline code directly on HTML elements being clicked.
<a href="javascript:alert("Hello World!");">Click Me!
<button onClick="alert("Good Bye World");">Click Me Too!

Placement
Placement of the previous two options is important and can vary
depending on the situation. If you are including JavaScript that
doesn't access the elements on the page, you can safely place the
script before the closing HTML <head> tag. However, if the code will
interact with the elements on the page, you have to make sure
those elements exist at the time the script is executed. This
common pitfall can be seen in the example below. The script for
finding the element with the ID "hello-world" will be executed before
the element is defined in the document.
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<!--Attempting to access an element too early will have
<!doctype html>
<html>
<head>
<script type="text/javascript">
var title = document.getElementById("hello-world"
console.log( title );
</script>
</head>
<body>
<h1 id="hello-world">Hello World</h1>
</body>
</html>

It is a common pattern to move scripts to the bottom of the page,
prior to the closing HTML <body> tag. This will guarantee that
elements are defined when the script is executed.
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<!--Moving the script to the bottom of the page will ma
<!doctype html>
<html>
<head>
</head>
<body>
<h1 id="hello-world">Hello World</h1>
<script type="text/javascript">

var title = document.getElementById("hello-world"
console.log( title );
</script>
</body>
</html>
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Syntax Basics
Comments
JavaScript has support for single and multi-line comments.
Comments are ignored by the JavaScript engine and therefore
have no side-effects on the outcome of the program. Use
comments to document the code for other developers. Libraries like
JSDoc are available to help generate project documentation pages
based on commenting conventions.
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// Single and multi line comments.
// this is an example of a single line comment.
/*
* this is an example
* of a
* multi line
* comment.
*/

Whitespace
Whitespace is also ignored in JavaScript. There are many tools that
will strip out all the whitespace in a program, reducing the overall
file size and improving network latency. Given the availability of
tools like these, whitespace should be leveraged to make the code
as readable as possible.
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// Whitespace is insignificant.
var hello = "Hello";
var world

=

"World!";
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// Semantic whitespace promotes readability.
// Readable code is good!
var foo = function() {
for ( var i = 0; i < 10; i++ ) {
alert( i );
}
};
foo();

// This is much harder to read!
var foo=function() {for(var i=0;i<10;++){alert(i);}};fo

Reserved Words
There are a handful of reserved words that can't be used when
declaring user-defined variables and functions. Some of these
reserved words are currently implemented, some are saved for
future use, and others are reserved for historical reasons. A list of
words and in-depth explanations for each can be found on the MDN
JavaScript Reference site.

Identifiers
Identifiers are used to give variables and functions a unique name
so they can subsequently be referred to by that name. The name of
an identifier must follow a few rules:
Cannot be a reserved word.
Can only be composed of letters, numbers, dollar signs, and
underscores.
The first character cannot be a number.

It's a best practice to name identifiers in a way that will make sense
to you and other developers later on.
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// Valid identifier names.
var myAwesomeVariable = "a";
var myAwesomeVariable2 = "b";
var my_awesome_variable = "c";
var $my_AwesomeVariable = "d";
var _my_awesome_variable_$ = "e";

Types
Types in JavaScript fall into two categories: primitives or objects.
Primitive types include:
String
Number
Boolean
Null
Undefined

String
Strings are text wrapped in single or double quotation marks. It is
best practice to consistently use one or the other. There may be
times when the string contains quotation marks that collide with the
ones used to create the string. In this case, either escape the
characters using a \ backslash or use different quotes around the
string.
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// Strings can created with double or single quotes.
var a = "I am a string";
var b = 'So am I!';
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// Sometimes a string may contain quotation marks.
var statement1 = 'He said "JavaScript is awesome!"'

alert( a );
alert( b );

var statement2 = "He said \"JavaScript is awesome!\""

Number
Number types are any positive or negative numeric value. There is
no distinction between integer and floating point values.
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// Numbers
var num1 =
var num2 =
var num3 =

are any whole or floating point integer.
100;
100.10;
0.10;

Boolean
Boolean types are either true or false.
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// Boolean values.
var okay = true;
var fail = false;

Null and Undefined
Null and undefined are special types in JavaScript. Null types are a
value that represent the absence of a value, similar to many other
programming languages. Undefined types represent a state in
which no value has been assigned at all. This type is created in two
ways: by using the undefined keyword or by not defining a value at
all.
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// Two ways to achieve an undefined value.
var foo = null;
var bar1 = undefined;
var bar2;

Objects
Everything else in JavaScript is considered an Object. While there
are numerous built-in objects, this chapter will cover:
Object
Array
Function
The simplest way to create an object is either through the Object
constructor or the shorthand syntax known as object literal. These
simple objects are unordered key/value pairs. The key is formally
known as a property and the value can be any valid JavaScript
type, even another object. To create or access a property on an
object, we use what is known as "dot notation" or "bracket
notation."
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// Creating an object with the constructor:
var person1 = new Object;
person1.firstName = "John";
person1.lastName = "Doe";
alert( person1.firstName + " " + person1.lastName );
// Creating an object with the object literal syntax:
var person2 = {
firstName: "Jane",
lastName: "Doe"
};
alert( person2.firstName + " " + person2.lastName );

// As mentioned, objects can also have objects as a prop
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var people = {};
people["person1"] = person1;
people["person2"] = person2;
alert( people["person1"].firstName );
alert( people["person2"].firstName );

If a property is accessed that has not been defined, it will return a
type of undefined.
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// Properties that have not been created are undefined.
var person = { name: "John Doe" };
alert( person.email ); // => undefined

Objects are covered further in the Objects section.

Array
Arrays are a type of object that are ordered by the index of each
item it contains. The index starts at zero and extends to however
many items have been added, which is a property of the array
known as the "length" of the array. Similar to a basic object, an
array can be created with the array constructor or the shorthand
syntax known as array literal.
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// Creating an array with the constructor:
var foo = new Array;
// Creating an array with the array literal syntax:
var bar = [];

There is an important distinction to be made between the two. Both
an array constructor and an array literal can contain items to be
added to the array upon creating it. However, if just a single
numeric item is passed in, the array constructor will assume its
length to be that value.
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// The array literal returns a bar.length value of 1:
var foo = [ 100 ];
// => 100
alert( foo[0] );
// => 1
alert( foo.length );
// The array constructor returns a bar.length value of
var bar = new Array( 100 );
// => undefined
alert( bar[0] );
// => 100
alert( bar.length );

An array can be manipulated through methods that are available on
the instance of the array. Items in the array can be accessed using
bracket notation with a given. If the index does not exist or contains
no value, the return type will be undefined.
A few common array methods are shown below:
1
2
3
4
5
6
7
8

// Using the push(), pop(), unshift() and shift() metho
var foo = [];
foo.push("a");
foo.push("b");
alert( foo[ 0 ] ); // => a
alert( foo[ 1 ] ); // => b
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alert( foo.length ); // => 2
foo.pop();
alert( foo[ 0 ] ); // => a
alert( foo[ 1 ] ); // => undefined
alert( foo.length ); // => 1
foo.unshift("z");
alert( foo[ 0 ] ); => z
alert( foo[ 1 ] ); => a
alert( foo.length ); => 2
foo.shift();
alert( foo[ 0 ] ); // => a
alert( foo[ 1 ] ); // => undefined
alert( foo.length ); // => 1

There are many more methods for manipulating arrays, some of
which are covered further in the Arrays section. Details can be
found on the Mozilla Developer Network.
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Type Checking with jQuery
jQuery offers a few basic utility methods for determining the type of
a specific value. Type checking is covered further in the Testing
Type section, but here are some examples:
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// Checking the type of an arbitrary value
var myValue = [ 1, 2, 3 ];

// Using JavaScript's typeof operator to test for primi
// false
typeof myValue
// false
typeof myValue
// false
typeof myValue
// false
typeof myValue

=== "string";
=== "number";
=== "undefined";
=== "boolean";

// Using strict equality operator to check for null
// false
myValue === null;

// Using jQuery's methods to check for non-primitive ty
// false
jQuery.isFunction( myValue );
// false
jQuery.isPlainObject( myValue );
// true
jQuery.isArray( myValue );

Operators
Basic operators allow you to manipulate values.
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// Concatenation
var foo = "hello";
var bar = "world";
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// Multiplication and division
2 * 3;
2 / 3;
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console.log( foo + " " + bar ); // "hello world"

// Incrementing and decrementing
// The pre-increment operator increments the operand be
// pre-increment:
var i = 1;
console.log( ++i ); // 2
console.log( i );
// 2

// The post-increment operator increments the operand a
// post-increment:
var i = 1;
console.log( i++ ); // 1 - because i was 1
console.log( i );
// 2 - incremented after using it

Operations on Numbers & Strings
In JavaScript, numbers and strings will occasionally behave in
unexpected ways.
1
2
3
4
5

// Addition vs. Concatenation
var foo = 1;
var bar = "2";
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// Coercing a string to act as a number:
var foo = 1;
var bar = "2";

console.log( foo + bar ); // 12

console.log( foo + Number(bar) ); // 3

The Number constructor, when called as a function (as in the above
example), will have the effect of casting its argument into a number.
The unary plus operator also does the same thing:
1
2

// Forcing a string to act as a number (using the unary
console.log( foo + +bar ); // 3

Logical Operators
Logical operators allow evaluation of a series of operands using
AND ( && ) and OR ( || ) operations.
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// Logical AND and OR operators
var foo = 1;
var bar = 0;
var baz = 2;
// returns 1, which is true
foo || bar;
// returns 1, which is true
bar || foo;
// returns 0, which is false
foo && bar;
// returns 2, which is true
foo && baz;
// returns 1, which is true
baz && foo;

In the above example, the || operator returns the value of the first
truthy operand, or in cases where neither operand is truthy, it
returns the last operand. The && operator returns the value of the
first false operand, or the value of the last operand if both operands
are truthy.
You'll sometimes see developers use these logical operators for
flow control instead of using if statements. For example:
1
2

// do something with foo if foo is truthy
foo && doSomething( foo );

3
4
5
6
7

// set bar to baz if baz is truthy;
// otherwise, set it to the return
// value of createBar()
var bar = baz || createBar();

This style is quite elegant and pleasantly terse; that said, it can be
really hard to read or use, especially for beginners. See the section
on truthy and falsy things in the Conditional Code article for more
about evaluating truthiness.
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Comparison Operators
Comparison operators allow you to test whether values are
equivalent or whether values are identical.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

// Comparison operators
var foo = 1;
var bar = 0;
var baz = "1";
var bim = 2;
foo == bar;
foo != bar;
foo == baz;

// false
// true
// true; but note that the types are diff

foo === baz;
// false
foo !== baz;
// true
foo === parseInt( baz ); // true
foo > bim;
bim > baz;
foo <= baz;

// false
// true
// true

For more information about comparison operators, visit the Mozilla
Developer Network.

Conditional Code
Sometimes a block of code should only be run under certain
conditions. Flow control — via if and else blocks — lets you run
code if certain conditions have been met.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

// Flow control
var foo = true;
var bar = false;
if ( bar ) {
// this code will never run
console.log("hello!");
}
if ( bar ) {
// this code won't run
} else {
if ( foo ) {
// this code will run
} else {

// this code would run if foo and bar were both fal
}
}

While curly braces aren't strictly required around single-line

if

statements, using them consistently, even when they aren't strictly
required, makes for vastly more readable code.
Be mindful not to define functions with the same name multiple
times within separate if/else blocks, as doing so may not have the
expected result.

Truthy and Falsy Things
In order to use flow control successfully, it's important to understand
which kinds of values are "truthy" and which kinds of values are
"falsy." Sometimes, values that seem like they should evaluate one
way actually evaluate another.
1
2
3
4
5
6

// Values that evaluate to true
"0";
"any string";
[]; // an empty array
{}; // an empty object
1;
// any non-zero number

1
2
3
4
5

// Values that evaluate to false
""; // an empty string
NaN; // JavaScript's "not-a-number" variable
null;
undefined; // be careful -- undefined can be redefined!

Conditional Variable Assignment with the
Ternary Operator
Sometimes a variable should be set depending on some condition.
An if / else statement works, but in many cases the ternary
operator is more convenient. The ternary operator tests a condition;
if the condition is true, it returns a certain value, otherwise it returns
a different value.
The ternary operator:
1
2
3

// set foo to 1 if bar is true;
// otherwise, set foo to 0
var foo = bar ? 1 : 0;

While the ternary operator can be used without assigning the return
value to a variable, this is generally discouraged.
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Switch Statements
Rather than using a series of if / else blocks, sometimes it can be
useful to use a switch statement instead. Switch statements look at
the value of a variable or expression, and run different blocks of
code depending on the value.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

// A switch statement
switch ( foo ) {
case "bar":
alert("the value was bar -- yay!");
break;
case "baz":
alert("boo baz :(");
break;
default:
alert("everything else is just ok");
}

Switch statements have somewhat fallen out of favor in JavaScript,
because often the same behavior can be accomplished by creating
an object that has more potential for reuse or testing. For example:
1
2
3

var stuffToDo = {
"bar" : function() {

4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

alert("the value was bar -- yay!");
},
"baz" : function() {
alert("boo baz :(");
},
"default" : function() {
alert("everything else is just ok");
}
};
if ( stuffToDo[ foo ] ) {
stuffToDo[ foo ]();
} else {
stuffToDo["default"]();
}

Objects are covered further in the Types and Objects sections.

Loops
Loops let a block of code run a certain number of times:
1
2
3
4
5
6
7

// A for loop
// logs "try 0", "try 1", ..., "try 4"
for ( var i = 0; i < 5; i++ ) {
console.log( "try " + i );
}

Note that in loops, the variable i is not "scoped" to the loop block
even though the keyword var is used before the variable name.
Scope is covered in more depth in the Scope section.

The

for

loop

A for loop is made up of four statements and has the following
structure:
for ( [initialisation]; [conditional]; [iteration] ) {

1
2
3
4
5

[ loopBody ]
}

The initialisation statement is executed only once, before the loop
starts. It gives you an opportunity to prepare or declare any
variables.
The conditional statement is executed before each iteration, and its
return value decides whether the loop is to continue. If the
conditional statement evaluates to a falsy value, then the loop
stops.
The iteration statement is executed at the end of each iteration and
gives you an opportunity to change the state of important variables.
Typically, this will involve incrementing or decrementing a counter
and thus bringing the loop closer to its end.
The loopBody statement is what runs on every iteration. It can
contain anything. Typically, there will be multiple statements that
need to be executed, and should be wrapped in a block ( {...}).
Here's a typical
1
2
3
4
5
6

for

loop:

// A typical for loop
for (var i = 0, limit = 100; i < limit; i++) {
// This block will be executed 100 times
console.log( 'Currently at ' + i );

7
8
9
10

// Note: the last log will be "Currently at 99"
}

The

while

loop

A while loop is similar to an if statement, except that its body will
keep executing until the condition evaluates to false.
1
2
3
4
5

while ( [conditional] ) {
[loopBody]
}

Here's a typical
1
2
3
4
5
6
7
8
9
10
11
12

while

loop:

// A typical while loop
var i = 0;
while ( i < 100 ) {
// This block will be executed 100 times
console.log( "Currently at " + i );
// increment i
i++;
}

Notice that the counter is incrementing within the loop's body. It's
possible to combine the conditional and incrementer, like so:
1
2
3
4

// A while loop with a combined conditional and incremen
var i = -1;
while ( ++i < 100 ) {

5
6
7
8
9

// This block will be executed 100 times
console.log( "Currently at " + i );
}

Notice that the counter starts at -1 and uses the prefix incrementer
(++i).

The

do-while

loop

This is almost exactly the same as the while loop, except for the
fact that the loop's body is executed at least once before the
condition is tested.
1
2
3
4
5

do {
[ loopBody ]
} while ( [conditional] )

Here's a
1
2
3
4
5
6
7
8

do-while

loop:

// A do-while loop
do {
// Even though the condition evaluates to false
// this loop's body will still execute once.
alert("Hi there!");
} while ( false );

These types of loops are quite rare since only few situations require
a loop that blindly executes at least once. Regardless, it's good to
be aware of it.
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Breaking and continuing
Usually, a loop's termination will result from the conditional
statement not evaluating to true, but it is possible to stop a loop in
its tracks from within the loop's body with the break statement.
1
2
3
4
5
6
7
8
9
10

// Stopping a loop
for ( var i = 0; i < 10; i++ ) {
if ( something ) {
break;
}
}

You may also want to continue the loop without executing more of
the loop's body. This is done using the continue statement.
1
2
3
4
5
6
7
8
9
10
11
12
13
14

// Skipping to the next iteration of a loop
for ( var i = 0; i < 10; i++ ) {
if ( something ) {
continue;
}
// The following statement will only be executed
// if the conditional 'something' has not been met
console.log("I have been reached");
}
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Reserved Words
JavaScript has a number of “reserved words,” or words that have
special meaning in the language. You should avoid using these
words in your code except when using them with their intended
meaning.
abstract
boolean
break
byte
case
catch
char
class
const
continue
debugger
default
delete
do
double
else
enum
export
extends
final
finally
float
for

function
goto
if
implements
import
in
instanceof
int
interface
long
native
new
package
private
protected
public
return
short
static
super
switch
synchronized
this
throw
throws
transient
try
typeof
var
void

volatile
while
with

Arrays
Arrays are zero-indexed, ordered lists of values. They are a handy
way to store a set of related items of the same type (such as
strings), though in reality, an array can include multiple types of
items, including other arrays.
To create an array, either use the object constructor or the literal
declaration, by assigning the variable a list of values after the
declaration.
1
2
3
4

// A simple array with constructor
var myArray1 = new Array( "hello", "world" );
// literal declaration, the preferred way
var myArray2 = [ "hello", "world" ];

The literal declaration is generally preferred. See the Google
Coding Guidelines for more information.
If the values are unknown, it is also possible to declare an empty
Array, and add elements either through functions or through
accessing by index:
1
2
3
4
5
6
7
8
9
10
11

// Creating empty arrays and adding values
var myArray = [];
// adds "hello" on index 0
myArray.push("hello");
// adds "world" on index 1
myArray.push("world");
// adds "!" on index 2
myArray[ 2 ] = "!";

'push' is a function that adds an element on the end of the array
and expands the array respectively. You also can directly add items
by index. Missing indices will be filled with 'undefined'.
1
2
3
4
5
6
7
8

// Leaving indices
var myArray = [];
myArray[ 0 ] = "hello";
myArray[ 1 ] = "world";
myArray[ 3 ] = "!";

console.log( myArray ); // [ "hello", "world", undefined

If the size of the array is unknown, 'push' is far more safe. You can
both access and assign values to array items with the index.
1
2
3
4

// Accessing array items by index
var myArray = [ "hello", "world", "!" ];
console.log( myArray[2] ); // "!"
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Array Methods and Properties
.length

The .length property is used to determine the amount of items in
an array.
1
2
3
4

// Length of an array
var myArray = [ "hello", "world", "!" ];
console.log( myArray.length ); // 3

You will need the
1
2
3
4
5
6

.length

// For loops and arrays - a classic
var myArray = [ "hello", "world", "!" ];
for ( var i = 0; i < myArray.length; i = i + 1 ) {
console.log( myArray[i] );
}

Except when using
1
2
3
4
5
6

property for looping through an array:

for / in

loops:

// For loops and arrays - alternate method
var myArray = [ "hello", "world", "!" ];
for ( var i in myArray ) {
console.log( myArray[ i ] );
}

.concat

Concatenate two or more arrays with

.concat :

1
2
3
4
5
6

// Concatenating Arrays
var myArray = [ 2, 3, 4 ];
var myOtherArray = [ 5, 6, 7 ];
// [ 2, 3, 4, 5, 6, 7 ]
var wholeArray = myArray.concat( myOtherArray );

.join

creates a string representation of the array. Its parameter is a
string that works as a separator between elements (default
separator is a comma):
.join

1
2
3
4
5
6
7

// Joining elements
var myArray = [ "hello", "world", "!" ];
console.log(
console.log(
console.log(
console.log(

myArray.join(" ") );
myArray.join() );
myArray.join("") );
myArray.join("!!") );

//
//
//
//

"hello world !";
"hello,world,!"
"helloworld!"
"hello!!world!!!";

.pop
.pop removes
of .push :

1
2
3
4
5
6
7

the last element of an array. It is the opposite method

// pushing and popping
var myArray = [];
myArray.push( 0 ); // [ 0
myArray.push( 2 ); // [ 0
myArray.push( 7 ); // [ 0
myArray.pop();
// [ 0

]
, 2 ]
, 2 , 7 ]
, 2 ]

.reverse

As the name suggests, the elements of the array are in reverse
order after calling this method:
1
2
3
4
5

// reverse
var myArray = [ "world" , "hello" ];
// [ "hello", "world" ]
myArray.reverse();

.shift

Removes the first element of an array. With
can recreate the method of a queue):
1
2
3
4
5
6
7

.push

and

.shift ,

you

// queue with shift() and push()
var myArray = [];
myArray.push( 0 );
myArray.push( 2 );
myArray.push( 7 );
myArray.shift();

//
//
//
//

[
[
[
[

0
0
0
2

]
, 2 ]
, 2 , 7 ]
, 7 ]

.slice

Extracts a part of the array and returns that part in a new array. This
method takes one parameter, which is the starting index:
1
2
3
4
5
6

// slicing
var myArray = [ 1, 2, 3, 4, 5, 6, 7, 8 ];
var newArray = myArray.slice( 3 );
console.log( myArray ); // [ 1, 2, 3, 4, 5, 6, 7, 8 ]
console.log( newArray ); // [ 4, 5, 6, 7, 8 ]

.splice

Removes a certain amount of elements and adds new ones at the
given index. It takes at least 3 parameters:
// splice method
myArray.splice( index, length, values, ... );

1
2

Index - The starting index.
Length - The number of elements to remove.
Values - The values to be inserted at the Index position.
For example:
1
2
3
4
5

// splice example
var myArray = [ 0, 7, 8, 5 ];
myArray.splice( 1, 2, 1, 2, 3, 4 );
console.log( myArray ); // [ 0, 1, 2, 3, 4, 5 ]

.sort

Sorts an array. It takes one parameter, which is a comparing
function. If this function is not given, the array is sorted ascending:
1
2
3
4

// sorting without comparing function
var myArray = [ 3, 4, 6, 1 ];

1

// sorting with comparing function

myArray.sort(); // 1, 3, 4, 6

2
3
4
5
6
7
8

function descending( a, b ) {
return b - a;
}
var myArray = [ 3, 4, 6, 1 ];
myArray.sort( descending ); // [ 6, 4, 3, 1 ]

The return value of descending (for this example) is important. If the
return value is less than zero, the index of a is before b, and if it is
greater than zero it's vice-versa. If the return value is zero, the
elements index is equal.
.unshift

Inserts an element at the first position of the array:
1
2
3
4
5
6

// unshift
var myArray = [];
myArray.unshift( 0 ); // [ 0 ]
myArray.unshift( 2 ); // [ 2 , 0 ]
myArray.unshift( 7 ); // [ 7 , 2 , 0 ]

.forEach

In modern browsers it is possible to traverse through arrays with a
.forEach method, where you pass a function that is called for each
element in the array.
The function takes up to three arguments: Element - The element
itself. Index - The index of this element in the array. Array* - The
array itself.
All of these are optional, but you will need at least the 'element'
parameter in most cases.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23

// native forEach
function printElement( elem ) {
console.log( elem );
}
function printElementAndIndex( elem, index ) {
console.log( "Index " + index + ": " + elem );
}
function negateElement( elem, index, array ) {
array[ index ] = -elem;
}
myArray = [ 1, 2, 3, 4, 5 ];
// prints all elements to the console
myArray.forEach( printElement );
// prints "Index 0: 1" "Index 1: 2" "Index 2: 3" ...
myArray.forEach( printElementAndIndex );
// myArray is now [ -1, -2, -3, -4, -5 ]
myArray.forEach( negateElement );

POWERED BY HERONOTE

Objects
Objects contain one or more key-value pairs. The key portion can
be any string. The value portion can be any type of value: a
number, a string, an array, a function, or even another object. When
one of these values is a function, it’s called a method of the object.
Otherwise, they are called properties.
As it turns out, nearly everything in JavaScript is an object —
arrays, functions, numbers, even strings — and they all have
properties and methods.
1
2
3
4
5
6
7
8
9
10
11

// Creating an object literal
var myObject = {
sayHello : function() {
console.log("hello");
},
myName : "Rebecca"
};
myObject.sayHello(); // "hello"
console.log( myObject.myName ); // "Rebecca"

When creating object literals, note that the key portion of each keyvalue pair can be written as any valid JavaScript identifier, a string
(wrapped in quotes), or a number:
1
2
3
4
5
6

// test
var myObject = {
validIdentifier: 123,
"some string": 456,
99999: 789
};

Functions
Functions contain blocks of code that need to be executed
repeatedly. Functions can take zero or more arguments, and can
optionally return a value.
Functions can be created in a variety of ways, two of which are
shown below:
1
2
3
4
5
6

// Function Declaration
function foo() {

1
2
3
4
5
6

// Named Function Expression
var foo = function() {

/* do something */
}

/* do something */
}

Using Functions
1
2
3
4
5
6
7
8
9
10

// A simple function
var greet = function( person, greeting ) {

1
2
3
4
5
6
7
8
9
10

// A function that returns a value
var greet = function( person, greeting ) {

1
2
3
4
5
6
7

var text = greeting + ", " + person;
console.log( text );
};
greet( "Rebecca", "Hello" );

var text = greeting + ", " + person;
return text;
};
console.log( greet( "Rebecca", "hello" ) ); // "hello,

// A function that returns another function
var greet = function( person, greeting ) {
var text = greeting + ", " + person;
return function() {
console.log( text );
};

8
9
10
11
12

};
var greeting = greet( "Rebecca", "Hello" );
greeting();

Immediately-Invoked Function Expression
(IIFE)
A common pattern in JavaScript is the immediately-invoked function
expression. This pattern creates a function expression and then
immediately executes the function. This pattern is extremely useful
for cases where you want to avoid polluting the global namespace
with code — no variables declared inside of the function are visible
outside of it.
1
2
3
4
5
6
7
8

// An immediately-invoked function expression
(function() {
var foo = "Hello world";
})();
console.log( foo );

// undefined!
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Functions as Arguments
In JavaScript, functions are "first-class citizens" — they can be
assigned to variables or passed to other functions as arguments.
Passing functions as arguments is an extremely common idiom in
jQuery.
1
2
3
4
5
6
7
8
9
10

// Passing an anonymous function as an argument
var myFn = function( fn ) {
var result = fn();
console.log( result );
};

1
2
3
4
5
6
7
8
9
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// Passing a named function as an argument

// logs "hello world"
myFn( function() {
return "hello world";
});

var myFn = function( fn ) {
var result = fn();
console.log( result );
};
var myOtherFn = function() {
return "hello world";
};
myFn( myOtherFn ); // "hello world"
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Testing Type
JavaScript offers a way to test the type of a variable. However, the
result can be confusing — for example, the type of an array is
"Object."
It's common practice to use the typeof operator when trying to
determining the type of a specific value.
1
2
3
4
5
6
7
8
9
10
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14
15
16
17
18
19
20
21
22
23
24
25
26
27

// Testing the type of various variables
var myFunction = function() {
console.log("hello");
};
var myObject = {
foo : "bar"
};
var myArray = [ "a", "b", "c" ];
var myString = "hello";
var myNumber = 3;
typeof
typeof
typeof
typeof
typeof
typeof

myFunction;
myObject;
myArray;
myString;
myNumber;
null;

//
//
//
//
//
//

"function"
"object"
"object" -- Careful!
"string"
"number"
"object" -- Careful!

if ( myArray.push && myArray.slice && myArray.join ) {
// probably an array (this is called "duck typing")
}
if ( Object.prototype.toString.call( myArray ) ===
// Definitely an array!
// This is widely considered as the most robust way

28
29

// to determine if a specific value is an Array.
}

jQuery also offers utility methods to help determine the type of an
arbitrary value.
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The “this” Keyword
In JavaScript, as in most object-oriented programming languages,
this is a special keyword that is used in methods to refer to the
object on which a method is being invoked. The value of this is
determined using a simple series of steps:
If the function is invoked using Function.call or
Function.apply , this will be set to the first argument passed to
call / apply . If the first argument passed to call / apply is null or
undefined, this will refer to the global object (which is the
window object in web browsers).
If the function being invoked was created using Function.bind ,
this will be the first argument that was passed to bind at the
time the function was created.
If the function is being invoked as a method of an object, this
will refer to that object.
Otherwise, the function is being invoked as a standalone
function not attached to any object, and this will refer to the
global object.
1
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4
5
6
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// A function invoked using Function.call
var myObject = {
sayHello: function() {
console.log( "Hi! My name is " + this.myName );
},
myName: "Rebecca"
};
var secondObject = {
myName: "Colin"
};

myObject.sayHello();
// "Hi! My name
myObject.sayHello.call( secondObject ); // "Hi! My name

1
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// A function created using Function.bind
var myName = "the global object";
var sayHello = function() {
console.log( "Hi! My name is " + this.myName );
};
var myObject = {
myName: "Rebecca"
};
var myObjectHello = sayHello.bind( myObject );

1
2
3
4
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// A function being attached to an object at runtime
var myName = "the global object";
var sayHello = function() {
console.log( "Hi! My name is " + this.myName );
};
var myObject = {
myName: "Rebecca"
};
var secondObject = {
myName: "Colin"
};

sayHello(); // "Hi! My name is the global object"
myObjectHello(); // "Hi! My name is Rebecca"

myObject.sayHello = sayHello;
secondObject.sayHello = sayHello;
sayHello();
// "Hi! My name is the global
myObject.sayHello();
// "Hi! My name is Rebecca"
secondObject.sayHello(); // "Hi! My name is Colin"

When invoking a function deep within a long namespace, it is often
tempting to reduce the amount of code you need to type by storing
a reference to the actual function as a single, shorter variable. It is
important not to do this with instance methods as this will cause the
value of this within the function to change, leading to incorrect
code operation. For instance:
1
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var myNamespace = {
myObject: {
sayHello: function() {
console.log( "Hi! My name is " + this.myName );
},
myName: "Rebecca"
}
};
var hello = myNamespace.myObject.sayHello;
hello(); // "Hi! My name is undefined"

You can, however, safely reduce everything up to the object on
which the method is invoked:
1
2
3
4
5
6
7
8
9
10
11
12

var myNamespace = {
myObject: {
sayHello: function() {
console.log( "Hi! My name is " + this.myName );
},
myName: "Rebecca"
}
};
var obj = myNamespace.myObject;
obj.sayHello(); // "Hi! My name is Rebecca"

POWERED BY HERONOTE

Scope
"Scope" refers to the variables that are available to a piece of code
at a given time. A lack of understanding of scope can lead to
frustrating debugging experiences.
When a variable is declared inside of a function using the var
keyword, it is only available to code inside of that function — code
outside of that function cannot access the variable. On the other
hand, functions defined inside that function will have access to the
declared variable.
Furthermore, variables that are declared inside a function without
the var keyword are not local to the function — JavaScript will
traverse the scope chain all the way up to the window scope to find
where the variable was previously defined. If the variable wasn't
previously defined, it will be defined in the global scope, which can
have unexpected consequences.
1
2
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// Functions have access to variables defined in the sam
var foo = "hello";
var sayHello = function() {
console.log( foo );
};

1
2
3
4
5
6
7

// Code outside the scope in which a variable was define
var sayHello = function() {
var foo = "hello";
console.log( foo );
};

sayHello(); // "hello"
console.log( foo ); // "hello"

sayHello(); // hello

8
9

console.log( foo ); // undefined

1
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// Variables with the same name can exist in different
var foo = "world";

1
2
3
4
5
6
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// Functions can see changes in variable values after t
var myFunction = function() {
var foo = "hello";
var myFn = function() {
console.log( foo );
};
foo = "world";
return myFn;
};

1
2
3
4

var sayHello = function() {
var foo = "hello";
console.log( foo );
};
sayHello();
// logs "hello"
console.log( foo ); // logs "world"

var f = myFunction();
f(); // "world"

// Scope insanity
// a self-executing anonymous function
(function() {
var baz = 1;
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var bim = function() {
alert( baz );
};
bar = function() {
alert( baz );
};
})();
// baz is not defined outside of the function
console.log( baz );
// bar is defined outside of the anonymous function
// because it wasn't declared with var; furthermore,
// because it was defined in the same scope as baz,
// it has access to baz even though other code
// outside of the function does not
bar();

// bim is not defined outside of the anonymous function
// so this will result in an error
bim();

Closures
Closures are an extension of the concept of scope. With closures,
functions have access to variables that were available in the scope
where the function was created. If that seems confusing, don’t
worry: closures are generally best understood by example.
As shown in the Functions section, functions have access to
changing variable values. The same sort of behavior exists with
functions defined within loops — the function "sees" the change in
the variable's value even after the function is defined, resulting in
each function referencing the last value stored in the variable.
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// Each function executed within the loop will referenc
// the last value stored in i (5).
// this won't behave as we want it to // every 100 milliseconds, 5 will alert
for ( var i = 0; i < 5; i++ ) {
setTimeout(function() {
alert( i );
}, i * 100 );
}

Closures can be used to prevent this by creating a unique scope for
each iteration — storing each unique value of the variable within its
scope.
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// Using a closure to create a new private scope
// fix: “close” the value of i inside createFunction, s
var createFunction = function( i ) {
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return function() {
alert( i );
};
};
for ( var i = 0; i < 5; i++ ) {
setTimeout( createFunction( i ), i * 100 );
}

Closures can also be used to resolve issues with the
which is unique to each scope:
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this

keyword,

//Using a closure to access inner and outer object inst
var outerObj = {
myName : "outer",
outerFunction : function() {

// provide a reference to outerObj through innerFun
var self = this;
var innerObj = {
myName : "inner",
innerFunction : function() {
console.log( self.myName, this.myName );
}
};
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innerObj.innerFunction();
console.log( this.myName ); // "outer"
}
};
outerObj.outerFunction();
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Function.bind

Closures can be particularly useful when dealing with callbacks.
However, it is often better to use Function.bind , which will avoid
any overhead associated with scope traversal.
is used to create a new function. When called, the
new function then calls itself in the context of the supplied this
value, using a given set of arguments that will precede any
arguments provided when the new function was initially called.
Function.bind

As bind is a recent addition to ECMAScript 5, it may not be present
in all browsers, which is something to be wary of when deciding
whether to use it. However, it's possible to work around support by
using this shim from MDN:
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// Shim from MDN
if (!Function.prototype.bind) {
Function.prototype.bind = function( oThis ) {
if (typeof this !== "function") {

// closest thing possible to the ECMAScript 5 int
// IsCallable function
throw new TypeError("Function.prototype.bind - wh
}
var fSlice = Array.prototype.slice,
aArgs = fSlice.call( arguments, 1 ),
fToBind = this,
fNOP = function() {},
fBound = function() {
return fToBind.apply( this instanceof
? this
: oThis || window,
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aArgs.concat( fSlice.cal
};
fNOP.prototype = this.prototype;
fBound.prototype = new fNOP();
return fBound;
};
}

One of the simplest uses of bind is making a function that is called
with a particular value for this , regardless of how it's called. A
common mistake developers make is attempting to extract a
method from an object, then later calling that method and expecting
it to the use the origin object as its this . However, this can be
solved by creating a bound function using the original object as
demonstrated below:
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//let's manipulate "this" with a basic example
var user = "johnsmith";
var module = {
getUser: function() {
return this.user;
},
user: "janedoe"
};
// module.getUser() is called where "module" is "this"
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// and "module.user" is returned.
// janedoe
module.getUser();

// let's now store a reference in the global version of
var getUser = module.getUser;

// getUser() called, "this" is global, "user" is return
// johnsmith
getUser();
// store a ref with "module" bound as "this"
var boundGetUser = getUser.bind( module );

// boundGetUser() called, "module" is "this" again, "mo
// janedoe
boundGetUser();
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Using jQuery Core
$ vs $()
$( document ).ready()
Avoiding Conflicts with Other Libraries
Attributes
Selecting Elements
Working with Selections
Manipulating Elements
The jQuery Object
Traversing
CSS, Styling, & Dimensions
Data Methods
Utility Methods
Iterating over jQuery and non-jQuery Objects
Using jQuery’s .index() Function
Frequently Asked Questions
How do I select an item using class or ID?
How do I select elements when I already have a DOM
element?
How do I test whether an element has a particular class?
How do I test whether an element exists?
How do I determine the state of a toggled element?
How do I select an element by an ID that has characters
used in CSS notation?
How do I disable/enable a form element?
How do I check/uncheck a checkbox input or radio button?
How do I get the text value of a selected option?
How do I replace text from the 3rd element of a list of 10
items?

How do I pull a native DOM element from a jQuery object?
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$ vs $()
Until now, we’ve been dealing entirely with methods that are called
on a jQuery object. For example:
1

$("h1").remove();

Most jQuery methods are called on jQuery objects as shown above;
these methods are said to be part of the $.fn namespace, or the
“jQuery prototype,” and are best thought of as jQuery object
methods.
However, there are several methods that do not act on a selection;
these methods are said to be part of the jQuery namespace, and
are best thought of as core jQuery methods.
This distinction can be incredibly confusing to new jQuery users.
Here’s what you need to remember:
Methods called on jQuery selections are in the $.fn
namespace, and automatically receive and return the selection
as this.
Methods in the $ namespace are generally utility-type
methods, and do not work with selections; they are not
automatically passed any arguments, and their return value will
vary.
There are a few cases where object methods and core methods
have the same names, such as $.each and $.fn.each . In these
cases, be extremely careful when reading the documentation that
you are exploring the correct method.
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$( document ).ready()
A page can't be manipulated safely until the document is “ready.”
jQuery detects this state of readiness for you. Code included inside
$( document ).ready() will only run once the page DOM (Document
Object Model) is ready for JavaScript code to execute. Code
included inside $( window ).load(function(){ ... }) will run once
the entire page (images or iframes), not just the DOM, is ready.
1
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// A $( document ).ready() block
$( document ).ready(function() {
console.log("ready!");
});

Experienced developers sometimes use shorthand for $( document
).ready() . If you are writing code that people who aren't
experienced with jQuery may see, it's best to use the long form.
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// Shorthand for $( document ).ready()
$(function() {
console.log("ready!");
});

You can also pass a named function to $( document
instead of passing an anonymous function.
1
2
3
4
5
6
7

).ready()

// Passing a named function instead of an anonymous func
function readyFn( jQuery ) {
// code to run when the document is ready
}
$( document ).ready( readyFn );

8
9

// OR
$( window ).load( readyFn );

The below example shows $( document ).ready() and $( window
).load() in action. The code tries to load a website url in an iframe
and checks for both events:
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<html>
<head>
<script src="http://code.jquery.com/jquery-1.7.1.mi
<script>
$( document ).ready(function() {
console.log("document loaded");
});
$( window ).load(function() {
console.log("window loaded");
});
</script>
</head>
<body>
<iframe src="http://techcrunch.com"></iframe
</body>
</html>

Avoiding Conflicts with Other
Libraries
The jQuery library and virtually all of its plugins are contained within
the jQuery namespace. As a general rule, global objects are stored
inside the jQuery namespace as well, so you shouldn't get a clash
between jQuery and any other library (like prototype.js, MooTools,
or YUI).
That said, there is one caveat: by default, jQuery uses $ as a
shortcut for jQuery . Thus, if you are using another JavaScript library
that uses the $ variable, you can run into conflicts with jQuery. In
order to avoid these conflicts, you need to put jQuery in no-conflict
mode immediately after it is loaded onto the page and before you
attempt to use jQuery in your page.

Putting jQuery into No-Conflict Mode
When you put jQuery into no-conflict mode, you have the option of
assigning a new variable name to replace the $ alias.
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<!-- Putting jQuery into no-conflict mode -->
<script src="prototype.js"></script>
<script src="jquery.js"></script>
<script>
// $j is now an alias to the jQuery function;
// creating the new alias is optional
var $j = jQuery.noConflict();
$j(document).ready(function(){
$j("div").hide();
});

// The $ variable now has the prototype meaning,
// which is a shortcut for document.getElementById.
// mainDiv below is a DOM element, not a jQuery obj
window.onload = function(){
var mainDiv = $('main');
}
</script>

In the code above, the $ will revert back to its meaning in original
library. You'll still be able to use the full function name jQuery as
well as the new alias $j in the rest of your application. The new
alias can be named anything you'd like: jq , $J , awesomeQuery , etc.
Finally, if you don't want to define another alternative to the full
jQuery function name (you really like to use $ and don't care about
using the other library's $ method), then there's still another
approach you might try: simply add the $ as an argument passed
to your jQuery(document).ready() function. This is most frequently
used in the case where you still want the benefits of really concise
jQuery code, but don't want to cause conflicts with other libraries.
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<!-- Another way to put jQuery into no-conflict mode -<script src="prototype.js"></script>
<script src="jquery.js"></script>
<script>

jQuery.noConflict();
jQuery(document).ready(function($){
// You can use the locally-scoped $ in here as a
$("div").hide();
});

// The $ variable in the global scope has the proto
window.onload = function(){
var mainDiv = $('main');
}
</script>

This is probably the ideal solution for most of your code,
considering that there'll be less code that you'll have to change in
order to achieve complete compatibility.

Including jQuery Before Other Libraries
The code snippets above rely on jQuery being loaded after
prototype.js is loaded. If you include jQuery before other libraries,
you may use jQuery when you do some work with jQuery, but the $
will have the meaning defined in the other library. There is no need
to relinquish the $ alias by calling jQuery.noConflict() .
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<!-- Loading jQuery before other libraries -->
<script src="jquery.js"></script>
<script src="prototype.js"></script>
<script>

// Use full jQuery function name to reference jQuer
jQuery(document).ready(function(){
jQuery("div").hide();
});
// Use the $ variable as defined in prototype.js
window.onload = function() {
var mainDiv = $('main');
};
</script>
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Summary of Ways to Reference the jQuery
Function
Here's a recap of ways you can reference the jQuery function when
the presence of another library creates a conflict over the use of the
$ variable:

Create a New Alias
The jQuery.noConflict() method returns a reference to the jQuery
function, so you can capture it in whatever variable you'd like:
1
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<script src="prototype.js"></script>
<script src="jquery.js"></script>
<script>
// Give $ back to prototype.js; create new alias to
var $jq = jQuery.noConflict();
</script>

Use an Immediately Invoked Function
Expression
You can continue to use the standard $ by wrapping your code in
an immediately invoked function expression; this is also a standard
pattern for jQuery plugin authoring, where the author cannot know
whether another library will have taken over the $ . See the Plugins
section for more information about writing plugins.
1
2
3
4

<!-- Using the $ inside an immediately-invoked function
<script src="prototype.js"></script>
<script src="jquery.js"></script>
<script>
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jQuery.noConflict();
(function($) {
// your jQuery code here, using the $
})(jQuery);
</script>

Note that if you use this technique, you will not be able to use
prototype.js methods inside the immediately invoked function that
expect $ to be prototype.js's $ .

Use the Argument That's Passed to the
jQuery(document).ready() Function
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<script src="jquery.js"></script>
<script src="prototype.js"></script>
<script>

jQuery(document).ready(function($){
// your jQuery code here, using $ to refer to jQue
});
</script>

Or using the more concise syntax for the DOM ready function:
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<script src="jquery.js"></script>
<script src="prototype.js"></script>
<script>
jQuery(function($){
// your jQuery code here, using the $
});
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</script>

Attributes
An element's attributes can contain useful information for your
application, so it's important to be able to get and set them.
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$.fn.attr

The $.fn.attr method acts as both a getter and a setter. As a
setter, $.fn.attr can accept either a key and a value, or an object
containing one or more key/value pairs.
$.fn.attr
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// Setting attributes
$("a").attr( "href", "allMyHrefsAreTheSameNow.html"
$("a").attr({
title: "all titles are the same too!",
href: "somethingNew.html"
});

$.fn.attr

1
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as a setter:

as a getter:

// Getting attributes
$("a").attr("href"); // returns the href for the first

Selecting Elements
The most basic concept of jQuery is to “select some elements and
do something with them.” jQuery supports most CSS3 selectors, as
well as some non-standard selectors. For a complete selector
reference, visit the Selectors documentation on api.jquery.com.

Selecting Elements by ID
1
2

// Selecting elements by ID
$("#myId"); // note IDs must be unique per page

Selecting Elements by Class Name
1
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// Selecting elements by class name
$(".myClass");

Selecting Elements by Attribute
1
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// Selecting elements by attribute
$("input[name='first_name']"); // beware, this can be ve

Selecting Elements by Compound CSS
Selector
1
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// Selecting elements by compound CSS selector
$("#contents ul.people li");

Pseudo-selectors
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// Pseudo-selectors
$("a.external:first");
$("tr:odd");

// select all input-like elements in a form (more on th
$("#myForm :input");
$("div:visible");
// all except the first three divs
$("div:gt(2)");
// all currently animated divs
$("div:animated");

Note: when using the :visible and :hidden pseudo-selectors,
jQuery tests the actual visibility of the element, not its CSS visibility
or display. jQuery looks to see if the element's physical height and
width on the page are both greater than zero.
However, this test doesn't work with <tr> elements. In the case of
<tr> jQuery does check the CSS display property, and considers
an element hidden if its display property is set to none.
Elements that have not been added to the DOM will always be
considered hidden, even if the CSS that would affect them would
render them visible. See the Manipulating Elements section to learn
how to create and add elements to the DOM.
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Choosing Selectors
Choosing good selectors is one way to improve JavaScript's
performance. A little specificity — for example, including an element
type when selecting elements by class name — can go a long way.
On the other hand, too much specificity can be a bad thing. A
selector such as #myTable thead tr th.special is overkill if a
selector such as #myTable th.special will get the job done.
jQuery offers many attribute-based selectors, allowing selections
based on the content of arbitrary attributes using simplified regular
expressions.
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// find all <a>s whose rel attribute
// ends with "thinger"
$("a[rel$='thinger']");

While these can be useful in a pinch, they can also be extremely
slow in older browsers. Wherever possible, make selections using
IDs, class names, and tag names.

Does My Selection Contain Any Elements?
Once you've made a selection, you'll often want to know whether
you have anything to work with. A common mistake is to use:
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// Doesn't work!
if ( $("div.foo") ) {
...
}

This won't work. When a selection is made using $() , an object is
always returned, and objects always evaluate to true. Even if the
selection doesn't contain any elements, the code inside the if
statement will still run.

The best way to determine if there are any elements is to test the
selection's length property, which tells you how many elements
were selected. If the answer is 0, the length property will evaluate to
false when used as a boolean value:
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//Testing whether a selection contains elements
if ( $("div.foo").length ) {
...
}

Saving Selections
jQuery doesn't cache elements for you. If you've made a selection
that you might need to make again, you should save the selection
in a variable rather than making the selection repeatedly.
1

var $divs = $("div");

In the example above, the variable name begins with a dollar sign.
Unlike in other languages, there's nothing special about the dollar
sign in JavaScript — it's just another character. Here, it's used to
indicate that the variable contains a jQuery object. This practice is
merely convention, and is not mandatory.
Once the selection is stored in a variable, you can call jQuery
methods on the variable just like you would have called them on the
original selection.
A selection only fetches the elements that are on the page at the
time the selection is made. If elements are added to the page later,
you'll have to repeat the selection or otherwise add them to the
selection stored in the variable. Stored selections don't magically
update when the DOM changes.

Refining & Filtering Selections

Sometimes the selection contains more than what you're after.
jQuery offers several methods for refining and filtering selections.
1
2
3
4
5
6

// Refining selections
$("div.foo").has("p");
$("h1").not(".bar");
$("ul li").filter(".current");
$("ul li").first();
$("ul li").eq( 5 );

//
//
//
//

div.foo elements that
h1 elements that don'
unordered list items
just the first unorde
// the sixth

Selecting Form Elements
jQuery offers several pseudo-selectors that help find elements in
forms. These are especially helpful because it can be difficult to
distinguish between form elements based on their state or type
using standard CSS selectors.
:button
Using the :button pseudo-selector targets just the
elements and elements with a type = "button" :
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<button>

// :button pseudo-selector
// selects <button> elements and elements with type="but
$("form :button");

In order to get the best performance using :button , it's best to first
select elements with a standard jQuery selector, then to use
.filter(":button") . More can be seen on the jQuery :button
documentation page. Another option is to precede the pseudoselector with a tag name or some other selector.
:checkbox
Using the

:checkbox

pseudo-selector targets any elements with a

type = "checkbox" :
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// :checkbox pseudo-selector
// selects elements with type="checkbox"
$("form :checkbox");

Much like the :button pseudo-selector, it's best to first select
elements with a standard jQuery selector, then to use
.filter(":checkbox") , or to precede the pseudo-selector with some
other selector.
:checked
Not to be confused with :checkbox, :checked targets only the
checked checkboxes as well as checked radio buttons.
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// :checked pseudo-selector
// selects checked checkboxes and radio buttons
$("form :checked");

The :checked pseudo-selector works when used with checkboxes
and radio buttons.
:disabled
Using the :disabled pseudo-selector targets all
with the disabled attribute:
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<input>

elements

// :disabled pseudo-selector
// selects all input elements with the disabled attribut
$("form :disabled");

In order to get the best performance using :disabled , first select
elements with a standard jQuery selector, then use

.filter(":disabled") ,

or precede the pseudo-selector with a tag
name or some other selector.
:enabled
Basically the inverse of the :disabled pseudo-selector, the :enabled
pseudo-selector targets all elements that do not have a disabled
attribute:
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// :enabled pseudo-selector
// selects all elements that do not have the disabled at
$("form :enabled");

In order to get the best performance using :enabled , first select
elements with a standard jQuery selector, then use
.filter(":enabled") , or precede the pseudo-selector with a tag
name or some other selector.
:file
Using the

:file
type = "file" :
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pseudo-selector targets all

<input> s

that have a

// :file pseudo-selector
// selects all inputs with a type = "file"
$("form :file");

In order to get the best performance using :file , first select
elements with a standard jQuery selector, then use
.filter(":file") , or precede the pseudo-selector with a tag name
or some other selector.
Note: for better performance in modern browsers, use
"file"] instead of the :file pseudo-selector.
:image

[type =

Using the :image pseudo-selector easily targets all
that are the image type:
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<input>

tags

// :image pseudo-selector
// selects all input elements of type "image"
$("form :image");

In order to get the best performance using :image , first select
elements with a standard jQuery selector, then use
.filter(":image") , or precede the pseudo-selector with a tag name
or some other selector.
Note: for better performance in modern browsers, use
"image"] instead of the :image pseudo-selector.

[type =

:input
Using the :input selector selects all
and <button> elements:
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<input> , <textarea> , <select> ,

:input pseudo-selector
// selects <input>, <textarea>, <select>, and <button> e
$("form :input");

:password
Using the :password pseudo-selector easily targets any
with a type of password:
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<input> s

// :password pseudo-selector
// selects all <input>s "password"
$("form :password");

In order to get the best performance using

:password ,first

select

elements with a standard jQuery selector, then use
.filter(":password") , or precede the pseudo-selector with a tag
name or some other selector.
Note: for better performance in modern browsers, use [
"password" ] instead of the :password pseudo-selector.

type =

:radio
Using the :radio pseudo-selector easily targets any
have a type of radio:
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<input> s

that

// :radio pseudo-selector
// selects all <input>s of type "radio"
$("form :radio");

To select a set of associated radio buttons use:
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// Selection associated radio buttons with :radio
// selects all radio buttons with the name attribute of
$("form input[name="gender"]:radio")

In order to get the best performance using :radio , first select
elements with a standard jQuery selector, then use
.filter(":radio") , or precede the pseudo-selector with a tag name
or some other selector.
Note: for better performance in modern browsers, use
"radio" ] instead of the :radio pseudo-selector.

[ type =

:reset
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// :reset pseudo-selector
// selects all elements of type "reset"
$("form :reset");

In order to get the best performance using :reset , first select
elements with a standard jQuery selector, then use
.filter(":reset") , or precede the pseudo-selector with a tag name
or some other selector.
Note: for better performance in modern browsers, use
"reset" ] instead of the :reset pseudo-selector.

[ type =

:selected
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// :selected pseudo-selector
// selects all selected items in <option> elements
$("form :selected");

In order to get the best performance using :selected , first select
elements with a standard jQuery selector, then use
.filter(":selected") , or precede the pseudo-selector with a tag
name or some other selector.
:submit
1
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// :submit pseudo-selector
// selects all inputs with type = "submit"
$("form :submit");

The :submit selector usually applies to <button> or <input>
elements. Some browsers (such as Internet Explorer) do not
automatically give the <button> element a type = "submit" by
default.
Note: for better performance in modern browsers, use
"submit" ] instead of the :submit pseudo-selector.
:text
1

// :text pseudo-selector

[ type =

2
3

// selects all inputs with type = "text"
$("form :text");

In order to get the best performance using :selected , first select
elements with a standard jQuery selector, then use
.filter(":selected") , or precede the pseudo-selector with a tag
name or some other selector.
Note: As of jQuery 1.5.2, :text selects <input> elements that have
no specified type attribute. So, type = "text" is implied.
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Working with Selections
Getters & Setters
jQuery “overloads” its methods, so the method used to set a value
generally has the same name as the method used to get a value.
When a method is used to set a value, it's called a setter. When a
method is used to get (or read) a value, it's called a getter. Setters
affect all elements in a selection. Getters get the requested value
only for the first element in the selection.
1
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//The $.fn.html method used as a setter
$("h1").html("hello world");

1
2

// The html method used as a getter
$("h1").html();

Setters return a jQuery object, allowing you to continue calling
jQuery methods on your selection. Getters return whatever they
were asked to get, so you can't continue to call jQuery methods on
the value returned by the getter.
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// Attempting to call a jQuery method after calling a ge
// This will NOT work
$("h1").html().addClass("test")

Chaining
If you call a method on a selection and that method returns a
jQuery object, you can continue to call jQuery methods on the
object without pausing for a semicolon. This practice is referred to
as 'chaining':

1
2

// Chaining
$("#content").find("h3").eq( 2 ).html("new text for the

It may help code readability to break the chain over several lines.
1
2
3
4
5

// Formatting chained code
$("#content")
.find("h3")
.eq( 2 )
.html("new text for the third h3!");

jQuery also provides the $.fn.end method to get back to the original
selection should you change the selection in the middle of a chain:
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Restoring your original selection using $.fn.end
$("#content")
.find("h3")
.eq( 2 )
.html("new text for the third h3!")
.end() // restores the selection to all h3s in #cont
.eq( 0 )
.html("new text for the first h3!");

Chaining is extraordinarily powerful, and it's a feature that many
libraries have adapted since it was made popular by jQuery.
However, it must be used with care — extensive chaining can make
code extremely difficult to modify or debug. There is no hard-andfast rule to how long a chain should be — just know that it's easy to
get carried away.

Manipulating Elements
For complete documentation of jQuery manipulation methods, visit
the Manipulation documentation on api.jquery.com.

Getting and Setting Information about
Elements
There are many ways to change an existing element. Among the
most common tasks is changing the inner HTML or attribute of an
element. jQuery offers simple, cross-browser methods for these
sorts of manipulations. You can also get information about elements
using many of the same methods in their getter incarnations. For
more information on getters and setters, see the Working with
Selections section. Here are a few methods you can use to get and
set information about elements:
$.fn.html

- Get or set the html contents.

$.fn.text

- Get or set the text contents; HTML will be stripped.

$.fn.attr

- Get or set the value of the provided attribute.

- Get or set the width in pixels of the first element in
the selection as an integer.
$.fn.height - Get or set the height in pixels of the first element
in the selection as an integer.
$.fn.position - Get an object with position information for the
first element in the selection, relative to its first positioned
ancestor. This is a getter only.
$.fn.val - Get or set the value of form elements.
$.fn.width

Changing things about elements is trivial, but remember that the
change will affect all elements in the selection. If you just want to
change one element, be sure to specify that in the selection before
calling a setter method.
1
2

// Changing the HTML of an element
$("#myDiv p:first").html("New <strong>first</strong> par

Moving, Copying, and Removing Elements
While there are a variety of ways to move elements around the
DOM, there are generally two approaches:
Place the selected element(s) relative to another element.
Place an element relative to the selected element(s).
For example, jQuery provides $.fn.insertAfter and $.fn.after .
The $.fn.insertAfter method places the selected element(s) after
the element that provided as an argument. The $.fn.after method
places the element provided as an argument after the selected
element. Several other methods follow this pattern:
$.fn.insertBefore and $.fn.before , $.fn.appendTo and $.fn.append ,
and $.fn.prependTo and $.fn.prepend .
The method that makes the most sense will depend on what
elements are selected, and whether you need to store a reference
to the elements you're adding to the page. If you need to store a
reference, you will always want to take the first approach — placing
the selected elements relative to another element — as it returns
the element(s) you're placing. In this case, $.fn.insertAfter ,
$.fn.insertBefore , $.fn.appendTo , and $.fn.prependTo should be
the tools of choice.
1
2
3
4
5
6
7
8
9
10
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// Moving elements using different approaches
// make the first list item the last list item
var $li = $("#myList li:first").appendTo("#myList"
// another approach to the same problem
$("#myList").append( $("#myList li:first") );
// note that there's no way to access the
// list item that we moved, as this returns
// the list itself

Cloning Elements
Methods such as $.fn.appendTo move the element, but sometimes
a copy of the element is needed instead. In this case, use
$.fn.clone first:
1
2
3
4

// Making a copy of an element
// copy the first list item to the end of the list
$("#myList li:first").clone().appendTo("#myList"

If you need to copy related data and events, be sure to pass
as an argument to $.fn.clone .

true

Removing Elements
There are two ways to remove elements from the page:
$.fn.remove and $.fn.detach . Use $.fn.remove when you want to
permanently remove the selection from the page. While
$.fn.remove does return the removed element(s), those elements
will not have their associated data and events attached to them if
you return them to the page.
Use

$.fn.detach if you need the data and
$.fn.remove , it returns the selection, but it

events to persist. Like
also maintains the data
and events associated with the selection, so you can restore the
selection to the page at a later time.
The $.fn.detach method is extremely valuable if you are doing
heavy manipulation on an element. In that case, it's beneficial to
$.fn.detach the element from the page, work on it in your code,
then restore it to the page when you're done. This limits expensive
"DOM touches" while maintaining the element's data and events.
If you want to leave the element on the page but remove its
contents, you can use $.fn.empty to dispose of the element's inner
HTML.

Creating New Elements
jQuery offers a trivial and elegant way to create new elements using
the same $() method used to make selections:
1
2
3
4

// Creating new elements from an HTML string
$("<p>This is a new paragraph</p>");

1
2
3
4
5
6

// Creating a new element with an attribute object
$( "<a/>", {
html : "This is a <strong>new</strong> link"
"class" : "new",
href : "foo.html"
});

$("<li class=\"new\">new list item</li>");

Note that the attributes object in the second argument above, the
property name class is quoted, although the property names 'text'
and 'href' are not. Property names generally do not need to be
quoted unless they are reserved words (as class is in this case).
When you create a new element, it is not immediately added to the
page. There are several ways to add an element to the page once
it's been created.
1
2
3
4
5
6
7

// Getting a new element on to the page
var $myNewElement = $("<p>New element</p>");
$myNewElement.appendTo("#content");

$myNewElement.insertAfter("ul:last"); // this will remov

8

$("ul").last().after( $myNewElement.clone() );

The created element doesn't need to be stored in a variable — you
can call the method to add the element to the page directly after the
$() . However, most of the time you'll want a reference to the
element you added so you won't have to select it later.
You can also create an element as you're adding it to the page, but
note that in this case you don't get a reference to the newly created
element:
1
2

// Creating and adding an element to the page at the sam
$("ul").append("<li>list item</li>");

The syntax for adding new elements to the page is easy, so it's
tempting to forget that there's a huge performance cost for adding
to the DOM repeatedly. If you're adding many elements to the same
container, you'll want to concatenate all the html into a single string,
and then append that string to the container instead of appending
the elements one at a time. Use an array to gather all the pieces
together, then join them into a single string for appending.
1
2
3
4
5
6
7
8
9
10

var myItems = [];
var $myList = $("#myList");
for ( var i = 0; i < 100; i++ ) {
myItems.push( "<li>item " + i + "</li>" );
}
$myList.append( myItems.join("") );
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Manipulating Attributes
jQuery's attribute manipulation capabilities are extensive. Basic
changes are simple, but the $.fn.attr method also allows for more
complex manipulations. It can either set an explicit value, or set a
value using the return value of a function. When the function syntax
is used, the function receives two arguments: the zero-based index
of the element whose attribute is being changed, and the current
value of the attribute being changed.
1
2

// Manipulating a single attribute
$("#myDiv a:first").attr( "href", "newDestination.html"

1
2
3
4
5

// Manipulating multiple attributes
$("#myDiv a:first").attr({
href: "newDestination.html",
rel: "super-special"
});

1
2
3
4
5
6
7
8
9
10
11
12
13

// Using a function to determine an attribute's new val
$("#myDiv a:first").attr({
rel: "super-special",
href: function( idx, href ) {
return "/new/" + href;
}
});

$("#myDiv a:first").attr( "href", function( idx, href )
return "/new/" + href;
});

The jQuery Object
When creating new elements (or selecting existing ones), jQuery
returns the elements in a collection. Many developers new to
jQuery assume that this collection is an array. It has a zero-indexed
sequence of DOM elements, some familiar array functions, and a
.length property, after all. Actually, the jQuery object is more
complicated than that.

DOM and DOM elements
The Document Object Model (DOM for short) is a representation of
an HTML document. It may contain any number of DOM elements.
At a high level, a DOM element can be thought of as a "piece" of a
web page. It may contain text and/or other DOM elements. DOM
elements are described by a type, such as <div> , <a> , or <p> , and
any number of attributes such as src , href , class and so on. For a
more thorough description, refer to the official DOM specification
from the W3C.
Elements have properties like any JavaScript object. Among these
properties are attributes like tagName and methods like appendChild .
These properties are the only way to interact with the web page via
JavaScript.
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The jQuery Object
It turns out that working directly with DOM elements can be
awkward. The jQuery object defines many methods to smooth out
the experience for developers. Some benefits of the jQuery Object
include:
Compatibility — The implementation of element methods varies
across browser vendors and versions. The following snippet
attempts to set the inner HTML of a <tr> element stored in target :
1
2
3

var target = document.getElementById("target");
target.innerHTML = "<td>Hello <b>World</b>!</td>"

This works in many cases, but it will fail in most versions of Internet
Explorer. In that case, the recommended approach is to use pure
DOM methods instead. By wrapping the target element in a jQuery
object, these edge cases are taken care of, and the expected result
is achieved in all supported browsers:
1
2
3
4

// Setting the inner HTML with jQuery
var target = document.getElementById("target");
$( target ).html("<td>Hello <b>World</b>!</td>"

Convenience — There are also a lot of common DOM manipulation
use cases that are awkward to accomplish with pure DOM
methods. For instance, inserting an element stored in newElement
after the target element requires a rather verbose DOM method:
1
2

// Inserting a new element after another with the native
var target = document.getElementById("target");

3
4
5
6

var newElement = document.createElement("div");

target.parentNode.insertBefore( target.nextSibling, newE

By wrapping the target element in a jQuery object, the same task
becomes much simpler:
1
2
3
4
5
6

// Inserting a new element after another with jQuery
var target = document.getElementById("target");
var newElement = document.createElement("div");
$( target ).after( newElement );

For the most part, these details are simply "gotchas" standing
between you and your goals.

Getting Elements in to the jQuery Object
When the jQuery function is invoked with a CSS selector, it will
return a jQuery object wrapping any element(s) that match this
selector. For instance, writing:
1
2

// Selecting all 'h1' tags
var headers = $("h1");

is now a jQuery element containing all the <h1> tags
already on the page. This can be verified by inspecting the length
property of headers :
headers

1
2

// Viewing the number of 'h1' tags on the page
var allHeaders = $("h1");

3
4

alert( allHeaders.length );

If the page has more than one <h1> tag, this number will be greater
than one. If the page has no <h1> tags, the length property will be
zero. Checking the length property is a common way to ensure that
the selector successfully matched one or more elements.
If the goal is to select only the first header element, another step is
required. There are a number of ways to accomplish this, but the
most straight-forward is the eq() function.
1
2
3
4

// Selecting only the first 'h1' element on the page (in
var headers = $("h1");
var firstHeader = headers.eq( 0 );

Now firstHeader is a jQuery object containing only the first <h1>
element on the page. And because firstHeader is a jQuery object,
it has useful methods like .html() and .after() . jQuery also has a
method named .get() which provides a related function. Instead of
returning a jQuery-wrapped DOM element, it returns the DOM
element itself.
1
2

// Selecting only the first 'h1' element on the page
var firstHeaderElem = $("h1").get( 0 );

Alternatively, because the jQuery object is "array-like," it supports
array subscripting via brackets:
1
2

// Selecting only the first 'h1' element on the page (al
var firstHeaderElem = $("h1")[ 0 ];

In either case, firstHeaderElem contains the native DOM element.
This means it has DOM properties like .innerHTML and methods like
.appendChild() , but not jQuery methods like .html() or .after() .
The firstHeaderElem element is more difficult to work with, but there
are certain instances that require it. One such instance is making
comparisons.

Not All jQuery Objects are Created

===

An important detail regarding this "wrapping" behavior is that each
wrapped object is unique. This is true even if the object was created
with the same selector or contain references to the exact same
DOM elements.
1
2
3

// Creating two jQuery objects for the same element
var logo1 = $("#logo");
var logo2 = $("#logo");

Although logo1 and logo2 are created in the same way (and wrap
the same DOM element), they are not the same object. For
example:
1
2

// Comparing jQuery objects
alert( $("#logo") === $("#logo") ); // alerts 'false'

However, both objects contain the same DOM element. The get
method is useful for testing if two jQuery objects have the same
DOM element.
1
2
3
4

// Comparing DOM elements
var logo1 = $("$logo");
var logo1Elem = logo1.get( 0 );

5
6
7
8

var logo2 = $("#logo");
var logo2Elem = logo2.get( 0 );
alert( logo1Elem === logo2Elem ); // alerts 'true'

Many developers prefix a $ to the name of variables that contain
jQuery objects in order to help differentiate. There is nothing magic
about this practice — it just helps some people keep track of what
different variables contain. The previous example could be rewritten to follow this convention:
1
2
3
4
5
6
7
8

// Comparing DOM elements (with more readable variable n
var $logo1 = $("#logo");
var logo1 = $logo1.get( 0 );
var $logo2 = $("#logo");
var logo2 = $logo2.get( 0 );
alert( logo1 === logo2 ); // alerts 'true'

This code functions identically to the example above, but it is a little
more clear to read.
Regardless of the naming convention used, it is very important to
make the distinction between jQuery object and native DOM
elements. Native DOM methods and properties are not present on
the jQuery object, and vice versa. Error messages like
"event.target.closest is not a function"' and "TypeError: Object
[object Object] has no method 'setAttribute'" indicate the presence
of this common mistake.

jQuery Objects Are Not "Live"
Given a jQuery object with all the paragraph elements on the page:

1
2

// Selecting all 'p' elements on the page
var allParagraphs = $("p");

...one might expect that the contents will grow and shrink over time
as <p> elements are added and removed from the document.
jQuery objects do not behave in this manner. The set of elements
contained within a jQuery object will not change unless explicitly
modified. This means that the collection is not "live" — it does not
automatically update as the document changes. If the document
may have changed since the creation the jQuery object, the
collection should be updated by creating a new one. It can be as
easy as re-running the same selector:
1
2

// Updating the selection
allParagraphs = $("p");

Wrapping Up
Although DOM elements provide all the functionality one needs to
create interactive web pages, they can be a hassle to work with.
The jQuery object wraps these elements to smooth out this
experience and make common tasks easy. When creating or
selecting elements with jQuery, the result will always be wrapped in
a new jQuery object. If the situation calls for the native DOM
elements, they may be accessed through the .get() method and/or
array-style subscripting.

Traversing
Once you've made an initial selection with jQuery, you can traverse
deeper into what was just selected. Traversing can be broken down
into three basic parts: parents, children, and siblings. jQuery has an
abundance of easy-to-use methods for all these parts. Notice that
each of these methods can optionally be passed string selectors,
and some can also take another jQuery object in order to filter your
selection down. Pay attention and refer to the API documentation
on traversing to know what variation of arguments you have
available.

Parents
The methods for finding the parents from a selection include
$.fn.parent() , $.fn.parents() , $.fn.parentsUntil() , and
$.fn.closest() .
1
2
3
4
5
6
7
8
9

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<div class="grandparent">
<div class="parent">
<div class="child">
<span class="subchild"></span>
</div>
</div>
<div class="surrogateParent1"></div>
<div class="surrogateParent2"></div>
</div>

// Selecting an element's direct parent
// returns [ div.child ]
$("span.subchild").parent();

// Selecting all the parents of an element that match a
// returns [ div.parent ]
$("span.subchild").parents("div.parent");
// returns [ div.child, div.parent, div.grandparent ]
$("span.subchild").parents();

// Selecting all the parents of an element up to, but *
// returns [ div.child, div.parent ]
$("span.subchild").parentsUntil("div.grandparent"

19
20
21
22
23
24
25

// Selecting the closest parent, note that only one par
// and that the initial element itself is included in t

// returns [ div.child ]
$("span.subchild").closest("div");
// returns [ div.child ] as the selector is also includ
$("div.child").closest("div");

Children
The methods for finding child elements from a selection include
$.fn.children() and $.fn.find() . The difference between these
methods lies in how far into the child structure the selection is
made. $.fn.children() only operates on direct child nodes, while
$.fn.find() can traverse recursively into children, children of those
children, and so on.
1
2
3
4
5
6
7
8
9

// Selecting an element's direct children

// returns [ div.parent, div.surrogateParent1, div.surro
$("div.grandparent").children("div");

// Finding all elements within a selection that match th

// returns [ div.child, div.parent, div.surrogateParent1
$("div.grandparent").find("div");
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Siblings
The rest of the traversal methods within jQuery all deal with finding
sibling selections. There are a few basic methods as far as the
direction of traversal is concerned. You can find previous elements
with $.fn.prev() , next elements with $.fn.next() , and both with
$.fn.siblings() . There are also a few other methods that build onto
these basic methods: $.fn.nextAll() , $.fn.nextUntil() ,
$.fn.prevAll() and $.fn.prevUntil() .
1
2
3
4
5
6
7
8
9
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12
13
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23
24
25
26

// Selecting a next sibling of the selectors
// returns [ div.surrogateParent1 ]
$("div.parent").next();
// Selecting a prev sibling of the selectors
// returns [] as No sibling exists before div.parent
$("div.parent").prev();
// Selecting all the next siblings of the selector

// returns [ div.surrogateParent1, div.surrogateParent2
$("div.parent").nextAll();
// returns [ div.surrogateParent1 ]
$("div.parent").nextAll().first();
// returns [ div.surrogateParent2 ]
$("div.parent").nextAll().last();
// Selecting all the previous siblings of the selector
// returns [ div.surrogateParent1, div.parent ]
$("div.surrogateParent2").prevAll();
// returns [ div.surrogateParent1 ]
$("div.surrogateParent2").prevAll().first();
// returns [ div.parent ]

27

Use
1
2
3
4
5
6

$("div.surrogateParent2").prevAll().last();

$.fn.siblings()

to select all siblings:

// Selecting an element's siblings in both directions th
// returns [ div.surrogateParent1, div.surrogateParent2
$("div.parent").siblings();
// returns [ div.parent, div.surrogateParent2 ]
$("div.surrogateParent1").siblings();

See the complete documentation for these methods and more at
Traversal documentation on api.jquery.com.
Be cautious when traversing long distances in documents —
complex traversal makes it imperative that the document's structure
remain the same, which is difficult to guarantee even if you're the
one creating the whole application from server to client. One- or
two-step traversal is fine, but it's best to avoid traversals that go
from one container to another.

CSS, Styling, & Dimensions
jQuery includes a handy way to get and set CSS properties of
elements:
1
2
3

// Getting CSS properties
$("h1").css("fontSize"); // returns a string such as "19
$("h1").css("font-size"); // also works

1
2
3
4
5
6
7
8

// Setting CSS properties
$("h1").css( "fontSize", "100px" ); // setting an indivi
// setting multiple properties
$("h1").css({
fontSize: "100px",
color: "red"
});

Note the style of the argument on the second line — it is an object
that contains multiple properties. This is a common way to pass
multiple arguments to a function, and many jQuery setter methods
accept objects to set multiple values at once.
CSS properties that normally include a hyphen need to be
camelCased in JavaScript. For example, the CSS property fontsize is expressed as fontSize when used as a property name in
JavaScript. However, this does not apply when passing the name of
a CSS property to the $.fn.css() method as a string — in that
case, either the camelCased or hyphenated form will work.
It's not recommended to use $.fn.css() as a setter in productionready code, but when passing in an object to set CSS, CSS
properties will be camelCased instead of using a hyphen.

Using CSS Classes for Styling
As a getter, the $.fn.css() method is valuable. However, it should
generally be avoided as a setter in production-ready code, because
it's generally best to keep presentational information out of
JavaScript code. Instead, write CSS rules for classes that describe
the various visual states, and then change the class on the
element.
1
2
3
4
5
6
7
8

// Working with classes
var $h1 = $("h1");
$h1.addClass("big");
$h1.removeClass("big");
$h1.toggleClass("big");
if ( $h1.hasClass("big") ) { ... }

Classes can also be useful for storing state information about an
element, such as indicating that an element is selected.
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Dimensions
jQuery offers a variety of methods for obtaining and modifying
dimension and position information about an element.
The code below shows a brief overview of the dimensions
functionality in jQuery. For complete details about jQuery dimension
methods, visit the dimensions documentation on api.jquery.com.
1
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// Basic dimensions methods
// sets the width of all H1 elements
$("h1").width("50px");
// gets the width of the first H1
$("h1").width();

// sets the height of all H1 elements
$("h1").height("50px");
// gets the height of the first H1
$("h1").height();

// returns an object containing position
// information for the first H1 relative to
// its "offset (positioned) parent"
$("h1").position();

POWERED BY HERONOTE

Data Methods
There's often data about an element you want to store with the
element. In plain JavaScript, you might do this by adding a property
to the DOM element, but you'd have to deal with memory leaks in
some browsers. jQuery offers a straightforward way to store data
related to an element, and it manages the memory issues for you.
1
2
3
4
5

// Storing and retrieving data related to an element
$("#myDiv").data( "keyName", { foo: "bar" } );
// { foo: "bar" }
$("#myDiv").data("keyName");

Any kind of data can be stored on an element. For the purposes of
this article, $.fn.data will be used to store references to other
elements.
For example, you may want to establish a relationship between a
list item and a <div> that's inside of it. This relationship could be
established every single time the list item is touched, but a better
solution would be to establish the relationship once, then store a
pointer to the <div> on the list item using $.fn.data :
1
2
3
4
5
6
7
8
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// Storing a relationship between elements using $.fn.d
$("#myList li").each(function() {
var $li = $( this );
var $div = $li.find("div.content");
$li.data( "contentDiv", $div );
});

11
12
13
14
15

// later, we don't have to find the div again;
// we can just read it from the list item's data
var $firstLi = $("#myList li:first");
$firstLi.data("contentDiv").html("new content"

In addition to passing $.fn.data a single key-value pair to store
data, you can also pass an object containing one or more pairs.
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Utility Methods
jQuery offers several utility methods in the $ namespace. These
methods are helpful for accomplishing routine programming tasks.
For a complete reference on jQuery utility methods, visit the utilities
documentation on api.jquery.com.
Below are examples of a few of the utility methods:
$.trim

Removes leading and trailing whitespace.
1
2

// returns "lots of extra whitespace"
$.trim("
lots of extra whitespace

");

$.each

Iterates over arrays and objects.
1
2
3
4
5
6
7

$.each([ "foo", "bar", "baz" ], function( idx, val ) {
console.log( "element " + idx + "is " + val );
});
$.each({ foo: "bar", baz: "bim" }, function( k, v ) {
console.log( k + " : " + v );
});

The method
elements.

$.fn.each

is also used for iterating over a selection of

$.inArray

Returns a value's index in an array, or -1 if the value is not in the
array.

1
2
3
4
5

var myArray = [ 1, 2, 3, 5 ];
if ( $.inArray( 4, myArray ) !== -1 ) {
console.log("found it!");
}

$.extend

Changes the properties of the first object using the properties of
subsequent objects.
1
2
3
4
5
6
7

var firstObject = { foo: "bar", a: "b" };
var secondObject = { foo: "baz" };
var newObject = $.extend( firstObject, secondObject );
console.log( firstObject.foo ); // "baz"
console.log( newObject.foo );
// "baz"

If you don't want to change any of the objects you pass to
pass an empty object as the first argument.
1
2
3
4
5
6
7

$.extend ,

var firstObject = { foo: "bar", a: "b" };
var secondObject = { foo: "baz" };
var newObject = $.extend( {}, firstObject, secondObject
console.log( firstObject.foo ); // "bar"
console.log( newObject.foo ); // "baz"

$.proxy

Returns a function that will always run in the provided scope — that
is, sets the meaning of this inside the passed function to the second

argument.
1
2
3
4
5
6
7
8
9
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var myFunction = function() {
console.log( this );
};
var myObject = {
foo: "bar"
};
myFunction(); // window
var myProxyFunction = $.proxy( myFunction, myObject );
myProxyFunction(); // myObject

If you have an object with methods, you can pass the object and
the name of a method to return a function that will always run in the
scope of the object.
1
2
3
4
5
6
7
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var myObject = {
myFn : function() {
console.log( this );
}
};
$("#foo").click( myObject.myFn ); // HTMLElement #foo
$("#foo").click( $.proxy( myObject, "myFn" ) );
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Iterating over jQuery and nonjQuery Objects
jQuery provides an object iterator utility called $.each() as well as a
jQuery collection iterator: .each() . These are not interchangeable.
In addition, there are a couple of helpful methods called $.map()
and .map() that can shortcut one of our common iteration use
cases.
$.each()

is a generic iterator function for looping over object, arrays,
and array-like objects. Plain objects are iterated via their named
properties while arrays and array-like objects are iterated via their
indices.
$.each

is essentially a drop-in replacement of a traditional
'for-in' loop. Given:
$.each()

1
2
3

for

or

var sum = 0;
var arr = [ 1, 2, 3, 4, 5 ];

then this:
1
2
3
4
5

for ( var i = 0, l = arr.length; i < l; i++ ) {
sum += arr[ i ];
}
console.log( sum ); // 15

can be replaced with this:

1
2
3
4
5

$.each( arr, function( index, value ){
sum += value;
});
console.log( sum ); // 15

Notice that arr[ index ] can't be accessed as the value is
conveniently passed to the callback in $.each() . In addition, given:
1
2
3
4
5

var sum = 0;
var obj = {
foo: 1,
bar: 2
}

then this:
1
2
3
4
5

for (var item in obj) {
sum += obj[ item ];
}
console.log( sum ); // 3

can be replaced with this:
1
2
3
4
5

$.each( obj, function( key, value ) {
sum += value;
});
console.log( sum ); // 3

Again, obj[ key ] is passed directly to the callback and thus can't
be accessed. Note that $.each() is for plain objects, arrays, array-

like objects that are not jQuery collections.
This would be considered incorrect:
1
2
3
4

// incorrect
$.each( $("p"), function() {
// Do something
});

For jQuery collections, use

.each() .

.each()

is used directly on a jQuery collection. It iterates over each
matched element in the collection and performs a callback on that
object. The index of the current element within the collection is
passed as an argument to the callback. The value (the DOM
element in this case) is also passed, but the callback is fired within
the context of the current matched element so the this keyword
points to the current element as expected in other jQuery callbacks.
.each()

For example, given the following markup:
1
2
3
4
5

<ul>
<li><a href="#">Link 1</a></li>
<li><a href="#">Link 2</a></li>
<li><a href="#">Link 3</a></li>
</ul>

.each()

1
2
3
4
5

may be used like so:

$("li").each( function( index, element ){
console.log( $( this ).text() );
});
// Logs the following:

6
7
8

// Link 1
// Link 2
// Link 3

The Second Argument
The question is often raised, "If this is the element, why is there a
second DOM element argument passed to the callback?"
Whether intentional or inadvert, the execution context may change.
When consistently using the keyword this , it's easy to end up
confusing ourselves or other developers reading the code. Even if
the execution context remains the same, it may be more readable
to use the second parameter as a named parameter. For example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14

$("li").each( function( index, listItem ) {
this === listItem; // true

// For example only. You probably shouldn't call $.aj
$.ajax({
success: function( data ) {
// The context has changed. The 'this' keyword
// no longer refers to listItem.
this !== listItem; // true
}
});
});

Sometimes

.each()

Isn't Necessary

Many jQuery methods implicitly iterate over the entire collection,
applying their behavior to each matched element. For example, this
is unnecessary:

$("li").each( function( index, el ) {
$( el ).addClass("newClass");
});

1
2
3

and this is fine:
1

$("li").addClass("newClass");

Each

in the document will have the class 'newClass' added.

<li/>

On the other hand, some methods do not iterate over the collection.
.each() is required when we need to get information from the
element before setting a new value.
This will not work:
1
2
3
4

// doesn't work:
$("input").val( $( this ).val() + "%" );

// .val() does not change the execution context, so this

Rather, this is how it should be written:
1
2
3
4

$("input").each( function( i, el ) {
var elem = $( el );
elem.val( elem.val() + "%" );
});

The following is a list of methods that require
.attr()
.css()

(getter)

(getter)

.data()

(getter)

.each() :

.height()
.html()

(getter)

(getter)

.innerHeight()
.innerWidth()
.offset()

(getter)

.outerHeight()
.outerWidth()
.position()
.prop()

(getter)

.scrollLeft()
.scrollTop()
.val()

(getter)

(getter)

(getter)

.width()

(getter)

Note that in most cases, the 'getter' signature returns the result
from the first element in a jQuery collection while the setter acts
over the entire collection of matched elements. The exception to
this is .text() where the getter signature will return a concatenated
string of text from all matched elements.
In addition to a setter value, the attribute, property, css setters, and
DOM insertion 'setter' methods (i.e. .text() and .html() ) accept
anonymous callback functions that are applied to each element in
the matching set. The arguments passed to the callback are the
index of the matched element within the set and the result of the
'getter' signature of the method.
For example, these are equivalent:
1
2
3
4
5

$("input").each( function( i, el ) {
var elem = $( el );
elem.val( elem.val() + "%" );
});

6
7
8
9

$("input").val(function( index, value ) {
return value + "%";
});

One other thing to keep in mind with this implicit iteration is that
traversal methods such as .children() or .parent() will act on
each matched element in a connection, returning a combined
collection of all children or parent nodes.
.map()

There is a common iteration use case that can be better handled by
using the .map() method. Anytime we want to create an array or
concatenated string based on all matched elements in our jQuery
selector, we're better served using .map() .
For example instead of doing this:
1
2
3
4
5

var newArr = [];
$("li").each( function() {
newArr.push( this.id );
});

We can do this:
1
2
3

$("li").map( function(index, element) {
return this.id;
}).get();

Notice the .get() chained at the end. .map() actually returns a
jQuery-wrapped collection, even if we return strings out of the
callback. We need to use the argument-less version of .get() in
order to return a basic JavaScript array that we can work with. To
concatenate into a string, we can chain the plain JS .join() array

method after

.get() .

$.map

Like $.each() and .each() , there is a $.map() as well as .map() .
The difference is also very similar to both .each methods. $.map()
works on plain JavaScript arrays while .map() works on jQuery
element collections. Because it's working on a plain array, $.map()
returns a plain array and .get() does not need to be called — in
fact, it will throw an error as it's not a native JavaScript method.
A word of warning: $.map() switches the order of callback
arguments. This was done in order to match the native JavaScript
.map() method made available in ECMAScript 5.
For example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22

<li id="a"></li>
<li id="b"></li>
<li id="c"></li>
<script>
var arr = [{
id: "a",
tagName: "li"
}, {
id: "b",
tagName: "li"
}, {
id: "c",
tagName: "li"
}];

// returns [ "a", "b", "c" ]
$("li").map( function( index, element ) {
return element.id;
}).get();

23
24
25
26
27
28
29
30

// also returns ["a", "b", "c"]
// note that the value comes first with $.map
$.map( arr, function( value, index ) {
return value.id;
});
</script>

Using jQuery’s .index()
Function
is a method on jQuery objects that's generally used to
search for a given element within the jQuery object that it's called
on. This method has four different signatures with different
semantics that can be confusing. This article covers details about
how to understand the way .index() works with each signature.
.index()

.index()

1
2
3
4
5
6
7

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

with No Arguments

<ul>
<div></div>
<li id="foo1">foo</li>
<li id="bar1">bar</li>
<li id="baz1">baz</li>
<div></div>
</ul>

var $foo = $("#foo1");
console.log( "Index: " + $foo.index() ); // 1
var $listItem = $("li");
// this implicitly calls .last()
console.log( "Index: " + $listItem.index() );
console.log( "Index: " + $listItem.last().index() );
var $div = $("div");
// this implicitly calls .last()
console.log( "Index: " + $div.index() ); // 4
console.log( "Index: " + $div.last().index() );

In the first example, .index() gives the zero-based index of #foo1
within its parent. Since #foo1 is the second child of its parent,
index() returns 1.
Potential confusion comes from the other examples of .index() in
the above code. When .index() is called on a jQuery object that
contains more than one element, it does not calculate the index of

the first element as might be expected, but instead calculates the
index of the last element. This is equivalent to always calling
$jqObject.last().index(); .

.index()

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23

with a String Argument
<ul>
<div class="test"></div>
<li id="foo1">foo</li>
<li id="bar1" class="test">bar</li>
<li id="baz1">baz</li>
<div class="test"></div>
</ul>
<div id="last"></div>
var $foo = $("li");

// this implicitly calls .first()
console.log( "Index: " + $foo.index("li") ); // 0
console.log( "Index: " + $foo.first().index("li") ); //
var $baz = $("#baz1");
console.log( "Index: " + $baz.index("li")); // 2

var $listItem = $("#bar1");
console.log( "Index: " + $listItem.index(".test") ); //
var $div = $("#last");
console.log( "Index: " + $div.index("div") ); // 2

When .index() is called with a string argument, there are two
things to consider. First, jQuery will implicitly call .first() on the
original jQuery object. It will be find the index of the first element,
not the last element in this case. This is inconsistent, so be careful
here.
The second point to consider is that jQuery is querying the entire
DOM using the passed in string selector and checking the index
within that newly queried jQuery object. For example, when using

.index("div") in the last example above, jQuery is selecting all of
the <divs> in the document, then searching for the index that
contains the first element in the jQuery object .index() is called on.

.index()

1
2
3
4
5
6
7
8

1
2
3
4
5
6
7
8
9
10
11
12

with a jQuery Object Argument

<ul>
<div class="test"></div>
<li id="foo1">foo</li>
<li id="bar1" class="test">bar</li>
<li id="baz1">baz</li>
<div class="test"></div>
</ul>
<div id="last"></div>

var $foo = $("li");
var $baz = $("#baz1");
console.log( "Index: " + $foo.index( $baz ) );
var $tests = $(".test");
var $bar = $("#bar1");
// implicitly calls .first() on the argument
console.log( "Index: " + $tests.index( $bar ) );

console.log( "Index: " + $tests.index( $bar.first() ) )

In this case, the first element of the jQuery object that is passed into
.index() is being checked against all of the elements in the original
jQuery object. The original jQuery object, on the left side of
.index() , is array-like and is searched from index 0 through length
- 1 for the first element of the argument jQuery object.
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.index()

with a DOM Element Argument

In this case, the DOM element that's passed into .index() is being
checked against all of the elements in the original jQuery object.
Once all other cases are understood, this should be the simplest
case. It is very similar to the previous case, except since the DOM
element is passed directly, it is not taken from a jQuery object
container.
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Frequently Asked Questions
How do I select an item using class or ID?
How do I select elements when I already have a DOM
element?
How do I test whether an element has a particular class?
How do I test whether an element exists?
How do I determine the state of a toggled element?
How do I select an element by an ID that has characters used
in CSS notation?
How do I disable/enable a form element?
How do I check/uncheck a checkbox input or radio button?
How do I get the text value of a selected option?
How do I replace text from the 3rd element of a list of 10
items?
How do I pull a native DOM element from a jQuery object?
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How do I select an item using
class or ID?
This code selects an element with an ID of "myDivId". Since IDs are
unique, this expression always selects either zero or one elements
depending upon whether or not an element with the specified ID
exists.
1

$("#myDivId")

This code selects an element with a class of "myCssClass". Since
any number of elements can have the same class, this expression
will select any number of elements.
1

$(".myCssClass")

A jQuery object containing the selected element can be assigned to
a JavaScript variable like normal:
1

var myDivElement = $("#myDivId");

Usually, elements in a jQuery object are acted on by other jQuery
functions:
1
2
3

var myValue = $("#myDivId").val();

// get the value o

$("#myDivId").val("hello world");

// set the value o

Related Articles

Selecting Elements
Working with Selections
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How do I select elements when
I already have a DOM element?
If you have a variable containing a DOM element, and want to
select elements related to that DOM element, simply wrap it in a
jQuery object.
1
2
3

var myDomElement = document.getElementById("foo"

$( myDomElement ).find("a"); // finds all anchors inside

Many people try to concatenate a DOM element or jQuery object
with a CSS selector, like so:
1

$( myDomElement + ".bar" ); // This is equivalent to $("

Unfortunately, you cannot concatenate strings to objects.

Related Articles
The jQuery Object
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How do I test whether an
element has a particular class?
hasClass (added in version 1.2) handles this common use case:
1
2
3
4
5
6
7
8
9
10
11
12
13
14

$("div").click(function() {
if ( $( this ).hasClass("protected") ) {
$( this )
.animate({
.animate({
.animate({
.animate({
.animate({

left:
left:
left:
left:
left:

-10 })
10 })
-10 })
10 })
0 });

}
});

You can also use the is() method along with an appropriate selector
for more advanced matching:
1
2
3
4
5

if ( $("#myDiv").is(".pretty.awesome") ) {
$("#myDiv").show();
}

Note that this method allows you to test for other things as well. For
example, you can test whether an element is hidden (by using the
custom :hidden selector):

1
2
3
4
5

if ( $("#myDiv").is(":hidden") ) {
$("#myDiv").show();
}
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How do I test whether an
element exists?
Use the length property of the jQuery collection returned by your
selector:
1
2
3
4
5

if ( $("#myDiv").length ) {
$("#myDiv").show();
}

Note that it isn't always necessary to test whether an element
exists. The following code will show the element if it exists, and do
nothing (with no errors) if it does not:
1

$("#myDiv").show();
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How do I determine the state of
a toggled element?
You can determine whether an element is collapsed or not by using
the :visible and :hidden selectors.
1
2
3

var isVisible = $("#myDiv").is(":visible");
var isHidden = $("#myDiv").is(":hidden");

If you're simply acting on an element based on its visibility, just
include ":visible" or ":hidden" in the selector expression. For
example:
1
2
3

$("#myDiv:visible").animate({
left: "+=200px"
}, "slow" );
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How do I select an element by
an ID that has characters used
in CSS notation?
Because jQuery uses CSS syntax for selecting elements, some
characters are interpreted as CSS notation. For example, ID
attributes, after an initial letter (a-z or A-Z), may also use periods
and colons, in addition to letters, numbers, hyphens, and
underscores (see W3C Basic HTML Data Types). The colon (":")
and period (".") are problematic within the context of a jQuery
selector because they indicate a pseudo-class and class,
respectively.
In order to tell jQuery to treat these characters literally rather than
as CSS notation, they must be "escaped" by placing two
backslashes in front of them.
1
2
3
4
5
6
7
8
9
10
11

// Does not work
$("#some:id")
// Works!
$("#some\\:id")
// Does not work
$("#some.id")
// Works!
$("#some\\.id")

The following function takes care of escaping these characters and
places a "#" at the beginning of the ID string:
1

function jq( myid ) {

2
3
4
5

return "#" + myid.replace( /(:|\.|\[|\])/g, "\\$1"
}

The function can be used like so:
1

$( jq("some.id") )
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How do I disable/enable a form
element?
You can enable or disable a form element using the
method:
1
2
3
4
5

.prop()

// Disable #x
$("#x").prop( "disabled", true );
// Enable #x
$("#x").prop( "disabled", false );
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How do I check/uncheck a
checkbox input or radio
button?
You can check or uncheck a checkbox element or a radio button
using the .prop() method:
1
2
3
4
5

// Check #x
$("#x").prop( "checked", true );
// Uncheck #x
$("#x").prop( "checked", false );
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How do I get the text value of a
selected option?
Select elements typically have two values that you want to access.
First there's the value to be sent to the server, which is easy:
1
2

$("#myselect").val();
// => 1

The second is the text value of the select. For example, using the
following select box:
1
2
3
4
5
6
7

<select id="myselect">
<option value="1">Mr</option>
<option value="2">Mrs</option>
<option value="3">Ms</option>
<option value="4">Dr</option>
<option value="5">Prof</option>
</select>

If you wanted to get the string "Mr" if the first option was selected
(instead of just "1"), you would do that in the following way:
1
2

$("#myselect option:selected").text();
// => "Mr"
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How do I replace text from the
3rd element of a list of 10
items?
Either the :eq() selector or the .eq() method will allow you to select
the proper item. However, to replace the text, you must get the
value before you set it:
1
2
3
4
5
6
7
8
9

// This doesn't work; text() returns a string, not the j
$( this ).find("li a").eq( 2 ).text().replace(
// This works
var $thirdLink = $( this ).find("li a").eq( 2 );
var linkText = $thirdLink.text().replace( "foo"
$thirdLink.text( linkText );

The first example just discards the modified text. The second
example saves the modified text and then replaces the old text with
the new modified text. Remember, .text() gets; .text("foo") sets.
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How do I pull a native DOM
element from a jQuery object?
A jQuery object is an array-like wrapper around one or more DOM
elements. To get a reference to the actual DOM elements (instead
of the jQuery object), you have two options. The first (and fastest)
method is to use array notation:
1

$("#foo")[ 0 ]; // equivalent to document.getElementById

The second method is to use the get function:
1

$("#foo").get( 0 ); // identical to above, only slower

You can also call get without any arguments to retrieve a true array
of DOM elements.
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Events
jQuery provides simple methods for attaching event handlers to
selections. When an event occurs, the provided function is
executed. Inside the function, this refers to the element that was
clicked.
For details on jQuery events, visit the Events documentation on
api.jquery.com.
The event handling function can receive an event object. This
object can be used to determine the nature of the event, and to
prevent the event’s default behavior.
For details on the event object, visit the Event object documentation
on api.jquery.com.
Event Helpers
jQuery Event Basics
Introducing Events
Handling Events
Inside the Event Handling Function
Understanding Event Delegation
Triggering Event Handlers
History of jQuery Events
Introducing Custom Events
jQuery Event Extensions
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Event Helpers
jQuery offers two event-related helper functions that save you a few
keystrokes.
$.fn.hover

The $.fn.hover method lets you pass one or two functions to be run
when the mouseenter and mouseleave events occur on an element. If
you pass one function, it will be run for both events; if you pass two
functions, the first will run for mouseenter , and the second will run for
mouseleave .
Prior to jQuery 1.4, the
1
2
3
4
5
6

$.fn.hover

method required two functions.

// The hover helper function
$("#menu li").hover(function() {
$( this ).toggleClass("hover");
});

$.fn.toggle

The $.fn.toggle method is triggered by the "click" event and
accepts two or more functions. Each time the click event occurs,
the next function in the list is called. Generally, $.fn.toggle is used
with just two functions; however, it will accept an unlimited number
of functions. Be careful, though: providing a long list of functions
can be difficult to debug.
1
2
3
4
5
6

// The toggle helper function
$("p.expander").toggle( function() {
$( this ).prev().addClass("open");
}, function() {
$( this ).prev().removeClass("open");
});

jQuery Event Basics
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jQuery Event Basics
Setting Up Event Responses on DOM
Elements
jQuery makes it straightforward to set up event-driven responses on
page elements. These events are often triggered by the end user's
interaction with the page, such as when text is entered into a form
element or the mouse pointer is moved.
In some cases, such as the page load and unload events, the
browser itself will trigger the event.
jQuery offers convenience methods for most native browser events.
These methods — including $.fn.click , $.fn.focus , $.fn.blur ,
$.fn.change , etc. — are shorthand for jQuery's $.fn.on method.
The on method is useful for binding the same handler function to
multiple events, when you want to provide data to the event hander,
when you are working with custom events, or when you want to
pass an object of multiple events and handlers.
1
2
3
4

// Event setup using a convenience method
$('p').click(function() {
console.log('You clicked a paragraph!');
});

1
2
3
4

// Equivalent event setup using the `$.fn.on` method
$('p').on('click', function() {
console.log('click');
});

Extending Events to New Page Elements
It is important to note that $.fn.on can only create event listeners
on elements that exist at the time you set up the listeners. Similar

elements created after the event listeners are established will not
automatically pick up event behaviors
you've set up previously. For example:
1
2
3
4
5
6
7
8
9
10
11

$(document).ready(function(){
// Sets up click behavior on all button elements wit
// that exist in the DOM when the instruction was ex
$('button.alert').on('click', function(){
console.log('A button with the alert class was cl
});
// Now create a new button element with the alert cl
// was created after the click listeners were applie
// will not have the same click behavior as its peer
$('button').addClass('alert').appendTo(document.body
});

Consult the article on event delegation to see how to use $.fn.on
so that event behaviors will be extended to new elements without
having to rebind them.

Inside the Event Handler Function
Every event handling function receives an event object, which
contains many properties and methods. The event object is most
commonly used to prevent the default action of the event via the
preventDefault method. However, the event object contains a
number of other useful properties and methods, including:
pageX, pageY
The mouse position at the time the event occurred, relative to the
top left corner of the page display area (not the entire browser
window).
type
The type of the event (e.g. "click").

which
The button or key that was pressed.
data
Any data that was passed in when the event was bound. For
example:
1
2
3
4
5
6
7
8

// Event setup using the `$.fn.on` method with data
$('input').on(
'change',
{foo : 'bar'}, // associate data with event binding
function(eventObject) {
console.log('An input value has changed! ', eventObj
}
);

target
The DOM element that initiated the event.
namespace
The namespace specified when the event was triggered.
timeStamp
The difference in milliseconds between the time the event occurred
in the browser and January 1, 1970.
preventDefault()
Prevent the default action of the event (e.g. following a link).
stopPropagation()
Stop the event from bubbling up to other elements.
In addition to the event object, the event handling function also has

access to the DOM element that the handler was bound to via the
keyword this . To turn the DOM element into a jQuery object that
we can use jQuery methods on, we simply do $(this) , often
following this idiom:
1

var $this = $(this);

A fuller example would be:
1
2
3
4
5
6
7
8

// Preventing a link from being followed
$('a').click(function(eventObject) {
var $this = $(this);
if ($this.attr('href').match(/evil/)) {
eventObject.preventDefault();
$this.addClass('evil');
}
});

Setting Up Multiple Event Responses
Quite often elements in your application will be bound to multiple
events. If multiple events are to share the same handling function,
you can provide the event types as a space-separated list to
$.fn.on :
1
2
3
4
5
6
7

// Multiple events, same handler
$('input').on(
'click change', // bind listeners for multiple events
function() {
console.log('An input was clicked or changed!'
}
);

When each event has its own handler, you can pass an object into
$.fn.on with one or more key/value pairs, with the key being the
event name and the value being the function to handle the event.
1
2
3
4
5

// Binding multiple events with different handlers
$('p').on({
'click': function() { console.log('clicked!'); },
'mouseover': function() { console.log('hovered!'
});

Namespacing Events
For complex applications and for plugins you share with others, it
can be useful to namespace your events so you don't
unintentionally disconnect events that you didn't or couldn't know
about.
1
2
3
4

// Namespacing events
$('p').on('click.myNamespace', function() { /* ... */
$('p').off('click.myNamespace');
$('p').off('.myNamespace'); // unbind all events in the

Tearing Down Event Listeners
To remove an event listener, you use the $.fn.off method and
pass in the event type to off. If you attached a named function to
the event, then you can isolate the event tear down to just that
named function by passing it as the second argument.
1
2

// Tearing down all click handlers on a selection
$('p').off('click');

1
2
3
4
5
6

// Tearing down a particular click handler, using a refe
var foo = function() { console.log('foo'); };
var bar = function() { console.log('bar'); };

$('p').on('click', foo).on('click', bar);
$('p').off('click', bar); // foo is still bound to the c

Setting Up Events to Run Only Once
Sometimes you need a particular handler to run only once — after
that, you may want no handler to run, or you may want a different
handler to run. jQuery provides the $.fn.one method for this
purpose.
1
2
3
4
5
6
7
8
9

// Switching handlers using the `$.fn.one` method
$('p').one('click', firstClick);

function firstClick(){
console.log('You just clicked this for the first time
// Now set up the new handler for subsequent clicks;
// omit this step if no further click responses are n
$(this).click(function() { console.log('You have clic
}

Note that in the code snippet above, the firstClick function will be
executed for the first click on each paragraph element rather than
the function being removed from all paragraphs when any
paragraph is clicked for the first time.
$.fn.one

1
2

can also be used to bind multiple events:

// Using $.fn.one to bind several events
$('input[id]').one('focus mouseover keydown', firstEvent

3
4
5
6

function firstEvent(eventObject){
console.log('A ' + eventObject.type + ' event occurred
}

In this case, the firstEvent function will be executed once for each
event. For the snippet above, this means that once an input
element gains focus, the handler function will still execute for the
first keydown event on that element.

Introducing Events

Introduction
Web pages are all about interaction. Users perform a countless
number of actions such as moving their mice over the page, clicking
on elements, and typing in textboxes—all of these are examples of
events. In addition to these user events, there are a slew of others
that occur, like when the page is loaded, when video begins playing
or is paused, etc. Whenever something interesting occurs on the
page, an event is fired, meaning that the browser basically
announces that something has happened. It's this announcement
that allows developers to "listen" for events and react to them
appropriately.

What's a DOM event?
As mentioned, there are a myriad of event types, but perhaps the
ones that are easiest to understand are user events, like when
someone clicks on an element or types into a form. These types of
events occur on an element, meaning that when a user clicks on a
button for example, the button has had an event occur on it. While
user interactions aren't the only types of DOM events, they're
certainly the easiest to understand when starting out. MDN has a
good reference of available DOM events.

Ways to listen for events
There are many ways to listen for events. Actions are constantly
occurring on a webpage, but the developer is only notified about
them if they're listening for them. Listening for an event basically
means you're waiting for the browser to tell you that a specific event
has occurred and then you'll specify how the page should react.
To specify to the browser what to do when an event occurs, you
provide a function, also known as an event handler. This function is
executed whenever the event occurs (or until the event is
unbound).
For instance, to alert a message whenever a user clicks on a
button, you might write something like this:
1

<button onclick="alert('Hello')">Say hello</button

The event we want to listen to is specified by the button's onclick
attribute, and the event handler is the alert function which alerts
"Hello" to the user. While this works, it's an abysmal way to achieve
this functionality for a couple of reasons:
1

2

First, we're coupling our view code (HTML) with our
interaction code (JS). That means that whenever we need to
update functionality, we'd have to edit our HTML which is just
a bad practice and a maintenance nightmare.
Second, it's not scalable. If you had to attach this
functionality onto numerous buttons, you'd not only bloat the
page with a bunch of repetitious code, but you would again
destroy maintainability.

Utilizing inline event handlers like this can be considered obtrusive
JavaScript, but its opposite, unobtrusive JavaScript is a much more
common way of discussing the topic. The notion of unobtrusive
JavaScript is that your HTML and JS are kept separate and are
therefore more maintainable. Separation of concerns is important
because it keeps like pieces of code together (i.e. HTML, JS, CSS)

and unlike pieces of code apart, facilitating changes,
enhancements, etc. Furthermore, unobtrusive JavaScript stresses
the importance of adding the least amount of cruft to a page as
possible. If a user's browser doesn't support JavaScript, then it
shouldn't be intertwined into the markup of the page. Also, to
prevent naming collisions, JS code should utilize a single
namespace for different pieces of functionality or libraries. jQuery is
a good example of this, in that the jQuery object/constructor (and
also the $ alias to jQuery ) only utilizes a single global variable, and
all of jQuery's functionality is packaged into that one object.
To accomplish the desired task unobtrusively, let's change our
HTML a little bit by removing the onclick attribute and replacing it
with an id , which we'll utilize to "hook onto" the button from within a
script file.
1

<button id="helloBtn">Say hello</button>

If we wanted to be informed when a user clicks on that button
unobtrusively, we might do something like the following in a
separate script file:
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//Event binding using addEventListener
var helloBtn = document.getElementById("helloBtn"
helloBtn.addEventListener( "click", function(event) {
alert("Hello.");
}, false );

Here we're saving a reference to the button element by calling
getElementById and assigning its return value to a variable. We then
call addEventListener and provide an event handler function that will
be called whenever that event occurs. While there's nothing wrong
with this code as it will work fine in modern browsers, it won't fare

well in versions of IE prior to IE9. This is because Microsoft chose
to implement a different method, attachEvent , as opposed to the
W3C standard addEventListener , and didn't get around to changing
it until IE9 was released. For this reason, it's beneficial to utilize
jQuery because it abstracts away browser inconsistencies, allowing
developers to use a single API for these types of tasks, as seen
below.
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//Event binding using a convenience method
$("#helloBtn").click(function( event ) {
alert("Hello.");
});

The $("#helloBtn") code selects the button element using the $
(aka jQuery ) function and returns a jQuery object. The jQuery
object has a bunch of methods (functions) available to it, one of
them named click , which resides in the jQuery object's prototype.
We call the click method on the jQuery object and pass along an
anonymous function event handler that's going to be executed
when a user clicks the button, alerting "Hello." to the user.
There are a number of ways that events can be listened for using
jQuery:
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//The many ways to bind events with jQuery
// Attach an event handler directly to the button using
// shorthand `click` method.
$("#helloBtn").click(function( event ) {
alert("Hello.");
});

// Attach an event handler directly the to button using
// `bind` method, passing it an event string of `click`

12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42

$("#helloBtn").bind( "click", function( event ) {
alert("Hello.");
});

// As of jQuery 1.7, attach an event handler directly t
// using jQuery's `on` method.
$("#helloBtn").on( "click", function( event ) {
alert("Hello.");
});

// As of jQuery 1.7, attach an event handler to the `bo
// is listening for clicks, and will respond whenever *
// clicked on the page.
$("body").on({
click: function( event ) {
alert("Hello.");
}
}, "button" );

// An alternative to the previous example, using slight
$("body").on( "click", "button", function( event ) {
alert("Hello.");
});

As of jQuery 1.7, all events are bound via the on method, whether
you call it directly or whether you use an alias/shortcut method such
as bind or click , which are mapped to the on method internally.
With this in mind, it's beneficial to use the on method because the

others are all just syntactic sugar, and utilizing the
going to result in faster and more consistent code.

on

method is

Let's look at the on examples from above and discuss their
differences. In the first example, a string of click is passed as the
first argument to the on method, and an anonymous function is
passed as the second. This looks a lot like the bind method before
it. Here, we're attaching an event handler directly to #helloBtn . If
there were any other buttons on the page, they wouldn't alert
"Hello" when clicked because the event is only attached to
#helloBtn .
In the second on example, we're passing an object (denoted by the
curly braces {} ), which has a property of click whose value is an
anonymous function. The second argument to the on method is a
jQuery selector string of button . While examples 1–3 are
functionally equivalent, example 4 is different in that the body
element is listening for click events that occur on any button
element, not just #helloBtn . The final example above is exactly the
same as the one preceding it, but instead of passing an object, we
pass an event string, a selector string, and the callback. Both of
these are examples of event delegation, a process by which an
element higher in the DOM tree listens for events occurring on its
children.
Event delegation works because of the notion of event bubbling.
For most events, whenever something occurs on a page (like an
element is clicked), the event travels from the element it occurred
on, up to its parent, then up to the parent's parent, and so on, until it
reaches the root element, aka the window . So in our table example,
whenever a td is clicked, its parent tr would also be notified of the
click, the parent table would be notified, the body would be notified,
and ultimately the window would be notified as well. While event
bubbling and delegation work well, the delegating element (in our
example, the table ) should always be as close to the delegatees
as possible so the event doesn't have to travel way up the DOM
tree before its handler function is called.
The two main pros of event delegation over binding directly to an
element (or set of elements) are performance and the
aforementioned event bubbling. Imagine having a large table of
1000 cells and binding to an event for each cell. That's 1000

separate event handlers that the browser has to attach, even if
they're all mapped to the same function. Instead of binding to each
individual cell though, we could instead use delegation to listen for
events that occur on the parent table and react accordingly. One
event would be bound instead of 1000, resulting in way better
performance and memory management.
The event bubbling that occurs affords us the ability to add cells via
AJAX for example, without having to bind events directly to those
cells since the parent table is listening for clicks and is therefore
notified of clicks on its children. If we weren't using delegation, we'd
have to constantly bind events for every cell that's added which is
not only a performance issue, but could also become a
maintenance nightmare.
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The event object
In all of the previous examples, we've been using anonymous
functions and specifying an event argument within that function.
Let's change it up a little bit.
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//Binding a named function
function sayHello( event ) {
alert("Hello.");
}
$("#helloBtn").on( "click", sayHello );

In this slightly different example, we're defining a function called
sayHello and then passing that function into the on method instead
of an anonymous function. So many online examples show
anonymous functions used as event handlers, but it's important to
realize that you can also pass defined functions as event handlers
as well. This is important if different elements or different events
should perform the same functionality. This helps to keep your code
DRY.
But what about that event argument in the sayHello function—what
is it and why does it matter? In all DOM event callbacks, jQuery
passes an event object argument which contains information about
the event, such as precisely when and where it occurred, what type
of event it was, which element the event occurred on, and a
plethora of other information. Of course you don't have to call it
event ; you could call it e or whatever you want to, but event is a
pretty common convention.
If the element has default functionality for a specific event (like a
link opens a new page, a button in a form submits the form, etc),
that default functionality can be cancelled. This is often useful for
AJAX requests. When a user clicks on a button to submit a form via
AJAX, we'd want to cancel the button/form's default action (to

submit it to the form's action attribute), and we would instead do an
AJAX request to accomplish the same task for a more seamless
experience. To do this, we would utilize the event object and call its
preventDefault method. We can also prevent the event from
bubbling up the DOM tree using stopPropagation so that parent
elements aren't notified of its occurrence (in the case that event
delegation is being used).
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//Preventing a default action from occurring and stoppi
$("form").on( "submit", function( event ) {
// Prevent the form's default submission.
event.preventDefault();

// Prevent event from bubbling up DOM tree, prohibiti
event.stopPropagation();
// Make an AJAX request to submit the form data
});

When utilizing both preventDefault and stopPropagation
simultaneously, you can instead return false to achieve both in a
more concise manner, but it's advisable to only return false when
both are actually necessary and not just for the sake of terseness. A
final note on stopPropagation is that when using it in delegated
events, the soonest that event bubbling can be stopped is when the
event reaches the element that is delegating it.
It's also important to note that the event object contains a property
called originalEvent , which is the event object that the browser
itself created. jQuery wraps this native event object with some
useful methods and properties, but in some instances, you'll need
to access the original event via event.originalEvent for instance.
This is especially useful for touch events on mobile devices and
tablets.
Finally, to inspect the event itself and see all of the data it contains,

you should log the event in the browser's console using
console.log . This will allow you to see all of an event's properties
(including the originalEvent ) which can be really helpful for
debugging.
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//Logging an event's information
$("form").on( "submit", function( event ) {
// Prevent the form's default submission.
event.preventDefault();
// Log the event object for inspectin'
console.log( event );
// Make an AJAX request to submit the form data
});
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Handling Events
jQuery provides a method .on() to respond to any event on the
selected elements. This is called an event binding. Although .on()
isn't the only method provided for event binding, it is a best practice
to use this for jQuery 1.7+. To learn more, read more about the
evolution of event binding in jQuery.
The on method provides several useful features:
Bind any event triggered on the selected elements to an event
handler
Bind multiple events to one event handler
Bind multiple events and multiple handlers to the selected
elements
Use details about the event in the event handler
Pass data to the event handler for custom events
Bind events to elements that will be rendered in the future

Examples
Simple event binding
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// When any <p> tag is clicked, we expect to see '<p> wa
$("p").on( "click", function() {
console.log("<p> was clicked");
});

Many events, but only one event handler
Suppose you want to trigger the same event whenever the mouse
hovers over or leaves the selected elements. The best practice for
this is to use "mouseenter mouseleave". Note the difference

between this and the next example.
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// When a user focuses on or changes any input element,
// bind to multiple events
$("div").on( "mouseenter mouseleave", function() {
console.log("mouse hovered over or left a div"
});

Many events and handlers
Suppose that instead you want different event handlers for when
the mouse enters and leaves an element. This is more common
than the previous example. For example, if you want to show and
hide a tooltip on hover, you would use this.
.on()
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accepts an object containing multiple events and handlers.
$("div").on({
mouseenter: function() {
console.log("hovered over a div");
},
mouseleave: function() {
console.log("mouse left a div");
},
click: function() {
console.log("clicked on a div");
}
});

The event object
Handling events can be tricky. It's often helpful to use the extra
information contained in the event object passed to the event
handler for more control. To become familiar with the event object,
use this code to inspect it in your browser console after you click on

a <div> in the page. For a breakdown of the event object, see
Inside the Event Handling Function.
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$("div").on( "click", function( event ) {
console.log("event object:");
console.dir( event );
});

Passing data to the event handler
You can pass your own data to the event object.
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$("p").on( "click", {
foo: "bar"
}, function( event ) {
console.log( "event data: " + event.data.foo +
});

Binding events to elements that don't exist yet
This is called event delegation. Here's an example just for
completeness, but see the page on Event Delegation for a full
explanation.
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$("ul").on( "click", "li", function() {
console.log("Something in a <ul> was clicked, and we d
});

Connecting Events to Run Only Once
Sometimes you need a particular handler to run only once — after
that, you may want no handler to run, or you may want a different
handler to run. jQuery provides the .one() method for this purpose.
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// Switching handlers using the `.one()` method
$("p").one( "click", function() {
console.log("You just clicked this for the first time!
$( this ).click(function() {
console.log("You have clicked this before!"
});
});

The .one() method is especially useful if you need to do some
complicated setup the first time an element is clicked, but not
subsequent times.
accepts the same arguments as on() which means it
supports multiple events to one or multiple handlers, passing
custom data and event delegation.
.one()

Disconnecting Events
Although all the fun of jQuery occurs in the .on() method, it's
counterpart is just as important if you want to be a responsible
developer. .off() cleans up that event binding when you don't
need it anymore. Complex user interfaces with lots of event
bindings can bog down browser performance, so using the .off()
method diligently is a best practice to ensure that you only have the
event bindings that you need, when you need them.
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// Unbinding all click handlers on a selection
$("p").off("click");
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// Unbinding a particular click handler, using a refere
var foo = function() {
console.log("foo");
};
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var bar = function() {
console.log("bar");
};
$("p").on( "click", foo ).on( "click", bar );
// foo will stay bound to the click event
$("p").off( "click", bar );

Namespacing Events
For complex applications and for plugins you share with others, it
can be useful to namespace your events so you don't
unintentionally disconnect events that you didn't or couldn't know
about. For details, see Event Namespacing.
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Inside the Event Handling
Function
Every event handling function receives an event object, which
contains many properties and methods. The event object is most
commonly used to prevent the default action of the event via the
preventDefault method. However, the event object contains a
number of other useful properties and methods, including:
pageX, pageY
The mouse position at the time the event occurred, relative to the
top left of the page.
type
The type of the event (e.g. "click").
which
The button or key that was pressed.
data
Any data that was passed in when the event was bound.
target
The DOM element that initiated the event.
preventDefault()
Prevent the default action of the event (e.g. following a link).
stopPropagation()
Stop the event from bubbling up to other elements.
In addition to the event object, the event handling function also has
access to the DOM element that the handler was bound to via the
keyword this. To turn the DOM element into a jQuery object that we

can use jQuery methods on, we simply do $( this ), often following
this idiom:
1
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var $this = $( this );

// Preventing a link from being followed
$("a").click(function(e) {
var $this = $( this );
if ( $this.attr("href").match("evil") ) {
e.preventDefault();
$this.addClass("evil");
}
});

Understanding Event
Delegation
Say you have to add new line items to your page, given the
following HTML:
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<html>
<body>
<div id="container">
<ul id="list">
<li>
<a href="#">Item #1</a>
</li>
<li>
<a href="http://somedomain.com">Item #2
</li>
<li>
<a href="#">Item #3</a>
</li>
<li>...</li>
<li>
<a href="http://someotherdomain.com"
</li>
</ul>
</div>
</body>
</html>

We need to attach the same event handler to multiple elements. In
this example we want to attach an event that will log the text of the
anchor tag to the console whenever it is clicked.
We can attach a direct bind click event to each <li> using the
.on() method, that will alert the text inside of it by doing the

following:
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// attach a directly bound event
$("#list a").on( "click", function( event ) {
event.preventDefault();
console.log( $( this ).text() );
});

While this works perfectly fine, there are drawbacks. Consider this:
1
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// add a new element on to our existing list
$("#list").append("<li><a href=\"http://newsite.com\">It

If we were to click our newly added item, nothing would happen.
This is because of the directly bound event that we attached
previously. Direct events are only attached to elements at the time
we called the .on() method for our existing collection of <a> "s, that
is only the <a> "s that were found when we call $()

Event Propagation
Understanding how events propagate is an important factor in being
able to leverage Event Delegation. Any time an anchor tags is
clicked, a click event is fired for the:
<a>
<li>
<ul>
<div>
<body>
<html>

document root
Anytime one of these links is clicked you can think of it as if you
were clicking the entire document body. This is called event
bubbling or event propagation.
Since we know how events bubble we can created a delegated
event that listens for a specific event to happen on our element
1
2
3
4
5

// attach a delegated event
$("#list").on( "click", "a", function( event ) {
event.preventDefault();
console.log( $( this ).text() );
});

Notice for the second parameter to the .on() method we are telling
it which selector to listen for. Now when a click event is triggered on
our <ul> , our delegated event will check to see if the triggering
element matches our selector ( "a" ). If it does, our anonymous
function will execute. We have now attached a single click event
listener to our <ul> instead of an unknown number of directly bound
events on our <a> "s.

Now lets say that whenever a link is clicked we want to check and
see if the href attribute starts with "http" and if it does we want to
set the target attribute to _blank .
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// attach a delegated event
$("#list").on( "click", "a", function( event ) {
var $elem = $( this );
if( $elem.is("[href^=http]") ) {
$elem.attr( "target", "_blank" );
}
});

This simply passes the .is() method a selector to see if the
element"s href attributes starts with "http". Also we have removed
the event.preventDefault(); statement, this is because we want the
default action to happen (which is to following the href )
We can actually take this a step further and make our code simpler
and more concise by allowing the selector argument to .on() do
our logic for us.
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// attach a delegated event with a more refined selector
$("#list").on( "click", "a[href^=http]", function
$( this ).attr( "target", "_blank" );
});

POWERED BY HERONOTE

Summary
Event delegation refers to the process of using event bubbling to
handle events at a higher level in the DOM than the element on
which the event originated. It allows us to attach a single event
listener for elements that exist now or in the future.

Triggering Event Handlers
jQuery provides a way to trigger the event handlers bound to an
element without any user interaction via the .trigger() method.

What handlers can be .trigger()'d
jQuery's event handling system is a layer on top of native browser
events. When an event handler is added using
.on("click",function() {...}) , it can be triggered using jQuery's
.trigger("click") because jQuery stores a reference to that handler
when it is originally added. Additionally, it will trigger the javascript
inside the "onclick" attribute. The .trigger() function cannot be
used to mimic native browser events, such as clicking on a file input
box or an anchor tag. This is because, there is no event handler
attached using jQuery's event system that corresponds to these
events.
1

<a href="http://learn.jquery.com">Learn jQuery</

1
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//This will not change the current page
$("a").trigger("click");

How can I mimic a native browser event, if
not .trigger() ?
In order to trigger a native browser event, you have to use
document.createEventObject for < IE9 and document.createEvent
for all other browsers. Using these two APIs, you can
programmatically create an event that behaves exactly as if
someone has actually clicked on a file input box. The default action
will happen, and the browse file dialog will display.
The jQuery UI Team created jquery.simulate.js in order to simplify
triggering a native browser event for use in their automated testing.
Its usage is modeled after jQuery's trigger.
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//Triggering a native browser event using the simulate p
$("a").simulate("click");

This will not only trigger the jQuery event handlers, but also follow
the link and change the current page.

.trigger()

vs

.triggerHandler()

There are four differences between

.trigger()

and

.triggerHandler()
1

.triggerHandler()

only triggers the event on the first element

of a jQuery object.
2

3

4

cannot be chained. It returns the value
that is returned by the last handler, not a jQuery object.
.triggerHandler() will not cause the default behavior of the
event (such as a form submission).
Events triggered by .triggerHandler() , will not bubble up the
DOM hierarchy. Only the handlers on the single element will
fire.
.triggerHandler()

For more information see the triggerHandler documentation
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Don't use
functions

.trigger()

simply to execute specific

While this method has its uses, it should not be used simply to call
a function that was bound as a click handler. Instead, you should
store the function you want to call in a variable, and pass the
variable name when you do your binding. Then, you can call the
function itself whenever you want, without the need for .trigger() .
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//Triggering an event handler the right way
var foo = function( event ) {
if ( event ) {
console.log( event );
} else {
console.log("this didn't come from an event!"
}
};
$("p").on( 'click', foo );
foo(); // instead of $("p").trigger("click")

A more complex architecture can built on top of trigger using the
publish-subscribe pattern using jQuery plugins. With this technique,
$.fn.trigger can be used to notify other sections of code that an
application specific event has happened.
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History of jQuery Events
Throughout the evolution of jQuery the means of event binding has
changed for various reasons ranging from performance to
semantics. As of jQuery v1.7 the .on() method is the accepted
means of both directly binding events and creating delegated
events. This article aims to explore the history of event delegation
from jQuery v1.0 - present and how each version leverages it.
Given the following html, for our example we want to log the text of
the each <li> to console whenever it is clicked.
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<div id="container">
<ul id="list">
<li>Item #1</li>
<li>Item #2</li>
<li>Item #3</li>
<li>...</li>
<li>Item #100</li>
</ul>
</div>

.bind() (Deprecated)
Introduced in jQuery v1.0
It is possible to use
1
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.bind()

and attach a handler to every element.

$("#list li").bind( "click", function(event) {
console.log( $elem.text() );
});

As discussed in the event delegation article, this is not optimal.

liveQuery
liveQuery was a popular jQuery plugin that allowed for the creation
of events which would be triggered for elements that existed now or
in the future. This plugin did not use event delegation and used
expensive CPU processing to poll the DOM for changes every
20ms and fire events accordingly.

.bind() delegation (Deprecated)
Introduced in jQuery v1.0
Generally we don't associate .bind() with event delegation,
however prior to jQuery v1.3 it was the only means of delegation
available to us.
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$("#list").bind( "click", function(event) {
var $elem = $( event.target );
if ( $elem.is("li") ){
console.log( $elem.text() );
}
});

We are able to take advantage of event bubbling here by attaching
a click event to the parent <ul> element. Whenever the <li> is
clicked, the event bubbles up to its parent, the <ul> , which
executes our event handler. Our event handler checks to see if the
event.target (the element that caused the event to fire) matches
our selector.

.live() (Deprecated)
Introduced in jQuery v1.3
All .live() event handlers are bound to the document root by
default.
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$("#list li").live( "click", function(event) {

2
3
4

var $elem = $( this );
console.log( $elem.text() );
});

When we use .live() our event is bound to $( document ) . When
the <li> is clicked, bubbling occurs and our click event is fired for
each of the following elements:
<ul>
<div>
<body>
<html>

document root
The last element to receive the click event is document, this is
where our .live() event is bound. .live() will then check to see if
our selector #list li is the element that triggered the event, if so
our event handler is executed.

.live() w/ context (Deprecated)
Introduced in jQuery v1.4
Passing the context as a second optional argument to the $()
function has been supported since v1.0. However support for using
this context with the $.live() method was not added until v1.4.
If we were take our previous .live() example and provide it the
default context, it would look like:
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$( "#list li", document ).live( "click", function
var $elem = $( this );
console.log( $elem.text() );
});

Since we can override the context when using the .live() method,
we can specify a context that is closer to the element in the DOM
hierarchy
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$( "li", "#list" ).live( "click", function(event) {
var $elem = $( this );
console.log( $elem.text() );
});

In this instance when an <li> is clicked the event still bubbles all
the way up the document tree as it did before. However, our event
handler is now bound to the parent <ul> tag, so we do not have to
wait for the event to bubble all the way up to the document root.

.delegate() (Deprecated)
First introduced in jQuery v1.4.2
The .delegate() method provides a clear difference between the
context of where to attach delegated event handler, and the
selector to match when the event bubbles up to the delegated
element.
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$("#list").delegate( "li", "click", function(event) {
var $elem = $( this );
console.log( $elem.text() );
});

.on()
First introduced in jQuery v1.7
The on.() method gives us a semantic approach for creating
directly bound events as well as delegated events. It eliminates the
need to use the deprecated .bind() , .live() and .delegate()

methods, providing a single API for creating events.
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$("#list").on( "click", "li", function(event) {
var $elem = $( this );
console.log( $elem.text() );
});

Summary
All of these ways of event delegation were innovative and
considered a best practice at the time of their release. Depending
on what version of jQuery you have implemented use the
appropriate means of event delegation.

Introducing Custom Events

POWERED BY HERONOTE

Custom Events
We're all familiar with the basic events — click, mouseover, focus,
blur, submit, etc. — that we can latch on to as a user interacts with
the browser. Custom events open up a whole new world of eventdriven programming. In this chapter, we'll use jQuery's custom
events system to make a simple Twitter search application.
It can be difficult at first to understand why you'd want to use
custom events, when the built-in events seem to suit your needs
just fine. It turns out that custom events offer a whole new way of
thinking about event-driven JavaScript. Instead of focusing on the
element that triggers an action, custom events put the spotlight on
the element being acted upon. This brings a bevy of benefits,
including:
Behaviors of the target element can easily be triggered by
different elements using the same code.
Behaviors can be triggered across multiple, similar, target
elements at once.
Behaviors are more clearly associated with the target element
in code, making code easier to read and maintain.
Why should you care? An example is probably the best way to
explain. Suppose you have a lightbulb in a room in a house. The
lightbulb is currently turned on, and it's controlled by two three-way
switches and a clapper:
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<div class="room" id="kitchen">
<div class="lightbulb on"></div>
<div class="switch"></div>
<div class="switch"></div>
<div class="clapper"></div>
</div>

Triggering the clapper or either of the switches will change the state
of the lightbulb. The switches and the clapper don't care what state

the lightbulb is in; they just want to change the state.
Without custom events, you might write some code like this:
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$(".switch, .clapper").click(function() {
var $light = $( this ).parent().find(".lightbulb"
if ( $light.hasClass("on") ) {
$light.removeClass("on").addClass("off");
} else {
$light.removeClass("off").addClass("on");
}
});

With custom events, your code might look more like this:
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$(".lightbulb").on( "changeState", function(e) {
var $light = $( this );
if ( $light.hasClass("on") ) {
$light.removeClass("on").addClass("off");
} else {
$light.removeClass("off").addClass("on");
}
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});
$(".switch, .clapper").click(function() {
$( this ).parent().find(".lightbulb").trigger(
});

This last bit of code is not that exciting, but something important
has happened: we've moved the behavior of the lightbulb to the
lightbulb, and away from the switches and the clapper.
Let's make our example a little more interesting. We'll add another
room to our house, along with a master switch, as shown here:
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<div class="room" id="kitchen">
<div class="lightbulb on"></div>
<div class="switch"></div>
<div class="switch"></div>
<div class="clapper"></div>
</div>
<div class="room" id="bedroom">
<div class="lightbulb on"></div>
<div class="switch"></div>
<div class="switch"></div>
<div class="clapper"></div>
</div>
<div id="master_switch"></div>

If there are any lights on in the house, we want the master switch to
turn all the lights off; otherwise, we want it to turn all lights on. To
accomplish this, we'll add two more custom events to the lightbulbs:
turnOn and turnOff . We'll make use of them in the changeState
custom event, and use some logic to decide which one the master
switch should trigger:
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$(".lightbulb").on( "changeState", function(e) {
var $light = $( this );
if ($light.hasClass("on")) {
$light.trigger("turnOff");
} else {
$light.trigger("turnOn");
}
}).on( "turnOn", function(e) {
$( this ).removeClass("off").addClass("on");
}).on( "turnOff", function(e) {
$( this ).removeClass("on").addClass("off");
});
$(".switch, .clapper").click(function() {
$( this ).parent().find(".lightbulb").trigger(
});
$("#master_switch").click(function() {
if ( $(".lightbulb.on").length ) {
$(".lightbulb").trigger("turnOff");
} else {
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$(".lightbulb").trigger("turnOn");
}
});

Note how the behavior of the master switch is attached to the
master switch; the behavior of a lightbulb belongs to the lightbulbs.
If you're accustomed to object-oriented programming, you may find
it useful to think of custom events as methods of objects. Loosely
speaking, the object to which the method belongs is created via the
jQuery selector. Binding the changeState custom event to all
$(".light") elements is akin to having a class called Light with a
method of changeState , and then instantiating new Light objects for
each element with a classname of light.

Recap: $.fn.on and $.fn.trigger
In the world of custom events, there are two important jQuery
methods: $.fn.on and $.fn.trigger . In the Events chapter, we saw
how to use these methods for working with user events; for this
chapter, it's important to remember two things:
method takes an event type and an event handling
function as arguments. Optionally, it can also receive eventrelated data as its second argument, pushing the event
handling function to the third argument. Any data that is passed
will be available to the event handling function in the data
property of the event object. The event handling function
always receives the event object as its first argument.
$.fn.on

method takes an event type as its argument.
Optionally, it can also take an array of values. These values will
be passed to the event handling function as arguments after
the event object.
$.fn.trigger

Here is an example of the usage of

$.fn.on

and

$.fn.trigger

that

uses custom data in both cases:
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$( document ).on( "myCustomEvent", {
foo: "bar"
}, function( event, arg1, arg2 ) {
console.log( event.data.foo ); // "bar"
console.log( arg1 );
// "bim"
console.log( arg2 );
// "baz"
});
$( document ).trigger( "myCustomEvent", [ "bim"

A Sample Application
To demonstrate the power of custom events, we're going to create
a simple tool for searching Twitter. The tool will offer several ways
for a user to add search terms to the display: by entering a search
term in a text box, by entering multiple search terms in the URL,
and by querying Twitter for trending terms.
The results for each term will be shown in a results container; these
containers will be able to be expanded, collapsed, refreshed, and
removed, either individually or all at once.
When we're done, it will look like this:
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<h1>Twitter Search</h1>
<input type="button" id="get_trends" value="Load Trendi

<form>
<input type="text" class="input_text" id="search_term
<input type="submit" class="input_submit" value
</form>
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<div id="twitter">
<div class="template results">
<h2>Search Results for
<span class="search_term"></span></h2>
</div>
</div>

This gives us a container (#twitter) for our widget, a template for our
results containers (hidden via CSS), and a simple form where users
can input a search term. (For the sake of simplicity, we're going to
assume that our application is JavaScript-only and that our users
will always have CSS.)
There are two types of objects we'll want to act on: the results
containers, and the Twitter container.
The results containers are the heart of the application. We'll create
a plugin that will prepare each results container once it's added to
the Twitter container. Among other things, it will bind the custom
events for each container and add the action buttons at the top right
of each container. Each results container will have the following
custom events:
- Mark the container as being in the "refreshing" state,
and fire the request to fetch the data for the search term.
refresh

- Receive the returned JSON data and use it to
populate the container.
populate

- Remove the container from the page after the user
verifies the request to do so. Verification can be bypassed by
passing true as the second argument to the event handler. The
remove event also removes the term associated with the
results container from the global object containing the search
terms.
remove

- Add a class of collapsed to the container, which will
hide the results via CSS. It will also turn the container's
"Collapse" button into an "Expand" button.
collapse

- Remove the collapsed class from the container. It will
also turn the container's "Expand" button into a "Collapse"
button.
expand

The plugin is also responsible for adding the action buttons to the
container. It binds a click event to each action's list item, and uses
the list item's class to determine which custom event will be
triggered on the corresponding results container.
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$.fn.twitterResult = function( settings ) {
return this.each(function() {
var $results = $( this );
var $actions = $.fn.twitterResult.actions = $.fn.t
var $a = $actions.clone().prependTo( $results );
var term = settings.term;
$results.find("span.search_term").text( term );
$.each([ "refresh", "populate", "remove",
$results.on( ev, {
term: term
}, $.fn.twitterResult.events[ ev ] );
});

// use the class of each action to figure out
// which event it will trigger on the results pane
$a.find("li").click(function() {
// pass the li that was clicked to the function
// so it can be manipulated if needed
$results.trigger( $( this ).attr("class"
});
});
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};
$.fn.twitterResult.createActions = function() {
return $("<ul class='actions' />").append(
"<li class='refresh'>Refresh</li>" +
"<li class='remove'>Remove</li>" +
"<li class='collapse'>Collapse</li>"
);
};
$.fn.twitterResult.events = {
refresh: function( e ) {
// indicate that the results are refreshing
var $this = $( this ).addClass("refreshing"

$this.find("p.tweet").remove();
$results.append("<p class='loading'>Loading ...</p

// get the twitter data using jsonp
$.getJSON("http://search.twitter.com/search.json?q
$this.trigger( "populate", [ json ] );
});
},
populate: function( e, json ) {
var results = json.results;
var $this = $( this );
$this.find("p.loading").remove();
$.each( results, function( i, result ) {
var tweet = "<p class='tweet'>" +
"<a href='http://twitter.com/" +
result.from_user +
"'>" +
result.from_user +
"</a>: " +
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result.text +
" <span class='date'>" +
result.created_at +
"</span>" +
"</p>";
$this.append( tweet );
});
// indicate that the results
// are done refreshing
$this.removeClass("refreshing");
},
remove: function( e, force ) {
if ( !force && !confirm("Remove panel for term "
return;
}
$( this ).remove();

// indicate that we no longer have a panel for the
search_terms[ e.data.term ] = 0;
},
collapse: function( e ) {
$( this ).find("li.collapse")
.removeClass("collapse")
.addClass("expand")
.text("Expand");
$( this ).addClass("collapsed");
},
expand: function( e ) {
$( this ).find("li.expand")
.removeClass("expand")
.addClass("collapse")
.text("Collapse");
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$( this ).removeClass("collapsed");
}
};

The Twitter container itself will have just two custom events:
- Receives a search term and checks to determine
whether there's already a results container for the term; if not,
adds a results container using the results template, set up the
results container using the $.fn.twitterResult plugin
discussed above, and then triggers the refresh event on the
results container in order to actually load the results. Finally, it
will store the search term so the application knows not to refetch the term.
getResults

- Queries Twitter for the top 10 trending terms, then
iterates over them and triggers the getResults event for each
of them, thereby adding a results container for each term.
getTrends

Here's how the Twitter container bindings look:
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$("#twitter").on( "getResults", function( e, term ) {

// make sure we don"t have a box for this term alread
if ( !search_terms[ term ] ) {
var $this = $( this );
var $template = $this.find("div.template");
// make a copy of the template div
// and insert it as the first results box
$results = $template.clone()
.removeClass("template")
.insertBefore( $this.find("div:first") )
.twitterResult({
"term": term
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});

// load the content using the "refresh"
// custom event that we bound to the results contai
$results.trigger("refresh");
search_terms[ term ] = 1;
}
}).on( "getTrends", function( e ) {
var $this = $( this );

$.getJSON( "http://search.twitter.com/trends.json?cal
var trends = json.trends;
$.each( trends, function( i, trend ) {
$this.trigger( "getResults", [ trend.name ] );
});
});
});

So far, we've written a lot of code that does approximately nothing,
but that's OK. By specifying all the behaviors that we want our core
objects to have, we've created a solid framework for rapidly building
out the interface.
Let's start by hooking up our text input and the "Load Trending
Terms" button. For the text input, we'll capture the term that was
entered in the input and pass it as we trigger the Twitter container's
getResults event. Clicking the "Load Trending Terms" will trigger
the Twitter container's getTrends event:
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$("form").submit(function( event ) {
var term = $("#search_term").val();
$("#twitter").trigger( "getResults", [ term ] );
event.preventDefault();
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});
$("#get_trends").click(function() {
$("#twitter").trigger("getTrends");
});

By adding a few buttons with the appropriate IDs, we can make it
possible to remove, collapse, expand, and refresh all results
containers at once, as shown below. For the remove button, note
how we're passing a value of true to the event handler as its
second argument, telling the event handler that we don't want to
verify the removal of individual containers.
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$.each([ "refresh", "expand", "collapse" ], function
$( "#" + ev ).click( function( e ) {
$("#twitter div.results").trigger( ev );
});
});
$("#remove").click(function( e ) {
if ( confirm("Remove all results?") ) {
$("#twitter div.results").trigger( "remove"
}
});

Conclusion
Custom events offer a new way of thinking about your code: they
put the emphasis on the target of a behavior, not on the element
that triggers it. If you take the time at the outset to spell out the
pieces of your application, as well as the behaviors those pieces
need to exhibit, custom events can provide a powerful way for you
to "talk" to those pieces, either one at a time or en masse. Once the
behaviors of a piece have been described, it becomes trivial to
trigger those behaviors from anywhere, allowing for rapid creation

of and experimentation with interface options. Finally, custom
events can enhance code readability and maintainability, by making
clear the relationship between an element and its behaviors.
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jQuery Event Extensions
jQuery offers several ways to extend its event system to provide
custom functionality when events are attached to elements.
Internally in jQuery, these extensions are primarily used to ensure
that standard events such as submit and change behave
consistently across browsers. However, they can also be used to
define new events with custom behavior.
This document covers the extensions available starting with jQuery
1.7; a sparsely documented subset of this functionality has been
available since jQuery 1.3 but the differences in functionality are
extensive. For an overview of special events in earlier versions, see
Ben Alman's jQuery Special Events article.

Note: jQuery event extensions are an
advanced feature; they require deeper
knowledge of both browser behavior and
jQuery internals than most of the API. Most
users of jQuery will not need to use event
extensions, and those who do should use
them with care. For example, on a large
project with third-party plugins, changing
the behavior of standard events such as
click or mouseover can cause serious
compatibility issues.
Events overview and general advice
When writing an event extension, it is essential to understand the
flow of events through jQuery's internal event system. For a
description of the event system from the API level, including a

discussion of event delegation, see the

.on()

method.

To simplify event management, jQuery only attaches a single event
handler per element per event type (using addEventListener on
W3C-compliant browsers or attachEvent on older IE) and then
dispatches to event handlers that are attached via jQuery's APIs.
For example, if three "click" event handlers are attached to an
element, jQuery attaches its own handler when the first handler is
attached and adds the user's event handler to a list to be executed
when the event occurs. For subsequent event handlers, jQuery only
adds them to its own internal list since it has already called the
browser to attach its solitary handler. Conversely, jQuery removes
its own event handler from the browser when the final event of a
particular type is removed from the element.
An event can be a native event defined by the W3C and fired by the
browser in response to something such as a user clicking a mouse
button or pressing a key. It can also be a custom event, triggered
only by code via jQuery's .trigger() or .triggerHandler() methods.
Code can also trigger native browser events, which is convenient
for simulating user actions.
In general, jQuery does not have intrinsic knowledge of whether an
event name may be fired by a browser. So by default, jQuery
always attaches an event to the browser when an API call is made
to add an event handler for that event. If that event type is never
generated by the browser, the only way the handler will be called is
if JavaScript code triggers the event. Although there is generally no
harm in attaching an unused event name to the browser, the default
behavior can be overridden using the special event setup hook as
described below.
Whenever elements are removed from a document via jQuery, the
event system tries to ensure that events and related data are
removed from the elements to prevent memory leaks. (Older
versions of Internet Explorer are notorious for leaking memory in
these situations if not managed carefully.) If an event extension
attaches events or creates new objects, it should detach those
objects or clear the data when the event is removed by defining
remove and teardown hooks.
jQuery event extension developers should avoid using event names

that have special meaning in a DOM setting. Event names such as
"click", "change", or "load" have specific semantics defined by the
W3C, so using them as custom events can cause unexpected
behavior. Generally, jQuery event extensions should only be used
for W3C-defined event names when the extension is normalizing
behavior across browsers. A common convention to avoid collisions
for custom events is to embed a colon or dash in the event type
name, since no W3C events use those characters.
Although jQuery's event system is oriented towards delivering DOM
events to DOM elements, jQuery methods can be used to attach
and trigger events on plain objects. For example, it can be used as
a simple publish/subscribe mechanism. Developers of event
extensions should attempt to avoid unwanted behavior if their
extensions are used in a mixed scenario with DOM and plain
objects. The canonical way that jQuery detects a DOM element is
to check for elem.nodeType === 1 on the object.

jQuery.event.props: Array
jQuery defines an Event object that represents a cross-browser
subset of the information available when an event occurs. The
jQuery.event.props property is an array of string names for
properties that are always copied when jQuery processes a native
browser event. (Events fired in code by .trigger() do not use this
list, since the code can construct a jQuery.Event object with the
needed values and trigger using that object.)
To add a property name to this list, use
jQuery.event.props.push("newPropertyName") .

However, be aware
that every event processed by jQuery will now attempt to copy this
property name from the native browser event to jQuery's
constructed event. If the property does not exist for that event type,
it will get an undefined value. Adding many properties to this list can
significantly reduce event delivery performance, so for infrequentlyneeded properties it is more efficient to use the value directly from
event.originalEvent instead. If properties must be copied, you are
strongly advised to use jQuery.event.fixHooks as of version 1.7.

jQuery.event.fixHooks: Object

The fixHooks interface provides a per-event-type way to extend or
normalize the event object that jQuery creates when it processes a
native browser event. A fixHooks entry is an object that has two
properties, each being optional:
props: Array : Strings representing properties that should be copied
from the browser's event object to the jQuery event object. If
omitted, no additional properties are copied beyond the standard
ones that jQuery copies and normalizes (e.g., event.target and
event.relatedTarget ).
filter: Function( event, originalEvent ) : jQuery calls this function
after it constructs the jQuery.Event object, copies standard
properties from jQuery.event.props , and copies the fixHooks specific props (if any) specified above. The function can create new
properties on the event object or modify existing ones. The second
argument is the browser's native event object, which is also
available in event.originalEvent .
Note that for all events, the browser's native event object is
available in event.originalEvent ; if the jQuery event handler
examines the properties there instead of jQuery's normalized event
object, there is no need to create a fixHooks entry to copy or modify
the properties.
For example, to set a hook for the "drop" event that copies the
"dataTransfer" property, assign an object to
jQuery.event.fixHooks.drop :
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jQuery.event.fixHooks.drop = {
props: [ "dataTransfer" ]
};

Since fixHooks are an advanced feature and rarely used externally,
jQuery does not include code or interfaces to deal with conflict
resolution. If there is a chance that some other code may be
assigning fixHooks to the same events, the code should check for
an existing hook and take appropriate measures. A simple solution
might look like this:
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if ( jQuery.event.fixHooks.drop ) {
throw new Error("Someone else took the jQuery.event.fi
}
jQuery.event.fixHooks.drop = {
props: [ "dataTransfer" ]
};

When there are known cases of different plugins wanting to attach
to the drop hook, this solution might be more appropriate:
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var existingHook = jQuery.event.fixHooks.drop;
if ( !existingHook ) {
jQuery.event.fixHooks.drop = {
props: [ "dataTransfer" ]
};
} else {
if ( existingHook.props ) {
existingHook.props.push( "dataTransfer" );
} else {
existingHook.props = [ "dataTransfer" ];
}
}

Special event hooks
The jQuery special event hooks are a set of per-event-name
functions and properties that allow code to control the behavior of
event processing within jQuery. The mechanism is similar to
fixHooks in that the special event information is stored in
jQuery.event.special.NAME , where NAME is the name of the special
event. Event names are case sensitive.

As with fixHooks , the special event hooks design assumes it will be
very rare that two unrelated pieces of code want to process the
same event name. Special event authors who need to modify
events with existing hooks will need to take precautions to avoid
introducing unwanted side-effects by clobbering those hooks.
noBubble: Boolean
Indicates whether this event type should be bubbled when the
.trigger() method is called; by default it is false , meaning that a
triggered event will bubble to the element's parents up to the
document (if attached to a document) and then to the window. Note
that defining noBubble on an event will effectively prevent that event
from being used for delegated events with .trigger() .
bindType: String, delegateType: String
When defined, these string properties specify that a special event
should be handled like another event type until the event is
delivered. The bindType is used if the event is attached directly, and
the delegateType is used for delegated events. These types are
generally DOM event types, and should not be a special event
themselves.
The behavior of these properties is easiest to see with an example.
Assume a special event defined as follows:
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jQuery.event.special.pushy = {
bindType: "click",
delegateType: "click"
};

When these properties are defined, the following behavior occurs in
the jQuery event system:
Event handlers for the "pushy" event are actually attached to
"click" -- both directly bound and delegated events.
Special event hooks for "click" are called if they exist, except
the handle hook for "pushy" is called when an event is
delivered if one exists.

Event handlers for "pushy" must be removed using the "pushy"
event name, and are unaffected if "click" events are removed
from the same elements.
So given the special event above, this code shows that a pushy
isn't removed by removing clicks. That might be an effective way to
defend against an ill-behaved plugin that didn't namespace its
removal of click events, for example:
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var $p = $("p");
$p.on( "click", function( e ) {
$("body").append( "I am a " + e.type + "!" ));
});
$p.on( "pushy", function( e ) {
$("body").append( "I am pushy but still a " + e.type
});
$p.trigger("click"); // triggers both handlers
$p.off("click");
$p.trigger("click"); // still triggers "pushy"
$p.off("pushy");

These two properties are often used in conjunction with a handle
hook function; the hook might, for example, change the event name
from "click" to "pushy" before calling event handlers. See below for
an example.
The handleObj object
Many of the special event hook functions below are passed a
handleObj object that provides more information about the event,
how it was attached, and its current state. This object and its

contents should be treated as read-only data, and only the
properties below are documented for use by special event handlers.
For the discussion below, assume an event is attached with this
code:
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$(".dialog").on( "click.myPlugin", "button", {
mydata: 42
}, myHandler );

type: String : The type of event, such as "click" . When special
event mapping is used via bindType or delegateType , this will be the
mapped type.
origType: String : The original type name (in this case, "click" )
regardless of whether it was mapped via bindType or delegateType.
So when a "pushy" event is mapped to "click" its origType would be
"pushy". See the examples in those special event properties above
for more detail.
namespace: String : Namespace(s), if any, provided when the event
was attached, such as "myPlugin" . When multiple namespaces are
given, they are separated by periods and sorted in ascending
alphabetical order. If no namespaces are provided, this property is
an empty string.
selector: String : For delegated events, this is the selector used to
filter descendant elements and determine if the handler should be
called. In the example it is "button" . For directly bound events, this
property is null .
data: Object : The data, if any, passed to jQuery during event
binding, e.g., { myData: 42 } . If the data argument was omitted or
undefined , this property is undefined as well.
handler: function( event: jQuery.Event ) : Event handler function
passed to jQuery during event binding; in the example it is a
reference to myHandler . If false was passed during event binding,
the handler refers to a single shared function that simply returns
false .

setup: function( data: Object, namespaces, eventHandle:
function )
The setup hook is called the first time an event of a particular type
is attached to an element; this provides the hook an opportunity to
do processing that will apply to all events of this type on this
element. The this keyword will be a reference to the element
where the event is being attached and eventHandle is jQuery's
event handler function. In most cases the namespaces argument
should not be used, since it only represents the namespaces of the
first event being attached; subsequent events may not have this
same namespaces.
This hook can perform whatever processing it desires, including
attaching its own event handlers to the element or to other
elements and recording setup information on the element using the
jQuery.data() method. If the setup hook wants jQuery to add a
browser event (via addEventListener or attachEvent , depending on
browser) it should return false . In all other cases, jQuery will not
add the browser event, but will continue all its other bookkeeping
for the event. This would be appropriate, for example, if the event
was never fired by the browser but invoked by .trigger() . To
attach the jQuery event handler in the setup hook, use the
eventHandle argument.
teardown: function()
The teardown hook is called when the final event of a particular
type is removed from an element. The this keyword will be a
reference to the element where the event is being cleaned up. This
hook should return false if it wants jQuery to remove the event
from the browser's event system (via removeEventListener or
detachEvent ). In most cases, the setup and teardown hooks should
return the same value.
If the setup hook attached event handlers or added data to an
element through a mechanism such as jQuery.data() , the teardown
hook should reverse the process and remove them. jQuery will
generally remove the data and events when an element is totally
removed from the document, but failing to remove data or events
on teardown will cause a memory leak if the element stays in the
document.

add: function( handleObj )
Each time an event handler is added to an element through an API
such as .on() , jQuery calls this hook. The this keyword will be the
element to which the event handler is being added, and the
handleObj argument is as described in the section above. The
return value of this hook is ignored.
remove: function( handleObj )
When an event handler is removed from an element using an API
such as .off() , this hook is called. The this keyword will be the
element where the handler is being removed, and the handleObj
argument is as described in the section above. The return value of
this hook is ignored.
trigger: function( event: jQuery.Event, data: Object )
Called when the .trigger() or .triggerHandler() methods are used
to trigger an event for the special type from code, as opposed to
events that originate from within the browser. The this keyword will
be the element being triggered, and the event argument will be a
jQuery.Event object constructed from the caller's input. At minimum,
the event type, data, namespace, and target properties are set on
the event. The data argument represents additional data passed by
.trigger() if present.
The trigger hook is called early in the process of triggering an
event, just after the jQuery.Event object is constructed and before
any handlers have been called. It can process the triggered event in
any way, for example by calling event.stopPropagation() or
event.preventDefault() before returning. If the hook returns false ,
jQuery does not perform any further event triggering actions and
returns immediately. Otherwise, it performs the normal trigger
processing, calling any event handlers for the element and bubbling
the event (unless propagation is stopped in advance or noBubble
was specified for the special event) to call event handlers attached
to parent elements.
_default: function( event: jQuery.Event, data: Object )
When the

.trigger()

method finishes running all the event

handlers for an event, it also looks for and runs any method on the
target object by the same name unless of the handlers called
event.preventDefault() . So, .trigger("submit") will execute the
submit() method on the element if one exists. When a _default
hook is specified, the hook is called just prior to checking for and
executing the element's default method. If this hook returns the
value false the element's default method will be called; otherwise it
is not.
handle: function( event: jQuery.Event, data: Object )
jQuery calls a handle hook when the event has occurred and
jQuery would normally call the user's event handler specified by
.on() or another event binding method. If the hook exists, jQuery
calls it instead of that event handler, passing it the event and any
data passed from .trigger() if it was not a native event. The this
keyword is the DOM element being handled, and event.handleObj
property has the detailed event information.
Based in the information it has, the handle hook should decide
whether to call the original handler function which is in
event.handleObj.handler . It can modify information in the event
object before calling the original handler, but must restore that data
before returning or subsequent unrelated event handlers may act
unpredictably. In most cases, the handle hook should return the
result of the original handler, but that is at the discretion of the hook.
The handle hook is unique in that it is the only special event
function hook that is called under its original special event name
when the type is mapped using bindType and delegateType . For that
reason, it is almost always an error to have anything other than a
handle hook present if the special event defines a bindType and
delegateType , since those other hooks will never be called.
Example: Multiclick event
This multiclick special event maps itself into a standard click
event, but uses a handle hook so that it can monitor the event and
only deliver it when the user clicks on the element a multiple of the
number of times specified during event binding.
The hook stores the current click count in the data object, so
multiclick handlers on different elements don't interfere with each

other. It changes the event type to the original "multiclick" type
before calling the handler and restores it to the mapped "click" type
before returning:
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jQuery.event.special.multiclick = {
delegateType: "click",
bindType: "click",
handle: function( event ) {
var handleObj = event.handleObj;
var targetData = jQuery.data( event.target );
var ret = null;

// If a multiple of the click count, run the handle
targetData.clicks = ( targetData.clicks ||

if ( targetData.clicks % event.data === 0 ) {
event.type = handleObj.origType;
ret = handleObj.handler.apply( this, arguments );
event.type = handleObj.type;
return ret;
}
}
};
// Sample usage
$("p").on( "multiclick", {
clicks: 3
}, function( event ) {
alert("clicked 3 times");
});
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Effects
jQuery makes it trivial to add simple effects to your page. Effects
can use the built-in settings, or provide a customized duration. You
can also create custom animations of arbitrary CSS properties.
For complete details on jQuery effects, visit the Effects
documentation on api.jquery.com.
Introduction to Effects
Custom Effects with $.fn.animate
Queue & Dequeue Explained
The uses of jQuery .queue() and .dequeue()

Introduction to Effects

Showing and Hiding Content
jQuery can show or hide content instantaneously with
$.fn.hide :
1
2
3
4
5

$.fn.show

or

// Instantaneously hide all paragraphs
$("p").hide();

// Instantaneously show all divs that have the hidden st
$("div.hidden").show();

When jQuery hides an element, it sets its CSS display property to
none . This means the content will have zero width and height; it
does not mean that the content will simply become transparent and
leave an empty area on the page.
jQuery can also show or hide content by means of animation
effects. You can tell $.fn.show and $.fn.hide to use animation in a
couple of ways. One is to pass in a string-valued argument of slow ,
normal , or fast :
1
2
3
4
5

// Slowly hide all paragraphs
$("p").hide("slow");

// Quickly show all divs that have the hidden style clas
$("div.hidden").show("fast");

If you prefer more direct control over the duration of the animation
effect, you can pass the desired duration in milliseconds to
$.fn.show and $.fn.hide :
1
2

// Hide all paragraphs over half a second
$("p").hide( 500 );

3
4
5

// Show all divs that have the hidden style class over 1
$("div.hidden").show( 1250 );

Most developers pass in a number of milliseconds to have more
precise control over the duration.

Fade and Slide Animations
You may have noticed that $.fn.show and $.fn.hide use a
combination of slide and fade effects when showing and hiding
content in an animated way. If you would rather show or hide
content with one effect or the other, there are additional methods
that can help. $.fn.slideDown and $.fn.slideUp show and hide
content, respectively, using only a slide effect. Slide animations are
accomplished by rapidly making changes to an element's CSS
height property.
1
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// Hide all paragraphs using a slide up animation over 0
$("p").slideUp( 800 );

// Show all hidden divs using a slide down animation ove
$("div.hidden").slideDown( 600 );

Similarly $.fn.fadeIn and $.fn.fadeOut show and hide content,
respectively, by means of a fade animation. Fade animations
involve rapidly making changes to an element's CSS opacity
property.
1
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// Hide all paragraphs using a fade out animation over 1
$("p").fadeOut( 1500 );

// Show all hidden divs using a fade in animation over 0
$("div.hidden").fadeIn( 750 );

Changing Display Based on Current
Visibility State
jQuery can also let you change a content's visibility based on its
current visibility state. $.fn.toggle will show content that is currently
hidden and hide content that is currently visible. You can pass the
same arguments to $.fn.toggle as you pass to any of the effects
methods above.
1
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// Instantaneously toggle the display of all paragraphs
$("p").toggle();
// Slowly toggle the display of all images
$("img").toggle("slow");
// Toggle the display of all divs over 1.8 seconds
$("div").toggle( 1800 );

$.fn.toggle will use a combination of slide and fade effects, just as
$.fn.show and $.fn.hide do. You can toggle the display of content
with just a slide or a fade using $.fn.slideToggle and
$.fn.fadeToggle .

1
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// Toggle the display of all ordered lists over 1 second
$("ol").slideToggle( 1000 );

// Toggle the display of all blockquotes over 0.4 second
$("blockquote").fadeToggle( 400 );

Doing Something After an Animation
Completes
A common mistake when implementing jQuery effects is assuming
that the execution of the next method in your chain will wait until the
animation runs to completion.
1
2

// Fade in all hidden paragraphs; then add a style class
$("p.hidden").fadeIn( 750 ).addClass("lookAtMe"

It is important to realize that $.fn.fadeIn above only kicks off the
animation. Once started, the animation is implemented by rapidly
changing CSS properties in a JavaScript setInterval() loop. When
you call $.fn.fadeIn , it starts the animation loop and then returns
the jQuery object, passing it along to $.fn.addClass which will then
add the lookAtMe style class while the animation loop is just getting
started.
To defer an action until after an animation has run to completion,
you need to use an animation callback function. You can specify
your animation callback as the second argument passed to any of
the animation methods discussed above. For the code snippet
above, we can implement a callback as follows:
1
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// Fade in all hidden paragraphs; then add a style class
$("p.hidden").fadeIn( 750, function(){
// this = DOM element which has just finished being an
$( this ).addClass("lookAtMe");
});

Note that you can use the keyword this to refer to the DOM
element being animated. Also note that the callback will be called
for each element in the jQuery object. This means that if your
selector returns no elements, your animation callback will never

run! You can solve this problem by testing whether your selection
returned any elements; if not, you can just run the callback
immediately.
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// Run a callback even if there were no elements to ani
var $someElement = $("#nonexistent");
var cb = function() {
console.log("done!");
};
if ( $someElement.length ) {
$someElement.fadeIn( 300, cb );
} else {
cb();
}
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Managing Animation Effects
jQuery provides some additional features for controlling your
animations:
$.fn.stop

will immediately terminate all animations running on the
elements in your selection. You might give end-users control over
page animations by rigging a button they can click to stop the
animations.
$.fn.stop

1
2
3
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7

// Create a button to stop all animations on the page:
$("input").attr({
type: "button",
value: "Stop All Animations"
}).on( "click", function() {
$("body *").filter(":animated").stop();
}).appendTo( document.body );

$.fn.delay

is used to introduce a delay between successive
animations. For example:
$.fn.delay

1
2
3

// Hide all level 1 headings over half a second; then wa
// and reveal all level 1 headings over 0.3 seconds
$("h1").hide( 500 ).delay( 1500 ).show( 300 );

jQuery.fx

The jQuery.fx object has a number of properties that control how
effects are implemented. jQuery.fx.speeds maps the slow , normal ,
and fast duration arguments mentioned above to a specific
number of milliseconds. The default value of jQuery.fx.speeds is:

1
2
3
4
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6

{
slow: 600,
fast: 200,
// Default speed, used for "normal"
_default: 400
}

You can modify any of these settings and even introduce some of
your own:
1
2
3

jQuery.fx.speeds.fast = 300;
jQuery.fx.speeds.blazing = 100;
jQuery.fx.speeds.excruciating = 60000;

controls the number of frames per second that
are displayed in an animation. The default value is 13 milliseconds
between successive frames. You can set this a lower value for
faster browsers to make the animations run smoother. However this
will mean more frames per second and thus a higher computational
load for the browser, so you should be sure to test the performance
implications of doing so thoroughly.
jQuery.fx.interval

Finally, jQuery.fx.off can be set to true to disable all animations.
Elements will immediately be set to the target final state instead.
This can be especially useful when dealing with older browsers; you
also may want to provide the option to disable all animations to your
users.
1
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$("input").attr({
type : "button",
value : "Disable Animations"
}).on( "click", function(){
jQuery.fx.off = true;
}).appendTo( document.body );
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Custom Effects with
$.fn.animate
jQuery makes it possible to animate arbitrary CSS properties via
the $.fn.animate method. The $.fn.animate method lets you
animate to a set value, or to a value relative to the current value.
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// Custom effects with `$.fn.animate`">
$("div.funtimes").animate({
left : "+=50",
opacity : 0.25
},
// duration:
300,
// callback:
function() {
console.log("done!");
}
});

Color-related properties cannot be animated with $.fn.animate
using jQuery out of the box. Color animations can easily be
accomplished by including the color plugin. We'll discuss using
plugins later in the book.

Easing
Definition: Easing describes the manner in which an effect occurs
— whether the rate of change is steady, or varies over the duration
of the animation. jQuery includes only two methods of easing:
swing and linear. If you want more natural transitions in your
animations, various easing plugins are available.
As of jQuery 1.4, it is possible to do per-property easing when using
the $.fn.animate method.

1
2
3
4
5

// Per-property easing">
$("div.funtimes").animate({
left: [ "+=50", "swing" ],
opacity: [ 0.25, "linear" ]
}, 300 );

For more details on easing options, see Animation documentation
on api.jquery.com.
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Queue & Dequeue Explained
When you use the animate and show, hide, slideUp, etc effect
methods, you’re adding a job on to the fx queue. By default, using
queue and passing a function, will add to the fx queue. So we’re
creating our own bespoke animation step:
1
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$(".box").animate({
height : 20
}, "slow" ).queue(function() {
$("#title").html("We're in the animation, baby!"
});

As I said though, these methods come in pairs, so anything you add
using queue, you need to dequeue to allow the process to continue.
In the code above, if I chained more animations on, until I call $(
this ).dequeue() , the subsequent animations wouldn’t run:
1
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$(".box").animate({
height : 20
}, "slow" ).queue(function() {
$("#title").html("We're in the animation, baby!"
$( this ).dequeue();
}).animate({
height: 150
});

Keeping in mind that the animation won’t continue until we’ve
explicitly called dequeue, we can easily create a pausing plugin, by
adding a step in the queue that sets a timer and triggers after n
milliseconds, at which time, it dequeues the element:
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$.fn.pause = function( n ) {
return this.queue(function() {
var el = this;
setTimeout( function() {
return $( el ).dequeue();
}, n );
});
};
$(".box").animate({
height : 20
}, "slow" ).pause( 1000 ).animate({
height: 150
});

Remember that the first argument for queue and dequeue are fx ,
and that in all of these examples I’m not including it because jQuery
set the argument to fx by default - so I don’t have to specify it.

The uses of jQuery .queue()
and .dequeue()
Queues in jQuery are used for animations. You can use them for
any purpose you like. They are an array of functions stored on a per
element basis, using jQuery.data() . The are First-In-First-Out
(FIFO). You can add a function to the queue by calling .queue() ,
and you remove (by calling) the functions using .dequeue() .
To understand the internal jQuery queue functions, reading the
source and looking at examples helps me out tremendously. One of
the best examples of a queue function I’ve seen is .delay() :
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$.fn.delay = function( time, type ) {

time = jQuery.fx ? jQuery.fx.speeds[ time ] || time :
type = type || "fx";
return this.queue( type, function() {
var elem = this;
setTimeout(function() {
jQuery.dequeue( elem, type );
}, time );
});
};

The default queue – fx
The default queue in jQuery is fx. The default queue has some
special properties that are not shared with other queues.
Auto Start: When calling $(elem).queue(function() {}); the fx
queue will automatically dequeue the next function and run it if
the queue hasn’t started.
‘inprogress’ sentinel: Whenever you dequeue() a function from
the fx queue, it will unshift() (push into the first location of the
array) the string "inprogress" – which flags that the queue is
currently being run.
It’s the default! The fx queue is used by .animate() and all
functions that call it by default.
If you are using a custom queue, you must manually
functions, they will not auto start!

.dequeue()

the

Retrieving/Setting the queue
You can retrieve a reference to a jQuery queue by calling .queue()
without a function argument. You can use the method if you want to
see how many items are in the queue. You can use push, pop,
unshift, shift to manipulate the queue in place. You can replace the
entire queue by passing an array to the .queue() function.
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Quick Examples:
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// lets assume $elem is a jQuery object that points to
var queue = $elem.queue();
// remove the last function from the animation queue.
var lastFunc = queue.pop();
// insert it at the beginning:
queue.unshift( lastFunc );

// replace queue with the first three items in the queu
$elem.queue( queue.slice( 0, 3 ) );

An animation (fx) queue example:
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$(function() {
// lets do something with google maps:
var $map = $("#map_canvas");
var myLatlng = new google.maps.LatLng( -34.397
var myOptions = {
zoom: 8,
center: myLatlng,
mapTypeId: google.maps.MapTypeId.ROADMAP
};
var geocoder = new google.maps.Geocoder();
var map = new google.maps.Map( $map[0], myOptions );
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var resized = function() {

// simple animation callback - let maps know we res
google.maps.event.trigger( map, "resize" );
};
// wait 2 seconds
$map.delay( 2000 );
// resize the div:
$map.animate({
width: 250,
height: 250,
marginLeft: 250,
marginTop:250
}, resized );
// geocode something
$map.queue(function( next ) {
// find stackoverflow's whois address:
geocoder.geocode( {
address: "55 Broadway New York NY 10006"
}, handleResponse );
function handleResponse( results, status )

if ( status === google.maps.GeocoderStatus.OK ) {

var location = results[ 0 ].geometry.location
map.setZoom( 13 );
map.setCenter( location );
new google.maps.Marker({
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map: map,
position: location
});
}

// geocoder result returned, continue with animat
next();
}
});
// after we find stack overflow, wait 3 more seconds
$map.delay( 3000 );
// and resize the map again
$map.animate({
width: 500,
height: 500,
marginLeft:0,
marginTop: 0
}, resized );
});

Queueing something like Ajax Calls:
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// jQuery on an empty object, we are going to use this
var ajaxQueue = $({});
$.ajaxQueue = function( ajaxOpts ) {
// hold the original complete function
var oldComplete = ajaxOpts.complete;

9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45

// queue our ajax request
ajaxQueue.queue(function( next ) {

// create a complete callback to fire the next even
ajaxOpts.complete = function() {
// fire the original complete if it was there
if ( oldComplete ) {
oldComplete.apply( this, arguments );
}
// run the next query in the queue
next();
};
// run the query
$.ajax( ajaxOpts );
});
};
// get each item we want to copy
$("#items li").each(function( idx ) {
// queue up an ajax request
$.ajaxQueue({
url: "/ajax_html_echo/",
data: {
html : "[" + idx + "] " + $( this ).html()
},
type: "POST",
success: function( data ) {
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// Write to #output
$("#output").append( $("<li>", {
html: data
}));
}
});
});

Another custom queue example
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var theQueue = $({}); // jQuery on an empty object - a
$.each( [1,2,3], function( i, num ) {
// lets add some really simple functions to a queue:
theQueue.queue( "alerts", function(next) {

// show something, and if they hit "yes", run the n
if ( confirm("index:" + i + " = " + num +
next();
}
});
});
// create a button to run the queue:
$("<button>", {
text: "Run Queue",
click: function() {
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theQueue.dequeue("alerts");
}
}).appendTo("body");
// create a button to show the length:
$("<button>", {
text: "Show Length",
click: function() {
alert(theQueue.queue("alerts").length);
}
}).appendTo("body");
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Ajax
Traditionally webpages required reloading to update their content.
For web-based email this meant that users had to manually reload
their inbox to check and see if they had new mail. This had huge
drawbacks: it was slow and it required user input. When the user
reloaded their inbox, the server had to reconstruct the entire web
page and resend all of the HTML, CSS, JavaScript, as well as the
user's email. This was hugely inefficient. Ideally, the server should
only have to send the user's new messages, not the entire page. By
2003 all the major browsers, solved this issue by adopting the
XMLHttpRequest (XHR) object, allowing browsers to communicate
with the server without requiring a page reload.
The XMLHttpRequest object is part of a technology called Ajax
(Asynchronous JavaScript and XML). Using Ajax, data could then
be passed between the browser and the server, using the
XMLHttpRequest API, without having to reload the web page. With
the widespread adoption of the XMLHttpRequest object it quickly
became possible to build web applications like Google Maps, and
GMail that used XMLHttpRequest to get new map tiles, or new
email without having to reload the entire page.
Ajax requests are triggered by JavaScript code; your code sends a
request to a URL, and when it receives a response, a callback
function can be triggered to handle the response. Because the
request is asynchronous, the rest of your code continues to execute
while the request is being processed, so it’s imperative that a
callback be used to handle the response.
Unfortunately, different browsers implement the Ajax API differently.
Typically this meant that developers would have to account for all
the different browsers to ensure that Ajax would work universally.
Fortunately, jQuery provides Ajax support that abstracts away
painful browser differences. It offers both a full-featured $.ajax()
method, and simple convenience methods such as $.get() ,
$.getScript() , $.getJSON() , $.post() , and $().load() .
Most jQuery applications don’t in fact use XML, despite the name
“Ajax”; instead, they transport data as plain HTML or JSON

(JavaScript Object Notation).
In general, Ajax does not work across domains. For instance, a
webpage loaded from example1.com is unable to make an Ajax
request to example2.com as it would violate the same origin policy.
As a work around, JSONP (JSON with Padding) uses <script> tags
to load files containing arbitrary JavaScript content and JSON, from
another domain. More recently browsers have implemented a
technology called Cross-origin resource sharing (CORS), that
allows Ajax requests to different domains.
Key Concepts
jQuery’s Ajax-Related Methods
Ajax and Forms
Working with JSONP
Ajax Events
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Key Concepts
Proper use of Ajax-related jQuery methods requires understanding
some key concepts first.

GET vs. Post
The two most common “methods” for sending a request to a server
are GET and POST. It’s important to understand the proper
application of each.
The GET method should be used for non-destructive operations —
that is, operations where you are only “getting” data from the server,
not changing data on the server. For example, a query to a search
service might be a GET request. GET requests may be cached by
the browser, which can lead to unpredictable behavior if you are not
expecting it. GET requests generally send all of their data in a
query string.
The POST method should be used for destructive operations —
that is, operations where you are changing data on the server. For
example, a user saving a blog post should be a POST request.
POST requests are generally not cached by the browser; a query
string can be part of the URL, but the data tends to be sent
separately as post data.

Data Types
jQuery generally requires some instruction as to the type of data
you expect to get back from an Ajax request; in some cases the
data type is specified by the method name, and in other cases it is
provided as part of a configuration object. There are several
options:
text
For transporting simple strings
html

For transporting blocks of HTML to be placed on the page
script
For adding a new script to the page
json
For transporting JSON-formatted data, which can include strings,
arrays, and objects

Note
As of jQuery 1.4, if the JSON data sent by your server isn't properly
formatted, the request may fail silently. See http://json.org/ for
details on properly formatting JSON, but as a general rule, use
built-in language methods for generating JSON on the server to
avoid syntax issues.
jsonp
For transporting JSON data from another domain
xml
For transporting data in a custom XML schema
I am a strong proponent of using the JSON format in most cases,
as it provides the most flexibility. It is especially useful for sending
both HTML and data at the same time.

A is for Asynchronous
The asynchronicity of Ajax catches many new jQuery users off
guard. Because Ajax calls are asynchronous by default, the
response is not immediately available. Responses can only be
handled using a callback. So, for example, the following code will
not work:
1
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var response;
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$.get( "foo.php", function( r ) {
response = r;
});
console.log( response ); // undefined

Instead, we need to pass a callback function to our request; this
callback will run when the request succeeds, at which point we can
access the data that it returned, if any.
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$.get( "foo.php", function( response ) {
console.log( response ); // server response
});

Same-Origin Policy and JSONP
In general, Ajax requests are limited to the same protocol (http or
https), the same port, and the same domain as the page making the
request. This limitation does not apply to scripts that are loaded via
jQuery's Ajax methods.
The other exception is requests targeted at a JSONP service on
another domain. In the case of JSONP, the provider of the service
has agreed to respond to your request with a script that can be
loaded into the page using a <script> tag, thus avoiding the sameorigin limitation; that script will include the data you requested,
wrapped in a callback function you provide.

Ajax and Firebug
Firebug (or the Webkit Inspector in Chrome or Safari) is an
invaluable tool for working with Ajax requests. You can see Ajax
requests as they happen in the Console tab of Firebug (and in the
Resources > XHR panel of Webkit Inspector), and you can click on

a request to expand it and see details such as the request headers,
response headers, response content, and more. If something isn't
going as expected with an Ajax request, this is the first place to look
to track down what's wrong.
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jQuery’s Ajax-Related Methods
While jQuery does offer many Ajax-related convenience methods,
the core $.ajax method is at the heart of all of them, and
understanding it is imperative. We'll review it first, and then touch
briefly on the convenience methods.
I generally use the $.ajax method and do not use convenience
methods. As you'll see, it offers features that the convenience
methods do not, and its syntax is more easily understandable, in
my opinion.
$.ajax

jQuery’s core $.ajax method is a powerful and straightforward way
of creating Ajax requests. It takes a configuration object that
contains all the instructions jQuery requires to complete the
request. The $.ajax method is particularly valuable because it
offers the ability to specify both success and failure callbacks. Also,
its ability to take a configuration object that can be defined
separately makes it easier to write reusable code. For complete
documentation of the configuration options, visit
http://api.jquery.com/jQuery.ajax/.
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// Using the core $.ajax method
$.ajax({
// the URL for the request
url : "post.php",
// the data to send
// (will be converted to a query string)
data : {
id : 123
},
// whether this is a POST or GET request
type : "GET",
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// the type of data we expect back
dataType : "json",

// code to run if the request succeeds;
// the response is passed to the function
success : function( json ) {
$("<h1/>").text( json.title ).appendTo("body"
$("<div class=\"content\"/>").html( json.html ).app
},
// code to run if the request fails;
// the raw request and status codes are
// passed to the function
error : function( xhr, status ) {
alert("Sorry, there was a problem!");
},
// code to run regardless of success or failure
complete : function( xhr, status ) {
alert("The request is complete!");
}
});

### Note A note about the dataType setting: if the server sends
back data that is in a different format than you specify, your code
may fail, and the reason will not always be clear, because the HTTP
response code will not show an error. When working with Ajax
requests, make sure your server is sending back the data type
you're asking for, and verify that the Content-type header is
accurate for the data type. For example, for JSON data, the
Content-type header should be application/json .
$.ajax

Options

There are many, many options for the

$.ajax

method, which is part

of its power. For a complete list of options, visit
http://api.jquery.com/jQuery.ajax/; here are several that you will use
frequently:
async
Set to false if the request should be sent synchronously. Defaults
to true . Note that if you set this option to false , your request will
block execution of other code until the response is received.
cache
Whether to use a cached response if available. Defaults to true for
all dataTypes except "script" and "jsonp". When set to false, the
URL will simply have a cachebusting parameter appended to it.
complete
A callback function to run when the request is complete, regardless
of success or failure. The function receives the raw request object
and the text status of the request.
context
The scope in which the callback function(s) should run (i.e. what
this will mean inside the callback function(s)). By default, this
inside the callback function(s) refers to the object originally passed
to $.ajax .
data
The data to be sent to the server. This can either be an object or a
query string, such as foo=bar&amp;baz=bim .
dataType
The type of data you expect back from the server. By default,
jQuery will look at the MIME type of the response if no dataType is
specified.
error
A callback function to run if the request results in an error. The

function receives the raw request object and the text status of the
request.
jsonp
The callback name to send in a query string when making a JSONP
request. Defaults to "callback".
success
A callback function to run if the request succeeds. The function
receives the response data (converted to a JavaScript object if the
dataType was JSON), as well as the text status of the request and
the raw request object.
timeout
The time in milliseconds to wait before considering the request a
failure.
traditional
Set to true to use the param serialization style in use prior to jQuery
1.4. For details, see http://api.jquery.com/jQuery.param/.
type
The type of the request, "POST" or "GET". Defaults to "GET". Other
request types, such as "PUT" and "DELETE" can be used, but they
may not be supported by all browsers.
url
The URL for the request.
The url option is the only required property of the $.ajax
configuration object; all other properties are optional. This can also
be passed as the first argument to $.ajax, and the options object as
the second argument.

Convenience Methods
If you don't need the extensive configurability of

$.ajax ,

and you

don't care about handling errors, the Ajax convenience functions
provided by jQuery can be useful, terse ways to accomplish Ajax
requests. These methods are just "wrappers" around the core
$.ajax method, and simply pre-set some of the options on the
$.ajax method.
The convenience methods provided by jQuery are:
$.get
Perform a GET request to the provided URL.
$.post
Perform a POST request to the provided URL.
$.getScript
Add a script to the page.
$.getJSON
Perform a GET request, and expect JSON to be returned.
In each case, the methods take the following arguments, in order:
url
The URL for the request. Required.
data
The data to be sent to the server. Optional. This can either be an
object or a query string, such as foo=bar&amp;baz=bim .
### Note This option is not valid for
success callback

$.getScript .

A callback function to run if the request succeeds. Optional. The
function receives the response data (converted to a JavaScript
object if the data type was JSON), as well as the text status of the
request and the raw request object.
data type

The type of data you expect back from the server. Optional.
### Note This option is only applicable for methods that don't
already specify the data type in their name.
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// Using jQuery's Ajax convenience methods
// get plain text or html
$.get( "/users.php", {
userId : 1234
}, function( resp ) {
console.log( resp ); // server response
});

// add a script to the page, then run a function define
$.getScript( "/static/js/myScript.js", function
functionFromMyScript();
});
// get JSON-formatted data from the server
$.getJSON( "/details.php", function( resp ) {
// log each key in the response data
$.each( resp, function( key, value ) {
console.log( key + " : " + value );
});
});

$.fn.load

The $.fn.load method is unique among jQuery’s Ajax methods in
that it is called on a selection. The $.fn.load method fetches HTML
from a URL, and uses the returned HTML to populate the selected
element(s). In addition to providing a URL to the method, you can
optionally provide a selector; jQuery will fetch only the matching

content from the returned HTML.
1
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// Using $.fn.load to populate an element
$("#newContent").load("/foo.html");

1
2
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// Using $.fn.load to populate an element based on a sel
$("#newContent").load( "/foo.html #myDiv h1:first:", fun
alert("Content updated!"");
});

POWERED BY HERONOTE

Ajax and Forms
jQuery’s ajax capabilities can be especially useful when dealing
with forms. There are several advantages, which can range from
serialization, to simple client-side validation (e.g. "Sorry, that
username is taken"), to prefilters (explained below), and even more!

Serialization
Serializing form inputs in jQuery is extremely easy. Two methods
come supported natively - $.fn.serialize and $.fn.serializeArray .
While the names are fairly self-explanatory, there are many
advantages to using them.
The serialize method serializes a form's data into a query string.
For the element's value to be serialized, it must have a name
attribute. Please note that values from inputs with a type of
checkbox or radio are included only if they are checked.
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// Turning form data into a query string
$("#myForm").serialize();
// creates a query string like this:
// field_1=something&field2=somethingElse

While plain old serialization is great, sometimes your application
would work better if you sent over an array of objects, instead of
just the query string. For that, jQuery has the serializeArray
method. It's very similar to the serialize method listed above,
except it produces an array of objects, instead of a string.
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// Creating an array of objects containing form data
$("#myForm").serializeArray();
// creates a structure like this:
// [
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//
//
//
//
//
//
//
//
//
//
//
//
// ]

{
name : "field_1",
value : "something"
},
{
name : "field_2",
value : "somethingElse"
}

Client-side validation
Client-side validation is, much like many other things, extremely
easy using jQuery. While there are several cases developers can
test for, some of the most common ones are: presence of a
required input, valid usernames/emails/phone numbers/etc..., or
checking an "I agree..." box.
Please note that it is advisable that you also perform server-side
validation for your inputs. However, it typically makes for a better
user experience to be able to validate some things without
submitting the form.
With that being said, let's jump on in to some examples! First, we'll
see how easy it is to check if a required field doesn't have anything
in it. If it doesn't, then we'll return false , and prevent the form from
processing.
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// Using validation to check for the presence of an inp
$("#form").submit(function( event ) {
// if .required's value's length is zero
if ( $(".required").val().length === 0 ) {
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// usually show some kind of error message here
// this prevents the form from submitting
return false;
} else {
// run $.ajax here
}
});

Let's see how easy it is to check for invalid characters in a
username:
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// Validate a phone number field
$("#form").submit(function( event ) {
var inputtedPhoneNumber = $("#phone").val();
// match only numbers
var phoneNumberRegex = ^\d*$/;
// if the phone number doesn't match the regex
if ( !phoneNumberRegex.test( inputtedPhoneNumber ) )
// usually show some kind of error message here
// prevent the form from submitting
return false;
} else {
// run $.ajax here
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}
});

Prefiltering
A prefilter is a way to modify the ajax options before each request is
sent (hence, the name prefilter ).
For example, say we would like to modify all crossDomain requests
through a proxy. To do so with a prefilter is quite simple:
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// Using a proxy with a prefilter
$.ajaxPrefilter(function( options, originalOptions, jqX
if ( options.crossDomain ) {
options.url = "http://mydomain.net/proxy/"
options.crossDomain = false;
}
});

You can pass in an optional argument before the callback function
that specifies which dataTypes you'd like the prefilter to be applied
to. For example, if we want our prefilter to only apply to JSON and
script requests, we'd do:
1
2
3

// Using the optional dataTypes argument">
$.ajaxPrefilter( "json script", function( options, origi
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// do all of the prefiltering here, but only for
// requests that indicate a dataType of "JSON" or "scr
});
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Working with JSONP
The advent of JSONP — essentially a consensual cross-site
scripting hack — has opened the door to powerful mashups of
content. Many prominent sites provide JSONP services, allowing
you access to their content via a predefined API. A particularly
great source of JSONP-formatted data is the Yahoo! Query
Language, which we'll use in the following example to fetch news
about cats.
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// Using YQL and JSONP
$.ajax({
url : "http://query.yahooapis.com/v1/public/yql"
// the name of the callback parameter,
// as specified by the YQL service
jsonp : "callback",
// tell jQuery we're expecting JSONP
dataType : "jsonp",

// tell YQL what we want and that we want JSON
data : {
q : "select title,abstract,url from search.news whe
format : "json"
},
// work with the response
success : function( response ) {
console.log( response ); // server response
}
});

jQuery handles all the complex aspects of JSONP behind-thescenes — all we have to do is tell jQuery the name of the JSONP
callback parameter specified by YQL ("callback" in this case), and
otherwise the whole process looks and feels like a normal Ajax
request.
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Ajax Events
Often, you’ll want to perform an operation whenever an Ajax
requests starts or stops, such as showing or hiding a loading
indicator. Rather than defining this behavior inside every Ajax
request, you can bind Ajax events to elements just like you'd bind
other events. For a complete list of Ajax events, visit Ajax Events
documentation on docs.jquery.com .
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// Setting up a loading indicator using Ajax Events
$("#loading_indicator").ajaxStart(function() {
$( this ).show();
}).ajaxStop(function() {
$( this ).hide();
});
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Plugins
A jQuery plugin is simply a new method that we use to extend
jQuery's prototype object. By extending the prototype object you
enable all jQuery objects to inherit any methods that you add. As
established, whenever you call jQuery() you're creating a new
jQuery object, with all of jQuery's methods inherited.
The idea of a plugin is to do something with a collection of
elements. You could consider each method that comes with the
jQuery core a plugin, like fadeOut or addClass .
You can make your own plugins and use them privately in your
code or you can release them into the wild. There are thousands of
jQuery plugins available online. The barrier to creating a plugin of
your own is so low that you'll want to do it straight away!
Finding & Evaluating Plugins
How to Create a Basic Plugin
Advanced Plugin Concepts
Writing Stateful Plugins with the jQuery UI Widget Factory

Finding & Evaluating Plugins
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Finding & Evaluating Plugins
One of the most celebrated aspects of jQuery is its extensive plugin
ecosystem. From table sorting to form validation to autocompletion
... if there’s a need for it, chances are good that someone has
written a plugin for it.
The quality of jQuery plugins varies widely. Many plugins are
extensively tested and well-maintained, but others are hastily
created and then ignored. More than a few fail to follow best
practices. Some plugins, mainly jQuery UI, are maintained by the
jQuery team. The quality of these plugins is as good as jQuery
itself.
Google is your best initial resource for locating plugins, though the
jQuery team is working on an improved plugin repository. Once
you’ve identified some options via a Google search, you may want
to consult the jQuery mailing list or the #jquery IRC channel to get
input from others.
When looking for a plugin to fill a need, do your homework. Ensure
that the plugin is well-documented, and look for the author to
provide lots of examples of its use. Be wary of plugins that do far
more than you need; they can end up adding substantial overhead
to your page. For more tips on spotting a subpar plugin, read Signs
of a poorly written jQuery plugin by Remy Sharp.
Once you choose a plugin, you’ll need to add it to your page.
Download the plugin, unzip it if necessary, place it your
application’s directory structure, then include the plugin in your
page using a script tag (after you include jQuery).

How to Create a Basic Plugin
Sometimes you want to make a piece of functionality available
throughout your code; for example, perhaps you want a single
method you can call on a jQuery selection that performs a series of
operations on the selection. Maybe you wrote a really useful utility
function that you want to be able to move easily to other projects. In
this case, you may want to write a plugin.

How jQuery Works 101: jQuery Object
Methods and Utility Methods
Before we write our own plugins, we must first understand a little
about how jQuery works. Take a look at this code:
1

$("a").css( "color", "red" );

This is some pretty basic jQuery code, but do you know what's
happening behind the scenes? Whenever you use the $ function to
select elements, it returns a jQuery object. This object contains all
of the methods you've been using ( css() , click() , etc.), and all of
the elements that fit your selector. The jQuery object gets these
methods from the $.fn object. This object contains all of the jQuery
object methods, and if we want to write our own methods, it will
need to contain those as well.
Additionally the jQuery utility method $.trim() is used above to
remove any leading or trailing empty space characters from the
user input. Utility methods are functions that reside directly on $
function itself. You may occasionally want to write a utility method
plugin when your extension to the jQuery API does not have to do
something to a set of DOM elements you've retrieved.

Basic Plugin Authoring
Let's say we want to create a plugin that makes text within a set of
retrieved elements green. All we have to do is add a function called
greenify to $.fn and it will be available just like any other jQuery
object method.
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$.fn.greenify = function() {
this.css( "color", "green" );
}
$("a").greenify();

// makes all the links green

Notice that to use css() , another method, we use this , not $(
) . This is because our greenify function is a part of the same
object as css() .

this

Chaining
This works, but there's a couple of things we need to do for our
plugin to survive in the real world. One of jQuery's features is
chaining, when you link five or six actions onto one selector. This is
accomplished by having all jQuery object methods return the
original jQuery object again (there are a few exceptions: width()
called without parameters returns the width of the selected element,
and is not chainable). Making our plugin method chainable takes
one line of code:
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$.fn.greenify = function() {
this.css( "color", "green" );
return this;
}
$("a").greenify().addClass("greenified");

Note that the notion of chaining is not applicable to jQuery utility
methods like $.trim() .

Protecting the $ Alias and Adding Scope
The $ variable is very popular among JavaScript libraries, and if
you're using another library with jQuery, you will have to make
jQuery not use the $ with jQuery.noConflict() . However, this will
break our plugin since it is written with the assumption that $ is an
alias to the jQuery function. To work well with other plugins, and still
use the jQuery $ alias, we need to put all of our code inside of an
Immediately Invoked Function Expression, and then pass the
function jQuery , and name the parameter $ :
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(function ( $ ) {
$.fn.greenify = function() {
this.css( "color", "green" );
return this;
}
$.ltrim = function( str ) {
return str.replace(/^\s+/, '');
}
$.rtrim = function( str ) {
return str.replace(/\s+$/, '');
}
}( jQuery ));

In addition, the primary purpose of an Immediately Invoked
Function is to allow us to have our own private variables. Pretend
we want a different color green, and we want to store it in a
variable.
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(function ( $ ) {
var shade = "#556B2F";
$.fn.greenify = function() {
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this.css( "color", shade );
return this;
}
}( jQuery ));

Minimizing Plugin Footprint
It's good practice when writing plugins to only take up one slot
within $.fn . This reduces both the chance that your plugin will be
overridden, and the chance that your plugin will override other
plugins. In other words, this is bad:
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(function( $ ) {
$.fn.openPopup = function() {
// Open popup code
};
$.fn.closePopup = function() {
// Close popup code
};
}( jQuery ));

It would be much better to have one slot, and use parameters to
control what action that one slot performs.
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(function( $ ) {
$.fn.popup = function( action ) {
if ( action === "open") {
// Open popup code
} if ( action === "close" ) {
// Close popup code
}
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};
}( jQuery ));

Using the

each()

Method

Your typical jQuery object will contain references to any number of
DOM elements, and that's why jQuery objects are often referred to
as collections.
If you want to do any manipulating with specific elements (e.g.
getting data an attribute, calculating specific positions) then you
need to use each() to loop through the elements.
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$.fn.myNewPlugin = function() {
return this.each(function() {
// do something to each element here
});
};

Notice that we return the results of each() instead of returning this .
Since each() is already chainable, it returns this , which we then
return. This is a better way to maintain chainability than what we've
been doing so far.

Accepting Options
As your plugins get more and more complex, it's a good idea to
make your plugin customizable by accepting options. The easiest
way do this, especially if there are lots of options, is with an object
literal. Let's change our greenify plugin to accept some options.
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(function ( $ ) {
$.greenify = function( options ) {

// This is the easiest way to have default options.
var settings = $.extend({
"color": "#556B2F", // These are the defaults
"background-color": "white"
}, options );

// Greenify the collection based on the settings va
return this.css({
"color": settings.color,
"background-color": settings.background-color
});
};
}( jQuery ));

Example usage:
1
2
3

$("div").greenify({
"color": "orange"
});

The default value for color of
$.extend() to be orange.

#556B2F

gets overridden by
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Putting It Together
Here's an example of a small plugin using some of the techniques
we've discussed:
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(function( $ ){
$.fn.showLinkLocation = function() {
return this.filter("a").each(function() {
$( this ).append( " (" + $( this ).attr(
});
};
}( jQuery ));
// Usage example:
$("a").showLinkLocation();

This handy plugin goes through all anchors in the collection and
appends the href attribute in brackets.
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<!-- Before plugin is called: -->
<a href="page.html">Foo</a>
<!-- After plugin is called: -->
<a href="page.html">Foo [page.html]</a>

Our plugin can be optimized though:
1

(function( $ ){
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$.fn.showLinkLocation = function() {
return this.filter("a").append(function() {
return " (" + this.href + ")";
});
};
}( jQuery ));

We're using the append() method's capability to accept a callback,
and the return value of that callback will determine what is
appended to each element in the collection. Notice also that we're
not using the attr method to retrieve the href attribute, because the
native DOM API gives us easy access with the aptly named href
property.
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Advanced Plugin Concepts
Provide public access to default plugin
settings
An improvement we can, and should, make to the code above is to
expose the default plugin settings. This is important because it
makes it very easy for plugin users to override/customize the plugin
with minimal code. And this is where we begin to take advantage of
the function object.
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// plugin definition
$.fn.hilight = function( options ) {

// Extend our default options with those provided.
// Note that the first arg to extend is an empty obje
// this is to keep from overriding our "defaults" obj
var opts = $.extend({}, $.fn.hilight.defaults, option
// Our plugin implementation code goes here.
};
// plugin defaults - added as a property on our plugin
$.fn.hilight.defaults = {
foreground: "red",
background: "yellow"
};

Now users can include a line like this in their scripts:
1
2

// this need only be called once and does not
// have to be called from within a 'ready' block

3

$.fn.hilight.defaults.foreground = "blue";

And now we can call the plugin method like this and it will use a
blue foreground color:
1

$("#myDiv").hilight();

As you can see, we"ve allowed the user to write a single line of
code to alter the default foreground color of the plugin. And users
can still selectively override this new default value when they want:
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// override plugin default foreground color
$.fn.hilight.defaults.foreground = "blue";
// ...
// invoke plugin using new defaults
$(".hilightDiv").hilight();
// ...

// override default by passing options to plugin method
$("#green").hilight({
foreground: "green"
});

Provide public access to secondary
functions as applicable
This item goes hand-in-hand with the previous item and is an
interesting way to extend your plugin (and to let others extend your
plugin). For example, the implementation of our plugin may define a
function called "format" which formats the hilight text. Our plugin

may now look like this, with the default implementation of the format
method defined below the hilight function.
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// plugin definition
$.fn.hilight = function( options ) {
// iterate and reformat each matched element
return this.each(function() {
var $this = $( this );
// ...
var markup = $this.html();
// call our format function
markup = $.fn.hilight.format( markup );
$this.html( markup );
});
};
// define our format function
$.fn.hilight.format = function( txt ) {"
return "<strong>" + txt + "</strong>";
};

We could have just as easily supported another property on the
options object that allowed a callback function to be provided to
override the default formatting. That's another excellent way to
support customization of your plugin. The technique shown here
takes this a step further by actually exposing the format function so
that it can be redefined. With this technique it would be possible for

others to ship their own custom overrides of your plugin ?in other
words, it means others can write plugins for your plugin.
Considering the trivial example plugin we're building in this article,
you may be wondering when this would ever be useful. One realworld example is the Cycle Plugin. The Cycle Plugin is a slideshow
plugin which supports a number of built-in transition effects ?scroll,
slide, fade, etc. But realistically, there is no way to define every
single type of effect that one might wish to apply to a slide
transition. And that's where this type of extensibility is useful. The
Cycle Plugin exposes a "transitions" object to which users can add
their own custom transition definitions. It's defined in the plugin like
this:
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$.fn.cycle.transitions = {
// ...
};

This technique makes it possible for others to define and ship
transition definitions that plug-in to the Cycle Plugin.

Keep private functions private
The technique of exposing part of your plugin to be overridden can
be very powerful. But you need to think carefully about what parts
of your implementation to expose. Once it's exposed, you need to
keep in mind that any changes to the calling arguments or
semantics may break backward compatibility. As a general rule, if
you're not sure whether to expose a particular function, then you
probably shouldn't.
So how then do we define more functions without cluttering the
namespace and without exposing the implementation? This is a job
for closures. To demonstrate, we'll add another function to our
plugin called "debug". The debug function will log the number of
selected elements to the Firebug console. To create a closure, we
wrap the entire plugin definition in a function (as detailed in the

jQuery Authoring Guidelines).
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

// create closure
(function( $ ) {
// plugin definition
$.fn.hilight = function( options ) {
debug( this );
// ...
};
// private function for debugging
function debug( $obj ) {
if ( window.console && window.console.log ) {
window.console.log( "hilight selection count: "
}
};
// ...
// end of closure
})( jQuery );

Our "debug" method cannot be accessed from outside of the
closure and thus is private to our implementation.

Support the Metadata Plugin
Depending on the type of plugin you're writing, adding support for
the Metadata Plugin can make it even more powerful. Personally, I
love the Metadata Plugin because it lets you use unobtrusive
markup to override plugin options (which is particularly useful when
creating demos and examples). And supporting it is very simple!
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// plugin definition

2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

$.fn.hilight = function( options ) {

// build main options before element iteration
var opts = $.extend( {}, $.fn.hilight.defaults, optio
return this.each(function() {
var $this = $( this );

// build element specific options
// This changed line tests to see if the Metadata P
// and if it is, it extends our options object with
var o = $.meta ? $.extend( {}, opts, $this
//...
});
};

This line is added as the last argument to jQuery.extend so it will
override any other option settings. Now we can drive behavior from
the markup if we choose:
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<!-- markup -->
<div class="hilight { background: 'red', foreground: 'w
Have a nice day!
</div>
<div class="hilight { foreground: 'orange' }">
Have a nice day!
</div>
<div class="hilight { background: 'green' }">
Have a nice day!
</div>

And now we can hilight each of these divs uniquely using a single
line of script:

1

$(".hilight").hilight();

Bob and Sue
Let's say Bob has created a wicked new gallery plugin (called
"superGallery") which takes a list of images and makes them
navigable. Bob's thrown in some animation to make it more
interesting. He's tried to make the plugin as customizable as
possible, and has ended up with something like this:
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jQuery.fn.superGallery = function( options ) {
// Bob"s default settings:
var defaults = {
textColor : "#000",
backgroundColor : "#FFF",
fontSize : "1em",
delay : "quite long",
getTextFromTitle : true,
getTextFromRel : false,
getTextFromAlt : false,
animateWidth : true,
animateOpacity : true,
animateHeight : true,
animationDuration : 500,
clickImgToGoToNext : true,
clickImgToGoToLast : false,
nextButtonText : "next",
previousButtonText : "previous",
nextButtonTextColor : "red",
previousButtonTextColor : "red"
};
var settings = $.extend( {}, defaults, options );
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return this.each(function() {
// Plugin code would go here...
});
};

The first thing that probably comes to your mind (ok, maybe not the
first) is the prospect of how huge this plugin must be to
accommodate such a level of customization. The plugin, if it weren't
fictional, would probably be a lot larger than necessary. There are
only so many kilobytes people will be willing to spend!
Now, our friend Bob thinks this is all fine; in fact, he's quite
impressed with the plugin and its level of customization. He
believes that all the options make for a more versatile solution, one
which can be used in many different situations.
Sue, another friend of ours, has decided to use this new plugin. She
has set up all of the options required and now has a working
solution sitting in front of her. It's only five minutes later, after
playing with the plugin, that she realizes the gallery would look
much nicer if each image's width were animated at a slower speed.
She hastily searches through Bob's documentation but finds no
animateWidthDuration option!

Do you see the problem?
It's not really about how many options your plugin has; but what
options it has!
Bob has gone a little over the top. The level of customization he's
offering, while it may seem high, is actually quite low, especially
considering all the possible things one might want to control when
using this plugin. Bob has made the mistake of offering a lot of
ridiculously specific options, rendering his plugin much more difficult
to customize!

A better model
So it's pretty obvious: Bob needs a new customization model, one

which does not relinquish control or abstract away the necessary
details.
The reason Bob is so drawn to this high-level simplicity is that the
jQuery framework very much lends itself to this mindset. Offering a
previousButtonTextColor option is nice and simple, but let's face it,
the vast majority of plugin users are going to want way more
control!
Here are a few tips which should help you create a better set of
customizable options for your plugins:

Don't create plugin-specific syntax
Developers who use your plugin shouldn't have to learn a new
language or terminology just to get the job done.
Bob thought he was offering maximum customization with his delay
option (look above). He made it so that with his plugin you can
specify four different delays, "quite short," "very short," "quite long,"
or "very long":
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var delayDuration = 0;
switch ( settings.delay ) {
case "very short":
delayDuration = 100;
break;
case "quite short":
delayDuration = 200;
break;
case "quite long":
delayDuration = 300;
break;
case "very long":
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delayDuration = 400;
break;
default:
delayDuration = 200
}

Not only does this limit the level of control people have, but it takes
up quite a bit of space. Twelve lines of code just to define the
delaying time is a bit much, don't you think? A better way to
construct this option would be to let plugin users specify the amount
of time (in milliseconds) as a number, so that no processing of the
option needs to take place.
The key here is not to diminish the level of control through your
abstraction. Your abstraction, whatever it is, can be as simplistic as
you want, but make sure that people who use your plugin will still
have that much-sought-after low-level control! (By low-level I mean
non-abstracted)

Give full control of elements
If your plugin creates elements to be used within the DOM, then it's
a good idea to offer plugin users some way to access those
elements. Sometimes this means giving certain elements IDs or
classes. But note that your plugin shouldn't rely on these hooks
internally:
A bad implementation:
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// Plugin code
$("<div id="the_gallery_Wrapper" />").appendTo(
$("#the_gallery_wrapper").append("...");
// Retain an internal reference:
var $wrapper = $("<div />")
.attr( settings.wrapperAttrs )
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.appendTo( settings.container );
$wrapper.append("..."); // Easy to reference later...

Notice that we've created a reference to the injected wrapper and
we're also calling the 'attr' method to add any specified attributes to
the element. So, in our settings it might be handled like this:
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var defaults = {
wrapperAttrs : {
id: "gallery-wrapper"
},
// ... rest of settings ...
};

// We can use the extend method to merge options/settin
// But with the added first parameter of TRUE to signif
var settings = $.extend( true, {}, defaults, options );

The $.extend() method will now recurse through all nested objects
to give us a merged version of both the defaults and the passed
options, giving the passed options precedence.
The plugin user now has the power to specify any attribute of that
wrapper element so if they require that there be a hook for any CSS
styles then they can quite easily add a class or change the name of
the ID without having to go digging around in plugin source.
The same model can be used to let the user define CSS styles:
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var defaults = {
wrapperCSS : {},
// ... rest of settings ...
};
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// Later on in the plugin where we define the wrapper:
var $wrapper = $("<div />")
.attr( settings.wrapperAttrs )
.css( settings.wrapperCSS ) // ** Set CSS!
.appendTo( settings.container );

Your plugin may have an associated StyleSheet where developers
can add CSS styles. Even in this situation it's a good idea to offer
some convenient way of setting styles in JavaScript, without having
to use a selector to get at the elements.

Provide callback capabilities
What is a callback? - A callback is essentially a function to be called
later, normally triggered by an event. It's passed as an argument,
usually to the initiating call of a component. (in this case, a jQuery
plugin).
If your plugin is driven by events then it might be a good idea to
provide a callback capability for each event. Plus, you can create
your own custom events and then provide callbacks for those. In
this gallery plugin it might make sense to add an 'onImageShow'
callback.
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var defaults = {
// we define an empty anonymous function
// so that we don't need to check its
// existence before calling it.
onImageShow : function() {},
// ... rest of settings ...
};
// Later on in the plugin:
$nextButton.bind( "click", showNextImage );
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function showNextImage() {
// stuff to show the image here...
// Here's the callback:
settings.onImageShow.call( this );
}

Instead of initiating the callback via traditional means (adding
parenthesis) we're calling it in the context of 'this' which will be a
reference to the image node. This means that you have access to
the actual image node through the 'this' keyword within the
callback:
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$("ul.imgs li").superGallery({
onImageShow : function() {
$( this ).after( "<span>" + $( this ).attr(
},
// ... other options ...
});

Similarly you could add an "onImageHide" callback and numerous
other ones...
The point with callbacks is to give plugin users an easy way to add
additional functionality without digging around in the source.

Remember, it's a compromise
Your plugin is not going to be able to work in every situation. And
equally, it's not going to be very useful if you offer no or very few
methods of control. So, remember, it's always going to be a
compromise. Three things you must always take into account are:

Flexibility: How many situations will your plugin be able to deal
with?
Size: Does the size of your plugin correspond to its level of
functionality? I.e. Would you use a very basic tooltip plugin if it
was 20k in size? - Probably not!
Performance: Does your plugin heavily process the options in
any way? Does this effect speed? Is the overhead caused
worth it for the end user?

Writing Stateful Plugins with
the jQuery UI Widget Factory
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Writing Stateful Plugins with the jQuery UI
Widget Factory
While most existing jQuery plugins are stateless — that is, we call
them on an element and that is the extent of our interaction with the
plugin — there’s a large set of functionality that doesn’t fit into the
basic plugin pattern.
In order to fill this gap, jQuery UI has implemented a more
advanced plugin system. The new system manages state, allows
multiple functions to be exposed via a single plugin, and provides
various extension points. This system is called the widget factory
and is exposed as jQuery.widget as part of jQuery UI 1.8; however,
it can be used independently of jQuery UI.
To demonstrate the capabilities of the widget factory, we'll build a
simple progress bar plugin.
To start, we’ll create a progress bar that just lets us set the progress
once. As we can see below, this is done by calling jQuery.widget
with two parameters: the name of the plugin to create and an object
literal containing functions to support our plugin. When our plugin
gets called, it will create a new plugin instance and all functions will
be executed within the context of that instance. This is different
from a standard jQuery plugin in two important ways. First, the
context is an object, not a DOM element. Second, the context is
always a single object, never a collection.
A simple, stateful plugin using the jQuery UI widget factory
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$.widget( "nmk.progressbar", {
_create: function() {
var progress = this.options.value + "%";

this.element.addClass("progressbar").text( progress
}
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});

The name of the plugin must contain a namespace; in this case
we’ve used the nmk namespace. There is a limitation that
namespaces be exactly one level deep — that is, we can't use a
namespace like nmk.foo . We can also see that the widget factory
has provided two properties for us. this.element is a jQuery object
containing exactly one element. If our plugin is called on a jQuery
object containing multiple elements, a separate plugin instance will
be created for each element, and each instance will have its own
this.element . The second property, this.options , is a hash
containing key/value pairs for all of our plugin’s options. These
options can be passed to our plugin as shown here.
### Note In our example we use the nmk namespace. The ui
namespace is reserved for official jQuery UI plugins. When building
your own plugins, you should create your own namespace. This
makes it clear where the plugin came from and whether it is part of
a larger collection.
Passing options to a widget
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$("<div></div>").appendTo( "body" ).progressbar({ va

When we call jQuery.widget it extends jQuery by adding a method
to jQuery.fn (the same way we'd create a standard plugin). The
name of the function it adds is based on the name you pass to
jQuery.widget , without the namespace; in our case it will create
jQuery.fn.progressbar . The options passed to our plugin get set in
this.options inside of our plugin instance. As shown below, we can
specify default values for any of our options. When designing your
API, you should figure out the most common use case for your
plugin so that you can set appropriate default values and make all
options truly optional.
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Setting default options for a widget
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$.widget( "nmk.progressbar", {
// default options
options: {
value: 0
},
_create: function() {
var progress = this.options.value + "%";

this.element.addClass( "progressbar" ).text( progre
}
});

Adding Methods to a Widget
Now that we can initialize our progress bar, we’ll add the ability to
perform actions by calling methods on our plugin instance. To
define a plugin method, we just include the function in the object
literal that we pass to jQuery.widget . We can also define “private”
methods by prepending an underscore to the function name.
Creating widget methods
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$.widget( "nmk.progressbar", {
options: {
value: 0
},
_create: function() {
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var progress = this.options.value + "%";

this.element.addClass("progressbar").text( progress
},
// create a public method
value: function( value ) {
// no value passed, act as a getter
if ( value === undefined ) {
return this.options.value;
// value passed, act as a setter
} else {
this.options.value = this._constrain( value );
var progress = this.options.value + "%";
this.element.text( progress );
}
},
// create a private method
_constrain: function( value ) {
if ( value > 100 ) {
value = 100;
}

44
45
46
47
48
49
50
51
52
53
54

if ( value < 0 ) {
value = 0;
}
return value;
}
});

To call a method on a plugin instance, you pass the name of the
method to the jQuery plugin. If you are calling a method that
accepts parameters, you simply pass those parameters after the
method name.
Calling methods on a plugin instance
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var bar = $("<div></div>").appendTo("body").progressbar
// get the current value
alert( bar.progressbar("value") );
// update the value
bar.progressbar( "value", 50 );
// get the current value again
alert( bar.progressbar("value") );

### Note Executing methods by passing the method name to the
same jQuery function that was used to initialize the plugin may
seem odd. This is done to prevent pollution of the jQuery
namespace while maintaining the ability to chain method calls.

Working with Widget Options
One of the methods that is automatically available to our plugin is
the option method. The option method allows you to get and set
options after initialization. This method works exactly like jQuery’s
css and attr methods: you can pass just a name to use it as a
setter, a name and value to use it as a single setter, or a hash of
name/value pairs to set multiple values. When used as a getter, the
plugin will return the current value of the option that corresponds to
the name that was passed in. When used as a setter, the plugin’s
_setOption method will be called for each option that is being set.
We can specify a _setOption method in our plugin to react to option
changes.
Responding when an option is set
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$.widget( "nmk.progressbar", {
options: {
value: 0
},
_create: function() {
this.element.addClass("progressbar");
this._update();
},
_setOption: function( key, value ) {
this.options[ key ] = value;
this._update();
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},
_update: function() {
var progress = this.options.value + "%";
this.element.text( progress );
}
});

Adding Callbacks
One of the easiest ways to make your plugin extensible is to add
callbacks so users can react when the state of your plugin changes.
We can see below how to add a callback to our progress bar to
signify when the progress has reached 100%. The _trigger method
takes three parameters: the name of the callback, a native event
object that initiated the callback, and a hash of data relevant to the
event. The callback name is the only required parameter, but the
others can be very useful for users who want to implement custom
functionality on top of your plugin. For example, if we were building
a draggable plugin, we could pass the native mousemove event
when triggering a drag callback; this would allow users to react to
the drag based on the x/y coordinates provided by the event object.
Providing callbacks for user extension
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$.widget( "nmk.progressbar", {
options: {
value: 0
},
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_create: function() {
this.element.addClass("progressbar");
this._update();
},
_setOption: function( key, value ) {
this.options[ key ] = value;
this._update();
},
_update: function() {
var progress = this.options.value + "%";
this.element.text( progress );
if ( this.options.value == 100 ) {
this._trigger( "complete", null, { value:
}
}
});

Callback functions are essentially just additional options, so you
can get and set them just like any other option. Whenever a
callback is executed, a corresponding event is triggered as well.
The event type is determined by concatenating the plugin name
and the callback name. The callback and event both receive the

same two parameters: an event object and a hash of data relevant
to the event, as we’ll see below.
If your plugin has functionality that you want to allow the user to
prevent, the best way to support this is by creating cancelable
callbacks. Users can cancel a callback, or its associated event, the
same way they cancel any native event: by calling
event.preventDefault() or using return false . If the user cancels
the callback, the _trigger method will return false so you can
implement the appropriate functionality within your plugin.
Binding to widget events
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var bar = $("<div></div>").appendTo("body").progressbar
complete: function( event, data ) {
alert("Callbacks are great!");
}

}).bind( "progressbarcomplete", function( event, data )

alert("Events bubble and support many handlers for ex
alert( "The progress bar value is " + data.value );
});
bar.progressbar( "option", "value", 100 );

The Widget Factory: Under the Hood
When you call jQuery.widget, it creates a constructor function for
your plugin and sets the object literal that you pass in as the
prototype for your plugin instances. All of the functionality that
automatically gets added to your plugin comes from a base widget

prototype, which is defined as jQuery.Widget.prototype. When a
plugin instance is created, it is stored on the original DOM element
using jQuery.data, with the plugin name as the key.
Because the plugin instance is directly linked to the DOM element,
you can access the plugin instance directly instead of going through
the exposed plugin method if you want. This will allow you to call
methods directly on the plugin instance instead of passing method
names as strings and will also give you direct access to the plugin’s
properties.
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var bar = $("<div></div>")
.appendTo("body")
.progressbar()
.data("progressbar");
// call a method directly on the plugin instance
bar.option( "value", 50 );
// access properties on the plugin instance
alert( bar.options.value );

One of the biggest benefits of having a constructor and prototype
for a plugin is the ease of extending the plugin. By adding or
modifying methods on the plugin’s prototype, we can modify the
behavior of all instances of our plugin. For example, if we wanted to
add a method to our progress bar to reset the progress to 0% we
could add this method to the prototype and it would instantly be
available to be called on any plugin instance.
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$.nmk.progressbar.prototype.reset = function() {
this._setOption( "value", 0 );
};

Cleaning Up
In some cases, it will make sense to allow users to apply and then
later unapply your plugin. You can accomplish this via the destroy
method. Within the destroy method, you should undo anything your
plugin may have done during initialization or later use. The destroy
method is automatically called if the element that your plugin
instance is tied to is removed from the DOM, so this can be used
for garbage collection as well. The default destroy method removes
the link between the DOM element and the plugin instance, so it’s
important to call the base function from your plugin’s destroy
method.
Adding a destroy method to a widget
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$.widget( "nmk.progressbar", {
options: {
value: 0
},
_create: function() {
this.element.addClass("progressbar");
this._update();
},
_setOption: function( key, value ) {
this.options[ key ] = value;
this._update();
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},
_update: function() {
var progress = this.options.value + "%";
this.element.text( progress );
if ( this.options.value === 100 ) {
this._trigger( "complete", null, { value:
}
},
destroy: function() {
this.element
.removeClass("progressbar")
.text("");
// call the base destroy function
$.Widget.prototype.destroy.call( this );
}
});

Conclusion
The widget factory is only one way of creating stateful plugins.
There are a few different models that can be used and each have
their own advantages and disadvantages. The widget factory solves
lots of common problems for you and can greatly improve
productivity, it also greatly improves code reuse, making it a great fit

for jQuery UI as well as many other stateful plugins.
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Performance
Append Outside of Loops
Cache Length During Loops
Detach Elements to Work with Them
Don’t Act on Absent Elements
Optimize Selectors
Use Stylesheets for Changing CSS on Many Elements
Variable Definition
Don’t Treat jQuery as a Black Box

POWERED BY HERONOTE

Append Outside of Loops
Touching the DOM comes at a cost; if you're appending a lot of
elements to the DOM, you will want to append them all at once,
rather then one at a time. This is common problem when appending
elements within a loop.
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$.each( myArray, function( i, item ) {
var newListItem = "<li>" + item + "</li>";
$("#ballers").append( newListItem );
});

One common technique is to leverage a document fragment.
During each iteration of the loop, you append the element to the
fragment rather than the DOM element. After the loop, just append
the fragment to the DOM element.
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var frag = document.createDocumentFragment();
$.each( myArray, function( i, item ) {
var newListItem = document.createElement("li"
var itemText = document.createTextNode( item );
newListItem.appendChild( itemText );
frag.appendChild( newListItem );
});
$("#ballers")[ 0 ].appendChild( frag );

Another technique, which is quite simple, is to build up a string
during each iteration of the loop. After the loop, just set the html of
the DOM element to that string.
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var myHtml = "";
$.each( myArray, function( i, item ) {
myHtml += "<li>" + item + "</li>";
});
$("#ballers").html( myHtml );

There are of course other techniques you could certainly test out; a
great way to test the performance of these is through a site called
jsperf. This site allows you to benchmark each technique and
visually see how it performs across all the browsers.
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Cache Length During Loops
In a for loop, don't access the length property of an array every
time; cache it beforehand.
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var myLength = myArray.length;
for ( var i = 0; i < myLength; i++ ) {
// do stuff
}
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Detach Elements to Work with
Them
The DOM is slow; you want to avoid manipulating it as much as
possible. jQuery introduced $.fn.detach in version 1.4 to help
address this issue, allowing you to remove an element from the
DOM while you work with it.
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var $table = $("#myTable");
var $parent = $table.parent();
$table.detach();
// ... add lots and lots of rows to table
$parent.append( $table );
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Don’t Act on Absent Elements
jQuery won't tell you if you're trying to run a whole lot of code on an
empty selection — it will proceed as though nothing's wrong. It's up
to you to verify that your selection contains some elements.
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// BAD: this runs three functions
// before it realizes there's nothing
// in the selection
$("#nosuchthing").slideUp();
// Better
var $mySelection = $("#nosuchthing");
if ( $mySelection.length ) {
$mySelection.slideUp();
}
// BEST: add a doOnce plugin
jQuery.fn.doOnce = function( func ){
this.length && func.apply( this );
return this;
}
$("li.cartitems").doOnce(function() {
// make it ajax! \o/
});

This guidance is especially applicable for jQuery UI widgets, which
have a lot of overhead even when the selection doesn't contain
elements.

Optimize Selectors
Selector optimization is less important than it used to be, as more
browsers implement document.querySelectorAll() and the burden of
selection shifts from jQuery to the browser. However, there are still
some tips to keep in mind.

ID-Based Selectors
Beginning your selector with an ID is always best.
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// fast
$("#container div.robotarm");
// super-fast
$("#container").find("div.robotarm");

The $.fn.find approach is faster because the first selection is
handled without going through the Sizzle selector engine — ID-only
selections are handled using document.getElementById() , which is
extremely fast because it is native to the browser.

Specificity
Be specific on the right-hand side of your selector, and less specific
on the left.
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// unoptimized
$("div.data .gonzalez");
// optimized
$(".data td.gonzalez");

Use tag.class if possible on your right-most selector, and just tag
or just .class on the left.

Avoid excessive specificity.
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$(".data table.attendees td.gonzalez");
// better: drop the middle if possible
$(".data td.gonzalez");

A "flatter" DOM also helps improve selector performance, as the
selector engine has fewer layers to traverse when looking for an
element.
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Avoid the Universal Selector
Selections that specify or imply that a match could be found
anywhere can be very slow.
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$(".buttons > *"); // extremely expensive
$(".buttons").children(); // much better
$(".gender :radio"); // implied universal selection
$(".gender *:radio"); // same thing, explicit now
$(".gender input:radio"); // much better
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Use Stylesheets for Changing
CSS on Many Elements
If you're changing the CSS of more than 20 elements using
$.fn.css , consider adding a style tag to the page instead for a
nearly 60% increase in speed.
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// fine for up to 20 elements, slow after that
$("a.swedberg").css("color", "#asd123");

$("<style type=\"text/css\">a.swedberg { color : #asd123
.appendTo("head");
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Variable Definition
Variables can be defined in one statement instead of several.
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// old & busted
var test = 1;
var test2 = function() { ... };
var test3 = test2( test );
// new hotness
var test = 1,
test2 = function() { ... },
test3 = test2( test );

In self-executing functions, variable definition can be skipped all
together.
1
2
3

(function( foo, bar ) {
// ...
})( 1, 2 );
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Don’t Treat jQuery as a Black
Box
Use the source as your documentation. Bookmark
http://bit.ly/jqsource and refer to it often.
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Code Organization
Understanding the basic mechanics is one thing, but the essence of
building applications is understanding how to organize code so that
it is navigable and well-encapsulated instead of a whole slew of
global functions.
Code Organization Concepts
Beware Anonymous Functions
Keep Things DRY
Feature & Browser Detection
Deferreds
jQuery Deferreds
Deferred examples

Code Organization Concepts
When you move beyond adding simple enhancements to your
website with jQuery and start developing full-blown client-side
applications, you need to consider how to organize your code. In
this chapter, we'll take a look at various code organization patterns
you can use in your jQuery application and explore the RequireJS
dependency management and build system.

Key Concepts
Before we jump into code organization patterns, it's important to
understand some concepts that are common to all good code
organization patterns.
Your code should be divided into units of functionality —
modules, services, etc. Avoid the temptation to have all of your
code in one huge $( document ).ready() block. This concept,
loosely, is known as encapsulation.
Don't repeat yourself. Identify similarities among pieces of
functionality, and use inheritance techniques to avoid repetitive
code.
Despite jQuery's DOM-centric nature, JavaScript applications
are not all about the DOM. Remember that not all pieces of
functionality need to — or should — have a DOM
representation.
Units of functionality should be loosely coupled, that is, a unit
of functionality should be able to exist on its own, and
communication between units should be handled via a
messaging system such as custom events or pub/sub. Stay
away from direct communication between units of functionality
whenever possible.
The concept of loose coupling can be especially troublesome to
developers making their first foray into complex applications, so be
mindful of this as you're getting started.
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Encapsulation
The first step to code organization is separating pieces of your
application into distinct pieces; sometimes, even just this effort is
sufficient to lend

The Object Literal
An object literal is perhaps the simplest way to encapsulate related
code. It doesn't offer any privacy for properties or methods, but it's
useful for eliminating anonymous functions from your code,
centralizing configuration options, and easing the path to reuse and
refactoring.
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// An object literal
var myFeature = {
myProperty: "hello",
myMethod: function() {
console.log( myFeature.myProperty );
},
init: function( settings ) {
myFeature.settings = settings;
},
readSettings : function() {
console.log( myFeature.settings );
}
};
myFeature.myProperty === "hello"; // true
myFeature.myMethod(); // "hello"
myFeature.init({
foo: "bar"
});
myFeature.readSettings(); // { foo: "bar" }

The object literal above is simply an object assigned to a variable.
The object has one property and several methods. All of the
properties and methods are public, so any part of your application
can see the properties and call methods on the object. While there
is an init method, there's nothing requiring that it be called before
the object is functional.
How would we apply this pattern to jQuery code? Let's say that we
had this code written in the traditional jQuery style:
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//
//
//
$(

clicking on a list item loads some content
using the list item's ID and hides content
in sibling list items
document ).ready(function() {
$("#myFeature li").append("<div/>").click(function
var $this = $( this );
var $div = $this.find("div");
$div.load( "foo.php?item=" + $this.attr(
$div.show();
$this.siblings().find("div").hide();
}
);
});

});

If this were the extent of our application, leaving it as-is would be
fine. On the other hand, if this was a piece of a larger application,
we'd do well to keep this functionality separate from unrelated
functionality. We might also want to move the URL out of the code
and into a configuration area. Finally, we might want to break up the
chain to make it easier to modify pieces of the functionality later.
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// Using an object literal for a jQuery feature
var myFeature = {
init : function( settings ) {
myFeature.config = {
$items : $("#myFeature li"),
$container : $("<div class='container'></div>"
urlBase : "/foo.php?item="
};
// allow overriding the default config
$.extend( myFeature.config, settings );
myFeature.setup();
},
setup : function() {

myFeature.config.$items.each( myFeature.createConta
},
createContainer : function() {
var $i = $( this );

var $c = myFeature.config.$container.clone().append
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$i.data( "container", $c );
},
buildUrl : function() {

return myFeature.config.urlBase + myFeature.$curren
},
showItem : function() {
var myFeature.$currentItem = $( this );
myFeature.getContent( myFeature.showContent );
},
getContent : function( callback ) {
var url = myFeature.buildUrl();

myFeature.$currentItem.data("container").load( url,
},
showContent : function() {
myFeature.$currentItem.data("container").show();
myFeature.hideContent();
},
hideContent : function() {
myFeature.$currentItem.siblings().each(function
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$( this ).data("container").hide();
});
}
};
$( document ).ready( myFeature.init );

The first thing you'll notice is that this approach is obviously far
longer than the original -- again, if this were the extent of our
application, using an object literal would likely be overkill. Assuming
it's not the extent of our application, though, we've gained several
things:
We've broken our feature up into tiny methods. In the future, if
we want to change how content is shown, it's clear where to
change it. In the original code, this step is much harder to
locate.
We've eliminated the use of anonymous functions.
We've moved configuration options out of the body of the code
and put them in a central location.
We've eliminated the constraints of the chain, making the code
easier to refactor, remix, and rearrange.
For non-trivial features, object literals are a clear improvement over
a long stretch of code stuffed in a $( document ).ready() block, as
they get us thinking about the pieces of our functionality. However,
they aren't a whole lot more advanced than simply having a bunch
of function declarations inside of that $( document ).ready() block.

The Module Pattern
The module pattern overcomes some of the limitations of the object
literal, offering privacy for variables and functions while exposing a

public API if desired.
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// The module pattern
var feature = (function() {
// private variables and functions
var privateThing = "secret";
var publicThing = "not secret";
var changePrivateThing = function() {
privateThing = "super secret";
};
var sayPrivateThing = function() {
console.log( privateThing );
changePrivateThing();
};
// public API
return {
publicThing: publicThing,
sayPrivateThing: sayPrivateThing
};
})();
feature.publicThing; // "not secret"

// logs "secret" and changes the value
// of privateThing
feature.sayPrivateThing();

In the example above, we self-execute an anonymous function that
returns an object. Inside of the function, we define some variables.
Because the variables are defined inside of the function, we don't
have access to them outside of the function unless we put them in

the return object. This means that no code outside of the function
has access to the privateThing variable or to the
changePrivateThing function. However, sayPrivateThing does have
access to privateThing and changePrivateThing , because both were
defined in the same scope as sayPrivateThing .
This pattern is powerful because, as you can gather from the
variable names, it can give you private variables and functions
while exposing a limited API consisting of the returned object's
properties and methods.
Below is a revised version of the previous example, showing how
we could create the same feature using the module pattern while
only exposing one public method of the module, showItemByIndex() .
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// Using the module pattern for a jQuery feature
$( document ).ready(function() {
var feature = (function() {
var $items = $("#myFeature li");
var $container = $("<div class='container'></div>"
var $currentItem = null;
var urlBase = "/foo.php?item=";
var createContainer = function() {
var $i = $( this );
var $c = $container.clone().appendTo( $i );
$i.data( "container", $c );
},
buildUrl = function() {
return urlBase + $currentItem.attr("id");
},
showItem = function() {
$currentItem = $( this );
getContent( showContent );
},
showItemByIndex = function( idx ) {
$.proxy( showItem, $items.get( idx ) );
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},
getContent = function( callback ) {
$currentItem.data("container").load( buildUrl(),
},
showContent = function() {
$currentItem.data("container").show();
hideContent();
},
hideContent = function() {
$currentItem.siblings().each(function() {
$( this ).data("container").hide();
});
};
$items.each( createContainer ).click( showItem );
return {
showItemByIndex: showItemByIndex
};
})();
feature.showItemByIndex( 0 );
});
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Beware Anonymous Functions
Anonymous functions bound everywhere are a pain. They're difficult
to debug, maintain, test, or reuse. Instead, use an object literal to
organize and name your handlers and callbacks.
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// BAD
$( document ).ready(function() {
$("#magic").click(function( event ) {
$("#yayeffects").slideUp(function() {
// ...
});
});
$("#happiness").load( url + " #unicorns", function
// ...
});
});
// BETTER
var PI = {
onReady : function() {
$("#magic").click( PI.candyMtn );
$("#happiness").load( PI.url + " #unicorns"
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},
candyMtn : function( event ) {
$("#yayeffects").slideUp( PI.slideCb );
},
slideCb : function() { ... },
unicornCb : function() { ... }
};
$( document ).ready( PI.onReady );
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Keep Things DRY
Don't repeat yourself; if you're repeating yourself, you're doing it
wrong.
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// BAD
if ( $eventfade.data("currently") !== "showing"
$eventfade.stop();
}
if ( $eventhover.data("currently") !== "showing"
$eventhover.stop();
}
if ( $spans.data("currently") !== "showing" ) {
$spans.stop();
}
// GOOD!!
var $elems = [ $eventfade, $eventhover, $spans ];
$.each( $elems, function( i, elem ) {
if ( elem.data("currently") !== "showing" ) {
elem.stop();
}
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});
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Feature & Browser Detection
Can I Use This Browser Feature?
There are a couple of common ways to check whether or not a
particular feature is supported by a user's browser:
Browser Detection
Specific Feature Detection
In general, we recommend specific feature detection. Let's look at
why.

Browser Detection
Browser detection is a method where the browser's User Agent
(UA) string is checked for a particular pattern unique to a browser
family or version. For example, this is Chrome 18's UA string on
Mac OS X Lion:
1

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebK

Browser UA detection may check this string for something like
"Chrome" or "Chrome/18" or any other part the developer feels
identifies the browser they intend to target.
While this seems to be an easy solution, there are several
problems:
Other browsers other than your target may have the same
issue.
If we target a specific browser for different functionality, we implicitly
exclude any browser we did not account for. This is also not futureproof. If the browser we target receives a bug fix or change, we
may not be able to discern between a 'working' and 'non-working'

UA string. We may also need to update our test for each new
release. This isn't a maintainable solution.
User Agents are unreliable.
User Agents are set by the client browser. In the early days of the
web, browsers would mimic each others' UA strings in order to
bypass exactly this type of detection. It is still possible that a
browser with very different capabilities may mimic just the portion of
the UA string you're targeting.
The UA string is also user-configurable. While the user may change
this string, the browser's feature support remains the same.
In general, we do not recommend UA string-based feature
detection.

Specific Feature Detection
Specific feature detection checks if a specific feature is available,
instead of developing against a specific browser. This way,
developers can write their code for two cases: the browser does
support said feature, or the browser does not support said feature.
Developing against specific features, instead of developing against
a specific browser, not only clears up the peripheral logic of your
application, but also makes your job easier as a developer.
We recommend specific feature detection over UA string detection.
Now how would you go about doing that?

How to go about feature detection
There are several ways to go about feature detection:
Straight JavaScript
$.support
A Helper Library
Straight JavaScript

Let's take a look at how to check whether or not a <canvas> element
exists in a specific browser, without using a helper library. We do
this by specifically querying whether the method or property exists:
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// We want to show a graph in browsers that support can
// but a data table in browsers that don't.
var elem = document.createElement("canvas");
if ( elem.getContext && elem.getContext("2d") ) {
showGraph();
} else {
showTable();
}

This is a very simple way to provide conditional experiences,
depending on the features present in the user's browser. We can
extract this into a helper function for reuse, but still have to write a
test for every feature we're concerned about. This can be timeconsuming and error-prone.
What if someone else wrote all of that for us?
$.support
jQuery performs many tests to determine feature support to allow
cross-browser use of many of the features we've come to love.
jQuery's internal feature detection can be accessed through
jQuery.support.
However, we do not recommend this for general use. As the API
page says:

Since jQuery requires these tests internally,

they must be performed on every page
load. Although some of these properties
are documented below, they are not
subject to a long deprecation/removal cycle
and may be removed once internal jQuery
code no longer needs them.
This detection may be removed from jQuery without notice. That's
reason enough not to use it. What other options do we have?
A Helper Library
Thankfully, there are some great helper libraries (like Modernizr)
that provide a simple, high-level API for determining if a browser
has a specific feature available or not.
For example, utilizing Modernizr, we are able to do the same
canvas detection test with this code:
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if ( Modernizr.canvas ) {
showGraphWithCanvas();
} else {
showTable();
}

That's it. Easy.

Performance Considerations
So, while the Modernizr syntax is great, it can end up being quite
cumbersome to have several conditionals. Secondly, we're sending

the code for both conditions to every browser, regardless if we'll
need it or not.
The Modernizr object exposes a load() method that many prefer
over the syntax mentioned previously. This is due to the another
library that Modernizr now uses internally: yepnope. Testing for
canvas can now become something like this:
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Modernizr.load({
test: Modernizr.canvas,
yep : "canvas.js",
nope: "canvas-polyfill.js"
});

Using the load method allows us to send only the required polyfills
and code over the wire. You can also pass an array of objects as an
argument to .load() , and it will serve the correct files to the correct
audience.
Additionally, Modernizr has a production build configurator that
allows you to specify exactly what parts of Modernizr you want to
include and exclude the parts you don't.

Other Resources
Feature Detection Tools
modernizr - conditionally check to see if a specific feature is
available in a browser
html5please - use the new and shiny responsibly
html5please api - an API you can query to see how good (or
bad) support for a specific feature is.
caniuse - browser compatibility tables for HTML5, CSS3, SVG,
etc…
yepnope - conditional polyfill loader
Helpful Articles

Browser Feature Detection
Using Modernizr to detect HTML5 and CSS3 browser support
polyfilling the html5 gap by Addy Osmani
Feature, Browser, and Form Factor Detection: It's Good for the
Environment by Michael Mahemoff

Deferreds
At a high-level, deferreds can be thought of as a way to represent
asynchronous operations which can take a long time to complete.
They're the asynchronous alternative to blocking functions and the
general idea is that rather than your application blocking while it
awaits some request to complete before returning a result, a
deferred object can instead be returned immediately. You can then
attach callbacks to the deferred object: they will be called once the
request has actually completed.
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Promises
In its most basic form, a 'promise' is a model that provides a
solution for the concept of deferred (or future) results in software
engineering. The main idea behind it is something we've already
covered: rather than executing a call which may result in blocking,
we instead return a promise for a future value that will eventually be
satisfied.
If it helps to have an example here, consider that you are building a
web application which heavily relies on data from a third party API.
A common problem that's faced is having an unknown knowledge
of the API server's latency at a given time so it's possible that other
parts of your application may be blocked from running until a result
from it is returned. Deferreds provide a better solution to this
problem, one which is void of 'blocking' effects and completely
decoupled.
The Promise/A proposal defines a method called 'then' that can be
used to register callbacks to a promise and, thus, get the future
result when it is available. The pseudo-code for dealing with a third
party API that returns a promise may look like:
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promise = callToAPI( arg1, arg2, ...);
promise.then(function( futureValue ) {
/* handle futureValue */
});
promise.then(function( futureValue ) {
/* do something else */
});

Furthermore, a promise can actually end up being in two different
states:
resolved: in which case data is available
rejected: in which case something went wrong and no value is

available
Thankfully, the 'then' method accepts two parameters: one for when
the promise was resolved, another for when the promise was
rejected. If we get back to pseudo-code, we may do things like:
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promise.then( function( futureValue ) {
/* we got a value */
} , function() {
/* something went wrong */
} );

In the case of certain applications, it is necessary to have several
results returned before your application can continue at all (for
example, displaying a dynamic set of options on a screen before a
user is able to select the option that interests them). Where this is
the case, a method called 'when' exists, which can be used to
perform some action once all the promises have been fully fulfilled:
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when(
promise1,
promise2,
...
).then(function( futureValue1, futureValue2, ... ) {
/* all promises have completed and are resolved */
});

A good example is a scenario where you may have multiple
concurrent animations that are being run. Without keeping track of
each callback firing on completion, it can be difficult to truly
establish once all your animations have finished running. Using
promises and 'when' however this is very straightforward as each of
your animations can effectively say 'we promise to let you know
once we're done'. The compounded result of this means it's a trivial
process to execute a single callback once the animations are done.

For example:
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var promise1 = $("#id1").animate().promise();
var promise2 = $("#id2").animate().promise();
when(
promise1,
promise2
).then(function(){
/* once both animations have completed
we can then run our additional logic */
});

This means that one can basically write non-blocking logic that can
be executed without synchronization. Rather than directly passing
callbacks to functions, something which can lead to tightly coupled
interfaces, using promises allows one to separate concerns for
code that is synchronous or asynchronous.
jQuery Deferreds
Deferred examples

jQuery Deferreds
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jQuery Deferreds
Deferreds were added as a part of a large rewrite of the ajax
module, led by Julian Auborg following the CommonJS Promises/A
design. Whilst 1.5 and above include deferred capabilities, former
versions of jQuery had jQuery.ajax() accept callbacks that would be
invoked upon completion or error of the request, but suffered from
heavy coupling - the same principle that would drive developers
using other languages or toolkits to opt for deferred execution.
In practice what jQuery's version provides you with are several
enhancements to the way callbacks are managed, giving you
significantly more flexible ways to provide callbacks that can be
invoked whether the original callback dispatch has already fired or
not. It is also worth noting that jQuery's Deferred object supports
having multiple callbacks bound to the outcome of particular tasks
(and not just one) where the task itself can either be synchronous
or asynchronous.
At the heart of jQuery's implementation is jQuery.Deferred - a
chainable constructor which is able to create new deferred objects
that can check for the existence of a promise to establish whether
the object can be observed. It can also invoke callback queues and
pass on the success of synchronous and asynchronous functions.
It's quite essential to note that the default state of any Deferred
object is unresolved. Callbacks which may be added to it through
.then() or .fail() are queued up and get executed later on in the
process.
You are able to use Deferred objects in conjunction with the
promise concept of when(), implemented in jQuery as $.when() to
wait for all of the Deferred object's requests to complete executing
(ie. for all of the promises to be fulfilled). In technical terms,
$.when() is effectively a way to execute callbacks based on any
number of promises that represent asynchronous events.
An example of $.when() accepting multiple arguments can be seen
below in conjunction with .then():
1

function successFunc(){

2
3
4
5
6
7
8
9
10
11
12
13

console.log( "success!" );
}
function failureFunc(){
console.log( "failure!" );
}
$.when(
$.ajax( "/main.php" ),
$.ajax( "/modules.php" ),
$.ajax( "/lists.php" )
).then( successFunc, failureFunc );

The $.when() implementation offered in jQuery is quite interesting
as it not only interprets deferred objects, but when passed
arguments that are not deferreds, it treats these as if they were
resolved deferreds and executes any callbacks (doneCallbacks)
right away. It is also worth noting that jQuery's deferred
implementation, in addition to exposing deferred.then(), a jQuery
promise also supports the deferred.done() and deferred.fail()
methods which can also be used to add callbacks to the deferred's
queues.
We will now take a look at a code example that utilizes many of the
deferred features mentioned in the table presented earlier. Here is a
very basic application that consumes (1) an external news feed and
(2) a reactions feed for pulling in the latest comments via $.get()
(which will return a promise). The application also has a function
(prepareInterface()) which returns a promise to complete animating
our containers for both the news and reactions.
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function getLatestNews() {
return $.get( "latestNews.php", function(data){
console.log( "news data received" );
$( ".news" ).html(data);
} );
}
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function getLatestReactions() {
return $.get( "latestReactions.php", function
console.log( "reactions data received"
$( ".reactions" ).html(data);
} );
}
function prepareInterface() {
return $.Deferred(function( dfd ) {
var latest = $( ".news, .reactions" );
latest.slideDown( 500, dfd.resolve );
latest.addClass( "active" );
}).promise();
}
$.when(
getLatestNews(),
getLatestReactions(),
prepareInterface()
).then(function(){
console.log( "fire after requests succeed"
}).fail(function(){
console.log( "something went wrong!" );
});

Deferred examples
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Further Deferreds examples
Deferreds are used behind the hood in Ajax but it doesn't mean
they can't also be used elsewhere. This section describes situations
where deferreds will help abstract away asynchronous behaviour
and decouple our code.

Caching
Asynchronous cache
When it comes to asynchronous tasks, caching can be a bit
demanding since you have to make sure a task is only performed
once for a given key. As a consequence, the code has to somehow
keep track of inbound tasks.
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$.cachedGetScript( url, callback1 );
$.cachedGetScript( url, callback2 );

The caching mechanism has to make sure the url is only requested
once even if the script isn't in cache yet. This shows some logic to
keep track of callbacks bound to a given url in order for the cache
system to properly handle both complete and inbound requests.
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var cachedScriptPromises = {};

$.cachedGetScript = function( url, callback ) {
if ( !cachedScriptPromises[ url ] ) {
cachedScriptPromises[ url ] = $.Deferred(
$.getScript( url ).then( defer.resolve, def
}).promise();
}
return cachedScriptPromises[ url ].done( callback )
};

One promise is cached per url. If there is no promise for the given
url yet, then a deferred is created and the request is issued. If it
already exists, however, the callback is attached to the existing
deferred. The big advantage of this solution is that it will handle
both complete and inbound requests transparently. Another
advantage is that a deferred-based cache will deal with failure
gracefully. The promise will end up rejected which can be tested for
by providing an error callback:
1

$.cachedGetScript( url ).then( successCallback, errorCal

Generic asynchronous cache
It is also possible to make the code completely generic and build a
cache factory that will abstract out the actual task to be performed
when a key isn't in the cache yet:
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$.createCache = function( requestFunction ) {
var cache = {};
return function( key, callback ) {
if ( !cache[ key ] ) {
cache[ key ] = $.Deferred(function
requestFunction( defer, key );
}).promise();
}
return cache[ key ].done( callback );
};
}

Now that the request logic is abstracted away, cachedGetScript can
be rewritten as follows:
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$.cachedGetScript = $.createCache(function( defer, url )
$.getScript( url ).then( defer.resolve, defer.reject

3

});

This will work because every call to createCache will create a new
cache repository and return a new cache-retrieval function.
Image loading
A cache can be used to ensure that the same image is not loaded
multiple times.
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$.loadImage = $.createCache(function( defer, url ) {
var image = new Image();
function cleanUp() {
image.onload = image.onerror = null;
}
defer.then( cleanUp, cleanUp );
image.onload = function() {
defer.resolve( url );
};
image.onerror = defer.reject;
image.src = url;
});

Again, the following snippet:
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$.loadImage( "my-image.png" ).done( callback1 );
$.loadImage( "my-image.png" ).done( callback2 );

will work regardless of whether my-image.png has already been
loaded or not, or if it is actually in the process of being loaded.
Caching Data API responses
API requests that are considered immutable during the lifetime of

your page are also perfect candidates. For instance, the following:
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$.searchTwitter = $.createCache(function( defer, query
$.ajax({
url: "http://search.twitter.com/search.json"
data: {
q: query
},
dataType: "jsonp",
success: defer.resolve,
error: defer.reject
});
});

will allow you to perform searches on Twitter and cache them at the
same time:
1
2

$.searchTwitter( "jQuery Deferred", callback1 );
$.searchTwitter( "jQuery Deferred", callback2 );

Timing
This deferred-based cache is not limited to network requests; it can
also be used for timing purposes.
For instance, you may need to perform an action on the page after
a given amount of time so as to attract the user's attention to a
specific feature they may not be aware of or deal with a timeout (for
a quiz question for instance). While setTimeout is good for most
use-cases it doesn't handle the situation when the timer is asked for
later, even after it has theoretically expired. We can handle that with
the following caching system:
1

var readyTime;

2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

$(function() {
readyTime = jQuery.now();
});

$.afterDOMReady = $.createCache(function( defer, delay
delay = delay || 0;
$(function() {
var delta = $.now() - readyTime;
if ( delta >= delay ) {
defer.resolve();
} else {
setTimeout( defer.resolve, delay - delta );
}
});
});

The new afterDOMReady helper method provides proper timing
after the DOM is ready while ensuring the bare minimum of timers
will be used. If the delay is already expired, any callback will be
called right away.

One-time event
While jQuery offers all the event binding one may need, it can
become a bit cumbersome to handle events that are only supposed
to be dealt with once.
For instance, you may wish to have a button that will open a panel
the first time it is clicked and leave it open afterwards or take
special initialization actions the first time said button is clicked.
When dealing with such a situation, one usually end up with code
like this:
1
2
3

var buttonClicked = false;
$( "#myButton" ).click(function() {

4
5
6
7
8
9

if ( !buttonClicked ) {
buttonClicked = true;
initializeData();
showPanel();
}
});

then, later on, you may wish to take actions, but only if the panel is
opened:
1
2
3

if ( buttonClicked ) {
/* perform specific action */
}

This is a very coupled solution. If you want to add some other
action, you have to edit the bind code or just duplicate it all. If you
don't, your only option is to test for buttonClicked and you may lose
that new action because the buttonClicked variable may be false
and your new code may never be executed.
We can do much better using deferreds (for simplification sake, the
following code will only work for a single element and a single event
type, but it can be easily generalized for full-fledged collections with
multiple event types):
1
2
3
4
5
6
7
8
9
10
11

$.fn.bindOnce = function( event, callback ) {
var element = $( this[ 0 ] ),
defer = element.data( "bind_once_defer_"
if ( !defer ) {
defer = $.Deferred();
function deferCallback() {
element.unbind( event, deferCallback );
defer.resolveWith( this, arguments );
}
element.bind( event, deferCallback )
element.data( "bind_once_defer_" + event , defe

12
13
14

}
return defer.done( callback ).promise();
};

The code works as follows:
check if the element already has a deferred attached for the
given event
if not, create it and make it so it is resolved when the event is
fired the first time around
then attach the given callback to the deferred and return the
promise
While the code is definitely more verbose, it makes dealing with the
problem at hand much simpler in a compartmentalized and
decoupled way. But let's define a helper method first:
1
2
3

$.fn.firstClick = function( callback ) {
return this.bindOnce( "click", callback );
};

Then the logic can be re-factored as follows:
1
2
3
4

var openPanel = $( "#myButton" ).firstClick();
openPanel.done( initializeData );
openPanel.done( showPanel );

If an action should be performed only when a panel is opened later
on:
1

openPanel.done(function() {

2
3

/* perform specific action */
});

Nothing is lost if the panel isn't opened yet, the action will just get
deferred until the button is clicked.

Combining helpers
All of the samples above can seem a bit limited when looked at
separately. However, the true power of promises comes into play
when you mix them together.
Requesting panel content on first click and opening said panel
Following is the code for a button that, when clicked, opens a panel.
It requests its content over the wire and then fades the content in.
Using the helpers defined earlier, it could be defined as:
1
2
3
4
5
6
7
8
9

$( "#myButton" ).firstClick(function() {
var panel = $( "#myPanel" );
$.when(
$.get( "panel.html" ),
panel.slideDownPromise()
).done(function( ajaxResponse ) {
panel.html( ajaxResponse[ 0 ] ).fadeIn();
});
});

Loading images in a panel on first click and opening said
panel
Another possible goal is to have the panel fade in, only after the
button has been clicked and after all of the images have been
loaded.
The html code for this would look something like:

1
2
3
4
5
6

<div id="myPanel">
<img data-src="image1.png"
<img data-src="image2.png"
<img data-src="image3.png"
<img data-src="image4.png"
</div>

/>
/>
/>
/>

We use the data-src attribute to keep track of the real image
location. The code to handle our use case using our promise
helpers is as follows:
1
2
3
4
5
6
7
8
9
10
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12
13
14
15
16
17
18
19
20
21
22
23
24
25

$( "#myButton" ).firstClick(function() {
var panel = $( "#myPanel" ),
promises = [];
$( "img", panel ).each(function() {
var image = $( this ),
src = element.attr( "data-src" );
if ( src ) {
promises.push(
$.loadImage( src ).then( function
image.attr( "src", src );
}, function() {
image.attr( "src", "error.png"
} )
);
}
});
promises.push(
panel.slideDownPromise()
);
$.when.apply( null, promises ).done(function
panel.fadeIn();

26
27

});
});

The trick here is to keep track of all the loadImage promises. We
later join them with the panel slideDown animation using $.when.
So when the button is first clicked, the panel will slideDown and the
images will start loading. Once the panel has finished sliding down
and all the images have been loaded, then, and only then, will the
panel fade in.
Loading images on the page after a specific delay
In order to implement deferred image display on the entire page,
the following format in HTML can be used.
1
2
3
4

<img
<img
<img
<img

data-src="image1.png"
data-src="image2.png"
data-src="image1.png"
data-src="image2.png"

data-after="1000"
data-after="1000"
src="placeholder.png"
data-after="2000"

What it says is pretty straight-forward:
load image1.png and show it immediately for the third image
and after one second for the first one
load image2.png and show it after one second for the second
image and after two seconds for the fourth image
1
2
3
4
5
6
7
8

$( "img" ).each(function() {
var element = $( this ),
src = element.attr( "data-src" ),
after = element.attr( "data-after" );
if ( src ) {
$.when(
$.loadImage( src ),
$.afterDOMReady( after )

9
10
11
12
13
14
15
16
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).then(function() {
element.attr( "src", src );
}, function() {
element.attr( "src", "error.png" );
} ).done(function() {
element.fadeIn();
});
}
});

In order to delay the loading of the images themselves:
1
2
3
4
5
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$( "img" ).each(function() {
var element = $( this ),
src = element.attr( "data-src" ),
after = element.attr( "data-after" );
if ( src ) {
$.afterDOMReady( after, function() {
$.loadImage( src ).then(function() {
element.attr( "src", src );
}, function() {
element.attr( "src", "error.png"
} ).done(function() {
element.fadeIn();
});
} );
}
});

Here, after the delay to be fulfilled then the image is loaded. It can
make a lot of sense when you want to limit the number or network
requests on page load.
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jQuery UI
jQuery UI is a curated set of user interface interactions, effects,
widgets, and themes built on top of the jQuery JavaScript Library.
Whether you're building highly interactive web applications or you
just need to add a date picker to a form control, jQuery UI is the
perfect choice.
jQuery UI contains many widgets that maintain state and therefore
have a slightly different usage pattern than typical jQuery plugins.
All of jQuery UI's widgets use the same patterns, so if you learn
how to use one, then you'll know how to use all of them.
Getting Started with jQuery UI
How jQuery UI Works
Theming jQuery UI
Using jQuery UI ThemeRoller
jQuery UI CSS Framework API
How To Write a Theme
Widget Factory
Why Use the Widget Factory
How To Use the Widget Factory
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Getting Started with jQuery UI
What is jQuery UI?
jQuery UI is a widget and interaction library built on top of the
jQuery JavaScript Library that you can use to build highly
interactive web applications. This guide is designed to get you up to
speed on how jQuery UI works. Follow along below to get started.

Start by checking out the demos
To get a feel for what jQuery UI is capable of, check out the UI
Demos.
In the demos section, the navigation lists all of the interactions and
widgets that jQuery UI offers. Choose an interaction or widget and
you'll be presented with several demo configurations for that
particular plugin. Each demo allows you to view source code,
change themes, and the URL can always be bookmarked. For
example, check out the accordion widget's fill space demo page.

Build your custom jQuery UI download
Once you have a basic understanding of what jQuery UI is and
what it does, you're ready to try it out! It's time to head over to the
Download Builder on the jQuery UI website to download a copy of
jQuery UI. jQuery UI's download builder allows you to choose the
components you would like to download and get a custom version
of the library for your project. There are 3 easy steps to building
your custom jQuery UI download:
Step 1: Choose which components you need
The main column of the Download Builder lists all of the javascript
components in jQuery UI categorized into groups: core, interations,
widgets, and effects. Some components in jQuery UI depend on
other components. Just check the boxes for the widgets you'd like
to download and any required dependencies will automatically be
checked as well. The components you select will all be combined

into a custom jQuery UI javascript file.

Step 2: Select a theme (or roll your own custom theme)
In the right column of the download builder, you'll find a field where
you can choose from a number of pre-designed themes for your
jQuery UI widgets. You can either choose from the various themes
we provide, or you can design your own custom theme using
ThemeRoller (more on that later).
Advanced Theme Settings: The theme section of the download
builder also offers some advanced configuration settings for your
theme. If you plan to use multiple themes on a single page, these
fields will come in handy. If you plan to only use one theme on a
page, you can skip these settings entirely.
Step 3: Choose a version of jQuery UI
The last step in the download builder is to select a version number.
This is a very important step because jQuery UI versions are
designed to work with specific versions of jQuery. The current
versions are:

jQuery UI 1.10.0 - Requires jQuery 1.6+
jQuery UI 1.9.2 - Requires jQuery 1.6+
Click Download!
You're finished with the download builder! Click the download
button and you'll get a customized zip file containing everything you
selected.

After downloading: Intro to using jQuery UI
Once you've downloaded jQuery UI, you'll get a zip containing the
following files:
/css/
/development-bundle/
/js/
index.html

Basic overview: using jQuery UI on a web
page
Open up index.html in a text editor and you'll see that it links to a
few dependencies: your theme, jQuery, and jQuery UI. Generally,
you'll need to include these 3 files on any page to use jQuery UI
widgets and interactions:
1
2
3

<link type="text/css" href="css/themename/jquery-ui.cust
<script type="text/javascript" src="js/jquery.min.js"
<script type="text/javascript" src="js/jquery-ui.custom.

Once you've included the necessary files, you can add some
jQuery widgets to your page. For example, to make a datepicker
widget, you'll add a text input element to your page and then call
.datepicker(); on it. Like this:

HTML:
1

<input type="text" name="date" id="date">

JS:
1

$('#date').datepicker();

That's it!
For demos of all of the jQuery UI widgets and interactions. Check
out the demos section of the jQuery UI website.

Customizing jQuery UI to your needs
jQuery UI allows you to customize it in several ways. You've already
seen how the download builder allows you to customize your copy
of jQuery UI to include only the portions you want, but there are
additional ways to customize that code to your implementation.

jQuery UI basics: using options
Each plugin in jQuery UI has a default configuration which is
catered to the most basic and common use case. But if you want a
plugin to behave different from its default configuration, you can
override each of its default settings using "options". Options are a
set of properties passed into a jQuery UI widget as an argument.

For example, the slider widget has an option for orientation, which
allows you to specify whether the slider should be horizontal or
vertical. To set this option for a slider on your page, you just pass it
in as an argument, like this:
1
2
3

$('#mySliderDiv').slider({
orientation: 'vertical'
});

You can pass as many different options as you'd like by following
each one with a comma (except the last one):
1
2
3
4
5
6

$('#mySliderDiv').slider({
orientation: 'vertical',
min: 0,
max: 150,
value: 50
});

Just remember to surround your options with curly brackets { } ,
and you're well on your way. Of course, the example above barely
touches on what you can do with jQuery UI. To get detailed
information on the entire set of jQuery UI widgets, visit the jQuery
UI documentation.

Visual customization: Designing a jQuery UI
theme
If you want to design your own theme, jQuery UI has a very slick
application for just that purpose. It's called ThemeRoller, and you
can always get to it by either clicking the "Themes" link in the
jQuery UI navigation, or simply going to jQuery UI Themeroller.
ThemeRoller provides a custom interface for designing all of the
elements used by jQuery UI widgets. As you tweak the "levers" in
the left column, the widgets on the right will reflect your design. The

Gallery tab of ThemeRoller offers a number of pre-designed themes
(the same ones offered by the download builder) that you can
tweak or download as they are.

Downloading your theme
When you click the "Download theme" button in ThemeRoller, you'll
be directed to the Download Builder and your custom theme will be
auto-selected in the Theme dropdown menu. You can configure
your download package further from there. Once you download,
you'll see that the example.html page is styled using your custom
theme.
Quick tip: If you ever need to edit your theme, simply open the
CSS file and find on line 43 where it says "To view and modify this
theme, visit ..." That url will open the theme in ThemeRoller for
editing.

Support: Where can I get help?
JQuery UI user and developer resources are kept up-to-date at the
Support Center.

Developers Wanted!
Want to join the jQuery UI team? We'd love your help! Visit the UI
Development Center for details on how to get involved.

How jQuery UI Works
jQuery UI contains many widgets that maintain state and therefore
may have a slightly different usage pattern than typical jQuery
plugins you are already used to. While the initialization is the same
as most jQuery plugins, jQuery UI's widgets are built on top of the
Widget Factory which provides the same general API to all of them.
So if you learn how to use one, then you'll know how to use all of
them! This document will walk you through the common
functionality, using the progressbar widget for the code examples.

Initialization
In order to track the state of the widget, we must introduce a full life
cycle for the widget. The life cycle starts when the widget is
initalized. To initialize a widget, we simply call the plugin on one or
more elements.
1

$( "#elem" ).progressbar();

This will initialize each element in the jQuery object, in this case the
element with an id of "elem". Because we called the progressbar()
method with no parameters, the widget is initialized with its default
options. We can pass a set of options during initialization in order to
override the default options.
1

$( "#elem" ).progressbar({ value: 20 });

We can pass as many or as few options as we want during
initialization. Any options that we don't pass will just use their
default values.
The options are part of the widget's state, so we can set options
after initialization as well. We'll see this later with the option
method.

Methods
Now that the widget is initialized, we can query its state or perform
actions on the widget. All actions after initialization take the form of
a method call. To call a method on a widget, we pass the name of
the method to the jQuery plugin. For example, to call the value
method on our progressbar widget, we would use:
1

$( "#elem" ).progressbar( "value" );

If the method accepts parameters, we can pass them after the
method name. For example, to pass the parameter 40 to the value
method, we can use:
1

$( "#elem" ).progressbar( "value", 40 );

Just like other methods in jQuery, most widget methods return the
jQuery object for chaining.
1
2
3

$( "#elem" )
.progressbar( "value", 90 )
.addClass( "almost-done" );

Common Methods
Each widget will have its own set of methods based on the
functionality that the widget provides. However, there are a few
methods that exist on all widgets.
option
As we mentioned earlier, we can change options after initialization
through the option method. For example, we can change the
progressbar's value to 30 by calling the option method.

1

$( "#elem" ).progressbar( "option", "value",

Note that this is different from the previous example where we were
calling the value method. In this example, we're calling the option
method and saying that we want to change the value option to 30.
We can also get the current value for an option.
1

$( "#elem" ).progressbar( "option", "value" );

In addition, we can update multiple options at once by passing an
object to the option method.
1
2
3
4

$( "#elem" ).progressbar( "option", {
value: 100,
disabled: true
});

You may have noticed that the option method has the same
signature as getters and setters in jQuery core, such as .css() and
.attr() . The only difference is that you have to pass the string
"option" as the first parameter.
disable
As you might guess, the disable method disables the widget. In the
case of progressbar, this changes the styling to make the
progressbar look disabled.
1

$( "#elem" ).progressbar( "disable" );

Calling the

disable

method is equivalent to setting the

disabled

option to

true .

enable
The

enable

1

method is the opposite of the

disable

method.

$( "#elem" ).progressbar( "enable" );

Calling the enable method is equivalent to setting the
option to false .

disabled

destroy
If you no longer need the widget, you can destroy it and return back
to the original markup. This ends the life cycle of the widget.
1

$( "#elem" ).progressbar( "destroy" );

Once you destroy a widget, you can no longer call any methods on
it unless you initialize the widget again. If you're removing the
element, either directly via .remove() or by modifying an ancestor
with .html() or .empty() , the widget will automatically destroy itself.
widget
Some widgets generate wrapper elements, or elements
disconnected from the original element. In these cases, the widget
method will return the generated element. In cases like the
progressbar, where there is no generated wrapper, the widget
method returns the original element.
1

$( "#elem" ).progressbar( "widget" );
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Events
All widgets have events associated with their various behaviors to
notify you when the state is changing. For most widgets, when the
events are triggered, the names are prefixed with the widget name.
For example, we can bind to progressbar's change event which is
triggered whenever the value changes.
1
2
3

$( "#elem" ).bind( "progressbarchange", function
alert( "The value has changed!" );
});

Each event has a corresponding callback, which is exposed as an
option. We can hook into progressbar's change callback instead of
binding to the progressbarchange event, if we wanted to.
1
2
3
4
5

$( "#elem" ).progressbar({
change: function() {
alert( "The value has changed!" );
}
});

Common Events
While most events will be widget specific, all widgets have a create
event. This event will be triggered immediately after the widget is
created.
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Theming jQuery UI
All jQuery UI plugins are designed to allow a developer to
seamlessly integrate UI widgets into the look and feel of their site or
application. Each plugin is styled with CSS and contains two layers
of style information: standard jQuery UI CSS Framework styles and
plugin-specific styles.
The jQuery UI CSS Framework provide semantic presentation
classes to indicate the role of an element within a widget such as a
header, content area, or clickable region. These are applied
consistently across all widgets so a clickable tab, accordian or
button will all have the same ui-state-default class applied to
indicate that it is clickable. When a user mouses over one of these
elements, this class is changed to ui-state-hover , then ui-stateactive when selected. This level of class consistency makes it easy
to ensure that all elements with a similar role or interaction state will
look the same across all widgets.
The CSS Framework styles are encapsulated in a single file called
ui.theme.css and this is the file modified by the ThemeRoller
application. Framework styles only include attributes that affect the
look and feel (primarily color, background images and icons) so
these are 'safe' styles that will not affect functionality of individual
plugins. This separation means that a developer can create a
custom look and feel by modifying the colors and images in
theme.css file and know that as future plugins or bug fixes become
available, these should work with the theme without modification.
Since the framework styles only cover look and feel, plugin specific
stylesheets are included that contain all the additional structural
style rules required to make the widget functional, such as
dimensions, padding, margins, positioning and floats. Stylesheets
for each plugin are located in the themes/base folder of the
download and are named to match the plugin such as
"jquery.ui.accordion.css". These styles must be carefully edited
because they work in conjunction with the scripting and provide
overrides of framework styles as needed.
We encourage all developers creating jQuery plugins to leverage

the jQuery UI CSS Framework because it will make it much easier
for end users to theme and use your plugin.

Getting started
There are three general approaches to theming jQuery UI plugins:
Download a ThemeRoller theme: The easiest way to build a
theme is to use the Themeroller to generate and download a
theme. This app will create a new ui.theme.css file and and
images directory containing all necessary background images
and icon sprites which can simply be dropped into your project.
This approach will be the easiest to create and maintain but
limits customization to the options provided in ThemeRoller.
Modify the CSS files: To get a bit more control over the look
and feel, you may choose to start with the default theme
(Smoothness) or a ThemeRoller-generated theme and then
adjust the ui.theme.css file or any of the individual plugin
stylesheets. For example, you could easily tweak the corner
radius for all buttons to be different than the rest of the UI
components or change the path for the icon sprite to use a
custom set. With a bit of style scoping, you can even use
multiple themes together in a single UI. To keep maintenance
simple, restricting changes to just the ui.theme.css file and
images is recommended.
Write completely custom CSS: For the greatest amount of
control, the CSS for each plugin can be written from scratch
without using the framework classes or plugin-specific
stylesheet. This may be necessary if the desired look and feel
can't be achieved by modifying the CSS or if highly customized
markup is used. This approach requires deep expertise in CSS
and will require manual updates for future plugins.

Using ThemeRoller and Themes
ThemeRoller application
ThemeRoller documentation - How to use the ThemeRoller
application

jQuery UI CSS Framework & Custom themes

jQuery UI CSS Framework documentation - Explore the full
class API and icon set
How to create custom themes - Tutorial for creating a theme
from scratch
Using jQuery UI ThemeRoller
jQuery UI CSS Framework API
How To Write a Theme
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Using jQuery UI ThemeRoller

About ThemeRoller
ThemeRoller is a web app that offers a fun and intuitive interface for
designing and downloading custom themes for jQuery UI. You can
find ThemeRoller in the "Themes" section of the jQuery UI site, or
by following this link: jQuery UI ThemeRoller

The ThemeRoller Interface
The interface for ThemeRoller is categorized into panels for global
font and corner radius settings, widget container styles, and
interaction states for clickable elements, and various styles for
overlays and shadows. These panels allow configuration of various
CSS properties such as font size, color, and weight, background
color and texture, border color, text color, icon color, corner radius,
and more!

The Theme Gallery: Pre-Rolled Themes
ThemeRoller themes can be viewed via permalink URLs, and it
includes a gallery of pre-designed themes to choose from. The
theme gallery is accessible through the tab strip located at the top
of the application interface. From the gallery, you can preview and
download themes, or even choose to tweak a theme further in the
"Roll Your Own" tab.

Downloading Themes

When you're done designing a theme, you can download it for use
in your projects. ThemeRoller has a "Download Theme" button at
the top which will generate a ZIP file containing all of theme assets.
Images included in your download will be generated to your
specifications and saved as high-quality PNG files.
Your theme will include images and CSS that make up a
customized version of the jQuery UI CSS Framework including
images and CSS for all of our plugins.

Installing downloaded themes into your
project
Once the theme has been downloaded and unzipped, you will see a
folder named themes . This folder contains the CSS and images
needed for your theme. Copy the theme directory into your project
and link to the themes/all.css file from your pages.

Building Custom "ThemeRoller-Ready"
Components

ThemeRoller generates a customized version of the jQuery UI CSS
Framework for developing your own ThemeRoller-Ready jQuery
components. The classes generated by this framework are
designed to accommodate common user interface design situations
and include states, icons, and various helper classes as well.
For information on developing with the jQuery UI CSS Framework,
visit our Theming API documentation.

ThemeRoller Links
Tutorial: Develop Your Own jQuery “ThemeRoller-Ready”
Components, Filament Group
Introducing ThemeRoller: Design & Download Custom Themes
for jQuery UI, Filament Group

Videos about Design & Download Custom Themes for jQuery
UI, Filament Group

Credits
ThemeRoller was designed and developed for jQuery UI by
Filament Group, Inc, of Boston, MA.
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jQuery UI CSS Framework API
Back to jQuery UI Theming

The jQuery UI CSS Framework
jQuery UI includes a robust CSS Framework designed for building
custom jQuery widgets. The framework includes classes that cover
a wide array of common user interface needs, and can be
manipulated using jQuery UI ThemeRoller. By building your UI
components using the jQuery UI CSS Framework, you will be
adopting shared markup conventions and allowing for ease of code
integration across the plugin community at large.

Framework Classes
The following CSS classes are split between ui.core.css and
ui.theme.css, depending on whether styles are fixed and structural,
or themeable (colors, fonts, backgrounds, etc) respectively. These
classes are designed to be applied to User Interface elements to
achieve visual consistency across an application and allow
components to be themeable by jQuery UI ThemeRoller.

Layout Helpers
.ui-helper-hidden :

Applies display: none to elements.

.ui-helper-hidden-accessible :

Applies accessible hiding to
elements (via abs positioning off the page)
.ui-helper-reset : A basic style reset for UI elements. Resets
things such as padding, margins, text-decoration, list-style, etc.
.ui-helper-clearfix : Applies float wrapping properties to
parent elements
.ui-helper-zfix : Applies iframe "fix" css to iframe elements
when needed in overlays.

Widget Containers

.ui-widget :

Class to be applied on outer container of all
widgets. Applies font family and font size to widget. Also
applies same family and 1em font size to child form elements
specifically, to combat inheritance issues in Win browsers.
.ui-widget-header :

Class to be applied to header containers.
Applies header container styles to an element and its child text,
links, and icons.
.ui-widget-content :

Class to be applied to content containers.
Applies content container styles to an element and its child
text, links, and icons. (can be applied to parent or sibling of
header)

Interaction States
.ui-state-default :

Class to be applied to clickable button-like
elements. Applies "clickable default" container styles to an
element and its child text, links, and icons.
.ui-state-hover : Class to be applied on mouseover to clickable
button-like elements. Applies "clickable hover" container styles
to an element and its child text, links, and icons.
.ui-state-focus : Class to be applied on keyboard focus to
clickable button-like elements. Applies "clickable hover"
container styles to an element and its child text, links, and
icons.
.ui-state-active :

Class to be applied on mousedown to
clickable button-like elements. Applies "clickable active"
container styles to an element and its child text, links, and
icons.

Interaction Cues
.ui-state-highlight : Class to be applied to highlighted or
selected elements. Applies "highlight" container styles to an
element and its child text, links, and icons.

Class to be applied to error messaging
container elements. Applies "error" container styles to an
element and its child text, links, and icons.
.ui-state-error-text: An additional class that applies just the
.ui-state-error:

error text color without background. Can be used on form
labels for instance. Also applies error icon color to child icons.
.ui-state-disabled: Applies a dimmed opacity to disabled UI
elements. Meant to be added in addition to an already-styled
element.
.ui-priority-primary: Class to be applied to a priority-1 button
in situations where button hierarchy is needed. Applies bold
text.
.ui-priority-secondary: Class to be applied to a priority-2
button in situations where button hierarchy is needed. Applies
normal weight text and slight transparency to element.

Icons
States and images
.ui-icon : Base class to be applied to an icon element. Sets
dimensions to 16px square block, hides inner text, sets
background image to "content" state sprite image. Note: .uiicon class will be given a different sprite background image
depending on its parent container. For example, a ui-icon
element within a ui-state-default container will get colored
according to the ui-state-default 's icon color.

Icon types
After declaring a .ui-icon class, you can follow up with a second
class describing the type of icon you'd like. Icon classes generally
follow a syntax of .ui-icon-{icon type}-{icon sub description}{direction} .
For example, a single triangle icon pointing to the right looks like
this: .ui-icon-triangle-1-e
jQuery UI's ThemeRoller provides the full set of CSS framework
icons in its preview column. Hover over them to see the class
name.

Misc Visuals

Corner Radius helpers
.ui-corner-tl :

Applies corner-radius to top left corner of

element.
.ui-corner-tr :

Applies corner-radius to top right corner of

element.
.ui-corner-bl :

Applies corner-radius to bottom left corner of

element.
.ui-corner-br :

Applies corner-radius to bottom right corner of

element.
.ui-corner-top :

Applies corner-radius to both top corners of

element.
.ui-corner-bottom :

Applies corner-radius to both bottom
corners of element.
.ui-corner-right :

Applies corner-radius to both right corners of

element.
.ui-corner-left :

Applies corner-radius to both left corners of

element.
.ui-corner-all :

Applies corner-radius to all 4 corners of

element.
Overlay & Shadow
.ui-widget-overlay :

Applies 100% wxh dimensions to an
overlay screen, along with background color/texture, and
screen opacity.
.ui-widget-shadow : Class to be applied to overlay widpacity,
top/left offsets and shadow "thickness". Thickness is applied
via padding to all sides of a shadow that is set to match the
dimensions of the overlay element. Offsets are applied via top
and left margins (can be positive or negative).
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How To Write a Theme
File Structure
Themes are meant to be structured in a specific manner (in order to
increase their ease of use). The general file directory structure is as
follows:
- Your theme should be completely contained within
a single directory (named the same as your theme).
themename/themename.css - This is your base CSS file. This file
will be included on every page that uses your theme,
regardless of which plugins are being used. (This file should be
very lightweight and only include the essentials.)
themename/themename.pluginname.css - You'll need one CSS file
for each plugin that you support. The name of the plugin should
be included directly in the filename (for example, if you themed
the tabs plugin, you would have: themename.tabs.js).
themename/img.png - Your theme can include images, if need be.
They can be named whatever you'd like (there is no, particular,
naming convention for these).
themename/

For examples of how theme file structures are done, feel free to
look through the only completed theme so far: http://jqueryui.googlecode.com/svn/trunk/themes/flora/

Styling
Writing styles for themes is rather simplistic - which is good, as it
allows for a great amount of flexibility.
All themes should have a base CSS class to work off of. This main
class allows the user to enable, and switch between, themes. Your
root class should be of the format .ui-themename . And it will be used
like so, within a user's HTML file:
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<html>
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<head>
<title>My Site</title>
<link rel="stylesheet" href="themename/themename.css"
<link rel="stylesheet" href="othertheme/othertheme.cs
<link rel="stylesheet" href="othertheme/othertheme.di
</head>
<body class="ui-themename">
...
<div class="ui-othertheme">
<div class="ui-dialog">... modal dialog ...
</div>
</body>
</html>

In the above example, a couple important things are occurring:
We're loading two themes into a document at the same time.
The whole page, and all of its contents, are themed according
to themename's styling.
However, the div with the class of ui-othertheme, and
everything inside of it (including the modal dialog), is themed
according to othertheme's styling rules.
If we were to take a look inside
something like the following:
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themename.css

we might see

body.ui-themename { background:#111; color:snow;
.ui-themename a, a.ui-themename { color:#68D; outline
.ui-themename a:visited, a.ui-themename:visited
.ui-themename a:hover, a.ui-themename:hover { color

If you'll notice, the themename.css file only contains styling
information that is globally applicable (nothing plugin-specific is

contained within here). This will be true for all cases where a theme
is built. Don't worry about a theme taking up multiple files - that will
be simplified within the build and download process.
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Widget Factory
The jQuery UI Widget Factory is an extensible base on which all of
jQuery UI's widgets are built. Using the widget factory to build a
plugin provides conveniences for state management, as well as
conventions for common tasks like exposing plugin methods and
changing options after instantiation.
Why Use the Widget Factory
How To Use the Widget Factory

Why Use the Widget Factory
Writing jQuery plugins is as simple as adding a method to
jQuery.prototype (more commonly seen as $.fn ) and following
some simple conventions like returning this for chainability. So
why does the widget factory exist? And why is it hundreds of lines
of code?
In this document, we'll walk through the benefits of the widget
factory and find out when and why it makes sense to use it.

Stateless vs. Stateful Plugins
Most jQuery plugins are stateless; they perform some action and
their job is done. For example, if you set the text of an element
using .text( "hello" ) , there is no setup phase and the result is
always the same. For these types of plugins, it makes sense to just
extend jQuery's prototype.
However, some plugins are stateful; they have full life cycles,
maintain state, and react to changes. These plugins require a lot of
code dedicated to initialization and state management (and
sometimes destruction). This results in a lot of boilerplate for
building stateful plugins. Even worse, each plugin author may
manage life cycles and state differently, resulting in different API
styles for different plugins. The widget factory aims to solve both
problems, removing the boilerplate and creating a consistent API
across plugins.

Consistent API
The widget factory defines how to create and destroy widgets, get
and set options, invoke methods, and listen to events triggered by
the widget. By using the widget factory to build your stateful plugins,
you are automatically conforming to a defined standard, making it
easier for new users to start using your plugins. In addition to
defining the interface, the widget factory also implements much of
this functionality for you. If you're not familiar with the API provided
by the widget factory, you should read How jQuery UI Works.
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Setting Options on Initialization
Whenever you build a plugin that accepts options, you should
define defaults for as many options as possible, then merge the
user-provided options with the defaults on initialization. It's also a
good idea to expose the defaults so that users can even change the
default values. A common pattern in jQuery plugins looks like this:
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$.fn.plugin = function( options ) {
options = $.extend( {}, $.fn.plugin.defaults, optio
// plugin logic goes here
};
$.fn.plugin.defaults = {
param1: "foo",
param2: "bar",
param3: "baz"
};

The widget factory provides this functionality and even takes it a bit
further. Let's see what this looks like with the widget factory.
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$.widget( "ns.plugin", {
// default options
options: {
param1: "foo",
param2: "bar",
param3: "baz"
},

_create: function() {
// options are already merged and stored in this.
// plugin logic goes here
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}
});

How To Use the Widget Factory
To start, we’ll create a progress bar that just lets us set the progress
once. As we can see below, this is done by calling jQuery.widget
with two parameters: the name of the plugin to create and an object
literal containing functions to support our plugin. When our plugin
gets called, it will create a new plugin instance and all functions will
be executed within the context of that instance. This is different
from a standard jQuery plugin in two important ways. First, the
context is an object, not a DOM element. Second, the context is
always a single object, never a collection.
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$.widget( "custom.progressbar", {
_create: function() {
var progress = this.options.value +
this.element
.addClass( "progressbar" )
.text( progress );
}
});

The name of the plugin must contain a namespace, in this case
we’ve used the custom namespace. There is currently a limitation
that exactly one namespace must be used. We can also see that
the widget factory has provided two properties for us. this.element
is a jQuery object containing exactly one element. If our plugin is
called on a jQuery object containing multiple elements, a separate
plugin instance will be created for each element, and each instance
will have its own this.element . The second property, this.options ,
is a hash containing key/value pairs for all of our plugin’s options.
These options can be passed to our plugin as shown here.
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$( "<div></div>" )
.appendTo( "body" )
.progressbar({ value: 20 });

When we call jQuery.widget it extends jQuery by adding a function
to jQuery.fn (the system for creating a standard plugin). The name
of the function it adds is based on the name you pass to
jQuery.widget , without the namespace; in our case “progressbar”.
The options passed to our plugin are the values that get set in
this.options inside of our plugin instance. As shown below, we can
specify default values for any of our options. When designing your
API, you should figure out the most common use case for your
plugin so that you can set appropriate default values and make all
options truly optional.
1
2
3
4
5
6
7
8
9
10
11
12

$.widget( "custom.progressbar", {
// default options
options: {
value: 0
},
_create: function() {
var progress = this.options.value +
this.element
.addClass( "progressbar" )
.text( progress );
}
});

Calling plugin methods
Now that we can initialize our progress bar, we’ll add the ability to
perform actions by calling methods on our plugin instance. To
define a plugin method, we just include the function in the object
literal that we pass to jQuery.widget . We can also define “private”
methods by prepending an underscore to the function name.
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$.widget( "custom.progressbar", {
options: {
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value: 0

},
_create: function() {
var progress = this.options.value +
this.element
.addClass( "progressbar" )
.text( progress );
},
// create a public method
value: function( value ) {
// no value passed, act as a getter
if ( value === undefined ) {
return this.options.value;
// value passed, act as a setter
} else {
this.options.value = this._constrain( v
var progress = this.options.value +
this.element.text( progress );
}
},
// create a private method
_constrain: function( value ) {
if ( value > 100 ) {
value = 100;
}
if ( value < 0 ) {
value = 0;
}
return value;
}
});

To call a method on a plugin instance, you pass the name of the
method to the jQuery plugin. If you are calling a method that
accepts parameters, you simply pass those parameters after the
method name.

Note: Executing methods by passing the method name to the same
jQuery function that was used to initialize the plugin may seem odd.
This is done to prevent pollution of the jQuery namespace while
maintaining the ability to chain method calls. Later in this article
we’ll see alternative uses that may feel more natural.
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var bar = $( "<div></div>" )
.appendTo( "body" )
.progressbar({ value: 20 });
// get the current value
alert( bar.progressbar( "value" ) );
// update the value
bar.progressbar( "value", 50 );
// get the current value again
alert( bar.progressbar( "value" ) );

Working with options
One of the methods that are automatically available to our plugin is
the option method. The option method allows you to get and set
options after initialization. This method works exactly like jQuery’s
css and attr methods: you can pass just a name to use it as a
getter, a name and value to use it as a single setter, or a hash of
name/value pairs to set multiple values. When used as a getter, the
plugin will return the current value of the option that corresponds to
the name that was passed in. When used as a setter, the plugin’s
_setOption method will be called for each option that is being set.
We can specify a _setOption method in our plugin to react to option
changes. For actions to perform independent of the number of
options changed, we can override _setOptions .
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$.widget( "custom.progressbar", {
options: {
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value: 0
},
_create: function() {
this.element.addClass( "progressbar"
this.refresh();
},
_setOption: function( key, value ) {
if ( key === "value" ) {
value = this._constrain( value );
}
this._super( key, value );
},
_setOptions: function( options ) {
this._super( options );
this.refresh();
},
refresh: function() {
var progress = this.options.value +
this.element.text( progress );
},
_constrain: function( value ) {
if ( value > 100 ) {
value = 100;
}
if ( value < 0 ) {
value = 0;
}
return value;
}
});

Adding callbacks
One of the easiest ways to make your plugin extensible is to add
callbacks so users can react when the state of your plugin changes.
We can see below how to add a callback to our progress bar to

signify when the progress has reached 100%. The _trigger method
takes three parameters: the name of the callback, a jQuery event
object that initiated the callback, and a hash of data relevant to the
event. The callback name is the only required parameter, but the
others can be very useful for users who want to implement custom
functionality on top of your plugin. For example, if we were building
a draggable plugin, we could pass the mousemove event when
triggering a drag callback; this would allow users to react to the
drag based on the x/y coordinates provided by the event object.
Note that the original event passed to _trigger must be a jQuery
event, not a native browser event.
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$.widget( "custom.progressbar", {
options: {
value: 0
},
_create: function() {
this.element.addClass( "progressbar"
this.refresh();
},
_setOption: function( key, value ) {
if ( key === "value" ) {
value = this._constrain( value );
}
this._super( key, value );
},
_setOptions: function( options ) {
this._super( options );
this.refresh();
},
refresh: function() {
var progress = this.options.value +
this.element.text( progress );
if ( this.options.value == 100 ) {
this._trigger( "complete", null
}
},
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_constrain: function( value ) {
if ( value > 100 ) {
value = 100;
}
if ( value < 0 ) {
value = 0;
}
return value;
}
});

Callback functions are essentially just additional options, so you
can get and set them just like any other option. Whenever a
callback is executed, a corresponding event is triggered as well.
The event type is determined by concatenating the plugin name
and the callback name. The callback and event both receive the
same two parameters: an event object and a hash of data relevant
to the event, as we’ll see below. Your plugin may have functionality
that you want to allow the user to prevent. The best way to support
this is by creating cancelable callbacks. User’s can cancel a
callback, or its associated event, the same way they cancel any
native event, by calling event.preventDefault() or returning false. If
the user cancels the callback, the _trigger method will return false
so you can implement the appropriate functionality within your
plugin.
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var bar = $( "<div></div>" )
.appendTo( "body" )
.progressbar({
complete: function( event, data ) {
alert( "Callbacks are great!" );
}
})
.bind( "progressbarcomplete", function
alert( "Events bubble and support many hand
alert( "The progress bar value is "
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});
bar.progressbar( "option", "value", 100 );

Looking under the hood
Now that we’ve seen how to build a plugin using the widget factory,
let’s take a look at how it actually works. When you call
jQuery.widget , it creates a constructor for your plugin and sets the
object literal that you pass in as the prototype for your plugin
instances. All of the functionality that automatically gets added to
your plugin comes from a base widget prototype, which is defined
as jQuery.Widget.prototype . When a plugin instance is created, it is
stored on the original DOM element using jQuery.data , with the
plugin name as the key.
Because the plugin instance is directly linked to the DOM element,
you can access the plugin instance directly instead of going through
the exposed plugin method if you want. This will allow you to call
methods directly on the plugin instance instead of passing method
names as strings and will also give you direct access to the plugin’s
properties.
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var bar = $( "<div></div>" )
.appendTo( "body" )
.progressbar()
.data( "progressbar" );
// call a method directly on the plugin instance
bar.option( "value", 50 );
// access properties on the plugin instance
alert( bar.options.value );

You can also create an instance without going through the plugin
method, by calling the constructor directly, with the options and
element arguments:
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var bar = $.custom.progressbar( {}, $( "<div></div>"
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// same result as before
alert( bar.options.value );

Extending a plugin’s prototype
One of the biggest benefits of having a constructor and prototype
for a plugin is the ease of extending the plugin. By adding or
modifying methods on the plugin’s prototype, we can modify the
behavior of all instances of our plugin. For example, if we wanted to
add a method to our progress bar to reset the progress to 0% we
could add this method to the prototype and it would instantly be
available to be called on any plugin instance.
$.custom.progressbar.prototype.reset = function
this._setOption( "value", 0 );
};
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Cleaning up
In some cases, it will make sense to allow users to apply and then
later unapply your plugin. You can accomplish this via the _destroy
method. Within the _destroy method, you should undo anything
your plugin may have done during initialization or later use.
_destroy is called by the destroy method, which is automatically
called if the element that your plugin instance is tied to is removed
from the DOM, so this can be used for garbage collection as well.
That base destroy method also handles some general cleanup
operations, like removing the instance reference from the widget's
DOM element, unbinding all events in the widget's namespace from
the element, and unbinding generally all events that were added
using _bind .
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$.widget( "custom.progressbar", {
options: {
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value: 0
},
_create: function() {
this.element.addClass( "progressbar"
this.refresh();
},
_setOption: function( key, value ) {
if ( key === "value" ) {
value = this._constrain( value );
}
this._super( key, value );
},
_setOptions: function( options ) {
this._super( options );
this.refresh();
},
refresh: function() {
var progress = this.options.value +
this.element.text( progress );
if ( this.options.value == 100 ) {
this._trigger( "complete", null
}
},
_constrain: function( value ) {
if ( value > 100 ) {
value = 100;
}
if ( value < 0 ) {
value = 0;
}
return value;
},
_destroy: function() {
this.element
.removeClass( "progressbar" )
.text( "" );
}
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});

POWERED BY HERONOTE

Closing comments
The widget factory is only one way of creating stateful plugins.
There are a few different models that can be used and each have
their own advantages and disadvantages. The widget factory solves
lots of common problems for you and can greatly improve
productivity, it also greatly improves code reuse, making it a great fit
for jQuery UI as well as many other stateful plugins.
You may have noticed that in this article we used the custom
namespace. The ui namespace is reserved for official jQuery UI
plugins. When building your own plugins, you should create your
own namespace. This makes it clear where the plugin came from
and if it is part of a larger collection.
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jQuery Mobile
jQuery Mobile is the easiest way to build sites and apps that are
accessible on all popular smartphone, tablet and desktop devices.
This frameworks provides a set of touch-friendly UI widgets and an
AJAX-powered navigation system to support animated page
transitions.
Getting Started with jQuery Mobile
Creating a custom theme with ThemeRoller

Getting Started with jQuery
Mobile
jQuery Mobile provides a set of touch-friendly UI widgets and an
AJAX-powered navigation system to support animated page
transitions. This guide will show you how you can build your first
jQuery Mobile application.
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Create a basic page template
To get started, you can simply paste the template below in your
favorite text editor, save and open the document in a browser.
In the head of this template, a meta viewport tag sets the screen
width to the pixel width of the device. References to jQuery, jQuery
Mobile and the mobile theme stylesheet from the CDN add all the
styles and scripts. jQuery Mobile 1.2 (1.2.0) works with versions of
jQuery core from 1.7.0 to 1.8.2.
In the body , a div with a data-role of page is the wrapper used to
delineate a page. A header bar ( data-role="header" ), a content
region ( data-role="content" ) and a footer bar ( data-role="footer" )
are added inside to create a basic page (all three are optional).
These data- attributes are HTML5 attributes used throughout
jQuery Mobile to transform basic markup into an enhanced and
styled widget.
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<!DOCTYPE html>
<html>
<head>
<title>My Page</title>
<meta name="viewport" content="width=device-width,
<link rel="stylesheet" href="http://code.jquery.com
<script src="http://code.jquery.com/jquery-1.8.2.mi
<script src="http://code.jquery.com/mobile/1.2.0/jq
</head>
<body>
<div data-role="page">
<div data-role="header">
<h1>My Title</h1>
</div><!-- /header -->
<div data-role="content">
<p>Hello world</p>
</div><!-- /content -->
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<div data-role="footer">
<h4>My Footer</h4>
</div><!-- /header -->
</div><!-- /page -->
</body>
</html>

Add content
The next step is to add content inside the content container. Any
standard HTML elements - headings, lists, paragraphs, etc can be
added. You can write your own custom styles to create custom
layouts by adding an additional stylesheet to the head after the
jQuery Mobile stylesheet.

Make a listview
jQuery Mobile includes a diverse set of common listviews that are
coded as lists with a data-role="listview" added. Here is a simple
linked list that has a role of listview . The data-inset="true"
attribute makes the listview look like an inset module, while datafilter="true" adds a dynamic search filter.
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<ul data-role="listview" data-inset="true" data-filter
<li><a href="#">Acura</a></li>
<li><a href="#">Audi</a></li>
<li><a href="#">BMW</a></li>
<li><a href="#">Cadillac</a></li>
<li><a href="#">Ferrari</a></li>
</ul>

Add a slider
The framework contains a full set of form elements that
automatically are enhanced into touch-friendly styled widgets.
Here's a slider made with the new HTML5 input type of range, no
data-role needed. All form elements must always be properly
associated with a label and the group of form elements be
wrapped in a form tag.
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<form>
<label for="slider-0">Input slider:</label>
<input type="range" name="slider" id="slider-0"
</form>

Make a button
There are a few ways to make buttons. A common one is to turn a
link into a button so it's easy to click. Just start with a link and add a
data-role="button" attribute to it. You can add an icon with the
data-icon attribute and optionally set its position with the dataiconpos attribute.
1

<a href="#" data-role="button" data-icon="star"

Choose a theme swatch
jQuery Mobile has a robust theme framework that supports up to 26
sets of toolbar, content and button colors, called a "swatch". You
can add a data-theme="e" attribute to any of the widgets on this
page: page, header, list, input for the slider, or button to turn it
yellow. Different swatch letters in default theme from a-e can be
used to mix and match swatches.
If you add the theme swatch to the page, all the widgets inside the

content will automatically inherit the theme (headers and footers
don't inherit and default to swatch "a").
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<a href="#" data-role="button" data-icon="star"

If you would like to create a custom theme, you can use
ThemeRoller that allows users to create their own theme through
an easy to use drag and drop interface. You will then be able to
download and use your newly created theme.

Go forth and build something
This guide has provided you with a basic structure for a jQuery
Mobile page and a few enhanced elements. You can explore the full
jQuery Mobile documentation to learn about linking pages, adding
animated page transitions, and creating dialogs and popups.
If you're more of the type who prefers actually writing JavaScript to
build your apps, and you don't want to use the data- attribute
configuration system, you can take full control of everything and call
plugins directly as these are all standard jQuery plugins built with
the UI widget factory. Particularly useful information for such cases
can be found in the global configuration, events, and methods
sections.
Finally, you can read up on scripting pages, generating dynamic
pages, and building PhoneGap apps.

Creating a custom theme with
ThemeRoller

Theming Overview
jQuery Mobile has a robust theme framework that supports up to 26
sets of toolbar, content and button colors, called a "swatch". The
framework comes with five defined themes (swatches 'a' to 'e')
which can be used readily, removed or overwritten.

Default theme swatch mapping for
components
If no theme swatch letter is set at all, the framework uses the 'a'
swatch (black in the default theme) for headers and footers and the
'c' swatch (light gray in the default theme) for the page content to
maximize contrast between the both.
All items in containers inherit the swatch from their parent.
Exceptions to this rule are the listdivider in listviews, the header of
nested list pages, and the button of split button lists, which all
default to 'b' (blue in the default theme). Count bubbles default to 'c'
(silver in the default theme).
Note that there is also a swatch named "active" (bright blue in the
default theme) which is used to indicate an active selected item.
See the Global "Active" state further down this page for further
information on the active swatch.
The page loading dialog and error message don't inherit a swatch
theme. The loading dialog defaults to swatch 'a' (black in the default
theme) and the error message to swatch 'e' (yellow in the default
theme). You can configure those defaults globally.

Themes and swatches
The theme system separates color and texture from structural
styles that define things like padding and dimensions. This allows
theme colors and textures to be defined once in the stylesheet and
to be mixed, matched, and combined to achieve a wide range of
visual effects.
Each theme includes several global settings, including font family,

drop shadows for overlays, and corner radius values for buttons
and boxes. In addition, the theme can include multiple color
swatches, each with color values for bars, content blocks, buttons
and list items, and font text-shadow.
The default theme includes 5 swatches that are given letters (a, b,
c, d, e) for quick reference. To make mapping of color swatches
consistent across our widgets, we have followed the convention
that swatch 'a' is the highest level of visual priority (black in our
default theme), 'b' is secondary level (blue) and 'c' is the baseline
level (gray) that we use by default in many situations, 'd' for an
alternate secondary level and 'e' as an accent swatch. Themes may
have additional swatches for accent colors or specific situations.
For example, you could add a new theme swatch 'f' that has a red
bar and button for use in error situations.
Most theme changes can be done using ThemeRoller, but it is also
fairly simple to manually edit the base swatches in the default
theme and/or add additional swatches by editing the theme CSS
file. Just copy a block of swatch styles, rename the classes with the
new swatch letter name, and tweak colors as you see fit.

POWERED BY HERONOTE

Creating a Custom Theme with ThemeRoller

The easiest way to create custom themes is with the ThemeRoller
tool. It allows you to build a theme composed of up to 26 swatches,
download a the newly created CSS file, and use it in your project.

Creating the Theme swatches
The ThemeRoller allows users to create their own theme through
an easy to use drag and drop interface. By default, ThemeRoller
offers three swatches (a, b and c). You can use the offered default
colors, the Adobe kuler colors, or create your own. You will create
your theme by dragging the chosen color onto the chosen element
in the swatch of your choice. You can add more swatches by
pressing the '+' sign near the 'A', 'B', and 'C' tabs, in the left handside menu.
You can further edit your swatch from the menu. For example, you
can expand the various element parts and carry out detailed
editing. For example, this will allow you to text color, text shadow
size, position and color, etc. You can also edit the gradient used on
each element.
Here are two examples of theme swatches created, the first one
with the default colors and with the kuler colors:

Downloading the created Theme
Once you are satisfied with the various swatches that you have
created in your theme, you can download this theme to be able to
start using it in your project. You will simply need to press the
'Download theme zip file button', and enter the name of your theme
in the popup window. Then, press the 'Download Zip' button on the
download popup window, see below:

Using the downloaded Theme
The theme gets downloaded on your local machine as a zip file.
This contains an index.html file, and a themes folder. The
index.html file is an example of how you can now se your theme.
The themes folder contains your theme CSS files, and the icons that
are used by jQuery Mobile.
To start using your theme, you can either start from the provided
index.html or start from scratch. As explained in the theme
download popup window, all you need is to add your theme to the
head of your page before the jquery.mobile.structure file, like this:
1
2
3
4
5
6
7
8
9
10
11

<!DOCTYPE html>
<html>
<head>

<title>jQuery Mobile page</title>
<meta charset="utf-8" />
<meta name="viewport" content="width=device-width, in
<link rel="stylesheet" href="css/themes/my-custom-the
<link rel="stylesheet" href="http://code.jquery.com/m
<script src="http://code.jquery.com/jquery-1.8.2.min.
<script src="http://code.jquery.com/mobile/1.2.0/jque

12
13

</head>

Final Note
You need to be aware that jQuery Mobile will default to certain
swatches when none are specified. For example, page content will
default to swatch 'c', list dividers to swatch 'b', etc. As the full jQuery
Mobile CSS is replaced by your custom theme CSS and the jQuery
Mobile structure CSS, the only swatches available are the ones that
you have provided as part of your custom theme. Therefore, you
need to either always specify a swatch letter for all your elements or
their parent using for example the data-theme attribute, or you will
need to provide a swatch in your custom theme for the possible
defaults. Additionally, the error messages use the swatch 'e', so this
should also be specified in your theme.

jQuery API
Traversing > Miscellaneous Traversing

.add()
Add elements to the set of matched elements.
Traversing > Miscellaneous Traversing

.addBack()
Add the previous set of elements on the stack to the current set,
optionally filtered by a selector.
Attributes | Manipulation > Class Attribute | CSS

.addClass()
Adds the specified class(es) to each of the set of matched
elements.
Manipulation > DOM Insertion, Outside

.after()
Insert content, specified by the parameter, after each element in
the set of matched elements.
Ajax > Global Ajax Event Handlers

.ajaxComplete()
Register a handler to be called when Ajax requests complete. This
is an AjaxEvent.
Ajax > Global Ajax Event Handlers

.ajaxError()
Register a handler to be called when Ajax requests complete with
an error. This is an Ajax Event.
Ajax > Global Ajax Event Handlers

.ajaxSend()
Attach a function to be executed before an Ajax request is sent.
This is an Ajax Event.
Ajax > Global Ajax Event Handlers

.ajaxStart()
Register a handler to be called when the first Ajax request begins.
This is an Ajax Event.
Ajax > Global Ajax Event Handlers

.ajaxStop()
Register a handler to be called when all Ajax requests have
completed. This is an Ajax Event.
Ajax > Global Ajax Event Handlers

.ajaxSuccess()
Attach a function to be executed whenever an Ajax request
completes successfully. This is an Ajax Event.
Selectors > Basic

All Selector (“*”)
Selects all elements.
Traversing > Miscellaneous Traversing

.andSelf()
Add the previous set of elements on the stack to the current set.
Effects > Custom

.animate()
Perform a custom animation of a set of CSS properties.
Selectors > Basic Filter | Selectors > jQuery Extensions

:animated Selector
Select all elements that are in the progress of an animation at the
time the selector is run.
Manipulation > DOM Insertion, Inside

.append()
Insert content, specified by the parameter, to the end of each
element in the set of matched elements.
Manipulation > DOM Insertion, Inside

.appendTo()
Insert every element in the set of matched elements to the end of
the target.
Attributes | Manipulation > General Attributes

.attr()
Get the value of an attribute for the first element in the set of
matched elements or set one or more attributes for every matched
element.
Selectors > Attribute

Attribute Contains Prefix Selector
[name|="value"]
Selects elements that have the specified attribute with a value
either equal to a given string or starting with that string followed by
a hyphen (-).
Selectors > Attribute

Attribute Contains Selector [name*="value"]
Selects elements that have the specified attribute with a value
containing the a given substring.
Selectors > Attribute

Attribute Contains Word Selector
[name~="value"]
Selects elements that have the specified attribute with a value
containing a given word, delimited by spaces.
Selectors > Attribute

Attribute Ends With Selector
[name$="value"]
Selects elements that have the specified attribute with a value
ending exactly with a given string. The comparison is case
sensitive.
Selectors > Attribute

Attribute Equals Selector [name="value"]
Selects elements that have the specified attribute with a value
exactly equal to a certain value.
Selectors > Attribute | Selectors > jQuery Extensions

Attribute Not Equal Selector
[name!="value"]
Select elements that either don’t have the specified attribute, or do
have the specified attribute but not with a certain value.
Selectors > Attribute

Attribute Starts With Selector
[name^="value"]
Selects elements that have the specified attribute with a value
beginning exactly with a given string.
Manipulation > DOM Insertion, Outside

.before()
Insert content, specified by the parameter, before each element in
the set of matched elements.
Events > Event Handler Attachment

.bind()
Attach a handler to an event for the elements.
Events > Form Events | Forms

.blur()
Bind an event handler to the “blur” JavaScript event, or trigger that
event on an element.
Selectors > Form | Selectors > jQuery Extensions

:button Selector
Selects all button elements and elements of type button.
Callbacks Object

callbacks.add()
Add a callback or a collection of callbacks to a callback list.
Callbacks Object

callbacks.disable()
Disable a callback list from doing anything more.
Callbacks Object

callbacks.disabled()
Determine if the callbacks list has been disabled.
Callbacks Object

callbacks.empty()
Remove all of the callbacks from a list.
Callbacks Object

callbacks.fire()
Call all of the callbacks with the given arguments
Callbacks Object

callbacks.fired()
Determine if the callbacks have already been called at least once.
Callbacks Object

callbacks.fireWith()
Call all callbacks in a list with the given context and arguments.
Callbacks Object

callbacks.has()
Determine whether a supplied callback is in a list
Callbacks Object

callbacks.lock()
Lock a callback list in its current state.
Callbacks Object

callbacks.locked()
Determine if the callbacks list has been locked.
Callbacks Object

callbacks.remove()
Remove a callback or a collection of callbacks from a callback list.
Events > Form Events | Forms

.change()
Bind an event handler to the “change” JavaScript event, or trigger
that event on an element.
Selectors > Form | Selectors > jQuery Extensions

:checkbox Selector
Selects all elements of type checkbox.
Selectors > Form

:checked Selector
Matches all elements that are checked.
Selectors > Hierarchy

child”)" href="0D4EEA27BD.htm"
rel=bookmark>Child Selector (“parent >
child”)
Selects all direct child elements specified by “child” of elements
specified by “parent”.
Traversing > Tree Traversal

.children()
Get the children of each element in the set of matched elements,
optionally filtered by a selector.
Selectors > Basic

Class Selector (“.class”)
Selects all elements with the given class.
Effects > Custom | Data | Utilities

.clearQueue()
Remove from the queue all items that have not yet been run.
Events > Mouse Events

.click()
Bind an event handler to the “click” JavaScript event, or trigger
that event on an element.
Manipulation > Copying

.clone()
Create a deep copy of the set of matched elements.
Traversing > Tree Traversal

.closest()
For each element in the set, get the first element that matches the
selector by testing the element itself and traversing up through its
ancestors in the DOM tree.
Selectors > Content Filter

:contains() Selector
Select all elements that contain the specified text.
Traversing > Miscellaneous Traversing

.contents()
Get the children of each element in the set of matched elements,
including text and comment nodes.
Internals | Properties > Properties of jQuery Object Instances

.context
The DOM node context originally passed to jQuery(); if none was
passed then context will likely be the document.
CSS | Manipulation > Style Properties

.css()
Get the value of a style property for the first element in the set of
matched elements or set one or more CSS properties for every
matched element.
Data | Miscellaneous > Data Storage

.data()
Store arbitrary data associated with the matched elements or
return the value at the named data store for the first element in the
set of matched elements.
Events > Mouse Events

.dblclick()
Bind an event handler to the “dblclick” JavaScript event, or trigger
that event on an element.
Deferred Object

deferred.always()
Add handlers to be called when the Deferred object is either
resolved or rejected.
Deferred Object

deferred.done()
Add handlers to be called when the Deferred object is resolved.
Deferred Object

deferred.fail()
Add handlers to be called when the Deferred object is rejected.
Deferred Object

deferred.isRejected()
Determine whether a Deferred object has been rejected.
Deferred Object

deferred.isResolved()
Determine whether a Deferred object has been resolved.
Deferred Object

deferred.notify()
Call the progressCallbacks on a Deferred object with the given
args.
Deferred Object

deferred.notifyWith()
Call the progressCallbacks on a Deferred object with the given
context and args.
Deferred Object

deferred.pipe()
Utility method to filter and/or chain Deferreds.
Deferred Object

deferred.progress()
Add handlers to be called when the Deferred object generates
progress notifications.
Deferred Object

deferred.promise()
Return a Deferred’s Promise object.
Deferred Object

deferred.reject()
Reject a Deferred object and call any failCallbacks with the given
args.
Deferred Object

deferred.rejectWith()
Reject a Deferred object and call any failCallbacks with the given
context and args.
Deferred Object

deferred.resolve()
Resolve a Deferred object and call any doneCallbacks with the
given args.
Deferred Object

deferred.resolveWith()
Resolve a Deferred object and call any doneCallbacks with the
given context and args.
Deferred Object

deferred.state()
Determine the current state of a Deferred object.
Deferred Object

deferred.then()
Add handlers to be called when the Deferred object is resolved,
rejected, or still in progress.
Effects > Custom

.delay()
Set a timer to delay execution of subsequent items in the queue.
Events > Event Handler Attachment

.delegate()
Attach a handler to one or more events for all elements that match
the selector, now or in the future, based on a specific set of root
elements.
Effects > Custom | Data | Utilities

.dequeue()
Execute the next function on the queue for the matched elements.
Selectors > Hierarchy

Descendant Selector (“ancestor
descendant”)
Selects all elements that are descendants of a given ancestor.
Manipulation > DOM Removal

.detach()
Remove the set of matched elements from the DOM.
Events > Event Handler Attachment

.die()
Remove event handlers previously attached using .live() from the
elements.
Selectors > Form

:disabled Selector
Selects all elements that are disabled.
Miscellaneous > Collection Manipulation | Traversing

.each()
Iterate over a jQuery object, executing a function for each
matched element.
Selectors > Basic

Element Selector (“element”)
Selects all elements with the given tag name.
Manipulation > DOM Removal

.empty()
Remove all child nodes of the set of matched elements from the
DOM.
Selectors > Content Filter

:empty Selector
Select all elements that have no children (including text nodes).
Selectors > Form

:enabled Selector
Selects all elements that are enabled.
Traversing > Miscellaneous Traversing

.end()
End the most recent filtering operation in the current chain and
return the set of matched elements to its previous state.
Traversing > Filtering

.eq()
Reduce the set of matched elements to the one at the specified
index.
Selectors > Basic Filter | Selectors > jQuery Extensions

:eq() Selector
Select the element at index n within the matched set.
Events > Browser Events

.error()
Bind an event handler to the “error” JavaScript event.
Selectors > Basic Filter | Selectors > jQuery Extensions

:even Selector
Selects even elements, zero-indexed. See also odd.
Events > Event Object

event.currentTarget
The current DOM element within the event bubbling phase.
Events > Event Object

event.data
An optional object of data passed to an event method when the
current executing handler is bound.
Events > Event Object | Events

event.delegateTarget
The element where the currently-called jQuery event handler was
attached.
Events > Event Object

event.isDefaultPrevented()
Returns whether event.preventDefault() was ever called on this
event object.
Events > Event Object

event.isImmediatePropagationStopped()
Returns whether event.stopImmediatePropagation() was ever
called on this event object.
Events > Event Object

event.isPropagationStopped()
Returns whether event.stopPropagation() was ever called on this
event object.
Events > Event Object

event.metaKey
Indicates whether the META key was pressed when the event
fired.
Events > Event Object

event.namespace
The namespace specified when the event was triggered.
Events > Event Object

event.pageX
The mouse position relative to the left edge of the document.
Events > Event Object

event.pageY
The mouse position relative to the top edge of the document.
Events > Event Object

event.preventDefault()
If this method is called, the default action of the event will not be
triggered.
Events > Event Object

event.relatedTarget
The other DOM element involved in the event, if any.
Events > Event Object

event.result
The last value returned by an event handler that was triggered by
this event, unless the value was undefined.
Events > Event Object

event.stopImmediatePropagation()
Keeps the rest of the handlers from being executed and prevents
the event from bubbling up the DOM tree.
Events > Event Object

event.stopPropagation()
Prevents the event from bubbling up the DOM tree, preventing
any parent handlers from being notified of the event.
Events > Event Object

event.target
The DOM element that initiated the event.
Events > Event Object

event.timeStamp
The difference in milliseconds between the time the browser
created the event and January 1, 1970.
Events > Event Object

event.type
Describes the nature of the event.
Events > Event Object

event.which
For key or mouse events, this property indicates the specific key
or button that was pressed.
Effects > Fading

.fadeIn()
Display the matched elements by fading them to opaque.
Effects > Fading

.fadeOut()
Hide the matched elements by fading them to transparent.
Effects > Fading

.fadeTo()
Adjust the opacity of the matched elements.
Effects | Effects > Fading

.fadeToggle()
Display or hide the matched elements by animating their opacity.
Selectors > Form | Selectors > jQuery Extensions

:file Selector
Selects all elements of type file.
Traversing > Filtering

.filter()
Reduce the set of matched elements to those that match the
selector or pass the function’s test.
Traversing > Tree Traversal

.find()
Get the descendants of each element in the current set of
matched elements, filtered by a selector, jQuery object, or
element.
Effects > Custom

.finish()
Stop the currently-running animation, remove all queued
animations, and complete all animations for the matched
elements.
Traversing > Filtering

.first()
Reduce the set of matched elements to the first in the set.
Selectors > Child Filter

:first-child Selector
Selects all elements that are the first child of their parent.
Selectors > Child Filter

:first-of-type Selector
Selects all elements that are the first among siblings of the same
element name.
Selectors > Basic Filter | Selectors > jQuery Extensions

:first Selector
Selects the first matched element.
Events > Form Events | Forms

.focus()
Bind an event handler to the “focus” JavaScript event, or trigger
that event on an element.
Selectors > Basic Filter | Selectors > Form

:focus Selector
Selects element if it is currently focused.
Events > Keyboard Events | Events > Mouse Events

.focusin()
Bind an event handler to the “focusin” event.
Events > Keyboard Events | Events > Mouse Events

.focusout()
Bind an event handler to the “focusout” JavaScript event.
Miscellaneous > DOM Element Methods

.get()
Retrieve the DOM elements matched by the jQuery object.
Selectors > Basic Filter | Selectors > jQuery Extensions

:gt() Selector
Select all elements at an index greater than index within the
matched set.
Traversing > Filtering

.has()
Reduce the set of matched elements to those that have a
descendant that matches the selector or DOM element.
Selectors > Attribute

Has Attribute Selector [name]
Selects elements that have the specified attribute, with any value.
Selectors > Content Filter | Selectors > jQuery Extensions

:has() Selector
Selects elements which contain at least one element that matches
the specified selector.
Attributes | Manipulation > Class Attribute | CSS

.hasClass()
Determine whether any of the matched elements are assigned the
given class.
Selectors > Basic Filter | Selectors > jQuery Extensions

:header Selector
Selects all elements that are headers, like h1, h2, h3 and so on.
CSS | Dimensions | Manipulation > Style Properties

.height()
Get the current computed height for the first element in the set of
matched elements or set the height of every matched element.
Selectors > jQuery Extensions | Selectors > Visibility Filter

:hidden Selector
Selects all elements that are hidden.
Effects > Basics

.hide()
Hide the matched elements.
Events > Mouse Events

.hover()
Bind one or two handlers to the matched elements, to be executed
when the mouse pointer enters and leaves the elements.
Attributes | Manipulation > DOM Insertion, Inside

.html()
Get the HTML contents of the first element in the set of matched
elements or set the HTML contents of every matched element.
Selectors > Basic

ID Selector (“#id”)
Selects a single element with the given id attribute.
Selectors > Form | Selectors > jQuery Extensions

:image Selector
Selects all elements of type image.
Miscellaneous > DOM Element Methods

.index()
Search for a given element from among the matched elements.
CSS | Dimensions | Manipulation > Style Properties

.innerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding but not border.
CSS | Dimensions | Manipulation > Style Properties

.innerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding but not border.
Selectors > Form | Selectors > jQuery Extensions

:input Selector
Selects all input, textarea, select and button elements.
Manipulation > DOM Insertion, Outside

.insertAfter()
Insert every element in the set of matched elements after the
target.
Manipulation > DOM Insertion, Outside

.insertBefore()
Insert every element in the set of matched elements before the
target.
Traversing > Filtering

.is()
Check the current matched set of elements against a selector,
element, or jQuery object and return true if at least one of these
elements matches the given arguments.
Core

jQuery()
Return a collection of matched elements either found in the DOM
based on passed argument(s) or created by passing an HTML
string.
Internals | Properties > Properties of jQuery Object Instances

.jquery
A string containing the jQuery version number.
Ajax > Low-Level Interface

jQuery.ajax()
Perform an asynchronous HTTP (Ajax) request.
Ajax > Low-Level Interface

jQuery.ajaxPrefilter()
Handle custom Ajax options or modify existing options before
each request is sent and before they are processed by $.ajax().
Ajax > Low-Level Interface

jQuery.ajaxSetup()
Set default values for future Ajax requests.
Ajax > Low-Level Interface

jQuery.ajaxTransport()
Creates an object that handles the actual transmission of Ajax
data.
Utilities

jQuery.boxModel
Deprecated in jQuery 1.3 (see jQuery.support). States if the
current page, in the user’s browser, is being rendered using the
W3C CSS Box Model.
Properties > Properties of the Global jQuery Object | Utilities

jQuery.browser
Contains flags for the useragent, read from navigator.userAgent.
We recommend against using this property; please try to use
feature detection instead (see jQuery.support). jQuery.browser
may be moved to a plugin in a future release of jQuery.
Callbacks Object

jQuery.Callbacks()
A multi-purpose callbacks list object that provides a powerful way
to manage callback lists.
Utilities

jQuery.contains()
Check to see if a DOM element is a descendant of another DOM
element.
CSS

jQuery.cssHooks
Hook directly into jQuery to override how particular CSS
properties are retrieved or set, normalize CSS property naming, or
create custom properties.
Data | Utilities

jQuery.data()
Store arbitrary data associated with the specified element and/or
return the value that was set.
Deferred Object

jQuery.Deferred()
A constructor function that returns a chainable utility object with
methods to register multiple callbacks into callback queues,
invoke callback queues, and relay the success or failure state of
any synchronous or asynchronous function.
Data | Utilities

jQuery.dequeue()
Execute the next function on the queue for the matched element.
Utilities

jQuery.each()
A generic iterator function, which can be used to seamlessly
iterate over both objects and arrays. Arrays and array-like objects
with a length property (such as a function’s arguments object) are
iterated by numeric index, from 0 to length-1. Other objects are
iterated via their named properties.
Internals

jQuery.error()
Takes a string and throws an exception containing it.
Utilities

jQuery.extend()
Merge the contents of two or more objects together into the first
object.
Effects > Custom | Properties > Properties of the Global jQuery Object

jQuery.fx.interval
The rate (in milliseconds) at which animations fire.
Effects > Custom | Properties > Properties of the Global jQuery Object

jQuery.fx.off
Globally disable all animations.
Ajax > Shorthand Methods

jQuery.get()
Load data from the server using a HTTP GET request.
Ajax > Shorthand Methods

jQuery.getJSON()
Load JSON-encoded data from the server using a GET HTTP
request.
Ajax > Shorthand Methods

jQuery.getScript()
Load a JavaScript file from the server using a GET HTTP request,
then execute it.
Utilities

jQuery.globalEval()
Execute some JavaScript code globally.
Utilities

jQuery.grep()
Finds the elements of an array which satisfy a filter function. The
original array is not affected.
Data

jQuery.hasData()
Determine whether an element has any jQuery data associated
with it.
Core

jQuery.holdReady()
Holds or releases the execution of jQuery’s ready event.
Utilities

jQuery.inArray()
Search for a specified value within an array and return its index (or
-1 if not found).
Utilities

jQuery.isArray()
Determine whether the argument is an array.
Utilities

jQuery.isEmptyObject()
Check to see if an object is empty (contains no enumerable
properties).
Utilities

jQuery.isFunction()
Determine if the argument passed is a Javascript function object.
Utilities

jQuery.isNumeric()
Determines whether its argument is a number.
Utilities

jQuery.isPlainObject()
Check to see if an object is a plain object (created using “{}” or
“new Object”).
Utilities

jQuery.isWindow()
Determine whether the argument is a window.
Utilities

jQuery.isXMLDoc()
Check to see if a DOM node is within an XML document (or is an
XML document).
Utilities

jQuery.makeArray()
Convert an array-like object into a true JavaScript array.
Utilities

jQuery.map()
Translate all items in an array or object to new array of items.
Utilities

jQuery.merge()
Merge the contents of two arrays together into the first array.
Core | Miscellaneous > Setup Methods

jQuery.noConflict()
Relinquish jQuery’s control of the $ variable.
Utilities

jQuery.noop()
An empty function.
Utilities

jQuery.now()
Return a number representing the current time.
Miscellaneous > Collection Manipulation | Forms | Ajax > Helper Functions

jQuery.param()
Create a serialized representation of an array or object, suitable
for use in a URL query string or Ajax request.
Utilities

jQuery.parseHTML()
Parses a string into an array of DOM nodes.
Utilities

jQuery.parseJSON()
Takes a well-formed JSON string and returns the resulting
JavaScript object.
Utilities

jQuery.parseXML()
Parses a string into an XML document.
Ajax > Shorthand Methods

jQuery.post()
Load data from the server using a HTTP POST request.
Events > Event Handler Attachment | Utilities

jQuery.proxy()
Takes a function and returns a new one that will always have a
particular context.
Data | Utilities

jQuery.queue()
Show or manipulate the queue of functions to be executed on the
matched element.
Data | Utilities

jQuery.removeData()
Remove a previously-stored piece of data.
Core

jQuery.sub()
Creates a new copy of jQuery whose properties and methods can
be modified without affecting the original jQuery object.
Properties > Properties of the Global jQuery Object | Utilities

jQuery.support
A collection of properties that represent the presence of different
browser features or bugs. Primarily intended for jQuery’s internal
use; specific properties may be removed when they are no longer
needed internally to improve page startup performance.
Utilities

jQuery.trim()
Remove the whitespace from the beginning and end of a string.
Utilities

jQuery.type()
Determine the internal JavaScript [[Class]] of an object.
Utilities

jQuery.unique()
Sorts an array of DOM elements, in place, with the duplicates
removed. Note that this only works on arrays of DOM elements,
not strings or numbers.
Core | Deferred Object

jQuery.when()
Provides a way to execute callback functions based on one or
more objects, usually Deferred objects that represent
asynchronous events.
Events > Keyboard Events

.keydown()
Bind an event handler to the “keydown” JavaScript event, or
trigger that event on an element.
Events > Keyboard Events

.keypress()
Bind an event handler to the “keypress” JavaScript event, or
trigger that event on an element.
Events > Keyboard Events

.keyup()
Bind an event handler to the “keyup” JavaScript event, or trigger
that event on an element.
Selectors > Basic Filter

:lang Selector
Selects all elements of the specified language.
Traversing > Filtering

.last()
Reduce the set of matched elements to the final one in the set.
Selectors > Child Filter

:last-child Selector
Selects all elements that are the last child of their parent.
Selectors > Child Filter

:last-of-type Selector
Selects all elements that are the last among siblings of the same
element name.
Selectors > Basic Filter | Selectors > jQuery Extensions

:last Selector
Selects the last matched element.
Properties > Properties of jQuery Object Instances

.length
The number of elements in the jQuery object.
Events > Event Handler Attachment

.live()
Attach an event handler for all elements which match the current
selector, now and in the future.
Ajax > Shorthand Methods

.load()
Load data from the server and place the returned HTML into the
matched element.
Events > Document Loading

.load()
Bind an event handler to the “load” JavaScript event.
Selectors > Basic Filter | Selectors > jQuery Extensions

:lt() Selector
Select all elements at an index less than index within the matched
set.
Traversing > Filtering

.map()
Pass each element in the current matched set through a function,
producing a new jQuery object containing the return values.
Events > Mouse Events

.mousedown()
Bind an event handler to the “mousedown” JavaScript event, or
trigger that event on an element.
Events > Mouse Events

.mouseenter()
Bind an event handler to be fired when the mouse enters an
element, or trigger that handler on an element.
Events > Mouse Events

.mouseleave()
Bind an event handler to be fired when the mouse leaves an
element, or trigger that handler on an element.
Events > Mouse Events

.mousemove()
Bind an event handler to the “mousemove” JavaScript event, or
trigger that event on an element.
Events > Mouse Events

.mouseout()
Bind an event handler to the “mouseout” JavaScript event, or
trigger that event on an element.
Events > Mouse Events

.mouseover()
Bind an event handler to the “mouseover” JavaScript event, or
trigger that event on an element.
Events > Mouse Events

.mouseup()
Bind an event handler to the “mouseup” JavaScript event, or
trigger that event on an element.
Selectors > Attribute

Multiple Attribute Selector [name="value"]
[name2="value2"]
Matches elements that match all of the specified attribute filters.
Selectors > Basic

Multiple Selector (“selector1, selector2,
selectorN”)
Selects the combined results of all the specified selectors.
Traversing > Tree Traversal

.next()
Get the immediately following sibling of each element in the set of
matched elements. If a selector is provided, it retrieves the next
sibling only if it matches that selector.
Selectors > Hierarchy

Next Adjacent Selector (“prev + next”)
Selects all next elements matching “next” that are immediately
preceded by a sibling “prev”.
Selectors > Hierarchy

Next Siblings Selector (“prev ~ siblings”)
Selects all sibling elements that follow after the “prev” element,
have the same parent, and match the filtering “siblings” selector.
Traversing > Tree Traversal

.nextAll()
Get all following siblings of each element in the set of matched
elements, optionally filtered by a selector.
Traversing > Tree Traversal

.nextUntil()
Get all following siblings of each element up to but not including
the element matched by the selector, DOM node, or jQuery object
passed.
Traversing > Filtering | Traversing > Miscellaneous Traversing

.not()
Remove elements from the set of matched elements.
Selectors > Basic Filter

:not() Selector
Selects all elements that do not match the given selector.
Selectors > Child Filter

:nth-child() Selector
Selects all elements that are the nth-child of their parent.
Selectors > Child Filter

:nth-last-child() Selector
Selects all elements that are the nth-child of their parent, counting
from the last element to the first.
Selectors > Child Filter

:nth-last-of-type() Selector
Selects all elements that are the nth-child of their parent, counting
from the last element to the first.
Selectors > Child Filter

:nth-of-type() Selector
Selects all elements that are the nth child of their parent in relation
to siblings with the same element name.
Selectors > Basic Filter | Selectors > jQuery Extensions

:odd Selector
Selects odd elements, zero-indexed. See also even.
Events > Event Handler Attachment

.off()
Remove an event handler.
CSS | Offset | Manipulation > Style Properties

.offset()
Get the current coordinates of the first element, or set the
coordinates of every element, in the set of matched elements,
relative to the document.
Offset | Traversing > Tree Traversal

.offsetParent()
Get the closest ancestor element that is positioned.
Events > Event Handler Attachment

.on()
Attach an event handler function for one or more events to the
selected elements.
Events > Event Handler Attachment

.one()
Attach a handler to an event for the elements. The handler is
executed at most once per element.
Selectors > Child Filter

:only-child Selector
Selects all elements that are the only child of their parent.
Selectors > Child Filter

:only-of-type Selector
Selects all elements that have no siblings with the same element
name.
CSS | Dimensions | Manipulation > Style Properties

.outerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding, border, and optionally
margin. Returns an integer (without “px”) representation of the
value or null if called on an empty set of elements.
CSS | Dimensions | Manipulation > Style Properties

.outerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding and border.
Traversing > Tree Traversal

.parent()
Get the parent of each element in the current set of matched
elements, optionally filtered by a selector.
Selectors > Content Filter | Selectors > jQuery Extensions

:parent Selector
Select all elements that that have at least one child node (either
an element or text).
Traversing > Tree Traversal

.parents()
Get the ancestors of each element in the current set of matched
elements, optionally filtered by a selector.
Traversing > Tree Traversal

.parentsUntil()
Get the ancestors of each element in the current set of matched
elements, up to but not including the element matched by the
selector, DOM node, or jQuery object.
Selectors > Form | Selectors > jQuery Extensions

:password Selector
Selects all elements of type password.
CSS | Offset | Manipulation > Style Properties

.position()
Get the current coordinates of the first element in the set of
matched elements, relative to the offset parent.
Manipulation > DOM Insertion, Inside

.prepend()
Insert content, specified by the parameter, to the beginning of
each element in the set of matched elements.
Manipulation > DOM Insertion, Inside

.prependTo()
Insert every element in the set of matched elements to the
beginning of the target.
Traversing > Tree Traversal

.prev()
Get the immediately preceding sibling of each element in the set
of matched elements, optionally filtered by a selector.
Traversing > Tree Traversal

.prevAll()
Get all preceding siblings of each element in the set of matched
elements, optionally filtered by a selector.
Traversing > Tree Traversal

.prevUntil()
Get all preceding siblings of each element up to but not including
the element matched by the selector, DOM node, or jQuery object.
Deferred Object

.promise()
Return a Promise object to observe when all actions of a certain
type bound to the collection, queued or not, have finished.
Attributes | Manipulation > General Attributes

.prop()
Get the value of a property for the first element in the set of
matched elements or set one or more properties for every
matched element.
Internals

.pushStack()
Add a collection of DOM elements onto the jQuery stack.
Effects > Custom | Data | Utilities

.queue()
Show or manipulate the queue of functions to be executed on the
matched elements.
Selectors > Form | Selectors > jQuery Extensions

:radio Selector
Selects all elements of type radio.
Events > Document Loading

.ready()
Specify a function to execute when the DOM is fully loaded.
Manipulation > DOM Removal

.remove()
Remove the set of matched elements from the DOM.
Attributes | Manipulation > General Attributes

.removeAttr()
Remove an attribute from each element in the set of matched
elements.
Attributes | Manipulation > Class Attribute | CSS

.removeClass()
Remove a single class, multiple classes, or all classes from each
element in the set of matched elements.
Data | Miscellaneous > Data Storage

.removeData()
Remove a previously-stored piece of data.
Attributes | Manipulation > General Attributes

.removeProp()
Remove a property for the set of matched elements.
Manipulation > DOM Replacement

.replaceAll()
Replace each target element with the set of matched elements.
Manipulation > DOM Replacement

.replaceWith()
Replace each element in the set of matched elements with the
provided new content and return the set of elements that was
removed.
Selectors > Form | Selectors > jQuery Extensions

:reset Selector
Selects all elements of type reset.
Events > Browser Events

.resize()
Bind an event handler to the “resize” JavaScript event, or trigger
that event on an element.
Selectors > Basic Filter

:root Selector
Selects the element that is the root of the document.
Events > Browser Events

.scroll()
Bind an event handler to the “scroll” JavaScript event, or trigger
that event on an element.
CSS | Offset | Manipulation > Style Properties

.scrollLeft()
Get the current horizontal position of the scroll bar for the first
element in the set of matched elements or set the horizontal
position of the scroll bar for every matched element.
CSS | Offset | Manipulation > Style Properties

.scrollTop()
Get the current vertical position of the scroll bar for the first
element in the set of matched elements or set the vertical position
of the scroll bar for every matched element.
Events > Form Events | Forms

.select()
Bind an event handler to the “select” JavaScript event, or trigger
that event on an element.
Selectors > Form | Selectors > jQuery Extensions

:selected Selector
Selects all elements that are selected.
Internals | Properties > Properties of the Global jQuery Object

.selector
A selector representing selector originally passed to jQuery().
Forms | Ajax > Helper Functions

.serialize()
Encode a set of form elements as a string for submission.
Forms | Ajax > Helper Functions

.serializeArray()
Encode a set of form elements as an array of names and values.
Effects > Basics

.show()
Display the matched elements.
Traversing > Tree Traversal

.siblings()
Get the siblings of each element in the set of matched elements,
optionally filtered by a selector.
Miscellaneous > DOM Element Methods

.size()
Return the number of elements in the jQuery object.
Traversing > Filtering

.slice()
Reduce the set of matched elements to a subset specified by a
range of indices.
Effects > Sliding

.slideDown()
Display the matched elements with a sliding motion.
Effects > Sliding

.slideToggle()
Display or hide the matched elements with a sliding motion.
Effects > Sliding

.slideUp()
Hide the matched elements with a sliding motion.
Effects > Custom

.stop()
Stop the currently-running animation on the matched elements.
Events > Form Events | Forms

.submit()
Bind an event handler to the “submit” JavaScript event, or trigger
that event on an element.
Selectors > Form | Selectors > jQuery Extensions

:submit Selector
Selects all elements of type submit.
Selectors > Basic Filter

:target Selector
Selects the target element indicated by the fragment identifier of
the document’s URI.
Manipulation > DOM Insertion, Inside

.text()
Get the combined text contents of each element in the set of
matched elements, including their descendants, or set the text
contents of the matched elements.
Selectors > Form | Selectors > jQuery Extensions

:text Selector
Selects all elements of type text.
Miscellaneous > DOM Element Methods

.toArray()
Retrieve all the DOM elements contained in the jQuery set, as an
array.
Effects > Basics

.toggle()
Display or hide the matched elements.
Deprecated > Deprecated 1.8 | Events > Mouse Events

.toggle()
Bind two or more handlers to the matched elements, to be
executed on alternate clicks.
Attributes | Manipulation > Class Attribute | CSS

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument.
Events > Event Handler Attachment

.trigger()
Execute all handlers and behaviors attached to the matched
elements for the given event type.
Events > Event Handler Attachment

.triggerHandler()
Execute all handlers attached to an element for an event.
Events > Event Handler Attachment

.unbind()
Remove a previously-attached event handler from the elements.
Events > Event Handler Attachment

.undelegate()
Remove a handler from the event for all elements which match the
current selector, based upon a specific set of root elements.
Events > Document Loading

.unload()
Bind an event handler to the “unload” JavaScript event.
Manipulation > DOM Insertion, Around | Manipulation > DOM Removal

.unwrap()
Remove the parents of the set of matched elements from the
DOM, leaving the matched elements in their place.
Attributes | Forms | Manipulation > General Attributes

.val()
Get the current value of the first element in the set of matched
elements or set the value of every matched element.
Selectors > jQuery Extensions | Selectors > Visibility Filter

:visible Selector
Selects all elements that are visible.
CSS | Dimensions | Manipulation > Style Properties

.width()
Get the current computed width for the first element in the set of
matched elements or set the width of every matched element.
Manipulation > DOM Insertion, Around

.wrap()
Wrap an HTML structure around each element in the set of
matched elements.
Manipulation > DOM Insertion, Around

.wrapAll()
Wrap an HTML structure around all elements in the set of
matched elements.
Manipulation > DOM Insertion, Around

.wrapInner()
Wrap an HTML structure around the content of each element in
the set of matched elements.
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.add()
Categories: Traversing > Miscellaneous Traversing

.add( selector )

Returns: jQuery

Description: Add elements to the set of matched
elements.
.add( selector )

version added: 1.0

selector
Type: Selector
A string representing a selector expression to find additional
elements to add to the set of matched elements.

.add( elements )

version added: 1.0

elements
Type: Elements
One or more elements to add to the set of matched elements.

.add( html )

version added: 1.0

html
Type: HTML
An HTML fragment to add to the set of matched elements.

.add( jQuery object )

version added: 1.3.2

jQuery object
Type: jQuery object
An existing jQuery object to add to the set of matched
elements.

.add( selector, context )

version added: 1.4

selector
Type: Selector
A string representing a selector expression to find additional
elements to add to the set of matched elements.
context
Type: Element
The point in the document at which the selector should begin

matching; similar to the context argument of the
context) method.

$(selector,

Given a jQuery object that represents a set of DOM elements, the
.add() method constructs a new jQuery object from the union of
those elements and the ones passed into the method. The argument
to .add() can be pretty much anything that $() accepts, including a
jQuery selector expression, references to DOM elements, or an
HTML snippet.
The updated set of elements can be used in a following (chained)
method, or assigned to a variable for later use. For example:
1
2

$("p").add("div").addClass("widget");
var pdiv = $("p").add("div");

The following will not save the added elements, because the
method creates a new set and leaves the original set in pdiv
unchanged:
1
2

.add()

var pdiv = $("p");
pdiv.add("div"); // WRONG, pdiv will not change

Consider a page with a simple list and a paragraph following it:
1
2
3
4
5
6

<ul>
<li>list item 1</li>
<li>list item 2</li>
<li>list item 3</li>
</ul>
<p>a paragraph</p>

We can select the list items and then the paragraph by using either a
selector or a reference to the DOM element itself as the .add()

method's argument:
1

$('li').add('p').css('background-color', 'red');

Or:
1
2

$('li').add(document.getElementsByTagName('p')[0
.css('background-color', 'red');

The result of this call is a red background behind all four elements.
Using an HTML snippet as the .add() method's argument (as in the
third version), we can create additional elements on the fly and add
those elements to the matched set of elements. Let's say, for
example, that we want to alter the background of the list items along
with a newly created paragraph:
1
2

$('li').add('<p id="new">new paragraph</p>')
.css('background-color', 'red');

Although the new paragraph has been created and its background
color changed, it still does not appear on the page. To place it on the
page, we could add one of the insertion methods to the chain.
As of jQuery 1.4 the results from .add() will always be returned in
document order (rather than a simple concatenation).
Note: To reverse the .add() you can use .not( elements | selector
) to remove elements from the jQuery results, or .end() to return to
the selection before you added.

Examples:
Finds all divs and makes a border. Then adds
all paragraphs to the jQuery object to set their
backgrounds yellow.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<!DOCTYPE html>
<html>
<head>
<style>
div { width:60px; height:60px; margin:10px; float
p { clear:left; font-weight:bold; font-size:16
color:blue; margin:0 10px; padding:2px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<p>Added this... (notice no border)</p>
<script>
$("div").css("border", "2px solid red")
.add("p")
.css("background", "yellow");
</script>
</body>
</html>

Demo
Example:

Adds more elements, matched by the given
expression, to the set of matched elements.
1
2
3
4
5
6
7
8
9
10
11

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p><span>Hello Again</span>
<script>$("p").add("span").css("background", "yellow"
</body>
</html>

Demo
Example:

Adds more elements, created on the fly, to
the set of matched elements.
1
2
3
4
5
6
7
8
9
10
11

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<script>$("p").clone().add("<span>Again</span>"
</body>
</html>

Demo
Example:

Adds one or more Elements to the set of
matched elements.
1
2
3
4
5
6
7
8
9
10
11

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p><span id="a">Hello Again</span>
<script>$("p").add(document.getElementById("a")).css(
</body>
</html>

Demo
Example:

Demonstrates how to add (or push) elements
to an existing collection
1
2
3
4
5
6
7
8
9
10
11
12
13
14

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p><span id="a">Hello Again</span>
<script>var collection = $("p");
// capture the new collection
collection = collection.add(document.getElementById(
collection.css("background", "yellow");</script
</body>
</html>

Demo
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.addBack()
Categories: Traversing > Miscellaneous Traversing

.addBack( [selector ] )

Returns: jQuery

Description: Add the previous set of elements on the
stack to the current set, optionally filtered by a selector.
.addBack( [selector ] )

version added: 1.8

selector
Type: Selector
A string containing a selector expression to match the current
set of elements against.
As described in the discussion for .end() , jQuery objects maintain
an internal stack that keeps track of changes to the matched set of
elements. When one of the DOM traversal methods is called, the
new set of elements is pushed onto the stack. If the previous set of
elements is desired as well, .addBack() can help.
Consider a page with a simple list on it:
1
2
3
4
5
6
7

<ul>
<li>list item 1</li>
<li>list item 2</li>
<li class="third-item">list item 3</li>
<li>list item 4</li>
<li>list item 5</li>
</ul>

The result of the following code is a red background behind items 3,
4 and 5:
1
2

$('li.third-item').nextAll().addBack()
.css('background-color', 'red');

First, the initial selector locates item 3, initializing the stack with the
set containing just this item. The call to .nextAll() then pushes the
set of items 4 and 5 onto the stack. Finally, the .addBack() invocation
merges these two sets together, creating a jQuery object that points
to all three items in document order: {[<li.third-item>,<li>,<li> ]} .

Example:
The .addBack() method causes the previous set of DOM
elements in the traversal stack to be added to the
current set. In the first example, the top stack contains
the set resulting from .find("p") . In the second example,
.addBack() adds the previous set of elements on the
stack — in this case $("div.after-addback") — to the
current set, selecting both the div and its enclosed
paragraphs.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

<!DOCTYPE html>
<html>
<head>
<style>
p, div { margin:5px; padding:5px; }
.border { border: 2px solid red; }
.background { background:yellow; }
.left, .right { width: 45%; float: left;}
.right { margin-left:3%; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div class="left">
<p><strong>Before <code>addBack()</code></strong
<div class="before-addback">
<p>First Paragraph</p>
<p>Second Paragraph</p>
</div>
</div>
<div class="right">
<p><strong>After <code>addBack()</code></strong
<div class="after-addback">

25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

<p>First Paragraph</p>
<p>Second Paragraph</p>
</div>
</div>
<script>
$("div.left, div.right").find("div, div > p").addClass(
// First Example
$("div.before-addback").find("p").addClass("background"
// Second Example
$("div.after-addback").find("p").addBack().addClass(
</script>
</body>
</html>

Demo
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.addClass()
Categories: Attributes | Manipulation > Class Attribute | CSS

.addClass( className )

Returns: jQuery

Description: Adds the specified class(es) to each of the
set of matched elements.
.addClass( className )

version added: 1.0

className
Type: String
One or more space-separated classes to be added to the class
attribute of each matched element.

.addClass( function(index,
currentClass) )

version added: 1.4

function(index, currentClass)
Type: Function()
A function returning one or more space-separated class names
to be added to the existing class name(s). Receives the index
position of the element in the set and the existing class name(s)
as arguments. Within the function, this refers to the current
element in the set.
It's important to note that this method does not replace a class. It
simply adds the class, appending it to any which may already be
assigned to the elements.
More than one class may be added at a time, separated by a space,
to the set of matched elements, like so:
1

$("p").addClass("myClass yourClass");

This method is often used with .removeClass() to switch elements'
classes from one to another, like so:
1

$("p").removeClass("myClass noClass").addClass("yourClas

Here, the myClass and noClass classes are removed from all
paragraphs, while yourClass is added.
As of jQuery 1.4, the
function.
1
2
3

.addClass()

method's argument can receive a

$("ul li:last").addClass(function(index) {
return "item-" + index;
});

Given an unordered list with five <li> elements, this example adds
the class "item-4" to the last <li> .

Examples:
Add the class "selected" to the matched

Example:

elements.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22

<!DOCTYPE html>
<html>
<head>
<style>
p { margin: 8px; font-size:16px; }
.selected { color:blue; }
.highlight { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>and</p>
<p>Goodbye</p>
<script>
$("p").last().addClass("selected");
</script>
</body>
</html>

Demo
Example:

Add the classes "selected" and "highlight" to
the matched elements.
1

<!DOCTYPE html>

2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

<html>
<head>
<style>
p { margin: 8px; font-size:16px; }
.selected { color:red; }
.highlight { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>and</p>
<p>Goodbye</p>
<script>
$("p:last").addClass("selected highlight");
</script>
</body>
</html>

Demo
Example:

Pass in a function to .addClass() to add the
"green" class to a div that already has a "red" class.
1
2
3
4
5
6
7
8
9
10
11

<!DOCTYPE html>
<html>
<head>
<style>
div { background: white; }
.red { background: red; }
.red.green { background: green; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33

<div>This div should be white</div>
<div class="red">This div will be green because it now
It would be red if the addClass function failed.
<div>This div should be white</div>
<p>There are zero green divs</p>
<script>
$("div").addClass(function(index, currentClass) {
var addedClass;
if ( currentClass === "red" ) {
addedClass = "green";
$("p").text("There is one green div");
}
return addedClass;
});
</script>
</body>
</html>

Demo
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.after()
Categories: Manipulation > DOM Insertion, Outside

.after( content [, content ] )

Returns: jQuery

Description: Insert content, specified by the parameter,
after each element in the set of matched elements.
.after( content [, content ] )

version added: 1.0

content
Type: htmlString or Element or jQuery
HTML string, DOM element, or jQuery object to insert after each
element in the set of matched elements.
content
Type: htmlString or Element or Array or jQuery
One or more additional DOM elements, arrays of elements,
HTML strings, or jQuery objects to insert after each element in
the set of matched elements.

.after( function(index) )

version added: 1.4

function(index)
Type: Function()
A function that returns an HTML string, DOM element(s), or
jQuery object to insert after each element in the set of matched
elements. Receives the index position of the element in the set
as an argument. Within the function, this refers to the current
element in the set.
The .after() and .insertAfter() methods perform the same task.
The major difference is in the syntax—specifically, in the placement
of the content and target. With .after() , the selector expression
preceding the method is the container after which the content is
inserted. With .insertAfter() , on the other hand, the content
precedes the method, either as a selector expression or as markup
created on the fly, and it is inserted after the target container.
Using the following HTML:
1

<div class="container">

2
3
4
5

<h2>Greetings</h2>
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

Content can be created and then inserted after several elements at
once:
1

$('.inner').after('<p>Test</p>');

Each inner
1
2
3
4
5
6
7

<div>

element gets this new content:

<div class="container">
<h2>Greetings</h2>
<div class="inner">Hello</div>
<p>Test</p>
<div class="inner">Goodbye</div>
<p>Test</p>
</div>

An element in the DOM can also be selected and inserted after
another element:
1

$('.container').after($('h2'));

If an element selected this way is inserted into a single location
elsewhere in the DOM, it will be moved rather than cloned:
1
2
3
4

<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

5

<h2>Greetings</h2>

If there is more than one target element, however, cloned copies of
the inserted element will be created for each target after the first.
Inserting Disconnected DOM nodes
As of jQuery 1.4, .before() and .after() will also work on
disconnected DOM nodes. For example, given the following code:
1

$('<div/>').after('<p></p>');

The result is a jQuery set containing a div and a paragraph, in that
order. That set can be further manipulated, even before it is inserted
in the document.
1
2
3
4

$('<div/>').after('<p></p>').addClass('foo')
.filter('p').attr('id', 'bar').html('hello')
.end()
.appendTo('body');

This results in the following elements inserted just before the closing
</body> tag:
1
2

<div class="foo"></div>
<p class="foo" id="bar">hello</p>

Passing a Function
As of jQuery 1.4, .after() supports passing a function that returns
the elements to insert.
1

$('p').after(function() {

2
3

return '<div>' + this.className + '</div>';
});

This example inserts a <div> after each paragraph, with each new
<div> containing the class name(s) of its preceding paragraph.
Additional Arguments
Similar to other content-adding methods such as .prepend() and
.before() , .after() also supports passing in multiple arguments as
input. Supported input includes DOM elements, jQuery objects,
HTML strings, and arrays of DOM elements.
For example, the following will insert two new
<div> after the first paragraph:
1
2
3
4
5

<div> s

and an existing

var $newdiv1 = $('<div id="object1"/>'),
newdiv2 = document.createElement('div'),
existingdiv1 = document.getElementById('foo'

$('p').first().after($newdiv1, [newdiv2, existingdiv1]);

Since .after() can accept any number of additional arguments, the
same result can be achieved by passing in the three <div> s as three
separate arguments, like so: $('p').first().after($newdiv1,
newdiv2, existingdiv1) . The type and number of arguments will
largely depend on the elements that are collected in the code.

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12

<!DOCTYPE html>
<html>
<head>
<style>p { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>I would like to say: </p>
<script>$("p").after("<b>Hello</b>");</script>
</body>
</html>

Demo
Example:
1
2
3
4
5
6
7
8
9
10
11
12

Inserts some HTML after all paragraphs.

Inserts a DOM element after all paragraphs.

<!DOCTYPE html>
<html>
<head>
<style>p { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>I would like to say: </p>
<script>$("p").after( document.createTextNode("Hello"
</body>
</html>

Demo
Example:

Inserts a jQuery object (similar to an Array of
DOM Elements) after all paragraphs.
1
2
3
4
5
6
7
8
9
10
11
12

<!DOCTYPE html>
<html>
<head>
<style>p { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<b>Hello</b><p>I would like to say: </p>
<script>$("p").after( $("b") );</script>
</body>
</html>

Demo
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.ajaxComplete()
Categories: Ajax > Global Ajax Event Handlers

.ajaxComplete( handler(event, XMLHttpRequest,
ajaxOptions) )
Returns: jQuery
Description: Register a handler to be called when Ajax
requests complete. This is an AjaxEvent.
.ajaxComplete( handler(event,
XMLHttpRequest, ajaxOptions) )

version added: 1.0

handler(event, XMLHttpRequest, ajaxOptions)
Type: Function()
The function to be invoked.
Whenever an Ajax request completes, jQuery triggers the
ajaxComplete event. Any and all handlers that have been registered
with the .ajaxComplete() method are executed at this time.
To observe this method in action, set up a basic Ajax load request:
1
2
3

<div class="trigger">Trigger</div>
<div class="result"></div>
<div class="log"></div>

Attach the event handler to the document:
1
2
3

$(document).ajaxComplete(function() {
$( ".log" ).text( "Triggered ajaxComplete handler."
});

Now, make an Ajax request using any jQuery method:
1
2

$( ".trigger" ).click(function() {
$( ".result" ).load( "ajax/test.html" );

3

});

When the user clicks the element with class trigger and the Ajax
request completes, the log message is displayed.
Note: Because .ajaxComplete() is implemented as a method of
jQuery object instances, you can use the this keyword to refer to
the selected elements within the callback function. As of jQuery 1.8,
however, the .ajaxComplete() method should only be attached to
document .
All ajaxComplete handlers are invoked, regardless of what Ajax
request was completed. If you must differentiate between the
requests, use the parameters passed to the handler. Each time an
ajaxComplete handler is executed, it is passed the event object, the
XMLHttpRequest object, and the settings object that was used in the
creation of the request. For example, you can restrict the callback to
only handling events dealing with a particular URL:
1
2
3
4
5
6

$(document).ajaxComplete(function(event, xhr, settings)
if ( settings.url === "ajax/test.html" ) {
$( ".log" ).text( "Triggered ajaxComplete handler. T
xhr.responseHTML );
}
});

Note: You can get the returned ajax contents by looking at
xhr.responseXML or xhr.responseHTML for xml and html respectively.

Additional Notes:
If $.ajax() or $.ajaxSetup() is called with the global option set
to false , the .ajaxComplete() method will not fire.

Example:
Show a message when an Ajax request completes.
1
2
3

$(document).ajaxComplete(function(event,request, settings
$( "#msg" ).append( "<li>Request Complete.</li>"
});

POWERED BYHERONOTE
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.ajaxError()
Categories: Ajax > Global Ajax Event Handlers

.ajaxError( handler(event, jqXHR, ajaxSettings,
thrownError) )
Returns: jQuery
Description: Register a handler to be called when Ajax
requests complete with an error. This is an Ajax Event.
.ajaxError( handler(event, jqXHR,
ajaxSettings, thrownError) )

version added: 1.0

handler(event, jqXHR, ajaxSettings, thrownError)
Type: Function()
The function to be invoked.
Whenever an Ajax request completes with an error, jQuery triggers
the ajaxError event. Any and all handlers that have been registered
with the .ajaxError() method are executed at this time.
To observe this method in action, set up a basic Ajax load request.
1
2
3

<button class="trigger">Trigger</button>
<div class="result"></div>
<div class="log"></div>

Attach the event handler to the document:
1
2
3

$(document).ajaxError(function() {
$( "div.log" ).text( "Triggered ajaxError handler."
});

Now, make an Ajax request using any jQuery method:
1
2

$( "button.trigger" ).click(function() {
$( "div.result" ).load( "ajax/missing.html" );

3

});

When the user clicks the button and the Ajax request fails, because
the requested file is missing, the log message is displayed.
Note: Because .ajaxError() is implemented as a method of jQuery
object instances, you can use the this keyword within the callback
function to refer to the selected elements. As of jQuery 1.8,
however, the .ajaxError() method should only be attached to
document .
All ajaxError handlers are invoked, regardless of what Ajax request
was completed. To differentiate between the requests, use the
parameters passed to the handler. Each time an ajaxError handler
is executed, it is passed the event object, the jqXHR object (prior to
jQuery 1.5, the XHR object), and the settings object that was used in
the creation of the request. If the request failed because JavaScript
raised an exception, the exception object is passed to the handler as
a fourth parameter. For example, to restrict the error callback to only
handling events dealing with a particular URL:
1
2
3
4
5

$( document ).ajaxError(function(event, jqxhr, settings,
if ( settings.url == "ajax/missing.html" ) {
$( "div.log" ).text( "Triggered ajaxError handler."
}
});

Additional Notes:
If $.ajax() or $.ajaxSetup() is called with the global option set
to false , the .ajaxError() method will not fire.

Example:
Show a message when an Ajax request fails.
1
2
3

$(document).ajaxError(function(event, request, settings)
$( "#msg" ).append( "<li>Error requesting page "
});
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.ajaxSend()
Categories: Ajax > Global Ajax Event Handlers

.ajaxSend( handler(event, jqXHR, ajaxOptions) )
Returns: jQuery
Description: Attach a function to be executed before an
Ajax request is sent. This is an Ajax Event.
.ajaxSend( handler(event, jqXHR,
ajaxOptions) )

version added: 1.0

handler(event, jqXHR, ajaxOptions)
Type: Function()
The function to be invoked.
Whenever an Ajax request is about to be sent, jQuery triggers the
ajaxSend event. Any and all handlers that have been registered with
the .ajaxSend() method are executed at this time.
To observe this method in action, set up a basic Ajax load request:
1
2
3

<div class="trigger">Trigger</div>
<div class="result"></div>
<div class="log"></div>

Attach the event handler to the document:
1
2
3

$(document).ajaxSend(function() {
$( ".log" ).text( "Triggered ajaxSend handler."
});

Now, make an Ajax request using any jQuery method:
1
2

$( ".trigger" ).click(function() {
$( ".result" ).load( "ajax/test.html" );

3

});

When the user clicks the element with class trigger and the Ajax
request is about to begin, the log message is displayed.
Note: Because .ajaxSend() is implemented as a method of jQuery
instances, you can use the this keyword to refer to the selected
elements within the callback function. As of jQuery 1.8, however,
the .ajaxSend() method should only be attached to document .
All ajaxSend handlers are invoked, regardless of what Ajax request is
to be sent. If you must differentiate between the requests, use the
parameters passed to the handler. Each time an ajaxSend handler is
executed, it is passed the event object, the jqXHR object (in version
1.4, XMLHttpRequest object), and the settings object that was used in
the creation of the Ajax request. For example, you can restrict the
callback to only handling events dealing with a particular URL:
1
2
3
4
5

$(document).ajaxSend(function(event, jqxhr, settings) {
if ( settings.url == "ajax/test.html" ) {
$( ".log" ).text( "Triggered ajaxSend handler."
}
});

Additional Notes:
If $.ajax() or $.ajaxSetup() is called with the
to false , the .ajaxSend() method will not fire.

global

option set

Example:
Show a message before an Ajax request is sent.
1
2
3

$(document).ajaxSend(function(event, request, settings) {
$( "#msg" ).append( "<li>Starting request at "
});
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.ajaxStart()
Categories: Ajax > Global Ajax Event Handlers

.ajaxStart( handler() )

Returns: jQuery

Description: Register a handler to be called when the
first Ajax request begins. This is an Ajax Event.
.ajaxStart( handler() )

version added: 1.0

handler()
Type: Function()
The function to be invoked.
Whenever an Ajax request is about to be sent, jQuery checks
whether there are any other outstanding Ajax requests. If none are
in progress, jQuery triggers the ajaxStart event. Any and all
handlers that have been registered with the .ajaxStart() method
are executed at this time.
To observe this method in action, set up a basic Ajax load request:
1
2
3

<div class="trigger">Trigger</div>
<div class="result"></div>
<div class="log"></div>

Attach the event handler to any element:
1
2
3

$(document).ajaxStart(function() {
$( ".log" ).text( "Triggered ajaxStart handler."
});

Now, make an Ajax request using any jQuery method:
1
2

$( ".trigger" ).click(function() {
$( ".result" ).load("ajax/test.html");

3

});

When the user clicks the element with class trigger and the Ajax
request is sent, the log message is displayed.
Note: Because .ajaxStart() is implemented as a method of jQuery
object instances, you can use the this keyword to refer to the
selected elements within the callback function. As of jQuery 1.8,
however, the .ajaxStart() method should only be attached to
document .

Additional Notes:
If $.ajax() or $.ajaxSetup() is called with the global option set
to false , the .ajaxStart() method will not fire.

Example:
Show a loading message whenever an Ajax request
starts (and none is already active).
1
2
3

$(document).ajaxStart(function() {
$( "#loading" ).show();
});

POWERED BYHERONOTE
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.ajaxStop()
Categories: Ajax > Global Ajax Event Handlers

.ajaxStop( handler() )

Returns: jQuery

Description: Register a handler to be called when all
Ajax requests have completed. This is an Ajax Event.
.ajaxStop( handler() )

version added: 1.0

handler()
Type: Function()
The function to be invoked.
Whenever an Ajax request completes, jQuery checks whether there
are any other outstanding Ajax requests. If none remain, jQuery
triggers the ajaxStop event. Any and all handlers that have been
registered with the .ajaxStop() method are executed at this time.
The ajaxStop event is also triggered if the last outstanding Ajax
request is cancelled by returning false within the beforeSend callback
function.
To observe this method in action, set up a basic Ajax load request:
1
2
3

<div class="trigger">Trigger</div>
<div class="result"></div>
<div class="log"></div>

Attach the event handler to the document:
1
2
3

$( ".log" ).ajaxStop(function() {
$(this).text( "Triggered ajaxStop handler." );
});

Now, make an Ajax request using any jQuery method:

1
2
3

$( ".trigger" ).click(function() {
$( ".result" ).load( "ajax/test.html" );
});

When the user clicks the element with class trigger and the Ajax
request completes, the log message is displayed.
Because .ajaxStop() is implemented as a method of jQuery object
instances, you can use the this keyword to refer to the selected
elements within the callback function. As of jQuery 1.8, however,
the .ajaxStop() method should only be attached to document .

Additional Notes:
If $.ajax() or $.ajaxSetup() is called with the
to false , the .ajaxStop() method will not fire.

global

option set

Example:
Hide a loading message after all the Ajax requests
have stopped.
1
2
3

$(document).ajaxStop(function() {
$( "#loading" ).hide();
});
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.ajaxSuccess()
Categories: Ajax > Global Ajax Event Handlers

.ajaxSuccess( handler(event, XMLHttpRequest,
ajaxOptions) )
Returns: jQuery
Description: Attach a function to be executed whenever
an Ajax request completes successfully. This is an Ajax
Event.
.ajaxSuccess( handler(event,
XMLHttpRequest, ajaxOptions) )

version added: 1.0

handler(event, XMLHttpRequest, ajaxOptions)
Type: Function()
The function to be invoked.
Whenever an Ajax request completes successfully, jQuery triggers
the ajaxSuccess event. Any and all handlers that have been
registered with the .ajaxSuccess() method are executed at this time.
To observe this method in action, set up a basic Ajax load request:
1
2
3

<div class="trigger">Trigger</div>
<div class="result"></div>
<div class="log"></div>

Attach the event handler to any element:
1
2
3

$(document).ajaxSuccess(function() {
$( ".log" ).text( "Triggered ajaxSuccess handler."
});

Now, make an Ajax request using any jQuery method:
1

$( ".trigger" ).on("click", function() {

2
3

$( ".result" ).load( "ajax/test.html" );
});

When the user clicks the element with class trigger and the Ajax
request completes successfully, the log message is displayed.
Note: Because .ajaxSuccess() is implemented as a method of
jQuery object instances, use the this keyword to refer to the
selected elements within the callback function. As of jQuery 1.8,
however, the .ajaxSuccess() method should only be attached to
document .
All ajaxSuccess handlers are invoked, regardless of what Ajax
request was completed. If you must differentiate between the
requests, you can use the parameters passed to the handler. Each
time an ajaxSuccess handler is executed, it is passed the event
object, the XMLHttpRequest object, and the settings object that was
used in the creation of the request. For example, you can restrict the
callback to only handling events dealing with a particular URL:
1
2
3
4
5
6

$(document).ajaxSuccess(function(event, xhr, settings) {
if ( settings.url == "ajax/test.html" ) {
$( ".log" ).text( "Triggered ajaxSuccess handler. Th
xhr.responseText );
}
});

Note: You can get the returned ajax contents by looking at
xhr.responseXML or xhr.responseText for xml and html respectively.

Additional Notes:
If $.ajax() or $.ajaxSetup() is called with the global option set
to false , the .ajaxSuccess() method will not fire.

Example:
Show a message when an Ajax request completes
successfully.
1
2
3

$(document).ajaxSuccess(function(event, request, settings
$( "#msg" ).append( "<li>Successful Request!</li>"
});
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All Selector (“*”)
Categories: Selectors > Basic

all selector
Description: Selects all elements.
jQuery( "*" )

version added: 1.0

Caution: The all, or universal, selector is extremely slow, except
when used by itself.

Examples:
Find every element (including head, body,
etc) in the document. Note that if your browser has an
extension/add-on enabled that inserts a <script> or
<link> element into the DOM, that element will be
counted as well.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

<!DOCTYPE html>
<html>
<head>
<style>
h3 { margin: 0; }
div,span,p {
width: 80px;
height: 40px;
float:left;
padding: 10px;
margin: 10px;
background-color: #EEEEEE;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>DIV</div>

<span>SPAN</span>
<p>P <button>Button</button></p>
<script>var elementCount = $("*").css("border",
$("body").prepend("<h3>" + elementCount + " elements fou
</body>
</html>

Demo
Example:

Find all elements within document.body so
elements like head, script, etc. are excluded.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

<!DOCTYPE html>
<html>
<head>
<style>
h3 { margin: 0; }
div,span,p {
width: 80px;
height: 40px;
float:left;
padding: 10px;
margin: 10px;
background-color: #EEEEEE;
}
#test {
width: auto; height: auto; background-color
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="test">
<div>DIV</div>
<span>SPAN</span>
<p>P <button>Button</button></p>
</div>
<script>
var elementCount = $("#test").find("*").css("border"
$("body").prepend("<h3>" + elementCount + " elements fou
</body>
</html>

Demo
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.andSelf()
Categories: Traversing > Miscellaneous Traversing

.andSelf()

Returns: jQuery
version deprecated: 1.8

Description: Add the previous set of elements on the
stack to the current set.
.andSelf()

version added: 1.2

This method does not accept any arguments.
Note: This function has been deprecated and is now an alias for
.addBack() , which should be used with jQuery 1.8 and later.
As described in the discussion for .end() , jQuery objects maintain
an internal stack that keeps track of changes to the matched set of
elements. When one of the DOM traversal methods is called, the
new set of elements is pushed onto the stack. If the previous set of
elements is desired as well, .andSelf() can help.
Consider a page with a simple list on it:
1
2
3
4
5
6
7

<ul>
<li>list item 1</li>
<li>list item 2</li>
<li class="third-item">list item 3</li>
<li>list item 4</li>
<li>list item 5</li>
</ul>

The result of the following code is a red background behind items 3,
4 and 5:
1
2

$('li.third-item').nextAll().andSelf()
.css('background-color', 'red');

First, the initial selector locates item 3, initializing the stack with the
set containing just this item. The call to .nextAll() then pushes the
set of items 4 and 5 onto the stack. Finally, the .andSelf() invocation
merges these two sets together, creating a jQuery object that points
to all three items in document order: {[<li.third-item>,<li>,<li> ]} .

Example:
The .andSelf() method causes the previous set of DOM
elements in the traversal stack to be added to the
current set. In the first example, the top stack contains
the set resulting from .find("p") . In the second example,
.andSelf() adds the previous set of elements on the
stack — in this case $("div.after-andself") — to the
current set, selecting both the div and its enclosed
paragraphs.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

<!DOCTYPE html>
<html>
<head>
<style>
p, div { margin:5px; padding:5px; }
.border { border: 2px solid red; }
.background { background:yellow; }
.left, .right { width: 45%; float: left;}
.right { margin-left:3%; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div class="left">
<p><strong>Before <code>andSelf()</code></strong
<div class="before-andself">
<p>First Paragraph</p>
<p>Second Paragraph</p>
</div>
</div>
<div class="right">
<p><strong>After <code>andSelf()</code></strong
<div class="after-andself">

25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

<p>First Paragraph</p>
<p>Second Paragraph</p>
</div>
</div>
<script>
$("div.left, div.right").find("div, div > p").addClass(
// First Example
$("div.before-andself").find("p").addClass("background"
// Second Example
$("div.after-andself").find("p").andSelf().addClass(
</script>
</body>
</html>

Demo
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.animate()
Categories: Effects > Custom

.animate( properties [, duration ] [, easing ] [, complete ] )
Returns: jQuery
Description: Perform a custom animation of a set of
CSS properties.
.animate( properties [, duration ] [,
easing ] [, complete ] )

version added: 1.0

properties
Type: PlainObject
An object of CSS properties and values that the animation will
move toward.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.

.animate( properties, options )

version added: 1.0

properties
Type: PlainObject
An object of CSS properties and values that the animation will
move toward.
options
Type: PlainObject
A map of additional options to pass to the method.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will

run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
queue (default: true )
Type: Boolean
A Boolean indicating whether to place the animation in the
effects queue. If false, the animation will begin immediately.
As of jQuery 1.7, the queue option can also accept a
string, in which case the animation is added to the queue
represented by that string.
specialEasing
Type: PlainObject
A map of one or more of the CSS properties defined by the
properties argument and their corresponding easing
functions. (version added: 1.4)
step
Type: Function( Number now, Tween tween )
A function to be called for each animated property of each
animated element. This function provides an opportunity to
modify the Tween object to change the value of the
property before it is set.
progress
Type: Function( Promise animation, Number progress,
Number remainingMs )
A function to be called after each step of the animation,
only once per animated element regardless of the number
of animated properties. (version added: 1.8)
complete
Type: Function()
A function to call once the animation is complete.
done
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes (its
Promise object is resolved). (version added: 1.8)

fail
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation fails to complete
(its Promise object is rejected). (version added: 1.8)
always
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes or
stops without completing (its Promise object is either
resolved or rejected). (version added: 1.8)
The .animate() method allows us to create animation effects on any
numeric CSS property. The only required parameter is a plain object
of CSS properties. This object is similar to the one that can be sent
to the .css() method, except that the range of properties is more
restrictive.
Animation Properties and Values
All animated properties should be animated to a single numeric
value, except as noted below; most properties that are non-numeric
cannot be animated using basic jQuery functionality (For example,
width , height , or left can be animated but background-color cannot
be, unless the jQuery.Color() plugin is used). Property values are
treated as a number of pixels unless otherwise specified. The units
em and % can be specified where applicable.
In addition to style properties, some non-style properties such as
scrollTop and scrollLeft , as well as custom properties, can be
animated.
Shorthand CSS properties (e.g. font, background, border) are not
fully supported. For example, if you want to animate the rendered
border width, at least a border style and border width other than
"auto" must be set in advance. Or, if you want to animate font size,
you would use fontSize or the CSS equivalent 'font-size' rather
than simply 'font' .
In addition to numeric values, each property can take the strings
'show' , 'hide' , and 'toggle' . These shortcuts allow for custom

hiding and showing animations that take into account the display
type of the element.
Animated properties can also be relative. If a value is supplied with a
leading += or -= sequence of characters, then the target value is
computed by adding or subtracting the given number from the
current value of the property.

Note: Unlike shorthand animation methods
such as .slideDown() and .fadeIn() , the .animate()
method does not make hidden elements
visible as part of the effect. For example,
given $('someElement').hide().animate({height:'20px'},
500) , the animation will run, but the element
will remain hidden.
Duration
Durations are given in milliseconds; higher values indicate slower
animations, not faster ones. The default duration is 400 milliseconds.
The strings 'fast' and 'slow' can be supplied to indicate durations
of 200 and 600 milliseconds, respectively.
Complete Function
If supplied, the complete callback function is fired once the animation
is complete. This can be useful for stringing different animations
together in sequence. The callback is not sent any arguments, but
this is set to the DOM element being animated. If multiple elements
are animated, the callback is executed once per matched element,
not once for the animation as a whole.
Basic Usage
To animate any element, such as a simple image:

1
2
3
4
5

<div id="clickme">
Click here
</div>
<img id="book" src="book.png" alt="" width="100"
style="position: relative; left: 10px;" />

To animate the opacity, left offset, and height of the image
simultaneously:
1
2
3
4
5
6
7
8
9

$('#clickme').click(function() {
$('#book').animate({
opacity: 0.25,
left: '+=50',
height: 'toggle'
}, 5000, function() {
// Animation complete.
});
});

Note that the target value of the height property is 'toggle' . Since
the image was visible before, the animation shrinks the height to 0 to
hide it. A second click then reverses this transition:

The opacity of the image is already at its target value, so this
property is not animated by the second click. Since the target value
for left is a relative value, the image moves even farther to the right
during this second animation.
Directional properties ( top , right , bottom , left ) have no discernible
effect on elements if their position style property is static , which it
is by default.

Note: The jQuery UI project extends the
.animate() method by allowing some nonnumeric styles such as colors to be
animated. The project also includes
mechanisms for specifying animations
through CSS classes rather than individual
attributes.
Note: if attempting to animate an element
with a height or width of 0px, where
contents of the element are visible due to
overflow, jQuery may clip this overflow
during animation. By fixing the dimensions
of the original element being hidden

however, it is possible to ensure that the
animation runs smoothly. A clearfix can be
used to automatically fix the dimensions of
your main element without the need to set
this manually.
Step Function
The second version of .animate() provides a step option — a
callback function that is fired at each step of the animation. This
function is useful for enabling custom animation types or altering the
animation as it is occurring. It accepts two arguments ( now and fx ),
and this is set to the DOM element being animated.
now :

the numeric value of the property being animated at each

step
fx : a reference to the jQuery.fx prototype object, which
contains a number of properties such as elem for the animated
element, start and end for the first and last value of the
animated property, respectively, and prop for the property being
animated.

Note that the step function is called for each animated property on
each animated element. For example, given two list items, the step
function fires four times at each step of the animation:
1
2
3
4
5
6
7
8
9

$('li').animate({
opacity: .5,
height: '50%'
},
{
step: function(now, fx) {
var data = fx.elem.id + ' ' + fx.prop + ': '
$('body').append('<div>' + data + '</div>');
}

});

10

Easing
The remaining parameter of .animate() is a string naming an easing
function to use. An easing function specifies the speed at which the
animation progresses at different points within the animation. The
only easing implementations in the jQuery library are the default,
called swing , and one that progresses at a constant pace, called
linear . More easing functions are available with the use of plug-ins,
most notably the jQuery UI suite.
Per-property Easing
As of jQuery version 1.4, you can set per-property easing functions
within a single .animate() call. In the first version of .animate() ,
each property can take an array as its value: The first member of the
array is the CSS property and the second member is an easing
function. If a per-property easing function is not defined for a
particular property, it uses the value of the .animate() method's
optional easing argument. If the easing argument is not defined, the
default swing function is used.
For example, to simultaneously animate the width and height with
the swing easing function and the opacity with the linear easing
function:
1
2
3
4
5
6
7
8
9

$('#clickme').click(function() {
$('#book').animate({
width: ['toggle', 'swing'],
height: ['toggle', 'swing'],
opacity: 'toggle'
}, 5000, 'linear', function() {
$(this).after('<div>Animation complete.</div>'
});
});

In the second version of .animate() , the options object can include
the specialEasing property, which is itself an object of CSS
properties and their corresponding easing functions. For example, to
simultaneously animate the width using the linear easing function
and the height using the easeOutBounce easing function:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

$('#clickme').click(function() {
$('#book').animate({
width: 'toggle',
height: 'toggle'
}, {
duration: 5000,
specialEasing: {
width: 'linear',
height: 'easeOutBounce'
},
complete: function() {
$(this).after('<div>Animation complete.</div>'
}
});
});

As previously noted, a plugin is required for the
function.

easeOutBounce

Additional Notes:
All jQuery effects, including .animate() , can be turned off
globally by setting jQuery.fx.off = true , which effectively sets
the duration to 0. For more information, see jQuery.fx.off.

Examples:
Click the button to animate the div with a
number of different properties.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
div {
background-color:#bca;
width:100px;
border:1px solid green;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="go">&raquo; Run</button>
<div id="block">Hello!</div>
<script>
/* Using multiple unit types within one animation. */
$("#go").click(function(){
$("#block").animate({
width: "70%",
opacity: 0.4,
marginLeft: "0.6in",
fontSize: "3em",
borderWidth: "10px"
}, 1500 );
});
</script>

31
32
33

</body>
</html>

Demo
Example:

Animates a div's left property with a relative
value. Click several times on the buttons to see the
relative animations queued up.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

<!DOCTYPE html>
<html>
<head>
<style>
div {
position:absolute;
background-color:#abc;
left:50px;
width:90px;
height:90px;
margin:5px;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="left">&laquo;</button> <button id
<div class="block"></div>
<script>
$("#right").click(function(){
$(".block").animate({"left": "+=50px"}, "slow"
});
$("#left").click(function(){
$(".block").animate({"left": "-=50px"}, "slow"

27
28
29
30
31
32

});
</script>
</body>
</html>

Demo
Example:

The first button shows how an unqueued
animation works. It expands the div out to 90% width
while the font-size is increasing. Once the font-size
change is complete, the border animation will begin.
The second button starts a traditional chained
animation, where each animation will start once the
previous animation on the element has completed.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

<!DOCTYPE html>
<html>
<head>
<style>
div {
background-color:#bca;
width:200px;
height:1.1em;
text-align:center;
border:2px solid green;
margin:3px;
font-size:14px;
}
button {
font-size:14px;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

21
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23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53

<button id="go1">&raquo; Animate Block1</button
<button id="go2">&raquo; Animate Block2</button
<button id="go3">&raquo; Animate Both</button>
<button id="go4">&raquo; Reset</button>
<div id="block1">Block1</div>
<div id="block2">Block2</div>
<script>
$( "#go1" ).click(function(){
$( "#block1" ).animate( { width: "90%" }, { queue:
.animate({ fontSize: "24px" }, 1500 )
.animate({ borderRightWidth: "15px" }, 1500
});
$( "#go2" ).click(function(){
$( "#block2" ).animate({ width: "90%" }, 1000
.animate({ fontSize: "24px" }, 1000 )
.animate({ borderLeftWidth: "15px" }, 1000
});
$( "#go3" ).click(function(){
$( "#go1" ).add( "#go2" ).click();
});

$( "#go4" ).click(function(){
$( "div" ).css({ width: "", fontSize: "", borderWidth:
});
</script>
</body>
</html>

Demo
Example:

Animates the first div's left property and

synchronizes the remaining divs, using the step
function to set their left properties at each stage of the
animation.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32

<!DOCTYPE html>
<html>
<head>
<style>
div {
position: relative;
background-color: #abc;
width: 40px;
height: 40px;
float: left;
margin: 5px;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><button id="go">Run »</button></p>
<div class="block"></div> <div class="block"></
<div class="block"></div> <div class="block"></
<div class="block"></div> <div class="block"></
<script>
$( "#go" ).click(function(){
$( ".block:first" ).animate({
left: 100
}, {
duration: 1000,
step: function( now, fx ){
$( ".block:gt(0)" ).css( "left", now );
}
});

33
34
35
36
37

});
</script>
</body>
</html>

Demo
Example:

Animate all paragraphs to toggle both height
and opacity, completing the animation within 600
milliseconds.
1
2
3

$( "p" ).animate({
height: "toggle", opacity: "toggle"
}, "slow" );

Animate all paragraphs to a left style of 50
and opacity of 1 (opaque, visible), completing the
animation within 500 milliseconds.
Example:

1
2
3

$( "p" ).animate({
left: 50, opacity: 1
}, 500 );

Animate the left and opacity style properties
of all paragraphs; run the animation outside the queue,
so that it will automatically start without waiting for its
turn.
Example:

1
2
3

$( "p" ).animate({
left: "50px", opacity: 1
}, { duration: 500, queue: false });

An example of using an 'easing' function to
provide a different style of animation. This will only
work if you have a plugin that provides this easing
function. Note, this code will do nothing unless the
paragraph element is hidden.
Example:

1
2
3

$( "p" ).animate({
opacity: "show"
}, "slow", "easein" );

Animates all paragraphs to toggle both
height and opacity, completing the animation within
600 milliseconds.
Example:

1
2
3

$( "p" ).animate({
height: "toggle", opacity: "toggle"
}, { duration: "slow" });

Use an easing function to provide a different
style of animation. This will only work if you have a
plugin that provides this easing function.
Example:

1
2
3

$( "p" ).animate({
opacity: "show"
}, { duration: "slow", easing: "easein" });

Animate all paragraphs and execute a
callback function when the animation is complete. The
first argument is an object of CSS properties, the
second specifies that the animation should take 1000
milliseconds to complete, the third states the easing
type, and the fourth argument is an anonymous
callback function.
Example:

1
2
3
4
5

$( "p" ).animate({
height: 200, width: 400, opacity: 0.5
}, 1000, "linear", function() {
alert("all done");
});

POWERED BYHERONOTE
A new version of this book is available!

:animated Selector
Categories: Selectors > Basic Filter | Selectors > jQuery Extensions

animated selector
Description: Select all elements that are in the progress
of an animation at the time the selector is run.
jQuery( ":animated" )

version added: 1.2

Note: If you use a custom jQuery build without the effects module,
the :animated selector will throw an error.

Additional Notes:
Because :animated is a jQuery extension and not part of the
CSS specification, queries using :animated cannot take
advantage of the performance boost provided by the native
DOM querySelectorAll() method. To achieve the best
performance when using :animated to select elements, first
select the elements using a pure CSS selector, then use
.filter(":animated") .

Example:
Change the color of any div that is animated.
1
2
3
4
5
6
7
8
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10
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17
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19
20
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22
23
24
25
26
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<!DOCTYPE html>
<html>
<head>
<style>
div { background:yellow; border:1px solid #AAA
div.colored { background:green; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="run">Run</button>
<div></div>
<div id="mover"></div>
<div></div>
<script>
$("#run").click(function(){
$("div:animated").toggleClass("colored");
});
function animateIt() {
$("#mover").slideToggle("slow", animateIt);
}
animateIt();
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.append()
Categories: Manipulation > DOM Insertion, Inside

.append( content [, content ] )

Returns: jQuery

Description: Insert content, specified by the parameter,
to the end of each element in the set of matched
elements.
.append( content [, content ] )

version added: 1.0

content
Type: htmlString or Element or jQuery
DOM element, HTML string, or jQuery object to insert at the end
of each element in the set of matched elements.
content
Type: htmlString or Element or Array or jQuery
One or more additional DOM elements, arrays of elements,
HTML strings, or jQuery objects to insert at the end of each
element in the set of matched elements.

.append( function(index, html) )

version added: 1.4

function(index, html)
Type: Function()
A function that returns an HTML string, DOM element(s), or
jQuery object to insert at the end of each element in the set of
matched elements. Receives the index position of the element
in the set and the old HTML value of the element as arguments.
Within the function, this refers to the current element in the
set.
The .append() method inserts the specified content as the last child
of each element in the jQuery collection (To insert it as the first child,
use .prepend() ).
The .append() and .appendTo() methods perform the same task.
The major difference is in the syntax-specifically, in the placement of
the content and target. With .append() , the selector expression
preceding the method is the container into which the content is
inserted. With .appendTo() , on the other hand, the content precedes
the method, either as a selector expression or as markup created on

the fly, and it is inserted into the target container.
Consider the following HTML:
1
2
3
4
5

<h2>Greetings</h2>
<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

You can create content and insert it into several elements at once:
1

$('.inner').append('<p>Test</p>');

Each inner
1
2
3
4
5
6
7
8
9
10
11

<div>

element gets this new content:

<h2>Greetings</h2>
<div class="container">
<div class="inner">
Hello
<p>Test</p>
</div>
<div class="inner">
Goodbye
<p>Test</p>
</div>
</div>

You can also select an element on the page and insert it into
another:
1

$('.container').append($('h2'));

If an element selected this way is inserted into a single location
elsewhere in the DOM, it will be moved into the target (not cloned):
1
2
3
4
5

<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
<h2>Greetings</h2>
</div>

If there is more than one target element, however, cloned copies of
the inserted element will be created for each target after the first.
Additional Arguments
Similar to other content-adding methods such as .prepend() and
.before() , .append() also supports passing in multiple arguments as
input. Supported input includes DOM elements, jQuery objects,
HTML strings, and arrays of DOM elements.
For example, the following will insert two new <div> s and an existing
<div> as the last three child nodes of the body:
1
2
3
4
5

var $newdiv1 = $('<div id="object1"/>'),
newdiv2 = document.createElement('div'),
existingdiv1 = document.getElementById('foo'
$('body').append($newdiv1, [newdiv2, existingdiv1]);

Since .append() can accept any number of additional arguments, the
same result can be achieved by passing in the three <div> s as three
separate arguments, like so: $('body').append($newdiv1, newdiv2,
existingdiv1) . The type and number of arguments will largely
depend on how you collect the elements in your code.

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<!DOCTYPE html>
<html>
<head>
<style>
p { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>I would like to say: </p>
<script>
$("p").append("<strong>Hello</strong>");
</script>
</body>
</html>

Demo
Example:
1
2
3
4
5
6
7
8
9

Appends some HTML to all paragraphs.

Appends an Element to all paragraphs.

<!DOCTYPE html>
<html>
<head>
<style>
p { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

10
11
12
13
14
15
16
17

<p>I would like to say: </p>
<script>
$("p").append(document.createTextNode("Hello"
</script>
</body>
</html>

Demo
Example:

Appends a jQuery object (similar to an Array
of DOM Elements) to all paragraphs.
1
2
3
4
5
6
7
8
9
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12
13
14
15
16

<!DOCTYPE html>
<html>
<head>
<style>
p { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<strong>Hello world!!!</strong><p>I would like to say:
<script>
$("p").append( $("strong") );
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

.appendTo()
Categories: Manipulation > DOM Insertion, Inside

.appendTo( target )

Returns: jQuery

Description: Insert every element in the set of matched
elements to the end of the target.
.appendTo( target )

version added: 1.0

target
Type: Selector or htmlString or Element or jQuery
A selector, element, HTML string, or jQuery object; the matched
set of elements will be inserted at the end of the element(s)
specified by this parameter.
The .append() and .appendTo() methods perform the same task.
The major difference is in the syntax-specifically, in the placement of
the content and target. With .append() , the selector expression
preceding the method is the container into which the content is
inserted. With .appendTo() , on the other hand, the content precedes
the method, either as a selector expression or as markup created on
the fly, and it is inserted into the target container.
Consider the following HTML:
1
2
3
4
5

<h2>Greetings</h2>
<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

We can create content and insert it into several elements at once:
1

$('<p>Test</p>').appendTo('.inner');

Each inner

<div>

element gets this new content:

1
2
3
4
5
6
7
8
9
10
11

<h2>Greetings</h2>
<div class="container">
<div class="inner">
Hello
<p>Test</p>
</div>
<div class="inner">
Goodbye
<p>Test</p>
</div>
</div>

We can also select an element on the page and insert it into
another:
1

$('h2').appendTo($('.container'));

If an element selected this way is inserted into a single location
elsewhere in the DOM, it will be moved into the target (not cloned):
1
2
3
4
5

<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
<h2>Greetings</h2>
</div>

If there is more than one target element, however, cloned copies of
the inserted element will be created for each target after the first,
and that new set (the original element plus clones) is returned.

Example:
Append all spans to the element with the ID "foo"
(Check append() documentation for more examples)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<!DOCTYPE html>
<html>
<head>
<style>#foo { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<span>I have nothing more to say... </span>
<div id="foo">FOO! </div>
<script>
$("span").appendTo("#foo");
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
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.attr()
Categories: Attributes | Manipulation > General Attributes

Get the value of an attribute for the first element in the set of matched
elements or set one or more attributes for every matched element.
Contents:
.attr( attributeName )
.attr( attributeName )
.attr( attributeName, value )
.attr( attributeName, value )
.attr( attributes )
.attr( attributeName, function(index, attr) )

.attr( attributeName )

Returns: String

Description: Get the value of an attribute for the first
element in the set of matched elements.
.attr( attributeName )

version added: 1.0

attributeName
Type: String
The name of the attribute to get.
The .attr() method gets the attribute value for only the first element
in the matched set. To get the value for each element individually,
use a looping construct such as jQuery's .each() or .map() method.
As of jQuery 1.6, the .attr() method returns undefined for
attributes that have not been set. In addition, .attr() should not be
used on plain objects, arrays, the window, or the document. To
retrieve and change DOM properties, use the .prop() method.
Using jQuery's .attr() method to get the value of an element's
attribute has two main benefits:
1

2

Convenience: It can be called directly on a jQuery object and
chained to other jQuery methods.
Cross-browser consistency: The values of some attributes
are reported inconsistently across browsers, and even across
versions of a single browser. The .attr() method reduces
such inconsistencies.

Note: Attribute values are strings with the
exception of a few attributes such as value
and tabindex.

Example:
Find the title attribute of the first <em> in the page.
1
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Demo

<!DOCTYPE html>
<html>
<head>
<style>
em { color:blue; font-weight:bold; }
div { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
Once there was a <em title="huge, gigantic">large
</p>
The title of the emphasis is:<div></div>
<script>
var title = $("em").attr("title");
$("div").text(title);
</script>
</body>
</html>

.attr( attributeName, value )

Returns: jQuery

Description: Set one or more attributes for the set of
matched elements.
.attr( attributeName, value )

version added: 1.0

attributeName
Type: String
The name of the attribute to set.
value
Type: String or Number
A value to set for the attribute.

.attr( attributes )

version added: 1.0

attributes
Type: PlainObject
An object of attribute-value pairs to set.

.attr( attributeName, function(index, version added: 1.1
attr) )
attributeName
Type: String
The name of the attribute to set.
function(index, attr)
Type: Function()
A function returning the value to set. this is the current
element. Receives the index position of the element in the set
and the old attribute value as arguments.
The .attr() method is a convenient way to set the value of
attributes—especially when setting multiple attributes or using
values returned by a function. Consider the following image:
1

<img id="greatphoto" src="brush-seller.jpg" alt=

Setting a simple attribute
To change the alt attribute, simply pass the name of the attribute
and its new value to the .attr() method:
1

$('#greatphoto').attr('alt', 'Beijing Brush Seller'

Add an attribute the same way:
1
2

$('#greatphoto')
.attr('title', 'Photo by Kelly Clark');

Setting several attributes at once
To change the alt attribute and add the title attribute at the same
time, pass both sets of names and values into the method at once
using a plain JavaScript object. Each key-value pair in the object
adds or modifies an attribute:
1
2
3
4

$('#greatphoto').attr({
alt: 'Beijing Brush Seller',
title: 'photo by Kelly Clark'
});

When setting multiple attributes, the quotes around attribute names
are optional.
WARNING: When setting the 'class' attribute, you must always use
quotes!
Note: jQuery prohibits changing the type attribute on an <input> or
<button> element and will throw an error in all browsers. This is
because the type attribute cannot be changed in Internet Explorer.

Computed attribute values
By using a function to set attributes, you can compute the value
based on other properties of the element. For example, to
concatenate a new value with an existing value:
1
2
3

$('#greatphoto').attr('title', function(i, val) {
return val + ' - photo by Kelly Clark'
});

This use of a function to compute attribute values can be particularly
useful when modifying the attributes of multiple elements at once.
Note: If nothing is returned in the setter function (ie. function(index,
attr){}) , or if undefined is returned, the current value is not
changed. This is useful for selectively setting values only when
certain criteria are met.

Examples:
Example:

Set some attributes for all <img>s in the

page.
1
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<!DOCTYPE html>
<html>
<head>
<style>
img { padding:10px; }
div { color:red; font-size:24px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<img />
<img />
<img />
<div><B>Attribute of Ajax</B></div>
<script>
$("img").attr({
src: "/resources/hat.gif",
title: "jQuery",
alt: "jQuery Logo"
});
$("div").text($("img").attr("alt"));
</script>
</body>
</html>

Demo
Example:

Set the id for divs based on the position in

the page.
1
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<!DOCTYPE html>
<html>
<head>
<style>
div { color:blue; }
span { color:red; }
b { font-weight:bolder; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>Zero-th <span></span></div>
<div>First <span></span></div>
<div>Second <span></span></div>
<script>
$("div").attr("id", function (arr) {
return "div-id" + arr;
})
.each(function () {
$("span", this).html("(ID = '<b>" + this.id +
});
</script>
</body>
</html>

Demo
Example:

image.

Set the src attribute from title attribute on the

1
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<img title="hat.gif"/>
<script>
$("img").attr("src", function() {
return "/resources/" + this.title;
});
</script>
</body>
</html>

Demo
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Attribute Contains Prefix
Selector [name|="value"]
Categories: Selectors > Attribute

attributeContainsPrefix selector
Description: Selects elements that have the specified
attribute with a value either equal to a given string or
starting with that string followed by a hyphen (-).
jQuery( "[attribute|='value']" )

version added: 1.0

attribute: An attribute name.
value: An attribute value. Can be either an unquoted single word
or a quoted string.
This selector was introduced into the CSS specification to handle
language attributes.

Example:
Finds all links with an hreflang attribute that is
english.
1
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<!DOCTYPE html>
<html>
<head>
<style>
a { display: inline-block; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<a href="example.html" hreflang="en">Some text

<a href="example.html" hreflang="en-UK">Some other tex
<a href="example.html" hreflang="english">will not be
<script>
$('a[hreflang|="en"]').css('border','3px dotted green'
</script>
</body>
</html>

Demo
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Attribute Contains Selector
[name*="value"]
Categories: Selectors > Attribute

attributeContains selector
Description: Selects elements that have the specified
attribute with a value containing the a given substring.
jQuery( "[attribute*='value']" )

version added: 1.0

attribute: An attribute name.
value: An attribute value. Can be either an unquoted single word
or a quoted string.
This is the most generous of the jQuery attribute selectors that
match against a value. It will select an element if the selector's string
appears anywhere within the element's attribute value. Compare this
selector with the Attribute Contains Word selector (e.g.
[attr~="word"]), which is more appropriate in many cases.

Example:
Finds all inputs with a name attribute that contains
'man' and sets the value with some text.
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<input name="man-news" />
<input name="milkman" />
<input name="letterman2" />
<input name="newmilk" />
<script>$('input[name*="man"]').val('has man in it!'
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

Attribute Contains Word
Selector [name~="value"]
Categories: Selectors > Attribute

attributeContainsWord selector
Description: Selects elements that have the specified
attribute with a value containing a given word, delimited
by spaces.
jQuery( "[attribute~='value']" )

version added: 1.0

attribute: An attribute name.
value: An attribute value. Can be either an unquoted single word
or a quoted string.
This selector matches the test string against each word in the
attribute value, where a "word" is defined as a string delimited by
whitespace. The selector matches if the test string is exactly equal to
any of the words.

Example:
Finds all inputs with a name attribute that contains
the word 'man' and sets the value with some text.
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<input name="man-news" />
<input name="milk man" />
<input name="letterman2" />
<input name="newmilk" />
<script>$('input[name~="man"]').val('mr. man is in it!'
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

Attribute Ends With Selector
[name$="value"]
Categories: Selectors > Attribute

attributeEndsWith selector
Description: Selects elements that have the specified
attribute with a value ending exactly with a given string.
The comparison is case sensitive.
jQuery( "[attribute$='value']" )

version added: 1.0

attribute: An attribute name.
value: An attribute value. Can be either an unquoted single word
or a quoted string.

Example:
Finds all inputs with an attribute name that ends with
'letter' and puts text in them.
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<input name="newsletter" />
<input name="milkman" />
<input name="jobletter" />
<script>$('input[name$="letter"]').val('a letter'
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

Attribute Equals Selector
[name="value"]
Categories: Selectors > Attribute

attributeEquals selector
Description: Selects elements that have the specified
attribute with a value exactly equal to a certain value.
jQuery( "[attribute='value']" )

version added: 1.0

attribute: An attribute name.
value: An attribute value. Can be either an unquoted single
word or a quoted string.

Example:
Finds all inputs with a value of "Hot Fuzz" and
changes the text of the next sibling span.
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<label>
<input type="radio" name="newsletter" value
<span>name?</span>
</label>
</div>
<div>
<label>
<input type="radio" name="newsletter" value
<span>value?</span>
</label>
</div>
<div>
<label>
<input type="radio" name="newsletter" value
<span>value?</span>
</label>
</div>
<script>$('input[value="Hot Fuzz"]').next().text(
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

Attribute Not Equal Selector
[name!="value"]
Categories: Selectors > Attribute | Selectors > jQuery Extensions

attributeNotEqual selector
Description: Select elements that either don't have the
specified attribute, or do have the specified attribute but
not with a certain value.
jQuery( "[attribute!='value']" )

version added: 1.0

attribute: An attribute name.
value: An attribute value. Can be either an unquoted single word
or a quoted string.
This selector is equivalent to

:not([attr="value"]) .

Additional Notes:
Because [name!="value"] is a jQuery extension and not part of
the CSS specification, queries using [name!="value"] cannot
take advantage of the performance boost provided by the native
DOM querySelectorAll() method. For better performance in
modern browsers, use $("your-pure-cssselector").not('[name="value"]') instead.

Example:
Finds all inputs that don't have the name 'newsletter'
and appends text to the span next to it.
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Demo

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<input type="radio" name="newsletter" value
<span>name is newsletter</span>
</div>
<div>
<input type="radio" value="Cold Fusion" />
<span>no name</span>

</div>
<div>
<input type="radio" name="accept" value="Evil Plans"
<span>name is accept</span>
</div>
<script>$('input[name!="newsletter"]').next().append(
</body>
</html>

POWERED BYHERONOTE
A new version of this book is available!

Attribute Starts With Selector
[name^="value"]
Categories: Selectors > Attribute

attributeStartsWith selector
Description: Selects elements that have the specified
attribute with a value beginning exactly with a given
string.
jQuery( "[attribute^='value']" )

version added: 1.0

attribute: An attribute name.
value: An attribute value. Can be either an unquoted single word
or a quoted string.
This selector can be useful for identifying elements in pages
produced by server-side frameworks that produce HTML with
systematic element IDs. However it will be slower than using a class
selector so leverage classes, if you can, to group like elements.

Example:
Finds all inputs with an attribute name that starts with
'news' and puts text in them.
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<input name="newsletter" />
<input name="milkman" />
<input name="newsboy" />
<script>$('input[name^="news"]').val('news here!'
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.before()
Categories: Manipulation > DOM Insertion, Outside

.before( content [, content ] )

Returns: jQuery

Description: Insert content, specified by the parameter,
before each element in the set of matched elements.
.before( content [, content ] )

version added: 1.0

content
Type: htmlString or Element or jQuery
HTML string, DOM element, or jQuery object to insert before
each element in the set of matched elements.
content
Type: htmlString or Element or Array or jQuery
One or more additional DOM elements, arrays of elements,
HTML strings, or jQuery objects to insert before each element in
the set of matched elements.

.before( function )

version added: 1.4

function
Type: Function()
A function that returns an HTML string, DOM element(s), or
jQuery object to insert before each element in the set of
matched elements. Receives the index position of the element
in the set as an argument. Within the function, this refers to
the current element in the set.
The .before() and .insertBefore() methods perform the same task.
The major difference is in the syntax-specifically, in the placement of
the content and target. With .before() , the selector expression
preceding the method is the container before which the content is
inserted. With .insertBefore() , on the other hand, the content
precedes the method, either as a selector expression or as markup
created on the fly, and it is inserted before the target container.
Consider the following HTML:
1

<div class="container">

2
3
4
5

<h2>Greetings</h2>
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

You can create content and insert it before several elements at once:
1

$('.inner').before('<p>Test</p>');

Each inner
1
2
3
4
5
6
7

<div>

element gets this new content:

<div class="container">
<h2>Greetings</h2>
<p>Test</p>
<div class="inner">Hello</div>
<p>Test</p>
<div class="inner">Goodbye</div>
</div>

You can also select an element on the page and insert it before
another:
1

$('.container').before($('h2'));

If an element selected this way is inserted into a single location
elsewhere in the DOM, it will be moved before the target (not
cloned):
1
2
3
4

<h2>Greetings</h2>
<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>

5

</div>

If there is more than one target element, however, cloned copies of
the inserted element will be created for each target after the first.
In jQuery 1.4, .before() and
disconnected DOM nodes:
1

.after()

will also work on

$("<div/>").before("<p></p>");

The result is a jQuery set that contains a paragraph and a div (in that
order).
Additional Arguments
Similar to other content-adding methods such as .prepend() and
.after() , .before() also supports passing in multiple arguments as
input. Supported input includes DOM elements, jQuery objects,
HTML strings, and arrays of DOM elements.
For example, the following will insert two new
<div> before the first paragraph:
1
2
3
4
5

<div> s

and an existing

var $newdiv1 = $('<div id="object1"/>'),
newdiv2 = document.createElement('div'),
existingdiv1 = document.getElementById('foo'

$('p').first().before($newdiv1, [newdiv2, existingdiv1])

Since .before() can accept any number of additional arguments, the
same result can be achieved by passing in the three <div> s as three
separate arguments, like so: $('p').first().before($newdiv1,
newdiv2, existingdiv1) . The type and number of arguments will
largely depend on how you collect the elements in your code.

Examples:
Example:
1
2
3
4
5
6
7
8
9
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<!DOCTYPE html>
<html>
<head>
<style>p { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p> is what I said...</p>
<script>$("p").before("<b>Hello</b>");</script>
</body>
</html>

Demo
Example:
1
2
3
4
5
6
7
8
9
10
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12

Inserts some HTML before all paragraphs.

Inserts a DOM element before all paragraphs.

<!DOCTYPE html>
<html>
<head>
<style>p { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p> is what I said...</p>
<script>$("p").before( document.createTextNode(
</body>
</html>

Demo
Example:

Inserts a jQuery object (similar to an Array of
DOM Elements) before all paragraphs.
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<!DOCTYPE html>
<html>
<head>
<style>p { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p> is what I said...</p><b>Hello</b>
<script>$("p").before( $("b") );</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.bind()
Categories: Events > Event Handler Attachment

.bind( eventType [, eventData ], handler(eventObject) )
Returns: jQuery
Description: Attach a handler to an event for the
elements.
.bind( eventType [, eventData ],
handler(eventObject) )

version added: 1.0

eventType
Type: String
A string containing one or more DOM event types, such as
"click" or "submit," or custom event names.
eventData
Type: Object
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.bind( eventType [, eventData ],
preventBubble )

version added: 1.4.3

eventType
Type: String
A string containing one or more DOM event types, such as
"click" or "submit," or custom event names.
eventData
Type: Object
An object containing data that will be passed to the event
handler.
preventBubble
Type: Boolean
Setting the third argument to false will attach a function that
prevents the default action from occurring and stops the event

from bubbling. The default is true.

.bind( events )

version added: 1.4

events
Type: Object
An object containing one or more DOM event types and
functions to execute for them.
As of jQuery 1.7, the .on() method is the preferred method for
attaching event handlers to a document. For earlier versions, the
.bind() method is used for attaching an event handler directly to
elements. Handlers are attached to the currently selected elements
in the jQuery object, so those elements must exist at the point the
call to .bind() occurs. For more flexible event binding, see the
discussion of event delegation in .on() or .delegate() .
Any string is legal for eventType ; if the string is not the name of a
native DOM event, then the handler is bound to a custom event.
These events are never called by the browser, but may be triggered
manually from other JavaScript code using .trigger() or
.triggerHandler() .
If the eventType string contains a period ( . ) character, then the
event is namespaced. The period character separates the event
from its namespace. For example, in the call .bind('click.name',
handler) , the string click is the event type, and the string name is
the namespace. Namespacing allows us to unbind or trigger some
events of a type without affecting others. See the discussion of
.unbind() for more information.
There are shorthand methods for some standard browser events
such as .click() that can be used to attach or trigger event
handlers. For a complete list of shorthand methods, see the events
category.
When an event reaches an element, all handlers bound to that event
type for the element are fired. If there are multiple handlers
registered, they will always execute in the order in which they were
bound. After all handlers have executed, the event continues along
the normal event propagation path.

A basic usage of
1
2
3

.bind()

is:

$('#foo').bind('click', function() {
alert('User clicked on "foo."');
});

This code will cause the element with an ID of foo to respond to the
click event. When a user clicks inside this element thereafter, the
alert will be shown.
Multiple Events
Multiple event types can be bound at once by including each one
separated by a space:
1
2
3

$('#foo').bind('mouseenter mouseleave', function
$(this).toggleClass('entered');
});

The effect of this on <div id="foo"> (when it does not initially have
the "entered" class) is to add the "entered" class when the mouse
enters the <div> and remove the class when the mouse leaves.
As of jQuery 1.4 we can bind multiple event handlers simultaneously
by passing an object of event type/handler pairs:
1
2
3
4
5
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$('#foo').bind({
click: function() {
// do something on click
},
mouseenter: function() {
// do something on mouseenter
}
});

Event Handlers
The handler parameter takes a callback function, as shown above.
Within the handler, the keyword this refers to the DOM element to
which the handler is bound. To make use of the element in jQuery, it
can be passed to the normal $() function. For example:
1
2
3

$('#foo').bind('click', function() {
alert($(this).text());
});

After this code is executed, when the user clicks inside the element
with an ID of foo , its text contents will be shown as an alert.
As of jQuery 1.4.2 duplicate event handlers can be bound to an
element instead of being discarded. This is useful when the event
data feature is being used, or when other unique data resides in a
closure around the event handler function.
In jQuery 1.4.3 you can now pass in false in place of an event
handler. This will bind an event handler equivalent to: function(){
return false; } . This function can be removed at a later time by
calling: .unbind( eventName, false ) .
The Event object
The handler callback function can also take parameters. When the
function is called, the event object will be passed to the first
parameter.
The event object is often unnecessary and the parameter omitted,
as sufficient context is usually available when the handler is bound
to know exactly what needs to be done when the handler is
triggered. However, at times it becomes necessary to gather more
information about the user's environment at the time the event was
initiated. View the full Event Object.
Returning

false from a handler is equivalent to calling both
.preventDefault() and .stopPropagation() on the event object.

Using the event object in a handler looks like this:

1
2
3
4
5
6

$(document).ready(function() {
$('#foo').bind('click', function(event) {
alert('The mouse cursor is at ('
+ event.pageX + ', ' + event.pageY + ')');
});
});

Note the parameter added to the anonymous function. This code will
cause a click on the element with ID foo to report the page
coordinates of the mouse cursor at the time of the click.
Passing Event Data
The optional eventData parameter is not commonly used. When
provided, this argument allows us to pass additional information to
the handler. One handy use of this parameter is to work around
issues caused by closures. For example, suppose we have two
event handlers that both refer to the same external variable:
1
2
3
4
5
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var message = 'Spoon!';
$('#foo').bind('click', function() {
alert(message);
});
message = 'Not in the face!';
$('#bar').bind('click', function() {
alert(message);
});

Because the handlers are closures that both have message in their
environment, both will display the message Not in the face! when
triggered. The variable's value has changed. To sidestep this, we
can pass the message in using eventData :
1

var message = 'Spoon!';

2
3
4
5
6
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$('#foo').bind('click', {msg: message}, function
alert(event.data.msg);
});
message = 'Not in the face!';
$('#bar').bind('click', {msg: message}, function
alert(event.data.msg);
});

This time the variable is not referred to directly within the handlers;
instead, the variable is passed in by value through eventData , which
fixes the value at the time the event is bound. The first handler will
now display Spoon! while the second will alert Not in the face!

Note that objects are passed to functions by
reference, which further complicates this
scenario.
If eventData is present, it is the second argument to the .bind()
method; if no additional data needs to be sent to the handler, then
the callback is passed as the second and final argument.

See the .trigger() method reference for a
way to pass data to a handler at the time
the event happens rather than when the
handler is bound.
As of jQuery 1.4 we can no longer attach data (and thus, events) to
object, embed, or applet elements because critical errors occur
when attaching data to Java applets.
Note: Although demonstrated in the next example, it is inadvisable
to bind handlers to both the click and dblclick events for the same

element. The sequence of events triggered varies from browser to
browser, with some receiving two click events before the dblclick
and others only one. Double-click sensitivity (maximum time
between clicks that is detected as a double click) can vary by
operating system and browser, and is often user-configurable.

Examples:
Handle click and double-click for the
paragraph. Note: the coordinates are window relative,
so in this case relative to the demo iframe.
Example:
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<!DOCTYPE html>
<html>
<head>
<style>
p { background:yellow; font-weight:bold; cursor
padding:5px; }
p.over { background: #ccc; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Click or double click here.</p>
<span></span>
<script>
$("p").bind("click", function(event){
var str = "( " + event.pageX + ", " + event.pageY +
$("span").text("Click happened! " + str);
});
$("p").bind("dblclick", function(){
$("span").text("Double-click happened in " + this
});
$("p").bind("mouseenter mouseleave", function(event){
$(this).toggleClass("over");
});
</script>
</body>

30

</html>

Demo
Example:

To display each paragraph's text in an alert
box whenever it is clicked:
1
2
3

$("p").bind("click", function(){
alert( $(this).text() );
});

You can pass some extra data before the
event handler:
Example:

1
2
3
4

function handler(event) {
alert(event.data.foo);
}
$("p").bind("click", {foo: "bar"}, handler)

Cancel a default action and prevent it from
bubbling up by returning false :
Example:

1

$("form").bind("submit", function() { return false

Cancel only the default action by using the
.preventDefault() method.
Example:

1
2
3

$("form").bind("submit", function(event) {
event.preventDefault();
});

Stop an event from bubbling without
preventing the default action by using the
.stopPropagation() method.
Example:

1
2
3

$("form").bind("submit", function(event) {
event.stopPropagation();
});

Example:
1
2
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Bind custom events.

<!DOCTYPE html>
<html>
<head>
<style>
p { color:red; }
span { color:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Has an attached custom event.</p>
<button>Trigger custom event</button>
<span style="display:none;"></span>
<script>

$("p").bind("myCustomEvent", function(e, myName, myValue
$(this).text(myName + ", hi there!");
$("span").stop().css("opacity", 1)
.text("myName = " + myName)
.fadeIn(30).fadeOut(1000);
});
$("button").click(function () {
$("p").trigger("myCustomEvent", [ "John" ]);
});
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</script>
</body>
</html>

Demo
Example:
1
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3
4
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Bind multiple events simultaneously.

$("div.test").bind({
click: function(){
$(this).addClass("active");
},
mouseenter: function(){
$(this).addClass("inside");
},
mouseleave: function(){
$(this).removeClass("inside");
}
});

POWERED BYHERONOTE
A new version of this book is available!

.blur()
Categories: Events > Form Events | Forms

.blur( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "blur"
JavaScript event, or trigger that event on an element.
.blur( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.blur( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: Object
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.blur()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('blur', handler) in the first two
variations, and .trigger('blur') in the third.
The blur event is sent to an element when it loses focus. Originally,
this event was only applicable to form elements, such as <input> . In
recent browsers, the domain of the event has been extended to
include all element types. An element can lose focus via keyboard
commands, such as the Tab key, or by mouse clicks elsewhere on
the page.
For example, consider the HTML:

1
2
3
4
5
6
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8
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<form>
<input id="target" type="text" value="Field 1"
<input type="text" value="Field 2" />
</form>
<div id="other">
Trigger the handler
</div>
The event handler can be bound to the first input field
$('#target').blur(function() {
alert('Handler for .blur() called.');
});

Now if the first field has the focus, clicking elsewhere or tabbing
away from it displays the alert:
Handler for .blur() called.
To trigger the event programmatically, apply
argument:
1
2
3

.blur()

without an

$('#other').click(function() {
$('#target').blur();
});

After this code executes, clicks on Trigger the handler will also alert
the message.
The blur event does not bubble in Internet Explorer. Therefore,
scripts that rely on event delegation with the blur event will not work
consistently across browsers. As of version 1.4.2, however, jQuery
works around this limitation by mapping blur to the focusout event
in its event delegation methods, .live() and .delegate() .

Example:
To trigger the blur event on all paragraphs:
1

$("p").blur();

POWERED BYHERONOTE
A new version of this book is available!

:button Selector
Categories: Selectors > Form | Selectors > jQuery Extensions

button selector
Description: Selects all button elements and elements
of type button.
jQuery( ":button" )
An equivalent selector to
input[type='button']") .

version added: 1.0
$(":button")

using valid CSS is

$("button,

Additional Notes:
Because :button is a jQuery extension and not part of the CSS
specification, queries using :button cannot take advantage of
the performance boost provided by the native DOM
querySelectorAll() method. To achieve the best performance
when using :button to select elements, first select the elements
using a pure CSS selector, then use .filter(":button") .

Example:
Find all button inputs and mark them.
1
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25
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<!DOCTYPE html>
<html>
<head>
<style>
textarea { height:35px; }
div { color: red; }
fieldset { margin: 0; padding: 0; border-width
.marked { background-color: yellow; border: 3
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<fieldset>
<input type="button" value="Input Button"/>
<input type="checkbox" />
<input type="file" />
<input type="hidden" />
<input type="image" />
<input type="password" />
<input type="radio" />
<input type="reset" />
<input type="submit" />
<input type="text" />
<select><option>Option<option/></select>
<textarea></textarea>
<button>Button</button>
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</fieldset>
</form>

<div>
</div>
<script>
var input = $(":button").addClass("marked");
$("div").text( "For this type jQuery found " + input.l
$("form").submit(function () { return false; });
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

callbacks.add()
Categories: Callbacks Object

callbacks.add( callbacks )

Returns: Callbacks

Description: Add a callback or a collection of callbacks
to a callback list.
callbacks.add( callbacks )

version added: 1.7

callbacks
Type: Function() or Array
A function, or array of functions, that are to be added to the
callback list.
This method returns the Callbacks object onto which it is attached
( this ).

Example
Use
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28

callbacks.add()

to add new callbacks to a callback list:

// a sample logging function to be added to a callbacks
var foo = function( value ) {
console.log( "foo: " + value );
};
// another function to also be added to the list
var bar = function( value ){
console.log( "bar: " + value );
};
var callbacks = $.Callbacks();
// add the function "foo" to the list
callbacks.add( foo );
// fire the items on the list
callbacks.fire( "hello" );
// outputs: "foo: hello"
// add the function "bar" to the list
callbacks.add( bar );
// fire the items on the list again
callbacks.fire( "world" );
// outputs:
// "foo: world"
// "bar: world"

POWERED BYHERONOTE
A new version of this book is available!

callbacks.disable()
Categories: Callbacks Object

callbacks.disable()

Returns: Callbacks

Description: Disable a callback list from doing anything
more.
callbacks.disable()

version added: 1.7

This method does not accept any arguments.
This method returns the Callbacks object onto which it is attached
( this ).

Example
Use
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callbacks.disable()

to disable further calls to a callback list:

// a sample logging function to be added to a callbacks
var foo = function( value ) {
console.log( value );
};
var callbacks = $.Callbacks();
// add the above function to the list
callbacks.add( foo );
// fire the items on the list
callbacks.fire( "foo" );
// outputs: foo
// disable further calls being possible
callbacks.disable();
// attempt to fire with "foobar" as an argument
callbacks.fire( "foobar" );
// foobar isn't output

POWERED BYHERONOTE

A new version of this book is available!

callbacks.disabled()
Categories: Callbacks Object

callbacks.disabled()

Returns: Boolean

Description: Determine if the callbacks list has been
disabled.
callbacks.disabled()
This method does not accept any arguments.

version added: 1.7

Example:
Use callbacks.disabled() to determine if the callbacks list
has been disabled:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

// a sample logging function to be added to a callbacks
var foo = function( value ) {
console.log( "foo:" + value );
};
var callbacks = $.Callbacks();
// add the logging function to the callback list
callbacks.add( foo );
// fire the items on the list, passing an argument
callbacks.fire( "hello" );
// outputs "foo: hello"
// disable the callbacks list
callbacks.disable();
// test the disabled state of the list
console.log ( callbacks.disabled() );
// outputs: true

POWERED BYHERONOTE

A new version of this book is available!

callbacks.empty()
Categories: Callbacks Object

callbacks.empty()

Returns: Callbacks

Description: Remove all of the callbacks from a list.
callbacks.empty()

version added: 1.7

This method does not accept any arguments.
This method returns the Callbacks object onto which it is attached
( this ).

Example
Use
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callbacks.empty()

to empty a list of callbacks:

// a sample logging function to be added to a callbacks
var foo = function( value1, value2 ) {
console.log( "foo: " + value1 + "," + value2 );
}
// another function to also be added to the list
var bar = function( value1, value2 ){
console.log( "bar: " + value1 + "," + value2 );
}
var callbacks = $.Callbacks();
// add the two functions
callbacks.add( foo );
callbacks.add( bar );
// empty the callbacks list
callbacks.empty();
// check to ensure all callbacks have been removed
console.log( callbacks.has( foo ) );
// false
console.log( callbacks.has( bar ) );
// false

POWERED BYHERONOTE

A new version of this book is available!

callbacks.fire()
Categories: Callbacks Object

callbacks.fire( arguments )

Returns: Callbacks

Description: Call all of the callbacks with the given
arguments
callbacks.fire( arguments )

version added: 1.7

arguments
Type: Anything
The argument or list of arguments to pass back to the callback
list.
This method returns the Callbacks object onto which it is attached
( this ).

Example
Use callbacks.fire() to invoke the callbacks in a list with any
arguments that have been passed:
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// a sample logging function to be added to a callbacks
var foo = function( value ) {
console.log( "foo:" + value );
}
var callbacks = $.Callbacks();
// add the function "foo" to the list
callbacks.add( foo );
// fire the items on the list
callbacks.fire( "hello" ); // outputs: "foo: hello"
callbacks.fire( "world" ); // outputs: "foo: world"
// add another function to the list
var bar = function( value ){
console.log( "bar:" + value );
}
// add this function to the list
callbacks.add( bar );
// fire the items on the list again
callbacks.fire( "hello again" );
// outputs:
// "foo: hello again"
// "bar: hello again"

POWERED BYHERONOTE
A new version of this book is available!

callbacks.fired()
Categories: Callbacks Object

callbacks.fired()

Returns: Boolean

Description: Determine if the callbacks have already
been called at least once.
callbacks.fired()
This method does not accept any arguments.

version added: 1.7

Example
Use callbacks.fired() to determine if the callbacks in a list have
been called at least once:
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// a sample logging function to be added to a callbacks
var foo = function( value ) {
console.log( "foo:" + value );
};
var callbacks = $.Callbacks();
// add the function "foo" to the list
callbacks.add( foo );
// fire the items on the list
callbacks.fire( "hello" ); // outputs: "foo: hello"
callbacks.fire( "world" ); // outputs: "foo: world"
// test to establish if the callbacks have been called
console.log( callbacks.fired() );

POWERED BYHERONOTE
A new version of this book is available!

callbacks.fireWith()
Categories: Callbacks Object

callbacks.fireWith( [context ] [, args ] ) Returns: Callbacks
Description: Call all callbacks in a list with the given
context and arguments.
callbacks.fireWith( [context ] [, args ] version added: 1.7
)
context
Type:
A reference to the context in which the callbacks in the list
should be fired.
args
Type:
An argument, or array of arguments, to pass to the callbacks in
the list.
This method returns the Callbacks object onto which it is attached
( this ).

Example
Use callbacks.fireWith() to fire a list of callbacks with a specific
context and an array of arguments:
1
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// a sample logging function to be added to a callbacks
var log = function( value1, value2 ) {
console.log( "Received: " + value1 + "," + value2 );
};
var callbacks = $.Callbacks();
// add the log method to the callbacks list
callbacks.add( log );

// fire the callbacks on the list using the context "wi
// and an arguments array
callbacks.fireWith( window, ["foo","bar"]);
// outputs: "Received: foo, bar"

POWERED BYHERONOTE
A new version of this book is available!

callbacks.has()
Categories: Callbacks Object

callbacks.has( callback )

Returns: Boolean

Description: Determine whether a supplied callback is
in a list
callbacks.has( callback )
callback
Type: Function()
The callback to search for.

version added: 1.7

Example:
Use callbacks.has() to check if a callback list contains a
specific callback:
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// a sample logging function to be added to a callbacks
var foo = function( value1, value2 ) {
console.log( "Received: " + value1 + "," + value2 );
};

// a second function which will not be added to the list
var bar = function( value1, value2 ) {
console.log( "foobar" );
}
var callbacks = $.Callbacks();
// add the log method to the callbacks list
callbacks.add( foo );
// determine which callbacks are in the list
console.log( callbacks.has( foo ) );
// true
console.log( callbacks.has( bar ) );
// false

POWERED BYHERONOTE

A new version of this book is available!

callbacks.lock()
Categories: Callbacks Object

callbacks.lock()

Returns: Callbacks

Description: Lock a callback list in its current state.
callbacks.lock()

version added: 1.7

This method does not accept any arguments.
This method returns the Callbacks object onto which it is attached
( this ).
If the Callbacks object is created with the "memory" flag as its
argument, additional functions may be added and fired after the
callback list is locked.

Examples:
Use callbacks.lock() to lock a callback list to
avoid further changes being made to the list state:
Example:

1
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// a sample logging function to be added to a callbacks
var foo = function( value ) {
console.log( "foo:" + value );
};
var callbacks = $.Callbacks();
// add the logging function to the callback list
callbacks.add( foo );
// fire the items on the list, passing an argument
callbacks.fire( "hello" );
// outputs "foo: hello"
// lock the callbacks list
callbacks.lock();
// try firing the items again
callbacks.fire( "world" );
// as the list was locked, no items
// were called, so "world" isn"t logged

Use callbacks.lock() to lock a callback list with
"memory," and then resume using the list:
Example:

1
2

<!DOCTYPE html>
<html>
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<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="log"></div>
<script>// simple function for logging results
var log = function( value) {
$( "#log" ).append( "<p>" + value + "</p>" );
};
// two sample functions to be added to a callbacks list
var foo = function( value ) {
log( "foo: " + value );
};
var bar = function( value ) {
log( "bar: " + value );
};
// create the callbacks object with the "memory" flag
var callbacks = $.Callbacks( "memory" );
// add the foo logging function to the callback list
callbacks.add( foo );
// fire the items on the list, passing an argument
callbacks.fire( "hello" );
// outputs "foo: hello"
// lock the callbacks list
callbacks.lock();
// try firing the items again
callbacks.fire( "world" );
// as the list was locked, no items were called,
// so "foo: world" isn't logged
// add the foo function to the callback list again
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callbacks.add( foo );

// try firing the items again
callbacks.fire( "silentArgument" );
// outputs "foo: hello" because the argument value was s
// add the bar function to the callback list
callbacks.add( bar );

callbacks.fire( "youHadMeAtHello" );
// outputs "bar: hello" because the list is still locked
// and the argument value is still stored in memory
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

callbacks.locked()
Categories: Callbacks Object

callbacks.locked()

Returns: Boolean

Description: Determine if the callbacks list has been
locked.
callbacks.locked()
This method does not accept any arguments.

version added: 1.7

Example:
Use callbacks.locked() to determine the lock-state of a
callback list:
1
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// a sample logging function to be added to a callbacks
var foo = function( value ) {
console.log( "foo: " + value);
};
var callbacks = $.Callbacks();
// add the logging function to the callback list
callbacks.add( foo );
// fire the items on the list, passing an argument
callbacks.fire( "hello" );
// outputs "foo: hello"
// lock the callbacks list
callbacks.lock();
// test the lock-state of the list
console.log ( callbacks.locked() );
// true

POWERED BYHERONOTE

A new version of this book is available!

callbacks.remove()
Categories: Callbacks Object

callbacks.remove( callbacks )

Returns: Callbacks

Description: Remove a callback or a collection of
callbacks from a callback list.
callbacks.remove( callbacks )

version added: 1.7

callbacks
Type: Function() or Array
A function, or array of functions, that are to be removed from
the callback list.
This method returns the Callbacks object onto which it is attached
( this ).

Example:
Use callbacks.remove() to remove callbacks from a
callback list:
1
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// a sample logging function to be added to a callbacks
var foo = function( value ) {
console.log( "foo: " + value );
};
var callbacks = $.Callbacks();
// add the function "foo" to the list
callbacks.add( foo );
// fire the items on the list
callbacks.fire( "hello" );
// outputs: "foo: hello"
// remove "foo" from the callback list
callbacks.remove( foo );
// fire the items on the list again
callbacks.fire( "world" );
// nothing output as "foo" is no longer in the list

POWERED BYHERONOTE

A new version of this book is available!

.change()
Categories: Events > Form Events | Forms

.change( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "change"
JavaScript event, or trigger that event on an element.
.change( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.change( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: Object
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.change()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('change', handler) in the first two
variations, and .trigger('change') in the third.
The change event is sent to an element when its value changes. This
event is limited to <input> elements, <textarea> boxes and <select>
elements. For select boxes, checkboxes, and radio buttons, the
event is fired immediately when the user makes a selection with the
mouse, but for the other element types the event is deferred until the
element loses focus.
For example, consider the HTML:

1
2
3
4
5
6
7
8
9
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<form>
<input class="target" type="text" value="Field 1"
<select class="target">
<option value="option1" selected="selected"
<option value="option2">Option 2</option>
</select>
</form>
<div id="other">
Trigger the handler
</div>

The event handler can be bound to the text input and the select box:
1
2
3

$('.target').change(function() {
alert('Handler for .change() called.');
});

Now when the second option is selected from the dropdown, the
alert is displayed. It is also displayed if you change the text in the
field and then click away. If the field loses focus without the contents
having changed, though, the event is not triggered. To trigger the
event manually, apply .change() without arguments:
1
2
3

$('#other').click(function() {
$('.target').change();
});

After this code executes, clicks on Trigger the handler will also alert
the message. The message will display twice, because the handler
has been bound to the change event on both of the form elements.
As of jQuery 1.4, the change event bubbles in Internet Explorer,
behaving consistently with the event in other modern browsers.

Examples:
Attaches a change event to the select that
gets the text for each selected option and writes them
in the div. It then triggers the event for the initial text
draw.
Example:
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<!DOCTYPE html>
<html>
<head>
<style>
div { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<select name="sweets" multiple="multiple">
<option>Chocolate</option>
<option selected="selected">Candy</option>
<option>Taffy</option>
<option selected="selected">Caramel</option
<option>Fudge</option>
<option>Cookie</option>
</select>
<div></div>
<script>
$("select").change(function () {
var str = "";
$("select option:selected").each(function () {
str += $(this).text() + " ";
});
$("div").text(str);
})
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.change();
</script>
</body>
</html>

Demo
Example:

To add a validity test to all text input

elements:
1
2
3

$("input[type='text']").change( function() {
// check input ($(this).val()) for validity here
});

POWERED BYHERONOTE
A new version of this book is available!

:checkbox Selector
Categories: Selectors > Form | Selectors > jQuery Extensions

checkbox selector
Description: Selects all elements of type checkbox.
jQuery( ":checkbox" )

version added: 1.0

is equivalent to $('[type=checkbox]') . As with other
pseudo-class selectors (those that begin with a ":") it is
recommended to precede it with a tag name or some other selector;
otherwise, the universal selector ("*") is implied. In other words, the
bare $(':checkbox') is equivalent to $('*:checkbox') , so
$('input:checkbox') should be used instead.
$(':checkbox')

Additional Notes:
Because :checkbox is a jQuery extension and not part of the
CSS specification, queries using :checkbox cannot take
advantage of the performance boost provided by the native
DOM querySelectorAll() method. For better performance in
modern browsers, use [type="checkbox"] instead.

Example:
Finds all checkbox inputs.
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<!DOCTYPE html>
<html>
<head>
<style>
textarea { height:25px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<input type="button" value="Input Button"/>
<input type="checkbox" />
<input type="checkbox" />
<input type="file" />
<input type="hidden" />
<input type="image" />
<input type="password" />
<input type="radio" />
<input type="reset" />
<input type="submit" />
<input type="text" />
<select><option>Option<option/></select>
<textarea></textarea>
<button>Button</button>
</form>
<div>
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</div>
<script>

var input = $("form input:checkbox").wrap('<span></s
$("div").text("For this type jQuery found "
.css("color", "red");
$("form").submit(function () { return false
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

:checked Selector
Categories: Selectors > Form

checked selector
Description: Matches all elements that are checked.
jQuery( ":checked" )

version added: 1.0

The :checked selector works for checkboxes and radio buttons. For
select elements, use the :selected selector.

Examples:
Example:

Determine how many input elements are

checked.
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<!DOCTYPE html>
<html>
<head>
<style>
div { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<p>
<input type="checkbox" name="newsletter" value
<input type="checkbox" name="newsletter" value
<input type="checkbox" name="newsletter" value
<input type="checkbox" name="newsletter" value
<input type="checkbox" name="newsletter" value
</p>
</form>
<div></div>
<script>
var countChecked = function() {
var n = $( "input:checked" ).length;
$( "div" ).text( n + (n === 1 ? " is" : " are"
};
countChecked();
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$( "input[type=checkbox]" ).on( "click", countChecked );
</script>
</body>
</html>

Demo
Example:
1
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Identify the checked radio input.

<!DOCTYPE html>
<html>
<head>
<style>
input, label { line-height: 1.5em; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<div>
<input type="radio" name="fruit" value="orange"
<label for="orange">orange</label>
</div>
<div>
<input type="radio" name="fruit" value="apple"
<label for="apple">apple</label>
</div>
<div>
<input type="radio" name="fruit" value="banana"
<label for="banana">banana</label>
</div>
<div id="log"></div>
</form>
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<script>
$( "input" ).on( "click", function() {
$( "#log" ).html( $("input:checked").val() +
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
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Child Selector (“parent > child”)
Categories: Selectors > Hierarchy

child selector
Description: Selects all direct child elements specified
by "child" of elements specified by "parent".
jQuery( "parent > child" )

version added: 1.0

parent: Any valid selector.
child: A selector to filter the child elements.
As a CSS selector, the child combinator is supported by all modern
web browsers including Safari, Firefox, Opera, Chrome, and Internet
Explorer 7 and above, but notably not by Internet Explorer versions
6 and below. However, in jQuery, this selector (along with all others)
works across all supported browsers, including IE6.
The child combinator (E > F) can be thought of as a more specific
form of the descendant combinator (E F) in that it selects only firstlevel descendants.

Example:
Places a border around all list items that are children
of <ul class="topnav"> .
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<!DOCTYPE html>
<html>
<head>
<style>
body { font-size:14px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul class="topnav">
<li>Item 1</li>
<li>Item 2
<ul><li>Nested item 1</li><li>Nested item 2
</li>
<li>Item 3</li>
</ul>

<script>$("ul.topnav > li").css("border", "3px double re
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

.children()
Categories: Traversing > Tree Traversal

.children( [selector ] )

Returns: jQuery

Description: Get the children of each element in the set
of matched elements, optionally filtered by a selector.
.children( [selector ] )

version added: 1.0

selector
Type: Selector
A string containing a selector expression to match elements
against.
Given a jQuery object that represents a set of DOM elements, the
.children() method allows us to search throughthe children of these
elements in the DOM tree and construct a new jQuery object from
the matching elements. The .children() method differs from
.find() in that .children() only travels a single level down the DOM
tree while .find() can traverse down multiple levels to select
descendant elements (grandchildren, etc.) as well. Note also that
like most jQuery methods, .children() does not return text nodes; to
get all children including text and comment nodes, use .contents() .
The .children() method optionally accepts a selector expression of
the same type that we can pass to the $() function. If the selector is
supplied, the elements will be filtered by testing whether they match
it.
Consider a page with a basic nested list on it:
1
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<ul class="level-1">
<li class="item-i">I</li>
<li class="item-ii">II
<ul class="level-2">
<li class="item-a">A</li>
<li class="item-b">B
<ul class="level-3">
<li class="item-1">1</li>
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<li class="item-2">2</li>
<li class="item-3">3</li>
</ul>
</li>
<li class="item-c">C</li>
</ul>
</li>
<li class="item-iii">III</li>
</ul>

If we begin at the level-2 list, we can find its children:
1

$('ul.level-2').children().css('background-color'

The result of this call is a red background behind items A, B, and C.
Since we do not supply a selector expression, all of the children are
part of the returned jQuery object. If we had supplied one, only the
matching items among these three would be included.

Examples:
Example:
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Find all children of the clicked element.

<!DOCTYPE html>
<html>
<head>
<style>
body { font-size:16px; font-weight:bolder; }
div { width:130px; height:82px; margin:10px;
border:1px solid blue; padding:4px; }
#container { width:auto; height:105px; margin
border:none; }
.hilite { border-color:red; }
#results { display:block; color:red; }
p { margin:10px; border:1px solid transparent;
span { color:blue; border:1px solid transparent;
input { width:100px; }
em { border:1px solid transparent; }
a { border:1px solid transparent; }
b { border:1px solid transparent; }
button { border:1px solid transparent; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="container">
<div>
<p>This <span>is the <em>way</em> we</span
write <em>the</em> demo,</p>
</div>
<div>
<a href="#"><b>w</b>rit<b>e</b></a> the <
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the</button> demo,
</div>
<div>
This <span>the way we <em>write</em> the

<input type="text" value="early" /> in
</div>
<p>
<span>t</span>he <span>m</span>orning.
<span id="results">Found <span>0</span> children i
</p>
</div>
<script>
$("#container").click(function (e) {
$("*").removeClass("hilite");
var $kids = $(e.target).children();
var len = $kids.addClass("hilite").length;
$("#results span:first").text(len);
$("#results span:last").text(e.target.tagName);
e.preventDefault();
return false;
});
</script>
</body>
</html>

Demo
Example:

Find all children of each div.
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14
15
16
17
18
19
20
21

<!DOCTYPE html>
<html>
<head>
<style>
body { font-size:16px; font-weight:bolder; }
span { color:blue; }
p { margin:5px 0; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello (this is a paragraph)</p>
<div><span>Hello Again (this span is a child of the a
<p>And <span>Again</span> (in another paragraph)

<div>And One Last <span>Time</span> (most text directl
<script>$("div").children().css("border-bottom"
</body>
</html>

Demo
Example:

Find all children with a class "selected" of

each div.
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<!DOCTYPE html>
<html>
<head>
<style>
body { font-size:16px; font-weight:bolder; }
p { margin:5px 0; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"

10
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</head>
<body>
<div>
<span>Hello</span>
<p class="selected">Hello Again</p>
<div class="selected">And Again</div>
<p>And One Last Time</p>
</div>
<script>$("div").children(".selected").css("color"
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

Class Selector (“.class”)
Categories: Selectors > Basic

class selector
Description: Selects all elements with the given class.
jQuery( ".class" )

version added: 1.0

class: A class to search for. An element can have multiple
classes; only one of them must match.
For class selectors, jQuery uses JavaScript's native
getElementsByClassName() function if the browser supports it.

Examples:
Example:
1
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24

Finds the element with the class "myClass".

<!DOCTYPE html>
<html>
<head>
<style>
div,span {
width: 100px;
height: 40px;
float:left;
padding: 10px;
margin: 10px;
background-color: #EEEEEE;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div class="notMe">div class="notMe"</div>
<div class="myClass">div class="myClass"</div
<span class="myClass">span class="myClass"</span
<script>$(".myClass").css("border","3px solid red"
</body>
</html>

Demo
Example:

Finds the element with both "myclass" and
"otherclass" classes.

1
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20
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<!DOCTYPE html>
<html>
<head>
<style>
div,span {
width: 100px;
height: 40px;
float:left;
padding: 10px;
margin: 10px;
background-color: #EEEEEE;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div class="myclass">div class="notMe"</div>

<div class="myclass otherclass">div class="myClass"
<span class="myclass otherclass">span class="myClass"
<script>$(".myclass.otherclass").css("border","13px soli
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.clearQueue()
Categories: Effects > Custom | Data | Utilities

.clearQueue( [queueName ] )

Returns: jQuery

Description: Remove from the queue all items that
have not yet been run.
.clearQueue( [queueName ] )

version added: 1.4

queueName
Type: String
A string containing the name of the queue. Defaults to
standard effects queue.

fx ,

the

When the .clearQueue() method is called, all functions on the queue
that have not been executed are removed from the queue. When
used without an argument, .clearQueue() removes the remaining
functions from fx , the standard effects queue. In this way it is similar
to .stop(true) . However, while the .stop() method is meant to be
used only with animations, .clearQueue() can also be used to
remove any function that has been added to a generic jQuery queue
with the .queue() method.

Example:
Empty the queue.
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<!DOCTYPE html>
<html>
<head>
<style>
div { margin:3px; width:40px; height:40px;
position:absolute; left:0px; top:30px;
background:green; display:none; }
div.newcolor { background:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="start">Start</button>
<button id="stop">Stop</button>
<div></div>
<script>
$("#start").click(function () {
var myDiv = $("div");
myDiv.show("slow");
myDiv.animate({left:'+=200'},5000);
myDiv.queue(function () {
var _this = $(this);
_this.addClass("newcolor");
_this.dequeue();
});
myDiv.animate({left:'-=200'},1500);
myDiv.queue(function () {
var _this = $(this);
_this.removeClass("newcolor");

32
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_this.dequeue();
});
myDiv.slideUp();
});
$("#stop").click(function () {
var myDiv = $("div");
myDiv.clearQueue();
myDiv.stop();
});</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.click()
Categories: Events > Mouse Events

.click( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "click"
JavaScript event, or trigger that event on an element.
.click( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.click( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: Object
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.click()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('click', handler) in the first two
variations, and .trigger('click') in the third. The click event is
sent to an element when the mouse pointer is over the element, and
the mouse button is pressed and released. Any HTML element can
receive this event. For example, consider the HTML:
1
2
3
4
5

<div id="target">
Click here
</div>
<div id="other">
Trigger the handler

6

</div>

The event handler can be bound to any
1
2
3

<div> :

$("#target").click(function() {
alert("Handler for .click() called.");
});

Now if we click on this element, the alert is displayed:
Handler for .click() called.
We can also trigger the event when a different element is clicked:
1
2
3

$("#other").click(function() {
$("#target").click();
});

After this code executes, clicks on Trigger the handler will also alert
the message.
The

click

event is only triggered after this exact series of events:

The mouse button is depressed while the pointer is inside the
element.
The mouse button is released while the pointer is inside the
element.
This is usually the desired sequence before taking an action. If this
is not required, the mousedown or mouseup event may be more
suitable.

Examples:
Example:

Hide paragraphs on a page when they are

clicked:
1
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15
16
17
18
19
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<!DOCTYPE html>
<html>
<head>
<style>
p { color:red; margin:5px; cursor:pointer; }
p:hover { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>First Paragraph</p>
<p>Second Paragraph</p>
<p>Yet one more Paragraph</p>
<script>
$("p").click(function () {
$(this).slideUp();
});
</script>
</body>
</html>

Demo
Example:

Trigger the click event on all of the
paragraphs on the page:
1

$("p").click();

POWERED BYHERONOTE
A new version of this book is available!

.clone()
Categories: Manipulation > Copying

.clone( [withDataAndEvents ] )

Returns: jQuery

Description: Create a deep copy of the set of matched
elements.
.clone( [withDataAndEvents ] )

version added: 1.0

withDataAndEvents (default: false )
Type: Boolean
A Boolean indicating whether event handlers should be copied
along with the elements. As of jQuery 1.4, element data will be
copied as well.

.clone( [withDataAndEvents ] [,
deepWithDataAndEvents ] )

version added: 1.5

withDataAndEvents (default: false )
Type: Boolean
A Boolean indicating whether event handlers and data should
be copied along with the elements. The default value is false .
*In jQuery 1.5.0 the default value was incorrectly true ; it was
changed back to false in 1.5.1 and up.
deepWithDataAndEvents (default: value of
withDataAndEvents )
Type: Boolean
A Boolean indicating whether event handlers and data for all
children of the cloned element should be copied. By default its
value matches the first argument's value (which defaults to
false ).
The .clone() method performs a deep copy of the set of matched
elements, meaning that it copies the matched elements as well as all
of their descendant elements and text nodes. When used in
conjunction with one of the insertion methods, .clone() is a
convenient way to duplicate elements on a page. Consider the
following HTML:

1
2
3
4

<div class="container">
<div class="hello">Hello</div>
<div class="goodbye">Goodbye</div>
</div>

As shown in the discussion for .append() , normally when an element
is inserted somewhere in the DOM, it is moved from its old location.
So, given the code:
1

$('.hello').appendTo('.goodbye');

The resulting DOM structure would be:
1
2
3
4
5
6

<div class="container">
<div class="goodbye">
Goodbye
<div class="hello">Hello</div>
</div>
</div>

To prevent this and instead create a copy of the element, you could
write the following:
1

$('.hello').clone().appendTo('.goodbye');

This would produce:
1
2
3
4
5

<div class="container">
<div class="hello">Hello</div>
<div class="goodbye">
Goodbye
<div class="hello">Hello</div>

6
7

</div>
</div>

Note: When using the .clone() method, you
can modify the cloned elements or their
contents before (re-)inserting them into the
document.
Normally, any event handlers bound to the original element are not
copied to the clone. The optional withDataAndEvents parameter
allows us to change this behavior, and to instead make copies of all
of the event handlers as well, bound to the new copy of the element.
As of jQuery 1.4, all element data (attached by the .data() method)
is also copied to the new copy.
However, objects and arrays within element data are not copied and
will continue to be shared between the cloned element and the
original element. To deep copy all data, copy each one manually:
1
2
3

var $elem = $('#elem').data( "arr": [ 1 ] ), // Original
$clone = $elem.clone( true )
.data( "arr", $.extend( [], $elem.data("arr"

As of jQuery 1.5,

withDataAndEvents can be optionally enhanced with
deepWithDataAndEvents to copy the events and data for all children of

the cloned element.

Note: Using .clone() has the side-effect of
producing elements with duplicate id
attributes, which are supposed to be
unique. Where possible, it is recommended

to avoid cloning elements with this attribute
or using class attributes as identifiers
instead.

Examples:
Clones all b elements (and selects the
clones) and prepends them to all paragraphs.
Example:

1
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<b>Hello</b><p>, how are you?</p>
<script>
$("b").clone().prependTo("p");
</script>
</body>
</html>

Demo
Example:

When using .clone() to clone a collection of
elements that are not attached to the DOM, their order
when inserted into the DOM is not guaranteed.
However, it may be possible to preserve sort order with
a workaround, as demonstrated:
1
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<!DOCTYPE html>
<html>
<head>
<style>
#orig, #copy, #copy-correct {
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float: left;
width: 20%;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="orig">
<div class="elem"><a>1</a></div>
<div class="elem"><a>2</a></div>
<div class="elem"><a>3</a></div>
<div class="elem"><a>4</a></div>
<div class="elem"><a>5</a></div>
</div>
<div id="copy"></div>
<div id="copy-correct"></div>

<script>
// sort order is not guaranteed here and may vary with b
$('#copy').append($('#orig .elem')
.clone()
.children('a')
.prepend('foo - ')
.parent()
.clone());
// correct way to approach where order is maintained
$('#copy-correct')
.append($('#orig .elem')
.clone()
.children('a')
.prepend('bar - ')
.end());
</script>
</body>

43

</html>

Demo
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.closest()
Categories: Traversing > Tree Traversal

Contents:
.closest( selector )
.closest( selector )
.closest( selector [, context ] )
.closest( jQuery object )
.closest( element )
.closest( selectors [, context ] )
.closest( selectors [, context ] )

.closest( selector )

Returns: jQuery

Description: For each element in the set, get the first
element that matches the selector by testing the element
itself and traversing up through its ancestors in the DOM
tree.
.closest( selector )

version added: 1.3

selector
Type: Selector
A string containing a selector expression to match elements
against.

.closest( selector [, context ] )

version added: 1.4

selector
Type: Selector
A string containing a selector expression to match elements
against.
context
Type: Element
A DOM element within which a matching element may be
found. If no context is passed in then the context of the jQuery
set will be used instead.

.closest( jQuery object )

version added: 1.6

jQuery object
Type: jQuery
A jQuery object to match elements against.

.closest( element )

version added: 1.6

element
Type: Element
An element to match elements against.
Given a jQuery object that represents a set of DOM elements, the

method searches through these elements and their
ancestors in the DOM tree and constructs a new jQuery object from
the matching elements. The .parents() and .closest() methods are
similar in that they both traverse up the DOM tree. The differences
between the two, though subtle, are significant:
.closest()

.closest()

.parents()

Begins with the current
Begins with the parent element
element
Travels up the DOM tree to the document's
Travels up the DOM
root element, adding each ancestor element
tree until it finds a
to a temporary collection; it then filters that
match for the supplied
collection based on a selector if one is
selector
supplied
The returned jQuery
object contains zero or The returned jQuery object contains zero or
one element for each more elements for each element in the
element in the original original set
set
1
2
3
4
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<ul id="one" class="level-1">
<li class="item-i">I</li>
<li id="ii" class="item-ii">II
<ul class="level-2">
<li class="item-a">A</li>
<li class="item-b">B
<ul class="level-3">
<li class="item-1">1</li>
<li class="item-2">2</li>
<li class="item-3">3</li>
</ul>
</li>
<li class="item-c">C</li>
</ul>
</li>
<li class="item-iii">III</li>
</ul>

Suppose we perform a search for
1
2

<ul>

elements starting at item A:

$('li.item-a').closest('ul')
.css('background-color', 'red');

This will change the color of the level-2 <ul> , since it is the first
encountered when traveling up the DOM tree.
Suppose we search for an
1
2

<li>

element instead:

$('li.item-a').closest('li')
.css('background-color', 'red');

This will change the color of list item A. The .closest() method
begins its search with the element itself before progressing up the
DOM tree, and stops when item A matches the selector.
We can pass in a DOM element as the context within which to
search for the closest element.
1
2
3
4
5

var listItemII = document.getElementById('ii');
$('li.item-a').closest('ul', listItemII)
.css('background-color', 'red');
$('li.item-a').closest('#one', listItemII)
.css('background-color', 'green');

This will change the color of the level-2 <ul> , because it is both the
first <ul> ancestor of list item A and a descendant of list item II. It will
not change the color of the level-1 <ul> , however, because it is not a
descendant of list item II.

Examples:
Show how event delegation can be done with
closest. The closest list element toggles a yellow
background when it or its descendent is clicked.
Example:

1
2
3
4
5
6
7
8
9
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13
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16
17
18
19
20
21
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<!DOCTYPE html>
<html>
<head>
<style>
li { margin: 3px; padding: 3px; background: #EEEEEE
li.hilight { background: yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul>
<li><b>Click me!</b></li>
<li>You can also <b>Click me!</b></li>
</ul>
<script>
$( document ).on("click", function( e ) {
$( e.target ).closest("li").toggleClass("hilight"
});
</script>
</body>
</html>

Demo
Example:

Pass a jQuery object to closest. The closest
list element toggles a yellow background when it or its
descendent is clicked.
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Demo

<!DOCTYPE html>
<html>
<head>
<style>
li { margin: 3px; padding: 3px; background: #EEEEEE
li.hilight { background: yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul>
<li><b>Click me!</b></li>
<li>You can also <b>Click me!</b></li>
</ul>
<script>
var $listElements = $("li").css("color", "blue"
$( document ).on("click", function( e ) {
$( e.target ).closest( $listElements ).toggleClass(
});
</script>
</body>
</html>

.closest( selectors [, context ] )

Returns: Array

version deprecated: 1.7, removed: 1.8

Description: Get an array of all the elements and
selectors matched against the current element up
through the DOM tree.
.closest( selectors [, context ] )

version added: 1.4

selectors
Type: Array
An array or string containing a selector expression to match
elements against (can also be a jQuery object).
context
Type: Element
A DOM element within which a matching element may be
found. If no context is passed in then the context of the jQuery
set will be used instead.
This signature (only!) is deprecated as of jQuery 1.7 and
removed in jQuery 1.8. It was primarily meant to be used internally
or by plugin authors.

POWERED BYHERONOTE
A new version of this book is available!

:contains() Selector
Categories: Selectors > Content Filter

contains selector
Description: Select all elements that contain the
specified text.
jQuery( ":contains(text)" )

version added: 1.1.4

text: A string of text to look for. It's case sensitive.
The matching text can appear directly within the selected element, in
any of that element's descendants, or a combination thereof. As with
attribute value selectors, text inside the parentheses of :contains()
can be written as a bare word or surrounded by quotation marks.
The text must have matching case to be selected.

Example:
Finds all divs containing "John" and underlines
them.
1
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>John Resig</div>
<div>George Martin</div>
<div>Malcom John Sinclair</div>
<div>J. Ohn</div>
<script>
$("div:contains('John')").css("text-decoration"
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

.contents()
Categories: Traversing > Miscellaneous Traversing

.contents()

Returns: jQuery

Description: Get the children of each element in the set
of matched elements, including text and comment
nodes.
.contents()

version added: 1.2

This method does not accept any arguments.
Given a jQuery object that represents a set of DOM elements, the
.contents() method allows us to search throughthe immediate
children of these elements in the DOM tree and construct a new
jQuery object from the matching elements. The .contents() and
.children() methods are similar, except that the former includes text
nodes as well as HTML elements in the resulting jQuery object.
The .contents() method can also be used to get the content
document of an iframe, if the iframe is on the same domain as the
main page.
Consider a simple <div> with a number of text nodes, each of which
is separated by two line break elements ( <br /> ):
1
2
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<div class="container">
Lorem ipsum dolor sit amet, consectetur adipisicing e
do eiusmod tempor incididunt ut labore et dolore magn
<br /><br />
Ut enim ad minim veniam, quis nostrud exercitation ul
laboris nisi ut aliquip ex ea commodo consequat.
<br /> <br />
Duis aute irure dolor in reprehenderit in voluptate v
esse cillum dolore eu fugiat nulla pariatur.
</div>

We can employ the .contents() method to help convert this blob of
text into three well-formed paragraphs:
1
2
3
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7

$('.container').contents().filter(function() {
return this.nodeType == 3;
})
.wrap('<p></p>')
.end()
.filter('br')
.remove();

This code first retrieves the contents of <div class="container"> and
then filters it for text nodes, which are wrapped in paragraph tags.
This is accomplished by testing the .nodeType property of the
element. This DOM property holds a numeric code indicating the
node's type; text nodes use the code 3. The contents are again
filtered, this time for <br /> elements, and these elements are
removed.

Examples:
Find all the text nodes inside a paragraph
and wrap them with a bold tag.
Example:

1
2
3
4
5
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello <a href="http://ejohn.org/">John</a>
<script>$("p").contents().filter(function(){ return
</body>
</html>

Demo
Example:

Change the background colour of links
inside of an iframe.
1
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<iframe src="http://api.jquery.com/" width="80%"
<script>$("#frameDemo").contents().find("a").css(
</body>
</html>

Demo

POWERED BYHERONOTE
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.context
Categories: Internals | Properties > Properties of jQuery Object Instances

context

Returns: Element

Description: The DOM node context originally passed
to jQuery() ; if none was passed then context will likely be
the document.
context

version added: 1.3

The .live() method for binding event handlers uses this property to
determine the root element to use for its event delegation needs.
The value of this property is typically equal to document , as this is the
default context for jQuery objects if none is supplied. The context
may differ if, for example, the object was created by searching within
an <iframe> or XML document.
Note that the context property may only apply to the elements
originally selected by jQuery() , as it is possible for the user to add
elements to the collection via methods such as .add() and these
may have a different context.

Example:
Determine the exact context used.
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<!DOCTYPE html>
<html>
<head>
<style>
body { cursor:pointer; }
div { width:50px; height:30px; margin:5px; float
background:green; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
Context:<ul></ul>
<script>$("ul")
.append("<li>" + $("ul").context + "</li>")
.append("<li>" + $("ul", document.body).context.nodeNa
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
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.css()
Categories: CSS | Manipulation > Style Properties

Get the value of a style property for the first element in the set of
matched elements or set one or more CSS properties for every
matched element.
Contents:
.css( propertyName )
.css( propertyName )
.css( propertyNames )
.css( propertyName, value )
.css( propertyName, value )
.css( propertyName, function(index, value) )
.css( properties )

.css( propertyName )

Returns: String

Description: Get the value of style properties for the
first element in the set of matched elements.
.css( propertyName )

version added: 1.0

propertyName
Type: String
A CSS property.

.css( propertyNames )

version added: 1.9

propertyNames
Type: Array
An array of one or more CSS properties.
The .css() method is a convenient way to get a style property from
the first matched element, especially in light of the different ways
browsers access most of those properties (the getComputedStyle()
method in standards-based browsers versus the currentStyle and
runtimeStyle properties in Internet Explorer) and the different terms
browsers use for certain properties. For example, Internet Explorer's
DOM implementation refers to the float property as styleFloat ,
while W3C standards-compliant browsers refer to it as cssFloat . For
consistency, you can simply use "float" , and jQuery will translate it
to the correct value for each browser.
Also, jQuery can equally interpret the CSS and DOM formatting of
multiple-word properties. For example, jQuery understands and
returns the correct value for both .css('background-color') and
.css('backgroundColor') . Different browsers may return CSS color
values that are logically but not textually equal, e.g., #FFF, #ffffff, and
rgb(255,255,255).
Shorthand CSS properties (e.g. margin, background, border) are not
supported. For example, if you want to retrieve the rendered margin,
use: $(elem).css('marginTop') and $(elem).css('marginRight') , and
so on.

As of jQuery 1.9, passing an array of style properties to
result in an object of property-value pairs.

.css()

will

Examples:
Example:
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Get the background color of a clicked div.

<!DOCTYPE html>
<html>
<head>
<style>
div { width:60px; height:60px; margin:5px; float
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<span id="result">&nbsp;</span>
<div style="background-color:blue;"></div>
<div style="background-color:rgb(15,99,30);"></
<div style="background-color:#123456;"></div>
<div style="background-color:#f11;"></div>
<script>
$("div").click(function () {
var color = $(this).css("background-color");
$("#result").html("That div is <span style='color:"
color + ";'>" + color + "</span>."
});
</script>
</body>
</html>

Get the width, height, text color, and
background color of a clicked div.
Example:
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<!DOCTYPE html>
<html>
<head>
<style>
div { height: 50px; margin: 5px; padding: 5px;

#box1 { width: 50px; color: yellow; background-color
#box2 { width: 80px; color: rgb(255,255,255); background
#box3 { width: 40px; color: #fcc; background-color
#box4 { width: 70px; background-color: #f11; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

<p id="result">&nbsp;</p>
<div id="box1">1</div>
<div id="box2">2</div>
<div id="box3">3</div>
<div id="box4">4</div>
<script>
$("div").click(function () {
var html = ["The clicked div has the following styles:
var styleProps = $(this).css( ["width", "height"
$.each( styleProps, function( prop, value ) {
html.push( prop + ": " + value );
});
$( "#result" ).html( html.join( "<br>" ) );
});
</script>
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</body>
</html>

.css( propertyName, value )

Returns: jQuery

Description: Set one or more CSS properties for the set
of matched elements.
.css( propertyName, value )

version added: 1.0

propertyName
Type: String
A CSS property name.
value
Type: String or Number
A value to set for the property.

.css( propertyName, function(index, version added: 1.4
value) )
propertyName
Type: String
A CSS property name.
function(index, value)
Type: Function()
A function returning the value to set. this is the current
element. Receives the index position of the element in the set
and the old value as arguments.

.css( properties )

version added: 1.0

properties
Type: PlainObject
An object of property-value pairs to set.
As with the .prop() method, the .css() method makes setting
properties of elements quick and easy. This method can take either
a property name and value as separate parameters, or a single
object of key-value pairs.
Also, jQuery can equally interpret the CSS and DOM formatting of

multiple-word properties. For example, jQuery understands and
returns the correct value for both .css({'background-color': '#ffe',
'border-left': '5px solid #ccc'}) and .css({backgroundColor:
'#ffe', borderLeft: '5px solid #ccc'}) . Notice that with the DOM
notation, quotation marks around the property names are optional,
but with CSS notation they're required due to the hyphen in the
name.
When using .css() as a setter, jQuery modifies the element's style
property. For example, $('#mydiv').css('color', 'green') is
equivalent to document.getElementById('mydiv').style.color =
'green' . Setting the value of a style property to an empty string —
e.g. $('#mydiv').css('color', '') — removes that property from an
element if it has already been directly applied, whether in the HTML
style attribute, through jQuery's .css() method, or through direct
DOM manipulation of the style property. It does not, however,
remove a style that has been applied with a CSS rule in a stylesheet
or <style> element. Warning: one notable exception is that, for IE 8
and below, removing a shorthand property such as border or
background> will remove that style entirely from the element,
regardless of what is set in a stylesheet or <style> element.
As of jQuery 1.6, .css() accepts relative values similar to
.animate() . Relative values are a string starting with += or -= to
increment or decrement the current value. For example, if an
element's padding-left was 10px, .css( "padding-left", "+=15" )
would result in a total padding-left of 25px.
As of jQuery 1.4,
value:
1
2
3

.css()

allows us to pass a function as the property

$('div.example').css('width', function(index) {
return index * 50;
});

This example sets the widths of the matched elements to
incrementally larger values.
Note: If nothing is returned in the setter function (ie.

function(index,

style){}) ,

or if undefined is returned, the current value is not
changed. This is useful for selectively setting values only when
certain criteria are met.

Examples:
To change the color of any paragraph to red
on mouseover event.
Example:
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<!DOCTYPE html>
<html>
<head>
<style>
p { color:blue; width:200px; font-size:14px;
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Just roll the mouse over me.</p>
<p>Or me to see a color change.</p>
<script>
$("p").mouseover(function () {
$(this).css("color","red");
});
</script>
</body>
</html>

Demo
Example:
1
2

Increase the width of #box by 200 pixels

<!DOCTYPE html>
<html>
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<head>
<style>
#box { background: black; color: snow; width:
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="box">Click me to grow</div>
<script>
$("#box").one( "click", function () {
$( this ).css( "width","+=200" );
});
</script>
</body>
</html>

Demo
Example:
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To highlight a clicked word in the paragraph.

<!DOCTYPE html>
<html>
<head>
<style>
p { color:blue; font-weight:bold; cursor:pointer;
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
Once upon a time there was a man
who lived in a pizza parlor. This
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man just loved pizza and ate it all
the time. He went on to be the
happiest man in the world. The end.
</p>
<script>
var words = $("p:first").text().split(" ");
var text = words.join("</span> <span>");
$("p:first").html("<span>" + text + "</span>"
$("span").click(function () {
$(this).css("background-color","yellow");
});
</script>
</body>
</html>

Demo
Example:

To set the color of all paragraphs to red and
background to blue:
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<!DOCTYPE html>
<html>
<head>
<style>
p { color:green; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Move the mouse over a paragraph.</p>
<p>Like this one or the one above.</p>
<script>
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$("p").hover(function () {
$(this).css({'background-color' : 'yellow',
}, function () {
var cssObj = {
'background-color' : '#ddd',
'font-weight' : '',
'color' : 'rgb(0,40,244)'
};
$(this).css(cssObj);
});
</script>
</body>
</html>
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Increase the size of a div when you click it:

<!DOCTYPE html>
<html>
<head>
<style>
div { width: 20px; height: 15px; background-color
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>click</div>
<div>click</div>
<script>
$("div").click(function() {
$(this).css({
width: function(index, value) {
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return parseFloat(value) * 1.2;
},
height: function(index, value) {
return parseFloat(value) * 1.2;
}
});
});
</script>
</body>
</html>

Demo
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.data()
Categories: Data | Miscellaneous > Data Storage

Store arbitrary data associated with the matched elements or return the
value at the named data store for the first element in the set of
matched elements.
Contents:
.data( key, value )
.data( key, value )
.data( obj )
.data( key )
.data( key )
.data()

.data( key, value )

Returns: jQuery

Description: Store arbitrary data associated with the
matched elements.
.data( key, value )

version added: 1.2.3

key
Type: String
A string naming the piece of data to set.
value
Type: Object
The new data value; it can be any Javascript type including
Array or Object.

.data( obj )

version added: 1.4.3

obj
Type: Object
An object of key-value pairs of data to update.
The .data() method allows us to attach data of any type to DOM
elements in a way that is safe from circular references and therefore
from memory leaks.
We can set several distinct values for a single element and retrieve
them later:
1
2
3
4
5

$('body').data('foo', 52);
$('body').data('bar', { myType: 'test', count: 40

$('body').data('foo'); // 52
$('body').data(); // {foo: 52, bar: { myType: 'test', co

In jQuery 1.4.3 setting an element's data object with

.data(obj)

extends the data previously stored with that element. jQuery itself
uses the .data() method to save information under the names
'events' and 'handle', and also reserves any data name starting with
an underscore ('_') for internal use.
Prior to jQuery 1.4.3 (starting in jQuery 1.4) the .data() method
completely replaced all data, instead of just extending the data
object. If you are using third-party plugins it may not be advisable to
completely replace the element's data object, since plugins may
have also set data.
Due to the way browsers interact with plugins and external code, the
.data() method cannot be used on <object> (unless it's a Flash
plugin), <applet> or <embed> elements.

Additional Notes:
Note that this method currently does not provide cross-platform
support for setting data on XML documents, as Internet Explorer
does not allow data to be attached via expando properties.

Example:
Store then retrieve a value from the div element.
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<!DOCTYPE html>
<html>
<head>
<style>
div { color:blue; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
The values stored were
<span></span>
and
<span></span>
</div>
<script>
$("div").data("test", { first: 16, last: "pizza!"
$("span:first").text($("div").data("test").first);
$("span:last").text($("div").data("test").last);
</script>
</body>
</html>

.data( key )

Returns: Object

Description: Return the value at the named data store
for the first element in the jQuery collection, as set by
data(name, value) or by an HTML5 data-* attribute.
.data( key )

version added: 1.2.3

key
Type: String
Name of the data stored.

.data()

version added: 1.4

This method does not accept any arguments.
The .data() method allows us to attach data of any type to DOM
elements in a way that is safe from circular references and therefore
from memory leaks. We can retrieve several distinct values for a
single element one at a time, or as a set:
1
2

alert($('body').data('foo'));
alert($('body').data());

The above lines alert the data values that were set on the body
element. If no data at all was set on that element, undefined is
returned.
1
2
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alert( $("body").data("foo")); //undefined
$("body").data("bar", "foobar");
alert( $("body").data("bar")); //foobar

HTML5 data-* Attributes
As of jQuery 1.4.3 HTML 5 data- attributes will be automatically

pulled in to jQuery's data object. The treatment of attributes with
embedded dashes was changed in jQuery 1.6 to conform to the
W3C HTML5 specification.
For example, given the following HTML:
1

<div data-role="page" data-last-value="43" data-hidden

All of the following jQuery code will work.
1
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$("div").data("role") === "page";
$("div").data("lastValue") === 43;
$("div").data("hidden") === true;
$("div").data("options").name === "John";

Every attempt is made to convert the string to a JavaScript value
(this includes booleans, numbers, objects, arrays, and null)
otherwise it is left as a string. To retrieve the value's attribute as a
string without any attempt to convert it, use the attr() method.
When the data attribute is an object (starts with '{') or array (starts
with '[') then jQuery.parseJSON is used to parse the string; it must
follow valid JSON syntax including quoted property names. The
data- attributes are pulled in the first time the data property is
accessed and then are no longer accessed or mutated (all data
values are then stored internally in jQuery).
Calling .data() with no parameters retrieves all of the values as a
JavaScript object. This object can be safely cached in a variable as
long as a new object is not set with .data(obj) . Using the object
directly to get or set values is faster than making individual calls to
.data() to get or set each value:
1
2
3

var mydata = $("#mydiv").data();
if ( mydata.count < 9 ) {
mydata.count = 43;

4
5

mydata.status = "embiggened";
}

Additional Notes:
Note that this method currently does not provide cross-platform
support for setting data on XML documents, as Internet Explorer
does not allow data to be attached via expando properties.

Example:
Get the data named "blah" stored at for an element.
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<!DOCTYPE html>
<html>
<head>
<style>
div { margin:5px; background:yellow; }
button { margin:5px; font-size:14px; }
p { margin:5px; color:blue; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>A div</div>
<button>Get "blah" from the div</button>
<button>Set "blah" to "hello"</button>
<button>Set "blah" to 86</button>
<button>Remove "blah" from the div</button>
<p>The "blah" value of this div is <span>?</span
<script>
$("button").click(function(e) {
var value;
switch ($("button").index(this)) {
case 0 :
value = $("div").data("blah");
break;
case 1 :
$("div").data("blah", "hello");
value = "Stored!";
break;
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case 2 :
$("div").data("blah", 86);
value = "Stored!";
break;
case 3 :
$("div").removeData("blah");
value = "Removed!";
break;
}
$("span").text("" + value);
});
</script>
</body>
</html>

Demo
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.dblclick()
Categories: Events > Mouse Events

.dblclick( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "dblclick"
JavaScript event, or trigger that event on an element.
.dblclick( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.dblclick( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: Object
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.dblclick()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('dblclick', handler) in the first
two variations, and .trigger('dblclick') in the third. The dblclick
event is sent to an element when the element is double-clicked. Any
HTML element can receive this event. For example, consider the
HTML:
1
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<div id="target">
Double-click here
</div>
<div id="other">
Trigger the handler

6

</div>

The event handler can be bound to any
1
2
3

<div> :

$('#target').dblclick(function() {
alert('Handler for .dblclick() called.');
});

Now double-clicking on this element displays the alert:
Handler for .dblclick() called.
To trigger the event manually, apply
argument:
1
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3

.dblclick()

without an

$('#other').click(function() {
$('#target').dblclick();
});

After this code executes, (single) clicks on Trigger the handler will
also alert the message.
The

dblclick

event is only triggered after this exact series of events:

The mouse button is depressed while the pointer is inside the
element.
The mouse button is released while the pointer is inside the
element.
The mouse button is depressed again while the pointer is inside
the element, within a time window that is system-dependent.

The mouse button is released while the pointer is inside the
element.
It is inadvisable to bind handlers to both the click and dblclick
events for the same element. The sequence of events triggered
varies from browser to browser, with some receiving two click
events before the dblclick and others only one. Double-click
sensitivity (maximum time between clicks that is detected as a
double click) can vary by operating system and browser, and is often
user-configurable.

Examples:
To bind a "Hello World!" alert box the
dblclick event on every paragraph on the page:
Example:

1

$("p").dblclick( function () { alert("Hello World!"

Example:
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Double click to toggle background color.

<!DOCTYPE html>
<html>
<head>
<style>
div { background:blue;
color:white;
height:100px;
width:150px;
}
div.dbl { background:yellow;color:black; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div><span>Double click the block</span
<script>
var divdbl = $("div:first");
divdbl.dblclick(function () {
divdbl.toggleClass('dbl');
});
</script>
</body>
</html>

Demo
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deferred.always()
Categories: Deferred Object

deferred.always( alwaysCallbacks [, alwaysCallbacks ] )
Returns: Deferred
Description: Add handlers to be called when the
Deferred object is either resolved or rejected.
deferred.always( alwaysCallbacks [, version added: 1.6
alwaysCallbacks ] )
alwaysCallbacks
Type: Function()
A function, or array of functions, that is called when the
Deferred is resolved or rejected.
alwaysCallbacks
Type: Function()
Optional additional functions, or arrays of functions, that are
called when the Deferred is resolved or rejected.
The argument can be either a single function or an array of
functions. When the Deferred is resolved or rejected, the
alwaysCallbacks are called. Since deferred.always() returns the
Deferred object, other methods of the Deferred object can be
chained to this one, including additional .always() methods. When
the Deferred is resolved or rejected, callbacks are executed in the
order they were added, using the arguments provided to the
resolve , reject , resolveWith or rejectWith method calls. For more
information, see the documentation for Deferred object.

Example:
Since the jQuery.get() method returns a jqXHR object,
which is derived from a Deferred object, we can attach
a callback for both success and error using the
deferred.always() method.
1
2
3

$.get("test.php").always( function() {
alert("$.get completed with success or error callback a
} );

POWERED BYHERONOTE
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deferred.done()
Categories: Deferred Object

deferred.done( doneCallbacks [, doneCallbacks ] )
Returns: Deferred
Description: Add handlers to be called when the
Deferred object is resolved.
deferred.done( doneCallbacks [,
doneCallbacks ] )

version added: 1.5

doneCallbacks
Type: Function()
A function, or array of functions, that are called when the
Deferred is resolved.
doneCallbacks
Type: Function()
Optional additional functions, or arrays of functions, that are
called when the Deferred is resolved.
The deferred.done() method accepts one or more arguments, all of
which can be either a single function or an array of functions. When
the Deferred is resolved, the doneCallbacks are called. Callbacks
are executed in the order they were added. Since deferred.done()
returns the deferred object, other methods of the deferred object can
be chained to this one, including additional .done() methods. When
the Deferred is resolved, doneCallbacks are executed using the
arguments provided to the resolve or resolveWith method call in the
order they were added. For more information, see the
documentation for Deferred object.

Examples:
Since the jQuery.get method returns a jqXHR
object, which is derived from a Deferred object, we can
attach a success callback using the .done() method.
Example:

1
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3

$.get("test.php").done(function() {
alert("$.get succeeded");
});

Resolve a Deferred object when the user
clicks a button, triggering a number of callback
functions:
Example:
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Go</button>
<p>Ready...</p>
<script>
/* 3 functions to
function fn1() {
$("p").append("
}
function fn2() {
$("p").append("
}
function fn3(n) {
$("p").append(n

call when the Deferred object is resol
1 ");

2 ");

+ " 3 " + n);
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}
/* create a deferred object */
var dfd = $.Deferred();

/* add handlers to be called when dfd is resolved */
dfd
/* .done() can take any number of functions or arrays of
.done( [fn1, fn2], fn3, [fn2, fn1] )
/* we can chain done methods, too */
.done(function(n) {
$("p").append(n + " we're done.");
});

/* resolve the Deferred object when the button is clicke
$("button").on("click", function() {
dfd.resolve("and");
});
</script>
</body>
</html>

Demo
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deferred.fail()
Categories: Deferred Object

deferred.fail( failCallbacks [, failCallbacks ] )
Returns: Deferred
Description: Add handlers to be called when the
Deferred object is rejected.
deferred.fail( failCallbacks [,
failCallbacks ] )

version added: 1.5

failCallbacks
Type: Function()
A function, or array of functions, that are called when the
Deferred is rejected.
failCallbacks
Type: Function()
Optional additional functions, or arrays of functions, that are
called when the Deferred is rejected.
The deferred.fail() method accepts one or more arguments, all of
which can be either a single function or an array of functions. When
the Deferred is rejected, the failCallbacks are called. Callbacks are
executed in the order they were added. Since deferred.fail()
returns the deferred object, other methods of the deferred object can
be chained to this one, including additional deferred.fail()
methods. The failCallbacks are executed using the arguments
provided to the deferred.reject() or deferred.rejectWith() method
call in the order they were added. For more information, see the
documentation for Deferred object.

Example:
Since the jQuery.get method returns a jqXHR object,
which is derived from a Deferred, you can attach a
success and failure callback using the deferred.done()
and deferred.fail() methods.
1
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$.get("test.php")
.done(function(){ alert("$.get succeeded"); })
.fail(function(){ alert("$.get failed!"); });

POWERED BYHERONOTE
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deferred.isRejected()
Categories: Deferred Object

deferred.isRejected()

Returns: Boolean
version deprecated: 1.7, removed: 1.8

Description: Determine whether a Deferred object has
been rejected.
deferred.isRejected()

version added: 1.5

This method does not accept any arguments.
As of jQuery 1.7 this API has been deprecated; please use
deferred.state() instead.
Returns true if the Deferred object is in the rejected state, meaning
that either deferred.reject() or deferred.rejectWith() has been
called for the object and the failCallbacks have been called (or are in
the process of being called).
Note that a Deferred object can be in one of three states: pending,
resolved, or rejected; use deferred.isResolved() to determine
whether the Deferred object is in the resolved state. These methods
are primarily useful for debugging, for example to determine whether
a Deferred has already been resolved even though you are inside
code that intended to reject it.
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deferred.isResolved()
Categories: Deferred Object

deferred.isResolved()

Returns: Boolean
version deprecated: 1.7, removed: 1.8

Description: Determine whether a Deferred object has
been resolved.
deferred.isResolved()

version added: 1.5

This method does not accept any arguments.
This API is deprecated as of jQuery 1.7 and
1.8; please use deferred.state() instead.

removed

as of jQuery

Returns true if the Deferred object is in the resolved state, meaning
that either deferred.resolve() or deferred.resolveWith() has been
called for the object and the doneCallbacks have been called (or are
in the process of being called).
Note that a Deferred object can be in one of three states: pending,
resolved, or rejected; use deferred.isRejected() to determine
whether the Deferred object is in the rejected state. These methods
are primarily useful for debugging, for example to determine whether
a Deferred has already been resolved even though you are inside
code that intended to reject it.

POWERED BYHERONOTE
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deferred.notify()
Categories: Deferred Object

deferred.notify( args )

Returns: Deferred

Description: Call the progressCallbacks on a Deferred
object with the given args .
deferred.notify( args )

version added: 1.7

args
Type: Object
Optional arguments that are passed to the progressCallbacks.
Normally, only the creator of a Deferred should call this method; you
can prevent other code from changing the Deferred's state or
reporting status by returning a restricted Promise object through
deferred.promise().
When

deferred.notify is called, any progressCallbacks added
deferred.then or deferred.progress are called. Callbacks are

by

executed in the order they were added. Each callback is passed the
args from the .notify() . Any calls to .notify() after a Deferred is
resolved or rejected (or any progressCallbacks added after that) are
ignored. For more information, see the documentation for Deferred
object.

POWERED BYHERONOTE
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deferred.notifyWith()
Categories: Deferred Object

deferred.notifyWith( context [, args ] )

Returns: Deferred

Description: Call the progressCallbacks on a Deferred
object with the given context and args .
deferred.notifyWith( context [, args ] ) version added: 1.7
context
Type: Object
Context passed to the progressCallbacks as the

this

object.

args
Type: Object
Optional arguments that are passed to the progressCallbacks.
Normally, only the creator of a Deferred should call this method; you
can prevent other code from changing the Deferred's state or
reporting status by returning a restricted Promise object through
deferred.promise().
When deferred.notifyWith is called, any progressCallbacks added
by deferred.then or deferred.progress are called. Callbacks are
executed in the order they were added. Each callback is passed the
args from the .notifyWith() . Any calls to .notifyWith() after a
Deferred is resolved or rejected (or any progressCallbacks added
after that) are ignored. For more information, see the documentation
for Deferred object.

POWERED BYHERONOTE
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deferred.pipe()
Categories: Deferred Object

deferred.pipe( [doneFilter ] [, failFilter ] ) Returns: Promise
version deprecated: 1.8

Description: Utility method to filter and/or chain
Deferreds.
deferred.pipe( [doneFilter ] [, failFilter version added: 1.6
])
doneFilter
Type: Function()
An optional function that is called when the Deferred is
resolved.
failFilter
Type: Function()
An optional function that is called when the Deferred is rejected.

deferred.pipe( [doneFilter ] [, failFilter version added: 1.7
] [, progressFilter ] )
doneFilter
Type: Function()
An optional function that is called when the Deferred is
resolved.
failFilter
Type: Function()
An optional function that is called when the Deferred is rejected.
progressFilter
Type: Function()
An optional function that is called when progress notifications
are sent to the Deferred.
Deprecation Notice:As of jQuery 1.8, the deferred.pipe() method is
deprecated. The deferred.then() method, which replaces it, should
be used instead.
The

deferred.pipe()

method returns a new promise that filters the

status and values of a deferred through a function. The doneFilter
and failFilter functions filter the original deferred's resolved /
rejected status and values. As of jQuery 1.7, the method also
accepts a progressFilter function to filter any calls to the original
deferred's notify or notifyWith methods. These filter functions can
return a new value to be passed along to the piped promise's done()
or fail() callbacks, or they can return another observable object
(Deferred, Promise, etc) which will pass its resolved / rejected status
and values to the piped promise's callbacks. If the filter function used
is null , or not specified, the piped promise will be resolved or
rejected with the same values as the original.

Examples:
Example:
1
2
3
4
5
6
7
8
9

var defer = $.Deferred(),
filtered = defer.pipe(function( value ) {
return value * 2;
});
defer.resolve( 5 );
filtered.done(function( value ) {
alert( "Value is ( 2*5 = ) 10: " + value );
});

Example:
1
2
3
4
5
6
7
8
9

Filter reject value:

var defer = $.Deferred(),
filtered = defer.pipe( null, function( value ) {
return value * 3;
});
defer.reject( 6 );
filtered.fail(function( value ) {
alert( "Value is ( 3*6 = ) 18: " + value );
});

Example:
1
2
3

Filter resolve value:

Chain tasks:

var request = $.ajax( url, { dataType: "json" } ),
chained = request.pipe(function( data ) {
return $.ajax( url2, { data: { user: data.userId }

4
5
6
7
8
9

});

chained.done(function( data ) {
// data retrieved from url2 as provided by the first re
});
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deferred.progress()
Categories: Deferred Object

deferred.progress( progressCallbacks ) Returns: Deferred
Description: Add handlers to be called when the
Deferred object generates progress notifications.
deferred.progress(
progressCallbacks )

version added: 1.7

progressCallbacks
Type: Function()
A function, or array of functions, that is called when the
Deferred generates progress notifications.
The argument can be either a single function or an array of
functions. When the Deferred generates progress notifications by
calling notify or notifyWith , the progressCallbacks are called. Since
deferred.progress() returns the Deferred object, other methods of
the Deferred object can be chained to this one. When the Deferred
is resolved or rejected, progress callbacks will no longer be called,
with the exception that any progressCallbacks added after the
Deferred enters the resolved or rejected state are executed
immediately when they are added, using the arguments that were
passed to the .notify() or notifyWith() call. For more information,
see the documentation jQuery.Deferred().

POWERED BYHERONOTE
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deferred.promise()
Categories: Deferred Object

deferred.promise( [target ] )

Returns: Promise

Description: Return a Deferred's Promise object.
deferred.promise( [target ] )

version added: 1.5

target
Type: Object
Object onto which the promise methods have to be attached
The deferred.promise() method allows an asynchronous function to
prevent other code from interfering with the progress or status of its
internal request. The Promise exposes only the Deferred methods
needed to attach additional handlers or determine the state ( then ,
done , fail , always , pipe , progress , and state ), but not ones that
change the state ( resolve , reject , notify , resolveWith , rejectWith ,
and notifyWith ).
If target is provided, deferred.promise() will attach the methods
onto it and then return this object rather than create a new one. This
can be useful to attach the Promise behavior to an object that
already exists.
If you are creating a Deferred, keep a reference to the Deferred so
that it can be resolved or rejected at some point. Return only the
Promise object via deferred.promise() so other code can register
callbacks or inspect the current state.
For more information, see the documentation for Deferred object.

Examples:
Create a Deferred and set two timer-based
functions to either resolve or reject the Deferred after a
random interval. Whichever one fires first "wins" and
will call one of the callbacks. The second timeout has
no effect since the Deferred is already complete (in a
resolved or rejected state) from the first timeout action.
Also set a timer-based progress notification function,
and call a progress handler that adds "working..." to
the document body.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23

function asyncEvent(){
var dfd = new jQuery.Deferred();
// Resolve after a random interval
setTimeout(function(){
dfd.resolve("hurray");
}, Math.floor(400+Math.random()*2000));
// Reject after a random interval
setTimeout(function(){
dfd.reject("sorry");
}, Math.floor(400+Math.random()*2000));
// Show a "working..." message every half-second
setTimeout(function working(){
if ( dfd.state() === "pending" ) {
dfd.notify("working... ");
setTimeout(working, 500);
}
}, 1);

// Return the Promise so caller can't change the Def
return dfd.promise();

24
25
26
27
28
29
30
31
32
33
34
35
36
37

}

// Attach a done, fail, and progress handler for the asy
$.when( asyncEvent() ).then(
function(status){
alert( status+', things are going well'
},
function(status){
alert( status+', you fail this time' );
},
function(status){
$("body").append(status);
}
);

Use the target argument to promote an
existing object to a Promise:
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

// Existing object
var obj = {
hello: function( name ) {
alert( "Hello " + name );
}
},
// Create a Deferred
defer = $.Deferred();
// Set object as a promise
defer.promise( obj );
// Resolve the deferred
defer.resolve( "John" );
// Use the object as a Promise
obj.done(function( name ) {

18
19

obj.hello( name ); // will alert "Hello John"
}).hello( "Karl" ); // will alert "Hello Karl"
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deferred.reject()
Categories: Deferred Object

deferred.reject( args )

Returns: Deferred

Description: Reject a Deferred object and call any
failCallbacks with the given args .
deferred.reject( args )

version added: 1.5

args
Type: Object
Optional arguments that are passed to the failCallbacks.
Normally, only the creator of a Deferred should call this method; you
can prevent other code from changing the Deferred's state by
returning a restricted Promise object through deferred.promise() .
When the Deferred is rejected, any failCallbacks added by
deferred.then or deferred.fail are called. Callbacks are executed in
the order they were added. Each callback is passed the args from
the deferred.reject() call. Any failCallbacks added after the
Deferred enters the rejected state are executed immediately when
they are added, using the arguments that were passed to the
.reject() call. For more information, see the documentation for
Deferred object.

POWERED BYHERONOTE
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deferred.rejectWith()
Categories: Deferred Object

deferred.rejectWith( context [, args ] )

Returns: Deferred

Description: Reject a Deferred object and call any
failCallbacks with the given context and args .
deferred.rejectWith( context [, args ] ) version added: 1.5
context
Type: Object
Context passed to the failCallbacks as the

this

object.

args
Type: Array
An optional array of arguments that are passed to the
failCallbacks.
Normally, only the creator of a Deferred should call this method; you
can prevent other code from changing the Deferred's state by
returning a restricted Promise object through deferred.promise() .
When the Deferred is rejected, any failCallbacks added by
deferred.then or deferred.fail are called. Callbacks are executed in
the order they were added. Each callback is passed the args from
the deferred.reject() call. Any failCallbacks added after the
Deferred enters the rejected state are executed immediately when
they are added, using the arguments that were passed to the
.reject() call. For more information, see the documentation for
Deferred object.
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deferred.resolve()
Categories: Deferred Object

deferred.resolve( args )

Returns: Deferred

Description: Resolve a Deferred object and call any
doneCallbacks with the given args .
deferred.resolve( args )

version added: 1.5

args
Type: Object
Optional arguments that are passed to the doneCallbacks.
When the Deferred is resolved, any doneCallbacks added by
deferred.then or deferred.done are called. Callbacks are executed in
the order they were added. Each callback is passed the args from
the .resolve() . Any doneCallbacks added after the Deferred enters
the resolved state are executed immediately when they are added,
using the arguments that were passed to the .resolve() call. For
more information, see the documentation for Deferred object.
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deferred.resolveWith()
Categories: Deferred Object

deferred.resolveWith( context [, args ] ) Returns: Deferred
Description: Resolve a Deferred object and call any
doneCallbacks with the given context and args .
deferred.resolveWith( context [, args version added: 1.5
])
context
Type: Object
Context passed to the doneCallbacks as the

this

object.

args
Type: Array
An optional array of arguments that are passed to the
doneCallbacks.
Normally, only the creator of a Deferred should call this method; you
can prevent other code from changing the Deferred's state by
returning a restricted Promise object through deferred.promise() .
When the Deferred is resolved, any doneCallbacks added by
deferred.then or deferred.done are called. Callbacks are executed in
the order they were added. Each callback is passed the args from
the .resolve() . Any doneCallbacks added after the Deferred enters
the resolved state are executed immediately when they are added,
using the arguments that were passed to the .resolve() call. For
more information, see the documentation for Deferred object.
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deferred.state()
Categories: Deferred Object

deferred.state()

Returns: String

Description: Determine the current state of a Deferred
object.
deferred.state()

version added: 1.7

This method does not accept any arguments.
The deferred.state() method returns a string representing the current
state of the Deferred object. The Deferred object can be in one of
three states:
"pending": The Deferred object is not yet in a completed state
(neither "rejected" nor "resolved").
"resolved": The Deferred object is in the resolved state,
meaning that either deferred.resolve() or
deferred.resolveWith() has been called for the object and the
doneCallbacks have been called (or are in the process of being
called).
"rejected": The Deferred object is in the rejected state,
meaning that either deferred.reject() or deferred.rejectWith()
has been called for the object and the failCallbacks have been
called (or are in the process of being called).
This method is primarily useful for debugging to determine, for
example, whether a Deferred has already been resolved even
though you are inside code that intended to reject it.

POWERED BYHERONOTE
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deferred.then()
Categories: Deferred Object

deferred.then( doneFilter [, failFilter ] [, progressFilter ] )
Returns: Promise
Description: Add handlers to be called when the
Deferred object is resolved, rejected, or still in progress.
deferred.then( doneFilter [, failFilter ] version added: 1.8
[, progressFilter ] )
doneFilter
Type: Function()
A function that is called when the Deferred is resolved.
failFilter
Type: Function()
An optional function that is called when the Deferred is rejected.
progressFilter
Type: Function()
An optional function that is called when progress notifications
are sent to the Deferred.
version added: 1.5, removed: 1.8
deferred.then(
doneCallbacks, failCallbacks )
doneCallbacks
Type: Function()
A function, or array of functions, called when the Deferred is
resolved.
failCallbacks
Type: Function()
A function, or array of functions, called when the Deferred is
rejected.
version added: 1.7, removed: 1.8
deferred.then(
doneCallbacks, failCallbacks [, progressCallbacks ] )
doneCallbacks

Type: Function()
A function, or array of functions, called when the Deferred is
resolved.
failCallbacks
Type: Function()
A function, or array of functions, called when the Deferred is
rejected.
progressCallbacks
Type: Function()
A function, or array of functions, called when the Deferred
notifies progress.
Prior to jQuery 1.8, the arguments could be a function or an array
of functions.
For all signatures, the arguments can be null if no callback of that
type is desired. Alternatively, use .done() , .fail() or .progress() to
set only one type of callback without filtering status or values.
As of jQuery 1.8, the deferred.then() method returns a new
promise that can filter the status and values of a deferred through a
function, replacing the now-deprecated deferred.pipe() method.
The doneFilter and failFilter functions filter the original deferred's
resolved / rejected status and values. The progressFilter function
filters any calls to the original deferred's notify or notifyWith
methods. These filter functions can return a new value to be passed
along to the promise's .done() or .fail() callbacks, or they can
return another observable object (Deferred, Promise, etc) which will
pass its resolved / rejected status and values to the promise's
callbacks. If the filter function used is null , or not specified, the
promise will be resolved or rejected with the same values as the
original.
Callbacks are executed in the order they were added. Since
deferred.then returns a Promise, other methods of the Promise
object can be chained to this one, including additional .then()
methods.

Examples:
Since the jQuery.get method returns a jqXHR
object, which is derived from a Deferred object, we can
attach handlers using the .then method.
Example:

1
2
3
4

$.get("test.php").then(
function(){ alert("$.get succeeded"); },
function(){ alert("$.get failed!"); }
);

Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

Filter the resolve value:

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Filter Resolve</button>
<p></p>
<script>
var filterResolve = function() {
var defer = $.Deferred(),
filtered = defer.then(function( value ) {
return value * 2;
});
defer.resolve( 5 );
filtered.done(function( value ) {
$( "p" ).html( "Value is ( 2*5 = ) 10: " + value );

22
23
24
25
26
27
28
29

});
};
$( "button" ).on( "click", filterResolve );
</script>
</body>
</html>

Demo
Example:
1
2
3
4
5
6
7
8
9

var defer = $.Deferred(),
filtered = defer.then( null, function( value ) {
return value * 3;
});
defer.reject( 6 );
filtered.fail(function( value ) {
alert( "Value is ( 3*6 = ) 18: " + value );
});

Example:
1
2
3
4
5
6
7
8
9

Filter reject value:

Chain tasks:

var request = $.ajax( url, { dataType: "json" } ),
chained = request.then(function( data ) {
return $.ajax( url2, { data: { user: data.userId }
});

chained.done(function( data ) {
// data retrieved from url2 as provided by the first re
});
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.delay()
Categories: Effects > Custom

.delay( duration [, queueName ] )

Returns: jQuery

Description: Set a timer to delay execution of
subsequent items in the queue.
.delay( duration [, queueName ] )

version added: 1.4

duration
Type: Integer
An integer indicating the number of milliseconds to delay
execution of the next item in the queue.
queueName
Type: String
A string containing the name of the queue. Defaults to
standard effects queue.

fx ,

the

Added to jQuery in version 1.4, the .delay() method allows us to
delay the execution of functions that follow it in the queue. It can be
used with the standard effects queue or with a custom queue. Only
subsequent events in a queue are delayed; for example this will not
delay the no-arguments forms of .show() or .hide() which do not
use the effects queue.
Durations are given in milliseconds; higher values indicate slower
animations, not faster ones. The strings 'fast' and 'slow' can be
supplied to indicate durations of 200 and 600 milliseconds,
respectively.
Using the standard effects queue, we can, for example, set an 800millisecond delay between the .slideUp() and .fadeIn() of <div
id="foo"> :
1

$('#foo').slideUp(300).delay(800).fadeIn(400);

When this statement is executed, the element slides up for 300
milliseconds and then pauses for 800 milliseconds before fading in

for 400 milliseconds.

The .delay() method is best for delaying
between queued jQuery effects. Because
it is limited—it doesn't, for example, offer
a way to cancel the delay— .delay() is not a
replacement for JavaScript's native
setTimeout function, which may be more
appropriate for certain use cases.

Example:
Animate the hiding and showing of two divs, delaying
the first before showing it.
1
2
3
4
5
6
7
8
9
10
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14
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17
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20
21
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23

<!DOCTYPE html>
<html>
<head>
<style>
div { position: absolute; width: 60px; height:
.first { background-color: #3f3; left: 0;}
.second { background-color: #33f; left: 80px;}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><button>Run</button></p>
<div class="first"></div>
<div class="second"></div>
<script>
$("button").click(function() {
$("div.first").slideUp(300).delay(800).fadeIn(
$("div.second").slideUp(300).fadeIn(400);
});</script>
</body>
</html>

Demo
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.delegate()
Categories: Events > Event Handler Attachment

.delegate( selector, eventType, handler(eventObject) )
Returns: jQuery
Description: Attach a handler to one or more events for
all elements that match the selector, now or in the future,
based on a specific set of root elements.
.delegate( selector, eventType,
handler(eventObject) )

version added: 1.4.2

selector
Type: String
A selector to filter the elements that trigger the event.
eventType
Type: String
A string containing one or more space-separated JavaScript
event types, such as "click" or "keydown," or custom event
names.
handler(eventObject)
Type: Function()
A function to execute at the time the event is triggered.

.delegate( selector, eventType,
eventData, handler(eventObject) )

version added: 1.4.2

selector
Type: String
A selector to filter the elements that trigger the event.
eventType
Type: String
A string containing one or more space-separated JavaScript
event types, such as "click" or "keydown," or custom event
names.
eventData
Type: Object
An object containing data that will be passed to the event

handler.
handler(eventObject)
Type: Function()
A function to execute at the time the event is triggered.

.delegate( selector, events )

version added: 1.4.3

selector
Type: String
A selector to filter the elements that trigger the event.
events
Type: PlainObject
A plain object of one or more event types and functions to
execute for them.
As of jQuery 1.7, .delegate() has been superseded by the .on()
method. For earlier versions, however, it remains the most effective
means to use event delegation. More information on event binding
and delegation is in the .on() method. In general, these are the
equivalent templates for the two methods:
1
2
3
4

// jQuery 1.4.3+
$(elements).delegate( selector, events, data, handler );
// jQuery 1.7+
$(elements).on( events, selector, data, handler );

For example, the following
1
2
3

.delegate()

code:

$("table").delegate("td", "click", function() {
$(this).toggleClass("chosen");
});

is equivalent to the following code written using

.on() :

1
2
3

$("table").on("click", "td", function() {
$(this).toggleClass("chosen");
});

To remove events attached with
method.

delegate() ,

see the .undelegate()

Passing and handling event data works the same way as it does for
.on() .

Additional Notes:
Since the .live() method handles events once they have
propagated to the top of the document, it is not possible to stop
propagation of live events. Similarly, events handled by
.delegate() will propagate to the elements to which they are
delegated; event handlers bound on any elements below it in
the DOM tree will already have been executed by the time the
delegated event handler is called. These handlers, therefore,
may prevent the delegated handler from triggering by calling
event.stopPropagation() or returning false .

Examples:
Click a paragraph to add another. Note that
.delegate() attaches a click event handler to all
paragraphs - even new ones.
Example:

1
2
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16
17
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19
20
21
22
23

<!DOCTYPE html>
<html>
<head>
<style>
p { background:yellow; font-weight:bold; cursor
padding:5px; }
p.over { background: #ccc; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Click me!</p>
<span></span>
<script>
$("body").delegate("p", "click", function(){
$(this).after("<p>Another paragraph!</p>"
});
</script>
</body>
</html>

Demo
Example:

To display each paragraph's text in an alert
box whenever it is clicked:

1
2
3

$("body").delegate("p", "click", function(){
alert( $(this).text() );
});

To cancel a default action and prevent it from
bubbling up, return false:
Example:

1

$("body").delegate("a", "click", function() { return

To cancel only the default action by using the
preventDefault method.
Example:

1
2
3

$("body").delegate("a", "click", function(event){
event.preventDefault();
});

Example:
1
2
3
4
5
6
7
8
9
10
11
12
13

Can bind custom events too.

<!DOCTYPE html>
<html>
<head>
<style>
p { color:red; }
span { color:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Has an attached custom event.</p>
<button>Trigger custom event</button>
<span style="display:none;"></span>
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<script>
$("body").delegate("p", "myCustomEvent", function
$(this).text("Hi there!");
$("span").stop().css("opacity", 1)
.text("myName = " + myName)
.fadeIn(30).fadeOut(1000);
});
$("button").click(function () {
$("p").trigger("myCustomEvent");
});
</script>
</body>
</html>

Demo
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.dequeue()
Categories: Effects > Custom | Data | Utilities

.dequeue( [queueName ] )

Returns: jQuery

Description: Execute the next function on the queue for
the matched elements.
.dequeue( [queueName ] )

version added: 1.2

queueName
Type: String
A string containing the name of the queue. Defaults to
standard effects queue.

fx ,

the

When .dequeue() is called, the next function on the queue is
removed from the queue, and then executed. This function should in
turn (directly or indirectly) cause .dequeue() to be called, so that the
sequence can continue.

Example:
Use dequeue to end a custom queue function which
allows the queue to keep going.
1
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<!DOCTYPE html>
<html>
<head>
<style>
div { margin:3px; width:50px; position:absolute;
height:50px; left:10px; top:30px;
background-color:yellow; }
div.red { background-color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Start</button>
<div></div>
<script>
$("button").click(function () {
$("div").animate({left:'+=200px'}, 2000);
$("div").animate({top:'0px'}, 600);
$("div").queue(function () {
$(this).toggleClass("red");
$(this).dequeue();
});
$("div").animate({left:'10px', top:'30px'}, 700
});
</script>
</body>
</html>

Demo
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Descendant Selector (“ancestor
descendant”)
Categories: Selectors > Hierarchy

descendant selector
Description: Selects all elements that are descendants
of a given ancestor.
jQuery( "ancestor descendant" )

version added: 1.0

ancestor: Any valid selector.
descendant: A selector to filter the descendant elements.
A descendant of an element could be a child, grandchild, greatgrandchild, and so on, of that element.

Example:
Finds all input descendants of forms.
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<!DOCTYPE html>
<html>
<head>
<style>
body { font-size:14px; }
form { border:2px green solid; padding:2px; margin
background:#efe; }
div { color:red; }
fieldset { margin:1px; padding:3px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<div>Form is surrounded by the green outline
<label>Child:</label>
<input name="name" />
<fieldset>
<label>Grandchild:</label>
<input name="newsletter" />
</fieldset>
</form>
Sibling to form: <input name="none" />
<script>$("form input").css("border", "2px dotted blue"
</body>
</html>

Demo
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.detach()
Categories: Manipulation > DOM Removal

.detach( [selector ] )

Returns: jQuery

Description: Remove the set of matched elements from
the DOM.
.detach( [selector ] )

version added: 1.4

selector
Type: Selector
A selector expression that filters the set of matched elements to
be removed.
The

.detach() method is the same as .remove() , except that
.detach() keeps all jQuery data associated with the removed

elements. This method is useful when removed elements are to be
reinserted into the DOM at a later time.

Example:
Detach all paragraphs from the DOM
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

Demo

<!DOCTYPE html>
<html>
<head>
<style>p { background:yellow; margin:6px 0; }
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
how are
<p>you?</p>
<button>Attach/detach paragraphs</button>
<script>
$("p").click(function(){
$(this).toggleClass("off");
});
var p;
$("button").click(function(){
if ( p ) {
p.appendTo("body");
p = null;
} else {
p = $("p").detach();
}
});</script>
</body>
</html>

POWERED BYHERONOTE
A new version of this book is available!

.die()
Categories: Events > Event Handler Attachment

.die()

Returns: jQuery
version deprecated: 1.7, removed: 1.9

Description: Remove event handlers previously
attached using .live() from the elements.
.die()

version added: 1.4.1

This method does not accept any arguments.

.die( eventType [, handler ] )

version added: 1.3

eventType
Type: String
A string containing a JavaScript event type, such as
keydown .

click

or

handler
Type: String
The function that is no longer to be executed.

.die( events )

version added: 1.4.3

events
Type: PlainObject
A plain object of one or more event types, such as click or
keydown and their corresponding functions that are no longer to
be executed.
Any handler that has been attached with .live() can be removed
with .die() . This method is analogous to calling .off() with no
arguments, which is used to remove all handlers attached with
.on() . See the discussions of .live() and .off() for further details.
If used without an argument, .die() removes all event handlers
previously attached using .live() from the elements.
As of jQuery 1.7, use of .die() (and its complementary method,
.live() ) is not recommended. Instead, use .off() to remove event
handlers bound with .on()

Note: In order for .die() to function correctly, the selector used with it
must match exactly the selector initially used with .live().

Examples:
Example:

To unbind all live events from all paragraphs,

write:
1

$("p").die()

To unbind all live click events from all
paragraphs, write:
Example:

1

$("p").die( "click" )

To unbind just one previously bound handler,
pass the function in as the second argument:
Example:

1
2
3
4
5
6
7

var foo = function () {
// code to handle some kind of event
};
$("p").live("click", foo); // ... now foo will be called

$("p").die("click", foo); // ... foo will no longer be ca

POWERED BYHERONOTE

A new version of this book is available!

:disabled Selector
Categories: Selectors > Form

disabled selector
Description: Selects all elements that are disabled.
jQuery( ":disabled" )

version added: 1.0

As with other pseudo-class selectors (those that begin with a ":"), it
is recommended to precede it with a tag name or some other
selector; otherwise, the universal selector ("*") is implied. In other
words, the bare $(':disabled') is equivalent to $('*:disabled') , so
$('input:disabled') or similar should be used instead.
Although their resulting selections are usually the same, the
:disabled selector is subtly different from the [disabled] attribute
selector; :disabled checks the boolean (true/false) value of the
element's disabled property while [disabled] checks for the
existence of the disabled attribute.
The :disabled selector should only be used for selecting HTML
elements that support the disabled attribute ( <button> , <input> ,
<optgroup> , <option> , <select> , and <textarea> ).

Example:
Finds all input elements that are disabled.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<input name="email" disabled="disabled" />
<input name="id" />
</form>
<script>$("input:disabled").val("this is it");</
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.each()
Categories: Miscellaneous > Collection Manipulation | Traversing

.each( function(index, Element) )

Returns: jQuery

Description: Iterate over a jQuery object, executing a
function for each matched element.
.each( function(index, Element) )

version added: 1.0

function(index, Element)
Type: Function()
A function to execute for each matched element.
The .each() method is designed to make DOM looping constructs
concise and less error-prone. When called it iterates over the DOM
elements that are part of the jQuery object. Each time the callback
runs, it is passed the current loop iteration, beginning from 0. More
importantly, the callback is fired in the context of the current DOM
element, so the keyword this refers to the element.
Suppose you have a simple unordered list on the page:
1
2
3
4

<ul>
<li>foo</li>
<li>bar</li>
</ul>

You can select the list items and iterate across them:
1
2
3

$( "li" ).each(function( index ) {
console.log( index + ": " + $(this).text() );
});

A message is thus logged for each item in the list:
0: foo 1: bar

You can stop the loop from within the callback function by returning
false .
Note: most jQuery methods that return a jQuery object also loop
through the set of elements in the jQuery collection — a process
known as implicit iteration. When this occurs, it is often unnecessary
to explicitly iterate with the .each() method:
1
2
3
4
5
6
7

// The .each() method is unnecessary here:
$( "li" ).each(function() {
$(this).addClass( "foo" );
});
// Instead, you should rely on implicit iteration:
$( "li" ).addClass( "bar" );

Examples:
Example:

Iterate over three divs and sets their color

property.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<!DOCTYPE html>
<html>
<head>
<style>
div { color:red; text-align:center; cursor:pointer;
font-weight:bolder; width:300px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>Click here</div>
<div>to iterate through</div>
<div>these divs.</div>
<script>
$(document.body).click(function () {
$( "div" ).each(function (i) {
if ( this.style.color != "blue" ) {
this.style.color = "blue";
} else {
this.style.color = "";
}
});
});
</script>
</body>
</html>

Demo
Example:

To access a jQuery object instead of the
regular DOM element, use $(this) . For example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

Demo

<!DOCTYPE html>
<html>
<head>
<style>
ul { font-size:18px; margin:0; }
span { color:blue; text-decoration:underline;
.example { font-style:italic; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
To do list: <span>(click here to change)</span
<ul>
<li>Eat</li>
<li>Sleep</li>
<li>Be merry</li>
</ul>
<script>
$( "span" ).click(function () {
$( "li" ).each(function(){
$( this ).toggleClass( "example" );
});
});
</script>
</body>
</html>

Example:

Use "return" to break out of each() loops

early.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33

<!DOCTYPE html>
<html>
<head>
<style>
div { width:40px; height:40px; margin:5px; float
border:2px blue solid; text-align:center;
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Change colors</button>
<span></span>
<div></div>
<div></div>
<div></div>
<div></div>
<div id="stop">Stop here</div>
<div></div>
<div></div>
<div></div>
<script>
$( "button" ).click(function () {
$( "div" ).each(function ( index, domEle)
// domEle == this
$( domEle ).css( "backgroundColor", "yellow"
if ( $(this).is( "#stop" ) ) {
$( "span" ).text( "Stopped at div index #"
return false;
}
});

34
35
36
37
38
39

});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

Element Selector (“element”)
Categories: Selectors > Basic

element selector
Description: Selects all elements with the given tag
name.
jQuery( "element" )

version added: 1.0

element: An element to search for. Refers to the tagName of
DOM nodes.
JavaScript's getElementsByTagName() function is called to return the
appropriate elements when this expression is used.

Example:
Finds every DIV element.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

<!DOCTYPE html>
<html>
<head>
<style>
div,span {
width: 60px;
height: 60px;
float:left;
padding: 10px;
margin: 10px;
background-color: #EEEEEE;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>DIV1</div>
<div>DIV2</div>
<span>SPAN</span>
<script>$("div").css("border","9px solid red");
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

.empty()
Categories: Manipulation > DOM Removal

.empty()

Returns: jQuery

Description: Remove all child nodes of the set of
matched elements from the DOM.
.empty()

version added: 1.0

This method does not accept any arguments.
This method removes not only child (and other descendant)
elements, but also any text within the set of matched elements. This
is because, according to the DOM specification, any string of text
within an element is considered a child node of that element.
Consider the following HTML:
1
2
3
4

<div class="container">
<div class="hello">Hello</div>
<div class="goodbye">Goodbye</div>
</div>

We can target any element for removal:
1

$('.hello').empty();

This will result in a DOM structure with the
1
2
3
4

Hello

text deleted:

<div class="container">
<div class="hello"></div>
<div class="goodbye">Goodbye</div>
</div>

If we had any number of nested elements inside

<div

class="hello"> ,

they would be removed, too.

To avoid memory leaks, jQuery removes other constructs such as
data and event handlers from the child elements before removing
the elements themselves.
If you want to remove elements without destroying their data or
event handlers (so they can be re-added later), use .detach()
instead.

Example:
Removes all child nodes (including text nodes) from
all paragraphs
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22

<!DOCTYPE html>
<html>
<head>
<style>
p { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
Hello, <span>Person</span> <a href="javascript:;"
</p>
<button>Call empty() on above paragraph</button
<script>
$("button").click(function () {
$("p").empty();
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

:empty Selector
Categories: Selectors > Content Filter

empty selector
Description: Select all elements that have no children
(including text nodes).
jQuery( ":empty" )
This is the inverse of

version added: 1.0

:parent .

One important thing to note with :empty (and :parent) is that child
elements include text nodes.
The W3C recommends that the <p> element have at least one child
node, even if that child is merely text (see
http://www.w3.org/TR/html401/struct/text.html#edef-P). Some other
elements, on the other hand, are empty (i.e. have no children) by
definition: <input>, <img>, <br>, and <hr>, for example.

Example:
Finds all elements that are empty - they don't have
child elements or text.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

<!DOCTYPE html>
<html>
<head>
<style>
td { text-align:center; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<table border="1">
<tr><td>TD #0</td><td></td></tr>
<tr><td>TD #2</td><td></td></tr>

<tr><td></td><td>TD#5</td></tr>
</table>
<script>$("td:empty").text("Was empty!").css('background
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

:enabled Selector
Categories: Selectors > Form

enabled selector
Description: Selects all elements that are enabled.
jQuery( ":enabled" )

version added: 1.0

As with other pseudo-class selectors (those that begin with a ":") it is
recommended to precede it with a tag name or some other selector;
otherwise, the universal selector ("*") is implied. In other words, the
bare $(':enabled') is equivalent to $('*:enabled') , so
$('input:enabled') or similar should be used instead.
Although their resulting selections are usually the same, :enabled
selector is subtly different from :not([disabled]) ; :enabled selects
elements that have their boolean disabled property strictly equal to
false, while :not([disabled]) selects elements that do not have a
disabled attribute set (regardless of its value).
The :enabled selector should only be used for selecting HTML
elements that support the disabled attribute ( <button> , <input> ,
<optgroup> , <option> , <select> , and <textarea> ).

Example:
Find all input elements that are enabled.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<input name="email" disabled="disabled" />
<input name="id" />
</form>
<script>$("input:enabled").val("this is it");</
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.end()
Categories: Traversing > Miscellaneous Traversing

.end()

Returns: jQuery

Description: End the most recent filtering operation in
the current chain and return the set of matched elements
to its previous state.
.end()

version added: 1.0

This method does not accept any arguments.
Most of jQuery's DOM traversal methods operate on a jQuery object
instance and produce a new one, matching a different set of DOM
elements. When this happens, it is as if the new set of elements is
pushed onto a stack that is maintained inside the object. Each
successive filtering method pushes a new element set onto the
stack. If we need an older element set, we can use end() to pop the
sets back off of the stack.
Suppose we have a couple short lists on a page:
1
2
3
4
5
6
7
8
9
10

<ul class="first">
<li class="foo">list
<li>list item 2</li>
<li class="bar">list
</ul>
<ul class="second">
<li class="foo">list
<li>list item 2</li>
<li class="bar">list
</ul>

item 1</li>
item 3</li>

item 1</li>
item 3</li>

The end() method is useful primarily when exploiting jQuery's
chaining properties. When not using chaining, we can usually just
call up a previous object by variable name, so we don't need to
manipulate the stack. With end() , though, we can string all the
method calls together:

1
2

$('ul.first').find('.foo').css('background-color'
.end().find('.bar').css('background-color', 'green'

This chain searches for items with the class foo within the first list
only and turns their backgrounds red. Then end() returns the object
to its state before the call to find() , so the second find() looks for
'.bar' inside <ul class="first"> , not just inside that list's <li
class="foo"> , and turns the matching elements' backgrounds green.
The net result is that items 1 and 3 of the first list have a colored
background, and none of the items from the second list do.
A long jQuery chain can be visualized as a structured code block,
with filtering methods providing the openings of nested blocks and
end() methods closing them:
1
2
3
4
5

$('ul.first').find('.foo')
.css('background-color', 'red')
.end().find('.bar')
.css('background-color', 'green')
.end();

The last end() is unnecessary, as we are discarding the jQuery
object immediately thereafter. However, when the code is written in
this form, the end() provides visual symmetry and a sense of
completion —making the program, at least to the eyes of some
developers, more readable, at the cost of a slight hit to performance
as it is an additional function call.

Examples:
Selects all paragraphs, finds span elements
inside these, and reverts the selection back to the
paragraphs.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<!DOCTYPE html>
<html>
<head>
<style>
p, div { margin:1px; padding:1px; font-weight
font-size:16px; }
div { color:blue; }
b { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
Hi there <span>how</span> are you <span>doing
</p>
<p>
This <span>span</span> is one of
several <span>spans</span> in this
<span>sentence</span>.
</p>
<div>
Tags in jQuery object initially: <b></b>
</div>
<div>
Tags in jQuery object after find: <b></b>
</div>

30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54

<div>
Tags in jQuery object after end: <b></b>
</div>
<script>
jQuery.fn.showTags = function (n) {
var tags = this.map(function () {
return this.tagName;
})
.get().join(", ");
$("b:eq(" + n + ")").text(tags);
return this;
};
$("p").showTags(0)
.find("span")
.showTags(1)
.css("background", "yellow")
.end()
.showTags(2)
.css("font-style", "italic");
</script>
</body>
</html>

Demo
Example:

Selects all paragraphs, finds span elements
inside these, and reverts the selection back to the
paragraphs.
1
2
3
4

<!DOCTYPE html>
<html>
<head>
<style>p { margin:10px; padding:10px; }</style

5
6
7
8
9
10
11
12

<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><span>Hello</span>, how are you?</p>
<script>$("p").find("span").end().css("border",
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.eq()
Categories: Traversing > Filtering

.eq( index )

Returns: jQuery

Description: Reduce the set of matched elements to
the one at the specified index.
.eq( index )

version added: 1.1.2

index
Type: Integer
An integer indicating the 0-based position of the element.

.eq( -index )

version added: 1.4

-index
Type: Integer
An integer indicating the position of the element, counting
backwards from the last element in the set.
Given a jQuery object that represents a set of DOM elements, the
.eq() method constructs a new jQuery object from one element
within that set. The supplied index identifies the position of this
element in the set.
Consider a page with a simple list on it:
1
2
3
4
5
6
7

<ul>
<li>list
<li>list
<li>list
<li>list
<li>list
</ul>

item
item
item
item
item

1</li>
2</li>
3</li>
4</li>
5</li>

We can apply this method to the set of list items:
1

$('li').eq(2).css('background-color', 'red');

The result of this call is a red background for item 3. Note that the
supplied index is zero-based, and refers to the position of the
element within the jQuery object, not within the DOM tree.
Providing a negative number indicates a position starting from the
end of the set, rather than the beginning. For example:
1

$('li').eq(-2).css('background-color', 'red');

This time list item 4 is turned red, since it is two from the end of the
set.
If an element cannot be found at the specified zero-based index, the
method constructs a new jQuery object with an empty set and a
length property of 0.
1

$('li').eq(5).css('background-color', 'red');

Here, none of the list items is turned red, since
sixth of five list items.

.eq(5)

indicates the

Example:
Turn the div with index 2 blue by adding an
appropriate class.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

<!DOCTYPE html>
<html>
<head>
<style>
div { width:60px; height:60px; margin:10px; float
border:2px solid blue; }
.blue { background:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<script>
$("body").find("div").eq(2).addClass("blue");
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

:eq() Selector
Categories: Selectors > Basic Filter | Selectors > jQuery Extensions

eq selector
Description: Select the element at index
matched set.
jQuery( ":eq(index)" )

n

within the

version added: 1.0

index: Zero-based index of the element to match.

jQuery( ":eq(-index)" )

version added: 1.8

-index: Zero-based index of the element to match, counting
backwards from the last element.
The index-related selectors ( :eq() , :lt() , :gt() , :even , :odd ) filter
the set of elements that have matched the expressions that precede
them. They narrow the set down based on the order of the elements
within this matched set. For example, if elements are first selected
with a class selector ( .myclass ) and four elements are returned,
these elements are given indices 0 through 3 for the purposes of
these selectors.
Note that since JavaScript arrays use 0-based indexing, these
selectors reflect that fact. This is why $('.myclass:eq(1)') selects
the second element in the document with the class myclass, rather
than the first. In contrast, :nth-child(n) uses 1-based indexing to
conform to the CSS specification.
Prior to jQuery 1.8, the :eq(index) selector did not accept a negative
value for index (though the .eq(index) method did).

Additional Notes:
Because :eq() is a jQuery extension and not part of the CSS
specification, queries using :eq() cannot take advantage of the
performance boost provided by the native DOM
querySelectorAll() method. For better performance in modern
browsers, use $("your-pure-css-selector").eq(index) instead.

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

Finds the third td.

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<table border="1">
<tr><td>TD #0</td><td>TD #1</td><td>TD #2</td
<tr><td>TD #3</td><td>TD #4</td><td>TD #5</td
<tr><td>TD #6</td><td>TD #7</td><td>TD #8</td
</table>
<script>$("td:eq(2)").css("color", "red");</script
</body>
</html>

Demo
Example:

Apply three different styles to list items to
demonstrate that :eq() is designed to select a single
element while :nth-child() or :eq() within a looping
construct such as .each() can select multiple elements.
1
2
3
4
5
6
7

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul class="nav">

8
9
10
11
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<li>List 1, item 1</li>
<li>List 1, item 2</li>
<li>List 1, item 3</li>
</ul>
<ul class="nav">
<li>List 2, item 1</li>
<li>List 2, item 2</li>
<li>List 2, item 3</li>
</ul>
<script>
/* applies yellow background color to a single <li> */
$("ul.nav li:eq(1)").css( "backgroundColor", "#ff0"

/* applies italics to text of the second <li> within eac
$("ul.nav").each(function(index) {
$(this).find("li:eq(1)").css( "fontStyle", "italic"
});

/* applies red text color to descendants of <ul class="n
/* for each <li> that is the second child of its parent
$("ul.nav li:nth-child(2)").css( "color", "red"
</script>
</body>
</html>

Demo
Example:

Add a class to List 2, item 2 by targeting the
second to last <li>
1
2
3
4

<!DOCTYPE html>
<html>
<head>
<style>

5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

.foo {
color: blue;
background-color: yellow;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul class="nav">
<li>List 1, item 1</li>
<li>List 1, item 2</li>
<li>List 1, item 3</li>
</ul>
<ul class="nav">
<li>List 2, item 1</li>
<li>List 2, item 2</li>
<li>List 2, item 3</li>
</ul>
<script>
$( "li:eq(-2)" ).addClass( "foo" )
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

.error()
Categories: Events > Browser Events

.error( handler(eventObject) )

Returns: jQuery
version deprecated: 1.8

Description: Bind an event handler to the "error"
JavaScript event.
.error( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute when the event is triggered.

.error( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: Object
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.
This method is a shortcut for

.on('error', handler) .

The error event is sent to elements, such as images, that are
referenced by a document and loaded by the browser. It is called if
the element was not loaded correctly.
For example, consider a page with a simple image element:
1

<img alt="Book" id="book" />

The event handler can be bound to the image:
1

$('#book')

2
3
4
5

.error(function() {
alert('Handler for .error() called.')
})
.attr("src", "missing.png");

If the image cannot be loaded (for example, because it is not present
at the supplied URL), the alert is displayed:
Handler for .error() called.

The event handler must be attached before
the browser fires the error event, which is
why the example sets the src attribute after
attaching the handler. Also, the error event
may not be correctly fired when the page is
served locally; error relies on HTTP status
codes and will generally not be triggered if
the URL uses the file: protocol.
Note: A jQuery error event handler should not be attached to the
window object. The browser fires the window's error event when a
script error occurs. However, the window error event receives
different arguments and has different return value requirements than
conventional event handlers. Use window.onerror instead.

Example:
To hide the "broken image" icons for IE users, you
can try:
1
2
3
4
5

$("img")
.error(function(){
$(this).hide();
})
.attr("src", "missing.png");

POWERED BYHERONOTE
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:even Selector
Categories: Selectors > Basic Filter | Selectors > jQuery Extensions

even selector
Description: Selects even elements, zero-indexed. See
also odd.
jQuery( ":even" )

version added: 1.0

In particular, note that the 0-based indexing means that, counterintuitively, :even selects the first element, third element, and so on
within the matched set.

Additional Notes:
Because :even is a jQuery extension and not part of the CSS
specification, queries using :even cannot take advantage of the
performance boost provided by the native DOM
querySelectorAll() method. To achieve the best performance
when using :even to select elements, first select the elements
using a pure CSS selector, then use .filter(":even") .
Selected elements are in the order of their appearance in the
document.

Example:
Finds even table rows, matching the first, third and so
on (index 0, 2, 4 etc.).
1
2
3
4
5
6
7
8
9
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12
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14
15
16
17
18
19
20
21
22

<!DOCTYPE html>
<html>
<head>
<style>
table {
background:#eeeeee;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<table border="1">
<tr><td>Row with Index #0</td></tr>
<tr><td>Row with Index #1</td></tr>
<tr><td>Row with Index #2</td></tr>
<tr><td>Row with Index #3</td></tr>
</table>
<script>$("tr:even").css("background-color", "#bbbbff"
</body>
</html>

Demo
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event.currentTarget
Categories: Events > Event Object

event.currentTarget

Returns: Element

Description: The current DOM element within the event
bubbling phase.
event.currentTarget
This property will typically be equal to the

version added: 1.3
this

of the function.

If you are using jQuery.proxy or another form of scope manipulation,
this will be equal to whatever context you have provided, not
event.currentTarget

Example:
Alert that currentTarget matches the `this` keyword.
1
2
3

$("p").click(function(event) {
alert( event.currentTarget === this ); // true
});

POWERED BYHERONOTE
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event.data
Categories: Events > Event Object

event.data

Returns: Object

Description: An optional object of data passed to an
event method when the current executing handler is
bound.
event.data

version added: 1.1

Example:
Within a for loop, pass the value of i to the .on()
method so that the current iteration's value is
preserved.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>
<button>
<button>
<button>
<button>

0
1
2
3
4

</button>
</button>
</button>
</button>
</button>

<div id="log"></div>
<script>
var logDiv = $("#log");

/* Note: This code is for demonstration purposes only. *
for (var i = 0; i < 5; i++) {
$("button").eq(i).on("click", {value: i}, function
var msgs = [
"button = " + $(this).index(),
"event.data.value = " + event.data.value,
"i = " + i
];
logDiv.append( msgs.join(", ") + "<br>" );
});
}

30
31
32
33

</script>
</body>
</html>

Demo
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event.delegateTarget
Categories: Events > Event Object | Events

event.delegateTarget

Returns: Element

Description: The element where the currently-called
jQuery event handler was attached.
event.delegateTarget

version added: 1.7

This property is most often useful in delegated events attached by
.delegate() or .on() , where the event handler is attached at an
ancestor of the element being processed. It can be used, for
example, to identify and remove event handlers at the delegation
point.
For non-delegated event handlers attached directly to an element,
event.delegateTarget will always be equal to event.currentTarget .

Example:
When a button in any box class is clicked, change the
box's background color to red.
1
2
3

$(".box").on("click", "button", function(event) {
$(event.delegateTarget).css("background-color"
});

POWERED BYHERONOTE
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event.isDefaultPrevented()
Categories: Events > Event Object

event.isDefaultPrevented()

Returns: Boolean

Description: Returns whether event.preventDefault()
was ever called on this event object.
event.isDefaultPrevented()
This method does not accept any arguments.

version added: 1.3

Example:
Checks whether event.preventDefault() was called.
1
2
3
4
5

$("a").click(function(event){
alert( event.isDefaultPrevented() ); // false
event.preventDefault();
alert( event.isDefaultPrevented() ); // true
});

POWERED BYHERONOTE
A new version of this book is available!

event.isImmediatePropagationStopped(
Categories: Events > Event Object

event.isImmediatePropagationStopped() Returns: Boolean
Description: Returns whether
event.stopImmediatePropagation() was ever called on
this event object.
version added: 1.3

event.isImmediatePropagationStopped()
This method does not accept any arguments.
This property was introduced in DOM level 3.

Example:
Checks whether event.stopImmediatePropagation()
was called.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>click me</button>
<div id="stop-log"></div>
<script>
function immediatePropStopped(e) {
var msg = "";
if ( e.isImmediatePropagationStopped() ) {
msg = "called"
} else {
msg = "not called";
}
$("#stop-log").append( "<div>" + msg + "</div>"
}
$("button").click(function(event) {
immediatePropStopped(event);
event.stopImmediatePropagation();
immediatePropStopped(event);
});
</script>
</body>

31

</html>

Demo
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event.isPropagationStopped()
Categories: Events > Event Object

event.isPropagationStopped()

Returns: Boolean

Description: Returns whether event.stopPropagation()
was ever called on this event object.
event.isPropagationStopped()

version added: 1.3

This method does not accept any arguments.
This event method is described in the W3C DOM Level 3
specification.

Example:
Checks whether event.stopPropagation() was called
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>click me</button>
<div id="stop-log"></div>
<script>
function propStopped(e) {
var msg = "";
if ( e.isPropagationStopped() ) {
msg = "called"
} else {
msg = "not called";
}
$("#stop-log").append( "<div>" + msg + "</div>"
}
$("button").click(function(event) {
propStopped(event);
event.stopPropagation();
propStopped(event);
});
</script>
</body>
</html>

Demo
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event.metaKey
Categories: Events > Event Object

event.metaKey

Returns: Boolean

Description: Indicates whether the META key was
pressed when the event fired.
event.metaKey

version added: 1.0.4

Returns a boolean value ( true or false ) that indicates whether or
not the META key was pressed at the time the event fired. This key
might map to an alternative key name on some platforms.

Example:
Determine whether the META key was pressed when
the event fired.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

<!DOCTYPE html>
<html>
<head>
<style>body {background-color: #eef; }
div { padding: 20px; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button value="Test" name="Test" id="checkMetaKey"
<div id="display"></div>
<script>
$('#checkMetaKey').click(function(e){
$('#display').text(e.metaKey);
});
</script>
</body>
</html>

Demo
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event.namespace
Categories: Events > Event Object

event.namespace

Returns: String

Description: The namespace specified when the event
was triggered.
event.namespace

version added: 1.4.3

This will likely be used primarily by plugin authors who wish to
handle tasks differently depending on the event namespace used.

Example:
Determine the event namespace used.
1
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20
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>display event.namespace</button>
<p></p>
<script>
$("p").on("test.something", function(event) {
alert( event.namespace );
});
$("button").click(function(event) {
$("p").trigger("test.something");
});
</script>
</body>
</html>

Demo
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event.pageX
Categories: Events > Event Object

event.pageX

Returns: Number

Description: The mouse position relative to the left
edge of the document.
event.pageX

version added: 1.0.4

Example:
Show the mouse position relative to the left and top
edges of the document (within the iframe).
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

<!DOCTYPE html>
<html>
<head>
<style>body {background-color: #eef; }
div { padding: 20px; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="log"></div>
<script>$(document).on('mousemove',function(e){
$("#log").text("e.pageX: " + e.pageX +
}); </script>
</body>
</html>

Demo
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event.pageY
Categories: Events > Event Object

event.pageY

Returns: Number

Description: The mouse position relative to the top
edge of the document.
event.pageY

version added: 1.0.4

Example:
Show the mouse position relative to the left and top
edges of the document (within this iframe).
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<!DOCTYPE html>
<html>
<head>
<style>body {background-color: #eef; }
div { padding: 20px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="log"></div>
<script>
$(document).on('mousemove',function(e){
$("#log").text("e.pageX: " + e.pageX + ", e.pageY: "
});
</script>
</body>
</html>

Demo
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event.preventDefault()
Categories: Events > Event Object

event.preventDefault()

Returns: undefined

Description: If this method is called, the default action
of the event will not be triggered.
event.preventDefault()

version added: 1.0

This method does not accept any arguments.
For example, clicked anchors will not take the browser to a new
URL. We can use event.isDefaultPrevented() to determine if this
method has been called by an event handler that was triggered by
this event.

Example:
Cancel the default action (navigation) of the click.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

<a href="http://jquery.com">default click action is prev
<div id="log"></div>
<script>
$("a").click(function(event) {
event.preventDefault();
$('<div/>')
.append('default ' + event.type + ' prevented'
.appendTo('#log');
});
</script>
</body>
</html>

Demo
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event.relatedTarget
Categories: Events > Event Object

event.relatedTarget

Returns: Element

Description: The other DOM element involved in the
event, if any.
event.relatedTarget

version added: 1.1.4

For mouseout , indicates the element being entered; for
indicates the element being exited.

mouseover ,

Example:
On mouseout of anchors, alert the element type being
entered.
1
2
3

$("a").mouseout(function(event) {
alert(event.relatedTarget.nodeName); // "DIV"
});

POWERED BYHERONOTE
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event.result
Categories: Events > Event Object

event.result

Returns: Object

Description: The last value returned by an event
handler that was triggered by this event, unless the
value was undefined .
event.result

version added: 1.3

This property can be useful for getting previous return values of
custom events.

Example:
Display previous handler's return value
1
2
3
4
5
6
7
8
9
10
11
12
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14
15
16
17
18
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20
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>display event.result</button>
<p></p>
<script>
$("button").click(function(event) {
return "hey";
});
$("button").click(function(event) {
$("p").html( event.result );
});
</script>
</body>
</html>

Demo
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event.stopImmediatePropagation()
Categories: Events > Event Object

event.stopImmediatePropagation()

Returns:

Description: Keeps the rest of the handlers from being
executed and prevents the event from bubbling up the
DOM tree.
event.stopImmediatePropagation()

version added: 1.3

This method does not accept any arguments.
In addition to keeping any additional handlers on an element from
being executed, this method also stops the bubbling by implicitly
calling event.stopPropagation() . To simply prevent the event from
bubbling to ancestor elements but allow other event handlers to
execute on the same element, we can use event.stopPropagation()
instead.
Use event.isImmediatePropagationStopped() to know whether this
method was ever called (on that event object).

Additional Notes:
Since the .live() method handles events once they have
propagated to the top of the document, it is not possible to stop
propagation of live events. Similarly, events handled by
.delegate() will propagate to the elements to which they are
delegated; event handlers bound on any elements below it in
the DOM tree will already have been executed by the time the
delegated event handler is called. These handlers, therefore,
may prevent the delegated handler from triggering by calling
event.stopPropagation() or returning false .

Example:
Prevents other event handlers from being called.
1
2
3
4
5
6
7
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14
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17
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19
20
21
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23
24
25
26
27

Demo

<!DOCTYPE html>
<html>
<head>
<style>
p { height: 30px; width: 150px; background-color
div {height: 30px; width: 150px; background-color
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>paragraph</p>
<div>division</div>
<script>
$("p").click(function(event){
event.stopImmediatePropagation();
});
$("p").click(function(event){
// This function won't be executed
$(this).css("background-color", "#f00");
});
$("div").click(function(event) {
// This function will be executed
$(this).css("background-color", "#f00");
});</script>
</body>
</html>
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event.stopPropagation()
Categories: Events > Event Object

event.stopPropagation()

Returns:

Description: Prevents the event from bubbling up the
DOM tree, preventing any parent handlers from being
notified of the event.
event.stopPropagation()

version added: 1.0

This method does not accept any arguments.
We can use event.isPropagationStopped() to determine if this
method was ever called (on that event object).
This method works for custom events triggered with trigger(), as
well.
Note that this will not prevent other handlers on the same element
from running.

Additional Notes:
Since the .live() method handles events once they have
propagated to the top of the document, it is not possible to stop
propagation of live events. Similarly, events handled by
.delegate() will propagate to the elements to which they are
delegated; event handlers bound on any elements below it in
the DOM tree will already have been executed by the time the
delegated event handler is called. These handlers, therefore,
may prevent the delegated handler from triggering by calling
event.stopPropagation() or returning false .

Example:
Kill the bubbling on the click event.
1
2
3
4

$("p").click(function(event){
event.stopPropagation();
// do something
});

POWERED BYHERONOTE
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event.target
Categories: Events > Event Object

event.target

Returns: Element

Description: The DOM element that initiated the event.
event.target

version added: 1.0

The target property can be the element that registered for the event
or a descendant of it. It is often useful to compare event.target to
this in order to determine if the event is being handled due to event
bubbling. This property is very useful in event delegation, when
events bubble.

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23

Display the tag's name on click

<!DOCTYPE html>
<html>
<head>
<style>
span, strong, p {
padding: 8px; display: block; border: 1px solid
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="log"></div>
<div>
<p>
<strong><span>click</span></strong>
</p>
</div>
<script>$("body").click(function(event) {
$("#log").html("clicked: " + event.target.nodeName);
}); </script>
</body>
</html>

Demo
Example:

Implements a simple event delegation: The
click handler is added to an unordered list, and the
children of its li children are hidden. Clicking one of the
li children toggles (see toggle()) their children.

1
2
3
4
5
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15
16
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19
20
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23
24
25
26
27
28
29
30
31

Demo

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul>
<li>item 1
<ul>
<li>sub item 1-a</li>
<li>sub item 1-b</li>
</ul>
</li>
<li>item 2
<ul>
<li>sub item 2-a</li>
<li>sub item 2-b</li>
</ul>
</li>
</ul>
<script>function handler(event) {
var $target = $(event.target);
if( $target.is("li") ) {
$target.children().toggle();
}
}
$("ul").click(handler).find("ul").hide();</script
</body>
</html>
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event.timeStamp
Categories: Events > Event Object

event.timeStamp

Returns: Number

Description: The difference in milliseconds between the
time the browser created the event and January 1, 1970.
event.timeStamp

version added: 1.2.6

This property can be useful for profiling event performance by
getting the event.timeStamp value at two points in the code and
noting the difference. To simply determine the current time inside an
event handler, use (new Date).getTime() instead.
Note: Due to a bug open since 2004, this value is not populated
correctly in Firefox and it is not possible to know the time the event
was created in that browser.

Example:
Display the time since the click handler last
executed.
1
2
3
4
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<!DOCTYPE html>
<html>
<head>
<style>
div { height: 100px; width: 300px; margin: 10px;
background-color: #ffd; overflow: auto; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>Click.</div>
<script>
var last, diff;
$('div').click(function(event) {
if ( last ) {
diff = event.timeStamp - last
$('div').append('time since last event: ' + diff +
} else {
$('div').append('Click again.<br/>');
}
last = event.timeStamp;
});
</script>
</body>
</html>

Demo
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event.type
Categories: Events > Event Object

event.type

Returns: String

Description: Describes the nature of the event.
event.type

version added: 1.0

Example:
On all anchor clicks, alert the event type.
1
2
3

$("a").click(function(event) {
alert(event.type); // "click"
});

POWERED BYHERONOTE
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event.which
Categories: Events > Event Object

event.which

Returns: Number

Description: For key or mouse events, this property
indicates the specific key or button that was pressed.
event.which

version added: 1.1.3

The

event.which property normalizes event.keyCode and
event.charCode . It is recommended to watch event.which

for
keyboard key input. For more detail, read about event.charCode on
the MDC.
event.which also normalizes button presses ( mousedown and
mouseup events), reporting 1 for left button, 2 for middle, and 3
right. Use event.which instead of event.button .

for

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<input id="whichkey" value="type something">
<div id="log"></div>
<script>$('#whichkey').on('keydown',function(e){
$('#log').html(e.type + ': ' + e.which );
}); </script>
</body>
</html>

Demo
Example:
1
2
3
4
5
6
7
8
9
10

Log which key was depressed.

Log which mouse button was depressed.

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<input id="whichkey" value="type something">
<div id="log"></div>
<script>

11
12
13
14
15
16
17

$('#whichkey').on('mousedown',function(e){
$('#log').html(e.type + ': ' + e.which );
});
</script>
</body>
</html>

Demo
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.fadeIn()
Categories: Effects > Fading

.fadeIn( [duration ] [, complete ] )

Returns: jQuery

Description: Display the matched elements by fading
them to opaque.
.fadeIn( [duration ] [, complete ] )

version added: 1.0

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
complete
Type: Function()
A function to call once the animation is complete.

.fadeIn( options )

version added: 1.0

options
Type: PlainObject
A map of additional options to pass to the method.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will
run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
queue (default: true )
Type: Boolean
A Boolean indicating whether to place the animation in the
effects queue. If false, the animation will begin immediately.
As of jQuery 1.7, the queue option can also accept a
string, in which case the animation is added to the queue
represented by that string.
specialEasing
Type: PlainObject

A map of one or more of the CSS properties defined by the
properties argument and their corresponding easing
functions. (version added: 1.4)
step
Type: Function( Number now, Tween tween )
A function to be called for each animated property of each
animated element. This function provides an opportunity to
modify the Tween object to change the value of the
property before it is set.
progress
Type: Function( Promise animation, Number progress,
Number remainingMs )
A function to be called after each step of the animation,
only once per animated element regardless of the number
of animated properties. (version added: 1.8)
complete
Type: Function()
A function to call once the animation is complete.
done
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes (its
Promise object is resolved). (version added: 1.8)
fail
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation fails to complete
(its Promise object is rejected). (version added: 1.8)
always
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes or
stops without completing (its Promise object is either
resolved or rejected). (version added: 1.8)

.fadeIn( [duration ] [, easing ] [,
complete ] )

version added: 1.4.3

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.
The .fadeIn() method animates the opacity of the matched
elements.
Durations are given in milliseconds; higher values indicate slower
animations, not faster ones. The strings 'fast' and 'slow' can be
supplied to indicate durations of 200 and 600 milliseconds,
respectively. If any other string is supplied, or if the duration
parameter is omitted, the default duration of 400 milliseconds is
used.
We can animate any element, such as a simple image:
1
2
3
4
5
6
7
8
9
10

<div id="clickme">
Click here
</div>
<img id="book" src="book.png" alt="" width=
With the element initially hidden, we can show it s
$('#clickme').click(function() {
$('#book').fadeIn('slow', function() {
// Animation complete
});
});

Easing
As of jQuery 1.4.3, an optional string naming an easing function
may be used. Easing functions specify the speed at which the
animation progresses at different points within the animation. The
only easing implementations in the jQuery library are the default,
called swing , and one that progresses at a constant pace, called
linear . More easing functions are available with the use of plug-ins,
most notably the jQuery UI suite.
Callback Function
If supplied, the callback is fired once the animation is complete. This
can be useful for stringing different animations together in sequence.
The callback is not sent any arguments, but this is set to the DOM
element being animated. If multiple elements are animated, it is
important to note that the callback is executed once per matched
element, not once for the animation as a whole.
As of jQuery 1.6, the .promise() method can be used in conjunction
with the deferred.done() method to execute a single callback for the
animation as a whole when all matching elements have completed
their animations ( See the example for .promise() ).

Additional Notes:
All jQuery effects, including

.fadeIn() ,

can be turned off globally

by setting jQuery.fx.off = true , which effectively sets the
duration to 0. For more information, see jQuery.fx.off.

Examples:
Animates hidden divs to fade in one by one,
completing each animation within 600 milliseconds.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<!DOCTYPE html>
<html>
<head>
<style>
span { color:red; cursor:pointer; }
div { margin:3px; width:80px; display:none;
height:80px; float:left; }
div#one { background:#f00; }
div#two { background:#0f0; }
div#three { background:#00f; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<span>Click here...</span>
<div id="one"></div>
<div id="two"></div>
<div id="three"></div>
<script>
$(document.body).click(function () {
$("div:hidden:first").fadeIn("slow");
});
</script>
</body>
</html>

Demo
Example:

Fades a red block in over the text. Once the
animation is done, it quickly fades in more text on
top.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32

<!DOCTYPE html>
<html>
<head>
<style>
p { position:relative; width:400px; height:
div { position:absolute; width:400px; height
font-size:36px; text-align:center;
color:yellow; background:red;
padding-top:25px;
top:0; left:0; display:none; }
span { display:none; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
Let it be known that the party of the first part
and the party of the second part are henceforth
and hereto directed to assess the allegations
for factual correctness... (<a href="#">click!
<div><span>CENSORED!</span></div>
</p>
<script>
$("a").click(function () {
$("div").fadeIn(3000, function () {
$("span").fadeIn(100);
});
return false;
});
</script>
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</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.fadeOut()
Categories: Effects > Fading

.fadeOut( [duration ] [, complete ] )

Returns: jQuery

Description: Hide the matched elements by fading them
to transparent.
.fadeOut( [duration ] [, complete ] )

version added: 1.0

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
complete
Type: Function()
A function to call once the animation is complete.

.fadeOut( options )

version added: 1.0

options
Type: PlainObject
A map of additional options to pass to the method.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will
run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
queue (default: true )
Type: Boolean
A Boolean indicating whether to place the animation in the
effects queue. If false, the animation will begin immediately.
As of jQuery 1.7, the queue option can also accept a
string, in which case the animation is added to the queue
represented by that string.
specialEasing
Type: PlainObject

A map of one or more of the CSS properties defined by the
properties argument and their corresponding easing
functions. (version added: 1.4)
step
Type: Function( Number now, Tween tween )
A function to be called for each animated property of each
animated element. This function provides an opportunity to
modify the Tween object to change the value of the
property before it is set.
progress
Type: Function( Promise animation, Number progress,
Number remainingMs )
A function to be called after each step of the animation,
only once per animated element regardless of the number
of animated properties. (version added: 1.8)
complete
Type: Function()
A function to call once the animation is complete.
done
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes (its
Promise object is resolved). (version added: 1.8)
fail
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation fails to complete
(its Promise object is rejected). (version added: 1.8)
always
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes or
stops without completing (its Promise object is either
resolved or rejected). (version added: 1.8)

.fadeOut( [duration ] [, easing ] [,
complete ] )

version added: 1.4.3

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.
The .fadeOut() method animates the opacity of the matched
elements. Once the opacity reaches 0, the display style property is
set to none , so the element no longer affects the layout of the page.
Durations are given in milliseconds; higher values indicate slower
animations, not faster ones. The strings 'fast' and 'slow' can be
supplied to indicate durations of 200 and 600 milliseconds,
respectively. If any other string is supplied, or if the duration
parameter is omitted, the default duration of 400 milliseconds is
used.
We can animate any element, such as a simple image:
1
2
3
4

<div id="clickme">
Click here
</div>
<img id="book" src="book.png" alt="" width="100"

With the element initially shown, we can hide it slowly:
1
2
3
4

$('#clickme').click(function() {
$('#book').fadeOut('slow', function() {
// Animation complete.
});

5

});

Note: To avoid unnecessary DOM
manipulation, .fadeOut() will not hide an
element that is already considered hidden.
For information on which elements jQuery
considers hidden, see :hidden Selector.
Easing
As of jQuery 1.4.3, an optional string naming an easing function
may be used. Easing functions specify the speed at which the
animation progresses at different points within the animation. The
only easing implementations in the jQuery library are the default,
called swing , and one that progresses at a constant pace, called
linear . More easing functions are available with the use of plug-ins,
most notably the jQuery UI suite.
Callback Function
If supplied, the callback is fired once the animation is complete. This
can be useful for stringing different animations together in sequence.
The callback is not sent any arguments, but this is set to the DOM
element being animated. If multiple elements are animated, it is
important to note that the callback is executed once per matched

element, not once for the animation as a whole.
As of jQuery 1.6, the .promise() method can be used in conjunction
with the deferred.done() method to execute a single callback for the
animation as a whole when all matching elements have completed
their animations ( See the example for .promise() ).

Additional Notes:
All jQuery effects, including .fadeOut() , can be turned off
globally by setting jQuery.fx.off = true , which effectively sets
the duration to 0. For more information, see jQuery.fx.off.

Examples:
Animates all paragraphs to fade out,
completing the animation within 600 milliseconds.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<!DOCTYPE html>
<html>
<head>
<style>
p { font-size:150%; cursor:pointer; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
If you click on this paragraph
you'll see it just fade away.
</p>
<script>
$("p").click(function () {
$("p").fadeOut("slow");
});
</script>
</body>
</html>

Demo
Example:

Fades out spans in one section that you click

on.
1
2

<!DOCTYPE html>
<html>

3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36

Demo

<head>
<style>
span { cursor:pointer; }
span.hilite { background:yellow; }
div { display:inline; color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<h3>Find the modifiers - <div></div></h3>
<p>
If you <span>really</span> want to go outside
<span>in the cold</span> then make sure to wear
your <span>warm</span> jacket given to you by
your <span>favorite</span> teacher.
</p>
<script>
$("span").click(function () {
$(this).fadeOut(1000, function () {
$("div").text("'" + $(this).text() + "' has faded!"
$(this).remove();
});
});
$("span").hover(function () {
$(this).addClass("hilite");
}, function () {
$(this).removeClass("hilite");
});
</script>
</body>
</html>

Fades out two divs, one with a "linear"
easing and one with the default, "swing," easing.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33

<!DOCTYPE html>
<html>
<head>
<style>
.box,
button { float:left; margin:5px 10px 5px 0; }
.box { height:80px; width:80px; background:#090
#log { clear:left; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="btn1">fade out</button>
<button id="btn2">show</button>
<div id="log"></div>
<div id="box1" class="box">linear</div>
<div id="box2" class="box">swing</div>
<script>
$("#btn1").click(function() {
function complete() {
$("<div/>").text(this.id).appendTo("#log");
}
$("#box1").fadeOut(1600, "linear", complete);
$("#box2").fadeOut(1600, complete);
});
$("#btn2").click(function() {

34
35
36
37
38
39
40
41

$("div").show();
$("#log").empty();
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.fadeTo()
Categories: Effects > Fading

.fadeTo( duration, opacity [, complete ] )

Returns: jQuery

Description: Adjust the opacity of the matched
elements.
.fadeTo( duration, opacity [, complete version added: 1.0
])
duration
Type: String or Number
A string or number determining how long the animation will run.
opacity
Type: Number
A number between 0 and 1 denoting the target opacity.
complete
Type: Function()
A function to call once the animation is complete.

.fadeTo( duration, opacity [, easing ] version added: 1.4.3
[, complete ] )
duration
Type: String or Number
A string or number determining how long the animation will run.
opacity
Type: Number
A number between 0 and 1 denoting the target opacity.
easing
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.

The .fadeTo() method animates the opacity of the matched
elements.
Durations are given in milliseconds; higher values indicate slower
animations, not faster ones. The strings 'fast' and 'slow' can be
supplied to indicate durations of 200 and 600 milliseconds,
respectively. If any other string is supplied, the default duration of
400 milliseconds is used. Unlike the other effect methods, .fadeTo()
requires that duration be explicitly specified.
If supplied, the callback is fired once the animation is complete. This
can be useful for stringing different animations together in sequence.
The callback is not sent any arguments, but this is set to the DOM
element being animated. If multiple elements are animated, it is
important to note that the callback is executed once per matched
element, not once for the animation as a whole.
We can animate any element, such as a simple image:
1
2
3
4
5
6
7
8
9
10

<div id="clickme">
Click here
</div>
<img id="book" src="book.png" alt="" width="100"
With the element initially shown, we can dim it slowl
$('#clickme').click(function() {
$('#book').fadeTo('slow', 0.5, function() {
// Animation complete.
});
});

With duration set to 0 , this method just changes the opacity CSS
property, so .fadeTo(0, opacity) is the same as .css('opacity',
opacity) .

Additional Notes:

All jQuery effects, including .fadeTo() , can be turned off globally
by setting jQuery.fx.off = true , which effectively sets the
duration to 0. For more information, see jQuery.fx.off.

Examples:
Animates first paragraph to fade to an
opacity of 0.33 (33%, about one third visible),
completing the animation within 600 milliseconds.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
Click this paragraph to see it fade.
</p>
<p>
Compare to this one that won't fade.
</p>
<script>
$("p:first").click(function () {
$(this).fadeTo("slow", 0.33);
});
</script>
</body>
</html>

Demo
Example:

Fade div to a random opacity on each click,
completing the animation within 200 milliseconds.
1

<!DOCTYPE html>

2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

<html>
<head>
<style>
p { width:80px; margin:0; padding:5px; }
div { width:40px; height:40px; position:absolute;
div#one { top:0; left:0; background:#f00; }
div#two { top:20px; left:20px; background:#0f0;
div#three { top:40px; left:40px; background:#00f
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>And this is the library that John built...
<div id="one"></div>
<div id="two"></div>
<div id="three"></div>
<script>
$("div").click(function () {
$(this).fadeTo("fast", Math.random());
});
</script>
</body>
</html>

Demo
Example:

Find the right answer! The fade will take 250
milliseconds and change various styles when it
completes.
1
2
3
4

<!DOCTYPE html>
<html>
<head>
<style>

5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41

div, p { width:80px; height:40px; top:0; margin
position:absolute; padding-top:8px; }
p { background:#fcc; text-align:center; }
div { background:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Wrong</p>
<div></div>
<p>Wrong</p>
<div></div>
<p>Right!</p>
<div></div>
<script>
var getPos = function (n) {
return (Math.floor(n) * 90) + "px";
};
$("p").each(function (n) {
var r = Math.floor(Math.random() * 3);
var tmp = $(this).text();
$(this).text($("p:eq(" + r + ")").text());
$("p:eq(" + r + ")").text(tmp);
$(this).css("left", getPos(n));
});
$("div").each(function (n) {
$(this).css("left", getPos(n));
})
.css("cursor", "pointer")
.click(function () {
$(this).fadeTo(250, 0.25, function () {
$(this).css("cursor", "")
.prev().css({"font-weight": "bolder",
"font-style": "italic"});
});
});
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</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.fadeToggle()
Categories: Effects | Effects > Fading

.fadeToggle( [duration ] [, easing ] [, complete ] )
Returns: jQuery
Description: Display or hide the matched elements by
animating their opacity.
.fadeToggle( [duration ] [, easing ] [, version added: 1.4.4
complete ] )
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.

.fadeToggle( options )

version added: 1.4.4

options
Type: PlainObject
A map of additional options to pass to the method.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will
run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
queue (default: true )
Type: Boolean
A Boolean indicating whether to place the animation in the

effects queue. If false, the animation will begin immediately.
As of jQuery 1.7, the queue option can also accept a
string, in which case the animation is added to the queue
represented by that string.
specialEasing
Type: PlainObject
A map of one or more of the CSS properties defined by the
properties argument and their corresponding easing
functions. (version added: 1.4)
step
Type: Function( Number now, Tween tween )
A function to be called for each animated property of each
animated element. This function provides an opportunity to
modify the Tween object to change the value of the
property before it is set.
progress
Type: Function( Promise animation, Number progress,
Number remainingMs )
A function to be called after each step of the animation,
only once per animated element regardless of the number
of animated properties. (version added: 1.8)
complete
Type: Function()
A function to call once the animation is complete.
done
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes (its
Promise object is resolved). (version added: 1.8)
fail
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation fails to complete
(its Promise object is rejected). (version added: 1.8)
always
Type: Function( Promise animation, Boolean jumpedToEnd
)

A function to be called when the animation completes or
stops without completing (its Promise object is either
resolved or rejected). (version added: 1.8)
The .fadeToggle() method animates the opacity of the matched
elements. When called on a visible element, the element's display
style property is set to none once the opacity reaches 0, so the
element no longer affects the layout of the page.
Durations are given in milliseconds; higher values indicate slower
animations, not faster ones. The strings 'fast' and 'slow' can be
supplied to indicate durations of 200 and 600 milliseconds,
respectively.
Easing
The string representing an easing function specifies the speed at
which the animation progresses at different points within the
animation. The only easing implementations in the jQuery library are
the default, called swing , and one that progresses at a constant
pace, called linear . More easing functions are available with the
use of plug-ins, most notably the jQuery UI suite.
Callback Function
If supplied, the callback is fired once the animation is complete. This
can be useful for stringing different animations together in sequence.
The callback is not sent any arguments, but this is set to the DOM
element being animated. If multiple elements are animated, it is
important to note that the callback is executed once per matched
element, not once for the animation as a whole.
As of jQuery 1.6, the .promise() method can be used in conjunction
with the deferred.done() method to execute a single callback for the
animation as a whole when all matching elements have completed
their animations ( See the example for .promise() ).

Additional Notes:
All jQuery effects, including .fadeToggle() , can be turned off
globally by setting jQuery.fx.off = true , which effectively sets

the duration to 0. For more information, see jQuery.fx.off.

Example:
Fades first paragraph in or out, completing the
animation within 600 milliseconds and using a linear
easing. Fades last paragraph in or out for 200
milliseconds, inserting a "finished" message upon
completion.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>fadeToggle p1</button>
<button>fadeToggle p2</button>
<p>This paragraph has a slow, linear fade.</p>
<p>This paragraph has a fast animation.</p>
<div id="log"></div>
<script>
$("button:first").click(function() {
$("p:first").fadeToggle("slow", "linear");
});
$("button:last").click(function () {
$("p:last").fadeToggle("fast", function () {
$("#log").append("<div>finished</div>");
});
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

:file Selector
Categories: Selectors > Form | Selectors > jQuery Extensions

file selector
Description: Selects all elements of type file.
jQuery( ":file" )

version added: 1.0

is equivalent to [type="file"] . As with other pseudo-class
selectors (those that begin with a ":") it is recommended to precede
it with a tag name or some other selector; otherwise, the universal
selector ("*") is implied. In other words, the bare $(':file') is
equivalent to $('*:file') , so $('input:file') should be used
instead.
:file

Additional Notes:
Because :file is a jQuery extension and not part of the CSS
specification, queries using :file cannot take advantage of the
performance boost provided by the native DOM
querySelectorAll() method. For better performance in modern
browsers, use [type="file"] instead.

Example:
Finds all file inputs.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
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23
24
25
26
27
28
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<!DOCTYPE html>
<html>
<head>
<style>
textarea { height:45px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<input type="button" value="Input Button"/>
<input type="checkbox" />
<input type="file" />
<input type="hidden" />
<input type="image" />
<input type="password" />
<input type="radio" />
<input type="reset" />
<input type="submit" />
<input type="text" />
<select><option>Option<option/></select>
<textarea></textarea>
<button>Button</button>
</form>
<div>
</div>
<script>
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var input = $("input:file").css({background:
$("div").text("For this type jQuery found "
.css("color", "red");
$("form").submit(function () { return false
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.filter()
Categories: Traversing > Filtering

.filter( selector )

Returns: jQuery

Description: Reduce the set of matched elements to
those that match the selector or pass the function's test.
.filter( selector )

version added: 1.0

selector
Type: Selector
A string containing a selector expression to match the current
set of elements against.

.filter( function(index) )

version added: 1.0

function(index)
Type: Function()
A function used as a test for each element in the set.
current DOM element.

.filter( element )

this

is the

version added: 1.4

element
Type: Element
An element to match the current set of elements against.

.filter( jQuery object )

version added: 1.4

jQuery object
Type: Object
An existing jQuery object to match the current set of elements
against.
Given a jQuery object that represents a set of DOM elements, the
.filter() method constructs a new jQuery object from a subset of
the matching elements. The supplied selector is tested against each
element; all elements matching the selector will be included in the
result.
Consider a page with a simple list on it:

1
2
3
4
5
6
7
8

<ul>
<li>list
<li>list
<li>list
<li>list
<li>list
<li>list
</ul>

item
item
item
item
item
item

1</li>
2</li>
3</li>
4</li>
5</li>
6</li>

We can apply this method to the set of list items:
1

$('li').filter(':even').css('background-color'

The result of this call is a red background for items 1, 3, and 5, as
they match the selector (recall that :even and :odd use 0-based
indexing).
Using a Filter Function
The second form of this method allows us to filter elements against a
function rather than a selector. For each element, if the function
returns true (or a "truthy" value), the element will be included in the
filtered set; otherwise, it will be excluded. Suppose we have a
somewhat more involved HTML snippet:
1
2
3
4
5
6
7
8
9
10

<ul>
<li><strong>list</strong> item 1 one strong tag</li>
<li><strong>list</strong> item <strong>2</strong
two <span>strong tags</span></li>
<li>list item 3</li>
<li>list item 4</li>
<li>list item 5</li>
<li>list item 6</li>
</ul>

We can select the list items, then filter them based on their contents:
1
2
3

$('li').filter(function(index) {
return $('strong', this).length == 1;
}).css('background-color', 'red');

This code will alter the first list item only, as it contains exactly one
<strong> tag. Within the filter function, this refers to each DOM
element in turn. The parameter passed to the function tells us the
index of that DOM element within the set matched by the jQuery
object.
We can also take advantage of the index passed through the
function, which indicates the 0-based position of the element within
the unfiltered set of matched elements:
1
2
3

$('li').filter(function(index) {
return index % 3 == 2;
}).css('background-color', 'red');

This alteration to the code will cause the third and sixth list items to
be highlighted, as it uses the modulus operator ( % ) to select every
item with an index value that, when divided by 3, has a remainder of
2.

Examples:
Change the color of all divs; then add a
border to those with a "middle" class.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<!DOCTYPE html>
<html>
<head>
<style>
div { width:60px; height:60px; margin:5px; float
border:2px white solid;}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div>
<div
<div
<div
<div

class="middle"></div>
class="middle"></div>
class="middle"></div>
class="middle"></div>

<div></div>
<script>
$("div").css("background", "#c8ebcc")
.filter(".middle")
.css("border-color", "red");
</script>
</body>
</html>

Demo
Example:

Change the color of all divs; then add a
border to the second one (index == 1) and the div with
an id of "fourth."
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
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20
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27
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<!DOCTYPE html>
<html>
<head>
<style>
div { width:60px; height:60px; margin:5px; float
border:3px white solid; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="first"></div>
<div id="second"></div>
<div id="third"></div>
<div id="fourth"></div>
<div id="fifth"></div>
<div id="sixth"></div>
<script>
$("div").css("background", "#b4b0da")
.filter(function (index) {
return index == 1 || $(this).attr(
})
.css("border", "3px double red");
</script>
</body>
</html>

Demo
Example:

Select all divs and filter the selection with a
DOM element, keeping only the one with an id of
"unique".
1

$("div").filter( document.getElementById("unique"

Select all divs and filter the selection with a
jQuery object, keeping only the one with an id of
"unique".
Example:

1

$("div").filter( $("#unique") )

POWERED BYHERONOTE
A new version of this book is available!

.find()
Categories: Traversing > Tree Traversal

.find( selector )

Returns: jQuery

Description: Get the descendants of each element in
the current set of matched elements, filtered by a
selector, jQuery object, or element.
.find( selector )

version added: 1.0

selector
Type: Selector
A string containing a selector expression to match elements
against.

.find( jQuery object )

version added: 1.6

jQuery object
Type: Object
A jQuery object to match elements against.

.find( element )

version added: 1.6

element
Type: Element
An element to match elements against.
Given a jQuery object that represents a set of DOM elements, the
.find() method allows us to search through the descendants of
these elements in the DOM tree and construct a new jQuery object
from the matching elements. The .find() and .children() methods
are similar, except that the latter only travels a single level down the
DOM tree.
The first signature for the .find() method accepts a selector
expression of the same type that we can pass to the $() function.
The elements will be filtered by testing whether they match this
selector.
Consider a page with a basic nested list on it:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<ul class="level-1">
<li class="item-i">I</li>
<li class="item-ii">II
<ul class="level-2">
<li class="item-a">A</li>
<li class="item-b">B
<ul class="level-3">
<li class="item-1">1</li>
<li class="item-2">2</li>
<li class="item-3">3</li>
</ul>
</li>
<li class="item-c">C</li>
</ul>
</li>
<li class="item-iii">III</li>
</ul>

If we begin at item II, we can find list items within it:
1

$('li.item-ii').find('li').css('background-color'

The result of this call is a red background on items A, B, 1, 2, 3, and
C. Even though item II matches the selector expression, it is not
included in the results; only descendants are considered candidates
for the match.

Unlike in the rest of the tree traversal
methods, the selector expression is
required in a call to .find() . If we need to
retrieve all of the descendant elements, we
can pass in the universal selector '*' to

accomplish this.
Selector context is implemented with the .find() method; therefore,
$('li.item-ii').find('li') is equivalent to $('li', 'li.item-ii') .
As of jQuery 1.6, we can also filter the selection with a given jQuery
collection or element. With the same nested list as above, if we start
with:
1

var $allListElements = $('li');

And then pass this jQuery object to find:
1

$('li.item-ii').find( $allListElements );

This will return a jQuery collection which contains only the list
elements that are descendants of item II.
Similarly, an element may also be passed to find:
1
2

var item1 = $('li.item-1')[0];
$('li.item-ii').find( item1 ).css('background-color'

The result of this call would be a red background on item 1.

Examples:
Starts with all paragraphs and searches for
descendant span elements, same as $("p span")
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><span>Hello</span>, how are you?</p>
<p>Me? I'm <span>good</span>.</p>
<script>
$("p").find("span").css('color','red');
</script>
</body>
</html>

Demo
Example:

A selection using a jQuery collection of all
span tags. Only spans within p tags are changed to red
while others are left blue.
1
2
3
4
5
6
7
8

<!DOCTYPE html>
<html>
<head>
<style>
span { color: blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>

9
10
11
12
13
14
15
16
17
18
19

<body>
<p><span>Hello</span>, how are you?</p>
<p>Me? I'm <span>good</span>.</p>
<div>Did you <span>eat</span> yet?</div>
<script>
var $spans = $('span');
$("p").find( $spans ).css('color','red');
</script>
</body>
</html>

Demo
Example:

Add spans around each word then add a
hover and italicize words with the letter t.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

<!DOCTYPE html>
<html>
<head>
<style>
p { font-size:20px; width:200px; cursor:default;
color:blue; font-weight:bold; margin:0 10
.hilite { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
When the day is short
find that which matters to you
or stop believing
</p>
<script>
var newText = $("p").text().split(" ").join("</span> <
newText = "<span>" + newText + "</span>";

20
21
22
23
24
25
26
27
28
29
30
31
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33
34
35

$("p").html( newText )
.find('span')
.hover(function() {
$(this).addClass("hilite");
},
function() { $(this).removeClass("hilite"
})
.end()
.find(":contains('t')")
.css({"font-style":"italic", "font-weight":
</script>
</body>
</html>

Demo
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.finish()
Categories: Effects > Custom

.finish( [queue ] )

Returns: jQuery

Description: Stop the currently-running animation,
remove all queued animations, and complete all
animations for the matched elements.
.finish( [queue ] )

version added: 1.9

queue
Type: String
The name of the queue in which to stop animations.
When .finish() is called on an element, the currently-running
animation and all queued animations (if any) immediately stop and
their CSS properties set to their target values. All queued animations
are removed.
If the first argument is provided, only the animations in the queue
represented by that string will be stopped.
The .finish() method is similar to .stop(true, true) in that it clears
the queue and the current animation jumps to its end value. It differs,
however, in that .finish() also causes the CSS property of all
queued animations to jump to their end values, as well.

Animations may be stopped globally by
setting the property $.fx.off to true . When this
is done, all animation methods will
immediately set elements to their final state
when called, rather than displaying an
effect.

Example:
Click the Go button once to start the animation, and
then click the other buttons to see how they affect the
current and queued animations.
1
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13
14
15
16
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20
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22
23
24
25
26
27
28
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<!DOCTYPE html>
<html>
<head>
<style>.box {
position: absolute;
top: 10px;
left: 10px;
width: 15px;
height: 15px;
background: black;
}
#path {
height: 244px;
font-size: 70%;
border-left: 2px dashed red;
border-bottom: 2px dashed green;
border-right: 2px dashed blue;
}
button {
width: 12em;
display: block;
text-align: left;
margin: 0 auto;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div class="box"></div>

30
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36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66

<div id="path">
<button id="go">Go</button>
<br>
<button id="bstt" class="b">.stop(true,true)
<button id="bcf" class="b">.clearQueue().finish()
<br>
<button id="bstf" class="b">.stop(true, false)
<button id="bcs" class="b">.clearQueue().stop()
<br>
<button id="bsff" class="b">.stop(false, false)
<button id="bs" class="b">.stop()</button>
<br>
<button id="bsft" class="b">.stop(false, true)
<br>
<button id="bf" class="b">.finish()</button>
</div>
<script>
var horiz = $("#path").width() - 20,
vert = $("#path").height() - 20;
var btns = {
bstt: function () {
$("div.box").stop(true, true);
},
bs: function () {
$("div.box").stop();
},
bsft: function () {
$("div.box").stop(false, true);
},
bf: function () {
$("div.box").finish();
},
bcf: function () {
$("div.box").clearQueue().finish();
},
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bsff: function () {
$("div.box").stop(false, false);
},
bstf: function () {
$("div.box").stop(true, false);
},
bcs: function () {
$("div.box").clearQueue().stop();
}
};

$("button.b").on("click", function () {
btns[this.id]();
});
$("#go").on("click", function () {
$(".box")
.clearQueue()
.stop()
.css({
left: 10,
top: 10
})
.animate({
top: vert
}, 3000)
.animate({
left: horiz
}, 3000)
.animate({
top: 10
}, 3000);
});
</script>
</body>
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</html>

Demo
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.first()
Categories: Traversing > Filtering

.first()

Returns: jQuery

Description: Reduce the set of matched elements to
the first in the set.
.first()

version added: 1.4

This method does not accept any arguments.
Given a jQuery object that represents a set of DOM elements, the
.first() method constructs a new jQuery object from the first
element in that set.
Consider a page with a simple list on it:
1
2
3
4
5
6
7

<ul>
<li>list
<li>list
<li>list
<li>list
<li>list
</ul>

item
item
item
item
item

1</li>
2</li>
3</li>
4</li>
5</li>

We can apply this method to the set of list items:
1

$('li').first().css('background-color', 'red');

The result of this call is a red background for the first item.

Example:
Highlight the first span in a paragraph.
1
2
3
4
5
6
7
8
9
10
11
12

<!DOCTYPE html>
<html>
<head>
<style>.highlight{background-color: yellow}</
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><span>Look:</span> <span>This is some text in a par
<script>$("p span").first().addClass('highlight'
</body>
</html>

Demo
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:first-child Selector
Categories: Selectors > Child Filter

first-child selector
Description: Selects all elements that are the first child
of their parent.
jQuery( ":first-child" )

version added: 1.1.4

While :first matches only a single element, the :first-child selector
can match more than one: one for each parent. This is equivalent to
:nth-child(1) .

Example:
Finds the first span in each matched div to underline
and add a hover state.
1
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<!DOCTYPE html>
<html>
<head>
<style>
span { color:#008; }
span.sogreen { color:green; font-weight: bolder;
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<span>John,</span>
<span>Karl,</span>
<span>Brandon</span>
</div>
<div>
<span>Glen,</span>
<span>Tane,</span>
<span>Ralph</span>
</div>
<script>
$("div span:first-child")
.css("text-decoration", "underline")
.hover(function () {
$(this).addClass("sogreen");
}, function () {
$(this).removeClass("sogreen");
});

31
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34

</script>
</body>
</html>

Demo
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:first-of-type Selector
Categories: Selectors > Child Filter

first-of-type selector
Description: Selects all elements that are the first
among siblings of the same element name.
jQuery( ":first-of-type" )

version added: 1.9

The :first-of-type selector matches elements that have no other
element with both the same parent and the same element name
coming before it in the document tree.

Example:
Find the first span in each matched div and add a
class to it.
1
2
3
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<!DOCTYPE html>
<html>
<head>
<style>
span.fot { color: red; font-size: 120%; font-style
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<span>Corey,</span>
<span>Yehuda,</span>
<span>Adam,</span>
<span>Todd</span>
</div>
<div>
<b>Nobody,</b>
<span>Jörn,</span>
<span>Scott,</span>
<span>Timo</span>
</div>
<script>
$("span:first-of-type").addClass("fot");
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
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:first Selector
Categories: Selectors > Basic Filter | Selectors > jQuery Extensions

first selector
Description: Selects the first matched element.
jQuery( ":first" )

version added: 1.0

The :first pseudo-class is equivalent to :eq(0) . It could also be
written as :lt(1) . While this matches only a single element, :firstchild can match more than one: One for each parent.

Additional Notes:
Because :first is a jQuery extension and not part of the CSS
specification, queries using :first cannot take advantage of
the performance boost provided by the native DOM
querySelectorAll() method. To achieve the best performance
when using :first to select elements, first select the elements
using a pure CSS selector, then use .filter(":first") .
Selected elements are in the order of their appearance in the
document.

Example:
Finds the first table row.
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<!DOCTYPE html>
<html>
<head>
<style>
td { color:blue; font-weight:bold; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<table>
<tr><td>Row 1</td></tr>
<tr><td>Row 2</td></tr>
<tr><td>Row 3</td></tr>
</table>
<script>$("tr:first").css("font-style", "italic"
</body>
</html>

Demo
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.focus()
Categories: Events > Form Events | Forms

.focus( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "focus"
JavaScript event, or trigger that event on an element.
.focus( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.focus( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: Object
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.focus()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('focus', handler) in the first
and second variations, and .trigger('focus') in the third.
The focus event is sent to an element when it gains focus. This
event is implicitly applicable to a limited set of elements, such
as form elements ( <input> , <select> , etc.) and links ( <a href> ).
In recent browser versions, the event can be extended to
include all element types by explicitly setting the element's
tabindex property. An element can gain focus via keyboard
commands, such as the Tab key, or by mouse clicks on the
element.
Elements with focus are usually highlighted in some way by the
browser, for example with a dotted line surrounding the element.

The focus is used to determine which element is the first to
receive keyboard-related events.

Attempting to set focus to a hidden element
causes an error in Internet Explorer. Take
care to only use .focus() on elements that are
visible. To run an element's focus event
handlers without setting focus to the
element, use .triggerHandler("focus") instead of
.focus() .
For example, consider the HTML:
1
2
3
4
5
6
7

<form>
<input id="target" type="text" value="Field 1"
<input type="text" value="Field 2" />
</form>
<div id="other">
Trigger the handler
</div>

The event handler can be bound to the first input field:
1
2
3

$('#target').focus(function() {
alert('Handler for .focus() called.');
});

Now clicking on the first field, or tabbing to it from another field,
displays the alert:
Handler for .focus() called.

We can trigger the event when another element is clicked:
1
2
3

$('#other').click(function() {
$('#target').focus();
});

After this code executes, clicks on Trigger the handler will also alert
the message.
The focus event does not bubble in Internet Explorer. Therefore,
scripts that rely on event delegation with the focus event will not
work consistently across browsers. As of version 1.4.2, however,
jQuery works around this limitation by mapping focus to the focusin
event in its event delegation methods, .live() and .delegate() .

Examples:
Example:
1
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Fire focus.

<!DOCTYPE html>
<html>
<head>
<style>span {display:none;}</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><input type="text" /> <span>focus fire</span
<p><input type="password" /> <span>focus fire</
<script>
$("input").focus(function () {
$(this).next("span").css('display','inline').fadeOut(
});
</script>
</body>
</html>

Demo
Example:

To stop people from writing in text input
boxes, try:
1
2
3

$("input[type=text]").focus(function(){
$(this).blur();
});

To focus on a login input box with id 'login'
on page startup, try:
Example:

1
2
3

$(document).ready(function(){
$("#login").focus();
});

POWERED BYHERONOTE
A new version of this book is available!

:focus Selector
Categories: Selectors > Basic Filter | Selectors > Form

focus selector
Description: Selects element if it is currently focused.
jQuery( ":focus" )

version added: 1.6

As with other pseudo-class selectors (those that begin with a ":"), it
is recommended to precede :focus with a tag name or some other
selector; otherwise, the universal selector ("*") is implied. In other
words, the bare $(':focus') is equivalent to $('*:focus') . If you are
looking for the currently focused element, $( document.activeElement
) will retrieve it without having to search the whole DOM tree.

Example:
Adds the focused class to whatever element has
focus
1
2
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<!DOCTYPE html>
<html>
<head>
<style>
.focused {
background: #abcdef;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="content">
<input tabIndex="1">
<input tabIndex="2">
<select tabIndex="3">
<option>select menu</option>
</select>
<div tabIndex="4">
a div
</div>
</div>
<script>
$( "#content" ).delegate( "*", "focus blur", function
var elem = $( this );
setTimeout(function() {
elem.toggleClass( "focused", elem.is( ":focus"
}, 0);
});
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</script>
</body>
</html>

Demo
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.focusin()
Categories: Events > Keyboard Events | Events > Mouse Events

.focusin( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "focusin"
event.
.focusin( handler(eventObject) )

version added: 1.4

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.focusin( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: Object
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.
This method is a shortcut for

.on('focusin', handler) .

The focusin event is sent to an element when it, or any element
inside of it, gains focus. This is distinct from the focus event in that it
supports detecting the focus event on parent elements (in other
words, it supports event bubbling).
This event will likely be used together with the focusout event.

Example:
Watch for a focus to occur within the paragraphs on
the page.
1
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<!DOCTYPE html>
<html>
<head>
<style>span {display:none;}</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><input type="text" /> <span>focusin fire</
<p><input type="password" /> <span>focusin fire
<script>
$("p").focusin(function() {
$(this).find("span").css('display','inline').fadeOut(
});
</script>
</body>
</html>

Demo
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.focusout()
Categories: Events > Keyboard Events | Events > Mouse Events

.focusout( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "focusout"
JavaScript event.
.focusout( handler(eventObject) )

version added: 1.4

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.focusout( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: Object
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.
This method is a shortcut for

.on('focusout', handler) .

The focusout event is sent to an element when it, or any element
inside of it, loses focus. This is distinct from the blur event in that it
supports detecting the loss of focus on descendant elements (in
other words, it supports event bubbling).
This event will likely be used together with the focusin event.

Example:
Watch for a loss of focus to occur inside paragraphs
and note the difference between the focusout count and
the blur count.
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<!DOCTYPE
<html>
<head>
<style>
.inputs {
.inputs p
</style>
<script
</head>
<body>

html>

float: left; margin-right: 1em; }
{ margin-top: 0; }
src="http://code.jquery.com/jquery-latest.js"

<div class="inputs">
<p>
<input type="text" /><br />
<input type="text" />
</p>
<p>
<input type="password" />
</p>
</div>
<div id="fo">focusout fire</div>
<div id="b">blur fire</div>
<script>
var fo = 0, b = 0;
$("p").focusout(function() {
fo++;
$("#fo")
.text("focusout fired: " + fo + "x");
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}).blur(function() {
b++;
$("#b")
.text("blur fired: " + b + "x");
});
</script>
</body>
</html>

Demo
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.get()
Categories: Miscellaneous > DOM Element Methods

.get( [index ] )

Returns: Element, Array

Description: Retrieve the DOM elements matched by
the jQuery object.
.get( [index ] )

version added: 1.0

index
Type: Number
A zero-based integer indicating which element to retrieve.
The .get() method grants us access to the DOM nodes underlying
each jQuery object. Suppose we had a simple unordered list on the
page:
1
2
3
4

<ul>
<li id="foo">foo</li>
<li id="bar">bar</li>
</ul>

Without a parameter,
1

.get()

returns all of the elements:

alert($('li').get());

All of the matched DOM nodes are returned by this call, contained in
a standard array:
[<li id="foo">, <li id="bar">]
With an index specified, .get() will retrieve a single element:
1

($('li').get(0));

Since the index is zero-based, the first list item is returned:
<li id="foo">
Each jQuery object also masquerades as an array, so we can use
the array dereferencing operator to get at the list item instead:
1

alert($('li')[0]);

However, this syntax lacks some of the additional capabilities of
.get(), such as specifying a negative index:
1

alert($('li').get(-1));

A negative index is counted from the end of the matched set, so this
example will return the last item in the list:
<li id="bar">

Examples:
Selects all divs in the document and returns
the DOM Elements as an Array, then uses the built-in
reverse-method to reverse that array.
Example:

1
2
3
4
5
6
7
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11
12
13
14
15
16
17
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19
20
21
22
23
24
25
26
27

<!DOCTYPE html>
<html>
<head>
<style>
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
Reversed - <span></span>
<div>One</div>
<div>Two</div>
<div>Three</div>
<script>
function disp(divs) {
var a = [];
for (var i = 0; i < divs.length; i++) {
a.push(divs[i].innerHTML);
}
$("span").text(a.join(" "));
}
disp( $("div").get().reverse() );
</script>
</body>
</html>

Demo
Example:
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Gives the tag name of the element clicked on.

<!DOCTYPE html>
<html>
<head>
<style>
span { color:red; }
div { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<span>&nbsp;</span>
<p>In this paragraph is an <span>important</span

<div><input type="text" /></div>
<script>
$("*", document.body).click(function (e) {
e.stopPropagation();
var domEl = $(this).get(0);
$("span:first").text("Clicked on - " + domEl.tagName);
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

:gt() Selector
Categories: Selectors > Basic Filter | Selectors > jQuery Extensions

gt selector
Description: Select all elements at an index greater
than index within the matched set.
jQuery( ":gt(index)" )

version added: 1.0

index: Zero-based index.
index-related selectors
The index-related selector expressions (including this "greater than"
selector) filter the set of elements that have matched the
expressions that precede them. They narrow the set down based on
the order of the elements within this matched set. For example, if
elements are first selected with a class selector ( .myclass ) and four
elements are returned, these elements are given indices 0 through 3
for the purposes of these selectors.
Note that since JavaScript arrays use 0-based indexing, these
selectors reflect that fact. This is why $('.myclass:gt(1)') selects
elements after the second element in the document with the class
myclass , rather than after the first. In contrast, :nth-child(n) uses 1based indexing to conform to the CSS specification.

Additional Notes:
Because :gt() is a jQuery extension and not part of the CSS
specification, queries using :gt() cannot take advantage of the
performance boost provided by the native DOM
querySelectorAll() method. For better performance in modern
browsers, use $("your-pure-css-selector").slice(index)
instead.

Example:
Finds TD #5 and higher. Reminder: the indexing starts
at 0.
1
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<table border="1">
<tr><td>TD #0</td><td>TD #1</td><td>TD #2</
<tr><td>TD #3</td><td>TD #4</td><td>TD #5</

<tr><td>TD #6</td><td>TD #7</td><td>TD #8</
</table>
<script>$("td:gt(4)").css("text-decoration", "line-throu
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.has()
Categories: Traversing > Filtering

.has( selector )

Returns: jQuery

Description: Reduce the set of matched elements to
those that have a descendant that matches the selector
or DOM element.
.has( selector )

version added: 1.4

selector
Type: String
A string containing a selector expression to match elements
against.

.has( contained )

version added: 1.4

contained
Type: Element
A DOM element to match elements against.
Given a jQuery object that represents a set of DOM elements, the
.has() method constructs a new jQuery object from a subset of the
matching elements. The supplied selector is tested against the
descendants of the matching elements; the element will be included
in the result if any of its descendant elements matches the selector.
Consider a page with a nested list as follows:
1
2
3
4
5
6
7
8
9
10

<ul>
<li>list item 1</li>
<li>list item 2
<ul>
<li>list item 2-a</li>
<li>list item 2-b</li>
</ul>
</li>
<li>list item 3</li>
<li>list item 4</li>

11

</ul>

We can apply this method to the set of list items as follows:
1

$('li').has('ul').css('background-color', 'red');

The result of this call is a red background for item 2, as it is the only
<li> that has a <ul> among its descendants.

Example:
Check if an element is inside another.
1
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7
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13
14
15
16
17
18
19

<!DOCTYPE html>
<html>
<head>
<style>
.full { border: 1px solid red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul><li>Does the UL contain an LI?</li></ul>
<script>
$("ul").append("<li>" + ($("ul").has("li").length ?
$("ul").has("li").addClass("full");
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

Has Attribute Selector [name]
Categories: Selectors > Attribute

attributeHas selector
Description: Selects elements that have the specified
attribute, with any value.
jQuery( "[attribute]" )
attribute: An attribute name.

version added: 1.0

Example:
Bind a single click that adds the div id to its text.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>no id</div>
<div id="hey">with id</div>
<div id="there">has an id</div>
<div>nope</div>
<script>
$('div[id]').one('click', function(){
var idString = $(this).text() + ' = ' + $(this
$(this).text(idString);
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

:has() Selector
Categories: Selectors > Content Filter | Selectors > jQuery Extensions

has selector
Description: Selects elements which contain at least
one element that matches the specified selector.
jQuery( ":has(selector)" )

version added: 1.1.4

selector: Any selector.
The expression $('div:has(p)') matches a <div> if a <p> exists
anywhere among its descendants, not just as a direct child.

Additional Notes:
Because :has() is a jQuery extension and not part of the CSS
specification, queries using :has() cannot take advantage of
the performance boost provided by the native DOM
querySelectorAll() method. For better performance in modern
browsers, use $("your-pure-cssselector").has(selector/DOMElement) instead.

Example:
Adds the class "test" to all divs that have a paragraph
inside of them.
1
2
3
4
5
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9
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14
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<!DOCTYPE html>
<html>
<head>
<style>
.test{ border: 3px inset red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div><p>Hello in a paragraph</p></div>
<div>Hello again! (with no paragraph)</div>
<script>$("div:has(p)").addClass("test");</script
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.hasClass()
Categories: Attributes | Manipulation > Class Attribute | CSS

.hasClass( className )

Returns: Boolean

Description: Determine whether any of the matched
elements are assigned the given class.
.hasClass( className )

version added: 1.2

className
Type: String
The class name to search for.
Elements may have more than one class assigned to them. In
HTML, this is represented by separating the class names with a
space:
1

<div id="mydiv" class="foo bar"></div>

The .hasClass() method will return true if the class is assigned to
an element, even if other classes also are. For example, given the
HTML above, the following will return true :
1

$('#mydiv').hasClass('foo')

As would:
1

$('#mydiv').hasClass('bar')

While this would return
1

false :

$('#mydiv').hasClass('quux')

Example:
Looks for the paragraph that contains 'selected' as a
class.
1
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Demo

<!DOCTYPE html>
<html>
<head>
<style>
p { margin: 8px; font-size:16px; }
.selected { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

<p>This paragraph is black and is the first paragraph.
<p class="selected">This paragraph is red and is the s

<div id="result1">First paragraph has selected class:
<div id="result2">Second paragraph has selected class:
<div id="result3">At least one paragraph has selected
<script>
$("div#result1").append($("p:first").hasClass("selected"
$("div#result2").append($("p:last").hasClass("selected"
$("div#result3").append($("p").hasClass("selected"
</script>
</body>
</html>

POWERED BYHERONOTE
A new version of this book is available!

:header Selector
Categories: Selectors > Basic Filter | Selectors > jQuery Extensions

header selector
Description: Selects all elements that are headers, like
h1, h2, h3 and so on.
jQuery( ":header" )

version added: 1.2

Additional Notes:
Because :header is a jQuery extension and not part of the CSS
specification, queries using :header cannot take advantage of
the performance boost provided by the native DOM
querySelectorAll() method. To achieve the best performance
when using :header to select elements, first select the elements
using a pure CSS selector, then use .filter(":header") .

Example:
Adds a background and text color to all the headers
on the page.
1
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<!DOCTYPE html>
<html>
<head>
<style>
body { font-size: 10px; font-family: Arial; }
h1, h2 { margin: 3px 0; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<h1>Header 1</h1>
<p>Contents 1</p>
<h2>Header 2</h2>
<p>Contents 2</p>
<script>$(":header").css({ background:'#CCC', color:
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

.height()
Categories: CSS | Dimensions | Manipulation > Style Properties

Get the current computed height for the first element in the set of
matched elements or set the height of every matched element.
Contents:
.height()
.height()
.height( value )
.height( value )
.height( function(index, height) )

.height()

Returns: Integer

Description: Get the current computed height for the
first element in the set of matched elements.
.height()

version added: 1.0

This method does not accept any arguments.
The difference between .css('height') and .height() is that the
latter returns a unit-less pixel value (for example, 400 ) while the
former returns a value with units intact (for example, 400px ). The
.height() method is recommended when an element's height needs
to be used in a mathematical calculation.

This method is also able to find the height of the window and
document.
1
2

$(window).height();
// returns height of browser viewp
$(document).height(); // returns height of HTML document

Note that .height() will always return the content height, regardless
of the value of the CSS box-sizing property.

Note: Although style and script tags will
report a value for .width() or height() when

absolutely positioned and given display:block ,
it is strongly discouraged to call those
methods on these tags. In addition to being
a bad practice, the results may also prove
unreliable.

Example:
Show various heights. Note the values are from the
iframe so might be smaller than you expected. The
yellow highlight shows the iframe body.
1
2
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15
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26
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28
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<!DOCTYPE html>
<html>
<head>
<style>
body { background:yellow; }
button { font-size:12px; margin:2px; }
p { width:150px; border:1px red solid; }
div { color:red; font-weight:bold; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="getp">Get Paragraph Height</button
<button id="getd">Get Document Height</button
<button id="getw">Get Window Height</button>
<div>&nbsp;</div>
<p>
Sample paragraph to test height
</p>
<script>
function showHeight(ele, h) {
$("div").text("The height for the " + ele +
" is " + h + "px.");
}
$("#getp").click(function () {
showHeight("paragraph", $("p").height());
});
$("#getd").click(function () {

30
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showHeight("document", $(document).height());
});
$("#getw").click(function () {
showHeight("window", $(window).height());
});
</script>
</body>
</html>

.height( value )

Returns: jQuery

Description: Set the CSS height of every matched
element.
.height( value )

version added: 1.0

value
Type: String or Number
An integer representing the number of pixels, or an integer with
an optional unit of measure appended (as a string).

.height( function(index, height) )

version added: 1.4.1

function(index, height)
Type: Function()
A function returning the height to set. Receives the index
position of the element in the set and the old height as
arguments. Within the function, this refers to the current
element in the set.
When calling .height(value) , the value can be either a string
(number and unit) or a number. If only a number is provided for the
value, jQuery assumes a pixel unit. If a string is provided, however, a
valid CSS measurement must be provided for the height (such as
100px , 50% , or auto ). Note that in modern browsers, the CSS height
property does not include padding, border, or margin.
If no explicit unit was specified (like 'em' or '%') then "px" is
concatenated to the value.
Note that .height(value) sets the content height of the box
regardless of the value of the CSS box-sizing property.

Example:
To set the height of each div on click to 30px plus a
color change.
1
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20
21

<!DOCTYPE html>
<html>
<head>
<style>div { width:50px; height:70px; float:left;
background:rgb(255,140,0); cursor:pointer;
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<script>$("div").one('click', function () {
$(this).height(30)
.css({cursor:"auto", backgroundColor:
});</script>
</body>
</html>

Demo

POWERED BYHERONOTE
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:hidden Selector
Categories: Selectors > jQuery Extensions | Selectors > Visibility Filter

hidden selector
Description: Selects all elements that are hidden.
jQuery( ":hidden" )

version added: 1.0

Elements can be considered hidden for several reasons:
They have a CSS

display

value of

They are form elements with

none .

type="hidden" .

Their width and height are explicitly set to 0.
An ancestor element is hidden, so the element is not shown on
the page.
Elements with visibility: hidden or opacity: 0 are considered to
be visible, since they still consume space in the layout. During
animations that hide an element, the element is considered to be
visible until the end of the animation. During animations to show an
element, the element is considered to be visible at the start of the
animation.
How :hidden is determined was changed in jQuery 1.3.2. An
element is assumed to be hidden if it or any of its parents consumes
no space in the document. CSS visibility isn't taken into account
(therefore $(elem).css('visibility','hidden').is(':hidden') ==
false ). The release notes outline the changes in more detail.

Additional Notes:
Because :hidden is a jQuery extension and not part of the CSS
specification, queries using :hidden cannot take advantage of
the performance boost provided by the native DOM
querySelectorAll() method. To achieve the best performance
when using :hidden to select elements, first select the elements
using a pure CSS selector, then use .filter(":hidden") .

Example:
Shows all hidden divs and counts hidden inputs.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

<!DOCTYPE html>
<html>
<head>
<style>
div { width:70px; height:40px; background:#ee77ff
span { display:block; clear:left; color:red;
.starthidden { display:none; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<span></span>
<div></div>
<div style="display:none;">Hider!</div>
<div></div>
<div class="starthidden">Hider!</div>
<div></div>
<form>
<input type="hidden" />
<input type="hidden" />
<input type="hidden" />
</form>
<span>

</span>
<script>
// in some browsers :hidden includes head, title, script
var hiddenEls = $("body").find(":hidden").not("script"

32
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$("span:first").text("Found " + hiddenEls.length +
$("div:hidden").show(3000);
$("span:last").text("Found " + $("input:hidden"
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
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.hide()
Categories: Effects > Basics

.hide()

Returns: jQuery

Description: Hide the matched elements.
.hide()

version added: 1.0

This method does not accept any arguments.

.hide( [duration ] [, complete ] )

version added: 1.0

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
complete
Type: Function()
A function to call once the animation is complete.

.hide( options )

version added: 1.0

options
Type: PlainObject
A map of additional options to pass to the method.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will
run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
queue (default: true )
Type: Boolean
A Boolean indicating whether to place the animation in the
effects queue. If false, the animation will begin immediately.
As of jQuery 1.7, the queue option can also accept a
string, in which case the animation is added to the queue
represented by that string.

specialEasing
Type: PlainObject
A map of one or more of the CSS properties defined by the
properties argument and their corresponding easing
functions. (version added: 1.4)
step
Type: Function( Number now, Tween tween )
A function to be called for each animated property of each
animated element. This function provides an opportunity to
modify the Tween object to change the value of the
property before it is set.
progress
Type: Function( Promise animation, Number progress,
Number remainingMs )
A function to be called after each step of the animation,
only once per animated element regardless of the number
of animated properties. (version added: 1.8)
complete
Type: Function()
A function to call once the animation is complete.
done
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes (its
Promise object is resolved). (version added: 1.8)
fail
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation fails to complete
(its Promise object is rejected). (version added: 1.8)
always
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes or
stops without completing (its Promise object is either
resolved or rejected). (version added: 1.8)

.hide( [duration ] [, easing ] [,
complete ] )

version added: 1.4.3

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.
With no parameters, the
an element:
1

.hide()

method is the simplest way to hide

$('.target').hide();

The matched elements will be hidden immediately, with no
animation. This is roughly equivalent to calling .css('display',
'none') , except that the value of the display property is saved in
jQuery's data cache so that display can later be restored to its initial
value. If an element has a display value of inline , then is hidden
and shown, it will once again be displayed inline .
When a duration, a plain object, or a "complete" function is provided,
.hide() becomes an animation method. The .hide() method
animates the width, height, and opacity of the matched elements
simultaneously. When these properties reach 0, the display style
property is set to none to ensure that the element no longer affects
the layout of the page.
Durations are given in milliseconds; higher values indicate slower
animations, not faster ones. The strings 'fast' and 'slow' can be
supplied to indicate durations of 200 and 600 milliseconds,
respectively.

Note that .hide() is fired immediately and will override the animation
queue if no duration or a duration of 0 is specified.
As of jQuery 1.4.3, an optional string naming an easing function may
be used. Easing functions specify the speed at which the animation
progresses at different points within the animation. The only easing
implementations in the jQuery library are the default, called swing ,
and one that progresses at a constant pace, called linear . More
easing functions are available with the use of plug-ins, most notably
the jQuery UI suite.
If supplied, the callback is fired once the animation is complete. This
can be useful for stringing different animations together in sequence.
The callback is not sent any arguments, but this is set to the DOM
element being animated. If multiple elements are animated, it is
important to note that the callback is executed once per matched
element, not once for the animation as a whole.
We can animate any element, such as a simple image:
1
2
3
4
5
6
7
8
9
10

<div id="clickme">
Click here
</div>
<img id="book" src="book.png" alt="" width="100"
With the element initially shown, we can hide it slowly
$('#clickme').click(function() {
$('#book').hide('slow', function() {
alert('Animation complete.');
});
});

Additional Notes:
All jQuery effects, including .hide() , can be turned off globally
by setting jQuery.fx.off = true , which effectively sets the
duration to 0. For more information, see jQuery.fx.off.

Examples:
Example:
1
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Hides all paragraphs then the link on click.

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<a href="#">Click to hide me too</a>
<p>Here is another paragraph</p>
<script>
$("p").hide();
$("a").click(function ( event ) {
event.preventDefault();
$(this).hide();
});
</script>
</body>
</html>

Demo
Example:

Animates all shown paragraphs to hide
slowly, completing the animation within 600
milliseconds.
1
2
3
4

<!DOCTYPE html>
<html>
<head>
<style>
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p { background:#dad; font-weight:bold; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Hide 'em</button>
<p>Hiya</p>
<p>Such interesting text, eh?</p>
<script>
$("button").click(function () {
$("p").hide("slow");
});
</script>
</body>
</html>

Demo
Example:

Animates all spans (words in this case) to
hide fastly, completing each animation within 200
milliseconds. Once each animation is done, it starts the
next one.
1
2
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<!DOCTYPE html>
<html>
<head>
<style>
span { background:#def3ca; padding:3px; float
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="hidr">Hide</button>
<button id="showr">Show</button>

12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32

<div>
<span>Once</span> <span>upon</span> <span>a</
<span>time</span> <span>there</span> <span>were
<span>three</span> <span>programmers...</span
</div>
<script>
$("#hidr").click(function () {
$("span:last-child").hide("fast", function ()
// use callee so don't have to name the function
$(this).prev().hide("fast", arguments.callee);
});
});
$("#showr").click(function () {
$("span").show(2000);
});
</script>
</body>
</html>

Demo
Example:

Hides the divs when clicked over 2 seconds,
then removes the div element when its hidden. Try
clicking on more than one box at a time.
1
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3
4
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<!DOCTYPE html>
<html>
<head>
<style>
div { background:#ece023; width:30px;
height:40px; margin:2px; float:left; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
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</head>
<body>
<div></div>
<script>
for (var i = 0; i < 5; i++) {
$("<div>").appendTo(document.body);
}
$("div").click(function () {
$(this).hide(2000, function () {
$(this).remove();
});
});
</script>
</body>
</html>

Demo
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A new version of this book is available!

.hover()
Categories: Events > Mouse Events

Bind one or two handlers to the matched elements, to be executed
when the mouse pointer enters and leaves the elements.
Contents:
.hover( handlerIn(eventObject), handlerOut(eventObject) )
.hover( handlerIn(eventObject), handlerOut(eventObject) )
.hover( handlerInOut(eventObject) )
.hover( handlerInOut(eventObject) )

.hover( handlerIn(eventObject), handlerOut(eventObject) )
Returns: jQuery
Description: Bind two handlers to the matched
elements, to be executed when the mouse pointer
enters and leaves the elements.
.hover( handlerIn(eventObject),
handlerOut(eventObject) )

version added: 1.0

handlerIn(eventObject)
Type: Function()
A function to execute when the mouse pointer enters the
element.
handlerOut(eventObject)
Type: Function()
A function to execute when the mouse pointer leaves the
element.
The

.hover() method binds
mouseleave events. You can

handlers for both mouseenter and
use it to simply apply behavior to an
element during the time the mouse is within the element.
Calling
1

$(selector).hover(handlerIn, handlerOut)

is shorthand for:

$(selector).mouseenter(handlerIn).mouseleave(handlerOut)

See the discussions for
details.

.mouseenter()

and

.mouseleave()

for more

Examples:
To add a special style to list items that are
being hovered over, try:
Example:

1
2
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4
5
6
7
8
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25
26
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<!DOCTYPE html>
<html>
<head>
<style>
ul { margin-left:20px; color:blue; }
li { cursor:default; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul>
<li>Milk</li>
<li>Bread</li>
<li class='fade'>Chips</li>
<li class='fade'>Socks</li>
</ul>
<script>
$("li").hover(
function () {
$(this).append($("<span> ***</span>"));
},
function () {
$(this).find("span:last").remove();
}
);
//li with fade class
$("li.fade").hover(function(){$(this).fadeOut(100

31
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</script>
</body>
</html>

Demo
Example:

To add a special style to table cells that are
being hovered over, try:
1
2
3
4
5
6
7
8

$("td").hover(
function () {
$(this).addClass("hover");
},
function () {
$(this).removeClass("hover");
}
);

Example:
1

To unbind the above example use:

$("td").off('mouseenter mouseleave');

.hover( handlerInOut(eventObject) )

Returns: jQuery

Description: Bind a single handler to the matched
elements, to be executed when the mouse pointer
enters or leaves the elements.
.hover( handlerInOut(eventObject) )

version added: 1.4

handlerInOut(eventObject)
Type: Function()
A function to execute when the mouse pointer enters or leaves
the element.
The .hover() method, when passed a single function, will execute
that handler for both mouseenter and mouseleave events. This allows
the user to use jQuery's various toggle methods within the handler or
to respond differently within the handler depending on the
event.type .
Calling
1

$(selector).hover(handlerInOut)

is shorthand for:

$(selector).on("mouseenter mouseleave", handlerInOut);

See the discussions for
details.

.mouseenter()

and

.mouseleave()

for more

Example:
Slide the next sibling LI up or down on hover, and
toggle a class.
1
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<!DOCTYPE html>
<html>
<head>
<style>
ul { margin-left:20px; color:blue; }
li { cursor:default; }
li.active { background:black;color:white; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul>
<li>Milk</li>
<li>White</li>
<li>Carrots</li>
<li>Orange</li>
<li>Broccoli</li>
<li>Green</li>
</ul>
<script>
$("li")
.filter(":odd")
.hide()
.end()
.filter(":even")
.hover(
function () {
$(this).toggleClass("active")
.next().stop(true, true).slideToggle();
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}
);
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.html()
Categories: Attributes | Manipulation > DOM Insertion, Inside

Get the HTML contents of the first element in the set of matched
elements or set the HTML contents of every matched element.
Contents:
.html()
.html()
.html( htmlString )
.html( htmlString )
.html( function(index, oldhtml) )

.html()

Returns: String

Description: Get the HTML contents of the first element
in the set of matched elements.
.html()

version added: 1.0

This method does not accept any arguments.
This method is not available on XML documents.
In an HTML document, .html() can be used to get the contents of
any element. If the selector expression matches more than one
element, only the first match will have its HTML content returned.
Consider this code:
1

$('div.demo-container').html();

In order for the following <div> 's content to be retrieved, it would
have to be the first one with class="demo-container" in the document:
1
2
3

<div class="demo-container">
<div class="demo-box">Demonstration Box</div>
</div>

The result would look like this:
1

<div class="demo-box">Demonstration Box</div>

This method uses the browser's innerHTML property. Some browsers
may not return HTML that exactly replicates the HTML source in an

original document. For example, Internet Explorer sometimes leaves
off the quotes around attribute values if they contain only
alphanumeric characters.

Example:
Click a paragraph to convert it from html to text.
1
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<!DOCTYPE html>
<html>
<head>
<style>
p { margin:8px; font-size:20px; color:blue;
cursor:pointer; }
b { text-decoration:underline; }
button { cursor:pointer; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
<b>Click</b> to change the <span id="tag">html
</p>
<p>
to a <span id="text">text</span> node.
</p>
<p>
This <button name="nada">button</button> does nothin
</p>
<script>
$("p").click(function () {
var htmlStr = $(this).html();
$(this).text(htmlStr);
});
</script>
</body>
</html>

Demo

.html( htmlString )

Returns: jQuery

Description: Set the HTML contents of each element in
the set of matched elements.
.html( htmlString )

version added: 1.0

htmlString
Type: htmlString
A string of HTML to set as the content of each matched
element.

.html( function(index, oldhtml) )

version added: 1.4

function(index, oldhtml)
Type: Function()
A function returning the HTML content to set. Receives the
index position of the element in the set and the old HTML value
as arguments. jQuery empties the element before calling the
function; use the oldhtml argument to reference the previous
content. Within the function, this refers to the current element
in the set.
The

.html()

method is not available in XML documents.

When .html() is used to set an element's content, any content that
was in that element is completely replaced by the new content.
Additionally, jQuery removes other constructs such as data and
event handlers from child elements before replacing those elements
with the new content.
Consider the following HTML:
1
2
3

<div class="demo-container">
<div class="demo-box">Demonstration Box</div>
</div>

The content of
1
2

<div class="demo-container">

can be set like this:

$('div.demo-container')
.html('<p>All new content. <em>You bet!</em></p>'

That line of code will replace everything inside
container"> :
1
2
3

<div class="demo-

<div class="demo-container">
<p>All new content. <em>You bet!</em></p>
</div>

As of jQuery 1.4, the .html() method allows the HTML content to be
set by passing in a function.
1
2
3
4

$('div.demo-container').html(function() {
var emph = '<em>' + $('p').length + ' paragraphs!</em>
return '<p>All new content for ' + emph + '</p>'
});

Given a document with six paragraphs, this example will set the
HTML of <div class="demo-container"> to <p>All new content for
<em>6 paragraphs!</em></p> .
This method uses the browser's innerHTML property. Some browsers
may not generate a DOM that exactly replicates the HTML source
provided. For example, Internet Explorer prior to version 8 will
convert all href properties on links to absolute URLs, and Internet
Explorer prior to version 9 will not correctly handle HTML5 elements
without the addition of a separate compatibility layer.
Note: In Internet Explorer up to and including version 9, setting the
text content of an HTML element may corrupt the text nodes of its
children that are being removed from the document as a result of the

operation. If you are keeping references to these DOM elements and
need them to be unchanged, use .empty().html(string) instead of
.html(string) so that the elements are removed from the document
before the new string is assigned to the element.

Examples:
Example:
1
2
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7
8
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16
17

Add some html to each div.

<!DOCTYPE html>
<html>
<head>
<style>
.red { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<span>Hello</span>
<div></div>
<div></div>
<div></div>
<script>$("div").html("<span class='red'>Hello <b>Again<
</body>
</html>

Demo
Example:

Add some html to each div then immediately
do further manipulations to the inserted html.
1
2
3
4
5
6
7

<!DOCTYPE html>
<html>
<head>
<style>
div { color:blue; font-size:18px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
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</head>
<body>
<div></div>
<div></div>
<div></div>
<script>
$("div").html("<b>Wow!</b> Such excitement..."
$("div b").append(document.createTextNode("!!!"
.css("color", "red");
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

ID Selector (“#id”)
Categories: Selectors > Basic

id selector
Description: Selects a single element with the given id
attribute.
jQuery( "#id" )

version added: 1.0

id: An ID to search for, specified via the id attribute of an element.
For id selectors, jQuery uses the JavaScript function
document.getElementById() , which is extremely efficient. When
another selector is attached to the id selector, such as h2#pageTitle ,
jQuery performs an additional check before identifying the element
as a match.

As always, remember that as a developer,
your time is typically the most valuable
resource. Do not focus on optimization of
selector speed unless it is clear that
performance needs to be improved.
Each id value must be used only once within a document. If more
than one element has been assigned the same ID, queries that use
that ID will only select the first matched element in the DOM. This
behavior should not be relied on, however; a document with more
than one element using the same ID is invalid.
If the id contains characters like periods or colons you have to
escape those characters with backslashes.

Examples:
Example:
1
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Finds the element with the id "myDiv".

<!DOCTYPE html>
<html>
<head>
<style>
div {
width: 90px;
height: 90px;
float:left;
padding: 5px;
margin: 5px;
background-color: #EEEEEE;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="notMe"><p>id="notMe"</p></div>
<div id="myDiv">id="myDiv"</div>
<script>$("#myDiv").css("border","3px solid red"
</body>
</html>

Demo
Example:

Finds the element with the id "myID.entry[1]".
See how certain characters must be escaped with
backslashes.
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<!DOCTYPE html>
<html>
<head>
<style>
div {
width: 300px;
float:left;
padding: 2px;
margin: 3px;
background-color: #EEEEEE;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="myID.entry[0]">id="myID.entry[0]"</div
<div id="myID.entry[1]">id="myID.entry[1]"</div
<div id="myID.entry[2]">id="myID.entry[2]"</div
<script>$("#myID\\.entry\\[1\\]").css("border",
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

:image Selector
Categories: Selectors > Form | Selectors > jQuery Extensions

image selector
Description: Selects all elements of type image.
jQuery( ":image" )
:image

is equivalent to

version added: 1.0

[type="image"]

Additional Notes:
Because :image is a jQuery extension and not part of the CSS
specification, queries using :image cannot take advantage of
the performance boost provided by the native DOM
querySelectorAll() method. For better performance in modern
browsers, use [type="image"] instead.

Example:
Finds all image inputs.
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<!DOCTYPE html>
<html>
<head>
<style>
textarea { height:45px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<input type="button" value="Input Button"/>
<input type="checkbox" />
<input type="file" />
<input type="hidden" />
<input type="image" />
<input type="password" />
<input type="radio" />
<input type="reset" />
<input type="submit" />
<input type="text" />
<select><option>Option<option/></select>
<textarea></textarea>
<button>Button</button>
</form>
<div>
</div>
<script>
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var input = $("input:image").css({background:"yellow"
$("div").text("For this type jQuery found " + input.leng
.css("color", "red");
$("form").submit(function () { return false; });
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.index()
Categories: Miscellaneous > DOM Element Methods

.index()

Returns: Number

Description: Search for a given element from among
the matched elements.
.index()

version added: 1.4

This method does not accept any arguments.

.index( selector )

version added: 1.4

selector
Type: Selector
A selector representing a jQuery collection in which to look for
an element.

.index( element )

version added: 1.0

element
Type: Element or jQuery
The DOM element or first element within the jQuery object to
look for.
Return Values
If no argument is passed to the .index() method, the return value is
an integer indicating the position of the first element within the
jQuery object relative to its sibling elements.
If .index() is called on a collection of elements and a DOM element
or jQuery object is passed in, .index() returns an integer indicating
the position of the passed element relative to the original collection.
If a selector string is passed as an argument, .index() returns an
integer indicating the position of the first element within the jQuery
object relative to the elements matched by the selector. If the
element is not found, .index() will return -1.
Detail

The complementary operation to .get() , which accepts an index
and returns a DOM node, .index() can take a DOM node and
returns an index. Suppose we have a simple unordered list on the
page:
1
2
3
4
5

<ul>
<li id="foo">foo</li>
<li id="bar">bar</li>
<li id="baz">baz</li>
</ul>

If we retrieve one of the three list items (for example, through a DOM
function or as the context to an event handler), .index() can search
for this list item within the set of matched elements:
1
2
3

var listItem = document.getElementById('bar');
alert('Index: ' + $('li').index(listItem));
We get back the zero-based position of the list item:

Index: 1
Similarly, if we retrieve a jQuery object consisting of one of the three
list items, .index() will search for that list item:
1
2

var listItem = $('#bar');
alert('Index: ' + $('li').index(listItem));

We get back the zero-based position of the list item:
Index: 1
Note that if the jQuery collection used as the .index() method's
argument contains more than one element, the first element within
the matched set of elements will be used.

1
2

var listItems = $('li:gt(0)');
alert('Index: ' + $('li').index(listItems));

We get back the zero-based position of the first list item within the
matched set:
Index: 1
If we use a string as the .index() method's argument, it is
interpreted as a jQuery selector string. The first element among the
object's matched elements which also matches this selector is
located.
1
2

var listItem = $('#bar');
alert('Index: ' + listItem.index('li'));

We get back the zero-based position of the list item:
Index: 1
If we omit the argument, .index() will return the position of the first
element within the set of matched elements in relation to its siblings:
1

alert('Index: ' + $('#bar').index());

Again, we get back the zero-based position of the list item:
Index: 1

Examples:
On click, returns the index (based zero) of
that div in the page.
Example:

1
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18
19
20
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22
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<!DOCTYPE html>
<html>
<head>
<style>
div { background:yellow; margin:5px; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<span>Click a div!</span>
<div>First div</div>
<div>Second div</div>
<div>Third div</div>
<script>
$("div").click(function () {
// this is the dom element clicked
var index = $("div").index(this);
$("span").text("That was div index #" + index);
});
</script>
</body>
</html>

Demo
Example:

Returns the index for the element with ID bar.
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<!DOCTYPE html>
<html>
<head>
<style>div { font-weight: bold; color: #090;
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul>
<li id="foo">foo</li>
<li id="bar">bar</li>
<li id="baz">baz</li>
</ul>
<div></div>
<script>var listItem = $('#bar');
$('div').html( 'Index: ' + $('li').index(listItem) )
</body>
</html>

Demo
Example:

Returns the index for the first item in the
jQuery collection.
1
2
3
4
5
6
7
8
9
10
11
12

<!DOCTYPE html>
<html>
<head>
<style>div { font-weight: bold; color: #090;
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul>
<li id="foo">foo</li>
<li id="bar">bar</li>
<li id="baz">baz</li>
</ul>
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<div></div>
<script>var listItems = $('li:gt(0)');
$('div').html( 'Index: ' + $('li').index(listItems) );
</script>
</body>
</html>

Demo
Example:

Returns the index for the element with ID bar
in relation to all <li> elements.
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<!DOCTYPE html>
<html>
<head>
<style>div { font-weight: bold; color: #090;
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul>
<li id="foo">foo</li>
<li id="bar">bar</li>
<li id="baz">baz</li>
</ul>
<div></div>
<script>$('div').html('Index: ' + $('#bar').index(
</body>
</html>

Demo
Example:

Returns the index for the element with ID bar
in relation to its siblings.
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<!DOCTYPE html>
<html>
<head>
<style>div { font-weight: bold; color: #090;
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul>
<li id="foo">foo</li>
<li id="bar">bar</li>
<li id="baz">baz</li>
</ul>
<div></div>
<script>var barIndex = $('#bar').index();
$('div').html( 'Index: ' + barIndex );</script
</body>
</html>

Demo
Example:

Returns -1, as there is no element with ID

foobar.
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<!DOCTYPE html>
<html>
<head>
<style>div { font-weight: bold; color: #090;
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul>
<li id="foo">foo</li>
<li id="bar">bar</li>
<li id="baz">baz</li>
</ul>
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<div></div>
<script>var foobar = $("li").index( $('#foobar'
$('div').html('Index: ' + foobar);</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.innerHeight()
Categories: CSS | Dimensions | Manipulation > Style Properties

.innerHeight()

Returns: Integer

Description: Get the current computed height for the
first element in the set of matched elements, including
padding but not border.
.innerHeight()

version added: 1.2.6

This method does not accept any arguments.
This method returns the height of the element, including top and
bottom padding, in pixels.
This method is not applicable to
these, use .height() instead.

window

and

document

objects; for

Example:
Get the innerHeight of a paragraph.
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<!DOCTYPE html>
<html>
<head>
<style>p { margin:10px;padding:5px;border:2px solid
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p><p></p>
<script>var p = $("p:first");
$("p:last").text( "innerHeight:" + p.innerHeight() );
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.innerWidth()
Categories: CSS | Dimensions | Manipulation > Style Properties

.innerWidth()

Returns: Integer

Description: Get the current computed width for the first
element in the set of matched elements, including
padding but not border.
.innerWidth()

version added: 1.2.6

This method does not accept any arguments.
This method returns the width of the element, including left and right
padding, in pixels.
This method is not applicable to
these, use .width() instead.

window

and

document

objects; for

Example:
Get the innerWidth of a paragraph.
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<!DOCTYPE html>
<html>
<head>
<style>p { margin:10px;padding:5px;border:2px solid
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p><p></p>
<script>var p = $("p:first");
$("p:last").text( "innerWidth:" + p.innerWidth() );
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

:input Selector
Categories: Selectors > Form | Selectors > jQuery Extensions

input selector
Description: Selects all input, textarea, select and
button elements.
jQuery( ":input" )
The

:input

version added: 1.0

selector basically selects all form controls.

Additional Notes:
Because :input is a jQuery extension and not part of the CSS
specification, queries using :input cannot take advantage of
the performance boost provided by the native DOM
querySelectorAll() method. To achieve the best performance
when using :input to select elements, first select the elements
using a pure CSS selector, then use .filter(":input") .

Example:
Finds all input elements.
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<!DOCTYPE html>
<html>
<head>
<style>
textarea { height:25px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<input type="button" value="Input Button"/>
<input type="checkbox" />
<input type="file" />
<input type="hidden" />
<input type="image" />
<input type="password" />
<input type="radio" />
<input type="reset" />
<input type="submit" />
<input type="text" />
<select><option>Option</option></select>
<textarea></textarea>
<button>Button</button>
</form>
<div id="messages">
</div>
<script>
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var allInputs = $(":input");
var formChildren = $("form > *");
$("#messages").text("Found " + allInputs.length +
formChildren.length +
// so it won't submit
$("form").submit(function () { return false; });
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.insertAfter()
Categories: Manipulation > DOM Insertion, Outside

.insertAfter( target )

Returns: jQuery

Description: Insert every element in the set of matched
elements after the target.
.insertAfter( target )

version added: 1.0

target
Type: Selector or htmlString or Element or jQuery
A selector, element, HTML string, or jQuery object; the matched
set of elements will be inserted after the element(s) specified by
this parameter.
The .after() and .insertAfter() methods perform the same task.
The major difference is in the syntax-specifically, in the placement of
the content and target. With .after() , the selector expression
preceding the method is the container after which the content is
inserted. With .insertAfter() , on the other hand, the content
precedes the method, either as a selector expression or as markup
created on the fly, and it is inserted after the target container.
Consider the following HTML:
1
2
3
4
5

<div class="container">
<h2>Greetings</h2>
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

We can create content and insert it after several elements at once:
1

$('<p>Test</p>').insertAfter('.inner');

Each inner

<div>

element gets this new content:

1
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3
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<div class="container">
<h2>Greetings</h2>
<div class="inner">Hello</div>
<p>Test</p>
<div class="inner">Goodbye</div>
<p>Test</p>
</div>

We can also select an element on the page and insert it after
another:
1

$('h2').insertAfter($('.container'));

If an element selected this way is inserted into a single location
elsewhere in the DOM, it will be moved after the target (not cloned):
1
2
3
4
5

<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>
<h2>Greetings</h2>

If there is more than one target element, however, cloned copies of
the inserted element will be created for each target after the first,
and that new set (the original element plus clones) is returned.

Example:
Insert all paragraphs after an element with id of "foo".
Same as $("#foo").after("p")
1
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<!DOCTYPE html>
<html>
<head>
<style>#foo { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p> is what I said... </p><div id="foo">FOO!</
<script>
$("p").insertAfter("#foo");
</script>
</body>
</html>

Demo
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.insertBefore()
Categories: Manipulation > DOM Insertion, Outside

.insertBefore( target )

Returns: jQuery

Description: Insert every element in the set of matched
elements before the target.
.insertBefore( target )

version added: 1.0

target
Type: Selector or htmlString or Element or jQuery
A selector, element, HTML string, or jQuery object; the matched
set of elements will be inserted before the element(s) specified
by this parameter.
The .before() and .insertBefore() methods perform the same task.
The major difference is in the syntax-specifically, in the placement of
the content and target. With .before() , the selector expression
preceding the method is the container before which the content is
inserted. With .insertBefore() , on the other hand, the content
precedes the method, either as a selector expression or as markup
created on the fly, and it is inserted before the target container.
Consider the following HTML:
1
2
3
4
5

<div class="container">
<h2>Greetings</h2>
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

We can create content and insert it before several elements at once:
1

$('<p>Test</p>').insertBefore('.inner');

Each inner

<div>

element gets this new content:

1
2
3
4
5
6
7

<div class="container">
<h2>Greetings</h2>
<p>Test</p>
<div class="inner">Hello</div>
<p>Test</p>
<div class="inner">Goodbye</div>
</div>

We can also select an element on the page and insert it before
another:
1

$('h2').insertBefore($('.container'));

If an element selected this way is inserted into a single location
elsewhere in the DOM, it will be moved before the target (not
cloned):
1
2
3
4
5

<h2>Greetings</h2>
<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

If there is more than one target element, however, cloned copies of
the inserted element will be created for each target after the first,
and that new set (the original element plus clones) is returned.

Example:
Insert all paragraphs before an element with id of
"foo". Same as $("#foo").before("p")
1
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<!DOCTYPE html>
<html>
<head>
<style>#foo { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="foo">FOO!</div><p>I would like to say:
<script>
$("p").insertBefore("#foo");
</script>
</body>
</html>

Demo
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.is()
Categories: Traversing > Filtering

.is( selector )

Returns: Boolean

Description: Check the current matched set of
elements against a selector, element, or jQuery object
and return true if at least one of these elements matches
the given arguments.
.is( selector )

version added: 1.0

selector
Type: Selector
A string containing a selector expression to match elements
against.

.is( function(index) )

version added: 1.6

function(index)
Type: Function()
A function used as a test for the set of elements. It accepts one
argument, index , which is the element's index in the jQuery
collection.Within the function, this refers to the current DOM
element.

.is( jQuery object )

version added: 1.6

jQuery object
Type: Object
An existing jQuery object to match the current set of elements
against.

.is( element )

version added: 1.6

element
Type: Element
An element to match the current set of elements against.
Unlike other filtering methods, .is() does not create a new jQuery
object. Instead, it allows you to test the contents of a jQuery object
without modification. This is often useful inside callbacks, such as
event handlers.

Suppose you have a list, with two of its items containing a child
element:
1
2
3
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<ul>
<li>list <strong>item 1</strong></li>
<li><span>list item 2</span></li>
<li>list item 3</li>
</ul>

You can attach a click handler to the <ul> element, and then limit the
code to be triggered only when a list item itself, not one of its
children, is clicked:
1
2
3
4
5
6

$("ul").click(function(event) {
var $target = $(event.target);
if ( $target.is("li") ) {
$target.css("background-color", "red");
}
});

Now, when the user clicks on the word "list" in the first item or
anywhere in the third item, the clicked list item will be given a red
background. However, when the user clicks on item 1 in the first item
or anywhere in the second item, nothing will occur, because in those
cases the target of the event would be <strong> or <span> ,
respectively.
Prior to jQuery 1.7, in selector strings with positional selectors such
as :first , :gt() , or :even , the positional filtering is done against the
jQuery object passed to .is() , not against the containing document.
So for the HTML shown above, an expression such as
$("li:first").is("li:last") returns true , but $("li:firstchild").is("li:last-child") returns false . In addition, a bug in
Sizzle prevented many positional selectors from working properly.
These two factors made positional selectors almost unusable in
filters.

Starting with jQuery 1.7, selector strings with positional selectors
apply the selector against the document, and then determine
whether the first element of the current jQuery set matches any of
the resulting elements. So for the HTML shown above, an
expression such as $("li:first").is("li:last") returns false . Note
that since positional selectors are jQuery additions and not W3C
standard, we recommend using the W3C selectors whenever
feasible.
Using a Function
The second form of this method evaluates expressions related to
elements based on a function rather than a selector. For each
element, if the function returns true , .is() returns true as well. For
example, given a somewhat more involved HTML snippet:
1
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<ul>
<li><strong>list</strong> item 1 - one strong tag
<li><strong>list</strong> item <strong>2</strong
two <span>strong tags</span></li>
<li>list item 3</li>
<li>list item 4</li>
<li>list item 5</li>
</ul>

You can attach a click handler to every <li> that evaluates the
number of <strong> elements within the clicked <li> at that time like
so:
1
2
3
4
5
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$("li").click(function() {
var $li = $(this),
isWithTwo = $li.is(function() {
return $('strong', this).length === 2;
});
if ( isWithTwo ) {
$li.css("background-color", "green");

8
9
10
11

} else {
$li.css("background-color", "red");
}
});

Examples:
Shows a few ways is() can be used inside an
event handler.
Example:

1
2
3
4
5
6
7
8
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13
14
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16
17
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20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
div { width:60px; height:60px; margin:5px; float
border:4px outset; background:green; text-align
font-weight:bolder; cursor:pointer; }
.blue { background:blue; }
.red { background:red; }
span { color:white; font-size:16px; }
p { color:red; font-weight:bolder; background
margin:3px; clear:left; display:none; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div>
<div class="blue"></div>
<div></div>
<div class="red"></div>
<div><br/><span>Peter</span></div>
<div class="blue"></div>
<p>&nbsp;</p>
<script>
$("div").one('click', function () {
if ($(this).is(":first-child")) {
$("p").text("It's the first div.");
} else if ($(this).is(".blue,.red")) {
$("p").text("It's a blue or red div.");
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} else if ($(this).is(":contains('Peter')")) {
$("p").text("It's Peter!");
} else {
$("p").html("It's nothing <em>special</em>."
}
$("p").hide().slideDown("slow");
$(this).css({"border-style": "inset", cursor:
});
</script>
</body>
</html>

Demo
Example:

Returns true, because the parent of the input
is a form element.
1
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<!DOCTYPE html>
<html>
<head>
<style>div { color:red; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form><input type="checkbox" /></form>
<div></div>
<script>
var isFormParent = $("input[type='checkbox']"
$("div").text("isFormParent = " + isFormParent);
</script>
</body>
</html>

Demo
Example:

Returns false, because the parent of the
input is a p element.
1
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<!DOCTYPE html>
<html>
<head>
<style>div { color:red; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form><p><input type="checkbox" /></p></form>
<div></div>
<script>
var isFormParent = $("input[type='checkbox']"
$("div").text("isFormParent = " + isFormParent);
</script>
</body>
</html>

Demo
Example:

Checks against an existing collection of
alternating list elements. Blue, alternating list elements
slide up while others turn red.
1
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<!DOCTYPE html>
<html>
<head>
<style>li { cursor:pointer; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul id="browsers">
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<li>Chrome</li>
<li>Safari</li>
<li>Firefox</li>
<li>Opera</li>
</ul>
<script>
var $alt = $("#browsers li:nth-child(2n)").css(
$('li').click(function() {
var $li = $(this);
if ( $li.is( $alt ) ) {
$li.slideUp();
} else {
$li.css("background", "red");
}
});
</script>
</body>
</html>

Demo
Example:

An alternate way to achieve the above
example using an element rather than a jQuery object.
Checks against an existing collection of alternating list
elements. Blue, alternating list elements slide up while
others turn red.
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<!DOCTYPE html>
<html>
<head>
<style>li { cursor:pointer; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
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<ul id="browsers">
<li>Chrome</li>
<li>Safari</li>
<li>Firefox</li>
<li>Opera</li>
</ul>
<script>
var $alt = $("#browsers li:nth-child(2n)").css(
$('li').click(function() {
if ( $alt.is( this ) ) {
$(this).slideUp();
} else {
$(this).css("background", "red");
}
});
</script>
</body>
</html>

Demo
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jQuery()
Categories: Core

Return a collection of matched elements either found in the DOM
based on passed argument(s) or created by passing an HTML string.
Contents:
jQuery( selector [, context ] )
jQuery( selector [, context ] )
jQuery( element )
jQuery( elementArray )
jQuery( object )
jQuery( jQuery object )
jQuery()
jQuery( html [, ownerDocument ] )
jQuery( html [, ownerDocument ] )
jQuery( html, attributes )
jQuery( callback )
jQuery( callback )

jQuery( selector [, context ] )

Returns: jQuery

Description: Accepts a string containing a CSS selector
which is then used to match a set of elements.
jQuery( selector [, context ] )

version added: 1.0

selector
Type: selector
A string containing a selector expression
context
Type: Element or jQuery
A DOM Element, Document, or jQuery to use as context

jQuery( element )

version added: 1.0

element
Type: Element
A DOM element to wrap in a jQuery object.

jQuery( elementArray )

version added: 1.0

elementArray
Type: Array
An array containing a set of DOM elements to wrap in a jQuery
object.

jQuery( object )

version added: 1.0

object
Type: PlainObject
A plain object to wrap in a jQuery object.

jQuery( jQuery object )
jQuery object
Type: PlainObject
An existing jQuery object to clone.

version added: 1.0

jQuery()

version added: 1.4

This method does not accept any arguments.
In the first formulation listed above, jQuery() — which can also be
written as $() — searches through the DOM for any elements that
match the provided selector and creates a new jQuery object that
references these elements:
1

$( "div.foo" );

If no elements match the provided selector, the new jQuery object is
"empty"; that is, it contains no elements and has .length property of
0.
Selector Context
By default, selectors perform their searches within the DOM starting
at the document root. However, an alternate context can be given for
the search by using the optional second parameter to the $()
function. For example, to do a search within an event handler, the
search can be restricted like so:
1
2
3

$( "div.foo" ).click(function() {
$( "span", this ).addClass( "bar" );
});

When the search for the span selector is restricted to the context of
this , only spans within the clicked element will get the additional
class.
Internally, selector context is implemented with the .find() method,
so $( "span", this ) is equivalent to $( this ).find( "span" ) .
Using DOM elements
The second and third formulations of this function create a jQuery
object using one or more DOM elements that were already selected

in some other way.
Note: These formulations are meant to consume only DOM
elements; feeding mixed data to the elementArray form is
particularly discouraged.
A common use of this facility is to call jQuery methods on an
element that has been passed to a callback function through the
keyword this :
1
2
3

$( "div.foo" ).click(function() {
$(this).slideUp();
});

This example causes elements to be hidden with a sliding animation
when clicked. Because the handler receives the clicked item in the
this keyword as a bare DOM element, the element must be passed
to the $() function before applying jQuery methods to it.
XML data returned from an Ajax call can be passed to the $()
function so individual elements of the XML structure can be retrieved
using .find() and other DOM traversal methods.
1
2
3

$.post( "url.xml", function(data) {
var $child = $(data).find("child");
})

Cloning jQuery Objects
When a jQuery object is passed to the $() function, a clone of the
object is created. This new jQuery object references the same DOM
elements as the initial one.
Returning an Empty Set
As of jQuery 1.4, calling the jQuery() method with no arguments
returns an empty jQuery set (with a .length property of 0). In
previous versions of jQuery, this would return a set containing the

document node.
Working With Plain Objects
At present, the only operations supported on plain JavaScript
objects wrapped in jQuery are: .data() , .prop() , .on() , .off() ,
.trigger() and .triggerHandler() . The use of .data() (or any
method requiring .data() ) on a plain object will result in a new
property on the object called jQuery{randomNumber} (eg.
jQuery123456789).
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Should

// define a plain object
var foo = {foo: "bar", hello: "world"};
// Pass it to the jQuery function
var $foo = $( foo );
// test accessing property values
var test1 = $foo.prop( "foo" ); // bar
// test setting property values
$foo.prop( "foo", "foobar" );
var test2 = $foo.prop( "foo" ); // foobar

// test using .data() as summarized above
$foo.data( "keyName", "someValue");
console.log( $foo ); // will now contain a jQuery{rando
// test binding an event name and triggering
$foo.on( "eventName", function () {
console.log("eventName was called");
});

$foo.trigger( "eventName" ); // logs "eventName was cal

.trigger( "eventName" )

be used, it will search for an

"eventName" property on the object and attempt to execute it after
any attached jQuery handlers are executed. It does not check
whether the property is a function or not. To avoid this behavior,
.triggerHandler( "eventName" ) should be used instead.
1

$foo.triggerHandler( "eventName" ); // also logs "eventN

Examples:
Find all p elements that are children of a div
element and apply a border to them.
Example:

1
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>one</p> <div><p>two</p></div> <p>three</p>
<script>
$( "div > p").css("border", "1px solid gray");
</script>
</body>
</html>

Demo
Example:

Find all inputs of type radio within the first
form in the document.
1

$("input:radio", document.forms[0]);

Find all div elements within an XML
document from an Ajax response.
Example:

1

$("div", xml.responseXML);

Example:

Set the background color of the page to

black.
1

$(document.body).css( "background", "black" );

Example:
1

Hide all the input elements within a form.

$(myForm.elements).hide()

jQuery( html [, ownerDocument ] )

Returns: jQuery

Description: Creates DOM elements on the fly from the
provided string of raw HTML.
jQuery( html [, ownerDocument ] )

version added: 1.0

html
Type: htmlString
A string of HTML to create on the fly. Note that this parses
HTML, not XML.
ownerDocument
Type: document
A document in which the new elements will be created

jQuery( html, attributes )

version added: 1.4

html
Type: htmlString
A string defining a single, standalone, HTML element (e.g.
<div/> or <div></div>).
attributes
Type: PlainObject
An object of attributes, events, and methods to call on the
newly-created element.
Creating New Elements
If a string is passed as the parameter to $() , jQuery examines the
string to see if it looks like HTML (i.e., it starts with <tag ... > ). If
not, the string is interpreted as a selector expression, as explained
above. But if the string appears to be an HTML snippet, jQuery
attempts to create new DOM elements as described by the HTML.
Then a jQuery object is created and returned that refers to these
elements. You can perform any of the usual jQuery methods on this
object:

1

$( "<p id='test'>My <em>new</em> text</p>" ).appendTo(

For explicit parsing of a string to HTML, use the $.parseHTML()
method.
If the HTML is more complex than a single tag without attributes, as
it is in the above example, the actual creation of the elements is
handled by the browser's innerHTML mechanism. In most cases,
jQuery creates a new <div> element and sets the innerHTML
property of the element to the HTML snippet that was passed in.
When the parameter has a single tag (with optional closing tag or
quick-closing) — $( "<img />" ) or $( "<img>" ) , $( "<a></a>" ) or
$( "<a>" ) — jQuery creates the element using the native
JavaScript createElement() function.
When passing in complex HTML, some browsers may not generate
a DOM that exactly replicates the HTML source provided. As
mentioned, jQuery uses the browser"s .innerHTML property to parse
the passed HTML and insert it into the current document. During this
process, some browsers filter out certain elements such as <html> ,
<title> , or <head> elements. As a result, the elements inserted may
not be representative of the original string passed.
Filtering isn't, however, limited to these tags. For example, Internet
Explorer prior to version 8 will also convert all href properties on
links to absolute URLs, and Internet Explorer prior to version 9 will
not correctly handle HTML5 elements without the addition of a
separate compatibility layer.
To ensure cross-platform compatibility, the snippet must be wellformed. Tags that can contain other elements should be paired with
a closing tag:
1

$( "<a href='http://jquery.com'></a>" );

Tags that cannot contain elements may be quick-closed or not:

1
2

$( "<img />" );
$( "<input>" );

When passing HTML to jQuery() , please also note that text nodes
are not treated as DOM elements. With the exception of a few
methods (such as .content() ), they are generally otherwise ignored
or removed. E.g:
1
2

var el = $( "1<br/>2<br/>3" ); // returns [<br>, "2", <b
el = $( "1<br/>2<br/>3 >" ); // returns [<br>, "2", <br

This behavior is expected.
As of jQuery 1.4, the second argument to jQuery() can accept a
plain object consisting of a superset of the properties that can be
passed to the .attr() method.
Important: If the second argument is passed, the HTML string in the
first argument must represent a a simple element with no attributes.
As of jQuery 1.4, any event type can be passed in, and the
following jQuery methods can be called: val, css, html, text, data,
width, height, or offset.
As of jQuery 1.8, any jQuery instance method (a method of
jQuery.fn ) can be used as a property of the object passed to the
second parameter:
1
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$( "<div></div>", {
"class": "my-div",
on: {
touchstart: function( event ) {
// do something
}
}
}).appendTo( "body" );

The name "class" must be quoted in the object since it is a
JavaScript reserved word, and "className" cannot be used since it
refers to the DOM property, not the attribute.
While the second argument is convenient, its flexibility can lead to
unintended consequences (e.g. $("<input>", {size: "4"}) calling
the .size() method instead of setting the size attribute). The
previous code block could thus be written instead as:
1
2
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$( "<div></div>" )
.addClass( "my-div" )
.on({
touchstart: function( event ) {
// do something
}
}).appendTo( "body" );

Examples:
Create a div element (and all of its contents)
dynamically and append it to the body element.
Internally, an element is created and its innerHTML
property set to the given markup.
Example:

1

$( "<div><p>Hello</p></div>" ).appendTo( "body" )

Example:
1
2
3
4
5
6
7

Create some DOM elements.

$( "<div/>", {
"class": "test",
text: "Click me!",
click: function() {
$( this ).toggleClass( "test" );
}
}).appendTo( "body" );

jQuery( callback )

Returns: jQuery

Description: Binds a function to be executed when the
DOM has finished loading.
jQuery( callback )

version added: 1.0

callback
Type: Function()
The function to execute when the DOM is ready.
This function behaves just like $(document).ready() , in that it should
be used to wrap other $() operations on your page that depend on
the DOM being ready. While this function is, technically, chainable,
there really isn"t much use for chaining against it.

Examples:
Execute the function when the DOM is ready
to be used.
Example:

1
2
3

$(function(){
// Document is ready
});

Use both the shortcut for
$(document).ready() and the argument to write failsafe
jQuery code using the $ alias, without relying on the
global alias.
Example:

1
2
3

jQuery(function($) {
// Your code using failsafe $ alias here...
});
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.jquery
Categories: Internals | Properties > Properties of jQuery Object Instances

jquery

Returns: String

Description: A string containing the jQuery version
number.
jquery

version added: 1.0

The .jquery property is assigned to the jQuery prototype, commonly
referred to by its alias $.fn . It is a string containing the version
number of jQuery , such as "1.5.0" or "1.4.4".

Examples:
Example:
1
2
3
4
5
6
7
8
9
10

Determine if an object is a jQuery object

var a = { what: "A regular JS object" },
b = $('body');
if ( a.jquery ) { // falsy, since it's undefined
alert(' a is a jQuery object! ');
}
if ( b.jquery ) { // truthy, since it's a string
alert(' b is a jQuery object! ');
}

Example:

Get the current version of jQuery running on

the page
1

alert( 'You are running jQuery version: ' + $.fn.jquery )
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jQuery.ajax()
Categories: Ajax > Low-Level Interface

jQuery.ajax( url [, settings ] )

Returns: jqXHR

Description: Perform an asynchronous HTTP (Ajax)
request.
jQuery.ajax( url [, settings ] )

version added: 1.5

url
Type: String
A string containing the URL to which the request is sent.
settings
Type: PlainObject
A set of key/value pairs that configure the Ajax request. All
settings are optional. A default can be set for any option with
$.ajaxSetup(). See jQuery.ajax( settings ) below for a complete
list of all settings.

jQuery.ajax( [settings ] )

version added: 1.0

settings
Type: PlainObject
A set of key/value pairs that configure the Ajax request. All
settings are optional. A default can be set for any option with
$.ajaxSetup().
accepts (default: depends on DataType )
Type: PlainObject
The content type sent in the request header that tells the
server what kind of response it will accept in return. If the
accepts setting needs modification, it is recommended to
do so once in the $.ajaxSetup() method.
async (default: true )
Type: Boolean
By default, all requests are sent asynchronously (i.e. this is
set to true by default). If you need synchronous requests,
set this option to false . Cross-domain requests and
dataType: "jsonp" requests do not support synchronous
operation. Note that synchronous requests may temporarily
lock the browser, disabling any actions while the request is

active. As of jQuery 1.8, the use of async: false with
jqXHR ( $.Deferred ) is deprecated; you must use the
success/error/complete callback options instead of the
corresponding methods of the jqXHR object such as
jqXHR.done() or the deprecated jqXHR.success() .
beforeSend
Type: Function( jqXHR jqXHR, PlainObject settings )
A pre-request callback function that can be used to modify
the jqXHR (in jQuery 1.4.x, XMLHTTPRequest) object
before it is sent. Use this to set custom headers, etc. The
jqXHR and settings objects are passed as arguments. This
is an Ajax Event. Returning false in the beforeSend
function will cancel the request. As of jQuery 1.5, the
beforeSend option will be called regardless of the type of
request.
cache (default: true, false for dataType 'script' and
'jsonp' )
Type: Boolean
If set to false , it will force requested pages not to be
cached by the browser. Note: Setting cache to false will
only work correctly with HEAD and GET requests. It works
by appending "_={timestamp}" to the GET parameters. The
parameter is not needed for other types of requests, except
in IE8 when a POST is made to a URL that has already
been requested by a GET.
complete
Type: Function( jqXHR jqXHR, String textStatus )
A function to be called when the request finishes (after
success and error callbacks are executed). The function
gets passed two arguments: The jqXHR (in jQuery 1.4.x,
XMLHTTPRequest) object and a string categorizing the
status of the request ( "success" , "notmodified" , "error" ,
"timeout" , "abort" , or "parsererror" ). As of jQuery 1.5,
the complete setting can accept an array of functions. Each
function will be called in turn. This is an Ajax Event.
contents
Type: PlainObject
An object of string/regular-expression pairs that determine
how jQuery will parse the response, given its content type.
(version added: 1.5)

contentType (default: 'application/x-www-form-urlencoded;
charset=UTF-8' )
Type: String
When sending data to the server, use this content type.
Default is "application/x-www-form-urlencoded;
charset=UTF-8", which is fine for most cases. If you
explicitly pass in a content-type to $.ajax() , then it'll
always be sent to the server (even if no data is sent). If no
charset is specified, data will be transmitted to the server
using the server's default charset; you must decode this
appropriately on the server side.
context
Type: PlainObject
This object will be made the context of all Ajax-related
callbacks. By default, the context is an object that
represents the ajax settings used in the call
( $.ajaxSettings merged with the settings passed to
$.ajax ). For example, specifying a DOM element as the
context will make that the context for the complete callback
of a request, like so:
1
2
3
4
5
6

$.ajax({
url: "test.html",
context: document.body
}).done(function() {
$(this).addClass("done");
});

converters (default:

{"* text": window.String, "text
html": true, "text json": jQuery.parseJSON, "text xml":
jQuery.parseXML} )

Type: PlainObject
An object containing dataType-to-dataType converters.
Each converter's value is a function that returns the
transformed value of the response. (version added: 1.5)
crossDomain (default:

false for same-domain requests,
true for cross-domain requests )

Type: Boolean
If you wish to force a crossDomain request (such as
JSONP) on the same domain, set the value of
crossDomain to true . This allows, for example, server-side
redirection to another domain. (version added: 1.5)
data
Type: PlainObject or String
Data to be sent to the server. It is converted to a query
string, if not already a string. It's appended to the url for
GET-requests. See processData option to prevent this
automatic processing. Object must be Key/Value pairs. If
value is an Array, jQuery serializes multiple values with
same key based on the value of the traditional setting
(described below).
dataFilter
Type: Function( PlainObject data, String type ) => Object
A function to be used to handle the raw response data of
XMLHttpRequest.This is a pre-filtering function to sanitize
the response. You should return the sanitized data. The
function accepts two arguments: The raw data returned
from the server and the 'dataType' parameter.
dataType (default: Intelligent Guess (xml, json, script,
or html) )
Type: String
The type of data that you're expecting back from the server.
If none is specified, jQuery will try to infer it based on the
MIME type of the response (an XML MIME type will yield
XML, in 1.4 JSON will yield a JavaScript object, in 1.4
script will execute the script, and anything else will be
returned as a string). The available types (and the result
passed as the first argument to your success callback) are:
"xml": Returns a XML document that can be processed
via jQuery.
"html": Returns HTML as plain text; included script
tags are evaluated when inserted in the DOM.
"script": Evaluates the response as JavaScript and
returns it as plain text. Disables caching by appending
a query string parameter, "_=[TIMESTAMP]", to the

URL unless the cache option is set to true . Note: This
will turn POSTs into GETs for remote-domain requests.
"json": Evaluates the response as JSON and returns a
JavaScript object. In jQuery 1.4 the JSON data is
parsed in a strict manner; any malformed JSON is
rejected and a parse error is thrown. (See json.org for
more information on proper JSON formatting.)
"jsonp": Loads in a JSON block using JSONP. Adds
an extra "?callback=?" to the end of your URL to
specify the callback. Disables caching by appending a
query string parameter, "_=[TIMESTAMP]", to the URL
unless the cache option is set to true .
"text": A plain text string.
multiple, space-separated values: As of jQuery 1.5,
jQuery can convert a dataType from what it received in
the Content-Type header to what you require. For
example, if you want a text response to be treated as
XML, use "text xml" for the dataType. You can also
make a JSONP request, have it received as text, and
interpreted by jQuery as XML: "jsonp text xml."
Similarly, a shorthand string such as "jsonp xml" will
first attempt to convert from jsonp to xml, and, failing
that, convert from jsonp to text, and then from text to
xml.
error
Type: Function( jqXHR jqXHR, String textStatus, String
errorThrown )
A function to be called if the request fails. The function
receives three arguments: The jqXHR (in jQuery 1.4.x,
XMLHttpRequest) object, a string describing the type of
error that occurred and an optional exception object, if one
occurred. Possible values for the second argument
(besides null ) are "timeout" , "error" , "abort" , and
"parsererror" . When an HTTP error occurs, errorThrown
receives the textual portion of the HTTP status, such as
"Not Found" or "Internal Server Error." As of jQuery 1.5,
the error setting can accept an array of functions. Each
function will be called in turn. Note: This handler is not

called for cross-domain script and JSONP requests. This is
an Ajax Event.
global (default: true )
Type: Boolean
Whether to trigger global Ajax event handlers for this
request. The default is true . Set to false to prevent the
global handlers like ajaxStart or ajaxStop from being
triggered. This can be used to control various Ajax Events.
headers (default: {} )
Type: PlainObject
An object of additional header key/value pairs to send
along with the request. This setting is set before the
beforeSend function is called; therefore, any values in the
headers setting can be overwritten from within the
beforeSend function. (version added: 1.5)
ifModified (default: false )
Type: Boolean
Allow the request to be successful only if the response has
changed since the last request. This is done by checking
the Last-Modified header. Default value is false , ignoring
the header. In jQuery 1.4 this technique also checks the
'etag' specified by the server to catch unmodified data.
isLocal (default: depends on current location protocol )
Type: Boolean
Allow the current environment to be recognized as "local,"
(e.g. the filesystem), even if jQuery does not recognize it as
such by default. The following protocols are currently
recognized as local: file , *-extension , and widget . If the
isLocal setting needs modification, it is recommended to
do so once in the $.ajaxSetup() method. (version added:
1.5.1)
jsonp
Type: String
Override the callback function name in a jsonp request.
This value will be used instead of 'callback' in the
'callback=?' part of the query string in the url. So
{jsonp:'onJSONPLoad'} would result in 'onJSONPLoad=?'
passed to the server. As of jQuery 1.5, setting the jsonp

option to false prevents jQuery from adding the "?
callback" string to the URL or attempting to use "=?" for
transformation. In this case, you should also explicitly set
the jsonpCallback setting. For example, { jsonp: false,
jsonpCallback: "callbackName" }

jsonpCallback
Type: String or Function()
Specify the callback function name for a JSONP request.
This value will be used instead of the random name
automatically generated by jQuery. It is preferable to let
jQuery generate a unique name as it'll make it easier to
manage the requests and provide callbacks and error
handling. You may want to specify the callback when you
want to enable better browser caching of GET requests. As
of jQuery 1.5, you can also use a function for this setting,
in which case the value of jsonpCallback is set to the return
value of that function.
mimeType
Type: String
A mime type to override the XHR mime type. (version
added: 1.5.1)
password
Type: String
A password to be used in response to an HTTP access
authentication request.
processData (default: true )
Type: Boolean
By default, data passed in to the data option as an object
(technically, anything other than a string) will be processed
and transformed into a query string, fitting to the default
content-type "application/x-www-form-urlencoded". If you
want to send a DOMDocument, or other non-processed
data, set this option to false .
scriptCharset
Type: String
Only applies when the "script" transport is used (e.g.,
cross-domain requests with "jsonp" or "script" dataType
and "GET" type). Sets the charset attribute on the script
tag used in the request. Used when the character set on

the local page is not the same as the one on the remote
script.
statusCode (default: {} )
Type: PlainObject
An object of numeric HTTP codes and functions to be
called when the response has the corresponding code. For
example, the following will alert when the response status
is a 404:
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$.ajax({
statusCode: {
404: function() {
alert("page not found");
}
}
});

If the request is successful, the status code functions take
the same parameters as the success callback; if it results
in an error, they take the same parameters as the error
callback.
(version added: 1.5)
success
Type: Function( PlainObject data, String textStatus, jqXHR
jqXHR )
A function to be called if the request succeeds. The
function gets passed three arguments: The data returned
from the server, formatted according to the dataType
parameter; a string describing the status; and the jqXHR (in
jQuery 1.4.x, XMLHttpRequest) object. As of jQuery 1.5,
the success setting can accept an array of functions. Each
function will be called in turn. This is an Ajax Event.
timeout
Type: Number
Set a timeout (in milliseconds) for the request. This will
override any global timeout set with $.ajaxSetup(). The
timeout period starts at the point the $.ajax call is made; if

several other requests are in progress and the browser has
no connections available, it is possible for a request to time
out before it can be sent. In jQuery 1.4.x and below, the
XMLHttpRequest object will be in an invalid state if the
request times out; accessing any object members may
throw an exception. In Firefox 3.0+ only, script and
JSONP requests cannot be cancelled by a timeout; the
script will run even if it arrives after the timeout period.
traditional
Type: Boolean
Set this to true if you wish to use the traditional style of
param serialization.
type (default: 'GET' )
Type: String
The type of request to make ("POST" or "GET"), default is
"GET". Note: Other HTTP request methods, such as PUT
and DELETE, can also be used here, but they are not
supported by all browsers.
url (default: The current page )
Type: String
A string containing the URL to which the request is sent.
username
Type: String
A username to be used in response to an HTTP access
authentication request.
xhr (default:

ActiveXObject when available (IE), the
XMLHttpRequest otherwise )

Type: Function()
Callback for creating the XMLHttpRequest object. Defaults
to the ActiveXObject when available (IE), the
XMLHttpRequest otherwise. Override to provide your own
implementation for XMLHttpRequest or enhancements to
the factory.
xhrFields
Type: PlainObject
An object of fieldName-fieldValue pairs to set on the native
XHR object. For example, you can use it to set
withCredentials to true for cross-domain requests if

needed.
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$.ajax({
url: a_cross_domain_url,
xhrFields: {
withCredentials: true
}
});

In jQuery 1.5, the withCredentials property was not
propagated to the native XHR and thus CORS requests
requiring it would ignore this flag. For this reason, we
recommend using jQuery 1.5.1+ should you require the use
of it.
(version added: 1.5.1)
The $.ajax() function underlies all Ajax requests sent by jQuery. It is
often unnecessary to directly call this function, as several higherlevel alternatives like $.get() and .load() are available and are
easier to use. If less common options are required, though, $.ajax()
can be used more flexibly.
At its simplest, the
arguments:
1

$.ajax()

function can be called with no

$.ajax();

Note: Default settings can be set globally by using the
function.

$.ajaxSetup()

This example, using no options, loads the contents of the current
page, but does nothing with the result. To use the result, you can
implement one of the callback functions.
The jqXHR Object
The jQuery XMLHttpRequest (jqXHR) object returned by

$.ajax()

as of jQuery 1.5 is a superset of the browser's native
XMLHttpRequest object. For example, it contains responseText and
responseXML properties, as well as a getResponseHeader() method.
When the transport mechanism is something other than
XMLHttpRequest (for example, a script tag for a JSONP request) the
jqXHR object simulates native XHR functionality where possible.
As of jQuery 1.5.1, the jqXHR object also contains the
overrideMimeType() method (it was available in jQuery 1.4.x, as well,
but was temporarily removed in jQuery 1.5). The
.overrideMimeType() method may be used in the beforeSend()
callback function, for example, to modify the response content-type
header:
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$.ajax({
url: "http://fiddle.jshell.net/favicon.png",
beforeSend: function ( xhr ) {
xhr.overrideMimeType("text/plain; charset=x-user-de
}
}).done(function ( data ) {
if( console && console.log ) {
console.log("Sample of data:", data.slice(0
}
});

The jqXHR objects returned by $.ajax() as of jQuery 1.5 implement
the Promise interface, giving them all the properties, methods, and
behavior of a Promise (see Deferred object for more information).
These methods take one or more function arguments that are called
when the $.ajax() request terminates. This allows you to assign
multiple callbacks on a single request, and even to assign callbacks
after the request may have completed. (If the request is already
complete, the callback is fired immediately.) Available Promise
methods of the jqXHR object include:
jqXHR.done(function(data, textStatus, jqXHR) {});
An alternative construct to the success callback option, the
.done() method replaces the deprecated jqXHR.success()

method. Refer to

deferred.done()

for implementation details.

jqXHR.fail(function(jqXHR, textStatus, errorThrown) {});
An alternative construct to the error callback option, the .fail()
method replaces the deprecated .error() method. Refer to
deferred.fail() for implementation details.
jqXHR.always(function(data|jqXHR, textStatus,
jqXHR|errorThrown) { });
An alternative construct to the complete callback option, the
.always() method replaces the deprecated .complete() method.
In response to a successful request, the function's arguments
are the same as those of .done() : data, textStatus, and the
jqXHR object. For failed requests the arguments are the same
as those of .fail() : the jqXHR object, textStatus, and
errorThrown. Refer to deferred.always() for implementation
details.
jqXHR.then(function(data, textStatus, jqXHR) {},
function(jqXHR, textStatus, errorThrown) {});
Incorporates the functionality of the .done() and .fail()
methods, allowing (as of jQuery 1.8) the underlying Promise to
be manipulated. Refer to deferred.then() for implementation
details.

Deprecation Notice: The jqXHR.success() ,
jqXHR.error() , and jqXHR.complete() callbacks are
deprecated as of jQuery 1.8. To prepare
your code for their eventual removal, use
jqXHR.done() , jqXHR.fail() , and jqXHR.always()
instead.
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// Assign handlers immediately after making the request
// and remember the jqxhr object for this request
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var jqxhr = $.ajax( "example.php" )
.done(function() { alert("success"); })
.fail(function() { alert("error"); })
.always(function() { alert("complete"); });
// perform other work here ...

// Set another completion function for the request abov
jqxhr.always(function() { alert("second complete"

The this reference within all callbacks is the object in the context
option passed to $.ajax in the settings; if context is not specified,
this is a reference to the Ajax settings themselves.
For backward compatibility with XMLHttpRequest , a
expose the following properties and methods:

jqXHR

object will

readyState
status
statusText

and/or responseText when the underlying request
responded with xml and/or text, respectively
responseXML

setRequestHeader(name, value) which departs from the standard
by replacing the old value with the new one rather than
concatenating the new value to the old one
getAllResponseHeaders()
getResponseHeader()
statusCode()
abort()

No

onreadystatechange mechanism is provided, however, since done ,
fail , always , and statusCode cover all conceivable requirements.

Callback Function Queues
The

beforeSend , error , dataFilter , success

and

complete

options all

accept callback functions that are invoked at the appropriate times.
As of jQuery 1.5, the fail and done , and, as of jQuery 1.6, always
callback hooks are first-in, first-out managed queues, allowing for
more than one callback for each hook. See Deferred object
methods, which are implemented internally for these $.ajax()
callback hooks.
The callback hooks provided by
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$.ajax()

are as follows:

callback option is invoked; it receives the jqXHR
object and the settings object as parameters.
error callback option is invoked, if the request fails. It
receives the jqXHR , a string indicating the error type, and an
exception object if applicable. Some built-in errors will provide
a string as the exception object: "abort", "timeout", "No
Transport".
dataFilter callback option is invoked immediately upon
successful receipt of response data. It receives the returned
data and the value of dataType , and must return the (possibly
altered) data to pass on to success .
success callback option is invoked, if the request succeeds. It
receives the returned data, a string containing the success
code, and the jqXHR object.
Promise callbacks — .done() , .fail() , .always() , and
.then() — are invoked, in the order they are registered.
complete callback option fires, when the request finishes,
whether in failure or success. It receives the jqXHR object, as
well as a string containing the success or error code.
beforeSend

Data Types
The $.ajax() function relies on the server to provide information
about the retrieved data. If the server reports the return data as
XML, the result can be traversed using normal XML methods or
jQuery's selectors. If another type is detected, such as HTML in the
example above, the data is treated as text.
Different data handling can be achieved by using the
option. Besides plain xml , the dataType can be html ,
script , or text .

dataType
json , jsonp ,

The text and xml types return the data with no processing. The
data is simply passed on to the success handler, either through the
responseText or responseXML property of the jqXHR object,
respectively.
Note: We must ensure that the MIME type reported by the web
server matches our choice of dataType . In particular, XML must be
declared by the server as text/xml or application/xml for consistent
results.
If html is specified, any embedded JavaScript inside the retrieved
data is executed before the HTML is returned as a string. Similarly,
script will execute the JavaScript that is pulled back from the
server, then return nothing.
The json type parses the fetched data file as a JavaScript object
and returns the constructed object as the result data. To do so, it
uses jQuery.parseJSON() when the browser supports it; otherwise it
uses a Function constructor. Malformed JSON data will throw a
parse error (see json.org for more information). JSON data is
convenient for communicating structured data in a way that is
concise and easy for JavaScript to parse. If the fetched data file
exists on a remote server, specify the jsonp type instead.
The jsonp type appends a query string parameter of callback=? to
the URL. The server should prepend the JSON data with the
callback name to form a valid JSONP response. We can specify a
parameter name other than callback with the jsonp option to
$.ajax() .
Note: JSONP is an extension of the JSON format, requiring some
server-side code to detect and handle the query string parameter.
More information about it can be found in the original post detailing
its use.
When data is retrieved from remote servers (which is only possible
using the script or jsonp data types), the error callbacks and
global events will never be fired.
Sending Data to the Server
By default, Ajax requests are sent using the GET HTTP method. If
the POST method is required, the method can be specified by

setting a value for the type option. This option affects how the
contents of the data option are sent to the server. POST data will
always be transmitted to the server using UTF-8 charset, per the
W3C XMLHTTPRequest standard.
The

data option can contain either a query string of the form
key1=value1&key2=value2 , or an object of the form {key1: 'value1',
key2: 'value2'} . If the latter form is used, the data is converted into
a query string using jQuery.param() before it is sent. This processing
can be circumvented by setting processData to false . The

processing might be undesirable if you wish to send an XML object
to the server; in this case, change the contentType option from
application/x-www-form-urlencoded to a more appropriate MIME type.
Advanced Options
The

global option prevents handlers registered using .ajaxSend() ,
.ajaxError() , and similar methods from firing when this request

would trigger them. This can be useful to, for example, suppress a
loading indicator that was implemented with .ajaxSend() if the
requests are frequent and brief. With cross-domain script and
JSONP requests, the global option is automatically set to false . See
the descriptions of these methods below for more details. See the
descriptions of these methods below for more details.
If the server performs HTTP authentication before providing a
response, the user name and password pair can be sent via the
username and password options.
Ajax requests are time-limited, so errors can be caught and handled
to provide a better user experience. Request timeouts are usually
either left at their default or set as a global default using
$.ajaxSetup() rather than being overridden for specific requests with
the timeout option.
By default, requests are always issued, but the browser may serve
results out of its cache. To disallow use of the cached results, set
cache to false . To cause the request to report failure if the asset has
not been modified since the last request, set ifModified to true .
The scriptCharset allows the character set to be explicitly specified
for requests that use a <script> tag (that is, a type of script or

jsonp ).

This is useful if the script and host page have differing
character sets.
The first letter in Ajax stands for "asynchronous," meaning that the
operation occurs in parallel and the order of completion is not
guaranteed. The async option to $.ajax() defaults to true ,
indicating that code execution can continue after the request is
made. Setting this option to false (and thus making the call no
longer asynchronous) is strongly discouraged, as it can cause the
browser to become unresponsive.
The $.ajax() function returns the XMLHttpRequest object that it
creates. Normally jQuery handles the creation of this object
internally, but a custom function for manufacturing one can be
specified using the xhr option. The returned object can generally be
discarded, but does provide a lower-level interface for observing and
manipulating the request. In particular, calling .abort() on the object
will halt the request before it completes.
At present, due to a bug in Firefox where .getAllResponseHeaders()
returns the empty string although .getResponseHeader('ContentType') returns a non-empty string, automatically decoding JSON
CORS responses in Firefox with jQuery is not supported.
A workaround to this is possible by overriding
jQuery.ajaxSettings.xhr as follows:
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var _super = jQuery.ajaxSettings.xhr;
jQuery.ajaxSettings.xhr = function () {
var xhr = _super(),
getAllResponseHeaders = xhr.getAllResponseHeaders
xhr.getAllResponseHeaders = function () {
if ( getAllResponseHeaders() ) {
return getAllResponseHeaders();
}
var allHeaders = "";

$( ["Cache-Control", "Content-Language", "Content-T
"Expires", "Last-Modified", "Pragma"] )

14
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.each(function (i, header_name) {
if ( xhr.getResponseHeader( header_name ) ) {
allHeaders += header_name + ": " + xhr.getRespo
}
return allHeaders;
});
};
return xhr;
};

Extending Ajax
As of jQuery 1.5, jQuery's Ajax implementation includes prefilters,
transports, and converters that allow you to extend Ajax with a great
deal of flexibility.
Using Converters
converters support mapping data types to other data types.
If, however, you want to map a custom data type to a known type
(e.g json ), you must add a correspondance between the response
Content-Type and the actual data type using the contents option:
$.ajax()
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$.ajaxSetup({
contents: {
mycustomtype: /mycustomtype/
},
converters: {
"mycustomtype json": function ( result ) {
// do stuff
return newresult;
}
}
});

This extra object is necessary because the response Content-Types
and data types never have a strict one-to-one correspondance
(hence the regular expression).
To convert from a supported type (e.g text , json ) to a custom data
type and back again, use another pass-through converter:
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$.ajaxSetup({
contents: {
mycustomtype: /mycustomtype/
},
converters: {
"text mycustomtype": true,
"mycustomtype json": function ( result ) {
// do stuff
return newresult;
}
}
});

The above now allows passing from
mycustomtype to json .

text

to

mycustomtype

and then

Additional Notes:
Due to browser security restrictions, most "Ajax" requests are
subject to the same origin policy; the request can not
successfully retrieve data from a different domain, subdomain,
or protocol.
Script and JSONP requests are not subject to the same origin
policy restrictions.

Examples:
Save some data to the server and notify the
user once it's complete.
Example:
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$.ajax({
type: "POST",
url: "some.php",
data: { name: "John", location: "Boston" }
}).done(function( msg ) {
alert( "Data Saved: " + msg );
});

Example:
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Retrieve the latest version of an HTML page.

$.ajax({
url: "test.html",
cache: false
}).done(function( html ) {
$("#results").append(html);
});

Send an xml document as data to the server.
By setting the processData option to false , the
automatic conversion of data to strings is prevented.
Example:
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var xmlDocument = [create xml document];
var xmlRequest = $.ajax({
url: "page.php",
processData: false,
data: xmlDocument
});

7
8

xmlRequest.done(handleResponse);

Send an id as data to the server, save some
data to the server, and notify the user once it's
complete. If the request fails, alert the user.
Example:
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var menuId = $("ul.nav").first().attr("id");
var request = $.ajax({
url: "script.php",
type: "POST",
data: {id : menuId},
dataType: "html"
});
request.done(function(msg) {
$("#log").html( msg );
});
request.fail(function(jqXHR, textStatus) {
alert( "Request failed: " + textStatus );
});

Example:
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Load and execute a JavaScript file.

$.ajax({
type: "GET",
url: "test.js",
dataType: "script"
});
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jQuery.ajaxPrefilter()
Categories: Ajax > Low-Level Interface

jQuery.ajaxPrefilter( [dataTypes ], handler(options,
originalOptions, jqXHR) )
Returns: undefined
Description: Handle custom Ajax options or modify
existing options before each request is sent and before
they are processed by $.ajax() .
version added: 1.5
jQuery.ajaxPrefilter( [dataTypes ],
handler(options, originalOptions, jqXHR) )
dataTypes
Type: String
An optional string containing one or more space-separated
dataTypes
handler(options, originalOptions, jqXHR)
Type: Function()
A handler to set default values for future Ajax requests.
A typical prefilter registration using

$.ajaxPrefilter()

looks like this:

$.ajaxPrefilter( function( options, originalOptions, jqX
// Modify options, control originalOptions, store jqXH
});
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where:
options

are the request options

are the options as provided to the ajax method,
unmodified and, thus, without defaults from ajaxSettings
originalOptions

jqXHR

is the jqXHR object of the request

Prefilters are a perfect fit when custom options need to be handled.
Given the following code, for example, a call to $.ajax() would
automatically abort a request to the same URL if the custom

abortOnRetry
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option is set to

true :

var currentRequests = {};

$.ajaxPrefilter(function( options, originalOptions, jqX
if ( options.abortOnRetry ) {
if ( currentRequests[ options.url ] ) {
currentRequests[ options.url ].abort();
}
currentRequests[ options.url ] = jqXHR;
}
});

Prefilters can also be used to modify existing options. For example,
the following proxies cross-domain requests through
http://mydomain.net/proxy/:
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$.ajaxPrefilter( function( options ) {
if ( options.crossDomain ) {
options.url = "http://mydomain.net/proxy/" + encodeU
options.crossDomain = false;
}
});

If the optional dataTypes argument is supplied, the prefilter will be
only be applied to requests with the indicated dataTypes. For
example, the following only applies the given prefilter to JSON and
script requests:
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$.ajaxPrefilter( "json script", function( options, origi
// Modify options, control originalOptions, store jqXH
});

The $.ajaxPrefilter() method can also redirect a request to another
dataType by returning that dataType. For example, the following sets
a request as "script" if the URL has some specific properties defined
in a custom isActuallyScript() function:
1
2
3
4
5

$.ajaxPrefilter(function( options ) {
if ( isActuallyScript( options.url ) ) {
return "script";
}
});

This would ensure not only that the request is considered "script" but
also that all the prefilters specifically attached to the script dataType
would be applied to it.
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jQuery.ajaxSetup()
Categories: Ajax > Low-Level Interface

jQuery.ajaxSetup( options )

Returns:

Description: Set default values for future Ajax requests.
jQuery.ajaxSetup( options )

version added: 1.1

options
Type: PlainObject
A set of key/value pairs that configure the default Ajax request.
All options are optional.
For details on the settings available for

$.ajaxSetup() ,

see

$.ajax() .

All subsequent Ajax calls using any function will use the new
settings, unless overridden by the individual calls, until the next
invocation of $.ajaxSetup() .
For example, the following sets a default for the
before pinging the server repeatedly:
1
2
3

url

parameter

$.ajaxSetup({
url: 'ping.php'
});

Now each time an Ajax request is made, the "ping.php" URL will be
used automatically:
1
2
3
4

$.ajax({
// url not set here; uses ping.php
data: {'name': 'Dan'}
});

Note: Global callback functions should be

set with their respective global Ajax event
handler methods— .ajaxStart() , .ajaxStop() ,
.ajaxComplete() , .ajaxError() , .ajaxSuccess() , .ajaxSend()
—rather than within the options object for
$.ajaxSetup() .

Example:
Sets the defaults for Ajax requests to the url
"/xmlhttp/", disables global handlers and uses POST
instead of GET. The following Ajax requests then sends
some data without having to set anything else.
1
2
3
4
5
6
7

$.ajaxSetup({
url: "/xmlhttp/",
global: false,
type: "POST"
});
$.ajax({ data: myData });
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jQuery.ajaxTransport()
Categories: Ajax > Low-Level Interface

jQuery.ajaxTransport( dataType, handler(options,
originalOptions, jqXHR) )
Returns: undefined
Description: Creates an object that handles the actual
transmission of Ajax data.
version added: 1.5
jQuery.ajaxTransport( dataType,
handler(options, originalOptions, jqXHR) )
dataType
Type: String
A string identifying the data type to use
handler(options, originalOptions, jqXHR)
Type: Function()
A handler to return the new transport object to use with the data
type provided in the first argument.
A transport is an object that provides two methods, send and abort ,
that are used internally by $.ajax() to issue requests. A transport is
the most advanced way to enhance $.ajax() and should be used
only as a last resort when prefilters and converters are insufficient.
Since each request requires its own transport object instance,
transports cannot be registered directly. Therefore, you should
provide a function that returns a transport instead.
Transports factories are registered using
registration looks like this:
1
2
3
4
5
6
7

$.ajaxTransport() .

A typical

$.ajaxTransport( function( options, originalOptions, jq
if( /* transportCanHandleRequest */ ) {
return {
send: function( headers, completeCallback ) {
/* send code */
},
abort: function() {

8
9
10
11
12

/* abort code */
}
};
}
});

where:
options

are the request options

are the options as provided to the ajax method,
unmodified and, thus, without defaults from ajaxSettings
jqXHR is the jqXHR object of the request
originalOptions

is an object of (key-value) request headers that the
transport can transmit if it supports it
completeCallback is the callback used to notify ajax of the
completion of the request
headers

completeCallback

has the following signature:

function( status, statusText, responses, headers ) {}

1

where:
is the HTTP status code of the response, like 200 for a
typical success, or 404 for when the resource is not found.
statusText is the statusText of the response.
status

(Optional) is An object containing dataType/value that
contains the response in all the formats the transport could
provide (for instance, a native XMLHttpRequest object would
set reponses to { xml: XMLData, text: textData } for a
response that is an XML document)
headers (Optional) is a string containing all the response
headers if the transport has access to them (akin to what
XMLHttpRequest.getAllResponseHeaders() would provide).
responses

Just like prefilters, a transport's factory function can be attached to a
specific dataType:
1
2
3

$.ajaxTransport( "script", function( options, originalOp
/* Will only be called for script requests */
});

The following example shows how a minimal image transport could
be implemented:
1
2
3
4
5
6
7
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$.ajaxTransport( "image", function( s ) {
if ( s.type === "GET" && s.async ) {
var image;
return {
send: function( _ , callback ) {
image = new Image();

function done( status ) {
if ( image ) {
var statusText = ( status == 200 ) ?
tmp = image;
image = image.onreadystatechange = image.on
callback( status, statusText, { image: tmp
}
}
image.onreadystatechange = image.onload =
done( 200 );
};
image.onerror = function() {

26
27
28
29
30
31
32
33
34
35
36
37
38
39

done( 404 );
};
image.src = s.url;
},

abort: function() {
if ( image ) {
image = image.onreadystatechange = image.oner
}
}
};
}
});

Handling Custom Data Types
The jQuery Ajax implementation comes with a set of standard
dataTypes, such as text, json, xml, and html.
Use the converters option in $.ajaxSetup() to augment or modify the
data type conversion strategies used by $.ajax() .
The unminified jQuery source itself includes a list of default
converters, which effectively illustrates how they can be used:
1
2
3
4
5
6
7
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// List of data converters
// 1) key format is "source_type destination_type"
//
(a single space in-between)
// 2) the catchall symbol "*" can be used for source_ty
converters: {
// Convert anything to text
"* text": window.String,
// Text to html (true = no transformation)
"text html": true,

12
13
14
15
16
17
18

// Evaluate text as a json expression
"text json": jQuery.parseJSON,
// Parse text as xml
"text xml": jQuery.parseXML
}

When you specify a converters option globally in $.ajaxSetup() or
per call in $.ajax() , the object will map onto the default converters,
overwriting those you specify and leaving the others intact.
For example, the jQuery source uses
converter for "text script":
1
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3
4
5
6
7
8
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$.ajaxSetup()

to add a

jQuery.ajaxSetup({
accepts: {
script: "text/javascript, application/javascript"
},
contents: {
script: /javascript/
},
converters: {
"text script": jQuery.globalEval
}
});
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jQuery.boxModel
Categories: Utilities

jQuery.boxModel

Returns: Boolean
version deprecated: 1.3

Description: Deprecated in jQuery 1.3 (see
jQuery.support). States if the current page, in the user's
browser, is being rendered using the W3C CSS Box
Model.
jQuery.boxModel

version added: 1.0

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

Returns the box model for the iframe.

<!DOCTYPE html>
<html>
<head>
<style>
p { color:blue; margin:20px; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
</p>
<script>
$("p").html("The box model for this iframe is: <span>"
jQuery.boxModel + "</span>");
</script>
</body>
</html>

Demo
Example:

Returns false if the page is in Quirks Mode in
Internet Explorer
1

$.boxModel

Result:

1

false
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jQuery.browser
Categories: Properties > Properties of the Global jQuery Object | Utilities

Contents:
jQuery.browser
jQuery.browser.version

jQuery.browser

Returns: PlainObject
version deprecated: 1.3, removed: 1.9

Description: Contains flags for the useragent, read from
navigator.userAgent. We recommend against using
this property; please try to use feature detection
instead (see jQuery.support). jQuery.browser may be
moved to a plugin in a future release of jQuery.
jQuery.browser

version added: 1.0

The $.browser property provides information about the web browser
that is accessing the page, as reported by the browser itself. It
contains flags for each of the four most prevalent browser classes
(Internet Explorer, Mozilla, Webkit, and Opera) as well as version
information.
Available flags are:
webkit (as of jQuery 1.4)
safari (deprecated)
opera
msie
mozilla
This property is available immediately. It is therefore safe to use it to
determine whether or not to call $(document).ready() . The $.browser
property is deprecated in jQuery 1.3, and its functionality may be
moved to a team-supported plugin in a future release of jQuery.
Because $.browser uses navigator.userAgent to determine the
platform, it is vulnerable to spoofing by the user or misrepresentation
by the browser itself. It is always best to avoid browser-specific code
entirely where possible. The $.support property is available for
detection of support for particular features rather than relying on
$.browser .

Examples:
Example:
1
2
3
4

Show the browser info.

jQuery.each(jQuery.browser, function(i, val) {
$("<div>" + i + " : <span>" + val + "</span>")
.appendTo( document.body );
});

Returns true if the current useragent is some
version of Microsoft's Internet Explorer.
Example:

1

$.browser.msie;

Example:

Alerts "this is WebKit!" only for WebKit

browsers
1
2
3

if ($.browser.webkit) {
alert( "this is webkit!" );
}

Alerts "Do stuff for Firefox 3" only for Firefox
3 browsers.
Example:

1
2
3
4

var ua = $.browser;
if ( ua.mozilla && ua.version.slice(0,3) == "1.9"
alert( "Do stuff for firefox 3" );
}

Set a CSS property that's specific to a
particular browser.
Example:

1
2
3
4
5

if ( $.browser.msie ) {
$("#div ul li").css( "display","inline" );
} else {
$("#div ul li").css( "display","inline-table"
}

jQuery.browser.version

Returns: String
version deprecated: 1.3, removed: 1.9

Description: The version number of the rendering
engine for the user's browser.
jQuery.browser.version

version added: 1.1.3

Here are some typical results:
Internet Explorer: 6.0, 7.0, 8.0
Mozilla/Firefox/Flock/Camino: 1.7.12, 1.8.1.3, 1.9
Opera: 10.06, 11.01
Safari/Webkit: 312.8, 418.9
Note that IE8 claims to be 7 in Compatibility View.

Examples:
Returns the version number of the rendering
engine used by the user's current browser. For
example, FireFox 4 returns 2.0 (the version of the
Gecko rendering engine it utilizes).
Example:

1
2

$("p").html( "The version number of the rendering engine
$.browser.version + "</span>" );

Alerts the version of IE's rendering engine
that is being used:
Example:

1
2
3

if ( $.browser.msie ) {
alert( $.browser.version );
}

Often you only care about the "major
number," the whole number, which you can get by
using JavaScript's built-in parseInt() function:
Example:

1
2
3

if ( $.browser.msie ) {
alert( parseInt($.browser.version, 10) );
}
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jQuery.Callbacks()
Categories: Callbacks Object

jQuery.Callbacks( flags )

Returns: Callbacks

Description: A multi-purpose callbacks list object that
provides a powerful way to manage callback lists.
jQuery.Callbacks( flags )

version added: 1.7

flags
Type: String
An optional list of space-separated flags that change how the
callback list behaves.
The $.Callbacks() function is internally used to provide the base
functionality behind the jQuery $.ajax() and $.Deferred()
components. It can be used as a similar base to define functionality
for new components.
$.Callbacks() supports a number of methods including
callbacks.add() , callbacks.remove() , callbacks.fire() and
callbacks.disable() .

Getting started
The following are two sample methods named
1
2
3
4
5
6
7
8

fn1

and

fn2 :

function fn1( value ) {
console.log( value );
}
function fn2( value ) {
fn1("fn2 says: " + value);
return false;
}

These can be added as callbacks to a
as follows:

$.Callbacks

list and invoked

1
2
3
4
5
6
7
8
9
10

var callbacks = $.Callbacks();
callbacks.add( fn1 );
// outputs: foo!
callbacks.fire( "foo!" );
callbacks.add( fn2 );
// outputs: bar!, fn2 says: bar!
callbacks.fire( "bar!" );

The result of this is that it becomes simple to construct complex lists
of callbacks where input values can be passed through to as many
functions as needed with ease.
Two specific methods were being used above: .add() and .fire() .
The .add() method supports adding new callbacks to the callback
list, while the .fire() method executes the added functions and
provides a way to pass arguments to be processed by the callbacks
in the same list.
Another method supported by $.Callbacks is .remove() , which has
the ability to remove a particular callback from the callback list.
Here"s a practical example of .remove() being used:
1
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var callbacks = $.Callbacks();
callbacks.add( fn1 );
// outputs: foo!
callbacks.fire( "foo!" );
callbacks.add( fn2 );
// outputs: bar!, fn2 says: bar!
callbacks.fire( "bar!" );
callbacks.remove( fn2 );
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// only outputs foobar, as fn2 has been removed.
callbacks.fire( "foobar" );

Supported Flags
The flags argument is an optional argument to $.Callbacks() ,
structured as a list of space-separated strings that change how the
callback list behaves (eg. $.Callbacks( "unique stopOnFalse" ) ).

Possible flags:
once :

Ensures the callback list can only be fired once (like a
Deferred).
memory : Keeps track of previous values and will call any callback
added after the list has been fired right away with the latest
"memorized" values (like a Deferred).
unique : Ensures a callback can only be added once (so there
are no duplicates in the list).
stopOnFalse : Interrupts callings when a callback returns false.
By default a callback list will act like an event callback list and can
be "fired" multiple times.
For examples of how

flags

should ideally be used, see below:

$.Callbacks( "once" )

1
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:

var callbacks = $.Callbacks( "once" );
callbacks.add( fn1 );
callbacks.fire( "foo" );
callbacks.add( fn2 );
callbacks.fire( "bar" );
callbacks.remove( fn2 );
callbacks.fire( "foobar" );
/*
output:
foo
*/

$.Callbacks( "memory" )

1
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:

var callbacks = $.Callbacks( "memory" );
callbacks.add( fn1 );
callbacks.fire( "foo" );
callbacks.add( fn2 );
callbacks.fire( "bar" );
callbacks.remove( fn2 );
callbacks.fire( "foobar" );
/*
output:
foo
fn2 says:foo
bar
fn2 says:bar
foobar
*/

$.Callbacks( "unique" )
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:

var callbacks = $.Callbacks( "unique" );
callbacks.add( fn1 );
callbacks.fire( "foo" );
callbacks.add( fn1 ); // repeat addition
callbacks.add( fn2 );
callbacks.fire( "bar" );
callbacks.remove( fn2 );
callbacks.fire( "foobar" );
/*
output:
foo
bar
fn2 says:bar
foobar
*/

$.Callbacks( "stopOnFalse" )
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:

function fn1( value ){
console.log( value );
return false;
}
function fn2( value ){
fn1( "fn2 says: " + value );
return false;
}
var callbacks = $.Callbacks( "stopOnFalse" );
callbacks.add( fn1 );
callbacks.fire( "foo" );
callbacks.add( fn2 );
callbacks.fire( "bar" );
callbacks.remove( fn2 );
callbacks.fire( "foobar" );
/*
output:
foo
bar
foobar
*/

Because $.Callbacks() supports a list of flags rather than just one,
setting several flags has a cumulative effect similar to "&&". This
means it's possible to combine flags to create callback lists that, say,
both are unique and ensure if list was already fired, adding more
callbacks will have it called with the latest fired value (i.e.
$.Callbacks("unique memory") ).

$.Callbacks( 'unique memory' )
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:

function fn1( value ) {
console.log( value );
return false;
}
function fn2( value ) {
fn1( "fn2 says: " + value );
return false;
}
var callbacks = $.Callbacks( "unique memory" );
callbacks.add( fn1 );
callbacks.fire( "foo" );
callbacks.add( fn1 ); // repeat addition
callbacks.add( fn2 );
callbacks.fire( "bar" );
callbacks.add( fn2 );
callbacks.fire( "baz" );
callbacks.remove( fn2 );
callbacks.fire( "foobar" );
/*
output:
foo
fn2 says:foo
bar
fn2 says:bar
baz
fn2 says:baz
foobar
*/

Flag combinations with $.Callbacks() are internally in jQuery for the
.done() and .fail() functions on a Deferred — both of which use
$.Callbacks('memory once') .
The methods of $.Callbacks can also be detached, should there be
a need to define short-hand versions for convenience:
var callbacks = $.Callbacks(),
add = callbacks.add,
remove = callbacks.remove,
fire = callbacks.fire;

1
2
3
4
5
6
7
8

add( fn1 );
fire( "hello world" );
remove( fn1 );

$.Callbacks, $.Deferred and Pub/Sub
The general idea behind pub/sub (Publish/Subscribe, or, the
Observer pattern) is the promotion of loose coupling in applications.
Rather than single objects calling on the methods of other objects,
an object instead subscribes to a specific task or activity of another
object and is notified when it occurs. Observers are also called
Subscribers, and we refer to the object being observed as the
Publisher (or the subject). Publishers notify subscribers when events
occur.
To demonstrate the component-creation capabilities of
$.Callbacks() , it's possible to implement a Pub/Sub system using
only callback lists. Using $.Callbacks as a topics queue, a system
for publishing and subscribing to topics can be implemented as
follows:
1
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var topics = {};
jQuery.Topic = function( id ) {
var callbacks,
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method,
topic = id && topics[ id ];
if ( !topic ) {
callbacks = jQuery.Callbacks();
topic = {
publish: callbacks.fire,
subscribe: callbacks.add,
unsubscribe: callbacks.remove
};
if ( id ) {
topics[ id ] = topic;
}
}
return topic;
};

This can then be used by parts of your application to publish and
subscribe to events of interest quite easily:
1
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// Subscribers
$.Topic( "mailArrived" ).subscribe( fn1 );
$.Topic( "mailArrived" ).subscribe( fn2 );
$.Topic( "mailSent" ).subscribe( fn1 );
// Publisher
$.Topic( "mailArrived" ).publish( "hello world!"
$.Topic( "mailSent" ).publish( "woo! mail!" );
//
//
//
//

Here, "hello world!" gets pushed to fn1 and fn2
when the "mailArrived" notification is published
with "woo! mail!" also being pushed to fn1 when
the "mailSent" notification is published.

/*
output:

17
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hello world!
fn2 says: hello world!
woo! mail!
*/

While this is useful, the implementation can be taken further. Using
$.Deferreds , it's possible to ensure publishers only publish
notifications for subscribers once particular tasks have been
completed (resolved). See the below code sample for some further
comments on how this could be used in practice:
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// subscribe to the mailArrived notification
$.Topic( "mailArrived" ).subscribe( fn1 );
// create a new instance of Deferreds
var dfd = $.Deferred();
// define a new topic (without directly publishing)
var topic = $.Topic( "mailArrived" );
// when the deferred has been resolved, publish a
// notification to subscribers
dfd.done( topic.publish );

// Here the Deferred is being resolved with a message
// that will be passed back to subscribers. It's possib
// easily integrate this into a more complex routine
// (eg. waiting on an ajax call to complete) so that
// messages are only published once the task has actual
// finished.
dfd.resolve( "it's been published!" );
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jQuery.contains()
Categories: Utilities

jQuery.contains( container, contained )

Returns: Boolean

Description: Check to see if a DOM element is a
descendant of another DOM element.
jQuery.contains( container, contained version added: 1.4
)
container
Type: Element
The DOM element that may contain the other element.
contained
Type: Element
The DOM element that may be contained by (a descendant of)
the other element.
The $.contains() method returns true if the DOM element provided
by the second argument is a descendant of the DOM element
provided by the first argument, whether it is a direct child or nested
more deeply. Otherwise, it returns false . Only element nodes are
supported; if the second argument is a text or comment node,
$.contains() will return false .

Note: The first argument must be a DOM
element, not a jQuery object or plain
JavaScript object.

Example:
Check if an element is a descendant of another.
1
2

$.contains( document.documentElement, document.body );
$.contains( document.body, document.documentElement );
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jQuery.cssHooks
Categories: CSS

jQuery.cssHooks

Returns: Object

Description: Hook directly into jQuery to override how
particular CSS properties are retrieved or set, normalize
CSS property naming, or create custom properties.
jQuery.cssHooks

version added: 1.4.3

The $.cssHooks object provides a way to define functions for getting
and setting particular CSS values. It can also be used to create new
cssHooks for normalizing CSS3 features such as box shadows and
gradients.
For example, some versions of Webkit-based browsers require webkit-border-radius to set the border-radius on an element, while
earlier Firefox versions require -moz-border-radius . A css hook can
normalize these vendor-prefixed properties to let .css() accept a
single, standard property name ( border-radius , or with DOM
property syntax, borderRadius ).
In addition to providing fine-grained control over how specific style
properties are handled, $.cssHooks also extends the set of properties
available to the .animate() method.
Defining a new css hook is straight-forward. The skeleton template
below can serve as a guide to creating your own.
1
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(function($) {
// first, check to see if cssHooks are supported
if ( !$.cssHooks ) {
// if not, output an error message
throw("jQuery 1.4.3 or above is required for this p
return;
}

// Wrap in a document ready call, because jQuery writ
// cssHooks at this time and will blow away your func
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// if they exist.
$(function () {
$.cssHooks["someCSSProp"] = {
get: function( elem, computed, extra ) {
// handle getting the CSS property
},
set: function( elem, value ) {
// handle setting the CSS value
}
};
});
})(jQuery);

Feature Testing
Before normalizing a vendor-specific CSS property, first determine
whether the browser supports the standard property or a vendorprefixed variation. For example, to check for support of the borderradius property, see if any variation is a member of a temporary
element's style object.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

(function($) {
function styleSupport( prop ) {
var vendorProp, supportedProp,

// capitalize first character of the prop to te
capProp = prop.charAt(0).toUpperCase() + prop.s
prefixes = [ "Moz", "Webkit", "O", "ms"
div = document.createElement( "div" );
if ( prop in div.style ) {
// browser supports standard CSS property name
supportedProp = prop;
} else {

16
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// otherwise test support for vendor-prefixed pro
for ( var i = 0; i < prefixes.length; i++ ) {
vendorProp = prefixes[i] + capProp;
if ( vendorProp in div.style ) {
supportedProp = vendorProp;
break;
}
}
}
// avoid memory leak in IE
div = null;
// add property to $.support so it can be accessed
$.support[ prop ] = supportedProp;
return supportedProp;
}

// call the function, e.g. testing for "border-radius
styleSupport( "borderRadius" );
})(jQuery);

Defining a complete css hook
To define a complete css hook, combine the support test with a
filled-out version of the skeleton template provided in the first
example:
1
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(function($) {
if ( !$.cssHooks ) {
throw("jQuery 1.4.3+ is needed for this plugin to w
return;
}
function styleSupport( prop ) {
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var vendorProp, supportedProp,
capProp = prop.charAt(0).toUpperCase() + prop.s
prefixes = [ "Moz", "Webkit", "O", "ms"
div = document.createElement( "div" );
if ( prop in div.style ) {
supportedProp = prop;
} else {
for ( var i = 0; i < prefixes.length; i++ ) {
vendorProp = prefixes[i] + capProp;
if ( vendorProp in div.style ) {
supportedProp = vendorProp;
break;
}
}
}
div = null;
$.support[ prop ] = supportedProp
return supportedProp;
}
var borderRadius = styleSupport( "borderRadius"
// Set cssHooks only for browsers that
// support a vendor-prefixed border radius
if ( borderRadius && borderRadius !== "borderRadius"
$.cssHooks.borderRadius = {
get: function( elem, computed, extra ) {
return $.css( elem, borderRadius );
},
set: function( elem, value) {
elem.style[ borderRadius ] = value;
}
};
}
})(jQuery);

You can then set the border radius in a supported browser using
either the DOM (camelCased) style or the CSS (hyphenated) style:
1
2

$("#element").css("borderRadius", "10px");
$("#another").css("border-radius", "20px");

If the browser lacks support for any form of the CSS property,
vendor-prefixed or not, the style is not applied to the element.
However, if the browser supports a proprietary alternative, it can be
applied to the cssHooks instead.
1
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(function($) {
// feature test for support of a CSS property
// and a proprietary alternative
// ...

if ( $.support.someCSSProp && $.support.someCSSProp !=

// Set cssHooks for browsers that
// support only a vendor-prefixed someCSSProp
$.cssHooks.someCSSProp = {
get: function( elem, computed, extra ) {
return $.css( elem, $.support.someCSSProp );
},
set: function( elem, value) {
elem.style[ $.support.someCSSProp ] = value;
}
};
} else if ( supportsProprietaryAlternative ) {
$.cssHooks.someCSSProp = {
get: function( elem, computed, extra ) {
// Handle crazy conversion from the proprietary
},
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set: function( elem, value ) {
// Handle crazy conversion to the proprietary a
}
}
}
})(jQuery);

Special units
By default, jQuery adds a "px" unit to the values passed to the
.css() method. This behavior can be prevented by adding the
property to the jQuery.cssNumber object
1

$.cssNumber["someCSSProp"] = true;

Animating with cssHooks
A css hook can also hook into jQuery's animation mechanism by
adding a property to the jQuery.fx.step object:
1
2
3

$.fx.step["someCSSProp"] = function(fx){
$.cssHooks["someCSSProp"].set( fx.elem, fx.now + fx.un
};

Note that this works best for simple numeric-value animations. More
custom code may be required depending on the CSS property, the
type of value it returns, and the animation's complexity.
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jQuery.data()
Categories: Data | Utilities

Store arbitrary data associated with the specified element and/or return
the value that was set.
Contents:
jQuery.data( element, key, value )
jQuery.data( element, key, value )
jQuery.data( element, key )
jQuery.data( element, key )
jQuery.data( element )

jQuery.data( element, key, value )

Returns: Object

Description: Store arbitrary data associated with the
specified element. Returns the value that was set.
jQuery.data( element, key, value )

version added: 1.2.3

element
Type: Element
The DOM element to associate with the data.
key
Type: String
A string naming the piece of data to set.
value
Type: Object
The new data value.
Note: This is a low-level method; a more convenient
available.

.data()

is also

The jQuery.data() method allows us to attach data of any type to
DOM elements in a way that is safe from circular references and
therefore free from memory leaks. jQuery ensures that the data is
removed when DOM elements are removed via jQuery methods,
and when the user leaves the page. We can set several distinct
values for a single element and retrieve them later:
1
2

jQuery.data(document.body, 'foo', 52);
jQuery.data(document.body, 'bar', 'test');

Note: this method currently does not provide cross-platform support
for setting data on XML documents, as Internet Explorer does not
allow data to be attached via expando properties.

Example:
Store then retrieve a value from the div element.
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Demo

<!DOCTYPE html>
<html>
<head>
<style>
div { color:blue; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
The values stored were
<span></span>
and
<span></span>
</div>
<script>var div = $("div")[0];
jQuery.data(div, "test", { first: 16, last:
$("span:first").text(jQuery.data(div, "test"
$("span:last").text(jQuery.data(div, "test"
</body>
</html>

jQuery.data( element, key )

Returns: Object

Description: Returns value at named data store for the
element, as set by jQuery.data(element, name, value) , or the
full data store for the element.
jQuery.data( element, key )

version added: 1.2.3

element
Type: Element
The DOM element to query for the data.
key
Type: String
Name of the data stored.

jQuery.data( element )

version added: 1.4

element
Type: Element
The DOM element to query for the data.
Note: This is a low-level method; a more convenient
available.

.data()

is also

Regarding HTML5 data-* attributes: This low-level method does
NOT retrieve the data-* attributes unless the more convenient
.data() method has already retrieved them.
The jQuery.data() method allows us to attach data of any type to
DOM elements in a way that is safe from circular references and
therefore from memory leaks. We can retrieve several distinct values
for a single element one at a time, or as a set:
1
2

alert(jQuery.data( document.body, 'foo' ));
alert(jQuery.data( document.body ));

The above lines alert the data values that were set on the

body

element. If nothing was set on that element, an empty string is
returned.
Calling jQuery.data(element) retrieves all of the element's associated
values as a JavaScript object. Note that jQuery itself uses this
method to store data for internal use, such as event handlers, so do
not assume that it contains only data that your own code has stored.
Note: this method currently does not provide cross-platform support
for setting data on XML documents, as Internet Explorer does not
allow data to be attached via expando properties.

Example:
Get the data named "blah" stored at for an element.
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<!DOCTYPE html>
<html>
<head>
<style>
div { margin:5px; background:yellow; }
button { margin:5px; font-size:14px; }
p { margin:5px; color:blue; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>A div</div>
<button>Get "blah" from the div</button>
<button>Set "blah" to "hello"</button>
<button>Set "blah" to 86</button>
<button>Remove "blah" from the div</button>
<p>The "blah" value of this div is <span>?</span
<script>
$("button").click(function(e) {
var value, div = $("div")[0];
switch ($("button").index(this)) {
case 0 :
value = jQuery.data(div, "blah");
break;
case 1 :
jQuery.data(div, "blah", "hello");
value = "Stored!";
break;
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case 2 :
jQuery.data(div, "blah", 86);
value = "Stored!";
break;
case 3 :
jQuery.removeData(div, "blah");
value = "Removed!";
break;
}
$("span").text("" + value);
});
</script>
</body>
</html>

Demo
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jQuery.Deferred()
Categories: Deferred Object

jQuery.Deferred( [beforeStart ] )

Returns: Deferred

Description: A constructor function that returns a
chainable utility object with methods to register multiple
callbacks into callback queues, invoke callback queues,
and relay the success or failure state of any
synchronous or asynchronous function.
jQuery.Deferred( [beforeStart ] )

version added: 1.5

beforeStart
Type: Function( Deferred deferred )
A function that is called just before the constructor returns.
The
The

jQuery.Deferred() constructor
new operator is optional.

creates a new Deferred object.

The jQuery.Deferred method can be passed an optional function,
which is called just before the constructor returns and is passed the
constructed deferred object as both the this object and as the first
argument to the function. The called function can attach callbacks
using deferred.then() , for example.
A Deferred object starts in the pending state. Any callbacks added to
the object with deferred.then() , deferred.always() , deferred.done() ,
or deferred.fail() are queued to be executed later. Calling
deferred.resolve() or deferred.resolveWith() transitions the
Deferred into the resolved state and immediately executes any
doneCallbacks that are set. Calling deferred.reject() or
deferred.rejectWith() transitions the Deferred into the rejected state
and immediately executes any failCallbacks that are set. Once the
object has entered the resolved or rejected state, it stays in that
state. Callbacks can still be added to the resolved or rejected
Deferred — they will execute immediately.
Enhanced Callbacks with jQuery Deferred
In JavaScript it is common to invoke functions that optionally accept
callbacks that are called within that function. For example, in

versions prior to jQuery 1.5, asynchronous processes such as
jQuery.ajax() accept callbacks to be invoked some time in the nearfuture upon success, error, and completion of the ajax request.
introduces several enhancements to the way
callbacks are managed and invoked. In particular, jQuery.Deferred()
provides flexible ways to provide multiple callbacks, and these
callbacks can be invoked regardless of whether the original callback
dispatch has already occurred. jQuery Deferred is based on the
CommonJS Promises/A design.
jQuery.Deferred()

One model for understanding Deferred is to think of it as a chainaware function wrapper. The deferred.then() , deferred.always() ,
deferred.done() , and deferred.fail() methods specify the functions
to be called and the deferred.resolve(args) or deferred.reject(args)
methods "call" the functions with the arguments you supply. Once
the Deferred has been resolved or rejected it stays in that state; a
second call to deferred.resolve() , for example, is ignored. If more
functions are added by deferred.then() , for example, after the
Deferred is resolved, they are called immediately with the arguments
previously provided.
In most cases where a jQuery API call returns a Deferred or
Deferred-compatible object, such as jQuery.ajax() or jQuery.when() ,
you will only want to use the deferred.then() , deferred.done() , and
deferred.fail() methods to add callbacks to the Deferred's queues.
The internals of the API call or code that created the Deferred will
invoke deferred.resolve() or deferred.reject() on the deferred at
some point, causing the appropriate callbacks to run.
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jQuery.dequeue()
Categories: Data | Utilities

jQuery.dequeue( element [, queueName ] )
Returns: undefined
Description: Execute the next function on the queue for
the matched element.
jQuery.dequeue( element [,
queueName ] )

version added: 1.3

element
Type: Element
A DOM element from which to remove and execute a queued
function.
queueName
Type: String
A string containing the name of the queue. Defaults to
standard effects queue.

fx ,

the

Note: This is a low-level method, you should probably use
.dequeue() instead.
When jQuery.dequeue() is called, the next function on the queue is
removed from the queue, and then executed. This function should in
turn (directly or indirectly) cause jQuery.dequeue() to be called, so
that the sequence can continue.

Example:
Use jQuery.dequeue() to end a custom queue function
which allows the queue to keep going.
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Demo

<!DOCTYPE html>
<html>
<head>
<style>div {
margin:3px; width:50px; position:absolute;
height:50px; left:10px; top:30px;
background-color:yellow;
}
div.red { background-color:red; } </style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Start</button> <div></div>
<script>$("button").click(function () {
$("div").animate({left:'+=200px'}, 2000);
$("div").animate({top:'0px'}, 600);
$("div").queue(function () {
$(this).toggleClass("red");
$.dequeue( this );
});
$("div").animate({left:'10px', top:'30px'}, 700
});</script>
</body>
</html>
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jQuery.each()
Categories: Utilities

jQuery.each( collection, callback(indexInArray,
valueOfElement) )
Returns: Object
Description: A generic iterator function, which can be
used to seamlessly iterate over both objects and arrays.
Arrays and array-like objects with a length property
(such as a function's arguments object) are iterated by
numeric index, from 0 to length-1. Other objects are
iterated via their named properties.
version added: 1.0
jQuery.each( collection,
callback(indexInArray, valueOfElement) )
collection
Type: Object
The object or array to iterate over.
callback(indexInArray, valueOfElement)
Type: Function()
The function that will be executed on every object.
The $.each() function is not the same as $(selector).each(), which is
used to iterate, exclusively, over a jQuery object. The $.each()
function can be used to iterate over any collection, whether it is an
object or an array. In the case of an array, the callback is passed an
array index and a corresponding array value each time. (The value
can also be accessed through the this keyword, but Javascript will
always wrap the this value as an Object even if it is a simple string
or number value.) The method returns its first argument, the object
that was iterated.
1
2
3

$.each([52, 97], function(index, value) {
alert(index + ': ' + value);
});

This produces two messages:

0: 52 1: 97
If an object is used as the collection, the callback is passed a keyvalue pair each time:
1
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var obj = {
"flammable": "inflammable",
"duh": "no duh"
};
$.each( obj, function( key, value ) {
alert( key + ": " + value );
});

Once again, this produces two messages:
flammable: inflammable
duh: no duh
We can break the $.each() loop at a particular iteration by making
the callback function return false . Returning non-false is the same
as a continue statement in a for loop; it will skip immediately to the
next iteration.

Examples:
Iterates through the array displaying each
number as both a word and numeral
Example:
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<!DOCTYPE html>
<html>
<head>
<style>
div { color:blue; }
div#five { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="one"></div>
<div id="two"></div>
<div id="three"></div>
<div id="four"></div>
<div id="five"></div>
<script>
var arr = [ "one", "two", "three", "four",
var obj = { one:1, two:2, three:3, four:4, five:

jQuery.each(arr, function() {
$("#" + this).text("Mine is " + this + "."
return (this != "three"); // will stop running af
});
jQuery.each(obj, function(i, val) {
$("#" + i).append(document.createTextNode(
});
</script>
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</body>
</html>

Demo
Example:

Iterates over items in an array, accessing
both the current item and its index.
1
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$.each( ['a','b','c'], function(i, l){
alert( "Index #" + i + ": " + l );
});

Iterates over the properties in an object,
accessing both the current item and its key.
Example:

1
2
3

$.each( { name: "John", lang: "JS" }, function(k, v){
alert( "Key: " + k + ", Value: " + v );
});
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jQuery.error()
Categories: Internals

jQuery.error( message )

Returns:

Description: Takes a string and throws an exception
containing it.
jQuery.error( message )

version added: 1.4.1

message
Type: String
The message to send out.
This method exists primarily for plugin developers who wish to
override it and provide a better display (or more information) for the
error messages.

Example:
Override jQuery.error for display in Firebug.
1

jQuery.error = console.error;
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jQuery.extend()
Categories: Utilities

jQuery.extend( target [, object1 ] [, objectN ] )
Returns: Object
Description: Merge the contents of two or more objects
together into the first object.
jQuery.extend( target [, object1 ] [,
objectN ] )

version added: 1.0

target
Type: Object
An object that will receive the new properties if additional
objects are passed in or that will extend the jQuery namespace
if it is the sole argument.
object1
Type: Object
An object containing additional properties to merge in.
objectN
Type: Object
Additional objects containing properties to merge in.

jQuery.extend( [deep ], target,
object1 [, objectN ] )

version added: 1.1.4

deep
Type: Boolean
If true, the merge becomes recursive (aka. deep copy).
target
Type: Object
The object to extend. It will receive the new properties.
object1
Type: Object
An object containing additional properties to merge in.
objectN
Type: Object

Additional objects containing properties to merge in.
When two or more objects are supplied to $.extend() , properties
from all of the objects are added to the target object.
If only one argument is supplied to $.extend() , this means the target
argument was omitted. In this case, the jQuery object itself is
assumed to be the target. By doing this, you can add new functions
to the jQuery namespace. This can be useful for plugin authors
wishing to add new methods to JQuery.
Keep in mind that the target object (first argument) will be modified,
and will also be returned from $.extend() . If, however, you want to
preserve both of the original objects, you can do so by passing an
empty object as the target:
1

var object = $.extend({}, object1, object2);

The merge performed by $.extend() is not recursive by default; if a
property of the first object is itself an object or array, it will be
completely overwritten by a property with the same key in the
second object. The values are not merged. This can be seen in the
example below by examining the value of banana. However, by
passing true for the first function argument, objects will be
recursively merged.
Warning: Passing

false

for the first argument is not supported.

Undefined properties are not copied. However, properties inherited
from the object's prototype will be copied over. Properties that are an
object constructed via new MyCustomObject(args) , or built-in
JavaScript types such as Date or RegExp, are not re-constructed
and will appear as plain Objects in the resulting object or array.
On a deep extend, Object and Array are extended, but object
wrappers on primitive types such as String, Boolean, and Number
are not.
For needs that fall outside of this behavior, write a custom extend
method instead.

Examples:
Example:
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Merge two objects, modifying the first.

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="log"></div>
<script>
var object1 = {
apple: 0,
banana: {weight: 52, price: 100},
cherry: 97
};
var object2 = {
banana: {price: 200},
durian: 100
};
/* merge object2 into object1 */
$.extend(object1, object2);

var printObj = typeof JSON != "undefined" ? JSON.stringi
var arr = [];
$.each(obj, function(key, val) {
var next = key + ": ";
next += $.isPlainObject(val) ? printObj(val) : val;
arr.push( next );
});
return "{ " + arr.join(", ") + " }";
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};
$("#log").append( printObj(object1) );
</script>
</body>
</html>

Demo
Example:

Merge two objects recursively, modifying the

first.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="log"></div>
<script>
var object1 = {
apple: 0,
banana: {weight: 52, price: 100},
cherry: 97
};
var object2 = {
banana: {price: 200},
durian: 100
};
/* merge object2 into object1, recursively */
$.extend(true, object1, object2);
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var printObj = typeof JSON != "undefined" ? JSON.stringi
var arr = [];
$.each(obj, function(key, val) {
var next = key + ": ";
next += $.isPlainObject(val) ? printObj(val) : val;
arr.push( next );
});
return "{ " + arr.join(", ") + " }";
};
$("#log").append( printObj(object1) );
</script>
</body>
</html>

Demo
Example:

Merge defaults and options, without
modifying the defaults. This is a common plugin
development pattern.
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="log"></div>
<script>
var defaults = { validate: false, limit: 5, name:
var options = { validate: true, name: "bar" };

/* merge defaults and options, without modifying default
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var settings = $.extend({}, defaults, options);

var printObj = typeof JSON != "undefined" ? JSON.stringi
var arr = [];
$.each(obj, function(key, val) {
var next = key + ": ";
next += $.isPlainObject(val) ? printObj(val) : val;
arr.push( next );
});
return "{ " + arr.join(", ") + " }";
};

$("#log").append( "<div><b>defaults -- </b>" + printObj(
$("#log").append( "<div><b>options -- </b>" + printObj(o
$("#log").append( "<div><b>settings -- </b>" + printObj(
</script>
</body>
</html>

Demo
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jQuery.fx.interval
Categories: Effects > Custom | Properties > Properties of the Global jQuery Object

jQuery.fx.interval

Returns: Number

Description: The rate (in milliseconds) at which
animations fire.
jQuery.fx.interval

version added: 1.4.3

This property can be manipulated to adjust the number of frames per
second at which animations will run. The default is 13 milliseconds.
Making this a lower number could make the animations run
smoother in faster browsers (such as Chrome) but there may be
performance and CPU implications of doing so.
Since jQuery uses one global interval, no animation should be
running or all animations should stop for the change of this property
to take effect.
Note: jQuery.fx.interval currently has no effect in browsers that
support the requestAnimationFrame property, such as Google Chrome
11. This behavior is subject to change in a future release.

Example:
Cause all animations to run with less frames.
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<!DOCTYPE html>
<html>
<head>
<style>
div { width:50px; height:30px; margin:5px; float
background:green; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><input type="button" value="Run"/></p>
<div></div>
<script>
jQuery.fx.interval = 100;
$("input").click(function(){
$("div").toggle( 3000 );
});
</script>
</body>
</html>

Demo
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jQuery.fx.off
Categories: Effects > Custom | Properties > Properties of the Global jQuery Object

jQuery.fx.off

Returns: Boolean

Description: Globally disable all animations.
jQuery.fx.off

version added: 1.3

When this property is set to true , all animation methods will
immediately set elements to their final state when called, rather than
displaying an effect. This may be desirable for a couple reasons:
jQuery is being used on a low-resource device.
Users are encountering accessibility problems with the
animations (see the article Turn Off Animation for more
information).
Animations can be turned back on by setting the property to

false .

Example:
Toggle animation on and off
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Demo

<!DOCTYPE html>
<html>
<head>
<style>
div { width:50px; height:30px; margin:5px;
background:green; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><input type="button" value="Run"/> <button
<div></div>
<script>
var toggleFx = function() {
$.fx.off = !$.fx.off;
};
toggleFx();
$("button").click(toggleFx)
$("input").click(function(){
$("div").toggle("slow");
});
</script>
</body>
</html>
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jQuery.get()
Categories: Ajax > Shorthand Methods

jQuery.get( url [, data ] [, success(data, textStatus, jqXHR)
] [, dataType ] )
Returns: jqXHR
Description: Load data from the server using a HTTP
GET request.
version added: 1.0
jQuery.get( url [, data ] [,
success(data, textStatus, jqXHR) ] [, dataType ] )
url
Type: String
A string containing the URL to which the request is sent.
data
Type: PlainObject or String
A plain object or string that is sent to the server with the
request.
success(data, textStatus, jqXHR)
Type: Function()
A callback function that is executed if the request succeeds.
dataType
Type: String
The type of data expected from the server. Default: Intelligent
Guess (xml, json, script, or html).
This is a shorthand Ajax function, which is equivalent to:
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$.ajax({
url: url,
data: data,
success: success,
dataType: dataType
});

success

callback function is passed the returned data, which will

be an XML root element, text string, JavaScript file, or JSON object,
depending on the MIME type of the response. It is also passed the
text status of the response.
As of jQuery 1.5, the success callback function is also passed a
"jqXHR" object (in jQuery 1.4, it was passed the XMLHttpRequest
object). However, since JSONP and cross-domain GET requests do
not use XHR, in those cases the jqXHR and textStatus parameters
passed to the success callback are undefined.
Most implementations will specify a success handler:
1
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$.get('ajax/test.html', function(data) {
$('.result').html(data);
alert('Load was performed.');
});

This example fetches the requested HTML snippet and inserts it on
the page.
The jqXHR Object
As of jQuery 1.5, all of jQuery's Ajax methods return a superset of
the XMLHTTPRequest object. This jQuery XHR object, or "jqXHR,"
returned by $.get() implements the Promise interface, giving it all
the properties, methods, and behavior of a Promise (see Deferred
object for more information). The jqXHR.done() (for success),
jqXHR.fail() (for error) , and jqXHR.always() (for completion,
whether success or error) methods take a function argument that is
called when the request terminates. For information about the
arguments this function receives, see the jqXHR Object section of
the $.ajax() documentation.
The Promise interface also allows jQuery's Ajax methods, including
$.get() , to chain multiple .done() , .fail() , and .always() callbacks
on a single request, and even to assign these callbacks after the
request may have completed. If the request is already complete, the
callback is fired immediately.
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// Assign handlers immediately after making the request
// and remember the jqxhr object for this request
var jqxhr = $.get("example.php", function() {
alert("success");
})
.done(function() { alert("second success"); })
.fail(function() { alert("error"); })
.always(function() { alert("finished"); });
// perform other work here ...

// Set another completion function for the request abov
jqxhr.always(function(){ alert("second finished"

Deprecation Notice
The jqXHR.success() , jqXHR.error() , and jqXHR.complete() callback
methods introduced in jQuery 1.5 are deprecated as of jQuery 1.8.
To prepare your code for their eventual removal, use jqXHR.done() ,
jqXHR.fail() , and jqXHR.always() instead.

Additional Notes:
Due to browser security restrictions, most "Ajax" requests are
subject to the same origin policy; the request can not
successfully retrieve data from a different domain, subdomain,
or protocol.
If a request with jQuery.get() returns an error code, it will fail
silently unless the script has also called the global .ajaxError()
method. Alternatively, as of jQuery 1.5, the .error() method of
the jqXHR object returned by jQuery.get() is also available for
error handling.
Script and JSONP requests are not subject to the same origin
policy restrictions.

Examples:
Request the test.php page, but ignore the
return results.
Example:

1

$.get("test.php");

Request the test.php page and send some
additional data along (while still ignoring the return
results).
Example:

1

$.get("test.php", { name: "John", time: "2pm" } );

Pass arrays of data to the server (while still
ignoring the return results).
Example:

1

$.get("test.php", { 'choices[]': ["Jon", "Susan"

Alert the results from requesting test.php
(HTML or XML, depending on what was returned).
Example:

1
2
3

$.get("test.php", function(data) {
alert("Data Loaded: " + data);
});

Alert the results from requesting test.cgi with
an additional payload of data (HTML or XML, depending
on what was returned).
Example:

1
2
3
4

$.get("test.cgi", { name: "John", time: "2pm" })
.done(function(data) {
alert("Data Loaded: " + data);
});

Get the test.php page contents, which has
been returned in json format (<?php echo
json_encode(array("name"=>"John","time"=>"2pm"));
?>), and add it to the page.
Example:

1
2
3
4
5

$.get("test.php",
function(data) {
$('body').append( "Name: " + data.name ) // John
.append( "Time: " + data.time ); // 2pm
}, "json");

POWERED BYHERONOTE
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jQuery.getJSON()
Categories: Ajax > Shorthand Methods

jQuery.getJSON( url [, data ] [, success(data, textStatus,
jqXHR) ] )
Returns: jqXHR
Description: Load JSON-encoded data from the server
using a GET HTTP request.
jQuery.getJSON( url [, data ] [,
success(data, textStatus, jqXHR) ] )

version added: 1.0

url
Type: String
A string containing the URL to which the request is sent.
data
Type: PlainObject
A plain object or string that is sent to the server with the
request.
success(data, textStatus, jqXHR)
Type: Function()
A callback function that is executed if the request succeeds.
This is a shorthand Ajax function, which is equivalent to:
1
2
3
4
5
6

$.ajax({
dataType: "json",
url: url,
data: data,
success: success
});

Data that is sent to the server is appended to the URL as a query
string. If the value of the data parameter is a plain object, it is
converted to a string and url-encoded before it is appended to the
URL.
Most implementations will specify a success handler:

1
2
3
4
5
6
7
8
9
10
11
12

$.getJSON('ajax/test.json', function(data) {
var items = [];
$.each(data, function(key, val) {
items.push('<li id="' + key + '">' + val +
});
$('<ul/>', {
'class': 'my-new-list',
html: items.join('')
}).appendTo('body');
});

This example, of course, relies on the structure of the JSON file:
1
2
3
4
5

{
"one": "Singular sensation",
"two": "Beady little eyes",
"three": "Little birds pitch by my doorstep"
}

Using this structure, the example loops through the requested data,
builds an unordered list, and appends it to the body.
The success callback is passed the returned data, which is typically
a JavaScript object or array as defined by the JSON structure and
parsed using the $.parseJSON() method. It is also passed the text
status of the response.
As of jQuery 1.5, the success callback function receives a "jqXHR"
object (in jQuery 1.4, it received the XMLHttpRequest object).
However, since JSONP and cross-domain GET requests do not use
XHR, in those cases the jqXHR and textStatus parameters passed
to the success callback are undefined.

Important: As of jQuery 1.4, if the JSON
file contains a syntax error, the request will
usually fail silently. Avoid frequent handediting of JSON data for this reason. JSON
is a data-interchange format with syntax
rules that are stricter than those of
JavaScript's object literal notation. For
example, all strings represented in JSON,
whether they are properties or values, must
be enclosed in double-quotes. For details
on the JSON format, see http://json.org/.
JSONP
If the URL includes the string "callback=?" (or similar, as defined by
the server-side API), the request is treated as JSONP instead. See
the discussion of the jsonp data type in $.ajax() for more details.
The jqXHR Object
As of jQuery 1.5, all of jQuery's Ajax methods return a superset of
the XMLHTTPRequest object. This jQuery XHR object, or "jqXHR,"
returned by $.getJSON() implements the Promise interface, giving it
all the properties, methods, and behavior of a Promise (see Deferred
object for more information). For convenience and consistency with
the callback names used by $.ajax() , it provides .error() ,
.success() , and .complete() methods. These methods take a
function argument that is called when the request terminates, and
the function receives the same arguments as the correspondinglynamed $.ajax() callback.
The Promise interface in jQuery 1.5 also allows jQuery's Ajax
methods, including $.getJSON() , to chain multiple .success() ,
.complete() , and .error() callbacks on a single request, and even

to assign these callbacks after the request may have completed. If
the request is already complete, the callback is fired immediately.
1
2
3
4
5
6
7
8
9
10
11
12
13

// Assign handlers immediately after making the request
// and remember the jqxhr object for this request
var jqxhr = $.getJSON("example.json", function() {
alert("success");
})
.success(function() { alert("second success"); })
.error(function() { alert("error"); })
.complete(function() { alert("complete"); });
// perform other work here ...

// Set another completion function for the request abov
jqxhr.complete(function(){ alert("second complete"

Additional Notes:
Due to browser security restrictions, most "Ajax" requests are
subject to the same origin policy; the request can not
successfully retrieve data from a different domain, subdomain,
or protocol.
Script and JSONP requests are not subject to the same origin
policy restrictions.

Examples:
Loads the four most recent cat pictures from
the Flickr JSONP API.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
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22
23
24
25
26

Demo

<!DOCTYPE html>
<html>
<head>
<style>img{ height: 100px; float: left; }</style
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="images">

</div>
<script>
$.getJSON("http://api.flickr.com/services/feeds/photos_p
{
tags: "mount rainier",
tagmode: "any",
format: "json"
},
function(data) {
$.each(data.items, function(i,item){
$("<img/>").attr("src", item.media.m).appendTo(
if ( i == 3 ) return false;
});
});</script>
</body>
</html>

Load the JSON data from test.js and access a
name from the returned JSON data.
Example:

1
2
3

$.getJSON("test.js", function(json) {
alert("JSON Data: " + json.users[3].name);
});

Load the JSON data from test.js, passing
along additional data, and access a name from the
returned JSON data.
Example:

1
2
3

$.getJSON("test.js", { name: "John", time: "2pm"
alert("JSON Data: " + json.users[3].name);
});
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jQuery.getScript()
Categories: Ajax > Shorthand Methods

jQuery.getScript( url [, success(script, textStatus, jqXHR) ]
)
Returns: jqXHR
Description: Load a JavaScript file from the server
using a GET HTTP request, then execute it.
version added: 1.0
jQuery.getScript( url [,
success(script, textStatus, jqXHR) ] )
url
Type: String
A string containing the URL to which the request is sent.
success(script, textStatus, jqXHR)
Type: Function()
A callback function that is executed if the request succeeds.
This is a shorthand Ajax function, which is equivalent to:
1
2
3
4
5

$.ajax({
url: url,
dataType: "script",
success: success
});

The script is executed in the global context, so it can refer to other
variables and use jQuery functions. Included scripts can have some
impact on the current page.
Success Callback
The callback is fired once the script has been loaded but not
necessarily executed.
1

$(".result").html("<p>Lorem ipsum dolor sit amet.</p>"

Scripts are included and run by referencing the file name:
1
2
3
4
5
6

$.getScript("ajax/test.js", function(data, textStatus, j
console.log(data); //data returned
console.log(textStatus); //success
console.log(jqxhr.status); //200
console.log('Load was performed.');
});

Handling Errors
As of jQuery 1.5, you may use
1
2
3
4
5
6
7

.fail()

to account for errors:

$.getScript("ajax/test.js")
.done(function(script, textStatus) {
console.log( textStatus );
})
.fail(function(jqxhr, settings, exception) {
$( "div.log" ).text( "Triggered ajaxError handler."
});

Prior to jQuery 1.5, the global .ajaxError() callback event had to be
used in order to handle $.getScript() errors:
1
2
3
4
5

$( "div.log" ).ajaxError(function(e, jqxhr, settings, ex
if (settings.dataType=='script') {
$(this).text( "Triggered ajaxError handler."
}
});

Caching Responses
Be default, $.getScript() sets the cache setting to false . This
appends a timestamped query parameter to the request URL to
ensure that the browser downloads the script each time it is
requested. You can override this feature by setting the cache
property globally using $.ajaxSetup() :
1
2
3

$.ajaxSetup({
cache: true
});

Alternatively, you could define a new method that uses the more
flexible $.ajax() method.

Examples:
Define a $.cachedScript() method that allows
fetching a cached script:
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

jQuery.cachedScript = function(url, options) {

// allow user to set any option except for dataType, c
options = $.extend(options || {}, {
dataType: "script",
cache: true,
url: url
});

// Use $.ajax() since it is more flexible than $.getSc
// Return the jqXHR object so we can chain callbacks
return jQuery.ajax(options);
};

// Usage
$.cachedScript("ajax/test.js").done(function(script, tex
console.log( textStatus );
});

Load the official jQuery Color Animation
plugin dynamically and bind some color animations to
occur once the new functionality is loaded.
Example:

1
2
3
4
5

<!DOCTYPE html>
<html>
<head>
<style>
.block {

6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36

background-color: blue;
width: 150px;
height: 70px;
margin: 10px;
}</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="go">&raquo; Run</button>
<div class="block"></div>

<script>
(function() {
var url = "https://raw.github.com/jquery/jquery-color/
$.getScript(url, function() {
$("#go").click(function(){
$(".block")
.animate( { backgroundColor: "rgb(255, 180, 180)
.delay(500)
.animate( { backgroundColor: "olive" },
.delay(500)
.animate( { backgroundColor: "#00f" },
});
});
})();
</script>
</body>
</html>

Demo
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jQuery.globalEval()
Categories: Utilities

jQuery.globalEval( code )

Returns:

Description: Execute some JavaScript code globally.
jQuery.globalEval( code )

version added: 1.0.4

code
Type: String
The JavaScript code to execute.
This method behaves differently from using a normal JavaScript
eval() in that it's executed within the global context (which is
important for loading external scripts dynamically).

Example:
Execute a script in the global context.
1
2
3
4
5

function test(){
jQuery.globalEval("var newVar = true;")
}
test();
// newVar === true
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jQuery.grep()
Categories: Utilities

jQuery.grep( array, function(elementOfArray, indexInArray)
[, invert ] )
Returns: Array
Description: Finds the elements of an array which
satisfy a filter function. The original array is not affected.
version added: 1.0
jQuery.grep( array,
function(elementOfArray, indexInArray) [, invert ] )
array
Type: Array
The array to search through.
function(elementOfArray, indexInArray)
Type: Function()
The function to process each item against. The first argument to
the function is the item, and the second argument is the index.
The function should return a Boolean value. this will be the
global window object.
invert
Type: Boolean
If "invert" is false, or not provided, then the function returns an
array consisting of all elements for which "callback" returns true.
If "invert" is true, then the function returns an array consisting of
all elements for which "callback" returns false.
The $.grep() method removes items from an array as necessary so
that all remaining items pass a provided test. The test is a function
that is passed an array item and the index of the item within the
array. Only if the test returns true will the item be in the result array.
The filter function will be passed two arguments: the current array
item and its index. The filter function must return 'true' to include the
item in the result array.

Examples:
Filters the original array of numbers leaving
that are not 5 and have an index greater than 4. Then it
removes all 9s.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<!DOCTYPE html>
<html>
<head>
<style>
div { color:blue; }
p { color:green; margin:0; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div>
<p></p>
<span></span>
<script>
var arr = [ 1, 9, 3, 8, 6, 1, 5, 9, 4, 7, 3, 8,
$("div").text(arr.join(", "));
arr = jQuery.grep(arr, function(n, i){
return (n != 5 && i > 4);
});
$("p").text(arr.join(", "));
arr = jQuery.grep(arr, function (a) { return a !=
$("span").text(arr.join(", "));
</script>

30
31

</body>
</html>

Demo
Example:

Filter an array of numbers to include only
numbers bigger then zero.
1
2
3

$.grep( [0,1,2], function(n,i){
return n > 0;
});

Result:
1

[1, 2]

Filter an array of numbers to include
numbers that are not bigger than zero.
Example:

1
2
3

$.grep( [0,1,2], function(n,i){
return n > 0;
},true);

Result:
1

[0]

POWERED BYHERONOTE

A new version of this book is available!

jQuery.hasData()
Categories: Data

jQuery.hasData( element )

Returns: Boolean

Description: Determine whether an element has any
jQuery data associated with it.
jQuery.hasData( element )

version added: 1.5

element
Type: Element
A DOM element to be checked for data.
The jQuery.hasData() method provides a way to determine if an
element currently has any values that were set using jQuery.data() .
If no data is associated with an element (there is no data object at all
or the data object is empty), the method returns false ; otherwise it
returns true .
The primary advantage of jQuery.hasData(element) is that it does not
create and associate a data object with the element if none currently
exists. In contrast, jQuery.data(element) always returns a data object
to the caller, creating one if no data object previously existed.
Note that jQuery's event system uses the jQuery data API to store
event handlers. Therefore, binding an event to an element using
.on() , .bind() , .live() , .delegate() , or one of the shorthand event
methods also associates a data object with that element.

Example:
Set data on an element and see the results of
hasData.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Results: </p>
<script>
var $p = jQuery("p"), p = $p[0];
$p.append(jQuery.hasData(p)+" "); /* false */
$.data(p, "testing", 123);
$p.append(jQuery.hasData(p)+" "); /* true*/
$.removeData(p, "testing");
$p.append(jQuery.hasData(p)+" "); /* false */
$p.on('click', function() {});
$p.append(jQuery.hasData(p)+" "); /* true */
$p.off('click');
$p.append(jQuery.hasData(p)+" "); /* false */
</script>
</body>
</html>

Demo
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jQuery.holdReady()
Categories: Core

jQuery.holdReady( hold )

Returns: undefined

Description: Holds or releases the execution of jQuery's
ready event.
jQuery.holdReady( hold )

version added: 1.6

hold
Type: Boolean
Indicates whether the ready hold is being requested or released
The $.holdReady() method allows the caller to delay jQuery's ready
event. This advanced feature would typically be used by dynamic
script loaders that want to load additional JavaScript such as jQuery
plugins before allowing the ready event to occur, even though the
DOM may be ready. This method must be called early in the
document, such as in the <head> immediately after the jQuery script
tag. Calling this method after the ready event has already fired will
have no effect.
To delay the ready event, first call $.holdReady(true) . When the
ready event should be released to execute, call $.holdReady(false) .
Note that multiple holds can be put on the ready event, one for each
$.holdReady(true) call. The ready event will not actually fire until all
holds have been released with a corresponding number of
$.holdReady(false) calls and the normal document ready conditions
are met. (See ready for more information.)

Example:
Delay the ready event until a custom plugin has
loaded.
1
2
3
4

$.holdReady(true);
$.getScript("myplugin.js", function() {
$.holdReady(false);
});
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jQuery.inArray()
Categories: Utilities

jQuery.inArray( value, array [, fromIndex ] )
Returns: Number
Description: Search for a specified value within an
array and return its index (or -1 if not found).
jQuery.inArray( value, array [,
fromIndex ] )

version added: 1.2

value
Type: Anything
The value to search for.
array
Type: Array
An array through which to search.
fromIndex
Type: Number
The index of the array at which to begin the search. The default
is 0, which will search the whole array.
The $.inArray() method is similar to JavaScript's native .indexOf()
method in that it returns -1 when it doesn't find a match. If the first
element within the array matches value , $.inArray() returns 0.
Because JavaScript treats 0 as loosely equal to false (i.e. 0 == false,
but 0 !== false), if we're checking for the presence of value within
array , we need to check if it's not equal to (or greater than) -1.

Example:
Report the index of some elements in the array.
1
2
3
4
5
6
7
8
9
10
11
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23
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<!DOCTYPE html>
<html>
<head>
<style>
div { color:blue; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

<div>"John" found at <span></span></div>
<div>4 found at <span></span></div>
<div>"Karl" not found, so <span></span></div>
<div>"Pete" is in the array, but not at or after index 2
<script>var arr = [ 4, "Pete", 8, "John" ];
var $spans = $("span");
$spans.eq(0).text(jQuery.inArray("John", arr));
$spans.eq(1).text(jQuery.inArray(4, arr));
$spans.eq(2).text(jQuery.inArray("Karl", arr));
$spans.eq(3).text(jQuery.inArray("Pete", arr, 2
</script>
</body>
</html>

Demo
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jQuery.isArray()
Categories: Utilities

jQuery.isArray( obj )

Returns: boolean

Description: Determine whether the argument is an
array.
jQuery.isArray( obj )

version added: 1.3

obj
Type: Object
Object to test whether or not it is an array.
returns a Boolean indicating whether the object is a
JavaScript array (not an array-like object, such as a jQuery object).
$.isArray()

Example:
Finds out if the parameter is an array.
1
2
3
4
5
6
7
8
9
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
Is [] an Array? <b></b>
<script>$("b").append( "" + $.isArray([]) );</script
</body>
</html>

Demo
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jQuery.isEmptyObject()
Categories: Utilities

jQuery.isEmptyObject( object )

Returns: Boolean

Description: Check to see if an object is empty
(contains no enumerable properties).
jQuery.isEmptyObject( object )

version added: 1.4

object
Type: Object
The object that will be checked to see if it's empty.
As of jQuery 1.4 this method checks both properties on the object
itself and properties inherited from prototypes (in that it doesn't use
hasOwnProperty). The argument should always be a plain
JavaScript Object as other types of object (DOM elements, primitive
strings/numbers, host objects) may not give consistent results
across browsers. To determine if an object is a plain JavaScript
object, use $.isPlainObject()

Example:
Check an object to see if it's empty.
1
2

jQuery.isEmptyObject({}) // true
jQuery.isEmptyObject({ foo: "bar" }) // false
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jQuery.isFunction()
Categories: Utilities

jQuery.isFunction( obj )

Returns: boolean

Description: Determine if the argument passed is a
Javascript function object.
jQuery.isFunction( obj )

version added: 1.2

obj
Type: PlainObject
Object to test whether or not it is a function.
Note: As of jQuery 1.3, functions provided by the browser like
alert() and DOM element methods like getAttribute() are not
guaranteed to be detected as functions in browsers such as Internet
Explorer.

Examples:
Example:
1
2
3
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28
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30
31

Test a few parameter examples.

<!DOCTYPE html>
<html>
<head>
<style>
div { color:blue; margin:2px; font-size:14px;
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>jQuery.isFunction(objs[0]) = <span></span
<div>jQuery.isFunction(objs[1]) = <span></span
<div>jQuery.isFunction(objs[2]) = <span></span
<div>jQuery.isFunction(objs[3]) = <span></span
<div>jQuery.isFunction(objs[4]) = <span></span
<script>
function stub() {
}
var objs = [
function () {},
{ x:15, y:20 },
null,
stub,
"function"
];
jQuery.each(objs, function (i) {

32
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var isFunc = jQuery.isFunction(objs[i]);
$("span").eq(i).text(isFunc);
});
</script>
</body>
</html>

Demo
Example:
1

Finds out if the parameter is a function.

$.isFunction(function(){});

Result:
1

true
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jQuery.isNumeric()
Categories: Utilities

jQuery.isNumeric( value )

Returns: Boolean

Description: Determines whether its argument is a
number.
jQuery.isNumeric( value )

version added: 1.7

value
Type: PlainObject
The value to be tested.
The $.isNumeric() method checks whether its argument represents
a numeric value. If so, it returns true . Otherwise it returns false .
The argument can be of any type.

Example:
Sample return values of $.isNumeric with various
inputs.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

$.isNumeric("-10"); // true
$.isNumeric(16);
// true
$.isNumeric(0xFF);
// true
$.isNumeric("0xFF"); // true
$.isNumeric("8e5"); // true (exponential notation strin
$.isNumeric(3.1415); // true
$.isNumeric(+10);
// true
$.isNumeric(0144);
// true (octal integer literal)
$.isNumeric("");
// false
$.isNumeric({});
// false (empty object)
$.isNumeric(NaN);
// false
$.isNumeric(null);
// false
$.isNumeric(true);
// false
$.isNumeric(Infinity); // false
$.isNumeric(undefined); // false
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jQuery.isPlainObject()
Categories: Utilities

jQuery.isPlainObject( object )

Returns: Boolean

Description: Check to see if an object is a plain object
(created using "{}" or "new Object").
jQuery.isPlainObject( object )

version added: 1.4

object
Type: PlainObject
The object that will be checked to see if it's a plain object.
Note: Host objects (or objects used by browser host environments
to complete the execution environment of ECMAScript) have a
number of inconsistencies which are difficult to robustly feature
detect cross-platform. As a result of this, $.isPlainObject() may
evaluate inconsistently across browsers in certain instances.
An example of this is a test against
$.isPlainObject() as follows:
1

document.location

using

console.log($.isPlainObject(document.location));

which throws an invalid pointer exception in IE8. With this in mind,
it's important to be aware of any of the gotchas involved in using
$.isPlainObject() against older browsers. A couple basic examples
that do function correctly cross-browser can be found below.

Example:
Check an object to see if it's a plain object.
1
2

jQuery.isPlainObject({}) // true
jQuery.isPlainObject("test") // false
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jQuery.isWindow()
Categories: Utilities

jQuery.isWindow( obj )

Returns: boolean

Description: Determine whether the argument is a
window.
jQuery.isWindow( obj )

version added: 1.4.3

obj
Type: PlainObject
Object to test whether or not it is a window.
This is used in a number of places in jQuery to determine if we're
operating against a browser window (such as the current window or
an iframe).

Example:
Finds out if the parameter is a window.
1
2
3
4
5
6
7
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
Is 'window' a window? <b></b>
<script>$("b").append( "" + $.isWindow(window) );
</body>
</html>

Demo
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jQuery.isXMLDoc()
Categories: Utilities

jQuery.isXMLDoc( node )

Returns: Boolean

Description: Check to see if a DOM node is within an
XML document (or is an XML document).
jQuery.isXMLDoc( node )

version added: 1.1.4

node
Type: Element
The DOM node that will be checked to see if it's in an XML
document.

Example:
Check an object to see if it's in an XML document.
1
2

jQuery.isXMLDoc(document) // false
jQuery.isXMLDoc(document.body) // false

POWERED BYHERONOTE
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jQuery.makeArray()
Categories: Utilities

jQuery.makeArray( obj )

Returns: Array

Description: Convert an array-like object into a true
JavaScript array.
jQuery.makeArray( obj )

version added: 1.2

obj
Type: PlainObject
Any object to turn into a native Array.
Many methods, both in jQuery and in JavaScript in general, return
objects that are array-like. For example, the jQuery factory function
$() returns a jQuery object that has many of the properties of an
array (a length, the [] array access operator, etc.), but is not exactly
the same as an array and lacks some of an array's built-in methods
(such as .pop() and .reverse() ).
Note that after the conversion, any special features the object had
(such as the jQuery methods in our example) will no longer be
present. The object is now a plain array.

Examples:
Turn a collection of HTMLElements into an
Array of them.
Example:

1
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<!DOCTYPE html>
<html>
<head>
<style>
div { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>First</div>
<div>Second</div>
<div>Third</div>

<div>Fourth</div>
<script>
var elems = document.getElementsByTagName("div"
var arr = jQuery.makeArray(elems);
arr.reverse(); // use an Array method on list of dom
$(arr).appendTo(document.body);
</script>
</body>
</html>

Demo
Example:
1

Turn a jQuery object into an array
var obj = $('li');

var arr = $.makeArray(obj);

2
Result:
1
2

(typeof obj === 'object' && obj.jquery) === true
jQuery.isArray(arr) === true;
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jQuery.map()
Categories: Utilities

jQuery.map( array, callback(elementOfArray, indexInArray)
)
Returns: Array
Description: Translate all items in an array or object to
new array of items.
version added: 1.0
jQuery.map( array,
callback(elementOfArray, indexInArray) )
array
Type: Array
The Array to translate.
callback(elementOfArray, indexInArray)
Type: Function()
The function to process each item against. The first argument to
the function is the array item, the second argument is the index
in array The function can return any value. Within the function,
this refers to the global (window) object.

jQuery.map( arrayOrObject, callback( version added: 1.6
value, indexOrKey ) )
arrayOrObject
Type: Array or Object
The Array or Object to translate.
callback( value, indexOrKey )
Type: Function()
The function to process each item against. The first argument to
the function is the value; the second argument is the index or
key of the array or object property. The function can return any
value to add to the array. A returned array will be flattened into
the resulting array. Within the function, this refers to the global
(window) object.
If you wish to process a jQuery object — for example,
callback ); — use .map() instead.
The

$.map()

$('div').map(

method applies a function to each item in an array or

object and maps the results into a new array. Prior to jQuery 1.6,
$.map() supports traversing arrays only. As of jQuery 1.6 it also
traverses objects.
Array-like objects — those with a .length property and a value on
the .length - 1 index — must be converted to actual arrays before
being passed to $.map() . The jQuery library provides $.makeArray()
for such conversions.
1
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// The following object masquerades as an array.
var fakeArray = {"length": 1, 0: "Addy", 1: "Subtracty"
// Therefore, convert it to a real array
var realArray = $.makeArray( fakeArray )
// Now it can be used reliably with $.map()
$.map( realArray, function(val, i) {
// do something
});

The translation function that is provided to this method is called for
each top-level element in the array or object and is passed two
arguments: The element's value and its index or key within the array
or object.
The function can return:
the translated value, which will be mapped to the resulting array
null or undefined , to remove the item
an array of values, which will be flattened into the full array

Examples:
Example:
1
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Use $.map() to change the values of an array.

<!DOCTYPE html>
<html>
<head>
<style>
div { color:blue; }
p { color:green; margin:0; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div>
<p></p>
<span></span>
<script>
var arr = [ "a", "b", "c", "d", "e" ];
$("div").text(arr.join(", "));
arr = jQuery.map(arr, function(n, i){
return (n.toUpperCase() + i);
});
$("p").text(arr.join(", "));
arr = jQuery.map(arr, function (a) {
return a + a;
});
$("span").text(arr.join(", "));
</script>

32
33

</body>
</html>

Demo
Example:

Map the original array to a new one and add 4
to each value.
1
2
3

$.map( [0,1,2], function(n){
return n + 4;
});

Result:
1

[4, 5, 6]

Map the original array to a new one, adding 1
to each value if it is bigger then zero and removing it if
not.
Example:

1
2
3

$.map( [0,1,2], function(n){
return n > 0 ? n + 1 : null;
});

Result:
1

[2, 3]

Map the original array to a new one; each
element is added with its original value and the value
plus one.
Example:

1
2
3

$.map( [0,1,2], function(n){
return [ n, n + 1 ];
});

Result:
1

[0, 1, 1, 2, 2, 3]

Map the original object to a new array and
double each value.
Example:

1
2
3
4

var dimensions = { width: 10, height: 15, length:
dimensions = $.map( dimensions, function( value, index )
return value * 2;
});

Result:
1

[20, 30, 40]

Example:
1
2
3
4

Map an object's keys to an array.

var dimensions = { width: 10, height: 15, length:
var keys = $.map( dimensions, function( value, key ) {
return key;
});

Result:

1

["width", "height", "length"]

Map the original array to a new one; each
element is squared.
Example:

1
2
3

$.map( [0,1,2,3], function (a) {
return a * a;
});

Result:
1

[0, 1, 4, 9]

Map the original array to a new one,
removing numbers less than 50 by returning null and
subtracting 45 from the rest.
Example:

1
2
3

$.map( [0, 1, 52, 97], function (a) {
return (a > 50 ? a - 45 : null);
});

Result:
1

[7, 52]

Augment the resulting array by returning an
array inside the function.
Example:

1
2
3

var array = [0, 1, 52, 97];
array = $.map(array, function(a, index) {
return [a - 45, index];

4

});

Result:
1

[-45, 0, -44, 1, 7, 2, 52, 3]
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jQuery.merge()
Categories: Utilities

jQuery.merge( first, second )

Returns: Array

Description: Merge the contents of two arrays together
into the first array.
jQuery.merge( first, second )

version added: 1.0

first
Type: Array
The first array to merge, the elements of second added.
second
Type: Array
The second array to merge into the first, unaltered.
The $.merge() operation forms an array that contains all elements
from the two arrays. The orders of items in the arrays are preserved,
with items from the second array appended. The $.merge() function
is destructive. It alters the first parameter to add the items from the
second.
If you need the original first array, make a copy of it before calling
$.merge() . Fortunately, $.merge() itself can be used for this
duplication:
1

var newArray = $.merge([], oldArray);

This shortcut creates a new, empty array and merges the contents of
oldArray into it, effectively cloning the array.
Prior to jQuery 1.4, the arguments should be true Javascript Array
objects; use $.makeArray if they are not.

Examples:
Merges two arrays, altering the first
argument.
Example:

1

$.merge( [0,1,2], [2,3,4] )

Result:
1

[0,1,2,2,3,4]

Merges two arrays, altering the first
argument.
Example:

1

$.merge( [3,2,1], [4,3,2] )

Result:
1

[3,2,1,4,3,2]

Merges two arrays, but uses a copy, so the
original isn't altered.
Example:

1
2
3

var first = ['a','b','c'];
var second = ['d','e','f'];
$.merge( $.merge([],first), second);

Result:

1

["a","b","c","d","e","f"]
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jQuery.noConflict()
Categories: Core | Miscellaneous > Setup Methods

jQuery.noConflict( [removeAll ] )

Returns: Object

Description: Relinquish jQuery's control of the
variable.
jQuery.noConflict( [removeAll ] )

$

version added: 1.0

removeAll
Type: Boolean
A Boolean indicating whether to remove all jQuery variables
from the global scope (including jQuery itself).
Many JavaScript libraries use $ as a function or variable name, just
as jQuery does. In jQuery's case, $ is just an alias for jQuery , so all
functionality is available without using $ . If you need to use another
JavaScript library alongside jQuery, return control of $ back to the
other library with a call to $.noConflict() . Old references of $ are
saved during jQuery initialization; noConflict() simply restores
them.
If for some reason two versions of jQuery are loaded (which is not
recommended), calling $.noConflict(true) from the second version
will return the globally scoped jQuery variables to those of the first
version.
1
2
3
4
5
6

<script type="text/javascript" src="other_lib.js"
<script type="text/javascript" src="jquery.js"></
<script type="text/javascript">
$.noConflict();
// Code that uses other library's $ can follow here.
</script>

This technique is especially effective in conjunction with the
.ready() method's ability to alias the jQuery object, as within
callback passed to .ready() you can use $ if you wish without fear
of conflicts later:

1
2
3
4
5
6
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9

<script type="text/javascript" src="other_lib.js"
<script type="text/javascript" src="jquery.js"></
<script type="text/javascript">
$.noConflict();
jQuery(document).ready(function($) {
// Code that uses jQuery's $ can follow here.
});
// Code that uses other library's $ can follow here.
</script>

If necessary, you can free up the jQuery name as well by passing
true as an argument to the method. This is rarely necessary, and if
you must do this (for example, if you need to use multiple versions of
the jQuery library on the same page), you need to consider that
most plug-ins rely on the presence of the jQuery variable and may
not operate correctly in this situation.

Examples:
Map the original object that was referenced
by $ back to $.
Example:

1
2
3
4
5

jQuery.noConflict();
// Do something with jQuery
jQuery("div p").hide();
// Do something with another library's $()
$("content").style.display = 'none';

Revert the $ alias and then create and
execute a function to provide the $ as a jQuery alias
inside the function's scope. Inside the function the
original $ object is not available. This works well for
most plugins that don't rely on any other library.
Example:

1
2
3
4
5
6
7

jQuery.noConflict();
(function($) {
$(function() {
// more code using $ as alias to jQuery
});
})(jQuery);
// other code using $ as an alias to the other library

Create a different alias instead of jQuery to
use in the rest of the script.
Example:

1
2
3
4

var j = jQuery.noConflict();
// Do something with jQuery
j("div p").hide();
// Do something with another library's $()

5

$("content").style.display = 'none';

Completely move jQuery to a new
namespace in another object.
Example:

1
2

var dom = {};
dom.query = jQuery.noConflict(true);

Result:
1
2
3
4
5
6

// Do something with the new
dom.query("div p").hide();
// Do something with another
$("content").style.display =
// Do something with another
jQuery("div > p").hide();

jQuery
library's $()
'none';
version of jQuery

Load two versions of jQuery (not
recommended). Then, restore jQuery's globally scoped
variables to the first loaded jQuery.
Example:

1
2
3
4
5
6
7
8
9
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="log">
<h3>Before $.noConflict(true)</h3>
</div>
<script src="http://code.jquery.com/jquery-1.6.2.js"
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<script>
var $log = $( "#log" );

$log.append( "2nd loaded jQuery version ($): " + $.fn.jq

/*
Restore globally scoped jQuery variables to the first ve
(the newer version)
*/
jq162 = jQuery.noConflict(true);

$log.append( "<h3>After $.noConflict(true)</h3>"
$log.append( "1st loaded jQuery version ($): " + $.fn.jq
$log.append( "2nd loaded jQuery version (jq162): "
</script>
</body>
</html>

Demo
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jQuery.noop()
Categories: Utilities

jQuery.noop()

Returns: undefined

Description: An empty function.
jQuery.noop()

version added: 1.4

This method does not accept any arguments.
You can use this empty function when you wish to pass around a
function that will do nothing.
This is useful for plugin authors who offer optional callbacks; in the
case that no callback is given, something like jQuery.noop could
execute.
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jQuery.now()
Categories: Utilities

jQuery.now()

Returns: Number

Description: Return a number representing the current
time.
jQuery.now()

version added: 1.4.3

This method does not accept any arguments.
The $.now() method is a shorthand for the number returned by the
expression (new Date).getTime() .
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jQuery.param()
Categories: Miscellaneous > Collection Manipulation | Forms | Ajax > Helper Functions

jQuery.param( obj )

Returns: String

Description: Create a serialized representation of an
array or object, suitable for use in a URL query string or
Ajax request.
jQuery.param( obj )

version added: 1.2

obj
Type: Array or PlainObject
An array or object to serialize.

jQuery.param( obj, traditional )

version added: 1.4

obj
Type: Array or PlainObject
An array or object to serialize.
traditional
Type: Boolean
A Boolean indicating whether to perform a traditional "shallow"
serialization.
This function is used internally to convert form element values into a
serialized string representation (See .serialize() for more
information).
As of jQuery 1.3, the return value of a function is used instead of the
function as a String.
As of jQuery 1.4, the $.param() method serializes deep objects
recursively to accommodate modern scripting languages and
frameworks such as PHP and Ruby on Rails. You can disable this
functionality globally by setting jQuery.ajaxSettings.traditional =
true; .
If the object passed is in an Array, it must be an array of objects in
the format returned by .serializeArray()

1
2
3

[{name:"first",value:"Rick"},
{name:"last",value:"Astley"},
{name:"job",value:"Rock Star"}]

Note: Because some frameworks have
limited ability to parse serialized arrays,
developers should exercise caution when
passing an obj argument that contains
objects or arrays nested within another
array.
Note: Because there is no universally
agreed-upon specification for param strings,
it is not possible to encode complex data
structures using this method in a manner
that works ideally across all languages
supporting such input. Until such time that
there is, the $.param method will remain in its
current form.
In jQuery 1.4, HTML5 input elements are also serialized.
We can display a query string representation of an object and a URIdecoded version of the same as follows:
1
2
3

var myObject = {
a: {
one: 1,

4
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two: 2,
three: 3
},
b: [1,2,3]

};
var recursiveEncoded = $.param(myObject);
var recursiveDecoded = decodeURIComponent($.param(myObj
alert(recursiveEncoded);
alert(recursiveDecoded);

The values of
follows:

recursiveEncoded

and

recursiveDecoded

are alerted as

a%5Bone%5D=1&a%5Btwo%5D=2&a%5Bthree%5D=3&b%5B%5D=1&b%5B%5D
a[one]=1&a[two]=2&a[three]=3&b[]=1&b[]=2&b[]=3
To emulate the behavior of $.param() prior to jQuery 1.4, we can set
the traditional argument to true :
1
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var myObject = {
a: {
one: 1,
two: 2,
three: 3
},
b: [1,2,3]
};
var shallowEncoded = $.param(myObject, true);
var shallowDecoded = decodeURIComponent(shallowEncoded)
alert(shallowEncoded);
alert(shallowDecoded);

The values of

shallowEncoded

and

shallowDecoded

are alerted as

follows:
a=%5Bobject+Object%5D&b=1&b=2&b=3
a=[object+Object]&b=1&b=2&b=3

Examples:
Example:
1
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<!DOCTYPE html>
<html>
<head>
<style>div { color:red; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="results"></div>
<script>
var params = { width:1680, height:1050 };
var str = jQuery.param(params);
$("#results").text(str);
</script>
</body>
</html>

Demo
Example:
1
2
3
4
5
6
7
8

Serialize a key/value object.

Serialize a few complex objects

// <=1.3.2:
$.param({ a: [2,3,4] }) // "a=2&a=3&a=4"
// >=1.4:
$.param({ a: [2,3,4] }) // "a[]=2&a[]=3&a[]=4"

// <=1.3.2:
$.param({ a: { b:1,c:2 }, d: [3,4,{ e:5 }] }) // "a=[obj
// >=1.4:

9
10

$.param({ a: { b:1,c:2 }, d: [3,4,{ e:5 }] }) // "a[b]=1
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jQuery.parseHTML()
Categories: Utilities

jQuery.parseHTML( data [, context ] [, keepScripts ] )
Returns: Array
Description: Parses a string into an array of DOM
nodes.
jQuery.parseHTML( data [, context ] [, version added: 1.8
keepScripts ] )
data
Type: String
HTML string to be parsed
context (default: document )
Type: Element
DOM element to serve as the context in which the HTML
fragment will be created
keepScripts (default: false )
Type: Boolean
A Boolean indicating whether to include scripts passed in the
HTML string
uses a native DOM element creation function to
convert the string to a set of DOM elements, which can then be
inserted into the document.
jQuery.parseHTML

Example:
Create an array of Dom nodes using an HTML string
and insert it into a div.
1
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="log">
<h3>Content:</h3>
</div>
<script>
var $log = $( "#log" ),
str = "hello, <b>my name is</b> jQuery.",
html = $.parseHTML( str ),
nodeNames = [];
// Append the parsed HTML
$log.append( html );
// Gather the parsed HTML's node names
$.each( html, function( i, el ) {
nodeNames[i] = "<li>" + el.nodeName + "</li>"
});
// Insert the node names
$log.append( "<h3>Node Names:</h3>" );
$( "<ol></ol>" )
.append( nodeNames.join( "" ) )
.appendTo( $log );

31
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</script>
</body>
</html>

Demo
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jQuery.parseJSON()
Categories: Utilities

jQuery.parseJSON( json )

Returns: Object

Description: Takes a well-formed JSON string and
returns the resulting JavaScript object.
jQuery.parseJSON( json )

version added: 1.4.1

json
Type: String
The JSON string to parse.
Passing in a malformed JSON string may result in an exception
being thrown. For example, the following are all malformed JSON
strings:
{test: 1}

(test does not have double quotes around it).

{'test': 1}

('test' is using single quotes instead of double

quotes).
Additionally if you pass in nothing, an empty string, null, or
undefined, 'null' will be returned from parseJSON. Where the
browser provides a native implementation of JSON.parse , jQuery
uses it to parse the string. For details on the JSON format, see
http://json.org/.

Example:
Parse a JSON string.
1
2

var obj = jQuery.parseJSON('{"name":"John"}');
alert( obj.name === "John" );
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jQuery.parseXML()
Categories: Utilities

jQuery.parseXML( data )

Returns: XMLDocument

Description: Parses a string into an XML document.
jQuery.parseXML( data )

version added: 1.5

data
Type: String
a well-formed XML string to be parsed
uses the native parsing function of the browser to
create a valid XML Document. This document can then be passed to
jQuery to create a typical jQuery object that can be traversed and
manipulated.
jQuery.parseXML

Example:
Create a jQuery object using an XML string and obtain
the value of the title node.
1
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p id="someElement"></p>
<p id="anotherElement"></p>

<script>
var xml = "<rss version='2.0'><channel><title>RSS Title<
xmlDoc = $.parseXML( xml ),
$xml = $( xmlDoc ),
$title = $xml.find( "title" );
/* append "RSS Title" to #someElement */
$( "#someElement" ).append( $title.text() );
/* change the title to "XML Title" */
$title.text( "XML Title" );
/* append "XML Title" to #anotherElement */
$( "#anotherElement" ).append( $title.text() );
</script>
</body>
</html>

Demo
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jQuery.post()
Categories: Ajax > Shorthand Methods

jQuery.post( url [, data ] [, success(data, textStatus,
jqXHR) ] [, dataType ] )
Returns: jqXHR
Description: Load data from the server using a HTTP
POST request.
version added: 1.0
jQuery.post( url [, data ] [,
success(data, textStatus, jqXHR) ] [, dataType ] )
url
Type: String
A string containing the URL to which the request is sent.
data
Type: PlainObject or String
A plain object or string that is sent to the server with the
request.
success(data, textStatus, jqXHR)
Type: Function()
A callback function that is executed if the request succeeds.
dataType
Type: String
The type of data expected from the server. Default: Intelligent
Guess (xml, json, script, text, html).
This is a shorthand Ajax function, which is equivalent to:
1
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$.ajax({
type: "POST",
url: url,
data: data,
success: success,
dataType: dataType
});

The success callback function is passed the returned data, which will
be an XML root element or a text string depending on the MIME type
of the response. It is also passed the text status of the response.
As of jQuery 1.5, the success callback function is also passed a
"jqXHR" object (in jQuery 1.4, it was passed the XMLHttpRequest
object).
Most implementations will specify a success handler:
1
2
3

$.post('ajax/test.html', function(data) {
$('.result').html(data);
});

This example fetches the requested HTML snippet and inserts it on
the page.
Pages fetched with POST are never cached, so the cache and
ifModified options in jQuery.ajaxSetup() have no effect on these
requests.
The jqXHR Object
As of jQuery 1.5, all of jQuery's Ajax methods return a superset of
the XMLHTTPRequest object. This jQuery XHR object, or "jqXHR,"
returned by $.get() implements the Promise interface, giving it all
the properties, methods, and behavior of a Promise (see Deferred
object for more information). The jqXHR.done() (for success),
jqXHR.fail() (for error) , and jqXHR.always() (for completion,
whether success or error) methods take a function argument that is
called when the request terminates. For information about the
arguments this function receives, see the jqXHR Object section of
the $.ajax() documentation.
The Promise interface also allows jQuery's Ajax methods, including
$.get() , to chain multiple .done() , .fail() , and .always() callbacks
on a single request, and even to assign these callbacks after the
request may have completed. If the request is already complete, the
callback is fired immediately.
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// Assign handlers immediately after making the request
// and remember the jqxhr object for this request
var jqxhr = $.post("example.php", function() {
alert("success");
})
.done(function() { alert("second success"); })
.fail(function() { alert("error"); })
.always(function() { alert("finished"); });
// perform other work here ...

// Set another completion function for the request abov
jqxhr.always(function(){ alert("second finished"

Deprecation Notice
The jqXHR.success() , jqXHR.error() , and jqXHR.complete() callback
methods introduced in jQuery 1.5 are deprecated as of jQuery 1.8.
To prepare your code for their eventual removal, use jqXHR.done() ,
jqXHR.fail() , and jqXHR.always() instead.

Additional Notes:
Due to browser security restrictions, most "Ajax" requests are
subject to the same origin policy; the request can not
successfully retrieve data from a different domain, subdomain,
or protocol.
If a request with jQuery.post() returns an error code, it will fail
silently unless the script has also called the global .ajaxError()
method. Alternatively, as of jQuery 1.5, the .error() method of
the jqXHR object returned by jQuery.post() is also available for
error handling.

Examples:
Request the test.php page, but ignore the
return results.
Example:

1

$.post("test.php");

Request the test.php page and send some
additional data along (while still ignoring the return
results).
Example:

1

$.post("test.php", { name: "John", time: "2pm" } );

Pass arrays of data to the server (while still
ignoring the return results).
Example:

1

$.post("test.php", { 'choices[]': ["Jon", "Susan"

Example:
1

Send form data using ajax requests

$.post("test.php", $("#testform").serialize());

Alert the results from requesting test.php
(HTML or XML, depending on what was returned).
Example:

1
2
3

$.post("test.php", function(data) {
alert("Data Loaded: " + data);
});

Alert the results from requesting test.php
with an additional payload of data (HTML or XML,
depending on what was returned).
Example:

1
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$.post("test.php", { name: "John", time: "2pm" })
.done(function(data) {
alert("Data Loaded: " + data);
});

Post to the test.php page and get content
which has been returned in json format (<?php echo
json_encode(array("name"=>"John","time"=>"2pm"));
?>).
Example:

1
2
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5

$.post("test.php", { "func": "getNameAndTime" },
function(data){
console.log(data.name); // John
console.log(data.time); // 2pm
}, "json");

Example:

Post a form using ajax and put results in a

div
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form action="/" id="searchForm">
<input type="text" name="s" placeholder="Search..."
<input type="submit" value="Search" />
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</form>
<!-- the result of the search will be rendered inside
<div id="result"></div>
<script>
/* attach a submit handler to the form */
$("#searchForm").submit(function(event) {
/* stop form from submitting normally */
event.preventDefault();
/* get some values from elements on the page: */
var $form = $( this ),
term = $form.find( 'input[name="s"]' ).val(),
url = $form.attr( 'action' );
/* Send the data using post */
var posting = $.post( url, { s: term } );
/* Put the results in a div */
posting.done(function( data ) {
var content = $( data ).find( '#content' );
$( "#result" ).empty().append( content );
});
});
</script>
</body>
</html>

Demo
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jQuery.proxy()
Categories: Events > Event Handler Attachment | Utilities

jQuery.proxy( function, context )

Returns: Function

Description: Takes a function and returns a new one
that will always have a particular context.
jQuery.proxy( function, context )

version added: 1.4

function
Type: Function()
The function whose context will be changed.
context
Type: PlainObject
The object to which the context ( this ) of the function should be
set.

jQuery.proxy( context, name )

version added: 1.4

context
Type: PlainObject
The object to which the context of the function should be set.
name
Type: String
The name of the function whose context will be changed
(should be a property of the context object).

jQuery.proxy( function, context [,
additionalArguments ] )

version added: 1.6

function
Type: Function()
The function whose context will be changed.
context
Type: PlainObject
The object to which the context ( this ) of the function should be
set.
additionalArguments

Type: Anything
Any number of arguments to be passed to the function
referenced in the function argument.

jQuery.proxy( context, name [,
additionalArguments ] )

version added: 1.6

context
Type: PlainObject
The object to which the context of the function should be set.
name
Type: String
The name of the function whose context will be changed
(should be a property of the context object).
additionalArguments
Type: Anything
Any number of arguments to be passed to the function named
in the name argument.
This method is most useful for attaching event handlers to an
element where the context is pointing back to a different object.
Additionally, jQuery makes sure that even if you bind the function
returned from jQuery.proxy() it will still unbind the correct function if
passed the original.
Be aware, however, that jQuery's event binding subsystem assigns a
unique id to each event handling function in order to track it when it
is used to specify the function to be unbound. The function
represented by jQuery.proxy() is seen as a single function by the
event subsystem, even when it is used to bind different contexts. To
avoid unbinding the wrong handler, use a unique event namespace
for binding and unbinding (e.g., "click.myproxy1" ) rather than
specifying the proxied function during unbinding.
As of jQuery 1.6, any number of additional arguments may supplied
to $.proxy() , and they will be passed to the function whose context
will be changed.

Examples:
Change the context of functions bound to a
click handler using the "function, context" signature.
Unbind the first handler after first click.
Example:
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><button type="button" id="test">Test</button
<div id="log"></div>

<script>
var me = {
type: "zombie",
test: function(event) {
/* Without proxy, `this` would refer to the event ta
/* use event.target to reference that element. */
var element = event.target;
$(element).css("background-color", "red");

/* With proxy, `this` refers to the me object encaps
/* this function. */
$("#log").append( "Hello " + this.type + "<br>"
$("#test").off("click", this.test);
}
};
var you = {
type: "person",
test: function(event) {
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$("#log").append( this.type + " " );
}
};

/* execute you.test() in the context of the `you` object
/* no matter where it is called */
/* i.e. the `this` keyword will refer to `you` */
var youClick = $.proxy( you.test, you );

/* attach click handlers to #test */
$("#test")

/* this === "zombie"; handler unbound after first clic
.on( "click", $.proxy( me.test, me ) )
/* this === "person" */
.on( "click", youClick )
/* this === "zombie" */
.on( "click", $.proxy( you.test, me ) )
/* this === "<button> element" */
.on( "click", you.test );
</script>
</body>
</html>

Demo
Example:

Enforce the context of the function using the
"context, function name" signature. Unbind the handler
after first click.
1

<!DOCTYPE html>
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<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><button id="test">Test</button></p>
<p id="log"></p>
<script>
var obj = {
name: "John",
test: function() {
$("#log").append( this.name );
$("#test").off("click", obj.test);
}
};
$("#test").on( "click", jQuery.proxy( obj, "test"
</script>
</body>
</html>

Demo
Example:

Change the context of a function bound to
the click handler,
1
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
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<p><button type="button" id="test">Test</button
<div id="log"></div>
<script>
var me = {
/* I'm a dog */
type: "dog",
/* Note that event comes *after* one and two */
test: function(one, two, event) {
$("#log")
/* `one` maps to `you`, the 1st additional */
/* argument in the $.proxy function call */
.append( "<h3>Hello " + one.type + ":</h3>"
/* the `this` keyword refers to `me` */
/*(the 2nd, context, argument of $.proxy) */
.append( "I am a " + this.type + ", " )
/* `two` maps to `they`, the 2nd additional */
/* argument in the $.proxy function call */
.append( "and they are " + two.type + ".<br>"
/* the event type is "click" */
.append( "Thanks for " + event.type + "ing "
/* the clicked element is `event.target`, */
/* and its type is "button" */
.append( "the " + event.target.type + "."
}
};
var you = { type: "cat" };
var they = { type: "fish" };
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/* Set up handler to execute me.test() in the context */
/* of `me`, with `you` and `they` as additional argument
var proxy = $.proxy( me.test, me, you, they );
$("#test")
.on( "click", proxy );
</script>
</body>
</html>

Demo
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jQuery.queue()
Categories: Data | Utilities

Show or manipulate the queue of functions to be executed on the
matched element.
Contents:
jQuery.queue( element [, queueName ] )
jQuery.queue( element [, queueName ] )
jQuery.queue( element, queueName, newQueue )
jQuery.queue( element, queueName, newQueue )
jQuery.queue( element, queueName, callback() )

jQuery.queue( element [, queueName ] )

Returns: Array

Description: Show the queue of functions to be
executed on the matched element.
jQuery.queue( element [, queueName version added: 1.3
])
element
Type: Element
A DOM element to inspect for an attached queue.
queueName
Type: String
A string containing the name of the queue. Defaults to
standard effects queue.

fx ,

Note: This is a low-level method, you should probably use
instead.

the

.queue()

Example:
Show the length of the queue.
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<!DOCTYPE html>
<html>
<head>
<style>div { margin:3px; width:40px; height:40
position:absolute; left:0px; top:30px;
background:green; display:none; }
div.newcolor { background:blue; }
span { color:red; } </style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="show">Show Length of Queue</button
<span></span>
<div></div>
<script>
$("#show").click(function () {
var n = jQuery.queue( $("div")[0], "fx" );
$("span").text("Queue length is: " + n.length);
});
function runIt() {
$("div").show("slow");
$("div").animate({left:'+=200'},2000);
$("div").slideToggle(1000);
$("div").slideToggle("fast");
$("div").animate({left:'-=200'},1500);
$("div").hide("slow");
$("div").show(1200);
$("div").slideUp("normal", runIt);
}
runIt();
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Demo

</script>
</body>
</html>

jQuery.queue( element, queueName, newQueue )
Returns: jQuery
Description: Manipulate the queue of functions to be
executed on the matched element.
jQuery.queue( element, queueName, version added: 1.3
newQueue )
element
Type: Element
A DOM element where the array of queued functions is
attached.
queueName
Type: String
A string containing the name of the queue. Defaults to
standard effects queue.

fx ,

the

newQueue
Type: Array
An array of functions to replace the current queue contents.

jQuery.queue( element, queueName, version added: 1.3
callback() )
element
Type: Element
A DOM element on which to add a queued function.
queueName
Type: String
A string containing the name of the queue. Defaults to
standard effects queue.
callback()
Type: Function()
The new function to add to the queue.

fx ,

the

Note: This is a low-level method, you should probably use
instead.

.queue()

Every element can have one or more queues of functions attached
to it by jQuery. In most applications, only one queue (called fx ) is
used. Queues allow a sequence of actions to be called on an
element asynchronously, without halting program execution.
The jQuery.queue() method allows us to directly manipulate this
queue of functions. Calling jQuery.queue() with a callback is
particularly useful; it allows us to place a new function at the end of
the queue.
Note that when adding a function with jQuery.queue() , we should
ensure that jQuery.dequeue() is eventually called so that the next
function in line executes.

Examples:
Example:
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Queue a custom function.

<!DOCTYPE html>
<html>
<head>
<style>
div { margin:3px; width:40px; height:40px;
position:absolute; left:0px; top:30px;
background:green; display:none; }
div.newcolor { background:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
Click here...
<div></div>
<script>
$(document.body).click(function () {
$("div").show("slow");
$("div").animate({left:'+=200'},2000);
jQuery.queue( $("div")[0], "fx", function ()
$(this).addClass("newcolor");
jQuery.dequeue( this );
});
$("div").animate({left:'-=200'},500);
jQuery.queue( $("div")[0], "fx", function ()
$(this).removeClass("newcolor");
jQuery.dequeue( this );
});
$("div").slideUp();
});</script>
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</body>
</html>

Demo
Example:
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Set a queue array to delete the queue.

<!DOCTYPE html>
<html>
<head>
<style>
div { margin:3px; width:40px; height:40px;
position:absolute; left:0px; top:30px;
background:green; display:none; }
div.newcolor { background:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="start">Start</button>
<button id="stop">Stop</button>
<div></div>
<script>
$("#start").click(function () {
$("div").show("slow");
$("div").animate({left:'+=200'},5000);
jQuery.queue( $("div")[0], "fx", function
$(this).addClass("newcolor");
jQuery.dequeue( this );
});
$("div").animate({left:'-=200'},1500);
jQuery.queue( $("div")[0], "fx", function
$(this).removeClass("newcolor");
jQuery.dequeue( this );
});
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$("div").slideUp();
});
$("#stop").click(function () {
jQuery.queue( $("div")[0], "fx", [] );
$("div").stop();
});
</script>
</body>
</html>

Demo
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jQuery.removeData()
Categories: Data | Utilities

jQuery.removeData( element [, name ] )

Returns: jQuery

Description: Remove a previously-stored piece of data.
jQuery.removeData( element [,
name ] )

version added: 1.2.3

element
Type: Element
A DOM element from which to remove data.
name
Type: String
A string naming the piece of data to remove.
Note: This is a low-level method, you should probably use
.removeData() instead.
The jQuery.removeData() method allows us to remove values that
were previously set using jQuery.data() . When called with the name
of a key, jQuery.removeData() deletes that particular value; when
called with no arguments, all values are removed.

Example:
Set a data store for 2 names then remove one of
them.
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<!DOCTYPE html>
<html>
<head>
<style>
div { margin:2px; color:blue; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>value1 before creation: <span></span></div
<div>value1 after creation: <span></span></
<div>value1 after removal: <span></span></div
<div>value2 after removal: <span></span></div
<script>
var div = $("div")[0];
$("span:eq(0)").text("" + $("div").data("test1"
jQuery.data(div, "test1", "VALUE-1");
jQuery.data(div, "test2", "VALUE-2");
$("span:eq(1)").text("" + jQuery.data(div, "test1"
jQuery.removeData(div, "test1");
$("span:eq(2)").text("" + jQuery.data(div, "test1"
$("span:eq(3)").text("" + jQuery.data(div, "test2"
</body>
</html>

POWERED BYHERONOTE
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jQuery.sub()
Categories: Core

jQuery.sub()

Returns: jQuery
version deprecated: 1.7, removed: 1.9

Description: Creates a new copy of jQuery whose
properties and methods can be modified without
affecting the original jQuery object.
jQuery.sub()

version added: 1.5

This method does not accept any arguments.
This method is deprecated as of jQuery 1.7 and will be moved
to a plugin in jQuery 1.8.
There are two specific use cases for which jQuery.sub() was
created. The first was for providing a painless way of overriding
jQuery methods without completely destroying the original methods
and another was for helping to do encapsulation and basic
namespacing for jQuery plugins.
Note that jQuery.sub() doesn't attempt to do any sort of isolation that's not its intention. All the methods on the sub'd version of jQuery
will still point to the original jQuery (events bound and triggered will
still be through the main jQuery, data will be bound to elements
through the main jQuery, Ajax queries and events will run through
the main jQuery, etc.).
Note that if you're looking to use this for plugin development you
should first strongly consider using something like the jQuery UI
widget factory which manages both state and plugin sub-methods.
Some examples of using the jQuery UI widget factory to build a
plugin.
The particular use cases of this method can be best described
through some examples.

Examples:
Adding a method to a jQuery sub so that it
isn't exposed externally:
Example:
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(function(){
var sub$ = jQuery.sub();
sub$.fn.myCustomMethod = function(){
return 'just for me';
};
sub$(document).ready(function() {
sub$('body').myCustomMethod() // 'just for me'
});
})();
typeof jQuery('body').myCustomMethod // undefined

Override some jQuery methods to provide
new functionality.
Example:
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(function() {
var myjQuery = jQuery.sub();
myjQuery.fn.remove = function() {
// New functionality: Trigger a remove event
this.trigger("remove");

// Be sure to call the original jQuery remove method
return jQuery.fn.remove.apply( this, arguments );
};
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myjQuery(function($) {
$(".menu").click(function() {
$(this).find(".submenu").remove();
});

// A new remove event is now triggered from this cop
$(document).on("remove", function(e) {
$(e.target).parent().hide();
});
});
})();

// Regular jQuery doesn't trigger a remove event when re
// This functionality is only contained within the modif

Create a plugin that returns plugin-specific

Example:

methods.
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(function() {
// Create a new copy of jQuery using sub()
var plugin = jQuery.sub();
// Extend that copy with the new plugin methods
plugin.fn.extend({
open: function() {
return this.show();
},
close: function() {
return this.hide();
}
});
// Add our plugin to the original jQuery
jQuery.fn.myplugin = function() {
this.addClass("plugin");
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// Make sure our plugin returns our special plugin v
return plugin( this );
};
})();
$(document).ready(function() {
// Call the plugin, open method now exists
$('#main').myplugin().open();
// Note: Calling just $("#main").open() won't work as
});

POWERED BYHERONOTE
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jQuery.support
Categories: Properties > Properties of the Global jQuery Object | Utilities

jQuery.support

Returns: Object

Description: A collection of properties that represent the
presence of different browser features or bugs. Primarily
intended for jQuery's internal use; specific properties
may be removed when they are no longer needed
internally to improve page startup performance.
jQuery.support

version added: 1.3

Rather than using $.browser to detect the current user agent and
alter the page presentation based on which browser is running, it is
a good practice to use feature detection. To make this process
simpler, jQuery performs many such tests and sets properties of the
jQuery.support object.
Since jQuery requires these tests internally, they must be
performed on every page load. Although some of these
properties are documented below, they are not subject to a long
deprecation/removal cycle and may be removed once internal
jQuery code no longer needs them.

Following are a few resources that explain
how feature detection works:
http://peter.michaux.ca/articles/feature-detection-state-of-theart-browser-scripting
http://www.jibbering.com/faq/faq_notes/not_browser_detect.html
http://yura.thinkweb2.com/cft/
For your own project's feature-detection needs, we strongly
recommend the use of an external library such as Modernizr instead
of dependency on properties in jQuery.support .
The tests included in

jQuery.support

are as follows:

ajax is equal to true if a
XMLHttpRequest object.

browser is able to create an

is equal to true if the page is rendering according to
the W3C CSS Box Model (is currently false in IE 6 and 7 when
they are in Quirks Mode). This property is null until document
ready occurs.
boxModel

is equal to true if the change event bubbles up
the DOM tree, as required by the W3C DOM event model. (It is
currently false in IE, and jQuery simulates bubbling).
changeBubbles

is equal to true if a browser correctly clones the
checked state of radio buttons or checkboxes in document
fragments.
checkOn is equal to true if the value of a checkbox defaults to
"on" when no value is specified.
cors is equal to true if a browser can create an XMLHttpRequest
object and if that XMLHttpRequest object has a withCredentials
property. To enable cross-domain requests in environments that
do not support cors yet but do allow cross-domain XHR
requests (windows gadget, etc), set $.support.cors = true; .
CORS WD
cssFloat is equal to true if the name of the property containing
the CSS float value is .cssFloat, as defined in the CSS Spec. (It
is currently false in IE, it uses styleFloat instead).
checkClone

hrefNormalized is equal to true if the .getAttribute() method
retrieves the href attribute of elements unchanged, rather than
normalizing it to a fully-qualified URL. (It is currently false in IE,
the URLs are normalized).
DOM l3 spec
htmlSerialize is equal to true if the browser is able to
serialize/insert <link> elements using the .innerHTML property
of elements. (is currently false in IE).
HTML5 WD
leadingWhitespace is equal to true if the browser inserts content
with .innerHTML exactly as provided—specifically, if leading
whitespace characters are preserved. (It is currently false in IE
6-8).
HTML5 WD
noCloneChecked is equal to true if cloned DOM elements copy

over the state of the .checked expando. (It is currently false in
IE). (Added in jQuery 1.5.1)
noCloneEvent is equal to true if cloned DOM elements are
created without event handlers (that is, if the event handlers on
the source element are not cloned). (It is currently false in IE).
DOM l2 spec
opacity is equal to true if a browser can properly interpret the
opacity style property. (It is currently false in IE, it uses alpha
filters instead).
CSS3 spec
optDisabled is equal to true if option elements within disabled
select elements are not automatically marked as disabled.
HTML5 WD
is equal to true if an <option> element that is
selected by default has a working selected property.
HTML5 WD
scriptEval() is equal to true if inline scripts are automatically
evaluated and executed when inserted into the document using
standard DOM manipulation methods such as .appendChild()
and .createTextNode() . (It is currently false in IE, it uses .text
to insert executable scripts).
Note: No longer supported; removed in jQuery 1.6. Prior to
jQuery 1.5.1, the scriptEval() method was the static
scriptEval property. The change to a method allowed the test to
be deferred until first use to prevent content security policy
inline-script violations.
HTML5 WD
style is equal to true if inline styles for an element can be
accessed through the DOM attribute called style, as required by
the DOM Level 2 specification. In this case,
.getAttribute('style') can retrieve this value; in Internet
Explorer, .cssText is used for this purpose.
DOM l2 Style spec
submitBubbles is equal to true if the submit event bubbles up the
DOM tree, as required by the W3C DOM event model. (It is
currently false in IE, and jQuery simulates bubbling).
optSelected

is equal to true if an empty <table> element can exist
without a <tbody> element. According to the HTML specification,
this sub-element is optional, so the property should be true in a
fully-compliant browser. If false, we must account for the
tbody

possibility of the browser injecting <tbody> tags implicitly. (It is
currently false in IE, which automatically inserts tbody if it is not
present in a string assigned to innerHTML ).
HTML5 spec

Examples:
Example:
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Returns the box model for the iframe.

<!DOCTYPE html>
<html>
<head>
<style>
p { color:blue; margin:20px; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
</p>
<script>
$("p").html("This frame uses the W3C box model: <span>"
jQuery.support.boxModel + "</span>"
</script>
</body>
</html>

Demo
Example:

Returns false if the page is in QuirksMode in
Internet Explorer
1

jQuery.support.boxModel

Result:

1

false
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jQuery.trim()
Categories: Utilities

jQuery.trim( str )

Returns: String

Description: Remove the whitespace from the
beginning and end of a string.
jQuery.trim( str )

version added: 1.0

str
Type: String
The string to trim.
The $.trim() function removes all newlines, spaces (including nonbreaking spaces), and tabs from the beginning and end of the
supplied string. If these whitespace characters occur in the middle of
the string, they are preserved.

Examples:
Remove the two white spaces at the start and
at the end of the string.
Example:
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<pre id="original"></pre>
<pre id="trimmed"></pre>
<script>
var str = "
lots of spaces before and after
$("#original").html("Original String: '" + str +
$("#trimmed").html("$.trim()'ed: '" + $.trim(str) +
</script>
</body>
</html>

Demo
Example:

Remove the two white spaces at the start and
at the end of the string.
1

$.trim("

Result:

hello, how are you?

");

1

"hello, how are you?"

POWERED BYHERONOTE
A new version of this book is available!

jQuery.type()
Categories: Utilities

jQuery.type( obj )

Returns: String

Description: Determine the internal JavaScript [[Class]]
of an object.
jQuery.type( obj )

version added: 1.4.3

obj
Type: PlainObject
Object to get the internal JavaScript [[Class]] of.
A number of techniques are used to determine the exact return value
for an object. The [[Class]] is determined as follows:
If the object is undefined or null, then "undefined" or "null" is
returned accordingly.
jQuery.type( undefined ) === "undefined"
jQuery.type() === "undefined"
jQuery.type( window.notDefined ) === "undefined"
jQuery.type( null ) === "null"
If the object has an internal [[Class]] equivalent to one of the
browser's built-in objects, the associated name is returned.
(More details about this technique.)
jQuery.type( true ) === "boolean"
jQuery.type( 3 ) === "number"
jQuery.type( "test" ) === "string"
jQuery.type( function(){} ) === "function"
jQuery.type( [] ) === "array"
jQuery.type( new Date() ) === "date"
jQuery.type( new Error() ) === "error" // as of jQuery 1.9
jQuery.type( /test/ ) === "regexp"
Everything else returns "object" as its type.

Example:
Find out if the parameter is a RegExp.
1
2
3
4
5
6
7
8
9
10
11

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
Is it a RegExp? <b></b>
<script>$("b").append( "" + jQuery.type(/test/) );
</body>
</html>

Demo
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jQuery.unique()
Categories: Utilities

jQuery.unique( array )

Returns: Array

Description: Sorts an array of DOM elements, in place,
with the duplicates removed. Note that this only works
on arrays of DOM elements, not strings or numbers.
jQuery.unique( array )

version added: 1.1.3

array
Type: Array
The Array of DOM elements.
The $.unique() function searches through an array of objects,
sorting the array, and removing any duplicate nodes. This function
only works on plain JavaScript arrays of DOM elements, and is
chiefly used internally by jQuery.
As of jQuery 1.4 the results will always be returned in document
order.

Example:
Removes any duplicate elements from the array of
divs.
1
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<!DOCTYPE html>
<html>
<head>
<style>
div { color:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>There are 6 divs in this document.</div>
<div></div>
<div class="dup"></div>
<div class="dup"></div>
<div class="dup"></div>
<div></div>
<script>

var divs = $("div").get(); // unique() must take a nat

// add 3 elements of class dup too (they are divs)
divs = divs.concat($(".dup").get());
$("div:eq(1)").text("Pre-unique there are " + divs.len

divs = jQuery.unique(divs);
$("div:eq(2)").text("Post-unique there are " + divs.le
.css("color", "red");
</script>
</body>
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</html>

Demo
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jQuery.when()
Categories: Core | Deferred Object

jQuery.when( deferreds )

Returns: Promise

Description: Provides a way to execute callback
functions based on one or more objects, usually
Deferred objects that represent asynchronous events.
jQuery.when( deferreds )

version added: 1.5

deferreds
Type: Deferred
One or more Deferred objects, or plain JavaScript objects.
If a single Deferred is passed to jQuery.when , its Promise object (a
subset of the Deferred methods) is returned by the method.
Additional methods of the Promise object can be called to attach
callbacks, such as deferred.then . When the Deferred is resolved or
rejected, usually by the code that created the Deferred originally, the
appropriate callbacks will be called. For example, the jqXHR object
returned by jQuery.ajax() is a Promise and can be used this way:
1
2
3

$.when( $.ajax("test.aspx") ).then(function(data, textSt
alert( jqXHR.status ); // alerts 200
});

If a single argument is passed to jQuery.when and it is not a Deferred
or a Promise, it will be treated as a resolved Deferred and any
doneCallbacks attached will be executed immediately. The
doneCallbacks are passed the original argument. In this case any
failCallbacks you might set are never called since the Deferred is
never rejected. For example:
1
2
3

$.when( { testing: 123 } ).done(
function(x) { alert(x.testing); } /* alerts "123" */
);

In the case where multiple Deferred objects are passed to
jQuery.when , the method returns the Promise from a new "master"
Deferred object that tracks the aggregate state of all the Deferreds it
has been passed. The method will resolve its master Deferred as
soon as all the Deferreds resolve, or reject the master Deferred as
soon as one of the Deferreds is rejected. If the master Deferred is
resolved, it is passed the resolved values of all the Deferreds that
were passed to jQuery.when . For example, when the Deferreds are
jQuery.ajax() requests, the arguments will be the jqXHR objects for
the requests, in the order they were given in the argument list.
In the multiple-Deferreds case where one of the Deferreds is
rejected, jQuery.when immediately fires the failCallbacks for its
master Deferred. Note that some of the Deferreds may still be
unresolved at that point. If you need to perform additional processing
for this case, such as canceling any unfinished ajax requests, you
can keep references to the underlying jqXHR objects in a closure
and inspect/cancel them in the failCallback.

Examples:
Execute a function after two ajax requests
are successful. (See the jQuery.ajax() documentation
for a complete description of success and error cases
for an ajax request).
Example:

1
2
3
4
5
6
7
8

$.when($.ajax("/page1.php"), $.ajax("/page2.php"
/* a1 and a2 are arguments resolved for the
page1 and page2 ajax requests, respectively */
var jqXHR = a1[2]; /* arguments are [ "success", status
if ( /Whip It/.test(jqXHR.responseText) ) {
alert("First page has 'Whip It' somewhere.");
}
});

Execute the function myFunc when both ajax
requests are successful, or myFailure if either one has an
error.
Example:

1
2

$.when($.ajax("/page1.php"), $.ajax("/page2.php"
.then(myFunc, myFailure);

POWERED BYHERONOTE
A new version of this book is available!

.keydown()
Categories: Events > Keyboard Events

.keydown( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "keydown"
JavaScript event, or trigger that event on an element.
.keydown( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.keydown( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.keydown()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('keydown', handler) in the first and
second variations, and .trigger('keydown') in the third.
The keydown event is sent to an element when the user first presses
a key on the keyboard. It can be attached to any element, but the
event is only sent to the element that has the focus. Focusable
elements can vary between browsers, but form elements can always
get focus so are reasonable candidates for this event type.
For example, consider the HTML:
1

<form>

2
3
4
5
6

<input id="target" type="text" value="Hello there"
</form>
<div id="other">
Trigger the handler
</div>

The event handler can be bound to the input field:
1
2
3

$('#target').keydown(function() {
alert('Handler for .keydown() called.');
});

Now when the insertion point is inside the field, pressing a key
displays the alert:
Handler for .keydown() called.
To trigger the event manually, apply
1
2
3

.keydown()

without an argument:

$('#other').click(function() {
$('#target').keydown();
});

After this code executes, clicks on Trigger the handler will also alert
the message.
If key presses anywhere need to be caught (for example, to
implement global shortcut keys on a page), it is useful to attach this
behavior to the document object. Because of event bubbling, all key
presses will make their way up the DOM to the document object
unless explicitly stopped.
To determine which key was pressed, examine the event object that
is passed to the handler function. While browsers use differing
properties to store this information, jQuery normalizes the .which
property so you can reliably use it to retrieve the key code. This

code corresponds to a key on the keyboard, including codes for
special keys such as arrows. For catching actual text entry,
.keypress() may be a better choice.

Example:
Show the event object for the keydown handler when
a key is pressed in the input.
1
2
3
4
5
6
7
8
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14
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16
17
18
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20
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22
23
24
25
26
27
28
29
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<!DOCTYPE html>
<html>
<head>
<style>
fieldset { margin-bottom: 1em; }
input { display: block; margin-bottom: .25em; }
#print-output {
width: 100%;
}
.print-output-line {
white-space: pre;
padding: 5px;
font-family: monaco, monospace;
font-size: .7em;
}

</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<fieldset>
<label for="target">Type Something:</label>
<input id="target" type="text" />
</fieldset>
</form>
<button id="other">
Trigger the handler
</button>
<script type="text/javascript" src="/resources/events.js
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<script>
var xTriggered = 0;
$('#target').keydown(function(event) {
if (event.which == 13) {
event.preventDefault();
}
xTriggered++;
var msg = 'Handler for .keydown() called ' + xTrigger
$.print(msg, 'html');
$.print(event);
});
$('#other').click(function() {
$('#target').keydown();
});</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.keypress()
Categories: Events > Keyboard Events

.keypress( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "keypress"
JavaScript event, or trigger that event on an element.
.keypress( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.keypress( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.keypress()

version added: 1.0

This method does not accept any arguments.
Note: as the keypress event isn't covered by any official
specification, the actual behavior encountered when using it may
differ across browsers, browser versions, and platforms.
This method is a shortcut for .on('keypress', handler) in the first
two variations, and .trigger('keypress') in the third.
The keypress event is sent to an element when the browser registers
keyboard input. This is similar to the keydown event, except in the
case of key repeats. If the user presses and holds a key, a keydown
event is triggered once, but separate keypress events are triggered
for each inserted character. In addition, modifier keys (such as Shift)
trigger keydown events but not keypress events.

A keypress event handler can be attached to any element, but the
event is only sent to the element that has the focus. Focusable
elements can vary between browsers, but form elements can always
get focus so are reasonable candidates for this event type.
For example, consider the HTML:
1
2
3
4
5
6
7
8

<form>
<fieldset>
<input id="target" type="text" value="Hello there"
</fieldset>
</form>
<div id="other">
Trigger the handler
</div>

The event handler can be bound to the input field:
1
2
3

$("#target").keypress(function() {
alert("Handler for .keypress() called.");
});

Now when the insertion point is inside the field, pressing a key
displays the alert:
Handler for .keypress() called.
The message repeats if the key is held down. To trigger the event
manually, apply .keypress() without an argument::
1
2
3

$('#other').click(function() {
$("#target").keypress();
});

After this code executes, clicks on Trigger the handler will also alert
the message.
If key presses anywhere need to be caught (for example, to
implement global shortcut keys on a page), it is useful to attach this
behavior to the document object. Because of event bubbling, all key
presses will make their way up the DOM to the document object
unless explicitly stopped.
To determine which character was entered, examine the event
object that is passed to the handler function. While browsers use
differing properties to store this information, jQuery normalizes the
.which property so you can reliably use it to retrieve the character
code.
Note that keydown and keyup provide a code indicating which key is
pressed, while keypress indicates which character was entered. For
example, a lowercase "a" will be reported as 65 by keydown and
keyup , but as 97 by keypress . An uppercase "A" is reported as 65 by
all events. Because of this distinction, when catching special
keystrokes such as arrow keys, .keydown() or .keyup() is a better
choice.

Example:
Show the event object when a key is pressed in the
input. Note: This demo relies on a simple $.print()
plugin (http://api.jquery.com/resources/events.js) for
the event object's output.
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<!DOCTYPE html>
<html>
<head>
<style>
fieldset { margin-bottom: 1em; }
input { display: block; margin-bottom: .25em; }
#print-output {
width: 100%;
}
.print-output-line {
white-space: pre;
padding: 5px;
font-family: monaco, monospace;
font-size: .7em;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<fieldset>
<label for="target">Type Something:</label>
<input id="target" type="text" />
</fieldset>
</form>
<button id="other">
Trigger the handler
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</button>
<script src="http://api.jquery.com/resources/events.js"

<script>
var xTriggered = 0;
$("#target").keypress(function(event) {
if ( event.which == 13 ) {
event.preventDefault();
}
xTriggered++;
var msg = "Handler for .keypress() called " + xTrigge
$.print( msg, "html" );
$.print( event );
});
$("#other").click(function() {
$("#target").keypress();
});</script>
</body>
</html>

Demo
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.keyup()
Categories: Events > Keyboard Events

.keyup( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "keyup"
JavaScript event, or trigger that event on an element.
.keyup( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.keyup( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.keyup()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('keyup', handler) in the first two
variations, and .trigger('keyup') in the third.
The keyup event is sent to an element when the user releases a key
on the keyboard. It can be attached to any element, but the event is
only sent to the element that has the focus. Focusable elements can
vary between browsers, but form elements can always get focus so
are reasonable candidates for this event type.
For example, consider the HTML:
1

<form>

2
3
4
5
6

<input id="target" type="text" value="Hello there"
</form>
<div id="other">
Trigger the handler
</div>

The event handler can be bound to the input field:
1
2
3

$('#target').keyup(function() {
alert('Handler for .keyup() called.');
});

Now when the insertion point is inside the field and a key is pressed
and released, the alert is displayed:
Handler for .keyup() called.
To trigger the event manually, apply
1
2
3

.keyup()

without arguments:

$('#other').click(function() {
$('#target').keyup();
});

After this code executes, clicks on Trigger the handler will also alert
the message.
If key presses anywhere need to be caught (for example, to
implement global shortcut keys on a page), it is useful to attach this
behavior to the document object. Because of event bubbling, all key
presses will make their way up the DOM to the document object
unless explicitly stopped.
To determine which key was pressed, examine the event object that
is passed to the handler function. While browsers use differing
properties to store this information, jQuery normalizes the .which
property so you can reliably use it to retrieve the key code. This

code corresponds to a key on the keyboard, including codes for
special keys such as arrows. For catching actual text entry,
.keypress() may be a better choice.

Example:
Show the event object for the keyup handler (using a
simple $.print plugin) when a key is released in the
input.
1
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<!DOCTYPE html>
<html>
<head>
<style>
fieldset { margin-bottom: 1em; }
input { display: block; margin-bottom: .25em; }
#print-output {
width: 100%;
}
.print-output-line {
white-space: pre;
padding: 5px;
font-family: monaco, monospace;
font-size: .7em;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<fieldset>
<label for="target">Type Something:</label>
<input id="target" type="text" />
</fieldset>
</form>
<button id="other">
Trigger the handler
</button>
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<script type="text/javascript" src="/resources/events.js
<script>
var xTriggered = 0;
$('#target').keyup(function(event) {
xTriggered++;
var msg = 'Handler for .keyup() called ' + xTriggered
$.print(msg, 'html');
$.print(event);
}).keydown(function(event) {
if (event.which == 13) {
event.preventDefault();
}
});
$('#other').click(function() {
$('#target').keyup();
});</script>
</body>
</html>

Demo
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:lang Selector
Categories: Selectors > Basic Filter

lang selector
Description: Selects all elements of the specified
language.
jQuery( ":lang(language)" )

version added: 1.9

language: A language code.
The :lang selector matches elements that have a language value
equal to the supplied language code or that start with the supplied
language code immediately followed by "-". For example, the
selector $("div:lang(en)") will match <div lang="en"> and <div
lang="en-us"> (and any of their descendant <div> s), but not <div
lang="fr">

For HTML elements, the language value is determined by the lang
attribute and possibly information from meta elements or HTTP
headers.
Further discussion of this usage can be found in the W3C CSS
specification.

Example:
Color div elements according to their language.
1
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<!DOCTYPE html>
<html>
<head>
<style>
body { background-color: #ccc; }
h3 { margin: .25em 0; }
div { line-height: 1.5em}
.usa { background-color: #f00; color: #fff; }
.usa .usa { background-color: #fff; color: #000
.usa .usa .usa { background-color: #00f; color:
.spain { background-color: #f00; color: #ff0; }
.spain .spain { background-color: #ff0; color:
.spain .spain .spain { background-color: #f00;
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<h3>USA</h3>
<div lang="en-us">red
<div>white
<div>and blue</div>
</div>
</div>
<h3>España</h3>
<div lang="es-es">rojo
<div>amarillo
<div>y rojo</div>
</div>
</div>
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<script>
$( "div:lang(en-us)" ).addClass( "usa" );
$( "div:lang(es-es)" ).addClass( "spain" );
</script>
</body>
</html>

Demo
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.last()
Categories: Traversing > Filtering

.last()

Returns: jQuery

Description: Reduce the set of matched elements to
the final one in the set.
.last()

version added: 1.4

This method does not accept any arguments.
Given a jQuery object that represents a set of DOM elements, the
.last() method constructs a new jQuery object from the last
element in that set.
Consider a page with a simple list on it:
1
2
3
4
5
6
7

<ul>
<li>list
<li>list
<li>list
<li>list
<li>list
</ul>

item
item
item
item
item

1</li>
2</li>
3</li>
4</li>
5</li>

We can apply this method to the set of list items:
1

$('li').last().css('background-color', 'red');

The result of this call is a red background for the final item.

Example:
Highlight the last span in a paragraph.
1
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<!DOCTYPE html>
<html>
<head>
<style>.highlight{background-color: yellow}</
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><span>Look:</span> <span>This is some text in a par
<script>$("p span").last().addClass('highlight'
</body>
</html>

Demo
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:last-child Selector
Categories: Selectors > Child Filter

last-child selector
Description: Selects all elements that are the last child
of their parent.
jQuery( ":last-child" )
While :last matches only a single element,
more than one: one for each parent.

version added: 1.1.4
:last-child

can match

Example:
Find the last span in each matched div and add some
css plus a hover state.
1
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<!DOCTYPE html>
<html>
<head>
<style>
span.solast { text-decoration:line-through; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<span>John,</span>
<span>Karl,</span>
<span>Brandon,</span>
<span>Sam</span>
</div>
<div>
<span>Glen,</span>
<span>Tane,</span>
<span>Ralph,</span>
<span>David</span>
</div>
<script>
$("div span:last-child")
.css({color:"red", fontSize:"80%"})
.hover(function () {
$(this).addClass("solast");
}, function () {
$(this).removeClass("solast");
});
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</script>
</body>
</html>

Demo
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:last-of-type Selector
Categories: Selectors > Child Filter

last-of-type selector
Description: Selects all elements that are the last
among siblings of the same element name.
jQuery( ":last-of-type" )

version added: 1.9

The :last-of-type selector matches elements that have no other
element with the same parent and the same element name coming
after it in the document tree.

Example:
Find the last span in each matched div and add some
css plus a hover state.
1
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<!DOCTYPE html>
<html>
<head>
<style>
span.solast { text-decoration:line-through; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<span>Corey,</span>
<span>Yehuda,</span>
<span>Adam,</span>
<span>Todd</span>
</div>
<div>
<span>Jörn,</span>
<span>Scott,</span>
<span>Timo,</span>
<b>Nobody</b>
</div>
<script>
$("span:last-of-type")
.css({color:"red", fontSize:"80%"})
.hover(function () {
$(this).addClass("solast");
}, function () {
$(this).removeClass("solast");
});
</script>
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</body>
</html>

Demo
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:last Selector
Categories: Selectors > Basic Filter | Selectors > jQuery Extensions

last selector
Description: Selects the last matched element.
jQuery( ":last" )

version added: 1.0

Note that :last selects a single element by filtering the current
jQuery collection and matching the last element within it.

Additional Notes:
Because :last is a jQuery extension and not part of the CSS
specification, queries using :last cannot take advantage of the
performance boost provided by the native DOM
querySelectorAll() method. To achieve the best performance
when using :last to select elements, first select the elements
using a pure CSS selector, then use .filter(":last") .

Example:
Finds the last table row.
1
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<table>
<tr><td>First Row</td></tr>
<tr><td>Middle Row</td></tr>
<tr><td>Last Row</td></tr>
</table>
<script>$("tr:last").css({backgroundColor: 'yellow'
</body>
</html>

Demo
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.length
Categories: Properties > Properties of jQuery Object Instances

length

Returns: Number

Description: The number of elements in the jQuery
object.
length

version added: 1.0

The number of elements currently matched. The .size() method will
return the same value.

Example:
Count the divs. Click to add more.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

<!DOCTYPE html>
<html>
<head>
<style>
body { cursor:pointer; }
div { width:50px; height:30px; margin:5px; float
background:green; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<span></span>
<div></div>
<script>$(document.body).click(function () {
$(document.body).append($("<div>"));
var n = $("div").length;
$("span").text("There are " + n + " divs." +
"Click to add more.");
}).trigger('click'); // trigger the click to start
</script>
</body>
</html>

Demo
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.live()
Categories: Events > Event Handler Attachment

.live( events, handler(eventObject) )

Returns: jQuery

version deprecated: 1.7, removed: 1.9

Description: Attach an event handler for all elements
which match the current selector, now and in the future.
.live( events, handler(eventObject) ) version added: 1.3
events
Type: String
A string containing a JavaScript event type, such as "click" or
"keydown." As of jQuery 1.4 the string can contain multiple,
space-separated event types or custom event names.
handler(eventObject)
Type: Function()
A function to execute at the time the event is triggered.

.live( events, data,
handler(eventObject) )

version added: 1.4

events
Type: String
A string containing a JavaScript event type, such as "click" or
"keydown." As of jQuery 1.4 the string can contain multiple,
space-separated event types or custom event names.
data
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute at the time the event is triggered.

.live( events )
events
Type: PlainObject

version added: 1.4.3

A plain object of one or more JavaScript event types and
functions to execute for them.
As of jQuery 1.7, the .live() method is deprecated. Use .on() to
attach event handlers. Users of older versions of jQuery should use
.delegate() in preference to .live() .
This method provides a means to attach delegated event handlers to
the document element of a page, which simplifies the use of event
handlers when content is dynamically added to a page. See the
discussion of direct versus delegated events in the .on() method for
more information.
Rewriting the .live() method in terms of its successors is
straightforward; these are templates for equivalent calls for all three
event attachment methods:
1
2
3

$(selector).live(events, data, handler);
$(document).delegate(selector, events, data, handler);
$(document).on(events, selector, data, handler);

The events argument can either be a space-separated list of event
type names and optional namespaces, or an object of event name
strings and handlers. The data argument is optional and can be
omitted. For example, the following three method calls are
functionally equivalent (but see below for more effective and
performant ways to attach delegated event handlers):
1
2
3

$("a.offsite").live("click", function(){ alert("Goodbye!
$(document).delegate("a.offsite", "click", function
$(document).on("click", "a.offsite", function(){ alert(

Use of the .live() method is no longer recommended since later
versions of jQuery offer better methods that do not have its
drawbacks. In particular, the following issues arise with the use of
.live() :

jQuery attempts to retrieve the elements specified by the
selector before calling the .live() method, which may be timeconsuming on large documents.
Chaining methods is not supported. For example,
$("a").find(".offsite, .external").live( ... ); is not valid
and does not work as expected.
Since all .live() events are attached at the document element,
events take the longest and slowest possible path before they
are handled.
On mobile iOS (iPhone, iPad and iPod Touch) the click event
does not bubble to the document body for most elements and
cannot be used with .live() without applying one of the
following workarounds:
1
Use natively clickable elements such as a or button , as
both of these do bubble to document .
2

Use .on() or .delegate() attached to an element below
the level of document.body , since mobile iOS does bubble
within the body.

3

Apply the CSS style cursor:pointer to the element that
needs to bubble clicks (or a parent including
document.documentElement ). Note however, this will disable
copy\paste on the element and cause it to be highlighted
when touched.

Calling event.stopPropagation() in the event handler is
ineffective in stopping event handlers attached lower in the
document; the event has already propagated to document .
The .live() method interacts with other event methods in ways
that can be surprising, e.g., $(document).off("click") removes
all click handlers attached by any call to .live() !
For pages still using
may be helpful:

.live() ,

this list of version-specific differences

Before jQuery 1.7, to stop further handlers from executing after
one bound using .live() , the handler must return false .
Calling .stopPropagation() will not accomplish this.
As of jQuery 1.4 the

.live()

method supports custom events

as well as all JavaScript events that bubble. It also supports
certain events that don't bubble, including change , submit , focus
and blur .
In jQuery 1.3.x only the following JavaScript events could be
bound: click , dblclick , keydown , keypress , keyup , mousedown ,
mousemove , mouseout , mouseover , and mouseup .

Examples:
Cancel a default action and prevent it from
bubbling up by returning false.
Example:

1

$("a").live("click", function() { return false; })

Cancel only the default action by using the
preventDefault method.
Example:

1
2
3

$("a").live("click", function(event){
event.preventDefault();
});

Example:
1
2
3
4
5
6
7
8
9

Bind custom events with .live().

$("p").live("myCustomEvent", function(e, myName, myValue)
$(this).text("Hi there!");
$("span").stop().css("opacity", 1)
.text("myName = " + myName)
.fadeIn(30).fadeOut(1000);
});
$("button").click(function () {
$("p").trigger("myCustomEvent");
});

Use an object to bind multiple live event
handlers. Note that .live() calls the click, mouseover,
and mouseout event handlers for all paragraphs--even
new ones.
Example:

1
2
3
4
5
6
7
8
9
10
11

$("p").live({
click: function() {
$(this).after("<p>Another paragraph!</p>");
},
mouseover: function() {
$(this).addClass("over");
},
mouseout: function() {
$(this).removeClass("over");
}
});

POWERED BYHERONOTE
A new version of this book is available!

.load()
Categories: Ajax > Shorthand Methods

.load( url [, data ] [, complete(responseText, textStatus,
XMLHttpRequest) ] )
Returns: jQuery
Description: Load data from the server and place the
returned HTML into the matched element.
version added: 1.0
.load( url [, data ] [,
complete(responseText, textStatus, XMLHttpRequest)
])
url
Type: String
A string containing the URL to which the request is sent.
data
Type: PlainObject or String
A plain object or string that is sent to the server with the
request.
complete(responseText, textStatus, XMLHttpRequest)
Type: Function()
A callback function that is executed when the request
completes.

Note: The event handling suite also has a
method named .load() . jQuery determines
which method to fire based on the set of
arguments passed to it.
This method is the simplest way to fetch data from the server. It is
roughly equivalent to $.get(url, data, success) except that it is a
method rather than global function and it has an implicit callback
function. When a successful response is detected (i.e. when
textStatus is "success" or "notmodified"), .load() sets the HTML

contents of the matched element to the returned data. This means
that most uses of the method can be quite simple:
1

$('#result').load('ajax/test.html');

If no element is matched by the selector — in this case, if the
document does not contain an element with id="result" — the Ajax
request will not be sent.
Callback Function
If a "complete" callback is provided, it is executed after postprocessing and HTML insertion has been performed. The callback is
fired once for each element in the jQuery collection, and this is set
to each DOM element in turn.
1
2
3

$('#result').load('ajax/test.html', function() {
alert('Load was performed.');
});

In the two examples above, if the current document does not contain
an element with an ID of "result," the .load() method is not
executed.
Request Method
The POST method is used if data is provided as an object;
otherwise, GET is assumed.
Loading Page Fragments
The .load() method, unlike $.get() , allows us to specify a portion of
the remote document to be inserted. This is achieved with a special
syntax for the url parameter. If one or more space characters are
included in the string, the portion of the string following the first
space is assumed to be a jQuery selector that determines the
content to be loaded.

We could modify the example above to use only part of the
document that is fetched:
1

$('#result').load('ajax/test.html #container');

When this method executes, it retrieves the content of
ajax/test.html , but then jQuery parses the returned document to
find the element with an ID of container . This element, along with its
contents, is inserted into the element with an ID of result , and the
rest of the retrieved document is discarded.
jQuery uses the browser's .innerHTML property to parse the retrieved
document and insert it into the current document. During this
process, browsers often filter elements from the document such as
<html> , <title> , or <head> elements. As a result, the elements
retrieved by .load() may not be exactly the same as if the document
were retrieved directly by the browser.
Script Execution
When calling .load() using a URL without a suffixed selector
expression, the content is passed to .html() prior to scripts being
removed. This executes the script blocks before they are discarded.
If .load() is called with a selector expression appended to the URL,
however, the scripts are stripped out prior to the DOM being
updated, and thus are not executed. An example of both cases can
be seen below:
Here, any JavaScript loaded into
successfully execute.
1

#a

as a part of the document will

$('#a').load('article.html');

However, in the following case, script blocks in the document being
loaded into #b are stripped out and not executed:

1

$('#b').load('article.html #target');

Additional Notes:
Due to browser security restrictions, most "Ajax" requests are
subject to the same origin policy; the request can not
successfully retrieve data from a different domain, subdomain,
or protocol.

Examples:
Load the main page's footer navigation into
an ordered list.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

<!DOCTYPE html>
<html>
<head>
<style>
body{ font-size: 12px; font-family: Arial; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<b>Footer navigation:</b>
<ol id="new-nav"></ol>
<script>
$("#new-nav").load("/ #jq-footerNavigation li"
</script>
</body>
</html>

Demo
Example:

Display a notice if the Ajax request
encounters an error.
1
2
3
4

<!DOCTYPE html>
<html>
<head>
<style>

5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

body{ font-size: 12px; font-family: Arial; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<b>Successful Response (should be blank):</b>
<div id="success"></div>
<b>Error Response:</b>
<div id="error"></div>

<script>
$("#success").load("/not-here.php", function(response, s
if (status == "error") {
var msg = "Sorry but there was an error: ";
$("#error").html(msg + xhr.status + " " + xhr.status
}
});
</script>
</body>
</html>

Demo
Example:

Load the feeds.html file into the div with the
ID of feeds.
1

$("#feeds").load("feeds.html");

Result:
1

<div id="feeds"><b>45</b> feeds found.</div>

Example:
1

pass arrays of data to the server.

$("#objectID").load("test.php", { 'choices[]': [

Same as above, but will POST the additional
parameters to the server and a callback that is
executed when the server is finished responding.
Example:

1
2
3

$("#feeds").load("feeds.php", {limit: 25}, function
alert("The last 25 entries in the feed have been loaded"
});

POWERED BYHERONOTE
A new version of this book is available!

.load()
Categories: Events > Document Loading

.load( handler(eventObject) )

Returns: jQuery
version deprecated: 1.8

Description: Bind an event handler to the "load"
JavaScript event.
.load( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute when the event is triggered.

.load( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.
This method is a shortcut for

.on('load', handler) .

The load event is sent to an element when it and all sub-elements
have been completely loaded. This event can be sent to any
element associated with a URL: images, scripts, frames, iframes,
and the window object.
For example, consider a page with a simple image:
1

<img src="book.png" alt="Book" id="book" />

The event handler can be bound to the image:

1
2
3

$('#book').load(function() {
// Handler for .load() called.
});

As soon as the image has been loaded, the handler is called.
In general, it is not necessary to wait for all images to be fully
loaded. If code can be executed earlier, it is usually best to place it in
a handler sent to the .ready() method.

The Ajax module also has a method named
.load() . Which one is fired depends on the
set of arguments passed.
Caveats of the
images

load

event when used with

A common challenge developers attempt to
solve using the .load() shortcut is to execute
a function when an image (or collection of
images) have completely loaded. There are
several known caveats with this that should
be noted. These are:
It doesn't work consistently nor reliably cross-browser
It doesn't fire correctly in WebKit if the image src is set to the
same src as before
It doesn't correctly bubble up the DOM tree
Can cease to fire for images that already live in the browser's
cache

Note: The .live() and .delegate() methods
cannot be used to detect the load event of
an iframe. The load event does not correctly
bubble up the parent document and the
event.target isn't set by Firefox, IE9 or
Chrome, which is required to do event
delegation.

Examples:
Run a function when the page is fully loaded
including graphics.
Example:

1
2
3

$(window).load(function () {
// run code
});

Add the class bigImg to all images with
height greater then 100 upon each image load.
Example:

1
2
3
4
5

$('img.userIcon').load(function(){
if($(this).height() > 100) {
$(this).addClass('bigImg');
}
});

POWERED BYHERONOTE
A new version of this book is available!

:lt() Selector
Categories: Selectors > Basic Filter | Selectors > jQuery Extensions

lt selector
Description: Select all elements at an index less than
index within the matched set.
jQuery( ":lt(index)" )

version added: 1.0

index: Zero-based index.
index-related selectors
The index-related selectors (including this "less than" selector) filter
the set of elements that have matched the expressions that precede
them. They narrow the set down based on the order of the elements
within this matched set. For example, if elements are first selected
with a class selector ( .myclass ) and four elements are returned,
these elements are given indices 0 through 3 for the purposes of
these selectors.
Note that since JavaScript arrays use 0-based indexing, these
selectors reflect that fact. This is why $('.myclass:lt(1)') selects
the first element in the document with the class myclass , rather than
selecting no elements. In contrast, :nth-child(n) uses 1-based
indexing to conform to the CSS specification.

Additional Notes:
Because :lt() is a jQuery extension and not part of the CSS
specification, queries using :lt() cannot take advantage of the
performance boost provided by the native DOM
querySelectorAll() method. For better performance in modern
browsers, use $("your-pure-css-selector").slice(0, index)
instead.

Example:
Finds TDs less than the one with the 4th index
(TD#4).
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<table border="1">
<tr><td>TD #0</td><td>TD #1</td><td>TD #2</td
<tr><td>TD #3</td><td>TD #4</td><td>TD #5</td
<tr><td>TD #6</td><td>TD #7</td><td>TD #8</td
</table>
<script>$("td:lt(4)").css("color", "red");</script
</body>
</html>

Demo
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.map()
Categories: Traversing > Filtering

.map( callback(index, domElement) )

Returns: jQuery

Description: Pass each element in the current matched
set through a function, producing a new jQuery object
containing the return values.
.map( callback(index, domElement) ) version added: 1.2
callback(index, domElement)
Type: Function()
A function object that will be invoked for each element in the
current set.
If you wish to process a plain array or object, use the jQuery.map()
instead.
As the return value is a jQuery object, which contains an array, it's
very common to call .get() on the result to work with a basic array.
The .map() method is particularly useful for getting or setting the
value of a collection of elements. Consider a form with a set of
checkboxes in it:
1
2
3
4
5
6
7
8
9
10
11
12
13
14

<form method="post" action="">
<fieldset>
<div>
<label for="two">2</label>
<input type="checkbox" value="2" id="two"
</div>
<div>
<label for="four">4</label>
<input type="checkbox" value="4" id="four"
</div>
<div>
<label for="six">6</label>
<input type="checkbox" value="6" id="six"
</div>

15
16
17
18
19
20

<div>
<label for="eight">8</label>
<input type="checkbox" value="8" id="eight"
</div>
</fieldset>
</form>

To get a comma-separated list of checkbox
1
2
3

ID s:

$(':checkbox').map(function() {
return this.id;
}).get().join();

The result of this call is the string,

"two,four,six,eight" .

Within the callback function, this refers to the current DOM element
for each iteration. The function can return an individual data item or
an array of data items to be inserted into the resulting set. If an array
is returned, the elements inside the array are inserted into the set. If
the function returns null or undefined , no element will be inserted.

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25

Build a list of all the values within a form.

<!DOCTYPE html>
<html>
<head>
<style>
p { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><b>Values: </b></p>
<form>
<input type="text" name="name" value="John"

<input type="text" name="password" value="password"
<input type="text" name="url" value="http://ejohn.or
</form>
<script>
$("p").append( $("input").map(function(){
return $(this).val();
}).get().join(", ") );
</script>
</body>
</html>

Demo
Example:

A contrived example to show some
functionality.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36

<!DOCTYPE html>
<html>
<head>
<style>
body { font-size:16px; }
ul { float:left; margin:0 30px; color:blue; }
#results { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul>
<li>First</li>
<li>Second</li>
<li>Third</li>
<li>Fourth</li>
<li>Fifth</li>
</ul>
<ul id="results">

</ul>
<script>
var mappedItems = $("li").map(function (index) {
var replacement = $("<li>").text($(this).text()).get(
if (index == 0) {
/* make the first item all caps */
$(replacement).text($(replacement).text().toUpperCas
} else if (index == 1 || index == 3) {
/* delete the second and fourth items */
replacement = null;
} else if (index == 2) {
/* make two of the third item and add some text */
replacement = [replacement,$("<li>").get(0)];
$(replacement[0]).append("<b> - A</b>");
$(replacement[1]).append("Extra <b> - B</b>"

37
38
39
40
41
42
43
44
45
46
47
48

}
/* replacement will be a dom element, null,
or an array of dom elements */
return replacement;
});
$("#results").append(mappedItems);
</script>
</body>
</html>

Demo
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

Equalize the heights of the divs.

<!DOCTYPE html>
<html>
<head>
<style>
div { width: 40px; float:left; }
input { clear:left}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

<input type="button" value="equalize div heights"
<div style="background:red; height: 40px; "></div
<div style="background:green; height: 70px;"></
<div style="background:blue; height: 50px; "></

20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36

<script>
$.fn.equalizeHeights = function() {
var maxHeight = this.map(function(i,e) {
return $(e).height();
}).get();

return this.height( Math.max.apply(this, maxHeight) );
};
$('input').click(function(){
$('div').equalizeHeights();
});
</script>
</body>
</html>

Demo
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.mousedown()
Categories: Events > Mouse Events

.mousedown( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "mousedown"
JavaScript event, or trigger that event on an element.
.mousedown( handler(eventObject) ) version added: 1.0
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mousedown( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mousedown()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('mousedown', handler) in the first
variation, and .trigger('mousedown') in the second.
The mousedown event is sent to an element when the mouse pointer
is over the element, and the mouse button is pressed. Any HTML
element can receive this event.
For example, consider the HTML:
1
2
3

<div id="target">
Click here
</div>

4
5
6

<div id="other">
Trigger the handler
</div>

The event handler can be bound to any
1
2
3

<div> :

$('#target').mousedown(function() {
alert('Handler for .mousedown() called.');
});

Now if we click on this element, the alert is displayed:
Handler for .mousedown() called.
We can also trigger the event when a different element is clicked:
1
2
3

$('#other').click(function() {
$('#target').mousedown();
});

After this code executes, clicks on Trigger the handler will also alert
the message.
The mousedown event is sent when any mouse button is clicked. To
act only on specific buttons, we can use the event object's which
property. Not all browsers support this property (Internet Explorer
uses button instead), but jQuery normalizes the property so that it is
safe to use in any browser. The value of which will be 1 for the left
button, 2 for the middle button, or 3 for the right button.
This event is primarily useful for ensuring that the primary button

was used to begin a drag operation; if ignored, strange results can
occur when the user attempts to use a context menu. While the
middle and right buttons can be detected with these properties, this
is not reliable. In Opera and Safari, for example, right mouse button
clicks are not detectable by default.
If the user clicks on an element, drags away from it, and releases
the button, this is still counted as a mousedown event. This sequence
of actions is treated as a "canceling" of the button press in most user
interfaces, so it is usually better to use the click event unless we
know that the mousedown event is preferable for a particular situation.

Example:
Show texts when mouseup and mousedown event
triggering.
1
2
3
4
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Press mouse and release here.</p>

<script>
$("p").mouseup(function(){
$(this).append('<span style="color:#F00;">Mouse up
}).mousedown(function(){
$(this).append('<span style="color:#00F;">Mouse do
});
</script>
</body>
</html>

Demo
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.mouseenter()
Categories: Events > Mouse Events

.mouseenter( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to be fired when the
mouse enters an element, or trigger that handler on an
element.
.mouseenter( handler(eventObject) ) version added: 1.0
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mouseenter( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mouseenter()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('mouseenter', handler) in the first
two variations, and .trigger('mouseenter') in the third.
The mouseenter JavaScript event is proprietary to Internet Explorer.
Because of the event's general utility, jQuery simulates this event so
that it can be used regardless of browser. This event is sent to an
element when the mouse pointer enters the element. Any HTML
element can receive this event.
For example, consider the HTML:

1
2
3
4
5
6
7
8
9
10

<div id="outer">
Outer
<div id="inner">
Inner
</div>
</div>
<div id="other">
Trigger the handler
</div>
<div id="log"></div>

The event handler can be bound to any element:
1
2
3

$('#outer').mouseenter(function() {
$('#log').append('<div>Handler for .mouseenter() calle
});

Now when the mouse pointer moves over the Outer <div> , the
message is appended to <div id="log"> . You can also trigger the
event when another element is clicked:
1
2
3

$('#other').click(function() {
$('#outer').mouseenter();
});

After this code executes, clicks on Trigger the handler will also

append the message.
The mouseenter event differs from mouseover in the way it handles
event bubbling. If mouseover were used in this example, then when
the mouse pointer moved over the Inner element, the handler would
be triggered. This is usually undesirable behavior. The mouseenter
event, on the other hand, only triggers its handler when the mouse
enters the element it is bound to, not a descendant. So in this
example, the handler is triggered when the mouse enters the Outer
element, but not the Inner element.

Example:
Show texts when mouseenter and mouseout event
triggering. mouseover fires when the pointer moves into
the child element as well, while mouseenter fires only
when the pointer moves into the bound element.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28

<!DOCTYPE html>
<html>
<head>
<style>
div.out {
width:40%;
height:120px;
margin:0 15px;
background-color:#D6EDFC;
float:left;
}
div.in {
width:60%;
height:60%;
background-color:#FFCC00;
margin:10px auto;
}
p {
line-height:1em;
margin:0;
padding:0;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div class="out overout"><p>move your mouse</p>
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45
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47
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<div class="out enterleave"><p>move your mouse</

<script>
var i = 0;
$("div.overout").mouseover(function(){
$("p:first",this).text("mouse over");
$("p:last",this).text(++i);
}).mouseout(function(){
$("p:first",this).text("mouse out");
});
var n = 0;
$("div.enterleave").mouseenter(function(){
$("p:first",this).text("mouse enter");
$("p:last",this).text(++n);
}).mouseleave(function(){
$("p:first",this).text("mouse leave");
});
</script>
</body>
</html>

Demo
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.mouseleave()
Categories: Events > Mouse Events

.mouseleave( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to be fired when the
mouse leaves an element, or trigger that handler on an
element.
.mouseleave( handler(eventObject) ) version added: 1.0
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mouseleave( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mouseleave()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('mouseleave', handler) in the first
two variations, and .trigger('mouseleave') in the third.
The mouseleave JavaScript event is proprietary to Internet Explorer.
Because of the event's general utility, jQuery simulates this event so
that it can be used regardless of browser. This event is sent to an
element when the mouse pointer leaves the element. Any HTML
element can receive this event.
For example, consider the HTML:

1
2
3
4
5
6
7
8
9
10

<div id="outer">
Outer
<div id="inner">
Inner
</div>
</div>
<div id="other">
Trigger the handler
</div>
<div id="log"></div>

The event handler can be bound to any element:
1
2
3

$('#outer').mouseleave(function() {
$('#log').append('<div>Handler for .mouseleave() calle
});

Now when the mouse pointer moves out of the Outer <div> , the
message is appended to <div id="log"> . You can also trigger the
event when another element is clicked:
1
2
3

$('#other').click(function() {
$('#outer').mouseleave();
});

After this code executes, clicks on Trigger the handler will also

append the message.
The mouseleave event differs from mouseout in the way it handles
event bubbling. If mouseout were used in this example, then when
the mouse pointer moved out of the Inner element, the handler
would be triggered. This is usually undesirable behavior. The
mouseleave event, on the other hand, only triggers its handler when
the mouse leaves the element it is bound to, not a descendant. So in
this example, the handler is triggered when the mouse leaves the
Outer element, but not the Inner element.

Example:
Show number of times mouseout and mouseleave
events are triggered. mouseout fires when the pointer
moves out of child element as well, while mouseleave fires
only when the pointer moves out of the bound
element.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<!DOCTYPE html>
<html>
<head>
<style>
div.out {
width:40%;
height:120px;
margin:0 15px;
background-color:#D6EDFC;
float:left;
}
div.in {
width:60%;
height:60%;
background-color:#FFCC00;
margin:10px auto;
}
p {
line-height:1em;
margin:0;
padding:0;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

28
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30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53

<div class="out overout"><p>move your mouse</p>
<div class="out enterleave"><p>move your mouse</

<script>
var i = 0;
$("div.overout").mouseover(function(){
$("p:first",this).text("mouse over");
}).mouseout(function(){
$("p:first",this).text("mouse out");
$("p:last",this).text(++i);
});
var n = 0;
$("div.enterleave").mouseenter(function(){
$("p:first",this).text("mouse enter");
}).mouseleave(function(){
$("p:first",this).text("mouse leave");
$("p:last",this).text(++n);
});
</script>
</body>
</html>
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.mousemove()
Categories: Events > Mouse Events

.mousemove( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "mousemove"
JavaScript event, or trigger that event on an element.
.mousemove( handler(eventObject) ) version added: 1.0
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mousemove( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mousemove()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('mousemove', handler) in the first
two variations, and .trigger('mousemove') in the third.
The mousemove event is sent to an element when the mouse pointer
moves inside the element. Any HTML element can receive this
event.
For example, consider the HTML:
1
2
3

<div id="target">
Move here
</div>

4
5
6
7

<div id="other">
Trigger the handler
</div>
<div id="log"></div>

The event handler can be bound to the target:
1
2
3
4
5

$("#target").mousemove(function(event) {
var msg = "Handler for .mousemove() called at "
msg += event.pageX + ", " + event.pageY;
$("#log").append("<div>" + msg + "</div>");
});

Now when the mouse pointer moves within the target button, the
messages are appended to <div id="log">:
Handler for .mousemove() called at (399, 48) Handler for
.mousemove() called at (398, 46)
Handler for .mousemove() called at (397, 44)
Handler for .mousemove() called at (396, 42)
To trigger the event manually, apply
argument:
1
2
3

.mousemove()

without an

$("#other").click(function() {
$("#target").mousemove();
});

After this code executes, clicks on the Trigger button will also
append the message:
Handler for .mousemove() called at (undefined, undefined)
When tracking mouse movement, you usually need to know the
actual position of the mouse pointer. The event object that is passed
to the handler contains some information about the mouse

coordinates. Properties such as .clientX , .offsetX , and .pageX are
available, but support for them differs between browsers.
Fortunately, jQuery normalizes the .pageX and .pageY properties so
that they can be used in all browsers. These properties provide the
X and Y coordinates of the mouse pointer relative to the top-left
corner of the document, as illustrated in the example output above.
Keep in mind that the mousemove event is triggered whenever the
mouse pointer moves, even for a pixel. This means that hundreds of
events can be generated over a very small amount of time. If the
handler has to do any significant processing, or if multiple handlers
for the event exist, this can be a serious performance drain on the
browser. It is important, therefore, to optimize mousemove handlers as
much as possible, and to unbind them as soon as they are no longer
needed.
A common pattern is to bind the mousemove handler from within a
mousedown hander, and to unbind it from a corresponding mouseup
handler. If implementing this sequence of events, remember that the
mouseup event might be sent to a different HTML element than the
mousemove event was. To account for this, the mouseup handler should
typically be bound to an element high up in the DOM tree, such as
<body> .

Example:
Show the mouse coordinates when the mouse is
moved over the yellow div. Coordinates are relative to
the window, which in this case is the iframe.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<!DOCTYPE html>
<html>
<head>
<style>
div { width:220px; height:170px; margin: 10px 50
background:yellow; border:2px groove; float
p { margin:0; margin-left:10px; color:red; width
height:120px; padding-top:70px;
float:left; font-size:14px; }
span { display:block; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
<span>Move the mouse over the div.</span>
<span>&nbsp;</span>
</p>

<div></div>
<script>
$("div").mousemove(function(e){
var pageCoords = "( " + e.pageX + ", " + e.pageY +
var clientCoords = "( " + e.clientX + ", " + e.clientY
$("span:first").text("( e.pageX, e.pageY ) : "
$("span:last").text("( e.clientX, e.clientY ) : "
});
</script>

30
31
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</body>
</html>
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.mouseout()
Categories: Events > Mouse Events

.mouseout( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "mouseout"
JavaScript event, or trigger that event on an element.
.mouseout( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mouseout( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mouseout()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('mouseout', handler) in the first
two variation, and .trigger('mouseout') in the third.
The mouseout event is sent to an element when the mouse pointer
leaves the element. Any HTML element can receive this event.
For example, consider the HTML:
1
2
3

<div id="outer">
Outer
<div id="inner">

4
5
6
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9
10

Inner
</div>
</div>
<div id="other">
Trigger the handler
</div>
<div id="log"></div>

The event handler can be bound to any element:
1
2
3

$('#outer').mouseout(function() {
$('#log').append('Handler for .mouseout() called.'
});

Now when the mouse pointer moves out of the Outer <div> , the
message is appended to <div id="log"> . To trigger the event
manually, apply .mouseout() without an argument::
1
2
3

$('#other').click(function() {
$('#outer').mouseout();
});

After this code executes, clicks on Trigger the handler will also
append the message.
This event type can cause many headaches due to event bubbling.

For instance, when the mouse pointer moves out of the Inner
element in this example, a mouseout event will be sent to that, then
trickle up to Outer. This can trigger the bound mouseout handler at
inopportune times. See the discussion for .mouseleave() for a useful
alternative.

Example:
Show the number of times mouseout and mouseleave
events are triggered. mouseout fires when the pointer
moves out of the child element as well, while mouseleave
fires only when the pointer moves out of the bound
element.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<!DOCTYPE html>
<html>
<head>
<style>
div.out {
width:40%;
height:120px;
margin:0 15px;
background-color:#D6EDFC;
float:left;
}
div.in {
width:60%;
height:60%;
background-color:#FFCC00;
margin:10px auto;
}
p {
line-height:1em;
margin:0;
padding:0;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
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<div class="out overout"><p>move your mouse</p>
<div class="out enterleave"><p>move your mouse</

<script>
var i = 0;
$("div.overout").mouseout(function(){
$("p:first",this).text("mouse out");
$("p:last",this).text(++i);
}).mouseover(function(){
$("p:first",this).text("mouse over");
});
var n = 0;
$("div.enterleave").on("mouseenter",function(){
$("p:first",this).text("mouse enter");
}).on("mouseleave",function(){
$("p:first",this).text("mouse leave");
$("p:last",this).text(++n);
});
</script>
</body>
</html>
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.mouseover()
Categories: Events > Mouse Events

.mouseover( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "mouseover"
JavaScript event, or trigger that event on an element.
.mouseover( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mouseover( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mouseover()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('mouseover', handler) in the first
two variations, and .trigger('mouseover') in the third.
The mouseover event is sent to an element when the mouse pointer
enters the element. Any HTML element can receive this event.
For example, consider the HTML:
1
2
3

<div id="outer">
Outer
<div id="inner">

4
5
6
7
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9
10

Inner
</div>
</div>
<div id="other">
Trigger the handler
</div>
<div id="log"></div>

The event handler can be bound to any element:
1
2
3

$('#outer').mouseover(function() {
$('#log').append('<div>Handler for .mouseover() called
});

Now when the mouse pointer moves over the Outer <div> , the
message is appended to <div id="log"> . We can also trigger the
event when another element is clicked:
1
2
3

$('#other').click(function() {
$('#outer').mouseover();
});

After this code executes, clicks on Trigger the handler will also
append the message.
This event type can cause many headaches due to event bubbling.

For instance, when the mouse pointer moves over the Inner element
in this example, a mouseover event will be sent to that, then trickle up
to Outer. This can trigger our bound mouseover handler at
inopportune times. See the discussion for .mouseenter() for a useful
alternative.

Example:
Show the number of times mouseover and
mouseenter events are triggered. mouseover fires when
the pointer moves into the child element as well, while
mouseenter fires only when the pointer moves into the
bound element.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<!DOCTYPE html>
<html>
<head>
<style>
div.out { width:40%; height:120px; margin:0 15px;
background-color:#D6EDFC; float:left;
div.in { width:60%; height:60%;
background-color:#FFCC00; margin:10px auto;
p { line-height:1em; margin:0; padding:0; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div class="out overout">
<span>move your mouse</span>
<div class="in">
</div>
</div>
<div class="out enterleave">
<span>move your mouse</span>
<div class="in">
</div>
</div>
<script>
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47

var i = 0;
$("div.overout").mouseover(function() {
i += 1;
$(this).find("span").text( "mouse over x " + i );
}).mouseout(function(){
$(this).find("span").text("mouse out ");
});
var n = 0;
$("div.enterleave").mouseenter(function() {
n += 1;
$(this).find("span").text( "mouse enter x "
}).mouseleave(function() {
$(this).find("span").text("mouse leave");
});
</script>
</body>
</html>
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.mouseup()
Categories: Events > Mouse Events

.mouseup( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "mouseup"
JavaScript event, or trigger that event on an element.
.mouseup( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mouseup( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.mouseup()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('mouseup', handler) in the first
variation, and .trigger('mouseup') in the second.
The mouseup event is sent to an element when the mouse pointer is
over the element, and the mouse button is released. Any HTML
element can receive this event.
For example, consider the HTML:
1
2
3

<div id="target">
Click here
</div>

4
5
6

<div id="other">
Trigger the handler
</div>

The event handler can be bound to any
1
2
3

<div> :

$('#target').mouseup(function() {
alert('Handler for .mouseup() called.');
});

Now if we click on this element, the alert is displayed:
Handler for .mouseup() called.
We can also trigger the event when a different element is clicked:
1
2
3

$('#other').click(function() {
$('#target').mouseup();
});

After this code executes, clicks on Trigger the handler will also alert
the message.
If the user clicks outside an element, drags onto it, and releases the
button, this is still counted as a mouseup event. This sequence of
actions is not treated as a button press in most user interfaces, so it
is usually better to use the click event unless we know that the
mouseup event is preferable for a particular situation.

Example:
Show texts when mouseup and mousedown event
triggering.
1
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Press mouse and release here.</p>

<script>
$("p").mouseup(function(){
$(this).append('<span style="color:#F00;">Mouse up
}).mousedown(function(){
$(this).append('<span style="color:#00F;">Mouse do
});
</script>
</body>
</html>
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Multiple Attribute Selector
[name="value"]
[name2="value2"]
Categories: Selectors > Attribute

attributeMultiple selector
Description: Matches elements that match all of the
specified attribute filters.
jQuery( "[attributeFilter1]
[attributeFilter2][attributeFilterN]" )

version added: 1.0

attributeFilter1: An attribute filter.
attributeFilter2: Another attribute filter, reducing the selection
even more
attributeFilterN: As many more attribute filters as necessary

Example:
Finds all inputs that have an id attribute and whose
name attribute ends with man and sets the value.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<input id="man-news" name="man-news" />
<input name="milkman" />
<input id="letterman" name="new-letterman" />
<input name="newmilk" />
<script>$('input[id][name$="man"]').val('only this one'
</body>
</html>

Demo
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Multiple Selector (“selector1,
selector2, selectorN”)
Categories: Selectors > Basic

multiple selector
Description: Selects the combined results of all the
specified selectors.
jQuery( "selector1, selector2,
selectorN" )

version added: 1.0

selector1: Any valid selector.
selector2: Another valid selector.
selectorN: As many more valid selectors as you like.
You can specify any number of selectors to combine into a single
result. This multiple expression combinator is an efficient way to
select disparate elements. The order of the DOM elements in the
returned jQuery object may not be identical, as they will be in
document order. An alternative to this combinator is the .add()
method.

Examples:
Finds the elements that match any of these
three selectors.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<!DOCTYPE html>
<html>
<head>
<style>
div,span,p {
width: 126px;
height: 60px;
float:left;
padding: 3px;
margin: 2px;
background-color: #EEEEEE;
font-size:14px;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>div</div>
<p class="myClass">p class="myClass"</p>
<p class="notMyClass">p class="notMyClass"</p
<span>span</span>
<script>$("div,span,p.myClass").css("border","3px solid
</body>
</html>

Demo
Example:
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30
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Show the order in the jQuery object.

<!DOCTYPE html>
<html>
<head>
<style>
b { color:red; font-size:16px; display:block;
div,span,p { width: 40px; height: 40px; float
margin: 10px; background-color: blue;
padding:3px; color:white;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<span>span</span>
<p>p</p>
<p>p</p>
<div>div</div>
<span>span</span>
<p>p</p>
<div>div</div>
<b></b>
<script>
var list = $("div,p,span").map(function () {
return this.tagName;
}).get().join(", ");
$("b").append(document.createTextNode(list));
</script>
</body>
</html>

Demo
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.next()
Categories: Traversing > Tree Traversal

.next( [selector ] )

Returns: jQuery

Description: Get the immediately following sibling of
each element in the set of matched elements. If a
selector is provided, it retrieves the next sibling only if it
matches that selector.
.next( [selector ] )

version added: 1.0

selector
Type: Selector
A string containing a selector expression to match elements
against.
Given a jQuery object that represents a set of DOM elements, the
.next() method allows us to search through the immediately
following sibling of these elements in the DOM tree and construct a
new jQuery object from the matching elements.
The method optionally accepts a selector expression of the same
type that we can pass to the $() function. If the immediately
following sibling matches the selector, it remains in the newly
constructed jQuery object; otherwise, it is excluded.
Consider a page with a simple list on it:
1
2
3
4
5
6
7

<ul>
<li>list item 1</li>
<li>list item 2</li>
<li class="third-item">list item 3</li>
<li>list item 4</li>
<li>list item 5</li>
</ul>

If we begin at the third item, we can find the element which comes
just after it:

1

$('li.third-item').next().css('background-color'

The result of this call is a red background behind item 4. Since we
do not supply a selector expression, this following element is
unequivocally included as part of the object. If we had supplied one,
the element would be tested for a match before it was included.

Examples:
Find the very next sibling of each disabled
button and change its text "this button is disabled".
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

<!DOCTYPE html>
<html>
<head>
<style>
span { color:blue; font-weight:bold; }
button { width:100px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div><button disabled="disabled">First</button
<div><button>Second</button> - <span></span></

<div><button disabled="disabled">Third</button
<script>$("button[disabled]").next().text("this button i
</body>
</html>

Demo
Example:

Find the very next sibling of each paragraph.
Keep only the ones with a class "selected".
1
2
3
4

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"

5
6
7
8
9
10
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</head>
<body>
<p>Hello</p>
<p class="selected">Hello Again</p>
<div><span>And Again</span></div>
<script>$("p").next(".selected").css("background"
</body>
</html>

Demo
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Next Adjacent Selector (“prev +
next”)
Categories: Selectors > Hierarchy

next adjacent selector
Description: Selects all next elements matching "next"
that are immediately preceded by a sibling "prev".
jQuery( "prev + next" )

version added: 1.0

prev: Any valid selector.
next: A selector to match the element that is next to the first
selector.
One important point to consider with both the next adjacent sibling
selector ( prev + next ) and the general sibling selector ( prev ~
siblings ) is that the elements on either side of the combinator must
share the same parent.

Example:
Finds all inputs that are next to a label.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<label>Name:</label>
<input name="name" />
<fieldset>
<label>Newsletter:</label>
<input name="newsletter" />
</fieldset>
</form>
<input name="none" />
<script>$("label + input").css("color", "blue").val(
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

Next Siblings Selector (“prev ~
siblings”)
Categories: Selectors > Hierarchy

next siblings selector
Description: Selects all sibling elements that follow
after the "prev" element, have the same parent, and
match the filtering "siblings" selector.
jQuery( "prev ~ siblings" )

version added: 1.0

prev: Any valid selector.
siblings: A selector to filter elements that are the following
siblings of the first selector.
The notable difference between ( prev + next ) and ( prev ~ siblings )
is their respective reach. While the former reaches only to the
immediately following sibling element, the latter extends that reach
to all following sibling elements.

Example:
Finds all divs that are siblings after the element with
#prev as its id. Notice the span isn't selected since it is
not a div and the "niece" isn't selected since it is a
child of a sibling, not an actual sibling.
1
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6
7
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14
15
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<!DOCTYPE html>
<html>
<head>
<style>
div,span {
display:block;
width:80px;
height:80px;
margin:5px;
background:#bbffaa;
float:left;
font-size:14px;
}
div#small {
width:60px;
height:25px;
font-size:12px;
background:#fab;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>div (doesn't match since before #prev)</
<span id="prev">span#prev</span>
<div>div sibling</div>
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<div>div sibling <div id="small">div niece</div
<span>span sibling (not div)</span>
<div>div sibling</div>
<script>$("#prev ~ div").css("border", "3px groove blue"
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.nextAll()
Categories: Traversing > Tree Traversal

.nextAll( [selector ] )

Returns: jQuery

Description: Get all following siblings of each element
in the set of matched elements, optionally filtered by a
selector.
.nextAll( [selector ] )

version added: 1.2

selector
Type: String
A string containing a selector expression to match elements
against.
Given a jQuery object that represents a set of DOM elements, the
.nextAll() method allows us to search through the successors of
these elements in the DOM tree and construct a new jQuery object
from the matching elements.
The method optionally accepts a selector expression of the same
type that we can pass to the $() function. If the selector is supplied,
the elements will be filtered by testing whether they match it.
Consider a page with a simple list on it:
1
2
3
4
5
6
7

<ul>
<li>list item 1</li>
<li>list item 2</li>
<li class="third-item">list item 3</li>
<li>list item 4</li>
<li>list item 5</li>
</ul>

If we begin at the third item, we can find the elements which come
after it:
1

$('li.third-item').nextAll().css('background-color'

The result of this call is a red background behind items 4 and 5.
Since we do not supply a selector expression, these following
elements are unequivocally included as part of the object. If we had
supplied one, the elements would be tested for a match before they
were included.

Examples:
Locate all the divs after the first and give
them a class.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

<!DOCTYPE html>
<html>
<head>
<style>
div { width: 80px; height: 80px; background:
border: 2px solid black; margin: 10px;
div.after { border-color: red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>first</div>
<div>sibling<div>child</div></div>
<div>sibling</div>
<div>sibling</div>
<script>$("div:first").nextAll().addClass("after"
</body>
</html>

Demo
Example:

Locate all the paragraphs after the second
child in the body and give them a class.
1
2
3

<!DOCTYPE html>
<html>
<head>

4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25

<style>
div, p { width: 60px; height: 60px; background:
border: 2px solid black; margin: 10px;
.after { border-color: red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>p</p>
<div>div</div>
<p>p</p>
<p>p</p>
<div>div</div>
<p>p</p>
<div>div</div>
<script>
$(":nth-child(1)").nextAll("p").addClass("after"
</script>
</body>
</html>

Demo
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.nextUntil()
Categories: Traversing > Tree Traversal

.nextUntil( [selector ] [, filter ] )

Returns: jQuery

Description: Get all following siblings of each element
up to but not including the element matched by the
selector, DOM node, or jQuery object passed.
.nextUntil( [selector ] [, filter ] )

version added: 1.4

selector
Type: Selector
A string containing a selector expression to indicate where to
stop matching following sibling elements.
filter
Type: Selector
A string containing a selector expression to match elements
against.

.nextUntil( [element ] [, filter ] )

version added: 1.6

element
Type: Element
A DOM node or jQuery object indicating where to stop matching
following sibling elements.
filter
Type: Selector
A string containing a selector expression to match elements
against.
Given a selector expression that represents a set of DOM elements,
the .nextUntil() method searches through the successors of these
elements in the DOM tree, stopping when it reaches an element
matched by the method's argument. The new jQuery object that is
returned contains all following siblings up to but not including the
one matched by the .nextUntil() argument.
If the selector is not matched or is not supplied, all following siblings
will be selected; in these cases it selects the same elements as the
.nextAll() method does when no filter selector is provided.

As of jQuery 1.6, A DOM node or jQuery object, instead of a
selector, may be passed to the .nextUntil() method.
The method optionally accepts a selector expression for its second
argument. If this argument is supplied, the elements will be filtered
by testing whether they match it.

Example:
Find the siblings that follow <dt id="term-2"> up to
the next <dt> and give them a red background color.
Also, find <dd> siblings that follow <dt id="term-1"> up
to <dt id="term-3"> and give them a green text color.
1
2
3
4
5
6
7
8
9
10
11
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13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<dl>
<dt id="term-1">term 1</dt>
<dd>definition 1-a</dd>
<dd>definition 1-b</dd>
<dd>definition 1-c</dd>
<dd>definition 1-d</dd>
<dt id="term-2">term 2</dt>
<dd>definition 2-a</dd>
<dd>definition 2-b</dd>
<dd>definition 2-c</dd>
<dt id="term-3">term 3</dt>
<dd>definition 3-a</dd>
<dd>definition 3-b</dd>
</dl>
<script>
$("#term-2").nextUntil("dt")
.css("background-color", "red");
var term3 = document.getElementById("term-3");
$("#term-1").nextUntil(term3, "dd")
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.css("color", "green");
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
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.not()
Categories: Traversing > Filtering | Traversing > Miscellaneous Traversing

.not( selector )

Returns: jQuery

Description: Remove elements from the set of matched
elements.
.not( selector )

version added: 1.0

selector
Type: Selector
A string containing a selector expression to match elements
against.

.not( elements )

version added: 1.0

elements
Type: Elements
One or more DOM elements to remove from the matched set.

.not( function(index) )

version added: 1.4

function(index)
Type: Function()
A function used as a test for each element in the set.
current DOM element.

.not( jQuery object )

this

is the

version added: 1.4

jQuery object
Type: PlainObject
An existing jQuery object to match the current set of elements
against.
Given a jQuery object that represents a set of DOM elements, the
.not() method constructs a new jQuery object from a subset of the
matching elements. The supplied selector is tested against each
element; the elements that don't match the selector will be included
in the result.
Consider a page with a simple list on it:

1
2
3
4
5
6
7

<ul>
<li>list
<li>list
<li>list
<li>list
<li>list
</ul>

item
item
item
item
item

1</li>
2</li>
3</li>
4</li>
5</li>

We can apply this method to the set of list items:
1

$('li').not(':even').css('background-color', 'red'

The result of this call is a red background for items 2 and 4, as they
do not match the selector (recall that :even and :odd use 0-based
indexing).
Removing Specific Elements
The second version of the .not() method allows us to remove
elements from the matched set, assuming we have found those
elements previously by some other means. For example, suppose
our list had an id applied to one of its items:
1
2
3
4
5
6
7

<ul>
<li>list item 1</li>
<li>list item 2</li>
<li id="notli">list item 3</li>
<li>list item 4</li>
<li>list item 5</li>
</ul>

We can fetch the third list item using the native JavaScript
getElementById() function, then remove it from a jQuery object:

1
2

$('li').not(document.getElementById('notli'))
.css('background-color', 'red');

This statement changes the color of items 1, 2, 4, and 5. We could
have accomplished the same thing with a simpler jQuery expression,
but this technique can be useful when, for example, other libraries
provide references to plain DOM nodes.
As of jQuery 1.4, the .not() method can take a function as its
argument in the same way that .filter() does. Elements for which
the function returns true are excluded from the filtered set; all other
elements are included.

Examples:
Example:

Adds a border to divs that are not green or

blue.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
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22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
div { width:50px; height:50px; margin:10px; float
background:yellow; border:2px solid white;
.green { background:#8f8; }
.gray { background:#ccc; }
#blueone { background:#99f; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div>
<div id="blueone"></div>
<div></div>
<div class="green"></div>
<div class="green"></div>
<div class="gray"></div>
<div></div>
<script>
$("div").not(".green, #blueone")
.css("border-color", "red");
</script>
</body>
</html>

Demo
Example:

Removes the element with the ID "selected"
from the set of all paragraphs.
1

$("p").not( $("#selected")[0] )

Removes the element with the ID "selected"
from the set of all paragraphs.
Example:

1

$("p").not("#selected")

Removes all elements that match "div
p.selected" from the total set of all paragraphs.
Example:

1

$("p").not($("div p.selected"))

POWERED BYHERONOTE
A new version of this book is available!

:not() Selector
Categories: Selectors > Basic Filter

not selector
Description: Selects all elements that do not match the
given selector.
jQuery( ":not(selector)" )

version added: 1.0

selector: A selector with which to filter by.
All selectors are accepted inside
and :not(div,a) .

:not() ,

for example:

:not(div a)

Additional Notes
The .not() method will end up providing you with more readable
selections than pushing complex selectors or variables into a :not()
selector filter. In most cases, it is a better choice.

Example:
Finds all inputs that are not checked and highlights
the next sibling span. Notice there is no change when
clicking the checkboxes since no click events have
been linked.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<input type="checkbox" name="a" />
<span>Mary</span>
</div>
<div>
<input type="checkbox" name="b" />
<span>lcm</span>
</div>
<div>
<input type="checkbox" name="c" checked="checked"

<span>Peter</span>
</div>
<script>
$("input:not(:checked) + span").css("background-color"
$("input").attr("disabled", "disabled");
</script>
</body>
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Demo
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:nth-child() Selector
Categories: Selectors > Child Filter

nth-child selector
Description: Selects all elements that are the nth-child
of their parent.
jQuery( ":nthchild(index/even/odd/equation)" )

version added: 1.1.4

index: The index of each child to match, starting with 1 , the string
even or odd , or an equation ( eg. :nth-child(even) , :nthchild(4n) )
Because jQuery's implementation of :nth- selectors is strictly
derived from the CSS specification, the value of n is "1-indexed",
meaning that the counting starts at 1. For other selector expressions
such as :eq() or :even jQuery follows JavaScript's "0-indexed"
counting. Given a single <ul> containing two <li> s, $('li:nthchild(1)') selects the first <li> while $('li:eq(1)') selects the
second.
The :nth-child(n) pseudo-class is easily confused with :eq(n) ,
even though the two can result in dramatically different matched
elements. With :nth-child(n) , all children are counted, regardless of
what they are, and the specified element is selected only if it
matches the selector attached to the pseudo-class. With :eq(n) only
the selector attached to the pseudo-class is counted, not limited to
children of any other element, and the (n+1)th one (n is 0-based) is
selected.
Further discussion of this unusual usage can be found in the W3C
CSS specification.

Examples:
Example:

Find the second li in each matched ul and

note it.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
div { float:left; }
span { color:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<ul>
<li>John</li>
<li>Karl</li>
<li>Brandon</li>
</ul>
</div>
<div>
<ul>
<li>Sam</li>
</ul>
</div>
<div>
<ul>
<li>Glen</li>
<li>Tane</li>
<li>Ralph</li>
<li>David</li>
</ul>

31
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</div>
<script>$("ul li:nth-child(2)").append("<span> - 2nd!</s
</body>
</html>

Demo
Example:

This is a playground to see how the selector
works with different strings. Notice that this is different
from the :even and :odd which have no regard for
parent and just filter the list of elements to every other
one. The :nth-child, however, counts the index of the
child to its particular parent. In any case, it's easier to
see than explain so...
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<!DOCTYPE html>
<html>
<head>
<style>
button { display:block; font-size:12px; width:100
div { float:left; margin:10px; font-size:10px;
border:1px solid black; }
span { color:blue; font-size:18px; }
#inner { color:red; }
td { width:50px; text-align:center; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<button>:nth-child(even)</button>
<button>:nth-child(odd)</button>
<button>:nth-child(3n)</button>
<button>:nth-child(2)</button>
</div>
<div>
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40
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44
45
46
47
48
49
50
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54
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56
57
58

<button>:nth-child(3n+1)</button>
<button>:nth-child(3n+2)</button>
<button>:even</button>
<button>:odd</button>
</div>
<div>
<table>
<tr><td>John</td></tr>
<tr><td>Karl</td></tr>
<tr><td>Brandon</td></tr>
<tr><td>Benjamin</td></tr>
</table>
</div>
<div>
<table>
<tr><td>Sam</td></tr>
</table>
</div>
<div>
<table>
<tr><td>Glen</td></tr>
<tr><td>Tane</td></tr>
<tr><td>Ralph</td></tr>
<tr><td>David</td></tr>
<tr><td>Mike</td></tr>
<tr><td>Dan</td></tr>
</table>
</div>
<span>tr<span id="inner"></span></span>
<script>
$("button").click(function () {
var str = $(this).text();
$("tr").css("background", "white");
$("tr" + str).css("background", "#ff0000");
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$("#inner").text(str);
});
</script>
</body>
</html>

Demo
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:nth-last-child() Selector
Categories: Selectors > Child Filter

nth-last-child selector
Description: Selects all elements that are the nth-child
of their parent, counting from the last element to the first.
jQuery( ":nth-lastchild(index/even/odd/equation)" )

version added: 1.9

index: The index of each child to match, starting with the last one
( 1 ), the string even or odd , or an equation ( eg. :nth-lastchild(even) , :nth-last-child(4n) )
Because jQuery's implementation of :nth- selectors is strictly
derived from the CSS specification, the value of n is "1-indexed",
meaning that the counting starts at 1. For other selector expressions
such as :eq() or :even jQuery follows JavaScript's "0-indexed"
counting. Given a single <ul> containing three <li> s, $('li:nthlast-child(1)') selects the third, last, <li> .
Further discussion of this usage can be found in the W3C CSS
specification.

Examples:
Find the second to last li in each matched ul
and note it.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
div { float:left; }
span { color:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<ul>
<li>John</li>
<li>Karl</li>
<li>Adam</li>
</ul>
</div>
<div>
<ul>
<li>Dan</li>
</ul>
</div>
<div>
<ul>
<li>Dave</li>
<li>Rick</li>
<li>Timmy</li>
<li>Gibson</li>
</ul>
</div>
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<script>$("ul li:nth-last-child(2)").append("<span> - 2n
</body>
</html>

Demo
Example:

This is a playground to see how the selector
works with different strings.
1
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<!DOCTYPE html>
<html>
<head>
<style>
button { display:block; font-size:12px; width:100
div { float:left; margin:10px; font-size:10px;
border:1px solid black; }
span { color:blue; font-size:18px; }
#inner { color:red; }
td { width:50px; text-align:center; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<button>:nth-last-child(even)</button>
<button>:nth-last-child(odd)</button>
<button>:nth-last-child(3n)</button>
<button>:nth-last-child(2)</button>
</div>
<div>
<button>:nth-last-child(3n+1)</button>
<button>:nth-last-child(3n+2)</button>
</div>
<div>
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<table>
<tr><td>John</td></tr>
<tr><td>Karl</td></tr>
<tr><td>Brandon</td></tr>
<tr><td>Benjamin</td></tr>
</table>
</div>
<div>
<table>
<tr><td>Sam</td></tr>
</table>
</div>
<div>
<table>
<tr><td>Glen</td></tr>
<tr><td>Tane</td></tr>
<tr><td>Ralph</td></tr>
<tr><td>David</td></tr>
<tr><td>Mike</td></tr>
<tr><td>Dan</td></tr>
</table>
</div>
<span>tr<span id="inner"></span></span>
<script>
$("button").click(function () {
var str = $(this).text();
$("tr").css("background", "white");
$("tr" + str).css("background", "#ff0000");
$("#inner").text(str);
});
</script>
</body>
</html>

Demo
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A new version of this book is available!

:nth-last-of-type() Selector
Categories: Selectors > Child Filter

nth-last-of-type selector
Description: Selects all elements that are the nth-child
of their parent, counting from the last element to the first.
jQuery( ":nth-last-oftype(index/even/odd/equation)" )

version added: 1.9

index: The index of each child to match, starting with the last one
( 1 ), the string even or odd , or an equation ( eg. :nth-last-oftype(even) , :nth-last-of-type(4n) )
Because jQuery's implementation of :nth- selectors is strictly
derived from the CSS specification, the value of n is "1-indexed",
meaning that the counting starts at 1. For other selector expressions
such as :eq() or :even jQuery follows JavaScript's "0-indexed"
counting. Given a single <ul> containing three <li> s, $('li:nthlast-of-type(1)') selects the third, last, <li> .
Further discussion of this usage can be found in the W3C CSS
specification.

Examples:
Find the second to last li in each matched ul
and note it.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
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22
23
24
25
26
27
28
29
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<!DOCTYPE html>
<html>
<head>
<style>
div { float:left; }
span { color:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<ul>
<li>John</li>
<li>Karl</li>
<li>Adam</li>
</ul>
</div>
<div>
<ul>
<li>Dan</li>
</ul>
</div>
<div>
<ul>
<li>Dave</li>
<li>Rick</li>
<li>Timmy</li>
<li>Gibson</li>
</ul>
</div>

31
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<script>$("ul li:nth-last-of-type(2)").append("<span> </body>
</html>

Demo
Example:

This is a playground to see how the selector
works with different strings.
1
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<!DOCTYPE html>
<html>
<head>
<style>
button { display:block; font-size:12px; width:100
div { float:left; margin:10px; font-size:10px;
border:1px solid black; }
span { color:blue; font-size:18px; }
#inner { color:red; }
td { width:50px; text-align:center; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<button>:nth-last-of-type(even)</button>
<button>:nth-last-of-type(odd)</button>
<button>:nth-last-of-type(3n)</button>
<button>:nth-last-of-type(2)</button>
</div>
<div>
<button>:nth-last-of-type(3n+1)</button>
<button>:nth-last-of-type(3n+2)</button>
</div>
<div>
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<table>
<tr><td>John</td></tr>
<tr><td>Karl</td></tr>
<tr><td>Brandon</td></tr>
<tr><td>Benjamin</td></tr>
</table>
</div>
<div>
<table>
<tr><td>Sam</td></tr>
</table>
</div>
<div>
<table>
<tr><td>Glen</td></tr>
<tr><td>Tane</td></tr>
<tr><td>Ralph</td></tr>
<tr><td>David</td></tr>
<tr><td>Mike</td></tr>
<tr><td>Dan</td></tr>
</table>
</div>
<span>tr<span id="inner"></span></span>
<script>
$("button").click(function () {
var str = $(this).text();
$("tr").css("background", "white");
$("tr" + str).css("background", "#ff0000");
$("#inner").text(str);
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

:nth-of-type() Selector
Categories: Selectors > Child Filter

nth-of-type selector
Description: Selects all elements that are the nth child
of their parent in relation to siblings with the same
element name.
jQuery( ":nth-oftype(index/even/odd/equation)" )

version added: 1.9

index: The index of each child to match, starting with
even or odd , or an equation ( eg. :nth-of-type(even) ,
type(4n) )

1 , the string
:nth-of-

Because jQuery's implementation of :nth- selectors is strictly
derived from the CSS specification, the value of n is "1-indexed",
meaning that the counting starts at 1. For other selector expressions
such as :eq() or :even jQuery follows JavaScript's "0-indexed"
counting.
Further discussion of this usage can be found in the W3C CSS
specification.

Example:
Find each span that is second in relation to its sibling
spans.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
.nth { color: red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<span>John</span>,
<b>Kim</b>,
<span>Adam</span>,
<b>Rafael</b>,
<span>Oleg</span>
</div>
<div>
<b>Dave</b>,
<span>Ann</span>
</div>
<div>
<i><span>Maurice</span></i>,
<span>Richard</span>,
<span>Ralph</span>,
<span>Jason</span>
</div>
<script>
$( "span:nth-of-type(2)" )
.append( "<span> is 2nd sibling span</span>" )
.addClass( "nth" );

31
32
33
34

</script>
</body>
</html>

Demo
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:odd Selector
Categories: Selectors > Basic Filter | Selectors > jQuery Extensions

odd selector
Description: Selects odd elements, zero-indexed. See
also even.
jQuery( ":odd" )

version added: 1.0

In particular, note that the 0-based indexing means that, counterintuitively, :odd selects the second element, fourth element, and so
on within the matched set.

Additional Notes:
Because :odd is a jQuery extension and not part of the CSS
specification, queries using :odd cannot take advantage of the
performance boost provided by the native DOM
querySelectorAll() method. To achieve the best performance
when using :odd to select elements, first select the elements
using a pure CSS selector, then use .filter(":odd") .
Selected elements are in the order of their appearance in the
document.

Example:
Finds odd table rows, matching the second, fourth
and so on (index 1, 3, 5 etc.).
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22

<!DOCTYPE html>
<html>
<head>
<style>
table {
background:#f3f7f5;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<table border="1">
<tr><td>Row with Index #0</td></tr>
<tr><td>Row with Index #1</td></tr>
<tr><td>Row with Index #2</td></tr>
<tr><td>Row with Index #3</td></tr>
</table>
<script>$("tr:odd").css("background-color", "#bbbbff"
</body>
</html>

Demo
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.off()
Categories: Events > Event Handler Attachment

.off( events [, selector ] [, handler(eventObject) ] )
Returns: jQuery
Description: Remove an event handler.
.off( events [, selector ] [,
handler(eventObject) ] )

version added: 1.7

events
Type: String
One or more space-separated event types and optional
namespaces, or just namespaces, such as "click",
"keydown.myPlugin", or ".myPlugin".
selector
Type: String
A selector which should match the one originally passed to
.on() when attaching event handlers.
handler(eventObject)
Type: Function()
A handler function previously attached for the event(s), or the
special value false .

.off( events [, selector ] )

version added: 1.7

events
Type: PlainObject
An object where the string keys represent one or more spaceseparated event types and optional namespaces, and the
values represent handler functions previously attached for the
event(s).
selector
Type: String
A selector which should match the one originally passed to
.on() when attaching event handlers.
The

off() method removes event handlers that were attached with
.on() . See the discussion of delegated and directly bound events on

that page for more information. Specific event handlers can be
removed on elements by providing combinations of event names,
namespaces, selectors, or handler function names. When multiple
filtering arguments are given, all of the arguments provided
must match for the event handler to be removed.
If a simple event name such as "click" is provided, all events of
that type (both direct and delegated) are removed from the elements
in the jQuery set. When writing code that will be used as a plugin, or
simply when working with a large code base, best practice is to
attach and remove events using namespaces so that the code will
not inadvertently remove event handlers attached by other code. All
events of all types in a specific namespace can be removed from an
element by providing just a namespace, such as ".myPlugin" . At
minimum, either a namespace or event name must be provided.
To remove specific delegated event handlers, provide a selector
argument. The selector string must exactly match the one passed to
.on() when the event handler was attached. To remove all
delegated events from an element without removing non-delegated
events, use the special value "**" .
A handler can also be removed by specifying the function name in
the handler argument. When jQuery attaches an event handler, it
assigns a unique id to the handler function. Handlers proxied by
jQuery.proxy() or a similar mechanism will all have the same unique
id (the proxy function), so passing proxied handlers to .off may
remove more handlers than intended. In those situations it is better
to attach and remove event handlers using namespaces.
As with .on() , you can pass events as an object instead of
specifying an events string and handler function as separate
arguments. The keys for the events object are events and/or
namespaces; the values are handler functions or the special value
false .

Examples:
Add and remove event handlers on the
colored button.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
button { margin:5px; }
button#theone { color:red; background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="theone">Does nothing...</button>
<button id="bind">Add Click</button>
<button id="unbind">Remove Click</button>
<div style="display:none;">Click!</div>
<script>
function aClick() {
$("div").show().fadeOut("slow");
}
$("#bind").click(function () {
$("body").on("click", "#theone", aClick)
.find("#theone").text("Can Click!");
});
$("#unbind").click(function () {
$("body").off("click", "#theone", aClick)
.find("#theone").text("Does nothing...");
});
</script>
</body>
</html>

Demo
Example:

Remove all event handlers from all
paragraphs:
1

$("p").off()

Remove all delegated click handlers from all
paragraphs:
Example:

1

$("p").off( "click", "**" )

Remove just one previously bound handler
by passing it as the third argument:
Example:

var foo = function () {
// code to handle some kind of event
};

1
2
3
4
5
6
7
8
9

// ... now foo will be called when paragraphs are clicked
$("body").on("click", "p", foo);
// ... foo will no longer be called.
$("body").off("click", "p", foo);

Unbind all delegated event handlers by their
namespace:
Example:

1
2
3

var validate = function () {
// code to validate form entries
};

4
5
6
7
8
9
10
11
12

// delegate events under the ".validator" namespace
$("form").on("click.validator", "button", validate);
$("form").on("keypress.validator", "input[type='text']"
// remove event handlers in the ".validator" namespace
$("form").off(".validator");

POWERED BYHERONOTE
A new version of this book is available!

.offset()
Categories: CSS | Offset | Manipulation > Style Properties

Get the current coordinates of the first element, or set the coordinates
of every element, in the set of matched elements, relative to the
document.
Contents:
.offset()
.offset()
.offset( coordinates )
.offset( coordinates )
.offset( function(index, coords) )

.offset()

Returns: Object

Description: Get the current coordinates of the first
element in the set of matched elements, relative to the
document.
.offset()

version added: 1.2

This method does not accept any arguments.
The .offset() method allows us to retrieve the current position of an
element relative to the document. Contrast this with .position() ,
which retrieves the current position relative to the offset parent.
When positioning a new element on top of an existing one for global
manipulation (in particular, for implementing drag-and-drop),
.offset() is the more useful.
.offset()

returns an object containing the properties

top

and

left .

Note: jQuery does not support getting the
offset coordinates of hidden elements or
accounting for borders, margins, or padding
set on the body element.
While it is possible to get the coordinates of
elements with visibility:hidden set, display:none is
excluded from the rendering tree and thus
has a position that is undefined.

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<!DOCTYPE html>
<html>
<head>
<style>
p { margin-left:10px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p><p>2nd Paragraph</p>
<script>var p = $("p:last");
var offset = p.offset();
p.html( "left: " + offset.left + ", top: " + offset.top
</body>
</html>

Demo
Example:
1
2
3
4
5
6
7
8
9

Access the offset of the second paragraph:

Click to see the offset.

<!DOCTYPE html>
<html>
<head>
<style>
p { margin-left:10px; color:blue; width:200px;
cursor:pointer; }
span { color:red; cursor:pointer; }
div.abs { width:50px; height:50px; position:absolute;
left:220px; top:35px; background-color

10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34

Demo

cursor:pointer; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="result">Click an element.</div>
<p>
This is the best way to <span>find</span> an offset.
</p>
<div class="abs">
</div>
<script>
$("*", document.body).click(function (e) {
var offset = $(this).offset();
e.stopPropagation();
$("#result").text(this.tagName + " coords ( "
offset.top +
});
</script>
</body>
</html>

.offset( coordinates )

Returns: jQuery

Description: Set the current coordinates of every
element in the set of matched elements, relative to the
document.
.offset( coordinates )

version added: 1.4

coordinates
Type: PlainObject
An object containing the properties top and left , which are
integers indicating the new top and left coordinates for the
elements.

.offset( function(index, coords) )

version added: 1.4

function(index, coords)
Type: Function()
A function to return the coordinates to set. Receives the index
of the element in the collection as the first argument and the
current coordinates as the second argument. The function
should return an object with the new top and left properties.
The .offset() setter method allows us to reposition an element. The
element's position is specified relative to the document. If the
element's position style property is currently static , it will be set to
relative to allow for this repositioning.

Example:
Set the offset of the second paragraph:
1
2
3
4
5
6
7
8
9
10
11
12

<!DOCTYPE html>
<html>
<head>
<style>p { margin-left:10px; } </style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p><p>2nd Paragraph</p>
<script>$("p:last").offset({ top: 10, left: 30 });
</body>
</html>

Demo
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.offsetParent()
Categories: Offset | Traversing > Tree Traversal

.offsetParent()

Returns: jQuery

Description: Get the closest ancestor element that is
positioned.
.offsetParent()

version added: 1.2.6

This method does not accept any arguments.
Given a jQuery object that represents a set of DOM elements, the
.offsetParent() method allows us to search through the ancestors
of these elements in the DOM tree and construct a new jQuery
object wrapped around the closest positioned ancestor. An element
is said to be positioned if it has a CSS position attribute of relative ,
absolute , or fixed . This information is useful for calculating offsets
for performing animations and placing objects on the page.
Consider a page with a basic nested list on it, with a positioned
element:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<ul class="level-1">
<li class="item-i">I</li>
<li class="item-ii" style="position: relative;"
<ul class="level-2">
<li class="item-a">A</li>
<li class="item-b">B
<ul class="level-3">
<li class="item-1">1</li>
<li class="item-2">2</li>
<li class="item-3">3</li>
</ul>
</li>
<li class="item-c">C</li>
</ul>
</li>
<li class="item-iii">III</li>

17

</ul>

If we begin at item A, we can find its positioned ancestor:
1

$('li.item-a').offsetParent().css('background-color'

This will change the color of list item II, which is positioned.

Example:
Find the offsetParent of item "A."
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

<ul class="level-1">
<li class="item-i">I</li>
<li class="item-ii" style="position: relative;"
<ul class="level-2">
<li class="item-a">A</li>
<li class="item-b">B
<ul class="level-3">
<li class="item-1">1</li>
<li class="item-2">2</li>
<li class="item-3">3</li>
</ul>
</li>
<li class="item-c">C</li>
</ul>
</li>
<li class="item-iii">III</li>
</ul>
<script>$('li.item-a').offsetParent().css('background-co
</body>
</html>

Demo
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.on()
Categories: Events > Event Handler Attachment

.on( events [, selector ] [, data ], handler(eventObject) )
Returns: jQuery
Description: Attach an event handler function for one or
more events to the selected elements.
.on( events [, selector ] [, data ],
handler(eventObject) )

version added: 1.7

events
Type: String
One or more space-separated event types and optional
namespaces, such as "click" or "keydown.myPlugin".
selector
Type: String
A selector string to filter the descendants of the selected
elements that trigger the event. If the selector is null or
omitted, the event is always triggered when it reaches the
selected element.
data
Type: Anything
Data to be passed to the handler in
is triggered.

event.data

when an event

handler(eventObject)
Type: Function()
A function to execute when the event is triggered. The value
false is also allowed as a shorthand for a function that simply
does return false .

.on( events [, selector ] [, data ] )

version added: 1.7

events
Type: PlainObject
An object in which the string keys represent one or more spaceseparated event types and optional namespaces, and the
values represent a handler function to be called for the event(s).

selector
Type: String
A selector string to filter the descendants of the selected
elements that will call the handler. If the selector is null or
omitted, the handler is always called when it reaches the
selected element.
data
Type: Anything
Data to be passed to the handler in
occurs.

event.data

when an event

The .on() method attaches event handlers to the currently selected
set of elements in the jQuery object. As of jQuery 1.7, the .on()
method provides all functionality required for attaching event
handlers. For help in converting from older jQuery event methods,
see .bind() , .delegate() , and .live() . To remove events bound
with .on() , see .off() . To attach an event that runs only once and
then removes itself, see .one()

Event names and namespaces
Any event names can be used for the events argument. jQuery will
pass through the browser's standard JavaScript event types, calling
the handler function when the browser generates events due to user
actions such as click . In addition, the .trigger() method can
trigger both standard browser event names and custom event
names to call attached handlers.
An event name can be qualified by event namespaces that simplify
removing or triggering the event. For example,
"click.myPlugin.simple" defines both the myPlugin and simple
namespaces for this particular click event. A click event handler
attached via that string could be removed with
.off("click.myPlugin") or .off("click.simple") without disturbing
other click handlers attached to the elements. Namespaces are
similar to CSS classes in that they are not hierarchical; only one
name needs to match. Namespaces beginning with an underscore
are reserved for jQuery's use.
In the second form of .on() , the events argument is a plain object.
The keys are strings in the same form as the events argument with
space-separated event type names and optional namespaces. The
value for each key is a function (or false value) that is used as the
handler instead of the final argument to the method. In other
respects, the two forms are identical in their behavior as described
below.

Direct and delegated events
The majority of browser events bubble, or propagate, from the
deepest, innermost element (the event target) in the document
where they occur all the way up to the body and the document
element. In Internet Explorer 8 and lower, a few events such as
change and submit do not natively bubble but jQuery patches these
to bubble and create consistent cross-browser behavior.
If selector is omitted or is null, the event handler is referred to as
direct or directly-bound. The handler is called every time an event
occurs on the selected elements, whether it occurs directly on the
element or bubbles from a descendant (inner) element.
When a selector is provided, the event handler is referred to as
delegated. The handler is not called when the event occurs directly
on the bound element, but only for descendants (inner elements)
that match the selector. jQuery bubbles the event from the event
target up to the element where the handler is attached (i.e.,
innermost to outermost element) and runs the handler for any
elements along that path matching the selector.
Event handlers are bound only to the currently selected
elements; they must exist on the page at the time your code
makes the call to .on() . To ensure the elements are present and
can be selected, perform event binding inside a document ready
handler for elements that are in the HTML markup on the page. If
new HTML is being injected into the page, select the elements and
attach event handlers after the new HTML is placed into the page.
Or, use delegated events to attach an event handler, as described
next.
Delegated events have the advantage that they can process events
from descendant elements that are added to the document at a later
time. By picking an element that is guaranteed to be present at the
time the delegated event handler is attached, you can use delegated
events to avoid the need to frequently attach and remove event
handlers. This element could be the container element of a view in a
Model-View-Controller design, for example, or document if the event
handler wants to monitor all bubbling events in the document. The

element is available in the head of the document before
loading any other HTML, so it is safe to attach events there without
waiting for the document to be ready.
document

In addition to their ability to handle events on descendant elements
not yet created, another advantage of delegated events is their
potential for much lower overhead when many elements must be
monitored. On a data table with 1,000 rows in its tbody , this example
attaches a handler to 1,000 elements:
1
2
3

$("#dataTable tbody tr").on("click", function(event){
alert($(this).text());
});

A delegated-events approach attaches an event handler to only one
element, the tbody, and the event only needs to bubble up one level
(from the clicked tr to tbody ):
1
2
3

$("#dataTable tbody").on("click", "tr", function
alert($(this).text());
});

Note: Delegated events do not work for SVG.

The event handler and its environment
The handler argument is a function (or the value false , see below),
and is required unless you pass an object for the events argument.
You can provide an anonymous handler function at the point of the
.on() call, as the examples have done above, or declare a named
function and pass its name:
1
2

function notify() { alert("clicked"); }
$("button").on("click", notify);

When the browser triggers an event or other JavaScript calls
jQuery's .trigger() method, jQuery passes the handler an event
object it can use to analyze and change the status of the event. This
object is a normalized subset of data provided by the browser; the
browser's unmodified native event object is available in
event.originalEvent . For example, event.type contains the event
name (e.g., "resize") and event.target indicates the deepest
(innermost) element where the event occurred.
By default, most events bubble up from the original event target to
the document element. At each element along the way, jQuery calls
any matching event handlers that have been attached. A handler
can prevent the event from bubbling further up the document tree
(and thus prevent handlers on those elements from running) by
calling event.stopPropagation() . Any other handlers attached on the
current element will run however. To prevent that, call
event.stopImmediatePropagation() . (Event handlers bound to an
element are called in the same order that they were bound.)
Similarly, a handler can call event.preventDefault() to cancel any
default action that the browser may have for this event; for example,
the default action on a click event is to follow the link. Not all
browser events have default actions, and not all default actions can
be canceled. See the W3C Events Specification for details.
Returning

false from an event handler will automatically call
event.stopPropagation() and event.preventDefault() . A false

value

can also be passed for the handler as a shorthand for function(){
return false; } . So, $("a.disabled").on("click", false); attaches
an event handler to all links with class "disabled" that prevents them
from being followed when they are clicked and also stops the event
from bubbling.
When jQuery calls a handler, the this keyword is a reference to the
element where the event is being delivered; for directly bound
events this is the element where the event was attached and for
delegated events this is an element matching selector . (Note that
this may not be equal to event.target if the event has bubbled from
a descendant element.) To create a jQuery object from the element
so that it can be used with jQuery methods, use $(this) .

Passing data to the handler
If a data argument is provided to .on() and is not null or undefined ,
it is passed to the handler in the event.data property each time an
event is triggered. The data argument can be any type, but if a
string is used the selector must either be provided or explicitly
passed as null so that the data is not mistaken for a selector. Best
practice is to use a plain object so that multiple values can be
passed as properties.
As of jQuery 1.4, the same event handler can be bound to an
element multiple times. This is especially useful when the event.data
feature is being used, or when other unique data resides in a closure
around the event handler function. For example:
1
2
3

function greet(event) { alert("Hello "+event.data.name);
$("button").on("click", { name: "Karl" }, greet);
$("button").on("click", { name: "Addy" }, greet);

The above code will generate two different alerts when the button is
clicked.
As an alternative or in addition to the data argument provided to the
.on() method, you can also pass data to an event handler using a
second argument to .trigger() or .triggerHandler().

Event performance
In most cases, an event such as click occurs infrequently and
performance is not a significant concern. However, high frequency
events such as mousemove or scroll can fire dozens of times per
second, and in those cases it becomes more important to use
events judiciously. Performance can be increased by reducing the
amount of work done in the handler itself, caching information
needed by the handler rather than recalculating it, or by rate-limiting
the number of actual page updates using setTimeout .
Attaching many delegated event handlers near the top of the
document tree can degrade performance. Each time the event
occurs, jQuery must compare all selectors of all attached events of
that type to every element in the path from the event target up to the
top of the document. For best performance, attach delegated events
at a document location as close as possible to the target elements.
Avoid excessive use of document or document.body for delegated
events on large documents.
jQuery can process simple selectors of the form tag#id.class very
quickly when they are used to filter delegated events. So, "#myForm" ,
"a.external" , and "button" are all fast selectors. Delegated events
that use more complex selectors, particularly hierarchical ones, can
be several times slower--although they are still fast enough for most
applications. Hierarchical selectors can often be avoided simply by
attaching the handler to a more appropriate point in the document.
For example, instead of $("body").on("click", "#commentForm
.addNew", addComment) use $("#commentForm").on("click", ".addNew",
addComment) .

Additional notes
There are shorthand methods for some events such as .click() that
can be used to attach or trigger event handlers. For a complete list
of shorthand methods, see the events category.
Deprecated as of jQuery 1.8: The name "hover" used as a
shorthand for the string "mouseenter mouseleave" . It attaches a single
event handler for those two events, and the handler must examine
event.type to determine whether the event is mouseenter or
mouseleave . Do not confuse the "hover" pseudo-event-name with the
.hover() method, which accepts one or two functions.
jQuery's event system requires that a DOM element allow attaching
data via a property on the element, so that events can be tracked
and delivered. The object , embed , and applet elements cannot
attach data, and therefore cannot have jQuery events bound to
them.
The focus and blur events are specified by the W3C to not bubble,
but jQuery defines cross-browser focusin and focusout events that
do bubble. When focus and blur are used to attach delegated event
handlers, jQuery maps the names and delivers them as focusin and
focusout respectively. For consistency and clarity, use the bubbling
event type names.
In all browsers, the load , scroll , and error events (e.g., on an
<img> element) do not bubble. In Internet Explorer 8 and lower, the
paste and reset events do not bubble. Such events are not
supported for use with delegation, but they can be used when the
event handler is directly attached to the element generating the
event.
The error event on the window object uses nonstandard arguments
and return value conventions, so it is not supported by jQuery.
Instead, assign a handler function directly to the window.onerror
property.

Examples:
Display a paragraph's text in an alert when it
is clicked:
Example:

1
2
3

$("p").on("click", function(){
alert( $(this).text() );
});

Pass data to the event handler, which is
specified here by name:
Example:

1
2
3
4

function myHandler(event) {
alert(event.data.foo);
}
$("p").on("click", {foo: "bar"}, myHandler)

Cancel a form submit action and prevent the
event from bubbling up by returning false :
Example:

1

$("form").on("submit", false)

Cancel only the default action by using
.preventDefault().
Example:

1
2
3

$("form").on("submit", function(event) {
event.preventDefault();
});

Example:

Stop submit events from bubbling without

preventing form submit, using .stopPropagation().
1
2
3

$("form").on("submit", function(event) {
event.stopPropagation();
});

Example:

Attach and trigger custom (non-browser)

events.
1
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<!DOCTYPE html>
<html>
<head>
<style>
p { color:red; }
span { color:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Has an attached custom event.</p>
<button>Trigger custom event</button>
<span style="display:none;"></span>
<script>
$("p").on("myCustomEvent", function(e, myName, myValue){
$(this).text(myName + ", hi there!");
$("span").stop().css("opacity", 1)
.text("myName = " + myName)
.fadeIn(30).fadeOut(1000);
});
$("button").click(function () {
$("p").trigger("myCustomEvent", [ "John" ]);
});
</script>
</body>
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</html>

Demo
Example:

Attach multiple event handlers
simultaneously using a plain object.
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21
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Demo

<!DOCTYPE html>
<html>
<head>
<style>
.test { color: #000; padding: .5em; border: 1px solid
.active { color: #900;}
.inside { background-color: aqua; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div class="test">test div</div>
<script>$("div.test").on({
click: function(){
$(this).toggleClass("active");
},
mouseenter: function(){
$(this).addClass("inside");
},
mouseleave: function(){
$(this).removeClass("inside");
}
});</script>
</body>
</html>

Click any paragraph to add another after it.
Note that .on() allows a click event on any paragraph-even new ones--since the event is handled by the everpresent body element after it bubbles to there.
Example:

1
2
3
4
5
6
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14
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19
20
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23

<!DOCTYPE html>
<html>
<head>
<style>
p { background:yellow; font-weight:bold; cursor
padding:5px; }
p.over { background: #ccc; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Click me!</p>
<span></span>
<script>
var count = 0;
$("body").on("click", "p", function(){
$(this).after("<p>Another paragraph! "+(++count)+
});
</script>
</body>
</html>

Demo
Example:

Display each paragraph's text in an alert box
whenever it is clicked:
1

$("body").on("click", "p", function(){

2
3

alert( $(this).text() );
});

Cancel a link's default action using the
preventDefault method.
Example:

1
2
3

$("body").on("click", "a", function(event){
event.preventDefault();
});

POWERED BYHERONOTE
A new version of this book is available!

.one()
Categories: Events > Event Handler Attachment

.one( events [, data ], handler(eventObject) )
Returns: jQuery
Description: Attach a handler to an event for the
elements. The handler is executed at most once per
element.
.one( events [, data ],
handler(eventObject) )

version added: 1.1

events
Type: String
A string containing one or more JavaScript event types, such as
"click" or "submit," or custom event names.
data
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute at the time the event is triggered.

.one( events [, selector ] [, data ],
handler(eventObject) )

version added: 1.7

events
Type: String
One or more space-separated event types and optional
namespaces, such as "click" or "keydown.myPlugin".
selector
Type: String
A selector string to filter the descendants of the selected
elements that trigger the event. If the selector is null or
omitted, the event is always triggered when it reaches the
selected element.
data

Type: Anything
Data to be passed to the handler in
is triggered.

event.data

when an event

handler(eventObject)
Type: Function()
A function to execute when the event is triggered. The value
false is also allowed as a shorthand for a function that simply
does return false .

.one( events [, selector ] [, data ] )

version added: 1.7

events
Type: PlainObject
An object in which the string keys represent one or more spaceseparated event types and optional namespaces, and the
values represent a handler function to be called for the event(s).
selector
Type: String
A selector string to filter the descendants of the selected
elements that will call the handler. If the selector is null or
omitted, the handler is always called when it reaches the
selected element.
data
Type: Anything
Data to be passed to the handler in
occurs.

event.data

when an event

The first form of this method is identical to .bind() , except that the
handler is unbound after its first invocation. The second two forms,
introduced in jQuery 1.7, are identical to .on() except that the
handler is removed after the first time the event occurs at the
delegated element, whether the selector matched anything or not.
For example:
1
2
3
4

$("#foo").one("click", function() {
alert("This will be displayed only once.");
});
$("body").one("click", "#foo", function() {

5
6

alert("This displays if #foo is the first thing clicke
});

After the code is executed, a click on the element with ID foo will
display the alert. Subsequent clicks will do nothing. This code is
equivalent to:
1
2
3
4

$("#foo").on("click", function( event ) {
alert("This will be displayed only once.");
$(this).off( event );
});

In other words, explicitly calling .off() from within a regularly-bound
handler has exactly the same effect.
If the first argument contains more than one space-separated event
types, the event handler is called once for each event type.

Examples:
Example:
1
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27
28
29
30
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Tie a one-time click to each div.

<!DOCTYPE html>
<html>
<head>
<style>
div { width:60px; height:60px; margin:5px; float
background:green; border:10px outset;
cursor:pointer; }
p { color:red; margin:0; clear:left; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<p>Click a green square...</p>
<script>
var n = 0;
$("div").one("click", function() {
var index = $("div").index(this);
$(this).css({
borderStyle:"inset",
cursor:"auto"
});
$("p").text("Div at index #" + index + " clicked."
" That's " + ++n + " total clicks.");
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});
</script>
</body>
</html>

Demo
Example:

To display the text of all paragraphs in an
alert box the first time each of them is clicked:
1
2
3

$("p").one("click", function(){
alert( $(this).text() );
});

POWERED BYHERONOTE
A new version of this book is available!

:only-child Selector
Categories: Selectors > Child Filter

only-child selector
Description: Selects all elements that are the only child
of their parent.
jQuery( ":only-child" )

version added: 1.1.4

If the parent has other child elements, nothing is matched.

Example:
Change the text and add a border for each button that
is the only child of its parent.
1
2
3
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<!DOCTYPE html>
<html>
<head>
<style>
div { width:100px; height:80px; margin:5px; float
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<button>Sibling!</button>
<button>Sibling!</button>
</div>
<div>
<button>Sibling!</button>
</div>
<div>
None
</div>
<div>
<button>Sibling!</button>
<button>Sibling!</button>
<button>Sibling!</button>
</div>
<div>
<button>Sibling!</button>
</div>
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<script>
$("div button:only-child").text("Alone").css(
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

:only-of-type Selector
Categories: Selectors > Child Filter

only-of-type selector
Description: Selects all elements that have no siblings
with the same element name.
jQuery( ":only-of-type" )

version added: 1.9

If the parent has other child elements with the same element name,
nothing is matched.

Example:
Change the text and add a border for each button that
is the only child button of its parent.
1
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<!DOCTYPE html>
<html>
<head>
<style>
div { width:100px; height:80px; margin:5px; float
span { padding: 2px; margin: 3px; line-height
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<button>Sibling!</button>
<button>Sibling!</button>
</div>
<div>
<button>Sibling!</button>
</div>
<div>
None
</div>
<div>
<button>Sibling!</button>
<span>Sibling!</span>
<span>Sibling!</span>
</div>
<div>
<button>Sibling!</button>
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</div>
<script>
$("button:only-of-type").text("Alone").css("border"
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.outerHeight()
Categories: CSS | Dimensions | Manipulation > Style Properties

.outerHeight( [includeMargin ] )

Returns: Integer

Description: Get the current computed height for the
first element in the set of matched elements, including
padding, border, and optionally margin. Returns an
integer (without "px") representation of the value or null if
called on an empty set of elements.
.outerHeight( [includeMargin ] )

version added: 1.2.6

includeMargin
Type: Boolean
A Boolean indicating whether to include the element's margin in
the calculation.
The top and bottom padding and border are always included in the
.outerHeight() calculation; if the includeMargin argument is set to
true , the margin (top and bottom) is also included.
This method is not applicable to
these, use .height() instead.

window

and

document

objects; for

Example:
Get the outerHeight of a paragraph.
1
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<!DOCTYPE html>
<html>
<head>
<style>p { margin:10px;padding:5px;border:2px solid
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p><p></p>
<script>var p = $("p:first");
$("p:last").text( "outerHeight:" + p.outerHeight() +
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.outerWidth()
Categories: CSS | Dimensions | Manipulation > Style Properties

.outerWidth( [includeMargin ] )

Returns: Integer

Description: Get the current computed width for the first
element in the set of matched elements, including
padding and border.
.outerWidth( [includeMargin ] )

version added: 1.2.6

includeMargin
Type: Boolean
A Boolean indicating whether to include the element's margin in
the calculation.
Returns the width of the element, along with left and right padding,
border, and optionally margin, in pixels.
If includeMargin is omitted or false , the padding and border are
included in the calculation; if true , the margin is also included.
This method is not applicable to
these, use .width() instead.

window

and

document

objects; for

Example:
Get the outerWidth of a paragraph.
1
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<!DOCTYPE html>
<html>
<head>
<style>
p { margin:10px;padding:5px;border:2px solid
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p><p></p>
<script>var p = $("p:first");
$("p:last").text( "outerWidth:" + p.outerWidth()+
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.parent()
Categories: Traversing > Tree Traversal

.parent( [selector ] )

Returns: jQuery

Description: Get the parent of each element in the
current set of matched elements, optionally filtered by a
selector.
.parent( [selector ] )

version added: 1.0

selector
Type: Selector
A string containing a selector expression to match elements
against.
Given a jQuery object that represents a set of DOM elements, the
.parent() method allows us to search through the parents of these
elements in the DOM tree and construct a new jQuery object from
the matching elements. The .parents() and .parent() methods are
similar, except that the latter only travels a single level up the DOM
tree.
The method optionally accepts a selector expression of the same
type that we can pass to the $() function. If the selector is supplied,
the elements will be filtered by testing whether they match it.
Consider a page with a basic nested list on it:
1
2
3
4
5
6
7
8
9
10
11

<ul class="level-1">
<li class="item-i">I</li>
<li class="item-ii">II
<ul class="level-2">
<li class="item-a">A</li>
<li class="item-b">B
<ul class="level-3">
<li class="item-1">1</li>
<li class="item-2">2</li>
<li class="item-3">3</li>
</ul>
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</li>
<li class="item-c">C</li>
</ul>
</li>
<li class="item-iii">III</li>
</ul>

If we begin at item A, we can find its parents:
1

$('li.item-a').parent().css('background-color',

The result of this call is a red background for the level-2 list. Since
we do not supply a selector expression, the parent element is
unequivocally included as part of the object. If we had supplied one,
the element would be tested for a match before it was included.

Examples:
Shows the parent of each element as (parent
> child). Check the View Source to see the raw html.
Example:

1
2
3
4
5
6
7
8
9
10
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20
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28
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<!DOCTYPE html>
<html>
<head>
<style>
div,p { margin:10px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>div,
<span>span, </span>
<b>b </b>
</div>
<p>p,
<span>span,
<em>em </em>
</span>
</p>
<div>div,
<strong>strong,
<span>span, </span>
<em>em,
<b>b, </b>
</em>
</strong>
<b>b </b>
</div>
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<script>
$("*", document.body).each(function () {
var parentTag = $(this).parent().get(0).tagName;
$(this).prepend(document.createTextNode(parentTag +
});
</script>
</body>
</html>

Demo
Example:

Find the parent element of each paragraph
with a class "selected".
1
2
3
4
5
6
7
8
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div><p>Hello</p></div>
<div class="selected"><p>Hello Again</p></div
<script>$("p").parent(".selected").css("background"
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

:parent Selector
Categories: Selectors > Content Filter | Selectors > jQuery Extensions

parent selector
Description: Select all elements that that have at least
one child node (either an element or text).
jQuery( ":parent" )
This is the inverse of

version added: 1.0

:empty .

One important thing to note regarding the use of
:empty ) is that child nodes include text nodes.

:parent

(and

The W3C recommends that the <p> element have at least one child
node, even if that child is merely text (see
http://www.w3.org/TR/html401/struct/text.html#edef-P). Some other
elements, on the other hand, are empty (i.e. have no children) by
definition: <input> , <img> , <br> , and <hr> , for example.

Additional Notes:
Because :parent is a jQuery extension and not part of the CSS
specification, queries using :parent cannot take advantage of
the performance boost provided by the native DOM
querySelectorAll() method. To achieve the best performance
when using :parent to select elements, first select the elements
using a pure CSS selector, then use .filter(":parent") .

Example:
Finds all tds with children, including text.
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<!DOCTYPE html>
<html>
<head>
<style>
td { width:40px; background:green; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<table border="1">
<tr><td>Value 1</td><td></td></tr>
<tr><td>Value 2</td><td></td></tr>
</table>
<script>$("td:parent").fadeTo(1500, 0.3);</script
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.parents()
Categories: Traversing > Tree Traversal

.parents( [selector ] )

Returns: jQuery

Description: Get the ancestors of each element in the
current set of matched elements, optionally filtered by a
selector.
.parents( [selector ] )

version added: 1.0

selector
Type: Selector
A string containing a selector expression to match elements
against.
Given a jQuery object that represents a set of DOM elements, the
.parents() method allows us to search through the ancestors of
these elements in the DOM tree and construct a new jQuery object
from the matching elements ordered from immediate parent on up;
the elements are returned in order from the closest parent to the
outer ones. The .parents() and .parent() methods are similar,
except that the latter only travels a single level up the DOM tree.
The method optionally accepts a selector expression of the same
type that we can pass to the $() function. If the selector is supplied,
the elements will be filtered by testing whether they match it.
Consider a page with a basic nested list on it:
1
2
3
4
5
6
7
8
9
10

<ul class="level-1">
<li class="item-i">I</li>
<li class="item-ii">II
<ul class="level-2">
<li class="item-a">A</li>
<li class="item-b">B
<ul class="level-3">
<li class="item-1">1</li>
<li class="item-2">2</li>
<li class="item-3">3</li>
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</ul>
</li>
<li class="item-c">C</li>
</ul>
</li>
<li class="item-iii">III</li>
</ul>

If we begin at item A, we can find its ancestors:
1

$('li.item-a').parents().css('background-color',

The result of this call is a red background for the level-2 list, item II,
and the level-1 list (and on up the DOM tree all the way to the
<html> element). Since we do not supply a selector expression, all of
the ancestors are part of the returned jQuery object. If we had
supplied one, only the matching items among these would be
included.

Examples:
Example:
1
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3
4
5
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7
8
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27
28
29
30
31

Find all parent elements of each b.

<!DOCTYPE html>
<html>
<head>
<style>
b, span, p, html body {
padding: .5em;
border: 1px solid;
}
b { color:blue; }
strong { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<p>
<span>
<b>My parents are: </b>
</span>
</p>
</div>
<script>
var parentEls = $("b").parents()
.map(function () {
return this.tagName;
})
.get().join(", ");
$("b").append("<strong>" + parentEls + "</strong>"
</script>
</body>
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</html>

Demo
Example:

Click to find all unique div parent elements of
each span.
1
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20
21
22
23
24
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<!DOCTYPE html>
<html>
<head>
<style>
p, div, span {margin:2px; padding:1px; }
div { border:2px white solid; }
span { cursor:pointer; font-size:12px; }
.selected { color:blue; }
b { color:red; display:block; font-size:14px;
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
<div>
<div><span>Hello</span></div>
<span>Hello Again</span>
</div>
<div>
<span>And Hello Again</span>
</div>
</p>
<b>Click Hellos to toggle their parents.</b>
<script>
function showParents() {
$("div").css("border-color", "white");
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var len = $("span.selected")
.parents("div")
.css("border", "2px red solid"
.length;
$("b").text("Unique div parents: " + len);
}
$("span").click(function () {
$(this).toggleClass("selected");
showParents();
});</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.parentsUntil()
Categories: Traversing > Tree Traversal

.parentsUntil( [selector ] [, filter ] )

Returns: jQuery

Description: Get the ancestors of each element in the
current set of matched elements, up to but not including
the element matched by the selector, DOM node, or
jQuery object.
.parentsUntil( [selector ] [, filter ] )

version added: 1.4

selector
Type: Selector
A string containing a selector expression to indicate where to
stop matching ancestor elements.
filter
Type: Selector
A string containing a selector expression to match elements
against.

.parentsUntil( [element ] [, filter ] )

version added: 1.6

element
Type: Element
A DOM node or jQuery object indicating where to stop matching
ancestor elements.
filter
Type: Selector
A string containing a selector expression to match elements
against.
Given a selector expression that represents a set of DOM elements,
the .parentsUntil() method traverses through the ancestors of
these elements until it reaches an element matched by the selector
passed in the method's argument. The resulting jQuery object
contains all of the ancestors up to but not including the one matched
by the .parentsUntil() selector.
If the selector is not matched or is not supplied, all ancestors will be
selected; in these cases it selects the same elements as the

.parents()

method does when no selector is provided.

As of jQuery 1.6, A DOM node or jQuery object, instead of a
selector, may be used for the first .parentsUntil() argument.
The method optionally accepts a selector expression for its second
argument. If this argument is supplied, the elements will be filtered
by testing whether they match it.

Example:
Find the ancestors of <li class="item-a"> up to <ul
class="level-1"> and give them a red background color.
Also, find ancestors of <li class="item-2"> that have a
class of "yes" up to <ul class="level-1"> and give them
a green border.
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul class="level-1 yes">
<li class="item-i">I</li>
<li class="item-ii">II
<ul class="level-2 yes">
<li class="item-a">A</li>
<li class="item-b">B
<ul class="level-3">
<li class="item-1">1</li>
<li class="item-2">2</li>
<li class="item-3">3</li>
</ul>
</li>
<li class="item-c">C</li>
</ul>
</li>
<li class="item-iii">III</li>
</ul>
<script>
$("li.item-a").parentsUntil(".level-1")
.css("background-color", "red");
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$("li.item-2").parentsUntil( $("ul.level-1"), ".yes"
.css("border", "3px solid green");
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

:password Selector
Categories: Selectors > Form | Selectors > jQuery Extensions

password selector
Description: Selects all elements of type password.
jQuery( ":password" )

version added: 1.0

is equivalent to $('[type=password]') . As with other
pseudo-class selectors (those that begin with a ":") it is
recommended to precede it with a tag name or some other selector;
otherwise, the universal selector ("*") is implied. In other words, the
bare $(':password') is equivalent to $('*:password') , so
$('input:password') should be used instead.
$(':password')

Additional Notes:
Because :password is a jQuery extension and not part of the
CSS specification, queries using :password cannot take
advantage of the performance boost provided by the native
DOM querySelectorAll() method. For better performance in
modern browsers, use [type="password"] instead.

Example:
Finds all password inputs.
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<!DOCTYPE html>
<html>
<head>
<style>
textarea { height:45px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<input type="button" value="Input Button"/>
<input type="checkbox" />
<input type="file" />
<input type="hidden" />
<input type="image" />
<input type="password" />
<input type="radio" />
<input type="reset" />
<input type="submit" />
<input type="text" />
<select><option>Option<option/></select>
<textarea></textarea>
<button>Button</button>
</form>
<div>
</div>
<script>
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var input = $("input:password").css({background:
$("div").text("For this type jQuery found " + input.leng
.css("color", "red");
$("form").submit(function () { return false; });
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.position()
Categories: CSS | Offset | Manipulation > Style Properties

.position()

Returns: Object

Description: Get the current coordinates of the first
element in the set of matched elements, relative to the
offset parent.
.position()

version added: 1.2

This method does not accept any arguments.
The .position() method allows us to retrieve the current position of
an element relative to the offset parent. Contrast this with .offset() ,
which retrieves the current position relative to the document. When
positioning a new element near another one and within the same
containing DOM element, .position() is the more useful.
Returns an object containing the properties

top

and

left .

Note: jQuery does not support getting the
position coordinates of hidden elements or
accounting for borders, margins, or padding
set on the body element.

Example:
Access the position of the second paragraph:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25

<!DOCTYPE html>
<html>
<head>
<style>
div { padding: 15px;}
p { margin-left:10px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<p>Hello</p>
</div>
<p></p>
<script>
var p = $("p:first");
var position = p.position();
$("p:last").text( "left: " + position.left + ", top: "
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

.prepend()
Categories: Manipulation > DOM Insertion, Inside

.prepend( content [, content ] )

Returns: jQuery

Description: Insert content, specified by the parameter,
to the beginning of each element in the set of matched
elements.
.prepend( content [, content ] )

version added: 1.0

content
Type: htmlString or Element or jQuery
DOM element, array of elements, HTML string, or jQuery object
to insert at the beginning of each element in the set of matched
elements.
content
Type: htmlString or Element or jQuery
One or more additional DOM elements, arrays of elements,
HTML strings, or jQuery objects to insert at the beginning of
each element in the set of matched elements.

.prepend( function(index, html) )

version added: 1.4

function(index, html)
Type: Function()
A function that returns an HTML string, DOM element(s), or
jQuery object to insert at the beginning of each element in the
set of matched elements. Receives the index position of the
element in the set and the old HTML value of the element as
arguments. Within the function, this refers to the current
element in the set.
The .prepend() method inserts the specified content as the first child
of each element in the jQuery collection (To insert it as the last child,
use .append() ).
The .prepend() and .prependTo() methods perform the same task.
The major difference is in the syntax—specifically, in the placement
of the content and target. With .prepend() , the selector expression
preceding the method is the container into which the content is
inserted. With .prependTo() , on the other hand, the content precedes

the method, either as a selector expression or as markup created on
the fly, and it is inserted into the target container.
Consider the following HTML:
1
2
3
4
5

<h2>Greetings</h2>
<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

You can create content and insert it into several elements at once:
1
Each
1
2
3
4
5
6
7
8
9
10
11

$('.inner').prepend('<p>Test</p>');

<div class="inner">

element gets this new content:

<h2>Greetings</h2>
<div class="container">
<div class="inner">
<p>Test</p>
Hello
</div>
<div class="inner">
<p>Test</p>
Goodbye
</div>
</div>

You can also select an element on the page and insert it into
another:
1

$('.container').prepend($('h2'));

If a single element selected this way is inserted into a single location
elsewhere in the DOM, it will be moved into the target (not cloned):
1
2
3
4
5

<div class="container">
<h2>Greetings</h2>
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

Important: If there is more than one target element, however,
cloned copies of the inserted element will be created for each target
after the first.
Additional Arguments
Similar to other content-adding methods such as .append() and
.before() , .prepend() also supports passing in multiple arguments
as input. Supported input includes DOM elements, jQuery objects,
HTML strings, and arrays of DOM elements.
For example, the following will insert two new <div> s and an existing
<div> as the first three child nodes of the body:
1
2
3
4
5

var $newdiv1 = $('<div id="object1"/>'),
newdiv2 = document.createElement('div'),
existingdiv1 = document.getElementById('foo'
$('body').prepend($newdiv1, [newdiv2, existingdiv1]);

Since .prepend() can accept any number of additional arguments,
the same result can be achieved by passing in the three <div> s as
three separate arguments, like so: $('body').prepend($newdiv1,
newdiv2, existingdiv1) . The type and number of arguments will
largely depend on how you collect the elements in your code.

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14

<!DOCTYPE html>
<html>
<head>
<style>p { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>there, friend!</p>
<p>amigo!</p>
<script>$("p").prepend("<b>Hello </b>");</script
</body>
</html>

Demo
Example:
1
2
3
4
5
6
7
8
9
10
11

Prepends some HTML to all paragraphs.

Prepends a DOM Element to all paragraphs.

<!DOCTYPE html>
<html>
<head>
<style>p { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>is what I'd say</p>
<p>is what I said</p>
<script>$("p").prepend(document.createTextNode(

12
13

</body>
</html>

Demo
Example:

Prepends a jQuery object (similar to an Array
of DOM Elements) to all paragraphs.
1
2
3
4
5
6
7
8
9
10
11
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<!DOCTYPE html>
<html>
<head>
<style>p { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p> is what was said.</p><b>Hello</b>
<script>$("p").prepend( $("b") );</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.prependTo()
Categories: Manipulation > DOM Insertion, Inside

.prependTo( target )

Returns: jQuery

Description: Insert every element in the set of matched
elements to the beginning of the target.
.prependTo( target )

version added: 1.0

target
Type: Selector or htmlString or Element or jQuery
A selector, element, HTML string, or jQuery object; the matched
set of elements will be inserted at the beginning of the
element(s) specified by this parameter.
The .prepend() and .prependTo() methods perform the same task.
The major difference is in the syntax-specifically, in the placement of
the content and target. With .prepend() , the selector expression
preceding the method is the container into which the content is
inserted. With .prependTo() , on the other hand, the content precedes
the method, either as a selector expression or as markup created on
the fly, and it is inserted into the target container.
Consider the following HTML:
1
2
3
4
5

<h2>Greetings</h2>
<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

We can create content and insert it into several elements at once:
1

$('<p>Test</p>').prependTo('.inner');

Each inner

<div>

element gets this new content:

1
2
3
4
5
6
7
8
9
10
11

<h2>Greetings</h2>
<div class="container">
<div class="inner">
<p>Test</p>
Hello
</div>
<div class="inner">
<p>Test</p>
Goodbye
</div>
</div>

We can also select an element on the page and insert it into
another:
1

$('h2').prependTo($('.container'));

If an element selected this way is inserted into a single location
elsewhere in the DOM, it will be moved into the target (not cloned):
1
2
3
4
5

<div class="container">
<h2>Greetings</h2>
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

If there is more than one target element, however, cloned copies of
the inserted element will be created for each target after the first.

Example:
Prepend all spans to the element with the ID "foo"
(Check .prepend() documentation for more examples)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

<!DOCTYPE html>
<html>
<head>
<style>div { background:yellow; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="foo">FOO!</div>
<span>I have something to say... </span>
<script>
$("span").prependTo("#foo");
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.prev()
Categories: Traversing > Tree Traversal

.prev( [selector ] )

Returns: jQuery

Description: Get the immediately preceding sibling of
each element in the set of matched elements, optionally
filtered by a selector.
.prev( [selector ] )

version added: 1.0

selector
Type: Selector
A string containing a selector expression to match elements
against.
Given a jQuery object that represents a set of DOM elements, the
.prev() method searches for the predecessor of each of these
elements in the DOM tree and constructs a new jQuery object from
the matching elements.
The method optionally accepts a selector expression of the same
type that can be passed to the $() function. If the selector is
supplied, the preceding element will be filtered by testing whether it
match the selector.
Consider a page with a simple list on it:
1
2
3
4
5
6
7

<ul>
<li>list item 1</li>
<li>list item 2</li>
<li class="third-item">list item 3</li>
<li>list item 4</li>
<li>list item 5</li>
</ul>

To select the element that comes immediately before item three:
1

$('li.third-item').prev().css('background-color'

The result of this call is a red background behind item 2. Since no
selector expression is supplied, this preceding element is
unequivocally included as part of the object. If one had been
supplied, the element would be tested for a match before it was
included.
If no previous sibling exists, or if the previous sibling element does
not match a supplied selector, an empty jQuery object is returned.
To select all preceding sibling elements, rather than just the
preceding adjacent sibling, use the .prevAll() method.

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
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22
23
24
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26
27
28
29
30
31

Find the very previous sibling of each div.

<!DOCTYPE html>
<html>
<head>
<style>
div { width:40px; height:40px; margin:10px;
float:left; border:2px blue solid;
padding:2px; }
span { font-size:14px; }
p { clear:left; margin:10px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div>
<div></div>
<div><span>has child</span></div>
<div></div>
<div></div>
<div></div>
<div id="start"></div>
<div></div>
<p><button>Go to Prev</button></p>
<script>
var $curr = $("#start");
$curr.css("background", "#f99");
$("button").click(function () {
$curr = $curr.prev();
$("div").css("background", "");
$curr.css("background", "#f99");
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});
</script>
</body>
</html>

Demo
Example:

For each paragraph, find the very previous
sibling that has a class "selected".
1
2
3
4
5
6
7
8
9
10
11
12
13
14

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div><span>Hello</span></div>
<p class="selected">Hello Again</p>
<p>And Again</p>
<script>$("p").prev(".selected").css("background"
</body>
</html>

Demo
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A new version of this book is available!

.prevAll()
Categories: Traversing > Tree Traversal

.prevAll( [selector ] )

Returns: jQuery

Description: Get all preceding siblings of each element
in the set of matched elements, optionally filtered by a
selector.
.prevAll( [selector ] )

version added: 1.2

selector
Type: Selector
A string containing a selector expression to match elements
against.
Given a jQuery object that represents a set of DOM elements, the
.prevAll() method searches through the predecessors of these
elements in the DOM tree and construct a new jQuery object from
the matching elements; the elements are returned in order beginning
with the closest sibling.
The method optionally accepts a selector expression of the same
type that we can pass to the $() function. If the selector is supplied,
the elements will be filtered by testing whether they match it.
Consider a page with a simple list on it:
1
2
3
4
5
6
7

<ul>
<li>list item 1</li>
<li>list item 2</li>
<li class="third-item">list item 3</li>
<li>list item 4</li>
<li>list item 5</li>
</ul>

If we begin at the third item, we can find the elements which come
before it:

1

$('li.third-item').prevAll().css('background-color'

The result of this call is a red background behind items 1 and 2.
Since we do not supply a selector expression, these preceding
elements are unequivocally included as part of the object. If we had
supplied one, the elements would be tested for a match before they
were included.

Example:
Locate all the divs preceding the last div and give
them a class.
1
2
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5
6
7
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14
15
16
17
18
19
20

<!DOCTYPE html>
<html>
<head>
<style>
div { width:70px; height:70px; background:#abc
border:2px solid black; margin:10px; float
div.before { border-color: red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div>
<div></div>
<div></div>
<div></div>
<script>$("div:last").prevAll().addClass("before"
</body>
</html>

Demo
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.prevUntil()
Categories: Traversing > Tree Traversal

.prevUntil( [selector ] [, filter ] )

Returns: jQuery

Description: Get all preceding siblings of each element
up to but not including the element matched by the
selector, DOM node, or jQuery object.
.prevUntil( [selector ] [, filter ] )

version added: 1.4

selector
Type: Selector
A string containing a selector expression to indicate where to
stop matching preceding sibling elements.
filter
Type: Selector
A string containing a selector expression to match elements
against.

.prevUntil( [element ] [, filter ] )

version added: 1.6

element
Type: Element
A DOM node or jQuery object indicating where to stop matching
preceding sibling elements.
filter
Type: Selector
A string containing a selector expression to match elements
against.
Given a selector expression that represents a set of DOM elements,
the .prevUntil() method searches through the predecessors of
these elements in the DOM tree, stopping when it reaches an
element matched by the method's argument. The new jQuery object
that is returned contains all previous siblings up to but not including
the one matched by the .prevUntil() selector; the elements are
returned in order from the closest sibling to the farthest.
If the selector is not matched or is not supplied, all previous siblings
will be selected; in these cases it selects the same elements as the

.prevAll()

method does when no filter selector is provided.

As of jQuery 1.6, A DOM node or jQuery object, instead of a
selector, may be used for the first .prevUntil() argument.
The method optionally accepts a selector expression for its second
argument. If this argument is supplied, the elements will be filtered
by testing whether they match it.

Example:
Find the siblings that precede <dt id="term-2"> up to
the preceding <dt> and give them a red background
color. Also, find previous <dd> siblings of <dt id="term3"> up to <dt id="term-1"> and give them a green text
color.
1
2
3
4
5
6
7
8
9
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14
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27

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<dl>
<dt id="term-1">term 1</dt>
<dd>definition 1-a</dd>
<dd>definition 1-b</dd>
<dd>definition 1-c</dd>
<dd>definition 1-d</dd>
<dt id="term-2">term 2</dt>
<dd>definition 2-a</dd>
<dd>definition 2-b</dd>
<dd>definition 2-c</dd>
<dt id="term-3">term 3</dt>
<dd>definition 3-a</dd>
<dd>definition 3-b</dd>
</dl>
<script>
$("#term-2").prevUntil("dt")
.css("background-color", "red");
var term1 = document.getElementById('term-1');
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$("#term-3").prevUntil(term1, "dd")
.css("color", "green");
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.promise()
Categories: Deferred Object

.promise( [type ] [, target ] )

Returns: Promise

Description: Return a Promise object to observe when
all actions of a certain type bound to the collection,
queued or not, have finished.
.promise( [type ] [, target ] )

version added: 1.6

type (default: fx )
Type: String
The type of queue that needs to be observed.
target
Type: PlainObject
Object onto which the promise methods have to be attached
The .promise() method returns a dynamically generated Promise
that is resolved once all actions of a certain type bound to the
collection, queued or not, have ended.
By default, type is "fx" , which means the returned Promise is
resolved when all animations of the selected elements have
completed.
Resolve context and sole argument is the collection onto which
.promise() has been called.
If target is provided, .promise() will attach the methods onto it and
then return this object rather than create a new one. This can be
useful to attach the Promise behavior to an object that already
exists.

Note: The returned Promise is linked to a
Deferred object stored on the .data() for an
element. Since the .remove() method removes
the element's data as well as the element

itself, it will prevent any of the element's
unresolved Promises from resolving. If it is
necessary to remove an element from the
DOM before its Promise is resolved, use
.detach() instead and follow with .removeData()
after resolution.

Examples:
Using .promise() on a collection with no active
animation returns a resolved Promise:
Example:

1
2
3
4
5
6

var div = $( "<div />" );
div.promise().done(function( arg1 ) {
// will fire right away and alert "true"
alert( this === div && arg1 === div );
});

Resolve the returned Promise when all
animations have ended (including those initiated in the
animation callback or added later on):
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18

<!DOCTYPE html>
<html>
<head>
<style>
div {
height: 50px; width: 50px;
float: left; margin-right: 10px;
display: none; background-color: #090;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Go</button>
<p>Ready...</p>
<div></div>
<div></div>
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<div></div>
<div></div>

<script>
$("button").on( "click", function() {
$("p").append( "Started...");
$("div").each(function( i ) {
$( this ).fadeIn().fadeOut( 1000 * (i+1) );
});
$( "div" ).promise().done(function() {
$( "p" ).append( " Finished! " );
});
});
</script>
</body>
</html>

Demo
Example:

Resolve the returned Promise using a $.when()
statement (the .promise() method makes it possible to
do this with jQuery collections):
1
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<!DOCTYPE html>
<html>
<head>
<style>
div {
height: 50px; width: 50px;
float: left; margin-right: 10px;
display: none; background-color: #090;
}

10
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</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Go</button>
<p>Ready...</p>
<div></div>
<div></div>
<div></div>
<div></div>

<script>
var effect = function() {
return $("div").fadeIn(800).delay(1200).fadeOut();
};
$("button").on( "click", function() {
$("p").append( " Started... ");
$.when( effect() ).done(function() {
$("p").append(" Finished! ");
});
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

.prop()
Categories: Attributes | Manipulation > General Attributes

Get the value of a property for the first element in the set of matched
elements or set one or more properties for every matched element.
Contents:
.prop( propertyName )
.prop( propertyName )
.prop( propertyName, value )
.prop( propertyName, value )
.prop( properties )
.prop( propertyName, function(index, oldPropertyValue) )

.prop( propertyName )

Returns: String

Description: Get the value of a property for the first
element in the set of matched elements.
.prop( propertyName )

version added: 1.6

propertyName
Type: String
The name of the property to get.
The .prop() method gets the property value for only the first
element in the matched set. It returns undefined for the value of a
property that has not been set, or if the matched set has no
elements. To get the value for each element individually, use a
looping construct such as jQuery's .each() or .map() method.
The difference between attributes and properties can be important in
specific situations. Before jQuery 1.6, the .attr() method
sometimes took property values into account when retrieving some
attributes, which could cause inconsistent behavior. As of jQuery
1.6, the .prop() method provides a way to explicitly retrieve property
values, while .attr() retrieves attributes.
For example,

selectedIndex , tagName , nodeName , nodeType ,
ownerDocument , defaultChecked , and defaultSelected should be
retrieved and set with the .prop() method. Prior to jQuery 1.6, these
properties were retrievable with the .attr() method, but this was not
within the scope of attr . These do not have corresponding

attributes and are only properties.
Concerning boolean attributes, consider a DOM element defined by
the HTML markup <input type="checkbox" checked="checked" /> , and
assume it is in a JavaScript variable named elem :
elem.checked
$(elem).prop("checked")

(Boolean) Will change with
checkbox state
true (Boolean) Will change with
checkbox state
true

(String) Initial state of the
checkbox; does not change
$(elem).attr("checked")
"checked" (String) Initial state of the
(1.6)
checkbox; does not change
$(elem).attr("checked")
"checked" (String) Will change with
(1.6.1+)
checkbox state
$(elem).attr("checked")
true (Boolean) Changed with
(pre-1.6)
checkbox state
According to the W3C forms specification, the checked attribute is a
boolean attribute, which means the corresponding property is true if
the attribute is present at all—even if, for example, the attribute has
no value or an empty string value. The preferred cross-browsercompatible way to determine if a checkbox is checked is to check for
a "truthy" value on the element's property using one of the following:
elem.getAttribute("checked") "checked"

if ( elem.checked )
if ( $(elem).prop("checked") )
if ( $(elem).is(":checked") )

If using jQuery 1.6, the code if ( $(elem).attr("checked") ) will
retrieve the actual content attribute, which does not change as the
checkbox is checked and unchecked. It is meant only to store the
default or initial value of the checked property. To maintain
backwards compatability, the .attr() method in jQuery 1.6.1+ will
retrieve and update the property for you so no code for boolean
attributes is required to be changed to .prop() . Nevertheless, the
preferred way to retrieve a checked value is with one of the options
listed above. To see how this works in the latest jQuery,
check/uncheck the checkbox in the example below.

Additional Notes:
In Internet Explorer prior to version 9, using .prop() to set a
DOM element property to anything other than a simple primitive
value (number, string, or boolean) can cause memory leaks if
the property is not removed (using .removeProp() ) before the
DOM element is removed from the document. To safely set
values on DOM objects without memory leaks, use .data() .

Example:
Display the checked property and attribute of a
checkbox as it changes.
1
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Demo

<!DOCTYPE html>
<html>
<head>
<style>
p { margin: 20px 0 0 }
b { color: blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<input id="check1" type="checkbox" checked="checked"
<label for="check1">Check me</label>
<p></p>
<script>
$("input").change(function() {
var $input = $(this);
$("p").html(".attr('checked'): <b>" + $input.attr(
+ ".prop('checked'): <b>" + $input.prop(
+ ".is(':checked'): <b>" + $input.is(
}).change();
</script>
</body>
</html>

.prop( propertyName, value )

Returns: jQuery

Description: Set one or more properties for the set of
matched elements.
.prop( propertyName, value )

version added: 1.6

propertyName
Type: String
The name of the property to set.
value
Type: String or Number or Boolean
A value to set for the property.

.prop( properties )

version added: 1.6

properties
Type: PlainObject
An object of property-value pairs to set.

.prop( propertyName, function(index, version added: 1.6
oldPropertyValue) )
propertyName
Type: String
The name of the property to set.
function(index, oldPropertyValue)
Type: Function()
A function returning the value to set. Receives the index
position of the element in the set and the old property value as
arguments. Within the function, the keyword this refers to the
current element.
The .prop() method is a convenient way to set the value of
properties—especially when setting multiple properties, using values
returned by a function, or setting values on multiple elements at
once. It should be used when setting selectedIndex , tagName ,
nodeName , nodeType , ownerDocument , defaultChecked , or

defaultSelected . Since
be set with the .attr()

jQuery 1.6, these properties can no longer
method. They do not have corresponding
attributes and are only properties.
Properties generally affect the dynamic state of a DOM element
without changing the serialized HTML attribute. Examples include
the value property of input elements, the disabled property of inputs
and buttons, or the checked property of a checkbox. The .prop()
method should be used to set disabled and checked instead of the
.attr() method. The .val() method should be used for getting and
setting value.
1
2
3

$("input").prop("disabled", false);
$("input").prop("checked", true);
$("input").val("someValue");

Important: the .removeProp() method should not be used to set
these properties to false. Once a native property is removed, it
cannot be added again. See .removeProp() for more information.
Computed property values
By using a function to set properties, you can compute the value
based on other properties of the element. For example, to toggle all
checkboxes based off their individual values:
1
2
3

$("input[type='checkbox']").prop("checked", function
return !val;
});

Note: If nothing is returned in the setter function (ie. function(index,
prop){}) , or if undefined is returned, the current value is not
changed. This is useful for selectively setting values only when
certain criteria are met.

Additional Notes:

In Internet Explorer prior to version 9, using .prop() to set a
DOM element property to anything other than a simple primitive
value (number, string, or boolean) can cause memory leaks if
the property is not removed (using .removeProp() ) before the
DOM element is removed from the document. To safely set
values on DOM objects without memory leaks, use .data() .

Example:
Disable all checkboxes on the page.
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<!DOCTYPE html>
<html>
<head>
<style>
img { padding:10px; }
div { color:red; font-size:24px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<input
<input
<input
<input

type="checkbox" checked="checked" />
type="checkbox" />
type="checkbox" />
type="checkbox" checked="checked" />

<script>
$("input[type='checkbox']").prop({
disabled: true
});
</script>
</body>
</html>

Demo
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A new version of this book is available!

.pushStack()
Categories: Internals

.pushStack( elements )

Returns: jQuery

Description: Add a collection of DOM elements onto the
jQuery stack.
.pushStack( elements )

version added: 1.0

elements
Type: Array
An array of elements to push onto the stack and make into a
new jQuery object.

.pushStack( elements, name,
arguments )

version added: 1.3

elements
Type: Array
An array of elements to push onto the stack and make into a
new jQuery object.
name
Type: String
The name of a jQuery method that generated the array of
elements.
arguments
Type: Array
The arguments that were passed in to the jQuery method (for
serialization).

Example:
Add some elements onto the jQuery stack, then pop
back off again.
1
2
3
4

jQuery([])
.pushStack( document.getElementsByTagName("div"
.remove()
.end();

POWERED BYHERONOTE
A new version of this book is available!

.queue()
Categories: Effects > Custom | Data | Utilities

Show or manipulate the queue of functions to be executed on the
matched elements.
Contents:
.queue( [queueName ] )
.queue( [queueName ] )
.queue( [queueName ], newQueue )
.queue( [queueName ], newQueue )
.queue( [queueName ], callback( next ) )

.queue( [queueName ] )

Returns: Array

Description: Show the queue of functions to be
executed on the matched elements.
.queue( [queueName ] )

version added: 1.2

queueName
Type: String
A string containing the name of the queue. Defaults to
standard effects queue.

fx ,

the

Example:
Show the length of the queue.
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<!DOCTYPE html>
<html>
<head>
<style>div { margin:3px; width:40px; height:40
position:absolute; left:0px; top:60px;
background:green; display:none; }
div.newcolor { background:blue; }
p { color:red; } </style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>The queue length is: <span></span></p>
<div></div>
<script>
var div = $("div");
function runIt() {
div.show("slow");
div.animate({left:'+=200'},2000);
div.slideToggle(1000);
div.slideToggle("fast");
div.animate({left:'-=200'},1500);
div.hide("slow");
div.show(1200);
div.slideUp("normal", runIt);
}
function showIt() {
var n = div.queue("fx");
$("span").text( n.length );
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setTimeout(showIt, 100);
}
runIt();
showIt();
</script>
</body>
</html>

.queue( [queueName ], newQueue )

Returns: jQuery

Description: Manipulate the queue of functions to be
executed, once for each matched element.
.queue( [queueName ], newQueue )

version added: 1.2

queueName
Type: String
A string containing the name of the queue. Defaults to
standard effects queue.

fx ,

the

newQueue
Type: Array
An array of functions to replace the current queue contents.

.queue( [queueName ], callback( next version added: 1.2
))
queueName
Type: String
A string containing the name of the queue. Defaults to
standard effects queue.

fx ,

the

callback( next )
Type: Function()
The new function to add to the queue, with a function to call that
will dequeue the next item.
Every element can have one to many queues of functions attached
to it by jQuery. In most applications, only one queue (called fx ) is
used. Queues allow a sequence of actions to be called on an
element asynchronously, without halting program execution. The
typical example of this is calling multiple animation methods on an
element. For example:
1

$('#foo').slideUp().fadeIn();

When this statement is executed, the element begins its sliding
animation immediately, but the fading transition is placed on the
queue to be called only once the sliding transition is complete.

fx

The .queue() method allows us to directly manipulate this queue of
functions. Calling .queue() with a callback is particularly useful; it
allows us to place a new function at the end of the queue. The
callback function is executed once for each element in the jQuery
set.
This feature is similar to providing a callback function with an
animation method, but does not require the callback to be given at
the time the animation is performed.
1
2
3
4
5

$('#foo').slideUp();
$('#foo').queue(function() {
alert('Animation complete.');
$(this).dequeue();
});

This is equivalent to:
1
2
3

$('#foo').slideUp(function() {
alert('Animation complete.');
});

Note that when adding a function with .queue() , we should ensure
that .dequeue() is eventually called so that the next function in line
executes.
As of jQuery 1.4, the function that's called is passed another
function as the first argument. When called, this automatically
dequeues the next item and keeps the queue moving. We use it as
follows:
1

$("#test").queue(function(next) {

2
3
4

// Do some stuff...
next();
});

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

Queue a custom function.

<!DOCTYPE html>
<html>
<head>
<style>
div { margin:3px; width:40px; height:40px;
position:absolute; left:0px; top:30px;
background:green; display:none; }
div.newcolor { background:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
Click here...
<div></div>
<script>$(document.body).click(function () {
$("div").show("slow");
$("div").animate({left:'+=200'},2000);
$("div").queue(function () {
$(this).addClass("newcolor");
$(this).dequeue();
});
$("div").animate({left:'-=200'},500);
$("div").queue(function () {
$(this).removeClass("newcolor");
$(this).dequeue();
});
$("div").slideUp();
});</script>
</body>
</html>

Demo
Example:
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Set a queue array to delete the queue.

<!DOCTYPE html>
<html>
<head>
<style>
div { margin:3px; width:40px; height:40px;
position:absolute; left:0px; top:30px;
background:green; display:none; }
div.newcolor { background:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="start">Start</button>
<button id="stop">Stop</button>
<div></div>
<script>$("#start").click(function () {
$("div").show("slow");
$("div").animate({left:'+=200'},5000);
$("div").queue(function () {
$(this).addClass("newcolor");
$(this).dequeue();
});
$("div").animate({left:'-=200'},1500);
$("div").queue(function () {
$(this).removeClass("newcolor");
$(this).dequeue();
});
$("div").slideUp();
});
$("#stop").click(function () {
$("div").queue("fx", []);
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$("div").stop();
});</script>
</body>
</html>

Demo
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:radio Selector
Categories: Selectors > Form | Selectors > jQuery Extensions

radio selector
Description: Selects all elements of type radio.
jQuery( ":radio" )

version added: 1.0

is equivalent to $('[type=radio]') . As with other
pseudo-class selectors (those that begin with a ":") it is
recommended to precede it with a tag name or some other selector;
otherwise, the universal selector ("*") is implied. In other words, the
bare $(':radio') is equivalent to $('*:radio') , so $('input:radio')
should be used instead.
$(':radio')

To select a set of associated radio buttons, you might use:
$('input[name=gender]:radio')

Additional Notes:
Because :radio is a jQuery extension and not part of the CSS
specification, queries using :radio cannot take advantage of
the performance boost provided by the native DOM
querySelectorAll() method. For better performance in modern
browsers, use [type="radio"] instead.

Example:
Finds all radio inputs.
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<!DOCTYPE html>
<html>
<head>
<style>
textarea { height:25px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<input type="button" value="Input Button"/>
<input type="checkbox" />
<input type="file" />
<input type="hidden" />
<input type="image" />
<input type="password" />
<input type="radio" name="asdf" />
<input type="radio" name="asdf" />
<input type="reset" />
<input type="submit" />
<input type="text" />
<select><option>Option<option/></select>
<textarea></textarea>
<button>Button</button>
</form>
<div>
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</div>
<script>
var input = $("form input:radio")
.wrap('<span></span>')
.parent()
.css({background:"yellow", border:"3px red s

$("div").text("For this type jQuery found " + input.leng
.css("color", "red");
$("form").submit(function () { return false; });
</script>
</body>
</html>

Demo
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.ready()
Categories: Events > Document Loading

.ready( handler )

Returns: jQuery

Description: Specify a function to execute when the
DOM is fully loaded.
.ready( handler )

version added: 1.0

handler
Type: Function()
A function to execute after the DOM is ready.
While JavaScript provides the load event for executing code when a
page is rendered, this event does not get triggered until all assets
such as images have been completely received. In most cases, the
script can be run as soon as the DOM hierarchy has been fully
constructed. The handler passed to .ready() is guaranteed to be
executed after the DOM is ready, so this is usually the best place to
attach all other event handlers and run other jQuery code. When
using scripts that rely on the value of CSS style properties, it's
important to reference external stylesheets or embed style elements
before referencing the scripts.
In cases where code relies on loaded assets (for example, if the
dimensions of an image are required), the code should be placed in
a handler for the load event instead.

The .ready() method is generally
incompatible with the <body onload=""> attribute.
If load must be used, either do not use
.ready() or use jQuery's .load() method to
attach load event handlers to the window or
to more specific items, like images.
All three of the following syntaxes are equivalent:

$(document).ready(handler)
$().ready(handler)

(this is not recommended)

$(handler)

There is also $(document).on("ready", handler) , deprecated as of
jQuery 1.8. This behaves similarly to the ready method but if the
ready event has already fired and you try to .on("ready") the bound
handler will not be executed. Ready handlers bound this way are
executed after any bound by the other three methods above.
The .ready() method can only be called on a jQuery object
matching the current document, so the selector can be omitted.
The
1
2
3

.ready()

method is typically used with an anonymous function:

$(document).ready(function() {
// Handler for .ready() called.
});

Which is equivalent to calling:
1
2
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$(function() {
// Handler for .ready() called.
});

If .ready() is called after the DOM has been initialized, the new
handler passed in will be executed immediately.
Aliasing the jQuery Namespace
When using another JavaScript library, we may wish to call
$.noConflict() to avoid namespace difficulties. When this function is
called, the $ shortcut is no longer available, forcing us to write
jQuery each time we would normally write $ . However, the handler
passed to the .ready() method can take an argument, which is
passed the global jQuery object. This means we can rename the
object within the context of our .ready() handler without affecting

other code:
1
2
3

jQuery(document).ready(function($) {
// Code using $ as usual goes here.
});

Example:
Display a message when the DOM is loaded.
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<!DOCTYPE html>
<html>
<head>
<style>p { color:red; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
<script>
$(document).ready(function () {
$("p").text("The DOM is now loaded and can be manipula
});
</script>
</head>
<body>
<p>Not loaded yet.</p>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.remove()
Categories: Manipulation > DOM Removal

.remove( [selector ] )

Returns: jQuery

Description: Remove the set of matched elements from
the DOM.
.remove( [selector ] )

version added: 1.0

selector
Type: String
A selector expression that filters the set of matched elements to
be removed.
Similar to .empty() , the .remove() method takes elements out of the
DOM. Use .remove() when you want to remove the element itself, as
well as everything inside it. In addition to the elements themselves,
all bound events and jQuery data associated with the elements are
removed. To remove the elements without removing data and
events, use .detach() instead.
Consider the following HTML:
1
2
3
4

<div class="container">
<div class="hello">Hello</div>
<div class="goodbye">Goodbye</div>
</div>

We can target any element for removal:
1

$('.hello').remove();

This will result in a DOM structure with the
1
2

<div>

element deleted:

<div class="container">
<div class="goodbye">Goodbye</div>

3

</div>

If we had any number of nested elements inside <div
class="hello"> , they would be removed, too. Other jQuery constructs
such as data or event handlers are erased as well.
We can also include a selector as an optional parameter. For
example, we could rewrite the previous DOM removal code as
follows:
1

$('div').remove('.hello');

This would result in the same DOM structure:
1
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<div class="container">
<div class="goodbye">Goodbye</div>
</div>

Examples:
Example:
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Removes all paragraphs from the DOM

<!DOCTYPE html>
<html>
<head>
<style>p { background:yellow; margin:6px 0; }
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
how are
<p>you?</p>
<button>Call remove() on paragraphs</button>
<script>
$("button").click(function () {
$("p").remove();
});
</script>
</body>
</html>

Demo
Example:

Removes all paragraphs that contain "Hello"
from the DOM. Analogous to doing
$("p").filter(":contains('Hello')").remove() .
1
2
3
4

<!DOCTYPE html>
<html>
<head>
<style>p { background:yellow; margin:6px 0; }
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<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p class="hello">Hello</p>
how are
<p>you?</p>

<button>Call remove(":contains('Hello')") on paragraph
<script>
$("button").click(function () {
$("p").remove(":contains('Hello')");
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.removeAttr()
Categories: Attributes | Manipulation > General Attributes

.removeAttr( attributeName )

Returns: jQuery

Description: Remove an attribute from each element in
the set of matched elements.
.removeAttr( attributeName )

version added: 1.0

attributeName
Type: String
An attribute to remove; as of version 1.7, it can be a spaceseparated list of attributes.
The .removeAttr() method uses the JavaScript removeAttribute()
function, but it has the advantage of being able to be called directly
on a jQuery object and it accounts for different attribute naming
across browsers.
Note: Removing an inline onclick event handler using
.removeAttr() doesn't achieve the desired effect in Internet Explorer
6, 7, or 8. To avoid potential problems, use .prop() instead:
1
2

$element.prop("onclick", null);
console.log("onclick property: ", $element[0].onclick);

Example:
Clicking the button enables the input next to it.
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Enable</button>
<input type="text" title="hello there" />
<div id="log"></div>
<script>
(function() {
var inputTitle = $("input").attr("title");
$("button").click(function () {
var input = $(this).next();
if ( input.attr("title") == inputTitle ) {
input.removeAttr("title")
} else {
input.attr("title", inputTitle);
}
$("#log").html( "input title is now " + input.attr(
});
})();
</script>
</body>
</html>

Demo
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.removeClass()
Categories: Attributes | Manipulation > Class Attribute | CSS

.removeClass( [className ] )

Returns: jQuery

Description: Remove a single class, multiple classes,
or all classes from each element in the set of matched
elements.
.removeClass( [className ] )

version added: 1.0

className
Type: String
One or more space-separated classes to be removed from the
class attribute of each matched element.

.removeClass( function(index, class) version added: 1.4
)
function(index, class)
Type: Function()
A function returning one or more space-separated class names
to be removed. Receives the index position of the element in
the set and the old class value as arguments.
If a class name is included as a parameter, then only that class will
be removed from the set of matched elements. If no class names
are specified in the parameter, all classes will be removed.
More than one class may be removed at a time, separated by a
space, from the set of matched elements, like so:
1

$('p').removeClass('myClass yourClass')

This method is often used with .addClass() to switch elements'
classes from one to another, like so:
1

$('p').removeClass('myClass noClass').addClass('yourClas

Here, the myClass and noClass classes are removed from all
paragraphs, while yourClass is added.
To replace all existing classes with another class, we can use
.attr('class', 'newClass') instead.
As of jQuery 1.4, the .removeClass() method allows us to indicate
the class to be removed by passing in a function.
1
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$('li:last').removeClass(function() {
return $(this).prev().attr('class');
});

This example removes the class name of the penultimate
the last <li> .

<li>

from

Examples:
Example:

Remove the class 'blue' from the matched

elements.
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<!DOCTYPE html>
<html>
<head>
<style>
p { margin: 4px; font-size:16px; font-weight:
.blue { color:blue; }
.under { text-decoration:underline; }
.highlight { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p class="blue under">Hello</p>
<p class="blue under highlight">and</p>
<p class="blue under">then</p>
<p class="blue under">Goodbye</p>
<script>$("p:even").removeClass("blue");</script
</body>
</html>

Demo
Example:

Remove the class 'blue' and 'under' from the
matched elements.
1

<!DOCTYPE html>
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<html>
<head>
<style>
p { margin: 4px; font-size:16px; font-weight:
.blue { color:blue; }
.under { text-decoration:underline; }
.highlight { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p class="blue under">Hello</p>
<p class="blue under highlight">and</p>
<p class="blue under">then</p>
<p class="blue under">Goodbye</p>
<script>$("p:odd").removeClass("blue under");</
</body>
</html>

Demo
Example:

Remove all the classes from the matched

elements.
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<!DOCTYPE html>
<html>
<head>
<style>
p { margin: 4px; font-size:16px; font-weight:
.blue { color:blue; }
.under { text-decoration:underline; }
.highlight { background:yellow; }
</style>
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<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p class="blue under">Hello</p>
<p class="blue under highlight">and</p>
<p class="blue under">then</p>
<p class="blue under">Goodbye</p>
<script>$("p:eq(1)").removeClass();</script>
</body>
</html>

Demo
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.removeData()
Categories: Data | Miscellaneous > Data Storage

.removeData( [name ] )

Returns: jQuery

Description: Remove a previously-stored piece of data.
.removeData( [name ] )

version added: 1.2.3

name
Type: String
A string naming the piece of data to delete.

.removeData( [list ] )

version added: 1.7

list
Type: Array or String
An array or space-separated string naming the pieces of data to
delete.
The .removeData() method allows us to remove values that were
previously set using .data() . When called with the name of a key,
.removeData() deletes that particular value; when called with no
arguments, all values are removed. Removing data from jQuery's
internal .data() cache does not effect any HTML5 data- attributes
in a document; use .removeAttr() to remove those.
When using .removeData("name") , jQuery will attempt to locate a
data- attribute on the element if no property by that name is in the
internal data cache. To avoid a re-query of the data- attribute, set
the name to a value of either null or undefined (e.g. .data("name",
undefined) ) rather than using .removeData() .
As of jQuery 1.7, when called with an array of keys or a string of
space-separated keys, .removeData() deletes the value of each key
in that array or string.
As of jQuery 1.4.3, calling .removeData() will cause the value of the
property being removed to revert to the value of the data attribute of
the same name in the DOM, rather than being set to undefined .

Example:
Set a data store for 2 names then remove one of
them.
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<!DOCTYPE html>
<html>
<head>
<style>
div { margin:2px; color:blue; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>value1 before creation: <span></span></div
<div>value1 after creation: <span></span></div
<div>value1 after removal: <span></span></div
<div>value2 after removal: <span></span></div
<script>
$("span:eq(0)").text("" + $("div").data("test1"
$("div").data("test1", "VALUE-1");
$("div").data("test2", "VALUE-2");
$("span:eq(1)").text("" + $("div").data("test1"
$("div").removeData("test1");
$("span:eq(2)").text("" + $("div").data("test1"
$("span:eq(3)").text("" + $("div").data("test2"
</script>
</body>
</html>

Demo
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.removeProp()
Categories: Attributes | Manipulation > General Attributes

.removeProp( propertyName )

Returns: jQuery

Description: Remove a property for the set of matched
elements.
.removeProp( propertyName )

version added: 1.6

propertyName
Type: String
The name of the property to remove.
The .removeProp() method removes properties set by the
method.

.prop()

With some built-in properties of a DOM element or window object,
browsers may generate an error if an attempt is made to remove the
property. jQuery first assigns the value undefined to the property and
ignores any error the browser generates. In general, it is only
necessary to remove custom properties that have been set on an
object, and not built-in (native) properties.
Note: Do not use this method to remove native properties such as
checked, disabled, or selected. This will remove the property
completely and, once removed, cannot be added again to element.
Use .prop() to set these properties to false instead.

Additional Notes:
In Internet Explorer prior to version 9, using .prop() to set a
DOM element property to anything other than a simple primitive
value (number, string, or boolean) can cause memory leaks if
the property is not removed (using .removeProp() ) before the
DOM element is removed from the document. To safely set
values on DOM objects without memory leaks, use .data() .

Example:
Set a numeric property on a paragraph and then
remove it.
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<!DOCTYPE html>
<html>
<head>
<style>
img { padding:10px; }
div { color:red; font-size:24px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p></p>

<script>
var $para = $("p");
$para.prop("luggageCode", 1234);
$para.append("The secret luggage code is: ", String($par
$para.removeProp("luggageCode");
$para.append("Now the secret luggage code is: "
</script>
</body>
</html>

Demo
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A new version of this book is available!

.replaceAll()
Categories: Manipulation > DOM Replacement

.replaceAll( target )

Returns: jQuery

Description: Replace each target element with the set
of matched elements.
.replaceAll( target )

version added: 1.2

target
Type: Selector
A selector expression indicating which element(s) to replace.
The .replaceAll() method is corollary to .replaceWith() , but with
the source and target reversed. Consider this DOM structure:
1
2
3
4
5

<div class="container">
<div class="inner first">Hello</div>
<div class="inner second">And</div>
<div class="inner third">Goodbye</div>
</div>

We can create an element, then replace other elements with it:
1

$('<h2>New heading</h2>').replaceAll('.inner');

This causes all of them to be replaced:
1
2
3
4
5

<div class="container">
<h2>New heading</h2>
<h2>New heading</h2>
<h2>New heading</h2>
</div>

Or, we could select an element to use as the replacement:
1

$('.first').replaceAll('.third');

This results in the DOM structure:
1
2
3
4

<div class="container">
<div class="inner second">And</div>
<div class="inner first">Hello</div>
</div>

From this example, we can see that the selected element replaces
the target by being moved from its old location, not by being cloned.

Example:
Replace all the paragraphs with bold words.
1
2
3
4
5
6
7
8
9
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13

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>cruel</p>
<p>World</p>
<script>$("<b>Paragraph. </b>").replaceAll("p");
</body>
</html>

Demo
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.replaceWith()
Categories: Manipulation > DOM Replacement

.replaceWith( newContent )

Returns: jQuery

Description: Replace each element in the set of
matched elements with the provided new content and
return the set of elements that was removed.
.replaceWith( newContent )

version added: 1.2

newContent
Type: htmlString or Element or jQuery
The content to insert. May be an HTML string, DOM element, or
jQuery object.

.replaceWith( function )

version added: 1.4

function
Type: Function()
A function that returns content with which to replace the set of
matched elements.
The .replaceWith() method removes content from the DOM and
inserts new content in its place with a single call. Consider this DOM
structure:
1
2
3
4
5

<div class="container">
<div class="inner first">Hello</div>
<div class="inner second">And</div>
<div class="inner third">Goodbye</div>
</div>

The second inner
1

<div>

could be replaced with the specified HTML:

$('div.second').replaceWith('<h2>New heading</h2>'

This results in the structure:
1
2
3
4
5

<div class="container">
<div class="inner first">Hello</div>
<h2>New heading</h2>
<div class="inner third">Goodbye</div>
</div>

All inner
1

<div>

elements could be targeted at once:

$('div.inner').replaceWith('<h2>New heading</h2>'

This causes all of them to be replaced:
1
2
3
4
5

<div class="container">
<h2>New heading</h2>
<h2>New heading</h2>
<h2>New heading</h2>
</div>

An element could also be selected as the replacement:
1

$('div.third').replaceWith($('.first'));

This results in the DOM structure:
1
2
3
4

<div class="container">
<div class="inner second">And</div>
<div class="inner first">Hello</div>
</div>

This example demonstrates that the selected element replaces the
target by being moved from its old location, not by being cloned.
The .replaceWith() method, like most jQuery methods, returns the
jQuery object so that other methods can be chained onto it.
However, it must be noted that the original jQuery object is returned.
This object refers to the element that has been removed from the
DOM, not the new element that has replaced it.
As of jQuery 1.4, .replaceWith() can also work on disconnected
DOM nodes. For example, with the following code, .replaceWith()
returns a jQuery set containing only a paragraph.:
1
The
1
2
3

$("<div/>").replaceWith("<p></p>");

.replaceWith()

method can also take a function as its argument:

$('div.container').replaceWith(function() {
return $(this).contents();
});

This results in <div class="container"> being replaced by its three
child <div> s. The return value of the function may be an HTML
string, DOM element, or jQuery object.

Examples:
On click, replace the button with a div
containing the same word.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

<!DOCTYPE html>
<html>
<head>
<style>
button { display:block; margin:3px; color:red;
div { color:red; border:2px solid blue; width
margin:3px; text-align:center; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>First</button>
<button>Second</button>
<button>Third</button>
<script>
$("button").click(function () {
$(this).replaceWith( "<div>" + $(this).text() +
});
</script>
</body>
</html>

Demo
Example:

Replace all paragraphs with bold words.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>cruel</p>
<p>World</p>
<script>
$("p").replaceWith( "<b>Paragraph. </b>" );
</script>
</body>
</html>

Demo
Example:

On click, replace each paragraph with a div
that is already in the DOM and selected with the $()
function. Notice it doesn't clone the object but rather
moves it to replace the paragraph.
1
2
3
4
5
6
7
8
9
10
11

<!DOCTYPE html>
<html>
<head>
<style>
div { border:2px solid blue; color:red; margin
p { border:2px solid red; color:blue; margin:
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

12
13
14
15
16
17
18
19
20
21
22
23
24
25

<p>Hello</p>
<p>cruel</p>
<p>World</p>
<div>Replaced!</div>
<script>
$("p").click(function () {
$(this).replaceWith( $("div") );
});
</script>
</body>
</html>

Demo
Example:

On button click, replace the containing div
with its child divs and append the class name of the
selected element to the paragraph.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

<!DOCTYPE html>
<html>
<head>
<style>
.container { background-color: #991; }
.inner { color: #911; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>
<button>Replace!</button>
</p>
<div class="container">

16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32

<div class="inner">Scooby</div>
<div class="inner">Dooby</div>
<div class="inner">Doo</div>
</div>
<script>
$('button').on("click", function() {
var $container = $("div.container").replaceWith(
return $(this).contents();
});
$("p").append( $container.attr("class") );
});
</script>
</body>
</html>

Demo
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:reset Selector
Categories: Selectors > Form | Selectors > jQuery Extensions

reset selector
Description: Selects all elements of type reset.
jQuery( ":reset" )
:reset

is equivalent to

version added: 1.0
[type="reset"]

Additional Notes:
Because :reset is a jQuery extension and not part of the CSS
specification, queries using :reset cannot take advantage of
the performance boost provided by the native DOM
querySelectorAll() method. For better performance in modern
browsers, use [type="reset"] instead.

Example:
Finds all reset inputs.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

<!DOCTYPE html>
<html>
<head>
<style>
textarea { height:45px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<input type="button" value="Input Button"/>
<input type="checkbox" />
<input type="file" />
<input type="hidden" />
<input type="image" />
<input type="password" />
<input type="radio" />
<input type="reset" />
<input type="submit" />
<input type="text" />
<select><option>Option<option/></select>
<textarea></textarea>
<button>Button</button>
</form>
<div>
</div>
<script>

32
33
34
35
36
37
38
39

var input = $("input:reset").css({background:"yellow"
$("div").text("For this type jQuery found " + input.leng
.css("color", "red");
$("form").submit(function () { return false; });
</script>
</body>
</html>

Demo
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.resize()
Categories: Events > Browser Events

.resize( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "resize"
JavaScript event, or trigger that event on an element.
.resize( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.resize( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.resize()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('resize', handler) in the first and
second variations, and .trigger('resize') in the third.
The resize event is sent to the
browser window changes:
1
2
3

window

element when the size of the

$(window).resize(function() {
$('#log').append('<div>Handler for .resize() called.</
});

Now whenever the browser window's size is changed, the message
is appended to <div id="log"> one or more times, depending on the
browser.
Code in a resize handler should never rely on the number of times
the handler is called. Depending on implementation, resize events
can be sent continuously as the resizing is in progress (the typical
behavior in Internet Explorer and WebKit-based browsers such as
Safari and Chrome), or only once at the end of the resize operation
(the typical behavior in some other browsers such as Opera).

Example:
To see the window width while (or after) it is resized,
try:
1
2
3

$(window).resize(function() {
$('body').prepend('<div>' + $(window).width() +
});

POWERED BYHERONOTE
A new version of this book is available!

:root Selector
Categories: Selectors > Basic Filter

root selector
Description: Selects the element that is the root of the
document.
jQuery( ":root" )

version added: 1.9

index: The index of each child to match, starting with 1 , the string
even or odd , or an equation ( eg. :nth-last-child(even) , :nthlast-child(4n) )
In HTML, the root of the document, and thus the element that
$(":root") selects, is always the <html> element.

Example:
Display the tag name of the root element.
1
2
3
4
5
6
7
8
9
10
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13
14
15
16

<!DOCTYPE html>
<html>
<head>
<style>
span.fot { color: red; font-size: 120%; font-style
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div id="log">The root of this document is: </
<script>
$( "<b></b>" ).html( $( ":root" )[0].nodeName ).appendTo
</script>
</body>
</html>

Demo
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.scroll()
Categories: Events > Browser Events

.scroll( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "scroll"
JavaScript event, or trigger that event on an element.
.scroll( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.scroll( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.scroll()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('scroll', handler) in the first and
second variations, and .trigger('scroll') in the third.
The scroll event is sent to an element when the user scrolls to a
different place in the element. It applies to window objects, but also to
scrollable frames and elements with the overflow CSS property set
to scroll (or auto when the element's explicit height or width is less
than the height or width of its contents).
For example, consider the HTML:
1

<div id="target" style="overflow: scroll; width: 200px;

2
3
4
5
6
7
8
9
10
11
12
13
14

Lorem ipsum dolor sit amet, consectetur adipisicing e
sed do eiusmod tempor incididunt ut labore et dolore
aliqua. Ut enim ad minim veniam, quis nostrud exercit
ullamco laboris nisi ut aliquip ex ea commodo consequ
Duis aute irure dolor in reprehenderit in voluptate v
esse cillum dolore eu fugiat nulla pariatur. Excepteu
sint occaecat cupidatat non proident, sunt in culpa q
officia deserunt mollit anim id est laborum.
</div>
<div id="other">
Trigger the handler
</div>
<div id="log"></div>

The style definition is present to make the target element small
enough to be scrollable:

The
1
2
3

scroll

event handler can be bound to this element:

$('#target').scroll(function() {
$('#log').append('<div>Handler for .scroll() called.</
});

Now when the user scrolls the text up or down, one or more
messages are appended to <div id="log"></div> :

Handler for .scroll() called.
To trigger the event manually, apply
1
2
3

.scroll()

without an argument:

$('#other').click(function() {
$('#target').scroll();
});

After this code executes, clicks on Trigger the handler will also
append the message.
A scroll event is sent whenever the element's scroll position
changes, regardless of the cause. A mouse click or drag on the
scroll bar, dragging inside the element, pressing the arrow keys, or
using the mouse's scroll wheel could cause this event.

Example:
To do something when your page is scrolled:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

<!DOCTYPE html>
<html>
<head>
<style>
div { color:blue; }
p { color:green; }
span { color:red; display:none; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>Try scrolling the iframe.</div>
<p>Paragraph - <span>Scroll happened!</span></
<script>
$("p").clone().appendTo(document.body);
$("p").clone().appendTo(document.body);
$("p").clone().appendTo(document.body);
$(window).scroll(function () {
$("span").css("display", "inline").fadeOut("slow"
});
</script>
</body>
</html>

Demo
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.scrollLeft()
Categories: CSS | Offset | Manipulation > Style Properties

Get the current horizontal position of the scroll bar for the first element
in the set of matched elements or set the horizontal position of the
scroll bar for every matched element.
Contents:
.scrollLeft()
.scrollLeft()
.scrollLeft( value )
.scrollLeft( value )

.scrollLeft()

Returns: Integer

Description: Get the current horizontal position of the
scroll bar for the first element in the set of matched
elements.
.scrollLeft()

version added: 1.2.6

This method does not accept any arguments.
The horizontal scroll position is the same as the number of pixels
that are hidden from view to the left of the scrollable area. If the
scroll bar is at the very left, or if the element is not scrollable, this
number will be 0 .

Note: .scrollLeft() , when called directly or
animated as a property using .animate() , will
not work if the element it is being applied to
is hidden.

Example:
Get the scrollLeft of a paragraph.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

Demo

<!DOCTYPE html>
<html>
<head>
<style>
p { margin:10px;padding:5px;border:2px solid
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p><p></p>
<script>var p = $("p:first");
$("p:last").text( "scrollLeft:" + p.scrollLeft() );
</script>
</body>
</html>

.scrollLeft( value )

Returns: jQuery

Description: Set the current horizontal position of the
scroll bar for each of the set of matched elements.
.scrollLeft( value )

version added: 1.2.6

value
Type: Number
An integer indicating the new position to set the scroll bar to.
The horizontal scroll position is the same as the number of pixels
that are hidden from view above the scrollable area. Setting the
scrollLeft positions the horizontal scroll of each matched element.

Example:
Set the scrollLeft of a div.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
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24
25

<!DOCTYPE html>
<html>
<head>
<style>
div.demo {
background:#CCCCCC none repeat scroll 0 0;
border:3px solid #666666;
margin:5px;
padding:5px;
position:relative;
width:200px;
height:100px;
overflow:auto;
}
p { margin:10px;padding:5px;border:2px solid
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div class="demo"><h1>lalala</h1><p>Hello</p>
<script>$("div.demo").scrollLeft(300);
</script>
</body>
</html>

Demo
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A new version of this book is available!

.scrollTop()
Categories: CSS | Offset | Manipulation > Style Properties

Contents:
.scrollTop()
.scrollTop()
.scrollTop( value )
.scrollTop( value )

.scrollTop()

Returns: Integer

Description: Get the current vertical position of the
scroll bar for the first element in the set of matched
elements or set the vertical position of the scroll bar for
every matched element.
.scrollTop()

version added: 1.2.6

This method does not accept any arguments.
The vertical scroll position is the same as the number of pixels that
are hidden from view above the scrollable area. If the scroll bar is at
the very top, or if the element is not scrollable, this number will be 0 .

Example:
Get the scrollTop of a paragraph.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

Demo

<!DOCTYPE html>
<html>
<head>
<style>
p { margin:10px;padding:5px;border:2px solid
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p><p></p>
<script>var p = $("p:first");
$("p:last").text( "scrollTop:" + p.scrollTop() );
</script>
</body>
</html>

.scrollTop( value )

Returns: jQuery

Description: Set the current vertical position of the
scroll bar for each of the set of matched elements.
.scrollTop( value )

version added: 1.2.6

value
Type: Number
An integer indicating the new position to set the scroll bar to.
The vertical scroll position is the same as the number of pixels that
are hidden from view above the scrollable area. Setting the
scrollTop positions the vertical scroll of each matched element.

Example:
Set the scrollTop of a div.
1
2
3
4
5
6
7
8
9
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12
13
14
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20
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<!DOCTYPE html>
<html>
<head>
<style>
div.demo {
background:#CCCCCC none repeat scroll 0 0;
border:3px solid #666666;
margin:5px;
padding:5px;
position:relative;
width:200px;
height:100px;
overflow:auto;
}
p { margin:10px;padding:5px;border:2px solid
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div class="demo"><h1>lalala</h1><p>Hello</p>
<script>$("div.demo").scrollTop(300);
</script>
</body>
</html>

Demo
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.select()
Categories: Events > Form Events | Forms

.select( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "select"
JavaScript event, or trigger that event on an element.
.select( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.select( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.select()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('select', handler) in the first two
variations, and .trigger('select') in the third.
The select event is sent to an element when the user makes a text
selection inside it. This event is limited to <input type="text"> fields
and <textarea> boxes.
For example, consider the HTML:
1
2
3

<form>
<input id="target" type="text" value="Hello there"
</form>

4
5
6

<div id="other">
Trigger the handler
</div>

The event handler can be bound to the text input:
1
2
3

$('#target').select(function() {
alert('Handler for .select() called.');
});

Now when any portion of the text is selected, the alert is displayed.
Merely setting the location of the insertion point will not trigger the
event. To trigger the event manually, apply .select() without an
argument:
1
2
3

$('#other').click(function() {
$('#target').select();
});

After this code executes, clicks on the Trigger button will also alert
the message:
Handler for .select() called.
In addition, the default select action on the field will be fired, so the
entire text field will be selected.

The method for retrieving the current
selected text differs from one browser to
another. A number of jQuery plug-ins offer
cross-platform solutions.

Examples:
To do something when text in input boxes is

Example:

selected:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

Demo

<!DOCTYPE html>
<html>
<head>
<style>
p { color:blue; }
div { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

<p>
Click and drag the mouse to select text in the input
</p>
<input type="text" value="Some text" />
<input type="text" value="to test on" />

<div></div>
<script>
$(":input").select( function () {
$("div").text("Something was selected").show().fadeOut
});
</script>
</body>
</html>

To trigger the select event on all input
elements, try:
Example:

1

$("input").select();

POWERED BYHERONOTE
A new version of this book is available!

:selected Selector
Categories: Selectors > Form | Selectors > jQuery Extensions

selected selector
Description: Selects all elements that are selected.
jQuery( ":selected" )

version added: 1.0

The :selected selector works for <option> elements. It does not
work for checkboxes or radio inputs; use :checked for them.

Additional Notes:
Because :selected is a jQuery extension and not part of the
CSS specification, queries using :selected cannot take
advantage of the performance boost provided by the native
DOM querySelectorAll() method. To achieve the best
performance when using :selected to select elements, first
select the elements using a pure CSS selector, then use
.filter(":selected") .

Example:
Attaches a change event to the select that gets the
text for each selected option and writes them in the div.
It then triggers the event for the initial text draw.
1
2
3
4
5
6
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23
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27
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<!DOCTYPE html>
<html>
<head>
<style>
div { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<select name="garden" multiple="multiple">
<option>Flowers</option>
<option selected="selected">Shrubs</option>
<option>Trees</option>
<option selected="selected">Bushes</option>
<option>Grass</option>
<option>Dirt</option>
</select>
<div></div>
<script>
$("select").change(function () {
var str = "";
$("select option:selected").each(function () {
str += $(this).text() + " ";
});
$("div").text(str);
})
.trigger('change');

30
31
32
33

</script>
</body>
</html>

Demo
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.selector
Categories: Internals | Properties > Properties of the Global jQuery Object

selector

Returns: String
version removed: 1.9

Description: A selector representing selector originally
passed to jQuery().
selector

version added: 1.3

Should be used in conjunction with context to determine the exact
query used.
The .live() method for binding event handlers uses this property to
determine how to perform its searches. Plug-ins which perform
similar tasks may also find the property useful. This property
contains a string representing the matched set of elements, but if
DOM traversal methods have been called on the object, the string
may not be a valid jQuery selector expression. For this reason, the
value of .selector is generally most useful immediately following the
original creation of the object. Consequently, the .live() method
should only be used in this scenario.

POWERED BYHERONOTE
A new version of this book is available!

.serialize()
Categories: Forms | Ajax > Helper Functions

.serialize()

Returns: String

Description: Encode a set of form elements as a string
for submission.
.serialize()

version added: 1.0

This method does not accept any arguments.
The .serialize() method creates a text string in standard URLencoded notation. It operates on a jQuery object representing a set
of form elements. The form elements can be of several types:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

The

<form>
<div><input type="text" name="a" value="1" id
<div><input type="text" name="b" value="2" id
<div><input type="hidden" name="c" value="3"
<div>
<textarea name="d" rows="8" cols="40">4</textarea
</div>
<div><select name="e">
<option value="5" selected="selected">5</option
<option value="6">6</option>
<option value="7">7</option>
</select></div>
<div>
<input type="checkbox" name="f" value="8" id
</div>
<div>
<input type="submit" name="g" value="Submit"
</div>
</form>

.serialize()

method can act on a jQuery object that has

selected individual form elements, such as <input> ,
<select> . However, it is typically easier to select the
for serialization:
1
2
3
4

<textarea> , and
<form> tag itself

$('form').submit(function() {
alert($(this).serialize());
return false;
});

This produces a standard-looking query string:
1

a=1&b=2&c=3&d=4&e=5

Warning: selecting both the form and its children will cause
duplicates in the serialized string.
Note: Only "successful controls" are serialized to the string. No
submit button value is serialized since the form was not submitted
using a button. For a form element's value to be included in the
serialized string, the element must have a name attribute. Values
from checkboxes and radio buttons ( input s of type "radio" or
"checkbox") are included only if they are checked. Data from file
select elements is not serialized.

Example:
Serialize a form to a query string, that could be sent
to a server in an Ajax request.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
body, select { font-size:12px; }
form { margin:5px; }
p { color:red; margin:5px; font-size:14px; }
b { color:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

<form>
<select name="single">
<option>Single</option>
<option>Single2</option>
</select>
<br />
<select name="multiple" multiple="multiple">
<option selected="selected">Multiple</option
<option>Multiple2</option>
<option selected="selected">Multiple3</option
</select>
<br/>
<input type="checkbox" name="check" value="check1"

31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56

<label for="ch1">check1</label>
<input type="checkbox" name="check" value="check2"
<label for="ch2">check2</label>
<br />
<input type="radio" name="radio" value="radio1"
<label for="r1">radio1</label>
<input type="radio" name="radio" value="radio2"
<label for="r2">radio2</label>
</form>
<p><tt id="results"></tt></p>
<script>
function showValues() {
var str = $("form").serialize();
$("#results").text(str);
}
$(":checkbox, :radio").click(showValues);
$("select").change(showValues);
showValues();
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

.serializeArray()
Categories: Forms | Ajax > Helper Functions

.serializeArray()

Returns: Array

Description: Encode a set of form elements as an array
of names and values.
.serializeArray()

version added: 1.2

This method does not accept any arguments.
The .serializeArray() method creates a JavaScript array of objects,
ready to be encoded as a JSON string. It operates on a jQuery
object representing a set of form elements. The form elements can
be of several types:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

<form>
<div><input type="text" name="a" value="1" id
<div><input type="text" name="b" value="2" id
<div><input type="hidden" name="c" value="3"
<div>
<textarea name="d" rows="8" cols="40">4</textarea
</div>
<div><select name="e">
<option value="5" selected="selected">5</option
<option value="6">6</option>
<option value="7">7</option>
</select></div>
<div>
<input type="checkbox" name="f" value="8" id
</div>
<div>
<input type="submit" name="g" value="Submit"
</div>
</form>

The .serializeArray() method uses the standard W3C rules for
successful controls to determine which elements it should include; in
particular the element cannot be disabled and must contain a name
attribute. No submit button value is serialized since the form was not
submitted using a button. Data from file select elements is not
serialized.
This method can act on a jQuery object that has selected individual
form elements, such as <input> , <textarea> , and <select> .
However, it is typically easier to select the <form> tag itself for
serialization:
1
2
3
4

$('form').submit(function() {
console.log($(this).serializeArray());
return false;
});

This produces the following data structure (provided that the browser
supports console.log ):
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

[
{
name: "a",
value: "1"
},
{
name: "b",
value: "2"
},
{
name: "c",
value: "3"
},
{
name: "d",
value: "4"

17
18
19
20
21
22

},
{
name: "e",
value: "5"
}
]

Example:
Get the values from a form, iterate through them, and
append them to a results display.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
body, select { font-size:14px; }
form { margin:5px; }
p { color:red; margin:5px; }
b { color:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><b>Results:</b> <span id="results"></span>
<form>
<select name="single">
<option>Single</option>
<option>Single2</option>
</select>
<select name="multiple" multiple="multiple"
<option selected="selected">Multiple</option
<option>Multiple2</option>
<option selected="selected">Multiple3</option
</select><br/>
<input type="checkbox" name="check" value="check1"
<label for="ch1">check1</label>
<input type="checkbox" name="check" value="check2"

31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55

<label for="ch2">check2</label>
<input type="radio" name="radio" value="radio1"
<label for="r1">radio1</label>
<input type="radio" name="radio" value="radio2"
<label for="r2">radio2</label>
</form>
<script>
function showValues() {
var fields = $(":input").serializeArray();
$("#results").empty();
jQuery.each(fields, function(i, field){
$("#results").append(field.value + " ");
});
}
$(":checkbox, :radio").click(showValues);
$("select").change(showValues);
showValues();
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

.show()
Categories: Effects > Basics

.show()

Returns: jQuery

Description: Display the matched elements.
.show()

version added: 1.0

This method does not accept any arguments.

.show( [duration ] [, complete ] )

version added: 1.0

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
complete
Type: Function()
A function to call once the animation is complete.

.show( options )

version added: 1.0

options
Type: PlainObject
A map of additional options to pass to the method.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will
run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
queue (default: true )
Type: Boolean
A Boolean indicating whether to place the animation in the
effects queue. If false, the animation will begin immediately.
As of jQuery 1.7, the queue option can also accept a
string, in which case the animation is added to the queue
represented by that string.

specialEasing
Type: PlainObject
A map of one or more of the CSS properties defined by the
properties argument and their corresponding easing
functions. (version added: 1.4)
step
Type: Function( Number now, Tween tween )
A function to be called for each animated property of each
animated element. This function provides an opportunity to
modify the Tween object to change the value of the
property before it is set.
progress
Type: Function( Promise animation, Number progress,
Number remainingMs )
A function to be called after each step of the animation,
only once per animated element regardless of the number
of animated properties. (version added: 1.8)
complete
Type: Function()
A function to call once the animation is complete.
done
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes (its
Promise object is resolved). (version added: 1.8)
fail
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation fails to complete
(its Promise object is rejected). (version added: 1.8)
always
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes or
stops without completing (its Promise object is either
resolved or rejected). (version added: 1.8)

.show( [duration ] [, easing ] [,
complete ] )

version added: 1.4.3

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.
With no parameters, the
display an element:
1

.show()

method is the simplest way to

$('.target').show();

The matched elements will be revealed immediately, with no
animation. This is roughly equivalent to calling .css('display',
'block') , except that the display property is restored to whatever it
was initially. If an element has a display value of inline , then is
hidden and shown, it will once again be displayed inline .
Note: If using !important in your styles, such as display: none
!important , it is necessary to override the style using .css('display',
'block !important') should you wish for .show() to function correctly.
When a duration, a plain object, or a "complete" function is provided,
.show() becomes an animation method. The .show() method
animates the width, height, and opacity of the matched elements
simultaneously.
Durations are given in milliseconds; higher values indicate slower
animations, not faster ones. The strings 'fast' and 'slow' can be
supplied to indicate durations of 200 and 600 milliseconds,
respectively.

As of jQuery 1.4.3, an optional string naming an easing function may
be used. Easing functions specify the speed at which the animation
progresses at different points within the animation. The only easing
implementations in the jQuery library are the default, called swing ,
and one that progresses at a constant pace, called linear . More
easing functions are available with the use of plug-ins, most notably
the jQuery UI suite.
If supplied, the callback is fired once the animation is complete. This
can be useful for stringing different animations together in sequence.
The callback is not sent any arguments, but this is set to the DOM
element being animated. If multiple elements are animated, it is
important to note that the callback is executed once per matched
element, not once for the animation as a whole.
We can animate any element, such as a simple image:
1
2
3
4
5
6
7
8
9
10

<div id="clickme">
Click here
</div>
<img id="book" src="book.png" alt="" width="100"
With the element initially hidden, we can show it slowl
$('#clickme').click(function() {
$('#book').show('slow', function() {
// Animation complete.
});
});

Additional Notes:
All jQuery effects, including .show() , can be turned off globally
by setting jQuery.fx.off = true , which effectively sets the
duration to 0. For more information, see jQuery.fx.off.

Examples:
Animates all hidden paragraphs to show
slowly, completing the animation within 600
milliseconds.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

<!DOCTYPE html>
<html>
<head>
<style>
p { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Show it</button>
<p style="display: none">Hello 2</p>
<script>
$("button").click(function () {
$("p").show("slow");
});
</script>
</body>
</html>

Demo
Example:

Show the first div, followed by each next
adjacent sibling div in order, with a 200ms animation.
Each animation starts when the previous sibling div's
animation ends.
1

<!DOCTYPE html>

2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32

<html>
<head>
<style>
div { background:#def3ca; margin:3px; width:80
display:none; float:left; text-align:center;
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="showr">Show</button>
<button id="hidr">Hide</button>
<div>Hello 3,</div>
<div>how</div>
<div>are</div>
<div>you?</div>
<script>
$("#showr").click(function () {
$("div").first().show("fast", function showNext
$(this).next("div").show("fast", showNext);
});
});
$("#hidr").click(function () {
$("div").hide(1000);
});
</script>
</body>
</html>

Demo
Example:

Show all span and input elements with an
animation. Change the text once the animation is
done.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36

<!DOCTYPE html>
<html>
<head>
<style>
span { display:none; }
div { display:none; }
p { font-weight:bold; background-color:#fcd;
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Do it!</button>
<span>Are you sure? (type 'yes' if you are) </span
<div>
<form>
<input type="text" value="as;ldkfjalsdf"/>
</form>
</div>
<p style="display:none;">I'm hidden...</p>
<script>
function doIt() {
$("span,div").show("slow");
}
/* can pass in function name */
$("button").click(doIt);
$("form").submit(function () {
if ($("input").val() == "yes") {
$("p").show(4000, function () {
$(this).text("Ok, DONE! (now showing)");
});
}
$("span,div").hide("fast");
/* to stop the submit */

37
38
39
40
41
42

return false;
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.siblings()
Categories: Traversing > Tree Traversal

.siblings( [selector ] )

Returns: jQuery

Description: Get the siblings of each element in the set
of matched elements, optionally filtered by a selector.
.siblings( [selector ] )

version added: 1.0

selector
Type: Selector
A string containing a selector expression to match elements
against.
Given a jQuery object that represents a set of DOM elements, the
.siblings() method allows us to search through the siblings of
these elements in the DOM tree and construct a new jQuery object
from the matching elements.
The method optionally accepts a selector expression of the same
type that we can pass to the $() function. If the selector is supplied,
the elements will be filtered by testing whether they match it.
Consider a page with a simple list on it:
1
2
3
4
5
6
7

<ul>
<li>list item 1</li>
<li>list item 2</li>
<li class="third-item">list item 3</li>
<li>list item 4</li>
<li>list item 5</li>
</ul>

If we begin at the third item, we can find its siblings:
1

$('li.third-item').siblings().css('background-color'

The result of this call is a red background behind items 1, 2, 4, and
5. Since we do not supply a selector expression, all of the siblings
are part of the object. If we had supplied one, only the matching
items among these four would be included.
The original element is not included among the siblings, which is
important to remember when we wish to find all elements at a
particular level of the DOM tree.

Examples:
Find the unique siblings of all yellow li
elements in the 3 lists (including other yellow li
elements if appropriate).
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<!DOCTYPE html>
<html>
<head>
<style>
ul { float:left; margin:5px; font-size:16px;
p { color:blue; margin:10px 20px; font-size:16
font-weight:bolder; }
.hilite { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<ul>
<li>One</li>
<li>Two</li>
<li class="hilite">Three</li>
<li>Four</li>
</ul>
<ul>
<li>Five</li>
<li>Six</li>
<li>Seven</li>
</ul>
<ul>
<li>Eight</li>
<li class="hilite">Nine</li>
<li>Ten</li>
<li class="hilite">Eleven</li>

30
31
32
33
34
35
36
37
38
39
40

</ul>
<p>Unique siblings: <b></b></p>
<script>
var len = $(".hilite").siblings()
.css("color", "red")
.length;
$("b").text(len);
</script>
</body>
</html>

Demo
Example:

Find all siblings with a class "selected" of

each div.
1
2
3
4
5
6
7
8
9
10
11
12
13
14

Demo

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div><span>Hello</span></div>
<p class="selected">Hello Again</p>
<p>And Again</p>
<script>$("p").siblings(".selected").css("background"
</body>
</html>

POWERED BYHERONOTE
A new version of this book is available!

.size()
Categories: Miscellaneous > DOM Element Methods

.size()

Returns: Number
version deprecated: 1.8

Description: Return the number of elements in the
jQuery object.
.size()

version added: 1.0

This method does not accept any arguments.
The .size() method is deprecated as of jQuery 1.8. Use the
property instead.

.length

The .size() method is functionally equivalent to the .length
property; however, the .length property is preferred because it
does not have the overhead of a function call.
Given a simple unordered list on the page:
1
2
3
4
Both

<ul>
<li>foo</li>
<li>bar</li>
</ul>

.size()

1
2

and

.length

alert( "Size: " + $("li").size() );
alert( "Size: " + $("li").length );

This results in two alerts:
Size: 2
Size: 2

identify the number of items:

Example:
Count the divs. Click to add more.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<!DOCTYPE html>
<html>
<head>
<style>
body { cursor:pointer; min-height: 100px; }
div { width:50px; height:30px; margin:5px;
float:left; background:blue; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<span></span>
<div></div>

<script>
$(document.body)
.click(function() {
$(this).append( $("<div>") );
var n = $("div").size();
$("span").text("There are " + n + " divs. Click to add
})
// trigger the click to start
.click();
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.slice()
Categories: Traversing > Filtering

.slice( start [, end ] )

Returns: jQuery

Description: Reduce the set of matched elements to a
subset specified by a range of indices.
.slice( start [, end ] )

version added: 1.1.4

start
Type: Integer
An integer indicating the 0-based position at which the elements
begin to be selected. If negative, it indicates an offset from the
end of the set.
end
Type: Integer
An integer indicating the 0-based position at which the elements
stop being selected. If negative, it indicates an offset from the
end of the set. If omitted, the range continues until the end of
the set.
Given a jQuery object that represents a set of DOM elements, the
.slice() method constructs a new jQuery object containing a subset
of the elements specified by the start and, optionally, end
argument. The supplied start index identifies the position of one of
the elements in the set; if end is omitted, all elements after this one
will be included in the result.
Consider a page with a simple list on it:
1
2
3
4
5
6
7

<ul>
<li>list
<li>list
<li>list
<li>list
<li>list
</ul>

item
item
item
item
item

1</li>
2</li>
3</li>
4</li>
5</li>

We can apply this method to the set of list items:
1

$('li').slice(2).css('background-color', 'red');

The result of this call is a red background for items 3, 4, and 5. Note
that the supplied index is zero-based, and refers to the position of
elements within the jQuery object, not within the DOM tree.
The end parameter allows us to limit the selected range even further.
For example:
1

$('li').slice(2, 4).css('background-color', 'red'

Now only items 3 and 4 are selected. The index is once again zerobased; the range extends up to but not including the specified index.
Negative Indices
The jQuery .slice() method is patterned after the JavaScript .slice()
method for arrays. One of the features that it mimics is the ability for
negative numbers to be passed as either the start or end
parameter. If a negative number is provided, this indicates a position
starting from the end of the set, rather than the beginning. For
example:
1

$('li').slice(-2, -1).css('background-color', 'red'

This time only list item 4 is turned red, since it is the only item in the
range between two from the end ( -2 ) and one from the end ( -1 ).

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
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22
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25
26
27
28
29
30
31

Turns divs yellow based on a random slice.

<!DOCTYPE html>
<html>
<head>
<style>
div { width:40px; height:40px; margin:10px; float
border:2px solid blue; }
span { color:red; font-weight:bold; }
button { margin:5px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><button>Turn slice yellow</button>
<span>Click the button!</span></p>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<script>
function colorEm() {
var $div = $("div");
var start = Math.floor(Math.random() *
$div.length);
var end = Math.floor(Math.random() *
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($div.length - start)) +
start + 1;
if (end == $div.length) end = undefined;
$div.css("background", "");
if (end)
$div.slice(start, end).css("background", "yellow"
else
$div.slice(start).css("background", "yellow"
$("span").text('$("div").slice(' + start +
(end ? ', ' + end : '') +
').css("background", "yellow");'
}
$("button").click(colorEm);
</script>
</body>
</html>

Demo
Example:

Selects all paragraphs, then slices the
selection to include only the first element.
1

$("p").slice(0, 1).wrapInner("<b></b>");

Selects all paragraphs, then slices the
selection to include only the first and second element.
Example:

1

$("p").slice(0, 2).wrapInner("<b></b>");

Selects all paragraphs, then slices the
selection to include only the second element.
Example:

1

$("p").slice(1, 2).wrapInner("<b></b>");

Selects all paragraphs, then slices the
selection to include only the second and third
element.
Example:

1

$("p").slice(1).wrapInner("<b></b>");

Selects all paragraphs, then slices the
selection to include only the third element.
Example:

1

$("p").slice(-1).wrapInner("<b></b>");

POWERED BYHERONOTE
A new version of this book is available!

.slideDown()
Categories: Effects > Sliding

.slideDown( [duration ] [, complete ] )

Returns: jQuery

Description: Display the matched elements with a
sliding motion.
.slideDown( [duration ] [, complete ] ) version added: 1.0
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
complete
Type: Function()
A function to call once the animation is complete.

.slideDown( options )

version added: 1.0

options
Type: PlainObject
A map of additional options to pass to the method.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will
run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
queue (default: true )
Type: Boolean
A Boolean indicating whether to place the animation in the
effects queue. If false, the animation will begin immediately.
As of jQuery 1.7, the queue option can also accept a
string, in which case the animation is added to the queue
represented by that string.
specialEasing
Type: PlainObject

A map of one or more of the CSS properties defined by the
properties argument and their corresponding easing
functions. (version added: 1.4)
step
Type: Function( Number now, Tween tween )
A function to be called for each animated property of each
animated element. This function provides an opportunity to
modify the Tween object to change the value of the
property before it is set.
progress
Type: Function( Promise animation, Number progress,
Number remainingMs )
A function to be called after each step of the animation,
only once per animated element regardless of the number
of animated properties. (version added: 1.8)
complete
Type: Function()
A function to call once the animation is complete.
done
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes (its
Promise object is resolved). (version added: 1.8)
fail
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation fails to complete
(its Promise object is rejected). (version added: 1.8)
always
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes or
stops without completing (its Promise object is either
resolved or rejected). (version added: 1.8)

.slideDown( [duration ] [, easing ] [, version added: 1.4.3
complete ] )

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.
The .slideDown() method animates the height of the matched
elements. This causes lower parts of the page to slide down, making
way for the revealed items.
Durations are given in milliseconds; higher values indicate slower
animations, not faster ones. The strings 'fast' and 'slow' can be
supplied to indicate durations of 200 and 600 milliseconds,
respectively. If any other string is supplied, or if the duration
parameter is omitted, the default duration of 400 milliseconds is
used.
We can animate any element, such as a simple image:
1
2
3
4

<div id="clickme">
Click here
</div>
<img id="book" src="book.png" alt="" width="100"

With the element initially hidden, we can show it slowly:
1
2
3
4

$('#clickme').click(function() {
$('#book').slideDown('slow', function() {
// Animation complete.
});

5

});

Easing
As of jQuery 1.4.3, an optional string naming an easing function
may be used. Easing functions specify the speed at which the
animation progresses at different points within the animation. The
only easing implementations in the jQuery library are the default,
called swing , and one that progresses at a constant pace, called
linear . More easing functions are available with the use of plug-ins,
most notably the jQuery UI suite.
Callback Function
If supplied, the callback is fired once the animation is complete. This
can be useful for stringing different animations together in sequence.
The callback is not sent any arguments, but this is set to the DOM
element being animated. If multiple elements are animated, it is
important to note that the callback is executed once per matched
element, not once for the animation as a whole.
As of jQuery 1.6, the .promise() method can be used in conjunction
with the deferred.done() method to execute a single callback for the
animation as a whole when all matching elements have completed
their animations ( See the example for .promise() ).

Additional Notes:

All jQuery effects, including .slideDown() , can be turned off
globally by setting jQuery.fx.off = true , which effectively sets
the duration to 0. For more information, see jQuery.fx.off.
If .slideDown() is called on an unordered list ( <ul> ) and its <li>
elements have position (relative, absolute, or fixed), the effect
may not work properly in IE6 through at least IE9 unless the
<ul> has "layout." To remedy the problem, add the position:
relative; and zoom: 1; CSS declarations to the ul .

Examples:
Animates all divs to slide down and show
themselves over 600 milliseconds.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<!DOCTYPE html>
<html>
<head>
<style>
div { background:#de9a44; margin:3px; width:80px;
height:40px; display:none; float:left; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
Click me!
<div></div>
<div></div>
<div></div>
<script>
$(document.body).click(function () {
if ($("div:first").is(":hidden")) {
$("div").slideDown("slow");
} else {
$("div").hide();
}
});
</script>
</body>
</html>

Demo
Example:

Animates all inputs to slide down,
completing the animation within 1000 milliseconds.
Once the animation is done, the input look is changed
especially if it is the middle input which gets the
focus.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
div { background:#cfd; margin:3px; width:50px;
text-align:center; float:left; cursor:pointer;
border:2px outset black; font-weight:bolder; }
input { display:none; width:120px; float:left;
margin:10px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>Push!</div>
<input type="text" />
<input type="text" class="middle" />
<input type="text" />
<script>
$("div").click(function () {
$(this).css({ borderStyle:"inset", cursor:"wait"
$("input").slideDown(1000,function(){
$(this).css("border", "2px red inset")
.filter(".middle")
.css("background", "yellow")
.focus();
$("div").css("visibility", "hidden");
});
});
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</script>
</body>
</html>

Demo
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.slideToggle()
Categories: Effects > Sliding

.slideToggle( [duration ] [, complete ] )

Returns: jQuery

Description: Display or hide the matched elements with
a sliding motion.
.slideToggle( [duration ] [, complete ] version added: 1.0
)
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
complete
Type: Function()
A function to call once the animation is complete.

.slideToggle( options )

version added: 1.0

options
Type: PlainObject
A map of additional options to pass to the method.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will
run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
queue (default: true )
Type: Boolean
A Boolean indicating whether to place the animation in the
effects queue. If false, the animation will begin immediately.
As of jQuery 1.7, the queue option can also accept a
string, in which case the animation is added to the queue
represented by that string.
specialEasing

Type: PlainObject
A map of one or more of the CSS properties defined by the
properties argument and their corresponding easing
functions. (version added: 1.4)
step
Type: Function( Number now, Tween tween )
A function to be called for each animated property of each
animated element. This function provides an opportunity to
modify the Tween object to change the value of the
property before it is set.
progress
Type: Function( Promise animation, Number progress,
Number remainingMs )
A function to be called after each step of the animation,
only once per animated element regardless of the number
of animated properties. (version added: 1.8)
complete
Type: Function()
A function to call once the animation is complete.
done
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes (its
Promise object is resolved). (version added: 1.8)
fail
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation fails to complete
(its Promise object is rejected). (version added: 1.8)
always
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes or
stops without completing (its Promise object is either
resolved or rejected). (version added: 1.8)

.slideToggle( [duration ] [, easing ] version added: 1.4.3

[, complete ] )
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.
The .slideToggle() method animates the height of the matched
elements. This causes lower parts of the page to slide up or down,
appearing to reveal or conceal the items. If the element is initially
displayed, it will be hidden; if hidden, it will be shown. The display
property is saved and restored as needed. If an element has a
display value of inline , then is hidden and shown, it will once again
be displayed inline . When the height reaches 0 after a hiding
animation, the display style property is set to none to ensure that
the element no longer affects the layout of the page.
Durations are given in milliseconds; higher values indicate slower
animations, not faster ones. The strings 'fast' and 'slow' can be
supplied to indicate durations of 200 and 600 milliseconds,
respectively.
We can animate any element, such as a simple image:
1
2
3
4

<div id="clickme">
Click here
</div>
<img id="book" src="book.png" alt="" width="100"

We will cause
clicked:

.slideToggle()

to be called when another element is

1
2
3
4
5

$('#clickme').click(function() {
$('#book').slideToggle('slow', function() {
// Animation complete.
});
});

With the element initially shown, we can hide it slowly with the first
click:

A second click will show the element once again:

Easing

As of jQuery 1.4.3, an optional string naming an easing function
may be used. Easing functions specify the speed at which the
animation progresses at different points within the animation. The
only easing implementations in the jQuery library are the default,
called swing , and one that progresses at a constant pace, called
linear . More easing functions are available with the use of plug-ins,
most notably the jQuery UI suite.
Callback Function
If supplied, the callback is fired once the animation is complete. This
can be useful for stringing different animations together in sequence.
The callback is not sent any arguments, but this is set to the DOM
element being animated. If multiple elements are animated, it is
important to note that the callback is executed once per matched
element, not once for the animation as a whole.
As of jQuery 1.6, the .promise() method can be used in conjunction
with the deferred.done() method to execute a single callback for the
animation as a whole when all matching elements have completed
their animations ( See the example for .promise() ).

Additional Notes:
All jQuery effects, including .slideToggle() , can be turned off
globally by setting jQuery.fx.off = true , which effectively sets
the duration to 0. For more information, see jQuery.fx.off.
If .slideDown() is called on an unordered list ( <ul> ) and its <li>
elements have position (relative, absolute, or fixed), the effect
may not work properly in IE6 through at least IE9 unless the
<ul> has "layout." To remedy the problem, add the position:
relative; and zoom: 1; CSS declarations to the ul .

Examples:
Animates all paragraphs to slide up or down,
completing the animation within 600 milliseconds.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

<!DOCTYPE html>
<html>
<head>
<style>
p { width:400px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Toggle</button>

<p>
This is the paragraph to end all paragraphs. You
should feel <em>lucky</em> to have seen such a parag
your life. Congratulations!
</p>
<script>
$("button").click(function () {
$("p").slideToggle("slow");
});
</script>
</body>
</html>

Demo
Example:

Animates divs between dividers with a toggle
that makes some appear and some disappear.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
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<!DOCTYPE html>
<html>
<head>
<style>
div { background:#b977d1; margin:3px; width:60
height:60px; float:left; }
div.still { background:#345; width:5px; }
div.hider { display:none; }
span { color:red; }
p { clear: left; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div></div>
<div class="still"></div>
<div style="display:none;">
</div><div class="still"></div>
<div></div>
<div class="still"></div>
<div class="hider"></div>
<div class="still"></div>
<div class="hider"></div>
<div class="still"></div>
<div></div>
<p><button id="aa">Toggle</button> There have been
<script>
$("#aa").click(function () {
$("div:not(.still)").slideToggle("slow", function
var n = parseInt($("span").text(), 10);
$("span").text(n + 1);
});
});
</script>
</body>
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</html>

Demo
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.slideUp()
Categories: Effects > Sliding

.slideUp( [duration ] [, complete ] )

Returns: jQuery

Description: Hide the matched elements with a sliding
motion.
.slideUp( [duration ] [, complete ] )

version added: 1.0

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
complete
Type: Function()
A function to call once the animation is complete.

.slideUp( options )

version added: 1.0

options
Type: PlainObject
A map of additional options to pass to the method.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will
run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
queue (default: true )
Type: Boolean
A Boolean indicating whether to place the animation in the
effects queue. If false, the animation will begin immediately.
As of jQuery 1.7, the queue option can also accept a
string, in which case the animation is added to the queue
represented by that string.
specialEasing
Type: PlainObject

A map of one or more of the CSS properties defined by the
properties argument and their corresponding easing
functions. (version added: 1.4)
step
Type: Function( Number now, Tween tween )
A function to be called for each animated property of each
animated element. This function provides an opportunity to
modify the Tween object to change the value of the
property before it is set.
progress
Type: Function( Promise animation, Number progress,
Number remainingMs )
A function to be called after each step of the animation,
only once per animated element regardless of the number
of animated properties. (version added: 1.8)
complete
Type: Function()
A function to call once the animation is complete.
done
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes (its
Promise object is resolved). (version added: 1.8)
fail
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation fails to complete
(its Promise object is rejected). (version added: 1.8)
always
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes or
stops without completing (its Promise object is either
resolved or rejected). (version added: 1.8)

.slideUp( [duration ] [, easing ] [,
complete ] )

version added: 1.4.3

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.
The .slideUp() method animates the height of the matched
elements. This causes lower parts of the page to slide up, appearing
to conceal the items. Once the height reaches 0 (or, if set, to
whatever the CSS min-height property is), the display style property
is set to none to ensure that the element no longer affects the layout
of the page.
Durations are given in milliseconds; higher values indicate slower
animations, not faster ones. The strings 'fast' and 'slow' can be
supplied to indicate durations of 200 and 600 milliseconds,
respectively. If any other string is supplied, or if the duration
parameter is omitted, the default duration of 400 milliseconds is
used.
We can animate any element, such as a simple image:
1
2
3
4

<div id="clickme">
Click here
</div>
<img id="book" src="book.png" alt="" width="100"

With the element initially shown, we can hide it slowly:
1
2

$('#clickme').click(function() {
$('#book').slideUp('slow', function() {

3
4
5

// Animation complete.
});
});

Easing
As of jQuery 1.4.3, an optional string naming an easing function
may be used. Easing functions specify the speed at which the
animation progresses at different points within the animation. The
only easing implementations in the jQuery library are the default,
called swing , and one that progresses at a constant pace, called
linear . More easing functions are available with the use of plug-ins,
most notably the jQuery UI suite.
Callback Function
If supplied, the callback is fired once the animation is complete. This
can be useful for stringing different animations together in sequence.
The callback is not sent any arguments, but this is set to the DOM
element being animated. If multiple elements are animated, it is
important to note that the callback is executed once per matched
element, not once for the animation as a whole.
As of jQuery 1.6, the .promise() method can be used in conjunction
with the deferred.done() method to execute a single callback for the
animation as a whole when all matching elements have completed
their animations ( See the example for .promise() ).

Additional Notes:

All jQuery effects, including .slideUp() , can be turned off
globally by setting jQuery.fx.off = true , which effectively sets
the duration to 0. For more information, see jQuery.fx.off.
If .slideDown() is called on an unordered list ( <ul> ) and its <li>
elements have position (relative, absolute, or fixed), the effect
may not work properly in IE6 through at least IE9 unless the
<ul> has "layout." To remedy the problem, add the position:
relative; and zoom: 1; CSS declarations to the ul .

Examples:
Animates all divs to slide up, completing the
animation within 400 milliseconds.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
div { background:#3d9a44; margin:3px; width:80
height:40px; float:left; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
Click me!
<div></div>
<div></div>
<div></div>
<div></div>
<div></div>
<script>
$(document.body).click(function () {
if ($("div:first").is(":hidden")) {
$("div").show("slow");
} else {
$("div").slideUp();
}
});
</script>
</body>
</html>

Demo
Example:

Animates the parent paragraph to slide up,
completing the animation within 200 milliseconds.
Once the animation is done, it displays an alert.
1
2
3
4
5
6
7
8
9
10
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13
14
15
16
17
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20
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24
25
26
27
28
29

<!DOCTYPE html>
<html>
<head>
<style>
div { margin:2px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<button>Hide One</button>
<input type="text" value="One" />
</div>
<div>
<button>Hide Two</button>
<input type="text" value="Two" />
</div>
<div>
<button>Hide Three</button>
<input type="text" value="Three" />
</div>
<div id="msg"></div>
<script>
$("button").click(function () {
$(this).parent().slideUp("slow", function ()
$("#msg").text($("button", this).text() +
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});
});
</script>
</body>
</html>

Demo
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.stop()
Categories: Effects > Custom

.stop( [clearQueue ] [, jumpToEnd ] )

Returns: jQuery

Description: Stop the currently-running animation on
the matched elements.
.stop( [clearQueue ] [, jumpToEnd ] ) version added: 1.2
clearQueue
Type: Boolean
A Boolean indicating whether to remove queued animation as
well. Defaults to false .
jumpToEnd
Type: Boolean
A Boolean indicating whether to complete the current animation
immediately. Defaults to false .

.stop( [queue ] [, clearQueue ] [,
jumpToEnd ] )

version added: 1.7

queue
Type: String
The name of the queue in which to stop animations.
clearQueue
Type: Boolean
A Boolean indicating whether to remove queued animation as
well. Defaults to false .
jumpToEnd
Type: Boolean
A Boolean indicating whether to complete the current animation
immediately. Defaults to false .
When .stop() is called on an element, the currently-running
animation (if any) is immediately stopped. If, for instance, an
element is being hidden with .slideUp() when .stop() is called, the
element will now still be displayed, but will be a fraction of its
previous height. Callback functions are not called.

If more than one animation method is called on the same element,
the later animations are placed in the effects queue for the element.
These animations will not begin until the first one completes. When
.stop() is called, the next animation in the queue begins
immediately. If the clearQueue parameter is provided with a value of
true , then the rest of the animations in the queue are removed and
never run.
If the jumpToEnd argument is provided with a value of true , the
current animation stops, but the element is immediately given its
target values for each CSS property. In our above .slideUp()
example, the element would be immediately hidden. The callback
function is then immediately called, if provided.
As of jQuery 1.7, if the first argument is provided as a string, only
the animations in the queue represented by that string will be
stopped.
The usefulness of the .stop() method is evident when we need to
animate an element on mouseenter and mouseleave :
1
2
3
4

<div id="hoverme">
Hover me
<img id="hoverme" src="book.png" alt="" width=
</div>

We can create a nice fade effect without the common problem of
multiple queued animations by adding .stop(true, true) to the
chain:
1
2
3
4
5

$('#hoverme-stop-2').hover(function() {
$(this).find('img').stop(true, true).fadeOut();
}, function() {
$(this).find('img').stop(true, true).fadeIn();
});

Toggling Animations
As of jQuery 1.7, stopping a toggled animation prematurely with
.stop() will trigger jQuery's internal effects tracking. In previous
versions, calling the .stop() method before a toggled animation was
completed would cause the animation to lose track of its state (if
jumpToEnd was false). Any subsequent animations would start at a
new "half-way" state, sometimes resulting in the element
disappearing. To observe the new behavior, see the final example
below.

Animations may be stopped globally by
setting the property $.fx.off to true . When this
is done, all animation methods will
immediately set elements to their final state
when called, rather than displaying an
effect.

Examples:
Click the Go button once to start the
animation, then click the STOP button to stop it where
it's currently positioned. Another option is to click
several buttons to queue them up and see that stop
just kills the currently playing one.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27

<!DOCTYPE html>
<html>
<head>
<style>div {
position: absolute;
background-color: #abc;
left: 0px;
top:30px;
width: 60px;
height: 60px;
margin: 5px;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="go">Go</button>
<button id="stop">STOP!</button>
<button id="back">Back</button>
<div class="block"></div>
<script>
/* Start animation */
$("#go").click(function(){
$(".block").animate({left: '+=100px'}, 2000);
});
/* Stop animation when button is clicked */

28
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$("#stop").click(function(){
$(".block").stop();
});
/* Start animation in the opposite direction */
$("#back").click(function(){
$(".block").animate({left: '-=100px'}, 2000);
});
</script>
</body>
</html>

Demo
Example:

Click the slideToggle button to start the
animation, then click again before the animation is
completed. The animation will toggle the other
direction from the saved starting point.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

<!DOCTYPE html>
<html>
<head>
<style>.block {
background-color: #abc;
border: 2px solid black;
width: 200px;
height: 80px;
margin: 10px;
}
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="toggle">slideToggle</button>

16
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<div class="block"></div>
<script>
var $block = $('.block');
/* Toggle a sliding animation animation */
$('#toggle').on('click', function() {
$block.stop().slideToggle(1000);
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.submit()
Categories: Events > Form Events | Forms

.submit( handler(eventObject) )

Returns: jQuery

Description: Bind an event handler to the "submit"
JavaScript event, or trigger that event on an element.
.submit( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.submit( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: PlainObject
An object containing data that will be passed to the event
handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.

.submit()

version added: 1.0

This method does not accept any arguments.
This method is a shortcut for .on('submit', handler) in the first
variation, and .trigger('submit') in the third.
The submit event is sent to an element when the user is attempting
to submit a form. It can only be attached to <form> elements. Forms
can be submitted either by clicking an explicit <input type="submit"> ,
<input type="image"> , or <button type="submit"> , or by pressing
Enter when certain form elements have focus.

Depending on the browser, the Enter key

may only cause a form submission if the
form has exactly one text field, or only when
there is a submit button present. The
interface should not rely on a particular
behavior for this key unless the issue is
forced by observing the keypress event for
presses of the Enter key.
For example, consider the HTML:
1
2
3
4
5
6
7

<form id="target" action="destination.html">
<input type="text" value="Hello there" />
<input type="submit" value="Go" />
</form>
<div id="other">
Trigger the handler
</div>

The event handler can be bound to the form:
1
2
3
4

$('#target').submit(function() {
alert('Handler for .submit() called.');
return false;
});

Now when the form is submitted, the message is alerted. This
happens prior to the actual submission, so we can cancel the submit
action by calling .preventDefault() on the event object or by
returning false from our handler. We can trigger the event manually
when another element is clicked:

1
2
3

$('#other').click(function() {
$('#target').submit();
});

After this code executes, clicks on Trigger the handler will also
display the message. In addition, the default submit action on the
form will be fired, so the form will be submitted.
The JavaScript submit event does not bubble in Internet Explorer.
However, scripts that rely on event delegation with the submit event
will work consistently across browsers as of jQuery 1.4, which has
normalized the event's behavior.

Additional Notes:
Forms and their child elements should not use input names or
ids that conflict with properties of a form, such as submit ,
length , or method . Name conflicts can cause confusing failures.
For a complete list of rules and to check your markup for these
problems, see DOMLint.

Examples:
If you'd like to prevent forms from being
submitted unless a flag variable is set, try:
Example:

1
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<!DOCTYPE html>
<html>
<head>
<style>
p { margin:0; color:blue; }
div,p { margin-left:10px; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Type 'correct' to validate.</p>
<form action="javascript:alert('success!');">
<div>
<input type="text" />
<input type="submit" />
</div>
</form>
<span></span>
<script>
$("form").submit(function() {
if ($("input:first").val() == "correct") {
$("span").text("Validated...").show();
return true;
}
$("span").text("Not valid!").show().fadeOut(1000
return false;
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});
</script>
</body>
</html>

Demo
Example:

If you'd like to prevent forms from being
submitted unless a flag variable is set, try:
1
2
3

$("form").submit( function () {
return this.some_flag_variable;
} );

To trigger the submit event on the first form
on the page, try:
Example:

1

$("form:first").submit();

POWERED BYHERONOTE
A new version of this book is available!

:submit Selector
Categories: Selectors > Form | Selectors > jQuery Extensions

submit selector
Description: Selects all elements of type submit.
jQuery( ":submit" )

version added: 1.0

The :submit selector typically applies to button or input elements.
Note that some browsers treat <button> element as type="default"
implicitly while others (such as Internet Explorer) do not.

Additional Notes:
Because :submit is a jQuery extension and not part of the CSS
specification, queries using :submit cannot take advantage of
the performance boost provided by the native DOM
querySelectorAll() method. For better performance in modern
browsers, use [type="submit"] instead.

Example:
Finds all submit elements that are descendants of a td
element.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
textarea { height:45px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<table id="exampleTable" border="1" cellpadding
<tr>
<th>
Element Type
</th>
<th>
Element
</th>
</tr>
<tr>
<td>
<input type="button" value="Input Button"
</td>
</tr>
<tr>
<td>
<input type="checkbox" />
</td>
</tr>
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<tr>
<td>
<input
</td>
</tr>
<tr>
<td>
<input
</td>
</tr>
<tr>
<td>
<input
</td>
</tr>
<tr>
<td>
<input
</td>
</tr>
<tr>
<td>
<input
</td>

type="file" />

type="hidden" />

type="image" />

type="password" />

type="radio" />

</tr>
<tr>
<td>
<input type="reset" />
</td>
</tr>
<tr>
<td>
<input type="submit" />
</td>
</tr>
<tr>
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<td>
<input type="text" />
</td>
</tr>
<tr>
<td>
<select><option>Option</option></select>
</td>
</tr>
<tr>
<td>
<textarea></textarea>
</td>
</tr>
<tr>
<td>
<button>Button</button>
</td>
</tr>
<tr>
<td>
<button type="submit">Button type="submit"
</td>
</tr>
</table>
</form>
<div id="result"></div>
<script>
var submitEl = $("td :submit")
.parent('td')
.css({background:"yellow", border:"3px red solid"
.end();

$('#result').text('jQuery matched ' + submitEl.length +

105
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// so it won't submit
$("form").submit(function () { return false; });

// Extra JS to make the HTML easier to edit (None of th
$('#exampleTable').find('td').each(function(i, el) {
var inputEl = $(el).children(),
inputType = inputEl.attr('type') ? ' type="'
$(el).before('<td>' + inputEl[0].nodeName + inputTy
})
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

:target Selector
Categories: Selectors > Basic Filter

target selector
Description: Selects the target element indicated by the
fragment identifier of the document's URI.
jQuery( ":target" )

version added: 1.9

If the document's URI contains a fragment identifier, or hash, then
the :target selector will match the element with an ID that matches
the identifier. For example, given a document with a URI of
http://example.com/#foo, $( "p:target" ) will select the <p
id="foo"> element.
Further discussion of this usage can be found in the W3C CSS
specification.

POWERED BYHERONOTE
A new version of this book is available!

.text()
Categories: Manipulation > DOM Insertion, Inside

Get the combined text contents of each element in the set of matched
elements, including their descendants, or set the text contents of the
matched elements.
Contents:
.text()
.text()
.text( textString )
.text( textString )
.text( function(index, text) )

.text()

Returns: String

Description: Get the combined text contents of each
element in the set of matched elements, including their
descendants.
.text()

version added: 1.0

This method does not accept any arguments.
Unlike the .html() method, .text() can be used in both XML and
HTML documents. The result of the .text() method is a string
containing the combined text of all matched elements. (Due to
variations in the HTML parsers in different browsers, the text
returned may vary in newlines and other white space.) Consider the
following HTML:
1
2
3
4
5
6
7

<div class="demo-container">
<div class="demo-box">Demonstration Box</div
<ul>
<li>list item 1</li>
<li>list <strong>item</strong> 2</li>
</ul>
</div>

The code $('div.demo-container').text() would produce the
following result:
Demonstration Box list item 1 list item 2

The .text() method cannot be used on form inputs or scripts. To set
or get the text value of input or textarea elements, use the .val()
method. To get the value of a script element, use the .html()
method.
As of jQuery 1.4, the

.text()

method returns the value of text and

CDATA nodes as well as element nodes.

Example:
Find the text in the first paragraph (stripping out the
html), then set the html of the last paragraph to show it
is just text (the red bold is gone).
1
2
3
4
5
6
7
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Demo

<!DOCTYPE html>
<html>
<head>
<style>
p { color:blue; margin:8px; }
b { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p><b>Test</b> Paragraph.</p>
<p></p>
<script>
var str = $("p:first").text();
$("p:last").html(str);
</script>
</body>
</html>

.text( textString )

Returns: jQuery

Description: Set the content of each element in the set
of matched elements to the specified text.
.text( textString )

version added: 1.0

textString
Type: String
A string of text to set as the content of each matched element.

.text( function(index, text) )

version added: 1.4

function(index, text)
Type: Function()
A function returning the text content to set. Receives the index
position of the element in the set and the old text value as
arguments.
Unlike the .html() method,
HTML documents.

.text()

can be used in both XML and

We need to be aware that this method escapes the string provided
as necessary so that it will render correctly in HTML. To do so, it
calls the DOM method .createTextNode() , which replaces special
characters with their HTML entity equivalents (such as &lt; for < ).
Consider the following HTML:
1
2
3
4
5
6
7

<div class="demo-container">
<div class="demo-box">Demonstration Box</div>
<ul>
<li>list item 1</li>
<li>list <strong>item</strong> 2</li>
</ul>
</div>

The code $('div.demo-container').text('<p>This
will produce the following DOM output:
1
2
3

is a test.</p>');

<div class="demo-container">
&lt;p&gt;This is a test.&lt;/p&gt;
</div>

It will appear on a rendered page as though the tags were exposed,
like this:
1

<p>This is a test</p>

The .text() method cannot be used on input elements. For input
field text, use the .val() method.
As of jQuery 1.4, the .text() method allows us to set the text
content by passing in a function.
1
2
3

$('ul li').text(function(index) {
return 'item number ' + (index + 1);
});

Given an unordered list with three <li> elements, this example will
produce the following DOM output:
1
2
3
4
5

<ul>
<li>item number 1</li>
<li>item number 2</li>
<li>item number 3</li>
</ul>

Example:
Add text to the paragraph (notice the bold tag is
escaped).
1
2
3
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<!DOCTYPE html>
<html>
<head>
<style>
p { color:blue; margin:8px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Test Paragraph.</p>
<script>$("p").text("<b>Some</b> new text.");</
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

:text Selector
Categories: Selectors > Form | Selectors > jQuery Extensions

text selector
Description: Selects all elements of type text.
jQuery( ":text" )

version added: 1.0

allows us to select all <input type="text"> elements. As
with other pseudo-class selectors (those that begin with a ":") it is
recommended to precede it with a tag name or some other selector;
otherwise, the universal selector ("*") is implied. In other words, the
bare $(':text') is equivalent to $('*:text') , so $('input:text')
should be used instead.
$(':text')

Note: As of jQuery 1.5.2, :text selects input elements that have no
specified type attribute (in which case type="text" is implied).
This difference in behavior between $(':text') and
$('[type=text]') , can be seen below:
1
2

$('<input>').is('[type=text]'); // false
$('<input>').is(':text'); // true

Additional Notes:
Because :text is a jQuery extension and not part of the CSS
specification, queries using :text cannot take advantage of the
performance boost provided by the native DOM
querySelectorAll() method. For better performance in modern
browsers, use [type="text"] instead.

Example:
Finds all text inputs.
1
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<!DOCTYPE html>
<html>
<head>
<style>
textarea { height:25px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<form>
<input type="button" value="Input Button"/>
<input type="checkbox" />
<input type="file" />
<input type="hidden" />
<input type="image" />
<input type="password" />
<input type="radio" />
<input type="reset" />
<input type="submit" />
<input type="text" />
<select><option>Option</option></select>
<textarea></textarea>
<button>Button</button>
</form>
<div>
</div>
<script>
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var input = $("form input:text").css({background:
$("div").text("For this type jQuery found " + input.leng
.css("color", "red");
$("form").submit(function () { return false; });
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
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.toArray()
Categories: Miscellaneous > DOM Element Methods

.toArray()

Returns: Array

Description: Retrieve all the DOM elements contained
in the jQuery set, as an array.
.toArray()

version added: 1.4

This method does not accept any arguments.
.toArray()

1

returns all of the elements in the jQuery set:

alert($('li').toArray());

All of the matched DOM nodes are returned by this call, contained in
a standard array:
[<li id="foo">, <li id="bar">]

Example:
Selects all divs in the document and returns the DOM
Elements as an Array, then uses the built-in reversemethod to reverse that array.
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<!DOCTYPE html>
<html>
<head>
<style>
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
Reversed - <span></span>
<div>One</div>
<div>Two</div>
<div>Three</div>
<script>
function disp(divs) {
var a = [];
for (var i = 0; i < divs.length; i++) {
a.push(divs[i].innerHTML);
}
$("span").text(a.join(" "));
}
disp( $("div").toArray().reverse() );
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
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.toggle()
Categories: Effects > Basics

.toggle( [duration ] [, complete ] )

Returns: jQuery

Description: Display or hide the matched elements.
.toggle( [duration ] [, complete ] )

version added: 1.0

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
complete
Type: Function()
A function to call once the animation is complete.

.toggle( options )

version added: 1.0

options
Type: PlainObject
A map of additional options to pass to the method.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will
run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
queue (default: true )
Type: Boolean
A Boolean indicating whether to place the animation in the
effects queue. If false, the animation will begin immediately.
As of jQuery 1.7, the queue option can also accept a
string, in which case the animation is added to the queue
represented by that string.
specialEasing
Type: PlainObject
A map of one or more of the CSS properties defined by the

properties argument and their corresponding easing
functions. (version added: 1.4)
step
Type: Function( Number now, Tween tween )
A function to be called for each animated property of each
animated element. This function provides an opportunity to
modify the Tween object to change the value of the
property before it is set.
progress
Type: Function( Promise animation, Number progress,
Number remainingMs )
A function to be called after each step of the animation,
only once per animated element regardless of the number
of animated properties. (version added: 1.8)
complete
Type: Function()
A function to call once the animation is complete.
done
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes (its
Promise object is resolved). (version added: 1.8)
fail
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation fails to complete
(its Promise object is rejected). (version added: 1.8)
always
Type: Function( Promise animation, Boolean jumpedToEnd
)
A function to be called when the animation completes or
stops without completing (its Promise object is either
resolved or rejected). (version added: 1.8)

.toggle( [duration ] [, easing ] [,
complete ] )

version added: 1.4.3

duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.

.toggle( showOrHide )

version added: 1.3

showOrHide
Type: Boolean
A Boolean indicating whether to show or hide the elements.

Note: The event handling suite also has a
method named .toggle(). Which one is fired
depends on the set of arguments passed.
With no parameters, the
visibility of elements:
1

.toggle()

method simply toggles the

$('.target').toggle();

The matched elements will be revealed or hidden immediately, with
no animation, by changing the CSS display property. If the element
is initially displayed, it will be hidden; if hidden, it will be shown. The
display property is saved and restored as needed. If an element has
a display value of inline , then is hidden and shown, it will once
again be displayed inline .
When a duration, a plain object, or a single "complete" function is

provided, .toggle() becomes an animation method. The .toggle()
method animates the width, height, and opacity of the matched
elements simultaneously. When these properties reach 0 after a
hiding animation, the display style property is set to none to ensure
that the element no longer affects the layout of the page.
Durations are given in milliseconds; higher values indicate slower
animations, not faster ones. The strings 'fast' and 'slow' can be
supplied to indicate durations of 200 and 600 milliseconds,
respectively.
As of jQuery 1.4.3, an optional string naming an easing function may
be used. Easing functions specify the speed at which the animation
progresses at different points within the animation. The only easing
implementations in the jQuery library are the default, called swing ,
and one that progresses at a constant pace, called linear . More
easing functions are available with the use of plug-ins, most notably
the jQuery UI suite.
If supplied, the callback is fired once the animation is complete. This
can be useful for stringing different animations together in sequence.
The callback is not sent any arguments, but this is set to the DOM
element being animated. If multiple elements are animated, it is
important to note that the callback is executed once per matched
element, not once for the animation as a whole.
We can animate any element, such as a simple image:
1
2
3
4

<div id="clickme">
Click here
</div>
<img id="book" src="book.png" alt="" width="100"

We will cause
clicked:
1
2

.toggle()

to be called when another element is

$('#clickme').click(function() {
$('#book').toggle('slow', function() {

3
4
5

// Animation complete.
});
});

With the element initially shown, we can hide it slowly with the first
click:

A second click will show the element once again:

The second version of the method accepts a Boolean parameter. If
this parameter is true , then the matched elements are shown; if
false , the elements are hidden. In essence, the statement:
1

$('#foo').toggle(showOrHide);

is equivalent to:
1
2
3
4
5

if ( showOrHide == true ) {
$('#foo').show();
} else if ( showOrHide == false ) {
$('#foo').hide();
}

Additional Notes:
All jQuery effects, including .toggle() , can be turned off globally
by setting jQuery.fx.off = true , which effectively sets the
duration to 0. For more information, see jQuery.fx.off.

Examples:
Example:
1
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Toggles all paragraphs.

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Toggle</button>
<p>Hello</p>
<p style="display: none">Good Bye</p>
<script>
$("button").click(function () {
$("p").toggle();
});
</script>
</body>
</html>

Demo
Example:

Animates all paragraphs to be shown if they
are hidden and hidden if they are visible, completing
the animation within 600 milliseconds.
1
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<!DOCTYPE html>
<html>
<head>
<style>
p { background:#dad;
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font-weight:bold;
font-size:16px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Toggle 'em</button>
<p>Hiya</p>
<p>Such interesting text, eh?</p>
<script>
$("button").click(function () {
$("p").toggle("slow");
});
</script>
</body>
</html>

Demo
Example:

Shows all paragraphs, then hides them all,
back and forth.
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Toggle</button>
<p>Hello</p>
<p style="display: none">Good Bye</p>
<script>
var flip = 0;
$("button").click(function () {
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$("p").toggle( flip++ % 2 == 0 );
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.toggle()
Categories: Deprecated > Deprecated 1.8 | Events > Mouse Events

.toggle( handler(eventObject), handler(eventObject) [,
handler(eventObject) ] )
Returns: jQuery
version deprecated: 1.8, removed: 1.9

Description: Bind two or more handlers to the matched
elements, to be executed on alternate clicks.
version added: 1.0
.toggle( handler(eventObject),
handler(eventObject) [, handler(eventObject) ] )
handler(eventObject)
Type: Function()
A function to execute every even time the element is clicked.
handler(eventObject)
Type: Function()
A function to execute every odd time the element is clicked.
handler(eventObject)
Type: Function()
Additional handlers to cycle through after clicks.

Note: jQuery also provides an animation
method named .toggle() that toggles the
visibility of elements. Whether the animation
or the event method is fired depends on the
set of arguments passed.
The .toggle() method binds a handler for the click event, so the
rules outlined for the triggering of click apply here as well.
1
2

For example, consider the HTML:
<div id="target">

3
4

Click here
</div>

Event handlers can then be bound to the
1
2
3
4
5

<div> :

$('#target').toggle(function() {
alert('First handler for .toggle() called.');
}, function() {
alert('Second handler for .toggle() called.');
});

As the element is clicked repeatedly, the messages alternate:
First handler for .toggle() called. Second handler for .toggle() called.
First handler for .toggle() called.
Second handler for .toggle() called.
First handler for .toggle() called.
If more than two handlers are provided, .toggle() will cycle among
all of them. For example, if there are three handlers, then the first
handler will be called on the first click, the fourth click, the seventh
click, and so on.
The .toggle() method is provided for convenience. It is relatively
straightforward to implement the same behavior by hand, and this
can be necessary if the assumptions built into .toggle() prove
limiting. For example, .toggle() is not guaranteed to work correctly
if applied twice to the same element. Since .toggle() internally uses
a click handler to do its work, we must unbind click to remove a
behavior attached with .toggle() , so other click handlers can be
caught in the crossfire. The implementation also calls
.preventDefault() on the event, so links will not be followed and
buttons will not be clicked if .toggle() has been called on the
element.

Example:
Toggle a style on table cells. (Not recommended. Use
.toggleClass() instead.):
1
2
3
4
5
6
7
8

$("td").toggle(
function () {
$(this).addClass("selected");
},
function () {
$(this).removeClass("selected");
}
);

POWERED BYHERONOTE
A new version of this book is available!

.toggleClass()
Categories: Attributes | Manipulation > Class Attribute | CSS

.toggleClass( className )

Returns: jQuery

Description: Add or remove one or more classes from
each element in the set of matched elements, depending
on either the class's presence or the value of the switch
argument.
.toggleClass( className )

version added: 1.0

className
Type: String
One or more class names (separated by spaces) to be toggled
for each element in the matched set.

.toggleClass( className, switch )

version added: 1.3

className
Type: String
One or more class names (separated by spaces) to be toggled
for each element in the matched set.
switch
Type: Boolean
A Boolean (not just truthy/falsy) value to determine whether the
class should be added or removed.

.toggleClass( [switch ] )

version added: 1.4

switch
Type: Boolean
A boolean value to determine whether the class should be
added or removed.

.toggleClass( function(index, class,
switch) [, switch ] )

version added: 1.4

function(index, class, switch)
Type: Function()
A function that returns class names to be toggled in the class
attribute of each element in the matched set. Receives the

index position of the element in the set, the old class value, and
the switch as arguments.
switch
Type: Boolean
A boolean value to determine whether the class should be
added or removed.
This method takes one or more class names as its parameter. In the
first version, if an element in the matched set of elements already
has the class, then it is removed; if an element does not have the
class, then it is added. For example, we can apply .toggleClass() to
a simple <div> :
1

<div class="tumble">Some text.</div>

The first time we apply
get the following:
1

$('div.tumble').toggleClass('bounce') ,

we

<div class="tumble bounce">Some text.</div>

The second time we apply $('div.tumble').toggleClass('bounce') ,
the <div> class is returned to the single tumble value:
1

<div class="tumble">Some text.</div>

Applying
between

.toggleClass('bounce spin') to the same <div>
<div class="tumble bounce spin"> and <div
class="tumble"> .

alternates

The second version of .toggleClass() uses the second parameter
for determining whether the class should be added or removed. If
this parameter's value is true , then the class is added; if false , the
class is removed. In essence, the statement:

1

$('#foo').toggleClass(className, addOrRemove);

is equivalent to:
1
2
3
4
5
6

if (addOrRemove) {
$('#foo').addClass(className);
}
else {
$('#foo').removeClass(className);
}

As of jQuery 1.4, if no arguments are passed to .toggleClass() , all
class names on the element the first time .toggleClass() is called
will be toggled. Also as of jQuery 1.4, the class name to be toggled
can be determined by passing in a function.
1
2
3
4
5
6
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$('div.foo').toggleClass(function() {
if ($(this).parent().is('.bar')) {
return 'happy';
} else {
return 'sad';
}
});

This example will toggle the happy class for <div class="foo">
elements if their parent element has a class of bar ; otherwise, it will
toggle the sad class.

Examples:
Toggle the class 'highlight' when a paragraph
is clicked.
Example:

1
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<!DOCTYPE html>
<html>
<head>
<style>
p { margin: 4px; font-size:16px; font-weight:
cursor:pointer; }
.blue { color:blue; }
.highlight { background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p class="blue">Click to toggle</p>
<p class="blue highlight">highlight</p>
<p class="blue">on these</p>
<p class="blue">paragraphs</p>
<script>
$("p").click(function () {
$(this).toggleClass("highlight");
});
</script>
</body>
</html>

Demo
Example:

Add the "highlight" class to the clicked

paragraph on every third click of that paragraph,
remove it every first and second click.
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<!DOCTYPE html>
<html>
<head>
<style>
p { margin: 4px; font-size:16px; font-weight:
cursor:pointer; }
.blue { color:blue; }
.highlight { background:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p class="blue">Click to toggle (<span>clicks: 0
<p class="blue highlight">highlight (<span>clicks: 0
<p class="blue">on these (<span>clicks: 0</span
<p class="blue">paragraphs (<span>clicks: 0</
<script>
var count = 0;
$("p").each(function() {
var $thisParagraph = $(this);
var count = 0;
$thisParagraph.click(function() {
count++;
$thisParagraph.find("span").text('clicks: '
$thisParagraph.toggleClass("highlight", count %
});
});
</script>
</body>
</html>

Demo
Example:

Toggle the class name(s) indicated on the
buttons for each div.
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<!DOCTYPE html>
<html>
<head>
<style>
.wrap > div { float: left; width: 100px; margin: 1em 1em
padding=left: 3px; border: 1px solid #abc;
div.a { background-color: aqua; }
div.b { background-color: burlywood; }
div.c { background-color: cornsilk; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div class="buttons">
<button>toggle</button>
<button class="a">toggle a</button>
<button class="a b">toggle a b</button>
<button class="a b c">toggle a b c</button>
<a href="#">reset</a>
</div>
<div class="wrap">
<div></div>
<div class="b"></div>
<div class="a b"></div>
<div class="a c"></div>
</div>
<script>
var cls = ['', 'a', 'a b', 'a b c'];
var divs = $('div.wrap').children();
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var appendClass = function() {
divs.append(function() {
return '<div>' + (this.className || 'none') +
});
};
appendClass();
$('button').on('click', function() {
var tc = this.className || undefined;
divs.toggleClass(tc);
appendClass();
});
$('a').on('click', function(event) {
event.preventDefault();
divs.empty().each(function(i) {
this.className = cls[i];
});
appendClass();
});
</script>
</body>
</html>

Demo
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.trigger()
Categories: Events > Event Handler Attachment

.trigger( eventType [, extraParameters ] )

Returns: jQuery

Description: Execute all handlers and behaviors
attached to the matched elements for the given event
type.
.trigger( eventType [,
extraParameters ] )

version added: 1.0

eventType
Type: String
A string containing a JavaScript event type, such as
submit .

click

or

extraParameters
Type: Array or PlainObject
Additional parameters to pass along to the event handler.

.trigger( event )

version added: 1.3

event
Type: Event
A jQuery.Event object.
Any event handlers attached with .on() or one of its shortcut
methods are triggered when the corresponding event occurs. They
can be fired manually, however, with the .trigger() method. A call
to .trigger() executes the handlers in the same order they would
be if the event were triggered naturally by the user:
1
2
3
4

$('#foo').on('click', function() {
alert($(this).text());
});
$('#foo').trigger('click');

As of jQuery 1.3, .trigger() ed events bubble up the DOM tree; an
event handler can stop the bubbling by returning false from the

handler or calling the .stopPropagation() method on the event object
passed into the event. Although .trigger() simulates an event
activation, complete with a synthesized event object, it does not
perfectly replicate a naturally-occurring event.
To trigger handlers bound via jQuery without also triggering the
native event, use .triggerHandler() instead.
When we define a custom event type using the .on() method, the
second argument to .trigger() can become useful. For example,
suppose we have bound a handler for the custom event to our
element instead of the built-in click event as we did above:
1
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4

$('#foo').on('custom', function(event, param1, param2) {
alert(param1 + "\n" + param2);
});
$('#foo').trigger('custom', ['Custom', 'Event']);

The event object is always passed as the first parameter to an event
handler, but if additional parameters are specified during a
.trigger() call, these parameters will be passed along to the
handler as well. To pass more than one parameter, use an array as
shown here. As of jQuery 1.6.2, a single parameter can be passed
without using an array.
Note the difference between the extra parameters we're passing
here and the eventData parameter to the .on() method. Both are
mechanisms for passing information to an event handler, but the
extraParameters argument to .trigger() allows information to be
determined at the time the event is triggered, while the eventData
argument to .on() requires the information to be already computed
at the time the handler is bound.
The .trigger() method can be used on jQuery collections that wrap
plain JavaScript objects similar to a pub/sub mechanism; any event
handlers bound to the object will be called when the event is
triggered.
Note: For both plain objects and DOM objects, if a triggered event

name matches the name of a property on the object, jQuery will
attempt to invoke the property as a method if no event handler calls
event.preventDefault() . If this behavior is not desired, use
.triggerHandler() instead.

Examples:
Clicks to button #2 also trigger a click for
button #1.
Example:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!DOCTYPE html>
<html>
<head>
<style>
button { margin:10px; }
div { color:blue; font-weight:bold; }
span { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Button #1</button>
<button>Button #2</button>
<div><span>0</span> button #1 clicks.</div>
<div><span>0</span> button #2 clicks.</div>
<script>
$("button:first").click(function () {
update($("span:first"));
});
$("button:last").click(function () {
$("button:first").trigger('click');
update($("span:last"));
});
function update(j) {
var n = parseInt(j.text(), 10);
j.text(n + 1);
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}
</script>
</body>
</html>

Demo
Example:

To submit the first form without using the
submit() function, try:
1

$("form:first").trigger("submit")

To submit the first form without using the
submit() function, try:
Example:

1
2
3
4
5

var event = jQuery.Event("submit");
$("form:first").trigger(event);
if ( event.isDefaultPrevented() ) {
// Perform an action...
}

Example:
1
2
3
4
5

To pass arbitrary data to an event:

$("p").click( function (event, a, b) {
// when a normal click fires, a and b are undefined
// for a trigger like below a refers to "foo" and b refer
} ).trigger("click", ["foo", "bar"]);

Example:

object:

To pass arbitrary data through an event

1
2
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4

var event = jQuery.Event("logged");
event.user = "foo";
event.pass = "bar";
$("body").trigger(event);

Alternative way to pass data through an
event object:
Example:

1
2
3
4
5
6

$("body").trigger({
type:"logged",
user:"foo",
pass:"bar"
});
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.triggerHandler()
Categories: Events > Event Handler Attachment

.triggerHandler( eventType [, extraParameters ] )
Returns: Object
Description: Execute all handlers attached to an
element for an event.
.triggerHandler( eventType [,
extraParameters ] )

version added: 1.2

eventType
Type: String
A string containing a JavaScript event type, such as
submit .

click

or

extraParameters
Type: Array
An array of additional parameters to pass along to the event
handler.
The .triggerHandler() method behaves similarly to
the following exceptions:

.trigger() ,

with

The .triggerHandler() method does not cause the default
behavior of an event to occur (such as a form submission).
While .trigger() will operate on all elements matched by the
jQuery object, .triggerHandler() only affects the first matched
element.
Events created with .triggerHandler() do not bubble up the
DOM hierarchy; if they are not handled by the target element
directly, they do nothing.
Instead of returning the jQuery object (to allow chaining),
.triggerHandler() returns whatever value was returned by the
last handler it caused to be executed. If no handlers are
triggered, it returns undefined
For more information on this method, see the discussion for
.trigger() .

Example:
If you called .triggerHandler() on a focus event - the
browser's default focus action would not be triggered,
only the event handlers bound to the focus event.
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Demo

<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="old">.trigger("focus")</button>
<button id="new">.triggerHandler("focus")</button
<input type="text" value="To Be Focused"/>
<script>
$("#old").click(function(){
$("input").trigger("focus");
});
$("#new").click(function(){
$("input").triggerHandler("focus");
});
$("input").focus(function(){
$("<span>Focused!</span>").appendTo("body").fadeOut(
});
</script>
</body>
</html>

POWERED BYHERONOTE
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.unbind()
Categories: Events > Event Handler Attachment

.unbind( [eventType ] [, handler(eventObject) ] )
Returns: jQuery
Description: Remove a previously-attached event
handler from the elements.
.unbind( [eventType ] [,
handler(eventObject) ] )

version added: 1.0

eventType
Type: String
A string containing a JavaScript event type, such as
submit .

click

or

handler(eventObject)
Type: Function()
The function that is to be no longer executed.

.unbind( eventType, false )

version added: 1.4.3

eventType
Type: String
A string containing a JavaScript event type, such as
submit .

click

or

false
Type: Boolean
Unbinds the corresponding 'return false' function that was
bound using .bind( eventType, false ) .

.unbind( event )

version added: 1.0

event
Type: Object
A JavaScript event object as passed to an event handler.
Event handlers attached with .bind() can be removed with
.unbind() . (As of jQuery 1.7, the .on() and .off() methods are
preferred to attach and remove event handlers on elements.) In the

simplest case, with no arguments,
attached to the elements:
1

.unbind()

removes all handlers

$('#foo').unbind();

This version removes the handlers regardless of type. To be more
precise, we can pass an event type:
1

$('#foo').unbind('click');

By specifying the click event type, only handlers for that event type
will be unbound. This approach can still have negative ramifications
if other scripts might be attaching behaviors to the same element,
however. Robust and extensible applications typically demand the
two-argument version for this reason:
1
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var handler = function() {
alert('The quick brown fox jumps over the lazy dog.'
};
$('#foo').bind('click', handler);
$('#foo').unbind('click', handler);

By naming the handler, we can be assured that no other functions
are accidentally removed. Note that the following will not work:
1
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$('#foo').bind('click', function() {
alert('The quick brown fox jumps over the lazy dog.'
});
// will NOT work
$('#foo').unbind('click', function() {
alert('The quick brown fox jumps over the lazy dog.'
});

Even though the two functions are identical in content, they are
created separately and so JavaScript is free to keep them as distinct
function objects. To unbind a particular handler, we need a reference
to that function and not a different one that happens to do the same
thing.

Note: Using a proxied function to unbind an
event on an element will unbind all proxied
functions on that element, as the same
proxy function is used for all proxied events.
To allow unbinding a specific event, use
unique class names on the event (e.g.
click.proxy1 , click.proxy2 ) when attaching them.
Using Namespaces
Instead of maintaining references to handlers in order to unbind
them, we can namespace the events and use this capability to
narrow the scope of our unbinding actions. As shown in the
discussion for the .bind() method, namespaces are defined by
using a period ( . ) character when binding a handler:
1

$('#foo').bind('click.myEvents', handler);

When a handler is bound in this fashion, we can still unbind it the
normal way:
1

$('#foo').unbind('click');

However, if we want to avoid affecting other handlers, we can be
more specific:
1

$('#foo').unbind('click.myEvents');

We can also unbind all of the handlers in a namespace, regardless
of event type:
1

$('#foo').unbind('.myEvents');

It is particularly useful to attach namespaces to event bindings when
we are developing plug-ins or otherwise writing code that may
interact with other event-handling code in the future.
Using the Event Object
The third form of the .unbind() method is used when we wish to
unbind a handler from within itself. For example, suppose we wish to
trigger an event handler only three times:
1
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var timesClicked = 0;
$('#foo').bind('click', function(event) {
alert('The quick brown fox jumps over the lazy dog.'
timesClicked++;
if (timesClicked >= 3) {
$(this).unbind(event);
}
});

The handler in this case must take a parameter, so that we can
capture the event object and use it to unbind the handler after the
third click. The event object contains the context necessary for
.unbind() to know which handler to remove. This example is also an
illustration of a closure. Since the handler refers to the timesClicked

variable, which is defined outside the function, incrementing the
variable has an effect even between invocations of the handler.

Examples:
Example:

Can bind and unbind events to the colored

button.
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<!DOCTYPE html>
<html>
<head>
<style>
button { margin:5px; }
button#theone { color:red; background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="theone">Does nothing...</button>
<button id="bind">Bind Click</button>
<button id="unbind">Unbind Click</button>

<div style="display:none;">Click!</div>
<script>
function aClick() {
$("div").show().fadeOut("slow");
}
$("#bind").click(function () {
// could use .bind('click', aClick) instead but for vari
$("#theone").click(aClick)
.text("Can Click!");
});
$("#unbind").click(function () {
$("#theone").unbind('click', aClick)
.text("Does nothing...");
});
</script>
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</body>
</html>

Demo
Example:

To unbind all events from all paragraphs,

write:
1

$("p").unbind()

To unbind all click events from all
paragraphs, write:
Example:

1

$("p").unbind( "click" )

To unbind just one previously bound handler,
pass the function in as the second argument:
Example:

1
2
3
4
5
6
7

var foo = function () {
// code to handle some kind of event
};
$("p").bind("click", foo); // ... now foo will be called

$("p").unbind("click", foo); // ... foo will no longer be
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.undelegate()
Categories: Events > Event Handler Attachment

.undelegate()

Returns: jQuery

Description: Remove a handler from the event for all
elements which match the current selector, based upon
a specific set of root elements.
.undelegate()

version added: 1.4.2

This method does not accept any arguments.

.undelegate( selector, eventType )

version added: 1.4.2

selector
Type: String
A selector which will be used to filter the event results.
eventType
Type: String
A string containing a JavaScript event type, such as "click" or
"keydown"

.undelegate( selector, eventType,
handler(eventObject) )

version added: 1.4.2

selector
Type: String
A selector which will be used to filter the event results.
eventType
Type: String
A string containing a JavaScript event type, such as "click" or
"keydown"
handler(eventObject)
Type: Function()
A function to execute at the time the event is triggered.

.undelegate( selector, events )
selector

version added: 1.4.3

Type: String
A selector which will be used to filter the event results.
events
Type: PlainObject
An object of one or more event types and previously bound
functions to unbind from them.

.undelegate( namespace )

version added: 1.6

namespace
Type: String
A string containing a namespace to unbind all events from.
The .undelegate() method is a way of removing event handlers that
have been bound using .delegate() . As of jQuery 1.7, the .on()
and .off() methods are preferred for attaching and removing event
handlers.

Examples:
Example:

Can bind and unbind events to the colored

button.
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<!DOCTYPE html>
<html>
<head>
<style>
button { margin:5px; }
button#theone { color:red; background:yellow; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="theone">Does nothing...</button>
<button id="bind">Bind Click</button>
<button id="unbind">Unbind Click</button>
<div style="display:none;">Click!</div>
<script>
function aClick() {
$("div").show().fadeOut("slow");
}
$("#bind").click(function () {
$("body").delegate("#theone", "click", aClick)
.find("#theone").text("Can Click!");
});
$("#unbind").click(function () {
$("body").undelegate("#theone", "click", aClick)
.find("#theone").text("Does nothing...");
});
</script>
</body>
</html>

Demo
Example:

To unbind all delegated events from all
paragraphs, write:
1

$("p").undelegate()

To unbind all delegated click events from all
paragraphs, write:
Example:

1

$("p").undelegate( "click" )

To undelegate just one previously bound
handler, pass the function in as the third argument:
Example:

1
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var foo = function () {
// code to handle some kind of event
};

// ... now foo will be called when paragraphs are clicke
$("body").delegate("p", "click", foo);

// ... foo will no longer be called.
$("body").undelegate("p", "click", foo);

To unbind all delegated events by their
namespace:
Example:

1
2

var foo = function () {
// code to handle some kind of event
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};
// delegate events under the ".whatever" namespace
$("form").delegate(":button", "click.whatever", foo);

$("form").delegate("input[type='text']", "keypress.whate

// unbind all events delegated under the ".whatever" nam
$("form").undelegate(".whatever");
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.unload()
Categories: Events > Document Loading

.unload( handler(eventObject) )

Returns: jQuery
version deprecated: 1.8

Description: Bind an event handler to the "unload"
JavaScript event.
.unload( handler(eventObject) )

version added: 1.0

handler(eventObject)
Type: Function()
A function to execute when the event is triggered.

.unload( [eventData ],
handler(eventObject) )

version added: 1.4.3

eventData
Type: Object
A plain object of data that will be passed to the event handler.
handler(eventObject)
Type: Function()
A function to execute each time the event is triggered.
This method is a shortcut for

.on('unload', handler) .

The unload event is sent to the window element when the user
navigates away from the page. This could mean one of many things.
The user could have clicked on a link to leave the page, or typed in a
new URL in the address bar. The forward and back buttons will
trigger the event. Closing the browser window will cause the event to
be triggered. Even a page reload will first create an unload event.

The exact handling of the unload event has
varied from version to version of browsers.
For example, some versions of Firefox
trigger the event when a link is followed, but

not when the window is closed. In practical
usage, behavior should be tested on all
supported browsers, and contrasted with
the proprietary beforeunload event.
Any
1
2
3

unload

event handler should be bound to the

window

object:

$(window).unload(function() {
alert('Handler for .unload() called.');
});

After this code executes, the alert will be displayed whenever the
browser leaves the current page. It is not possible to cancel the
unload event with .preventDefault() . This event is available so that
scripts can perform cleanup when the user leaves the page.

Example:
To display an alert when a page is unloaded:
1

$(window).unload( function () { alert("Bye now!"
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.unwrap()
Categories: Manipulation > DOM Insertion, Around | Manipulation > DOM Removal

.unwrap()

Returns: jQuery

Description: Remove the parents of the set of matched
elements from the DOM, leaving the matched elements
in their place.
.unwrap()

version added: 1.4

This method does not accept any arguments.
The .unwrap() method removes the element's parent. This is
effectively the inverse of the .wrap() method. The matched
elements (and their siblings, if any) replace their parents within the
DOM structure.

Example:
Wrap/unwrap a div around each of the paragraphs.
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Demo

<!DOCTYPE html>
<html>
<head>
<style>
div { border: 2px solid blue; }
p { background:yellow; margin:4px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>wrap/unwrap</button>
<p>Hello</p>
<p>cruel</p>
<p>World</p>
<script>
var pTags = $("p");
$("button").click( function(){
if ( pTags.parent().is("div") ) {
pTags.unwrap();
} else {
pTags.wrap("<div></div>");
}
});</script>
</body>
</html>
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.val()
Categories: Attributes | Forms | Manipulation > General Attributes

Get the current value of the first element in the set of matched
elements or set the value of every matched element.
Contents:
.val()
.val()
.val( value )
.val( value )
.val( function(index, value) )

.val()

Returns: String, Number, Array

Description: Get the current value of the first element in
the set of matched elements.
.val()

version added: 1.0

This method does not accept any arguments.
The .val() method is primarily used to get the values of form
elements such as input , select and textarea . In the case of
<select multiple="multiple"> elements, the .val() method returns
an array containing each selected option; if no option is selected, it
returns null .
For selects and checkboxes, you can also use the :selected and
:checked selectors to get at values, for example:
1
2
3
4

$('select.foo option:selected').val();
$('select.foo').val();
$('input:checkbox:checked').val();
$('input:radio[name=bar]:checked').val();

//
//
//
//

Note: At present, using .val() on textarea
elements strips carriage return characters
from the browser-reported value. When this
value is sent to the server via XHR
however, carriage returns are preserved (or
added by browsers which do not include
them in the raw value). A workaround for
this issue can be achieved using a valHook

get
get
get
get

the
the
the
the

val
val
val
val

as follows:
1
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$.valHooks.textarea = {
get: function( elem ) {
return elem.value.replace( /\r?\n/g, "\r\n" );
}
};

Examples:
Get the single value from a single select and
an array of values from a multiple select and display
their values.
Example:
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<!DOCTYPE html>
<html>
<head>
<style>
p { color:red; margin:4px; }
b { color:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p></p>
<select id="single">
<option>Single</option>
<option>Single2</option>
</select>
<select id="multiple" multiple="multiple">
<option selected="selected">Multiple</option
<option>Multiple2</option>
<option selected="selected">Multiple3</option
</select>
<script>
function displayVals() {
var singleValues = $("#single").val();
var multipleValues = $("#multiple").val() || [];
$("p").html("<b>Single:</b> " +
singleValues +
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" <b>Multiple:</b> " +
multipleValues.join(", "));
}
$("select").change(displayVals);
displayVals();
</script>
</body>
</html>

Demo
Example:
1
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Find the value of an input box.

<!DOCTYPE html>
<html>
<head>
<style>
p { color:blue; margin:8px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<input type="text" value="some text"/>
<p></p>
<script>
$("input").keyup(function () {
var value = $(this).val();
$("p").text(value);
}).keyup();
</script>
</body>
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</html>

.val( value )

Returns: jQuery

Description: Set the value of each element in the set of
matched elements.
.val( value )

version added: 1.0

value
Type: String or Array
A string of text or an array of strings corresponding to the value
of each matched element to set as selected/checked.

.val( function(index, value) )

version added: 1.4

function(index, value)
Type: Function()
A function returning the value to set. this is the current
element. Receives the index position of the element in the set
and the old value as arguments.
This method is typically used to set the values of form fields.
Passing an array of element values allows matching <input
type="checkbox"> , <input type="radio"> and <option> s inside of n
<select multiple="multiple"> to be selected. In the case of <input
type="radio"> s that are part of a radio group and <select
multiple="multiple"> the other elements will be deselected.
The .val() method allows us to set the value by passing in a
function. As of jQuery 1.4, the function is passed two arguments, the
current element's index and its current value:
1
2
3

$('input:text.items').val(function( index, value ) {
return value + ' ' + this.className;
});

This example appends the string " items" to the text inputs' values.

Examples:
Example:
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Set the value of an input box.

<!DOCTYPE html>
<html>
<head>
<style>
button { margin:4px; cursor:pointer; }
input { margin:4px; color:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>
<button>Feed</button>
<button>the</button>
<button>Input</button>
</div>
<input type="text" value="click a button" />
<script>
$("button").click(function () {
var text = $(this).text();
$("input").val(text);
});
</script>
</body>
</html>

Demo
Example:

Use the function argument to modify the
value of an input box.
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<!DOCTYPE html>
<html>
<head>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>

<p>Type something and then click or tab out of the inp
<input type="text" value="type something" />
<script>
$('input').on('blur', function() {
$(this).val(function( i, val ) {
return val.toUpperCase();
});
});
</script>
</body>
</html>

Demo
Example:

Set a single select, a multiple select,
checkboxes and a radio button .
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<!DOCTYPE html>
<html>
<head>
<style>
body { color:blue; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
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<select id="single">
<option>Single</option>
<option>Single2</option>
</select>
<select id="multiple" multiple="multiple">
<option selected="selected">Multiple</option
<option>Multiple2</option>
<option selected="selected">Multiple3</option
</select><br/>
<input type="checkbox" name="checkboxname" value
<input type="checkbox" name="checkboxname" value
<input type="radio" name="r" value="radio1"/>
<input type="radio" name="r" value="radio2"/>
<script>
$("#single").val("Single2");
$("#multiple").val(["Multiple2", "Multiple3"
$("input").val(["check1","check2", "radio1"
</script>
</body>
</html>

Demo
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:visible Selector
Categories: Selectors > jQuery Extensions | Selectors > Visibility Filter

visible selector
Description: Selects all elements that are visible.
jQuery( ":visible" )

version added: 1.0

Elements are considered visible if they consume space in the
document. Visible elements have a width or height that is greater
than zero.
Elements with visibility: hidden or opacity: 0 are considered
visible, since they still consume space in the layout. During
animations that hide an element, the element is considered to be
visible until the end of the animation. During animations to show an
element, the element is considered to be visible at the start at the
animation.
How :visible is calculated was changed in jQuery 1.3.2. The
release notes outline the changes in more detail.

Additional Notes:
Because :visible is a jQuery extension and not part of the CSS
specification, queries using :visible cannot take advantage of
the performance boost provided by the native DOM
querySelectorAll() method. To achieve the best performance
when using :visible to select elements, first select the
elements using a pure CSS selector, then use
.filter(":visible") .

Example:
Make all visible divs turn yellow on click.
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<!DOCTYPE html>
<html>
<head>
<style>
div { width:50px; height:40px; margin:5px; border
.starthidden { display:none; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button>Show hidden to see they don't change</
<div></div>
<div class="starthidden"></div>
<div></div>
<div></div>
<div style="display:none;"></div>
<script>
$("div:visible").click(function () {
$(this).css("background", "yellow");
});
$("button").click(function () {
$("div:hidden").show("fast");
});
</script>
</body>
</html>

Demo
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.width()
Categories: CSS | Dimensions | Manipulation > Style Properties

Get the current computed width for the first element in the set of
matched elements or set the width of every matched element.
Contents:
.width()
.width()
.width( value )
.width( value )
.width( function(index, width) )

.width()

Returns: Integer

Description: Get the current computed width for the first
element in the set of matched elements.
.width()

version added: 1.0

This method does not accept any arguments.
The difference between .css(width) and .width() is that the latter
returns a unit-less pixel value (for example, 400 ) while the former
returns a value with units intact (for example, 400px ). The .width()
method is recommended when an element's width needs to be used
in a mathematical calculation.

This method is also able to find the width of the window and
document.
1
2

$(window).width();
// returns width of browser viewpor
$(document).width(); // returns width of HTML docu

Note that .width() will always return the content width, regardless of
the value of the CSS box-sizing property.

Example:
Show various widths. Note the values are from the
iframe so might be smaller than you expected. The
yellow highlight shows the iframe body.
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<!DOCTYPE html>
<html>
<head>
<style>
body { background:yellow; }
button { font-size:12px; margin:2px; }
p { width:150px; border:1px red solid; }
div { color:red; font-weight:bold; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<button id="getp">Get Paragraph Width</button
<button id="getd">Get Document Width</button>
<button id="getw">Get Window Width</button>
<div>&nbsp;</div>
<p>
Sample paragraph to test width
</p>
<script>
function showWidth(ele, w) {
$("div").text("The width for the " + ele +
" is " + w + "px.");
}
$("#getp").click(function () {
showWidth("paragraph", $("p").width());
});
$("#getd").click(function () {
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showWidth("document", $(document).width());
});
$("#getw").click(function () {
showWidth("window", $(window).width());
});
</script>
</body>
</html>

.width( value )

Returns: jQuery

Description: Set the CSS width of each element in the
set of matched elements.
.width( value )

version added: 1.0

value
Type: String or Number
An integer representing the number of pixels, or an integer
along with an optional unit of measure appended (as a string).

.width( function(index, width) )

version added: 1.4.1

function(index, width)
Type: Function()
A function returning the width to set. Receives the index
position of the element in the set and the old width as
arguments. Within the function, this refers to the current
element in the set.
When calling .width("value") , the value can be either a string
(number and unit) or a number. If only a number is provided for the
value, jQuery assumes a pixel unit. If a string is provided, however,
any valid CSS measurement may be used for the width (such as
100px , 50% , or auto ). Note that in modern browsers, the CSS width
property does not include padding, border, or margin, unless the
box-sizing CSS property is used.
If no explicit unit is specified (like "em" or "%") then "px" is assumed.
Note that .width("value") sets the content width of the box
regardless of the value of the CSS box-sizing property.

Example:
Change the width of each div the first time it is clicked
(and change its color).
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<!DOCTYPE html>
<html>
<head>
<style>
div { width: 70px; height: 50px; float:left; margin
background: red; cursor: pointer; }
.mod { background: blue; cursor: default; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<div>d</div>
<div>d</div>
<div>d</div>
<div>d</div>
<div>d</div>
<script>
(function() {
var modWidth = 50;
$("div").one('click', function () {
$(this).width(modWidth).addClass("mod");
modWidth -= 8;
});
})();
</script>
</body>
</html>

Demo
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.wrap()
Categories: Manipulation > DOM Insertion, Around

.wrap( wrappingElement )

Returns: jQuery

Description: Wrap an HTML structure around each
element in the set of matched elements.
.wrap( wrappingElement )

version added: 1.0

wrappingElement
Type: Selector or htmlString or Element or jQuery
A selector, element, HTML string, or jQuery object specifying
the structure to wrap around the matched elements.

.wrap( function(index) )

version added: 1.4

function(index)
Type: Function()
A callback function returning the HTML content or jQuery object
to wrap around the matched elements. Receives the index
position of the element in the set as an argument. Within the
function, this refers to the current element in the set.
The .wrap() function can take any string or object that could be
passed to the $() factory function to specify a DOM structure. This
structure may be nested several levels deep, but should contain only
one inmost element. A copy of this structure will be wrapped around
each of the elements in the set of matched elements. This method
returns the original set of elements for chaining purposes.
Consider the following HTML:
1
2
3
4
Using
<div>

<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>
.wrap() ,

we can insert an HTML structure around the inner
elements like so:

1

$('.inner').wrap('<div class="new" />');

The new <div> element is created on the fly and added to the DOM.
The result is a new <div> wrapped around each matched element:
1
2
3
4
5
6
7
8

<div class="container">
<div class="new">
<div class="inner">Hello</div>
</div>
<div class="new">
<div class="inner">Goodbye</div>
</div>
</div>

The second version of this method allows us to instead specify a
callback function. This callback function will be called once for every
matched element; it should return a DOM element, jQuery object, or
HTML snippet in which to wrap the corresponding element. For
example:
1
2
3

$('.inner').wrap(function() {
return '<div class="' + $(this).text() + '" />'
});

This will cause each
it wraps:
1
2
3
4
5

<div>

to have a class corresponding to the text

<div class="container">
<div class="Hello">
<div class="inner">Hello</div>
</div>
<div class="Goodbye">
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<div class="inner">Goodbye</div>
</div>
</div>

Examples:
Example:
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Wrap a new div around all of the paragraphs.

<!DOCTYPE html>
<html>
<head>
<style>
div { border: 2px solid blue; }
p { background:yellow; margin:4px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>cruel</p>
<p>World</p>
<script>$("p").wrap("<div></div>");</script>
</body>
</html>

Demo
Example:

Wraps a newly created tree of objects around
the spans. Notice anything in between the spans gets
left out like the <strong> (red text) in this example.
Even the white space between spans is left out. Click
View Source to see the original html.
1
2
3

<!DOCTYPE html>
<html>
<head>
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<style>

div { border:2px blue solid; margin:2px; padding
p { background:yellow; margin:2px; padding:2px;
strong { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<span>Span Text</span>
<strong>What about me?</strong>
<span>Another One</span>
<script>$("span").wrap("<div><div><p><em><b></b></em></p
</body>
</html>

Demo
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

Wrap a new div around all of the paragraphs.

<!DOCTYPE html>
<html>
<head>
<style>
div { border: 2px solid blue; }
p { background:yellow; margin:4px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>cruel</p>
<p>World</p>
<script>$("p").wrap(document.createElement("div"
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</body>
</html>

Demo
Example:

Wrap a jQuery object double depth div
around all of the paragraphs. Notice it doesn't move
the object but just clones it to wrap around its target.
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<!DOCTYPE html>
<html>
<head>
<style>
div { border: 2px solid blue; margin:2px; padding
.doublediv { border-color:red; }
p { background:yellow; margin:4px; font-size:
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>cruel</p>
<p>World</p>
<div class="doublediv"><div></div></div>
<script>$("p").wrap($(".doublediv"));</script>
</body>
</html>

Demo
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.wrapAll()
Categories: Manipulation > DOM Insertion, Around

.wrapAll( wrappingElement )

Returns: jQuery

Description: Wrap an HTML structure around all
elements in the set of matched elements.
.wrapAll( wrappingElement )

version added: 1.2

wrappingElement
Type: Selector or htmlString or Element or jQuery
A selector, element, HTML string, or jQuery object specifying
the structure to wrap around the matched elements.
The .wrapAll() function can take any string or object that could be
passed to the $() function to specify a DOM structure. This
structure may be nested several levels deep, but should contain only
one inmost element. The structure will be wrapped around all of the
elements in the set of matched elements, as a single group.
Consider the following HTML:
1
2
3
4
Using
<div>

1

<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>
.wrapAll() ,

we can insert an HTML structure around the inner
elements like so:
$('.inner').wrapAll('<div class="new" />');

The new <div> element is created on the fly and added to the DOM.
The result is a new <div> wrapped around all matched elements:
1

<div class="container">
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<div class="new">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>
</div>

Examples:
Example:
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Wrap a new div around all of the paragraphs.

<!DOCTYPE html>
<html>
<head>
<style>
div { border: 2px solid blue; }
p { background:yellow; margin:4px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>cruel</p>
<p>World</p>
<script>$("p").wrapAll("<div></div>");</script>
</body>
</html>

Demo
Example:

Wraps a newly created tree of objects around
the spans. Notice anything in between the spans gets
left out like the <strong> (red text) in this example.
Even the white space between spans is left out. Click
View Source to see the original html.
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<!DOCTYPE html>
<html>
<head>
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<style>

div { border:2px blue solid; margin:2px; padding
p { background:yellow; margin:2px; padding:2px;
strong { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<span>Span Text</span>
<strong>What about me?</strong>
<span>Another One</span>
<script>$("span").wrapAll("<div><div><p><em><b></b></em>
</body>
</html>

Demo
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

Wrap a new div around all of the paragraphs.

<!DOCTYPE html>
<html>
<head>
<style>
div { border: 2px solid blue; }
p { background:yellow; margin:4px; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>cruel</p>
<p>World</p>
<script>$("p").wrapAll(document.createElement("div"
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</body>
</html>

Demo
Example:

Wrap a jQuery object double depth div
around all of the paragraphs. Notice it doesn't move
the object but just clones it to wrap around its target.
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<!DOCTYPE html>
<html>
<head>
<style>
div { border: 2px solid blue; margin:2px; padding
.doublediv { border-color:red; }
p { background:yellow; margin:4px; font-size:
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>cruel</p>
<p>World</p>
<div class="doublediv"><div></div></div>
<script>$("p").wrapAll($(".doublediv"));</script
</body>
</html>

Demo
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A new version of this book is available!

.wrapInner()
Categories: Manipulation > DOM Insertion, Around

.wrapInner( wrappingElement )

Returns: jQuery

Description: Wrap an HTML structure around the
content of each element in the set of matched elements.
.wrapInner( wrappingElement )

version added: 1.2

wrappingElement
Type: String
An HTML snippet, selector expression, jQuery object, or DOM
element specifying the structure to wrap around the content of
the matched elements.

.wrapInner( function(index) )

version added: 1.4

function(index)
Type: Function()
A callback function which generates a structure to wrap around
the content of the matched elements. Receives the index
position of the element in the set as an argument. Within the
function, this refers to the current element in the set.
The .wrapInner() function can take any string or object that could be
passed to the $() factory function to specify a DOM structure. This
structure may be nested several levels deep, but should contain only
one inmost element. The structure will be wrapped around the
content of each of the elements in the set of matched elements.
Consider the following HTML:
1
2
3
4

<div class="container">
<div class="inner">Hello</div>
<div class="inner">Goodbye</div>
</div>

Using .wrapInner() , we can insert an HTML structure around the
content of each inner <div> elements like so:

1

$('.inner').wrapInner('<div class="new" />');

The new <div> element is created on the fly and added to the DOM.
The result is a new <div> wrapped around the content of each
matched element:
1
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<div class="container">
<div class="inner">
<div class="new">Hello</div>
</div>
<div class="inner">
<div class="new">Goodbye</div>
</div>
</div>

The second version of this method allows us to instead specify a
callback function. This callback function will be called once for every
matched element; it should return a DOM element, jQuery object, or
HTML snippet in which to wrap the content of the corresponding
element. For example:
1
2
3

$('.inner').wrapInner(function() {
return '<div class="' + this.nodeValue + '" />'
});

This will cause each
it wraps:
1
2
3
4

<div>

to have a class corresponding to the text

<div class="container">
<div class="inner">
<div class="Hello">Hello</div>
</div>

5
6
7
8

<div class="inner">
<div class="Goodbye">Goodbye</div>
</div>
</div>

Note: When passing a selector string to the .wrapInner() function,
the expected input is well formed HTML with correctly closed tags.
Examples of valid input include:
1
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3

$(elem).wrapInner("<div class='test' />");
$(elem).wrapInner("<div class='test'></div>");
$(elem).wrapInner("<div class=\"test\"></div>");

Examples:
Selects all paragraphs and wraps a bold tag
around each of its contents.
Example:
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<!DOCTYPE html>
<html>
<head>
<style>p { background:#bbf; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>cruel</p>
<p>World</p>
<script>$("p").wrapInner("<b></b>");</script>
</body>
</html>

Demo
Example:

Wraps a newly created tree of objects around
the inside of the body.
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<!DOCTYPE html>
<html>
<head>
<style>
div { border:2px green solid; margin:2px; padding
p { background:yellow; margin:2px; padding:2px;
</style>
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<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
Plain old text, or is it?
<script>$("body").wrapInner("<div><div><p><em><b></b></e
</body>
</html>

Demo
Example:

Selects all paragraphs and wraps a bold tag
around each of its contents.
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<!DOCTYPE html>
<html>
<head>
<style>p { background:#9f9; }</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>cruel</p>
<p>World</p>
<script>$("p").wrapInner(document.createElement(
</body>
</html>

Demo
Example:

Selects all paragraphs and wraps a jQuery
object around each of its contents.
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<!DOCTYPE html>
<html>
<head>
<style>
p { background:#9f9; }
.red { color:red; }
</style>
<script src="http://code.jquery.com/jquery-latest.js"
</head>
<body>
<p>Hello</p>
<p>cruel</p>
<p>World</p>
<script>$("p").wrapInner($("<span class='red'></span>"
</body>
</html>

Demo
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Category: Ajax
The jQuery library has a full suite of AJAX capabilities. The functions
and methods therein allow us to load data from the server without a
browser page refresh.
Also in: Ajax > Global Ajax Event Handlers

.ajaxComplete()
Register a handler to be called when Ajax requests complete. This
is an AjaxEvent.
Also in: Ajax > Global Ajax Event Handlers

.ajaxError()
Register a handler to be called when Ajax requests complete with
an error. This is an Ajax Event.
Also in: Ajax > Global Ajax Event Handlers

.ajaxSend()
Attach a function to be executed before an Ajax request is sent.
This is an Ajax Event.
Also in: Ajax > Global Ajax Event Handlers

.ajaxStart()
Register a handler to be called when the first Ajax request begins.
This is an Ajax Event.
Also in: Ajax > Global Ajax Event Handlers

.ajaxStop()
Register a handler to be called when all Ajax requests have
completed. This is an Ajax Event.
Also in: Ajax > Global Ajax Event Handlers

.ajaxSuccess()
Attach a function to be executed whenever an Ajax request
completes successfully. This is an Ajax Event.
Also in: Ajax > Low-Level Interface

jQuery.ajax()
Perform an asynchronous HTTP (Ajax) request.
Also in: Ajax > Low-Level Interface

jQuery.ajaxPrefilter()
Handle custom Ajax options or modify existing options before
each request is sent and before they are processed by $.ajax().
Also in: Ajax > Low-Level Interface

jQuery.ajaxSetup()
Set default values for future Ajax requests.
Also in: Ajax > Low-Level Interface

jQuery.ajaxTransport()
Creates an object that handles the actual transmission of Ajax
data.
Also in: Ajax > Shorthand Methods

jQuery.get()
Load data from the server using a HTTP GET request.
Also in: Ajax > Shorthand Methods

jQuery.getJSON()
Load JSON-encoded data from the server using a GET HTTP
request.
Also in: Ajax > Shorthand Methods

jQuery.getScript()
Load a JavaScript file from the server using a GET HTTP request,
then execute it.
Also in: Miscellaneous > Collection Manipulation | Forms | Ajax > Helper Functions

jQuery.param()
Create a serialized representation of an array or object, suitable
for use in a URL query string or Ajax request.
Also in: Ajax > Shorthand Methods

jQuery.post()
Load data from the server using a HTTP POST request.
Also in: Ajax > Shorthand Methods

.load()
Load data from the server and place the returned HTML into the
matched element.
Also in: Forms | Ajax > Helper Functions

.serialize()
Encode a set of form elements as a string for submission.
Also in: Forms | Ajax > Helper Functions

.serializeArray()
Encode a set of form elements as an array of names and values.

POWERED BYHERONOTE
A new version of this book is available!

Category: Global Ajax Event
Handlers
These methods register handlers to be called when certain events,
such as initialization or completion, take place for any AJAX request on
the page. The global events are fired on each AJAX request if the
global property in jQuery.ajaxSetup() is true , which it is by default.
Note: Global events are never fired for cross-domain script or JSONP
requests, regardless of the value of global .

.ajaxComplete()
Register a handler to be called when Ajax requests complete. This
is an AjaxEvent.

.ajaxError()
Register a handler to be called when Ajax requests complete with
an error. This is an Ajax Event.

.ajaxSend()
Attach a function to be executed before an Ajax request is sent.
This is an Ajax Event.

.ajaxStart()
Register a handler to be called when the first Ajax request begins.
This is an Ajax Event.

.ajaxStop()
Register a handler to be called when all Ajax requests have
completed. This is an Ajax Event.

.ajaxSuccess()
Attach a function to be executed whenever an Ajax request
completes successfully. This is an Ajax Event.

POWERED BYHERONOTE
A new version of this book is available!

Category: Helper Functions
These functions assist with common idioms encountered when
performing AJAX tasks.
Also in: Miscellaneous > Collection Manipulation | Forms

jQuery.param()
Create a serialized representation of an array or object, suitable
for use in a URL query string or Ajax request.
Also in: Forms

.serialize()
Encode a set of form elements as a string for submission.
Also in: Forms

.serializeArray()
Encode a set of form elements as an array of names and values.
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Category: Low-Level Interface
These methods can be used to make arbitrary AJAX requests.

jQuery.ajax()
Perform an asynchronous HTTP (Ajax) request.

jQuery.ajaxPrefilter()
Handle custom Ajax options or modify existing options before
each request is sent and before they are processed by $.ajax().

jQuery.ajaxSetup()
Set default values for future Ajax requests.

jQuery.ajaxTransport()
Creates an object that handles the actual transmission of Ajax
data.
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Category: Shorthand Methods
These methods perform the more common types of AJAX requests in
less code.

jQuery.get()
Load data from the server using a HTTP GET request.

jQuery.getJSON()
Load JSON-encoded data from the server using a GET HTTP
request.

jQuery.getScript()
Load a JavaScript file from the server using a GET HTTP request,
then execute it.

jQuery.post()
Load data from the server using a HTTP POST request.

.load()
Load data from the server and place the returned HTML into the
matched element.
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Ajax Events
Ajax requests produce a number of different events that you can
subscribe to. Here's a full list of the events and in what order they are
broadcast.
There are two types of events:

Local Events
These are callbacks that you can subscribe to within the Ajax request
object, like so:
1
2
3
4
5
6
7
8
9

$.ajax({
beforeSend: function(){
// Handle the beforeSend event
},
complete: function(){
// Handle the complete event
}
// ......
});

Global Events
These events are broadcast to all elements in the DOM, triggering any
handlers which may be listening. You can listen for these events like
so:
$("#loading").bind("ajaxSend", function(){
$(this).show();
}).bind("ajaxComplete", function(){
$(this).hide();
});

Global events can be disabled for a particular Ajax request by passing
in the global option, like so:

1
2
3
4
5

$.ajax({
url: "test.html",
global: false,
// ...
});

Events
This is the full list of Ajax events that are broadcast, and in the order in
which they are broadcast. The indented events are broadcast for each
and every Ajax request (unless a global option has been set). The
ajaxStart and ajaxStop events are events that relate to all Ajax
requests together.
ajaxStart (Global Event)
This event is broadcast if an Ajax request is started and no other
Ajax requests are currently running.
beforeSend (Local Event)
This event, which is triggered before an Ajax request is
started, allows you to modify the XMLHttpRequest object
(setting additional headers, if need be.)
ajaxSend (Global Event)
This global event is also triggered before the request is run.
success (Local Event)
This event is only called if the request was successful (no
errors from the server, no errors with the data).
ajaxSuccess (Global Event)
This event is also only called if the request was successful.
error (Local Event)
This event is only called if an error occurred with the request
(you can never have both an error and a success callback
with a request).
ajaxError (Global Event)
This global event behaves the same as the local error event.
complete (Local Event)
This event is called regardless of if the request was
successful, or not. You will always receive a complete

callback, even for synchronous requests.
ajaxComplete (Global Event)
This event behaves the same as the complete event and will
be triggered every time an Ajax request finishes.
ajaxStop (Global Event)
This global event is triggered if there are no more Ajax requests
being processed.
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Category: Attributes
These methods get and set DOM attributes of elements.
Also in: Manipulation > Class Attribute | CSS

.addClass()
Adds the specified class(es) to each of the set of matched
elements.
Also in: Manipulation > General Attributes

.attr()
Get the value of an attribute for the first element in the set of
matched elements or set one or more attributes for every matched
element.
Also in: Manipulation > Class Attribute | CSS

.hasClass()
Determine whether any of the matched elements are assigned the
given class.
Also in: Manipulation > DOM Insertion, Inside

.html()
Get the HTML contents of the first element in the set of matched
elements or set the HTML contents of every matched element.
Also in: Manipulation > General Attributes

.prop()
Get the value of a property for the first element in the set of
matched elements or set one or more properties for every
matched element.
Also in: Manipulation > General Attributes

.removeAttr()
Remove an attribute from each element in the set of matched
elements.
Also in: Manipulation > Class Attribute | CSS

.removeClass()
Remove a single class, multiple classes, or all classes from each
element in the set of matched elements.
Also in: Manipulation > General Attributes

.removeProp()
Remove a property for the set of matched elements.
Also in: Manipulation > Class Attribute | CSS

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument.
Also in: Forms | Manipulation > General Attributes

.val()
Get the current value of the first element in the set of matched
elements or set the value of every matched element.
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Category: Callbacks Object
The jQuery.Callbacks() function, introduced in version 1.7, returns a
multi-purpose object that provides a powerful way to manage callback
lists. It supports adding, removing, firing, and disabling callbacks.

callbacks.add()
Add a callback or a collection of callbacks to a callback list.

callbacks.disable()
Disable a callback list from doing anything more.

callbacks.disabled()
Determine if the callbacks list has been disabled.

callbacks.empty()
Remove all of the callbacks from a list.

callbacks.fire()
Call all of the callbacks with the given arguments

callbacks.fired()
Determine if the callbacks have already been called at least once.

callbacks.fireWith()
Call all callbacks in a list with the given context and arguments.

callbacks.has()
Determine whether a supplied callback is in a list

callbacks.lock()
Lock a callback list in its current state.

callbacks.locked()
Determine if the callbacks list has been locked.

callbacks.remove()
Remove a callback or a collection of callbacks from a callback list.

jQuery.Callbacks()
A multi-purpose callbacks list object that provides a powerful way
to manage callback lists.
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Category: Core

jQuery()
Return a collection of matched elements either found in the DOM
based on passed argument(s) or created by passing an HTML
string.

jQuery.holdReady()
Holds or releases the execution of jQuery’s ready event.
Also in: Miscellaneous > Setup Methods

jQuery.noConflict()
Relinquish jQuery’s control of the $ variable.

jQuery.sub()
Creates a new copy of jQuery whose properties and methods can
be modified without affecting the original jQuery object.
Also in: Deferred Object

jQuery.when()
Provides a way to execute callback functions based on one or
more objects, usually Deferred objects that represent
asynchronous events.
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Category: CSS
These methods get and set CSS-related properties of elements.
Also in: Attributes | Manipulation > Class Attribute

.addClass()
Adds the specified class(es) to each of the set of matched
elements.
Also in: Manipulation > Style Properties

.css()
Get the value of a style property for the first element in the set of
matched elements or set one or more CSS properties for every
matched element.
Also in: Attributes | Manipulation > Class Attribute

.hasClass()
Determine whether any of the matched elements are assigned the
given class.
Also in: Dimensions | Manipulation > Style Properties

.height()
Get the current computed height for the first element in the set of
matched elements or set the height of every matched element.
Also in: Dimensions | Manipulation > Style Properties

.innerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding but not border.
Also in: Dimensions | Manipulation > Style Properties

.innerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding but not border.

jQuery.cssHooks
Hook directly into jQuery to override how particular CSS
properties are retrieved or set, normalize CSS property naming, or
create custom properties.
Also in: Offset | Manipulation > Style Properties

.offset()
Get the current coordinates of the first element, or set the
coordinates of every element, in the set of matched elements,
relative to the document.
Also in: Dimensions | Manipulation > Style Properties

.outerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding, border, and optionally
margin. Returns an integer (without “px”) representation of the
value or null if called on an empty set of elements.
Also in: Dimensions | Manipulation > Style Properties

.outerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding and border.
Also in: Offset | Manipulation > Style Properties

.position()
Get the current coordinates of the first element in the set of
matched elements, relative to the offset parent.
Also in: Attributes | Manipulation > Class Attribute

.removeClass()
Remove a single class, multiple classes, or all classes from each
element in the set of matched elements.
Also in: Offset | Manipulation > Style Properties

.scrollLeft()
Get the current horizontal position of the scroll bar for the first
element in the set of matched elements or set the horizontal
position of the scroll bar for every matched element.
Also in: Offset | Manipulation > Style Properties

.scrollTop()
Get the current vertical position of the scroll bar for the first
element in the set of matched elements or set the vertical position
of the scroll bar for every matched element.
Also in: Attributes | Manipulation > Class Attribute

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument.
Also in: Dimensions | Manipulation > Style Properties

.width()
Get the current computed width for the first element in the set of
matched elements or set the width of every matched element.
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Category: Data
These methods allow us to associate arbitrary data with specific DOM
elements.
Also in: Effects > Custom | Utilities

.clearQueue()
Remove from the queue all items that have not yet been run.
Also in: Miscellaneous > Data Storage

.data()
Store arbitrary data associated with the matched elements or
return the value at the named data store for the first element in the
set of matched elements.
Also in: Effects > Custom | Utilities

.dequeue()
Execute the next function on the queue for the matched elements.
Also in: Utilities

jQuery.data()
Store arbitrary data associated with the specified element and/or
return the value that was set.
Also in: Utilities

jQuery.dequeue()
Execute the next function on the queue for the matched element.

jQuery.hasData()
Determine whether an element has any jQuery data associated
with it.
Also in: Utilities

jQuery.queue()
Show or manipulate the queue of functions to be executed on the
matched element.
Also in: Utilities

jQuery.removeData()
Remove a previously-stored piece of data.
Also in: Effects > Custom | Utilities

.queue()
Show or manipulate the queue of functions to be executed on the
matched elements.
Also in: Miscellaneous > Data Storage

.removeData()
Remove a previously-stored piece of data.
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Category: Deferred Object
The Deferred object, introduced in jQuery 1.5, is a chainable utility
object created by calling the jQuery.Deferred() method. It can register
multiple callbacks into callback queues, invoke callback queues, and
relay the success or failure state of any synchronous or asynchronous
function.
The Deferred object is chainable, similar to the way a jQuery object is
chainable, but it has its own methods. After creating a Deferred object,
you can use any of the methods below by either chaining directly from
the object creation or saving the object in a variable and invoking one
or more methods on that variable.

deferred.always()
Add handlers to be called when the Deferred object is either
resolved or rejected.

deferred.done()
Add handlers to be called when the Deferred object is resolved.

deferred.fail()
Add handlers to be called when the Deferred object is rejected.

deferred.isRejected()
Determine whether a Deferred object has been rejected.

deferred.isResolved()
Determine whether a Deferred object has been resolved.

deferred.notify()
Call the progressCallbacks on a Deferred object with the given
args.

deferred.notifyWith()
Call the progressCallbacks on a Deferred object with the given
context and args.

deferred.pipe()
Utility method to filter and/or chain Deferreds.

deferred.progress()
Add handlers to be called when the Deferred object generates
progress notifications.

deferred.promise()
Return a Deferred’s Promise object.

deferred.reject()
Reject a Deferred object and call any failCallbacks with the given
args.

deferred.rejectWith()
Reject a Deferred object and call any failCallbacks with the given
context and args.

deferred.resolve()
Resolve a Deferred object and call any doneCallbacks with the
given args.

deferred.resolveWith()
Resolve a Deferred object and call any doneCallbacks with the
given context and args.

deferred.state()
Determine the current state of a Deferred object.

deferred.then()
Add handlers to be called when the Deferred object is resolved,
rejected, or still in progress.

jQuery.Deferred()
A constructor function that returns a chainable utility object with
methods to register multiple callbacks into callback queues,
invoke callback queues, and relay the success or failure state of
any synchronous or asynchronous function.
Also in: Core

jQuery.when()
Provides a way to execute callback functions based on one or
more objects, usually Deferred objects that represent
asynchronous events.

.promise()
Return a Promise object to observe when all actions of a certain
type bound to the collection, queued or not, have finished.
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Category: Deprecated
Also in: Deprecated > Deprecated 1.8 | Events > Mouse Events

.toggle()
Bind two or more handlers to the matched elements, to be
executed on alternate clicks.

POWERED BYHERONOTE
A new version of this book is available!

Category: Deprecated 1.8
All the aspects of the API that were deprecated in the corresponding
version of jQuery.
For more information, see the Release Notes/Changelog at
http://blog.jquery.com/2012/08/09/jquery-1-8-released/
Also in: Events > Mouse Events

.toggle()
Bind two or more handlers to the matched elements, to be
executed on alternate clicks.
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Category: Dimensions
These methods are used to get and set the CSS dimensions for the
various properties.
Also in: CSS | Manipulation > Style Properties

.height()
Get the current computed height for the first element in the set of
matched elements or set the height of every matched element.
Also in: CSS | Manipulation > Style Properties

.innerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding but not border.
Also in: CSS | Manipulation > Style Properties

.innerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding but not border.
Also in: CSS | Manipulation > Style Properties

.outerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding, border, and optionally
margin. Returns an integer (without “px”) representation of the
value or null if called on an empty set of elements.
Also in: CSS | Manipulation > Style Properties

.outerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding and border.
Also in: CSS | Manipulation > Style Properties

.width()
Get the current computed width for the first element in the set of
matched elements or set the width of every matched element.
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Category: Effects
The jQuery library provides several techniques for adding animation to
a web page. These include simple, standard animations that are
frequently used, and the ability to craft sophisticated custom effects.
Also in: Effects > Custom

.animate()
Perform a custom animation of a set of CSS properties.
Also in: Effects > Custom | Data | Utilities

.clearQueue()
Remove from the queue all items that have not yet been run.
Also in: Effects > Custom

.delay()
Set a timer to delay execution of subsequent items in the queue.
Also in: Effects > Custom | Data | Utilities

.dequeue()
Execute the next function on the queue for the matched elements.
Also in: Effects > Fading

.fadeIn()
Display the matched elements by fading them to opaque.
Also in: Effects > Fading

.fadeOut()
Hide the matched elements by fading them to transparent.
Also in: Effects > Fading

.fadeTo()
Adjust the opacity of the matched elements.
Also in: Effects > Fading

.fadeToggle()
Display or hide the matched elements by animating their opacity.
Also in: Effects > Custom

.finish()
Stop the currently-running animation, remove all queued
animations, and complete all animations for the matched
elements.
Also in: Effects > Basics

.hide()
Hide the matched elements.
Also in: Effects > Custom | Properties > Properties of the Global jQuery Object

jQuery.fx.interval
The rate (in milliseconds) at which animations fire.
Also in: Effects > Custom | Properties > Properties of the Global jQuery Object

jQuery.fx.off
Globally disable all animations.
Also in: Effects > Custom | Data | Utilities

.queue()
Show or manipulate the queue of functions to be executed on the
matched elements.
Also in: Effects > Basics

.show()
Display the matched elements.
Also in: Effects > Sliding

.slideDown()
Display the matched elements with a sliding motion.
Also in: Effects > Sliding

.slideToggle()
Display or hide the matched elements with a sliding motion.
Also in: Effects > Sliding

.slideUp()
Hide the matched elements with a sliding motion.
Also in: Effects > Custom

.stop()
Stop the currently-running animation on the matched elements.
Also in: Effects > Basics

.toggle()
Display or hide the matched elements.
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Category: Basics

.hide()
Hide the matched elements.

.show()
Display the matched elements.

.toggle()
Display or hide the matched elements.
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Category: Custom
These methods allow you to create effects that are not provided “out of
the box” by jQuery.

.animate()
Perform a custom animation of a set of CSS properties.
Also in: Data | Utilities

.clearQueue()
Remove from the queue all items that have not yet been run.

.delay()
Set a timer to delay execution of subsequent items in the queue.
Also in: Data | Utilities

.dequeue()
Execute the next function on the queue for the matched elements.

.finish()
Stop the currently-running animation, remove all queued
animations, and complete all animations for the matched
elements.
Also in: Properties > Properties of the Global jQuery Object

jQuery.fx.interval
The rate (in milliseconds) at which animations fire.
Also in: Properties > Properties of the Global jQuery Object

jQuery.fx.off
Globally disable all animations.
Also in: Data | Utilities

.queue()
Show or manipulate the queue of functions to be executed on the
matched elements.

.stop()
Stop the currently-running animation on the matched elements.
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Category: Fading
These methods adjust the opacity of elements.

.fadeIn()
Display the matched elements by fading them to opaque.

.fadeOut()
Hide the matched elements by fading them to transparent.

.fadeTo()
Adjust the opacity of the matched elements.
Also in: Effects

.fadeToggle()
Display or hide the matched elements by animating their opacity.
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Category: Sliding

.slideDown()
Display the matched elements with a sliding motion.

.slideToggle()
Display or hide the matched elements with a sliding motion.

.slideUp()
Hide the matched elements with a sliding motion.
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Category: Events
These methods are used to register behaviors to take effect when the
user interacts with the browser, and to further manipulate those
registered behaviors.
Also in: Events > Event Handler Attachment

.bind()
Attach a handler to an event for the elements.
Also in: Events > Form Events | Forms

.blur()
Bind an event handler to the “blur” JavaScript event, or trigger that
event on an element.
Also in: Events > Form Events | Forms

.change()
Bind an event handler to the “change” JavaScript event, or trigger
that event on an element.
Also in: Events > Mouse Events

.click()
Bind an event handler to the “click” JavaScript event, or trigger
that event on an element.
Also in: Events > Mouse Events

.dblclick()
Bind an event handler to the “dblclick” JavaScript event, or trigger
that event on an element.
Also in: Events > Event Handler Attachment

.delegate()
Attach a handler to one or more events for all elements that match
the selector, now or in the future, based on a specific set of root
elements.
Also in: Events > Event Handler Attachment

.die()
Remove event handlers previously attached using .live() from the
elements.
Also in: Events > Browser Events

.error()
Bind an event handler to the “error” JavaScript event.
Also in: Events > Event Object

event.currentTarget
The current DOM element within the event bubbling phase.
Also in: Events > Event Object

event.data
An optional object of data passed to an event method when the
current executing handler is bound.
Also in: Events > Event Object

event.delegateTarget
The element where the currently-called jQuery event handler was
attached.
Also in: Events > Event Object

event.isDefaultPrevented()
Returns whether event.preventDefault() was ever called on this
event object.
Also in: Events > Event Object

event.isImmediatePropagationStopped()
Returns whether event.stopImmediatePropagation() was ever
called on this event object.
Also in: Events > Event Object

event.isPropagationStopped()
Returns whether event.stopPropagation() was ever called on this
event object.
Also in: Events > Event Object

event.metaKey
Indicates whether the META key was pressed when the event
fired.
Also in: Events > Event Object

event.namespace
The namespace specified when the event was triggered.
Also in: Events > Event Object

event.pageX
The mouse position relative to the left edge of the document.
Also in: Events > Event Object

event.pageY
The mouse position relative to the top edge of the document.
Also in: Events > Event Object

event.preventDefault()
If this method is called, the default action of the event will not be
triggered.
Also in: Events > Event Object

event.relatedTarget
The other DOM element involved in the event, if any.
Also in: Events > Event Object

event.result
The last value returned by an event handler that was triggered by
this event, unless the value was undefined.
Also in: Events > Event Object

event.stopImmediatePropagation()
Keeps the rest of the handlers from being executed and prevents
the event from bubbling up the DOM tree.
Also in: Events > Event Object

event.stopPropagation()
Prevents the event from bubbling up the DOM tree, preventing
any parent handlers from being notified of the event.
Also in: Events > Event Object

event.target
The DOM element that initiated the event.
Also in: Events > Event Object

event.timeStamp
The difference in milliseconds between the time the browser
created the event and January 1, 1970.
Also in: Events > Event Object

event.type
Describes the nature of the event.
Also in: Events > Event Object

event.which
For key or mouse events, this property indicates the specific key
or button that was pressed.
Also in: Events > Form Events | Forms

.focus()
Bind an event handler to the “focus” JavaScript event, or trigger
that event on an element.
Also in: Events > Keyboard Events | Events > Mouse Events

.focusin()
Bind an event handler to the “focusin” event.
Also in: Events > Keyboard Events | Events > Mouse Events

.focusout()
Bind an event handler to the “focusout” JavaScript event.
Also in: Events > Mouse Events

.hover()
Bind one or two handlers to the matched elements, to be executed
when the mouse pointer enters and leaves the elements.
Also in: Events > Event Handler Attachment | Utilities

jQuery.proxy()
Takes a function and returns a new one that will always have a
particular context.
Also in: Events > Keyboard Events

.keydown()
Bind an event handler to the “keydown” JavaScript event, or
trigger that event on an element.
Also in: Events > Keyboard Events

.keypress()
Bind an event handler to the “keypress” JavaScript event, or
trigger that event on an element.
Also in: Events > Keyboard Events

.keyup()
Bind an event handler to the “keyup” JavaScript event, or trigger
that event on an element.
Also in: Events > Event Handler Attachment

.live()
Attach an event handler for all elements which match the current
selector, now and in the future.
Also in: Events > Document Loading

.load()
Bind an event handler to the “load” JavaScript event.
Also in: Events > Mouse Events

.mousedown()
Bind an event handler to the “mousedown” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseenter()
Bind an event handler to be fired when the mouse enters an
element, or trigger that handler on an element.
Also in: Events > Mouse Events

.mouseleave()
Bind an event handler to be fired when the mouse leaves an
element, or trigger that handler on an element.
Also in: Events > Mouse Events

.mousemove()
Bind an event handler to the “mousemove” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseout()
Bind an event handler to the “mouseout” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseover()
Bind an event handler to the “mouseover” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseup()
Bind an event handler to the “mouseup” JavaScript event, or
trigger that event on an element.
Also in: Events > Event Handler Attachment

.off()
Remove an event handler.
Also in: Events > Event Handler Attachment

.on()
Attach an event handler function for one or more events to the
selected elements.
Also in: Events > Event Handler Attachment

.one()
Attach a handler to an event for the elements. The handler is
executed at most once per element.
Also in: Events > Document Loading

.ready()
Specify a function to execute when the DOM is fully loaded.
Also in: Events > Browser Events

.resize()
Bind an event handler to the “resize” JavaScript event, or trigger
that event on an element.
Also in: Events > Browser Events

.scroll()
Bind an event handler to the “scroll” JavaScript event, or trigger
that event on an element.
Also in: Events > Form Events | Forms

.select()
Bind an event handler to the “select” JavaScript event, or trigger
that event on an element.
Also in: Events > Form Events | Forms

.submit()
Bind an event handler to the “submit” JavaScript event, or trigger
that event on an element.
Also in: Deprecated > Deprecated 1.8 | Events > Mouse Events

.toggle()
Bind two or more handlers to the matched elements, to be
executed on alternate clicks.
Also in: Events > Event Handler Attachment

.trigger()
Execute all handlers and behaviors attached to the matched
elements for the given event type.
Also in: Events > Event Handler Attachment

.triggerHandler()
Execute all handlers attached to an element for an event.
Also in: Events > Event Handler Attachment

.unbind()
Remove a previously-attached event handler from the elements.
Also in: Events > Event Handler Attachment

.undelegate()
Remove a handler from the event for all elements which match the
current selector, based upon a specific set of root elements.
Also in: Events > Document Loading

.unload()
Bind an event handler to the “unload” JavaScript event.
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Category: Browser Events

.error()
Bind an event handler to the “error” JavaScript event.

.resize()
Bind an event handler to the “resize” JavaScript event, or trigger
that event on an element.

.scroll()
Bind an event handler to the “scroll” JavaScript event, or trigger
that event on an element.
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Category: Document Loading

.load()
Bind an event handler to the “load” JavaScript event.

.ready()
Specify a function to execute when the DOM is fully loaded.

.unload()
Bind an event handler to the “unload” JavaScript event.
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Category: Event Handler
Attachment

.bind()
Attach a handler to an event for the elements.

.delegate()
Attach a handler to one or more events for all elements that match
the selector, now or in the future, based on a specific set of root
elements.

.die()
Remove event handlers previously attached using .live() from the
elements.
Also in: Utilities

jQuery.proxy()
Takes a function and returns a new one that will always have a
particular context.

.live()
Attach an event handler for all elements which match the current
selector, now and in the future.

.off()
Remove an event handler.

.on()
Attach an event handler function for one or more events to the
selected elements.

.one()
Attach a handler to an event for the elements. The handler is
executed at most once per element.

.trigger()
Execute all handlers and behaviors attached to the matched
elements for the given event type.

.triggerHandler()
Execute all handlers attached to an element for an event.

.unbind()
Remove a previously-attached event handler from the elements.

.undelegate()
Remove a handler from the event for all elements which match the
current selector, based upon a specific set of root elements.
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Category: Event Object
jQuery’s event system normalizes the event object according to W3C
standards. The event object is guaranteed to be passed to the event
handler. Most properties from the original event are copied over and
normalized to the new event object.
jQuery.Event Constructor
The jQuery.Event constructor is exposed and can be used when calling
trigger. The new operator is optional.
Check trigger‘s documentation to see how to combine it with your own
event object.
Example:

//Create a new jQuery.Event object without
the "new" operator.
var e = jQuery.Event("click");
// trigger an artificial click event
jQuery("body").trigger( e );
As of jQuery 1.6, you can also pass an object to jQuery.Event() and its
properties will be set on the newly created Event object.
Example:

// Create a new jQuery.Event object with
specified event properties.
var e = jQuery.Event("keydown", { keyCode:
64 });
// trigger an artificial keydown event

with keyCode 64
jQuery("body").trigger( e );
Event Properties
jQuery normalizes the following properties for cross-browser
consistency:
target
relatedTarget
pageX
pageY
which
metaKey

The following properties are also copied to the event object, though
some of their values may be undefined depending on the event:
altKey, bubbles, button, cancelable, charCode, clientX, clientY, ctrlKey,
currentTarget, data, detail, eventPhase, metaKey, offsetX, offsetY,
originalTarget, pageX, pageY, prevValue, relatedTarget, screenX,
screenY, shiftKey, target, view, which
OtherProperties
Certain events may have properties specific to them. Those can be
accessed as properties of the event.originalEvent object. To make
special properties available in all event objects, they can be added to
the jQuery.event.props array. This is not recommended, since it adds
overhead to every event delivered by jQuery.
Example:

// add the dataTransfer property for use
with the native `drop` event
// to capture information about files
dropped into the browser window

jQuery.event.props.push("dataTransfer");

event.currentTarget
The current DOM element within the event bubbling phase.

event.data
An optional object of data passed to an event method when the
current executing handler is bound.
Also in: Events

event.delegateTarget
The element where the currently-called jQuery event handler was
attached.

event.isDefaultPrevented()
Returns whether event.preventDefault() was ever called on this
event object.

event.isImmediatePropagationStopped()
Returns whether event.stopImmediatePropagation() was ever
called on this event object.

event.isPropagationStopped()
Returns whether event.stopPropagation() was ever called on this
event object.

event.metaKey
Indicates whether the META key was pressed when the event
fired.

event.namespace
The namespace specified when the event was triggered.

event.pageX
The mouse position relative to the left edge of the document.

event.pageY
The mouse position relative to the top edge of the document.

event.preventDefault()
If this method is called, the default action of the event will not be
triggered.

event.relatedTarget
The other DOM element involved in the event, if any.

event.result
The last value returned by an event handler that was triggered by
this event, unless the value was undefined.

event.stopImmediatePropagation()
Keeps the rest of the handlers from being executed and prevents
the event from bubbling up the DOM tree.

event.stopPropagation()
Prevents the event from bubbling up the DOM tree, preventing
any parent handlers from being notified of the event.

event.target
The DOM element that initiated the event.

event.timeStamp
The difference in milliseconds between the time the browser
created the event and January 1, 1970.

event.type
Describes the nature of the event.

event.which
For key or mouse events, this property indicates the specific key
or button that was pressed.
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Category: Form Events
Also in: Forms

.blur()
Bind an event handler to the “blur” JavaScript event, or trigger that
event on an element.
Also in: Forms

.change()
Bind an event handler to the “change” JavaScript event, or trigger
that event on an element.
Also in: Forms

.focus()
Bind an event handler to the “focus” JavaScript event, or trigger
that event on an element.
Also in: Forms

.select()
Bind an event handler to the “select” JavaScript event, or trigger
that event on an element.
Also in: Forms

.submit()
Bind an event handler to the “submit” JavaScript event, or trigger
that event on an element.
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Category: Keyboard Events
Also in: Events > Mouse Events

.focusin()
Bind an event handler to the “focusin” event.
Also in: Events > Mouse Events

.focusout()
Bind an event handler to the “focusout” JavaScript event.

.keydown()
Bind an event handler to the “keydown” JavaScript event, or
trigger that event on an element.

.keypress()
Bind an event handler to the “keypress” JavaScript event, or
trigger that event on an element.

.keyup()
Bind an event handler to the “keyup” JavaScript event, or trigger
that event on an element.
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Category: Mouse Events

.click()
Bind an event handler to the “click” JavaScript event, or trigger
that event on an element.

.dblclick()
Bind an event handler to the “dblclick” JavaScript event, or trigger
that event on an element.
Also in: Events > Keyboard Events

.focusin()
Bind an event handler to the “focusin” event.
Also in: Events > Keyboard Events

.focusout()
Bind an event handler to the “focusout” JavaScript event.

.hover()
Bind one or two handlers to the matched elements, to be executed
when the mouse pointer enters and leaves the elements.

.mousedown()
Bind an event handler to the “mousedown” JavaScript event, or
trigger that event on an element.

.mouseenter()
Bind an event handler to be fired when the mouse enters an
element, or trigger that handler on an element.

.mouseleave()
Bind an event handler to be fired when the mouse leaves an
element, or trigger that handler on an element.

.mousemove()
Bind an event handler to the “mousemove” JavaScript event, or
trigger that event on an element.

.mouseout()
Bind an event handler to the “mouseout” JavaScript event, or
trigger that event on an element.

.mouseover()
Bind an event handler to the “mouseover” JavaScript event, or
trigger that event on an element.

.mouseup()
Bind an event handler to the “mouseup” JavaScript event, or
trigger that event on an element.
Also in: Deprecated > Deprecated 1.8

.toggle()
Bind two or more handlers to the matched elements, to be
executed on alternate clicks.
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Category: Forms
These methods and event handlers handle forms and their various
elements.
Also in: Events > Form Events

.blur()
Bind an event handler to the “blur” JavaScript event, or trigger that
event on an element.
Also in: Events > Form Events

.change()
Bind an event handler to the “change” JavaScript event, or trigger
that event on an element.
Also in: Events > Form Events

.focus()
Bind an event handler to the “focus” JavaScript event, or trigger
that event on an element.
Also in: Miscellaneous > Collection Manipulation | Ajax > Helper Functions

jQuery.param()
Create a serialized representation of an array or object, suitable
for use in a URL query string or Ajax request.
Also in: Events > Form Events

.select()
Bind an event handler to the “select” JavaScript event, or trigger
that event on an element.
Also in: Ajax > Helper Functions

.serialize()
Encode a set of form elements as a string for submission.
Also in: Ajax > Helper Functions

.serializeArray()
Encode a set of form elements as an array of names and values.
Also in: Events > Form Events

.submit()
Bind an event handler to the “submit” JavaScript event, or trigger
that event on an element.
Also in: Attributes | Manipulation > General Attributes

.val()
Get the current value of the first element in the set of matched
elements or set the value of every matched element.
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Category: Internals
Although this category is referred to as ‘internal’, any methods
documented within the API site should be considered public and may
be freely used.
Also in: Properties > Properties of jQuery Object Instances

.context
The DOM node context originally passed to jQuery(); if none was
passed then context will likely be the document.
Also in: Properties > Properties of jQuery Object Instances

.jquery
A string containing the jQuery version number.

jQuery.error()
Takes a string and throws an exception containing it.

.pushStack()
Add a collection of DOM elements onto the jQuery stack.
Also in: Properties > Properties of the Global jQuery Object

.selector
A selector representing selector originally passed to jQuery().
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Category: Manipulation
All of the methods in this section manipulate the DOM in some manner.
A few of them simply change one of the attributes of an element (also
listed in the Attributes category), while others set an element’s style
properties (also listed in the CSS category). Still others modify entire
elements (or groups of elements) themselves—inserting, copying,
removing, and so on. All of these methods are referred to as “setters,”
as they change the values of properties.
A few of these methods—such as .attr() , .html() , and .val() —also
act as “getters,” retrieving information from DOM elements for later
use.
Also in: Attributes | Manipulation > Class Attribute | CSS

.addClass()
Adds the specified class(es) to each of the set of matched
elements.
Also in: Manipulation > DOM Insertion, Outside

.after()
Insert content, specified by the parameter, after each element in
the set of matched elements.
Also in: Manipulation > DOM Insertion, Inside

.append()
Insert content, specified by the parameter, to the end of each
element in the set of matched elements.
Also in: Manipulation > DOM Insertion, Inside

.appendTo()
Insert every element in the set of matched elements to the end of
the target.
Also in: Attributes | Manipulation > General Attributes

.attr()
Get the value of an attribute for the first element in the set of
matched elements or set one or more attributes for every matched
element.
Also in: Manipulation > DOM Insertion, Outside

.before()
Insert content, specified by the parameter, before each element in
the set of matched elements.
Also in: Manipulation > Copying

.clone()
Create a deep copy of the set of matched elements.
Also in: CSS | Manipulation > Style Properties

.css()
Get the value of a style property for the first element in the set of
matched elements or set one or more CSS properties for every
matched element.
Also in: Manipulation > DOM Removal

.detach()
Remove the set of matched elements from the DOM.
Also in: Manipulation > DOM Removal

.empty()
Remove all child nodes of the set of matched elements from the
DOM.
Also in: Attributes | Manipulation > Class Attribute | CSS

.hasClass()
Determine whether any of the matched elements are assigned the
given class.
Also in: CSS | Dimensions | Manipulation > Style Properties

.height()
Get the current computed height for the first element in the set of
matched elements or set the height of every matched element.
Also in: Attributes | Manipulation > DOM Insertion, Inside

.html()
Get the HTML contents of the first element in the set of matched
elements or set the HTML contents of every matched element.
Also in: CSS | Dimensions | Manipulation > Style Properties

.innerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding but not border.
Also in: CSS | Dimensions | Manipulation > Style Properties

.innerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding but not border.
Also in: Manipulation > DOM Insertion, Outside

.insertAfter()
Insert every element in the set of matched elements after the
target.
Also in: Manipulation > DOM Insertion, Outside

.insertBefore()
Insert every element in the set of matched elements before the
target.
Also in: CSS | Offset | Manipulation > Style Properties

.offset()
Get the current coordinates of the first element, or set the
coordinates of every element, in the set of matched elements,
relative to the document.
Also in: CSS | Dimensions | Manipulation > Style Properties

.outerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding, border, and optionally
margin. Returns an integer (without “px”) representation of the
value or null if called on an empty set of elements.
Also in: CSS | Dimensions | Manipulation > Style Properties

.outerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding and border.
Also in: CSS | Offset | Manipulation > Style Properties

.position()
Get the current coordinates of the first element in the set of
matched elements, relative to the offset parent.
Also in: Manipulation > DOM Insertion, Inside

.prepend()
Insert content, specified by the parameter, to the beginning of
each element in the set of matched elements.
Also in: Manipulation > DOM Insertion, Inside

.prependTo()
Insert every element in the set of matched elements to the
beginning of the target.
Also in: Attributes | Manipulation > General Attributes

.prop()
Get the value of a property for the first element in the set of
matched elements or set one or more properties for every
matched element.
Also in: Manipulation > DOM Removal

.remove()
Remove the set of matched elements from the DOM.
Also in: Attributes | Manipulation > General Attributes

.removeAttr()
Remove an attribute from each element in the set of matched
elements.
Also in: Attributes | Manipulation > Class Attribute | CSS

.removeClass()
Remove a single class, multiple classes, or all classes from each
element in the set of matched elements.
Also in: Attributes | Manipulation > General Attributes

.removeProp()
Remove a property for the set of matched elements.
Also in: Manipulation > DOM Replacement

.replaceAll()
Replace each target element with the set of matched elements.
Also in: Manipulation > DOM Replacement

.replaceWith()
Replace each element in the set of matched elements with the
provided new content and return the set of elements that was
removed.
Also in: CSS | Offset | Manipulation > Style Properties

.scrollLeft()
Get the current horizontal position of the scroll bar for the first
element in the set of matched elements or set the horizontal
position of the scroll bar for every matched element.
Also in: CSS | Offset | Manipulation > Style Properties

.scrollTop()
Get the current vertical position of the scroll bar for the first
element in the set of matched elements or set the vertical position
of the scroll bar for every matched element.
Also in: Manipulation > DOM Insertion, Inside

.text()
Get the combined text contents of each element in the set of
matched elements, including their descendants, or set the text
contents of the matched elements.
Also in: Attributes | Manipulation > Class Attribute | CSS

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument.
Also in: Manipulation > DOM Insertion, Around | Manipulation > DOM Removal

.unwrap()
Remove the parents of the set of matched elements from the
DOM, leaving the matched elements in their place.
Also in: Attributes | Forms | Manipulation > General Attributes

.val()
Get the current value of the first element in the set of matched
elements or set the value of every matched element.
Also in: CSS | Dimensions | Manipulation > Style Properties

.width()
Get the current computed width for the first element in the set of
matched elements or set the width of every matched element.
Also in: Manipulation > DOM Insertion, Around

.wrap()
Wrap an HTML structure around each element in the set of
matched elements.
Also in: Manipulation > DOM Insertion, Around

.wrapAll()
Wrap an HTML structure around all elements in the set of
matched elements.
Also in: Manipulation > DOM Insertion, Around

.wrapInner()
Wrap an HTML structure around the content of each element in
the set of matched elements.
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Category: Class Attribute
These methods inspect and manipulate the CSS classes assigned to
elements.
Also in: Attributes | CSS

.addClass()
Adds the specified class(es) to each of the set of matched
elements.
Also in: Attributes | CSS

.hasClass()
Determine whether any of the matched elements are assigned the
given class.
Also in: Attributes | CSS

.removeClass()
Remove a single class, multiple classes, or all classes from each
element in the set of matched elements.
Also in: Attributes | CSS

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument.
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Category: Copying
This method allows us to make copies of elements.

.clone()
Create a deep copy of the set of matched elements.
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Category: DOM Insertion,
Around
These methods allow us to insert new content surrounding existing
content.
Also in: Manipulation > DOM Removal

.unwrap()
Remove the parents of the set of matched elements from the
DOM, leaving the matched elements in their place.

.wrap()
Wrap an HTML structure around each element in the set of
matched elements.

.wrapAll()
Wrap an HTML structure around all elements in the set of
matched elements.

.wrapInner()
Wrap an HTML structure around the content of each element in
the set of matched elements.
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Category: DOM Insertion, Inside
These methods allow us to insert new content inside an existing
element.

.append()
Insert content, specified by the parameter, to the end of each
element in the set of matched elements.

.appendTo()
Insert every element in the set of matched elements to the end of
the target.
Also in: Attributes

.html()
Get the HTML contents of the first element in the set of matched
elements or set the HTML contents of every matched element.

.prepend()
Insert content, specified by the parameter, to the beginning of
each element in the set of matched elements.

.prependTo()
Insert every element in the set of matched elements to the
beginning of the target.

.text()
Get the combined text contents of each element in the set of
matched elements, including their descendants, or set the text
contents of the matched elements.
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Category: DOM Insertion,
Outside
These methods allow us to insert new content outside an existing
element.

.after()
Insert content, specified by the parameter, after each element in
the set of matched elements.

.before()
Insert content, specified by the parameter, before each element in
the set of matched elements.

.insertAfter()
Insert every element in the set of matched elements after the
target.

.insertBefore()
Insert every element in the set of matched elements before the
target.
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Category: DOM Removal
These methods allow us to delete elements from the DOM.

.detach()
Remove the set of matched elements from the DOM.

.empty()
Remove all child nodes of the set of matched elements from the
DOM.

.remove()
Remove the set of matched elements from the DOM.
Also in: Manipulation > DOM Insertion, Around

.unwrap()
Remove the parents of the set of matched elements from the
DOM, leaving the matched elements in their place.
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Category: DOM Replacement
These methods are used to remove content from the DOM and replace
it with new content.

.replaceAll()
Replace each target element with the set of matched elements.

.replaceWith()
Replace each element in the set of matched elements with the
provided new content and return the set of elements that was
removed.
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Category: General Attributes
These methods get and set DOM attributes of elements
Also in: Attributes

.attr()
Get the value of an attribute for the first element in the set of
matched elements or set one or more attributes for every matched
element.
Also in: Attributes

.prop()
Get the value of a property for the first element in the set of
matched elements or set one or more properties for every
matched element.
Also in: Attributes

.removeAttr()
Remove an attribute from each element in the set of matched
elements.
Also in: Attributes

.removeProp()
Remove a property for the set of matched elements.
Also in: Attributes | Forms

.val()
Get the current value of the first element in the set of matched
elements or set the value of every matched element.
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Category: Style Properties
These methods get and set CSS-related properties of elements.
Also in: CSS

.css()
Get the value of a style property for the first element in the set of
matched elements or set one or more CSS properties for every
matched element.
Also in: CSS | Dimensions

.height()
Get the current computed height for the first element in the set of
matched elements or set the height of every matched element.
Also in: CSS | Dimensions

.innerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding but not border.
Also in: CSS | Dimensions

.innerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding but not border.
Also in: CSS | Offset

.offset()
Get the current coordinates of the first element, or set the
coordinates of every element, in the set of matched elements,
relative to the document.
Also in: CSS | Dimensions

.outerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding, border, and optionally
margin. Returns an integer (without “px”) representation of the
value or null if called on an empty set of elements.
Also in: CSS | Dimensions

.outerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding and border.
Also in: CSS | Offset

.position()
Get the current coordinates of the first element in the set of
matched elements, relative to the offset parent.
Also in: CSS | Offset

.scrollLeft()
Get the current horizontal position of the scroll bar for the first
element in the set of matched elements or set the horizontal
position of the scroll bar for every matched element.
Also in: CSS | Offset

.scrollTop()
Get the current vertical position of the scroll bar for the first
element in the set of matched elements or set the vertical position
of the scroll bar for every matched element.
Also in: CSS | Dimensions

.width()
Get the current computed width for the first element in the set of
matched elements or set the width of every matched element.
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Category: Miscellaneous
Also in: Data | Miscellaneous > Data Storage

.data()
Store arbitrary data associated with the matched elements or
return the value at the named data store for the first element in the
set of matched elements.
Also in: Miscellaneous > Collection Manipulation | Traversing

.each()
Iterate over a jQuery object, executing a function for each
matched element.
Also in: Miscellaneous > DOM Element Methods

.get()
Retrieve the DOM elements matched by the jQuery object.
Also in: Miscellaneous > DOM Element Methods

.index()
Search for a given element from among the matched elements.
Also in: Core | Miscellaneous > Setup Methods

jQuery.noConflict()
Relinquish jQuery’s control of the $ variable.
Also in: Miscellaneous > Collection Manipulation | Forms | Ajax > Helper Functions

jQuery.param()
Create a serialized representation of an array or object, suitable
for use in a URL query string or Ajax request.
Also in: Data | Miscellaneous > Data Storage

.removeData()
Remove a previously-stored piece of data.
Also in: Miscellaneous > DOM Element Methods

.size()
Return the number of elements in the jQuery object.
Also in: Miscellaneous > DOM Element Methods

.toArray()
Retrieve all the DOM elements contained in the jQuery set, as an
array.
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Category: Collection
Manipulation
Also in: Traversing

.each()
Iterate over a jQuery object, executing a function for each
matched element.
Also in: Forms | Ajax > Helper Functions

jQuery.param()
Create a serialized representation of an array or object, suitable
for use in a URL query string or Ajax request.

POWERED BYHERONOTE
A new version of this book is available!

Category: Data Storage
These methods allow us to associate arbitrary data with specific DOM
elements.
Also in: Data

.data()
Store arbitrary data associated with the matched elements or
return the value at the named data store for the first element in the
set of matched elements.
Also in: Data

.removeData()
Remove a previously-stored piece of data.

POWERED BYHERONOTE
A new version of this book is available!

Category: DOM Element
Methods

.get()
Retrieve the DOM elements matched by the jQuery object.

.index()
Search for a given element from among the matched elements.

.size()
Return the number of elements in the jQuery object.

.toArray()
Retrieve all the DOM elements contained in the jQuery set, as an
array.
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Category: Setup Methods
Also in: Core

jQuery.noConflict()
Relinquish jQuery’s control of the $ variable.
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Category: Offset
Also in: CSS | Manipulation > Style Properties

.offset()
Get the current coordinates of the first element, or set the
coordinates of every element, in the set of matched elements,
relative to the document.
Also in: Traversing > Tree Traversal

.offsetParent()
Get the closest ancestor element that is positioned.
Also in: CSS | Manipulation > Style Properties

.position()
Get the current coordinates of the first element in the set of
matched elements, relative to the offset parent.
Also in: CSS | Manipulation > Style Properties

.scrollLeft()
Get the current horizontal position of the scroll bar for the first
element in the set of matched elements or set the horizontal
position of the scroll bar for every matched element.
Also in: CSS | Manipulation > Style Properties

.scrollTop()
Get the current vertical position of the scroll bar for the first
element in the set of matched elements or set the vertical position
of the scroll bar for every matched element.
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Category: Properties
Also in: Internals | Properties > Properties of jQuery Object Instances

.context
The DOM node context originally passed to jQuery(); if none was
passed then context will likely be the document.
Also in: Internals | Properties > Properties of jQuery Object Instances

.jquery
A string containing the jQuery version number.
Also in: Properties > Properties of the Global jQuery Object | Utilities

jQuery.browser
Contains flags for the useragent, read from navigator.userAgent.
We recommend against using this property; please try to use
feature detection instead (see jQuery.support). jQuery.browser
may be moved to a plugin in a future release of jQuery.
Also in: Effects > Custom | Properties > Properties of the Global jQuery Object

jQuery.fx.interval
The rate (in milliseconds) at which animations fire.
Also in: Effects > Custom | Properties > Properties of the Global jQuery Object

jQuery.fx.off
Globally disable all animations.
Also in: Properties > Properties of the Global jQuery Object | Utilities

jQuery.support
A collection of properties that represent the presence of different
browser features or bugs. Primarily intended for jQuery’s internal
use; specific properties may be removed when they are no longer
needed internally to improve page startup performance.
Also in: Properties > Properties of jQuery Object Instances

.length
The number of elements in the jQuery object.
Also in: Internals | Properties > Properties of the Global jQuery Object

.selector
A selector representing selector originally passed to jQuery().
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Category: Properties of jQuery
Object Instances
Each jQuery object created with the jQuery() function contains a
number of properties alongside its methods. These properties allow us
to inspect various attributes of the object.
Also in: Internals

.context
The DOM node context originally passed to jQuery(); if none was
passed then context will likely be the document.
Also in: Internals

.jquery
A string containing the jQuery version number.

.length
The number of elements in the jQuery object.
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Category: Properties of the
Global jQuery Object
These properties are associated with the global jQuery object.
Also in: Utilities

jQuery.browser
Contains flags for the useragent, read from navigator.userAgent.
We recommend against using this property; please try to use
feature detection instead (see jQuery.support). jQuery.browser
may be moved to a plugin in a future release of jQuery.
Also in: Effects > Custom

jQuery.fx.interval
The rate (in milliseconds) at which animations fire.
Also in: Effects > Custom

jQuery.fx.off
Globally disable all animations.
Also in: Utilities

jQuery.support
A collection of properties that represent the presence of different
browser features or bugs. Primarily intended for jQuery’s internal
use; specific properties may be removed when they are no longer
needed internally to improve page startup performance.
Also in: Internals

.selector
A selector representing selector originally passed to jQuery().
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Category: Selectors
Borrowing from CSS 1–3, and then adding its own, jQuery offers a
powerful set of tools for matching a set of elements in a document.
To use any of the meta-characters ( such as !"#$%&'()*+,./:;<=>?
@[\]^`{|}~ ) as a literal part of a name, it must be escaped with with
two backslashes: \\ . For example, an element with id="foo.bar" , can
use the selector $("#foo\\.bar") . The W3C CSS specification contains
the complete set of rules regarding valid CSS selectors. Also useful is
the blog entry by Mathias Bynens on CSS character escape
sequences for identifiers.
Also in: Selectors > Basic

All Selector (“*”)
Selects all elements.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:animated Selector
Select all elements that are in the progress of an animation at the
time the selector is run.
Also in: Selectors > Attribute

Attribute Contains Prefix Selector
[name|="value"]
Selects elements that have the specified attribute with a value
either equal to a given string or starting with that string followed by
a hyphen (-).
Also in: Selectors > Attribute

Attribute Contains Selector [name*="value"]
Selects elements that have the specified attribute with a value
containing the a given substring.
Also in: Selectors > Attribute

Attribute Contains Word Selector
[name~="value"]
Selects elements that have the specified attribute with a value
containing a given word, delimited by spaces.
Also in: Selectors > Attribute

Attribute Ends With Selector
[name$="value"]
Selects elements that have the specified attribute with a value
ending exactly with a given string. The comparison is case
sensitive.
Also in: Selectors > Attribute

Attribute Equals Selector [name="value"]
Selects elements that have the specified attribute with a value
exactly equal to a certain value.
Also in: Selectors > Attribute | Selectors > jQuery Extensions

Attribute Not Equal Selector
[name!="value"]
Select elements that either don’t have the specified attribute, or do
have the specified attribute but not with a certain value.
Also in: Selectors > Attribute

Attribute Starts With Selector
[name^="value"]
Selects elements that have the specified attribute with a value
beginning exactly with a given string.
Also in: Selectors > Form | Selectors > jQuery Extensions

:button Selector
Selects all button elements and elements of type button.
Also in: Selectors > Form | Selectors > jQuery Extensions

:checkbox Selector
Selects all elements of type checkbox.
Also in: Selectors > Form

:checked Selector
Matches all elements that are checked.
Also in: Selectors > Hierarchy

child”)" href="0D4EEA27BD.htm"
rel=bookmark>Child Selector (“parent >
child”)
Selects all direct child elements specified by “child” of elements
specified by “parent”.
Also in: Selectors > Basic

Class Selector (“.class”)
Selects all elements with the given class.
Also in: Selectors > Content Filter

:contains() Selector
Select all elements that contain the specified text.
Also in: Selectors > Hierarchy

Descendant Selector (“ancestor
descendant”)
Selects all elements that are descendants of a given ancestor.
Also in: Selectors > Form

:disabled Selector
Selects all elements that are disabled.
Also in: Selectors > Basic

Element Selector (“element”)
Selects all elements with the given tag name.
Also in: Selectors > Content Filter

:empty Selector
Select all elements that have no children (including text nodes).
Also in: Selectors > Form

:enabled Selector
Selects all elements that are enabled.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:eq() Selector
Select the element at index n within the matched set.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:even Selector
Selects even elements, zero-indexed. See also odd.
Also in: Selectors > Form | Selectors > jQuery Extensions

:file Selector
Selects all elements of type file.
Also in: Selectors > Child Filter

:first-child Selector
Selects all elements that are the first child of their parent.
Also in: Selectors > Child Filter

:first-of-type Selector
Selects all elements that are the first among siblings of the same
element name.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:first Selector
Selects the first matched element.
Also in: Selectors > Basic Filter | Selectors > Form

:focus Selector
Selects element if it is currently focused.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:gt() Selector
Select all elements at an index greater than index within the
matched set.
Also in: Selectors > Attribute

Has Attribute Selector [name]
Selects elements that have the specified attribute, with any value.
Also in: Selectors > Content Filter | Selectors > jQuery Extensions

:has() Selector
Selects elements which contain at least one element that matches
the specified selector.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:header Selector
Selects all elements that are headers, like h1, h2, h3 and so on.
Also in: Selectors > jQuery Extensions | Selectors > Visibility Filter

:hidden Selector
Selects all elements that are hidden.
Also in: Selectors > Basic

ID Selector (“#id”)
Selects a single element with the given id attribute.
Also in: Selectors > Form | Selectors > jQuery Extensions

:image Selector
Selects all elements of type image.
Also in: Selectors > Form | Selectors > jQuery Extensions

:input Selector
Selects all input, textarea, select and button elements.
Also in: Selectors > Basic Filter

:lang Selector
Selects all elements of the specified language.
Also in: Selectors > Child Filter

:last-child Selector
Selects all elements that are the last child of their parent.
Also in: Selectors > Child Filter

:last-of-type Selector
Selects all elements that are the last among siblings of the same
element name.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:last Selector
Selects the last matched element.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:lt() Selector
Select all elements at an index less than index within the matched
set.
Also in: Selectors > Attribute

Multiple Attribute Selector [name="value"]
[name2="value2"]
Matches elements that match all of the specified attribute filters.
Also in: Selectors > Basic

Multiple Selector (“selector1, selector2,
selectorN”)
Selects the combined results of all the specified selectors.
Also in: Selectors > Hierarchy

Next Adjacent Selector (“prev + next”)
Selects all next elements matching “next” that are immediately
preceded by a sibling “prev”.
Also in: Selectors > Hierarchy

Next Siblings Selector (“prev ~ siblings”)
Selects all sibling elements that follow after the “prev” element,
have the same parent, and match the filtering “siblings” selector.
Also in: Selectors > Basic Filter

:not() Selector
Selects all elements that do not match the given selector.
Also in: Selectors > Child Filter

:nth-child() Selector
Selects all elements that are the nth-child of their parent.
Also in: Selectors > Child Filter

:nth-last-child() Selector
Selects all elements that are the nth-child of their parent, counting
from the last element to the first.
Also in: Selectors > Child Filter

:nth-last-of-type() Selector
Selects all elements that are the nth-child of their parent, counting
from the last element to the first.
Also in: Selectors > Child Filter

:nth-of-type() Selector
Selects all elements that are the nth child of their parent in relation
to siblings with the same element name.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:odd Selector
Selects odd elements, zero-indexed. See also even.
Also in: Selectors > Child Filter

:only-child Selector
Selects all elements that are the only child of their parent.
Also in: Selectors > Child Filter

:only-of-type Selector
Selects all elements that have no siblings with the same element
name.
Also in: Selectors > Content Filter | Selectors > jQuery Extensions

:parent Selector
Select all elements that that have at least one child node (either
an element or text).
Also in: Selectors > Form | Selectors > jQuery Extensions

:password Selector
Selects all elements of type password.
Also in: Selectors > Form | Selectors > jQuery Extensions

:radio Selector
Selects all elements of type radio.
Also in: Selectors > Form | Selectors > jQuery Extensions

:reset Selector
Selects all elements of type reset.
Also in: Selectors > Basic Filter

:root Selector
Selects the element that is the root of the document.
Also in: Selectors > Form | Selectors > jQuery Extensions

:selected Selector
Selects all elements that are selected.
Also in: Selectors > Form | Selectors > jQuery Extensions

:submit Selector
Selects all elements of type submit.
Also in: Selectors > Basic Filter

:target Selector
Selects the target element indicated by the fragment identifier of
the document’s URI.
Also in: Selectors > Form | Selectors > jQuery Extensions

:text Selector
Selects all elements of type text.
Also in: Selectors > jQuery Extensions | Selectors > Visibility Filter

:visible Selector
Selects all elements that are visible.
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Category: Attribute
The CSS specification allows elements to be identified by their
attributes. While not supported by some older browsers for the purpose
of styling documents, jQuery allows you to employ them regardless of
the browser being used.
When using any of the following attribute selectors, you should account
for attributes that have multiple, space-separated values. Since these
selectors see attribute values as a single string, this selector, for
example, $("a[rel='nofollow']") , will select <a href="example.html"
rel="nofollow">Some text</a> but not <a href="example.html"
rel="nofollow foe">Some text</a> .
Attribute values in selector expressions must follow the rules for W3C
CSS selectors; in general, that means anything other than a valid
identifier should be surrounded by quotation marks.
double quotes inside single quotes:

$('a[rel="nofollow self"]')

single quotes inside double quotes:

$("a[rel='nofollow self']")

escaped single quotes inside single quotes:

$('a[rel=\'nofollow

self\']')

escaped double quotes inside double quotes:

$("a[rel=\"nofollow

self\"]")

The variation you choose is generally a matter of style or convenience.
Note: In jQuery 1.3 [@attr] style selectors were removed (they were
previously deprecated in jQuery 1.2). Simply remove the “@” symbol
from your selectors in order to make them work again.

Attribute Contains Prefix Selector
[name|="value"]
Selects elements that have the specified attribute with a value
either equal to a given string or starting with that string followed by
a hyphen (-).

Attribute Contains Selector [name*="value"]
Selects elements that have the specified attribute with a value
containing the a given substring.

Attribute Contains Word Selector
[name~="value"]
Selects elements that have the specified attribute with a value
containing a given word, delimited by spaces.

Attribute Ends With Selector
[name$="value"]
Selects elements that have the specified attribute with a value
ending exactly with a given string. The comparison is case
sensitive.

Attribute Equals Selector [name="value"]
Selects elements that have the specified attribute with a value
exactly equal to a certain value.
Also in: Selectors > jQuery Extensions

Attribute Not Equal Selector
[name!="value"]
Select elements that either don’t have the specified attribute, or do
have the specified attribute but not with a certain value.

Attribute Starts With Selector
[name^="value"]
Selects elements that have the specified attribute with a value
beginning exactly with a given string.

Has Attribute Selector [name]
Selects elements that have the specified attribute, with any value.

Multiple Attribute Selector [name="value"]
[name2="value2"]
Matches elements that match all of the specified attribute filters.
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Category: Basic
The following selectors are based on the Cascading Style Sheet 1
specification, as outlined by the W3C. For more information about the
specifications, visit http://www.w3.org/Style/CSS/#specs.

All Selector (“*”)
Selects all elements.

Class Selector (“.class”)
Selects all elements with the given class.

Element Selector (“element”)
Selects all elements with the given tag name.

ID Selector (“#id”)
Selects a single element with the given id attribute.

Multiple Selector (“selector1, selector2,
selectorN”)
Selects the combined results of all the specified selectors.
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Category: Basic Filter
Also in: Selectors > jQuery Extensions

:animated Selector
Select all elements that are in the progress of an animation at the
time the selector is run.
Also in: Selectors > jQuery Extensions

:eq() Selector
Select the element at index n within the matched set.
Also in: Selectors > jQuery Extensions

:even Selector
Selects even elements, zero-indexed. See also odd.
Also in: Selectors > jQuery Extensions

:first Selector
Selects the first matched element.
Also in: Selectors > Form

:focus Selector
Selects element if it is currently focused.
Also in: Selectors > jQuery Extensions

:gt() Selector
Select all elements at an index greater than index within the
matched set.
Also in: Selectors > jQuery Extensions

:header Selector
Selects all elements that are headers, like h1, h2, h3 and so on.

:lang Selector
Selects all elements of the specified language.
Also in: Selectors > jQuery Extensions

:last Selector
Selects the last matched element.
Also in: Selectors > jQuery Extensions

:lt() Selector
Select all elements at an index less than index within the matched
set.

:not() Selector
Selects all elements that do not match the given selector.
Also in: Selectors > jQuery Extensions

:odd Selector
Selects odd elements, zero-indexed. See also even.

:root Selector
Selects the element that is the root of the document.

:target Selector
Selects the target element indicated by the fragment identifier of
the document’s URI.
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Category: Child Filter

:first-child Selector
Selects all elements that are the first child of their parent.

:first-of-type Selector
Selects all elements that are the first among siblings of the same
element name.

:last-child Selector
Selects all elements that are the last child of their parent.

:last-of-type Selector
Selects all elements that are the last among siblings of the same
element name.

:nth-child() Selector
Selects all elements that are the nth-child of their parent.

:nth-last-child() Selector
Selects all elements that are the nth-child of their parent, counting
from the last element to the first.

:nth-last-of-type() Selector
Selects all elements that are the nth-child of their parent, counting
from the last element to the first.

:nth-of-type() Selector
Selects all elements that are the nth child of their parent in relation
to siblings with the same element name.

:only-child Selector
Selects all elements that are the only child of their parent.

:only-of-type Selector
Selects all elements that have no siblings with the same element
name.
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Category: Content Filter

:contains() Selector
Select all elements that contain the specified text.

:empty Selector
Select all elements that have no children (including text nodes).
Also in: Selectors > jQuery Extensions

:has() Selector
Selects elements which contain at least one element that matches
the specified selector.
Also in: Selectors > jQuery Extensions

:parent Selector
Select all elements that that have at least one child node (either
an element or text).
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Category: Form
Also in: Selectors > jQuery Extensions

:button Selector
Selects all button elements and elements of type button.
Also in: Selectors > jQuery Extensions

:checkbox Selector
Selects all elements of type checkbox.

:checked Selector
Matches all elements that are checked.

:disabled Selector
Selects all elements that are disabled.

:enabled Selector
Selects all elements that are enabled.
Also in: Selectors > jQuery Extensions

:file Selector
Selects all elements of type file.
Also in: Selectors > Basic Filter

:focus Selector
Selects element if it is currently focused.
Also in: Selectors > jQuery Extensions

:image Selector
Selects all elements of type image.
Also in: Selectors > jQuery Extensions

:input Selector
Selects all input, textarea, select and button elements.
Also in: Selectors > jQuery Extensions

:password Selector
Selects all elements of type password.
Also in: Selectors > jQuery Extensions

:radio Selector
Selects all elements of type radio.
Also in: Selectors > jQuery Extensions

:reset Selector
Selects all elements of type reset.
Also in: Selectors > jQuery Extensions

:selected Selector
Selects all elements that are selected.
Also in: Selectors > jQuery Extensions

:submit Selector
Selects all elements of type submit.
Also in: Selectors > jQuery Extensions

:text Selector
Selects all elements of type text.
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Category: Hierarchy

child”)" href="0D4EEA27BD.htm"
rel="bookmark">Child Selector (“parent >
child”)
Selects all direct child elements specified by “child” of elements
specified by “parent”.

Descendant Selector (“ancestor
descendant”)
Selects all elements that are descendants of a given ancestor.

Next Adjacent Selector (“prev + next”)
Selects all next elements matching “next” that are immediately
preceded by a sibling “prev”.

Next Siblings Selector (“prev ~ siblings”)
Selects all sibling elements that follow after the “prev” element,
have the same parent, and match the filtering “siblings” selector.
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Category: jQuery Extensions
jQuery has extended the CSS3 selectors with the following selectors.
Because these selectors are jQuery extension and not part of the CSS
specification, queries using them cannot take advantage of the
performance boost provided by the native DOM querySelectorAll()
method. To achieve the best performance when using these selectors,
first select some elements using a pure CSS selector, then use
.filter() .
Also in: Selectors > Basic Filter

:animated Selector
Select all elements that are in the progress of an animation at the
time the selector is run.
Also in: Selectors > Attribute

Attribute Not Equal Selector
[name!="value"]
Select elements that either don’t have the specified attribute, or do
have the specified attribute but not with a certain value.
Also in: Selectors > Form

:button Selector
Selects all button elements and elements of type button.
Also in: Selectors > Form

:checkbox Selector
Selects all elements of type checkbox.
Also in: Selectors > Basic Filter

:eq() Selector
Select the element at index n within the matched set.
Also in: Selectors > Basic Filter

:even Selector
Selects even elements, zero-indexed. See also odd.
Also in: Selectors > Form

:file Selector
Selects all elements of type file.
Also in: Selectors > Basic Filter

:first Selector
Selects the first matched element.
Also in: Selectors > Basic Filter

:gt() Selector
Select all elements at an index greater than index within the
matched set.
Also in: Selectors > Content Filter

:has() Selector
Selects elements which contain at least one element that matches
the specified selector.
Also in: Selectors > Basic Filter

:header Selector
Selects all elements that are headers, like h1, h2, h3 and so on.
Also in: Selectors > Visibility Filter

:hidden Selector
Selects all elements that are hidden.
Also in: Selectors > Form

:image Selector
Selects all elements of type image.
Also in: Selectors > Form

:input Selector
Selects all input, textarea, select and button elements.
Also in: Selectors > Basic Filter

:last Selector
Selects the last matched element.
Also in: Selectors > Basic Filter

:lt() Selector
Select all elements at an index less than index within the matched
set.
Also in: Selectors > Basic Filter

:odd Selector
Selects odd elements, zero-indexed. See also even.
Also in: Selectors > Content Filter

:parent Selector
Select all elements that that have at least one child node (either
an element or text).
Also in: Selectors > Form

:password Selector
Selects all elements of type password.
Also in: Selectors > Form

:radio Selector
Selects all elements of type radio.
Also in: Selectors > Form

:reset Selector
Selects all elements of type reset.
Also in: Selectors > Form

:selected Selector
Selects all elements that are selected.
Also in: Selectors > Form

:submit Selector
Selects all elements of type submit.
Also in: Selectors > Form

:text Selector
Selects all elements of type text.
Also in: Selectors > Visibility Filter

:visible Selector
Selects all elements that are visible.
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Category: Visibility Filter
Also in: Selectors > jQuery Extensions

:hidden Selector
Selects all elements that are hidden.
Also in: Selectors > jQuery Extensions

:visible Selector
Selects all elements that are visible.
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Category: Traversing
Also in: Traversing > Miscellaneous Traversing

.add()
Add elements to the set of matched elements.
Also in: Traversing > Miscellaneous Traversing

.addBack()
Add the previous set of elements on the stack to the current set,
optionally filtered by a selector.
Also in: Traversing > Miscellaneous Traversing

.andSelf()
Add the previous set of elements on the stack to the current set.
Also in: Traversing > Tree Traversal

.children()
Get the children of each element in the set of matched elements,
optionally filtered by a selector.
Also in: Traversing > Tree Traversal

.closest()
For each element in the set, get the first element that matches the
selector by testing the element itself and traversing up through its
ancestors in the DOM tree.
Also in: Traversing > Miscellaneous Traversing

.contents()
Get the children of each element in the set of matched elements,
including text and comment nodes.
Also in: Miscellaneous > Collection Manipulation

.each()
Iterate over a jQuery object, executing a function for each
matched element.
Also in: Traversing > Miscellaneous Traversing

.end()
End the most recent filtering operation in the current chain and
return the set of matched elements to its previous state.
Also in: Traversing > Filtering

.eq()
Reduce the set of matched elements to the one at the specified
index.
Also in: Traversing > Filtering

.filter()
Reduce the set of matched elements to those that match the
selector or pass the function’s test.
Also in: Traversing > Tree Traversal

.find()
Get the descendants of each element in the current set of
matched elements, filtered by a selector, jQuery object, or
element.
Also in: Traversing > Filtering

.first()
Reduce the set of matched elements to the first in the set.
Also in: Traversing > Filtering

.has()
Reduce the set of matched elements to those that have a
descendant that matches the selector or DOM element.
Also in: Traversing > Filtering

.is()
Check the current matched set of elements against a selector,
element, or jQuery object and return true if at least one of these
elements matches the given arguments.
Also in: Traversing > Filtering

.last()
Reduce the set of matched elements to the final one in the set.
Also in: Traversing > Filtering

.map()
Pass each element in the current matched set through a function,
producing a new jQuery object containing the return values.
Also in: Traversing > Tree Traversal

.next()
Get the immediately following sibling of each element in the set of
matched elements. If a selector is provided, it retrieves the next
sibling only if it matches that selector.
Also in: Traversing > Tree Traversal

.nextAll()
Get all following siblings of each element in the set of matched
elements, optionally filtered by a selector.
Also in: Traversing > Tree Traversal

.nextUntil()
Get all following siblings of each element up to but not including
the element matched by the selector, DOM node, or jQuery object
passed.
Also in: Traversing > Filtering | Traversing > Miscellaneous Traversing

.not()
Remove elements from the set of matched elements.
Also in: Offset | Traversing > Tree Traversal

.offsetParent()
Get the closest ancestor element that is positioned.
Also in: Traversing > Tree Traversal

.parent()
Get the parent of each element in the current set of matched
elements, optionally filtered by a selector.
Also in: Traversing > Tree Traversal

.parents()
Get the ancestors of each element in the current set of matched
elements, optionally filtered by a selector.
Also in: Traversing > Tree Traversal

.parentsUntil()
Get the ancestors of each element in the current set of matched
elements, up to but not including the element matched by the
selector, DOM node, or jQuery object.
Also in: Traversing > Tree Traversal

.prev()
Get the immediately preceding sibling of each element in the set
of matched elements, optionally filtered by a selector.
Also in: Traversing > Tree Traversal

.prevAll()
Get all preceding siblings of each element in the set of matched
elements, optionally filtered by a selector.
Also in: Traversing > Tree Traversal

.prevUntil()
Get all preceding siblings of each element up to but not including
the element matched by the selector, DOM node, or jQuery object.
Also in: Traversing > Tree Traversal

.siblings()
Get the siblings of each element in the set of matched elements,
optionally filtered by a selector.
Also in: Traversing > Filtering

.slice()
Reduce the set of matched elements to a subset specified by a
range of indices.
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Category: Filtering

.eq()
Reduce the set of matched elements to the one at the specified
index.

.filter()
Reduce the set of matched elements to those that match the
selector or pass the function’s test.

.first()
Reduce the set of matched elements to the first in the set.

.has()
Reduce the set of matched elements to those that have a
descendant that matches the selector or DOM element.

.is()
Check the current matched set of elements against a selector,
element, or jQuery object and return true if at least one of these
elements matches the given arguments.

.last()
Reduce the set of matched elements to the final one in the set.

.map()
Pass each element in the current matched set through a function,
producing a new jQuery object containing the return values.
Also in: Traversing > Miscellaneous Traversing

.not()
Remove elements from the set of matched elements.

.slice()
Reduce the set of matched elements to a subset specified by a
range of indices.
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Category: Miscellaneous
Traversing

.add()
Add elements to the set of matched elements.

.addBack()
Add the previous set of elements on the stack to the current set,
optionally filtered by a selector.

.andSelf()
Add the previous set of elements on the stack to the current set.

.contents()
Get the children of each element in the set of matched elements,
including text and comment nodes.

.end()
End the most recent filtering operation in the current chain and
return the set of matched elements to its previous state.
Also in: Traversing > Filtering

.not()
Remove elements from the set of matched elements.
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Category: Tree Traversal

.children()
Get the children of each element in the set of matched elements,
optionally filtered by a selector.

.closest()
For each element in the set, get the first element that matches the
selector by testing the element itself and traversing up through its
ancestors in the DOM tree.

.find()
Get the descendants of each element in the current set of
matched elements, filtered by a selector, jQuery object, or
element.

.next()
Get the immediately following sibling of each element in the set of
matched elements. If a selector is provided, it retrieves the next
sibling only if it matches that selector.

.nextAll()
Get all following siblings of each element in the set of matched
elements, optionally filtered by a selector.

.nextUntil()
Get all following siblings of each element up to but not including
the element matched by the selector, DOM node, or jQuery object
passed.
Also in: Offset

.offsetParent()
Get the closest ancestor element that is positioned.

.parent()
Get the parent of each element in the current set of matched
elements, optionally filtered by a selector.

.parents()
Get the ancestors of each element in the current set of matched
elements, optionally filtered by a selector.

.parentsUntil()
Get the ancestors of each element in the current set of matched
elements, up to but not including the element matched by the
selector, DOM node, or jQuery object.

.prev()
Get the immediately preceding sibling of each element in the set
of matched elements, optionally filtered by a selector.

.prevAll()
Get all preceding siblings of each element in the set of matched
elements, optionally filtered by a selector.

.prevUntil()
Get all preceding siblings of each element up to but not including
the element matched by the selector, DOM node, or jQuery object.

.siblings()
Get the siblings of each element in the set of matched elements,
optionally filtered by a selector.
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Category: Utilities
Also in: Effects > Custom | Data

.clearQueue()
Remove from the queue all items that have not yet been run.
Also in: Effects > Custom | Data

.dequeue()
Execute the next function on the queue for the matched elements.

jQuery.boxModel
Deprecated in jQuery 1.3 (see jQuery.support). States if the
current page, in the user’s browser, is being rendered using the
W3C CSS Box Model.
Also in: Properties > Properties of the Global jQuery Object

jQuery.browser
Contains flags for the useragent, read from navigator.userAgent.
We recommend against using this property; please try to use
feature detection instead (see jQuery.support). jQuery.browser
may be moved to a plugin in a future release of jQuery.

jQuery.contains()
Check to see if a DOM element is a descendant of another DOM
element.
Also in: Data

jQuery.data()
Store arbitrary data associated with the specified element and/or
return the value that was set.
Also in: Data

jQuery.dequeue()
Execute the next function on the queue for the matched element.

jQuery.each()
A generic iterator function, which can be used to seamlessly
iterate over both objects and arrays. Arrays and array-like objects
with a length property (such as a function’s arguments object) are
iterated by numeric index, from 0 to length-1. Other objects are
iterated via their named properties.

jQuery.extend()
Merge the contents of two or more objects together into the first
object.

jQuery.globalEval()
Execute some JavaScript code globally.

jQuery.grep()
Finds the elements of an array which satisfy a filter function. The
original array is not affected.

jQuery.inArray()
Search for a specified value within an array and return its index (or
-1 if not found).

jQuery.isArray()
Determine whether the argument is an array.

jQuery.isEmptyObject()
Check to see if an object is empty (contains no enumerable
properties).

jQuery.isFunction()
Determine if the argument passed is a Javascript function object.

jQuery.isNumeric()
Determines whether its argument is a number.

jQuery.isPlainObject()
Check to see if an object is a plain object (created using “{}” or
“new Object”).

jQuery.isWindow()
Determine whether the argument is a window.

jQuery.isXMLDoc()
Check to see if a DOM node is within an XML document (or is an
XML document).

jQuery.makeArray()
Convert an array-like object into a true JavaScript array.

jQuery.map()
Translate all items in an array or object to new array of items.

jQuery.merge()
Merge the contents of two arrays together into the first array.

jQuery.noop()
An empty function.

jQuery.now()
Return a number representing the current time.

jQuery.parseHTML()
Parses a string into an array of DOM nodes.

jQuery.parseJSON()
Takes a well-formed JSON string and returns the resulting
JavaScript object.

jQuery.parseXML()
Parses a string into an XML document.
Also in: Events > Event Handler Attachment

jQuery.proxy()
Takes a function and returns a new one that will always have a
particular context.
Also in: Data

jQuery.queue()
Show or manipulate the queue of functions to be executed on the
matched element.
Also in: Data

jQuery.removeData()
Remove a previously-stored piece of data.
Also in: Properties > Properties of the Global jQuery Object

jQuery.support
A collection of properties that represent the presence of different
browser features or bugs. Primarily intended for jQuery’s internal
use; specific properties may be removed when they are no longer
needed internally to improve page startup performance.

jQuery.trim()
Remove the whitespace from the beginning and end of a string.

jQuery.type()
Determine the internal JavaScript [[Class]] of an object.

jQuery.unique()
Sorts an array of DOM elements, in place, with the duplicates
removed. Note that this only works on arrays of DOM elements,
not strings or numbers.
Also in: Effects > Custom | Data

.queue()
Show or manipulate the queue of functions to be executed on the
matched elements.
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Category: Version
Also in: Traversing > Miscellaneous Traversing

.add()
Add elements to the set of matched elements.
Also in: Traversing > Miscellaneous Traversing

.addBack()
Add the previous set of elements on the stack to the current set,
optionally filtered by a selector.
Also in: Attributes | Manipulation > Class Attribute | CSS

.addClass()
Adds the specified class(es) to each of the set of matched
elements.
Also in: Manipulation > DOM Insertion, Outside

.after()
Insert content, specified by the parameter, after each element in
the set of matched elements.
Also in: Ajax > Global Ajax Event Handlers

.ajaxComplete()
Register a handler to be called when Ajax requests complete. This
is an AjaxEvent.
Also in: Ajax > Global Ajax Event Handlers

.ajaxError()
Register a handler to be called when Ajax requests complete with
an error. This is an Ajax Event.
Also in: Ajax > Global Ajax Event Handlers

.ajaxSend()
Attach a function to be executed before an Ajax request is sent.
This is an Ajax Event.
Also in: Ajax > Global Ajax Event Handlers

.ajaxStart()
Register a handler to be called when the first Ajax request begins.
This is an Ajax Event.
Also in: Ajax > Global Ajax Event Handlers

.ajaxStop()
Register a handler to be called when all Ajax requests have
completed. This is an Ajax Event.
Also in: Ajax > Global Ajax Event Handlers

.ajaxSuccess()
Attach a function to be executed whenever an Ajax request
completes successfully. This is an Ajax Event.
Also in: Selectors > Basic

All Selector (“*”)
Selects all elements.
Also in: Traversing > Miscellaneous Traversing

.andSelf()
Add the previous set of elements on the stack to the current set.
Also in: Effects > Custom

.animate()
Perform a custom animation of a set of CSS properties.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:animated Selector
Select all elements that are in the progress of an animation at the
time the selector is run.
Also in: Manipulation > DOM Insertion, Inside

.append()
Insert content, specified by the parameter, to the end of each
element in the set of matched elements.
Also in: Manipulation > DOM Insertion, Inside

.appendTo()
Insert every element in the set of matched elements to the end of
the target.
Also in: Attributes | Manipulation > General Attributes

.attr()
Get the value of an attribute for the first element in the set of
matched elements or set one or more attributes for every matched
element.
Also in: Selectors > Attribute

Attribute Contains Prefix Selector
[name|="value"]
Selects elements that have the specified attribute with a value
either equal to a given string or starting with that string followed by
a hyphen (-).
Also in: Selectors > Attribute

Attribute Contains Selector [name*="value"]
Selects elements that have the specified attribute with a value
containing the a given substring.
Also in: Selectors > Attribute

Attribute Contains Word Selector
[name~="value"]
Selects elements that have the specified attribute with a value
containing a given word, delimited by spaces.
Also in: Selectors > Attribute

Attribute Ends With Selector
[name$="value"]
Selects elements that have the specified attribute with a value
ending exactly with a given string. The comparison is case
sensitive.
Also in: Selectors > Attribute

Attribute Equals Selector [name="value"]
Selects elements that have the specified attribute with a value
exactly equal to a certain value.
Also in: Selectors > Attribute | Selectors > jQuery Extensions

Attribute Not Equal Selector
[name!="value"]
Select elements that either don’t have the specified attribute, or do
have the specified attribute but not with a certain value.
Also in: Selectors > Attribute

Attribute Starts With Selector
[name^="value"]
Selects elements that have the specified attribute with a value
beginning exactly with a given string.
Also in: Manipulation > DOM Insertion, Outside

.before()
Insert content, specified by the parameter, before each element in
the set of matched elements.
Also in: Events > Event Handler Attachment

.bind()
Attach a handler to an event for the elements.
Also in: Events > Form Events | Forms

.blur()
Bind an event handler to the “blur” JavaScript event, or trigger that
event on an element.
Also in: Selectors > Form | Selectors > jQuery Extensions

:button Selector
Selects all button elements and elements of type button.
Also in: Callbacks Object

callbacks.add()
Add a callback or a collection of callbacks to a callback list.
Also in: Callbacks Object

callbacks.disable()
Disable a callback list from doing anything more.
Also in: Callbacks Object

callbacks.disabled()
Determine if the callbacks list has been disabled.
Also in: Callbacks Object

callbacks.empty()
Remove all of the callbacks from a list.
Also in: Callbacks Object

callbacks.fire()
Call all of the callbacks with the given arguments
Also in: Callbacks Object

callbacks.fired()
Determine if the callbacks have already been called at least once.
Also in: Callbacks Object

callbacks.fireWith()
Call all callbacks in a list with the given context and arguments.
Also in: Callbacks Object

callbacks.has()
Determine whether a supplied callback is in a list
Also in: Callbacks Object

callbacks.lock()
Lock a callback list in its current state.
Also in: Callbacks Object

callbacks.locked()
Determine if the callbacks list has been locked.
Also in: Callbacks Object

callbacks.remove()
Remove a callback or a collection of callbacks from a callback list.
Also in: Events > Form Events | Forms

.change()
Bind an event handler to the “change” JavaScript event, or trigger
that event on an element.
Also in: Selectors > Form | Selectors > jQuery Extensions

:checkbox Selector
Selects all elements of type checkbox.
Also in: Selectors > Form

:checked Selector
Matches all elements that are checked.
Also in: Selectors > Hierarchy

child”)" href="0D4EEA27BD.htm"
rel="bookmark">Child Selector (“parent >
child”)
Selects all direct child elements specified by “child” of elements
specified by “parent”.
Also in: Traversing > Tree Traversal

.children()
Get the children of each element in the set of matched elements,
optionally filtered by a selector.
Also in: Selectors > Basic

Class Selector (“.class”)
Selects all elements with the given class.
Also in: Effects > Custom | Data | Utilities

.clearQueue()
Remove from the queue all items that have not yet been run.
Also in: Events > Mouse Events

.click()
Bind an event handler to the “click” JavaScript event, or trigger
that event on an element.
Also in: Manipulation > Copying

.clone()
Create a deep copy of the set of matched elements.
Also in: Traversing > Tree Traversal

.closest()
For each element in the set, get the first element that matches the
selector by testing the element itself and traversing up through its
ancestors in the DOM tree.
Also in: Selectors > Content Filter

:contains() Selector
Select all elements that contain the specified text.
Also in: Traversing > Miscellaneous Traversing

.contents()
Get the children of each element in the set of matched elements,
including text and comment nodes.
Also in: Internals | Properties > Properties of jQuery Object Instances

.context
The DOM node context originally passed to jQuery(); if none was
passed then context will likely be the document.
Also in: CSS | Manipulation > Style Properties

.css()
Get the value of a style property for the first element in the set of
matched elements or set one or more CSS properties for every
matched element.
Also in: Data | Miscellaneous > Data Storage

.data()
Store arbitrary data associated with the matched elements or
return the value at the named data store for the first element in the
set of matched elements.
Also in: Events > Mouse Events

.dblclick()
Bind an event handler to the “dblclick” JavaScript event, or trigger
that event on an element.
Also in: Deferred Object

deferred.always()
Add handlers to be called when the Deferred object is either
resolved or rejected.
Also in: Deferred Object

deferred.done()
Add handlers to be called when the Deferred object is resolved.
Also in: Deferred Object

deferred.fail()
Add handlers to be called when the Deferred object is rejected.
Also in: Deferred Object

deferred.isRejected()
Determine whether a Deferred object has been rejected.
Also in: Deferred Object

deferred.isResolved()
Determine whether a Deferred object has been resolved.
Also in: Deferred Object

deferred.notify()
Call the progressCallbacks on a Deferred object with the given
args.
Also in: Deferred Object

deferred.notifyWith()
Call the progressCallbacks on a Deferred object with the given
context and args.
Also in: Deferred Object

deferred.pipe()
Utility method to filter and/or chain Deferreds.
Also in: Deferred Object

deferred.progress()
Add handlers to be called when the Deferred object generates
progress notifications.
Also in: Deferred Object

deferred.promise()
Return a Deferred’s Promise object.
Also in: Deferred Object

deferred.reject()
Reject a Deferred object and call any failCallbacks with the given
args.
Also in: Deferred Object

deferred.rejectWith()
Reject a Deferred object and call any failCallbacks with the given
context and args.
Also in: Deferred Object

deferred.resolve()
Resolve a Deferred object and call any doneCallbacks with the
given args.
Also in: Deferred Object

deferred.resolveWith()
Resolve a Deferred object and call any doneCallbacks with the
given context and args.
Also in: Deferred Object

deferred.state()
Determine the current state of a Deferred object.
Also in: Deferred Object

deferred.then()
Add handlers to be called when the Deferred object is resolved,
rejected, or still in progress.
Also in: Effects > Custom

.delay()
Set a timer to delay execution of subsequent items in the queue.
Also in: Events > Event Handler Attachment

.delegate()
Attach a handler to one or more events for all elements that match
the selector, now or in the future, based on a specific set of root
elements.
Also in: Effects > Custom | Data | Utilities

.dequeue()
Execute the next function on the queue for the matched elements.
Also in: Selectors > Hierarchy

Descendant Selector (“ancestor
descendant”)
Selects all elements that are descendants of a given ancestor.
Also in: Manipulation > DOM Removal

.detach()
Remove the set of matched elements from the DOM.
Also in: Events > Event Handler Attachment

.die()
Remove event handlers previously attached using .live() from the
elements.
Also in: Selectors > Form

:disabled Selector
Selects all elements that are disabled.
Also in: Miscellaneous > Collection Manipulation | Traversing

.each()
Iterate over a jQuery object, executing a function for each
matched element.
Also in: Selectors > Basic

Element Selector (“element”)
Selects all elements with the given tag name.
Also in: Manipulation > DOM Removal

.empty()
Remove all child nodes of the set of matched elements from the
DOM.
Also in: Selectors > Content Filter

:empty Selector
Select all elements that have no children (including text nodes).
Also in: Selectors > Form

:enabled Selector
Selects all elements that are enabled.
Also in: Traversing > Miscellaneous Traversing

.end()
End the most recent filtering operation in the current chain and
return the set of matched elements to its previous state.
Also in: Traversing > Filtering

.eq()
Reduce the set of matched elements to the one at the specified
index.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:eq() Selector
Select the element at index n within the matched set.
Also in: Events > Browser Events

.error()
Bind an event handler to the “error” JavaScript event.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:even Selector
Selects even elements, zero-indexed. See also odd.
Also in: Events > Event Object

event.currentTarget
The current DOM element within the event bubbling phase.
Also in: Events > Event Object

event.data
An optional object of data passed to an event method when the
current executing handler is bound.
Also in: Events > Event Object | Events

event.delegateTarget
The element where the currently-called jQuery event handler was
attached.
Also in: Events > Event Object

event.isDefaultPrevented()
Returns whether event.preventDefault() was ever called on this
event object.
Also in: Events > Event Object

event.isImmediatePropagationStopped()
Returns whether event.stopImmediatePropagation() was ever
called on this event object.
Also in: Events > Event Object

event.isPropagationStopped()
Returns whether event.stopPropagation() was ever called on this
event object.
Also in: Events > Event Object

event.metaKey
Indicates whether the META key was pressed when the event
fired.
Also in: Events > Event Object

event.namespace
The namespace specified when the event was triggered.
Also in: Events > Event Object

event.pageX
The mouse position relative to the left edge of the document.
Also in: Events > Event Object

event.pageY
The mouse position relative to the top edge of the document.
Also in: Events > Event Object

event.preventDefault()
If this method is called, the default action of the event will not be
triggered.
Also in: Events > Event Object

event.relatedTarget
The other DOM element involved in the event, if any.
Also in: Events > Event Object

event.result
The last value returned by an event handler that was triggered by
this event, unless the value was undefined.
Also in: Events > Event Object

event.stopImmediatePropagation()
Keeps the rest of the handlers from being executed and prevents
the event from bubbling up the DOM tree.
Also in: Events > Event Object

event.stopPropagation()
Prevents the event from bubbling up the DOM tree, preventing
any parent handlers from being notified of the event.
Also in: Events > Event Object

event.target
The DOM element that initiated the event.
Also in: Events > Event Object

event.timeStamp
The difference in milliseconds between the time the browser
created the event and January 1, 1970.
Also in: Events > Event Object

event.type
Describes the nature of the event.
Also in: Events > Event Object

event.which
For key or mouse events, this property indicates the specific key
or button that was pressed.
Also in: Effects > Fading

.fadeIn()
Display the matched elements by fading them to opaque.
Also in: Effects > Fading

.fadeOut()
Hide the matched elements by fading them to transparent.
Also in: Effects > Fading

.fadeTo()
Adjust the opacity of the matched elements.
Also in: Effects | Effects > Fading

.fadeToggle()
Display or hide the matched elements by animating their opacity.
Also in: Selectors > Form | Selectors > jQuery Extensions

:file Selector
Selects all elements of type file.
Also in: Traversing > Filtering

.filter()
Reduce the set of matched elements to those that match the
selector or pass the function’s test.
Also in: Traversing > Tree Traversal

.find()
Get the descendants of each element in the current set of
matched elements, filtered by a selector, jQuery object, or
element.
Also in: Effects > Custom

.finish()
Stop the currently-running animation, remove all queued
animations, and complete all animations for the matched
elements.
Also in: Traversing > Filtering

.first()
Reduce the set of matched elements to the first in the set.
Also in: Selectors > Child Filter

:first-child Selector
Selects all elements that are the first child of their parent.
Also in: Selectors > Child Filter

:first-of-type Selector
Selects all elements that are the first among siblings of the same
element name.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:first Selector
Selects the first matched element.
Also in: Events > Form Events | Forms

.focus()
Bind an event handler to the “focus” JavaScript event, or trigger
that event on an element.
Also in: Selectors > Basic Filter | Selectors > Form

:focus Selector
Selects element if it is currently focused.
Also in: Events > Keyboard Events | Events > Mouse Events

.focusin()
Bind an event handler to the “focusin” event.
Also in: Events > Keyboard Events | Events > Mouse Events

.focusout()
Bind an event handler to the “focusout” JavaScript event.
Also in: Miscellaneous > DOM Element Methods

.get()
Retrieve the DOM elements matched by the jQuery object.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:gt() Selector
Select all elements at an index greater than index within the
matched set.
Also in: Traversing > Filtering

.has()
Reduce the set of matched elements to those that have a
descendant that matches the selector or DOM element.
Also in: Selectors > Attribute

Has Attribute Selector [name]
Selects elements that have the specified attribute, with any value.
Also in: Selectors > Content Filter | Selectors > jQuery Extensions

:has() Selector
Selects elements which contain at least one element that matches
the specified selector.
Also in: Attributes | Manipulation > Class Attribute | CSS

.hasClass()
Determine whether any of the matched elements are assigned the
given class.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:header Selector
Selects all elements that are headers, like h1, h2, h3 and so on.
Also in: CSS | Dimensions | Manipulation > Style Properties

.height()
Get the current computed height for the first element in the set of
matched elements or set the height of every matched element.
Also in: Selectors > jQuery Extensions | Selectors > Visibility Filter

:hidden Selector
Selects all elements that are hidden.
Also in: Effects > Basics

.hide()
Hide the matched elements.
Also in: Events > Mouse Events

.hover()
Bind one or two handlers to the matched elements, to be executed
when the mouse pointer enters and leaves the elements.
Also in: Attributes | Manipulation > DOM Insertion, Inside

.html()
Get the HTML contents of the first element in the set of matched
elements or set the HTML contents of every matched element.
Also in: Selectors > Basic

ID Selector (“#id”)
Selects a single element with the given id attribute.
Also in: Selectors > Form | Selectors > jQuery Extensions

:image Selector
Selects all elements of type image.
Also in: Miscellaneous > DOM Element Methods

.index()
Search for a given element from among the matched elements.
Also in: CSS | Dimensions | Manipulation > Style Properties

.innerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding but not border.
Also in: CSS | Dimensions | Manipulation > Style Properties

.innerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding but not border.
Also in: Selectors > Form | Selectors > jQuery Extensions

:input Selector
Selects all input, textarea, select and button elements.
Also in: Manipulation > DOM Insertion, Outside

.insertAfter()
Insert every element in the set of matched elements after the
target.
Also in: Manipulation > DOM Insertion, Outside

.insertBefore()
Insert every element in the set of matched elements before the
target.
Also in: Traversing > Filtering

.is()
Check the current matched set of elements against a selector,
element, or jQuery object and return true if at least one of these
elements matches the given arguments.
Also in: Core

jQuery()
Return a collection of matched elements either found in the DOM
based on passed argument(s) or created by passing an HTML
string.
Also in: Ajax > Low-Level Interface

jQuery.ajax()
Perform an asynchronous HTTP (Ajax) request.
Also in: Ajax > Low-Level Interface

jQuery.ajaxPrefilter()
Handle custom Ajax options or modify existing options before
each request is sent and before they are processed by $.ajax().
Also in: Ajax > Low-Level Interface

jQuery.ajaxSetup()
Set default values for future Ajax requests.
Also in: Ajax > Low-Level Interface

jQuery.ajaxTransport()
Creates an object that handles the actual transmission of Ajax
data.
Also in: Utilities

jQuery.boxModel
Deprecated in jQuery 1.3 (see jQuery.support). States if the
current page, in the user’s browser, is being rendered using the
W3C CSS Box Model.
Also in: Properties > Properties of the Global jQuery Object | Utilities

jQuery.browser
Contains flags for the useragent, read from navigator.userAgent.
We recommend against using this property; please try to use
feature detection instead (see jQuery.support). jQuery.browser
may be moved to a plugin in a future release of jQuery.
Also in: Callbacks Object

jQuery.Callbacks()
A multi-purpose callbacks list object that provides a powerful way
to manage callback lists.
Also in: Utilities

jQuery.contains()
Check to see if a DOM element is a descendant of another DOM
element.
Also in: CSS

jQuery.cssHooks
Hook directly into jQuery to override how particular CSS
properties are retrieved or set, normalize CSS property naming, or
create custom properties.
Also in: Data | Utilities

jQuery.data()
Store arbitrary data associated with the specified element and/or
return the value that was set.
Also in: Deferred Object

jQuery.Deferred()
A constructor function that returns a chainable utility object with
methods to register multiple callbacks into callback queues,
invoke callback queues, and relay the success or failure state of
any synchronous or asynchronous function.
Also in: Data | Utilities

jQuery.dequeue()
Execute the next function on the queue for the matched element.
Also in: Utilities

jQuery.each()
A generic iterator function, which can be used to seamlessly
iterate over both objects and arrays. Arrays and array-like objects
with a length property (such as a function’s arguments object) are
iterated by numeric index, from 0 to length-1. Other objects are
iterated via their named properties.
Also in: Internals

jQuery.error()
Takes a string and throws an exception containing it.
Also in: Utilities

jQuery.extend()
Merge the contents of two or more objects together into the first
object.
Also in: Effects > Custom | Properties > Properties of the Global jQuery Object

jQuery.fx.interval
The rate (in milliseconds) at which animations fire.
Also in: Effects > Custom | Properties > Properties of the Global jQuery Object

jQuery.fx.off
Globally disable all animations.
Also in: Ajax > Shorthand Methods

jQuery.get()
Load data from the server using a HTTP GET request.
Also in: Ajax > Shorthand Methods

jQuery.getJSON()
Load JSON-encoded data from the server using a GET HTTP
request.
Also in: Ajax > Shorthand Methods

jQuery.getScript()
Load a JavaScript file from the server using a GET HTTP request,
then execute it.
Also in: Utilities

jQuery.globalEval()
Execute some JavaScript code globally.
Also in: Utilities

jQuery.grep()
Finds the elements of an array which satisfy a filter function. The
original array is not affected.
Also in: Data

jQuery.hasData()
Determine whether an element has any jQuery data associated
with it.
Also in: Core

jQuery.holdReady()
Holds or releases the execution of jQuery’s ready event.
Also in: Utilities

jQuery.inArray()
Search for a specified value within an array and return its index (or
-1 if not found).
Also in: Utilities

jQuery.isArray()
Determine whether the argument is an array.
Also in: Utilities

jQuery.isEmptyObject()
Check to see if an object is empty (contains no enumerable
properties).
Also in: Utilities

jQuery.isFunction()
Determine if the argument passed is a Javascript function object.
Also in: Utilities

jQuery.isNumeric()
Determines whether its argument is a number.
Also in: Utilities

jQuery.isPlainObject()
Check to see if an object is a plain object (created using “{}” or
“new Object”).
Also in: Utilities

jQuery.isWindow()
Determine whether the argument is a window.
Also in: Utilities

jQuery.isXMLDoc()
Check to see if a DOM node is within an XML document (or is an
XML document).
Also in: Utilities

jQuery.makeArray()
Convert an array-like object into a true JavaScript array.
Also in: Utilities

jQuery.map()
Translate all items in an array or object to new array of items.
Also in: Utilities

jQuery.merge()
Merge the contents of two arrays together into the first array.
Also in: Core | Miscellaneous > Setup Methods

jQuery.noConflict()
Relinquish jQuery’s control of the $ variable.
Also in: Utilities

jQuery.noop()
An empty function.
Also in: Utilities

jQuery.now()
Return a number representing the current time.
Also in: Miscellaneous > Collection Manipulation | Forms | Ajax > Helper Functions

jQuery.param()
Create a serialized representation of an array or object, suitable
for use in a URL query string or Ajax request.
Also in: Utilities

jQuery.parseHTML()
Parses a string into an array of DOM nodes.
Also in: Utilities

jQuery.parseJSON()
Takes a well-formed JSON string and returns the resulting
JavaScript object.
Also in: Utilities

jQuery.parseXML()
Parses a string into an XML document.
Also in: Ajax > Shorthand Methods

jQuery.post()
Load data from the server using a HTTP POST request.
Also in: Events > Event Handler Attachment | Utilities

jQuery.proxy()
Takes a function and returns a new one that will always have a
particular context.
Also in: Data | Utilities

jQuery.queue()
Show or manipulate the queue of functions to be executed on the
matched element.
Also in: Data | Utilities

jQuery.removeData()
Remove a previously-stored piece of data.
Also in: Core

jQuery.sub()
Creates a new copy of jQuery whose properties and methods can
be modified without affecting the original jQuery object.
Also in: Properties > Properties of the Global jQuery Object | Utilities

jQuery.support
A collection of properties that represent the presence of different
browser features or bugs. Primarily intended for jQuery’s internal
use; specific properties may be removed when they are no longer
needed internally to improve page startup performance.
Also in: Utilities

jQuery.trim()
Remove the whitespace from the beginning and end of a string.
Also in: Utilities

jQuery.type()
Determine the internal JavaScript [[Class]] of an object.
Also in: Utilities

jQuery.unique()
Sorts an array of DOM elements, in place, with the duplicates
removed. Note that this only works on arrays of DOM elements,
not strings or numbers.
Also in: Core | Deferred Object

jQuery.when()
Provides a way to execute callback functions based on one or
more objects, usually Deferred objects that represent
asynchronous events.
Also in: Events > Keyboard Events

.keydown()
Bind an event handler to the “keydown” JavaScript event, or
trigger that event on an element.
Also in: Events > Keyboard Events

.keypress()
Bind an event handler to the “keypress” JavaScript event, or
trigger that event on an element.
Also in: Events > Keyboard Events

.keyup()
Bind an event handler to the “keyup” JavaScript event, or trigger
that event on an element.
Also in: Selectors > Basic Filter

:lang Selector
Selects all elements of the specified language.
Also in: Traversing > Filtering

.last()
Reduce the set of matched elements to the final one in the set.
Also in: Selectors > Child Filter

:last-child Selector
Selects all elements that are the last child of their parent.
Also in: Selectors > Child Filter

:last-of-type Selector
Selects all elements that are the last among siblings of the same
element name.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:last Selector
Selects the last matched element.
Also in: Properties > Properties of jQuery Object Instances

.length
The number of elements in the jQuery object.
Also in: Events > Event Handler Attachment

.live()
Attach an event handler for all elements which match the current
selector, now and in the future.
Also in: Ajax > Shorthand Methods

.load()
Load data from the server and place the returned HTML into the
matched element.
Also in: Events > Document Loading

.load()
Bind an event handler to the “load” JavaScript event.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:lt() Selector
Select all elements at an index less than index within the matched
set.
Also in: Traversing > Filtering

.map()
Pass each element in the current matched set through a function,
producing a new jQuery object containing the return values.
Also in: Events > Mouse Events

.mousedown()
Bind an event handler to the “mousedown” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseenter()
Bind an event handler to be fired when the mouse enters an
element, or trigger that handler on an element.
Also in: Events > Mouse Events

.mouseleave()
Bind an event handler to be fired when the mouse leaves an
element, or trigger that handler on an element.
Also in: Events > Mouse Events

.mousemove()
Bind an event handler to the “mousemove” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseout()
Bind an event handler to the “mouseout” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseover()
Bind an event handler to the “mouseover” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseup()
Bind an event handler to the “mouseup” JavaScript event, or
trigger that event on an element.
Also in: Selectors > Attribute

Multiple Attribute Selector [name="value"]
[name2="value2"]
Matches elements that match all of the specified attribute filters.
Also in: Selectors > Basic

Multiple Selector (“selector1, selector2,
selectorN”)
Selects the combined results of all the specified selectors.
Also in: Traversing > Tree Traversal

.next()
Get the immediately following sibling of each element in the set of
matched elements. If a selector is provided, it retrieves the next
sibling only if it matches that selector.
Also in: Selectors > Hierarchy

Next Adjacent Selector (“prev + next”)
Selects all next elements matching “next” that are immediately
preceded by a sibling “prev”.
Also in: Selectors > Hierarchy

Next Siblings Selector (“prev ~ siblings”)
Selects all sibling elements that follow after the “prev” element,
have the same parent, and match the filtering “siblings” selector.
Also in: Traversing > Tree Traversal

.nextAll()
Get all following siblings of each element in the set of matched
elements, optionally filtered by a selector.
Also in: Traversing > Tree Traversal

.nextUntil()
Get all following siblings of each element up to but not including
the element matched by the selector, DOM node, or jQuery object
passed.
Also in: Traversing > Filtering | Traversing > Miscellaneous Traversing

.not()
Remove elements from the set of matched elements.
Also in: Selectors > Basic Filter

:not() Selector
Selects all elements that do not match the given selector.
Also in: Selectors > Child Filter

:nth-child() Selector
Selects all elements that are the nth-child of their parent.
Also in: Selectors > Child Filter

:nth-last-child() Selector
Selects all elements that are the nth-child of their parent, counting
from the last element to the first.
Also in: Selectors > Child Filter

:nth-last-of-type() Selector
Selects all elements that are the nth-child of their parent, counting
from the last element to the first.
Also in: Selectors > Child Filter

:nth-of-type() Selector
Selects all elements that are the nth child of their parent in relation
to siblings with the same element name.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:odd Selector
Selects odd elements, zero-indexed. See also even.
Also in: Events > Event Handler Attachment

.off()
Remove an event handler.
Also in: CSS | Offset | Manipulation > Style Properties

.offset()
Get the current coordinates of the first element, or set the
coordinates of every element, in the set of matched elements,
relative to the document.
Also in: Events > Event Handler Attachment

.on()
Attach an event handler function for one or more events to the
selected elements.
Also in: Events > Event Handler Attachment

.one()
Attach a handler to an event for the elements. The handler is
executed at most once per element.
Also in: Selectors > Child Filter

:only-child Selector
Selects all elements that are the only child of their parent.
Also in: Selectors > Child Filter

:only-of-type Selector
Selects all elements that have no siblings with the same element
name.
Also in: CSS | Dimensions | Manipulation > Style Properties

.outerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding, border, and optionally
margin. Returns an integer (without “px”) representation of the
value or null if called on an empty set of elements.
Also in: CSS | Dimensions | Manipulation > Style Properties

.outerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding and border.
Also in: Traversing > Tree Traversal

.parent()
Get the parent of each element in the current set of matched
elements, optionally filtered by a selector.
Also in: Selectors > Content Filter | Selectors > jQuery Extensions

:parent Selector
Select all elements that that have at least one child node (either
an element or text).
Also in: Traversing > Tree Traversal

.parents()
Get the ancestors of each element in the current set of matched
elements, optionally filtered by a selector.
Also in: Traversing > Tree Traversal

.parentsUntil()
Get the ancestors of each element in the current set of matched
elements, up to but not including the element matched by the
selector, DOM node, or jQuery object.
Also in: Selectors > Form | Selectors > jQuery Extensions

:password Selector
Selects all elements of type password.
Also in: CSS | Offset | Manipulation > Style Properties

.position()
Get the current coordinates of the first element in the set of
matched elements, relative to the offset parent.
Also in: Manipulation > DOM Insertion, Inside

.prepend()
Insert content, specified by the parameter, to the beginning of
each element in the set of matched elements.
Also in: Manipulation > DOM Insertion, Inside

.prependTo()
Insert every element in the set of matched elements to the
beginning of the target.
Also in: Traversing > Tree Traversal

.prev()
Get the immediately preceding sibling of each element in the set
of matched elements, optionally filtered by a selector.
Also in: Traversing > Tree Traversal

.prevAll()
Get all preceding siblings of each element in the set of matched
elements, optionally filtered by a selector.
Also in: Traversing > Tree Traversal

.prevUntil()
Get all preceding siblings of each element up to but not including
the element matched by the selector, DOM node, or jQuery object.
Also in: Deferred Object

.promise()
Return a Promise object to observe when all actions of a certain
type bound to the collection, queued or not, have finished.
Also in: Attributes | Manipulation > General Attributes

.prop()
Get the value of a property for the first element in the set of
matched elements or set one or more properties for every
matched element.
Also in: Internals

.pushStack()
Add a collection of DOM elements onto the jQuery stack.
Also in: Effects > Custom | Data | Utilities

.queue()
Show or manipulate the queue of functions to be executed on the
matched elements.
Also in: Selectors > Form | Selectors > jQuery Extensions

:radio Selector
Selects all elements of type radio.
Also in: Events > Document Loading

.ready()
Specify a function to execute when the DOM is fully loaded.
Also in: Manipulation > DOM Removal

.remove()
Remove the set of matched elements from the DOM.
Also in: Attributes | Manipulation > General Attributes

.removeAttr()
Remove an attribute from each element in the set of matched
elements.
Also in: Attributes | Manipulation > Class Attribute | CSS

.removeClass()
Remove a single class, multiple classes, or all classes from each
element in the set of matched elements.
Also in: Data | Miscellaneous > Data Storage

.removeData()
Remove a previously-stored piece of data.
Also in: Attributes | Manipulation > General Attributes

.removeProp()
Remove a property for the set of matched elements.
Also in: Manipulation > DOM Replacement

.replaceAll()
Replace each target element with the set of matched elements.
Also in: Manipulation > DOM Replacement

.replaceWith()
Replace each element in the set of matched elements with the
provided new content and return the set of elements that was
removed.
Also in: Selectors > Form | Selectors > jQuery Extensions

:reset Selector
Selects all elements of type reset.
Also in: Events > Browser Events

.resize()
Bind an event handler to the “resize” JavaScript event, or trigger
that event on an element.
Also in: Selectors > Basic Filter

:root Selector
Selects the element that is the root of the document.
Also in: Events > Browser Events

.scroll()
Bind an event handler to the “scroll” JavaScript event, or trigger
that event on an element.
Also in: CSS | Offset | Manipulation > Style Properties

.scrollLeft()
Get the current horizontal position of the scroll bar for the first
element in the set of matched elements or set the horizontal
position of the scroll bar for every matched element.
Also in: CSS | Offset | Manipulation > Style Properties

.scrollTop()
Get the current vertical position of the scroll bar for the first
element in the set of matched elements or set the vertical position
of the scroll bar for every matched element.
Also in: Events > Form Events | Forms

.select()
Bind an event handler to the “select” JavaScript event, or trigger
that event on an element.
Also in: Selectors > Form | Selectors > jQuery Extensions

:selected Selector
Selects all elements that are selected.
Also in: Forms | Ajax > Helper Functions

.serialize()
Encode a set of form elements as a string for submission.
Also in: Forms | Ajax > Helper Functions

.serializeArray()
Encode a set of form elements as an array of names and values.
Also in: Effects > Basics

.show()
Display the matched elements.
Also in: Traversing > Tree Traversal

.siblings()
Get the siblings of each element in the set of matched elements,
optionally filtered by a selector.
Also in: Miscellaneous > DOM Element Methods

.size()
Return the number of elements in the jQuery object.
Also in: Traversing > Filtering

.slice()
Reduce the set of matched elements to a subset specified by a
range of indices.
Also in: Effects > Sliding

.slideDown()
Display the matched elements with a sliding motion.
Also in: Effects > Sliding

.slideToggle()
Display or hide the matched elements with a sliding motion.
Also in: Effects > Sliding

.slideUp()
Hide the matched elements with a sliding motion.
Also in: Effects > Custom

.stop()
Stop the currently-running animation on the matched elements.
Also in: Events > Form Events | Forms

.submit()
Bind an event handler to the “submit” JavaScript event, or trigger
that event on an element.
Also in: Selectors > Form | Selectors > jQuery Extensions

:submit Selector
Selects all elements of type submit.
Also in: Selectors > Basic Filter

:target Selector
Selects the target element indicated by the fragment identifier of
the document’s URI.
Also in: Manipulation > DOM Insertion, Inside

.text()
Get the combined text contents of each element in the set of
matched elements, including their descendants, or set the text
contents of the matched elements.
Also in: Selectors > Form | Selectors > jQuery Extensions

:text Selector
Selects all elements of type text.
Also in: Miscellaneous > DOM Element Methods

.toArray()
Retrieve all the DOM elements contained in the jQuery set, as an
array.
Also in: Effects > Basics

.toggle()
Display or hide the matched elements.
Also in: Deprecated > Deprecated 1.8 | Events > Mouse Events

.toggle()
Bind two or more handlers to the matched elements, to be
executed on alternate clicks.
Also in: Attributes | Manipulation > Class Attribute | CSS

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument.
Also in: Events > Event Handler Attachment

.trigger()
Execute all handlers and behaviors attached to the matched
elements for the given event type.
Also in: Events > Event Handler Attachment

.triggerHandler()
Execute all handlers attached to an element for an event.
Also in: Events > Event Handler Attachment

.unbind()
Remove a previously-attached event handler from the elements.
Also in: Events > Event Handler Attachment

.undelegate()
Remove a handler from the event for all elements which match the
current selector, based upon a specific set of root elements.
Also in: Events > Document Loading

.unload()
Bind an event handler to the “unload” JavaScript event.
Also in: Manipulation > DOM Insertion, Around | Manipulation > DOM Removal

.unwrap()
Remove the parents of the set of matched elements from the
DOM, leaving the matched elements in their place.
Also in: Attributes | Forms | Manipulation > General Attributes

.val()
Get the current value of the first element in the set of matched
elements or set the value of every matched element.
Also in: Selectors > jQuery Extensions | Selectors > Visibility Filter

:visible Selector
Selects all elements that are visible.
Also in: CSS | Dimensions | Manipulation > Style Properties

.width()
Get the current computed width for the first element in the set of
matched elements or set the width of every matched element.
Also in: Manipulation > DOM Insertion, Around

.wrap()
Wrap an HTML structure around each element in the set of
matched elements.
Also in: Manipulation > DOM Insertion, Around

.wrapAll()
Wrap an HTML structure around all elements in the set of
matched elements.
Also in: Manipulation > DOM Insertion, Around

.wrapInner()
Wrap an HTML structure around the content of each element in
the set of matched elements.
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Category: Version 1.0
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
jQuery 1.0 Release Notes.
Also in: Traversing > Miscellaneous Traversing

.add()
Add elements to the set of matched elements.
Also in: Attributes | Manipulation > Class Attribute | CSS

.addClass()
Adds the specified class(es) to each of the set of matched
elements.
Also in: Manipulation > DOM Insertion, Outside

.after()
Insert content, specified by the parameter, after each element in
the set of matched elements.
Also in: Ajax > Global Ajax Event Handlers

.ajaxComplete()
Register a handler to be called when Ajax requests complete. This
is an AjaxEvent.
Also in: Ajax > Global Ajax Event Handlers

.ajaxError()
Register a handler to be called when Ajax requests complete with
an error. This is an Ajax Event.
Also in: Ajax > Global Ajax Event Handlers

.ajaxSend()
Attach a function to be executed before an Ajax request is sent.
This is an Ajax Event.
Also in: Ajax > Global Ajax Event Handlers

.ajaxStart()
Register a handler to be called when the first Ajax request begins.
This is an Ajax Event.
Also in: Ajax > Global Ajax Event Handlers

.ajaxStop()
Register a handler to be called when all Ajax requests have
completed. This is an Ajax Event.
Also in: Ajax > Global Ajax Event Handlers

.ajaxSuccess()
Attach a function to be executed whenever an Ajax request
completes successfully. This is an Ajax Event.
Also in: Selectors > Basic

All Selector (“*”)
Selects all elements.
Also in: Effects > Custom

.animate()
Perform a custom animation of a set of CSS properties.
Also in: Manipulation > DOM Insertion, Inside

.append()
Insert content, specified by the parameter, to the end of each
element in the set of matched elements.
Also in: Manipulation > DOM Insertion, Inside

.appendTo()
Insert every element in the set of matched elements to the end of
the target.
Also in: Attributes | Manipulation > General Attributes

.attr()
Get the value of an attribute for the first element in the set of
matched elements or set one or more attributes for every matched
element.
Also in: Selectors > Attribute

Attribute Contains Prefix Selector
[name|="value"]
Selects elements that have the specified attribute with a value
either equal to a given string or starting with that string followed by
a hyphen (-).
Also in: Selectors > Attribute

Attribute Contains Selector [name*="value"]
Selects elements that have the specified attribute with a value
containing the a given substring.
Also in: Selectors > Attribute

Attribute Contains Word Selector
[name~="value"]
Selects elements that have the specified attribute with a value
containing a given word, delimited by spaces.
Also in: Selectors > Attribute

Attribute Ends With Selector
[name$="value"]
Selects elements that have the specified attribute with a value
ending exactly with a given string. The comparison is case
sensitive.
Also in: Selectors > Attribute

Attribute Equals Selector [name="value"]
Selects elements that have the specified attribute with a value
exactly equal to a certain value.
Also in: Selectors > Attribute | Selectors > jQuery Extensions

Attribute Not Equal Selector
[name!="value"]
Select elements that either don’t have the specified attribute, or do
have the specified attribute but not with a certain value.
Also in: Selectors > Attribute

Attribute Starts With Selector
[name^="value"]
Selects elements that have the specified attribute with a value
beginning exactly with a given string.
Also in: Manipulation > DOM Insertion, Outside

.before()
Insert content, specified by the parameter, before each element in
the set of matched elements.
Also in: Events > Event Handler Attachment

.bind()
Attach a handler to an event for the elements.
Also in: Events > Form Events | Forms

.blur()
Bind an event handler to the “blur” JavaScript event, or trigger that
event on an element.
Also in: Selectors > Form | Selectors > jQuery Extensions

:button Selector
Selects all button elements and elements of type button.
Also in: Events > Form Events | Forms

.change()
Bind an event handler to the “change” JavaScript event, or trigger
that event on an element.
Also in: Selectors > Form | Selectors > jQuery Extensions

:checkbox Selector
Selects all elements of type checkbox.
Also in: Selectors > Form

:checked Selector
Matches all elements that are checked.
Also in: Selectors > Hierarchy

child”)" href="0D4EEA27BD.htm"
rel="bookmark">Child Selector (“parent >
child”)
Selects all direct child elements specified by “child” of elements
specified by “parent”.
Also in: Traversing > Tree Traversal

.children()
Get the children of each element in the set of matched elements,
optionally filtered by a selector.
Also in: Selectors > Basic

Class Selector (“.class”)
Selects all elements with the given class.
Also in: Events > Mouse Events

.click()
Bind an event handler to the “click” JavaScript event, or trigger
that event on an element.
Also in: Manipulation > Copying

.clone()
Create a deep copy of the set of matched elements.
Also in: CSS | Manipulation > Style Properties

.css()
Get the value of a style property for the first element in the set of
matched elements or set one or more CSS properties for every
matched element.
Also in: Events > Mouse Events

.dblclick()
Bind an event handler to the “dblclick” JavaScript event, or trigger
that event on an element.
Also in: Selectors > Hierarchy

Descendant Selector (“ancestor
descendant”)
Selects all elements that are descendants of a given ancestor.
Also in: Selectors > Form

:disabled Selector
Selects all elements that are disabled.
Also in: Miscellaneous > Collection Manipulation | Traversing

.each()
Iterate over a jQuery object, executing a function for each
matched element.
Also in: Selectors > Basic

Element Selector (“element”)
Selects all elements with the given tag name.
Also in: Manipulation > DOM Removal

.empty()
Remove all child nodes of the set of matched elements from the
DOM.
Also in: Selectors > Content Filter

:empty Selector
Select all elements that have no children (including text nodes).
Also in: Selectors > Form

:enabled Selector
Selects all elements that are enabled.
Also in: Traversing > Miscellaneous Traversing

.end()
End the most recent filtering operation in the current chain and
return the set of matched elements to its previous state.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:eq() Selector
Select the element at index n within the matched set.
Also in: Events > Browser Events

.error()
Bind an event handler to the “error” JavaScript event.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:even Selector
Selects even elements, zero-indexed. See also odd.
Also in: Events > Event Object

event.preventDefault()
If this method is called, the default action of the event will not be
triggered.
Also in: Events > Event Object

event.stopPropagation()
Prevents the event from bubbling up the DOM tree, preventing
any parent handlers from being notified of the event.
Also in: Events > Event Object

event.target
The DOM element that initiated the event.
Also in: Events > Event Object

event.type
Describes the nature of the event.
Also in: Effects > Fading

.fadeIn()
Display the matched elements by fading them to opaque.
Also in: Effects > Fading

.fadeOut()
Hide the matched elements by fading them to transparent.
Also in: Effects > Fading

.fadeTo()
Adjust the opacity of the matched elements.
Also in: Selectors > Form | Selectors > jQuery Extensions

:file Selector
Selects all elements of type file.
Also in: Traversing > Filtering

.filter()
Reduce the set of matched elements to those that match the
selector or pass the function’s test.
Also in: Traversing > Tree Traversal

.find()
Get the descendants of each element in the current set of
matched elements, filtered by a selector, jQuery object, or
element.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:first Selector
Selects the first matched element.
Also in: Events > Form Events | Forms

.focus()
Bind an event handler to the “focus” JavaScript event, or trigger
that event on an element.
Also in: Miscellaneous > DOM Element Methods

.get()
Retrieve the DOM elements matched by the jQuery object.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:gt() Selector
Select all elements at an index greater than index within the
matched set.
Also in: Selectors > Attribute

Has Attribute Selector [name]
Selects elements that have the specified attribute, with any value.
Also in: CSS | Dimensions | Manipulation > Style Properties

.height()
Get the current computed height for the first element in the set of
matched elements or set the height of every matched element.
Also in: Selectors > jQuery Extensions | Selectors > Visibility Filter

:hidden Selector
Selects all elements that are hidden.
Also in: Effects > Basics

.hide()
Hide the matched elements.
Also in: Events > Mouse Events

.hover()
Bind one or two handlers to the matched elements, to be executed
when the mouse pointer enters and leaves the elements.
Also in: Attributes | Manipulation > DOM Insertion, Inside

.html()
Get the HTML contents of the first element in the set of matched
elements or set the HTML contents of every matched element.
Also in: Selectors > Basic

ID Selector (“#id”)
Selects a single element with the given id attribute.
Also in: Selectors > Form | Selectors > jQuery Extensions

:image Selector
Selects all elements of type image.
Also in: Miscellaneous > DOM Element Methods

.index()
Search for a given element from among the matched elements.
Also in: Selectors > Form | Selectors > jQuery Extensions

:input Selector
Selects all input, textarea, select and button elements.
Also in: Manipulation > DOM Insertion, Outside

.insertAfter()
Insert every element in the set of matched elements after the
target.
Also in: Manipulation > DOM Insertion, Outside

.insertBefore()
Insert every element in the set of matched elements before the
target.
Also in: Traversing > Filtering

.is()
Check the current matched set of elements against a selector,
element, or jQuery object and return true if at least one of these
elements matches the given arguments.
Also in: Core

jQuery()
Return a collection of matched elements either found in the DOM
based on passed argument(s) or created by passing an HTML
string.
Also in: Ajax > Low-Level Interface

jQuery.ajax()
Perform an asynchronous HTTP (Ajax) request.
Also in: Utilities

jQuery.boxModel
Deprecated in jQuery 1.3 (see jQuery.support). States if the
current page, in the user’s browser, is being rendered using the
W3C CSS Box Model.
Also in: Properties > Properties of the Global jQuery Object | Utilities

jQuery.browser
Contains flags for the useragent, read from navigator.userAgent.
We recommend against using this property; please try to use
feature detection instead (see jQuery.support). jQuery.browser
may be moved to a plugin in a future release of jQuery.
Also in: Utilities

jQuery.each()
A generic iterator function, which can be used to seamlessly
iterate over both objects and arrays. Arrays and array-like objects
with a length property (such as a function’s arguments object) are
iterated by numeric index, from 0 to length-1. Other objects are
iterated via their named properties.
Also in: Utilities

jQuery.extend()
Merge the contents of two or more objects together into the first
object.
Also in: Ajax > Shorthand Methods

jQuery.get()
Load data from the server using a HTTP GET request.
Also in: Ajax > Shorthand Methods

jQuery.getJSON()
Load JSON-encoded data from the server using a GET HTTP
request.
Also in: Ajax > Shorthand Methods

jQuery.getScript()
Load a JavaScript file from the server using a GET HTTP request,
then execute it.
Also in: Utilities

jQuery.grep()
Finds the elements of an array which satisfy a filter function. The
original array is not affected.
Also in: Utilities

jQuery.map()
Translate all items in an array or object to new array of items.
Also in: Utilities

jQuery.merge()
Merge the contents of two arrays together into the first array.
Also in: Core | Miscellaneous > Setup Methods

jQuery.noConflict()
Relinquish jQuery’s control of the $ variable.
Also in: Ajax > Shorthand Methods

jQuery.post()
Load data from the server using a HTTP POST request.
Also in: Utilities

jQuery.trim()
Remove the whitespace from the beginning and end of a string.
Also in: Events > Keyboard Events

.keydown()
Bind an event handler to the “keydown” JavaScript event, or
trigger that event on an element.
Also in: Events > Keyboard Events

.keypress()
Bind an event handler to the “keypress” JavaScript event, or
trigger that event on an element.
Also in: Events > Keyboard Events

.keyup()
Bind an event handler to the “keyup” JavaScript event, or trigger
that event on an element.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:last Selector
Selects the last matched element.
Also in: Properties > Properties of jQuery Object Instances

.length
The number of elements in the jQuery object.
Also in: Ajax > Shorthand Methods

.load()
Load data from the server and place the returned HTML into the
matched element.
Also in: Events > Document Loading

.load()
Bind an event handler to the “load” JavaScript event.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:lt() Selector
Select all elements at an index less than index within the matched
set.
Also in: Events > Mouse Events

.mousedown()
Bind an event handler to the “mousedown” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseenter()
Bind an event handler to be fired when the mouse enters an
element, or trigger that handler on an element.
Also in: Events > Mouse Events

.mouseleave()
Bind an event handler to be fired when the mouse leaves an
element, or trigger that handler on an element.
Also in: Events > Mouse Events

.mousemove()
Bind an event handler to the “mousemove” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseout()
Bind an event handler to the “mouseout” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseover()
Bind an event handler to the “mouseover” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseup()
Bind an event handler to the “mouseup” JavaScript event, or
trigger that event on an element.
Also in: Selectors > Attribute

Multiple Attribute Selector [name="value"]
[name2="value2"]
Matches elements that match all of the specified attribute filters.
Also in: Selectors > Basic

Multiple Selector (“selector1, selector2,
selectorN”)
Selects the combined results of all the specified selectors.
Also in: Traversing > Tree Traversal

.next()
Get the immediately following sibling of each element in the set of
matched elements. If a selector is provided, it retrieves the next
sibling only if it matches that selector.
Also in: Selectors > Hierarchy

Next Adjacent Selector (“prev + next”)
Selects all next elements matching “next” that are immediately
preceded by a sibling “prev”.
Also in: Selectors > Hierarchy

Next Siblings Selector (“prev ~ siblings”)
Selects all sibling elements that follow after the “prev” element,
have the same parent, and match the filtering “siblings” selector.
Also in: Traversing > Filtering | Traversing > Miscellaneous Traversing

.not()
Remove elements from the set of matched elements.
Also in: Selectors > Basic Filter

:not() Selector
Selects all elements that do not match the given selector.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:odd Selector
Selects odd elements, zero-indexed. See also even.
Also in: Traversing > Tree Traversal

.parent()
Get the parent of each element in the current set of matched
elements, optionally filtered by a selector.
Also in: Selectors > Content Filter | Selectors > jQuery Extensions

:parent Selector
Select all elements that that have at least one child node (either
an element or text).
Also in: Traversing > Tree Traversal

.parents()
Get the ancestors of each element in the current set of matched
elements, optionally filtered by a selector.
Also in: Selectors > Form | Selectors > jQuery Extensions

:password Selector
Selects all elements of type password.
Also in: Manipulation > DOM Insertion, Inside

.prepend()
Insert content, specified by the parameter, to the beginning of
each element in the set of matched elements.
Also in: Manipulation > DOM Insertion, Inside

.prependTo()
Insert every element in the set of matched elements to the
beginning of the target.
Also in: Traversing > Tree Traversal

.prev()
Get the immediately preceding sibling of each element in the set
of matched elements, optionally filtered by a selector.
Also in: Internals

.pushStack()
Add a collection of DOM elements onto the jQuery stack.
Also in: Selectors > Form | Selectors > jQuery Extensions

:radio Selector
Selects all elements of type radio.
Also in: Events > Document Loading

.ready()
Specify a function to execute when the DOM is fully loaded.
Also in: Manipulation > DOM Removal

.remove()
Remove the set of matched elements from the DOM.
Also in: Attributes | Manipulation > General Attributes

.removeAttr()
Remove an attribute from each element in the set of matched
elements.
Also in: Attributes | Manipulation > Class Attribute | CSS

.removeClass()
Remove a single class, multiple classes, or all classes from each
element in the set of matched elements.
Also in: Selectors > Form | Selectors > jQuery Extensions

:reset Selector
Selects all elements of type reset.
Also in: Events > Browser Events

.resize()
Bind an event handler to the “resize” JavaScript event, or trigger
that event on an element.
Also in: Events > Browser Events

.scroll()
Bind an event handler to the “scroll” JavaScript event, or trigger
that event on an element.
Also in: Events > Form Events | Forms

.select()
Bind an event handler to the “select” JavaScript event, or trigger
that event on an element.
Also in: Selectors > Form | Selectors > jQuery Extensions

:selected Selector
Selects all elements that are selected.
Also in: Forms | Ajax > Helper Functions

.serialize()
Encode a set of form elements as a string for submission.
Also in: Effects > Basics

.show()
Display the matched elements.
Also in: Traversing > Tree Traversal

.siblings()
Get the siblings of each element in the set of matched elements,
optionally filtered by a selector.
Also in: Miscellaneous > DOM Element Methods

.size()
Return the number of elements in the jQuery object.
Also in: Effects > Sliding

.slideDown()
Display the matched elements with a sliding motion.
Also in: Effects > Sliding

.slideToggle()
Display or hide the matched elements with a sliding motion.
Also in: Effects > Sliding

.slideUp()
Hide the matched elements with a sliding motion.
Also in: Events > Form Events | Forms

.submit()
Bind an event handler to the “submit” JavaScript event, or trigger
that event on an element.
Also in: Selectors > Form | Selectors > jQuery Extensions

:submit Selector
Selects all elements of type submit.
Also in: Manipulation > DOM Insertion, Inside

.text()
Get the combined text contents of each element in the set of
matched elements, including their descendants, or set the text
contents of the matched elements.
Also in: Selectors > Form | Selectors > jQuery Extensions

:text Selector
Selects all elements of type text.
Also in: Effects > Basics

.toggle()
Display or hide the matched elements.
Also in: Deprecated > Deprecated 1.8 | Events > Mouse Events

.toggle()
Bind two or more handlers to the matched elements, to be
executed on alternate clicks.
Also in: Attributes | Manipulation > Class Attribute | CSS

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument.
Also in: Events > Event Handler Attachment

.trigger()
Execute all handlers and behaviors attached to the matched
elements for the given event type.
Also in: Events > Event Handler Attachment

.unbind()
Remove a previously-attached event handler from the elements.
Also in: Events > Document Loading

.unload()
Bind an event handler to the “unload” JavaScript event.
Also in: Attributes | Forms | Manipulation > General Attributes

.val()
Get the current value of the first element in the set of matched
elements or set the value of every matched element.
Also in: Selectors > jQuery Extensions | Selectors > Visibility Filter

:visible Selector
Selects all elements that are visible.
Also in: CSS | Dimensions | Manipulation > Style Properties

.width()
Get the current computed width for the first element in the set of
matched elements or set the width of every matched element.
Also in: Manipulation > DOM Insertion, Around

.wrap()
Wrap an HTML structure around each element in the set of
matched elements.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.0.4
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
Release Notes: 1.0.1, 1.0.2, 1.0.3, 1.0.4.
Also in: Events > Event Object

event.metaKey
Indicates whether the META key was pressed when the event
fired.
Also in: Events > Event Object

event.pageX
The mouse position relative to the left edge of the document.
Also in: Events > Event Object

event.pageY
The mouse position relative to the top edge of the document.
Also in: Utilities

jQuery.globalEval()
Execute some JavaScript code globally.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.1
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
jQuery 1.1 Release Notes.
Also in: Attributes | Manipulation > General Attributes

.attr()
Get the value of an attribute for the first element in the set of
matched elements or set one or more attributes for every matched
element.
Also in: Events > Event Object

event.data
An optional object of data passed to an event method when the
current executing handler is bound.
Also in: Ajax > Low-Level Interface

jQuery.ajaxSetup()
Set default values for future Ajax requests.
Also in: Events > Event Handler Attachment

.one()
Attach a handler to an event for the elements. The handler is
executed at most once per element.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.1.2
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
jQuery 1.1.2 Release Notes.
Also in: Traversing > Filtering

.eq()
Reduce the set of matched elements to the one at the specified
index.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.1.3
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
jQuery 1.1.3 Release Notes
Also in: Events > Event Object

event.which
For key or mouse events, this property indicates the specific key
or button that was pressed.
Also in: Properties > Properties of the Global jQuery Object | Utilities

jQuery.browser
Contains flags for the useragent, read from navigator.userAgent.
We recommend against using this property; please try to use
feature detection instead (see jQuery.support). jQuery.browser
may be moved to a plugin in a future release of jQuery.
Also in: Utilities

jQuery.unique()
Sorts an array of DOM elements, in place, with the duplicates
removed. Note that this only works on arrays of DOM elements,
not strings or numbers.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.1.4
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
jQuery 1.1.4 Release Notes.
Also in: Selectors > Content Filter

:contains() Selector
Select all elements that contain the specified text.
Also in: Events > Event Object

event.relatedTarget
The other DOM element involved in the event, if any.
Also in: Selectors > Child Filter

:first-child Selector
Selects all elements that are the first child of their parent.
Also in: Selectors > Content Filter | Selectors > jQuery Extensions

:has() Selector
Selects elements which contain at least one element that matches
the specified selector.
Also in: Utilities

jQuery.isXMLDoc()
Check to see if a DOM node is within an XML document (or is an
XML document).
Also in: Selectors > Child Filter

:last-child Selector
Selects all elements that are the last child of their parent.
Also in: Selectors > Child Filter

:nth-child() Selector
Selects all elements that are the nth-child of their parent.
Also in: Selectors > Child Filter

:only-child Selector
Selects all elements that are the only child of their parent.
Also in: Traversing > Filtering

.slice()
Reduce the set of matched elements to a subset specified by a
range of indices.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.2
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
jQuery 1.2 Release Notes
Also in: Traversing > Miscellaneous Traversing

.andSelf()
Add the previous set of elements on the stack to the current set.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:animated Selector
Select all elements that are in the progress of an animation at the
time the selector is run.
Also in: Traversing > Miscellaneous Traversing

.contents()
Get the children of each element in the set of matched elements,
including text and comment nodes.
Also in: Effects > Custom | Data | Utilities

.dequeue()
Execute the next function on the queue for the matched elements.
Also in: Attributes | Manipulation > Class Attribute | CSS

.hasClass()
Determine whether any of the matched elements are assigned the
given class.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:header Selector
Selects all elements that are headers, like h1, h2, h3 and so on.
Also in: Utilities

jQuery.inArray()
Search for a specified value within an array and return its index (or
-1 if not found).
Also in: Utilities

jQuery.isFunction()
Determine if the argument passed is a Javascript function object.
Also in: Utilities

jQuery.makeArray()
Convert an array-like object into a true JavaScript array.
Also in: Miscellaneous > Collection Manipulation | Forms | Ajax > Helper Functions

jQuery.param()
Create a serialized representation of an array or object, suitable
for use in a URL query string or Ajax request.
Also in: Traversing > Filtering

.map()
Pass each element in the current matched set through a function,
producing a new jQuery object containing the return values.
Also in: Traversing > Tree Traversal

.nextAll()
Get all following siblings of each element in the set of matched
elements, optionally filtered by a selector.
Also in: CSS | Offset | Manipulation > Style Properties

.offset()
Get the current coordinates of the first element, or set the
coordinates of every element, in the set of matched elements,
relative to the document.
Also in: CSS | Offset | Manipulation > Style Properties

.position()
Get the current coordinates of the first element in the set of
matched elements, relative to the offset parent.
Also in: Traversing > Tree Traversal

.prevAll()
Get all preceding siblings of each element in the set of matched
elements, optionally filtered by a selector.
Also in: Effects > Custom | Data | Utilities

.queue()
Show or manipulate the queue of functions to be executed on the
matched elements.
Also in: Manipulation > DOM Replacement

.replaceAll()
Replace each target element with the set of matched elements.
Also in: Manipulation > DOM Replacement

.replaceWith()
Replace each element in the set of matched elements with the
provided new content and return the set of elements that was
removed.
Also in: Forms | Ajax > Helper Functions

.serializeArray()
Encode a set of form elements as an array of names and values.
Also in: Effects > Custom

.stop()
Stop the currently-running animation on the matched elements.
Also in: Events > Event Handler Attachment

.triggerHandler()
Execute all handlers attached to an element for an event.
Also in: Manipulation > DOM Insertion, Around

.wrapAll()
Wrap an HTML structure around all elements in the set of
matched elements.
Also in: Manipulation > DOM Insertion, Around

.wrapInner()
Wrap an HTML structure around the content of each element in
the set of matched elements.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.2.3
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
Release Notes: 1.2.1, 1.2.2, 1.2.3.
Also in: Data | Miscellaneous > Data Storage

.data()
Store arbitrary data associated with the matched elements or
return the value at the named data store for the first element in the
set of matched elements.
Also in: Data | Utilities

jQuery.data()
Store arbitrary data associated with the specified element and/or
return the value that was set.
Also in: Data | Utilities

jQuery.removeData()
Remove a previously-stored piece of data.
Also in: Data | Miscellaneous > Data Storage

.removeData()
Remove a previously-stored piece of data.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.2.6
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
jQuery 1.2.6 Release Notes.
Also in: Events > Event Object

event.timeStamp
The difference in milliseconds between the time the browser
created the event and January 1, 1970.
Also in: CSS | Dimensions | Manipulation > Style Properties

.innerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding but not border.
Also in: CSS | Dimensions | Manipulation > Style Properties

.innerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding but not border.
Also in: CSS | Dimensions | Manipulation > Style Properties

.outerHeight()
Get the current computed height for the first element in the set of
matched elements, including padding, border, and optionally
margin. Returns an integer (without “px”) representation of the
value or null if called on an empty set of elements.
Also in: CSS | Dimensions | Manipulation > Style Properties

.outerWidth()
Get the current computed width for the first element in the set of
matched elements, including padding and border.
Also in: CSS | Offset | Manipulation > Style Properties

.scrollLeft()
Get the current horizontal position of the scroll bar for the first
element in the set of matched elements or set the horizontal
position of the scroll bar for every matched element.
Also in: CSS | Offset | Manipulation > Style Properties

.scrollTop()
Get the current vertical position of the scroll bar for the first
element in the set of matched elements or set the vertical position
of the scroll bar for every matched element.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.3
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
Release Notes: 1.3, 1.3.1, 1.3.2
Also in: Traversing > Tree Traversal

.closest()
For each element in the set, get the first element that matches the
selector by testing the element itself and traversing up through its
ancestors in the DOM tree.
Also in: Internals | Properties > Properties of jQuery Object Instances

.context
The DOM node context originally passed to jQuery(); if none was
passed then context will likely be the document.
Also in: Events > Event Handler Attachment

.die()
Remove event handlers previously attached using .live() from the
elements.
Also in: Events > Event Object

event.currentTarget
The current DOM element within the event bubbling phase.
Also in: Events > Event Object

event.isDefaultPrevented()
Returns whether event.preventDefault() was ever called on this
event object.
Also in: Events > Event Object

event.isImmediatePropagationStopped()
Returns whether event.stopImmediatePropagation() was ever
called on this event object.
Also in: Events > Event Object

event.isPropagationStopped()
Returns whether event.stopPropagation() was ever called on this
event object.
Also in: Events > Event Object

event.result
The last value returned by an event handler that was triggered by
this event, unless the value was undefined.
Also in: Events > Event Object

event.stopImmediatePropagation()
Keeps the rest of the handlers from being executed and prevents
the event from bubbling up the DOM tree.
Also in: Data | Utilities

jQuery.dequeue()
Execute the next function on the queue for the matched element.
Also in: Effects > Custom | Properties > Properties of the Global jQuery Object

jQuery.fx.off
Globally disable all animations.
Also in: Utilities

jQuery.isArray()
Determine whether the argument is an array.
Also in: Data | Utilities

jQuery.queue()
Show or manipulate the queue of functions to be executed on the
matched element.
Also in: Properties > Properties of the Global jQuery Object | Utilities

jQuery.support
A collection of properties that represent the presence of different
browser features or bugs. Primarily intended for jQuery’s internal
use; specific properties may be removed when they are no longer
needed internally to improve page startup performance.
Also in: Events > Event Handler Attachment

.live()
Attach an event handler for all elements which match the current
selector, now and in the future.
Also in: Internals

.pushStack()
Add a collection of DOM elements onto the jQuery stack.
Also in: Effects > Basics

.toggle()
Display or hide the matched elements.
Also in: Attributes | Manipulation > Class Attribute | CSS

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.4
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
jQuery 1.4 Release Notes.
Also in: Traversing > Miscellaneous Traversing

.add()
Add elements to the set of matched elements.
Also in: Attributes | Manipulation > Class Attribute | CSS

.addClass()
Adds the specified class(es) to each of the set of matched
elements.
Also in: Manipulation > DOM Insertion, Outside

.after()
Insert content, specified by the parameter, after each element in
the set of matched elements.
Also in: Manipulation > DOM Insertion, Inside

.append()
Insert content, specified by the parameter, to the end of each
element in the set of matched elements.
Also in: Manipulation > DOM Insertion, Outside

.before()
Insert content, specified by the parameter, before each element in
the set of matched elements.
Also in: Events > Event Handler Attachment

.bind()
Attach a handler to an event for the elements.
Also in: Effects > Custom | Data | Utilities

.clearQueue()
Remove from the queue all items that have not yet been run.
Also in: Traversing > Tree Traversal

.closest()
For each element in the set, get the first element that matches the
selector by testing the element itself and traversing up through its
ancestors in the DOM tree.
Also in: CSS | Manipulation > Style Properties

.css()
Get the value of a style property for the first element in the set of
matched elements or set one or more CSS properties for every
matched element.
Also in: Data | Miscellaneous > Data Storage

.data()
Store arbitrary data associated with the matched elements or
return the value at the named data store for the first element in the
set of matched elements.
Also in: Effects > Custom

.delay()
Set a timer to delay execution of subsequent items in the queue.
Also in: Manipulation > DOM Removal

.detach()
Remove the set of matched elements from the DOM.
Also in: Traversing > Filtering

.filter()
Reduce the set of matched elements to those that match the
selector or pass the function’s test.
Also in: Traversing > Filtering

.first()
Reduce the set of matched elements to the first in the set.
Also in: Events > Keyboard Events | Events > Mouse Events

.focusin()
Bind an event handler to the “focusin” event.
Also in: Events > Keyboard Events | Events > Mouse Events

.focusout()
Bind an event handler to the “focusout” JavaScript event.
Also in: Traversing > Filtering

.has()
Reduce the set of matched elements to those that have a
descendant that matches the selector or DOM element.
Also in: Attributes | Manipulation > DOM Insertion, Inside

.html()
Get the HTML contents of the first element in the set of matched
elements or set the HTML contents of every matched element.
Also in: Miscellaneous > DOM Element Methods

.index()
Search for a given element from among the matched elements.
Also in: Core

jQuery()
Return a collection of matched elements either found in the DOM
based on passed argument(s) or created by passing an HTML
string.
Also in: Utilities

jQuery.contains()
Check to see if a DOM element is a descendant of another DOM
element.
Also in: Data | Utilities

jQuery.data()
Store arbitrary data associated with the specified element and/or
return the value that was set.
Also in: Utilities

jQuery.isEmptyObject()
Check to see if an object is empty (contains no enumerable
properties).
Also in: Utilities

jQuery.isPlainObject()
Check to see if an object is a plain object (created using “{}” or
“new Object”).
Also in: Utilities

jQuery.noop()
An empty function.
Also in: Miscellaneous > Collection Manipulation | Forms | Ajax > Helper Functions

jQuery.param()
Create a serialized representation of an array or object, suitable
for use in a URL query string or Ajax request.
Also in: Events > Event Handler Attachment | Utilities

jQuery.proxy()
Takes a function and returns a new one that will always have a
particular context.
Also in: Traversing > Filtering

.last()
Reduce the set of matched elements to the final one in the set.
Also in: Traversing > Tree Traversal

.nextUntil()
Get all following siblings of each element up to but not including
the element matched by the selector, DOM node, or jQuery object
passed.
Also in: Traversing > Filtering | Traversing > Miscellaneous Traversing

.not()
Remove elements from the set of matched elements.
Also in: CSS | Offset | Manipulation > Style Properties

.offset()
Get the current coordinates of the first element, or set the
coordinates of every element, in the set of matched elements,
relative to the document.
Also in: Traversing > Tree Traversal

.parentsUntil()
Get the ancestors of each element in the current set of matched
elements, up to but not including the element matched by the
selector, DOM node, or jQuery object.
Also in: Manipulation > DOM Insertion, Inside

.prepend()
Insert content, specified by the parameter, to the beginning of
each element in the set of matched elements.
Also in: Traversing > Tree Traversal

.prevUntil()
Get all preceding siblings of each element up to but not including
the element matched by the selector, DOM node, or jQuery object.
Also in: Attributes | Manipulation > General Attributes

.removeAttr()
Remove an attribute from each element in the set of matched
elements.
Also in: Attributes | Manipulation > Class Attribute | CSS

.removeClass()
Remove a single class, multiple classes, or all classes from each
element in the set of matched elements.
Also in: Manipulation > DOM Replacement

.replaceWith()
Replace each element in the set of matched elements with the
provided new content and return the set of elements that was
removed.
Also in: Manipulation > DOM Insertion, Inside

.text()
Get the combined text contents of each element in the set of
matched elements, including their descendants, or set the text
contents of the matched elements.
Also in: Miscellaneous > DOM Element Methods

.toArray()
Retrieve all the DOM elements contained in the jQuery set, as an
array.
Also in: Attributes | Manipulation > Class Attribute | CSS

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument.
Also in: Manipulation > DOM Insertion, Around | Manipulation > DOM Removal

.unwrap()
Remove the parents of the set of matched elements from the
DOM, leaving the matched elements in their place.
Also in: Attributes | Forms | Manipulation > General Attributes

.val()
Get the current value of the first element in the set of matched
elements or set the value of every matched element.
Also in: Manipulation > DOM Insertion, Around

.wrap()
Wrap an HTML structure around each element in the set of
matched elements.
Also in: Manipulation > DOM Insertion, Around

.wrapAll()
Wrap an HTML structure around all elements in the set of
matched elements.
Also in: Manipulation > DOM Insertion, Around

.wrapInner()
Wrap an HTML structure around the content of each element in
the set of matched elements.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.4.1
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
jQuery 1.4.1 Release Notes.
Also in: Events > Event Handler Attachment

.die()
Remove event handlers previously attached using .live() from the
elements.
Also in: CSS | Dimensions | Manipulation > Style Properties

.height()
Get the current computed height for the first element in the set of
matched elements or set the height of every matched element.
Also in: Internals

jQuery.error()
Takes a string and throws an exception containing it.
Also in: Utilities

jQuery.parseJSON()
Takes a well-formed JSON string and returns the resulting
JavaScript object.
Also in: CSS | Dimensions | Manipulation > Style Properties

.width()
Get the current computed width for the first element in the set of
matched elements or set the width of every matched element.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.4.2
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
jQuery 1.4.2 Release Notes.
Also in: Events > Event Handler Attachment

.delegate()
Attach a handler to one or more events for all elements that match
the selector, now or in the future, based on a specific set of root
elements.
Also in: Events > Event Handler Attachment

.undelegate()
Remove a handler from the event for all elements which match the
current selector, based upon a specific set of root elements.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.4.3
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
jQuery 1.4.3 Release Notes.
Also in: Events > Event Handler Attachment

.bind()
Attach a handler to an event for the elements.
Also in: Events > Form Events | Forms

.blur()
Bind an event handler to the “blur” JavaScript event, or trigger that
event on an element.
Also in: Events > Form Events | Forms

.change()
Bind an event handler to the “change” JavaScript event, or trigger
that event on an element.
Also in: Events > Mouse Events

.click()
Bind an event handler to the “click” JavaScript event, or trigger
that event on an element.
Also in: Data | Miscellaneous > Data Storage

.data()
Store arbitrary data associated with the matched elements or
return the value at the named data store for the first element in the
set of matched elements.
Also in: Events > Mouse Events

.dblclick()
Bind an event handler to the “dblclick” JavaScript event, or trigger
that event on an element.
Also in: Events > Event Handler Attachment

.delegate()
Attach a handler to one or more events for all elements that match
the selector, now or in the future, based on a specific set of root
elements.
Also in: Events > Event Handler Attachment

.die()
Remove event handlers previously attached using .live() from the
elements.
Also in: Events > Browser Events

.error()
Bind an event handler to the “error” JavaScript event.
Also in: Events > Event Object

event.namespace
The namespace specified when the event was triggered.
Also in: Effects > Fading

.fadeIn()
Display the matched elements by fading them to opaque.
Also in: Effects > Fading

.fadeOut()
Hide the matched elements by fading them to transparent.
Also in: Effects > Fading

.fadeTo()
Adjust the opacity of the matched elements.
Also in: Events > Form Events | Forms

.focus()
Bind an event handler to the “focus” JavaScript event, or trigger
that event on an element.
Also in: Events > Keyboard Events | Events > Mouse Events

.focusin()
Bind an event handler to the “focusin” event.
Also in: Events > Keyboard Events | Events > Mouse Events

.focusout()
Bind an event handler to the “focusout” JavaScript event.
Also in: Effects > Basics

.hide()
Hide the matched elements.
Also in: CSS

jQuery.cssHooks
Hook directly into jQuery to override how particular CSS
properties are retrieved or set, normalize CSS property naming, or
create custom properties.
Also in: Data | Utilities

jQuery.data()
Store arbitrary data associated with the specified element and/or
return the value that was set.
Also in: Effects > Custom | Properties > Properties of the Global jQuery Object

jQuery.fx.interval
The rate (in milliseconds) at which animations fire.
Also in: Utilities

jQuery.isWindow()
Determine whether the argument is a window.
Also in: Utilities

jQuery.now()
Return a number representing the current time.
Also in: Utilities

jQuery.type()
Determine the internal JavaScript [[Class]] of an object.
Also in: Events > Keyboard Events

.keydown()
Bind an event handler to the “keydown” JavaScript event, or
trigger that event on an element.
Also in: Events > Keyboard Events

.keypress()
Bind an event handler to the “keypress” JavaScript event, or
trigger that event on an element.
Also in: Events > Keyboard Events

.keyup()
Bind an event handler to the “keyup” JavaScript event, or trigger
that event on an element.
Also in: Events > Document Loading

.load()
Bind an event handler to the “load” JavaScript event.
Also in: Events > Mouse Events

.mousedown()
Bind an event handler to the “mousedown” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseenter()
Bind an event handler to be fired when the mouse enters an
element, or trigger that handler on an element.
Also in: Events > Mouse Events

.mouseleave()
Bind an event handler to be fired when the mouse leaves an
element, or trigger that handler on an element.
Also in: Events > Mouse Events

.mousemove()
Bind an event handler to the “mousemove” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseout()
Bind an event handler to the “mouseout” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseover()
Bind an event handler to the “mouseover” JavaScript event, or
trigger that event on an element.
Also in: Events > Mouse Events

.mouseup()
Bind an event handler to the “mouseup” JavaScript event, or
trigger that event on an element.
Also in: Events > Browser Events

.resize()
Bind an event handler to the “resize” JavaScript event, or trigger
that event on an element.
Also in: Events > Browser Events

.scroll()
Bind an event handler to the “scroll” JavaScript event, or trigger
that event on an element.
Also in: Events > Form Events | Forms

.select()
Bind an event handler to the “select” JavaScript event, or trigger
that event on an element.
Also in: Effects > Basics

.show()
Display the matched elements.
Also in: Effects > Sliding

.slideDown()
Display the matched elements with a sliding motion.
Also in: Effects > Sliding

.slideToggle()
Display or hide the matched elements with a sliding motion.
Also in: Effects > Sliding

.slideUp()
Hide the matched elements with a sliding motion.
Also in: Events > Form Events | Forms

.submit()
Bind an event handler to the “submit” JavaScript event, or trigger
that event on an element.
Also in: Effects > Basics

.toggle()
Display or hide the matched elements.
Also in: Events > Event Handler Attachment

.unbind()
Remove a previously-attached event handler from the elements.
Also in: Events > Event Handler Attachment

.undelegate()
Remove a handler from the event for all elements which match the
current selector, based upon a specific set of root elements.
Also in: Events > Document Loading

.unload()
Bind an event handler to the “unload” JavaScript event.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.4.4
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery. jQuery 1.4.4 Release
Notes.
Also in: Effects | Effects > Fading

.fadeToggle()
Display or hide the matched elements by animating their opacity.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.5
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
jQuery 1.5 also includes a large rewrite of the Ajax module, which has
a number of extensibility improvements. You can find out more about
those improvements in the Extending Ajax documentation.
Additionally jQuery 1.5 includes a new Deferred callback management
system you can learn more about in in the Deferred Object
documentation.
Also in: Manipulation > Copying

.clone()
Create a deep copy of the set of matched elements.
Also in: Deferred Object

deferred.done()
Add handlers to be called when the Deferred object is resolved.
Also in: Deferred Object

deferred.fail()
Add handlers to be called when the Deferred object is rejected.
Also in: Deferred Object

deferred.isRejected()
Determine whether a Deferred object has been rejected.
Also in: Deferred Object

deferred.isResolved()
Determine whether a Deferred object has been resolved.
Also in: Deferred Object

deferred.promise()
Return a Deferred’s Promise object.
Also in: Deferred Object

deferred.reject()
Reject a Deferred object and call any failCallbacks with the given
args.
Also in: Deferred Object

deferred.rejectWith()
Reject a Deferred object and call any failCallbacks with the given
context and args.
Also in: Deferred Object

deferred.resolve()
Resolve a Deferred object and call any doneCallbacks with the
given args.
Also in: Deferred Object

deferred.resolveWith()
Resolve a Deferred object and call any doneCallbacks with the
given context and args.
Also in: Deferred Object

deferred.then()
Add handlers to be called when the Deferred object is resolved,
rejected, or still in progress.
Also in: Ajax > Low-Level Interface

jQuery.ajax()
Perform an asynchronous HTTP (Ajax) request.
Also in: Ajax > Low-Level Interface

jQuery.ajaxPrefilter()
Handle custom Ajax options or modify existing options before
each request is sent and before they are processed by $.ajax().
Also in: Ajax > Low-Level Interface

jQuery.ajaxTransport()
Creates an object that handles the actual transmission of Ajax
data.
Also in: Deferred Object

jQuery.Deferred()
A constructor function that returns a chainable utility object with
methods to register multiple callbacks into callback queues,
invoke callback queues, and relay the success or failure state of
any synchronous or asynchronous function.
Also in: Ajax > Shorthand Methods

jQuery.get()
Load data from the server using a HTTP GET request.
Also in: Ajax > Shorthand Methods

jQuery.getJSON()
Load JSON-encoded data from the server using a GET HTTP
request.
Also in: Ajax > Shorthand Methods

jQuery.getScript()
Load a JavaScript file from the server using a GET HTTP request,
then execute it.
Also in: Data

jQuery.hasData()
Determine whether an element has any jQuery data associated
with it.
Also in: Utilities

jQuery.parseXML()
Parses a string into an XML document.
Also in: Ajax > Shorthand Methods

jQuery.post()
Load data from the server using a HTTP POST request.
Also in: Core

jQuery.sub()
Creates a new copy of jQuery whose properties and methods can
be modified without affecting the original jQuery object.
Also in: Core | Deferred Object

jQuery.when()
Provides a way to execute callback functions based on one or
more objects, usually Deferred objects that represent
asynchronous events.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.5.1
Aspects of the API that were changed in the corresponding version of
jQuery. API changes in jQuery 1.5.1 dealt primarily with jQuery.ajax
settings and jQuery.support properties.
Also in: Ajax > Low-Level Interface

jQuery.ajax()
Perform an asynchronous HTTP (Ajax) request.
Also in: Properties > Properties of the Global jQuery Object | Utilities

jQuery.support
A collection of properties that represent the presence of different
browser features or bugs. Primarily intended for jQuery’s internal
use; specific properties may be removed when they are no longer
needed internally to improve page startup performance.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.6
All the aspects of the API that were added, or had a new signature
added, in the corresponding version of jQuery.
Also in: Attributes | Manipulation > General Attributes

.attr()
Get the value of an attribute for the first element in the set of
matched elements or set one or more attributes for every matched
element.
Also in: Traversing > Tree Traversal

.closest()
For each element in the set, get the first element that matches the
selector by testing the element itself and traversing up through its
ancestors in the DOM tree.
Also in: Deferred Object

deferred.always()
Add handlers to be called when the Deferred object is either
resolved or rejected.
Also in: Deferred Object

deferred.pipe()
Utility method to filter and/or chain Deferreds.
Also in: Traversing > Tree Traversal

.find()
Get the descendants of each element in the current set of
matched elements, filtered by a selector, jQuery object, or
element.
Also in: Selectors > Basic Filter | Selectors > Form

:focus Selector
Selects element if it is currently focused.
Also in: Traversing > Filtering

.is()
Check the current matched set of elements against a selector,
element, or jQuery object and return true if at least one of these
elements matches the given arguments.
Also in: Core

jQuery.holdReady()
Holds or releases the execution of jQuery’s ready event.
Also in: Utilities

jQuery.map()
Translate all items in an array or object to new array of items.
Also in: Events > Event Handler Attachment | Utilities

jQuery.proxy()
Takes a function and returns a new one that will always have a
particular context.
Also in: Traversing > Tree Traversal

.nextUntil()
Get all following siblings of each element up to but not including
the element matched by the selector, DOM node, or jQuery object
passed.
Also in: Traversing > Tree Traversal

.parentsUntil()
Get the ancestors of each element in the current set of matched
elements, up to but not including the element matched by the
selector, DOM node, or jQuery object.
Also in: Traversing > Tree Traversal

.prevUntil()
Get all preceding siblings of each element up to but not including
the element matched by the selector, DOM node, or jQuery object.
Also in: Deferred Object

.promise()
Return a Promise object to observe when all actions of a certain
type bound to the collection, queued or not, have finished.
Also in: Attributes | Manipulation > General Attributes

.prop()
Get the value of a property for the first element in the set of
matched elements or set one or more properties for every
matched element.
Also in: Attributes | Manipulation > General Attributes

.removeProp()
Remove a property for the set of matched elements.
Also in: Events > Event Handler Attachment

.undelegate()
Remove a handler from the event for all elements which match the
current selector, based upon a specific set of root elements.

POWERED BYHERONOTE
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Category: Version 1.7
Aspects of the API that were changed in the corresponding version of
jQuery. API changes in jQuery 1.7.0 dealt primarily with the new
Event APIs: .on() and .off()
Better Support for HTML5 in IE6/7/8
jQuery.Callbacks()

Toggling Animations Work Intuitively
For more information, see the Release Notes/Changelog at
http://blog.jquery.com/2011/11/03/jquery-1-7-released/

Also in: Callbacks Object

callbacks.add()
Add a callback or a collection of callbacks to a callback list.
Also in: Callbacks Object

callbacks.disable()
Disable a callback list from doing anything more.
Also in: Callbacks Object

callbacks.disabled()
Determine if the callbacks list has been disabled.
Also in: Callbacks Object

callbacks.empty()
Remove all of the callbacks from a list.
Also in: Callbacks Object

callbacks.fire()
Call all of the callbacks with the given arguments
Also in: Callbacks Object

callbacks.fired()
Determine if the callbacks have already been called at least once.
Also in: Callbacks Object

callbacks.fireWith()
Call all callbacks in a list with the given context and arguments.
Also in: Callbacks Object

callbacks.has()
Determine whether a supplied callback is in a list
Also in: Callbacks Object

callbacks.lock()
Lock a callback list in its current state.
Also in: Callbacks Object

callbacks.locked()
Determine if the callbacks list has been locked.
Also in: Callbacks Object

callbacks.remove()
Remove a callback or a collection of callbacks from a callback list.
Also in: Deferred Object

deferred.notify()
Call the progressCallbacks on a Deferred object with the given
args.
Also in: Deferred Object

deferred.notifyWith()
Call the progressCallbacks on a Deferred object with the given
context and args.
Also in: Deferred Object

deferred.pipe()
Utility method to filter and/or chain Deferreds.
Also in: Deferred Object

deferred.progress()
Add handlers to be called when the Deferred object generates
progress notifications.
Also in: Deferred Object

deferred.state()
Determine the current state of a Deferred object.
Also in: Deferred Object

deferred.then()
Add handlers to be called when the Deferred object is resolved,
rejected, or still in progress.
Also in: Events > Event Object | Events

event.delegateTarget
The element where the currently-called jQuery event handler was
attached.
Also in: Traversing > Filtering

.is()
Check the current matched set of elements against a selector,
element, or jQuery object and return true if at least one of these
elements matches the given arguments.
Also in: Callbacks Object

jQuery.Callbacks()
A multi-purpose callbacks list object that provides a powerful way
to manage callback lists.
Also in: Utilities

jQuery.isNumeric()
Determines whether its argument is a number.
Also in: Events > Event Handler Attachment

.off()
Remove an event handler.
Also in: Events > Event Handler Attachment

.on()
Attach an event handler function for one or more events to the
selected elements.
Also in: Attributes | Manipulation > General Attributes

.removeAttr()
Remove an attribute from each element in the set of matched
elements.
Also in: Data | Miscellaneous > Data Storage

.removeData()
Remove a previously-stored piece of data.
Also in: Effects > Custom

.stop()
Stop the currently-running animation on the matched elements.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.8
Aspects of the API that were changed in the corresponding version of
jQuery. API changes in jQuery 1.8.0 dealt primarily with animations and
the removal of some methods such as deferred.isResolved() ,
deferred.isRejected() , $.curCSS() , $.attrFn() , and
$(element).closest(Array) returning Array.
For more information, see the Release Notes/Changelog at
http://blog.jquery.com/2012/08/09/jquery-1-8-released/

Also in: Traversing > Miscellaneous Traversing

.addBack()
Add the previous set of elements on the stack to the current set,
optionally filtered by a selector.
Also in: Deferred Object

deferred.pipe()
Utility method to filter and/or chain Deferreds.
Also in: Selectors > Basic Filter | Selectors > jQuery Extensions

:eq() Selector
Select the element at index n within the matched set.
Also in: Utilities

jQuery.parseHTML()
Parses a string into an array of DOM nodes.

POWERED BYHERONOTE
A new version of this book is available!

Category: Version 1.9
Aspects of the API that were changed in the corresponding version of
jQuery. Changes in jQuery 1.9 dealt primarily removal or modification
of several APIs that behaved inconsistently or inefficiently in the past. A
jQuery Migrate Plugin was offered to help developers with a transitional
upgrade path.
For more information, see the jQuery Core 1.9 Upgrade guide and the
Release Notes/Changelog

Also in: CSS | Manipulation > Style Properties

.css()
Get the value of a style property for the first element in the set of
matched elements or set one or more CSS properties for every
matched element.
Also in: Effects > Custom

.finish()
Stop the currently-running animation, remove all queued
animations, and complete all animations for the matched
elements.
Also in: Selectors > Child Filter

:first-of-type Selector
Selects all elements that are the first among siblings of the same
element name.
Also in: Selectors > Basic Filter

:lang Selector
Selects all elements of the specified language.
Also in: Selectors > Child Filter

:last-of-type Selector
Selects all elements that are the last among siblings of the same
element name.
Also in: Selectors > Child Filter

:nth-last-child() Selector
Selects all elements that are the nth-child of their parent, counting
from the last element to the first.
Also in: Selectors > Child Filter

:nth-last-of-type() Selector
Selects all elements that are the nth-child of their parent, counting
from the last element to the first.
Also in: Selectors > Child Filter

:nth-of-type() Selector
Selects all elements that are the nth child of their parent in relation
to siblings with the same element name.
Also in: Selectors > Child Filter

:only-of-type Selector
Selects all elements that have no siblings with the same element
name.
Also in: Selectors > Basic Filter

:root Selector
Selects the element that is the root of the document.
Also in: Selectors > Basic Filter

:target Selector
Selects the target element indicated by the fragment identifier of
the document’s URI.

POWERED BYHERONOTE
A new version of this book is available!

Types
JavaScript provides several built-in datatypes. In addition to those, this
page documents virtual types like Selectors, enhanced pseudo-types
like Events and all and everything you wanted to know about
Functions.
You should be able to try out most of the examples below by just
copying them to your browser's JavaScript Console (Chrome, Safari
with Develop menu activated, IE 8+) or Firebug console (Firefox).
Whenever an example mentions that a type defaults to a boolean
value, the result is good to know when using that type in a boolean
context:
1
2
3
4
5
6

var x = "";
if ( x ) {
console.log( "x defaulted to true" );
} else {
console.log( "x defaulted to false" );
}

In this case,

"x defaulted to false"

is printed.

To keep the examples short, the invert ("not") operator and doublenegation are used to show a boolean context:
1
2
3

var x = "";
!x // true
!!x // false (Double negation: Since "not (empty string)"

On to the actual types.
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String
A string in JavaScript is an immutable object that contains none, one or
many characters.
1
2

"I'm a String in JavaScript!"
'So am I!'

The type of a string is "string".
1

typeof "some string"; // "string"

Quoting
A string can be defined using single or double quotes. You can nest
single quotes inside of double quotes, and the other way around. To
mix double quotes with double quotes (or single with single), the
nested ones have to be escaped with a backslash.
1
2
3

"You make 'me' sad."
'That\'s "cranking" good fun!'
"<a href=\"home\">Home</a>"

Built-in Methods
A string in JavaScript has some built-in methods to manipulate the
string, though the result is always a new string - or something else, eg.
split returns an array.
1
2
3

"hello".charAt( 0 ) // "h"
"hello".toUpperCase() // "HELLO"
"Hello".toLowerCase() // "hello"

4
5

"hello".replace( /e|o/g, "x" ) // "hxllx"
"1,2,3".split( "," ) // [ "1", "2", "3" ]

Length Property
All strings have a length property.
1
2

"Hello".length // 5
"".length // 0

Boolean Default
An empty string defaults to false:
1
2
3
4
5

!"" // true
!!"" // false
!"hello" // false
!"true" // false
!new Boolean( false ) // false

htmlString
A string is designated htmlString in jQuery documentation when it is
used to represent one or more DOM elements, typically to be created
and inserted in the document. When passed as an argument of the
jQuery() function, the string is identified as HTML if it starts with <tag
... > ) and is parsed as such until the final > character.
For explicit parsing of a string to HTML, the
available as of jQuery 1.8.
1
2
3
4
5
6
7
8
9
10
11
12
13
14

$.parseHTML()

method is

// Appends <b>hello</b>:
$( "<b>hello</b>" ).appendTo( "body" );
// Appends <b>hello</b>:
$( "<b>hello</b>bye" ).appendTo( "body" );

// Syntax error, unrecognized expression: bye<b>hello</b
$( "bye<b>hello</b>" ).appendTo( "body" );
// Appends bye<b>hello</b>:
$( $.parseHTML( "bye<b>hello</b>" ) ).appendTo(
// Appends <b>hello</b>wait<b>bye</b>:
$( "<b>hello</b>wait<b>bye</b>" ).appendTo( "body"

Number
Numbers in JavaScript are double-precision 64-bit format IEEE 754
values. They are immutable, just as strings. All operators common in cbased languages are available to work with numbers (+, -, *, /, %, =,
+=, -=, *=, /=, ++, --).
1
2

12
3.543

The type of a number is "number".
1
2

typeof 12 // "number"
typeof 3.543 // "number"

Boolean Default
If a number is zero, it defaults to false:
1
2
3
4

!0 // true
!!0 // false
!1 // false
!-1 // false

Due to the implementation of numbers as double-precision values, the
following result is not an error:
1

0.1 + 0.2 // 0.30000000000000004

Math

JavaScript provides utilities to work with numbers in the Math object:
1
2

Math.PI // 3.141592653589793
Math.cos( Math.PI ) // -1

Parsing Numbers
parseInt and parseFloat help parsing strings into numbers. Both do
some implicit conversion if the base isn't specified:
1
2
3
4
5
6

parseInt( "123" ) = 123 // (implicit decimal)
parseInt( "010" ) = 8 // (implicit octal)
parseInt( "0xCAFE" ) = 51966 // (implicit hexadecimal)
parseInt( "010", 10 ) = 10 // (explicit decimal)
parseInt( "11", 2 ) = 3 // (explicit binary)
parseFloat( "10.10" ) = 10.1

Numbers to Strings
When appending numbers to string, the result is always a string. The
operator is the same, so be careful: If you want to add numbers and
then append them to a string, put parentheses around them:
1
2
3
4

"" + 1 + 2; // "12"
"" + ( 1 + 2 ); // "3"
"" + 0.0000001; // "1e-7"
parseInt( 0.0000001 ); // 1 (!)

Or you use the String class provided by javascript, which try to parse a
value as string:
1

String( 1 ) + String( 2 ); // "12"

2

String( 1 + 2 ); // "3"

NaN and Infinity
Parsing something that isn't a number results in NaN. isNaN helps to
detect those cases:
1
2

parseInt( "hello", 10 ) // NaN
isNaN( parseInt("hello", 10) ) // true

Division by zero results in Infinity:
1

1 / 0 // Infinity

Both NaN and Infinity are of type "number":
1
2

typeof NaN // "number"
typeof Infinity // "number"

Note that NaN compares in a strange way:
1

NaN == NaN // false (!)

But:
1

Infinity == Infinity // true

Integer
An integer is a plain Number type, but whenever explicitly mentioned,

indicates that a non-floating-point number is expected.

Float
A float is a plain Number type, just as Integer, but whenever explicitly
mentioned, indicates that a floating-point number is expected.

Boolean
A boolean in JavaScript can be either true or false:
1
2

if ( true ) console.log( "always!" );
if ( false ) console.log( "never!" );

Object
Everything in JavaScript is an object, though some are more objective
(haha). The easiest way to create an object is the object literal:
1
2
3
4
5

var x = {};
var y = {
name: "Pete",
age: 15
};

The type of an object is "object":
1

typeof {} // "object"

Dot Notation
You can write and read properties of an object using the dot notation:
1
2
3
4

y.name // "Pete"
y.age // 15
x.name = y.name + " Pan" // "Pete Pan"
x.age = y.age + 1 // 16

Array Notation
Or you write and read properties using the array notation, which allows
you to dynamically choose the property:
1
2
3

var operations = {
increase: "++",
decrease: "--"

4
5
6
7

};
var operation = "increase";
operations[ operation ] // "++"
operations[ "multiply" ] = "*"; // "*"

Iteration
Iterating over objects is easy with the for-in-loop:
1
2
3
4
5
6
7

var obj = {
name: "Pete",
age: 15
};
for( key in obj ) {
alert( "key is " + [ key ] + ", value is " + obj[ key ]
}

Note that for-in-loop can be spoiled by extending Object.prototype (see
Object.prototype is verboten) so take care when using other libraries.
jQuery provides a generic each function to iterate over properties of
objects, as well as elements of arrays:
1
2
3

jQuery.each( obj, function( key, value ) {
console.log( "key", key, "value", value );
});

The drawback is that the callback is called in the context of each value
and you therefore lose the context of your own object if applicable.
More on this below at Functions.

Boolean default
An object, no matter if it has properties or not, never defaults to false:

1
2

!{} // false
!!{} // true

Prototype
All objects have a prototype property. Whenever the interpreter looks
for a property, it also checks in the object's prototype if the property is
not found on the object itself. jQuery uses the prototype extensively to
add methods to jQuery instances. Internally, jQuery makes jQuery.fn
an alias of jQuery.prototype so you can use either one (though plugin
developers have standardized on fn ).
1
2
3
4
5
6
7
8
9
10
11
12
13
14

var form = $("#myform");
console.log( form.clearForm ); // undefined
// jQuery.fn == jQuery.prototype
jQuery.fn.clearForm = function() {
return this.find( ":input" ).each(function() {
this.value = "";
}).end();
};
// works for all instances of jQuery objects, because
// the new method was added to the prototype
console.log( form.clearForm ); // function
form.clearForm();

Array
Arrays in JavaScript are mutable lists with a few built-in methods. You
can define arrays using the array literal:
1
2

var x = [];
var y = [ 1, 2, 3 ];

The type of an array is "object":
1
2

typeof []; // "object"
typeof [ 1, 2, 3 ]; // "object"

Reading and writing elements to an array uses the array-notation:
1
2

x[ 0 ] = 1;
y[ 2 ] // 3

Iteration
An array has a length property that is useful for iteration:
1
2
3

for ( var i = 0; i < a.length; i++ ) {
// Do something with a[i]
}

When performance is critical, reading the length property only once
can help to speed things up. This should be used only when a
performance bottleneck was discovered:
1

for ( var i = 0, j = a.length; i < j; i++ ) {

2
3

// Do something with a[i]
}

Another variation defines a variable that is filled for each iteration,
removing the array-notation from the loop-body. It does not work when
the array contains 0 or empty strings!
1
2
3

for ( var i = 0, item; item = a[i]; i++ ) {
// Do something with item
}

jQuery provides a generic each function to iterate over element of
arrays, as well as properties of objects:
1
2
3
4

var x = [ 1, 2, 3 ];
jQuery.each( x, function( index, value ) {
console.log( "index", index, "value", value );
});

The drawback is that the callback is called in the context of each value
and you therefore lose the context of your own object if applicable.
More on this below at Functions.
The length property can also be used to add elements to the end of an
array. That is equivalent to using the push-method:
1
2
3
4

var x = [];
x.push( 1 );
x[ x.length ] = 2;
x // [ 1, 2 ]

You'll see both variations a lot when looking through JavaScript library
code.

Other built-in methods are reverse, join, shift, unshift, pop, slice, splice
and sort:
1
2
3
4
5
6
7
8

var x = [ 0, 3, 1, 2 ];
x.reverse()
// [ 2, 1, 3, 0 ]
x.join(" – ")
// "2 - 1 - 3 - 0"
x.pop()
// [ 2, 1, 3 ]
x.unshift( -1 ) // [ -1, 2, 1, 3 ]
x.shift()
// [ 2, 1, 3 ]
x.sort()
// [ 1, 2, 3 ]
x.splice( 1, 2 ) // [ 2, 3 ]

Note: .unshift() method does not return a length property in Internet
Explorer.

Boolean Default
An array, no matter if it has elements or not, never defaults to false:
1
2

![] // false
!![] // true

Array<Type> Notation
In the jQuery API you'll often find the notation of Array<Type>:
dragPrevention

Array<String>

This indicates that the method doesn't only expect an array as the
argument, but also specifies the expected type. The notation is
borrowed from Java 5's generics notation (or C++ templates).

PlainObject
The PlainObject type is a JavaScript object containing zero or more
key-value pairs. The plain object is, in other words, an Object object. It
is designated "plain" in jQuery documentation to distinguish it from
other kinds of JavaScript objects: for example, null , user-defined
arrays, and host objects such as document , all of which have a typeof
value of "object." The jQuery.isPlainObject() method identifies
whether the passed argument is a plain object or not, as demonstrated
below:
1
2
3
4
5
6
7
8
9
10
11

var a = [];
var d = document;
var o = {};
typeof a; // object
typeof d; // object
typeof o; // object
jQuery.isPlainObject( a ); // false
jQuery.isPlainObject( d ); // false
jQuery.isPlainObject( o ); // true

Function
A function in JavaScript can be either named or anonymous. Any
function can be assigned to a variable or passed to a method, but
passing member functions this way can cause them to be called in the
context of another object (i.e. with a different "this" object).
1
2

function named() {}
var handler = function() {}

You see a lot of anonymous functions in jQuery code:
1
2
3
4
5
6

$( document ).ready(function() {});
$( "a" ).click(function() {});
$.ajax({
url: "someurl.php",
success: function() {}
});

The type of a function is "function".

Arguments
Inside a function a special variable "arguments" is always available. It's
similar to an array in that it has a length property, but it lacks the built-in
methods of an array. The elements of the pseudo-array are the
argument of the function call.
1
2
3
4
5
6

function log( x ) {
console.log( typeof x, arguments.length );
}
log(); // "undefined", 0
log( 1 ); // "number", 1
log( "1", "2", "3" ); // "string", 3

The arguments object also has a callee property, which refers to the
function you're inside of. For instance:
1
2

var awesome = function() { return arguments.callee; }
awesome() == awesome // true

Context, Call and Apply
In JavaScript, the variable "this" always refers to the current context.
By default, "this" refers to the window object. Within a function this
context can change, depending on how the function is called.
All event handlers in jQuery are called with the handling element as the
context.
1
2
3
4
5
6

$( document ).ready(function() {
// this refers to window.document
});
$( "a" ).click(function() {
// this refers to an anchor DOM element
});

You can specify the context for a function call using the function-built-in
methods call and apply. The difference between them is how they pass
arguments. Call passes all arguments through as arguments to the
function, while apply accepts an array as the arguments.
1
2
3
4
5
6

function scope() {
console.log( this, arguments.length );
}
scope() // window, 0
scope.call( "foobar", [ 1, 2 ] ); // "foobar", 1
scope.apply( "foobar", [ 1, 2 ] ); // "foobar", 2

Scope
In JavaScript, all variables defined inside a function are only visible
inside that function scope. Consider the following example:
1
2
3
4
5
6
7
8

// global
var x = 0;
(function() {
// private
var x = 1;
console.log( x ); // 1
})();
console.log( x ); // 0

It defines a variable x in the global scope, then defines an anonymous
function and executes it immediately (the additional parentheses are
required for immediate execution). Inside the function another variable
x is defined with a different value. It is only visible within that function
and doesn't overwrite the global variable.

Closures
Closures are created whenever a variable that is defined outside the
current scope is accessed from within some inner scope. In the
following example, the variable counter is visible within the create,
increment, and print functions, but not outside of them.
1
2
3
4
5
6
7

function create() {
var counter = 0;
return {
increment: function() {
counter++;
},
print: function() {

8
9
10
11
12
13
14

console.log( counter );
}
}
}
var c = create();
c.increment();
c.print(); // 1

The pattern allows you to create objects with methods that operate on
data that isn't visible to the outside—the very basis of object-oriented
programming.

Proxy Pattern
Combining the above knowledge gives you as a JavaScript developer
quite a lot of power. One way to combine that is to implement a proxy
pattern in JavaScript, enabling the basics of aspect-oriented
programming (AOP):
1
2
3
4
5
6
7
8

(function() {
// log all calls to setArray
var proxied = jQuery.fn.setArray;
jQuery.fn.setArray = function() {
console.log( this, arguments );
return proxied.apply( this, arguments );
};
})();

The above wraps its code in a function to hide the "proxied"-variable. It
saves jQuery's setArray-method in a closure and overwrites it. The
proxy then logs all calls to the method and delegates the call to the
original. Using apply(this, arguments) guarantees that the caller won't
be able to notice the difference between the original and the proxied
method.

Callback
A callback is a plain JavaScript function passed to some method as an
argument or option. Some callbacks are just events, called to give the
user a chance to react when a certain state is triggered. jQuery's event
system uses such callbacks everywhere:
1
2
3

$( "body" ).click(function( event ) {
console.log( "clicked: " + event.target );
});

Most callbacks provide arguments and a context. In the event-handler
example, the callback is called with one argument, an Event. The
context is set to the handling element, in the above example,
document.body.
Some callbacks are required to return something, others make that
return value optional. To prevent a form submission, a submit event
handler can return false:
1
2
3

$( "#myform" ).submit(function() {
return false;
});

Instead of always returning false, the callback could check fields of the
form for validity, and return false only when the form is invalid.

Selector
A selector is used in jQuery to select DOM elements from a DOM
document. That document is, in most cases, the DOM document
present in all browsers, but can also be an XML document received via
AJAX.
The selectors are a composition of CSS and custom additions. All
selectors available in jQuery are documented on the Selectors API
page.
There are lot of plugins that leverage jQuery's selectors in other ways.
The validation plugin accepts a selector to specify a dependency,
whether an input is required or not:
1
2
3

emailrules: {
required: "#email:filled"
}

This would make a checkbox with name "emailrules" required only if
the user entered an email address in the email field, selected via its id,
filtered via a custom selector ":filled" that the validation plugin provides.
If Selector is specified as the type of an argument, it accepts
everything that the jQuery constructor accepts, eg. Strings, Elements,
Lists of Elements.

Event
jQuery's event system normalizes the event object according to W3C
standards. The event object is guaranteed to be passed to the event
handler (no checks for window.event required). It normalizes the target,
relatedTarget, which, metaKey and pageX/Y properties and provides
both stopPropagation() and preventDefault() methods.
Those properties are all documented, and accompanied by examples,
on the Event object page.
The standard events in the Document Object Model are:

blur, focus,
load, resize, scroll, unload, beforeunload, click, dblclick,
mousedown, mouseup, mousemove, mouseover, mouseout, mouseenter,
mouseleave, change, select, submit, keydown, keypress, and keyup .

Since the DOM event names have predefined meanings for some
elements, using them for other purposes is not recommended. jQuery's
event model can trigger an event by any name on an element, and it is
propagated up the DOM tree to which that element belongs, if any.

Element
An element in the Document Object Model (DOM) has attributes, text
and children. It provides methods to traverse the parent and children
and to get access to its attributes. Due to a lot of flaws in DOM API
specifications and implementations, those methods are no fun to use.
jQuery provides a wrapper around those elements to help interacting
with the DOM. But often enough you will be working directly with DOM
elements, or see methods that (also) accept DOM elements as
arguments.
Whenever you use jQuery's each-method, the context of your callback
is set to a DOM element. That is also the case for event handlers.
Some properties of DOM elements are quite consistent among
browsers. Consider this example of a simple on-blur-validation:
1
2
3
4
5

$( ":text" ).blur(function() {
if( !this.value ) {
alert( "Please enter some text!" );
}
});

You could replace this.value with $(this).val() to access the value of the
text input via jQuery, but in that case you don't gain anything.

jQuery
A jQuery object contains a collection of Document Object Model (DOM)
elements that have been created from an HTML string or selected from
a document. Since jQuery methods often use CSS selectors to match
elements from a document, the set of elements in a jQuery object is
often called a set of "matched elements" or "selected elements".
The jQuery object itself behaves much like an array; it has a length
property and the elements in the object can be accessed by their
numeric indices [0] to [length-1] . Note that a jQuery object is not
actually a Javascript Array object, so it does not have all the methods
of a true Array object such as join() .
Most frequently, you will use the jQuery() function to create a jQuery
object. jQuery() can also be accessed by its familiar single-character
alias of $() , unless you have called jQuery.noConflict() to disable this
option. Many jQuery methods return the jQuery object itself, so that
method calls can be chained:
1

$( "p" ).css( "color", "red" ).find( ".special" ).css(

Whenever you use a "destructive" jQuery method that potentially
changes the set of elements in the jQuery object, such as .filter() or
.find() , that method actually returns a new jQuery object with the
resulting elements. To return to the previous jQuery object, you use the
.end() method.
A jQuery object may be empty, containing no DOM elements. You can
create an empty jQuery object with $() (that is, passing no arguments
at all). A jQuery object may also be empty if a selector doesn't select
any elements, or if a chained method filters out all the elements. It is
not an error; any further methods called on that jQuery object simply
have no effect since they have no elements to act upon. So, in this
example if there are no bad entries on the page then no elements will
be colored red:

1

$( ".badEntry" ).css({ color: "red" });

XMLHttpRequest
Some of jQuery's AJAX functions return the native XMLHttpRequest
(XHR) object, or pass it as an argument to success/error/complete
handlers, so that you can do additional processing or monitoring on the
request. Note that AJAX functions only return or pass an XHR object
when an XHR object is actually used in the request. For example,
JSONP requests and cross-domain GET requests use a script element
rather than an XHR object.
Although the XHR object is a standard, there are variations in its
behavior on different browsers. Refer to the W3C site and browsers'
documentation for more information:
W3C standard
Apple (Safari)
Mozilla (Firefox)
Microsoft (Internet Explorer)
Opera
Google does not appear to have an official page for their XHR
documentation for Chrome. As of version 5, Chrome does not support
the use of the file protocol for XHR requests.

jqXHR
As of jQuery 1.5, the $.ajax() method returns the jqXHR object, which
is a superset of the XMLHTTPRequest object. For more information,
see the jqXHR section of the $.ajax entry

Deferred Object
As of jQuery 1.5, the Deferred object provides a way to register
multiple callbacks into self-managed callback queues, invoke callback
queues as appropriate, and relay the success or failure state of any
synchronous or asynchronous function.

Promise Object
This object provides a subset of the methods of the Deferred object
( then , done , fail , always , pipe . isResolved , and isRejected ) to
prevent users from changing the state of the Deferred.

Callbacks Object
A multi-purpose object that provides a powerful way to manage
callback lists. It supports adding, removing, firing, and disabling
callbacks. The Callbacks object is created and returned by the
$.Callbacks function and subsequently returned by most of that
function's methods.
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jQuery UI 1.10 API
Documentation
jQuery UI is a curated set of user interface interactions, effects,
widgets, and themes built on top of the jQuery JavaScript Library. If
you're new to jQuery UI, you might want to check out our main site for
more information and full demos. If you're new to jQuery, you might
also be interested in the jQuery Learning Center tutorials.
This site provides API documentation for jQuery UI 1.10. If you're
working with jQuery UI 1.9, you can find the API documentation on
api.jqueryui.com/1.9/. However, we would encourage you to upgrade to
jQuery UI 1.10 in order to receive the best support and take advantage
of recent bug fixes and enhancements. Check out the release
announcement and upgrade guide to find out more about jQuery UI
1.10.
To get started, use the search at the top of the page, view the full listing
of entries, or browse by category from the sidebar.
jQuery UI 1.10 supports jQuery 1.6 and newer.

Can't find what you're looking for?
Perhaps one of the following sites will help:
jQuery UI 1.9 API Documentation
jQuery UI 1.8 API Documentation
jQuery Core API Documentation
jQuery Mobile API Documentation
jQuery Learning Center
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Category: All
Also in: Widgets

Accordion Widget
Convert a pair of headers and content panels into an accordion.
Also in: Effects | Effects Core | Method Overrides

.addClass()
Adds the specified class(es) to each of the set of matched
elements while animating all style changes.
Also in: Widgets

Autocomplete Widget
Autocomplete enables users to quickly find and select from a prepopulated list of values as they type, leveraging searching and
filtering.
Also in: Effects

Blind Effect
The blind effect hides or shows an element by wrapping the
element in a container, and “pulling the blinds”
Also in: Effects

Bounce Effect
The bounce effect bounces an element. When used with hide or
show, the last or first bounce will also fade in/out.
Also in: Widgets

Button Widget
Themable buttons and button sets.
Also in: Effects

Clip Effect
The clip effect will hide or show an element by clipping the
element vertically or horizontally.
Also in: Selectors | UI Core

:data() Selector
Selects elements which have data stored under the specified key.
Also in: Widgets

Datepicker Widget
Select a date from a popup or inline calendar
Also in: Widgets

Dialog Widget
Open content in an interactive overlay.
Also in: Methods | UI Core

.disableSelection()
Disable selection of text content within the set of matched
elements.
Also in: Interactions

Draggable Widget
Allow elements to be moved using the mouse.
Also in: Effects

Drop Effect
The drop effect hides or shows an element fading in/out and
sliding in a direction.
Also in: Interactions

Droppable Widget
Create targets for draggable elements.
Also in: Effects | Effects Core | Methods

.effect()
Apply an animation effect to an element.
Also in: Methods | UI Core

.enableSelection()
Enable selection of text content within the set of matched
elements.
Also in: Effects

Explode Effect
The explode effect hides or shows an element by splitting it into
pieces.
Also in: Effects

Fade Effect
The fade effect hides or shows an element by fading it.
Also in: Method Overrides | Methods | UI Core

.focus()
Asynchronously set focus to an element.
Also in: Selectors | UI Core

:focusable Selector
Selects elements which can be focused.
Also in: Effects

Fold Effect
The fold effect hides or shows an element by folding it.
Also in: Effects | Effects Core | Method Overrides | Methods

.hide()
Hide the matched elements, using custom effects.
Also in: Effects

Highlight Effect
The highlight effect hides or shows an element by animating its
background color first.
Also in: Utilities | Widgets

Widget Factory
Create stateful jQuery plugins using the same abstraction as all
jQuery UI widgets.
Also in: Widgets

Menu Widget
Themeable menu with mouse and keyboard interactions for
navigation.
Also in: Interactions | Utilities

Mouse Interaction
The base interaction layer.
Also in: Method Overrides | Methods | Utilities

.position()
Position an element relative to another.
Also in: Widgets

Progressbar Widget
Display status of a determinate or indeterminate process.
Also in: Effects

Puff Effect
Creates a puff effect by scaling the element up and hiding it at the
same time.
Also in: Effects

Pulsate Effect
The pulsate effect hides or shows an element by pulsing it in or
out.
Also in: Effects | Effects Core | Method Overrides

.removeClass()
Removes the specified class(es) from each of the set of matched
elements while animating all style changes.
Also in: Methods | UI Core

.removeUniqueId()
Remove ids that were set by .uniqueId() for the set of matched
elements.
Also in: Interactions

Resizable Widget
Change the size of an element using the mouse.
Also in: Effects

Scale Effect
Shrink or grow an element by a percentage factor.
Also in: Methods | UI Core

.scrollParent()
Get the closest ancestor element that is scrollable.
Also in: Interactions

Selectable Widget
Use the mouse to select elements, individually or in a group.
Also in: Effects

Shake Effect
Shakes the element multiple times, vertically or horizontally.
Also in: Effects | Effects Core | Method Overrides | Methods

.show()
Display the matched elements, using custom effects.
Also in: Effects

Size Effect
Resize an element to a specified width and height.
Also in: Effects

Slide Effect
Slides the element out of the viewport.
Also in: Widgets

Slider Widget
Drag a handle to select a numeric value.
Also in: Interactions

Sortable Widget
Reorder elements in a list or grid using the mouse.
Also in: Widgets

Spinner Widget
Enhance a text input for entering numeric values, with up/down
buttons and arrow key handling.
Also in: Effects | Effects Core

.switchClass()
Adds and removes the specified class(es) to each of the set of
matched elements while animating all style changes.
Also in: Selectors | UI Core

:tabbable Selector
Selects elements which the user can focus via tabbing.
Also in: Widgets

Tabs Widget
A single content area with multiple panels, each associated with a
header in a list.
Also in: Effects | Effects Core | Method Overrides | Methods

.toggle()
Display or hide the matched elements, using custom effects.
Also in: Effects | Effects Core | Method Overrides

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument, while animating all style
changes.
Also in: Widgets

Tooltip Widget
Customizable, themeable tooltips, replacing native tooltips.
Also in: Effects

Transfer Effect
Transfers the outline of an element to another element
Also in: Methods | UI Core

.uniqueId()
Generate and apply a unique id for the set of matched elements.
Also in: Methods | UI Core

.zIndex()
Get the z-index for an element.
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Accordion Widget
Categories: Widgets

Accordion Widget

version added: 1.0

Description: Convert a pair of headers and content
panels into an accordion.

QuickNav

Examples

Options

Methods

Events

active
animate
collapsible
disabled
event
header
heightStyle
icons

destroy
disable
enable
option
refresh
widget

activate
beforeActivate
create

The markup of your accordion container needs pairs of headers and
content panels:
1
2
3
4
5
6

<div id="accordion">
<h3>First header</h3>
<div>First content panel</div>
<h3>Second header</h3>
<div>Second content panel</div>
</div>

Accordions support arbitrary markup, but each content panel must
always be the next sibling after its associated header. See the
header option for information on how to use custom markup
structures.
The panels can be activated programmatically by setting the
option.

Keyboard interaction
When focus is on a header, the following key commands are
available:

active

UP/LEFT - Move focus to the previous header. If on first header,
moves focus to last header.
DOWN/RIGHT - Move focus to the next header. If on last
header, moves focus to first header.
HOME - Move focus to the first header.
END - Move focus to the last header.
SPACE/ENTER - Activate panel associated with focused
header.
When focus is in a panel:
CTRL+UP: Move focus to associated header.

Dependencies
UI Core
Widget Factory
Effects Core (optional; for use with the

animate

option)

Additional Notes:
This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific
CSS file as a starting point.

Options
active

Type: Boolean or Integer
Default: 0

Which panel is currently open.
Multiple types supported:
Boolean: Setting active to false will collapse all
panels. This requires the collapsible option to be

true .

Integer: The zero-based index of the panel that is
active (open). A negative value selects panels going
backward from the last panel.
Code examples:
Initialize the accordion with the active option specified:
1

$( ".selector" ).accordion({ active: 2 });

Get or set the active option, after initialization:
1
2
3
4
5

// getter
var active = $( ".selector" ).accordion( "option"
// setter
$( ".selector" ).accordion( "option", "active"

animate
Default: Type:

Boolean or Number or String or Object
{}

If and how to animate changing panels.
Multiple types supported:
Boolean: A value of false will disable animations.
Number: Duration in milliseconds with default easing.
String: Name of easing to use with default duration.
Object: Animation settings with easing and duration
properties.
Can also contain a down property with any of the
above options.
"Down" animations occur when the panel being
activated has a lower index than the currently
active panel.
Code examples:
Initialize the accordion with the animate option specified:
1

$( ".selector" ).accordion({ animate: "bounceslide"

Get or set the animate option, after initialization:
1
2
3
4
5

// getter
var animate = $( ".selector" ).accordion( "option"
// setter
$( ".selector" ).accordion( "option", "animate"

collapsible

Type: Boolean
Default: false

Whether all the sections can be closed at once. Allows
collapsing the active section.
Code examples:

Initialize the accordion with the collapsible option specified:
1

$( ".selector" ).accordion({ collapsible: true

Get or set the collapsible option, after initialization:
1
2
3
4
5

// getter
var collapsible = $( ".selector" ).accordion(
// setter
$( ".selector" ).accordion( "option", "collapsible"

disabled

Type: Boolean
Default: false

Disables the accordion if set to true .
Code examples:
Initialize the accordion with the disabled option specified:
1

$( ".selector" ).accordion({ disabled: true });

Get or set the disabled option, after initialization:
1
2
3
4
5

// getter
var disabled = $( ".selector" ).accordion( "option"
// setter
$( ".selector" ).accordion( "option", "disabled"

Type: String

event

Default: "click"

The event that accordion headers will react to in order to
activate the associated panel. Multiple events can be
specificed, separated by a space.
Code examples:
Initialize the accordion with the event option specified:
1

$( ".selector" ).accordion({ event: "mouseover"

Get or set the event option, after initialization:
1
2
3
4
5

// getter
var event = $( ".selector" ).accordion( "option"
// setter
$( ".selector" ).accordion( "option", "event"

header

Type: Selector
Default: "> li > :first-child,> :not(li):even"

Selector for the header element, applied via .find() on the
main accordion element. Content panels must be the sibling
immedately after their associated headers.
Code examples:
Initialize the accordion with the header option specified:
1

$( ".selector" ).accordion({ header: "h3" });

Get or set the header option, after initialization:
1
2
3
4
5

// getter
var header = $( ".selector" ).accordion( "option"
// setter
$( ".selector" ).accordion( "option", "header"

heightStyle

Type: String
Default: "auto"

Controls the height of the accordion and each panel.
Possible values:
"auto" :

All panels will be set to the height of the tallest

panel.
"fill" :

Expand to the available height based on the
accordion's parent height.
"content" : Each panel will be only as tall as its content.
Code examples:
Initialize the accordion with the heightStyle option specified:
1

$( ".selector" ).accordion({ heightStyle: "fill"

Get or set the heightStyle option, after initialization:
1
2
3

// getter
var heightStyle = $( ".selector" ).accordion(

4
5

// setter
$( ".selector" ).accordion( "option", "heightStyle"

icons

Type: Object

Default: { "header": "ui-icon-triangle-1-e", "activeHeader":
"ui-icon-triangle-1-s" }

Icons to use for headers, matching an icon defined by the
jQuery UI CSS Framework. Set to false to have no icons
displayed.
header (string, default: "ui-icon-triangle-1-e")
activeHeader (string, default: "ui-icon-triangle-1-s")
Code examples:
Initialize the accordion with the icons option specified:
1

$( ".selector" ).accordion({ icons: { "header"

Get or set the icons option, after initialization:
1
2
3
4
5

// getter
var icons = $( ".selector" ).accordion( "option"
// setter
$( ".selector" ).accordion( "option", "icons"

Methods
destroy()
Removes the accordion functionality completely. This will
return the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).accordion( "destroy" );

disable()
Disables the accordion.
This method does not accept any arguments.
Code examples:
Invoke the disable method:
1

$( ".selector" ).accordion( "disable" );

enable()
Enables the accordion.
This method does not accept any arguments.

Code examples:
Invoke the enable method:
1

$( ".selector" ).accordion( "enable" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).accordion(

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current accordion options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).accordion( "option"

option( optionName, value )
Sets the value of the accordion option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).accordion( "option", "disabled"

option( options )
Sets one or more options for the accordion.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).accordion( "option", { disabled:

refresh()
Recompute the height of the accordion panels. Results
depend on the content and the heightStyle option.
This method does not accept any arguments.
Code examples:
Invoke the refresh method:
1

$( ".selector" ).accordion( "refresh" );

widget()

Returns: jQuery

Returns a jQuery object containing the accordion.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).accordion( "widget"

Events
activate( event, ui )

Type:

accordionactivate

Triggered after a panel has been activated (after animation
completes). If the accordion was previously collapsed,
ui.oldHeader and ui.oldPanel will be empty jQuery objects.
If the accordion is collapsing, ui.newHeader and ui.newPanel
will be empty jQuery objects.
event
Type: Event
ui
Type: Object
newHeader
Type: jQuery
The header that was just activated.
oldHeader
Type: jQuery
The header that was just deactivated.
newPanel
Type: jQuery
The panel that was just activated.
oldPanel
Type: jQuery
The panel that was just deactivated.

Code examples:
Initialize the accordion with the activate callback specified:
1

$( ".selector" ).accordion({

2
3

activate: function( event, ui ) {}
});

Bind an event listener to the accordionactivate event:
1

$( ".selector" ).on( "accordionactivate", function

beforeActivate( event, ui )
Type:

accordionbeforeactivate

Triggered directly before a
panel is activated. Can be canceled to prevent the panel
from activating. If the accordion is currently collapsed,
ui.oldHeader and ui.oldPanel will be empty jQuery objects.
If the accordion is collapsing, ui.newHeader and ui.newPanel
will be empty jQuery objects.
event
Type: Event
ui
Type: Object
newHeader
Type: jQuery
The header that is about to be activated.
oldHeader
Type: jQuery
The header that is about to be deactivated.
newPanel
Type: jQuery
The panel that is about to be activated.
oldPanel
Type: jQuery

The panel that is about to be deactivated.

Code examples:
Initialize the accordion with the beforeActivate callback
specified:
1
2
3

$( ".selector" ).accordion({
beforeActivate: function( event, ui ) {}
});

Bind an event listener to the accordionbeforeactivate event:
1

$( ".selector" ).on( "accordionbeforeactivate"

create( event, ui )

Type:

accordioncreate

Triggered when the accordion is created. If the accordion is
collapsed, ui.header and ui.panel will be empty jQuery
objects.
event
Type: Event
ui
Type: Object
header
Type: jQuery
The active header.
panel
Type: jQuery
The active panel.

Code examples:
Initialize the accordion with the create callback specified:
1
2
3

$( ".selector" ).accordion({
create: function( event, ui ) {}
});

Bind an event listener to the accordioncreate event:
1

$( ".selector" ).on( "accordioncreate", function

Example:
A simple jQuery UI Accordion
1
2
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>accordion demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>

<div id="accordion">
<h3>Section 1</h3>
<div>
<p>Mauris mauris ante, blandit et, ultrices a, susci
Integer ut neque. Vivamus nisi metus, molestie vel,
condimentum sit amet, nunc. Nam a nibh. Donec suscip
Nam mi. Proin viverra leo ut odio.</p>
</div>
<h3>Section 2</h3>
<div>
<p>Sed non urna. Phasellus eu ligula. Vestibulum sit
Vivamus hendrerit, dolor aliquet laoreet, mauris tur
faucibus interdum tellus libero ac justo.</
</div>
<h3>Section 3</h3>
<div>
<p>Nam enim risus, molestie et, porta ac, aliquam ac
Quisque lobortis.Phasellus pellentesque purus in mas
<ul>
<li>List item one</li>
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<li>List item two</li>
<li>List item three</li>
</ul>
</div>
</div>
<script>
$( "#accordion" ).accordion();
</script>
</body>
</html>

Demo
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.addClass()
Categories: Effects | Effects Core | Method Overrides

.addClass( className [, duration ] [, easing ] [, complete ]
)
Returns: jQuery
Description: Adds the specified class(es) to each of the
set of matched elements while animating all style
changes.
.addClass( className [, duration ] [, easing ] [,
complete ] )
className
Type: String
One or more class names (space separated) to be added to the
class attribute of each matched element.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.
Similar to native CSS transitions, jQuery UI's class animations
provide a smooth transition from one state to another while allowing
you to keep all the details about which styles to change in CSS and
out of your JavaScript. All class animation methods, including
.addClass() , support custom durations and easings, as well as
providing a callback for when the animation completes.
Not all styles can be animated. For example, there is no way to
animate a background image. Any styles that cannot be animated
will be changed at the end of the animation.
This plugin extends jQuery's built-in

.addClass()

method. If jQuery

UI is not loaded, calling the .addClass() method may not fail directly,
as the method still exists. However, the expected behavior will not
occur.

Example:
Adds the class "big-blue" to the matched elements.
1
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>addClass demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
div {
width: 100px;
height: 100px;
background-color: #ccc;
}
.big-blue {
width: 200px;
height: 200px;
background-color: #00f;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div></div>
<script>
$( "div" ).click(function() {
$( this ).addClass( "big-blue", 1000, "easeOutBounce"
});
</script>
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</body>
</html>
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Autocomplete Widget
Categories: Widgets

Autocomplete Widget

version added: 1.8

Description: Autocomplete enables users to quickly find
and select from a pre-populated list of values as they
type, leveraging searching and filtering.

QuickNav

Examples

Options

Methods

Events

appendTo
autoFocus
delay
disabled
minLength
position
source

close
destroy
disable
enable
option
search
widget

change
close
create
focus
open
response
search
select

By giving an Autocomplete field focus or entering something into it,
the plugin starts searching for entries that match and displays a list
of values to choose from. By entering more characters, the user can
filter down the list to better matches.
This can be used to choose previously selected values, such as
entering tags for articles or entering email addresses from an
address book. Autocomplete can also be used to populate
associated information, such as entering a city name and getting the
zip code.
You can pull data in from a local or remote source: Local is good for
small data sets, e.g., an address book with 50 entries; remote is
necessary for big data sets, such as a database with hundreds or
millions of entries to select from. To find out more about customizing
the data soure, see the documentation for the source option.

Keyboard interaction
When the menu is open, the following key commands are available:
UP - Move focus to the previous item. If on first item, move
focus to the input. If on the input, move focus to last item.
DOWN - Move focus to the next item. If on last item, move

focus to the input. If on the input, move focus to the first item.
ESCAPE - Close the menu.
ENTER - Select the currently focused item and close the menu.
TAB - Select the currently focused item, close the menu, and
move focus to the next focusable element.
PAGE UP/DOWN - Scroll through a page of items (based on
height of menu). It's generally a bad idea to display so many
items that users need to page..
When the menu is closed, the following key commands are
available:
UP/DOWN - Open the menu, if the

minLength

has been met.

Dependencies
UI Core
Widget Factory
Position
Menu

Additional Notes:
This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific
CSS file as a starting point.
This widget manipulates its element's value programmatically,
therefore a native change may not be fired when the element's
value changes.

Options
appendTo

Type: Selector
Default: null

Which element the menu should be appended to. When the
value is null , the parents of the input field will be checked
for a class of ui-front . If an element with the ui-front class
is found, the menu will be appended to that element.
Regardless of the value, if no element is found, the menu
will be appended to the body.
Code examples:
Initialize the autocomplete with the appendTo option
specified:
1

$( ".selector" ).autocomplete({ appendTo: "#someElem"

Get or set the appendTo option, after initialization:
1
2
3
4
5

// getter
var appendTo = $( ".selector" ).autocomplete(
// setter
$( ".selector" ).autocomplete( "option", "appendTo"

autoFocus

Type: Boolean
Default: false

If set to true the first item will automatically be focused
when the menu is shown.

Code examples:
Initialize the autocomplete with the autoFocus option
specified:
1

$( ".selector" ).autocomplete({ autoFocus: true

Get or set the autoFocus option, after initialization:
1
2
3
4
5

// getter
var autoFocus = $( ".selector" ).autocomplete(
// setter
$( ".selector" ).autocomplete( "option", "autoFocus"

delay

Type: Integer
Default: 300

The delay in milliseconds between when a keystroke occurs
and when a search is performed. A zero-delay makes sense
for local data (more responsive), but can produce a lot of
load for remote data, while being less responsive.
Code examples:
Initialize the autocomplete with the delay option specified:
1

$( ".selector" ).autocomplete({ delay: 500 });

Get or set the delay option, after initialization:
1
2

// getter
var delay = $( ".selector" ).autocomplete( "option"

3
4
5

// setter
$( ".selector" ).autocomplete( "option", "delay"

disabled

Type: Boolean
Default: false

Disables the autocomplete if set to true .
Code examples:
Initialize the autocomplete with the disabled option specified:
1

$( ".selector" ).autocomplete({ disabled: true

Get or set the disabled option, after initialization:
1
2
3
4
5

// getter
var disabled = $( ".selector" ).autocomplete(
// setter
$( ".selector" ).autocomplete( "option", "disabled"

minLength

Type: Integer
Default: 1

The minimum number of characters a user must type before
a search is performed. Zero is useful for local data with just
a few items, but a higher value should be used when a
single character search could match a few thousand items.
Code examples:
Initialize the autocomplete with the minLength option

specified:
1

$( ".selector" ).autocomplete({ minLength: 0 });

Get or set the minLength option, after initialization:
1
2
3
4
5

// getter
var minLength = $( ".selector" ).autocomplete(
// setter
$( ".selector" ).autocomplete( "option", "minLength"

position

Type: Object

Default: { my: "left top", at: "left bottom", collision:
"none" }

Identifies the position of the suggestions menu in relation to
the associated input element. The of option defaults to the
input element, but you can specify another element to
position against. You can refer to the jQuery UI Position
utility for more details about the various options.
Code examples:
Initialize the autocomplete with the position option specified:
1

$( ".selector" ).autocomplete({ position: { my :

Get or set the position option, after initialization:
1
2

// getter
var position = $( ".selector" ).autocomplete(

3
4
5

// setter
$( ".selector" ).autocomplete( "option", "position"

source
Type: Array or String or Function( Object request,
Function response( Object data ) )
Default: none; must be specified

Defines the data to use, must be specified.
Independent of the variant you use, the label is always
treated as text. If you want the label to be treated as html
you can use Scott González' html extension. The demos all
focus on different variations of the source option - look for
one that matches your use case, and check out the code.
Multiple types supported:
Array: An array can be used for local data. There are
two supported formats:
An array of strings: [ "Choice1", "Choice2" ]
An array of objects with label and value
properties: [ { label: "Choice1", value:

"value1"

}, ... ]

The label property is displayed in the suggestion menu.
The value will be inserted into the input element when a
user selects an item. If just one property is specified, it
will be used for both, e.g., if you provide only value
properties, the value will also be used as the label.
String: When a string is used, the Autocomplete plugin
expects that string to point to a URL resource that will
return JSON data. It can be on the same host or on a
different one (must provide JSONP). The Autocomplete
plugin does not filter the results, instead a query string
is added with a term field, which the server-side script
should use for filtering the results. For example, if the
source option is set to "http://example.com" and the
user types foo , a GET request would be made to

http://example.com?term=foo .

The data itself can be in
the same format as the local data described above.
Function: The third variation, a callback, provides the
most flexibility and can be used to connect any data
source to Autocomplete. The callback gets two
arguments:
A request object, with a single term property, which
refers to the value currently in the text input. For
example, if the user enters "new yo" in a city field,
the Autocomplete term will equal "new yo" .
A response callback, which expects a single
argument: the data to suggest to the user. This
data should be filtered based on the provided term,
and can be in any of the formats described above
for simple local data. It's important when providing
a custom source callback to handle errors during
the request. You must always call the response
callback even if you encounter an error. This
ensures that the widget always has the correct
state.
When filtering data locally, you can make use of the
built-in $.ui.autocomplete.escapeRegex function. It'll take
a single string argument and escape all regex
characters, making the result safe to pass to new
RegExp() .
Code examples:
Initialize the autocomplete with the source option specified:
1

$( ".selector" ).autocomplete({ source: [ "c++"

Get or set the source option, after initialization:
1
2
3

// getter
var source = $( ".selector" ).autocomplete( "option"

4
5

// setter
$( ".selector" ).autocomplete( "option", "source"

Methods
close()
Closes the Autocomplete menu. Useful in combination with
the search method, to close the open menu.
This method does not accept any arguments.
Code examples:
Invoke the close method:
1

$( ".selector" ).autocomplete( "close" );

destroy()
Removes the autocomplete functionality completely. This will
return the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).autocomplete( "destroy" );

disable()
Disables the autocomplete.

This method does not accept any arguments.
Code examples:
Invoke the disable method:
1

$( ".selector" ).autocomplete( "disable" );

enable()
Enables the autocomplete.
This method does not accept any arguments.
Code examples:
Invoke the enable method:
1

$( ".selector" ).autocomplete( "enable" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).autocomplete(

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current autocomplete options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).autocomplete(

option( optionName, value )
Sets the value of the autocomplete option associated with
the specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).autocomplete( "option", "disabled"

option( options )
Sets one or more options for the autocomplete.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).autocomplete( "option", { disabled:

search( [value ] )
Triggers a search event and invokes the data source if the
event is not canceled. Can be used by a selectbox-like
button to open the suggestions when clicked. When invoked
with no parameters, the current input's value is used. Can
be called with an empty string and minLength: 0 to display
all items.
value
Type: String
Code examples:
Invoke the search method:
1

$( ".selector" ).autocomplete( "search", "" );

widget()

Returns: jQuery

Returns a jQuery object containing the menu element.
Although the menu items are constantly created and
destroyed, the menu element itself is created during
initialization and is constantly reused.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

$( ".selector" ).autocomplete( "widget" );

Events
change( event, ui )

Type:

autocompletechange

Triggered when the field is blurred, if the value has changed.
event
Type: Event
ui
Type: Object
item
Type: jQuery
The item selected from the menu, if any. Otherwise
the property is null .

Code examples:
Initialize the autocomplete with the change callback
specified:
1
2
3

$( ".selector" ).autocomplete({
change: function( event, ui ) {}
});

Bind an event listener to the autocompletechange event:
1

$( ".selector" ).on( "autocompletechange", function

close( event, ui )

Type:

autocompleteclose

Triggered when the menu is hidden. Not every
will be accompanied by a change event.
event
Type: Event

close

event

ui
Type: Object
Code examples:
Initialize the autocomplete with the close callback specified:
1
2
3

$( ".selector" ).autocomplete({
close: function( event, ui ) {}
});

Bind an event listener to the autocompleteclose event:
1

$( ".selector" ).on( "autocompleteclose", function

create( event, ui )

Type:

autocompletecreate

Triggered when the autocomplete is created.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the autocomplete with the create callback specified:
1

$( ".selector" ).autocomplete({

2
3

create: function( event, ui ) {}
});

Bind an event listener to the autocompletecreate event:
1

$( ".selector" ).on( "autocompletecreate", function

focus( event, ui )

Type:

autocompletefocus

Triggered when focus is moved to an item (not selecting).
The default action is to replace the text field's value with the
value of the focused item, though only if the event was
triggered by a keyboard interaction.
Canceling this event prevents the value from being updated,
but does not prevent the menu item from being focused.
event
Type: Event
ui
Type: Object
item
Type: jQuery
The focused item.

Code examples:
Initialize the autocomplete with the focus callback specified:
1
2
3

$( ".selector" ).autocomplete({
focus: function( event, ui ) {}
});

Bind an event listener to the autocompletefocus event:
1

$( ".selector" ).on( "autocompletefocus", function

open( event, ui )

Type:

autocompleteopen

Triggered when the suggestion menu is opened or updated.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the autocomplete with the open callback specified:
1
2
3

$( ".selector" ).autocomplete({
open: function( event, ui ) {}
});

Bind an event listener to the autocompleteopen event:
1

$( ".selector" ).on( "autocompleteopen", function

response( event, ui ) Type:

autocompleteresponse

Triggered after a search completes, before the menu is
shown. Useful for local manipulation of suggestion data,
where a custom source option callback is not required. This

event is always triggered when a search completes, even if
the menu will not be shown because there are no results or
the Autocomplete is disabled.
event
Type: Event
ui
Type: Object
content
Type: Array
Contains the response data and can be modified to
change the results that will be shown. This data is
already normalized, so if you modify the data,
make sure to include both value and label
properties for each item.

Code examples:
Initialize the autocomplete with the response callback
specified:
1
2
3

$( ".selector" ).autocomplete({
response: function( event, ui ) {}
});

Bind an event listener to the autocompleteresponse event:
1

$( ".selector" ).on( "autocompleteresponse",

search( event, ui )

Type:

autocompletesearch

Triggered before a search is performed, after minLength and
delay are met. If canceled, then no request will be started
and no items suggested.

event
Type: Event
ui
Type: Object
Code examples:
Initialize the autocomplete with the search callback
specified:
1
2
3

$( ".selector" ).autocomplete({
search: function( event, ui ) {}
});

Bind an event listener to the autocompletesearch event:
1

$( ".selector" ).on( "autocompletesearch", function

select( event, ui )

Type:

autocompleteselect

Triggered when an item is selected from the menu. The
default action is to replace the text field's value with the
value of the selected item.
Canceling this event prevents the value from being updated,
but does not prevent the menu from closing.
event
Type: Event
ui
Type: Object
item
Type: jQuery
The selected item.

Code examples:
Initialize the autocomplete with the select callback specified:
1
2
3

$( ".selector" ).autocomplete({
select: function( event, ui ) {}
});

Bind an event listener to the autocompleteselect event:
1

$( ".selector" ).on( "autocompleteselect", function

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22

A simple jQuery UI Autocomplete

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>autocomplete demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>

<label for="autocomplete">Select a programming language:
<input id="autocomplete">
<script>
$( "#autocomplete" ).autocomplete({
source: [ "c++", "java", "php", "coldfusion",
});
</script>
</body>
</html>

Demo
Example:

Using a custom source callback to match
only the beginning of terms
1
2

<!doctype html>
<html lang="en">

3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
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22
23
24
25
26
27
28

<head>
<meta charset="utf-8">
<title>autocomplete demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>

<label for="autocomplete">Select a programming language:
<input id="autocomplete">

<script>
var tags = [ "c++", "java", "php", "coldfusion"
$( "#autocomplete" ).autocomplete({
source: function( request, response ) {
var matcher = new RegExp( "^" + $.ui.autocompl
response( $.grep( tags, function( item ){
return matcher.test( item );
}) );
}
});
</script>
</body>
</html>

Demo
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Blind Effect
Categories: Effects

Blind Effect
Description: The blind effect hides or shows an element
by wrapping the element in a container, and "pulling the
blinds"
blind
direction (default: "up" )
Type: String
The direction the blind will be pulled to hide the element, or the
direction from which the element will be revealed.
Possible Values:

up , down , left , right , vertical , horizontal .

The container has overflow:
affect what's visible.

hidden

applied, so height changes

Example:
Toggle a div using the blind effect.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>blind demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle( "blind" );
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

Bounce Effect
Categories: Effects

Bounce Effect
Description: The bounce effect bounces an element.
When used with hide or show, the last or first bounce will
also fade in/out.
bounce
distance (default: 20 )
Type: Number
The distance of the largest "bounce" in pixels.
times (default: 5 )
Type: Integer
The number of times the element will bounce. When used with
hide or show, there is an extra "half" bounce for the fade in/out.

Example:
Toggle a div using the bounce effect.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>bounce demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle( "bounce", { times: 3 },
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

Button Widget
Categories: Widgets

Button Widget

version added: 1.8

Description: Themable buttons and button sets.

QuickNav

Examples

Options

Methods

Events

disabled
icons
label
text

destroy
disable
enable
refresh
option
widget

create

Button enhances standard form elements like buttons, inputs and
anchors to themable buttons with appropiate hover and active styles.
In addition to basic push buttons, radio buttons and checkboxes
(inputs of type radio and checkbox) can be converted to buttons.
Their associated label is styled to appear as the button, while the
underlying input is updated on click. For the association to work
properly, give the input an id attribute, and refer to that in the label's
for attribute. Don't nest the input inside the label, as that causes
accessbility problems.
In order to group radio buttons, Button also provides an additional
widget, called Buttonset. Buttonset is used by selecting a container
element (which contains the radio buttons) and calling .buttonset() .
Buttonset will also provide visual grouping, and therefore should be
used whenever you have a group of buttons. It works by selecting all
descendants and applying .button() to them. You can enable and
disable a button set, which will enable and disable all contained
buttons. Destroying a button set also calls each button's destroy
method.
When using an input of type button, submit or reset, support is
limited to plain text labels with no icons.

Dependencies
UI Core

Widget Factory

Additional Notes:
This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific
CSS file as a starting point.

Options
disabled

Type: Boolean
Default: false

Disables the button if set to true .
Code examples:
Initialize the button with the disabled option specified:
1

$( ".selector" ).button({ disabled: true });

Get or set the disabled option, after initialization:
1
2
3
4
5

// getter
var disabled = $( ".selector" ).button( "option"
// setter
$( ".selector" ).button( "option", "disabled"

icons

Type: Object
Default: { primary: null, secondary: null }

Icons to display, with or without text (see text option). By
default, the primary icon is displayed on the left of the label
text and the secondary is displayed on the right. The
positioning can be controlled via CSS. The value for the
primary and secondary properties must be a class name,
e.g., "ui-icon-gear" . For using only one icon: icons: {
primary: "ui-icon-locked" } . For using two icons: icons: {
primary: "ui-icon-gear", secondary: "ui-icon-triangle-1-s"

}.

Code examples:
Initialize the button with the icons option specified:
1

$( ".selector" ).button({ icons: { primary: "ui-icon-

Get or set the icons option, after initialization:
1
2
3
4
5

// getter
var icons = $( ".selector" ).button( "option"

// setter
$( ".selector" ).button( "option", "icons", { primary

Type: String

label

Default: null

Text to show in the button. When not specified ( null ), the
element's HTML content is used, or its value attribute if the
element is an input element of type submit or reset, or the
HTML content of the associated label element if the element
is an input of type radio or checkbox.
Code examples:
Initialize the button with the label option specified:
1

$( ".selector" ).button({ label: "custom label"

Get or set the label option, after initialization:
1

// getter

2
3
4
5

var label = $( ".selector" ).button( "option"

// setter
$( ".selector" ).button( "option", "label", "custom l

Type: Boolean

text

Default: true

Whether to show the label. When set to false no text will be
displayed, but the icons option must be enabled, otherwise
the text option will be ignored.
Code examples:
Initialize the button with the text option specified:
1

$( ".selector" ).button({ text: false });

Get or set the text option, after initialization:
1
2
3
4
5

// getter
var text = $( ".selector" ).button( "option",
// setter
$( ".selector" ).button( "option", "text", false

Methods
destroy()
Removes the button functionality completely. This will return
the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).button( "destroy" );

disable()
Disables the button.
This method does not accept any arguments.
Code examples:
Invoke the disable method:
1

$( ".selector" ).button( "disable" );

enable()
Enables the button.
This method does not accept any arguments.

Code examples:
Invoke the enable method:
1

$( ".selector" ).button( "enable" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).button( "option"

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current button options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).button( "option"

option( optionName, value )
Sets the value of the button option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).button( "option", "disabled"

option( options )
Sets one or more options for the button.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).button( "option", { disabled:

refresh()
Refreshes the visual state of the button. Useful for updating
button state after the native element's checked or disabled
state is changed programmatically.
This method does not accept any arguments.
Code examples:
Invoke the refresh method:
1

$( ".selector" ).button( "refresh" );

widget()

Returns: jQuery

Returns a jQuery object containing the element visually
representing the button.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).button( "widget"

Events
create( event, ui )

Type:

buttoncreate

Triggered when the button is created.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the button with the create callback specified:
1
2
3

$( ".selector" ).button({
create: function( event, ui ) {}
});

Bind an event listener to the buttoncreate event:
1

$( ".selector" ).on( "buttoncreate", function

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>button demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<button>Button label</button>
<script>
$( "button" ).button();
</script>
</body>
</html>

Demo
Example:
1
2
3
4
5
6

A simple jQuery UI Button

A simple jQuery UI Buttonset

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>button demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui

7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23

<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div id="radio">
<input type="radio" id="radio1" name="radio">
<input type="radio" id="radio2" name="radio"
<input type="radio" id="radio3" name="radio">
</div>
<script>
$( "#radio" ).buttonset();
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

Clip Effect
Categories: Effects

Clip Effect
Description: The clip effect will hide or show an
element by clipping the element vertically or horizontally.
clip
direction (default: "up" )
Type: String
The plane in which the clip effect will hide or show its element.
clips the top and bottom edges, while
the right and left edges.
vertical

horizontal

clips

Example:
Toggle a div using the clip effect.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>clip demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle( "clip" );
});
</script>
</body>
</html>

Demo
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:data() Selector
Categories: Selectors | UI Core

data selector
Description: Selects elements which have data stored
under the specified key.
jQuery( ":data(key)" )
key: The data key.
The expression $( "div:data(foo)") matches a
stored via .data( "foo", value ) .

<div>

if it has data

Example:
Select elements with data and change their
background color.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>data demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
div {
width: 100px;
height: 100px;
border: 1px solid #000;
float: left;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div id="one"></div>
<div id="two"></div>
<div id="three"></div>
<script>
$( "#one" ).data( "color", "blue" );
$( "#three" ).data( "color", "green" );
$( ":data(color)" ).each(function() {
var element = $( this );
element.css( "backgroundColor", element.data(

31
32
33
34
35

});
</script>
</body>
</html>

Demo
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Datepicker Widget
Categories: Widgets

Datepicker Widget

version added: 1.0

Description: Select a date from a popup or inline
calendar

QuickNav
Options

Examples
Methods

altField
destroy
altFormat
dialog
appendText
isDisabled
autoSize
hide
buttonImage
show
buttonImageOnly
refresh
buttonText
getDate
calculateWeek
setDate
changeMonth
option
changeYear
widget
closeText
constrainInput
currentText
dateFormat
dayNames
dayNamesMin
dayNamesShort
defaultDate
duration
firstDay
gotoCurrent
hideIfNoPrevNext
isRTL
maxDate
minDate
monthNames
monthNamesShort
navigationAsDateFormat
nextText
numberOfMonths
prevText
selectOtherMonths
shortYearCutoff

Events

showAnim
showButtonPanel
showCurrentAtPos
showMonthAfterYear
showOn
showOptions
showOtherMonths
showWeek
stepMonths
weekHeader
yearRange
yearSuffix
beforeShow
beforeShowDay
onChangeMonthYear
onClose
onSelect
The jQuery UI Datepicker is a highly configurable plugin that adds
datepicker functionality to your pages. You can customize the date
format and language, restrict the selectable date ranges and add in
buttons and other navigation options easily.
By default, the datepicker calendar opens in a small overlay when
the associated text field gains focus. For an inline calendar, simply
attach the datepicker to a div or span.

Keyboard interaction
While the datepicker is open, the following key commands are
available:
PAGE UP: Move to the previous month.
PAGE DOWN: Move to the next month.
CTRL+PAGE UP: Move to the previous year.
CTRL+PAGE DOWN: Move to the next year.
CTRL+HOME: Move to the current month. Open the datepicker
if closed.
CTRL+LEFT: Move to the previous day.

CTRL+RIGHT: Move to the next day.
CTRL+UP: Move to the previous week.
CTRL+DOWN: Move the next week.
ENTER: Select the focused date.
CTRL+END: Close the datepicker and erase the date.
ESCAPE: Close the datepicker without selection.

Utility functions
$.datepicker.setDefaults( settings )
Change the default settings for all date pickers.
Use the

option()

method to change settings for individual instances.

Code examples:
Set all date pickers to open on focus or a click on an icon.
1
2
3
4
5
6

$.datepicker.setDefaults({
showOn: "both",
buttonImageOnly: true,
buttonImage: "calendar.gif",
buttonText: "Calendar"
});

Set all date pickers to have French text.
1

$.datepicker.setDefaults( $.datepicker.regional[

$.datepicker.formatDate( format, date, settings )
Format a date into a string value with a specified format.
The format can be combinations of the following:

d - day of month (no leading zero)
dd - day of month (two digit)
o - day of the year (no leading zeros)
oo - day of the year (three digit)
D - day name short
DD - day name long
m - month of year (no leading zero)
mm - month of year (two digit)
M - month name short
MM - month name long
y - year (two digit)
yy - year (four digit)
@ - Unix timestamp (ms since 01/01/1970)
! - Windows ticks (100ns since 01/01/0001)
'...' - literal text
'' - single quote
anything else - literal text
There are also a number of predefined standard date formats
available from $.datepicker :
ATOM - 'yy-mm-dd' (Same as RFC 3339/ISO 8601)
COOKIE - 'D, dd M yy'
ISO_8601 - 'yy-mm-dd'
RFC_822 - 'D, d M y' (See RFC 822)
RFC_850 - 'DD, dd-M-y' (See RFC 850)
RFC_1036 - 'D, d M y' (See RFC 1036)
RFC_1123 - 'D, d M yy' (See RFC 1123)
RFC_2822 - 'D, d M yy' (See RFC 2822)
RSS - 'D, d M y' (Same as RFC 822)
TICKS - '!'

TIMESTAMP - '@'
W3C - 'yy-mm-dd' (Same as ISO 8601)
Code examples:
Display the date in ISO format. Produces "2007-01-26".
1

$.datepicker.formatDate( "yy-mm-dd", new Date( 2007

Display the date in expanded French format. Produces "Samedi,
Juillet 14, 2007".
1
2
3
4
5
6

$.datepicker.formatDate( "DD, MM d, yy", new Date(
dayNamesShort: $.datepicker.regional[ "fr" ].dayNamesS
dayNames: $.datepicker.regional[ "fr" ].dayNames,
monthNamesShort: $.datepicker.regional[ "fr" ].monthNa
monthNames: $.datepicker.regional[ "fr" ].monthNames
});

$.datepicker.parseDate( format, value, settings )
Extract a date from a string value with a specified format.
The format can be combinations of the following:
d - day of month (no leading zero)
dd - day of month (two digit)
o - day of year (no leading zeros)
oo - day of year (three digit)
D - day name short
DD - day name long
m - month of year (no leading zero)
mm - month of year (two digit)

M - month name short
MM - month name long
y - year (two digit)
yy - year (four digit)
@ - Unix timestamp (ms since 01/01/1970)
! - Windows ticks (100ns since 01/01/0001)
'...' - literal text
'' - single quote
anything else - literal text
A number of exceptions may be thrown:
'Invalid arguments' if either format or value is null
'Missing number at position nn' if format indicated a numeric
value that is not then found
'Unknown name at position nn' if format indicated day or month
name that is not then found
'Unexpected literal at position nn' if format indicated a literal
value that is not then found
'Invalid date' if the date is invalid, such as '31/02/2007'
Code examples:
Extract a date in ISO format.
1

$.datepicker.parseDate( "yy-mm-dd", "2007-01-26"

Extract a date in expanded French format.
1
2
3
4

$.datepicker.parseDate( "DD, MM d, yy", "Samedi, Juillet
shortYearCuroff: 20,
dayNamesShort: $.datepicker.regional[ "fr" ].dayNamesS
dayNames: $.datepicker.regional[ "fr" ].dayNames,

5
6
7

monthNamesShort: $.datepicker.regional[ "fr" ].monthNa
monthNames: $.datepicker.regional[ "fr" ].monthNames
});

$.datepicker.iso8601Week( date )
Determine the week of the year for a given date: 1 to 53.
This function uses the ISO 8601 definition of a week: weeks start on
a Monday and the first week of the year contains January 4. This
means that up to three days from the previous year may be included
in the of first week of the current year, and that up to three days from
the current year may be included in the last week of the previous
year.
This function is the default implementation for the
option.

calculateWeek

Code examples:
Find the week of the year for a date.
1

$.datepicker.iso8601Week( new Date( 2007, 1 - 1,

$.datepicker.noWeekends
Set as beforeShowDay function to prevent selection of weekends.
We can provide the noWeekends() function into the beforeShowDay
option which will calculate all the weekdays and provide an array of
true / false values indicating whether a date is selectable.
Code examples:
Set the DatePicker so no weekend is selectable
1
2
3

$( "#datepicker" ).datepicker({
beforeShowDay: $.datepicker.noWeekends
});

Localization
Datepicker provides support for localizing its content to cater for
different languages and date formats. Each localization is contained
within its own file with the language code appended to the name,
e.g., jquery.ui.datepicker-fr.js for French. The desired localization
file should be included after the main datepicker code. Each
localization file adds its settings to the set of available localizations
and automatically applies them as defaults for all instances.
The $.datepicker.regional attribute holds an array of localizations,
indexed by language code, with "" referring to the default (English).
Each entry is an object with the following attributes: closeText ,
prevText , nextText , currentText , monthNames , monthNamesShort ,
dayNames , dayNamesShort , dayNamesMin , weekHeader , dateFormat ,
firstDay , isRTL , showMonthAfterYear , and yearSuffix .
You can restore the default localizations with:
$.datepicker.setDefaults( $.datepicker.regional[ "" ] );

And can then override an individual datepicker for a specific locale:
$( selector ).datepicker( $.datepicker.regional[ "fr" ] );

Dependencies
UI Core
Effects Core (optional; for use with the

showAnim

option)

Additional Notes:
This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific
CSS file as a starting point.
This widget manipulates its element's value programmatically,
therefore a native change may not be fired when the element's
value changes.

Options
altField

Type: Selector or jQuery or Element
Default: ""

An input element that is to be updated with the selected date
from the datepicker. Use the altFormat option to change the
format of the date within this field. Leave as blank for no
alternate field.
Code examples:
Initialize the datepicker with the altField option specified:
1

$( ".selector" ).datepicker({ altField: "#actualDate"

Get or set the altField option, after initialization:
1
2
3
4
5

// getter
var altField = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "altField"

altFormat

Type: String
Default: ""

The dateFormat to be used for the altField option. This
allows one date format to be shown to the user for selection
purposes, while a different format is actually sent behind the
scenes. For a full list of the possible formats see the
[[UI/Datepicker/formatDate|formatDate]] function

Code examples:
Initialize the datepicker with the altFormat option specified:
1

$( ".selector" ).datepicker({ altFormat: "yy-mm-dd"

Get or set the altFormat option, after initialization:
1
2
3
4
5

// getter
var altFormat = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "altFormat"

appendText

Type: String
Default: ""

The text to display after each date field, e.g., to show the
required format.
Code examples:
Initialize the datepicker with the appendText option
specified:
1

$( ".selector" ).datepicker({ appendText: "(yyyy-mm-d

Get or set the appendText option, after initialization:
1
2
3
4

// getter
var appendText = $( ".selector" ).datepicker(
// setter

5

$( ".selector" ).datepicker( "option", "appendText"

Type: Boolean

autoSize

Default: false

Set to true to automatically resize the input field to
accommodate dates in the current dateFormat .
Code examples:
Initialize the datepicker with the autoSize option specified:
1

$( ".selector" ).datepicker({ autoSize: true });

Get or set the autoSize option, after initialization:
1
2
3
4
5

// getter
var autoSize = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "autoSize"

beforeShow
Default: Type:

Function( Element input, Object inst )
null

A function that takes an input field and current datepicker
instance and returns an options object to update the
datepicker with. It is called just before the datepicker is
displayed.

beforeShowDay

Type: Function( Date date )
Default: null

A function takes a date as a parameter and must return an
array with [0] equal to true / false indicating whether or not
this date is selectable, [1] equal to a CSS class name or ""
for the default presentation, and [2] an optional popup
tooltip for this date. It is called for each day in the datepicker
before it is displayed.

buttonImage

Type: String
Default: ""

The URL for the popup button image. If set, the buttonText
option becomes the alt value and is not directly displayed.
Code examples:
Initialize the datepicker with the buttonImage option
specified:
1

$( ".selector" ).datepicker({ buttonImage: "/images/d

Get or set the buttonImage option, after initialization:
1
2
3
4
5

// getter
var buttonImage = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "buttonImage"

buttonImageOnly

Type: Boolean
Default: false

Whether the button image should be rendered by itself
instead of inside a button element.
Code examples:
Initialize the datepicker with the buttonImageOnly option
specified:
1

$( ".selector" ).datepicker({ buttonImageOnly:

Get or set the buttonImageOnly option, after initialization:
1
2
3
4
5

// getter
var buttonImageOnly = $( ".selector" ).datepicker(

// setter
$( ".selector" ).datepicker( "option", "buttonImageOn

buttonText

Type: String
Default: "..."

The text to display on the trigger button. Use in conjunction
with the showOn option set to "button" or "both" .
Code examples:
Initialize the datepicker with the buttonText option specified:
1

$( ".selector" ).datepicker({ buttonText: "Choose"

Get or set the buttonText option, after initialization:
1
2

// getter
var buttonText = $( ".selector" ).datepicker(

3
4
5

// setter
$( ".selector" ).datepicker( "option", "buttonText"

calculateWeek

Type: Function()
Default: jQuery.datepicker.iso8601Week

A function to calculate the week of the year for a given date.
The default implementation uses the ISO 8601 definition:
weeks start on a Monday; the first week of the year contains
the first Thursday of the year.
Code examples:
Initialize the datepicker with the calculateWeek option
specified:
1

$( ".selector" ).datepicker({ calculateWeek: myWeekCa

Get or set the calculateWeek option, after initialization:
1
2
3
4
5

// getter
var calculateWeek = $( ".selector" ).datepicker(

// setter
$( ".selector" ).datepicker( "option", "calculateWeek

changeMonth

Type: Boolean
Default: false

Whether the month should be rendered as a dropdown
instead of text.

Code examples:
Initialize the datepicker with the changeMonth option
specified:
1

$( ".selector" ).datepicker({ changeMonth: true

Get or set the changeMonth option, after initialization:
1
2
3
4
5

// getter
var changeMonth = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "changeMonth"

changeYear

Type: Boolean
Default: false

Whether the year should be rendered as a dropdown
instead of text. Use the yearRange option to control which
years are made available for selection.
Code examples:
Initialize the datepicker with the changeYear option
specified:
1

$( ".selector" ).datepicker({ changeYear: true

Get or set the changeYear option, after initialization:
1
2

// getter
var changeYear = $( ".selector" ).datepicker(

3
4
5

// setter
$( ".selector" ).datepicker( "option", "changeYear"

closeText

Type: String
Default: "Done"

The text to display for the close link. Use the
showButtonPanel option to display this button.
Code examples:
Initialize the datepicker with the closeText option specified:
1

$( ".selector" ).datepicker({ closeText: "Close"

Get or set the closeText option, after initialization:
1
2
3
4
5

// getter
var closeText = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "closeText"

constrainInput

Type: Boolean
Default: true

When true , entry in the input field is constrained to those
characters allowed by the current dateFormat option.
Code examples:
Initialize the datepicker with the constrainInput option
specified:

1

$( ".selector" ).datepicker({ constrainInput:

Get or set the constrainInput option, after initialization:
1
2
3
4
5

// getter
var constrainInput = $( ".selector" ).datepicker(

// setter
$( ".selector" ).datepicker( "option", "constrainInpu

currentText

Type: String
Default: "Today"

The text to display for the current day link. Use the
showButtonPanel option to display this button.
Code examples:
Initialize the datepicker with the currentText option specified:
1

$( ".selector" ).datepicker({ currentText: "Now"

Get or set the currentText option, after initialization:
1
2
3
4
5

// getter
var currentText = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "currentText"

dateFormat

Type: String
Default: "mm/dd/yy"

The format for parsed and displayed dates. For a full list of
the possible formats see the
[[UI/Datepicker/formatDate|formatDate]] function.
Code examples:
Initialize the datepicker with the dateFormat option specified:
1

$( ".selector" ).datepicker({ dateFormat: "yy-mm-dd"

Get or set the dateFormat option, after initialization:
1
2
3
4
5

// getter
var dateFormat = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "dateFormat"

dayNames

Type: Array

Default: [ "Sunday", "Monday", "Tuesday", "Wednesday",
"Thursday", "Friday", "Saturday" ]

The list of long day names, starting from Sunday, for use as
requested via the dateFormat option.
Code examples:
Initialize the datepicker with the dayNames option specified:
1

$( ".selector" ).datepicker({ dayNames: [ "Dimanche"

Get or set the dayNames option, after initialization:
1
2
3
4
5

// getter
var dayNames = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "dayNames"

dayNamesMin

Type: Array

Default: [ "Su", "Mo", "Tu", "We", "Th", "Fr", "Sa" ]

The list of minimised day names, starting from Sunday, for
use as column headers within the datepicker.
Code examples:
Initialize the datepicker with the dayNamesMin option
specified:
1

$( ".selector" ).datepicker({ dayNamesMin: [

Get or set the dayNamesMin option, after initialization:
1
2
3
4
5

// getter
var dayNamesMin = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "dayNamesMin"

dayNamesShort

Type: Array

Default: [ "Sun", "Mon", "Tue", "Wed", "Thu", "Fri", "Sat" ]

The list of abbreviated day names, starting from Sunday, for
use as requested via the dateFormat option.
Code examples:
Initialize the datepicker with the dayNamesShort option
specified:
1

$( ".selector" ).datepicker({ dayNamesShort: [

Get or set the dayNamesShort option, after initialization:
1
2
3
4
5

// getter
var dayNamesShort = $( ".selector" ).datepicker(

// setter
$( ".selector" ).datepicker( "option", "dayNamesShort

defaultDate

Type: Date or Number or String
Default: null

Set the date to highlight on first opening if the field is blank.
Specify either an actual date via a Date object or as a string
in the current [[UI/Datepicker#optiondateFormat|dateFormat]] , or a number of days from today
(e.g. +7) or a string of values and periods ('y' for years, 'm'
for months, 'w' for weeks, 'd' for days, e.g. '+1m +7d'), or null
for today.
Multiple types supported:
Date: A date object containing the default date.
Number: A number of days from today. For example 2
represents two days from today and -1 represents
yesterday.
String: A string in the format defined by the dateFormat

option, or a relative date. Relative dates must contain
value and period pairs; valid periods are "y" for years,
"m" for months, "w" for weeks, and "d" for days. For
example, "+1m +7d" represents one month and seven
days from today.
Code examples:
Initialize the datepicker with the defaultDate option specified:
1

$( ".selector" ).datepicker({ defaultDate: +7

Get or set the defaultDate option, after initialization:
1
2
3
4
5

// getter
var defaultDate = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "defaultDate"

duration

Type: or String
Default: "normal"

Control the speed at which the datepicker appears, it may
be a time in milliseconds or a string representing one of the
three predefined speeds ("slow", "normal", "fast").
Code examples:
Initialize the datepicker with the duration option specified:
1

$( ".selector" ).datepicker({ duration: "slow"

Get or set the duration option, after initialization:

1
2
3
4
5

// getter
var duration = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "duration"

firstDay

Type: Integer
Default: 0

Set the first day of the week: Sunday is 0 , Monday is 1 , etc.
Code examples:
Initialize the datepicker with the firstDay option specified:
1

$( ".selector" ).datepicker({ firstDay: 1 });

Get or set the firstDay option, after initialization:
1
2
3
4
5

// getter
var firstDay = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "firstDay"

gotoCurrent

Type: Boolean
Default: false

When true , the current day link moves to the currently
selected date instead of today.
Code examples:

Initialize the datepicker with the gotoCurrent option
specified:
1

$( ".selector" ).datepicker({ gotoCurrent: true

Get or set the gotoCurrent option, after initialization:
1
2
3
4
5

// getter
var gotoCurrent = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "gotoCurrent"

hideIfNoPrevNext

Type: Boolean
Default: false

Normally the previous and next links are disabled when not
applicable (see the minDate and maxDate options). You can
hide them altogether by setting this attribute to true .
Code examples:
Initialize the datepicker with the hideIfNoPrevNext option
specified:
1

$( ".selector" ).datepicker({ hideIfNoPrevNext:

Get or set the hideIfNoPrevNext option, after initialization:
1
2
3

// getter
var hideIfNoPrevNext = $( ".selector" ).datepicker(

4
5

// setter
$( ".selector" ).datepicker( "option", "hideIfNoPrevN

isRTL

Type: Boolean
Default: false

Whether the current language is drawn from right to left.
Code examples:
Initialize the datepicker with the isRTL option specified:
1

$( ".selector" ).datepicker({ isRTL: true });

Get or set the isRTL option, after initialization:
1
2
3
4
5

// getter
var isRTL = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "isRTL"

maxDate

Type: Date or Number or String
Default: null

The maximum selectable date. When set to null , there is
no maximum.
Multiple types supported:
Date: A date object containing the maximum date.
Number: A number of days from today. For example
represents two days from today and -1 represents

2

yesterday.
String: A string in the format defined by the dateFormat
option, or a relative date. Relative dates must contain
value and period pairs; valid periods are "y" for years,
"m" for months, "w" for weeks, and "d" for days. For
example, "+1m +7d" represents one month and seven
days from today.
Code examples:
Initialize the datepicker with the maxDate option specified:
1

$( ".selector" ).datepicker({ maxDate: "+1m +1w"

Get or set the maxDate option, after initialization:
1
2
3
4
5

// getter
var maxDate = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "maxDate"

minDate

Type: Date or Number or String
Default: null

The minimum selectable date. When set to null , there is no
minimum.
Multiple types supported:
Date: A date object containing the minimum date.
Number: A number of days from today. For example
represents two days from today and -1 represents
yesterday.
String: A string in the format defined by the

2

dateFormat

option, or a relative date. Relative dates must contain
value and period pairs; valid periods are "y" for years,
"m" for months, "w" for weeks, and "d" for days. For
example, "+1m +7d" represents one month and seven
days from today.
Code examples:
Initialize the datepicker with the minDate option specified:
1

$( ".selector" ).datepicker({ minDate: new Date(

Get or set the minDate option, after initialization:
1
2
3
4
5

// getter
var minDate = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "minDate"

monthNames

Type: Array

Default: [ "January", "February", "March", "April", "May",
"June", "July", "August", "September", "October",
"November", "December" ]

The list of full month names, for use as requested via the
dateFormat option.
Code examples:
Initialize the datepicker with the monthNames option
specified:
1

$( ".selector" ).datepicker({ monthNames: [ "Januar"

Get or set the monthNames option, after initialization:
1
2
3
4
5

// getter
var monthNames = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "monthNames"

monthNamesShort

Type: Array

Default: [ "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul",
"Aug", "Sep", "Oct", "Nov", "Dec" ]

The list of abbreviated month names, as used in the month
header on each datepicker and as requested via the
dateFormat option.
Code examples:
Initialize the datepicker with the monthNamesShort option
specified:
1

$( ".selector" ).datepicker({ monthNamesShort: [

Get or set the monthNamesShort option, after initialization:
1
2
3
4
5

// getter
var monthNamesShort = $( ".selector" ).datepicker(

// setter
$( ".selector" ).datepicker( "option", "monthNamesSho

navigationAsDateFormat

Type: Boolean
Default: false

Whether the prevText and
parsed as dates by the

nextText

options should be

function, allowing
them to display the target month names for example.
Code examples:
Initialize the datepicker with the navigationAsDateFormat
option specified:
[[UI/Datepicker/formatDate|formatDate]]

1

$( ".selector" ).datepicker({ navigationAsDateFormat:

Get or set the navigationAsDateFormat option, after
initialization:
1
2
3
4
5

// getter
var navigationAsDateFormat = $( ".selector" ).datepic

// setter
$( ".selector" ).datepicker( "option", "navigationAsD

nextText

Type: String
Default: "Next"

The text to display for the next month link. With the standard
ThemeRoller styling, this value is replaced by an icon.
Code examples:
Initialize the datepicker with the nextText option specified:
1

$( ".selector" ).datepicker({ nextText: "Later"

Get or set the nextText option, after initialization:
1
2
3
4
5

// getter
var nextText = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "nextText"

numberOfMonths

Type: Number or Array
Default: 1

The number of months to show at once.
Multiple types supported:
Number: The number of months to display in a single
row.
Array: An array defining the number of rows and
columns to display.
Code examples:
Initialize the datepicker with the numberOfMonths option
specified:
1

$( ".selector" ).datepicker({ numberOfMonths: [

Get or set the numberOfMonths option, after initialization:
1
2
3
4

// getter
var numberOfMonths = $( ".selector" ).datepicker(
// setter

5

$( ".selector" ).datepicker( "option", "numberOfMonth

onChangeMonthYear
Type: Function( Integer year, Integer month,
Object inst )
Default: null

Called when the datepicker moves to a new month and/or
year. The function receives the selected year, month (1-12),
and the datepicker instance as parameters. this refers to
the associated input field.

onClose
Default:Type:

Function( String dateText, Object inst )
null

Called when the datepicker is closed, whether or not a date
is selected. The function receives the selected date as text
( "" if none) and the datepicker instance as parameters.
this refers to the associated input field.

onSelect
Default:Type:

Function( String dateText, Object inst )
null

Called when the datepicker is selected. The function
receives the selected date as text and the datepicker
instance as parameters. this refers to the associated input
field.

prevText

Type: String
Default: "Prev"

The text to display for the previous month link. With the
standard ThemeRoller styling, this value is replaced by an

icon.
Code examples:
Initialize the datepicker with the prevText option specified:
1

$( ".selector" ).datepicker({ prevText: "Earlier"

Get or set the prevText option, after initialization:
1
2
3
4
5

// getter
var prevText = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "prevText"

selectOtherMonths

Type: Boolean
Default: false

Whether days in other months shown before or after the
current month are selectable. This only applies if the
showOtherMonths option is set to true .
Code examples:
Initialize the datepicker with the selectOtherMonths option
specified:
1

$( ".selector" ).datepicker({ selectOtherMonths:

Get or set the selectOtherMonths option, after initialization:
1
2

// getter
var selectOtherMonths = $( ".selector" ).datepicker(

3
4
5

// setter
$( ".selector" ).datepicker( "option", "selectOtherMo

shortYearCutoff

Type: Number or String
Default: "+10"

The cutoff year for determining the century for a date (used
in conjunction with [[UI/Datepicker#optiondateFormat|dateFormat]] 'y'). Any dates entered with a year
value less than or equal to the cutoff year are considered to
be in the current century, while those greater than it are
deemed to be in the previous century.
Multiple types supported:
Number: A value between 0 and 99 indicating the
cutoff year.
String: A relative number of years from the current
year, e.g., "+3" or "-5" .
Code examples:
Initialize the datepicker with the shortYearCutoff option
specified:
1

$( ".selector" ).datepicker({ shortYearCutoff:

Get or set the shortYearCutoff option, after initialization:
1
2
3
4
5

// getter
var shortYearCutoff = $( ".selector" ).datepicker(

// setter
$( ".selector" ).datepicker( "option", "shortYearCuto

showAnim

Type: String
Default: "show"

The name of the animation used to show and hide the
datepicker. Use "show" (the default), "slideDown" , "fadeIn" ,
any of the jQuery UI effects. Set to an empty string to
disable animation.
Code examples:
Initialize the datepicker with the showAnim option specified:
1

$( ".selector" ).datepicker({ showAnim: "fold"

Get or set the showAnim option, after initialization:
1
2
3
4
5

// getter
var showAnim = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "showAnim"

showButtonPanel

Type: Boolean
Default: false

Whether to show the button panel.
Code examples:
Initialize the datepicker with the showButtonPanel option
specified:
1

$( ".selector" ).datepicker({ showButtonPanel:

Get or set the showButtonPanel option, after initialization:
1
2
3
4
5

// getter
var showButtonPanel = $( ".selector" ).datepicker(

// setter
$( ".selector" ).datepicker( "option", "showButtonPan

showCurrentAtPos

Type: Number
Default: 0

When displaying multiple months via the numberOfMonths
option, the showCurrentAtPos option defines which position to
display the current month in.
Code examples:
Initialize the datepicker with the showCurrentAtPos option
specified:
1

$( ".selector" ).datepicker({ showCurrentAtPos:

Get or set the showCurrentAtPos option, after initialization:
1
2
3
4
5

// getter
var showCurrentAtPos = $( ".selector" ).datepicker(

// setter
$( ".selector" ).datepicker( "option", "showCurrentAt

showMonthAfterYear

Type: Boolean
Default: false

Whether to show the month after the year in the header.
Code examples:
Initialize the datepicker with the showMonthAfterYear option
specified:
1

$( ".selector" ).datepicker({ showMonthAfterYear:

Get or set the showMonthAfterYear option, after
initialization:
1
2
3
4
5

// getter
var showMonthAfterYear = $( ".selector" ).datepicker(

// setter
$( ".selector" ).datepicker( "option", "showMonthAfte

showOn

Type: String
Default: "focus"

When the datepicker should appear. The datepicker can
appear when the field receives focus ( "focus" ), when a
button is clicked ( "button" ), or when either event occurs
( "both" ).
Code examples:
Initialize the datepicker with the showOn option specified:
1

$( ".selector" ).datepicker({ showOn: "both" });

Get or set the showOn option, after initialization:
1
2
3
4
5

// getter
var showOn = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "showOn"

showOptions

Type: Object
Default: {}

If using one of the jQuery UI effects for the showAnim option,
you can provide additional settings for that animation via this
option.
Code examples:
Initialize the datepicker with the showOptions option
specified:
1

$( ".selector" ).datepicker({ showOptions: { directio

Get or set the showOptions option, after initialization:
1
2
3
4
5

// getter
var showOptions = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "showOptions"

showOtherMonths

Type: Boolean
Default: false

Whether to display dates in other months (non-selectable) at
the start or end of the current month. To make these days
selectable use the selectOtherMonths option.
Code examples:
Initialize the datepicker with the showOtherMonths option
specified:
1

$( ".selector" ).datepicker({ showOtherMonths:

Get or set the showOtherMonths option, after initialization:
1
2
3
4
5

// getter
var showOtherMonths = $( ".selector" ).datepicker(

// setter
$( ".selector" ).datepicker( "option", "showOtherMont

showWeek

Type: Boolean
Default: false

When true , a column is added to show the week of the
year. The calculateWeek option determines how the week of
the year is calculated. You may also want to change the
firstDay option.
Code examples:
Initialize the datepicker with the showWeek option specified:
1

$( ".selector" ).datepicker({ showWeek: true });

Get or set the showWeek option, after initialization:
1
2
3
4
5

// getter
var showWeek = $( ".selector" ).datepicker( "option"
// setter
$( ".selector" ).datepicker( "option", "showWeek"

stepMonths

Type: Number
Default: 1

Set how many months to move when clicking the
previous/next links.
Code examples:
Initialize the datepicker with the stepMonths option
specified:
1

$( ".selector" ).datepicker({ stepMonths: 3 });

Get or set the stepMonths option, after initialization:
1
2
3
4
5

// getter
var stepMonths = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "stepMonths"

weekHeader

Type: String
Default: "Wk"

The text to display for the week of the year column heading.
Use the showWeek option to display this column.
Code examples:
Initialize the datepicker with the weekHeader option
specified:
1

$( ".selector" ).datepicker({ weekHeader: "W"

Get or set the weekHeader option, after initialization:
1
2
3
4
5

// getter
var weekHeader = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "weekHeader"

yearRange

Type: String
Default: "c-10:c+10"

The range of years displayed in the year drop-down: either
relative to today's year ( "-nn:+nn" ), relative to the currently
selected year ( "c-nn:c+nn" ), absolute ( "nnnn:nnnn" ), or
combinations of these formats ( "nnnn:-nn" ). Note that this
option only affects what appears in the drop-down, to restrict
which dates may be selected use the minDate and/or
maxDate options.
Code examples:
Initialize the datepicker with the yearRange option specified:

1

$( ".selector" ).datepicker({ yearRange: "2002:2012"

Get or set the yearRange option, after initialization:
1
2
3
4
5

// getter
var yearRange = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "yearRange"

yearSuffix

Type: String
Default: ""

Additional text to display after the year in the month
headers.
Code examples:
Initialize the datepicker with the yearSuffix option specified:
1

$( ".selector" ).datepicker({ yearSuffix: "CE"

Get or set the yearSuffix option, after initialization:
1
2
3
4
5

// getter
var yearSuffix = $( ".selector" ).datepicker(
// setter
$( ".selector" ).datepicker( "option", "yearSuffix"

Methods
destroy()
Removes the datepicker functionality completely. This will
return the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).datepicker( "destroy" );

dialog( date [, onSelect ] [, settings ] [,
pos ] )
Opens the datepicker in a dialog box.
date
Type: String or Date
The initial date.
onSelect
Type: Function()
A callback function when a date is selected. The
function receives the date text and date picker instance
as parameters.
settings
Type: Options
The new settings for the date picker.

pos
Type: Number[2] or MouseEvent
The position of the top/left of the dialog as [x, y] or a
MouseEvent that contains the coordinates. If not
specified the dialog is centered on the screen.
Code examples:
Invoke the dialog method:
1

$( ".selector" ).datepicker( "dialog", "10/12/2012"

getDate()

Returns: Date

Returns the current date for the datepicker or null if no date
has been selected.
This method does not accept any arguments.
Code examples:
Invoke the getDate method:
1

var currentDate = $( ".selector" ).datepicker(

hide()
Close a previously opened date picker.
This method does not accept any arguments.
Code examples:
Invoke the hide method:

1

$( ".selector" ).datepicker( "hide" );

isDisabled()

Returns: Boolean

Determine whether a date picker has been disabled.
This method does not accept any arguments.
Code examples:
Invoke the isDisabled method:
1

var isDisabled = $( ".selector" ).datepicker(

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).datepicker(

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the

current datepicker options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).datepicker( "option"

option( optionName, value )
Sets the value of the datepicker option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).datepicker( "option", "disabled"

option( options )
Sets one or more options for the datepicker.
options
Type: Object
A map of option-value pairs to set.

Code examples:
Invoke the method:
1

$( ".selector" ).datepicker( "option", { disabled:

refresh()
Redraw the date picker, after having made some external
modifications.
This method does not accept any arguments.
Code examples:
Invoke the refresh method:
1

$( ".selector" ).datepicker( "refresh" );

setDate( date )
Sets the date for the datepicker. The new date may be a
Date object or a string in the current date format (e.g.,
"01/26/2009" ), a number of days from today (e.g., +7 ) or a
string of values and periods ( "y" for years, "m" for months,
"w" for weeks, "d" for days, e.g., "+1m +7d" ), or null to
clear the selected date.
date
Type: String or Date
The new date.
Code examples:
Invoke the setDate method:

1

$( ".selector" ).datepicker( "setDate", "10/12/2012"

show()
Open the date picker. If the datepicker is attached to an
input, the input must be visible for the datepicker to be
shown.
This method does not accept any arguments.
Code examples:
Invoke the show method:
1

$( ".selector" ).datepicker( "show" );

widget()

Returns: jQuery

Returns a jQuery object containing the datepicker.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).datepicker( "widget"

Example:
A simple jQuery UI Datepicker.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>datepicker demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div id="datepicker"></div>
<script>
$( "#datepicker" ).datepicker();
</script>
</body>
</html>
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Dialog Widget
Categories: Widgets

Dialog Widget

version added: 1.0

Description: Open content in an interactive overlay.

QuickNav

Examples

Options

Methods

Events

appendTo
autoOpen
buttons
closeOnEscape
closeText
dialogClass
draggable
height
hide
maxHeight
maxWidth
minHeight
minWidth
modal
position
resizable
show
title
width

close
destroy
isOpen
moveToTop
open
option
widget

beforeClose
create
open
focus
dragStart
drag
dragStop
resizeStart
resize
resizeStop
close

A dialog is a floating window that contains a title bar and a content
area. The dialog window can be moved, resized and closed with the
'x' icon by default.
If the content length exceeds the maximum height, a scrollbar will
automatically appear.
A bottom button bar and semi-transparent modal overlay layer are
common options that can be added.

Hiding the close button
In some cases, you may want to hide the close button, for instance,

if you have a close button in the button pane. The best way to
accomplish this is via CSS. As an example, you can define a simple
rule, such as:
1
2
3

.no-close .ui-dialog-titlebar-close {
display: none;
}

Then, you can simply add the
to hide it's close button:
1
2
3
4
5
6
7
8
9
10
11

no-close

class to any dialog in order

$( "#dialog" ).dialog({
dialogClass: "no-close",
buttons: [
{
text: "OK",
click: function() {
$( this ).dialog( "close" );
}
}
]
});

Dependencies
UI Core
Widget Factory
Position
Button
Draggable (optional; for use with the

draggable

option)

Resizable (optional; for use with the

resizable

option)

Effects Core (optional; for use with the

show

and

hide

options)

Additional Notes:
This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific
CSS file as a starting point.

Options
appendTo

Type: Selector
Default: "body"

Which element the dialog (and overlay, if modal) should be
appended to. (version added: 1.10.0)
Code examples:
Initialize the dialog with the appendTo option specified:
1

$( ".selector" ).dialog({ appendTo: "#someElem"

Get or set the appendTo option, after initialization:
1
2
3
4
5

// getter
var appendTo = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "appendTo"

autoOpen

Type: Boolean
Default: true

If set to true , the dialog will automatically open upon
initialization. If false , the dialog will stay hidden until the
open() method is called.
Code examples:
Initialize the dialog with the autoOpen option specified:

1

$( ".selector" ).dialog({ autoOpen: false });

Get or set the autoOpen option, after initialization:
1
2
3
4
5

// getter
var autoOpen = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "autoOpen"

buttons

Type: Object or Array
Default: {}

Specifies which buttons should be displayed on the dialog.
The context of the callback is the dialog element; if you need
access to the button, it is available as the target of the event
object.
Multiple types supported:
Object: The keys are the button labels and the values
are the callbacks for when the associated button is
clicked.
Array: Each element of the array must be an object
defining the attributes, properties, and event handlers to
set on the button.
Code examples:
Initialize the dialog with the buttons option specified:
1

$( ".selector" ).dialog({ buttons: [ { text:

Get or set the buttons option, after initialization:

1
2
3
4
5

// getter
var buttons = $( ".selector" ).dialog( "option"

// setter
$( ".selector" ).dialog( "option", "buttons", [ { tex

closeOnEscape

Type: Boolean
Default: true

Specifies whether the dialog should close when it has focus
and the user presses the esacpe (ESC) key.
Code examples:
Initialize the dialog with the closeOnEscape option specified:
1

$( ".selector" ).dialog({ closeOnEscape: false

Get or set the closeOnEscape option, after initialization:
1
2
3
4
5

// getter
var closeOnEscape = $( ".selector" ).dialog(
// setter
$( ".selector" ).dialog( "option", "closeOnEscape"

closeText

Type: String
Default: "close"

Specifies the text for the close button. Note that the close
text is visibly hidden when using a standard theme.

Code examples:
Initialize the dialog with the closeText option specified:
1

$( ".selector" ).dialog({ closeText: "hide" });

Get or set the closeText option, after initialization:
1
2
3
4
5

// getter
var closeText = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "closeText"

dialogClass

Type: String
Default: ""

The specified class name(s) will be added to the dialog, for
additional theming.
Code examples:
Initialize the dialog with the dialogClass option specified:
1

$( ".selector" ).dialog({ dialogClass: "alert"

Get or set the dialogClass option, after initialization:
1
2
3
4
5

// getter
var dialogClass = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "dialogClass"

draggable

Type: Boolean
Default: true

If set to true , the dialog will be draggable by the title bar.
Requires the jQuery UI Draggable wiget to be included.
Code examples:
Initialize the dialog with the draggable option specified:
1

$( ".selector" ).dialog({ draggable: false });

Get or set the draggable option, after initialization:
1
2
3
4
5

// getter
var draggable = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "draggable"

height

Type: Number or String
Default: "auto"

The height of the dialog.
Multiple types supported:
Number: The height in pixels.
String: The only supported string value is "auto" which
will allow the dialog height to adjust based on its
content.
Code examples:

Initialize the dialog with the height option specified:
1

$( ".selector" ).dialog({ height: 400 });

Get or set the height option, after initialization:
1
2
3
4
5

hide

// getter
var height = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "height",

Type: Number or String or Object
Default: null

If and how to animate the hiding of the dialog.
Multiple types supported:
Number: The dialog will fade out while animating the
height and width for the specified duration.
String: The dialog will be hidden using the specified
jQuery UI effect. See the list of effects for possible
values.
Object: If the value is an object, then effect , delay ,
duration , and easing properties may be provided. The
effect property must be the name of a jQuery UI effect.
When using a jQuery UI effect that supports additional
settings, you may include those settings in the object
and they will be passed to the effect. If duration or
easing is omitted, then the default values will be used. If
delay is omitted, then no delay is used.
Code examples:
Initialize the dialog with the hide option specified:

1

$( ".selector" ).dialog({ hide: "explode" });

Get or set the hide option, after initialization:
1
2
3
4
5

// getter
var hide = $( ".selector" ).dialog( "option",
// setter
$( ".selector" ).dialog( "option", "hide", "explode"

maxHeight

Type: Number
Default: false

The maximum height to which the dialog can be resized, in
pixels.
Code examples:
Initialize the dialog with the maxHeight option specified:
1

$( ".selector" ).dialog({ maxHeight: 600 });

Get or set the maxHeight option, after initialization:
1
2
3
4
5

// getter
var maxHeight = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "maxHeight"

maxWidth

Type: Number
Default: false

The maximum width to which the dialog can be resized, in
pixels.
Code examples:
Initialize the dialog with the maxWidth option specified:
1

$( ".selector" ).dialog({ maxWidth: 600 });

Get or set the maxWidth option, after initialization:
1
2
3
4
5

// getter
var maxWidth = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "maxWidth"

minHeight

Type: Number
Default: 150

The minimum height to which the dialog can be resized, in
pixels.
Code examples:
Initialize the dialog with the minHeight option specified:
1

$( ".selector" ).dialog({ minHeight: 200 });

Get or set the minHeight option, after initialization:

1
2
3
4
5

// getter
var minHeight = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "minHeight"

minWidth

Type: Number
Default: 150

The minimum width to which the dialog can be resized, in
pixels.
Code examples:
Initialize the dialog with the minWidth option specified:
1

$( ".selector" ).dialog({ minWidth: 200 });

Get or set the minWidth option, after initialization:
1
2
3
4
5

// getter
var minWidth = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "minWidth"

modal

Type: Boolean
Default: false

If set to true , the dialog will have modal behavior; other
items on the page will be disabled, i.e., cannot be interacted

with. Modal dialogs create an overlay below the dialog but
above other page elements.
Code examples:
Initialize the dialog with the modal option specified:
1

$( ".selector" ).dialog({ modal: true });

Get or set the modal option, after initialization:
1
2
3
4
5

// getter
var modal = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "modal", true

Type: Object or String or Array

position

Default: { my: "center", at: "center", of: window }

Specifies where the dialog should be displayed. The dialog
will handle collisions such that as much of the dialog is
visible as possible.
Note: The

String

and

Array

forms are deprecated.

Multiple types supported:
Object: Identifies the position of the dialog when
opened. The of option defaults to the window, but you
can specify another element to position against. You
can refer to the jQuery UI Position utility for more details
about the various options.
String: A string representing the position within the
viewport. Possible values: "center" , "left" , "right" ,
"top" , "bottom" .
Array: An array containing an x, y coordinate pair in

pixel offset from the top left corner of the viewport or the
name of a possible string value.
Code examples:
Initialize the dialog with the position option specified:
1

$( ".selector" ).dialog({ position: { my: "left top"

Get or set the position option, after initialization:
1
2
3
4
5

// getter
var position = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "position"

resizable

Type: Boolean
Default: true

If set to true , the dialog will be resizable. Requires the
jQuery UI Resizable widget to be included.
Code examples:
Initialize the dialog with the resizable option specified:
1

$( ".selector" ).dialog({ resizable: false });

Get or set the resizable option, after initialization:
1
2

// getter
var resizable = $( ".selector" ).dialog( "option"

3
4
5

// setter
$( ".selector" ).dialog( "option", "resizable"

show

Type: Number or String or Object
Default: null

If and how to animate the showing of the dialog.
Multiple types supported:
Number: The dialog will fade in while animating the
height and width for the specified duration.
String: The dialog will be shown using the specified
jQuery UI effect. See the list of effects for possible
values.
Object: If the value is an object, then effect , delay ,
duration , and easing properties may be provided. The
effect property must be the name of a jQuery UI effect.
When using a jQuery UI effect that supports additional
settings, you may include those settings in the object
and they will be passed to the effect. If duration or
easing is omitted, then the default values will be used. If
delay is omitted, then no delay is used.
Code examples:
Initialize the dialog with the show option specified:
1

$( ".selector" ).dialog({ show: "slow" });

Get or set the show option, after initialization:
1
2
3

// getter
var show = $( ".selector" ).dialog( "option",

4
5

// setter
$( ".selector" ).dialog( "option", "show", "slow"

Type: String

title

Default: null

Specifies the title of the dialog. If the value is null , the
title attribute on the dialog source element will be used.
Code examples:
Initialize the dialog with the title option specified:
1

$( ".selector" ).dialog({ title: "Dialog Title"

Get or set the title option, after initialization:
1
2
3
4
5

// getter
var title = $( ".selector" ).dialog( "option"

// setter
$( ".selector" ).dialog( "option", "title", "Dialog T

width

Type: Number
Default: 300

The width of the dialog, in pixels.
Code examples:
Initialize the dialog with the width option specified:
1

$( ".selector" ).dialog({ width: 500 });

Get or set the width option, after initialization:
1
2
3
4
5

// getter
var width = $( ".selector" ).dialog( "option"
// setter
$( ".selector" ).dialog( "option", "width", 500

Methods
close()
Closes the dialog.
This method does not accept any arguments.
Code examples:
Invoke the close method:
1

$( ".selector" ).dialog( "close" );

destroy()
Removes the dialog functionality completely. This will return
the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).dialog( "destroy" );

isOpen()

Returns: Boolean

Whether the dialog is currently open.
This method does not accept any arguments.

Code examples:
Invoke the isOpen method:
1

var isOpen = $( ".selector" ).dialog( "isOpen"

moveToTop()
Moves the dialog to the top of the dialog stack.
This method does not accept any arguments.
Code examples:
Invoke the moveToTop method:
1

$( ".selector" ).dialog( "moveToTop" );

open()
Opens the dialog.
This method does not accept any arguments.
Code examples:
Invoke the open method:
1

$( ".selector" ).dialog( "open" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).dialog( "option"

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current dialog options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).dialog( "option"

option( optionName, value )
Sets the value of the dialog option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.

value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).dialog( "option", "disabled"

option( options )
Sets one or more options for the dialog.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).dialog( "option", { disabled:

widget()

Returns: jQuery

Returns a jQuery object containing the generated wrapper.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).dialog( "widget"

Events
beforeClose( event, ui ) Type:

dialogbeforeclose

Triggered when a dialog is about to close. If canceled, the
dialog will not close.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the dialog with the beforeClose callback specified:
1
2
3

$( ".selector" ).dialog({
beforeClose: function( event, ui ) {}
});

Bind an event listener to the dialogbeforeclose event:
1

$( ".selector" ).on( "dialogbeforeclose", function

close( event, ui )
Triggered when the dialog is closed.
event
Type: Event

Type:

dialogclose

ui
Type: Object
Code examples:
Initialize the dialog with the close callback specified:
1
2
3

$( ".selector" ).dialog({
close: function( event, ui ) {}
});

Bind an event listener to the dialogclose event:
1

$( ".selector" ).on( "dialogclose", function( event,

create( event, ui )

Type:

dialogcreate

Triggered when the dialog is created.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the dialog with the create callback specified:
1
2
3

$( ".selector" ).dialog({
create: function( event, ui ) {}
});

Bind an event listener to the dialogcreate event:

1

$( ".selector" ).on( "dialogcreate", function

drag( event, ui )

Type:

dialogdrag

Triggered while the dialog is being dragged.
event
Type: Event
ui
Type: Object
position
Type: Object
The current CSS position of the dialog.
offset
Type: Object
The current offset position of the dialog.

Code examples:
Initialize the dialog with the drag callback specified:
1
2
3

$( ".selector" ).dialog({
drag: function( event, ui ) {}
});

Bind an event listener to the dialogdrag event:
1

$( ".selector" ).on( "dialogdrag", function( event, u

dragStart( event, ui )

Type:

dialogdragstart

Triggered when the user starts dragging the dialog.
event
Type: Event
ui
Type: Object
position
Type: Object
The current CSS position of the dialog.
offset
Type: Object
The current offset position of the dialog.

Code examples:
Initialize the dialog with the dragStart callback specified:
1
2
3

$( ".selector" ).dialog({
dragStart: function( event, ui ) {}
});

Bind an event listener to the dialogdragstart event:
1

$( ".selector" ).on( "dialogdragstart", function

dragStop( event, ui )

Type:

Triggered after the dialog has been dragged.
event

dialogdragstop

Type: Event
ui
Type: Object
position
Type: Object
The current CSS position of the dialog.
offset
Type: Object
The current offset position of the dialog.

Code examples:
Initialize the dialog with the dragStop callback specified:
1
2
3

$( ".selector" ).dialog({
dragStop: function( event, ui ) {}
});

Bind an event listener to the dialogdragstop event:
1

$( ".selector" ).on( "dialogdragstop", function

focus( event, ui )
Triggered when the dialog gains focus.
event
Type: Event
ui
Type: Object

Type:

dialogfocus

Code examples:
Initialize the dialog with the focus callback specified:
1
2
3

$( ".selector" ).dialog({
focus: function( event, ui ) {}
});

Bind an event listener to the dialogfocus event:
1

$( ".selector" ).on( "dialogfocus", function( event,

open( event, ui )

Type:

dialogopen

Triggered when the dialog is opened.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the dialog with the open callback specified:
1
2
3

$( ".selector" ).dialog({
open: function( event, ui ) {}
});

Bind an event listener to the dialogopen event:
1

$( ".selector" ).on( "dialogopen", function( event, u

resize( event, ui )

Type:

dialogresize

Triggered while the dialog is being resized.
event
Type: Event
ui
Type: Object
originalPosition
Type: Object
The CSS position of the dialog prior to being
resized.
position
Type: Object
The current CSS position of the dialog.
originalSize
Type: Object
The size of the dialog prior to being resized.
size
Type: Object
The current size of the dialog.

Code examples:
Initialize the dialog with the resize callback specified:
1
2
3

$( ".selector" ).dialog({
resize: function( event, ui ) {}
});

Bind an event listener to the dialogresize event:

1

$( ".selector" ).on( "dialogresize", function

resizeStart( event, ui ) Type:

dialogresizestart

Triggered when the user starts resizing the dialog.
event
Type: Event
ui
Type: Object
originalPosition
Type: Object
The CSS position of the dialog prior to being
resized.
position
Type: Object
The current CSS position of the dialog.
originalSize
Type: Object
The size of the dialog prior to being resized.
size
Type: Object
The current size of the dialog.

Code examples:
Initialize the dialog with the resizeStart callback specified:
1
2
3

$( ".selector" ).dialog({
resizeStart: function( event, ui ) {}
});

Bind an event listener to the dialogresizestart event:
1

$( ".selector" ).on( "dialogresizestart", function

resizeStop( event, ui )

Type:

dialogresizestop

Triggered after the dialog has been resized.
event
Type: Event
ui
Type: Object
originalPosition
Type: Object
The CSS position of the dialog prior to being
resized.
position
Type: Object
The current CSS position of the dialog.
originalSize
Type: Object
The size of the dialog prior to being resized.
size
Type: Object
The current size of the dialog.

Code examples:
Initialize the dialog with the resizeStop callback specified:

1
2
3

$( ".selector" ).dialog({
resizeStop: function( event, ui ) {}
});

Bind an event listener to the dialogresizestop event:
1

$( ".selector" ).on( "dialogresizestop", function

Example:
A simple jQuery UI Dialog
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>dialog demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<button id="opener">open the dialog</button>
<div id="dialog" title="Dialog Title">I'm a dialog
<script>
$( "#dialog" ).dialog({ autoOpen: false });
$( "#opener" ).click(function() {
$( "#dialog" ).dialog( "open" );
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

.disableSelection()
Categories: Methods | UI Core

.disableSelection()

Returns: jQuery

Description: Disable selection of text content within the
set of matched elements.
.disableSelection()

version added: 1.6, deprecated: 1.9

This method does not accept any arguments.
Disabling text selection is bad. Don't use this.

POWERED BYHERONOTE
A new version of this book is available!

Draggable Widget
Categories: Interactions

Draggable Widget

version added: 1.0

Description: Allow elements to be moved using the
mouse.

QuickNav

Examples

Options

Methods

Events

addClasses
appendTo
axis
cancel
connectToSortable
containment
cursor
cursorAt
delay
disabled
distance
grid
handle
helper
iframeFix
opacity
refreshPositions
revert
revertDuration
scope
scroll
scrollSensitivity
scrollSpeed
snap
snapMode
snapTolerance
stack
zIndex

destroy
disable
enable
option
widget

create
start
drag
stop

Make the selected elements draggable by mouse. If you want not
just drag, but drag & drop, see the jQuery UI Droppable plugin,
which provides a drop target for draggables.

Dependencies
UI Core
Widget Factory
Mouse Interaction

Options
addClasses

Type: Boolean
Default: true

If set to false , will prevent the ui-draggable class from
being added. This may be desired as a performance
optimization when calling .draggable() on hundreds of
elements.
Code examples:
Initialize the draggable with the addClasses option specified:
1

$( ".selector" ).draggable({ addClasses: false

Get or set the addClasses option, after initialization:
1
2
3
4
5

// getter
var addClasses = $( ".selector" ).draggable(
// setter
$( ".selector" ).draggable( "option", "addClasses"

appendTo
Default:Type:

jQuery or Element or Selector or String
"parent"

Which element the draggable helper should be appended to
while dragging.
Multiple types supported:
jQuery: A jQuery object containing the element to

append the helper to.
Element: The element to append the helper to.
Selector: A selector specifying which element to
append the helper to.
String: The string "parent" will cause the helper to be a
sibling of the draggable.
Code examples:
Initialize the draggable with the appendTo option specified:
1

$( ".selector" ).draggable({ appendTo: "body"

Get or set the appendTo option, after initialization:
1
2
3
4
5

axis

// getter
var appendTo = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "appendTo"

Type: String
Default: false

Constrains dragging to either the horizontal (x) or vertical (y)
axis. Possible values: "x" , "y" .
Code examples:
Initialize the draggable with the axis option specified:
1

$( ".selector" ).draggable({ axis: "x" });

Get or set the axis option, after initialization:
1
2
3
4
5

// getter
var axis = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "axis",

Type: Selector

cancel

Default: "input,textarea,button,select,option"

Prevents dragging from starting on specified elements.
Code examples:
Initialize the draggable with the cancel option specified:
1

$( ".selector" ).draggable({ cancel: ".title"

Get or set the cancel option, after initialization:
1
2
3
4
5

// getter
var cancel = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "cancel"

connectToSortable

Type: Selector
Default: false

Allows the draggable to be dropped onto the specified

sortables. If this option is used, a draggable can be dropped
onto a sortable list and then becomes part of it. Note: The
helper option must be set to "clone" in order to work
flawlessly. Requires the jQuery UI Sortable plugin to be
included.
Code examples:
Initialize the draggable with the connectToSortable option
specified:
1

$( ".selector" ).draggable({ connectToSortable:

Get or set the connectToSortable option, after initialization:
1
2
3
4
5

// getter
var connectToSortable = $( ".selector" ).draggable(

// setter
$( ".selector" ).draggable( "option", "connectToSorta

containment
Default: Type:

Selector or Element or String or Array
false

Constrains dragging to within the bounds of the specified
element or region.
Multiple types supported:
Selector: The draggable element will be contained to
the bounding box of the first element found by the
selector. If no element is found, no containment will be
set.
Element: The draggable element will be contained to
the bounding box of this element.
String: Possible values: "parent" , "document" ,

"window" .

Array: An array defining a bounding box in the form
x1, y1, x2, y2 ] .

[

Code examples:
Initialize the draggable with the containment option
specified:
1

$( ".selector" ).draggable({ containment: "parent"

Get or set the containment option, after initialization:
1
2
3
4
5

// getter
var containment = $( ".selector" ).draggable(
// setter
$( ".selector" ).draggable( "option", "containment"

cursor

Type: String
Default: "auto"

The CSS cursor during the drag operation.
Code examples:
Initialize the draggable with the cursor option specified:
1

$( ".selector" ).draggable({ cursor: "crosshair"

Get or set the cursor option, after initialization:
1

// getter

2
3
4
5

var cursor = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "cursor"

cursorAt

Type: Object
Default: false

Sets the offset of the dragging helper relative to the mouse
cursor. Coordinates can be given as a hash using a
combination of one or two keys: { top, left, right, bottom
}.
Code examples:
Initialize the draggable with the cursorAt option specified:
1

$( ".selector" ).draggable({ cursorAt: { left:

Get or set the cursorAt option, after initialization:
1
2
3
4
5

// getter
var cursorAt = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "cursorAt"

delay

Type: Number
Default: 0

Time in milliseconds after mousedown until dragging should
start. This option can be used to prevent unwanted drags

when clicking on an element.
Code examples:
Initialize the draggable with the delay option specified:
1

$( ".selector" ).draggable({ delay: 300 });

Get or set the delay option, after initialization:
1
2
3
4
5

// getter
var delay = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "delay"

disabled

Type: Boolean
Default: false

Disables the draggable if set to true .
Code examples:
Initialize the draggable with the disabled option specified:
1

$( ".selector" ).draggable({ disabled: true });

Get or set the disabled option, after initialization:
1
2
3
4
5

// getter
var disabled = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "disabled"

distance

Type: Number
Default: 1

Distance in pixels after mousedown the mouse must move
before dragging should start. This option can be used to
prevent unwanted drags when clicking on an element.
Code examples:
Initialize the draggable with the distance option specified:
1

$( ".selector" ).draggable({ distance: 10 });

Get or set the distance option, after initialization:
1
2
3
4
5

grid

// getter
var distance = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "distance"

Type: Array
Default: false

Snaps the dragging helper to a grid, every x and y pixels.
The array must be of the form [ x, y ] .
Code examples:
Initialize the draggable with the grid option specified:
1

$( ".selector" ).draggable({ grid: [ 50, 20 ] });

Get or set the grid option, after initialization:
1
2
3
4
5

// getter
var grid = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "grid", [

handle

Type: Selector or Element
Default: false

If specified, restricts dragging from starting unless the
mousedown occurs on the specified element(s).
Code examples:
Initialize the draggable with the handle option specified:
1

$( ".selector" ).draggable({ handle: "h2" });

Get or set the handle option, after initialization:
1
2
3
4
5

// getter
var handle = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "handle"

helper

Type: String or Function()
Default: "original"

Allows for a helper element to be used for dragging display.
Multiple types supported:
String: If set to "clone" , then the element will be cloned
and the clone will be dragged.
Function: A function that will return a DOMElement to
use while dragging.
Code examples:
Initialize the draggable with the helper option specified:
1

$( ".selector" ).draggable({ helper: "clone" });

Get or set the helper option, after initialization:
1
2
3
4
5

// getter
var helper = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "helper"

iframeFix

Type: Boolean or Selector
Default: false

Prevent iframes from capturing the mousemove events
during a drag. Useful in combination with the cursorAt
option, or in any case where the mouse cursor may not be
over the helper.
Multiple types supported:
Boolean: When set to true , transparent overlays will

be placed over all iframes on the page.
Selector: Any iframes matching the selector will be
covered by transparent overlays.
Code examples:
Initialize the draggable with the iframeFix option specified:
1

$( ".selector" ).draggable({ iframeFix: true });

Get or set the iframeFix option, after initialization:
1
2
3
4
5

// getter
var iframeFix = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "iframeFix"

opacity

Type: Number
Default: false

Opacity for the helper while being dragged.
Code examples:
Initialize the draggable with the opacity option specified:
1

$( ".selector" ).draggable({ opacity: 0.35 });

Get or set the opacity option, after initialization:
1
2

// getter
var opacity = $( ".selector" ).draggable( "option"

3
4
5

// setter
$( ".selector" ).draggable( "option", "opacity"

refreshPositions

Type: Boolean
Default: false

If set to true , all droppable positions are calculated on every
mousemove. Caution: This solves issues on highly dynamic
pages, but dramatically decreases performance.
Code examples:
Initialize the draggable with the refreshPositions option
specified:
1

$( ".selector" ).draggable({ refreshPositions:

Get or set the refreshPositions option, after initialization:
1
2
3
4
5

// getter
var refreshPositions = $( ".selector" ).draggable(

// setter
$( ".selector" ).draggable( "option", "refreshPositio

revert

Type: Boolean or String
Default: false

Whether the element should revert to its start position when
dragging stops.
Multiple types supported:

Boolean: If set to

true

the element will always revert.

String: If set to "invalid" , revert will only occur if the
draggable has not been dropped on a droppable. For
"valid" , it's the other way around.
Code examples:
Initialize the draggable with the revert option specified:
1

$( ".selector" ).draggable({ revert: true });

Get or set the revert option, after initialization:
1
2
3
4
5

// getter
var revert = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "revert"

revertDuration

Type: Number
Default: 500

The duration of the revert animation, in milliseconds.
Ignored if the revert option is false .
Code examples:
Initialize the draggable with the revertDuration option
specified:
1

$( ".selector" ).draggable({ revertDuration:

Get or set the revertDuration option, after initialization:

1
2
3
4
5

// getter
var revertDuration = $( ".selector" ).draggable(

// setter
$( ".selector" ).draggable( "option", "revertDuration

Type: String

scope

Default: "default"

Used to group sets of draggable and droppable items, in
addition to droppable's accept option. A draggable with the
same scope value as a droppable will be accepted by the
droppable.
Code examples:
Initialize the draggable with the scope option specified:
1

$( ".selector" ).draggable({ scope: "tasks" });

Get or set the scope option, after initialization:
1
2
3
4
5

// getter
var scope = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "scope"

scroll

Type: Boolean
Default: true

If set to true , container auto-scrolls while dragging.
Code examples:
Initialize the draggable with the scroll option specified:
1

$( ".selector" ).draggable({ scroll: false });

Get or set the scroll option, after initialization:
1
2
3
4
5

// getter
var scroll = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "scroll"

scrollSensitivity

Type: Number
Default: 20

Distance in pixels from the edge of the viewport after which
the viewport should scroll. Distance is relative to pointer, not
the draggable. Ignored if the scroll option is false .
Code examples:
Initialize the draggable with the scrollSensitivity option
specified:
1

$( ".selector" ).draggable({ scrollSensitivity:

Get or set the scrollSensitivity option, after initialization:
1
2

// getter
var scrollSensitivity = $( ".selector" ).draggable(

3
4
5

// setter
$( ".selector" ).draggable( "option", "scrollSensitiv

scrollSpeed

Type: Number
Default: 20

The speed at which the window should scroll once the
mouse pointer gets within the scrollSensitivity distance.
Ignored if the scroll option is false .
Code examples:
Initialize the draggable with the scrollSpeed option specified:
1

$( ".selector" ).draggable({ scrollSpeed: 100

Get or set the scrollSpeed option, after initialization:
1
2
3
4
5

// getter
var scrollSpeed = $( ".selector" ).draggable(
// setter
$( ".selector" ).draggable( "option", "scrollSpeed"

snap

Type: Boolean or Selector
Default: false

Whether the element should snap to other elements.
Multiple types supported:
Boolean: When set to true , the element will snap to all
other draggable elements.

Selector: A selector specifying which elements to snap
to.
Code examples:
Initialize the draggable with the snap option specified:
1

$( ".selector" ).draggable({ snap: true });

Get or set the snap option, after initialization:
1
2
3
4
5

// getter
var snap = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "snap",

snapMode

Type: String
Default: "both"

Determines which edges of snap elements the draggable
will snap to. Ignored if the snap option is false . Possible
values: "inner" , "outer" , "both" .
Code examples:
Initialize the draggable with the snapMode option specified:
1

$( ".selector" ).draggable({ snapMode: "inner"

Get or set the snapMode option, after initialization:
1

// getter

2
3
4
5

var snapMode = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "snapMode"

snapTolerance

Type: Number
Default: 20

The distance in pixels from the snap element edges at which
snapping should occur. Ignored if the snap option is false .
Code examples:
Initialize the draggable with the snapTolerance option
specified:
1

$( ".selector" ).draggable({ snapTolerance: 30

Get or set the snapTolerance option, after initialization:
1
2
3
4
5

// getter
var snapTolerance = $( ".selector" ).draggable(

// setter
$( ".selector" ).draggable( "option", "snapTolerance"

stack

Type: Selector
Default: false

Controls the z-index of the set of elements that match the
selector, always brings the currently dragged item to the
front. Very useful in things like window managers.

Code examples:
Initialize the draggable with the stack option specified:
1

$( ".selector" ).draggable({ stack: ".products"

Get or set the stack option, after initialization:
1
2
3
4
5

// getter
var stack = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "stack"

zIndex

Type: Number
Default: false

Z-index for the helper while being dragged.
Code examples:
Initialize the draggable with the zIndex option specified:
1

$( ".selector" ).draggable({ zIndex: 100 });

Get or set the zIndex option, after initialization:
1
2
3
4
5

// getter
var zIndex = $( ".selector" ).draggable( "option"
// setter
$( ".selector" ).draggable( "option", "zIndex"

Methods
destroy()
Removes the draggable functionality completely. This will
return the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).draggable( "destroy" );

disable()
Disables the draggable.
This method does not accept any arguments.
Code examples:
Invoke the disable method:
1

$( ".selector" ).draggable( "disable" );

enable()
Enables the draggable.
This method does not accept any arguments.

Code examples:
Invoke the enable method:
1

$( ".selector" ).draggable( "enable" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).draggable(

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current draggable options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).draggable( "option"

option( optionName, value )
Sets the value of the draggable option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).draggable( "option", "disabled"

option( options )
Sets one or more options for the draggable.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).draggable( "option", { disabled:

widget()

Returns: jQuery

Returns a jQuery object containing the draggable element.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).draggable( "widget"

Events
create( event, ui )

Type:

dragcreate

Triggered when the draggable is created.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the draggable with the create callback specified:
1
2
3

$( ".selector" ).draggable({
create: function( event, ui ) {}
});

Bind an event listener to the dragcreate event:

$( ".selector" ).on( "dragcreate", function( event, u

1

drag( event, ui )

Type:

drag

Triggered while the mouse is moved during the dragging.
event
Type: Event
ui

Type: Object
helper
Type: jQuery
The jQuery object representing the helper that's
being dragged.
position
Type: Object
Current CSS position of the helper as
} object.
offset
Type: Object
Current offset position of the helper as
} object.

{ top, left

{ top, left

Code examples:
Initialize the draggable with the drag callback specified:
1
2
3

$( ".selector" ).draggable({
drag: function( event, ui ) {}
});

Bind an event listener to the drag event:
1

$( ".selector" ).on( "drag", function( event, ui ) {}

start( event, ui )
Triggered when dragging starts.
event
Type: Event

Type:

dragstart

ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper that's
being dragged.
position
Type: Object
Current CSS position of the helper as
} object.
offset
Type: Object
Current offset position of the helper as
} object.

{ top, left

{ top, left

Code examples:
Initialize the draggable with the start callback specified:
1
2
3

$( ".selector" ).draggable({
start: function( event, ui ) {}
});

Bind an event listener to the dragstart event:
1

$( ".selector" ).on( "dragstart", function( event, ui

stop( event, ui )
Triggered when dragging stops.
event

Type:

dragstop

Type: Event
ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper that's
being dragged.
position
Type: Object
Current CSS position of the helper as
} object.
offset
Type: Object
Current offset position of the helper as
} object.

{ top, left

{ top, left

Code examples:
Initialize the draggable with the stop callback specified:
1
2
3

$( ".selector" ).draggable({
stop: function( event, ui ) {}
});

Bind an event listener to the dragstop event:
1

$( ".selector" ).on( "dragstop", function( event, ui

Example:
A simple jQuery UI Draggable
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Demo

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>draggable demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#draggable {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div id="draggable">Drag me</div>
<script>
$( "#draggable" ).draggable();
</script>
</body>
</html>

POWERED BYHERONOTE
A new version of this book is available!

Drop Effect
Categories: Effects

Drop Effect
Description: The drop effect hides or shows an element
fading in/out and sliding in a direction.
drop
direction (default: "left" )
Type: String
The direction the element will fall to hide the element, or the
direction from which the element will be revealed.
Possible Values:

up , down , left , right .

Example:
Toggle a div using the drop effect.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>drop demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle( "drop" );
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
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Droppable Widget
Categories: Interactions

Droppable Widget

version added: 1.0

Description: Create targets for draggable elements.

QuickNav

Examples

Options

Methods

Events

accept
activeClass
addClasses
disabled
greedy
hoverClass
scope
tolerance

destroy
disable
enable
option
widget

create
activate
deactivate
over
out
drop

The jQuery UI Droppable plugin makes selected elements droppable
(meaning they accept being dropped on by draggables). You can
specify which draggables each will accept.

Dependencies
UI Core
Widget Factory
Mouse Interaction

Options
accept

Type: Selector or Function()
Default: "*"

Controls which draggable elements are accepted by the
droppable.
Multiple types supported:
Selector: A selector indicating which draggable
elements are accepted.
Function: A function that will be called for each
draggable on the page (passed as the first argument to
the function). The function must return true if the
draggable should be accepted.
Code examples:
Initialize the droppable with the accept option specified:
1

$( ".selector" ).droppable({ accept: ".special"

Get or set the accept option, after initialization:
1
2
3
4
5

// getter
var accept = $( ".selector" ).droppable( "option"
// setter
$( ".selector" ).droppable( "option", "accept"

activeClass

Type: String

Default: false

If specified, the class will be added to the droppable while
an acceptable draggable is being dragged.
Code examples:
Initialize the droppable with the activeClass option specified:
1

$( ".selector" ).droppable({ activeClass: "ui-state-h

Get or set the activeClass option, after initialization:
1
2
3
4
5

// getter
var activeClass = $( ".selector" ).droppable(
// setter
$( ".selector" ).droppable( "option", "activeClass"

addClasses

Type: Boolean
Default: true

If set to false , will prevent the ui-droppable class from
being added. This may be desired as a performance
optimization when calling .droppable() init on hundreds of
elements.
Code examples:
Initialize the droppable with the addClasses option specified:
1

$( ".selector" ).droppable({ addClasses: false

Get or set the addClasses option, after initialization:

1
2
3
4
5

// getter
var addClasses = $( ".selector" ).droppable(
// setter
$( ".selector" ).droppable( "option", "addClasses"

disabled

Type: Boolean
Default: false

Disables the droppable if set to true .
Code examples:
Initialize the droppable with the disabled option specified:
1

$( ".selector" ).droppable({ disabled: true });

Get or set the disabled option, after initialization:
1
2
3
4
5

// getter
var disabled = $( ".selector" ).droppable( "option"
// setter
$( ".selector" ).droppable( "option", "disabled"

greedy

Type: Boolean
Default: false

By default, when an element is dropped on nested
droppables, each droppable will receive the element.
However, by setting this option to true , any parent
droppables will not receive the element.

Code examples:
Initialize the droppable with the greedy option specified:
1

$( ".selector" ).droppable({ greedy: true });

Get or set the greedy option, after initialization:
1
2
3
4
5

// getter
var greedy = $( ".selector" ).droppable( "option"
// setter
$( ".selector" ).droppable( "option", "greedy"

hoverClass

Type: String
Default: false

If specified, the class will be added to the droppable while
an acceptable draggable is being hovered over the
droppable.
Code examples:
Initialize the droppable with the hoverClass option specified:
1

$( ".selector" ).droppable({ hoverClass: "drop-hover"

Get or set the hoverClass option, after initialization:
1
2
3
4

// getter
var hoverClass = $( ".selector" ).droppable(
// setter

5

$( ".selector" ).droppable( "option", "hoverClass"

Type: String

scope

Default: "default"

Used to group sets of draggable and droppable items, in
addition to the accept option. A draggable with the same
scope value as a droppable will be accepted.
Code examples:
Initialize the droppable with the scope option specified:
1

$( ".selector" ).droppable({ scope: "tasks" });

Get or set the scope option, after initialization:
1
2
3
4
5

// getter
var scope = $( ".selector" ).droppable( "option"
// setter
$( ".selector" ).droppable( "option", "scope"

tolerance

Type: String
Default: "intersect"

Specifies which mode to use for testing whether a draggable
is hovering over a droppable. Possible values:
"fit" : Draggable overlaps the droppable entirely.
"intersect" :

Draggable overlaps the droppable at least
50% in both directions.

"pointer" :
"touch" :

Mouse pointer overlaps the droppable.

Draggable overlaps the droppable any

amount.
Code examples:
Initialize the droppable with the tolerance option specified:
1

$( ".selector" ).droppable({ tolerance: "fit"

Get or set the tolerance option, after initialization:
1
2
3
4
5

// getter
var tolerance = $( ".selector" ).droppable( "option"
// setter
$( ".selector" ).droppable( "option", "tolerance"

Methods
destroy()
Removes the droppable functionality completely. This will
return the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).droppable( "destroy" );

disable()
Disables the droppable.
This method does not accept any arguments.
Code examples:
Invoke the disable method:
1

$( ".selector" ).droppable( "disable" );

enable()
Enables the droppable.
This method does not accept any arguments.

Code examples:
Invoke the enable method:
1

$( ".selector" ).droppable( "enable" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).droppable(

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current droppable options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).droppable( "option"

option( optionName, value )
Sets the value of the droppable option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).droppable( "option", "disabled"

option( options )
Sets one or more options for the droppable.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).droppable( "option", { disabled:

widget()

Returns: jQuery

Returns a jQuery object containing the droppable element.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).droppable( "widget"

Events
activate( event, ui )

Type:

dropactivate

Triggered when an accepted draggable starts dragging. This
can be useful if you want to make the droppable "light up"
when it can be dropped on.
event
Type: Event
ui
Type: Object
draggable
Type: jQuery
A jQuery object representing the draggable
element.
helper
Type: jQuery
A jQuery object representing the helper that is
being dragged.
position
Type: Object
Current CSS position of the draggable helper as
top, left } object.

{

offset
Type: Object
Current offset position of the draggable helper as
top, left } object.

Code examples:
Initialize the droppable with the activate callback specified:

{

1
2
3

$( ".selector" ).droppable({
activate: function( event, ui ) {}
});

Bind an event listener to the dropactivate event:
1

$( ".selector" ).on( "dropactivate", function

create( event, ui )

Type:

dropcreate

Triggered when the droppable is created.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the droppable with the create callback specified:
1
2
3

$( ".selector" ).droppable({
create: function( event, ui ) {}
});

Bind an event listener to the dropcreate event:
1

$( ".selector" ).on( "dropcreate", function( event, u

deactivate( event, ui )

Type:

dropdeactivate

Triggered when an accepted draggable stops dragging.
event
Type: Event
ui
Type: Object
draggable
Type: jQuery
A jQuery object representing the draggable
element.
helper
Type: jQuery
A jQuery object representing the helper that is
being dragged.
position
Type: Object
Current CSS position of the draggable helper as
top, left } object.

{

offset
Type: Object
Current offset position of the draggable helper as
top, left } object.

Code examples:
Initialize the droppable with the deactivate callback
specified:
1
2
3

$( ".selector" ).droppable({
deactivate: function( event, ui ) {}
});

{

Bind an event listener to the dropdeactivate event:
1

$( ".selector" ).on( "dropdeactivate", function

drop( event, ui )

Type:

drop

Triggered when an accepted draggable is dropped on the
droppable (based on the tolerance option).
event
Type: Event
ui
Type: Object
draggable
Type: jQuery
A jQuery object representing the draggable
element.
helper
Type: jQuery
A jQuery object representing the helper that is
being dragged.
position
Type: Object
Current CSS position of the draggable helper as
top, left } object.
offset
Type: Object
Current offset position of the draggable helper as
top, left } object.

Code examples:

{

{

Initialize the droppable with the drop callback specified:
1
2
3

$( ".selector" ).droppable({
drop: function( event, ui ) {}
});

Bind an event listener to the drop event:
1

$( ".selector" ).on( "drop", function( event, ui ) {}

out( event, ui )

Type:

dropout

Triggered when an accepted draggable is dragged out of the
droppable (based on the tolerance option).
event
Type: Event
ui
Type: Object
Code examples:
Initialize the droppable with the out callback specified:
1
2
3

$( ".selector" ).droppable({
out: function( event, ui ) {}
});

Bind an event listener to the dropout event:
1

$( ".selector" ).on( "dropout", function( event, ui )

over( event, ui )

Type:

dropover

Triggered when an accepted draggable is dragged over the
droppable (based on the tolerance option).
event
Type: Event
ui
Type: Object
draggable
Type: jQuery
A jQuery object representing the draggable
element.
helper
Type: jQuery
A jQuery object representing the helper that is
being dragged.
position
Type: Object
Current CSS position of the draggable helper as
top, left } object.
offset
Type: Object
Current offset position of the draggable helper as
top, left } object.

Code examples:
Initialize the droppable with the over callback specified:
1
2

$( ".selector" ).droppable({
over: function( event, ui ) {}

{

{

3

});

Bind an event listener to the dropover event:
1

$( ".selector" ).on( "dropover", function( event, ui

Example:
A pair of draggable and droppable elements.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>droppable demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#draggable {
width: 100px;
height: 100px;
background: #ccc;
}
#droppable {
position: absolute;
left: 250px;
top: 0;
width: 125px;
height: 125px;
background: #999;
color: #fff;
padding: 10px;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div id="droppable">Drop here</div>
<div id="draggable">Drag me</div>

32
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<script>
$( "#draggable" ).draggable();
$( "#droppable" ).droppable({
drop: function() {
alert( "dropped" );
}
});
</script>
</body>
</html>

Demo
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.effect()
Categories: Effects | Effects Core | Methods

.effect( effect [, options ] [, duration ] [, complete ] )
Returns: jQuery
Description: Apply an animation effect to an element.
.effect( effect [, options ] [, duration ] [, complete ] )
effect
Type: String
A string indicating which effect to use for the transition.
options
Type: Object
Effect-specific settings and easing.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
complete
Type: Function()
A function to call once the animation is complete.

.effect( options )
options
Type: Object
All animation settings. The only required property is

effect .

effect
Type: String
A string indicating which effect to use for the transition.
easing (default: "swing" )
Type: String
A string indicating which easing function to use for the
transition.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will

run.
complete
Type: Function()
A function to call once the animation is complete.
The .effect() method applies a named animation effect to an
element. Many effects also support a show or hide mode, which can
be accomplished with the .show() , .hide() , and .toggle() methods.

Example:
Apply the bounce effect to a div.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>effect demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
div {
width: 100px;
height: 100px;
background: #ccc;
border: 1px solid #000;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to apply the effect.</p>
<div></div>
<script>
$( document ).click(function() {
$( "div" ).effect( "bounce", "slow" );
});
</script>
</body>
</html>

Demo
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.enableSelection()
Categories: Methods | UI Core

.enableSelection()

Returns: jQuery

Description: Enable selection of text content within the
set of matched elements.
.enableSelection()

version added: 1.6, deprecated: 1.9

This method does not accept any arguments.
The .enableSelection() method can be used to re-enable selection
of text that was disabled via .disableSelection() .

POWERED BYHERONOTE
A new version of this book is available!

Explode Effect
Categories: Effects

Explode Effect
Description: The explode effect hides or shows an
element by splitting it into pieces.
explode
pieces (default: 9 )
Type: Integer
The number of pieces to explode, should be a perfect square,
any other values are rounded to the nearest square.

Example:
Toggle a div using the explode effect.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>explode demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle( "explode" );
});
</script>
</body>
</html>

Demo
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Fade Effect
Categories: Effects

Fade Effect
Description: The fade effect hides or shows an element
by fading it.
fade

Example:
Toggle a div using the fade effect.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>fade demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle( "fade" );
});
</script>
</body>
</html>

Demo

POWERED BYHERONOTE
A new version of this book is available!

.focus()
Categories: Method Overrides | Methods | UI Core

.focus( delay [, callback ] )

Returns: jQuery

Description: Asynchronously set focus to an element.
.focus( delay [, callback ] )
delay
Type: Integer
The number of milliseconds to wait before setting focus.
callback
Type: Function()
A function to invoke after the element has been focused.
This plugin extends jQuery's built-in .focus() method. If jQuery UI is
not loaded, calling the .focus() method may not fail directly, as the
method still exists. However, the expected behavior will not occur.

POWERED BYHERONOTE
A new version of this book is available!

:focusable Selector
Categories: Selectors | UI Core

focusable selector
Description: Selects elements which can be focused.
jQuery( ":focusable" )
Some elements are natively focusable, while others require explictly
setting a tab index. In all cases, the element must be visible in order
to be focusable.
Elements of the following type are focusable if they are not disabled:
input , select , textarea , button , and object . Anchors are focusable
if they have an href or tabindex attribute. area elements are
focusable if they are inside a named map, have an href attribute,
and there is a visible image using the map. All other elements are
focusable based solely on their tabindex attribute and visibility.
Note: Elements with a negative tab index are
:tabbable .

:focusable ,

but not

Example:
Select focusable elements and highlight them with a
red border.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>focusable demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
input, a, p {
border: 1px solid #000;
}
div {
padding: 5px;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div><input value="text input"></div>
<div><a>anchor without href</a></div>
<div><a href="#">anchor with href</a></div>
<div><p>paragraph without tabindex</p></div>
<div><p tabindex="1">paragraph with tabindex</p
<script>
$( ":focusable" ).css( "border-color", "red" );
</script>
</body>
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</html>
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Fold Effect
Categories: Effects

Fold Effect
Description: The fold effect hides or shows an element
by folding it.
fold
size (default: 15 )
Type: Number or String
The size of the "folded" element.
horizFirst (default: false )
Type: Boolean
Whether the horizontal direction happens first when hiding.
Remember, showing inverts hiding.

Example:
Toggle a div using the fold effect.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>fold demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle( "fold" );
});
</script>
</body>
</html>

Demo
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.hide()
Categories: Effects | Effects Core | Method Overrides | Methods

.hide( effect [, options ] [, duration ] [, complete ] )
Returns: jQuery
Description: Hide the matched elements, using custom
effects.
.hide( effect [, options ] [, duration ] [, complete ] )
effect
Type: String
A string indicating which effect to use for the transition.
options
Type: Object
Effect-specific settings and easing.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
complete
Type: Function()
A function to call once the animation is complete.

.hide( options )
options
Type: Object
All animation settings. The only required property is

effect .

effect
Type: String
A string indicating which effect to use for the transition.
easing (default: "swing" )
Type: String
A string indicating which easing function to use for the
transition.
duration (default: 400 )
Type: Number or String

A string or number determining how long the animation will
run.
complete
Type: Function()
A function to call once the animation is complete.
This plugin extends jQuery's built-in .hide() method. If jQuery UI is
not loaded, calling the .hide() method may not fail directly, as the
method still exists. However, the expected behavior will not occur.

Example:
Hide a div using the drop effect.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>hide demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
div {
width: 100px;
height: 100px;
background: #ccc;
border: 1px solid #000;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<button>hide the div</button>
<div></div>
<script>
$( "button" ).click(function() {
$( "div" ).hide( "drop", { direction: "down" },
});
</script>
</body>
</html>

Demo
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Highlight Effect
Categories: Effects

Highlight Effect
Description: The highlight effect hides or shows an
element by animating its background color first.
highlight
color (default: "#ffff99" )
Type: String
The background color used during the animation.

Example:
Toggle a div using the highlight effect.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>highlight demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle( "highlight" );
});
</script>
</body>
</html>

Demo
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Widget Factory
Categories: Utilities | Widgets

Contents:
jQuery.widget( name [, base ], prototype )
jQuery.widget( name [, base ], prototype )
jQuery.Widget

jQuery.widget( name [, base ], prototype )
Description: Create stateful jQuery plugins using the
same abstraction as all jQuery UI widgets.
jQuery.widget( name [, base ], prototype )
name
Type: String
The name of the widget to create, including the namespace.
base
Type: Function()
The base widget to inherit from. This must be a constructor that
can be instantiated with the `new` keyword. Defaults to
jQuery.Widget .
prototype
Type: PlainObject
The object to use as a prototype for the widget.
You can create new widgets from scratch, using just the $.Widget
object as a base to inherit from, or you can explicitly inherit from
existing jQuery UI or third-party widgets. Defining a widget with the
same name as you inherit from even allows you to extend widgets in
place.
jQuery UI contains many widgets that maintain state and therefore
have a slightly different usage pattern than typical jQuery plugins. All
of jQuery UI's widgets use the same patterns, which is defined by
the widget factory. So if you learn how to use one widget, then you'll
know how to use all of them.
Note: This documentation shows examples using the progressbar
widget but the syntax is the same for every widget.

Initialization
In order to track the state of the widget, we must introduce a full life
cycle for the widget. The life cycle starts when the widget is

initalized. To initialize a widget, we simply call the plugin on one or
more elements.
1

$( "#elem" ).progressbar();

This will initialize each element in the jQuery object, in this case the
element with an id of "elem" . Because we called the progressbar()
method with no parameters, the widget is initialized with its default
options. We can pass a set of options during initialization in order to
override the default options.
1

$( "#elem" ).progressbar({ value: 20 });

We can pass as many or as few options as we want during
initialization. Any options that we don't pass will just use their default
values.
The options are part of the widget's state, so we can set options
after initialization as well. We'll see this later with the option method.

Methods
Now that the widget is initialized, we can query its state or perform
actions on the widget. All actions after initialization take the form of a
method call. To call a method on a widget, we pass the name of the
method to the jQuery plugin. For example, to call the value()
method on our progressbar widget, we would use:
1

$( "#elem" ).progressbar( "value" );

If the method accepts parameters, we can pass them after the
method name. For example, to pass the parameter 40 to the
value() method, we can use:
1

$( "#elem" ).progressbar( "value", 40 );

Just like other methods in jQuery, most widget methods return the
jQuery object for chaining.
1
2
3

$( "#elem" )
.progressbar( "value", 90 )
.addClass( "almost-done" );

Each widget will have its own set of methods based on the
functionality that the widget provides. However, there are a few
methods that exist on all widgets, which are documented below.

Events
All widgets have events associated with their various behaviors to
notify you when the state is changing. For most widgets, when the
events are triggered, the names are prefixed with the widget name.
For example, we can bind to progressbar's change event which is
triggered whenever the value changes.
1
2
3

$( "#elem" ).bind( "progressbarchange", function
alert( "The value has changed!" );
});

Each event has a corresponding callback, which is exposed as an
option. We can hook into progressbar's change callback instead of
binding to the progressbarchange event, if we want to.
1
2
3
4
5

$( "#elem" ).progressbar({
change: function() {
alert( "The value has changed!" );
}
});

All widgets have a
instantiation.

create

event which is triggered upon

Base Widget
Description: The base widget used by the widget
factory.

QuickNav
Options

Methods

Events

disabled
hide
show

destroy
create
disable
enable
option
widget
_create
_destroy
_getCreateEventData
_getCreateOptions
_init
_setOptions
_setOption
_on
_off
_super
_superApply
_delay
_hoverable
_focusable
_trigger
_show
_hide

Options
disabled

Type: Boolean
Default: false

Disables the widget if set to true .
Code examples:
Initialize the widget with the disabled option specified:
1

$( ".selector" ).widget({ disabled: true });

Get or set the disabled option, after initialization:
1
2
3
4
5

// getter
var disabled = $( ".selector" ).widget( "option"
// setter
$( ".selector" ).widget( "option", "disabled"

hide Type: Boolean or Number or String or Object
Default: null

If and how to animate the hiding of the element.
Multiple types supported:
Boolean: When set to false , no animation will be used
and the element will be hidden immediately. When set
to true , the element will fade out with the default
duration and the default easing.
Number: The element will fade out with the specified
duration and the default easing.

String: The element will be hidden using the specified
effect. The value can either be the name of a built-in
jQuery animation method, such as "slideUp" , or the
name of a jQuery UI effect, such as "fold" . In either
case the effect will be used with the default duration
and the default easing.
Object: If the value is an object, then effect , delay ,
duration , and easing properties may be provided. If the
effect property contains the name of a jQuery method,
then that method will be used; otherwise it is assumed
to be the name of a jQuery UI effect. When using a
jQuery UI effect that supports additional settings, you
may include those settings in the object and they will be
passed to the effect. If duration or easing is omitted,
then the default values will be used. If effect is omitted,
then "fadeOut" will be used. If delay is omitted, then no
delay is used.
Code examples:
Initialize the widget with the hide option specified:
1

$( ".selector" ).widget({ hide: { effect: "explode"

Get or set the hide option, after initialization:
1
2
3
4
5

// getter
var hide = $( ".selector" ).widget( "option",
// setter
$( ".selector" ).widget( "option", "hide", { effect:

show Type: Boolean or Number or String or Object
Default: null

If and how to animate the showing of the element.
Multiple types supported:
Boolean: When set to false , no animation will be used
and the element will be shown immediately. When set
to true , the element will fade in with the default
duration and the default easing.
Number: The element will fade in with the specified
duration and the default easing.
String: The element will be shown using the specified
effect. The value can either be the name of a built-in
jQuery animation method, such as "slideDown" , or the
name of a jQuery UI effect, such as "fold" . In either
case the effect will be used with the default duration
and the default easing.
Object: If the value is an object, then effect , delay ,
duration , and easing properties may be provided. If the
effect property contains the name of a jQuery method,
then that method will be used; otherwise it is assumed
to be the name of a jQuery UI effect. When using a
jQuery UI effect that supports additional settings, you
may include those settings in the object and they will be
passed to the effect. If duration or easing is omitted,
then the default values will be used. If effect is omitted,
then "fadeIn" will be used. If delay is omitted, then no
delay is used.
Code examples:
Initialize the widget with the show option specified:
1

$( ".selector" ).widget({ show: { effect: "blind"

Get or set the show option, after initialization:
1
2
3
4

// getter
var show = $( ".selector" ).widget( "option",
// setter

5

$( ".selector" ).widget( "option", "show", { effect:

Methods
_create()
The _create() method is the widget's constructor. There are
no parameters, but this.element and this.options are
already set.
This method does not accept any arguments.

_delay( fn [, delay ] )

Returns: Number

Invokes the provided function after a specified delay. Keeps
this context correct. Essentially setTimeout() .
Returns the timeout ID for use with clearTimeout() .
fn
Type: Function() or String
The function to invoke. Can also be the name of a
method on the widget.
delay
Type: Number
The number of milliseconds to wait before invoking the
function. Deafults to 0 .

_destroy()
The public destroy() method cleans up all common data,
events, etc. and then delegates out to _destroy() for
custom, widget-specific, cleanup.
This method does not accept any arguments.

_focusable( element )
Sets up element to apply the ui-state-focus class on focus.
The event handlers are automatically cleaned up on destroy.
element
Type: jQuery
The element(s) to apply the focusable behavior to.

_getCreateEventData()

Returns: Object

All widgets trigger the create event. By default, no data is
provided in the event, but this method can return an object
which will be passed as the create event's data.
This method does not accept any arguments.

_getCreateOptions()

Returns: Object

This method allows the widget to define a custom method
for defining options during instantiation. This user-provided
options override the options returned by this method which
override the default options.
This method does not accept any arguments.

_hide( element, option [, callback ] )
Hides an element immediately, using built-in animation
methods, or using custom effects. See the hide option for
possible option values.
element
Type: jQuery
The element(s) to hide.

option
Type: Object
The settings defining how to hide the element.
callback
Type: Function()
Callback to invoke after the element has been fully
hidden.

_hoverable( element )
Sets up element to apply the ui-state-hover class on hover.
The event handlers are automatically cleaned up on destroy.
element
Type: jQuery
The element(s) to apply the hoverable behavior to.

_init()
Widgets have the concept of initialization that is distinct from
creation. Any time the plugin is called with no arguments or
with only an option hash, the widget is initialized; this
includes when the widget is created.
Note: Initialization should only be handled if there is a logical
action to perform on successive calls to the widget with no
arguments.
This method does not accept any arguments.

_off( element, eventName )
Unbinds event handlers from the specified element(s).

element
Type: jQuery
The element(s) to unbind the event handlers from.
Unlike the _on() method, the elements are required for
_off() .
eventName
Type: String
One or more space-separated event types.

_on( [element ], handlers )
Binds event handlers to the specified element(s). Delegation
is supported via selectors inside the event names, e.g.,
" click .foo ". The _on() method provides several benefits of
direct event binding:
Maintains proper this context inside the handlers.
Automatically handles disabled widgets: If the widget is
disabled or the event occurs on an element with the uistate-disabled class, the event handler is not invoked.
Event handlers are automatically namespaced and
cleaned up on destroy.
element
Type: jQuery
Which element(s) to bind the event handlers to. If no
element is provided, this.element is used.
handlers
Type: Object
A map in which the string keys represent the event type
and optional selector for delegation, and the values
represent a handler function to be called for the event.

_setOption( key, value )
Called from the _setOptions() method for each individual
option. Widget state should be updated based on changes.
key
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.

_setOptions( options )
Called whenever the option() method is called, regardless
of the form in which the option() method was called.
Overriding this is useful if you can defer processor-intensive
changes for multiple option changes.
options
Type: Object
A map of option-value pairs to set.

_show( element, option [, callback ] )
Shows an element immediately, using built-in animation
methods, or using custom effects. See the show option for
possible option values.
element
Type: jQuery
The element(s) to show.
option
Type: Object
The settings defining how to show the element.

callback
Type: Function()
Callback to invoke after the element has been fully
shown.

_super()
Invokes the method of the same name from the parent
widget, with any specified arguments. Essentially .call() .
This method does not accept any arguments.

_superApply( arguments )
Invokes the method of the same name from the parent
widget, with the array of arguments. Essentially .apply() .
arguments
Type: Array
Array of arguments to pass to the parent method.

_trigger( type [, event ] [, data ] )
Triggers an event and its associated callback.
The option with the name equal to type is invoked as the
callback.
The event name is the widget name + type.
Note: When providing data, you must provide all three
parameters. If there is no event to pass along, just pass
null .
type
Type: String

The type should match the name of a callback option.
The full event type will be generated automatically.
event
Type: Event
The original event that caused this event to occur;
useful for providing context to the listener.
data
Type: Object
A hash of data associated with the event.

destroy()
Removes the widget functionality completely. This will return
the element back to its pre-init state.
This method does not accept any arguments.

disable()
Disables the widget.
This method does not accept any arguments.

enable()
Enables the widget.
This method does not accept any arguments.

option( optionName )

Returns: Object

Gets the value currently associated with the specified

optionName .

optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).widget( "option"

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current widget options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).widget( "option"

option( optionName, value )
Sets the value of the widget option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object

A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).widget( "option", "disabled"

option( options )
Sets one or more options for the widget.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).widget( "option", { disabled:

widget()

Returns: jQuery

Returns a jQuery object containing the original element or
other relevant generated element.
This method does not accept any arguments.

Events
create( event, ui )

Type:

widgetcreate

Triggered when the widget is created.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the widget with the create callback specified:
1
2
3

$( ".selector" ).widget({
create: function( event, ui ) {}
});

Bind an event listener to the widgetcreate event:
1

$( ".selector" ).on( "widgetcreate", function
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Menu Widget
Categories: Widgets

Menu Widget

version added: 1.9

Description: Themeable menu with mouse and
keyboard interactions for navigation.

QuickNav

Examples

Options

Methods

Events

disabled
icons
menus
position
role

blur
collapse
collapseAll
destroy
disable
enable
expand
focus
isFirstItem
isLastItem
next
nextPage
option
previous
previousPage
refresh
select
widget

blur
create
focus
select

A menu can be created from any valid markup as long as the
elements have a strict parent/child relationship and each menu item
has an anchor. The most commonly used element is the unordered
list ( <ul> ):
<ul id="menu">
<li><a href="#">Item 1</a></li>
<li><a href="#">Item 2</a></li>
<li><a href="#">Item 3</a>
<ul>
<li><a href="#">Item
<li><a href="#">Item
<li><a href="#">Item
<li><a href="#">Item
<li><a href="#">Item
</ul>
</li>
<li><a href="#">Item 4</a></li>

3-1</a></li>
3-2</a></li>
3-3</a></li>
3-4</a></li>
3-5</a></li>

<li><a href="#">Item 5</a></li>
</ul>

If you use a structure other than <ul> / <li> , including using the
same element for the menu and the menu items, use the menus
option to specify a way to differentiate the two elements, e.g., menus:
"div.menuElement" .
Any menu item can be disabled by adding the
class to that element.

ui-state-disabled

To add icons to the menu, include them in the markup:
<ul id="menu">
<li><a href="#"><span class="ui-icon ui-icon-disk">
</span>Save</a></li>
</ul>

Menu automatically adds the necessary padding to items without
icons.

Keyboard interaction
ENTER/SPACE: Invoke the focused menu item's action, which
may be opening a submenu.
UP: Move focus to the previous menu item.
DOWN: Move focus to the next menu item.
RIGHT: Open the submenu, if available.
LEFT: Close the current submenu and move focus to the parent
menu item. If not in a submenu, do nothing.
ESCAPE: Close the current submenu and move focus to the
parent menu item. If not in a submenu, do nothing.
Typing a letter moves focus to the first item whose title starts with
that character. Repeating the same character cycles through
matching items. Typing more characters within the one second timer
matches those characters.
Disabled items can receive keyboard focus, but do not allow any
other interaction.

Dependencies

UI Core
Widget Factory
Position

Additional Notes:
This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific
CSS file as a starting point.

Options
disabled

Type: Boolean
Default: false

Disables the menu if set to true .
Code examples:
Initialize the menu with the disabled option specified:
1

$( ".selector" ).menu({ disabled: true });

Get or set the disabled option, after initialization:
1
2
3
4
5

// getter
var disabled = $( ".selector" ).menu( "option"
// setter
$( ".selector" ).menu( "option", "disabled",

icons

Type: Object
Default: { submenu: "ui-icon-carat-1-e" }

Icons to use for submenus, matching an icon defined by the
jQuery UI CSS Framework.
submenu (string, default: "ui-icon-carat-1-e")
Code examples:
Initialize the menu with the icons option specified:

1

$( ".selector" ).menu({ icons: { submenu: "ui-icon-ci

Get or set the icons option, after initialization:
1
2
3
4
5

// getter
var icons = $( ".selector" ).menu( "option",
// setter
$( ".selector" ).menu( "option", "icons", { submenu:

menus

Type: String
Default: "ul"

Selector for the elements that serve as the menu container,
including sub-menus.
Note: The menus option should not be changed after
initialization. Existing submenus will not be updated.
Code examples:
Initialize the menu with the menus option specified:
1

$( ".selector" ).menu({ menus: "div" });

Get or set the menus option, after initialization:
1
2
3
4
5

// getter
var menus = $( ".selector" ).menu( "option",
// setter
$( ".selector" ).menu( "option", "menus", "div"

position

Type: Object
Default: { my: "left top", at: "right top" }

Identifies the position of submenus in relation to the
associated parent menu item. The of option defaults to the
parent menu item, but you can specify another element to
position against. You can refer to the jQuery UI Position
utility for more details about the various options.
Code examples:
Initialize the menu with the position option specified:
1

$( ".selector" ).menu({ position: { my: "left top"

Get or set the position option, after initialization:
1
2
3
4
5

role

// getter
var position = $( ".selector" ).menu( "option"
// setter
$( ".selector" ).menu( "option", "position", { my:

Type: String
Default: "menu"

Customize the ARIA roles used for the menu and menu
items. The default uses "menuitem" for items. Setting the
role option to "listbox" will use "option" for items. If set to
null , no roles will be set, which is useful if the menu is
being controlled by another element that is maintaining
focus.

Note: The role option should not be changed after
initialization. Existing (sub)menus and menu items will not
be updated.
Code examples:
Initialize the menu with the role option specified:
1

$( ".selector" ).menu({ role: null });

Get or set the role option, after initialization:
1
2
3
4
5

// getter
var role = $( ".selector" ).menu( "option", "role"
// setter
$( ".selector" ).menu( "option", "role", null

Methods
blur( [event ] )
Removes focus from a menu, resets any active element
styles and triggers the menu's blur event.
event
Type: Event
What triggered the menu to blur.
Code examples:
Invoke the blur method:
1

$( ".selector" ).menu( "blur" );

collapse( [event ] )
Closes the currently active sub-menu.
event
Type: Event
What triggered the menu to collapse.
Code examples:
Invoke the collapse method:
1

$( ".selector" ).menu( "collapse" );

collapseAll( [event ] [, all ] )

Closes all open sub-menus.
event
Type: Event
What triggered the menu to collapse.
all
Type: Boolean
Indicates whether all sub-menus should be closed or
only sub-menus below and including the menu that is or
contains the target of the triggering event.
Code examples:
Invoke the collapseAll method:
1

$( ".selector" ).menu( "collapseAll", null, true

destroy()
Removes the menu functionality completely. This will return
the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).menu( "destroy" );

disable()
Disables the menu.
This method does not accept any arguments.

Code examples:
Invoke the disable method:
1

$( ".selector" ).menu( "disable" );

enable()
Enables the menu.
This method does not accept any arguments.
Code examples:
Invoke the enable method:
1

$( ".selector" ).menu( "enable" );

expand( [event ] )
Opens the sub-menu below the currently active item, if one
exists.
event
Type: Event
What triggered the menu to expand.
Code examples:
Invoke the expand method:
1

$( ".selector" ).menu( "expand" );

focus( [event ], item )
Activates a particular menu item, begins opening any submenu if present and triggers the menu's focus event.
event
Type: Event
What triggered the menu item to gain focus.
item
Type: jQuery
The menu item to focus/activate.
Code examples:
Invoke the focus method:
1

$( ".selector" ).menu( "focus", null, menu.find(

isFirstItem()
Returns a boolean value stating whether or not the currently
active item is the first item in the menu.
This method does not accept any arguments.
Code examples:
Invoke the isFirstItem method:
1

var firstItem = $( ".selector" ).menu( "isFirstItem"

isLastItem()

Returns a boolean value stating whether or not the currently
active item is the last item in the menu.
This method does not accept any arguments.
Code examples:
Invoke the isLastItem method:
1

var lastItem = $( ".selector" ).menu( "isLastItem"

next( [event ] )
Moves active state to next menu item.
event
Type: Event
What triggered the focus to move.
Code examples:
Invoke the next method:
1

$( ".selector" ).menu( "next" );

nextPage( [event ] )
Moves active state to first menu item below the bottom of a
scrollable menu or the last item if not scrollable.
event
Type: Event
What triggered the focus to move.
Code examples:
Invoke the nextPage method:

1

$( ".selector" ).menu( "nextPage" );

Returns: Object

option( optionName )

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).menu( "option"

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current menu options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).menu( "option"

option( optionName, value )

Sets the value of the menu option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).menu( "option", "disabled",

option( options )
Sets one or more options for the menu.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).menu( "option", { disabled:

previous( [event ] )
Moves active state to previous menu item.
event

Type: Event
What triggered the focus to move.
Code examples:
Invoke the previous method:
1

$( ".selector" ).menu( "previous" );

previousPage( [event ] )
Moves active state to first menu item above the top of a
scrollable menu or the first item if not scrollable.
event
Type: Event
What triggered the focus to move.
Code examples:
Invoke the previousPage method:
1

$( ".selector" ).menu( "previousPage" );

refresh()
Initializes sub-menus and menu items that have not already
been initialized. New menu items, including sub-menus can
be added to the menu or all of the contents of the menu can
be replaced and then initialized with the refresh() method.
This method does not accept any arguments.
Code examples:
Invoke the refresh method:

1

$( ".selector" ).menu( "refresh" );

select( [event ] )
Selects the currently active menu item, collapses all submenus and triggers the menu's select event.
event
Type: Event
What triggered the selection.
Code examples:
Invoke the select method:
1

$( ".selector" ).menu( "select" );

widget()

Returns: jQuery

Returns a jQuery object containing the menu.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).menu( "widget" );

Events
blur( event, ui )

Type:

menublur

Triggered when the menu loses focus.
event
Type: Event
ui
Type: Object
item
Type: jQuery
The currently active menu item.

Code examples:
Initialize the menu with the blur callback specified:
1
2
3

$( ".selector" ).menu({
blur: function( event, ui ) {}
});

Bind an event listener to the menublur event:
1

$( ".selector" ).on( "menublur", function( event, ui

create( event, ui )
Triggered when the menu is created.

Type:

menucreate

event
Type: Event
ui
Type: Object
Code examples:
Initialize the menu with the create callback specified:
1
2
3

$( ".selector" ).menu({
create: function( event, ui ) {}
});

Bind an event listener to the menucreate event:
1

$( ".selector" ).on( "menucreate", function( event, u

focus( event, ui )

Type:

menufocus

Triggered when a menu gains focus or when any menu item
is activated.
event
Type: Event
ui
Type: Object
item
Type: jQuery
The currently active menu item.

Code examples:
Initialize the menu with the focus callback specified:

1
2
3

$( ".selector" ).menu({
focus: function( event, ui ) {}
});

Bind an event listener to the menufocus event:
1

$( ".selector" ).on( "menufocus", function( event, ui

select( event, ui )

Type:

menuselect

Triggered when a menu item is selected.
event
Type: Event
ui
Type: Object
item
Type: jQuery
The currently active menu item.

Code examples:
Initialize the menu with the select callback specified:
1
2
3

$( ".selector" ).menu({
select: function( event, ui ) {}
});

Bind an event listener to the menuselect event:

1

$( ".selector" ).on( "menuselect", function( event, u

Example:
A simple jQuery UI Menu
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>menu demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
.ui-menu {
width: 200px;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<ul id="menu">
<li><a href="#">Item 1</a></li>
<li><a href="#">Item 2</a></li>
<li><a href="#">Item 3</a>
<ul>
<li><a href="#">Item 3-1</a></li>
<li><a href="#">Item 3-2</a></li>
<li><a href="#">Item 3-3</a></li>
<li><a href="#">Item 3-4</a></li>
<li><a href="#">Item 3-5</a></li>
</ul>
</li>
<li><a href="#">Item 4</a></li>
<li><a href="#">Item 5</a></li>
</ul>

32
33
34
35
36
37
38

<script>
$( "#menu" ).menu();
</script>
</body>
</html>

Demo
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Mouse Interaction
Categories: Interactions | Utilities

Mouse Interaction
Description: The base interaction layer.

QuickNav
Options

Methods

cancel
delay
distance

_mouseInit
_mouseDestroy
_mouseDown
_mouseMove
_mouseUp
_mouseDistanceMet
_mouseDelayMet
_mouseStart
_mouseDrag
_mouseStop
_mouseCapture

Events

Similar to jQuery.Widget , the mouse interaction is not intended to be
used directly. It is purely a base layer for other widgets to inherit
from. This page only documents what is added to jQuery.Widget , but
it does include internal methods that are not intended to be
overwritten. The intended public API is _mouseStart() , _mouseDrag() ,
_mouseStop() , and _mouseCapture() .

Dependencies
Widget Factory

Options
cancel

Type: Selector
Default: "input,textarea,button,select,option"

Prevents interactions from starting on specified elements.
Code examples:
Initialize the mouse with the cancel option specified:
1

$( ".selector" ).mouse({ cancel: ".title" });

Get or set the cancel option, after initialization:
1
2
3
4
5

// getter
var cancel = $( ".selector" ).mouse( "option"
// setter
$( ".selector" ).mouse( "option", "cancel", ".title"

delay

Type: Number
Default: 0

Time in milliseconds after mousedown until the interaction
should start. This option can be used to prevent unwanted
interactions when clicking on an element.
Code examples:
Initialize the mouse with the delay option specified:
1

$( ".selector" ).mouse({ delay: 300 });

Get or set the delay option, after initialization:
1
2
3
4
5

// getter
var delay = $( ".selector" ).mouse( "option",
// setter
$( ".selector" ).mouse( "option", "delay", 300

distance

Type: Number
Default: 1

Distance in pixels after mousedown the mouse must move
before the interaction should start. This option can be used
to prevent unwanted interactions when clicking on an
element.
Code examples:
Initialize the mouse with the distance option specified:
1

$( ".selector" ).mouse({ distance: 10 });

Get or set the distance option, after initialization:
1
2
3
4
5

// getter
var distance = $( ".selector" ).mouse( "option"
// setter
$( ".selector" ).mouse( "option", "distance",

Methods
_mouseCapture()

Returns: Boolean

Determines whether an interaction should start based on
event target of the interaction. The default implementation
always returns true .
This method does not accept any arguments.
Code examples:
Invoke the _mouseCapture method:
1

$( ".selector" ).mouse( "_mouseCapture" );

_mouseDelayMet()

Returns: Boolean

Determines whether the delay option has been met for the
current interaction.
This method does not accept any arguments.
Code examples:
Invoke the _mouseDelayMet method:
1

$( ".selector" ).mouse( "_mouseDelayMet" );

_mouseDestroy()

Destroys the interaction event handlers. This must be called
from the extending widget's _destroy() method.
This method does not accept any arguments.
Code examples:
Invoke the _mouseDestroy method:
1

$( ".selector" ).mouse( "_mouseDestroy" );

_mouseDistanceMet()

Returns: Boolean

Determines whether the distance option has been met for
the current interaction.
This method does not accept any arguments.
Code examples:
Invoke the _mouseDistanceMet method:
1

$( ".selector" ).mouse( "_mouseDistanceMet" );

_mouseDown()
Handles the beginning of an interaction. Verifies that the
event is associated with the primary mouse button and
ensures that the delay and distance options are met prior to
starting the interaction. When the interaction is ready to
start, invokes the _mouseStart() method for the extending
widget to handle.
This method does not accept any arguments.

Code examples:
Invoke the _mouseDown method:
1

$( ".selector" ).mouse( "_mouseDown" );

_mouseDrag()
The extending widget should implement a _mouseDrag()
method to handle each movement of an interaction. This
method will receive the mouse event associated with the
movement.
This method does not accept any arguments.
Code examples:
Invoke the _mouseDrag method:
1

$( ".selector" ).mouse( "_mouseDrag" );

_mouseInit()
Initializes the interaction event handlers. This must be called
from the extending widget's _create() method.
This method does not accept any arguments.
Code examples:
Invoke the _mouseInit method:
1

$( ".selector" ).mouse( "_mouseInit" );

_mouseMove()
Handles each movement of the interaction. Invokes the
mouseDrag() method for the extending widget to handle.
This method does not accept any arguments.
Code examples:
Invoke the _mouseMove method:
1

$( ".selector" ).mouse( "_mouseMove" );

_mouseStart()
The extending widget should implement a _mouseStart()
method to handle the beginning of an interaction. This
method will receive the mouse event associated with the
start of the interaction.
This method does not accept any arguments.
Code examples:
Invoke the _mouseStart method:
1

$( ".selector" ).mouse( "_mouseStart" );

_mouseStop()
The extending widget should implement a _mouseStop()
method to handle the end of an interaction. This method will

receive the mouse event associated with the end of the
interaction.
This method does not accept any arguments.
Code examples:
Invoke the _mouseStop method:
1

$( ".selector" ).mouse( "_mouseStop" );

_mouseUp()
Handles the end of the interaction. Invokes the mouseStop()
method for the extending widget to handle.
This method does not accept any arguments.
Code examples:
Invoke the _mouseUp method:
1

$( ".selector" ).mouse( "_mouseUp" );

POWERED BYHERONOTE
A new version of this book is available!

.position()
Categories: Method Overrides | Methods | Utilities

.position( options )

Returns: jQuery
version added: 1.8

Description: Position an element relative to another.
.position( options )
options
Type: Object
my (default: "center" )
Type: String
Defines which position on the element being positioned
to align with the target element: "horizontal vertical"
alignment. A single value such as "right" will be
normalized to "right center" , "top" will be normalized to
"center top" (following CSS convention). Acceptable
horizontal values: "left" , "center" , "right" . Acceptable
vertical values: "top" , "center" , "bottom" . Example: "left
top" or "center center" . Each dimension can also contain
offsets, in pixels or percent, e.g., "right+10 top-25%" .
Percentage offsets are relative to the element being
positioned.
at (default: "center" )
Type: String
Defines which position on the target element to align the
positioned element against: "horizontal vertical" alignment.
See the my option for full details on possible values.
Percentage offsets are relative to the target element.
of (default: null )
Type: Selector or Element or jQuery or Event
Which element to position against. If you provide a selector
or jQuery object, the first matching element will be used. If
you provide an event object, the pageX and pageY
properties will be used. Example: "#top-menu"
collision (default: "flip" )
Type: String
When the positioned element overflows the window in

some direction, move it to an alternative position. Similar to
my and at , this accepts a single value or a pair for
horizontal/vertical, e.g., "flip" , "fit" , "fit flip" , "fit
none" .
"flip" :

Flips the element to the opposite side of the
target and the collision detection is run again to see if
it will fit. Whichever side allows more of the element to
be visible will be used.
"fit" : Shift the element away from the edge of the
window.
"flipfit" : First applies the flip logic, placing the
element on whichever side allows more of the element
to be visible. Then the fit logic is applied to ensure as
much of the element is visible as possible.
"none" :

Does not apply any collision detection.

using (default: null )
Type: Function()
When specified, the actual property setting is delegated to
this callback. Receives two parameters: The first is a hash
of top and left values for the position that should be set
and can be forwarded to .css() or .animate() .
The second provides feedback about the position and
dimensions of both elements, as well as calculations to
their relative position. Both target and element have these
properties: element , left , top , width , height . In addition,
there's horizontal , vertical and important , giving you
twelve potential directions like { horizontal: "center",
vertical: "left", important: "horizontal" } .
within (default: window )
Type: Selector or Element or jQuery
Element to position within, affecting collision detection. If
you provide a selector or jQuery object, the first matching
element will be used.
The jQuery UI

.position()

method allows you to position an element

relative to the window, document, another element, or the
cursor/mouse, without worrying about offset parents.
Note: jQuery UI does not support positioning hidden elements.
This is a standalone jQuery plugin and has no dependencies on
other jQuery UI components.
This plugin extends jQuery's built-in .position() method. If jQuery
UI is not loaded, calling the .position() method may not fail directly,
as the method still exists. However, the expected behavior will not
occur.

Example:
A simple jQuery UI Position example.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>position demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
.positionDiv {
position: absolute;
width: 75px;
height: 75px;
background: green;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div id="targetElement">
<div class="positionDiv"
<div class="positionDiv"
<div class="positionDiv"
<div class="positionDiv"
</div>

id="position1"></div
id="position2"></div
id="position3"></div
id="position4"></div

<script>
$( "#position1" ).position({
my: "center",
at: "center",
of: "#targetElement"

32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56

});
$( "#position2" ).position({
my: "left top",
at: "left top",
of: "#targetElement"
});
$( "#position3" ).position({
my: "right center",
at: "right bottom",
of: "#targetElement"
});
$( document ).mousemove(function( event ) {
$( "#position4" ).position({
my: "left+3 bottom-3",
of: event,
collision: "fit"
});
});
</script>
</body>
</html>

Demo
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Progressbar Widget
Categories: Widgets

Progressbar Widget

version added: 1.6

Description: Display status of a determinate or
indeterminate process.

QuickNav

Examples

Options

Methods

Events

disabled
max
value

destroy
disable
enable
option
value
widget

change
create
complete

The progress bar is designed to display the current percent
complete for a process. The bar is coded to be flexibly sized through
CSS and will scale to fit inside its parent container by default.
A determinate progress bar should only be used in situations where
the system can accurately update the current status. A determinate
progress bar should never fill from left to right, then loop back to
empty for a single process — if the actual status cannot be
calculated, an indeterminate progress bar should be used to provide
user feedback.

Dependencies
UI Core
Widget Factory

Additional Notes:
This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific
CSS file as a starting point.

Options
disabled

Type: Boolean
Default: false

Disables the progressbar if set to true .
Code examples:
Initialize the progressbar with the disabled option specified:
1

$( ".selector" ).progressbar({ disabled: true

Get or set the disabled option, after initialization:
1
2
3
4
5

max

// getter
var disabled = $( ".selector" ).progressbar(
// setter
$( ".selector" ).progressbar( "option", "disabled"

Type: Number
Default: 100

The maximum value of the progressbar.
Code examples:
Initialize the progressbar with the max option specified:
1

$( ".selector" ).progressbar({ max: 1024 });

Get or set the max option, after initialization:
1
2
3
4
5

// getter
var max = $( ".selector" ).progressbar( "option"
// setter
$( ".selector" ).progressbar( "option", "max"

value

Type: Number or Boolean
Default: 0

The value of the progressbar.
Multiple types supported:
Number: A value between

0

and the

Boolean: Value can be set to
indeterminate progressbar.

false

max .

to create an

Code examples:
Initialize the progressbar with the value option specified:
1

$( ".selector" ).progressbar({ value: 25 });

Get or set the value option, after initialization:
1
2
3
4
5

// getter
var value = $( ".selector" ).progressbar( "option"
// setter
$( ".selector" ).progressbar( "option", "value"

Methods
destroy()
Removes the progressbar functionality completely. This will
return the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).progressbar( "destroy" );

disable()
Disables the progressbar.
This method does not accept any arguments.
Code examples:
Invoke the disable method:
1

$( ".selector" ).progressbar( "disable" );

enable()
Enables the progressbar.
This method does not accept any arguments.

Code examples:
Invoke the enable method:
1

$( ".selector" ).progressbar( "enable" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).progressbar(

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current progressbar options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).progressbar( "option"

option( optionName, value )
Sets the value of the progressbar option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).progressbar( "option", "disabled"

option( options )
Sets one or more options for the progressbar.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).progressbar( "option", { disabled:

value()

Returns: Number or Boolean

Gets the current value of the progressbar.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var progressSoFar = $( ".selector" ).progressbar(

value( value )
Sets the current value of the progressbar.
value
Type: Number or Boolean
The value to set. See the value option for details on
valid values.
Code examples:
Invoke the method:
1

$( ".selector" ).progressbar( "value", 50 );

widget()

Returns: jQuery

Returns a jQuery object containing the progressbar.
This method does not accept any arguments.
Code examples:

Invoke the widget method:
1

var widget = $( ".selector" ).progressbar( "widget"

Events
change( event, ui )

Type:

progressbarchange

Triggered when the value of the progressbar changes.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the progressbar with the change callback specified:
1
2
3

$( ".selector" ).progressbar({
change: function( event, ui ) {}
});

Bind an event listener to the progressbarchange event:
1

$( ".selector" ).on( "progressbarchange", function

complete( event, ui ) Type:

progressbarcomplete

Triggered when the value of the progressbar reaches the
maximum value.
event
Type: Event

ui
Type: Object
Code examples:
Initialize the progressbar with the complete callback
specified:
1
2
3

$( ".selector" ).progressbar({
complete: function( event, ui ) {}
});

Bind an event listener to the progressbarcomplete event:
1

$( ".selector" ).on( "progressbarcomplete", function

create( event, ui )

Type:

progressbarcreate

Triggered when the progressbar is created.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the progressbar with the create callback specified:
1
2
3

$( ".selector" ).progressbar({
create: function( event, ui ) {}
});

Bind an event listener to the progressbarcreate event:
1

$( ".selector" ).on( "progressbarcreate", function

Examples:
Example:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

A simple jQuery UI Progressbar

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>progressbar demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div id="progressbar"></div>
<script>
$( "#progressbar" ).progressbar({
value: 37
});
</script>
</body>
</html>

Demo
Example:

A simple jQuery UI Indeterminate
Progressbar
1
2
3

<!doctype html>
<html lang="en">
<head>

4
5
6
7
8
9
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<meta charset="utf-8">
<title>progressbar demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div id="progressbar"></div>
<script>
$( "#progressbar" ).progressbar({
value: false
});
</script>
</body>
</html>

Demo
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Puff Effect
Categories: Effects

Puff Effect
Description: Creates a puff effect by scaling the
element up and hiding it at the same time.
puff
percent (default: 150 )
Type: Number
The percentage to scale to.

Example:
Toggle a div using the puff effect.
1
2
3
4
5
6
7
8
9
10
11
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13
14
15
16
17
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19
20
21
22
23
24
25
26
27
28
29

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>puff demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle( "puff" );
});
</script>
</body>
</html>

Demo
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Pulsate Effect
Categories: Effects

Pulsate Effect
Description: The pulsate effect hides or shows an
element by pulsing it in or out.
pulsate
times (default: 5 )
Type: Integer
The number of times the element should pulse. An extra half
pulse is added for hide/show.

Example:
Toggle a div using the pulsate effect.
1
2
3
4
5
6
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25
26
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>pulsate demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle( "pulsate" );
});
</script>
</body>
</html>

Demo
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.removeClass()
Categories: Effects | Effects Core | Method Overrides

.removeClass( className [, duration ] [, easing ] [,
complete ] )
Returns: jQuery
Description: Removes the specified class(es) from
each of the set of matched elements while animating all
style changes.
.removeClass( className [, duration ] [, easing ] [,
complete ] )
className
Type: String
One or more class names (space separated) to be removed
from the class attribute of each matched element.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.
Similar to native CSS transitions, jQuery UI's class animations
provide a smooth transition from one state to another while allowing
you to keep all the details about which styles to change in CSS and
out of your JavaScript. All class animation methods, including
.removeClass() , support custom durations and easings, as well as
providing a callback for when the animation completes.
Not all styles can be animated. For example, there is no way to
animate a background image. Any styles that cannot be animated
will be changed at the end of the animation.
This plugin extends jQuery's built-in

.removeClass()

method. If

jQuery UI is not loaded, calling the .removeClass() method may not
fail directly, as the method still exists. However, the expected
behavior will not occur.

Example:
Removes the class "big-blue" from the matched
elements.
1
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>removeClass demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
div {
width: 100px;
height: 100px;
background-color: #ccc;
}
.big-blue {
width: 200px;
height: 200px;
background-color: #00f;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div class="big-blue"></div>
<script>
$( "div" ).click(function() {
$( this ).removeClass( "big-blue", 1000, "easeInBack"
});
</script>
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</body>
</html>
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.removeUniqueId()
Categories: Methods | UI Core

.removeUniqueId()

Returns: jQuery

Description: Remove ids that were set by
the set of matched elements.
.removeUniqueId()

.uniqueId()

for

version added: 1.9

This method does not accept any arguments.
The .removeUniqueId() will remove ids that were set by .uniqueId() .
Calling .removeUniqueId() on an element that did not have its id set
by .uniqueId() will have no affect, even if the element has an id.

POWERED BYHERONOTE
A new version of this book is available!

Resizable Widget
Categories: Interactions

Resizable Widget

version added: 1.0

Description: Change the size of an element using the
mouse.

QuickNav

Examples

Options

Methods

Events

alsoResize
animate
animateDuration
animateEasing
aspectRatio
autoHide
cancel
containment
delay
disabled
distance
ghost
grid
handles
helper
maxHeight
maxWidth
minHeight
minWidth

destroy
disable
enable
option
widget

create
start
resize
stop

The jQuery UI Resizable plugin makes selected elements resizable
(meaning they have draggable resize handles). You can specify one
or more handles as well as min and max width and height.

Dependencies
UI Core
Widget Factory
Mouse Interaction

Additional Notes:

This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific
CSS file as a starting point.

Options
alsoResize Type: Selector or jQuery or Element
Default: false

One or more elements to resize synchronously with the
resizable element.
Code examples:
Initialize the resizable with the alsoResize option specified:
1

$( ".selector" ).resizable({ alsoResize: "#mirror"

Get or set the alsoResize option, after initialization:
1
2
3
4
5

// getter
var alsoResize = $( ".selector" ).resizable(
// setter
$( ".selector" ).resizable( "option", "alsoResize"

animate

Type: Boolean
Default: false

Animates to the final size after resizing.
Code examples:
Initialize the resizable with the animate option specified:
1

$( ".selector" ).resizable({ animate: true });

Get or set the animate option, after initialization:
1
2
3
4
5

// getter
var animate = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "animate"

animateDuration

Type: Number or String
Default: "slow"

How long to animate when using the animate option.
Multiple types supported:
Number: Duration in milliseconds.
String: A named duration, such as "slow" or "fast" .
Code examples:
Initialize the resizable with the animateDuration option
specified:
1

$( ".selector" ).resizable({ animateDuration:

Get or set the animateDuration option, after initialization:
1
2
3
4
5

// getter
var animateDuration = $( ".selector" ).resizable(

// setter
$( ".selector" ).resizable( "option", "animateDuratio

animateEasing

Type: String
Default: "swing"

Which easing to apply when using the animate option.
Code examples:
Initialize the resizable with the animateEasing option
specified:
1

$( ".selector" ).resizable({ animateEasing: "easeOutB

Get or set the animateEasing option, after initialization:
1
2
3
4
5

// getter
var animateEasing = $( ".selector" ).resizable(

// setter
$( ".selector" ).resizable( "option", "animateEasing"

aspectRatio

Type: Boolean or Number
Default: false

Whether the element should be constrained to a specific
aspect ratio.
Multiple types supported:
Boolean: When set to true , the element will maintain
its original aspect ratio.
Number: Force the element to maintain a specific
aspect ratio during resizing.
Code examples:
Initialize the resizable with the aspectRatio option specified:

1

$( ".selector" ).resizable({ aspectRatio: true

Get or set the aspectRatio option, after initialization:
1
2
3
4
5

// getter
var aspectRatio = $( ".selector" ).resizable(
// setter
$( ".selector" ).resizable( "option", "aspectRatio"

autoHide

Type: Boolean
Default: false

Whether the handles should hide when the user is not
hovering over the element.
Code examples:
Initialize the resizable with the autoHide option specified:
1

$( ".selector" ).resizable({ autoHide: true });

Get or set the autoHide option, after initialization:
1
2
3
4
5

// getter
var autoHide = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "autoHide"

Type: Selector

cancel

Default: "input,textarea,button,select,option"

Prevents resizing from starting on specified elements.
Code examples:
Initialize the resizable with the cancel option specified:
1

$( ".selector" ).resizable({ cancel: ".cancel"

Get or set the cancel option, after initialization:
1
2
3
4
5

// getter
var cancel = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "cancel"

containment Type: Selector or Element or String
Default: false

Constrains resizing to within the bounds of the specified
element or region.
Multiple types supported:
Selector: The resizable element will be contained to the
bounding box of the first element found by the selector.
If no element is found, no containment will be set.
Element: The resizable element will be contained to the
bounding box of this element.
String: Possible values: "parent" and "document" .
Code examples:

Initialize the resizable with the containment option specified:
1

$( ".selector" ).resizable({ containment: "parent"

Get or set the containment option, after initialization:
1
2
3
4
5

// getter
var containment = $( ".selector" ).resizable(
// setter
$( ".selector" ).resizable( "option", "containment"

delay

Type: Number
Default: 0

Tolerance, in milliseconds, for when resizing should start. If
specified, resizing will not start until after mouse is moved
beyond duration. This can help prevent unintended resizing
when clicking on an element.
Code examples:
Initialize the resizable with the delay option specified:
1

$( ".selector" ).resizable({ delay: 150 });

Get or set the delay option, after initialization:
1
2
3
4

// getter
var delay = $( ".selector" ).resizable( "option"
// setter

5

$( ".selector" ).resizable( "option", "delay"

disabled

Type: Boolean
Default: false

Disables the resizable if set to true .
Code examples:
Initialize the resizable with the disabled option specified:
1

$( ".selector" ).resizable({ disabled: true });

Get or set the disabled option, after initialization:
1
2
3
4
5

// getter
var disabled = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "disabled"

distance

Type: Number
Default: 1

Tolerance, in pixels, for when resizing should start. If
specified, resizing will not start until after mouse is moved
beyond distance. This can help prevent unintended resizing
when clicking on an element.
Code examples:
Initialize the resizable with the distance option specified:

1

$( ".selector" ).resizable({ distance: 30 });

Get or set the distance option, after initialization:
1
2
3
4
5

// getter
var distance = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "distance"

ghost

Type: Boolean
Default: false

If set to true , a semi-transparent helper element is shown
for resizing.
Code examples:
Initialize the resizable with the ghost option specified:
1

$( ".selector" ).resizable({ ghost: true });

Get or set the ghost option, after initialization:
1
2
3
4
5

// getter
var ghost = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "ghost"

Type: Array

grid

Default: false

Snaps the resizing element to a grid, every x and y pixels.
Array values: [ x, y ] .
Code examples:
Initialize the resizable with the grid option specified:
1

$( ".selector" ).resizable({ grid: [ 20, 10 ] });

Get or set the grid option, after initialization:
1
2
3
4
5

// getter
var grid = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "grid", [

handles

Type: String or Object
Default: "e, s, se"

Which handles can be used for resizing.
Multiple types supported:
String: A comma delimited list of any of the following: n,
e, s, w, ne, se, sw, nw, all. The necessary handles will
be auto-generated by the plugin.
Object:
The following keys are supported: { n, e, s, w, ne, se,
sw, nw }. The value of any specified should be a jQuery
selector matching the child element of the resizable to
use as that handle. If the handle is not a child of the
resizable, you can pass in the DOMElement or a valid
jQuery object directly.

Note: When generating your own handles, each handle
must have the ui-resizable-handle class, as well as the
appropriate ui-resizable-{direction} class, .e.g., uiresizable-s .
Code examples:
Initialize the resizable with the handles option specified:
1

$( ".selector" ).resizable({ handles: "n, e, s, w"

Get or set the handles option, after initialization:
1
2
3
4
5

// getter
var handles = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "handles"

helper

Type: String
Default: false

A class name that will be added to a proxy element to
outline the resize during the drag of the resize handle. Once
the resize is complete, the original element is sized.
Code examples:
Initialize the resizable with the helper option specified:
1

$( ".selector" ).resizable({ helper: "resizable-helpe

Get or set the helper option, after initialization:

1
2
3
4
5

// getter
var helper = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "helper"

maxHeight

Type: Number
Default: null

The maximum height the resizable should be allowed to
resize to.
Code examples:
Initialize the resizable with the maxHeight option specified:
1

$( ".selector" ).resizable({ maxHeight: 300 });

Get or set the maxHeight option, after initialization:
1
2
3
4
5

// getter
var maxHeight = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "maxHeight"

maxWidth

Type: Number
Default: null

The maximum width the resizable should be allowed to
resize to.

Code examples:
Initialize the resizable with the maxWidth option specified:
1

$( ".selector" ).resizable({ maxWidth: 300 });

Get or set the maxWidth option, after initialization:
1
2
3
4
5

// getter
var maxWidth = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "maxWidth"

minHeight

Type: Number
Default: 10

The minimum height the resizable should be allowed to
resize to.
Code examples:
Initialize the resizable with the minHeight option specified:
1

$( ".selector" ).resizable({ minHeight: 150 });

Get or set the minHeight option, after initialization:
1
2
3
4
5

// getter
var minHeight = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "minHeight"

minWidth

Type: Number
Default: 10

The minimum width the resizable should be allowed to
resize to.
Code examples:
Initialize the resizable with the minWidth option specified:
1

$( ".selector" ).resizable({ minWidth: 150 });

Get or set the minWidth option, after initialization:
1
2
3
4
5

// getter
var minWidth = $( ".selector" ).resizable( "option"
// setter
$( ".selector" ).resizable( "option", "minWidth"

Methods
destroy()
Removes the resizable functionality completely. This will
return the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).resizable( "destroy" );

disable()
Disables the resizable.
This method does not accept any arguments.
Code examples:
Invoke the disable method:
1

$( ".selector" ).resizable( "disable" );

enable()
Enables the resizable.
This method does not accept any arguments.

Code examples:
Invoke the enable method:
1

$( ".selector" ).resizable( "enable" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).resizable(

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current resizable options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).resizable( "option"

option( optionName, value )
Sets the value of the resizable option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).resizable( "option", "disabled"

option( options )
Sets one or more options for the resizable.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).resizable( "option", { disabled:

widget()

Returns: jQuery

Returns a jQuery object containing the resizable element.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).resizable( "widget"

Events
create( event, ui )

Type:

resizecreate

Triggered when the resizable is created.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the resizable with the create callback specified:
1
2
3

$( ".selector" ).resizable({
create: function( event, ui ) {}
});

Bind an event listener to the resizecreate event:
1

$( ".selector" ).on( "resizecreate", function

resize( event, ui )

Type:

resize

This event is triggered during the resize, on the drag of the
resize handler.
event
Type: Event

ui
Type: Object
element
Type: jQuery
The jQuery object representing the element to be
resized
helper
Type: jQuery
The jQuery object representing the helper that's
being resized
originalElement
Type: jQuery
The jQuery object representing the original element
before it is wrapped
originalPosition
Type: Object
The position represented as
the resizable is resized
originalSize
Type: Object
The size represented as
the resizable is resized

{ left, top }

before

{ width, height }

before

position
Type: Object
The current position represented as
size
Type: Object
The current size represented as

{ left, top }

{ width, height }

Code examples:
Initialize the resizable with the resize callback specified:

1
2
3

$( ".selector" ).resizable({
resize: function( event, ui ) {}
});

Bind an event listener to the resize event:
1

$( ".selector" ).on( "resize", function( event, ui )

start( event, ui )

Type:

resizestart

This event is triggered at the start of a resize operation.
event
Type: Event
ui
Type: Object
element
Type: jQuery
The jQuery object representing the element to be
resized
helper
Type: jQuery
The jQuery object representing the helper that's
being resized
originalElement
Type: jQuery
The jQuery object representing the original element
before it is wrapped
originalPosition
Type: Object
The position represented as

{ left, top }

before

the resizable is resized
originalSize
Type: Object
The size represented as
the resizable is resized

{ width, height }

position
Type: Object
The current position represented as
size
Type: Object
The current size represented as

before

{ left, top }

{ width, height }

Code examples:
Initialize the resizable with the start callback specified:
1
2
3

$( ".selector" ).resizable({
start: function( event, ui ) {}
});

Bind an event listener to the resizestart event:
1

$( ".selector" ).on( "resizestart", function( event,

stop( event, ui )

Type:

resizestop

This event is triggered at the end of a resize operation.
event
Type: Event

ui
Type: Object
element
Type: jQuery
The jQuery object representing the element to be
resized
helper
Type: jQuery
The jQuery object representing the helper that's
being resized
originalElement
Type: jQuery
The jQuery object representing the original element
before it is wrapped
originalPosition
Type: Object
The position represented as
the resizable is resized
originalSize
Type: Object
The size represented as
the resizable is resized

{ left, top }

before

{ width, height }

before

position
Type: Object
The current position represented as
size
Type: Object
The current size represented as

{ left, top }

{ width, height }

Code examples:
Initialize the resizable with the stop callback specified:

1
2
3

$( ".selector" ).resizable({
stop: function( event, ui ) {}
});

Bind an event listener to the resizestop event:
1

$( ".selector" ).on( "resizestop", function( event, u

Example:
A simple jQuery UI Resizable.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
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23
24
25

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>resizable demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#resizable {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div id="resizable"></div>
<script>
$( "#resizable" ).resizable();
</script>
</body>
</html>

Demo
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Scale Effect
Categories: Effects

Scale Effect
Description: Shrink or grow an element by a
percentage factor.
scale
direction (default: "both" )
Type: String
The direction of the effect. Possible values:
or "horizontal" .
origin (default: [ "middle",
Type: Array
The vanishing point.

"both" , "vertical"

"center" ] )

percent
Type: Number
The percentage to scale to.
scale (default: "both" )
Type: String
Which areas of the element will be resized: "both" , "box" ,
"content" . Box resizes the border and padding of the element;
content resizes any content inside of the element.

Examples:
Example:
1
2
3
4
5
6
7
8
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24
25
26
27
28
29

Toggle a div using the scale effect.

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>scale demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle( "scale" );
});
</script>
</body>
</html>

Demo
Example:

Toggle a div using the scale effect in just one

direction.
1
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3
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29

Demo

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>scale demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle({ effect: "scale", direction:
});
</script>
</body>
</html>

POWERED BYHERONOTE
A new version of this book is available!

.scrollParent()
Categories: Methods | UI Core

.scrollParent()

Returns: jQuery

Description: Get the closest ancestor element that is
scrollable.
.scrollParent()
This method does not accept any arguments.
This method finds the nearest ancestor that allows scrolling. In other
words, the .scrollParent() method finds the element that the
currently selected element will scroll within.
Note: This method only works on jQuery objects containing one
element.

POWERED BYHERONOTE
A new version of this book is available!

Selectable Widget
Categories: Interactions

Selectable Widget

version added: 1.0

Description: Use the mouse to select elements,
individually or in a group.

QuickNav

Examples

Options

Methods

Events

appendTo
autoRefresh
cancel
delay
disabled
distance
filter
tolerance

destroy
disable
enable
refresh
option
widget

create
selected
selecting
start
stop
unselected
unselecting

The jQuery UI Selectable plugin allows for elements to be selected
by dragging a box (sometimes called a lasso) with the mouse over
the elements. Elements can also be selected via click or drag while
holding the ctrl/meta key, allowing for multiple (non-contiguous)
selections.

Dependencies
UI Core
Widget Factory
Mouse Interaction

Additional Notes:
This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific
CSS file as a starting point.

Options
appendTo

Type: Selector
Default: "body"

Which element the selection helper (the lasso) should be
appended to.
Code examples:
Initialize the selectable with the appendTo option specified:
1

$( ".selector" ).selectable({ appendTo: "#someElem"

Get or set the appendTo option, after initialization:
1
2
3
4
5

// getter
var appendTo = $( ".selector" ).selectable( "option"
// setter
$( ".selector" ).selectable( "option", "appendTo"

autoRefresh

Type: Boolean
Default: true

This determines whether to refresh (recalculate) the position
and size of each selectee at the beginning of each select
operation. If you have many items, you may want to set this
to false and call the refresh() method manually.
Code examples:
Initialize the selectable with the autoRefresh option
specified:

1

$( ".selector" ).selectable({ autoRefresh: false

Get or set the autoRefresh option, after initialization:
1
2
3
4
5

// getter
var autoRefresh = $( ".selector" ).selectable(
// setter
$( ".selector" ).selectable( "option", "autoRefresh"

cancel

Type: Selector
Default: "input,textarea,button,select,option"

Prevents selecting if you start on elements matching the
selector.
Code examples:
Initialize the selectable with the cancel option specified:
1

$( ".selector" ).selectable({ cancel: "a,.cancel"

Get or set the cancel option, after initialization:
1
2
3
4
5

// getter
var cancel = $( ".selector" ).selectable( "option"
// setter
$( ".selector" ).selectable( "option", "cancel"

delay

Type: Integer
Default: 0

Time in milliseconds to define when the selecting should
start. This helps prevent unwanted selections when clicking
on an element.
Code examples:
Initialize the selectable with the delay option specified:
1

$( ".selector" ).selectable({ delay: 150 });

Get or set the delay option, after initialization:
1
2
3
4
5

// getter
var delay = $( ".selector" ).selectable( "option"
// setter
$( ".selector" ).selectable( "option", "delay"

disabled

Type: Boolean
Default: false

Disables the selectable if set to true .
Code examples:
Initialize the selectable with the disabled option specified:
1

$( ".selector" ).selectable({ disabled: true });

Get or set the disabled option, after initialization:

1
2
3
4
5

// getter
var disabled = $( ".selector" ).selectable( "option"
// setter
$( ".selector" ).selectable( "option", "disabled"

distance

Type: Number
Default: 0

Tolerance, in pixels, for when selecting should start. If
specified, selecting will not start until the mouse has been
dragged beyond the specified distance.
Code examples:
Initialize the selectable with the distance option specified:
1

$( ".selector" ).selectable({ distance: 30 });

Get or set the distance option, after initialization:
1
2
3
4
5

filter

// getter
var distance = $( ".selector" ).selectable( "option"
// setter
$( ".selector" ).selectable( "option", "distance"

Type: Selector
Default: "*"

The matching child elements will be made selectees (able to

be selected).
Code examples:
Initialize the selectable with the filter option specified:
1

$( ".selector" ).selectable({ filter: "li" });

Get or set the filter option, after initialization:
1
2
3
4
5

// getter
var filter = $( ".selector" ).selectable( "option"
// setter
$( ".selector" ).selectable( "option", "filter"

tolerance

Type: String
Default: "touch"

Specifies which mode to use for testing whether the lasso
should select an item. Possible values:
"fit" : Lasso overlaps the item entirely.
"touch" :

Lasso overlaps the item by any amount.

Code examples:
Initialize the selectable with the tolerance option specified:
1

$( ".selector" ).selectable({ tolerance: "fit"

Get or set the tolerance option, after initialization:

1
2
3
4
5

// getter
var tolerance = $( ".selector" ).selectable(
// setter
$( ".selector" ).selectable( "option", "tolerance"

Methods
destroy()
Removes the selectable functionality completely. This will
return the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).selectable( "destroy" );

disable()
Disables the selectable.
This method does not accept any arguments.
Code examples:
Invoke the disable method:
1

$( ".selector" ).selectable( "disable" );

enable()
Enables the selectable.
This method does not accept any arguments.

Code examples:
Invoke the enable method:
1

$( ".selector" ).selectable( "enable" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).selectable(

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current selectable options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).selectable( "option"

option( optionName, value )
Sets the value of the selectable option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).selectable( "option", "disabled"

option( options )
Sets one or more options for the selectable.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).selectable( "option", { disabled:

refresh()
Refresh the position and size of each selectee element. This
method can be used to manually recalculate the position
and size of each selectee when the autoRefresh option is set
to false .
This method does not accept any arguments.
Code examples:
Invoke the refresh method:
1

$( ".selector" ).selectable( "refresh" );

widget()

Returns: jQuery

Returns a jQuery object containing the selectable element.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).selectable( "widget"

Events
create( event, ui )

Type:

selectablecreate

Triggered when the selectable is created.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the selectable with the create callback specified:
1
2
3

$( ".selector" ).selectable({
create: function( event, ui ) {}
});

Bind an event listener to the selectablecreate event:
1

$( ".selector" ).on( "selectablecreate", function

selected( event, ui )

Type:

selectableselected

Triggered at the end of the select operation, on each
element added to the selection.
event
Type: Event

ui
Type: Object
selected
Type: Element
The selectable item that has been selected.

Code examples:
Initialize the selectable with the selected callback specified:
1
2
3

$( ".selector" ).selectable({
selected: function( event, ui ) {}
});

Bind an event listener to the selectableselected event:
1

$( ".selector" ).on( "selectableselected", function

selecting( event, ui )

Type:

selectableselecting

Triggered during the select operation, on each element
added to the selection.
event
Type: Event
ui
Type: Object
selecting
Type: Element
The current selectable item being selected.

Code examples:

Initialize the selectable with the selecting callback specified:
1
2
3

$( ".selector" ).selectable({
selecting: function( event, ui ) {}
});

Bind an event listener to the selectableselecting event:
1

$( ".selector" ).on( "selectableselecting", function

start( event, ui )

Type:

selectablestart

Triggered at the beginning of the select operation.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the selectable with the start callback specified:
1
2
3

$( ".selector" ).selectable({
start: function( event, ui ) {}
});

Bind an event listener to the selectablestart event:
1

$( ".selector" ).on( "selectablestart", function

Type:

stop( event, ui )

selectablestop

Triggered at the end of the select operation.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the selectable with the stop callback specified:
1
2
3

$( ".selector" ).selectable({
stop: function( event, ui ) {}
});

Bind an event listener to the selectablestop event:
1

$( ".selector" ).on( "selectablestop", function

unselected( event, ui )
Type:

selectableunselected

Triggered at the end of the
select operation, on each element removed from the
selection.
event
Type: Event
ui
Type: Object

unselected
Type: Element
The selectable item that has been unselected.

Code examples:
Initialize the selectable with the unselected callback
specified:
1
2
3

$( ".selector" ).selectable({
unselected: function( event, ui ) {}
});

Bind an event listener to the selectableunselected event:
1

$( ".selector" ).on( "selectableunselected",

unselecting( event, ui )
Type:

selectableunselecting

Triggered during the select
operation, on each element removed from the selection.
event
Type: Event
ui
Type: Object
unselecting
Type: Element
The current selectable item being unselected.

Code examples:
Initialize the selectable with the unselecting callback

specified:
1
2
3

$( ".selector" ).selectable({
unselecting: function( event, ui ) {}
});

Bind an event listener to the selectableunselecting event:
1

$( ".selector" ).on( "selectableunselecting",

Example:
A simple jQuery UI Selectable.
1
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>selectable demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#selectable .ui-selecting {
background: #ccc;
}
#selectable .ui-selected {
background: #999;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<ul id="selectable">
<li>Item 1</li>
<li>Item 2</li>
<li>Item 3</li>
<li>Item 4</li>
<li>Item 5</li>
</ul>
<script>
$( "#selectable" ).selectable();
</script>

32
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</body>
</html>

Demo
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Shake Effect
Categories: Effects

Shake Effect
Description: Shakes the element multiple times,
vertically or horizontally.
shake
direction (default: "both" )
Type: String
The direction of the effect. Possible values:
"up" , "down" .
distance (default: 20 )
Type: Number
Distance to shake.
times (default: 3 )
Type: Integer
Times to shake.

"left" , "right" ,

Example:
Shake a div.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>shake demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to shake the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).effect( "shake" );
});
</script>
</body>
</html>

Demo
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.show()
Categories: Effects | Effects Core | Method Overrides | Methods

.show( effect [, options ] [, duration ] [, complete ] )
Returns: jQuery
Description: Display the matched elements, using
custom effects.
.show( effect [, options ] [, duration ] [, complete ] )
effect
Type: String
A string indicating which effect to use for the transition.
options
Type: Object
Effect-specific settings and easing.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
complete
Type: Function()
A function to call once the animation is complete.

.show( options )
options
Type: Object
All animation settings. The only required property is

effect .

effect
Type: String
A string indicating which effect to use for the transition.
easing (default: "swing" )
Type: String
A string indicating which easing function to use for the
transition.
duration (default: 400 )
Type: Number or String

A string or number determining how long the animation will
run.
complete
Type: Function()
A function to call once the animation is complete.
This plugin extends jQuery's built-in .show() method. If jQuery UI is
not loaded, calling the .show() method may not fail directly, as the
method still exists. However, the expected behavior will not occur.

Example:
Show a div using the fold effect.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>show demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
div {
display: none;
width: 100px;
height: 100px;
background: #ccc;
border: 1px solid #000;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<button>show the div</button>
<div></div>
<script>
$( "button" ).click(function() {
$( "div" ).show( "fold", 1000 );
});
</script>
</body>
</html>

Demo
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Size Effect
Categories: Effects

Size Effect
Description: Resize an element to a specified width and
height.
size
to
Type: Object
Height and width to resize to.
origin (default: [ "top",
Type: Array
The vanishing point.

"left" ] )

scale (default: "both" )
Type: String
Which areas of the element will be resized: "both" , "box" ,
"content" . Box resizes the border and padding of the element;
content resizes any content inside of the element.

Example:
Resize the element using the size effect.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>size demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to resize the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).effect( "size", {
to: { width: 200, height: 60 }
}, 1000 );
});
</script>
</body>
</html>

Demo
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Slide Effect
Categories: Effects

Slide Effect
Description: Slides the element out of the viewport.
slide
direction (default: "both" )
Type: String
The direction of the effect. Possible values:
"up" , "down" .

"left" , "right" ,

distance (default: element's outerWidth )
Type: Number
The distance of the effect. Defaults to either the height or width
of the elemenet depending on the direction argument. Can be
set to any integer less than the width/height of the element.

Example:
Toggle a div using the slide effect.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>slide demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
#toggle {
width: 100px;
height: 100px;
background: #ccc;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>Click anywhere to toggle the box.</p>
<div id="toggle"></div>
<script>
$( document ).click(function() {
$( "#toggle" ).toggle( "slide" );
});
</script>
</body>
</html>

Demo
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Slider Widget
Categories: Widgets

Slider Widget

version added: 1.5

Description: Drag a handle to select a numeric value.

QuickNav

Examples

Options

Methods

Events

animate
disabled
max
min
orientation
range
step
value
values

destroy
disable
enable
option
value
values
widget

create
start
slide
change
stop

The jQuery UI Slider plugin makes selected elements into sliders.
There are various options such as multiple handles and ranges. The
handle can be moved with the mouse or the arrow keys.
The slider widget will create handle elements with the class uislider-handle on initialization. You can specify custom handle
elements by creating and appending the elements and adding the
ui-slider-handle class before initialization. It will only create the
number of handles needed to match the length of value / values . For
example, if you specify values: [ 1, 5, 18 ] and create one custom
handle, the plugin will create the other two.

Dependencies
UI Core
Widget Factory
Mouse Interaction

Additional Notes:
This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific

CSS file as a starting point.

Options
animate

Type: Boolean or String or Number
Default: false

Whether to slide the handle smoothly when the user clicks
on the slider track. Also accepts any valid animation
duration.
Multiple types supported:
Boolean: When set to true , the handle will animate
with the default duration.
String: The name of a speed, such as "fast" or
"slow" .
Number: The duration of the animation, in milliseconds.
Code examples:
Initialize the slider with the animate option specified:
1

$( ".selector" ).slider({ animate: "fast" });

Get or set the animate option, after initialization:
1
2
3
4
5

// getter
var animate = $( ".selector" ).slider( "option"
// setter
$( ".selector" ).slider( "option", "animate",

disabled

Type: Boolean
Default: false

Disables the slider if set to true .
Code examples:
Initialize the slider with the disabled option specified:
1

$( ".selector" ).slider({ disabled: true });

Get or set the disabled option, after initialization:
1
2
3
4
5

max

// getter
var disabled = $( ".selector" ).slider( "option"
// setter
$( ".selector" ).slider( "option", "disabled"

Type: Number
Default: 100

The maximum value of the slider.
Code examples:
Initialize the slider with the max option specified:
1

$( ".selector" ).slider({ max: 50 });

Get or set the max option, after initialization:
1
2

// getter
var max = $( ".selector" ).slider( "option",

3
4
5

// setter
$( ".selector" ).slider( "option", "max", 50 );

Type: Number

min

Default: 0

The minimum value of the slider.
Code examples:
Initialize the slider with the min option specified:
1

$( ".selector" ).slider({ min: 10 });

Get or set the min option, after initialization:
1
2
3
4
5

// getter
var min = $( ".selector" ).slider( "option",
// setter
$( ".selector" ).slider( "option", "min", 10 );

orientation

Type: String
Default: "horizontal"

Determines whether the slider handles move horizontally
(min on left, max on right) or vertically (min on bottom, max
on top). Possible values: "horizontal" , "vertical" .
Code examples:
Initialize the slider with the orientation option specified:

1

$( ".selector" ).slider({ orientation: "vertical"

Get or set the orientation option, after initialization:
1
2
3
4
5

// getter
var orientation = $( ".selector" ).slider( "option"
// setter
$( ".selector" ).slider( "option", "orientation"

range

Type: Boolean or String
Default: false

Whether the slider represents a range.
Multiple types supported:
Boolean: If set to true , the slider will detect if you have
two handles and create a stylable range element
between these two.
String: Either "min" or "max" . A min range goes from
the slider min to one handle. A max range goes from
one handle to the slider max.
Code examples:
Initialize the slider with the range option specified:
1

$( ".selector" ).slider({ range: true });

Get or set the range option, after initialization:
1

// getter

2
3
4
5

var range = $( ".selector" ).slider( "option"
// setter
$( ".selector" ).slider( "option", "range", true

Type: Number

step

Default: 1

Determines the size or amount of each interval or step the
slider takes between the min and max. The full specified
value range of the slider (max - min) should be evenly
divisible by the step.
Code examples:
Initialize the slider with the step option specified:
1

$( ".selector" ).slider({ step: 5 });

Get or set the step option, after initialization:
1
2
3
4
5

// getter
var step = $( ".selector" ).slider( "option",
// setter
$( ".selector" ).slider( "option", "step", 5 );

value

Type: Number
Default: 0

Determines the value of the slider, if there's only one handle.
If there is more than one handle, determines the value of the

first handle.
Code examples:
Initialize the slider with the value option specified:
1

$( ".selector" ).slider({ value: 10 });

Get or set the value option, after initialization:
1
2
3
4
5

// getter
var value = $( ".selector" ).slider( "option"
// setter
$( ".selector" ).slider( "option", "value", 10

values

Type: Array
Default: null

This option can be used to specify multiple handles. If the
range option is set to true , the length of values should be 2.
Code examples:
Initialize the slider with the values option specified:
1

$( ".selector" ).slider({ values: [ 10, 25 ] });

Get or set the values option, after initialization:
1
2
3
4

// getter
var values = $( ".selector" ).slider( "option"
// setter

5

$( ".selector" ).slider( "option", "values", [

Methods
destroy()
Removes the slider functionality completely. This will return
the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).slider( "destroy" );

disable()
Disables the slider.
This method does not accept any arguments.
Code examples:
Invoke the disable method:
1

$( ".selector" ).slider( "disable" );

enable()
Enables the slider.
This method does not accept any arguments.

Code examples:
Invoke the enable method:
1

$( ".selector" ).slider( "enable" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).slider( "option"

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current slider options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).slider( "option"

option( optionName, value )
Sets the value of the slider option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).slider( "option", "disabled"

option( options )
Sets one or more options for the slider.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).slider( "option", { disabled:

value()

Returns: Number

Get the value of the slider.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var selection = $( ".selector" ).slider( "value"

value( value )
Set the value of the slider.
value
Type: Number
The value to set.
Code examples:
Invoke the method:
1

$( ".selector" ).slider( "value", 55 );

values()

Returns: Array

Get the value for all handles.
This method does not accept any arguments.
Code examples:
Invoke the method:

1

var values = $( ".selector" ).slider( "values"

values( index )

Returns: Number

Get the value for the specified handle.
index
Type: Integer
The zero-based index of the handle.
Code examples:
Invoke the method:
1

var value = $( ".selector" ).slider( "values"

values( index, value )
Set the value for the specified handle.
index
Type: Integer
The zero-based index of the handle.
value
Type: Number
The value to set.
Code examples:
Invoke the method:
1

$( ".selector" ).slider( "values", 0, 55 );

values( values )
Set the value for all handles.
values
Type: Array
The values to set.
Code examples:
Invoke the method:
1

$( ".selector" ).slider( "values", [ 55, 105 ] );

widget()

Returns: jQuery

Returns a jQuery object containing the slider.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).slider( "widget"

Events
change( event, ui )

Type:

slidechange

Triggered after the user slides a handle, if the value has
changed; or if the value is changed programmatically via the
value method.
event
Type: Event
ui
Type: Object
handle
Type: jQuery
The jQuery object representing the handle that was
changed.
value
Type: Number
The current value of the slider.

Code examples:
Initialize the slider with the change callback specified:
1
2
3

$( ".selector" ).slider({
change: function( event, ui ) {}
});

Bind an event listener to the slidechange event:
1

$( ".selector" ).on( "slidechange", function( event,

create( event, ui )

Type:

slidecreate

Triggered when the slider is created.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the slider with the create callback specified:
1
2
3

$( ".selector" ).slider({
create: function( event, ui ) {}
});

Bind an event listener to the slidecreate event:
1

$( ".selector" ).on( "slidecreate", function( event,

slide( event, ui )

Type:

slide

Triggered on every mouse move during slide. The value
provided in the event as ui.value represents the value that
the handle will have as a result of the current movement.
Canceling the event will prevent the handle from moving and
the handle will continue to have its previous value.
event
Type: Event

ui
Type: Object
handle
Type: jQuery
The jQuery object representing the handle being
moved.
value
Type: Number
The value that the handle will move to if the event
is not canceled.
values
Type: Array
An array of the current values of a multi-handled
slider.

Code examples:
Initialize the slider with the slide callback specified:
1
2
3

$( ".selector" ).slider({
slide: function( event, ui ) {}
});

Bind an event listener to the slide event:
1

$( ".selector" ).on( "slide", function( event, ui ) {

start( event, ui )
Triggered when the user starts sliding.
event
Type: Event

Type:

slidestart

ui
Type: Object
handle
Type: jQuery
The jQuery object representing the handle being
moved.
value
Type: Number
The current value of the slider.

Code examples:
Initialize the slider with the start callback specified:
1
2
3

$( ".selector" ).slider({
start: function( event, ui ) {}
});

Bind an event listener to the slidestart event:
1

$( ".selector" ).on( "slidestart", function( event, u

stop( event, ui )
Triggered after the user slides a handle.
event
Type: Event
ui
Type: Object
handle

Type:

slidestop

Type: jQuery
The jQuery object representing the handle that was
moved.
value
Type: Number
The current value of the slider.

Code examples:
Initialize the slider with the stop callback specified:
1
2
3

$( ".selector" ).slider({
stop: function( event, ui ) {}
});

Bind an event listener to the slidestop event:
1

$( ".selector" ).on( "slidestop", function( event, ui

Example:
A simple jQuery UI Slider.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>slider demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>#slider { margin: 10px; }
</style
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div id="slider"></div>
<script>
$( "#slider" ).slider();
</script>
</body>
</html>

Demo
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A new version of this book is available!

Sortable Widget
Categories: Interactions

Sortable Widget

version added: 1.0

Description: Reorder elements in a list or grid using the
mouse.

QuickNav
Options

Examples
Methods

Events

appendTo
cancel
axis
destroy
cancel
disable
connectWith
enable
containment
option
cursor
refresh
cursorAt
refreshPositions
delay
serialize
disabled
toArray
distance
widget
dropOnEmpty
forceHelperSize
forcePlaceholderSize
grid
handle
helper
items
opacity
placeholder
revert
scroll
scrollSensitivity
scrollSpeed
tolerance
zIndex

create
start
sort
change
beforeStop
stop
update
receive
remove
over
out
activate
deactivate

The jQuery UI Sortable plugin makes selected elements sortable by
dragging with the mouse.
Note: In order to sort table rows, the
not the table .

Dependencies

tbody

must be made sortable,

UI Core
Widget Factory
Mouse Interaction

Options
appendTo
Default:Type:

jQuery or Element or Selector or String
"parent"

Defines where the helper that moves with the mouse is
being appended to during the drag (for example, to resolve
overlap/zIndex issues).
Multiple types supported:
jQuery: A jQuery object containing the element to
append the helper to.
Element: The element to append the helper to.
Selector: A selector specifying which element to
append the helper to.
String: The string "parent" will cause the helper to be a
sibling of the sortable item.
Code examples:
Initialize the sortable with the appendTo option specified:
1

$( ".selector" ).sortable({ appendTo: document.body }

Get or set the appendTo option, after initialization:
1
2
3
4
5

// getter
var appendTo = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "appendTo"

Type: String

axis

Default: false

If defined, the items can be dragged only horizontally or
vertically. Possible values: "x" , "y" .
Code examples:
Initialize the sortable with the axis option specified:
1

$( ".selector" ).sortable({ axis: "x" });

Get or set the axis option, after initialization:
1
2
3
4
5

// getter
var axis = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "axis",

cancel

Type: Selector
Default: ":input,button"

Prevents sorting if you start on elements matching the
selector.
Code examples:
Initialize the sortable with the cancel option specified:
1

$( ".selector" ).sortable({ cancel: "a,button"

Get or set the cancel option, after initialization:

1
2
3
4
5

// getter
var cancel = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "cancel"

connectWith

Type: Selector
Default: false

A selector of other sortable elements that the items from this
list should be connected to. This is a one-way relationship, if
you want the items to be connected in both directions, the
connectWith option must be set on both sortable elements.
Code examples:
Initialize the sortable with the connectWith option specified:
1

$( ".selector" ).sortable({ connectWith: "#shopping-c

Get or set the connectWith option, after initialization:
1
2
3
4
5

// getter
var connectWith = $( ".selector" ).sortable(
// setter
$( ".selector" ).sortable( "option", "connectWith"

containment Type: Element or Selector or String
Default: false

Defines a bounding box that the sortable items are
constrained to while dragging.
Note: The element specified for containment must have a
calculated width and height (though it need not be explicit).
For example, if you have float: left sortable children and
specify containment: "parent" be sure to have float: left
on the sortable/parent container as well or it will have
height: 0 , causing undefined behavior.
Multiple types supported:
Element: An element to use as the container.
Selector: A selector specifying an element to use as
the container.
String: A string identifying an element to use as the
container. Possible values: "parent" , "document" ,
"window" .
Code examples:
Initialize the sortable with the containment option specified:
1

$( ".selector" ).sortable({ containment: "parent"

Get or set the containment option, after initialization:
1
2
3
4
5

// getter
var containment = $( ".selector" ).sortable(
// setter
$( ".selector" ).sortable( "option", "containment"

cursor

Type: String

Default: "auto"

Defines the cursor that is being shown while sorting.
Code examples:
Initialize the sortable with the cursor option specified:
1

$( ".selector" ).sortable({ cursor: "move" });

Get or set the cursor option, after initialization:
1
2
3
4
5

// getter
var cursor = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "cursor"

cursorAt

Type: Object
Default: false

Moves the sorting element or helper so the cursor always
appears to drag from the same position. Coordinates can be
given as a hash using a combination of one or two keys: {
top, left, right, bottom } .
Code examples:
Initialize the sortable with the cursorAt option specified:
1

$( ".selector" ).sortable({ cursorAt: { left:

Get or set the cursorAt option, after initialization:
1

// getter

2
3
4
5

var cursorAt = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "cursorAt"

delay

Type: Integer
Default: 0

Time in milliseconds to define when the sorting should start.
Adding a delay helps preventing unwanted drags when
clicking on an element.
Code examples:
Initialize the sortable with the delay option specified:
1

$( ".selector" ).sortable({ delay: 150 });

Get or set the delay option, after initialization:
1
2
3
4
5

// getter
var delay = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "delay",

disabled

Type: Boolean
Default: false

Disables the sortable if set to true .
Code examples:
Initialize the sortable with the disabled option specified:

1

$( ".selector" ).sortable({ disabled: true });

Get or set the disabled option, after initialization:
1
2
3
4
5

// getter
var disabled = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "disabled"

distance

Type: Number
Default: 1

Tolerance, in pixels, for when sorting should start. If
specified, sorting will not start until after mouse is dragged
beyond distance. Can be used to allow for clicks on
elements within a handle.
Code examples:
Initialize the sortable with the distance option specified:
1

$( ".selector" ).sortable({ distance: 5 });

Get or set the distance option, after initialization:
1
2
3
4
5

// getter
var distance = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "distance"

dropOnEmpty

Type: Boolean
Default: true

If false , items from this sortable can't be dropped on an
empty connect sortable (see the connectWith option.
Code examples:
Initialize the sortable with the dropOnEmpty option specified:
1

$( ".selector" ).sortable({ dropOnEmpty: false

Get or set the dropOnEmpty option, after initialization:
1
2
3
4
5

// getter
var dropOnEmpty = $( ".selector" ).sortable(
// setter
$( ".selector" ).sortable( "option", "dropOnEmpty"

forceHelperSize

Type: Boolean
Default: false

If true , forces the helper to have a size.
Code examples:
Initialize the sortable with the forceHelperSize option
specified:
1

$( ".selector" ).sortable({ forceHelperSize:

Get or set the forceHelperSize option, after initialization:
1
2
3
4
5

// getter
var forceHelperSize = $( ".selector" ).sortable(

// setter
$( ".selector" ).sortable( "option", "forceHelperSize

forcePlaceholderSize

Type: Boolean
Default: false

If true, forces the placeholder to have a size.
Code examples:
Initialize the sortable with the forcePlaceholderSize option
specified:
1

$( ".selector" ).sortable({ forcePlaceholderSize:

Get or set the forcePlaceholderSize option, after
initialization:
1
2
3
4
5

grid

// getter
var forcePlaceholderSize = $( ".selector" ).sortable(

// setter
$( ".selector" ).sortable( "option", "forcePlaceholde

Type: Array

Default: false

Snaps the sorting element or helper to a grid, every x and y
pixels. Array values: [ x, y ] .
Code examples:
Initialize the sortable with the grid option specified:
1

$( ".selector" ).sortable({ grid: [ 20, 10 ] });

Get or set the grid option, after initialization:
1
2
3
4
5

// getter
var grid = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "grid", [

handle

Type: Selector or Element
Default: false

Restricts sort start click to the specified element.
Code examples:
Initialize the sortable with the handle option specified:
1

$( ".selector" ).sortable({ handle: ".handle"

Get or set the handle option, after initialization:
1
2
3

// getter
var handle = $( ".selector" ).sortable( "option"

4
5

// setter
$( ".selector" ).sortable( "option", "handle"

helper

Type: String or Function()
Default: "original"

Allows for a helper element to be used for dragging display.
Multiple types supported:
String: If set to "clone" , then the element will be cloned
and the clone will be dragged.
Function: A function that will return a DOMElement to
use while dragging. The function receives the event and
the element being sorted.
Code examples:
Initialize the sortable with the helper option specified:
1

$( ".selector" ).sortable({ helper: "clone" });

Get or set the helper option, after initialization:
1
2
3
4
5

// getter
var helper = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "helper"

items

Type: Selector

Default: "> *"

Specifies which items inside the element should be sortable.
Code examples:
Initialize the sortable with the items option specified:
1

$( ".selector" ).sortable({ items: "> li" });

Get or set the items option, after initialization:
1
2
3
4
5

// getter
var items = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "items",

opacity

Type: Number
Default: false

Defines the opacity of the helper while sorting. From 0.01 to
1.
Code examples:
Initialize the sortable with the opacity option specified:
1

$( ".selector" ).sortable({ opacity: 0.5 });

Get or set the opacity option, after initialization:
1
2
3

// getter
var opacity = $( ".selector" ).sortable( "option"

4
5

// setter
$( ".selector" ).sortable( "option", "opacity"

placeholder

Type: String
Default: false

A class name that gets applied to the otherwise white space.
Code examples:
Initialize the sortable with the placeholder option specified:
1

$( ".selector" ).sortable({ placeholder: "sortable-pl

Get or set the placeholder option, after initialization:
1
2
3
4
5

// getter
var placeholder = $( ".selector" ).sortable(
// setter
$( ".selector" ).sortable( "option", "placeholder"

revert

Type: Boolean or Number
Default: false

Whether the sortable items should revert to their new
positions using a smooth animation.
Multiple types supported:
Boolean: When set to true , the items will animate with
the default duration.
Number: The duration for the animation, in

milliseconds.
Code examples:
Initialize the sortable with the revert option specified:
1

$( ".selector" ).sortable({ revert: true });

Get or set the revert option, after initialization:
1
2
3
4
5

// getter
var revert = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "revert"

scroll

Type: Boolean
Default: true

If set to true, the page scrolls when coming to an edge.
Code examples:
Initialize the sortable with the scroll option specified:
1

$( ".selector" ).sortable({ scroll: false });

Get or set the scroll option, after initialization:
1
2
3
4

// getter
var scroll = $( ".selector" ).sortable( "option"
// setter

5

$( ".selector" ).sortable( "option", "scroll"

scrollSensitivity

Type: Number
Default: 20

Defines how near the mouse must be to an edge to start
scrolling.
Code examples:
Initialize the sortable with the scrollSensitivity option
specified:
1

$( ".selector" ).sortable({ scrollSensitivity:

Get or set the scrollSensitivity option, after initialization:
1
2
3
4
5

// getter
var scrollSensitivity = $( ".selector" ).sortable(

// setter
$( ".selector" ).sortable( "option", "scrollSensitivi

scrollSpeed

Type: Number
Default: 20

The speed at which the window should scroll once the
mouse pointer gets within the scrollSensitivity distance.
Code examples:
Initialize the sortable with the scrollSpeed option specified:

1

$( ".selector" ).sortable({ scrollSpeed: 40 });

Get or set the scrollSpeed option, after initialization:
1
2
3
4
5

// getter
var scrollSpeed = $( ".selector" ).sortable(
// setter
$( ".selector" ).sortable( "option", "scrollSpeed"

tolerance

Type: String
Default: "intersect"

Specifies which mode to use for testing whether the item
being moved is hovering over another item. Possible values:
"intersect" : The item overlaps the other item by at
least 50%.
"pointer" : The mouse pointer overlaps the other item.
Code examples:
Initialize the sortable with the tolerance option specified:
1

$( ".selector" ).sortable({ tolerance: "pointer"

Get or set the tolerance option, after initialization:
1
2
3
4

// getter
var tolerance = $( ".selector" ).sortable( "option"
// setter

5

$( ".selector" ).sortable( "option", "tolerance"

zIndex

Type: Integer
Default: 1000

Z-index for element/helper while being sorted.
Code examples:
Initialize the sortable with the zIndex option specified:
1

$( ".selector" ).sortable({ zIndex: 9999 });

Get or set the zIndex option, after initialization:
1
2
3
4
5

// getter
var zIndex = $( ".selector" ).sortable( "option"
// setter
$( ".selector" ).sortable( "option", "zIndex"

Methods
cancel()
Cancels a change in the current sortable and reverts it to the
state prior to when the current sort was started. Useful in the
stop and receive callback functions.
This method does not accept any arguments.
Code examples:
Invoke the cancel method:
1

$( ".selector" ).sortable( "cancel" );

destroy()
Removes the sortable functionality completely. This will
return the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).sortable( "destroy" );

disable()

Disables the sortable.
This method does not accept any arguments.
Code examples:
Invoke the disable method:
1

$( ".selector" ).sortable( "disable" );

enable()
Enables the sortable.
This method does not accept any arguments.
Code examples:
Invoke the enable method:
1

$( ".selector" ).sortable( "enable" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).sortable( "option"

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current sortable options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).sortable( "option"

option( optionName, value )
Sets the value of the sortable option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).sortable( "option", "disabled"

option( options )
Sets one or more options for the sortable.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).sortable( "option", { disabled:

refresh()
Refresh the sortable items. Triggers the reloading of all
sortable items, causing new items to be recognized.
This method does not accept any arguments.
Code examples:
Invoke the refresh method:
1

$( ".selector" ).sortable( "refresh" );

refreshPositions()
Refresh the cached positions of the sortable items. Calling
this method refreshes the cached item positions of all
sortables.
This method does not accept any arguments.

Code examples:
Invoke the refreshPositions method:
1

$( ".selector" ).sortable( "refreshPositions"

serialize( options )

Returns: String

Serializes the sortable's item id s into a form/ajax
submittable string. Calling this method produces a hash that
can be appended to any url to easily submit a new item
order back to the server.
It works by default by looking at the id of each item in the
format "setname_number" , and it spits out a hash like
"setname[]=number&setname[]=number" .
Note: If serialize returns an empty string, make sure the id
attributes include an underscore. They must be in the form:
"set_number" For example, a 3 element list with id attributes
"foo_1" , "foo_5" , "foo_2" will serialize to
"foo[]=1&foo[]=5&foo[]=2" . You can use an underscore,
equal sign or hyphen to separate the set and number. For
example "foo=1" , "foo-1" , and "foo_1" all serialize to
"foo[]=1" .
options
Type: Object
Options to customize the serialization.
key (default: the part of the attribute in front
the separator )
Type: String
Replaces part1[] with the specified value.
attribute (default: "id" )
Type: String
The name of the attribute to use for the values.

of

expression (default: /(.+)[-=_](.+)/ )
Type: RegExp
A regular expression used to split the attribute
value into key and value parts.

Code examples:
Invoke the serialize method:
1

var sorted = $( ".selector" ).sortable( "serialize"

toArray( options )

Returns: Array

Serializes the sortable's item id's into an array of string.
options
Type: Object
Options to customize the serialization.
attribute (default: "id" )
Type: String
The name of the attribute to use for the values.

Code examples:
Invoke the toArray method:
1

var sortedIDs = $( ".selector" ).sortable( "toArray"

widget()
Returns a

jQuery

Returns: jQuery
object containing the sortable element.

This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).sortable( "widget"

Events
activate( event, ui )

Type:

sortactivate

This event is triggered when using connected lists, every
connected list on drag start receives it.
event
Type: Event
ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper being
sorted
item
Type: jQuery
The jQuery object representing the current dragged
element
offset
Type: Object
The current absolute position of the helper
represented as { top, left }
position
Type: Object
The current position of the helper represented as

{

top, left }

originalPosition
Type: Object
The original position of the element represented as
{ top, left }

sender
Type: jQuery
The sortable that the item comes from if moving
from one sortable to another

Code examples:
Initialize the sortable with the activate callback specified:
1
2
3

$( ".selector" ).sortable({
activate: function( event, ui ) {}
});

Bind an event listener to the sortactivate event:
1

$( ".selector" ).on( "sortactivate", function

beforeStop( event, ui )

Type:

sortbeforestop

This event is triggered when sorting stops, but when the
placeholder/helper is still available.
event
Type: Event
ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper being
sorted
item
Type: jQuery

The jQuery object representing the current dragged
element
offset
Type: Object
The current absolute position of the helper
represented as { top, left }
position
Type: Object
The current position of the helper represented as

{

top, left }

originalPosition
Type: Object
The original position of the element represented as
{ top, left }

sender
Type: jQuery
The sortable that the item comes from if moving
from one sortable to another

Code examples:
Initialize the sortable with the beforeStop callback specified:
1
2
3

$( ".selector" ).sortable({
beforeStop: function( event, ui ) {}
});

Bind an event listener to the sortbeforestop event:
1

$( ".selector" ).on( "sortbeforestop", function

change( event, ui )

Type:

sortchange

This event is triggered during sorting, but only when the
DOM position has changed.
event
Type: Event
ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper being
sorted
item
Type: jQuery
The jQuery object representing the current dragged
element
offset
Type: Object
The current absolute position of the helper
represented as { top, left }
position
Type: Object
The current position of the helper represented as

{

top, left }

originalPosition
Type: Object
The original position of the element represented as
{ top, left }

sender
Type: jQuery
The sortable that the item comes from if moving
from one sortable to another

Code examples:
Initialize the sortable with the change callback specified:
1
2
3

$( ".selector" ).sortable({
change: function( event, ui ) {}
});

Bind an event listener to the sortchange event:
1

$( ".selector" ).on( "sortchange", function( event, u

create( event, ui )

Type:

sortcreate

Triggered when the sortable is created.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the sortable with the create callback specified:
1
2
3

$( ".selector" ).sortable({
create: function( event, ui ) {}
});

Bind an event listener to the sortcreate event:
1

$( ".selector" ).on( "sortcreate", function( event, u

deactivate( event, ui )

Type:

sortdeactivate

This event is triggered when sorting was stopped, is
propagated to all possible connected lists.
event
Type: Event
ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper being
sorted
item
Type: jQuery
The jQuery object representing the current dragged
element
offset
Type: Object
The current absolute position of the helper
represented as { top, left }
position
Type: Object
The current position of the helper represented as

{

top, left }

originalPosition
Type: Object
The original position of the element represented as
{ top, left }

sender
Type: jQuery
The sortable that the item comes from if moving

from one sortable to another

Code examples:
Initialize the sortable with the deactivate callback specified:
1
2
3

$( ".selector" ).sortable({
deactivate: function( event, ui ) {}
});

Bind an event listener to the sortdeactivate event:
1

$( ".selector" ).on( "sortdeactivate", function

out( event, ui )

Type:

sortout

This event is triggered when a sortable item is moved away
from a connected list.
Note: This event is also triggered when a sortable item is
dropped.
event
Type: Event
ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper being
sorted
item
Type: jQuery

The jQuery object representing the current dragged
element
offset
Type: Object
The current absolute position of the helper
represented as { top, left }
position
Type: Object
The current position of the helper represented as

{

top, left }

originalPosition
Type: Object
The original position of the element represented as
{ top, left }

sender
Type: jQuery
The sortable that the item comes from if moving
from one sortable to another

Code examples:
Initialize the sortable with the out callback specified:
1
2
3

$( ".selector" ).sortable({
out: function( event, ui ) {}
});

Bind an event listener to the sortout event:
1

$( ".selector" ).on( "sortout", function( event, ui )

over( event, ui )

Type:

sortover

This event is triggered when a sortable item is moved into a
connected list.
event
Type: Event
ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper being
sorted
item
Type: jQuery
The jQuery object representing the current dragged
element
offset
Type: Object
The current absolute position of the helper
represented as { top, left }
position
Type: Object
The current position of the helper represented as

{

top, left }

originalPosition
Type: Object
The original position of the element represented as
{ top, left }

sender
Type: jQuery
The sortable that the item comes from if moving
from one sortable to another

Code examples:
Initialize the sortable with the over callback specified:
1
2
3

$( ".selector" ).sortable({
over: function( event, ui ) {}
});

Bind an event listener to the sortover event:
1

$( ".selector" ).on( "sortover", function( event, ui

receive( event, ui )

Type:

sortreceive

This event is triggered when a connected sortable list has
received an item from another list.
event
Type: Event
ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper being
sorted
item
Type: jQuery
The jQuery object representing the current dragged
element
offset
Type: Object
The current absolute position of the helper
represented as { top, left }

position
Type: Object
The current position of the helper represented as

{

top, left }

originalPosition
Type: Object
The original position of the element represented as
{ top, left }

sender
Type: jQuery
The sortable that the item comes from if moving
from one sortable to another

Code examples:
Initialize the sortable with the receive callback specified:
1
2
3

$( ".selector" ).sortable({
receive: function( event, ui ) {}
});

Bind an event listener to the sortreceive event:
1

$( ".selector" ).on( "sortreceive", function( event,

remove( event, ui )

Type:

sortremove

This event is triggered when a sortable item has been
dragged out from the list and into another.
event
Type: Event

ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper being
sorted
item
Type: jQuery
The jQuery object representing the current dragged
element
offset
Type: Object
The current absolute position of the helper
represented as { top, left }
position
Type: Object
The current position of the helper represented as

{

top, left }

originalPosition
Type: Object
The original position of the element represented as
{ top, left }

sender
Type: jQuery
The sortable that the item comes from if moving
from one sortable to another

Code examples:
Initialize the sortable with the remove callback specified:
1
2
3

$( ".selector" ).sortable({
remove: function( event, ui ) {}
});

Bind an event listener to the sortremove event:
1

$( ".selector" ).on( "sortremove", function( event, u

sort( event, ui )

Type:

sort

This event is triggered during sorting.
event
Type: Event
ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper being
sorted
item
Type: jQuery
The jQuery object representing the current dragged
element
offset
Type: Object
The current absolute position of the helper
represented as { top, left }
position
Type: Object
The current position of the helper represented as

{

top, left }

originalPosition
Type: Object
The original position of the element represented as

{ top, left }

sender
Type: jQuery
The sortable that the item comes from if moving
from one sortable to another

Code examples:
Initialize the sortable with the sort callback specified:
1
2
3

$( ".selector" ).sortable({
sort: function( event, ui ) {}
});

Bind an event listener to the sort event:
1

$( ".selector" ).on( "sort", function( event, ui ) {}

start( event, ui )

Type:

sortstart

This event is triggered when sorting starts.
event
Type: Event
ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper being
sorted
item
Type: jQuery

The jQuery object representing the current dragged
element
offset
Type: Object
The current absolute position of the helper
represented as { top, left }
position
Type: Object
The current position of the helper represented as

{

top, left }

originalPosition
Type: Object
The original position of the element represented as
{ top, left }

sender
Type: jQuery
The sortable that the item comes from if moving
from one sortable to another

Code examples:
Initialize the sortable with the start callback specified:
1
2
3

$( ".selector" ).sortable({
start: function( event, ui ) {}
});

Bind an event listener to the sortstart event:
1

$( ".selector" ).on( "sortstart", function( event, ui

stop( event, ui )

Type:

sortstop

This event is triggered when sorting has stopped.
event
Type: Event
ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper being
sorted
item
Type: jQuery
The jQuery object representing the current dragged
element
offset
Type: Object
The current absolute position of the helper
represented as { top, left }
position
Type: Object
The current position of the helper represented as

{

top, left }

originalPosition
Type: Object
The original position of the element represented as
{ top, left }

sender
Type: jQuery
The sortable that the item comes from if moving
from one sortable to another

Code examples:

Initialize the sortable with the stop callback specified:
1
2
3

$( ".selector" ).sortable({
stop: function( event, ui ) {}
});

Bind an event listener to the sortstop event:
1

$( ".selector" ).on( "sortstop", function( event, ui

update( event, ui )

Type:

sortupdate

This event is triggered when the user stopped sorting and
the DOM position has changed.
event
Type: Event
ui
Type: Object
helper
Type: jQuery
The jQuery object representing the helper being
sorted
item
Type: jQuery
The jQuery object representing the current dragged
element
offset
Type: Object
The current absolute position of the helper
represented as { top, left }

position
Type: Object
The current position of the helper represented as

{

top, left }

originalPosition
Type: Object
The original position of the element represented as
{ top, left }

sender
Type: jQuery
The sortable that the item comes from if moving
from one sortable to another

Code examples:
Initialize the sortable with the update callback specified:
1
2
3

$( ".selector" ).sortable({
update: function( event, ui ) {}
});

Bind an event listener to the sortupdate event:
1

$( ".selector" ).on( "sortupdate", function( event, u

Example:
A simple jQuery UI Sortable.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>sortable demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<ul id="sortable">
<li>Item 1</li>
<li>Item 2</li>
<li>Item 3</li>
<li>Item 4</li>
<li>Item 5</li>
</ul>
<script>$("#sortable").sortable();</script>
</body>
</html>

Demo
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A new version of this book is available!

Spinner Widget
Categories: Widgets

Spinner Widget

version added: 1.9

Description: Enhance a text input for entering numeric
values, with up/down buttons and arrow key handling.

QuickNav
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disabled
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numberFormat
page
step

destroy
disable
enable
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pageDown
pageUp
stepDown
stepUp
value
widget

create
start
spin
stop
change

Spinner, or number stepper, widget is perfect for handling all kinds of
numeric input. It allow users to type a value directly or modify an
existing value by spinning with the keyboard, mouse or scrollwheel.
When combined with Globalize, you can even spin currencies and
dates in a variety of locales.
Spinner wraps a text input, adds two buttons to increment and
decrement the current value, along with handling key events for the
same purpose. It delegates to Globalize for number formatting and
parsing.

Keyboard interaction
UP: Increment the value by one step.
DOWN: Decrement the value by one step.
PAGE UP: Increment the value by one page.
PAGE DOWN: Decrement the value by one page.
Focus stays in the text field, even after using the mouse to click one
of the spin buttons.

Dependencies
UI Core
Widget Factory
Button
Globalize (external, optional; for use with the
numberFormat options)

culture

and

Additional Notes:
This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific
CSS file as a starting point.
This widget manipulates its element's value programmatically,
therefore a native change may not be fired when the element's
value changes.

Options
culture

Type: String
Default: null

Sets the culture to use for parsing and formatting the value.
If null , the currently set culture in Globalize is used, see
Globalize docs for available cultures. Only relevant if the
numberFormat option is set. Requires Globalize to be
included.
Code examples:
Initialize the spinner with the culture option specified:
1

$( ".selector" ).spinner({ culture: "fr" });

Get or set the culture option, after initialization:
1
2
3
4
5

// getter
var culture = $( ".selector" ).spinner( "option"
// setter
$( ".selector" ).spinner( "option", "culture"

disabled

Type: Boolean
Default: false

Disables the spinner if set to true .
Code examples:
Initialize the spinner with the disabled option specified:

1

$( ".selector" ).spinner({ disabled: true });

Get or set the disabled option, after initialization:
1
2
3
4
5

// getter
var disabled = $( ".selector" ).spinner( "option"
// setter
$( ".selector" ).spinner( "option", "disabled"

icons

Type: Object

Default: { down: "ui-icon-triangle-1-s", up: "ui-icontriangle-1-n" }

Icons to use for buttons, matching an icon defined by the
jQuery UI CSS Framework.
up (string, default: "ui-icon-triangle-1-n")
down (string, default: "ui-icon-triangle-1-s")
Code examples:
Initialize the spinner with the icons option specified:
1

$( ".selector" ).spinner({ icons: { down: "custom-dow

Get or set the icons option, after initialization:
1
2
3
4

// getter
var icons = $( ".selector" ).spinner( "option"
// setter

5

$( ".selector" ).spinner( "option", "icons", { down:

incremental
Default: true Type:

Boolean or Function( Integer count )

Controls the number of steps taken when holding down a
spin button.
Multiple types supported:
Boolean: When set to true , the stepping delta will
increase when spun incessantly. When set to false , all
steps are equal (as defined by the step option).
Function: Receives one parameter: the number of
spins that have occurred. Must return the number of
steps that should occur for the current spin.
Code examples:
Initialize the spinner with the incremental option specified:
1

$( ".selector" ).spinner({ incremental: false

Get or set the incremental option, after initialization:
1
2
3
4
5

max

// getter
var incremental = $( ".selector" ).spinner( "option"
// setter
$( ".selector" ).spinner( "option", "incremental"

Type: Number or String

Default: null

The maximum allowed value. The element's max attribute is
used if it exists and the option is not explicitly set. If null ,
there is no maximum enforced.
Multiple types supported:
Number: The maximum value.
String: If Globalize is included, the max option can be
passed as a string which will be parsed based on the
numberFormat and culture options; otherwise it will fall
back to the native parseFloat() method.
Code examples:
Initialize the spinner with the max option specified:
1

$( ".selector" ).spinner({ max: 50 });

Get or set the max option, after initialization:
1
2
3
4
5

min

// getter
var max = $( ".selector" ).spinner( "option",
// setter
$( ".selector" ).spinner( "option", "max", 50

Type: Number or String
Default: null

The minimum allowed value. The element's min attribute is
used if it exists and the option is not explicitly set. If null ,
there is no minimum enforced.
Multiple types supported:
Number: The minimum value.
String: If Globalize is included, the min option can be

passed as a string which will be parsed based on the
numberFormat and culture options; otherwise it will fall
back to the native parseFloat() method.
Code examples:
Initialize the spinner with the min option specified:
1

$( ".selector" ).spinner({ min: 0 });

Get or set the min option, after initialization:
1
2
3
4
5

// getter
var min = $( ".selector" ).spinner( "option",
// setter
$( ".selector" ).spinner( "option", "min", 0 );

numberFormat

Type: String
Default: null

Format of numbers passed to Globalize , if available. Most
common are "n" for a decimal number and "C" for a
currency value. Also see the culture option.
Code examples:
Initialize the spinner with the numberFormat option
specified:
1

$( ".selector" ).spinner({ numberFormat: "n" });

Get or set the numberFormat option, after initialization:

1
2
3
4
5

// getter
var numberFormat = $( ".selector" ).spinner(
// setter
$( ".selector" ).spinner( "option", "numberFormat"

page

Type: Number
Default: 10

The number of steps to take when paging via the
pageUp / pageDown methods.
Code examples:
Initialize the spinner with the page option specified:
1

$( ".selector" ).spinner({ page: 5 });

Get or set the page option, after initialization:
1
2
3
4
5

step

// getter
var page = $( ".selector" ).spinner( "option"
// setter
$( ".selector" ).spinner( "option", "page", 5

Type: Number or String
Default: 1

The size of the step to take when spinning via buttons or via
the stepUp() / stepDown() methods. The element's step
attribute is used if it exists and the option is not explicitly set.

Multiple types supported:
Number: The size of the step.
String: If Globalize is included, the step option can be
passed as a string which will be parsed based on the
numberFormat and culture options, otherwise it will fall
back to the native parseFloat .
Code examples:
Initialize the spinner with the step option specified:
1

$( ".selector" ).spinner({ step: 2 });

Get or set the step option, after initialization:
1
2
3
4
5

// getter
var step = $( ".selector" ).spinner( "option"
// setter
$( ".selector" ).spinner( "option", "step", 2

Methods
destroy()
Removes the spinner functionality completely. This will
return the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).spinner( "destroy" );

disable()
Disables the spinner.
This method does not accept any arguments.
Code examples:
Invoke the disable method:
1

$( ".selector" ).spinner( "disable" );

enable()
Enables the spinner.
This method does not accept any arguments.

Code examples:
Invoke the enable method:
1

$( ".selector" ).spinner( "enable" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).spinner( "option"

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current spinner options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).spinner( "option"

option( optionName, value )
Sets the value of the spinner option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).spinner( "option", "disabled"

option( options )
Sets one or more options for the spinner.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).spinner( "option", { disabled:

pageDown( [pages ] )
Decrements the value by the specified number of pages, as
defined by the page option. Without the parameter, a single
page is decremented.
If the resulting value is above the max, below the min, or
results in a step mismatch, the value will be adjusted to the
closest valid value.
Invoking pageDown() will cause
to be triggered.

start , spin ,

and

stop

events

pages
Type: Number
Number of pages to decrement, defaults to 1.
Code examples:
Invoke the pageDown method:
1

$( ".selector" ).spinner( "pageDown" );

pageUp( [pages ] )
Increments the value by the specified number of pages, as
defined by the page option. Without the parameter, a single
page is incremented.
If the resulting value is above the max, below the min, or
results in a step mismatch, the value will be adjusted to the
closest valid value.
Invoking pageUp() will cause
to be triggered.
pages

start , spin ,

and

stop

events

Type: Number
Number of pages to increment, defaults to 1.
Code examples:
Invoke the pageUp method:
1

$( ".selector" ).spinner( "pageUp", 10 );

stepDown( [steps ] )
Decrements the value by the specified number of steps.
Without the parameter, a single step is decremented.
If the resulting value is above the max, below the min, or
results in a step mismatch, the value will be adjusted to the
closest valid value.
Invoking stepDown() will cause
to be triggered.

start , spin ,

and

stop

events

steps
Type: Number
Number of steps to decrement, defaults to 1.
Code examples:
Invoke the stepDown method:
1

$( ".selector" ).spinner( "stepDown" );

stepUp( [steps ] )
Increments the value by the specified number of steps.

Without the parameter, a single step is incremented.
If the resulting value is above the max, below the min, or
results in a step mismatch, the value will be adjusted to the
closest valid value.
Invoking stepUp() will cause
to be triggered.

start , spin ,

and

stop

events

steps
Type: Number
Number of steps to increment, defaults to 1.
Code examples:
Invoke the stepUp method:
1

$( ".selector" ).spinner( "stepUp", 5 );

value()

Returns: Number

Gets the current value as a number. The value is parsed
based on the numberFormat and culture options.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var value = $( ".selector" ).spinner( "value"

value( value )

value
Type: Number or String
The value to set. If passed as a string, the value is
parsed based on the numberFormat and culture options.
Code examples:
Invoke the method:
1

$( ".selector" ).spinner( "value", 50 );

widget()

Returns: jQuery

Returns a jQuery object containing the generated wrapper.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).spinner( "widget"

Events
change( event, ui )

Type:

spinchange

Triggered when the value of the spinner has changed and
the input is no longer focused.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the spinner with the change callback specified:
1
2
3

$( ".selector" ).spinner({
change: function( event, ui ) {}
});

Bind an event listener to the spinchange event:
1

$( ".selector" ).on( "spinchange", function( event, u

create( event, ui )
Triggered when the spinner is created.
event
Type: Event

Type:

spincreate

ui
Type: Object
Code examples:
Initialize the spinner with the create callback specified:
1
2
3

$( ".selector" ).spinner({
create: function( event, ui ) {}
});

Bind an event listener to the spincreate event:
1

$( ".selector" ).on( "spincreate", function( event, u

spin( event, ui )

Type:

spin

Triggered during increment/decrement (to determine
direction of spin compare current value with ui.value ).
Can be canceled, preventing the value from being updated.
event
Type: Event
ui
Type: Object
value
Type: Number
The new value to be set, unless the event is
cancelled.

Code examples:
Initialize the spinner with the spin callback specified:

1
2
3

$( ".selector" ).spinner({
spin: function( event, ui ) {}
});

Bind an event listener to the spin event:
1

$( ".selector" ).on( "spin", function( event, ui ) {}

start( event, ui )

Type:

spinstart

Triggered before a spin. Can be canceled, preventing the
spin from occurring.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the spinner with the start callback specified:
1
2
3

$( ".selector" ).spinner({
start: function( event, ui ) {}
});

Bind an event listener to the spinstart event:
1

$( ".selector" ).on( "spinstart", function( event, ui

stop( event, ui )

Type:

spinstop

Triggered after a spin.
event
Type: Event
ui
Type: Object
Code examples:
Initialize the spinner with the stop callback specified:
1
2
3

$( ".selector" ).spinner({
stop: function( event, ui ) {}
});

Bind an event listener to the spinstop event:
1

$( ".selector" ).on( "spinstop", function( event, ui

Example:
Plain number spinner
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>spinner demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<input id="spinner">
<script>
$( "#spinner" ).spinner();
</script>
</body>
</html>

Demo
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A new version of this book is available!

.switchClass()
Categories: Effects | Effects Core

.switchClass( removeClassName, addClassName [,
duration ] [, easing ] [, complete ] )
Returns: jQuery
Description: Adds and removes the specified class(es)
to each of the set of matched elements while animating
all style changes.
.switchClass( removeClassName, addClassName [,
duration ] [, easing ] [, complete ] )
removeClassName
Type: String
One or more class names (space separated) to be removed
from the class attribute of each matched element.
addClassName
Type: String
One or more class names (space separated) to be added to the
class attribute of each matched element.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.
The .switchClass() method allows you to animate the transition of
adding and removing classes at the same time.
Similar to native CSS transitions, jQuery UI's class animations
provide a smooth transition from one state to another while allowing
you to keep all the details about which styles to change in CSS and
out of your JavaScript. All class animation methods, including

.switchClass() ,

support custom durations and easings, as well as
providing a callback for when the animation completes.
Not all styles can be animated. For example, there is no way to
animate a background image. Any styles that cannot be animated
will be changed at the end of the animation.
This plugin extends jQuery's built-in .switchClass() method. If
jQuery UI is not loaded, calling the .switchClass() method may not
fail directly, as the method still exists. However, the expected
behavior will not occur.

Example:
Adds the class "blue" and removes the class "big"
from the matched elements.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>switchClass demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
div {
width: 100px;
height: 100px;
background-color: #ccc;
}
.big {
width: 200px;
height: 200px;
}
.blue {
background-color: #00f;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div class="big"></div>

<script>
$( "div" ).click(function() {
$( this ).switchClass( "big", "blue", 1000, "easeInOut

31
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});
</script>
</body>
</html>
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:tabbable Selector
Categories: Selectors | UI Core

tabbable selector
Description: Selects elements which the user can focus
via tabbing.
jQuery( ":tabbable" )
Some elements are natively tabbable, while others require explictly
setting a positive tab index. In all cases, the element must be visible
in order to be tabbable.
Elements of the following type are tabbale if they do not have a
negative tab index and are not disabled: input , select , textarea ,
button , and object . Anchors are focusable if they have an href or
positive tabindex attribute. area elements are focusable if they are
inside a named map, have an href attribute, and there is a visible
image using the map. All other elements are tabbable based solely
on their tabindex attribute and visibility.
Note: Elements with a negative tab index are
:tabbable .

:focusable ,

but not

Example:
Select tabbable elements and highlight them with a
red border.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>tabbable demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
input {
border: 1px solid #000;
}
div {
padding: 5px;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div><input value="no tabindex"></div>
<div><input tabindex="5" value="positive tabindex"
<div><input tabindex="-1" value="negative tabindex"
<script>
$( ":tabbable" ).css( "border-color", "red" );
</script>
</body>
</html>
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Tabs Widget
Categories: Widgets

Tabs Widget

version added: 1.0

Description: A single content area with multiple panels,
each associated with a header in a list.

QuickNav

Examples

Options

Methods

Events

active
collapsible
disabled
event
heightStyle
hide
show

destroy
disable
enable
load
option
refresh
widget

activate
beforeActivate
beforeLoad
create
load

Tabs are generally used to break content into multiple sections that
can be swapped to save space, much like an accordion.
The content for each tab panel can be defined in-page or can be
loaded via Ajax; both are handled automatically based on the href
of the anchor associated with the tab. By default tabs are activated
on click, but the events can be changed to hover via the event
option.

Keyboard interaction
When focus is on a tab, the following key commands are available:
UP/LEFT: Move focus to the previous tab. If on first tab, moves
focus to last tab. Activate focused tab after a short delay.
DOWN/RIGHT: Move focus to the next tab. If on last tab, moves
focus to first tab. Activate focused tab after a short delay.
HOME: Move focus to the first tab. Activate focused tab after a
short delay.
END: Move focus to the last tab. Activate focused tab after a
short delay.
SPACE: Activate panel associated with focused tab.
ENTER: Activate or toggle panel associated with focused tab.

ALT+PAGE UP: Move focus to the previous tab and
immediately activate.
ALT+PAGE DOWN: Move focus to the next tab and immediately
activate.
When focus is in a panel, the following key commands are available:
CTRL+UP: Move focus to associated tab.
ALT+PAGE UP: Move focus to the previous tab and
immediately activate.
ALT+PAGE DOWN: Move focus to the next tab and immediately
activate.

Dependencies
UI Core
Widget Factory
Effects Core (optional; for use with the

show

and

hide

options)

Additional Notes:
This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific
CSS file as a starting point.

Options
Type: Boolean or Integer

active

Default: 0

Which panel is currently open.
Multiple types supported:
Boolean: Setting active to false will collapse all
panels. This requires the collapsible option to be

true .

Integer: The zero-based index of the panel that is
active (open). A negative value selects panels going
backward from the last panel.
Code examples:
Initialize the tabs with the active option specified:
1

$( ".selector" ).tabs({ active: 1 });

Get or set the active option, after initialization:
1
2
3
4
5

// getter
var active = $( ".selector" ).tabs( "option",
// setter
$( ".selector" ).tabs( "option", "active", 1 );

collapsible

Type: Boolean
Default: false

When set to

true ,

the active panel can be closed.

Code examples:
Initialize the tabs with the collapsible option specified:
1

$( ".selector" ).tabs({ collapsible: true });

Get or set the collapsible option, after initialization:
1
2
3
4
5

// getter
var collapsible = $( ".selector" ).tabs( "option"
// setter
$( ".selector" ).tabs( "option", "collapsible"

disabled

Type: Boolean or Array
Default: false

Which tabs are disabled.
Multiple types supported:
Boolean: Enable or disable all tabs.
Array: An array containing the zero-based indexes of
the tabs that should be disabled, e.g., [ 0, 2 ] would
disable the first and third tab.
Code examples:
Initialize the tabs with the disabled option specified:
1

$( ".selector" ).tabs({ disabled: [ 0, 2 ] });

Get or set the disabled option, after initialization:

1
2
3
4
5

// getter
var disabled = $( ".selector" ).tabs( "option"
// setter
$( ".selector" ).tabs( "option", "disabled", [

Type: String

event

Default: "click"

The type of event that the tabs should react to in order to
activate the tab. To activate on hover, use "mouseover" .
Code examples:
Initialize the tabs with the event option specified:
1

$( ".selector" ).tabs({ event: "mouseover" });

Get or set the event option, after initialization:
1
2
3
4
5

// getter
var event = $( ".selector" ).tabs( "option",

// setter
$( ".selector" ).tabs( "option", "event", "mouseover"

heightStyle

Type: String
Default: "content"

Controls the height of the tabs widget and each panel.
Possible values:

"auto" :

All panels will be set to the height of the tallest

panel.
"fill" : Expand to the available height based on the
tabs' parent height.
"content" :

Each panel will be only as tall as its content.

Code examples:
Initialize the tabs with the heightStyle option specified:
1

$( ".selector" ).tabs({ heightStyle: "fill" });

Get or set the heightStyle option, after initialization:
1
2
3
4
5

// getter
var heightStyle = $( ".selector" ).tabs( "option"
// setter
$( ".selector" ).tabs( "option", "heightStyle"

hide Type: Boolean or Number or String or Object
Default: null

If and how to animate the hiding of the panel.
Multiple types supported:
Boolean: When set to false , no animation will be used
and the panel will be hidden immediately. When set to
true , the panel will fade out with the default duration
and the default easing.
Number: The panel will fade out with the specified
duration and the default easing.
String: The panel will be hidden using the specified
effect. The value can either be the name of a built-in

jQuery animation method, such as "slideUp" , or the
name of a jQuery UI effect, such as "fold" . In either
case the effect will be used with the default duration
and the default easing.
Object: If the value is an object, then effect , delay ,
duration , and easing properties may be provided. If the
effect property contains the name of a jQuery method,
then that method will be used; otherwise it is assumed
to be the name of a jQuery UI effect. When using a
jQuery UI effect that supports additional settings, you
may include those settings in the object and they will be
passed to the effect. If duration or easing is omitted,
then the default values will be used. If effect is omitted,
then "fadeOut" will be used. If delay is omitted, then no
delay is used.
Code examples:
Initialize the tabs with the hide option specified:
1

$( ".selector" ).tabs({ hide: { effect: "explode"

Get or set the hide option, after initialization:
1
2
3
4
5

// getter
var hide = $( ".selector" ).tabs( "option", "hide"
// setter
$( ".selector" ).tabs( "option", "hide", { effect:

show Type: Boolean or Number or String or Object
Default: null

If and how to animate the showing of the panel.
Multiple types supported:

Boolean: When set to false , no animation will be used
and the panel will be shown immediately. When set to
true , the panel will fade in with the default duration and
the default easing.
Number: The panel will fade in with the specified
duration and the default easing.
String: The panel will be shown using the specified
effect. The value can either be the name of a built-in
jQuery animation method, such as "slideDown" , or the
name of a jQuery UI effect, such as "fold" . In either
case the effect will be used with the default duration
and the default easing.
Object: If the value is an object, then effect , delay ,
duration , and easing properties may be provided. If the
effect property contains the name of a jQuery method,
then that method will be used; otherwise it is assumed
to be the name of a jQuery UI effect. When using a
jQuery UI effect that supports additional settings, you
may include those settings in the object and they will be
passed to the effect. If duration or easing is omitted,
then the default values will be used. If effect is omitted,
then "fadeIn" will be used. If delay is omitted, then no
delay is used.
Code examples:
Initialize the tabs with the show option specified:
1

$( ".selector" ).tabs({ show: { effect: "blind"

Get or set the show option, after initialization:
1
2
3
4
5

// getter
var show = $( ".selector" ).tabs( "option", "show"
// setter
$( ".selector" ).tabs( "option", "show", { effect:

Methods
destroy()
Removes the tabs functionality completely. This will return
the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).tabs( "destroy" );

disable()
Disables all tabs.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

$( ".selector" ).tabs( "disable" );

disable( index )
Disables a tab. The selected tab cannot be disabled. To
disable more than one tab at once, set the disabled option:
$( "#tabs" ).tabs( "option", "disabled", [ 1, 2, 3 ] ) .

index
Type: Number or String
Which tab to disable.
Code examples:
Invoke the method:
1

$( ".selector" ).tabs( "disable", 1 );

enable()
Enables all tabs.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

$( ".selector" ).tabs( "enable" );

enable( index )
Enables a tab. To enable more than one tab at once reset
the disabled property like: $( "#example" ).tabs( "option",
"disabled", [] ); .
index
Type: Number or String
Which tab to enable.
Code examples:
Invoke the method:

1

$( ".selector" ).tabs( "enable", 1 );

load( index )
Loads the panel content of a remote tab.
index
Type: Number or String
Which tab to load.
Code examples:
Invoke the load method:
1

$( ".selector" ).tabs( "load", 1 );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).tabs( "option"

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current tabs options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).tabs( "option"

option( optionName, value )
Sets the value of the tabs option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.
value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).tabs( "option", "disabled",

option( options )
Sets one or more options for the tabs.
options
Type: Object

A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).tabs( "option", { disabled:

refresh()
Process any tabs that were added or removed directly in the
DOM and recompute the height of the tab panels. Results
depend on the content and the heightStyle option.
This method does not accept any arguments.
Code examples:
Invoke the refresh method:
1

$( ".selector" ).tabs( "refresh" );

widget()

Returns: jQuery

Returns a jQuery object containing the tabs container.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).tabs( "widget" );

Events
activate( event, ui )

Type:

tabsactivate

Triggered after a tab has been activated (after animation
completes). If the tabs were previously collapsed, ui.oldTab
and ui.oldPanel will be empty jQuery objects. If the tabs are
collapsing, ui.newTab and ui.newPanel will be empty jQuery
objects.
event
Type: Event
ui
Type: Object
newTab
Type: jQuery
The tab that was just activated.
oldTab
Type: jQuery
The tab that was just deactivated.
newPanel
Type: jQuery
The panel that was just activated.
oldPanel
Type: jQuery
The panel that was just deactivated.

Code examples:
Initialize the tabs with the activate callback specified:
1

$( ".selector" ).tabs({

2
3

activate: function( event, ui ) {}
});

Bind an event listener to the tabsactivate event:
1

$( ".selector" ).on( "tabsactivate", function

beforeActivate( event, ui )
Type:

tabsbeforeactivate

Triggered directly after a tab is
activated. Can be canceled to prevent the tab from
activating. If the tabs are currently collapsed, ui.oldTab and
ui.oldPanel will be empty jQuery objects. If the tabs are
collapsing, ui.newTab and ui.newPanel will be empty jQuery
objects.
event
Type: Event
ui
Type: Object
newTab
Type: jQuery
The tab that is about to be activated.
oldTab
Type: jQuery
The tab that is about to be deactivated.
newPanel
Type: jQuery
The panel that is about to be activated.
oldPanel
Type: jQuery

The panel that is about to be deactivated.

Code examples:
Initialize the tabs with the beforeActivate callback specified:
1
2
3

$( ".selector" ).tabs({
beforeActivate: function( event, ui ) {}
});

Bind an event listener to the tabsbeforeactivate event:
1

$( ".selector" ).on( "tabsbeforeactivate", function

beforeLoad( event, ui )

Type:

tabsbeforeload

Triggered when a remote tab is about to be loaded, after the
beforeActivate event. Can be canceled to prevent the tab
panel from loading content; though the panel will still be
activated. This event is triggered just before the Ajax
request is made, so modifications can be made to ui.jqXHR
and ui.ajaxSettings .
Note: Although ui.ajaxSettings is provided and can be
modified, some of these settings have already been
processed by jQuery. For example, prefilters have been
applied, data has been processed, and type has been
determined. The beforeLoad event occurs at the same time,
and therefore has the same restrictions, as the beforeSend
callback from jQuery.ajax() .
event
Type: Event

ui
Type: Object
tab
Type: jQuery
The tab that is being loaded.
panel
Type: jQuery
The panel which will be populated by the Ajax
response.
jqXHR
Type: jqXHR
The jqXHR object that is requesting the content.
ajaxSettings
Type: Object
The settings that will be used by
request the content.

jQuery.ajax

to

Code examples:
Initialize the tabs with the beforeLoad callback specified:
1
2
3

$( ".selector" ).tabs({
beforeLoad: function( event, ui ) {}
});

Bind an event listener to the tabsbeforeload event:
1

$( ".selector" ).on( "tabsbeforeload", function

create( event, ui )

Type:

tabscreate

Triggered when the tabs are created. If the tabs are
collapsed, ui.tab and ui.panel will be empty jQuery
objects.
event
Type: Event
ui
Type: Object
tab
Type: jQuery
The active tab.
panel
Type: jQuery
The active panel.

Code examples:
Initialize the tabs with the create callback specified:
1
2
3

$( ".selector" ).tabs({
create: function( event, ui ) {}
});

Bind an event listener to the tabscreate event:
1

$( ".selector" ).on( "tabscreate", function( event, u

load( event, ui )

Type:

Triggered after a remote tab has been loaded.
event
Type: Event

tabsload

ui
Type: Object
tab
Type: jQuery
The tab that was just loaded.
panel
Type: jQuery
The panel which was just populated by the Ajax
response.

Code examples:
Initialize the tabs with the load callback specified:
1
2
3

$( ".selector" ).tabs({
load: function( event, ui ) {}
});

Bind an event listener to the tabsload event:
1

$( ".selector" ).on( "tabsload", function( event, ui

Example:
A simple jQuery UI Tabs
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>tabs demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div id="tabs">
<ul>
<li><a href="#fragment-1"><span>One</span></
<li><a href="#fragment-2"><span>Two</span></
<li><a href="#fragment-3"><span>Three</span
</ul>
<div id="fragment-1">
<p>First tab is active by default:</p>
<pre><code>$( "#tabs" ).tabs(); </code></pre
</div>
<div id="fragment-2">
Lorem ipsum dolor sit amet, consectetuer adipiscing
Lorem ipsum dolor sit amet, consectetuer adipiscing
</div>
<div id="fragment-3">
Lorem ipsum dolor sit amet, consectetuer adipiscing
Lorem ipsum dolor sit amet, consectetuer adipiscing
Lorem ipsum dolor sit amet, consectetuer adipiscing
</div>
</div>

32
33
34
35
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<script>
$( "#tabs" ).tabs();
</script>
</body>
</html>
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.toggle()
Categories: Effects | Effects Core | Method Overrides | Methods

.toggle( effect [, options ] [, duration ] [, complete ] )
Returns: jQuery
Description: Display or hide the matched elements,
using custom effects.
.toggle( effect [, options ] [, duration ] [, complete ] )
effect
Type: String
A string indicating which effect to use for the transition.
options
Type: Object
Effect-specific settings and easing.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
complete
Type: Function()
A function to call once the animation is complete.

.toggle( options )
options
Type: Object
All animation settings. The only required property is

effect .

effect
Type: String
A string indicating which effect to use for the transition.
easing (default: "swing" )
Type: String
A string indicating which easing function to use for the
transition.
duration (default: 400 )
Type: Number or String

A string or number determining how long the animation will
run.
complete
Type: Function()
A function to call once the animation is complete.
This plugin extends jQuery's built-in .toggle() method. If jQuery UI
is not loaded, calling the .toggle() method may not fail directly, as
the method still exists. However, the expected behavior will not
occur.

Example:
Toggle a div using the fold effect.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>toggle demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
div {
width: 100px;
height: 100px;
background: #ccc;
border: 1px solid #000;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<button>toggle the div</button>
<div></div>
<script>
$( "button" ).click(function() {
$( "div" ).toggle( "fold", 1000 );
});
</script>
</body>
</html>

Demo
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A new version of this book is available!

.toggleClass()
Categories: Effects | Effects Core | Method Overrides

.toggleClass( className [, switch ] [, duration ] [, easing ]
[, complete ] )
Returns: jQuery
Description: Add or remove one or more classes from
each element in the set of matched elements, depending
on either the class's presence or the value of the switch
argument, while animating all style changes.
.toggleClass( className [, switch ] [, duration ] [,
easing ] [, complete ] )
className
Type: String
One or more class names (space separated) to be toggled for
each element in the matched set.
switch
Type: Boolean
A boolean value to determine whether the class should be
added or removed.
duration (default: 400 )
Type: Number or String
A string or number determining how long the animation will run.
easing (default: swing )
Type: String
A string indicating which easing function to use for the
transition.
complete
Type: Function()
A function to call once the animation is complete.
Similar to native CSS transitions, jQuery UI's class animations
provide a smooth transition from one state to another while allowing
you to keep all the details about which styles to change in CSS and
out of your JavaScript. All class animation methods, including
.toggleClass() , support custom durations and easings, as well as

providing a callback for when the animation completes.
Not all styles can be animated. For example, there is no way to
animate a background image. Any styles that cannot be animated
will be changed at the end of the animation.
This plugin extends jQuery's built-in .toggleClass() method. If
jQuery UI is not loaded, calling the .toggleClass() method may not
fail directly, as the method still exists. However, the expected
behavior will not occur.

Example:
Toggles the class "big-blue" for the matched
elements.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>toggleClass demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
div {
width: 100px;
height: 100px;
background-color: #ccc;
}
.big-blue {
width: 200px;
height: 200px;
background-color: #00f;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<div></div>

<script>
$( "div" ).click(function() {
$( this ).toggleClass( "big-blue", 1000, "easeOutSine"
});
</script>
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</body>
</html>

Demo
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Tooltip Widget
Categories: Widgets

Tooltip Widget

version added: 1.9

Description: Customizable, themeable tooltips,
replacing native tooltips.

QuickNav

Examples

Options

Methods

Events

content
disabled
hide
items
position
show
tooltipClass
track

close
destroy
disable
enable
open
option
widget

create
open
close

Tooltip replaces native tooltips, making them themable as well as
allowing various customizations:
Display other content than just the title, like inline footnotes or
extra content retrieved via Ajax.
Customize the positioning, e.g., to center the tooltip above
elements.
Add extra styling to customize the appearance, for warning or
error fields.
A fade animation is used by default to show and hide the tooltip,
making the appearance a bit more organic, compared to just
toggling the visiblity. This can be customized with the show and hide
options.
The items and content options need to stay in-sync. If you change
one of them, you need to change the other.
In general, disabled elements do not trigger any DOM events.
Therefore, it is not possible to properly control tooltips for disabled
elements, since we need to listen to events to determine when to
show and hide the tooltip. As a result, jQuery UI does not guarantee
any level of support for tooltips attached to disabled elements.
Unfortunately, this means that if you require tooltips on disabled

elements, you may end up with a mixture of native tooltips and
jQuery UI tooltips.

Dependencies
UI Core
Widget Factory
Position
Effects Core (optional; for use with the

show

and

hide

options)

Additional Notes:
This widget requires some functional CSS, otherwise it won't
work. If you build a custom theme, use the widget's specific
CSS file as a starting point.

Options
Type: Function() or String

content

Default: function returning the title attribute

The content of the tooltip.
When changing this option, you likely need to also change
the items option.
Multiple types supported:
Function: A callback which can either return the
content directly, or call the first argument, passing in the
content, e.g., for Ajax content.
String: A string of HTML to use for the tooltip content.
Code examples:
Initialize the tooltip with the content option specified:
1

$( ".selector" ).tooltip({ content: "Awesome title!"

Get or set the content option, after initialization:
1
2
3
4
5

// getter
var content = $( ".selector" ).tooltip( "option"
// setter
$( ".selector" ).tooltip( "option", "content"

disabled

Type: Boolean

Default: false

Disables the tooltip if set to true .
Code examples:
Initialize the tooltip with the disabled option specified:
1

$( ".selector" ).tooltip({ disabled: true });

Get or set the disabled option, after initialization:
1
2
3
4
5

// getter
var disabled = $( ".selector" ).tooltip( "option"
// setter
$( ".selector" ).tooltip( "option", "disabled"

hide Type: Boolean or Number or String or Object
Default: null

If and how to animate the hiding of the tooltip.
Multiple types supported:
Boolean: When set to false , no animation will be used
and the tooltip will be hidden immediately. When set to
true , the tooltip will fade out with the default duration
and the default easing.
Number: The tooltip will fade out with the specified
duration and the default easing.
String: The tooltip will be hidden using the specified
effect. The value can either be the name of a built-in
jQuery animation method, such as "slideUp" , or the
name of a jQuery UI effect, such as "fold" . In either
case the effect will be used with the default duration
and the default easing.
Object: If the value is an object, then effect , delay ,

duration , and easing properties may be provided. If the
effect property contains the name of a jQuery method,

then that method will be used; otherwise it is assumed
to be the name of a jQuery UI effect. When using a
jQuery UI effect that supports additional settings, you
may include those settings in the object and they will be
passed to the effect. If duration or easing is omitted,
then the default values will be used. If effect is omitted,
then "fadeOut" will be used. If delay is omitted, then no
delay is used.
Code examples:
Initialize the tooltip with the hide option specified:
1

$( ".selector" ).tooltip({ hide: { effect: "explode"

Get or set the hide option, after initialization:
1
2
3
4
5

// getter
var hide = $( ".selector" ).tooltip( "option"

// setter
$( ".selector" ).tooltip( "option", "hide", { effect:

items

Type: Selector
Default: [title]

A selector indicating which items should show tooltips.
Customize if you're using something other then the title
attribute for the tooltip content, or if you need a different
selector for event delegation.
When changing this option, you likely need to also change
the content option.

Code examples:
Initialize the tooltip with the items option specified:
1

$( ".selector" ).tooltip({ items: "img[alt]" });

Get or set the items option, after initialization:
1
2
3
4
5

// getter
var items = $( ".selector" ).tooltip( "option"
// setter
$( ".selector" ).tooltip( "option", "items",

position

Type: Object

Default: { my: "left top+15", at: "left bottom", collision:
"flipfit" }

Identifies the position of the tooltip in relation to the
associated target element. The of option defaults to the
target element, but you can specify another element to
position against. You can refer to the jQuery UI Position
utility for more details about the various options.
Code examples:
Initialize the tooltip with the position option specified:
1

$( ".selector" ).tooltip({ position: { my: "left+15 c

Get or set the position option, after initialization:
1

// getter

2
3
4
5

var position = $( ".selector" ).tooltip( "option"
// setter
$( ".selector" ).tooltip( "option", "position"

show Type: Boolean or Number or String or Object
Default: null

If and how to animate the showing of the tooltip.
Multiple types supported:
Boolean: When set to false , no animation will be used
and the tooltip will be shown immediately. When set to
true , the tooltip will fade in with the default duration and
the default easing.
Number: The tooltip will fade in with the specified
duration and the default easing.
String: The tooltip will be shown using the specified
effect. The value can either be the name of a built-in
jQuery animation method, such as "slideDown" , or the
name of a jQuery UI effect, such as "fold" . In either
case the effect will be used with the default duration
and the default easing.
Object: If the value is an object, then effect , delay ,
duration , and easing properties may be provided. If the
effect property contains the name of a jQuery method,
then that method will be used; otherwise it is assumed
to be the name of a jQuery UI effect. When using a
jQuery UI effect that supports additional settings, you
may include those settings in the object and they will be
passed to the effect. If duration or easing is omitted,
then the default values will be used. If effect is omitted,
then "fadeIn" will be used. If delay is omitted, then no
delay is used.
Code examples:
Initialize the tooltip with the show option specified:

1

$( ".selector" ).tooltip({ show: { effect: "blind"

Get or set the show option, after initialization:
1
2
3
4
5

// getter
var show = $( ".selector" ).tooltip( "option"

// setter
$( ".selector" ).tooltip( "option", "show", { effect:

tooltipClass

Type: String
Default: null

A class to add to the widget, can be used to display various
tooltip types, like warnings or errors.
This may get replaced by the classes option.
Code examples:
Initialize the tooltip with the tooltipClass option specified:
1

$( ".selector" ).tooltip({ tooltipClass: "custom-tool

Get or set the tooltipClass option, after initialization:
1
2
3
4
5

// getter
var tooltipClass = $( ".selector" ).tooltip(
// setter
$( ".selector" ).tooltip( "option", "tooltipClass"

track

Type: Boolean
Default: false

Whether the tooltip should track (follow) the mouse.
Code examples:
Initialize the tooltip with the track option specified:
1

$( ".selector" ).tooltip({ track: true });

Get or set the track option, after initialization:
1
2
3
4
5

// getter
var track = $( ".selector" ).tooltip( "option"
// setter
$( ".selector" ).tooltip( "option", "track",

Methods
close()
Closes a tooltip. This is only intended to be called for nondelegated tooltips.
This method does not accept any arguments.
Code examples:
Invoke the close method:
1

$( ".selector" ).tooltip( "close" );

destroy()
Removes the tooltip functionality completely. This will return
the element back to its pre-init state.
This method does not accept any arguments.
Code examples:
Invoke the destroy method:
1

$( ".selector" ).tooltip( "destroy" );

disable()
Disables the tooltip.
This method does not accept any arguments.

Code examples:
Invoke the disable method:
1

$( ".selector" ).tooltip( "disable" );

enable()
Enables the tooltip.
This method does not accept any arguments.
Code examples:
Invoke the enable method:
1

$( ".selector" ).tooltip( "enable" );

open()
Programmatically open a tooltip. This is only intended to be
called for non-delegated tooltips.
This method does not accept any arguments.
Code examples:
Invoke the open method:
1

$( ".selector" ).tooltip( "open" );

option( optionName )

Returns: Object

Gets the value currently associated with the specified
optionName .
optionName
Type: String
The name of the option to get.
Code examples:
Invoke the method:
1

var isDisabled = $( ".selector" ).tooltip( "option"

option()

Returns: PlainObject

Gets an object containing key/value pairs representing the
current tooltip options hash.
This method does not accept any arguments.
Code examples:
Invoke the method:
1

var options = $( ".selector" ).tooltip( "option"

option( optionName, value )
Sets the value of the tooltip option associated with the
specified optionName .
optionName
Type: String
The name of the option to set.

value
Type: Object
A value to set for the option.
Code examples:
Invoke the method:
1

$( ".selector" ).tooltip( "option", "disabled"

option( options )
Sets one or more options for the tooltip.
options
Type: Object
A map of option-value pairs to set.
Code examples:
Invoke the method:
1

$( ".selector" ).tooltip( "option", { disabled:

widget()

Returns: jQuery

Returns a jQuery object containing the original element.
This method does not accept any arguments.
Code examples:
Invoke the widget method:
1

var widget = $( ".selector" ).tooltip( "widget"

Events
close( event, ui )

Type:

Triggered when a tooltip is closed, triggered on
mouseleave .
event
Type: Event

tooltipclose
focusout

or

ui
Type: Object
tooltip
Type: jQuery
The generated tooltip element.

Code examples:
Initialize the tooltip with the close callback specified:
1
2
3

$( ".selector" ).tooltip({
close: function( event, ui ) {}
});

Bind an event listener to the tooltipclose event:
1

$( ".selector" ).on( "tooltipclose", function

create( event, ui )
Triggered when the tooltip is created.

Type:

tooltipcreate

event
Type: Event
ui
Type: Object
Code examples:
Initialize the tooltip with the create callback specified:
1
2
3

$( ".selector" ).tooltip({
create: function( event, ui ) {}
});

Bind an event listener to the tooltipcreate event:
1

$( ".selector" ).on( "tooltipcreate", function

open( event, ui )

Type:

Triggered when a tooltip is shown, triggered on
mouseover .
event
Type: Event

tooltipopen

focusin

ui
Type: Object
tooltip
Type: jQuery
The generated tooltip element.

Code examples:
Initialize the tooltip with the open callback specified:

or

1
2
3

$( ".selector" ).tooltip({
open: function( event, ui ) {}
});

Bind an event listener to the tooltipopen event:
1

$( ".selector" ).on( "tooltipopen", function( event,

Example:
Create a tooltip on the document, using event
delegation for all elements with a title attribute.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>tooltip demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
<p>
<a href="#" title="Anchor description">Anchor text
<input title="Input help">
</p>
<script>
$( document ).tooltip();
</script>
</body>
</html>

Demo

POWERED BYHERONOTE

A new version of this book is available!

Transfer Effect
Categories: Effects

Transfer Effect
Description: Transfers the outline of an element to
another element
transfer
className
Type: String
argumental class name the transfer element will receive.
to
Type: String
jQuery selector, the element to transfer to.
Very useful when trying to visualize interaction between two
elements.
The transfer element iself has the class ui-effects-transfer , and
needs to be styled by you, for example by adding a background or
border.

Example:
Clicking on the green element transfers to the other.
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<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<title>transfer demo</title>
<link rel="stylesheet" href="http://code.jquery.com/ui
<style>
div.green {
width: 100px;
height: 80px;
background: green;
border: 1px solid black;
position: relative;
}
div.red {
margin-top: 10px;
width: 50px;
height: 30px;
background: red;
border: 1px solid black;
position: relative;
}
.ui-effects-transfer {
border: 1px dotted black;
}
</style>
<script src="http://code.jquery.com/jquery-1.9.1.js"
<script src="http://code.jquery.com/ui/1.10.1/jquery-u
</head>
<body>
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<div class="green"></div>
<div class="red"></div>

<script>
$( "div" ).click(function() {
var i = 1 - $( "div" ).index( this );
$( this ).effect( "transfer", { to: $( "div" ).eq( i )
});
</script>
</body>
</html>

Demo
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.uniqueId()
Categories: Methods | UI Core

.uniqueId()

Returns: jQuery

Description: Generate and apply a unique id for the set
of matched elements.
.uniqueId()

version added: 1.9

This method does not accept any arguments.
Many widgets need to generate unique ids for elements. .uniqueId()
will check if the element has an id, and if not, it will generate one and
set it on the element. It is safe to call .uniqueId() on an element
without checking if it already has an id. If/when the widget needs to
clean up after itself, the .removeUniqueId() method will remove the id
from the element if it was added by .uniqueId() and leave the id
alone if it was not. .removeUniqueId() is able to be smart about this
because the generated ids have a prefix of "ui-id-" .

POWERED BYHERONOTE
A new version of this book is available!

.zIndex()
Categories: Methods | UI Core

Contents:
.zIndex()
.zIndex()
.zIndex( zIndex )
.zIndex( zIndex )

.zIndex()

Returns: jQuery

Description: Get the z-index for an element.
.zIndex()
This method does not accept any arguments.
The .zIndex() method is useful for finding the z-index of an element,
regardless of whether the z-index is set directly on the element or on
one of its ancestors. In order to determine the z-index, this method
will start at the specified element and walk up the DOM until it finds
an element that is positioned and has a z-index set. If no such
element is found, then the method will return a value of 0 .
This method assumes that elements with nested z-indexes would
not have a z-index of 0 . For example, given the following DOM the
inner element will be treated as if it does not have a z-index set
because it is impossible to differentiate between an explicit value of
0 and no value in Internet Explorer.
1
2
3

<div style="z-index: -10;">
<div style="z-index: 0;"></div>
</div>

.zIndex( zIndex )

Returns: Integer

Description: Set the z-index for an element.
.zIndex( zIndex )
zIndex
Type: Integer
The z-index to set.
This is equivalent to

.css( "zIndex", zIndex ) .

POWERED BYHERONOTE
A new version of this book is available!

Category: Effects
jQuery UI adds quite a bit of functionality on top of jQuery’s built-in
effects. jQuery UI adds support for animating colors and class
transitions, as well as providing several additional easings. In addition,
a full suite of custom effects are available for use when showing and
hiding elements or just to add some visual appeal.
Also in: Effects Core | Method Overrides

.addClass()
Adds the specified class(es) to each of the set of matched
elements while animating all style changes.

Blind Effect
The blind effect hides or shows an element by wrapping the
element in a container, and “pulling the blinds”

Bounce Effect
The bounce effect bounces an element. When used with hide or
show, the last or first bounce will also fade in/out.

Clip Effect
The clip effect will hide or show an element by clipping the
element vertically or horizontally.

Drop Effect
The drop effect hides or shows an element fading in/out and
sliding in a direction.
Also in: Effects Core | Methods

.effect()
Apply an animation effect to an element.

Explode Effect
The explode effect hides or shows an element by splitting it into
pieces.

Fade Effect
The fade effect hides or shows an element by fading it.

Fold Effect
The fold effect hides or shows an element by folding it.
Also in: Effects Core | Method Overrides | Methods

.hide()
Hide the matched elements, using custom effects.

Highlight Effect
The highlight effect hides or shows an element by animating its
background color first.

Puff Effect
Creates a puff effect by scaling the element up and hiding it at the
same time.

Pulsate Effect
The pulsate effect hides or shows an element by pulsing it in or
out.
Also in: Effects Core | Method Overrides

.removeClass()
Removes the specified class(es) from each of the set of matched
elements while animating all style changes.

Scale Effect
Shrink or grow an element by a percentage factor.

Shake Effect
Shakes the element multiple times, vertically or horizontally.
Also in: Effects Core | Method Overrides | Methods

.show()
Display the matched elements, using custom effects.

Size Effect
Resize an element to a specified width and height.

Slide Effect
Slides the element out of the viewport.
Also in: Effects Core

.switchClass()
Adds and removes the specified class(es) to each of the set of
matched elements while animating all style changes.
Also in: Effects Core | Method Overrides | Methods

.toggle()
Display or hide the matched elements, using custom effects.
Also in: Effects Core | Method Overrides

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument, while animating all style
changes.

Transfer Effect
Transfers the outline of an element to another element

POWERED BYHERONOTE
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Category: Effects Core
Functionality provided by jquery.ui.effect.js. In addition to the methods
listed below, jquery.ui.effect.js also includes several easings.
Also in: Effects | Method Overrides

.addClass()
Adds the specified class(es) to each of the set of matched
elements while animating all style changes.
Also in: Effects | Methods

.effect()
Apply an animation effect to an element.
Also in: Effects | Method Overrides | Methods

.hide()
Hide the matched elements, using custom effects.
Also in: Effects | Method Overrides

.removeClass()
Removes the specified class(es) from each of the set of matched
elements while animating all style changes.
Also in: Effects | Method Overrides | Methods

.show()
Display the matched elements, using custom effects.
Also in: Effects

.switchClass()
Adds and removes the specified class(es) to each of the set of
matched elements while animating all style changes.
Also in: Effects | Method Overrides | Methods

.toggle()
Display or hide the matched elements, using custom effects.
Also in: Effects | Method Overrides

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument, while animating all style
changes.

POWERED BYHERONOTE
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Category: Interactions
jQuery UI provides a set of mouse-based interactions as building
blocks for rich interfaces and complex widgets.

Draggable Widget
Allow elements to be moved using the mouse.

Droppable Widget
Create targets for draggable elements.
Also in: Utilities

Mouse Interaction
The base interaction layer.

Resizable Widget
Change the size of an element using the mouse.

Selectable Widget
Use the mouse to select elements, individually or in a group.

Sortable Widget
Reorder elements in a list or grid using the mouse.

POWERED BYHERONOTE
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Category: Method Overrides
jQuery UI overrides several built-in jQuery methods in order to provide
additional functionality. When using these overrides, it’s important to
make sure that jQuery UI is loaded. If jQuery UI is not loaded, the
methods will still exist, but the expected functionality will not be
available, resulting in bugs that may be hard to track down.
Also in: Effects | Effects Core

.addClass()
Adds the specified class(es) to each of the set of matched
elements while animating all style changes.
Also in: Methods | UI Core

.focus()
Asynchronously set focus to an element.
Also in: Effects | Effects Core | Methods

.hide()
Hide the matched elements, using custom effects.
Also in: Methods | Utilities

.position()
Position an element relative to another.
Also in: Effects | Effects Core

.removeClass()
Removes the specified class(es) from each of the set of matched
elements while animating all style changes.
Also in: Effects | Effects Core | Methods

.show()
Display the matched elements, using custom effects.
Also in: Effects | Effects Core | Methods

.toggle()
Display or hide the matched elements, using custom effects.
Also in: Effects | Effects Core

.toggleClass()
Add or remove one or more classes from each element in the set
of matched elements, depending on either the class’s presence or
the value of the switch argument, while animating all style
changes.
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Category: Methods
Although jQuery UI is mostly comprised of widgets, interactions, and
effects, there are also a few simple methods that are added for
convenience.
Also in: UI Core

.disableSelection()
Disable selection of text content within the set of matched
elements.
Also in: Effects | Effects Core

.effect()
Apply an animation effect to an element.
Also in: UI Core

.enableSelection()
Enable selection of text content within the set of matched
elements.
Also in: Method Overrides | UI Core

.focus()
Asynchronously set focus to an element.
Also in: Effects | Effects Core | Method Overrides

.hide()
Hide the matched elements, using custom effects.
Also in: Method Overrides | Utilities

.position()
Position an element relative to another.
Also in: UI Core

.removeUniqueId()
Remove ids that were set by .uniqueId() for the set of matched
elements.
Also in: UI Core

.scrollParent()
Get the closest ancestor element that is scrollable.
Also in: Effects | Effects Core | Method Overrides

.show()
Display the matched elements, using custom effects.
Also in: Effects | Effects Core | Method Overrides

.toggle()
Display or hide the matched elements, using custom effects.
Also in: UI Core

.uniqueId()
Generate and apply a unique id for the set of matched elements.
Also in: UI Core

.zIndex()
Get the z-index for an element.
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Category: Selectors
Also in: UI Core

:data() Selector
Selects elements which have data stored under the specified key.
Also in: UI Core

:focusable Selector
Selects elements which can be focused.
Also in: UI Core

:tabbable Selector
Selects elements which the user can focus via tabbing.
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Category: UI Core
Functionality provided by jquery.ui.core.js.
Also in: Selectors

:data() Selector
Selects elements which have data stored under the specified key.
Also in: Methods

.disableSelection()
Disable selection of text content within the set of matched
elements.
Also in: Methods

.enableSelection()
Enable selection of text content within the set of matched
elements.
Also in: Method Overrides | Methods

.focus()
Asynchronously set focus to an element.
Also in: Selectors

:focusable Selector
Selects elements which can be focused.
Also in: Methods

.removeUniqueId()
Remove ids that were set by .uniqueId() for the set of matched
elements.
Also in: Methods

.scrollParent()
Get the closest ancestor element that is scrollable.
Also in: Selectors

:tabbable Selector
Selects elements which the user can focus via tabbing.
Also in: Methods

.uniqueId()
Generate and apply a unique id for the set of matched elements.
Also in: Methods

.zIndex()
Get the z-index for an element.
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Category: Utilities
Also in: Widgets

Widget Factory
Create stateful jQuery plugins using the same abstraction as all
jQuery UI widgets.
Also in: Interactions

Mouse Interaction
The base interaction layer.
Also in: Method Overrides | Methods

.position()
Position an element relative to another.
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Category: Widgets
Widgets are feature-rich, stateful plugins that have a full life-cycle,
along with methods and events. Check out the widget factory
documentation for more details.

Accordion Widget
Convert a pair of headers and content panels into an accordion.

Autocomplete Widget
Autocomplete enables users to quickly find and select from a prepopulated list of values as they type, leveraging searching and
filtering.

Button Widget
Themable buttons and button sets.

Datepicker Widget
Select a date from a popup or inline calendar

Dialog Widget
Open content in an interactive overlay.
Also in: Utilities

Widget Factory
Create stateful jQuery plugins using the same abstraction as all
jQuery UI widgets.

Menu Widget
Themeable menu with mouse and keyboard interactions for
navigation.

Progressbar Widget
Display status of a determinate or indeterminate process.

Slider Widget
Drag a handle to select a numeric value.

Spinner Widget
Enhance a text input for entering numeric values, with up/down
buttons and arrow key handling.

Tabs Widget
A single content area with multiple panels, each associated with a
header in a list.

Tooltip Widget
Customizable, themeable tooltips, replacing native tooltips.
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Easings
Easing functions specify the speed at which an animation progresses
at different points within the animation. jQuery core ships with two
easings: linear , which progresses at a constant pace throughout the
animation, and swing (jQuery core's default easing), which progresses
slightly slower at the beginning and end of the animation than it does in
the middle of the animation. jQuery UI provides several additional
easing functions, ranging from variations on the swing behavior to
customized effects such as bouncing.
Some easings will result in negative values during the animation.
Depending on the properties that are being animated, the actual value
may be clamped at zero. For example, you can animate left to a
negative value, but you cannot animate height or opacity to a
negative value.
The best way to understand how an easing will affect an animation is
to see the equation graphed over time. See below for a graph of all
animations available in jQuery UI.
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