
Guides

These	guides	will	help	you	to	use	the	features	of	eCtune	and	illustrates	how	to	setup	certain	options.

Create	a	basemap
Setting	up	injectors
Tps	calibration
Why	use	a	calibration?
Electronic	boost	controller
Setting	up	scalars
Using	Map	Trails
Using	Snapshot	Manager
Working	with	Secondary	Maps
3-Step

Anti-lag
Full	Throttle	Shift
Launch	Control



Creating	a	basemap

Select	file	->	New	or	press	the	new	basemap	button	on	the	toolbar.

	 	Toolbar	new	button

	New	file	menu	item

eCtune	BaseMap	Creator	-	Parameters

Mapsensor:	Select	a	predefined	mapsenor	or	fill	in	the	min	and	max	mbar.
Note:	If	you	want	to	know	if	you	configuration	is	good.	The	KOEO	mbar	displayed	shouldn't	differ	much
from	the	PA(baro)	mbar
Injector	Setup:	Select	the	injector	size(this	will	adjust	injector	fuel	trim	and	crank	fuel	trim)	select	the
correct	battery	offset	table
Boost	Setup:
																		-Not	Boosted(10	columns)	NA	cars
																		-Boosted:
																															-Boost	columns:	Select	the	amount	of	columns	you	want(max	14).	Your	mapscalars	will
be	setup.	You	can	change	them	later



																															-Boost	cut:	You	can	enable	a	boostcut	during	creation
																															-Boost	fuel:	Boost	fuel	sets	how	much	additional	fuel	to	add	to	the	boost	portion	of	the
basemap.	The	more	efficent	the	turbo	is,	the	higher	you	want	to	set	this	number.	A	good	starting	point	is
usually	120%	
																															-Boost	retard:	This	will	retard	a	specified	amount	timing	per	PSI(starting	at	the	first
boost	column)
Base:	This	will	show	you	whice	codebase	and	version	is	in	the	basemap	creator.
Setup	these	parameters	and	press	"NEXT"

New	BaseMap	Creator	->	Ecu	Type

Here	you	need	to	select	the	ecu	type	you	have.	
This	will	set:
																	-ELD
																	-Baro	sensor
																	-Knock	sensor
																	-Injector	test
																	-O2	heater
																	-VTEC	enable/disable
																	-VTEC	points
																	-Rev	limit	points(cold/hot)
After	selecting	the	ecu	type	press	"NEXT"



New	BaseMap	Creator	->	Base	map

Here	you	select	which	fuel	and	ignition	map	you	will	start	with.	
Ecu:	Which	ecu	the	map	was	orginally
Regoin:	JDM/EDM/USDM/CDN
Engine:	which	engine	the	stock	map	was	designed
Description:	About	the	map
Note:	You	can	select	a	map	with	extended	high	cam	rpm	scale(11000	rpm)	
									These	are	basemap.	Tuning	is	always	required.

After	selecting	the	right	ignition	and	fuel	map	press	"Finish".



Injector	calibration

Injector	Calibration	tool

Parameters/information:
-Old	injector	size
-New	injector	size
-Overall	fuel	trim
-Injector	deadtime	compensation(injector	offset)
-Battery	compensation	table
-Fnl	multiplier:	Injector	fuel	trim(multplier)	due	to	an	other	injector	size

Notes:
1)	You	must	first	setup	your	wideband	to	read	correctly	in	eCtune.
2)	Changing	the	injector	size	adjusts	the	final	multiplier	and	the	cranking	multiplier.	Cranking	multiplier
can	be	adjusted	in	"Fuel	Trims".
3)	Injector	offset	can	be	used	the	adjust	for	injector	latency(In	Fuel	Values).
4)	Overall	fuel	trim	can	be	used	to	add/substract	fuel	op	top	of	injector	trim.

Steps:
-Let	your	car	IDLE
-Put	in	the	information	about	your	injectors.(already	done	if	you	used	the	basemap	creator)
-You	want	to	adjust	injector	offset	and	overall	fuel	trim	during	idle.
-Adjust	injector	offset	and/or	overall	trim	until	you	get	a	reading	round	14.75	afr	or	1	lambda



Tps	calibration

Select	Tools	->	Tps	Calibration

Notes:
-This	only	works	during	KOEO(:	Key	on	engine	off)
-Datalogging	must	be	turned	on

Datalogging	not	connected

if	your	throttle	at	0%	press	"NEXT"

Set	your	throttle	at	100%	and	press	"NEXT"

Press	"Close".	Settings	will	be	saved	in	the	calibration.



You	will	see	your	tps	volt	at	0%	and	at	100%



Why	use	a	calibration?

This	section	details	the	benefits	of	using	a	calibration	file	(.cal)	instead	of	a	.bin	file	for	editing	the	ROM's
parameters.

Note:	Bin	saving	is	only	possible	in	Tuner	Version	of	eCtune	

Calibration	Benefits

Calibration	Holds	all	the	settings	of	the	tune.	
-Tables	
-All	settings	
-Comments	
-EVERYTHING
Calibraitons	are	universal	
Calibration	are	backwards	compatible
Calibration	can	be	opened	in	eCtune,	eCtune	will	use	the	baseRom	stored	in	the	program.
File	extention	*.cal
Tuner	version	can	import/export	calibrations

Example:	
If	you	make	a	tune	with	rombase	0.0.35	and	save	a	calibration.	
Then,	if	you	open	the	calibration	with	an	updated	ectune	version/rombase	e.g.	0.0.37	--	Every	setting	will
be	in	the	new	bin	with	rombase	0.0.37.	New	settings/options	in	0.0.37	rom	that	are	not	in	0.0.35	will	not	be
overwritten.	They	will	have	the	default	values.



Electronic	boost	controller

	



Setting	up	Scalars

Boost	scalar	setup

NOTE:	This	will	adjust	the	map	scalar	for	the	selected	map	set(primary	or	secondary)

Increment:
Start	psi:										The	first	boost	value	for	the	first	column.	Specify	0	here	and	the	first	column	with	get	the
increment.
Increase:										Amount	of	psi	the	load	increments	each	column
Column:											The	first	boost	column
Note:																You	can	specify	1	psi	increment	for	the	first	3psi(e.g.	column	11,12,13)	then	2	psi
increments	for	the	following	4	columns)

Devide:
Coloumn:										Fill	in	the	first	boost	column
Start	pressure:		The	start	psi	for	the	first	given	column	
End	pressure:				End	psi	for	the	last	column
This	will	devide	the	boost	range	over	the	boost	columns	of	your	map



Rpm	scalar	setup

Note:	This	will	adjust	the	currect	rpm	scale.	E.g.	if	low	cam	primary	map	is	selected	this	scalar	will
change

Increment:
Start	rpm:											The	rpm	the	first	given	row	will	get
Increase:													Amount	of	rpm	the	following	row	get	increased
Starting	row:								Which	row	you	start	adjusting
Note:																			You	can	make	the	first	row	increase	e.g.	300	rpm	and	afterward	500	rpm

Devide:
Start	rpm:											The	start	rpm	of	your	rpm	band
End	rpm:												The	end	rpm	of	your	rpm	band
Starting	row:								Start	row
Note:																		The	rpm	band	will	be	devide	into	row(start)	till	the	last	row.



Map	trace	trails

What	is	map	trails?:Map	trails	highlights	the	area	of	the	fuel	maps	where	the	ecu	read	during	a	pull.	This
for	quick	reference	to	find	where	the	afr	was	not	what	you	want.
To	use	live	plot	Rpm	vs	Afr/Boost	wideband	o2	logging	must	be	enabled

Steps	for	map	trails:
Enable	map	trails
Enable	Live	plot	Rpm	vs	Afr/Boost
Make	a	pull(dyno/street)
Look	at	the	plot
Spot	a	wrong	AFR	and	lookup	in	the	table	with	map	trail	where	that	spot	is

Enabling	Map	Trails

Enable	map	trails	by	clicking	the	map	trace	trail	menu	item

Clearing	Map	Trails:

Click	this	icon	to	clear	map	trails
Click	the	menu	item	Clear	Map	Trace	Trail	from	above	screen.	

Example:



At	8000	rpm	you	see	that	the	afr	dipped	to	12.	So	you	need	to	know	fast	where	that	was	read	of	the	fuel
table.
With	map	trails	you	see	where	the	ecu	read	during	a	pull.
You	know	where	the	dip	happend	and	you	can	change	the	2	rows(8000/8300)(mabye	from	column	14	to	the
end)



Snapshot	Manager

What	is	Snapshot	Manager?During	tuning	i	always	used	to	put	names	like	try00,	try001,	try003.	I	did	this
to	save	the	rom	if	i	made	a	lot	of	changes.
Snapshot	manager	does	the	same.	You	save	the	base	then	after	doing	things	you	save	an	other	time.
If	you	don't	like	the	changes	just	roll	back	an	older	version.

To	open	snapshot	manager	go	to	"View"	->	"Snapshot	list"

Click	snapshot	on	the	toolbar

Snapshot	manager

Save:	Click	save	to	save	the	current	rom	as	a	snapshot
Load:	Select	which	snapshot	to	roll	back
Clear:	Remove	all	the	snapshots



Working	with	Secondary	Maps

	



3-Step

Launch	Control
Settings

Type:
-TPS	Based
-VSS	Based

General
Activation	input:	Here	you	can	select	which	input(switch)	you	want	to	you	use	as	activation
																								You	can	choose	"always	off"	to	disable	FTL	or	"always	On"	to	enable	it	full	time
																								This	can	be	a	clutch	swith	or	a	on/off	toggle	switch
TPS	Based:
Tps	based	launch	control	the	driver	can	adjust	the	launch	rpm	on	the	fly.	Just	rev	to	that	rpm	point
and	cross	the	tps	engage	threshold	after	that	you	can	give	less	tps	but	the	lock	will	stay.	If	you	drop
below	the	disengage	threshold	the	lock	is	removed.
Minimum	rpm:	The	mimimum	rpm	for	2-Step	cut	to	work.	Putting	this	to	low(when	always	enabled)	
																						can	cause	ftl	locks	in	city	traffic.	High	tps	and	low	minimum	rpm	will	cause	FTL	to	engage.
Below	vss:								2-Step	will	be	active	below	this	vss
TPS	engage:				If	you	cross	the	tps	therhold	the	rpm	will	be	lock
TPS	disengage:If	you	come	below	this	tps	threshold	the	rpm	lock	will	be	released

VSS	Based:
Launch	rpm:					specified	rpm	where	the	2-Step	will	cut
Below	vss:							speed	at	which	ftl	lock	deactivates.
To	use	clutch	based	just	select	in	activation	input	that	is	connected	to	the	clutch.



Full-Throttle	Shift

Full	Throttle	Shift
Clutch	input:						Select	which	input	is	connected	to	the	clutch
Shift	rpm:										The	rpm	where	the	engine	will	hold	during	shifts.

Note:	If	you	enable	Ignition	cut	or	Ignition	and	fuel	cut	you	keep	your	boost	up	during	shifts(anti-lag	effect)

Anti-Lag

See	anti-lag	setup	guide



Anti-Lag

Anti-lag	Setting

Anti-lag:
Anti-lag	helps	you	build	boost(spool	turbo)	at	the	start	line	when	2-Step	is	active.	
You	can	prestage	on	2-step	and	the	tps		threshold	decides	when	anti-lag	starts.

Enable	anti-lag:										Enables/Disables	anti-lag	feature
Tps	threshold:												Anti-lag	will	start	pulling	timing	and	throw	extra	fuel	above	this	tps	threshold(only
when	2step	active)
Extra	Fuel:																	Amount	of	fuel	to	dump	during	anti-lag(Fuel	value	between	0	-255)
IngitionRetard:												Amount	of	retard	during	anti-lag(postive	value)
Apply	to	final	ignition:	The	anti-lag	value	will	be	substracted	from	the	final	ignition.
																																Otherwise	it	will	be	substracted	from	the	ignition	table	lookup

Note:	Anti-lag	disengage	as	soon	as	the	wheels	spin



eCtune

Installation	of	eCtune
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Error	(MIL)	Codes
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Injector	Calibration
TPS	Calibration
Timing	Sync
Kill	Injectors
Boost	Table	Setup
RPM	Scalar	Setup
MAP	Scalar	Setup
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Table	Editing
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Datalogging
Logging
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Templates
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Datalog	Display
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Datalog	Parameters
Sensor	Setup
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Map	Trace	Trails
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Time	Vs	AFR
RPM	Vs	AFR/Boost
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Smart	Tracking
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Downloading
Upload	Calibration
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Installation	of	eCtune

Content	body



List	of	usable	Outputs

These	are	the	selectable	outpus	for	eCtune.
-Ac	clutch	(A15)
-Purge	valve	(A20)	out->ground
-O2	heater	(A6)	out->ground
-Radiator	Fan	Relay	(A12)		out->ground
-Check	engine	light	(A7)	out->ground
-Fuel	Pump	(A7)	out->ground
-Intake	butterflys	(A17)	out->ground
-Vtec	solenoid	(A4)	out->	12v

Notes:	Most	outputs	can	also	be	inverted.



List	of	usable	Inputs

	
Service	Check	connector	(d4)
Start	Signal	(B9)
Vtec	Pressure	Switch	(D6)
AC	request	(B5)
Brake	Switch	(D2)
Park/Neutral	Input	(B7)

Brake	switch	is	not	available	on	EDM	ecus
Park/Neutral	is		available	on	NON-AUTO	ecu's



Registration

Registration	Window

Fill	in	your	details(name,	organization,	email)	and	press	"Register	Online"
The	information	will	be	received	by	eCtune	Webserver.
After	the	license	payment	is	received	you	will	receive	an	email.

Follow	the	steps	in	the	email	to	complete	the	registration.	If	you	have	
the	reg	key	you	don't	have	to	fill	in	you	infromation.	Just	paste	the	key	in	"Serial	Key",
If	your	key	is	valid	you	will	see	your	name,	organization	and	email.	
"Register	Online"	will	be	disabled.	
Your	software	is	now	registered.	you	can	press	"Close".

Note:	You	need	to	fill	in	a	valid	email	address.	
Your	reg	key	will	be	send	to	that	address.



Shortcut	keys

Content	body



Settings

Content	body



Advanced	Tables

Advanced
Table	IAT	correction

Advanced	Tables:
Most	advanced	tables	are	correction	tables.
Shortcuts:	Ctrl	+	Arrow	up	(increase	selection)
																Ctrl	+	Arrow	down	(decrease	selection)
																Page	up	(increase	selection)
																Page	down	(decrease	selection)

Context	menu:
													Set	Selection
													Adj	Selection(-/+)
													Adj	Selection(%)
													Show	2d	graph



Advance	table	trace

Advance	Table	Trace:
When	datalogging	is	active	you	will	see	in	most	advance	tables	a	trace	where	the	current	ecu	reads.

Advance	table	graph

After	clicking	the	2d	button	or	Right	click	"show	2d	graph",	you	will	see	a	2d	graph	of	the	data.

	



Import/Export

Content	body



Chip	Operations

Content	body



Communication	Errors

Content	body



Error	(MIL)	Codes

Error	Codes

When	you	have	an	error	code:
MIL	led	will	turn	on
MIL	in	the	datalogging	data(parameters)	window	will	turn	ON(RED)	(double	clicking	will	open	the	error
code	window)

To	view	error	codes:
Click	"Error	codes"	on	the	view	toolbar

Click	"View	Error	Codes"	after	right-click	on	the	datalog	grid

Click	"View"	->	"Error	codes"
Shortcut:	CTRL	+	E

Clear	Error	Codes:
Click	"Clear	DTC(error	codes)"	after	right-clicking	on	the	datalog	grid
Click	"Clear	DTC(error	codes)"	after	right-clicking	on	the	error	code	list
Click	"Tools"->"Clear	DTC(error	codes)



Updating	eCtune

Methods	to	update:

During	loading
Force	update
Check	for	update

If	there	is	an	update	and	you	update	your	installation	these	are	the	step	you	will	see.

During	update	you	will	see	this

Finished

After	the	update	completes	the	changelog	will	be	displayed	and	you	will	be	able	to	use	the	latest	version	of
eCtune.



Force	update

To	force	a	update	go	to	Start->	All	programs	->	eCtune	->	eCtune	Force	Update

Start	menu



Check	for	update

To	check	to	see	if	you	are	using	the	latest	version	of	eCtune,	select	Help	->
Check	for	update	from	eCtune's	menu.

eCtune	help	menu

If	there	is	an	update	you	will	see:

If	there	is	no	update	you	will	see:



Check	for	update	on	load

This	setting	allows	eCtune	to	automatically	check	for	updates	when	the	program	is	first	ran.	To	enable	this
feature	in	eCtune,	select	Settings,	then	the	Main	tab.

Loading	screen	eCtune



Tools

Injector	Calibration
Tps	Calibration
Timing	Sync
Kill	Injectors
Boost	Table	Setup
Rpm	Scalar	Setup
Map	Scalar	Setup



Timing	sync

To	Sync	your	ignition	to	16.5	go	to	Tools	->	Ignition	Sync

Startup	screen	ignition	sync

Ignition	sync	lock	16.5	enable

Note:	For	ignition	lock	to	work	an	emulator	must	be	connected	and	real-time	update	enabled.



Kill	Injectors

When	this	feature	is	enables,	the	injectors	will	not	fire.	This	feature	can	be	useful	to	free-air	calibrate	a
wideband	or	measure	your	compression.

Click	Kill	Injectors	to	turn	off	your	fuel	injectors



Boost	table	setup

Boost	Table	Setup

Boost	table	setup:	
1:	Select	which	map	set	you	want	to	adjust
2:	Fuel	Adjustment:
				Boost	fuel	sets	how	much	additional	fuel	to	add	to	the	boost	portion	of	the	basemap.	The	more	efficent
the	turbo	is,	the	higher	you	want	to	set	this	number.	
				A	good	starting	point	is	usually	120%	
3:	Ignition	Adjustment:
				Retard	per	psi:	This	will	retard	a	specified	amount	timing	per	PSI(starting	at	the	first	boost	column)
				Step	retard:	This	will	retard	your	ignition	in	steps.	Lower	boost	less	retard
																						Click	here	to	read	more	on	Step	Retard.	



RPM	scalar	setup

Rpm	scalar	setup

Note:	This	will	adjust	the	currently	selected	rpm	scale.	For	example	if	the	low	cam	primary	map	is	selected,
then	the	scalar	changes	will	be	applied	to	that	table	only.

Increment
Start	rpm:											The	rpm	the	first	given	row	will	get
Increase:													Amount	of	rpm	the	following	row	get	increased
Starting	row:								Which	row	you	start	adjusting
Note:																			You	can	make	the	first	row	increase	e.g.	300	rpm	and	afterward	500	rpm

Divide
Start	rpm:											The	start	rpm	of	your	rpm	band
End	rpm:												The	end	rpm	of	your	rpm	band
Starting	row:								Start	row
Note:																		The	rpm	band	will	be	devide	into	row(start)	till	the	last	row.

	



Map	scalar	setup

Boost	scalar	setup

NOTE:	This	will	adjust	the	map	scalar	for	the	selected	map	set(primary	or	secondary)

Increment
Start	psi:										The	first	boost	value	for	the	first	column.	Specify	0	here	and	the	first	column	with	get	the
increment.
Increase:										Amount	of	psi	the	load	increments	each	column
Column:											The	first	boost	column

Note:You	can	specify	1	psi	increment	for	the	first	3psi	(e.g.	column	11,12,13)	then	2	psi	increments	for	the
following	4	columns.

Divide
Coloumn:										Fill	in	the	first	boost	column
Start	pressure:		The	start	psi	for	the	first	given	column	
End	pressure:				End	psi	for	the	last	column
This	will	divide	the	boost	range	over	the	boost	columns	of	your	map

	



Tables	and	Graphs

Table	Editing
Graphs



Table	Editing

Content	body



Graphs

Graphs	window

Graphs	Context	menu(right-click)

Datalogging	Graphs:

-	Template:	Select	the	template	you	want	to	use	
-	Show	data	at	cursor:	This	will	show	the	data	from	the	plots	at	the	current	cursor.
-	Zoom	In:	This	will	zoom	in	the	datalog
-	Zoom	out:	This	will	zoom	out	if	the	datalog	is	zoomed	in
-	Zoom	full:	this	will	show	the	complete	datalog
-	Set	Marker:	This	will	put	a	cursor	marker	with	data	where	the	mouse	is.	We	scrolling	through	the	log	file
you	can	see	where	you	put	flags(markers)
-	Clear	all	markers:	This	will	remove	all	the	markers	currently	set.



-	Set	plot	start:	This	will	set	the	plot	start	frame(time)
-	Set	plot	end:	This	will	set	the	plot	end	frame(time)
																						Note:	If	a	datalog	is	fully	ploted	you	can	zoom	in	on	a	piece	of	the	log	with	plot	start	and	plot
end

Example	Dyno	Run:	

Full	datalog	

Used	plot	start	at	the	beginning	of	the	run
Used	plot	end	at	the	end	of	the	run

Datalogging	Graphs	Information:

1:	Plotted	graph	start	time
2:	Plotted	graph	end	time
3:	Cursor	time



Graph	Shortcuts:
Left/Right:														Scroll	through	log	file
Ctrl	+	Left:													Move	datalog	cursor	left(small	step)
Ctrl	+	Right:											Move	datalog	cursor	right(small	step)
Ctrl	+	Shift	+	Left:			Move	datalog	cursor	left(large	step)
Ctrl	+	Shift	+	Right:	Move	datalog	cursor	right(large	step)
Ctrl	+	Shift	+	Up:				Zoom	in
Ctrl	+	Shift	+	Down:	Zoom	out



Datalogging

Logging
Graphs
Graph	Templates
Review	Log	File
Datalog	Display
Customize	Datalog	Display
Datalog	Parameters
Sensor	Setup



Logging

Datalogging	Menu

Datalogging	Toolbar

Connect	To	Ecu:	
Click	"Datalog	"->"Connect"
Click	Connect	Icon(first	from	left)	on	the	tool	bar
Note:	If	auto-scan	datalogging	is	enabled	in	setting	it	takes	a	little	longer	to	connect	to	the	ecu.

Record	datalog:
The	datalog	will	be	recored	in	a	temp	log	file(eCtune	diretory	~tmp.elf).
If	eCtune	ever	crashes	you	can	open	that	file	to	review	your	last	log.
Click	"Datalog"	->	"Record"
Click	Record	icon(second	from	left)	on	datalog	toolbar

Save	datalog:
Click	"Datalog"	->	"Save"
Click	Save	icon	on	the	datalog	toolbar

Datalogging	Options(Settings	menu):
Sampling	rate:	Set	how	fast	your	display	will	be	updated.	To	much	data	to	fast	makes	your	screen
unreadable
Load	datalog	after	recording:	If	this	is	enabled	after	recording	the	temporary	log	file	is	loaded	after
recording	stopped.	You	view	graphs	to	see	where	something	went	wrong.
Add	data	and	time	to	log	file:	This	will	add	the	time	and	date	to	filename	when	saving	a	log	file
Record	on	connection:	This	will	start	recording	as	soons	as	a	connection	to	the	ecu	is	made
Play	datalog	on	load:	This	will	start	playing	the	datalog	when	opened

Shortcuts:
Connect	to	ecu:	CTRL	+	ALT	+	D
Record:	CTRL	+	ALT	+	R



Templates

Template	setup

Graph	Templates:
You	can	make	different	templates	to	see	data	you	want	easy.
-	Add:	Click	"Add"	to	add	a	new	template	to	the	template	collection
-	Name:	The	name	of	the	template
-	Remove:	Click	"Remove"	to	remove	the	current	template
-	Graphs:	Enable	how	many	plots	there	will	be	in	this	template
-	Plot1-5:	Select	the	sensor(parameters)	you	want	to	view(also	set	the	color)

Example:
Closeloop(if	you	are	testing	wideabnd	closeloop)
Tuning(to	see	all	important	tuning	sensors)
EBC(to	see	your	duty	and	target/current)



Review	log	file

Datalogging	Toolbar

Review	a	datalog	file:
1:	Open	a	log	file
2:	Close	a	log	file
3:	Play	a	log	file	in	reverse	mode
4:	Play	log	file
5:	Play	log	file	a	in	fast	mode
6:	Pause	a	log	file
7:	Stop	a	log	file
8:	Current	index	time	and	total	log	file	time
9:	Track	bar	to	scroll	through	the	log	file
Note:	during	play	back	you	can	move	the	trackbar



Datalog	Display

Datalogging	display

Datalogging	display:
This	displays	all	nessary	data	you	need	during	tuning.	You	can	customize	this	display(click	here).

Data	Display(example	INJ):
INJ:	Injector	data
Primary	data:	Duty	cycle
Secondary	Data:	Injector	duration
Warning	color:	If	you	setup	warning	colors	in	sensor	setup	the	back	ground	will	color	orange	to	red(click
here).

Context	menu	display	item(Exmaple	right	click	on	o2	display	item)

Context	menu:
Add	Data	display:	This	adds	a	new	data	display(see	customize	display	)
Add	Led	display:	This	adds	a	new	led	display
Remove	o2:	This	removes	the	current	display
Move	left:	Move	the	current	item	one	to	the	left
Move	right:	Move	the	current	item	one	to	the	right
Restore	defaults:	This	restore	the	default	display	items
Show	Secondary	data:	This	enable/disable	secondary	data	for	current	display	item
Note:	Some	display	items	have	extra	options



Customize	Display

Context	menu	display	item

Click	"add	data	display".	You	will	see	the	following	in	your	display	window.(note	if	you	don't	see	it	make
your	display	window	bigger)

Right	click	the	"New"	Item.	Then	go	to	"Set	type"	and	select	the	display	you	want.

Note:	Expect	this	list	to	get	bigger



Datalog	Paramers

Datalogging	Data

Datalogging	Data(Parameters):
This	displays	all	the	data	collected	from	the	ecu.

Context	Menu:
Sensor	Setup
Clear	DTC(error	codes)
View	error	Codes
Log	mininal



Sensor	Setup

Sensor	setup

Sensor	List:	
all	the	datalogging	parameters
Sensor	tag:	The	internal	name	of	the	sensor	in	eCtune
Display	name:	This	name	will	be	displayed	in	the	datalogging	data	window
Description:	Description	for	the	parameter

Sensor	Detail:
Here	you	can	change:	display	name,	sensor	description,	warning	min	and	warning	max.
Warning:	you	can	fill	in	a	min	and	max	value.	The	background(grid/display)	will	go	from	orange	to	red.



Tuner	Tools

Map	Trace	Trails
Live	Plots
Live	Plot	Time	Vs	AFR
Live	Plot	RPM	Vs	AFR/Boost
Live	Plot	RPM	Vs	Accel
Smart	Tracking



Live	plots

Time	Vs	AFR
RPM	Vs	AFR/Boost
RPM	Vs	Accel



Time	vs	AFR

Content	body



RPM	Vs	AFR/Boost

Content	body



RPM	Vs	Accel

Content	body



Smart	Tracking

Content	body



Realtime	programming

Downloading
Upload	Calibration
Upload	Base	ROM
Verify

	



Downloading

Content	body



Upload	Calibration

Content	body



Upload	Base	ROM

Content	body



Verify

Content	body



Rom	Parameters

These	topics	will	guide	you	through	the	rom	parameters

Main	Settings
Fuel	and	Ignition	corrections
Features
Boost	settings



Main	Settings

Rom	options
Map	sensor
Idle	settings
Vtec	settings
IAB	settings
Rev	limits
Fuelcut	settings
Closeloop
Tps	sensor
Comments
Fuel	and	Ign	table	settings
Purge	valve(PCS)



Rom	Options

Rom	options



MAP	Sensor

Map	sensor



Idle	Settings

Idle	settings



VTEC	Settings

VTEC	settings



IAB	Settings

IAB	settings



Rev	Limits

Rev	limits	&	Options



Fuel	Cut	Settings

Fuel	cut
settings



Closeloop

Closeloop
settings



TPS	Sensor

TPS	sensor



ROM	Comments

Here	you	can	add	comments	to	the	calibration.	Comments	are	save	both	in	the	binary(tuner	version)	and
calibration.



Fuel	And	Ign	Table	Settings

Fuel	and
Ignition	Table	settings	



Purge	Valve	(PCS)

Purge
valve(PCS)	Settings

Disable	PCS:	Disables	the	Purge	valve	function	in	the	ECU.
Invert	PCS:	Some	obd2	cars	have	their	PCS	signal	inverted.	You	may	need	to	invert	the	output	otherwise	it
may	cause	the	PCS	to	stay	open	causing	a	vaccum	leak.



Fuel	And	Ignition	Corrections

	

Injector	calibration
Fuel	Trims
ECT	corrections
IAT	corrections
Individual	Cylinder	Corrections
Gear	Corrections
Crank	Fuel	Map
Post	Start	Map
VE	correction
Dwell	Ignition	Corrections
About	Advance	Tables



Injector	Calibration

Injector
calibration



Fuel	Trims

Fuel	Trims



ECT	Corrections

ECT
Corrections



IAT	corrections

IAT
Corrections



Individual	Cylinder	Corrections

Individual	Cylinder	Corrections



Gear	Corrections

Gear	Corrections



Crank	Fuel	Map

Crank
Fuel	Corrections



Post	Start	Map

Post	Start
Correction



VE	Corrections

VE
Corrections	setting



Dwell	Ignition	Corrections

		
Dwell	Ignition	settings



Features

Service	Check	Connector
Fuel	pump	setting
Secondary	Map	settings
Output	Control(General	Purpose	Outputs)

GPO
GPO	Fuel	and	Ignition	Settings

3-Step	Settings

Anti-lag
Full	Throttle	Shift
Launch	Control

MIL	Shiflight
Air	Conditioning
Radiator	Fan	Settings
Anti-Start	Device



Service	check	connector

Service	check	connector	input

SCC	Input:	Use	any	any	input	as	SCC	connector

KOEO	TPS	BASED:	Your	MIL	will	flash	ecu	codes.	
To	flash	codes,	turn	the	key	on,	engine	off	and	press	the	throttle	more	then	50%
To	clear	the	current	error	codes,	press	the	brake	pedal	while	codes	are	flashing.



Fuel	Pump	control

Fuel	Pump	Settings

Fuel	Pump:
Normal:	The	fuel	pump	will	work	as	stock.
													If	you	switch	you	key,	your	pump	will	prime	and	turn	off	again.
													After	starting	your	car	the	fuel	pump	will	turn	back	on(when	starter	signal	input	is	active)
Always	ON:	you	fuel	pump	will	be	on	as	soon	as	your	key	is	ON.
																		This	can	be	usefull	to	drain	your	fuel	tank
Always	OFF:	your	fuel	pump	will	be	always	off
																				This	can	be	usefull	to	free-air	calibrate	a	wideband	or	messure	your	compression(no	fuel	in	the
cylinders)



Secondary	Map	Settings

Secondary	Map	Settings



General	Purpose	output

GPO
Adjustments



Fuel	And	Ignition	Corrections

GPO	fuel	and	ignition	corrections



General	Purpose	Output

General	Purpose	Output	Settings



3-Step	Settings

Launch	control
settings

Anti-lag	Settings

Full	throttle	Shift	Settings

See	3-Step	guide



Full	Throttle	Shift

Content	goes	here



Launch	Control

Content	goes	here



MIL	shiftlight

MIL	Shiftlight	settings



Air	Conditioning

Air	Condition	Settings



Radiator	Fan	Settings

Radiator	Fan	Settings



Anti-Start	Device

Content	goes	here



Boost	settings

Options
Boostcut	Settings
Electronic	Boost	Controller	Settings

EBC	Settings
Solenoid	Sonfiguration
Duty	Lookup	Map
Boost	on	Error	Map
IAT	Compensation	Map
Gear	Based	Target	Maps
RPM	Based	Target	Maps

Manual	Boost	Controller	settings

See	guide	how	to	setup	EBC



Options

Content	goes	here



Boost	Cut	Settings

Boost	Cut	Settings



Electronic	Boost	Controller	Settings

	

EBC	Settings
Solenoid	Configuration
Duty	lookup	map
Boost	on	error	map
IAT	compensation	map
Gear	Based	Target	Maps
Rpm	Based	Target	Maps

See	guide	how	to	setup	EBC



EBC	Settings

EBC	Settings



Solenoid	Configuration

EBC	solenoid	configuration



Duty	Lookup	map

EBC	duty	lookup	map



Boost	on	error	map

EBC	boost	on	error	map



IAT	compensation	map

Content	goes	here



Gear	Based	target	maps

EBC	gear	based	target	maps



Rpm	Based	target	maps

EBC	rpm	based	target	maps



Manual	Boost	Controller

Manual	Boost	Controller	Settings



Snapshot	Manager

See	snapshot	manager	guide
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