
Installation	&	Handling	Exception 	Top	Next

To	install	the	silver-J	onto	your	system,
Double	click	on	the	installer	file	&	click	next	untill	installation	is
finished.

Exception	occured	to	start	the	Silver-J	?

If	you	got	any	error	to	start	the	Silver-J	then	run	the	Silver-J	As
Administrator.because	of	security,If	you	have	installed	the	program	in
to	C:\Program	Files(x86)	folder.

Try	to	install	the	program	in	other	directory	instead	of	C:\Program
Files(x86)	folder.

But	you	can	also	run	program	even	if	you	have	installed	Silver-J	in	to
C:\Program	Files(x86)	folder.	Right	click	on	the	Silver-J.exe	file	&
select	Run	as	administrator	option.



Create	New	Java	Application	Project Previous	Top	Next

To	create	New	Java	Application	project	in	Silver-J	then	go	to
		File	->	New	->	Java	Application	Project
Or	press	key	CTRL+SHIFT+N

This	will	popup	following	dialog	box

Project	Name	:	Enter	your	project	name
Project	Location	:	Select	the	location	folder	where	you	want	to	save	your
project	by	clicking	on	Browse	button.

Create	Java	Class	:	Check	this	check	box	to	add	Java	class	to	the	project.

Click	Finish



Create	New	Java	Applet	Project Previous	Top	Next

To	create	New	Java	Applet	project	in	Silver-J	then	go	to
		File	->	New	->	Java	Applet	Project
Or	press	key	CTRL+ALT+N

This	will	popup	following	dialog	box

Project	Name	:	Enter	your	project	name
Project	Location	:	Select	the	location	folder	where	you	want	to	save	your
project	by	clicking	on	Browse	button.

HTML	File	Name	:	Enter	the	HTML	file	name	for	applet.

Create	Java	Class	:	Check	this	check	box	to	add	Java	class	to	the	project.

Click	Finish



Create	New	Java	Class Previous	Top	Next

Once	project	is	created,
To	create	New	Java	Class	then	go	to
	
			File	->	New	->	Class
This	will	show	following	dialog

Class	Name	:	Enter	the	java	class	name.

Modifiers	:	Select	the	modifiers	of	the	created	class.

Super	Class	:	Enter	the	class	name	that	extends	the	sub	class.



Interface	:	Enter	the	interface	name	that	the	sub	class	may	implement.

Methods	:	If	you	want	to	insert	main	method	of	java	or	to	create	the	constructor
of	given	class	then	check	these	check	boxes.

Create	Class	with	Java	Themes	:	This	is	another	separate	task.In	this	you	only
need	to	enter	the	Class	Name	&	select	one	of	the	theme,it	will	create	itself	the
java	code.

Click	Finish.



Create	Package Previous	Top	Next

To	create	package	go	to
		File	->	New	->	Package

This	will	show	following	dialoag

Package	Name	:	Enter	package	name	that	you	want	to	create	with	(.)	operator.
																											e.g.:	hello.world.button

Class	Name	:	Enter	the	class	name	that	you	want	to	add	to	current	package.

Click	Finish.

If	you	have	already	created	the	package	or	already	added	the	package	to	your
project	and	want	to	add	another	java	class	file	to	that	package	then	go	to

			File	->	New	->	Package

Enter	Class	Name	&	check	the	Add	Class	to	existing	package	check	box.
Select	the	package	name	in	the	list	and	click	Finish.



Adding	Other	Files Previous	Top	Next

Interface	:	To	add	interface	file	to	the	project	then	go	to
																			File	->	New	->	Interface

																	Enter	Interface	Name	&	select	modifier	and	Click	Finish

Enums	:	To	add	Enums	file	to	the	project	then	go	to
																			File	->	New	->	Enums

																	Enter	Enum	Name	&	select	modifier	and	Click	Finish

HTML	File	:	To	add	html	file	to	the	project	then	go	to
																			File	->	New	->	HTML	File

																	Enter	HTML	File	Name	&	Check	the	check	box	if	you	want	to	insert
the	main	html	source	and	Click	Finish

CSS	File	:	To	add	CSS	file	to	the	project	then	go	to
																			File	->	New	->	CSS	File

																	Enter	CSS	File	Name	and	Click	Finish

Text	File	:	To	add	Text	file	to	the	project	then	go	to
																			File	->	New	->	Text	File

																	Enter	Text	File	Name	and	Click	Finish

JavaScript	File	:	To	add	JavaScript	file	to	the	project	then	go	to



																			File	->	New	->	JavaScript	File

																	Enter	JavaScript	File	Name	and	Click	Finish

SQL	File	:	To	add	SQL	file	to	the	project	then	go	to
																			File	->	New	->	SQL	File

																	Enter	SQL	File	Name	and	Click	Finish

XML	File	:	To	add	XML	file	to	the	project	then	go	to
																			File	->	New	->	XML	File

																	Enter	XML	File	Name	and	Click	Finish

New	File	:	To	add	a	file	with	your	own	file	extension	to	the	project	then	go	to
																			File	->	New	->	New	File

																	Enter	File	Name	with	file	extension	and	Click	Finish



Open	Project Previous	Top	Next

To	open	a	project	go	to
			File	->	Open	Project

Or	press	CTRL+SHIFT+O	keys.

Once	file	dialog	is	appeared	then	select	your	project	filename	with	file	extension
.slvjproj	and	click	Open.

e.g	:	If	you	have	created	the	HelloWorld	project	then	the	project	file	name	would
be	HelloWorld.slvjproj

You	can	also	associate	these	project	files	with	Silver-J	application.
	
Go	to	your	project	folder,right	click	on	the	project	file	and	select	Open	With
option	&	select	Silver-J	application	from	installation	folder.

Once	you	associated	the	project	files	with	Silver-J	application	then	you	can	open
your	project	by	just	double	clicking	on	that	project	file.



Open	Files Previous	Top	Next

To	open	other	files	in	the	Silver-J	then	go	to
										File	->	Open	Files
Or	press	CTRL+O	key

Once	file	dialog	is	appeared	then	select	multiple	files	that	you	want	to	open	in
the	Silver-J	&	click	Open.



Load	Sample	Project Previous	Top	Next

If	you	want	to	load	some	sample	project	then	go	to
				File	->	Load	Sample	Project

This	will	show	following	dialog

Silver-J	provides	10	following	sample	java	projects

1)	Basic	Controls	Demo
2)	Bounce	Ball
3)	Buttons	Demo
4)	Calculator
5)	Fonts	Test
6)	Graphics	Test
7)	HTML	Editor	in	Java
8)	Look	And	Feel	Demo
9)	Notepad
10)	Paint	App



Select	any	one	project	from	the	list	and	click	OK.



Saving	Files Previous	Top	Next

Save	:	To	save	current	opened	document	go	to
										File	->	Save
or	press	CTRL+S
or	Right	click	on	the	document	tab	&	select	Save	(filename)	option.

Save	As	:	To	save	current	document	outside	the	application	then	go	to
											File	->	Save	As

Save	All	:	To	save	all	opened	documents	in	application	then	go	to

								File	->	Save	All



Closing	Files	&	Project Previous	Top	Next

To	close	the	current	document	then	go	to
File	->	Close

or	right	click	on	that	document	&	select	Close	options

To	close	all	opened	documents	at	once	then	go	to

		File	->	Close	All

or	right	click	on	any	document	tab	&	select	Close	All	option

You	can	also	close	all	documents	instead	of	current	document	by	right	clicking
on	the	tab	that	you	dont	want	to	close	&	select	Close	All	but	this	option.

To	close	current	opened	project	go	to

		File	->	Close	Project

or	right	click	on	the	Project	name	in	Project	Explorer	&	select	Close	Project
Option

To	delete	current	project	then	go	to



		File	->	Delete	Project

or	right	click	on	the	project	name	in	Project	Explorer	&	select	Delete	option.

	



Change	Case	&	Comment	Line Previous	Top	Next

To	change	the	case	of	selected	text	in	the	editor	then	go	to
Edit	->	Change	Case	->	Upper	Case
Edit	->	Change	Case	->	Lower	Case
Edit	->	Change	Case	->	Sentence	Case

Select	your	appropriate	option	or	Right	click	on	the	editor

To	add/insert	comment	in	the	editor	then	go	to
		Edit	->	Comment	Line	->	Single	Line	Comment
		Edit	->	Comment	Line	->	Multi	Line	Comment

Above	comment	line	functions	will	only	insert	the	comment	at	the	position	in
the	editor.

To	convert	selected	text	into	comment	go	to

Edit	->	Comment	Line	->	Selection	Comment

or	you	can	Right	click	on	the	editor.



Insert	main	function,Class	&	Events Previous	Top	Next

You	can	insert	main()	function	of	java	without	typing	it.this	save	your	time	of
coding.go	to
			Edit	->	Insert	->	main()	Function

You	can	also	insert	the	code	snippet	of	tour	own	class.	go	to
	
			Edit	->	Insert	->	Class

This	will	show	following	dialog

This	wont	create	a	java	file.It	will	just	insert	the	code	snippet	of	class	on	the
provided	information.
To	insert	the	class,select	modifier,enter	class	name,extends	-	superclass	name	&
interface	name	&	click	Insert.

You	can	also	insert	events	into	your	program.	go	to



		Edit	->	Insert	->	Events

This	will	show	following	dialog

Select	the	events	&	click	Insert.



Appearance Previous	Top	Next

You	can	set	different	apperances	to	the	window.go	to
View	->	Appearance

and	select	your	theme.

or	you	can	set	the	appearance	by	going	to

Run	->	Options

Silver-J	provides	following	different	appearances

1)	Default
2)	System
3)	Light
4)	Dark
5)	Night



Compile Previous	Top	Next

To	compile	a	project	go	to
		Run	->	Compile

or	press	ALT+C	key.

There	must	have	a	valid	JDK(Java	Development	Kit)	path.
You	can	change	your	path	by	going	to	Run	->	Options.

Remember	there	must	have	one	java	class	in	your	project	to	compile.

You	can	see	error	on	Errors	List	at	the	bottom.

You	can	change	the	main	class	of	your	project	by	going	to	Run->	Main	Class.
here	you	can	change	the	java	class	that	you	want	to	compile	or	run.



Run	Application Previous	Top	Next

If	your	project	is	of	Application	type	then	to	run	your	project	go	to
Run	->	Run	Application

or	press	ALT+R	key.

There	must	have	a	valid	JDK(Java	Development	Kit)	path.
You	can	change	your	path	by	going	to	Run	->	Options.

Remember	there	must	have	one	java	class	in	your	project	to	run.

You	can	see	error	on	Errors	List	at	the	bottom.

You	can	change	the	main	class	of	your	project	by	going	to	Run->	Main	Class.
here	you	can	change	the	java	class	that	you	want	to	run.



Run	Applet Previous	Top	Next

If	your	project	is	of	Applet	type	then	to	run	your	project	go	to
Run	->	Run	Applet

or	press	ALT+A	key.

There	must	have	a	valid	JDK(Java	Development	Kit)	path.
You	can	change	your	path	by	going	to	Run	->	Options.

Remember	there	must	have	one	java	class	in	your	project	to	run.

You	can	see	error	on	Errors	List	at	the	bottom.

You	can	change	the	main	class	of	your	project	by	going	to	Run->	Main	Class.
here	you	can	change	the	java	class	that	you	want	to	run.



Run	with	Parameters Previous	Top	Next

Silver-J	allows	you	to	run	your	program	with	parameters.
To	run	your	project	by	specifying	parameters	then	go	to
Run	->	Run	with	Parameters

or	press	CTRL+ALT+R	key.

This	will	show	following	dialog

Enter	your	parameters	&	click	Run.



Auto	Compile	Program Previous	Top	Next

When	you	released	the	SPACE	bar	key	then	the	project	is	automatically	get
compile.
To	enable	this	feature	go	to	&	select	following	item
Run	->	Auto	Compile	Program



Add	Files	to	Project Previous	Top	Next

You	can	add	files	to	your	project	by	going	to
Run	->	Add	Files	to	Project

Select	the	files	that	you	want	to	add	to	your	project	&	click	Open.

Remember	when	you	build	your	application	then	these	all	files	will	be	added	to
the	builded	executable	jar	application,but	.java	source	files	will	not	be	added	to
jar	file.

If	you	want	to	add	the	folder	to	your	project	&	also	want	to	add	that	folder	to	the
builded	executable	jar	application	then	copy	your	folder	to	your	project
srcclasses	folder.	That	folder	will	automatically	be	added	to	the	executable	jar
file.



Build	Executable	Jar	Application Previous	Top	Next

If	your	project	is	of	Application	type	then	you	can	build	its	executable	jar
application.
To	build	jar	application	go	to
Run	->	Build

or	press	CTRL+SHIFT+B	key.

You	can	see	your	builded	executable	jar	application	in	build	folder	at	your
project	folder.

See	Add	Files	to	Project	help	contents	for	how	to	add	files	&	folders	to
executable	jar	application.



Preview	HTML	Page	&	View	in	WebBrowser Previous	Top	Next

If	you	are	editing	an	HTML	document	then	you	can	see	it	in	internal	browser	of
Silver-	J.
go	to
Run	->	Preview	HTML	Page

You	can	also	see	the	current	html	document	in	the	webbrowser	by	going	to

		View	->	View	in	Web	Browser

You	can	change	your	browser	at	Options	in	Run	->	Options



Options Previous	Top	Next



To	change	the	options	of	Silver-J	go	to

		Run	->	Options

You	can	change	the	JDK	path,Browser,Font,Auto	Completion,Appearance	etc.



Remove	Added	Files	to	Project Previous	Top	Next

You	can	remove	the	added	files	from	your	project.
Right	click	on	the	project	name	in	Project	Explorer	&	select
Remove	Added	Files	to	Project

This	will	open	a	dialog	box,select	file	name	that	you	want	to	remove	&	click
Remove.



Auto	Completion Previous	Top	Next

This	is	the	feature	of	Silver-J.

When	you	type	a	key	then	the	list	of	that	key	is	popuped	and	you	can	select	the
word	from	that	list.this	saves	a	lot	of	time.

If	you	dont	want	this	feature	then	you	can	disable	it	by	going	to

Run	->	Options

In	Editor	tab,	uncheck	the	Auto	Completion	check	box.

When	you	type	a	character	&	you	dont	see	any	word	in	the	list	then	you	can	add
that	or	any	word	at	a	file	jkeywords.slvjfile	at	installation	folder	in	files	folder.

Open	jkeywords.slvjfile	in	notepad	or	in	any	editor.



Consider	the	word	JFrame	does	not	exists	in	the	list	then	you	can	add	this	word
in	that	file	within	tags	like	this

<JKeyword>JFrame</JKeyword>

then	the	JFrame	word	will	appear	in	that	popup	list.

Remember	the	tag	must	complete	with	</JKeyword>.

Same	way	you	can	also	add	method	to	a	file	by	using	<JMethodKeyword>
</JMethodKeyword>	tag.



Automatic	Object	Creation Previous	Top	

You	can	create	the	object	of	the	given	class	which	is	shown	in	the	popuped	list
by	pressing	F3	key.
When	you	type	the	letter	J,it	will	popup	all	the	list	of	words	that	starts	with	J,e.g
JFrame,JApplet	etc.

If	you	want	to	create	the	object	of	the	selected	item	from	the	popuped	list	then
press	F3	key,it	will	automatically	create	the	object	of	that	selected	item	class.

e.g.	:	If	you	select	the	JApplet	world	in	the	popup	list	&	if	you	press	F3	now	it
will	insert	following	code	into	the	editor	automatically

JApplet	obj1=new	JApplet();
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