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Introduction to ST Visual Programmer (STVP)
STVP is a Windows interface that lets you:
View, edit and save executable files in the Hex (Intel) and .S19
(Motorola) formats, generated by the Assembler, Linker or C
Compiler for ST microcontrollers.
Blank Check EPROM or FLASH contents of ST
microcontrollers.
Program EPROM/EEPROM/FLASH/Option Byte of ST
microcontrollers.
Erase FLASH ST microcontrollers.
View and verify a ST microcontroller's memory contents.
STVP is the user interface for ST EPROM Programming Boards (EPBs)
and ST Development Kits (DVPs) . It is installed on a PC running
Windows® 98, Millennium®, 2000®, NT®, XP® or Vista®, connected to
the EPB or DVP.
Two methods can be used to program ST microcontrollers with STVP:
you can either create a project that defines the programming environment
and procedure to follow, or load data from the master device and then
program it.
We recommend that you use projects, since they provide you with
greater control over the programming procedure.
NOTES:
1: STVP configures itself in order to display only the existing memory
area for each device.
2: Under Windows® NT®4, 2000®, XP® and Vista®, during installation
of STVP, PARSTM driver version is checked and compared to the one
installed on the PC: if PARSTM driver is not installed or PARSTM driver
version is less than 1.5, it will be installed.

Visual environment
Below is a screen shot of the STVP main window with the main areas of
interest highlighted:

The different areas on this screen are:
Title bar: The title bar displays the name of the project
currently opened in STVP. If no project is opened, then 'no
project - STVP' is displayed.
Menu bar: The menu bar contains pull down menus for access
to the principal STVP functions.

Toolbar: The toolbar contains a number of buttons which
provide another means of access to the principal STVP
functions. Place the mouse pointer over a button to display a
popup which describes the function of that button.
Device status area: The device status area displays the
current hardware configuration and settings.
Display area: The display area displays the details that are
stored in the STVP buffer for the currently selected tab (see tab
menu below).
Flash sector area: The flash sector area allows you to select
particular sectors of program memory on which to perform
actions.
Tab menu: The tab menu allows you to display a particular
memory area in the display area.
Output window: The output window displays the tasks that are
performed by STVP as it performs them.
Status bar: The status bar displays the current attributes
associated with the Edit window.
The menu bar, toolbar or information area can be transformed into
independent always-on-top windows with their own headers, as shown
below, by left clicking on their respective move tabs and dragging
them over (or part over) the display area or on to the desktop outside
the frame of the STVP main application window. In this floating form
they may be relocated by mouse dragging on the window title bar or
any unoccupied area in the window. These areas may be resized in
the standard manner by dragging on the edge of the frame (double
arrow cursor indicates resize dimension).
In the same manner these areas may be picked up and repositioned
anywhere in the STVP main application window.
Use the resize cursor to resize the display area, device status window,
flash sector area and output window relative to each other.

Toolbar
The diagram below shows the icons of the toolbar:

NOTE: The Erase icon and the Erase All icon are grayed out if the ST
microcontroller being used doesn't have FLASH memory.

Description of toolbar icons:
Save File icon: Saves the current file.
Open File icon: Opens a file.
Execute File icon: Executes a file in RAM.
Copy icon: Copies the contents of the whole buffer to the
clipboard.
Fill icon: Fills a specified area with a specified value.
Configure icon: Configures Hardware, Port, Programming
mode and Device.
ST microcontroller type list: Lists the ST microcontrollers
that can be programmed with the hardware device that is
currently connected, allowing you to choose one. This is a
shortcut for choosing the ST microcontroller device that is
currently plugged into the socket without opening the
Configuration dialog box.
Read icon: Reads and displays the contents of the ST
microcontroller relating to the currently selected tab (Program
Memory, Data Memory or Option Byte) in the Display area.
Program icon: Programs the information displayed in the
currently selected tab (PROGRAM MEMORY, DATA MEMORY or
OPTION BYTE) in the Display area to the ST microcontroller.
Verify icon: Checks that the information displayed in the
selected tab (PROGRAM MEMORY, DATA MEMORY or OPTION
BYTE) in the Display area is the same as that in the ST
microcontroller that is plugged into the hardware device.
Blank Check icon: Checks that the memory area of the ST
microcontroller plugged into the hardware device has not been
written to.
Erase icon: Erases selected FLASH memory sectors.
Read Area Range icon: Reads the selected area of memory
from the ST microcontroller and displays it in the Display area.
Program Area Range icon: Programs the contents of the
selected memory area to the EPROM, FLASH or EEPROM of
the ST microcontroller.
Verify Area Range icon: Checks that the information of the
selected area of memory (EPROM, FLASH or EEPROM) held in

the STVP buffer is the same as that programmed in the same
area of memory in the ST microcontroller.
Read All icon: Reads the EPROM, FLASH, EEPROM and
Options information from the ST microcontroller and displays it in
the Display area.
Program All icon: Programs the current EPROM, FLASH,
EEPROM and Options data from STVP to the ST microcontroller.
Verify All icon: Checks that the EPROM, FLASH, EEPROM
and Options information in the STVP buffer is the same as that
programmed in the ST microcontroller.

Display area
Displays the details that are stored in the STVP buffer for the currently
selected tab (Program Memory, Data Memory or Option Byte). Rightclicking on this area opens a contextual menu of frequently-used
commands, such as read, program, verify and so on.

Device status area
Displays the current project name (if any), the current hardware
configuration, including hardware programming tool, programming mode,
ST microcontroller device name and PC communication port. It also
shows the program memory, data memory and option byte status of the
selected device. Right-clicking in this area opens a contextual menu with
the refresh and copy commands. The * character at the end of each
memory status name indicate that the area has been modified. If a file is
loaded, this character is removed.

NOTE: To display/hide the device status area select Device Status from
the View menu.

Flash sector area
When the selected ST microcontroller has FLASH memory then this area
is displayed. To select a sector of FLASH memory, click on its check box.
When Active Sector(s) is chosen from the Read, Program, Verify,
Erase or Blank-Check menus, the corresponding action is only
performed on the selected sectors.

NOTE: To display/hide the flash sector area select Flash Sector from the
View menu.

Tab menu
With these tabs, you can display a memory area. Only tabs of existing
memory areas of a device are displayed.
There are different combinations of tab menus, here are two examples:
Device with Program and Data memory:

Device with Program memory and Option Byte:

Output window
Displays the tasks that are performed by STVP as it performs them.
Right-clicking on this area opens a frequently-used commands menu,
enabling you to clear or copy the contents of the output area to the
clipboard.
An example of the output window after loading a file is shown below:

Status bar
The diagram below shows the status bar:

Description of status bar:
Progress bar: Indicates the progress of the current task being
executed by STVP during lengthy operations. A red indicator
indicates that the ST microcontroller is being programmed and
should not be removed. Doing so may damage the programming
device or the ST microcontroller. The progress indicator is green
for other operations.
The progress bar also indicates what the command that is
currently pointed to does.
Address field: Indicates the address of the character on which
the cursor is currently placed in the display area.
Hardware name: Indicates the name of the programming
board currently selected in the Configure ST Visual Programmer
window.
Device name: Indicates the name of the microcontroller
currently selected in the Configure ST Visual Programmer
window.
Programming mode: Indicates the name of the programming
mode selected in the Configure ST Visual Programmer window.

File menu

This command:
Open...
Save
Save As...
RAM Exec
Exit

Does this:
Opens a file.
Saves the currently open file.
Saves the currently open file under a
new name.
Executes a file in RAM.
Exits STVP.

Note: In the Recent File area of the menu will appear a list of the last files
that you used. Clicking on a name in the list opens that file.

Edit menu

This command:

Does this:

Go to...

Moves the cursor to a specified
address.

Search...

Searches for bytes in the current
area.

Copy All

Copies the contents of the selected
area (selected from the tab menu) to
the clipboard.

Fill area

Fills a specified area with a specified
value.

Preferences...

Displays the properties window.

Project menu

This command:
New...
Open...
Save
Edit
Close

Does this:
Creates a new project.
Opens a project file.
Saves a project file.
Edits a project.
Saves and Closes the current project
into a project file.

The list of file names at the bottom of the menu lists the last project files
that you used. Clicking on a name in the list opens that file.

Configure menu
When you select Configure ST Visual Programmer from the Configure
menu (or press the
button), the Configuration dialog box opens.
This dialog box allows you to choose a hardware programming tool, a PC
communication port, a programming mode and a ST microcontroller
device.

1. From the Hardware list, select the programming board hardware that
you are using (the specific EPB or DVP, or STICK).
2. From the Port list, select the parallel port on the host PC to which the
EPB or DVP is connected. Only the ports that are compatible with
the selected hardware are listed.
3. From the Programming mode list, select the programming mode you
want to use. Programming modes available depend upon the
hardware you have, and can include:
Socket - This option means that you wish to program
your target ST MCU using one of the sockets provided
on the EPB or DVP.
ISP -This option is only available with certain EPBs and
DVPs. Choose this option if you wish to use In Situ
Programming to program a device already mounted on
your application board via a flex cable connection

between the EPB/DVP and your application board.
ICP - Only available for FLASH devices. Choose this
option if you wish to use In Circuit Programming to
program a device already mounted on your application
board via a flex cable connection between the EPB/DVP
and your application board. For certain devices, two ICP
modes exists: "ICP OPT Enable" or "ICP OPT Disable",
see the details in programming mode.
4. From the Device list, select the ST microcontroller you want to
program.
5. When some devices in the Device list are selected (such as the
ST7LITE09), an additional Protections list will appear in which you
can choose to protect certain values when programming. However,
most devices do not have this option. Information on RC Calibration
values are given in How to restore default RC Calibration values
topic.
6. Click OK to save your changes and close the dialog box.
7. To view your configuration settings, select Device Status from the
View menu. The Device Status area displays the current
configuration settings.
TIP: You can also select a ST microcontroller from the drop-down
list in the main window toolbar.
NOTE: There are two ways of programming a FLASH or EEPROM
ST microcontroller device. You can program it by plugging it onto
the hardware programming tool socket and selecting the device
name (STxxx) or, you can program it by using the EPB or DVP and
an ISP or ICP connector to your application board and selecting
ISP or ICP programming mode and the device name.

Read menu

Can include the following commands:
This command:

Does this:

Current tab

Reads from the ST microcontroller and
displays the contents of the selected memory
tab.

Active Sector(s)

Reads from the ST microcontroller and
displays the contents of the selected sectors.

Address Range...

Reads from the ST microcontroller and
displays the contents of the selected memory
area from the selected memory tab.

All tabs

Reads from the ST microcontroller the contents
of all existing memory and Option byte
information.

Program menu

Can include the following commands:
This command:

Does this:

Current tab

Writes to the ST microcontroller the contents of
the selected memory tab.

Active Sector(s)

Writes to the ST microcontroller the contents of
the selected sector(s).

Address Range...

Writes to the ST microcontroller the contents of
the selected memory area from the selected
memory tab.

All tabs

Writes to the ST microcontroller the contents of
all existing memory and Option byte
information.

Verify menu

Can include the following commands:
This command:

Does this:

Current tab

Checks that data displayed in selected memory
tab is identical to the corresponding ST
microcontroller memory.

Active Sector(s)

Checks that data displayed in selected
sector(s) is identical to the corresponding ST
microcontroller memory.

Address Range...

Checks that data displayed in the selected
memory area from the current memory tab is
identical to the corresponding ST
microcontroller memory.

All tabs

Checks that all memory data and Option byte
are identical to ST microcontroller contents.

Erase menu

These commands are valid only for FLASH memory of the ST
microcontroller.
Can include the following commands
This command:
Active Sector(s)

Does this:
Erase selected sector(s).

Blank-Check menu

Can include the following commands:
This command:

Does this:

Current tab

Checks that memory data in current tab is not
programmed.

Active Sector(s)

Checks that memory data in selected sector(s)
is not programmed.

View menu
Includes the following commands:
This command:
Toolbar
Status Bar
Device Status

Output

Flash Sector

Does this:
Displays/hides the toolbar. When Toolbar is
checked, the toolbar is displayed.
Displays/hides the status bar. When Status
Bar is checked the status bar is displayed.
Displays/hides the device status window. When
Device Status is checked the device status
window is displayed.
Displays/Hides the output window. When
Output is checked the output window is
displayed.
Displays/Hides the flash sector window. When
Flash Sector is checked the flash sector
window is displayed.

NOTE: The Flash Sector command is grayed out if the ST microcontroller
device in use doesn't have FLASH memory.

Help menu
Includes the following commands:
This command:

Does this:

Index

Presents this STVP online help.

Using Help

Explains how to use Help.

About ...

Gives information about the programming tool
(hardware & software).

A typical programming session
The following instructions describe how you should program a ST
microcontroller using STVP.
Make sure that the ST microcontroller is plugged into the hardware
programming tool socket.
1. Configure STVP.
2. Open the files holding the data to program.
3. Check that the ST microcontroller memory has not already been
programmed: in the STVP main window, click on BlankCheck>Current tab or Blank-Check>Active Sectors. Or you can
also set the "Blank check before programming" option in the
Edit/Preferences dialog box.
4. Execute the programming session: in the STVP main window, click
on All tabs in the Program menu (or press the button).
5. Check that the programing session was successfully completed: in
the STVP main window, click on All tabs in the Verify menu (or
press the button). Or set the "Verify after programming" option in
the Edit/Preferences dialog box.
NOTE: For additional information refer to Using Projects/What is a
project ?.
TIP: Press the ESC key to abort the programming device process.

Checking memory is blank
To blank check memory:
1. Make sure that the ST microcontroller is plugged into the hardware
programming tool socket.
2. Make sure that the hardware is correctly configured, follow the
instructions given in Configuring STVP.
3. To blank check EPROM memory area, click on Current tab in the
Blank-Check menu.
To blank check one or more FLASH sector(s):
a. Select the sector(s) to be blank-checked in the Flash sector
area.
b. Click on Active sector(s) in the Blank-Check menu.
4. The blank check result is displayed in the Output window.

Programming program memory
To program Program memory:
1. Make sure that the ST microcontroller is plugged into the hardware
programming tool socket.
2. Make sure that the hardware is correctly configured by following the
instructions given in Configuring ST Visual Programmer.
3. In the STVP main window, click on the PROGRAM MEMORY tab.
4. Open a file that contains data for a program. You can modify
program memory before writing it to a device.
5. To program all program memory in a FLASH device:
a. Select all sectors in the FLASH sector area.
b. Click on Active Sector(s) in the Program menu (or press the
button).
6. To program all program memory in an EEPROM or EPROM device,
select Program>Current tab from the main menu.
7. Or to program a selected area of program memory:
a. Click on Address Range... in the Program menu (or press the
button). The Address range dialog box opens.
b. In the Valid address ranges are list, choose the predefined
range address you want to program or, enter addresses in the
Start @ and End @ fields.
c. Click on OK.
8. After data has been written into program memory, a verify operation
is done. Any discrepancies are reported in the Output window.
TIP: Program memory is also written by clicking on All tabs in the
Program menu (or pressing the button).
NOTE 1: If any area of the program memory is already
programmed, an appropriate message is displayed in the Output
window.
NOTE 2: To find out if an area is programmed, follow the
instructions given in Checking memory is blank.

Programming data memory
To program Data memory:
1. Make sure that the ST microcontroller is plugged into the hardware
programming tool socket.
2. Make sure that the hardware is correctly configured by following the
instructions given in Configuring ST Visual Programmer.
3. In the STVP main window, click on the DATA MEMORY tab.
4. Open a file that contains data for a program. You can modify data
memory before writing it to a device.
5. To program all data memory, select Program>Current tab from the
main menu.
6. To program a selected data memory area:
a. Select Program>Address Range... from the main menu (or
press the button). The Address range dialog box opens.
b. In the Valid address ranges are list, choose the predefined
range address you want to program or, enter addresses in the
Start @ and End @ fields.
c. Click on OK.
7. After data has been written into data memory, a verify operation is
done. Any discrepancies are reported in the Output window.
TIP: Data memory is also written by clicking on All tabs in the
Program menu (or pressing the button).

Programming the option byte
To program the Option byte:
1. Make sure that the ST microcontroller is plugged into the hardware
programming tool socket.
2. Make sure that the hardware is correctly configured by following the
instructions given in Configuring ST Visual Programmer.
3. In the STVP main window, click on the OPTION BYTE tab. The
available options are listed. ST Mcu option bits have only two states:
0, 1. Unprogrammed states could be 0 or 1 depending on the device.
4. To change the status of an option, click on the option name or its
current setting. Click on the button ( ) which appears beside the
option to display a drop down menu from which you can select a new
setting.

5. Click on Current tab in the Program menu (or press the button).
6. After the Option byte has been written, a verify operation is done.
Any discrepancies are reported in the Output window.
TIP: The Option byte is also written by clicking on All tabs instead
of Current tab in the Program menu (or pressing the button).
NOTE: You can modify option byte settings before writing them to
the device.

Erase FLASH memory sectors
To erase FLASH memory sectors:
1. Make sure that the ST microcontroller is plugged into the
programming socket.
2. Make sure that STVP is correctly configured for the ST
microcontroller by following the instructions given in Configuring ST
Visual Programmer.
3. In the STVP main window, click on the PROGRAM MEMORY tab.
4. For Program memory only: to erase one (or more) FLASH memory
sector(s):
a. In the Flash sector area click the check box(es) corresponding
to the sector(s) you want to erase.
b. Click on Active Sector(s) in the Erase menu (or press the
button).
c. Click on OK.

Viewing a microcontroller's memory contents
and option settings
To view a ST microcontroller's memory contents and option settings:
1. Make sure that the ST microcontroller is plugged into the
programming socket
2. Make sure that STVP is correctly configured for the connected ST
microcontroller by following the instructions given in Configuring ST
Visual Programmer.
3. To view the ST microcontroller's Program memory, Data memory and
Option byte contents, click All tabs in the Read menu (or press the
button). You can now view the read information by clicking on the
appropriate tab at the bottom of the main window.
4. To view the ST microcontroller's Program memory, Data memory or
Option byte contents individually:
a. Click the appropriate tab at the bottom of the main window.
b. Click on Current in the Read menu (or press the button).
5. To view a selected area of the ST microcontroller's EPROM, FLASH
or EEPROM:
a. Click the appropriate tab at the bottom of the main window.
b. Click on Address Range... in the Read menu (or press the
button). The Address Range dialog box opens.
c. Select the area you want to view either by selecting it from the
Valid address ranges are list, or entering its start and end
addresses in the Start @ and End @ fields.
d. Click on OK.
6. To view selected sectors of FLASH memory click the Program
Memory tab, then click on Active sector(s) in the Read menu (or
press the button).
The memory contents are now read and displayed in the Display
area.
TIP: Press the ESC key to abort the reading device process.

Verifying a microcontroller's memory contents
and option settings
Verifying a ST microcontroller's memory and option settings means
checking that its Program memory, Data memory and Option byte
settings are the same as those displayed in the STVP Display area.
To verify a ST microcontroller's memory and option settings:
1. Make sure that the ST microcontroller is plugged into the
programming socket.
2. Make sure that STVP is correctly configured for the ST
microcontroller by following the instructions given in Configuring ST
Visual Programmer.
3. Make sure the file you want to verify is loaded in the STVP main
window.
4. To verify all memory contents, click on All tabs in the Verify menu
(or press the button).
5. To verify an individual memory area click the appropriate tab at the
bottom of the main window, then click on Current tab in the Verify
menu (or press the button).
To verify a selected area of the ST microcontroller's
memory click the appropriate tab at the bottom of the
main window, then click on Address Range... in the
Verify menu (or press the button).
To verify selected sectors of FLASH memory click the
appropriate tab at the bottom of the main window, then
click on Active sector(s) in the Verify menu (or press
the button).
Any discrepancies are reported in the Output window.
TIP: Press the ESC key to abort verifying device process.

How to restore default RC Calibration values
This feature is present on certain ST devices having an Internal RC
oscillator as clock selection.
RC Calibration values are used to get a good frequency accuracy on
internal RC oscillator.
Some ST devices have the default RC Calibration values factory
programmed in the ST Mcu's Program and Data memory.
Restoring the default RC Calibration values in the ST Mcu's Program and
Data memory can be done by enabling and then disabling Read-Out
Protection.
If Read-Out Protection is already disabled, set it to ON in the option byte
settings and program the option byte.
Then set Read-Out Protection back to OFF and reprogram the option
byte.
The default RC Calibration values are then automatically written to the
appropriate addresses in Program and Data memory.
Note: This feature is working only in specific programming modes:
"Socket" or "ICP OPT Disable".
Refer to your STxxxx Datasheet for the default values and addresses.
CAUTION: Any Program or Data in the ST Mcu memory are lost when
Read-Out Protection is disabled.

Opening an executable file
Before opening a file, you need to select the corresponding memory area
to be loaded with data file content. For instance, to open a program
memory area:
1. In the STVP main window, click on the PROGRAM MEMORY tab.
2. Click on Open in the File menu (or press the
button). The Open
dialog box appears.

3. Browse to where you have saved the file holding the data you want
to program, and then select it.
4. Click on Open. When the file is loaded, the Output area displays the
file checksum. The file checksum for each file loaded and the
memory checksum for each area are displayed in the Device Status
window.
5. To open other memory area data files, repeat steps 1 to 4, selecting
the appropriate memory area tab for each data file (DATA MEMORY
or OPTION BYTE) in step 1.
TIP: The names of the last opened files are displayed at the
bottom of the File menu. To open one of these files, click on its
name.

Editing an executable file

Open the file you want to edit by following the instructions given
in Open a file.
You can now modify the program memory contents, data memory
contents or the Option byte settings.
To modify the program memory contents or data memory contents:
1. Click on the appropriate tab at the bottom of the display area.
2. Over type either any hexadecimal values you want to change or any
visible ASCII characters you want to change in the display area.
ASCII characters are automatically updated when you change
hexadecimal characters, and the same vice-versa.
To modify the Option byte settings:
1. Click on the Options tab at the bottom of the main window.
2. The available options are listed in the left hand column with their
value descriptions in the right hand column.
3. ST option bits have only two states: 0, 1. Unprogrammed state could
be 0 or 1 depending on the device. To change the status of an
option, click on the option name or its current setting. Click on the (
) button which appears beside the option to display a drop down
menu from which you can select a new setting.
NOTE: Make sure you save your changes before exiting STVP by
clicking on Save in the File menu (or pressing the
button).

Writing a pattern to a selected memory area
To write a pattern in a selected memory area proceed as follows:
1. Click on Fill area... in the Edit menu (or press the
Choose area & value dialog box is displayed.

button). The

2. In the Fill with field, enter the data you want to fill the area with.
3. Under the Fill Area section, proceed as follows:
To fill the entire program space, select Whole address
space.
To fill a selected area, select Subrange:. Either enter
the start and end addresses of the area to fill in the Start
@ and End @ fields respectively, or select an address
range from the Valid ranges are field.
4. Click on OK. If the address range is valid, STVP fills the specified
address space with the specified fill value.
NOTE: Make sure you save your changes before exiting STVP by
clicking on Save in the File menu (or pressing the
button).

Saving an executable file
Click on Save in the File menu (or press the

button).

With this command, you can create a file in the Motorola or the Intel
format for a project.
TIP: You can also save a file under a new name by clicking on Save As...
on the File menu.

Executing a file in RAM
To execute a file in RAM:
1. Click on RAM Exec in the File menu (or press the
button). The
Open dialog box appears.
2. In the drive list, click the drive that contains the file holding the data
you want to execute.
3. In the box beneath the drive list, double-click the name of the folder
that contains the file you want to execute. Continue double-clicking
subfolders until you open the subfolder that contains the file.
4. In the list of files, click the file you want to execute.
5. Click on Open. When the file is executed, the Output area displays a
message.

What is a project?
A project is a way to automatically configure STVP each time you run it. A
project exists only in a file format that contains STVP commands. This
allows you to set up a programming environment and to define
programming procedures by opening the project file.

A programming environment must or could include:
The programming hardware used to program the ST
microcontroller (EPB, DVP, STICK, etc.). This information is a
mandatory part of the project definition.
The PC port that the programming hardware is connected to
(mandatory).
The Programming mode used (mandatory).
The ST microcontroller to be programmed (mandatory).
The program file that contains the program to be programmed.
The data file that contains the data to be programmed.
The Option Byte file that contains the Option Byte settings to
be programmed.

Programming procedures could include the following actions:
Erase all before programming (FLASH memory device only).
Blank check before programming.
Verify after programming.
Unlock protection before a programming cycle.
Prompt for new programming cycle.
Generate and write serial numbering.
Once the project file is open: to program a device, click on All tabs in the
Program menu.

Create a project
Before creating a project, you must read What is a project ?
To create a project:
1. Click on New in the Project menu. The Create New Project dialog
box opens.
2. In the drive list, click the drive on which you want to create the new
project file.
3. In the box beneath the drive list, double-click the name of the folder
in which you want to create the new project file. Continue doubleclicking subfolders until you open the subfolder in which you want to
create the file.
4. Type the project file name in the File name box.
5. Click on Save.
6. The project is now created (the project file name extension is .stp).
The name of the project appears in the window title bar:

NOTE: When you create a project, it inherits the current
configuration. This configuration can be modified before closing
the project. Closing a project saves it automatically.

Open a project
STVP project files have the file extension .stp.
To open a project:
1. Click on Open in the Project menu. The Open Existing Project
dialog box opens.
2. In the drive list, click the drive that contains the file.
3. In the box beneath the drive list, double-click the name of the folder
that contains the file. Continue double-clicking subfolders until you
open the subfolder that contains the file.
4. In the list of files, click the project file name to open (only files with
.stp extension are displayed).
5. Click on Open. The project name appears in the window title bar:

At this stage, the programming environment is set up and all data
files are opened.
NOTE: Once the project file is open: to program a device, click on
All in the Program menu (or press the button).
TIPS:
The names of the last opened projects are displayed at the
bottom of the Project menu. To open one of these projects,
click on its name.
You can also set up a shortcut to STVP where a specific
project is opened automatically. Just create a shortcut on
your Windows desktop to STVP, right-click the shortcut icon
and select Properties. In the Shortcut tab of the Properties
window, edit the Target line by adding project=project_name.stp to the end of the command line.
For example, to open my_project.stp automatically, the
Target field might look like:
C:\Program Files\stvp\stvp.exe -project=my_project.stp

Editing a project
First, open a project.
1. Click on Edit in the Project menu.
2. The Project Edition window opens. Below is an example of a Project
Edition window with two types of memory area (PROGRAM
MEMORY and Option BYTE) for the chip:

3. Make any necessary modifications to the different tabs of the Project
Edition window: Configuration, Properties, Serial Numbering and
applicable memory area tabs (Program Memory, Data Memory or
Option Byte).
4. Click on OK to exit the Project Edition window and to save your
changes.

Setting a project hardware environment
A project hardware environment defines:
The programming hardware used to program the ST
microcontroller (EPB, DVP, STICK, etc).
The PC port that the programming hardware is connected to.
The programming mode to be used.
The ST microcontroller to be programmed.
To set a project hardware environment:
1. Click on Configure ST Visual Programmer from the Configure
menu (or press the
button). The Configuration dialog box opens:

2. From the Hardware list, select the one you are using (EPB, DVP or
STICK).
3. From the Port list, select the PC port from which STVP is connected.
4. From the Programing mode list, select the programming mode you
want to use.
5. From the Device list, select the ST microcontroller you want to
program.
6. Click OK to save your changes and close the dialog box.
TIP: You can also select a ST microcontroller from the drop-down
list in the main window toolbar.

Setting EPROM, FLASH, EEPROM or Option
files in your project
Data files contain data to program into memory. Setting data files in a
project file (.stp extension), enables these data files to be loaded
automatically each time a project file is open.
To set data files in a project:
1. Click on Edit in the Project menu. The Project Edition window opens
as follows:

NOTE: this is a Project Edition window with two types of memory
area (option byte and program memory) for the device.
2. Click on a memory tab (DATA MEMORY, PROGRAM MEMORY or
OPTION BYTE) and then click on Add.
3. The Open dialog box is displayed.
4. Find and select the file you want to set to the project and click on
Open. The file is set to the project - its path name and other
attributes are displayed in the Project Edition window.

NOTE: this is a Project Edition window with two types of memory
area (data memory and program memory) for the device.
5. Click on OK to save your changes and close the Project Edition
window.
6. Repeat steps 2 to 5 if you want to set files for the DATA MEMORY,
PROGRAM MEMORY or OPTION BYTE memory areas.

Setting up automatic programming procedures
Automatic programming procedures allow you to accomplish the
following actions:
Blank check before programming.
Verify after programming.
Clear memory before loading a file.
Erase device memory before programming.
Display a popup window when an error occurs.
Log activity.
Unlock protection before a programming cycle
Prompt for new programming cycle.
Activate user mode on next project loading.
To set up automatic programming procedures:
1. Click on Edit in the Project menu. The Project Edition window
opens.
2. Click on the Properties tab. The Properties dialog box opens as
shown below (this is a Project Edition window with two types of
memory areas (option byte and program memory) for the device.)

3. Check the Programming Option boxes you want to perform.
Blank check before programming (when available):
This option is only available with FLASH devices.

Verify after programming
Clear memory before loading a file: Checking this
option will clear the existing memory values in your
STVP session when loading a new file. If you do not
check this option, each time you load a new file, only
those memory values also present in the newly loaded
file will be overwritten.
Erase device memory before programming (when
available): This option is only available with FLASH
devices.
Display a popup window when an error occurs
Log activity
Unlock protection before a programming cycle: This
option is only available if a project file is open and on
certain devices. Click this option if you want to unlock the
protection at the beggining of a cycle to be able to
reprogram the device if it was protected before executing
the project.
Prompt for new programming cycle: This option is only
available if a project file is open. Click this option if you
want to repeat the same programming procedure for
several microcontrollers. When this option is checked, a
dialog box will appear at the end of each programming
cycle, asking you if you wish to perform the same
programming cycle again.
Activate secure mode on next project loading: This
option is only available if a project file is open. Checking
this option only allows the programming session saved in
the project file to be performed while the project is open.
This option is useful if you want a specific programming
session to be used repeatedly without tampering. Once
applied, this option can be removed from the Project
Edition window, Properties tab, accessible by selecting
Project>Edit from the main menu.

4. Click on OK to save your changes and close the Project Edition
window.

Setting up automatic serial numbering
STVP can automatically generate and write serial numbers into the
memory of ST microcontrollers. You define automatic serial numbering by
specifying:
the memory address where to program it,
the length (in byte),
the starting value,
the step increment value.
NOTE 1: Each time you leave a project, the current serial number value
is saved. It will be reloaded during the next project opening.
To set up automatic serial numbering:
1. Click on Edit in the Project menu. The Project Edition window
opens.
2. Click on the Serial Numbering tab. The Serial Numbering dialog
box opens:

NOTE: This is a Project Edition window with two types of memory
areas (data memory and program memory) in the device
3. Check the Enable Serial Numbering box.
4. In the Start Address (Hex) field, enter the start address where to
write the serial number.

5. In the Length (in byte) field, select the number of bytes (1, 2, 4 or 8)
of the serial number.
6. In the Base Value (Hex) field, enter the starting value for the serial
number.
7. In the Step (Hex) field, enter the step increment value to apply to the
serial number.
8. Click on OK to save your changes and close the Project Edition
window.

Executing a project programming cycle
If you have defined a project, you can execute a blank check, program all
the memory areas that have associated files in one go, and verify that all
areas have been correctly programmed.
There are two ways of doing this
1. Manually, by using the functions available under the menu bar
To perform a blank check:
With the defined project already open, click on Current
tab or Active Sector(s) in the Blank-Check menu.
To program all the memory areas whose
corresponding files are loaded:
With the defined project already open, click on All tabs
in the Program menu (or press the button).
To verify all programmed areas:
With the defined project already open, click on All tabs
in the Verify menu (or press the button).
2. Automatically, by using the automatic programming procedure.
Refer to the documentation provided with the programming device
you are using for further details about how the blank check,
program and verify are executed.

Troubleshooting

When I try to read or write to the ST microcontroller the message
"Cannot communicate with the device" is displayed:
Check that the port to which the programming device is
connected is correctly configured in STVP.
Note: If you use the LPT port, you must configure this port using
Centronics, EPP, ECP or bidirectional modes only. With Windows® NT®,
2000® and XP®, the PARSTM driver must be installed.
Check that STVP is correctly configured for the programming
device in use.
Check that the ST microcontroller for which STVP is configured
is the same as that which is plugged into the programming
device.
Refer to Configuring ST Visual Programmer for further
information.

When I try to read, program, verify or blank check a ST
microcontroller, the message " ... failed at address XXXX" is
displayed:
Check that the correct device is plugged into the socket or that
STVP is correctly configured for the device in use.
Check that the device isn't defective (change the device).

When I open a project file, the message "Data
displayed:

file not found"

is

Check that data files associated with the project file exist or that data files
have not been moved

When using the STICK, the message “PC parallel port cable not
connected” is displayed:
Most communication failures between the host PC running STVP and the
STICK interface board stem from problems in the parallel port
connection. To prevent communication problems, when setting up your
parallel port connection, ensure that:
You use the parallel cable provided with your STICK—using a
longer parallel cable may cause malfunctions.
Connect the cable directly between the host PC and STICK
interface board— the insertion of additional cables or switch
boxes between the host PC and the interface board may cause
malfunctions.
You remove any parallel port dongles.
Ensure LPT1 address is in the range 03BC-03BF or 0378-037F
or 0278-027F.
Ensure that “printer port LPT1” is not disabled in your PC. For
example, in the IBM® ThinkPad, you can select “infrared printing
(LPT) port on”.

When using the STICK, the message “Problem on supply
voltages” is displayed:
When you have supply voltage problems the green LED will not come on.
To find the cause of the problem:
Check that the AC/DC power supply adaptor is firmly
connected to both the main power supply and to the STICK
interface board. To check that the main power supply is on,
disconnect ICC cable and measure the voltage at test pin 2 at
location TP1. This pin should have unregulated DC value in the
range 18 V to 21 V. (Ground is on TP1 pin 1 which has a white
dot mark.)
Check that the W1 jumper is set on one of the three positions
outlined in the STICK User Manual. If it is set on the “VDD”
position, check that the ICC cable is connected properly and that
your application’s VDD is connected to ICC connector pin 7. Your
application VDD must be in the range 2.4 V to 5 V. On test pin 4
at location TP1, you must have the same voltage value that you
selected with the W1 jumper.
Check that there is 5 V on test pin 3 at location TP1.
If you have made all of these checks and you still get the “Problem on
supply voltages” message, contact your ST distributor or sales office in
order to have your STICK repaired.

When using the STICK, the message “Cannot communicate with
the device” is displayed:
Check that:
The ICC cable is well connected.
You have selected the right ST7 device.
The ICC signals are clear and within the following ranges:
ICCDATA:
This application signal must not drive more
than 1 mA.
ICCCLK:
This application must not drive more than 1 mA.
ICCRESET:
This application must not drive more than
5 mA.
ICCSEL_VPP:
The pull-down resistor must not be lower than
10 kOhm.
You have selected the right programming mode in the main
menu Configure window > programming mode list .
Remember that if you use:
ICP OPT Enable mode, check that your application clock
circuitry does match the CLOCK SOURCE and OSCTYPE
options already programmed in ST7 Flash microcontroller
option byte. For devices out of factory you have to check
these values in datasheet. If you don’t know these values you
have to select ICP OPT Disable.
ICP OPT Disable mode, ensure that external source clock
is a square wave signal from 0 V to VDD. If not, you have to
connect ICCOSC safe clock (ICC connector pin 9) to the
OSC1 pin of the ST7Flash microcontroller in your application.

Other frequently asked questions:
How can I find out which STVP and Hardware configuration file versions
I'm using?

Programming mode
Socket programming mode is used when putting the device in the
EPB/DVP sockets. Take care to place only one device if there are
several sockets.The arrow indicates pin 1 of the device on the
EPB/DVP sockets. If the EPB/DVP support also ISP or ICP
programming mode, remove the flat cable provided with the board
from the ISP or ICP connector to use Socket programming mode.
ISP/ICP programming modes are used when you have soldered your
device on your application board and you want to access the device
afterwards.
ISP stands for In Situ Programming, it is working with
ST72C254xx/ST72C334xx/ST72C171xx and ST72C411xx devices
only. Refer to the Data sheet of the device for more details on ISP
connector and ISP programming. Take care to remove the devices that
are in the socket of the EPB/DVP before using the ISP programming
mode.
ICP stands for In Circuit Programming, it is working with the latest
Flash devices (XFlash or HDFlash). Refer to the data sheet of the
device for more details on ICP connector and In Circuit Programming.
Take care to remove the devices that are in the socket of the EPB/DVP
before using the ICP programming mode.
Before selecting the Programming mode you have to check the
option byte description in your ST Flash microcontroller Data sheet
and also whether the ST is ex-factory or not. Ex-factory devices are
brand new devices with factory default options programmed.
ICP OPT Disable: This programming mode is ICP mode with Option
Bytes Disabled. This means that the setting or state of the device's
option bytes have no effect in application, which the exception of
Read-out Protection. The clock configuration is forced to "External
Source" and if your ST7 Flash application clock is not a square wave
from 0v to VDD (i.e. if you use the internal RC oscillator of the ST7
Flash Microcontroller or if you have a resonator or an external RC

oscillator on the OSC1/OSC2 pins), you have to connect the clock
ICCOSC from the ICC connector to the OSC1 pin of the ST7 Flash
microcontroller in your application. This programming mode is a safe
mode. It must be used when the ICP OPT Enable configuration does
not work. This can be the case if your application clock circuitry
doesn’t match the previously programmed clock source or osctype
option byte selection.
ICP OPT Enable: This programming mode is ICP mode with Option
Bytes Enabled. This means that the option bytes of the ST7 device in
the application are activated with their programmed values. The Readout Protection and the Clock Configuration (OSC Type, OSC Range,
PLL) are Enabled, the Watchdog is forced to Software during
communication. This programming mode has to be selected if the ST7
Flash is has the factory default settings or if your application clock
circuitry matches the previously programmed clock source or osctype
option byte selection. In this Programming mode, the ICCOSC clock
from the ICC connector is not needed.
ICP: This programming mode is the same as ICP OPT Enable, the
Option Bytes are 'Enabled' and the Watchdog is forced to Software
during communication. Normally, this mode is the only choice for that
device because there is no clock configuration, at least a resonator
must be used with that ST7 device. So, the ICCOSC clock from the
ICC connector must not be connected to the application.
Refer to the latest Errata sheet of the device to get extra useful
information.

Choose address
When you select Go to... from the Edit menu, the Choose Address
dialog box appears:

1. Enter the address you want to jump to in the Jump to field.
2. Choose Set cursor in HEXA area if you want the cursor to appear
in the Hexadecimal view or Set cursor in ASCII area if you want the
cursor to appear in the ASCII view.
3. Click on OK. If the address is valid, STVP places the cursor at the
specified address in the display area.
NOTE: Use backspace to clear the input area.

Search bytes
When you select Search... from the Edit menu, the Search bytes dialog
box appears:

1. Click to choose in which view (Hexadecimal or ASCII) you want to
search the bytes.
2. Enter the bytes you want to find in the input area.
3. Click Find next to begin the search. If the search is successful,
STVP places the cursor on the found occurrence in the display area.

Properties window
When you select Preferences from the Edit menu, the Properties window
appears.
Note: These same programming options appear in the Properties tab of
the Project Edition window, which appears when you create or edit a
project.
Click on a property check box to turn on/off that property. Click on OK to
save settings and exit the window.

Check the Programming Option boxes you want to perform.
Blank check before programming (when available): This
option is only available with FLASH devices.
Verify after programming
Clear memory before loading a file: Checking this option will
clear the existing memory values in your STVP session when
loading a new file. If you do not check this option, each time
you load a new file, only those memory values also present in
the newly loaded file will be overwritten.
Erase device memory before programming (when
available): This option is only available with FLASH devices.
Display a popup window when an error occurs

Log activity
Unlock protection before a programming cycle: This option
is only available if a project file is open and on certain
devices. Click this option if you want to unlock the protection
at the beginning of a cycle to be able to reprogram the device
if it was protected before executing the project.
Prompt for new programming cycle: This option is only
available if a project file is open. Click this option if you want
to repeat the same programming procedure for several
microcontrollers. When this option is checked, a dialog box
will appear at the end of each programming cycle, asking you
if you wish to perform the same programming cycle again.
Activate secure mode on next project loading: This option is
only available if a project file is open. Checking this option
only allows the programming session saved in the project file
to be performed while the project is open. This option is
useful if you want a specific programming session to be used
repeatedly without tampering. Once applied, this option can
be removed from the Project Edition window, Properties tab,
accessible by selecting Project>Edit from the main menu.
NOTE 1: The 'Unlock protection before a programming cycle', 'Prompt for
new programming cycle' and 'Activate user mode on next project loading'
options are only available when a project is opened.
NOTE 2: Click on Browse to create or select a log file. The log file name
is displayed in the bottom left hand corner of the Properties window.

Read active sectors
1. Click Flash Sector from the View menu to display the Flash sector
area if not already displayed.
2. Select the sectors you want to read from by clicking on their
respective check boxes
3. Click Active Sector(s) from the Read menu.

Read address range
When you select Address Range... from the Read menu, the Address
range dialog box appears:

1. Choose the area you want to read from either by selecting it from the
Valid address ranges are list, or entering its start and end addresses
in the Start @ and End @ fields.
2. Click on OK. If the address range is valid, STVP reads from the ST
microcontroller and displays the contents of the selected memory
area from the selected memory tab.
NOTE: Use backspace to clear the input areas.

Program active sectors
1. Click on Flash Sector from the View menu to display the Flash
sector area if not already displayed.
2. Select the sectors you want to blank-check by clicking on their
respective check boxes
3. Click on Active Sector(s) from the Program menu.

Program address range
When you select Address Range... from the Program menu, the
Address range dialog box appears:

1. Choose the area you want to program either by selecting it from the
Valid address ranges are list, or entering its start and end addresses
in the Start @ and End @ fields.
2. Click on OK. If the address range is valid, STVP writes to the ST
microcontroller the contents of the selected memory area from the
current memory tab.
NOTE: Use backspace to clear the input areas.

Verify active sectors
1. Click Flash Sector from the View menu to display the Flash sector
area if not already displayed.
2. Select the sectors you want to verify by clicking on their respective
check boxes
3. Click Active Sector(s) from the Verify menu.

Verify address range
When you select Address Range... from the Verify menu, the Address
range dialog box appears:

1. Choose the area you want to verify either by selecting it from the
Valid address ranges are: list, or entering its start and end
addresses in the Start @ and End @ fields.
2. Click on OK. If the address range is valid, STVP checks that data
displayed in the selected memory area is identical to the
corresponding ST microcontroller memory.
NOTE: Use backspace to clear the input areas.

Erase active sectors
1. Click on Flash Sector from the View menu to display the Flash
sector area if not already displayed.
2. Select the sectors you want to erase by clicking on their respective
check boxes
3. Click on Active Sector(s) from the Erase menu.

Blank-Check active sectors
1. Click Flash Sector from the View menu to display the Flash sector
area if not already displayed.
2. Select the sectors you want to be blank-checked by clicking on their
respective check boxes
3. Click Active Sector(s) from the Blank-Check menu.

About ...
This window describes general information concerning STVP. In it, you
can find:
the version number of STVP,
the version number of configuration files (Hardware
Configuration and Target Configuration),
by selecting Modules in the Information combo box, you can
read the version numbers of STVP's DLLs and the PARSTM
driver. The DLL information will appear in the information area.

A typical programming session - configuring
STVP
1. In the Configure menu, click Configure ST Visual Programmer (or
press the
button). The Configuration dialog box opens.
2. From the Hardware list, select the hardware you are using.
3. From the Port list, select the parallel port on the host PC to which
the EPB or DVP is connected. Only the ports that are compatible
with the selected hardware are listed.
4. From the Programming mode list, select the programming mode
you want to use.
5. From the Device list, select the ST microcontroller you want to
program.
6. Click OK to save your changes and close the dialog box.
TIP: You can also select a ST microcontroller type from the dropdown list in the toolbar.

File checksum
This checksum is done on all data present in a data file. This could
include data on a non existing memory area of a ST microcontroller (for
example: EPROM split in two areas).
The file checksum operation is performed simply by calculating the sum
of all of the file's data bytes, giving a unique signature for each file. The
Device Status window shows for all different areas, all the files loaded
with their file checksums.
NOTE: one data file is needed per memory area (EPROM, FLASH,
EEPROM and Option Byte).

Memory checksum
This checksum is done on device existing memory area. Each existing
memory area (EPROM, FLASH and EEPROM) has its own device
checksum.
Each checksum operation is performed simply by calculating the sum of
each device tab data bytes, giving a unique signature for each memory
type.
The Device Status window shows all memory checksums for all memory
types.

Blank Check
You can perform a blank check on the EPROM or FLASH memory area.
When you perform a blank check, you check that the ST microcontroller's
EPROM or FLASH has not been written. This is a useful way of verifying
that a ST microcontroller has not already been programmed.

Verify
STVP can check that the code written to the ST microcontroller EPROM,
FLASH, EEPROM or Options Byte are consistent with that stored in the
files whose contents were used.

Erase
You can perform an automatic erase on a FLASH memory area. This is
the way to erase all information in a FLASH memory area before
programming.

