User and Group Overview
To be able to access, process, and set security in EPS, set up the
following information:
user record
Create a user record for each user. This record includes the user's
name, initials, employee ID number, user group, license numbers,
and other information. An administrative user can also access the
User Biometrics window to scan a user's fingerprint and save it as
part of his or her user record. Users can then use a biometric
device to identify themselves when they log into the system and
start and complete various tasks.
user group
Create user groups for each type of employee (such as
administrator, pharmacist, technician) so that you can add a user
to a group and then define roles and security for that group. For
example, if you create a technician group, you then link all of
your technician user records to that group.
user roles
Link user roles to a user group. User roles determine some of the
security for the system. For example, to enable a user to process
call tasks, you add the corresponding call task user role to that
user's user group.
field-level security
For all of the windows, menu options, tasks, and other
components in EPS that do not have a user role defined on the
User Role window, use field-level security to determine if users in
a specific user group can view, access, or edit a component (such
as a window, field, button, task). Only an administrator with the
Field-Level Security user role can set up field-level security for

other users.
Note: EPS is equipped with an LDAP (Lightweight Directory Access
Protocol) server that communicates with your corporate LDAP server.
When you add or update user and user group records on your local
system, the records are saved to your corporate LDAP server.
Therefore, all stores in your chain have access to a chain-wide
database of user records. This shared database, however, also means
that user group changes affect all stores and you should therefore limit
user group security changes to your corporate system.
See Also
Add a User Record
Add a User Group
User Roles (2.5.01)
User Roles (2.5.02)
Set Up Field-Level Security
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About Personal Health Information (PHI)
Security
In addition to role-based security, EPS audits PHI access, both
internally and in the web applications linked to EPS (the Dashboard,
Audit Monitor, and Message Monitor). This setting must be enabled
in the ECC (Administration > Application Settings > Store
Settings). The system tracks the information listed below. This
information is sent to the KP data warehouse to be used for reports.
Information Captured

Type of Audit
Internal
Web
Audit
Applications
Linked to
EPS

Pharmacy User Information
Window name

•

•

Workstation used to access a window

•

•

Employee number of the user who
entered the window

•

IP address of the computer accessing
the window

•

Date/time stamp indicating when the
user entered the window

•

•

Employee number of the user who
exited the window

•

N/A1

Date/time stamp indicating when the
user exited the window

•

N/A1

Geographic Region

•

•

Geographic Location

•

•

Medical Record Number (MRN)*

•

•

Rx.com ID (from the Electronic
Pharmacy Record - unique across the
chain)*

•

•

Patient Information

Patient ID (local ID from the
pharmacy; unique only to that
pharmacy)*

•

•

KP Rx (Rx Grouping Reference
Number)
If a user enters a window that
displays a list of KP Rx’s, EPS
captures each one displayed, if
applicable.

•

•

Rx Number (see KP Rx)

•

•

Tx Number (see KP Rx)

•

•

1

There is no conclusive way to capture this
* All three of these values might not be available, but at least one must be
present to capture an audit event. If the system cannot capture at least one ID, no
audit event is captured.

See Also
Dashboard
Audit Monitor
Message Monitor
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Add a User Group
Create user groups for each type of employee (such as administrator,
pharmacist, technician) so that you can add a user to a group and then
define roles and security for that group.
To add a user group:
1. Select Administration > Group.
2. Select Add New on the User Group Search window to close the
search window.
3. In the Group Name field on the User Group window, type a
name for the user group record.
Note: You link users to the group name via the User Group option
on the User window.
4. In the Group Description field, type a description of the user
group.
5. For each role you want to remove from the user group, highlight
the role in the Selected Roles column and select Remove >. To
remove all of the roles, select Remove All >>.
The system moves the selected role to the Available Roles
column. To add a role back to the group, highlight the role in the
Available Roles column and select < Add. To add all of the roles
back to the group, select << Add All.
Note: For more information about each available role, see User
Roles.
5. Select Save.
The system saves the user group to your local system. In addition,
the system saves the group to your corporate LDAP server so
other stores in your chain can search for and select the group

record.
See Also
User Overview
User Group Window
User Roles (2.5.01)
User Roles (2.5.02)
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Add a New User
Create a user record for each user and link that user to a user group as
indicated below.
To add a new user:
1. Select Administration > User.
2. Select Add New User.
3. In the Last Name field, type the user's last name.
4. In the First Name field, type the user's first name.
5. In the Initials field, type the user's initials.
6. Enter the user's group in the User Group field.
Notes:
You can select to display the User Group Search window,
where you can search for and select a user group.
The user group determines which tasks the user can perform
in the system. You can create user group records on the User
Group window. For more information, see Add a User Group.
7. In the User Login Code field, type the user's login code.
For example, you can use the first letter of the user's first name
followed by the user's last name.
8. In the Password field, type the user's login password.
Note: The user's password must meet the requirements defined on
the Login Security Requirements window in Application Settings.
9. In the Confirm Password field, retype the user's login
password.

10. In the Employee ID Number field, type the user's companyassigned employee identification number.
11. Enter any additional information as needed.
12. Select Save.
The system saves the user record to your system.
See Also
User Overview
Add User Group
Add User Biometrics
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Add Custom FLS Role
Create a custom field-level security role as indicated below.
To add a new custom field-level security role:
1. Select Administration > Custom FLS Roles.
2. Select Add New.
3. In the Custom FLS Role Name field, type the name of the role.
4. In the Custom FLS Role Description field, type the description
of the role.
5. If you want to copy the securities from another custom fieldlevel security role, select the appropriate role in the Copy Field
Level Securities From field.
6. Select Save.
The system saves the field-level security record to your system.
See Also
Custom FLS Roles Window
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Add User License
For each pharmacist and technician, add the license as needed.
To add a professional license to a user record:
1. Select Administration > User.
2. Use the Select by Employee ID Number field to select an
existing user or select Add New User to add a new user record.
For more information on adding new users, see Add User Record.
3. Select Add License.
The system displays the User Licenses window.
4. Set the State option to the state where the user license was
issued.
5. In the License Number field, enter the user's license number.
6. Set the License Type option to the type of user license: RPh
(Registered Pharmacist) or CPhT (certified Pharmacy
Technician).
7. Select Save.
The system saves the license to the user record and displays the
User window.
See Also
User Overview
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Add User Biometrics
Only administrative users and non-administrative users assigned the
appropriate user role are authorized to add biometrics to a user record.
To add biometrics to a user record:
1. Select Administration > User.
2. For an existing user, enter the user's employee ID number in the
Select by Employee ID Number field and chose Select. To add a
new user, select Add New User. For more information, see Add
User Record.
Note: To allow a non-administrative user to add a user biometric
ID to another user's record, assign the Add User Biometric ID
and Admin Rebill user roles from the User Group field on the
User window.
3. Select Biometrics.
The system displays the User Biometrics window.
4. Have the user place his or her finger on the biometrics device.
The system displays a preview of the fingerprint and prompts the
user to lift and reapply the same finger four additional times.
5. After the fifth time, enter your information in the Employee ID
Number, User Login Code, and Password fields.
6. Select OK.
The system displays the User window.
7. Select Save.
See Also
User Biometrics Window
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Set Up Field-Level Security
For all of the windows, menu options, tasks, and other components in
EPS that do not have a user role defined on the User Role window,
use field-level security. For example, you can determine if users in a
specific user group can view and select a menu option, access a
window, edit or add a record, deactivate or activate a record, approve
a record, or delete a record. Components you can secure include:
fields
drop-down lists
table columns
selectable options, such as checkboxes and radio buttons
menu options and sub-menu options to disable access to an
entire window
(Securing a menu option only disables access. To set a window as
display-only, you must secure every component on the window.
Or you can allow access to the fields and just secure the ability to
save any changes.)
Note: Only an administrator with the Field-Level Security user role
can set up field-level security for other users. Because changes to user
group security affects those same groups at your other stores, we
recommend that you perform these security settings only on your
corporate system.
To set up field-level security for a group:
1. Log into EPS with your administrative user login that has the
field-level security user role.
2. Access the field, menu option, or button you want to secure.
3. With the mouse, select the component (field, menu option,
button).

4. Press CTRL + ALT + SHIFT + right click on the component.
The system displays the Security Settings window.
5. For each user group, highlight a group and use the single-arrow
buttons [ > ] to move that one group to the security level you want
or use the double-arrow buttons [ >> ] to move ALL of the groups
to the same security level as indicated.
To allow users in that group to have full access (view and
use/alter the component, such as using a Save button or altering
a field entry), use the arrow buttons to move the group to the
Groups that can access component column.
To allow users in that group to only view the component so
they cannot alter or use that component, use the arrow buttons
to move the group to the Make components view-only
column.
To prevent users from seeing and using the component, use
the arrow buttons to move the group to the Hide component
value column.
Note: You can use this security level only for text fields, dropdown lists, and columns.
6. After you move all of the groups to the security level you want,
select Save.
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User Roles
To determine which tasks you can perform and which windows,
fields, or buttons you can access, you set up field-level security on
some windows and user roles for other windows/tasks.
For the windows and tasks that require a user role, you must have that
user role in your user group to be able to perform the corresponding
tasks. If you do not have that user role, the system disables the menu
option, field, or button.
Note: The system logs all changes you make to your user and group
roles in the Audit Log table.
The first time you display the window when creating a new group,
EPS displays all roles (Workflow and RapidFill).
The following roles control the ability to access menu options,
windows, fields, and buttons in the system.
Role

Allows you to

ACS Complete

Process ACS Complete tasks
The system creates an ACS Complete task when it receives a message
from the ACS device indicating that a prescription was successfully
filled.

ACS Message
Failed

Process the ACS exception tasks the system creates when it fails to
send a prescription to the ACS device.

ACS Hold

Used by background processes to transmit prescriptions to an ACS
device.

ACS Receive

Receive a response back from the ACS device
The response type is either CNTD (counted) or ERR (error)

ACS Rejected

Process the ACS exception tasks the system creates when the ACS
device rejects a prescription

ACS Xmit

Used for orders with one or more prescriptions that can be filled via the
ACS device and one or more prescriptions that must be filled manually.
When the user at the Fill stations selects Next Task, the system sends
the ACS prescriptions to the ACS device.

Administrative
Role

Administration menu - Communication Settings and Patient Message
Queue options

Call Insurance

Process Call Insurance tasks
If you are not set up for this role and you attempt to select a Call
Insurance task, the system displays the message, Selected task is
checked out or insufficient permissions.

Call Patient

Process Call Patient tasks
If you are not set up for this role and you attempt to select a Call Patient
task, the system displays the message, Selected task is checked out or
insufficient permissions.

Call Pharmacy

Process Call Pharmacy tasks
If you are not set up for this role and you attempt to select a Call
Pharmacy task, the system displays the message, Selected task is
checked out or insufficient permissions.

Call Prescriber

Process Call Prescriber tasks
If you are not set up for this role and you attempt to select a Call
Prescriber task, the system displays the message, Selected task is
checked out or insufficient permissions.

Central Fill
Receive

Access Tools menu - Rx.com Store Delivery (or Central Fill) Receiving
option

Coordination of
Benefits Review

Process Coordination of Benefits (CoB) Review tasks
The system creates a CoB Review task when you receive a response
from a primary or secondary third party and you need to enter
additional information to split bill the claim to the secondary or tertiary
third party.
Note: The Requires Split Bill Review checkbox on the Insurance Plan
Billing window determines whether a plan requires you to enter
additional information before submitting a split billed claim.

Dashboard Admin

Administration > Dashboard menu - Detailed Dashboard option

Data Entry

Process Data Entry tasks
If you are not set up for this role, the system disables the DE task
counter label on the Welcome window.

Downtime Third
Party Exception

Access claims that are in downtime.

Data Verification

Process Data Verification tasks
If you are not set up for this role, the system disables the DV task

counter label on the Welcome window.
Data Verification 2 Process Data Verification 2 tasks
If you are not set up for this role, the system disables the DV2 task
counter label on the Welcome window.
Escript

Process new eScript tasks
The system creates a new eScript task when you receive a new
prescription from a prescriber electronically. If you are not set up for
this role, the system disables the ES task counter label on the Welcome
window.

Background
Exception

Process Error Handling tasks
The system creates an Error Handling task if an error occurs that
prevents a prescription from moving to the next step in the Workflow
process.

Central Fill
Exception

Process exception tasks the system creates for Central Fill prescriptions

Third Party Low
Pay

Process tasks generated to resolve third party low pay claims
You define whether a workstation can receive Low Pay tasks with the
Low Pay checkbox on the Workstation Configuration Workflow
window.

TP Exceptions Lvl
1

Process level 1 third party exceptions
Note: You define the level of third party exceptions with the User Role
drop-down list on the Third Party Exception Routing window.

TP Exceptions Lvl
2

Process level 2 third party exceptions
Note: You define the level of third party exceptions with the User Role
drop-down list on the Third Party Exception Routing window.

TP Exceptions Lvl
3

Process level 3 third party exceptions
Note: You define the level of third party exceptions with the User Role
drop-down list on the Third Party Exception Routing window.

TP Exceptions Lvl
4

Process level 4 third party exceptions
Note: You define the level of third party exceptions with the User Role
drop-down list on the Third Party Exception Routing window.

TP Exceptions Lvl
5

Process level 5 third party exceptions
Note: You define the level of third party exceptions with the User Role
drop-down list on the Third Party Exception Routing window.

Field Level

Assign security at the field, button, or tab level so you can hide, show

Security

as read-only, or allow users to perform the corresponding task

Fill Task

Process Fill tasks in Workflow and RapidFill (using the Opticon
scanner), depending on your system configuration
Perform the Verify NDC Manually task.
If you use Workflow and are not set up for this role, the system disables
the Fill task counter label on the Welcome window.

Inv Mgmt - Create Access Create Orders from Tools > Inventory Management
Orders
If you are not set up for this role, the system does not display the
Create Orders option on the Inventory Management window.
Inv Mgmt - Create Access Create Ret/Adj from Tools > Inventory Management
Ret. Adj.
If you are not set up for this role, the system does not display the
Create Ret/Adj option on the Inventory Management window.
Inv Mgmt - Drug
File

Access Drug File from Tools > Inventory Management
If you are not set up for this role, the system does not display the Drug
File option on the Inventory Management window.

Inv Mgmt Reorder File

Access Drug File > search and select [drug] > Reorder
If you are not set up for this role, when you select Reorder, Insuficient
Access Rights displays, preventing the user from accessing the Reorder
window.

Inv Mgmt Reorder File Add

Add new drug reorder records from Inventory Management > Drug File
> Reorder > Add New Reorder Record

Inv Mgmt Reorder File Edit

Edit existing drug reorder records on the Drug File Reorder window.

Inv Mgmt - Drug
Inv Count

Access the Drug Inventory Count option from Tools > Inventory
Management
If you are not set up for this role, the Drug Inventory Count option
will not appear on the Inventory Management window.

Inv Mgmt - Drug
Inv Count Edit

Edit existing inventory count records on the Inventory Management
Inventory Count window.

Inv Mgmt - Drug
Add or delete inventory count records on the Inventory Management
Inv Count Add-Del Inventory Count window.
Inv Mgmt - List
Orders

Access the List Orders option from Tools > Inventory Management

Inv Mgmt - List
Orders Delete

Access the To Delete checkbox on the Inventory Management List
Orders window.

Inv Mgmt - List
Orders Edit

Edit existing drug orders on the Inventory Management List Orders
window.

Inv Mgmt - List
Ret Adj

Access the List Ret/Adj option from Tools > Inventory Management

Inv Mgmt - List
Ret Adj Edit

Edit existing returns and adjustments on the Inventory Management
List Returns/Adjustments window.

Inv Mgmt Reorder File
Deact-Act

Activate or deactivate drug reorder records in Inventory Management
on the Drug File Reorder window.

Inventory

Access Filecabinet > Drug menu - Reorder option and Tools menu Inventory Management option

Mail Order
Approval

Process Mail Order Approval tasks, where you enter the credit card
authorization number before transmitting an order to Rx.com

New MTM

Enroll patients in Medication Therapy Management programs
If you are not set up for this role, the system disables the MTM button
on the Welcome window.

Order Entry

Perform the tasks available in the Order Entry feature
If you are not set up for this role, the system disables the Order Entry
button on the Welcome window.

Open Call Queue

Access to complete tasks within the Open Call Queue

Patient
Maintenance

Process Patient Maintenance tasks

Product
Verification

Display the next available Product Verification task by scanning the
transaction number in the Tx Number field on the Welcome window
If you are not set up for this role, the system disables the Tx Number
field.

Reports Administrative

Print and edit reports on the Tools > Reports menu that are set up with a
report role of Administrative
Note: You define the report roles for users on the ECC application.

Reports Pharmacist

Print and edit reports on the Tools > Reports menu that are set up with a
report role of Pharmacist

Reports Pharmacy
Manager

Print and edit reports on the Tools > Reports menu that are set up with a
report role of Pharmacy Manager

Reports -

Print and edit reports on the Tools > Reports menu that are set up with a

Technician

report role of Technician

Pharmacist
Counseling

Complete Pharmacist Counseling task
Tools menu - Pharmacist Counseling option, Pharmacist Counseling
window.

Resolve Downtime
Claim

Work Process Adjudication Result tasks generated to resolve downtime
claims submitted to the third party

System Task Administrative

Run system tasks on the Administration > System Tasks menu that are
set up with a role of Administrative.
Note: You define the system task roles for users in the ECC application.

System Task Pharmacist

Run system tasks on the Administration > System Tasks menu that are
set up with a role of Pharmacist.

System Task Pharmacy
Manager

Run system tasks on the Administration > System Tasks menu that are
set up with a role of Pharmacy Manager.

System Task Technician

Run system tasks on the Administration > System Tasks menu that are
set up with a role of Technician.

TP Exception
Queue

Tools > Task Queues menu - TP Exception Queue (CTRL+T) option

Third Party

Access Filecabinet menu - Insurance Plan, Employer, and Workers
Compensation Carrier options
Tools menu - TP Transmit Queue option

Will Call

Access and perform tasks available in the Will Call feature
If you are not set up for this role, the system disables the Will Call
button on the Welcome window.

See Also
User Overview
Add a User Group
User Group Window
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Security Settings Window
To display the Security Settings window, press CTRL + ALT +
SHIFT + right click on the desired field or menu option.
The following describes the fields on the Security Settings window.
Groups that can
access component

Groups in this column have full access and ability to use the
selected component..

Make component
view-only

Groups in this column can view the selected component, but not
edit or use it.

Hide component
value

Groups in this column no longer see the selected component.
Select to move the highlighted group one column over.
Select to move the entire list of groups one column over.
Select to the move the highlighted group back one column.
Select to move the entire list of groups back one column.

Select to save the security settings.
Select to clear the information from the window before saving
the security setting changes.
Component ID

Unique identifier for the field selected.
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User Biometrics Window
To display the User Biometrics window, select Administration >
User > Biometrics.
The following describes the fields on the User Biometrics window.
Employee Name

User's full name

Employee ID
Number

User's company-assigned employee ID number

Fingerprint
Preview

Displays the user's fingerprint when he or she touches the
biometrics device

Employee ID
Number

User's employee ID number

User Login Code

User's login code

Password

User's password

Select to save the user's fingerprint to the user record.
Select to clear the information from the window before saving
the user's fingerprint.
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User Group Window
To display the User Group window, select Administration > Group.
Note: The system displays the User Group Search window when you
initially display the User Group window.
The following describes the fields the User Group window.
Select to display the User Group Search window, where you can
search for an existing user group.
Group Name

Name of the user group record
For example, Pharmacist or Technician.

Group Description Description of the user group record
Selected Roles

Roles that users linked to the displayed group can perform
For example, if you add the Order Entry role, users linked to the
group can access the Order Entry window and create orders.
For a list of the available user roles, see User Roles.
Select to move a highlighted role from the Available Roles
column to the Selected Roles column.
Select to move all roles from the Available Roles column to the
Selected Roles column.
Select to move a highlighted role from the Selected Roles column
to the Available Roles column.
Select to move all roles from the Selected Roles column to the
Available Roles column.

Available Roles

Roles that users linked to the displayed group cannot perform

Show Workflow
Roles

Select to view the available user roles in Workflow.

Copy Field Level
Securities From

Group from which you want to copy existing securities

Select to save a new record or save changes to an existing record.
Select to clear the information you entered and restore the fields
with the last saved information.

/

Select to deactivate or activate the displayed record.
Note: The system displays the Activate button only on records
that have been previously deactivated.

See Also
User Roles
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User Window
To display the User window, select Administration > User.
The following describes the fields on the User window.
Select by Employee User's employee ID number
ID Number
Enter the user's employee ID number and choose Select to
display the employee's user record.
Select to add a new user record.
Note: You must select Add New User before you begin entering
information for the record you want to add.
Add/Edit This User Information
Last Name

User's last name

First Name

User's first name

Middle

User's middle name
Select to display the Use Biometrics window, where you can save
user's fingerprint to their user record.
Note: You must save the user record for the system to enable the
Biometrics button.

Initials

User's initials
Select to enable the user to log into the system.
Note: The system disables the user's ability to log into the system
if the maximum number of consecutive unsuccessful login
attempts.
Select to prevent the user from logging in to the system.
Select to print a barcode containing the employee ID number of
the displayed user. The system prints the barcode to your
Barcode printer.
Note: If you are using the Portable Fill station in RapidFill, you
must scan your employee ID barcode as the first step in the
Portable Fill task.

User Group

User group to which the user is assigned
Note: The user group determines which tasks the user can

perform in the system. You can create user group records on the
User Group window. For more information, see Add User Group
Record.
User Login Code

Code that represents the user
You use this code to log into the system.

Password

User's login password
Note: The user's password must meet the requirements defined
on the Login Security Requirements window in Application
Settings.

Confirm Password User's login password
You must type the user's password in the Confirm Password
field to save a user record.
NPI Number

National Provider Identifier number for the user

Employee ID
Number

Unique identification number for the user

State License Numbers
State

State in which the user license is assigned

License Number

Professional license number of the user (pharmacist or
technician)

Type

Indicates the type of user license number:
Rph = pharmacist
CPhT = certified technician

Deactivated

Date when the user license was deactivated
Highlight an existing user license and select Edit License to
display the User Licenses window.
Select to display the User Licenses window, where you can add a
new user license.

Deactivated

Date the user record was deactivated

Select to save the new record or save changes to an existing
record.
Select to clear the information you entered for a new record or

undo changes you made to an existing record.
Select to deactivate the displayed record.
Select to activate the displayed record.
Note: The system displays the Activate button only on records
that have been previously deactivated.
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Custom FLS Roles Window
To display the Custom FLS Roles window, select Administration >
Custom FLS Roles.
Note: The system displays the Custom FLS Roles Search window
when you initially display the Custom FLS Roles window.
The following describes the fields on the Custom FLS Roles window.
Select to display the Custom FLS Roles Search window, where
you can search for an existing custom field-level security role
record.
Custom FLS Role
Name

Name of the custom field-level security role record
For example, Pharmacist or Technician.

Custom FLS Role
Description

Description of the custom field-level security role record

Copy Field Level
Securities From

Group from which you want to copy existing securities

Select to save a new record or save changes to an existing record.
Select to clear the information you entered and restore the fields
with the last saved information.
/

Select to deactivate or activate the displayed record.
Note: The system displays the Activate button only on records
that have been previously deactivated.
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