


NI	OCR	Training	Interface	Help
February	2007,	370643F-01
The	NI	OCR	Training	Interface	Help	contains	information	about	how	to
use	the	OCR	Training	Interface	to	train	characters,	save	character	sets,
and	verify	characters	by	comparing	them	to	a	reference	character.
For	more	information	about	this	help	file,	refer	to	the	following	topics:
Using	Help
Related	Documentation
Important	Information
Technical	Support	and	Professional	Services
To	comment	on	National	Instruments	documentation,	refer	to	the	National
Instruments	Web	site.
©	2002–2007	National	Instruments	Corporation.	All	rights	reserved.

javascript:WWW(WWW_Feedback)


Using	Help
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Conventions
This	help	file	uses	the	following	conventions:

» The	»	symbol	leads	you	through	nested	menu	items	and
dialog	box	options	to	a	final	action.	The	sequence	File»Page
Setup»Options	directs	you	to	pull	down	the	File	menu,
select	the	Page	Setup	item,	and	select	Options	from	the	last
dialog	box.
This	icon	denotes	a	tip,	which	alerts	you	to	advisory
information.
This	icon	denotes	a	note,	which	alerts	you	to	important
information.

bold Bold	text	denotes	items	that	you	must	select	or	click	in	the
software,	such	as	menu	items	and	dialog	box	options.	Bold
text	also	denotes	parameter	names.

green Underlined	text	in	this	color	denotes	a	link	to	a	help	topic,
help	file,	or	Web	address.

italic Italic	text	denotes	variables,	emphasis,	cross	references,	or
an	introduction	to	a	key	concept.	Italic	text	also	denotes	text
that	is	a	placeholder	for	a	word	or	value	that	you	must
supply.

monospace Text	in	this	font	denotes	text	or	characters	that	you	should
enter	from	the	keyboard,	sections	of	code,	programming
examples,	and	syntax	examples.	This	font	is	also	used	for
the	proper	names	of	disk	drives,	paths,	directories,
programs,	subprograms,	subroutines,	device	names,
functions,	operations,	variables,	filenames,	and	extensions.



Navigating	Help	(Windows	Only)
To	navigate	this	help	file,	use	the	Contents,	Index,	and	Search	tabs	to
the	left	of	this	window	or	use	the	following	toolbar	buttons	located	above
the	tabs:

Hide—Hides	the	navigation	pane	from	view.
Locate—Locates	the	currently	displayed	topic	in	the	Contents	tab,
allowing	you	to	view	related	topics.
Back—Displays	the	previously	viewed	topic.
Forward—Displays	the	topic	you	viewed	before	clicking	the	Back
button.
Options—Displays	a	list	of	commands	and	viewing	options	for	the
help	file.



Searching	Help	(Windows	Only)
Use	the	Search	tab	to	the	left	of	this	window	to	locate	content	in	this	help
file.	If	you	want	to	search	for	words	in	a	certain	order,	such	as	"related
documentation,"	add	quotation	marks	around	the	search	words	as	shown
in	the	example.	Searching	for	terms	on	the	Search	tab	allows	you	to
quickly	locate	specific	information	and	information	in	topics	that	are	not
included	on	the	Contents	tab.



Wildcards
You	also	can	search	using	asterisk	(*)	or	question	mark	(?)	wildcards.
Use	the	asterisk	wildcard	to	return	topics	that	contain	a	certain	string.	For
example,	a	search	for	"prog*"	lists	topics	that	contain	the	words
"program,"	"programmatically,"	"progress,"	and	so	on.
Use	the	question	mark	wildcard	as	a	substitute	for	a	single	character	in	a
search	term.	For	example,	"?ext"	lists	topics	that	contain	the	words
"next,"	"text,"	and	so	on.

Note		Wildcard	searching	will	not	work	on	Simplified	Chinese,
Traditional	Chinese,	Japanese,	and	Korean	systems.



Nested	Expressions
Use	nested	expressions	to	combine	searches	to	further	refine	a	search.
You	can	use	Boolean	expressions	and	wildcards	in	a	nested	expression.
For	example,	"example	AND	(program	OR	VI)"	lists	topics	that	contain
"example	program"	or	"example	VI."	You	cannot	nest	expressions	more
than	five	levels.



Boolean	Expressions
Click	the	 	button	to	add	Boolean	expressions	to	a	search.	The	following
Boolean	operators	are	available:

AND	(default)—Returns	topics	that	contain	both	search	terms.	You
do	not	need	to	specify	this	operator	unless	you	are	using	nested
expressions.
OR—Returns	topics	that	contain	either	the	first	or	second	term.
NOT—Returns	topics	that	contain	the	first	term	without	the	second
term.
NEAR—Returns	topics	that	contain	both	terms	within	eight	words
of	each	other.



Search	Options

Use	the	following	checkboxes	on	the	Search	tab	to	customize	a	search:
Search	previous	results—Narrows	the	results	from	a	search	that
returned	too	many	topics.	You	must	remove	the	checkmark	from
this	checkbox	to	search	all	topics.
Match	similar	words—Broadens	a	search	to	return	topics	that
contain	words	similar	to	the	search	terms.	For	example,	a	search
for	"program"	lists	topics	that	include	the	words	"programs,"
"programming,"	and	so	on.
Search	titles	only—Searches	only	in	the	titles	of	topics.



Printing	Help	File	Topics	(Windows	Only)
Complete	the	following	steps	to	print	an	entire	book	from	the	Contents
tab:

1.	 Right-click	the	book.
2.	 Select	Print	from	the	shortcut	menu	to	display	the	Print	Topics

dialog	box.
3.	 Select	the	Print	the	selected	heading	and	all	subtopics	option.

Note		Select	Print	the	selected	topic	if	you	want	to	print
the	single	topic	you	have	selected	in	the	Contents	tab.

4.	 Click	the	OK	button.



Printing	PDF	Documents
This	help	file	may	contain	links	to	PDF	documents.	To	print	PDF
documents,	click	the	print	button	located	on	the	Adobe	Acrobat	Viewer
toolbar.



Accessing	the	OCR	Training	Interface
You	can	access	the	NI	OCR	Training	Interface	from	the	Start	menu	or
from	within	NI	Vision	Assistant	or	NI	Vision	Builder	for	Automated
Inspection	(Vision	Builder	AI).



From	the	Start	Menu
Complete	the	following	steps	to	launch	the	OCR	Training	Interface	from
the	Start	menu	and	open	an	image	from	which	you	want	to	read
characters.

1.	 Click	Start»All	Programs»National	Instruments»Vision»OCR
Training.

2.	 Click	File»Open	Images,	and	navigate	to	the	file	that	contains	the
image	or	images	from	which	you	want	to	read	characters.	You	can
select	multiple	image	files	by	pressing	the	<Ctrl>	key	and	clicking
each	file.	You	also	can	enable	the	Select	all	files	checkbox	to
open	all	images	in	the	directory	you	specified.

3.	 Click	Open	to	open	the	image	or	images.



From	Vision	Assistant
For	your	convenience,	the	OCR	Training	Interface	opens	from	Vision
Assistant	in	a	wizard	to	guide	you	through	the	creation	of	a	new	template.
Complete	the	following	steps	to	launch	the	OCR	Training	Interface	wizard
in	Vision	Assistant.

1.	 Click	File»Open	Image,	and	navigate	to	the	file	that	contains	the
image	or	images	from	which	you	want	to	read	characters.	You	can
select	multiple	image	files	by	pressing	the	<Ctrl>	key	and	clicking
each	file.	You	also	can	enable	the	Select	all	files	checkbox	to
open	all	images	in	the	directory	you	specified.

2.	 Click	Open	or	double-click	the	image	file	name	to	open	the	file.
3.	 Click	Identification»OCR/OCV,	or	click	OCR/OCV	in	the

Identification	tab	of	the	Processing	Functions	palette,	to	access
the	OCR/OCV	Setup	panel.

4.	 Click	New	Character	Set	File	in	the	Main	tab	of	the	OCR/OCV
Setup	panel.



From	Vision	Builder	AI
The	OCR	Training	Interface	opens	from	Vision	Builder	AI	in	a	wizard	to
guide	you	through	the	creation	of	a	new	template.	Complete	the	following
steps	to	launch	the	OCR	Training	Interface	wizard	in	Vision	Builder	AI.

1.	 Acquire,	or	simulate	the	acquisition	of,	an	image	that	contains	the
characters	you	want	to	read.	Refer	to	the	Vision	Builder	for
Automated	Inspection:	Configuration	Help	for	information	about
acquiring	images	or	simulating	acquisitions.

2.	 In	the	Identify	Parts	tab	of	the	Inspection	Steps	palette,	click
Read/Verify	Text.

3.	 Select	the	Mode	tab	on	the	Read/Verify	Text	Setup	panel,	and
Click	New	Character	Set	File.



OCR	Training	Interface	Tutorial
This	tutorial	walks	you	through	the	steps	for	training	characters	with	OCR
using	a	specific	set	of	images.	This	tutorial	illustrates	the	various	steps
required	to	train	varying	representations	of	the	same	characters.
This	tutorial	includes	the	following	sections:

Training	Characters	with	OCR
Reviewing	Character	Specifications
Saving	the	Character	Set	File



Training	Characters	with	OCR
Complete	the	following	steps	to	train	characters	with	OCR:

1.	 Access	the	OCR	Training	Interface.
2.	 Click	File»Open	Images.
3.	 Complete	one	of	the	following	sets	of	steps	to	select	the	tutorial

images:
NI	Vision	and	Vision	Assistant

a.	 Navigate	to	<Vision>\Images\OCR	Tutorial,	where
<Vision>	is	the	location	to	which	you	installed	the	NI
Vision	Development	Module.

b.	 Select	the	following	images:
NIOCRExample1.tif
NIOCRExample2.tif
NIOCRExample3.tif
NIOCRExample4.tif
NIOCRExample5.tif
Tip		You	can	select	multiple	image	files	by
pressing	the	<Ctrl>	key	and	clicking	each	file.
Enable	the	Select	all	files	checkbox	to	open
all	images	in	the	directory	you	specified.

c.	 Click	Open.
Vision	Builder	AI

a.	 Navigate	to	<Vision	Builder	AI>\DemoImg\OCR,
where	<Vision	Builder	AI>	is	the	location	to	which
you	installed	Vision	Builder	AI.

b.	 Select	the	following	images:
NIOCRExample1.tif
NIOCRExample2.tif
NIOCRExample3.tif
NIOCRExample4.tif
NIOCRExample5.tif
Tip		You	can	select	multiple	image	files	by
pressing	the	<Ctrl>	key	and	clicking	each	file.



Enable	the	Select	all	files	checkbox	to	open
all	images	in	the	directory	you	specified.

c.	 Click	Open.
Tip		Click	each	of	the	image	file	names	above	to	view	the
tutorial	steps	associated	with	the	image.	Click	each	image
to	return	to	the	list	above.

4.	 Use	the	navigation	buttons	to	locate	NIOCRExample1.tif.
5.	 Ensure	that	the	 	Rotated	Rectangle	Tool	is	selected	on	the

OCR	Training	Interface	toolbar.	On	the	image,	draw	a	region	of
interest	(ROI)	around	the	characters.

Tip		When	you	draw	the	ROI,	exclude	the	barcode,	but
ensure	that	the	region	you	draw	is	large	enough	to
encompass	possible	locations	of	characters	in	the	other
images	you	analyze.

OCR	segments	objects	in	the	ROI,	displaying	them	in	blue	and
drawing	character	bounding	rectangles	around	them,	according	to
the	default	settings	on	each	of	the	tabs	at	the	bottom	of	the	dialog
box.	Text	Read	displays	recognized	characters	and	the
substitution	character,	based	on	the	character	set	file	you	are
using,	if	applicable.	If	you	have	not	opened	a	character	set	file	or
trained	any	characters,	Text	Read	displays	the	substitution
character	for	each	of	the	segmented	objects	in	the	ROI.	For
example,	in	the	previous	illustration,	Text	Read	contains	six
substitution	characters.	Any	object	that	is	surrounded	by	a
character	bounding	rectangle	is	a	segmented	object.
You	can	specify	the	substitution	character	in	the	Read	Options
tab.

6.	 Enter	BACE30	in	Correct	String	and	click	Train.
7.	 Navigate	to	the	NIOCRExample2.tif	file.

When	analyzing	this	image,	OCR	uses	the	ROI	you	drew	on	the
NIOCRExample1.tif	image.	Because	the	barcode	in	the
NIOCRExample2.tif	file	is	positioned	differently,	the	ROI
encompasses	part	of	it,	and	OCR	segments	portions	of	the
barcode.



8.	 Enable	the	Reject	Particles	Touching	ROI	checkbox	on	the
Threshold	tab	to	configure	OCR	to	segment	the	characters
correctly	without	segmenting	any	portion	of	the	barcode.

9.	 Set	the	Remove	Particles	(Erosions)	control	to	1.
Setting	this	control	to	1	performs	one	erosion	on	the	image.	An
erosion	decreases	the	size	of	the	objects	in	the	image	by
removing	a	layer	of	pixels	along	the	boundary	of	the	particle.
Performing	an	erosion	helps	to	separate	the	characters	in	the
image	from	the	background	of	the	image.

10.	 Enter	B8F1E9	in	Correct	String	and	click	Train.
11.	 Navigate	to	the	NIOCRExample3.tif	file.

When	analyzing	this	image,	OCR	uses	the	ROI	you	drew	on	the
NIOCRExample1.tif	file	and	the	settings	you	modified	to	correctly
segment	the	characters	in	the	NIOCRExample2.tif	file.

12.	 Verify	that	the	objects	in	the	ROI	are	segmented	correctly.

13.	 Enter	B7ODF4	in	Correct	String	and	click	Train.
14.	 Navigate	to	the	NIOCRExample4.tif	file.

When	analyzing	this	image,	OCR	uses	the	ROI	you	drew	on	the
NIOCRExample1.tif	file	and	the	settings	you	modified	to	correctly
segment	the	characters	in	the	NIOCRExample3.tif	file.	Because
the	character	size	and	spacing	in	the	NIOCRExample4.tif	file	are
different	from	the	character	size	and	spacing	in	the	other	three
files	you	have	used	to	train	characters,	OCR	incorrectly	segments
the	two	instances	of	the	letter	A.

15.	 Use	the	Results	tab	to	view	size	statistics	for	the	two	instances	of
the	letter	A.

16.	 Click	the	Size	&	Spacing	tab.	Based	on	the	character	size
statistics	you	viewed	in	the	Results	tab,	change	Max	for	the
Bounding	Rect	Width.	For	example,	in	the	following	image,	Max
is	set	to	50	for	Bounding	Rect	Width.

17.	 Enter	B85AA6	in	Correct	String	and	click	Train.



18.	 Navigate	to	the	NIOCRExample5.tif	file.
When	analyzing	this	image,	OCR	uses	the	ROI	you	drew	on	the
NIOCRExample1.tif	file	and	the	settings	you	modified	to	correctly
segment	the	characters	in	the	NIOCRExample4.tif	file.

19.	 Verify	that	the	objects	are	segmented	correctly.

20.	 Enter	B8CE72	in	Correct	String	and	click	Train.



Reviewing	Character	Specifications
Use	the	Results	tab	to	view	statistics	about	the	characters	OCR
segmented	in	the	ROI.
The	following	list	includes	descriptions	of	each	of	the	columns	on	the
Results	tab.

Character—Lists	the	index	of	each	of	the	characters	in	the	current
ROI.
Class—Lists,	by	index,	the	character	value	for	each	of	the
characters	you	trained	in	the	current	ROI.
Left	and	Top—List,	by	index,	the	x	and	y	coordinates	of	the	top	left
corner	of	each	of	the	character	bounding	rectangles	in	the	current
ROI.	The	status	bar	in	the	image	viewer	displays	the	Left	and	Top
coordinates	of	the	character	bounding	rectangles	as	you	move	the
mouse	over	the	image.
Width	and	Height—List,	by	index,	the	width	and	height	of	each	of
the	characters	you	trained	in	the	current	ROI.
Size—Lists,	by	index,	the	size	of	the	character	in	pixels.
Class	Score—Lists,	by	index,	a	value	that	indicates	the	degree	to
which	the	assigned	character	class	represents	the	object	value
better	than	other	character	classes	in	the	character	set.	The	range
of	values	is	0	to	1000.
Ident.	Score	(identification	score)—Lists,	by	index,	a	value	that
indicates	how	closely	a	character	matched	its	reference	character
in	the	character	set.	The	range	of	values	is	0	to	1000.	A	value	of
1000	indicates	a	perfect	match	between	an	object	and	the
reference	character.

Note		You	can	set	a	reference	character	for	each	class.
When	you	set	a	reference	character,	OCR	returns	an
identification	score	that	indicates	how	closely	the	character
matched	the	reference	character	for	its	class.	Use	the
identification	score	to	perform	optical	character	verification.
OCR	returns	a	value	of	0	for	the	identification	score	if	you	do
not	set	a	reference	for	a	class.



Saving	the	Character	Set	File
Now	that	you	have	trained	several	characters,	you	are	ready	to	save	the
character	set	file.	Each	character	set	file	contains	the	current	state	of	the
OCR	parameters	as	well	as	the	characters	you	have	trained.

1.	 Use	the	navigation	buttons	to	scroll	through	each	of	the	images
you	used	in	this	tutorial.	Review	each	image	and	the	information
in	Text	Read	to	ensure	the	characters	are	trained	correctly.
Perform	this	step	to	ensure	that	the	parameters	you	have	set	in
OCR	enable	you	to	train	an	optimum	number	of	characters.
Because	you	will	use	this	character	set	file	in	a	reading
procedure,	you	must	ensure	that	it	contains	a	broad	spectrum	of
characters	and	parameters	that	configure	OCR	to	correctly
segment	characters	on	a	broad	variety	of	images.

2.	 Use	the	Edit	Character	Set	File	tab	to	review	and	modify	the
character	set	you	trained.

3.	 Click	File»Save	Character	Set	File,	enter	NIOCRTutorial.abc	in
File	Name	for	the	character	set	file,	and	click	OK	to	save	the
character	set.

Note		You	can	use	the	NIOCRTutorial.abc	character	set	file
in	the	examples	that	are	available	with	OCR.



Training	Characters
Use	the	Train/Read	tab	to	open	images	and	train	characters,	and	save
the	character	values	to	a	character	set	file.
Complete	the	following	steps	to	train	characters:

1.	 Access	the	OCR	Training	Interface.
2.	 Click	File»Open	Images,	and	select	the	image	or	images	you

want	to	use	for	training.	You	can	select	multiple	image	files	by
pressing	the	<Ctrl>	key	and	clicking	each	file.	You	can	also	enable
the	Select	all	files	checkbox	to	open	all	images	in	the	directory
you	specified.

3.	 Click	Open.
4.	 Use	the	navigation	buttons	to	locate	the	image	you	want	to	use	for

training.
5.	 On	the	image,	draw	an	ROI	around	the	characters	you	want	to

train.
Tip		You	can	modify	the	view	of	the	image	if	necessary.

OCR	segments	objects	in	the	ROI,	drawing	character	bounding
rectangles	around	them,	according	to	the	settings	on	each	of	the
tabs	at	the	bottom	of	the	training	interface.	Text	Read	displays
recognized	characters	and	the	substitution	character	based	on	the
character	set	file	you	are	using.	If	you	have	not	opened	a
character	set	file,	Text	Read	displays	the	substitution	character
for	each	of	the	segmented	objects	in	the	ROI.	For	example,	if	the
ROI	contains	three	segmented	objects,	Text	Read	contains	three
substitution	characters.	Any	object	that	is	surrounded	by	a
character	bounding	rectangle	is	a	segmented	object.
You	can	specify	the	substitution	character	in	the	Read	Options
tab.

6.	 Use	the	Threshold,	Advanced	Threshold,	and	Size	&	Spacing
tabs	to	set	up	the	parameters	you	want	to	use	in	the	training
process.	Adjust	threshold	methods	and	settings	and	make
changes	in	the	other	tabs	to	configure	OCR	to	draw	character
bounding	rectangles	around	objects	in	the	ROI	appropriately.
OCR	displays	segmented	objects	in	blue.

7.	 Click	Train	All	Characters.



8.	 In	Correct	String,	enter	the	character	values	you	want	to
associate	with	each	of	the	objects	in	the	ROI	you	specified.	The
number	of	character	values	you	enter	must	match	the	number	of
objects	found	in	the	ROI.

9.	 Click	Train.
10.	 If	Text	Read	displays	incorrect	characters,	adjust	the	parameters

on	the	Threshold,	Advanced	Threshold,	and	Size	&	Spacing
tabs	to	improve	the	results.

11.	 Repeat	steps	3	through	10	to	train	additional	characters.
12.	 Click	File»Save	Character	Set	File,	enter	a	name	for	the

character	set	file,	and	click	Save.
13.	 Use	the	navigation	buttons	to	view	each	image.	Ensure	that	Text

Read	displays	the	correct	characters	for	each	image.	If	Text	Read
displays	the	substitution	character	or	an	incorrect	character,
adjust	the	parameters	on	the	Read	Options	tab	and/or	train	the
incorrect	characters,	and	then	save	the	character	set	file.



Training	Incorrect	Characters
Train	incorrect	characters	when	the	ROI	you	draw	contains	characters
you	already	trained.	For	example,	if	you	analyze	an	image	that	contains
the	letters	A,	P,	and	R	and	you	train	these	letters,	saving	them	to	a
character	set	file,	you	can	later	use	the	character	set	file	to	train
characters	on	another	image.	If	the	second	image	contains	the	letters	A,
P,	R,	and	O,	OCR	displays	the	recognized	characters,	A,	P,	and	R,	and
the	substitution	character	in	Text	Read.
You	also	train	incorrect	characters	when	OCR	displays	the	wrong
character	value	for	a	segmented	object.	For	example,	if	an	ROI	contains
the	letters	A,	P,	R,	and	O	and	Text	Read	includes	the	letter	B	instead	of
P,	you	use	the	Train	Incorrect	Characters	option	to	correctly	train	the
letter	P.
Complete	the	following	steps	to	train	incorrect	characters:

1.	 Access	the	OCR	Training	Interface.
2.	 Click	File»Open	Images,	and	select	the	image	or	images	you

want	to	use	for	training.	You	can	select	multiple	image	files	by
pressing	the	<Ctrl>	key	and	clicking	each	file.	You	can	also	enable
the	Select	all	files	checkbox	to	open	all	images	in	the	directory
you	specified.

3.	 Click	Open.
4.	 Use	the	navigation	buttons	to	locate	the	image	you	want	to	use	for

training.
5.	 On	the	image,	draw	an	ROI	around	the	characters	you	want	to

train.
OCR	segments	objects	in	the	ROI,	drawing	character	bounding
rectangles	around	them,	according	to	the	settings	on	each	of	the
tabs	at	the	bottom	of	the	training	interface.	Text	Read	displays
recognized	characters	and	the	substitution	character	based	on	the
character	set	file	you	are	using.	If	you	have	not	opened	a
character	set	file,	Text	Read	displays	the	substitution	character
for	each	of	the	segmented	objects	in	the	ROI.	For	example,	if	the
ROI	contains	three	segmented	objects,	Text	Read	contains	three
substitution	characters.	Any	object	that	is	surrounded	by	a
character	bounding	rectangle	is	a	segmented	object.



6.	 Use	the	Threshold,	Advanced	Threshold,	and	Size	&	Spacing
tabs	to	set	up	the	parameters	you	want	to	use	in	the	training
process.	Adjust	threshold	methods	and	settings	and	make
changes	in	the	other	tabs	to	configure	OCR	to	draw	character
bounding	rectangles	around	objects	in	the	ROI	appropriately.
OCR	displays	objects	in	blue.

7.	 Click	Train	Incorrect	Characters.
8.	 Enter	the	appropriate	character	values	in	Correct	String,

including	the	previously	trained	and	recognized	characters,	and
click	Train.
Although	you	must	enter	character	values	for	all	segmented
objects	in	Correct	String,	OCR	trains	only	objects	that	do	not
have	a	match	or	have	an	incorrect	match	in	Text	Read.



Training	Single	Characters	or	Patterns
Complete	the	following	steps	to	train	single	characters	or	patterns:

1.	 Access	the	OCR	Training	Interface.
2.	 Click	File»Open	Images,	and	select	the	image	or	images	you

want	to	use	for	training.	You	can	select	multiple	image	files	by
pressing	the	<Ctrl>	key	and	clicking	each	file.	You	can	also	enable
the	Select	all	files	checkbox	to	open	all	images	in	the	directory
you	specified.

3.	 Click	Open.
4.	 Use	the	navigation	buttons	to	locate	the	image	you	want	to	use	for

training.
5.	 On	the	image,	draw	an	ROI	around	the	characters	you	want	to

train.
OCR	segments	objects	in	the	ROI,	drawing	character	bounding
rectangles	around	them,	according	to	the	settings	on	each	of	the
tabs	at	the	bottom	of	the	training	interface.	Text	Read	displays
recognized	characters	and	the	substitution	character	based	on	the
character	set	file	you	are	using.	If	you	have	not	opened	a
character	set	file,	Text	Read	displays	the	substitution	character
for	each	of	the	segmented	objects	in	the	ROI.	For	example,	if	the
ROI	contains	three	segmented	objects,	Text	Read	contains	three
substitution	characters.	Any	object	that	is	surrounded	by	a
character	bounding	rectangle	is	a	segmented	object.

6.	 Use	the	Threshold,	Advanced	Threshold,	and	Size	&	Spacing
tabs	to	set	up	the	parameters	you	want	to	use	in	the	training
process.	Adjust	threshold	methods	and	settings	and	make
changes	in	the	other	tabs	to	configure	OCR	to	draw	character
bounding	rectangles	around	objects	in	the	ROI	appropriately.
OCR	displays	objects	in	blue.

7.	 Click	Train	Single	Character.
8.	 Select	the	Index	of	the	character	you	want	to	train.	OCR	displays

the	character	bounding	rectangle	of	the	corresponding	character
with	a	different	color.

9.	 Enter	the	appropriate	character	value	in	Correct	String.
10.	 Click	Train.



Selecting	an	ROI	Tool	for	OCR
In	OCR	applications,	you	want	to	focus	on	specific	areas	of	the	image.
You	can	define	these	specific	areas	with	region	of	interest	(ROI)	tools.
The	following	tools	are	available	depending	on	the	orientation	of	the	text
in	the	image:

Rotated	Rectangle	ROI	tool—Use	this	tool	to	draw	a	rotatable
rectangle	in	the	image.	Click	and	drag	to	select	a	rectangular
region.	Hold	down	the	<Shift>	key	while	you	click	and	drag	to
contain	the	region	to	a	square,	and	then	click	the	lines	inside	the
rectangle	and	drag	to	adjust	the	rotation	angle.
Annulus	ROI	tool—Use	this	tool	to	draw	an	annulus	in	the	image.
Click	the	center	position	and	drag	to	the	size	you	want.	Adjust	the
inner	and	outer	radii,	and	adjust	the	start	and	end	angles.
The	Annulus	Orientation	control	becomes	available	when	you
select	the	Annulus	ROI	tool.	Choose	one	of	the	following	options.

Baseline	Inside—Select	this	option	when	the	imaginary	line
on	which	the	bottoms	of	the	letters	align	is	closer	to	the
center	of	the	annulus.
Baseline	Outside—Select	this	option	when	the	imaginary
line	on	which	the	bottoms	of	the	letters	align	is	closer	to	the
outside	of	the	annulus.



Setting	Up	the	Threshold
Use	the	settings	on	the	Threshold	tab	to	determine	how	you	want	OCR
to	calculate	the	threshold	value	it	uses	to	segment	objects	on	an	image.
Complete	the	following	steps	to	set	up	thresholding:

1.	 Click	Threshold,	and	select	a	threshold	Mode:
Fixed	Range—A	method	in	which	you	manually	determine
the	threshold	value	for	the	entire	ROI.
Uniform—A	method	in	which	OCR	calculates	a	single
threshold	value	for	the	entire	ROI.
Linear—A	method	in	which	OCR	divides	an	ROI	into	the
number	of	blocks	you	specify,	calculates	a	threshold	value
for	the	first	and	last	boxes,	then	linearly	interpolates	values
for	the	blocks	in	between.
Non	Linear—A	method	in	which	OCR	divides	the	ROI	into
the	number	of	blocks	you	specify,	and	calculates	a
threshold	value	for	each	block.	Specify	the	number	of
blocks	on	the	Advanced	Threshold	tab.

2.	 If	you	selected	Fixed	Range	in	Mode,	use	Min	and	Max,	or	the
slider	at	the	bottom	of	the	histogram,	to	set	the	threshold	value.

3.	 If	you	selected	Uniform,	Linear,	or	Non	Linear	in	Mode,	select
Dark	on	Light	in	Characters	if	the	image	contains	dark
characters	on	a	light	background.	Select	Light	on	Dark	in
Characters	if	the	image	contains	light	characters	on	a	dark
background.

4.	 Enable	the	Reject	Particles	Touching	ROI	checkbox	to	ignore
particles	that	are	touching	the	border	of	the	ROI	you	drew.

5.	 In	Remove	Particles	(Erosions),	select	the	number	of	erosions
you	want	OCR	to	perform	to	remove	small	particles	from	the	ROI.
As	you	manipulate	settings	on	the	Threshold	tab,	OCR	displays
segmented	objects	in	blue.

Tip		If	the	objects	in	the	ROI	are	not	segmented	as	you
expect	them	to	be,	experiment	with	settings	on	the
Threshold,	Advanced	Threshold,	and	Size	&	Spacing	tabs
to	improve	the	segmentation.



Setting	Up	the	Advanced	Threshold
Use	the	Advanced	Threshold	tab	to	set	up	additional	options	for	the
Non-Linear	threshold	methods.	If	you	selected	Fixed	Range	in	Mode	on
the	Threshold	tab,	the	options	on	the	Advanced	Threshold	tab	are	not
available.
Complete	the	following	steps	to	set	up	additional	options	for	thresholding:

1.	 Use	Lower	Value	and	Higher	Value	to	determine	the	threshold
limit	that	OCR	uses	to	calculate	the	threshold.

2.	 Enter	the	#	of	Blocks	you	want	to	use	with	the	Linear	and	Non-
Linear	threshold	calculation	methods.

3.	 If	speed	takes	precedence	in	calculating	the	threshold,	enable
Optimize	for	Speed	to	perform	the	thresholding	calculation	more
quickly,	but	less	accurately.	If	accuracy	takes	precedence,	disable
Optimize	for	Speed	to	perform	the	thresholding	calculation	more
slowly,	but	more	accurately.
If	you	enable	Optimize	for	Speed,	you	also	can	enable	Bi	modal
Calculation	to	enable	OCR	to	calculate	both	the	upper	and	lower
threshold	levels	for	images	that	are	dominated	by	two	pixel
intensity	levels.	If	you	enable	Bi	modal	Calculation,	OCR
disregards	the	pixel	intensity	level	setting	you	selected	in
Characters	on	the	Threshold	tab.

Tip		If	the	objects	in	the	ROI	are	not	segmented	as	you
expect	them	to	be,	experiment	with	settings	on	the
Threshold,	Advanced	Threshold,	and	Size	&	Spacing	tabs
to	improve	the	segmentation.



Setting	Up	Character	Size	and	Spacing	Criteria
Use	the	Size	&	Spacing	tab	to	indicate	the	character	size	and	spacing
values	required	for	character	recognition.	OCR	does	not	recognize	any
characters	in	the	ROI	that	do	not	meet	the	criteria	you	set	here.
Modify	the	fields	on	the	Size	&	Spacing	tab	to	set	up	the	character	size
and	spacing	requirements.

AutoSplit—Allows	you	to	configure	OCR	to	handle	slanted
characters.
Bounding	Rect	Width—Indicates	the	width	limits,	in	pixels,	for	the
character	bounding	rectangle.
Bounding	Rect	Height—Indicates	the	height	limits,	in	pixels,	for
the	character	bounding	rectangle.
Character	Size—Indicates	the	size	(area)	requirements,	in	pixels,
for	an	object	in	an	ROI	to	be	considered	a	character	that	can	be
trained.
Min	Char	Spacing—Indicates	the	minimum	amount	of	space,	in
pixels,	that	can	be	between	characters	in	the	ROI	you	specified.
This	value	must	be	greater	than	Max	Element	Spacing	(x).
Max	Element	Spacing	(x)—Indicates	the	maximum	amount	of
space,	in	pixels,	that	can	be	between	horizontally	adjacent
elements,	such	as	in	dot-matrix	objects.	This	value	must	be	less
than	Min	Char	Spacing.
Max	Element	Spacing	(y)—Indicates	the	maximum	amount	of
space,	in	pixels,	that	can	be	between	vertically	adjacent	elements.

Tip		If	the	objects	in	the	ROI	are	not	segmented	as	you
expect	them	to	be,	experiment	with	settings	on	the
Threshold,	Advanced	Threshold,	and	Size	&	Spacing	tabs	to
improve	the	segmentation.



Verifying	the	Quality	of	Characters
Complete	the	following	steps	to	verify	the	quality	of	characters	you	have
trained.

1.	 Click	the	Edit	Character	Set	File	tab.
2.	 Click	on	the	most	representative	character,	known	as	the

reference	character,	for	each	class	in	the	image	window.
3.	 Enable	the	Reference	Character	checkbox.

Note		The	OCR	Training	Interface	displays	a	warning	if	you
do	not	specify	a	reference	character	for	all	classes.

4.	 Click	the	Train/Read	tab.
5.	 Click	the	Results	tab
6.	 On	the	image,	draw	an	ROI	around	the	characters.

The	Ident.	Score	(identification	score)	in	the	Results	tab
indicates	how	closely	the	character	read	matched	the	reference
character	you	specified	for	that	class.	The	range	of	values	is	0	to
1000.	A	value	of	1000	indicates	a	perfect	match	between	an
object	and	the	reference	character.



Reviewing	Character	Statistics
Use	the	Results	tab	to	view	statistics	about	the	characters	OCR
segmented	in	the	ROI.
The	following	list	includes	descriptions	of	each	of	the	columns	on	the
Results	tab.

Character—Lists	the	index	of	each	of	the	characters	in	the	current
ROI.
Class—Lists,	by	index,	the	character	value	for	each	of	the
characters	you	trained	in	the	current	ROI.
Left	and	Top—List,	by	index,	the	x	and	y	coordinates	of	the	top	left
corner	of	each	of	the	character	bounding	rectangles	in	the	current
ROI.	The	status	bar	in	the	image	viewer	displays	the	Left	and	Top
coordinates	of	the	character	bounding	rectangles	as	you	move	the
mouse	over	the	image.
Width	and	Height—List	the	width	and	height	of	each	of	the
characters	you	trained	in	the	current	ROI.
Size—Lists,	by	index,	the	size	of	the	character	in	pixels.
Class	Score—Lists,	by	index,	a	value	that	indicates	the	degree	to
which	the	assigned	character	class	represents	the	object	value
better	than	other	character	classes	in	the	character	set.	The	range
of	values	is	0	to	1000.
Ident.	Score	(identification	score)—Lists,	by	index,	a	value	that
indicates	how	closely	a	character	matched	the	reference	character
from	its	assigned	class.	The	range	of	values	is	0	to	1000.	A	value
of	1000	indicates	a	perfect	match	between	an	object	and	the
reference	character.

Note		You	can	set	a	character	as	reference	for	each	class.
When	you	set	a	reference	character,	OCR	returns	a
identification	score	that	indicates	how	closely	the	character
matched	the	reference	character	for	its	class.	Use	the
identification	score	to	perform	optical	character	verification.
OCR	returns	a	value	of	0	for	the	identification	score	if	you	do
not	set	a	reference	for	a	class.



Modifying	the	Character	Set	File
Use	the	Edit	Character	Set	File	tab	to	review	and/or	modify	the	contents
of	a	character	set	file.
Complete	the	following	steps	to	review	and/or	modify	a	character	set	file:

1.	 Click	File»Open	Character	Set	File,	select	the	character	set	file
you	want	to	review	and/or	modify,	and	click	Open.

2.	 Click	the	Edit	Character	Set	File	tab.
The	browser	displays	the	trained	characters.

3.	 If	you	want	to	rename	a	character,	select	the	character	in	the
browser	and	click	Rename.	Type	the	new	character	value	in	New
Class	and	click	OK.

Tip		If	you	rename	a	reference	character,	its	reference
designation	is	removed.	Reset	the	character	as	a	reference
character	after	you	rename	it.

4.	 If	you	want	to	delete	a	character	from	the	character	set	file,	select
the	character	in	the	browser	and	click	Delete	or	press	the
<Delete>	key.

5.	 If	you	want	to	set	a	character	as	a	reference	character	to	perform
optical	character	verification	(OCV),	select	the	character	or
characters	in	the	browser	and	enable	the	Reference	Character
checkbox.	An	overlay	indicates	that	the	character	is	now	a
reference	character.	A	warning	indicates	if	you	have	not	selected
a	reference	character	in	all	classes.

Note		When	you	set	a	reference	character,	OCR	returns	an
identification	score	that	indicates	how	closely	the	character
matched	the	reference	character	for	its	class.	Click	the
Train/Read	tab,	then	click	the	Results	tab	to	view	the
identification	score.

6.	 Select	All	Trained	Characters	to	display	the	entire	contents	of
the	character	set	file	in	the	browser.	To	display	characters	of	only
one	class	value,	select	Characters	of	Class	and	select	the
character	you	want	to	view.
Samples	displays	the	number	of	instances	of	the	selected
character	class	in	the	character	set	file.



The	Character	Histogram	graphically	displays	the	number	of
instances	of	each	character	value	in	the	character	set.



Reading	Characters
Setting	Up	Read	Options	for	the	Training	Process
Developing	Read	Applications
OCR	LabVIEW	Example	Overview
OCR	LabWindows/CVI	Example	Overview
OCR	Microsoft	Visual	Basic	Example	Overview



Setting	Up	Read	Options	for	the	Training
Process
Use	the	Read	Options	tab	to	determine	how	OCR	processes	the	image
to	detect	characters.
Complete	the	following	steps	to	configure	the	OCR	reading	process:

1.	 Select	a	Read	Strategy.
Conservative—Configures	OCR	to	use	extensive	criteria	to
determine	if	read	characters	match	trained	characters.
Aggressive—Configures	OCR	to	use	few	criteria	to
determine	if	read	characters	match	trained	characters.

The	Aggressive	strategy	processes	images	faster	than	the
Conservative	strategy.

2.	 To	configure	OCR	to	consider	character	size	during	the	read
process,	select	Aspect	Ratio	Dependent	and	select	an	Aspect
Ratio	value	to	indicate	the	allowable	difference,	as	a	percentage,
between	the	training	and	reading	character	size	and	height/width
ratio.	The	minimum	value	is	100	percent,	which	indicates	that	the
read	character	must	be	the	exact	same	size	as	the	trained
character.

3.	 Select	the	Read	Resolution	to	determine	the	level	of	character
detail	you	want	OCR	to	use	during	the	reading	procedure.

4.	 Select	an	Acceptance	Level	value	to	indicate	how	closely	an
object	must	match	a	trained	character	to	be	a	recognized
character.	The	range	of	values	is	0	to	1000.

5.	 Enter	the	Substitution	Character	you	want	OCR	to	use	for
objects	that	are	not	yet	trained	and	recognized.



Developing	Read	Applications
You	can	use	the	following	OCR	examples	to	learn	how	to	use	OCR	to
create	OCR	reading	applications	in	LabVIEW,	LabWindows/CVI,	and/or
Microsoft	Visual	Basic:

LabVIEW—OCR	First	Example,	which	is	located	in	<LabVIEW>
examples\Vision\2.Functions\OCR\OCR	First	Example.vi,	where
<LabVIEW>	is	the	location	to	which	you	installed	LabVIEW.
LabWindows/CVI—OCR	First	Example,	which	is	located	in
<CVI>\samples\Vision\2.Functions\OCR\OCR	First	Example.prj,	where
<CVI>	is	the	location	to	which	you	installed	LabWindows/CVI.
Microsoft	Visual	Basic—OCR	First	Example,	which	is	located	in
<Vision>\Examples\MSVB\2.Functions\OCR	or
<Vision>\Examples\MSVB.NET\2.Functions\OCR,	where	<Vision>	is
the	location	to	which	you	installed	NI	Vision.



OCR	LabVIEW	Example	Overview
You	can	use	OCR	First	Example	to	perform	OCR	on	an	image	using	the
character	set	file	you	created	with	the	OCR	Training	Interface	Tutorial.
Complete	the	following	steps	to	use	OCR	First	Example:

1.	 Navigate	to	<LabVIEW>\examples\Vision\2.Functions\OCR\OCR	First
Example.llb	and	open	the	OCR	First	Example	VI,	where
<LabVIEW>	is	the	location	to	which	you	installed	LabVIEW.

2.	 Run	the	VI.
3.	 Click	Open	Character	Set	File	and	open	the	NIOCRTutorial.abc

file	you	created	upon	completing	the	OCR	Training	Interface
Tutorial.

4.	 Click	Open	Image,	select	one	of	the	NIOCRExample*	image	files,
and	click	Open.

5.	 Draw	an	ROI	on	the	image	and	click	Read.
Read	String	displays	the	recognized	characters	and	the
substitution	character.
Time	(ms)	displays	the	amount	of	time	it	took	OCR	to	read
the	image.

6.	 Click	Return	to	exit	the	example.



OCR	LabWindows/CVI	Example	Overview
You	can	use	OCR	First	Example	to	perform	OCR	on	an	image	using	the
character	set	file	you	created	with	the	OCR	Training	Interface	Tutorial.
Complete	the	following	steps	to	use	OCR	First	Example:

1.	 Navigate	to	<CVI>\samples\Vision\2.Functions\OCR\OCR	First
Example.prj,	where	<CVI>	is	the	location	to	which	you	installed
LabWindows/CVI.

2.	 Click	Build»Configuration»Debug,	and	then	click	Run»Debug
OCR	First	Example.exe	to	run	the	example.

3.	 Click	Open	Character	Set	File	and	open	the	NIOCRTutorial.abc
file	you	created	upon	completing	the	OCR	Training	Interface
Tutorial.

4.	 Click	Open	Image,	select	one	of	the	NIOCRExample*	image	files,
and	click	Load.

5.	 Draw	an	ROI	on	the	image	and	click	Read.
Read	String	displays	the	recognized	characters	and	the
substitution	character.
Time	(ms)	displays	the	amount	of	time	it	took	OCR	to	read
the	image.

6.	 Click	Quit	to	exit	the	example.



Warranty
The	media	on	which	you	receive	National	Instruments	software	are
warranted	not	to	fail	to	execute	programming	instructions,	due	to	defects
in	materials	and	workmanship,	for	a	period	of	90	days	from	date	of
shipment,	as	evidenced	by	receipts	or	other	documentation.	National
Instruments	will,	at	its	option,	repair	or	replace	software	media	that	do	not
execute	programming	instructions	if	National	Instruments	receives	notice
of	such	defects	during	the	warranty	period.	National	Instruments	does	not
warrant	that	the	operation	of	the	software	shall	be	uninterrupted	or	error
free.
A	Return	Material	Authorization	(RMA)	number	must	be	obtained	from
the	factory	and	clearly	marked	on	the	outside	of	the	package	before	any
equipment	will	be	accepted	for	warranty	work.	National	Instruments	will
pay	the	shipping	costs	of	returning	to	the	owner	parts	which	are	covered
by	warranty.
National	Instruments	believes	that	the	information	in	this	document	is
accurate.	The	document	has	been	carefully	reviewed	for	technical
accuracy.	In	the	event	that	technical	or	typographical	errors	exist,
National	Instruments	reserves	the	right	to	make	changes	to	subsequent
editions	of	this	document	without	prior	notice	to	holders	of	this	edition.
The	reader	should	consult	National	Instruments	if	errors	are	suspected.
In	no	event	shall	National	Instruments	be	liable	for	any	damages	arising
out	of	or	related	to	this	document	or	the	information	contained	in	it.
EXCEPT	AS	SPECIFIED	HEREIN,	NATIONAL	INSTRUMENTS	MAKES
NO	WARRANTIES,	EXPRESS	OR	IMPLIED,	AND	SPECIFICALLY
DISCLAIMS	ANY	WARRANTY	OF	MERCHANTABILITY	OR	FITNESS
FOR	A	PARTICULAR	PURPOSE.	CUSTOMER'S	RIGHT	TO	RECOVER
DAMAGES	CAUSED	BY	FAULT	OR	NEGLIGENCE	ON	THE	PART	OF
NATIONAL	INSTRUMENTS	SHALL	BE	LIMITED	TO	THE	AMOUNT
THERETOFORE	PAID	BY	THE	CUSTOMER.	NATIONAL
INSTRUMENTS	WILL	NOT	BE	LIABLE	FOR	DAMAGES	RESULTING
FROM	LOSS	OF	DATA,	PROFITS,	USE	OF	PRODUCTS,	OR
INCIDENTAL	OR	CONSEQUENTIAL	DAMAGES,	EVEN	IF	ADVISED	OF
THE	POSSIBILITY	THEREOF.	This	limitation	of	the	liability	of	National
Instruments	will	apply	regardless	of	the	form	of	action,	whether	in
contract	or	tort,	including	negligence.	Any	action	against	National
Instruments	must	be	brought	within	one	year	after	the	cause	of	action



accrues.	National	Instruments	shall	not	be	liable	for	any	delay	in
performance	due	to	causes	beyond	its	reasonable	control.	The	warranty
provided	herein	does	not	cover	damages,	defects,	malfunctions,	or
service	failures	caused	by	owner's	failure	to	follow	the	National
Instruments	installation,	operation,	or	maintenance	instructions;	owner's
modification	of	the	product;	owner's	abuse,	misuse,	or	negligent	acts;
and	power	failure	or	surges,	fire,	flood,	accident,	actions	of	third	parties,
or	other	events	outside	reasonable	control.



Copyright
Under	the	copyright	laws,	this	publication	may	not	be	reproduced	or
transmitted	in	any	form,	electronic	or	mechanical,	including	photocopying,
recording,	storing	in	an	information	retrieval	system,	or	translating,	in
whole	or	in	part,	without	the	prior	written	consent	of	National	Instruments
Corporation.
National	Instruments	respects	the	intellectual	property	of	others,	and	we
ask	our	users	to	do	the	same.	NI	software	is	protected	by	copyright	and
other	intellectual	property	laws.	Where	NI	software	may	be	used	to
reproduce	software	or	other	materials	belonging	to	others,	you	may	use
NI	software	only	to	reproduce	materials	that	you	may	reproduce	in
accordance	with	the	terms	of	any	applicable	license	or	other	legal
restriction.



Trademarks
National	Instruments,	NI,	ni.com,	and	LabVIEW	are	trademarks	of
National	Instruments	Corporation.	Refer	to	the	Terms	of	Use	section	on
ni.com/legal	for	more	information	about	National	Instruments	trademarks.
FireWire®	is	the	registered	trademark	of	Apple	Computer,	Inc.
Handle	Graphics®,	MATLAB®,	Real-Time	Workshop®,	Simulink®,
Stateflow®,	and	xPC	TargetBox®	are	registered	trademarks,	and
TargetBox™	and	Target	Language	Compiler™	are	trademarks	of	The
MathWorks,	Inc.
Tektronix®	and	Tek	are	registered	trademarks	of	Tektronix,	Inc.
Other	product	and	company	names	mentioned	herein	are	trademarks	or
trade	names	of	their	respective	companies.
Members	of	the	National	Instruments	Alliance	Partner	Program	are
business	entities	independent	from	National	Instruments	and	have	no
agency,	partnership,	or	joint-venture	relationship	with	National
Instruments.
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Patents
For	patents	covering	National	Instruments	products,	refer	to	the
appropriate	location:	Help»Patents	in	your	software,	the	patents.txt	file	on
your	CD,	or	ni.com/patents.
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Related	Documentation
Some	manuals	are	available	as	PDFs.	You	must	have	Adobe	Reader
with	Search	and	Accessibility	5.0.5	or	later	installed	to	view	the	PDFs.
Refer	to	the	Adobe	Systems	Incorporated	Web	site	at	www.adobe.com	to
download	Adobe	Reader.	Refer	to	the	National	Instruments	Product
Manuals	Library	at	ni.com/manuals	for	updated	documentation	resources.
The	following	documents	contain	information	that	you	may	find	helpful	as
you	use	this	help	file.

NI	Vision	Concepts	Manual—Describes	the	basic	concepts	of
image	analysis,	image	processing,	and	machine	vision.	This
document	also	contains	in-depth	discussions	about	imaging
functions	for	advanced	users.
NI	Vision	for	LabVIEW	VI	Reference	Help—Contains	reference
information	about	NI	Vision	for	LabVIEW	palettes	and	VIs.
NI	Vision	for	LabWindows/CVI	Function	Reference	Help—Contains
reference	information	about	NI	Vision	for	LabWindows/CVI
functions.
NI	Vision	for	Visual	Basic	Reference	Help—Contains	reference
information	about	NI	Vision	for	Visual	Basic	objects	and	their
associated	properties,	methods,	and	events.
NI	Vision	Assistant	Help—Contains	descriptions	of	the	NI	Vision
Assistant	features	and	functions	and	provides	instructions	for	using
them.
NI	Vision	Builder	for	Automated	Inspection:	Configuration	Help—
Contains	information	about	using	the	Vision	Builder	for	Automated
Inspection	Configuration	Interface	to	create	a	machine	vision
application.
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Important	Information
Warranty
Copyright
Trademarks
Patents
Warning	Regarding	Use	of	NI	Products



Technical	Support	and	Professional	Services
Visit	the	following	sections	of	the	National	Instruments	Web	site	at	ni.com
for	technical	support	and	professional	services:

Support—Online	technical	support	resources	at	ni.com/support
include	the	following:

Self-Help	Resources—For	answers	and	solutions,	visit	the
award-winning	National	Instruments	Web	site	for	software
drivers	and	updates,	a	searchable	KnowledgeBase,	product
manuals,	step-by-step	troubleshooting	wizards,	thousands	of
example	programs,	tutorials,	application	notes,	instrument
drivers,	and	so	on.
Free	Technical	Support—All	registered	users	receive	free
Basic	Service,	which	includes	access	to	hundreds	of
Applications	Engineers	worldwide	in	the	NI	Discussion
Forums	at	ni.com/forums.	National	Instruments	Applications
Engineers	make	sure	every	question	receives	an	answer.
For	information	about	other	technical	support	options	in	your
area,	visit	ni.com/services	or	contact	your	local	office	at
ni.com/contact.

Training	and	Certification—Visit	ni.com/training	for	self-paced
training,	eLearning	virtual	classrooms,	interactive	CDs,	and
Certification	program	information.	You	also	can	register	for
instructor-led,	hands-on	courses	at	locations	around	the	world.
System	Integration—If	you	have	time	constraints,	limited	in-house
technical	resources,	or	other	project	challenges,	National
Instruments	Alliance	Partner	members	can	help.	To	learn	more,
call	your	local	NI	office	or	visit	ni.com/alliance.

If	you	searched	ni.com	and	could	not	find	the	answers	you	need,	contact
your	local	office	or	NI	corporate	headquarters.	You	also	can	visit	the
Worldwide	Offices	section	of	ni.com/niglobal	to	access	the	branch	office
Web	sites,	which	provide	up-to-date	contact	information,	support	phone
numbers,	email	addresses,	and	current	events.
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Navigating	Images
You	can	use	the	toolbar	buttons	to	navigate	the	images	you	opened	for
training.	Refer	to	the	following	button	descriptions	for	information	about
how	to	view	images.

First	Image—Navigates	to	the	first	image	in	the	list	of	images	you
opened.
Previous	Image—Navigates	to	the	previous	image.
Next	Image—Navigates	to	the	next	image.
Last	Image—Navigates	to	the	last	image	in	the	list	of	images	you
opened.



Viewing	Images
You	can	use	the	toolbar	buttons	to	view	images	in	greater	or	lesser	detail.
Refer	to	the	following	button	descriptions	for	information	about	how	to
view	images:

Zooms	in	on	an	image.
Zooms	out	on	an	image.
Displays	an	image	at	regular	magnification.



OCR	Microsoft	Visual	Basic	Example	Overview
You	can	use	OCR	First	Example	to	perform	OCR	on	an	image	using	the
character	set	file	you	created	with	the	OCR	Training	Interface	Tutorial.
Complete	the	following	steps	to	use	OCR	First	Example:

1.	 Navigate	to	<Vision>\Examples\MSVB\2.Functions\OCR	or
<Vision>\Examples\MSVB.NET\2.Functions\OCR	and	open	the	OCR
First	Example.vbp	file,	where	<Vision>	is	the	location	to	which	you
installed	NI	Vision.

2.	 Run	the	example.
3.	 Click	Open	Character	Set	File	and	open	the	NIOCRTutorial.abc

file	you	created	upon	completing	the	OCR	Training	Interface
Tutorial.

4.	 Click	Open	Image,	select	one	of	the	NIOCRExample*	image	files,
and	click	Open.

5.	 Draw	an	ROI	on	the	image.
Read	String	displays	the	recognized	characters	and	the
substitution	character.
Time	(ms)	displays	the	amount	of	time	it	took	OCR	to	read
the	image.

6.	 Click	Quit	to	exit	the	example.



WARNING	REGARDING	USE	OF	NATIONAL
INSTRUMENTS	PRODUCTS
(1)	NATIONAL	INSTRUMENTS	PRODUCTS	ARE	NOT	DESIGNED
WITH	COMPONENTS	AND	TESTING	FOR	A	LEVEL	OF	RELIABILITY
SUITABLE	FOR	USE	IN	OR	IN	CONNECTION	WITH	SURGICAL
IMPLANTS	OR	AS	CRITICAL	COMPONENTS	IN	ANY	LIFE	SUPPORT
SYSTEMS	WHOSE	FAILURE	TO	PERFORM	CAN	REASONABLY	BE
EXPECTED	TO	CAUSE	SIGNIFICANT	INJURY	TO	A	HUMAN.
(2)	IN	ANY	APPLICATION,	INCLUDING	THE	ABOVE,	RELIABILITY	OF
OPERATION	OF	THE	SOFTWARE	PRODUCTS	CAN	BE	IMPAIRED	BY
ADVERSE	FACTORS,	INCLUDING	BUT	NOT	LIMITED	TO
FLUCTUATIONS	IN	ELECTRICAL	POWER	SUPPLY,	COMPUTER
HARDWARE	MALFUNCTIONS,	COMPUTER	OPERATING	SYSTEM
SOFTWARE	FITNESS,	FITNESS	OF	COMPILERS	AND
DEVELOPMENT	SOFTWARE	USED	TO	DEVELOP	AN	APPLICATION,
INSTALLATION	ERRORS,	SOFTWARE	AND	HARDWARE
COMPATIBILITY	PROBLEMS,	MALFUNCTIONS	OR	FAILURES	OF
ELECTRONIC	MONITORING	OR	CONTROL	DEVICES,	TRANSIENT
FAILURES	OF	ELECTRONIC	SYSTEMS	(HARDWARE	AND/OR
SOFTWARE),	UNANTICIPATED	USES	OR	MISUSES,	OR	ERRORS	ON
THE	PART	OF	THE	USER	OR	APPLICATIONS	DESIGNER	(ADVERSE
FACTORS	SUCH	AS	THESE	ARE	HEREAFTER	COLLECTIVELY
TERMED	"SYSTEM	FAILURES").	ANY	APPLICATION	WHERE	A
SYSTEM	FAILURE	WOULD	CREATE	A	RISK	OF	HARM	TO
PROPERTY	OR	PERSONS	(INCLUDING	THE	RISK	OF	BODILY
INJURY	AND	DEATH)	SHOULD	NOT	BE	RELIANT	SOLELY	UPON	ONE
FORM	OF	ELECTRONIC	SYSTEM	DUE	TO	THE	RISK	OF	SYSTEM
FAILURE.	TO	AVOID	DAMAGE,	INJURY,	OR	DEATH,	THE	USER	OR
APPLICATION	DESIGNER	MUST	TAKE	REASONABLY	PRUDENT
STEPS	TO	PROTECT	AGAINST	SYSTEM	FAILURES,	INCLUDING	BUT
NOT	LIMITED	TO	BACK-UP	OR	SHUT	DOWN	MECHANISMS.
BECAUSE	EACH	END-USER	SYSTEM	IS	CUSTOMIZED	AND
DIFFERS	FROM	NATIONAL	INSTRUMENTS'	TESTING	PLATFORMS
AND	BECAUSE	A	USER	OR	APPLICATION	DESIGNER	MAY	USE
NATIONAL	INSTRUMENTS	PRODUCTS	IN	COMBINATION	WITH
OTHER	PRODUCTS	IN	A	MANNER	NOT	EVALUATED	OR
CONTEMPLATED	BY	NATIONAL	INSTRUMENTS,	THE	USER	OR



APPLICATION	DESIGNER	IS	ULTIMATELY	RESPONSIBLE	FOR
VERIFYING	AND	VALIDATING	THE	SUITABILITY	OF	NATIONAL
INSTRUMENTS	PRODUCTS	WHENEVER	NATIONAL	INSTRUMENTS
PRODUCTS	ARE	INCORPORATED	IN	A	SYSTEM	OR	APPLICATION,
INCLUDING,	WITHOUT	LIMITATION,	THE	APPROPRIATE	DESIGN,
PROCESS	AND	SAFETY	LEVEL	OF	SUCH	SYSTEM	OR
APPLICATION.



Branch	Offices
Office Telephone	Number
Australia 1800	300	800
Austria 43	662	457990-0
Belgium 32	(0)	2	757	0020
Brazil 55	11	3262	3599
Canada 800	433	3488
China 86	21	6555	7838
Czech	Republic 420	224	235	774
Denmark 45	45	76	26	00
Finland 385	(0)	9	725	72511
France 33	(0)	1	48	14	24	24
Germany 49	89	7413130
India 91	80	41190000
Israel 972	0	3	6393737
Italy 39	02	413091
Japan 81	3	5472	2970
Korea 82	02	3451	3400
Lebanon 961	(0)	1	33	28	28
Malaysia 1800	887710
Mexico 01	800	010	0793
Netherlands 31	(0)	348	433	466
New	Zealand 0800	553	322
Norway 47	(0)	66	90	76	60
Poland 48	22	3390150
Portugal 351	210	311	210
Russia 7	495	783	6851
Singapore 1800	226	5886
Slovenia 386	3	425	42	00



South	Africa 27	0	11	805	8197
Spain 34	91	640	0085
Sweden 46	(0)	8	587	895	00
Switzerland 41	56	2005151
Taiwan 886	02	2377	2222
Thailand 662	278	6777
Turkey 90	212	279	3031
United	Kingdom 44	(0)	1635	523545
United	States	(Corporate) 512	683	0100
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