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Conventions
This	help	file	uses	the	following	conventions:
» The	»	symbol	leads	you	through	nested	menu	items	and

dialog	box	options	to	a	final	action.	The	sequence	File»Page
Setup»Options	directs	you	to	pull	down	the	File	menu,
select	the	Page	Setup	item,	and	select	Options	from	the	last
dialog	box.
This	icon	denotes	a	tip,	which	alerts	you	to	advisory
information.
This	icon	denotes	a	note,	which	alerts	you	to	important
information.

bold Bold	text	denotes	items	that	you	must	select	or	click	on	in	the
software,	such	as	menu	items	and	dialog	box	options.	Bold
text	also	denotes	parameter	names,	emphasis,	or	an
introduction	to	a	key	concept.

green Underlined	text	in	this	color	denotes	a	link	to	a	help	topic,
help	file,	or	Web	address.

italic Italic	text	denotes	variables	or	cross	references.	This	font
also	denotes	text	that	is	a	placeholder	for	a	word	or	value
that	you	must	supply.

monospace Text	in	this	font	denotes	text	or	characters	that	you	should
enter	from	the	keyboard,	sections	of	code,	programming
examples,	and	syntax	examples.	This	font	is	also	used	for
the	proper	names	of	disk	drives,	paths,	directories,
programs,	subprograms,	subroutines,	device	names,
functions,	operations,	variables,	filenames	and	extensions,
and	code	excerpts.



Navigating	Help	(Windows	Only)
To	navigate	this	help	file,	use	the	Contents,	Index,	and	Search	tabs	to
the	left	of	this	window	or	use	the	following	toolbar	buttons	located	above
the	tabs:

Hide—Hides	the	navigation	pane	from	view.
Locate—Locates	the	currently	displayed	topic	in	the	Contents	tab,
allowing	you	to	view	related	topics.
Back—Displays	the	previously	viewed	topic.
Forward—Displays	the	topic	you	viewed	before	clicking	the	Back
button.
Options—Displays	a	list	of	commands	and	viewing	options	for	the
help	file.



Searching	Help	(Windows	Only)
Use	the	Search	tab	to	the	left	of	this	window	to	locate	content	in	this	help
file.	If	you	want	to	search	for	words	in	a	certain	order,	such	as	"related
documentation,"	add	quotation	marks	around	the	search	words	as	shown
in	the	example.	Searching	for	terms	on	the	Search	tab	allows	you	to
quickly	locate	specific	information	and	information	in	topics	that	are	not
included	on	the	Contents	tab.



Wildcards
You	also	can	search	using	asterisk	(*)	or	question	mark	(?)	wildcards.
Use	the	asterisk	wildcard	to	return	topics	that	contain	a	certain	string.	For
example,	a	search	for	"prog*"	lists	topics	that	contain	the	words
"program,"	"programmatically,"	"progress,"	and	so	on.
Use	the	question	mark	wildcard	as	a	substitute	for	a	single	character	in	a
search	term.	For	example,	"?ext"	lists	topics	that	contain	the	words
"next,"	"text,"	and	so	on.

Note		Wildcard	searching	will	not	work	on	Simplified	Chinese,
Traditional	Chinese,	Japanese,	and	Korean	systems.



Nested	Expressions
Use	nested	expressions	to	combine	searches	to	further	refine	a	search.
You	can	use	Boolean	expressions	and	wildcards	in	a	nested	expression.
For	example,	"example	AND	(program	OR	VI)"	lists	topics	that	contain
"example	program"	or	"example	VI."	You	cannot	nest	expressions	more
than	five	levels.



Boolean	Expressions
Click	the	 	button	to	add	Boolean	expressions	to	a	search.	The	following
Boolean	operators	are	available:

AND	(default)—Returns	topics	that	contain	both	search	terms.	You
do	not	need	to	specify	this	operator	unless	you	are	using	nested
expressions.
OR—Returns	topics	that	contain	either	the	first	or	second	term.
NOT—Returns	topics	that	contain	the	first	term	without	the	second
term.
NEAR—Returns	topics	that	contain	both	terms	within	eight	words
of	each	other.



Search	Options

Use	the	following	checkboxes	on	the	Search	tab	to	customize	a	search:
Search	previous	results—Narrows	the	results	from	a	search	that
returned	too	many	topics.	You	must	remove	the	checkmark	from
this	checkbox	to	search	all	topics.
Match	similar	words—Broadens	a	search	to	return	topics	that
contain	words	similar	to	the	search	terms.	For	example,	a	search
for	"program"	lists	topics	that	include	the	words	"programs,"
"programming,"	and	so	on.
Search	titles	only—Searches	only	in	the	titles	of	topics.



Printing	Help	File	Topics	(Windows	Only)
Complete	the	following	steps	to	print	an	entire	book	from	the	Contents
tab:

1.	 Right-click	the	book.
2.	 Select	Print	from	the	shortcut	menu	to	display	the	Print	Topics

dialog	box.
3.	 Select	the	Print	the	selected	heading	and	all	subtopics	option.

Note		Select	Print	the	selected	topic	if	you	want	to	print
the	single	topic	you	have	selected	in	the	Contents	tab.

4.	 Click	the	OK	button.



Printing	PDF	Documents
This	help	file	may	contain	links	to	PDF	documents.	To	print	PDF
documents,	click	the	print	button	located	on	the	Adobe	Acrobat	Viewer
toolbar.



NI	Classification	Training	Interface	Tutorial
This	tutorial	guides	you	through	the	steps	for	classifying	samples	with	the
classification	engine	using	a	specific	set	of	images.	This	tutorial	illustrates
the	various	steps	required	to	classify	varying	representations	of	the	same
class.
This	tutorial	includes	the	following	sections:

Classifying	Samples	with	the	Classification	Engine
Editing	the	Classifier	File
Saving	the	Classifier	File



Classifying	Samples	with	the	Classification	Engine
Complete	the	following	steps	to	classify	samples	with	the	classification
engine:

1.	 Complete	one	of	the	following	steps	to	launch	the	NI	Classification
Training	Interface:

a.	 If	you	are	using	Vision	Builder	for	Automated	Inspection
(Vision	Builder	AI)	or	Vision	Assistant,	click	New/Edit
Classifier	File.

b.	 If	you	are	not	using	Vision	Builder	AI	or	Vision	Assistant,
click	Start»Programs»National
Instruments»Vision»Classification	Training.

2.	 Save	the	Classifier	File	as	Tutorial.clf	and	Click	OK.
3.	 Complete	one	of	the	following	sets	of	steps	to	select	the	tutorial

images:
NI	Vision	and	Vision	Assistant

a.	 Click	File»Open	Images.
b.	 Navigate	to	<Vision>\Images\Classification	Tutorial,

where	<Vision>	is	the	location	to	which	you	installed
the	NI	Vision	Development	Module.

c.	 Select	the	following	images:
Parts00.png
Parts01.png
Bolt00.png
Bolt01.png
Motor00.png
Motor01.png
Tip		You	can	select	multiple	image	files	by
pressing	the	<Ctrl>	key	and	clicking	each	file.
Enable	the	Select	all	files	checkbox	to	open
all	images	in	the	directory	you	specified.

d.	 Click	Open.
Vision	Builder	AI

a.	 Navigate	to	<Vision	Builder
AI>\DemoImg\Classification,	where	<Vision	Builder



AI>	is	the	location	to	which	you	installed	Vision
Builder	AI.

b.	 Select	the	following	images:
Parts00.png
Parts01.png
Bolt00.png
Bolt01.png
Motor00.png
Motor01.png
Tip		You	can	select	multiple	image	files	by
pressing	the	<Ctrl>	key	and	clicking	each	file.
Enable	the	Select	all	files	checkbox	to	open
all	images	in	the	directory	you	specified.

c.	 Click	Open.
Tip		Click	each	of	the	image	file	names	above	to	view	the
tutorial	steps	associated	with	the	image.	Click	each	image
to	return	to	the	list	above.

4.	 Click	Open.
5.	 Use	the	navigation	buttons	to	locate	Parts00.png.
6.	 Make	sure	your	Preprocessing	options	are	set	properly.	Select

Clustering	for	the	Method	of	thresholding,	and	select	Dark
Objects	from	the	Look	For	drop-down	menu.

7.	 Draw	an	ROI	around	the	bolt	in	the	image.
Tip		It	may	be	necessary	to	include	parts	of	other	objects	in
the	ROI	you	draw	around	the	bolt	to	successfully	contain
the	entire	bolt	in	the	ROI.	To	configure	the	classification
engine	to	classify	the	sample	of	the	bolt	correctly	even
though	the	ROI	contains	part	of	another	object,	enable
Reject	Objects	Touching	ROI	on	the	Preprocessing	tab.

The	NI	Classification	Training	Interface	displays	the	objects	in	the
ROI	according	to	the	preprocessing	settings.	When	the
preprocessing	settings	are	configured	to	use	a	clustering	method
of	thresholding	and	to	look	for	dark	objects,	the	objects	in	the	ROI



are	blue.
8.	 Select	Add	New	Label	from	the	Class	Label	list.	Enter	Bolt	for

the	New	Label.
9.	 Click	OK.
10.	 Navigate	to	the	Parts01.png	file.
11.	 Draw	an	ROI	around	a	bolt	in	the	image.

12.	 Check	that	the	Class	Label	control	reads	Bolt	and	click	Add
Sample.

13.	 Select	the	Classify	tab,	and	click	Train	Classifier.
14.	 Navigate	to	the	Bolt00.png	file.
15.	 Draw	an	ROI	around	the	bolt	in	the	image.

16.	 Verify	that	the	object	in	the	ROI	is	classified	correctly	by	checking
that	the	Assigned	Class	Label	indicator	reads	Bolt.	The
Classification	Score	is	1000	because	you	have	only	defined	one
class.

17.	 Navigate	to	the	Bolt01.png	file.
18.	 Draw	an	ROI	around	the	bolt	in	the	image.

19.	 Verify	that	the	sample	in	the	ROI	is	classified	correctly	by
checking	that	the	Assigned	Class	Label	indicator	reads	Bolt.

Complete	the	following	steps	to	train	and	classify	motors.
19.	 Use	the	navigation	buttons	to	locate	Parts00.png.
20.	 Make	sure	your	Preprocessing	options	are	set	properly.	Select

Clustering	for	the	Method	of	thresholding	and	select	Dark
Objects	from	the	Look	For	drop-down	menu.

21.	 Draw	an	ROI	around	a	motor	in	the	image.
Tip		It	may	be	necessary	to	include	parts	of	other	objects	in
the	ROI	you	draw	around	the	motor	to	successfully	contain
the	entire	motor	in	the	ROI.	To	configure	the	classification
engine	to	classify	the	sample	of	the	motor	correctly	even
though	the	ROI	contains	part	of	another	object,	enable
Reject	Objects	Touching	ROI	on	the	Preprocessing	tab.



The	NI	Classification	Training	Interface	displays	the	objects	in	the
ROI	according	to	the	preprocessing	settings.	When	the
preprocessing	settings	are	configured	to	use	a	clustering	method
of	thresholding	and	to	look	for	dark	objects,	the	objects	in	the	ROI
are	blue.

22.	 Select	Add	New	Label	from	the	Class	Label	list.	Enter	Motor	for
the	New	Label.

23.	 Click	OK.
24.	 Navigate	to	the	Parts01.png	file.
25.	 Draw	an	ROI	around	the	motor	in	the	image.

26.	 Check	that	the	Class	Label	control	reads	Motor	and	click	Add
Sample.

27.	 Select	the	Classify	tab,	and	click	Train	Classifier.
28.	 Navigate	to	the	Motor00.png	file.
29.	 Draw	an	ROI	around	a	motor	in	the	image.

30.	 Verify	that	the	sample	in	the	ROI	is	classified	correctly	by
checking	that	the	Assigned	Class	Label	indicator	reads	Motor.

31.	 Navigate	to	the	Motor01.png	file.
32.	 Draw	an	ROI	around	the	motor	in	the	image.

33.	 Verify	that	the	sample	in	the	ROI	is	classified	correctly	by
checking	that	the	Assigned	Class	Label	indicator	reads	Motor.



Editing	the	Classifier	File
Use	the	Edit	Classifier	tab	to	view	the	thumbnail	images	and	descriptive
information	about	the	samples	classified.
The	following	list	includes	descriptions	of	each	of	the	items	on	the	Edit
Classifier	tab.

Use	the	Classifier	File	Description	text	box	to	input	descriptive
characteristics	about	the	classifier	file.
Use	the	Relabel	button	to	change	the	class	to	which	a	sample
belongs.
Use	the	Delete	button	to	delete	a	sample	from	the	browser.
Use	Browser	Display	to	display	either	all	of	the	trained	samples
or	only	the	samples	of	a	certain	class.	If	you	select	to	display
Samples	of	Class,	you	can	select	the	class	to	display,	and	the
number	of	samples	in	that	class	appears	in	the	Samples	indicator.
Use	the	Class	Population	chart	to	graphically	display	the	number
of	each	type	of	different	class	of	samples	in	the	classifier	file	as
well	as	the	total	number	of	samples.



Saving	the	Classifier	File
Now	that	you	have	classified	several	objects,	you	are	ready	to	save	the
classifier	file.	Each	classifier	file	contains	the	current	state	of	the
classification	engine	options	as	well	as	the	samples	you	have	trained.

1.	 Use	the	navigation	buttons	to	scroll	through	the	images	you
classified	in	this	tutorial.	Review	each	image,	and	check	that	the
class	to	which	the	image	belongs	is	correct.	When	you	hover	your
mouse	over	the	thumbnail	image	in	the	Edit	Classifier	tab,	the
class	name	appears	in	the	lower	right	corner	below	the	image
window.

2.	 Relabel	any	images	that	are	not	correctly	labeled	by	selecting	the
image	from	the	browser	and	clicking	Relabel.	The	Relabel
Sample	dialog	opens.	Type	the	correct	label	for	the	image	in	the
New	Label	control.

3.	 Delete	any	unwanted	images	by	selecting	the	image	in	the
browser	and	clicking	Delete.

4.	 Click	File»Save	Classifier	File,	enter	Tutorial.clf	in	File	Name	for
the	classifier	file,	and	then	click	Save.



Adding	Samples	to	the	Classifier
Use	the	Add	Samples	tab	to	add	images	as	samples	in	the	NI
Classification	Training	Interface.
Complete	the	following	steps	to	add	an	image	as	a	sample:

1.	 Click	File»Open	Images.
2.	 Navigate	to	the	image	you	want	to	classify	and	click	Open.

Tip		You	can	select	all	of	the	files	in	a	folder	by	enabling	the
Select	All	Files	option,	or	you	can	select	multiple	files	by
holding	the	<Ctrl>	key	while	clicking	file	names.	When	you
select	an	image	from	the	list,	the	Preview	Image	window
displays	the	image,	file	type,	image	size,	and	image	type.	If
you	have	selected	a	collection	of	images,	the	Preview
window	displays	all	images	in	a	sequence.	To	view	the
sequence	at	a	different	rate,	adjust	the	slide	to	the	right	of
the	Preview	Image	window.
Tip		To	browse	the	images	you	opened,	use	the	navigation
buttons.

3.	 Draw	an	ROI	around	the	sample	you	want	to	add.
4.	 Use	the	Preprocessing,	Engine	Options,	and	Particle	Classifier

Options	tabs	to	adjust	the	parameters.
5.	 Select	the	appropriate	label	for	the	image	you	have	trained	from

the	Class	Label	drop-down	menu.	To	add	a	new	label,	select	Add
New	Label	from	the	Correct	Label	drop-down	menu.	The	Enter
a	new	label	dialog	box	opens.	Type	the	label	name	and	click	OK.
The	new	sample	is	automatically	added	to	the	group	of	trained
samples.

6.	 To	add	a	sample	with	an	already	existing	label,	select	the	label
from	the	list	and	click	Add	Sample	to	add	the	sample	to	the	group
of	trained	samples.

The	Particle	Histogram	graphically	displays,	for	each	sample,	the
number	of	instances	of	each	type	of	sample	in	the	class.
The	Total	#	of	Samples	indicator	displays	the	number	of	samples	you
have	trained.



Classifying	Samples
Use	the	Classify	tab	to	classify	image	samples	in	the	NI	Classification
Training	Interface.
Complete	the	following	steps	to	classify	an	image	sample:

1.	 Click	Train	Classifier.
2.	 Click	File»Open	Images.
3.	 Navigate	to	the	image	you	want	to	classify	and	click	Open.

Tip		You	can	select	all	of	the	files	in	a	folder	by	enabling	the
Select	All	Files	option,	or	you	can	select	multiple	files	by
holding	the	<Ctrl>	key	while	clicking	file	names.	When	you
select	an	image	from	the	list,	the	Preview	Image	window
displays	the	image,	file	type,	image	size,	and	image	type.	If
you	have	selected	a	collection	of	images,	the	Preview
window	displays	all	images	in	a	sequence.	To	view	the
sequence	at	a	different	rate,	adjust	the	slide	to	the	right	of
the	Preview	Image	window.
Tip		To	browse	the	images	you	opened,	use	the	navigation
buttons.

4.	 Draw	an	ROI	around	the	sample	you	want	to	classify.
The	assigned	class	label	for	the	sample	appears	in	the	Assigned	Class
Label	indicator.
The	Classification	Score	is	the	degree	of	certainty	that	a	sample	is
assigned	to	one	class	instead	of	another	class.	The	Identification	Score
is	the	degree	of	similarity	between	a	sample	and	members	of	the	class	to
which	the	sample	is	assigned.
The	Distances	chart	displays	the	distance	between	the	classified	sample
and	other	classes.

Note		If	you	change	the	Preprocessing,	Engine	Options,	or	Particle
Classifier	Options	settings,	you	must	retrain	the	classifier.



Editing	the	Classifier
Use	the	Edit	Classifier	tab	to	edit	the	image	samples	you	have	classified
in	the	NI	Classification	Training	Interface.

Classifier	File	Description—Add	descriptive	information	about
the	files	you	classify	in	this	control.
Relabel—To	relabel	a	sample,	select	a	sample	in	the	browser	and
click	Relabel.
Delete—To	delete	a	sample,	select	a	sample	in	the	browser	and
click	Delete.
Browser	Display—The	browser	can	display	all	trained	samples	or
samples	of	a	certain	class.

To	display	all	trained	samples,	click	All	Trained	Samples.
To	display	samples	of	a	certain	class,	click	Samples	of
Class	and	select	the	class	you	want	to	display.	The
Samples	indicator	displays	the	number	of	samples	from	that
class.

Class	Population—Graphically	displays,	for	each	sample,	the
number	of	instances	of	each	type	of	sample	in	the	class.

The	Total	#	of	Samples	control	displays	the	number	of	samples	you
have	trained.



Batch	Training
Batch	Results	Batch	Classify
Use	Tools»Batch	Training	to	train	a	folder	of	images.
Complete	the	following	steps	to	train	a	folder	of	images:

1.	 Click	Tools»Batch	Training.
2.	 Click	the	Browse	button	to	select	the	folder	of	images	to	train.

After	you	have	selected	the	folder	of	images,	click	Select	Cur	Dir.
3.	 Click	Draw	ROI	to	select	an	ROI	around	the	sample	to	train.

Note		Make	sure	the	ROI	encompasses	the	sample	to	train
in	all	images	in	the	folder.

Note		If	you	do	not	select	an	ROI	in	the	image,	the	largest
sample	will	be	trained.

4.	 Specify	labels	for	the	samples	to	add.
If	all	images	in	the	folder	are	of	the	same	class,	enable	the
Use	the	same	label	for	all	the	samples	option,	and	enter
the	label	in	the	Class	Label	control.
If	the	images	are	not	of	the	same	class,	enable	the	Use	a
file	that	specifies	the	labels	of	the	samples	option	to
specify	individual	labels	for	each	image.	Click	the	Browse
button	to	select	a	Labels	File	Path.	This	file	is	a	delimited
text	file	that	contains	a	corresponding	label	for	each	image.
A	delimiter	separates	the	image	name	from	its	label.

5.	 Click	Train	to	train	the	samples	in	all	the	images	of	the	folder.	The
training	process	trains	and	classifies	the	samples.

A	dialog	box	displays	the	results	of	the	batch	training.	The	first	tab
displays	the	label	and	scores	for	each	sample	as	well	as	if	it	was	properly
classified.	The	second	tab	displays	the	score	histogram,	which	displays
the	number	of	each	sample	for	each	score	value.	The	third	tab	displays
the	number	of	samples,	standard	deviation,	accuracy,	and	predictive
value	for	each	class.	The	fourth	tab	displays	the	classification	distribution.
The	last	tab	displays	the	mean	distance	from	each	class	to	each	other
class.



Batch	Classify
Batch	Training	Batch	Results
Use	Tools»Batch	Classify	to	classify	a	folder	of	images.
Complete	the	following	steps	to	classify	a	folder	of	images:

1.	 Click	Tools»Batch	Classify.
2.	 Click	the	Browse	button	to	select	the	folder	of	images	to	classify.

After	you	have	selected	the	folder	of	images,	click	Select	Cur	Dir.
3.	 Click	Draw	ROI	to	select	an	ROI	around	the	sample	to	classify.

Note		Make	sure	the	ROI	encompasses	the	sample	to
classify	in	all	images	in	the	folder.

4.	 Use	Batch	Classification	to	verify	the	accuracy	of	the	classifier.
You	must	provide	the	labels	of	all	images	in	the	folder	in	order	to
verify	the	accuracy	of	the	classifier.

To	check	the	accuracy	of	the	classification,	enable	the
Verify	Classification	option.
Click	the	Browse	button	to	select	a	Results	File	Path.	This
file	is	a	delimited	text	file	that	contains	a	corresponding
label	for	each	image.

5.	 Click	Classify	to	classify	the	samples	in	all	the	images	in	the
folder.	The	training	process	trains	and	classifies	the	samples.

A	dialog	box	displays	the	results	of	the	batch	classification.	The	first	tab
displays	the	label	and	scores	for	each	sample	as	well	as	if	it	was	properly
classified.	The	second	tab	displays	the	score	histogram,	which	displays
the	number	of	each	sample	for	each	score	value.	The	third	tab	displays
the	number	of	samples,	standard	deviation,	accuracy,	and	predictive
value	for	each	class.	The	fourth	tab	displays	the	classification	distribution.
The	last	tab	displays	the	mean	distance	from	each	class	to	each	other
class.



Batch	Results
Batch	Training	Batch	Classify
After	you	have	trained	or	classified	a	folder	of	images,	the	Batch	Results
dialog	box	displays	the	results	of	the	batch	training.	The	results	are
displayed	on	five	tabs:	Classification	Results,	Scores	Histogram,
Class	Information,	Classification	Distribution,	and	Distance	Table.



Classification	Results	Tab
The	classification	results	are	displayed	in	a	chart	that	lists	the	following
results	for	each	file	trained	and	classified:

Label—Class	to	which	the	sample	belongs.
Classification	Score—Degree	of	certainty	that	a	sample	is
assigned	to	one	class	instead	of	other	classes.
Identification	Score—Degree	of	similarity	between	a	sample	and
members	of	the	class	to	which	the	sample	is	assigned.
Classification—Classification	is	Good	if	the	sample	label	found
during	the	classification	process	matches	the	label	provided	by	the
user.	The	classification	is	Bad	if	the	sample	label	does	not	match.



Scores	Histogram	Tab
The	scores	histogram	displays	the	number	of	each	sample	classified	and
trained	for	each	score	value.
The	X-axis	can	represent	either	classification	scores	or	identification
scores.	The	Histogram	Mode	can	be	either	linear	or	cumulative.



Class	Information	Tab
The	accuracy	and	predictive	value	of	the	classification	are	displayed	in	a
chart	for	each	class.

Samples—Number	of	samples	belonging	to	the	class.
Standard	Deviation—Standard	deviation	from	the	mean	of	all
samples	in	the	class.
Accuracy	(sensitivity)—Probability	that	a	sample	is	classified	into
the	class	to	which	it	belongs.
Predictive	Value—Probability	that	a	sample	classified	into	a	given
class	belongs	to	that	class.



Classification	Distribution	Tab
The	classification	distribution	is	displayed	in	a	chart,	and	the	classifier
accuracy	is	calculated.	The	classification	distribution	is	a	matrix	that	gives
the	probability	that	a	sample	belonging	to	a	specific	class	will	be
classified	in	another	class.



Distance	Table	Tab
The	distance	table	displays	the	mean	distance	from	each	class	to	each
other	class.

Tip		You	can	also	display	this	dialog	by	choosing	Tools»Training
Summary.	Only	the	Class	Information,	Classification
Distribution,	and	Distance	Table	tabs	are	available.



Configuring	the	Preprocessing	Settings
Engine	Options	Particle	Classifier	Options
Use	the	settings	on	the	Preprocessing	tab	to	determine	how	you	want
the	classification	engine	to	calculate	the	threshold	value	it	uses	to
segment	particles	in	each	image.
Complete	the	following	steps	to	configure	the	preprocessing	settings:

1.	 Select	a	Method	for	thresholding.
Manual	Threshold	is	a	method	you	use	to	manually
determine	the	threshold	range	for	the	ROI.
Clustering	is	a	method	in	which	the	classification	engine
sorts	the	histogram	of	the	image	within	a	discrete	number	of
classes	corresponding	to	the	number	of	phases	perceived
in	an	image.	Clustering	is	the	most	frequently	used
automatic	thresholding	method.
Entropy	is	a	method	in	which	the	classification	engine
detects	samples	that	are	present	in	minuscule	proportions
on	the	image.
Metric	is	a	method	in	which	the	classification	engine
calculates	a	value	for	each	threshold	that	is	determined	by
the	surfaces	representing	the	initial	gray	scale.
Moments	is	a	method	of	thresholding	used	for	images	that
have	poor	contrast.
Inter	Variance	is	a	method	of	thresholding	used	for	images
in	which	classes	are	not	too	disproportionate.	For
satisfactory	results,	the	smallest	class	must	be	at	least	5%
of	the	largest	one.

2.	 If	you	selected	Manual	Threshold	in	Method,	use	the	Min	and
Max	controls	or	the	slider	at	the	bottom	of	the	histogram	to	set	the
threshold	value.	If	you	select	an	automatic	threshold	method,	the
algorithm	calculates	the	threshold	value	and	updates	the
Threshold	Range.	You	can	specify	a	Lower	Limit	and	an	Upper
Limit	for	the	threshold	computed	by	the	automatic	method.

3.	 Select	a	type	of	object	to	search	for	from	the	Look	For	drop-down
menu.	The	NI	Classifier	will	look	for	Bright	Objects,	Dark
Objects,	or	Gray	Objects.



4.	 Click	Reject	Objects	Touching	ROI	to	ignore	objects	that	are
touching	the	border	of	the	ROI	you	drew.

5.	 In	Remove	Small	Objects	(#	of	Erosions),	select	the	number	of
erosions	you	want	the	classification	engine	to	perform	to	remove
small	objects	from	the	ROI.
As	you	manipulate	settings	on	the	Preprocessing	tab,	the	NI
Classification	Training	Interface	displays	thresholded	objects	in
blue.

Tip		If	the	samples	in	the	ROI	are	not	classified	as	you	expect
them	to	be,	experiment	with	settings	on	the	Engine	Options	and
Particle	Classifier	Options	tabs	to	improve	the	classification.



Configuring	the	Engine	Options
Preprocessing	Particle	Classifier	Options
Use	the	Engine	Options	tab	to	indicate	the	Method	and	Metric	values
required	for	sample	classification.
Select	a	Method	on	the	Engine	Options	tab	to	configure	the	method	of
classification.

Nearest	Neighbor—Most	direct	approach	to	classification.	In
nearest	neighbor	classification,	the	distance	of	an	input	feature
vector	of	unknown	class	to	another	class	is	defined	as	the	distance
to	the	closest	samples	that	are	used	to	represent	that	class.
K-Nearest	Neighbor—More	tolerant	of	noise	compared	with
nearest	neighbor	classification.	In	K-nearest	neighbor
classification,	an	input	feature	vector	is	classified	into	a	class
based	on	a	voting	mechanism.	The	NI	Classifier	finds	K	nearest
samples	from	all	the	classes.	The	input	feature	vector	of	unknown
class	is	assigned	to	the	class	with	majority	of	the	votes	in	the	K
nearest	samples.
Minimum	Mean	Distance—Most	effective	in	applications	that
have	little	or	no	feature	pattern	variability	or	other	corruptive
influences.	In	minimum	mean	distance	classification,	an	input
feature	vector	of	unknown	class	is	classified	based	on	its	distance
to	each	class	center.

Select	a	Metric	on	the	Engine	Options	tab	to	configure	the	metric	used
in	the	classification	algorithm.

Maximum—Most	sensitive	to	small	variations	between	samples.
Use	Maximum	when	you	need	to	classify	samples	with	very	small
differences	into	different	classes.
Sum—Metric	used	in	most	classification	applications.	Sum	is	also
known	as	the	Manhattan	metric	or	Taxicab	metric.	This	is	the
default	Metric	value.
Euclidean—Least	sensitive	to	small	variations	between	samples.
Use	Euclidean	when	you	need	to	classify	samples	with	small
differences	into	the	same	class.
Tip		If	the	samples	in	the	ROI	are	not	classified	as	you	expect
them	to	be,	experiment	with	settings	on	the	Preprocessing	and



Particle	Classifier	Options	tabs	to	improve	the	classification.



Configuring	the	Particle	Classifier	Options
Preprocessing	Engine	Options
Use	the	Particle	Classifier	Options	tab	to	indicate	whether	the
classification	is	Scale	Dependent	or	Mirror	Dependent.

1.	 Enable	the	Scale	Dependent	option	if	you	want	to	distinguish
samples	of	different	sizes.

2.	 Enter	the	numeric	scale	factor	value	(between	0	and	1000)	in	the
Scale	Factor	control.	If	the	scale	factor	value	is	0,	the	samples
are	classified	independent	of	scale.

3.	 Enable	the	Mirror	Dependent	option	if	you	want	to	classify
mirrored	objects	in	separate	classes.

4.	 Enter	the	numeric	mirror	factor	value	(between	0	and	1000)	in	the
Mirror	Factor	control.	If	the	mirror	factor	value	is	0,	the	samples
are	classified	independent	of	mirror	symmetry.
Tip		If	the	samples	in	the	ROI	are	not	classified	as	you	expect
them	to	be,	experiment	with	settings	on	the	Preprocessing	and
Engine	Options	tabs	to	improve	the	classification.



Developing	Classification	Applications
You	can	use	the	following	Classification	Examples	to	learn	how	to	use
the	NI	Classification	Training	Interface	to	create	classification	applications
in	LabVIEW,	LabWindows/CVI,	and/or	Microsoft	Visual	Basic:

LabVIEW​Classification	Example,	which	is	located	in
<LabVIEW>\Examples\Vision\2.Functions\Classification\Classification.vi
Where	<LabVIEW>	is	the	location	to	which	you	installed	LabVIEW.
LabWindows/CVI​Classification	Example,	which	is	located	in
<CVI>\Samples\Vision\2.Functions\Classification\Classification.prj.
Where	<CVI>	is	the	location	to	which	you	installed
LabWindows/CVI.
Microsoft	Visual	Basic​Classification	Example,	which	is	located	in
<Vision>\Examples\MSVB\2.Functions\Classification\Classification.vbp.
Where	<Vision>	is	the	location	to	which	you	installed	Vision.



Classification	Example	for	LabVIEW
You	can	use	the	Classification	Example	for	LabVIEW	to	classify	samples
using	the	file	you	created	with	the	NI	Classification	Training	Interface
Tutorial.
Complete	the	following	steps	to	use	the	Classification	Example	for
LabVIEW:

1.	 Navigate	to	<LabVIEW>\Examples\Vision\2.Functions\Classification
and	open	the	Classification	VI.	Where	<LabVIEW>	is	the	location
to	which	you	installed	LabVIEW.

2.	 Run	the	VI.
3.	 Click	the	Browse	button	of	the	Classifier	File	Path	control	and

open	the	Tutorial.clf	file	you	created	upon	completing	the	NI
Classification	Training	Interface	Tutorial.

4.	 Click	Load	File.
5.	 Draw	an	ROI	around	the	sample	to	classify	and	click	Classify.
6.	 Click	Return	to	exit	the	example.



Classification	Example	for	LabWindows/CVI
You	can	use	the	Classification	Example	for	LabWindows/CVI	to	classify
samples	using	the	file	you	created	with	the	NI	Classification	Training
Interface	Tutorial.
Complete	the	following	steps	to	use	the	Classification	Example	for
LabWindows/CVI:

1.	 Navigate	to
<CVI>\Samples\Vision\2.Functions\Classification\Classification.prj.
Where	<CVI>	is	the	location	to	which	you	installed
LabWindows/CVI.

2.	 Click	Build»Configuration»Debug,	and	then	click	Run»Debug
Classification_dbg.exe	to	run	the	example.

3.	 Click	the	Browse	button	and	open	the	Tutorial.clf	file	you	created
upon	completing	the	NI	Classification	Training	Interface	Tutorial.

4.	 Click	Load	File,	select	one	of	the	image	files,	and	click	Load.
5.	 Draw	an	ROI	around	the	sample	to	classify	and	click	Classify.
6.	 Click	Return	to	exit	the	example.



WARNING	REGARDING	USE	OF	NATIONAL
INSTRUMENTS	PRODUCTS
(1)	National	Instruments	products	are	not	designed	with
components	and	testing	for	a	level	of	reliability	suitable	for	use	in	or
in	connection	with	surgical	implants	or	as	critical	components	in
any	life	support	systems	whose	failure	to	perform	can	reasonably
be	expected	to	cause	significant	injury	to	a	human.
(2)	In	any	application,	including	the	above,	reliability	of	operation	of
the	software	products	can	be	impaired	by	adverse	factors,	including
but	not	limited	to	fluctuations	in	electrical	power	supply,	computer
hardware	malfunctions,	computer	operating	system	software
fitness,	fitness	of	compilers	and	development	software	used	to
develop	an	application,	installation	errors,	software	and	hardware
compatibility	problems,	malfunctions	or	failures	of	electronic
monitoring	or	control	devices,	transient	failures	of	electronic
systems	(hardware	and/or	software),	unanticipated	uses	or
misuses,	or	errors	on	the	part	of	the	user	or	applications	designer
(adverse	factors	such	as	these	are	hereafter	collectively	termed
"system	failures").	Any	application	where	a	system	failure	would
create	a	risk	of	harm	to	property	or	persons	(including	the	risk	of
bodily	injury	and	death)	should	not	be	reliant	solely	upon	one	form
of	electronic	system	due	to	the	risk	of	system	failure.	To	avoid
damage,	injury,	or	death,	the	user	or	application	designer	must	take
reasonably	prudent	steps	to	protect	against	system	failures,
including	but	not	limited	to	back-up	or	shut	down	mechanisms.
Because	each	end-user	system	is	customized	and	differs	from
National	Instruments'	testing	platforms	and	because	a	user	or
application	designer	may	use	National	Instruments	products	in
combination	with	other	products	in	a	manner	not	evaluated	or
contemplated	by	National	Instruments,	the	user	or	application
designer	is	ultimately	responsible	for	verifying	and	validating	the
suitability	of	National	Instruments	products	whenever	National
Instruments	products	are	incorporated	in	a	system	or	application,
including,	without	limitation,	the	appropriate	design,	process	and
safety	level	of	such	system	or	application.



Technical	Support	and	Professional	Services
Visit	the	following	sections	of	the	National	Instruments	Web	site	at	ni.com
for	technical	support	and	professional	services:

Support—Online	technical	support	resources	at	ni.com/support
include	the	following:

Self-Help	Resources—For	answers	and	solutions,	visit	the
award-winning	National	Instruments	Web	site	for	software
drivers	and	updates,	a	searchable	KnowledgeBase,	product
manuals,	step-by-step	troubleshooting	wizards,	thousands	of
example	programs,	tutorials,	application	notes,	instrument
drivers,	and	so	on.
Free	Technical	Support—All	registered	users	receive	free
Basic	Service,	which	includes	access	to	hundreds	of
Applications	Engineers	worldwide	in	the	NI	Developer
Exchange	at	ni.com/exchange.	National	Instruments
Applications	Engineers	make	sure	every	question	receives
an	answer.

Training	and	Certification—Visit	ni.com/training	for	self-paced
training,	eLearning	virtual	classrooms,	interactive	CDs,	and
Certification	program	information.	You	also	can	register	for
instructor-led,	hands-on	courses	at	locations	around	the	world.
System	Integration—If	you	have	time	constraints,	limited	in-
house	technical	resources,	or	other	project	challenges,	NI	Alliance
Program	members	can	help.	To	learn	more,	call	your	local	NI	office
or	visit	ni.com/alliance.

If	you	searched	ni.com	and	could	not	find	the	answers	you	need,	contact
your	local	office	or	NI	corporate	headquarters.	You	also	can	visit	the
Worldwide	Offices	section	of	ni.com/niglobal	to	access	the	branch	office
Web	sites,	which	provide	up-to-date	contact	information,	support	phone
numbers,	email	addresses,	and	current	events.
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Navigating	Images
You	can	use	the	toolbar	buttons	to	navigate	the	images	you	opened	for
training.	Refer	to	the	following	button	descriptions	for	information	about
how	to	view	images.

Navigates	to	the	first	image	in	the	list	of	images	you	opened.
Navigates	to	the	previous	image.
Navigates	to	the	next	image.
Navigates	to	the	last	image	in	the	list	of	images	you	opened.



Classification	Example	for	Microsoft	Visual
Basic
You	can	use	the	Classification	Example	for	Microsoft	Visual	Basic	to
classify	samples	using	the	file	you	created	with	the	NI	Classification
Training	Interface	Tutorial.
Complete	the	following	steps	to	use	the	Classification	Example	for
Microsoft	Visual	Basic:

1.	 Navigate	to	<Vision>\Examples\MSVB\2.Functions\Classification	and
open	the	Classification.vbp	file.	Where	<Vision>	is	the	location	to
which	you	installed	Vision.

2.	 Run	the	example.
3.	 Click	the	Browse	button	and	open	the	Tutorial.clf	file	you	created

upon	completing	the	NI	Classification	Training	Interface	Tutorial.
4.	 Click	Load	File,	select	one	of	the	image	files,	and	click	Open.
5.	 Draw	an	ROI	around	the	sample	to	classify	and	click	Classify.
6.	 Click	Return	to	exit	the	example.



Branch	Offices
Office Telephone	Number
Australia 1800	300	800
Austria 43	0	662	45	79	90	0
Belgium 32	0	2	757	00	20
Brazil 55	11	3262	3599
Canada 800	433	3488
China 86	21	6555	7838
Czech	Republic 420	224	235	774
Denmark 45	45	76	26	00
Finland 385	0	9	725	725	11
France 33	0	1	48	14	24	24
Germany 49	0	89	741	31	30
India 91	80	51190000
Israel 972	0	3	6393737
Italy 39	02	413091
Japan 81	3	5472	2970
Korea 82	02	3451	3400
Lebanon 961	0	1	33	28	28
Malaysia 1800	887710
Mexico 01	800	010	0793
Netherlands 31	0	348	433	466
New	Zealand 0800	553	322
Norway 47	0	66	90	76	60
Poland 48	22	3390150
Portugal 351	210	311	210
Russia 7	095	783	68	51
Singapore 1800	226	5886
Slovenia 386	3	425	4200



South	Africa 27	0	11	805	8197
Spain 34	91	640	0085
Sweden 46	0	8	587	895	00
Switzerland 41	56	200	51	51
Taiwan 886	02	2377	2222
Thailand 662	992	7519
United	Kingdom 44	0	1635	523545
United	States	(Corporate) 512	683	0100


