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Use	the	Switch	Soft	Front	Panel	(SFP)	as	a	tool	to	test	the	basic
functionality	of	your	switch	device	and	trouble-shoot	your	applications.
Because	the	Switch	SFP	enables	you	to	monitor	connections	on	a	switch
module	as	you	make	them,	the	Switch	SFP	is	also	a	powerful	debugging
tool.



Accessing	the	Switch	Soft	Front	Panel
You	can	access	the	Switch	SFP	from	within	Measurement	&	Automation
Explorer	(MAX)	or	from	the	Start	menu.	To	launch	the	Switch	SFP	from
the	Tools	menu	in	MAX	or	from	the	Start	menu,	NI-SWITCH	2.4	or	later
must	be	installed.

Note		The	Switch	SFP	does	not	support	switch	devices	used	with
the	LabVIEW	Real-Time	Module.

From	MAX
Right-click	on	the	switch	device,	and	select	Test	Panels.

or
Select	Tools»Soft	Front	Panels»NI-SWITCH	Soft	Front	Panel.

From	the	Start	Menu
Select	Start»All	Programs»National	Instruments»NI-SWITCH»NI-
SWITCH	Soft	Front	Panel.



The	Switch	Soft	Front	Panel	Toolbar
Controls
Active	Device—Lists	all	of	the	switch	devices	that	are	installed	on	your
system.	This	list	also	includes	simulated	switch	devices	created	in	MAX.	

Topology—Lists	all	of	the	topologies	associated	with	the	switch	device.



Icons
Select	the	Refresh	icon	to	refresh	the	views	of	the	Schematic	and
Relay	tabs	of	the	Switch	Device	window.
Select	the	Disconnect	All	icon	to	disconnect	all	existing
connections	on	the	switch	device.



Switch	Device	Window
The	Switch	Device	window	displays	information	about	the	active	switch
device	and	is	divided	into	the	following	access	tabs:

Schematic	tab
Relays	tab



The	Schematic	Tab
The	Schematic	tab	contains	a	graphical	representation,	or	schematic,	of
the	topology	of	the	switch	device.
Use	the	Schematic	tab	to	control	the	switch	device.	Simply	click	the
connections	on	the	Schematic	tab	to	make	connections	on	the	switch
device.	The	Switch	SFP	translates	these	clicks	into	the	appropriate
channel	connections	and	makes	driver	calls	to	execute	the	connections.
Additionally,	use	the	Schematic	tab	to	verify	the	connection	state	of	the
switch	device.

Note		When	a	scan	list	is	downloaded	and	the	active	switch	device
is	being	scanned,	the	Schematic	tab	is	not	operational	and	does
not	reflect	the	state	of	the	switch	hardware.

Depending	on	the	topology	you	select	in	the	Topology	listbox	on	the
Switch	SFP	toolbar,	one	of	four	topologies	is	displayed	in	the
Schematic	tab:

Matrix
Multiplexer
Single-Pole	Double-Throw
Single-Pole	Single-Throw



The	Matrix	Topology
A	matrix	is	a	flexible	topology	that	can	connect	multiple	inputs	to	multiple
outputs	organized	as	columns	and	rows.	You	can	connect	any	column	to
any	number	of	rows	and	any	row	to	any	number	of	columns.	Refer	to	the
NI	Switches	Help	for	more	information	about	matrix	topologies.
On	a	matrix	schematic,	row-column	cross-points	represent	potential
connections	on	the	switch	device.	For	visibility,	the	Switch	SFP	displays
each	connection	and	its	associated	connection	route	on	the	matrix
schematic	in	a	different	color.	For	a	channel	with	multiple	connections,
the	Switch	SFP	displays	all	of	the	connections	and	their	associated
connection	routes	in	the	same	color.	Refer	to	row	0	(r0)	of	the	schematic
below	for	an	example	of	a	matrix	channel	with	multiple	connections.

Note		You	can	resize	the	Switch	Device	window	to	see	more
channels.

Refer	to	the	schematic	below	for	an	example	of	the	NI	PXI-2532	in	the	1-
Wire	4×128	matrix	topology.



Make	a	Matrix	Connection
Click	a	row-column	cross-point	to	make	a	connection	on	the	matrix.	To
break	a	connection,	simply	click	the	connection	again.	The	Switch	SFP
makes	the	appropriate	connect/disconnect	calls	to	the	driver.



The	Multiplexer	Topology
A	multiplexer,	or	a	mux,	is	a	topology	in	which	you	can	connect	one	input
to	multiple	outputs	or	one	output	to	multiple	inputs.	Use	this	topology	to
connect	a	sequence	of	channels	to	a	common	line.	Refer	to	the	NI
Switches	Help	for	more	information	about	multiplexer	topologies.

Note		You	can	resize	the	Switch	Device	window	to	see	more
channels.

Refer	to	the	schematic	below	for	an	example	of	the	NI	PXI-2575	in	the	1-
Wire	196×1	mux	topology.



Make	a	Multiplexer	Connection
Click	the	end	of	the	pole	associated	with	the	channel	(left)	you	want	to
connect	to	the	com	channel	(right).	The	Switch	SFP	makes	the
appropriate	connect/disconnect	calls	to	the	driver.



The	Single-Pole	Double-Throw	Topology
The	single-pole	double-throw	(SPDT)	topology	is	composed	of	one-pole,
two-throw	relays.	Based	on	the	default	position	of	the	pole,	one	throw	is
considered	normally	open	(NO)	while	the	other	is	normally	closed	(NC).
Refer	to	the	NI	Switches	Help	for	more	information	about	SPDT
topologies.

Note		You	can	resize	the	Switch	Device	window	to	see	more	SPDT
relays.

Refer	to	the	schematic	below	for	an	example	of	the	NI	PXI-2566	in	the
16-SPDT	topology.



Make	an	SPDT	Connection
Click	on	an	individual	relay	to	make	an	SPDT	connection.	To	connect	no5
to	com5,	for	example,	simply	click	on	the	relay.	The	pole	connects	no5	to
com5,	and	the	Switch	SFP	makes	the	appropriate	connect/disconnect
calls	to	the	driver.



The	Single-Pole	Single-Throw	Topology
The	single-pole	single-throw	(SPST)	topology	is	composed	of	one-pole,
one-throw	relays.	Refer	to	the	NI	Switches	Help	for	more	information
about	SPST	relay	forms.

Note		You	can	resize	the	Switch	Device	window	to	see	more	SPST
relays.

Refer	to	the	schematic	below	for	an	example	of	the	NI	PXI-2564	in	the
16-SPST	topology.



Make	an	SPST	Connection
Click	on	an	individual	relay	to	make	an	SPST	connection.	The
Switch	SFP	translates	this	click	into	the	appropriate	channel	connection
and	makes	the	connect	call	to	the	driver.	To	connect	ch2	to	com2,	for
example,	click	on	the	relay.	The	pole	connects	ch2	to	com2.	To	break	a
connection,	simply	click	the	connection.	The	Switch	SFP	makes	the
appropriate	connect/disconnect	calls	to	the	driver.



The	Relays	Tab
The	Relays	tab	displays	the	name,	position,	and	count	of	each	relay	on
the	switch	device.	Use	the	relay	count	information	to	determine	if	the
relays	on	the	switch	device	are	approaching	their	life-time	expectancy
and	if	scheduled	maintenance	is	needed.	If	your	switch	device	does	not
support	relay	counts,	the	Relays	tab	displays	only	the	names	and	the
positions	of	the	relays.

Note		When	using	the	NI	USB-1359	to	control	a	switch,	the	Switch
SFP	optimizes	updates	to	the	relay	states	by	updating	only	the
relays	that	are	visible.	Relay	states	that	have	not	been	updated	are
displayed	in	blue.	Upon	update,	the	relay	states	are	changed	from
blue	to	black.

Visit	ni.com	and	search	by	the	switch	module	name	to	order	replacement
relays	for	your	switch	module.	For	relay	replacement	instructions,	refer	to
the	Relay	Replacement	section	for	your	switch	module	in	the	NI	Switches
Help.
The	figure	below	illustrates	the	relay	positions	and	counts	for	the	NI	PXI-
2566.





Creating	a	New	Window
Create	a	new	window	to	monitor	multiple	switch	devices	simultaneously.
You	can	create	a	new	window	for	the	same	device	or	different	devices
without	causing	changes	in	the	hardware.	To	open	multiple	instances	of
the	Switch	SFP,	select	File»New	Window.



Customizing	the	Switch	Soft	Front	Panel
You	can	customize	settings	and	operations	in	the	Switch	SFP.



Customizing	the	Refresh	Settings
Select	File»Options,	and	click	Automatic	Refresh	to	disable	the
automatic	refresh	settings	for	the	Schematic	and	Relay	tabs.	To	enable
the	refresh	settings,	click	Automatic	Refresh	again.	Type	in	a	delay
time,	in	milliseconds,	to	customize	the	delay	interval,	or	the	amount	of
time	that	must	elapse	before	the	Schematic	and	Relays	tabs	are
refreshed	with	the	latest	information	for	the	switch	device.



Customizing	Relay	Operations
Select	File»Options,	and	click	Enable	changing	relay	positions	to
customize	relay	operations.	With	the	Enable	changing	relay	positions
control	enabled,	you	can	change	the	relay	positions	of	the	switch	device
from	within	the	Relays	tab.



Relay	Maintenance
Expand	this	topic	for	information	about	relay	maintenance,	including
instructions	for	replacing	and	resetting	a	relay.



Determining	Relay	End-of-Life
Relay	use	affects,	and	relay	arcing	can	accelerate,	the	end-of-life	of	a
relay.	For	more	detailed	information	about	relay	life	and	arcing,	refer	to
the	NI	Switches	Help.	To	determine	the	expected	life	of	your	relay,	refer
to	the	specifications	document	for	your	switch	module.
To	determine	if	you	need	to	replace	a	relay,	monitor	the	relay	count	of
your	switch	module	in	the	Relays	Tab	of	the	Switch	Device	window.	If
you	have	switched	a	relay	beyond	its	expected	life	or	it	has	sustained
excessive	arcing,	refer	to	Replacing	a	Relay.



Replacing	a	Relay
Refer	to	the	Relay	Replacement	topic	for	your	switch	module	in	the
NI	Switches	Help	for	instructions	on	how	to	replace	a	relay.	After	you
replace	the	relay,	refer	to	Resetting	a	Relay	Count.



Resetting	a	Relay	Count
Caution		Because	the	Switch	SFP	disables	relay	count
synchronization	during	the	relay	count	reset	process,	counts	may
be	lost	for	any	relay	operation	performed	up	to	ten	minutes	prior	to
resetting	a	relay	count.

Complete	the	following	steps	to	reset	a	relay	count.
1.	 Select	File»Relay	Maintenance.	The	Relay	Maintenance	dialog

box	appears.
2.	 Select	the	relay	to	reset	from	the	Relay	Name	drop-down	list.
3.	 (Optional)	Record	the	Existing	Relay	Count	for	your	records.
4.	 Verify	the	relay	you	selected	for	reset,	and	click	OK	to	reset	the

relay	count	to	zero.	The	Switch	SFP	saves	the	new	relay	count	to
the	hardware	and	resets	the	active	device.



Restoring	a	Relay	Count
In	case	of	unintentional	relay	reset,	complete	the	following	steps	to
restore	a	previous	relay	count.

1.	 Repeat	steps	1	and	2	of	Resetting	a	Relay.
2.	 Verify	the	relay	you	selected	for	reset,	and	enable	Edit	Count.
3.	 Type	the	previous	count	in	New	Relay	Count	and	click	OK.	The

Switch	SFP	saves	the	relay	count	to	the	hardware	and	resets	the
active	device.



Remotely	Accessing	the	Switch	Soft	Front	Panel
Using	a	Browser
You	can	view	and	control	the	Switch	SFP	and	debug	switch	applications
remotely	using	a	Web	browser.	To	access	the	Switch	SFP	from	a	client
machine,	first	configure	the	Web	host	feature	on	the	server	machine.



Configuring	the	Server
Complete	the	following	steps	to	configure	the	Web	host	feature	on	the
server	machine.

1.	 Run	the	Switch	SFP	on	the	server.
2.	 Select	File»Options	to	display	the	Options	dialog	box.
3.	 Select	the	Web	Host	tab.
4.	 Click	the	Enable	Web	host	checkbox.
5.	 Replace	the	value	of	Listen	on	port	number	with	the	TCP	port

value	you	want	to	use.
Note		If	you	use	a	TCP	port	value	other	than	80,	you	must
specify	the	TCP	port	value	on	the	URL	that	refers	to	the
server	when	accessing	the	Switch	SFP	from	a	client
machine.	For	example,	if	your	TCP	port	value	is	8000,
specify	the	TCP	port	value	on	the	URL	as
http://ipaddress:8000/SwitchSoftFrontPanel.htm.

After	you	configure	the	server,	the	client	can	view	and	control	the	Switch
SFP.	If	you	want	to	disable	control	of	the	Switch	SFP	and	leave	only
viewing	capability	from	the	client,	right-click	anywhere	on	the	Switch	SFP
window	of	the	server	outside	of	the	access	tabs	(i.e.,	the	Schematic	or
Relay	tab),	and	select	Regain	Control	from	the	shortcut	menu.	Control
of	the	Switch	SFP	then	returns	to	the	server,	and	the	server	is	locked.
When	the	server	is	locked,	the	client	can	view	the	Switch	SFP	but	cannot
control	it.
To	unlock	the	server,	right-click	anywhere	on	the	Switch	SFP	window
outside	of	the	access	tabs,	and	select	Unlock	Control	from	the	shortcut
menu.	The	server	is	unlocked,	and	control	returns	to	the	client.



Remotely	Accessing	the	Switch	SFP
Complete	the	following	steps	to	view	and	control	the	Switch	SFP
remotely	using	a	browser	on	a	client	machine.

1.	 Launch	the	default	browser	on	the	client.
2.	 In	the	URL	of	the	browser,	enter	the	IP	address	or	computer	name

of	the	server	followed	by	SwitchSoftFrontPanel.htm,	for	example,
http://ipaddress/SwitchSoftFrontPanel.htm.	

Note		If	the	LabVIEW	Run-Time	Engine	is	not	installed	on	the
client,	entering	the	URL	prompts	you	for	installation.	You	can	install
the	LabVIEW	Run-Time	Engine	from	the	LabVIEW	CD	or	visit	the
National	Instruments	Web	site	to	download	the	latest	version.
Refer	to	the	LabVIEW	Help	for	more	information	about	the
LabVIEW	Run-Time	Engine.

To	close	your	connection	to	the	Switch	SFP	running	on	the	server,	click
the	close	glyph	on	the	browser	window.

javascript:WWW(WWW_LV_Updates)


Additional	Considerations
Only	the	server	window	titled	Switch	Soft	Front	Panel	-	Web	Host	can

be	remotely	controlled.	You	cannot	remotely	control	new	windows
created	on	the	server.
The	File»New	Window	menu	item	does	not	launch	a	new	window	on

the	client.	Launch	separate	instances	of	the	Switch	SFP	on	separate
TCP	ports	to	view	multiple	windows.
Online	help	is	only	available	on	the	server	machine.



Hot	Keys	and	Keyboard	Shortcuts
The	table	below	lists	the	hot	keys	and	keyboard	shortcuts	you	can	use
with	Switch	SFP:

<F5> Refreshes	the	Schematic	and	Relays	tabs	of	the	Switch
Device	window

<F1>	 Displays	online	help
<Ctrl+N> Creates	a	new	window
<Ctrl+Q>	 Exits	Switch	SFP



Debugging	with	the	Switch	Soft	Front	Panel
When	you	launch	the	Switch	SFP	for	a	particular	switch	device,	the
current	connections	on	the	switch	device	are	displayed	in	the	Schematic
tab	of	the	Switch	Device	window.
By	default,	the	Switch	SFP	automatically	updates	all	changes	in	the
connection	state	of	the	switch	device.	If	an	application	changes	the	state
of	the	connections	on	the	switch	device,	and	you	have	enabled	the
Automatic	Refresh	option	in	the	Switch	SFP,	this	change	is	reflected	in
the	Schematic	tab.	For	example,	if	you	have	an	application	running	in
LabVIEW,	the	Switch	SFP	displays	the	connections	made	by	the
LabVIEW	application.
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