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This	help	file	describes	the	NI	Spy	software.	NI	Spy	is	an	application	that
monitors,	records,	and	displays	National	Instruments	API	calls	made	by
applications.	Use	NI	Spy	to	quickly	locate	and	analyze	any	erroneous
National	Instruments	API	calls	that	your	application	makes,	and	to	verify
that	the	communication	with	your	instrument	is	correct.
For	more	information	about	this	help	file,	refer	to	the	following	topics:
Using	Help
Important	Information
Technical	Support	and	Professional	Services
To	comment	on	National	Instruments	documentation,	refer	to	the	National
Instruments	Web	site.
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Using	Help
Conventions
Navigating	Help
Searching	Help
Printing	Help	File	Topics



Conventions
This	help	file	uses	the	following	formatting	and	typographical
conventions:

» The	»	symbol	leads	you	through	nested	menu	items	and
dialog	box	options	to	a	final	action.	The	sequence	File»Page
Setup»Options	directs	you	to	pull	down	the	File	menu,
select	the	Page	Setup	item,	and	select	Options	from	the	last
dialog	box.
This	icon	denotes	a	note,	which	alerts	you	to	important
information.

bold Bold	text	denotes	items	that	you	must	select	or	click	in	the
software,	such	as	menu	items	and	dialog	box	options.	Bold
text	also	denotes	parameter	names.

green Underlined	text	in	this	color	denotes	a	link	to	a	help	topic,
help	file,	or	Web	address.

monospace Text	in	this	font	denotes	text	or	characters	that	you	should
enter	from	the	keyboard,	sections	of	code,	programming
examples,	and	syntax	examples.	This	font	is	also	used	for
the	proper	names	of	disk	drives,	paths,	directories,
programs,	subprograms,	subroutines,	device	names,
functions,	operations,	variables,	filenames,	and	extensions.



Navigating	Help	(Windows	Only)
To	navigate	this	help	file,	use	the	Contents,	Index,	and	Search	tabs	to
the	left	of	this	window	or	use	the	following	toolbar	buttons	located	above
the	tabs:

Hide—Hides	the	navigation	pane	from	view.
Locate—Locates	the	currently	displayed	topic	in	the	Contents
tab,	allowing	you	to	view	related	topics.
Back—Displays	the	previously	viewed	topic.
Forward—Displays	the	topic	you	viewed	before	clicking	the
Back	button.
Options—Displays	a	list	of	commands	and	viewing	options	for
the	help	file.



Searching	Help	(Windows	Only)
Use	the	Search	tab	to	the	left	of	this	window	to	locate	content	in	this	help
file.	If	you	want	to	search	for	words	in	a	certain	order,	such	as	"related
documentation,"	add	quotation	marks	around	the	search	words	as	shown
in	the	example.	Searching	for	terms	on	the	Search	tab	allows	you	to
quickly	locate	specific	information	and	information	in	topics	that	are	not
included	on	the	Contents	tab.



Wildcards
You	also	can	search	using	asterisk	(*)	or	question	mark	(?)	wildcards.
Use	the	asterisk	wildcard	to	return	topics	that	contain	a	certain	string.	For
example,	a	search	for	"prog*"	lists	topics	that	contain	the	words
"program,"	"programmatically,"	"progress,"	and	so	on.
Use	the	question	mark	wildcard	as	a	substitute	for	a	single	character	in	a
search	term.	For	example,	"?ext"	lists	topics	that	contain	the	words
"next,"	"text,"	and	so	on.

Note		Wildcard	searching	will	not	work	on	Simplified	Chinese,
Traditional	Chinese,	Japanese,	and	Korean	systems.



Nested	Expressions
Use	nested	expressions	to	combine	searches	to	further	refine	a	search.
You	can	use	Boolean	expressions	and	wildcards	in	a	nested	expression.
For	example,	"example	AND	(program	OR	VI)"	lists	topics	that	contain
"example	program"	or	"example	VI."	You	cannot	nest	expressions	more
than	five	levels.



Boolean	Expressions
Click	the	 	button	to	add	Boolean	expressions	to	a	search.	The	following
Boolean	operators	are	available:

AND	(default)—Returns	topics	that	contain	both	search	terms.
You	do	not	need	to	specify	this	operator	unless	you	are	using
nested	expressions.
OR—Returns	topics	that	contain	either	the	first	or	second	term.
NOT—Returns	topics	that	contain	the	first	term	without	the
second	term.
NEAR—Returns	topics	that	contain	both	terms	within	eight	words
of	each	other.



Search	Options

Use	the	following	checkboxes	on	the	Search	tab	to	customize	a	search:
Search	previous	results—Narrows	the	results	from	a	search
that	returned	too	many	topics.	You	must	remove	the	checkmark
from	this	checkbox	to	search	all	topics.
Match	similar	words—Broadens	a	search	to	return	topics	that
contain	words	similar	to	the	search	terms.	For	example,	a	search
for	"program"	lists	topics	that	include	the	words	"programs,"
"programming,"	and	so	on.
Search	titles	only—Searches	only	in	the	titles	of	topics.



Printing	Help	File	Topics	(Windows	Only)
Complete	the	following	steps	to	print	an	entire	book	from	the	Contents
tab:

1.	 Right-click	the	book.
2.	 Select	Print	from	the	shortcut	menu	to	display	the	Print	Topics

dialog	box.
3.	 Select	the	Print	the	selected	heading	and	all	subtopics	option.

Note		Select	Print	the	selected	topic	if	you	want	to	print
the	single	topic	you	have	selected	in	the	Contents	tab.

4.	 Click	the	OK	button.



Printing	PDF	Documents
This	help	file	may	contain	links	to	PDF	documents.	To	print	PDF
documents,	click	the	print	button	located	on	the	Adobe	Acrobat	Viewer
toolbar.



NI	Spy	Overview
NI	Spy	is	an	application	that	monitors,	records,	and	displays	National
Instruments	API	calls	made	by	applications.	Use	NI	Spy	to	quickly	locate
and	analyze	any	erroneous	National	Instruments	API	calls	that	your
application	makes,	and	to	verify	that	the	communication	with	your
instrument	is	correct.



Getting	Help	with	NI	Spy
To	access	API	help	on	a	function	displayed	in	the	capture	window,	select
Help»Help	on	Function	or	right-click	on	the	function	call	and	select	Help
on	Function.	The	function	help	describes	a	function's	purpose,	syntax,
parameters,	and	return	values.
To	access	the	properties	of	a	function	displayed	in	the	capture	window,
right-click	on	the	function	call	and	select	Properties.
To	access	context-sensitive	help	for	any	UI	item,	click	on	the	Help	button	
,	and	then	hover	over	the	item	for	which	you	need	help.



Performance	Considerations
NI	Spy	can	slow	down	the	performance	of	your	application	and	the	entire
system.	Certain	configurations	of	NI	Spy	have	a	larger	impact	on
performance	than	others.	For	example,	configuring	NI	Spy	to	keep	a	file
log	or	to	record	full	buffer	information	might	have	a	significant	negative
effect	on	the	performance	of	both	your	application	and	the	system.	You
should	use	NI	Spy	only	while	you	are	debugging	your	application	or	when
performance	is	not	critical.
To	improve	performance	when	capturing	calls,	NI	Spy	double	buffers	call
information,	up	to	the	history	depth	size	you	have	specified.	Making	the
history	depth	very	small	also	has	a	significant	negative	impact	on
performance.



Saving	Captured	Data	as	a	.spy	File
To	save	the	information	displayed	in	the	NI	Spy	capture	window,	select
File»Save	As.	In	the	dialog	box	that	appears,	select	a	name	for	the
capture	file.

Note		A	.spy	extension	is	usually	used	for	saving	NI	Spy	capture
information.	If	you	want	the	NI	Spy	information	to	be	saved
automatically,	as	soon	as	the	API	call	is	recorded,	use	file	logging.
Alternately,	you	can	also	export	data	as	a	.txt	or	.csv	file.	But	unlike
a	.spy	file,	you	cannot	import	an	exported	NI	Spy	file	at	a	later	time.



Logging	Captured	Data	to	File
To	save	the	captured	NI	Spy	information	automatically	as	soon	as	it	is
recorded,	use	file	logging.	If	you	enable	file	logging,	the	NI	Spy	log	file	is
written	as	soon	as	each	call	is	recorded.	This	option	is	useful	in
debugging	an	application	that	causes	the	system	to	crash	before	you	can
save	current	captures,	because	you	can	open	the	log	file	after	restarting
the	system	to	see	which	call	caused	the	error.

Note		To	guarantee	that	the	captured	log	file	is	complete	during	a
crash,	log	a	Spy	Capture	file	with	Write	to	file	as	soon	as
possible	selected.

To	enable	NI	Spy	file	logging,	follow	these	steps:
1.	 Select	Spy»Options	when	capture	is	stopped.
2.	 In	the	File	Logging	box,	check	the	Log	to	File	checkbox.

In	the	edit	box,	either	type	the	path	and	name	for	the	log	file,	or
use	the	Browse	button	to	select	a	location	for	the	NI	Spy	log	file.

3.	 Select	the	type	of	file	to	log.

For	most	applications,	a	Spy	Capture	file	is	the	best	option.	A	Spy
Capture	file	is	a	binary	format	that	is	the	quickest	to	create,	and	it
can	be	logged	in	a	fail-safe	manner	if	you	select	Write	to	file	as
soon	as	possible.	Only	NI	Spy	can	open	and	display	Spy
Capture	files,	but	you	can	export	them	to	other	formats	after
logging	is	completed.

If	other	applications	need	the	log	output	while	NI	Spy	is	logging,
log	to	a	plain	text	file	or	comma-separated	variable	(CSV)	file.
These	files	are	slower	to	create	and	lack	much	of	the	information
stored	in	a	Spy	Capture	file.	But	they	are	logged	during	NI	Spy
operation,	and	other	applications	processing	the	output	can	use
them.	However,	NI	Spy	cannot	load	these	files.

4.	 Select	the	method	of	file	logging.

If	you	select	Allow	NI	Spy	to	schedule	writing	(the	default),	the
log	file	is	written	with	each	recorded	API	call	and	closed	only
when	capture	is	stopped.	This	method	of	file	logging	is	more



efficient	than	selecting	Write	to	file	as	soon	as	possible,	but
may	not	be	secure	during	system	crashes.	Consequently,	you
should	use	this	option	only	if	the	problem	you	are	trying	to	debug
does	not	cause	a	system	crash.

If	you	select	Write	to	file	as	soon	as	possible,	the	log	file	is
opened,	written,	and	flushed	with	each	recorded	API	call.	When
logging	to	a	Spy	Capture	file,	this	method	of	file	logging	is	secure
during	system	crashes,	but	is	somewhat	slow	because	of	the
overhead	caused	by	repeatedly	opening	and	closing	the	log	file.

Note		Using	file	logging	is	likely	to	slow	down	all	applications.	In
addition,	if	you	are	low	on	disk	space,	choosing	this	option	could
cause	you	to	run	out	of	disk	space.	To	turn	off	file	logging,	uncheck
the	Log	to	File	checkbox.



Exporting	Captured	Data	as	a	.txt	or	.csv	File
To	save	abbreviated	information	about	the	captured	API	calls,	you	can
save	the	captured	API	calls	as	a	text	file	or	comma-delimited
spreadsheet	file.	Select	File»Export...	and	choose	either	the	Text	Files
(*.txt)	or	Comma	Delimited	(*.csv)	option.	A	.txt	file	contains	only	basic
information	about	the	captured	API	calls	and	can	be	viewed	in	any	text
editor.	A	.csv	file	also	contains	only	basic	information	and	can	be	viewed
in	any	spreadsheet	application.	However,	NI	Spy	export	files	cannot
subsequently	be	imported	into	NI	Spy.	You	can	generate	an	NI	Spy
export	file	from	a	previously	saved	NI	Spy	file	by	opening	the	saved	.spy
file	in	NI	Spy	and	then	exporting	it.	To	aid	in	debugging,	save	the	data	as
a	.spy	file.
The	Extended	export	setting	does	not	apply	to	.csv	files	because	the
comma-delimited	files	would	be	too	large.	All	exported	.csv	files	use	the
Summary	export	mode.



Printing	NI	Spy	Data
To	print	the	information	displayed	in	the	NI	Spy	capture	window,	select
File»Print...	or	click	on	the	Print	button	 	on	the	toolbar.

Note		You	can	print	the	information	only	when	capture	is	stopped.

To	print	information	previously	saved	in	a	.spy	file,	first	open	the	file	in	NI
Spy	and	then	print	the	file.
You	can	print	exported	NI	Spy	.txt	or	.csv	files	from	within	some
application	besides	NI	Spy,	such	as	a	text-based	editor	or	spreadsheet;
NI	Spy	cannot	import	NI	Spy	.txt	or	.csv	files.
You	can	print	the	entire	list	of	calls,	or	you	can	print	a	range	of	calls	by
choosing	Lines	and	specifying	the	first	and	last	call	numbers	in	the	Print
range	area	of	the	print	dialog	box.

Note		NI	Spy	includes	two	options	for	printing	captured	call	data:
Summary,	which	includes	only	the	call	description,	and	Extended,
which	includes	buffer	data	details.	To	select	the	Summary	or
Extended	option,	select	Spy»Options.	In	the	Print/Export
Settings	box,	select	Summary	(Call	description	only)	or
Extended	(Buffer	data	details).



Print/Export	Settings
NI	Spy	includes	two	options	for	printing	and	exporting	captured	call	data:
Summary,	which	includes	only	the	call	description,	and	Extended,	which
includes	buffer	data	details.
To	select	the	Summary	or	Extended	option,	select	Spy»Options.	In	the
Print/Export	Settings	box,	select	Summary	(Call	description	only)	or
Extended	(Buffer	data	details).
The	Extended	export	setting	does	not	apply	to	.csv	files	because	the
comma-delimited	files	would	be	too	large.	All	exported	.csv	files	use	the
Summary	export	mode.



Viewing	Captured	Driver	Calls
You	can	view	API	calls	as	they	are	captured	by	NI	Spy	in	the	main	NI	Spy
window.	The	captured	API	calls	are	displayed	in	the	order	in	which	they
occur.	A	line	of	information	is	displayed	for	each	captured	call,	including
the	call	number,	a	C-style	function	prototype,	start	time	for	the	call,
Process	ID,	and	Thread	ID.	Other	information	may	be	displayed	based
on	your	column	header	selections.	Refer	to	Selecting	Column	Headers
for	more	information	about	column	headers.	Detailed	call	information	is
displayed	in	the	Properties	dialog	box.



Viewing	Detailed	Call	Information
You	can	see	detailed	call	information	for	every	captured	API	call	in	NI
Spy	using	the	Properties	dialog	box.	The	Properties	dialog	box	includes
one	to	four	pages	of	detailed	information	on	the	captured	call.	All
captured	calls	have	a	General	page,	most	captured	calls	have	Input	and
Output	pages,	and	some	captured	calls	have	a	Buffer	page.	The
General	page	displays	information	about	the	application	that	made	the
API	call	and	time	statistics	for	the	API	call.	The	Input	page	displays	the
API	call's	input	parameters.	The	Output	page	displays	the	API	call's
return	parameters	upon	call	completion.	The	Buffer	page	is	present	only
for	calls	that	involve	the	transfer	of	a	buffer	of	data;	this	page	displays	the
contents	of	the	data	buffer.
For	help	on	the	characteristics	of	the	General,	Input,	Output,	and	Buffer
pages,	look	at	the	context-sensitive	help	in	the	NI	Spy	application	by
using	the	question	mark	button	on	the	title	bar	of	the	Properties	dialog
box	 .
To	see	the	Properties	of	a	specific	call,	double-click	on	the	call	in	the
capture	window,	select	View»Properties,	or	right-click	on	the	call	and
select	Properties.

Note		If	no	input,	output,	or	buffer	information	exists	for	a	particular
call,	that	page	is	not	displayed	in	that	call's	Properties	dialog	box.



Opening	a	Previously	Saved	Capture	File
To	open	a	previously	saved	NI	Spy	capture	file,	select	File»Open.

Note		In	Windows,	You	can	also	open	a	.spy	file	directly	from	the
Windows	shell	or	Explorer	by	double-clicking	on	it.

Note		Any	data	that	was	exported	as	a	.txt	or	.csv	file	cannot
subsequently	be	reopened	from	NI	Spy.	Instead,	the	file	must	be
opened	from	a	text-based	editor	or	spreadsheet	application.



Clearing	NI	Spy	Captured	Data
To	permanently	delete	the	captured	calls	from	the	NI	Spy	capture
window,	select	Edit»Clear	All.



Finding	Captured	Calls
To	search	through	captured	calls	to	find	a	specific	string	(API	function
names,	parameter	values,	or	any	other	string)	select	Edit»Find	or	press
<Ctrl-F>	in	Windows,	<Meta-F>	in	Linux,	or	<Command-F>	in	Mac	OS	X.
Enter	the	search	text	in	the	Find	what	box	and	click	Find	Next	to	find	the
next	captured	call	containing	the	specified	string	(the	search	is	limited	to
the	Call	Description	column).	Use	the	drop-down	menu	over	the	Find
what	box	to	change	the	type	of	string	used	to	search	the	calls.	Backslash
codes	and	hexadecimal	are	especially	useful	when	searching	buffers,	as
opposed	to	normal	strings.
Use	the	Match	errors	only	to	limit	the	search	to	captured	calls	that	have
an	error.	If	you	do	not	specify	a	search	string,	the	search	locates	the	next
captured	call	that	failed.	If	you	do	specify	a	search	string,	the	search	for
the	specified	string	is	limited	to	those	calls	that	failed.
You	can	further	qualify	the	search	parameters	by	selecting	Match	case
and	by	specifying	a	search	direction	of	Up	or	Down.
Search	buffer	data	includes	call	buffers	in	the	search.
To	repeat	the	search,	click	Find	Next	in	the	dialog	box,	select	Edit»Find
Next,	or	press	<Ctrl-F3>	in	Windows,	<Meta-F3>	in	Linux,	or
<Command-F3>	in	Mac	OS	X.



Capture	Options
To	view	or	modify	your	NI	Spy	capture	options,	select	Spy»Options.	By
default,	NI	Spy	displays	1000	calls	in	the	capture	window,	displays
buffers	in	Small	buffer	mode,	and	does	not	enable	file	logging.

Note		You	can	modify	NI	Spy	options	only	when	capture	is
stopped.



Call	History	Depth
The	Call	history	depth	reflects	the	maximum	number	of	API	calls	that	NI
Spy	can	display.	When	the	number	of	captured	API	calls	exceeds	the
Call	history	depth,	only	the	most	recent	calls	are	kept.	If	your	computer
runs	out	of	memory,	NI	Spy	stops	capture	and	displays	a	message	box
saying	it	is	out	of	memory.



Start	NI	Spy	with	Capture	On
Select	the	Start	NI	Spy	with	capture	on	checkbox	to	start	NI	Spy
capture	automatically.	By	default,	this	option	is	not	selected,	and	NI	Spy
starts	with	capture	off.



Buffer	Limit	Per	Parameter
When	NI	Spy	records	an	API	call	that	includes	a	buffer,	the	buffer
contents	are	displayed	in	NI	Spy.	You	can	specify	how	much	of	the	buffer
to	record	and	save	by	choosing	Small	buffer	or	Large	buffer	mode.
Small	buffer	mode	displays	up	to	64	bytes	of	data.	If	there	are	more	than
64	bytes	of	data,	NI	Spy	displays	only	the	first	and	last	32	bytes	of	data.
Large	buffer	mode	displays	up	to	64	KB	of	data,	but	may	significantly
slow	down	your	application.	If	there	are	more	than	64	KB	of	data,	NI	Spy
displays	only	the	first	and	last	32	KB	of	data.	Both	buffer	modes	use	an
entire	row	of	dashes	to	signify	omitted	data.



File	Logging
If	file	logging	is	enabled,	NI	Spy	writes	all	recorded	calls	to	the	specified
log	file.	NI	Spy	can	save	calls	in	three	formats:	a	binary	Spy	Capture
format,	a	plain	text	file,	and	a	comma-separated	variable	(CSV)	file.	Only
NI	Spy	can	open	a	Spy	Capture	file,	which	is	much	more	efficient	to
create.	Using	the	plain	text	file	and	CSV	formats	creates	logs	that	a	wide
variety	of	editors	can	read,	but	the	logs	contain	less	information	and	are
much	slower	to	create	while	logging.
To	log	calls,	you	must	specify	the	name	of	a	file	to	store	the	logged	calls.
Calls	can	either	allow	NI	Spy	to	schedule	writing	or	write	to	file	as	soon
as	possible.
By	default,	Allow	NI	Spy	to	schedule	writing	is	selected.	Selecting
Allow	NI	Spy	to	schedule	writing	writes	to	the	logfile	for	each	captured
call,	but	does	not	flush	the	logfile	until	capture	is	halted.	This	mode	of	file
logging	is	much	faster	than	specifying	Write	to	file	as	soon	as	possible,
but	if	your	system	crashes,	at	least	some	of	the	logfile	likely	will	be	lost.

Note		The	use	of	file	logging	slows	down	the	performance	of	all
running	applications,	and	if	you	are	low	on	disk	space,	you	are
likely	to	run	out	of	disk	space.

Selecting	Write	to	file	as	soon	as	possible	ensures	that	the	call	is
logged	quickly.	In	a	Spy	Capture	file,	the	call	is	written	to	file	before
returning	control	to	the	calling	application,	ensuring	that	the	logfile	is
complete	even	if	the	system	crashes.	When	writing	to	a	plain	text	file	or
CSV	file,	the	file	is	written	when	NI	Spy	displays	it,	and	the	call	may	not
be	logged	if	there	is	a	crash.
File	logging	is	useful	in	debugging	an	application	that	causes	the	system
to	crash.	If	you	use	file	logging	to	log	a	Spy	Capture	file	with	Write	to	file
as	soon	as	possible	selected,	you	can	open	the	saved	.spy	file	after
your	system	has	restarted	to	examine	the	API	calls	captured	up	to	the
point	where	the	system	crashed.	If	file	logging	is	used	in	tandem	with	a
plain	text	file	or	CSV	file	and	Write	to	file	as	soon	as	possible	is
selected,	other	applications	can	use	the	output	without	having	to	stop
logging.



Capturing	Data
By	default,	capture	is	off	when	you	open	NI	Spy.	You	can	change	the
default	through	the	Spy»Options	dialog	box.
When	capture	is	off,	the	title	bar	of	the	capture	window	reads	"NI	Spy	–
[capture	off]",	and	the	blue	arrow	(start	button:	 )	is	enabled.	When
capture	is	on,	the	title	of	the	capture	window	is	"NI	Spy	–	[capture	on]",
and	the	red	X	(stop	button:	 )	is	enabled.
For	help	on	the	toolbar	buttons,	use	the	context-sensitive	help	in	the	NI
Spy	application.	Once	you	turn	capture	on,	you	can	run	your	application
and	then	return	to	NI	Spy	to	view	the	captured	calls	to	National
Instruments	drivers.
To	turn	capture	on,	select	Spy»Start	Capture,	press	<Ctrl-F8>	in
Windows,	<Meta-F8>	in	Linux,	or	<Command-F8>	in	Mac	OS	X,	or	click
on	the	blue	arrow	button	on	the	toolbar:	

Note		If	Spy»Start	Capture	is	grayed	out,	capture	is	already	on.

To	turn	capture	off,	select	Spy»Stop	Capture,	press	<Ctrl-Break>	in
Windows,	<Meta-Break>	in	Linux,	or	<Command-Break>	in	Mac	OS	X,	or
click	on	the	red	button	on	the	toolbar:	



Actions	on	API	Errors
NI	Spy	includes	several	options	for	capturing	API	errors.	To	access	these
options,	select	Spy»Options	and	select	the	Error	Action	tab.



Action	to	Take	on	API	Error
Select	Continue	capturing	and	ignore	error	to	continue	capturing	when
an	API	error	occurs.	Select	Stop	capturing	to	capture	the	error	and	then
stop	capturing.	Select	Pause	and	display	a	dialog	to	capture	the	error,
pause	capturing,	and	display	a	dialog.	The	dialog	gives	you	the	option	of
continuing	or	stopping	the	capture.



When	to	Take	Action
If	you	select	Stop	capturing	or	Pause	and	display	a	dialog,	select
Immediately	to	stop	capturing	immediately	after	the	API	error	or	select
Specific	number	of	calls	after	error	to	stop	capturing	after	a	specified
number	of	calls.



Limit	Error	Criteria
If	you	select	Stop	capturing	or	Pause	and	display	a	dialog,	you	have
several	options	for	limiting	the	error	criteria.
Select	Any	API	to	stop	capturing	after	errors	in	all	APIs.	Select	Specific
API	and	choose	the	API	from	the	drop-down	list	to	stop	capturing	only
after	errors	in	the	specified	API.
If	you	select	Specific	API,	select	Any	function	to	stop	capturing	after	all
errors,	or	select	Specific	function	and	enter	the	function	name	to	stop
capturing	after	the	specified	function.	(The	function	name	is	case
sensitive.)
Select	Any	error	code	to	stop	capturing	after	any	API	error.	Select
Specific	error	code	and	enter	the	error	code	to	stop	capturing	after	the
specified	error	code.	You	can	enter	this	number	in	either	decimal	format
(for	example,	6)	or	hexadecimal	format	(for	example,	0xBFFF0015).	For
NI-488	users,	you	can	enter	either	an	ibsta	or	iberr	value.



Selecting	Column	Headers
You	can	specify	which	API	call	data	is	displayed	in	the	main	NI	Spy
window	by	selecting	various	column	headers.	To	select	the	column
headers,	select	Spy»Options,	select	the	View	Selections	tab,	and
select	the	headers	you	want	to	display	under	Column	Headers.

Note		You	can	modify	NI	Spy	options	only	when	capture	is
stopped.



Number
This	column	displays	the	number	of	each	National	Instruments	API	call.



Description
This	column	displays	the	names	of	the	API	calls	that	NI	Spy	captures.



Status
This	column	displays	each	API	call's	output	status	value.	(For	calls	made
to	the	NI-488.2	API,	this	is	equivalent	to	ibsta.)



iberr
This	column	shows	the	API	call's	output	error	(iberr)	value.	(This	data	is
available	only	for	calls	made	to	the	NI-488.2	API.)



ibcntl
This	column	shows	the	API	call's	output	count	(ibcntl)	value.	(This	data	is
available	only	for	calls	made	to	the	NI-488.2	API.)



Time
This	column	displays	the	API	call's	start	time.	The	time	is	in	the	format
hours	:	minutes	:	seconds	:	milliseconds.



Process	ID
This	column	displays	the	process	ID	(in	hexadecimal	format)	of	the
process	that	made	each	API	call.



Thread	ID
This	column	displays	the	thread	ID	(in	hexadecimal	format)	of	the	thread
that	made	each	API	call.



Selecting	which	APIs	to	View
If	you	have	more	than	one	National	Instruments	driver	installed	on	your
computer,	you	can	specify	which	APIs	you	want	to	spy	on	at	any	time.	By
default,	all	installed	APIs	are	enabled.	To	select	the	APIs	to	spy	on,	select
Spy»Options,	select	the	View	Selections	tab,	and	select	the	APIs	under
Installed	API	Choices.

Note		You	can	modify	NI	Spy	options	only	when	capture	is
stopped.



Selecting	which	Process/Thread	to	View
When	capturing	multiple	threads	and	processes,	select	View	All
Processes	and	Threads	to	display	all	threads	and	processes	in	the
capture	window.	To	view	only	a	specific	process,	select	a	function	within
the	process	and	select	View	Only	this	Process.	To	view	only	a	specific
thread,	select	a	function	within	the	thread	and	select	View	Only	this
Thread.



Important	Information
Warranty
Copyright
Trademarks
Patents
Warning	Regarding	Use	of	NI	Products



Warranty
The	media	on	which	you	receive	National	Instruments	software	are
warranted	not	to	fail	to	execute	programming	instructions,	due	to	defects
in	materials	and	workmanship,	for	a	period	of	90	days	from	date	of
shipment,	as	evidenced	by	receipts	or	other	documentation.	National
Instruments	will,	at	its	option,	repair	or	replace	software	media	that	do	not
execute	programming	instructions	if	National	Instruments	receives	notice
of	such	defects	during	the	warranty	period.	National	Instruments	does	not
warrant	that	the	operation	of	the	software	shall	be	uninterrupted	or	error
free.
A	Return	Material	Authorization	(RMA)	number	must	be	obtained	from
the	factory	and	clearly	marked	on	the	outside	of	the	package	before	any
equipment	will	be	accepted	for	warranty	work.	National	Instruments	will
pay	the	shipping	costs	of	returning	to	the	owner	parts	which	are	covered
by	warranty.
National	Instruments	believes	that	the	information	in	this	document	is
accurate.	The	document	has	been	carefully	reviewed	for	technical
accuracy.	In	the	event	that	technical	or	typographical	errors	exist,
National	Instruments	reserves	the	right	to	make	changes	to	subsequent
editions	of	this	document	without	prior	notice	to	holders	of	this	edition.
The	reader	should	consult	National	Instruments	if	errors	are	suspected.
In	no	event	shall	National	Instruments	be	liable	for	any	damages	arising
out	of	or	related	to	this	document	or	the	information	contained	in	it.
EXCEPT	AS	SPECIFIED	HEREIN,	NATIONAL	INSTRUMENTS	MAKES
NO	WARRANTIES,	EXPRESS	OR	IMPLIED,	AND	SPECIFICALLY
DISCLAIMS	ANY	WARRANTY	OF	MERCHANTABILITY	OR	FITNESS
FOR	A	PARTICULAR	PURPOSE.	CUSTOMER'S	RIGHT	TO	RECOVER
DAMAGES	CAUSED	BY	FAULT	OR	NEGLIGENCE	ON	THE	PART	OF
NATIONAL	INSTRUMENTS	SHALL	BE	LIMITED	TO	THE	AMOUNT
THERETOFORE	PAID	BY	THE	CUSTOMER.	NATIONAL
INSTRUMENTS	WILL	NOT	BE	LIABLE	FOR	DAMAGES	RESULTING
FROM	LOSS	OF	DATA,	PROFITS,	USE	OF	PRODUCTS,	OR
INCIDENTAL	OR	CONSEQUENTIAL	DAMAGES,	EVEN	IF	ADVISED	OF
THE	POSSIBILITY	THEREOF.	This	limitation	of	the	liability	of	National
Instruments	will	apply	regardless	of	the	form	of	action,	whether	in
contract	or	tort,	including	negligence.	Any	action	against	National
Instruments	must	be	brought	within	one	year	after	the	cause	of	action



accrues.	National	Instruments	shall	not	be	liable	for	any	delay	in
performance	due	to	causes	beyond	its	reasonable	control.	The	warranty
provided	herein	does	not	cover	damages,	defects,	malfunctions,	or
service	failures	caused	by	owner's	failure	to	follow	the	National
Instruments	installation,	operation,	or	maintenance	instructions;	owner's
modification	of	the	product;	owner's	abuse,	misuse,	or	negligent	acts;
and	power	failure	or	surges,	fire,	flood,	accident,	actions	of	third	parties,
or	other	events	outside	reasonable	control.



Copyright
Under	the	copyright	laws,	this	publication	may	not	be	reproduced	or
transmitted	in	any	form,	electronic	or	mechanical,	including	photocopying,
recording,	storing	in	an	information	retrieval	system,	or	translating,	in
whole	or	in	part,	without	the	prior	written	consent	of	National	Instruments
Corporation.
National	Instruments	respects	the	intellectual	property	of	others,	and	we
ask	our	users	to	do	the	same.	NI	software	is	protected	by	copyright	and
other	intellectual	property	laws.	Where	NI	software	may	be	used	to
reproduce	software	or	other	materials	belonging	to	others,	you	may	use
NI	software	only	to	reproduce	materials	that	you	may	reproduce	in
accordance	with	the	terms	of	any	applicable	license	or	other	legal
restriction.



Trademarks
National	Instruments,	NI,	ni.com,	and	LabVIEW	are	trademarks	of
National	Instruments	Corporation.	Refer	to	the	Terms	of	Use	section	on
ni.com/legal	for	more	information	about	National	Instruments	trademarks.
FireWire®	is	the	registered	trademark	of	Apple	Computer,	Inc.
Handle	Graphics®,	MATLAB®,	Real-Time	Workshop®,	Simulink®,
Stateflow®,	and	xPC	TargetBox®	are	registered	trademarks,	and
TargetBox™	and	Target	Language	Compiler™	are	trademarks	of	The
MathWorks,	Inc.
Tektronix®	and	Tek	are	registered	trademarks	of	Tektronix,	Inc.
The	Bluetooth®	word	mark	is	a	registered	trademark	owned	by	the
Bluetooth	SIG,	Inc.
Other	product	and	company	names	mentioned	herein	are	trademarks	or
trade	names	of	their	respective	companies.
Members	of	the	National	Instruments	Alliance	Partner	Program	are
business	entities	independent	from	National	Instruments	and	have	no
agency,	partnership,	or	joint-venture	relationship	with	National
Instruments.

javascript:WWW(WWW_Trademark)


Patents
For	patents	covering	National	Instruments	products,	refer	to	the
appropriate	location:	Help»Patents	in	your	software,	the	patents.txt	file	on
your	media,	or	ni.com/patents.

javascript:WWW(WWW_Patents)


WARNING	REGARDING	USE	OF	NATIONAL
INSTRUMENTS	PRODUCTS
(1)	NATIONAL	INSTRUMENTS	PRODUCTS	ARE	NOT	DESIGNED
WITH	COMPONENTS	AND	TESTING	FOR	A	LEVEL	OF	RELIABILITY
SUITABLE	FOR	USE	IN	OR	IN	CONNECTION	WITH	SURGICAL
IMPLANTS	OR	AS	CRITICAL	COMPONENTS	IN	ANY	LIFE	SUPPORT
SYSTEMS	WHOSE	FAILURE	TO	PERFORM	CAN	REASONABLY	BE
EXPECTED	TO	CAUSE	SIGNIFICANT	INJURY	TO	A	HUMAN.
(2)	IN	ANY	APPLICATION,	INCLUDING	THE	ABOVE,	RELIABILITY	OF
OPERATION	OF	THE	SOFTWARE	PRODUCTS	CAN	BE	IMPAIRED	BY
ADVERSE	FACTORS,	INCLUDING	BUT	NOT	LIMITED	TO
FLUCTUATIONS	IN	ELECTRICAL	POWER	SUPPLY,	COMPUTER
HARDWARE	MALFUNCTIONS,	COMPUTER	OPERATING	SYSTEM
SOFTWARE	FITNESS,	FITNESS	OF	COMPILERS	AND
DEVELOPMENT	SOFTWARE	USED	TO	DEVELOP	AN	APPLICATION,
INSTALLATION	ERRORS,	SOFTWARE	AND	HARDWARE
COMPATIBILITY	PROBLEMS,	MALFUNCTIONS	OR	FAILURES	OF
ELECTRONIC	MONITORING	OR	CONTROL	DEVICES,	TRANSIENT
FAILURES	OF	ELECTRONIC	SYSTEMS	(HARDWARE	AND/OR
SOFTWARE),	UNANTICIPATED	USES	OR	MISUSES,	OR	ERRORS	ON
THE	PART	OF	THE	USER	OR	APPLICATIONS	DESIGNER	(ADVERSE
FACTORS	SUCH	AS	THESE	ARE	HEREAFTER	COLLECTIVELY
TERMED	"SYSTEM	FAILURES").	ANY	APPLICATION	WHERE	A
SYSTEM	FAILURE	WOULD	CREATE	A	RISK	OF	HARM	TO
PROPERTY	OR	PERSONS	(INCLUDING	THE	RISK	OF	BODILY
INJURY	AND	DEATH)	SHOULD	NOT	BE	RELIANT	SOLELY	UPON	ONE
FORM	OF	ELECTRONIC	SYSTEM	DUE	TO	THE	RISK	OF	SYSTEM
FAILURE.	TO	AVOID	DAMAGE,	INJURY,	OR	DEATH,	THE	USER	OR
APPLICATION	DESIGNER	MUST	TAKE	REASONABLY	PRUDENT
STEPS	TO	PROTECT	AGAINST	SYSTEM	FAILURES,	INCLUDING	BUT
NOT	LIMITED	TO	BACK-UP	OR	SHUT	DOWN	MECHANISMS.
BECAUSE	EACH	END-USER	SYSTEM	IS	CUSTOMIZED	AND
DIFFERS	FROM	NATIONAL	INSTRUMENTS'	TESTING	PLATFORMS
AND	BECAUSE	A	USER	OR	APPLICATION	DESIGNER	MAY	USE
NATIONAL	INSTRUMENTS	PRODUCTS	IN	COMBINATION	WITH
OTHER	PRODUCTS	IN	A	MANNER	NOT	EVALUATED	OR
CONTEMPLATED	BY	NATIONAL	INSTRUMENTS,	THE	USER	OR



APPLICATION	DESIGNER	IS	ULTIMATELY	RESPONSIBLE	FOR
VERIFYING	AND	VALIDATING	THE	SUITABILITY	OF	NATIONAL
INSTRUMENTS	PRODUCTS	WHENEVER	NATIONAL	INSTRUMENTS
PRODUCTS	ARE	INCORPORATED	IN	A	SYSTEM	OR	APPLICATION,
INCLUDING,	WITHOUT	LIMITATION,	THE	APPROPRIATE	DESIGN,
PROCESS	AND	SAFETY	LEVEL	OF	SUCH	SYSTEM	OR
APPLICATION.



Technical	Support	and	Professional	Services
Visit	the	following	sections	of	the	award-winning	National	Instruments
Web	site	at	ni.com	for	technical	support	and	professional	services:

Support—Technical	support	resources	at	ni.com/support	include
the	following:

Self-Help	Resources—For	answers	and	solutions,	visit
ni.com/support	for	software	drivers	and	updates,	a
searchable	KnowledgeBase,	product	manuals,	step-by-
step	troubleshooting	wizards,	thousands	of	example
programs,	tutorials,	application	notes,	instrument	drivers,
and	so	on.	Registered	users	also	receive	access	to	the	NI
Discussion	Forums	at	ni.com/forums.	NI	Applications
Engineers	make	sure	every	question	submitted	online
receives	an	answer.
Standard	Service	Program	Membership—This
program	entitles	members	to	direct	access	to	NI
Applications	Engineers	via	phone	and	email	for	one-to-
one	technical	support,	as	well	as	exclusive	access	to	on
demand	training	modules	via	the	Services	Resource
Center.	NI	offers	complementary	membership	for	a	full
year	after	purchase,	after	which	you	may	renew	to
continue	your	benefits.
For	information	about	other	technical	support	options	in
your	area,	visit	ni.com/services	or	contact	your	local	office
at	ni.com/contact.

Training	and	Certification—Visit	ni.com/training	for	self-paced
training,	eLearning	virtual	classrooms,	interactive	CDs,	and
Certification	program	information.	You	also	can	register	for
instructor-led,	hands-on	courses	at	locations	around	the	world.
System	Integration—If	you	have	time	constraints,	limited	in-
house	technical	resources,	or	other	project	challenges,	National
Instruments	Alliance	Partner	members	can	help.	To	learn	more,
call	your	local	NI	office	or	visit	ni.com/alliance.

If	you	searched	ni.com	and	could	not	find	the	answers	you	need,	contact
your	local	office	or	NI	corporate	headquarters.	You	also	can	visit	the
Worldwide	Offices	section	of	ni.com/niglobal	to	access	the	branch	office
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Web	sites,	which	provide	up-to-date	contact	information,	support	phone
numbers,	email	addresses,	and	current	events.



Branch	Offices
Office Telephone	Number
Australia 1800	300	800
Austria 43	662	457990-0
Belgium 32	(0)	2	757	0020
Brazil 55	11	3262	3599
Canada 800	433	3488
China 86	21	5050	9800
Czech	Republic 420	224	235	774
Denmark 45	45	76	26	00
Finland 358	(0)	9	725	72511
France 33	(0)	1	57	66	24	24
Germany 49	89	7413130
India 91	80	41190000
Israel 972	0	3	6393737
Italy 39	02	41309277
Japan 0120-527196	/	81	3	5472	2970
Korea 82	02	3451	3400
Lebanon 961	(0)	1	33	28	28
Malaysia 1800	887710
Mexico 01	800	010	0793
Netherlands 31	(0)	348	433	466
New	Zealand 0800	553	322
Norway 47	(0)	66	90	76	60
Poland 48	22	3390150
Portugal 351	210	311	210
Russia 7	495	783	6851
Singapore 1800	226	5886
Slovenia 386	3	425	42	00



South	Africa 27	0	11	805	8197
Spain 34	91	640	0085
Sweden 46	(0)	8	587	895	00
Switzerland 41	56	2005151
Taiwan 886	02	2377	2222
Thailand 662	278	6777
Turkey 90	212	279	3031
United	Kingdom 44	(0)	1635	523545
United	States	(Corporate) 512	683	0100
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