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This	help	file	contains	information	about	how	to	configure	your	remote
systems	or	devices	with	Measurement	&	Automation	Explorer	(MAX).

Note		Install	the	LabVIEW	Real-Time	Module	and	MAX	on	the	host
computer	before	you	configure	your	remote	system	or	device.
Refer	to	Chapter	2,	Installation,	of	the	LabVIEW	Real-Time	Module
Release	and	Upgrade	Notes	for	more	information	about	installing
the	LabVIEW	Real-Time	Module.

To	comment	on	National	Instruments	documentation,	refer	to	the	National
Instruments	Web	site.
©	2003–2008	National	Instruments	Corporation.	All	rights	reserved.
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Related	Documentation
Most	National	Instruments	manuals	also	are	available	as	PDFs.	You
must	have	Adobe	Acrobat	Reader	with	Search	and	Accessibility	5.0.5	or
later	installed	to	view	the	PDFs.	Refer	to	the	Adobe	Systems
Incorporated	Web	site	to	download	Adobe	Reader.	Refer	to	the	National
Instruments	Product	Manuals	Library	for	updated	documentation
resources.
The	following	documents	contain	information	that	you	might	find	helpful
as	you	use	this	file:

LabVIEW	Help	(In	LabVIEW,	select	Help»Search	the	LabVIEW
Help	to	display	the	LabVIEW	Help.	On	the	Contents	tab,	navigate
to	the	Real-Time	Module	book.)
LabVIEW	Real-Time	Module	Release	and	Upgrade	Notes
LabVIEW	Real-Time	Module	documentation,	tutorials,	examples,
and	discussion	forums	are	available	on	the	internet	at
http://ni.com/support/labview/real-time.
NI-CAN	User	Manual

Real-Time	FAQs
You	can	find	a	LabVIEW	Real-Time	Module	FAQ	on	the	National
Instruments	Web	site,	ni.com.
Common	Error	Codes
You	can	find	the	most	current	information	on	an	error	code	at
http://ni.com/support	by	entering	a	search	for	the	error	code.
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LabVIEW	Real-Time	Target	Configuration
Complete	the	following	steps	to	configure	your	remote	system	for	use
with	the	LabVIEW	Real-Time	Module.	For	a	more	complete	explanation
of	these	steps,	refer	to	the	LabVIEW	Real-Time	Target	Configuration
Tutorial.

1.	 Boot	into	LabVIEW	Real-Time
2.	Configure	Network	Settings

3.	 Install	Software
4.	Configure	I/O
5.	Configure	System	Settings

When	you	complete	these	steps,	your	remote	system	is	ready	to	target
from	LabVIEW	Real-Time.
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LabVIEW	Real-Time	Target	Configuration
Tutorial
Complete	the	following	steps	to	configure	your	remote	system	for	use
with	the	LabVIEW	Real-Time	Module.

1.	 Boot	target	into	LabVIEW	Real-Time	Before	you	begin
configuration,	make	sure	your	RT	series	hardware	is	booted	into
LabVIEW	Real-Time.	If	your	RT	target	came	with	only	LabVIEW
Real-Time	preinstalled	on	its	hard	drive,	the	system	is	already	set
up	to	boot	into	LabVIEW	Real-Time.	If	your	system	does	not	have
a	floppy	drive,	it	may	have	DIP	switches	or	BIOS	settings	for
booting	into	LabVIEW	Real-Time.	For	more	information,	refer	to
Booting	Into	the	LabVIEW	Real-Time	Module.

If	you	have	a	system	that	has	a	floppy	disk	drive,	you	may	need	to
create	a	boot	disk	to	boot	the	system	into	LabVIEW	Real-Time.
For	help	creating	a	boot	disk,	refer	to	PXI	Boot	Disk	or	Desktop
PC	Boot	Disk.	In	addition	to	the	normal	LabVIEW	Real-Time	boot
procedure,	there	are	some	additional	boot	modes	that	you	can
use	to	troubleshoot	or	recover	an	RT	target	that	is	in	a	faulty	state.
Alternatively,	you	can	permanently	format	the	hard	drive	and
configure	it	to	boot	directly	into	RT	without	a	boot	floppy	by	using
the	Desktop	PC	Utility	USB	Drive,	a	PXI	Format	Hard	Drive	Disk,
or	a	Desktop	PC	Format	Hard	Drive	Disk.

Note		You	must	use	Windows	XP/2000	computers	to	create
the	disk	utilities.	If	your	system	uses	Windows	Vista,	you
must	create	a	Desktop	PC	Utility	USB	Drive	instead.

2.	 Configure	Network	Settings
Verify	that	your	RT	target	is	detected	by	expanding	the	Remote
Systems	tree	(click	the	plus	sign	[+]	beside	Remote	Systems).
Your	device	may	show	up	as	0.0.0.0	if	you	have	not	previously
configured	it	with	an	IP	address.	If	your	device	is	not	listed,
refresh	the	list	by	pressing	<F5>.	Devices	that	have	not	been
configured	with	an	IP	address	must	be	on	the	same	local	subnet
as	the	host	in	order	to	configure	the	IP	address.	If	your	device	is
already	configured	with	an	IP	address	but	is	not	on	the	local
subnet,	add	it	to	Remote	Systems	by	right-clicking	Remote



Systems	and	selecting	Create	New.	Complete	the	wizard	to	add
your	system.

Note		Make	sure	that	any	network	firewalls	have	been
disabled.	Even	if	exceptions	have	been	set	to	allow
communication,	some	firewalls	continue	to	block	IP
addresses	of	0.0.0.0	as	long	as	they	are	enabled.

If	your	network	uses	DHCP,	select	the	Obtain	an	IP	address
automatically	radio	button.	Not	all	DHCP	servers	are
implemented	in	the	same	manner.	Therefore,	some	might	not	be
compatible	with	the	LabVIEW	Real-Time	Module.	After	you	select
Obtain	an	IP	address	automatically	and	restart	the	controller,
LabVIEW	Real-Time	tries	to	obtain	an	IP	address	from	the	DHCP
server.	If	this	operation	fails,	LabVIEW	Real-Time	restarts	the
controller.	If	your	target	supports	automatic	IP	assignment,	it	will
attempt	to	obtain	an	automatic	private	IP	address	(169.254.x.x)	and
use	it	to	boot	up	the	rest	of	the	system.	After	three	failed	attempts,
LabVIEW	Real-Time	returns	to	the	default	configuration	with	IP
address	0.0.0.0.	You	must	then	explicitly	specify	the	network
parameters.

If	you	need	to	specify	an	IP	address	manually,	select	the	Use	the
following	IP	address	radio	button	and	click	the	Suggest	Values
button.	This	selection	suggests	settings	based	off	of	the	network
adapter	in	your	computer.	You	are	then	prompted	for	an	IP
Address.	Choose	one	that	is	not	already	in	use	on	the	network
and	click	OK.	If	a	Gateway	and	DNS	are	not	available	on	the
network,	set	these	to	the	default	value	of	0.0.0.0.
You	can	enter	a	more	descriptive	name	for	the	remote	system	as
well	as	any	comments	you	would	like	to	include	to	describe	the
system	and	its	components.	When	you	are	finished,	click	the
Apply	button	at	the	top	of	the	screen	to	save	your	changes.	You
are	then	informed	that	the	system	must	be	rebooted	in	order	for
the	changes	to	take	effect.	You	can	reboot	the	system	remotely.
For	more	information	on	network	configuration,	refer	to
Configuring	Network	Settings.



3.	 Install	Software
You	can	install	the	LabVIEW	Real-Time	Module	or	other	driver
software	on	the	remote	target	after	you	have	assigned	it	an	IP
address.

If	your	RT	target	has	LabVIEW	Real-Time	preinstalled,	you	may
still	need	to	download	additional	driver	software	or	update	existing
driver	software.

Complete	the	following	steps	to	download	software	using	the
LabVIEW	Real-Time	Software	Wizard:

a.	 Expand	Remote	Systems	in	the	configuration	tree	and
then	expand	your	RT	target.

b.	 Select	Software.	Click	the	Add/Remove	Software	icon	on
the	toolbar	to	launch	the	LabVIEW	Real-Time	Software
Wizard.	If	your	target	does	not	have	a	Software	category,
then	it	does	not	support	the	LabVIEW	Real-Time	software.
Determine	what	you	want	to	do.	If	your	target	uses
recommended	software	sets,	refer	to	Installing
Recommended	Software	Sets.	If	your	target	uses	a
custom	software	selection,	refer	to	Installing	a	Custom
Software	Selection.

Note		If	a	driver	is	installed	on	the	host	PC	but	is	not
displayed	in	the	LabVIEW	Real-Time	Software
Wizard,	the	Real-Time	component	of	that	driver	may
not	be	installed.	This	issue	commonly	occurs	when
drivers	were	installed	prior	to	installing	the	LabVIEW
Real-Time	module.	To	resolve	this	issue,	navigate	to
Start»Control	Panel»Add	or	Remove	Programs
(in	Windows	Vista,	navigate	to	Start»Control
Panel»Programs»Programs	and	Features)	and
select	National	Instruments	Software	in	Currently
installed	programs.	Click	Change	to	modify	the
driver	installation	to	add	the	LabVIEW	Real-Time
components.

c.	 Configure	System	Settings
You	can	configure	two	system-level	settings	for	your
LabVIEW	Real-Time	target—time	zone	and	locale.



Use	the	time	zone	setting	to	configure	time	zone	and
daylight	saving	settings	for	the	location	in	which	the	target
resides.	You	can	use	this	setting	in	conjunction	with
LabVIEW	time	and	date	VIs	to	provide	accurate	time
information,	relative	to	the	time	zone	setting.

Use	the	locale	setting	to	change	the	locale	of	strings
returned	from	the	remote	target.	This	setting	is	not
supported	by	all	software	and	is	disabled	if	not	supported
by	any	software	on	your	target.

For	more	information	on	configuring	these	settings,	refer	to
Configuring	System	Settings.

d.	 Configure	I/O
You	must	configure	any	National	Instruments	I/O	devices
before	you	can	target	them	from	a	LabVIEW	Real-Time
application.	For	information	on	how	to	correctly	configure
I/O	devices,	refer	to	Device	Configuration	or	the
documentation	for	that	hardware.

When	you	complete	these	steps,	your	remote	system	is	ready	to	be
targeted	from	the	LabVIEW	Real-Time	module.



Connecting	to	LabVIEW	Real-Time	Targets
Complete	the	following	steps	to	locate	and	connect	to	a	LabVIEW	Real-
Time	target.

1.	 Connect	to	a	Host	Computer	Your	target	must	be	connected	to
the	same	subnet	that	contains	the	host	computer	you	use	to
configure	the	remote	system.	For	information	about	how	to
connect	your	target,	refer	to	Making	Network	and	Non-Network
Connections.

2.	 Detect	the	Remote	System	
In	order	to	configure	your	target,	you	must	detect	it	within	MAX.
For	information	about	how	to	detect	the	remote	system,	refer	to
Using	MAX	to	Detect	Remote	Systems.

Using	the	Network	Settings	panel,	you	can	also	enter	a	name	or
comments	for	your	target.



System	States
Connected	systems	can	be	in	any	one	of	number	of	states,	as	defined	in
the	following	table:

State Description
Unconfigured The	IP	address	is	set	at	0.0.0.0.	You	need

to	obtain	a	valid	IP	address.
Disconnected MAX	cannot	find	the	target	on	the	network.
Disconnected	-	Rebooting The	target	is	rebooting.
Initializing The	target	is	currently	starting	up.
Inconsistent	IP	Settings The	target	is	connected	but	has	an	IP

address	that	may	not	allow	full
configuration.	You	need	to	correct	its	IP
settings.

Connected	-	Running The	target	has	booted	and	is	functioning
normally.

Connected	-	Install	Mode The	target	is	connected	in	Install	mode.
Install	mode	means	the	target	is	in	safe
mode	where	you	can	change	any	software
on	the	target	using	MAX.

Connected	-	Safe	Mode
(No	Software	Installed)

The	target	is	connected	in	safe	mode,	but
it	has	no	software	installed	on	it.	You	will
see	No	software	installed	on	the	target's
monitor	if	the	system	boots	but	cannot	find
the	necessary	LabVIEW	Real-Time
operating	system	files	on	the	target.

Connected	-	Safe	Mode
(User	Directed)

You	will	see	Safe	Mode	(User	Directed)
when	the	target	has	been	designated	to
enter	safe	mode	by	flipping	a	safe	mode
switch	on	a	target,	or	if	you	boot	into	safe
mode	using	a	Safe	Mode	floppy	disk	or
Safe	Mode	on	the	Desktop	PC	Utility	USB
Drive.

Connected	-	Safe	Mode
(Software	Update	Required)

The	target	does	not	support	the	version	of
software	installed	on	the	system.	This



mode	requires	that	you	install	a	newer
version	of	LabVIEW	Real-Time	and/or
components.	The	target's	monitor	will
indicate	the	oldest	compatible	version	of
LabVIEW	Real-Time	supported	by	that
hardware	target.

Connected	-	Safe	Mode
(Software	Error)

This	mode	occurs	after	the	target's
controller	rebooted	three	times
unexpectedly	because	of	a	crashing
startup	application	or	driver	or	some	other
problem	that	causes	the	target	to	have	an
unsafe	reboot.

Connected	-	Safe	Mode
(Improper	Installation)

This	mode	occurs	after	the	target's
controller	attempted	to	boot	and	caused
specific	errors	when	attempting	to	load
core	operating	system	files.	This	mode	is
similar	to	No	Software	Installed,	however
the	files	are	present	and	are	causing	fatal
errors	when	attempted	to	load.	This
message	can	also	be	displayed	if	required
tokens	are	not	present	in	the	ni-rt.ini	file
that	refer	to	startup	information	and/or	core
operating	system	files.

Note		Booting	into	safe	mode	bypasses	the	normal	boot	programs
on	the	RT	target.	Safe	mode	boots	only	essential	services	required
for	updating	the	RT	target's	configuration	and	installing	software.
Safe	mode	is	useful	if	the	software	on	the	RT	target	becomes
corrupted,	as	it	bypasses	the	corrupted	software.	You	can	then	use
MAX	to	reinstall	the	software.	For	more	information	on	booting	into
safe	mode,	refer	to	Booting	Into	the	LabVIEW	Real-Time	Module.

	



Booting	Into	the	LabVIEW	Real-Time	Module
How	to	boot	into	LabVIEW	Real-Time	Module	depends	on	the	mode	and
the	type	of	system	you	have.



Boot	Modes
You	can	boot	into	LabVIEW	Real-Time	using	the	modes	described	in	the
following	table.

Boot	Mode Description
Normal
Boot	Mode

Booting	into	this	mode	makes	the	RT	target	fully
operational.	This	is	the	default	boot	mode.

IP	Reset Booting	into	this	mode	clears	all	the	IP	configuration
information,	as	well	as	the	system	configuration	password.
You	can	use	IP	Reset	to	recover	from	misconfigured	IP
settings	or	a	forgotten	password.

Startup
Application
Disabled

Booting	into	this	mode	prevents	a	LabVIEW	startup
application	from	running	on	the	RT	target,	even	if	one	is
present.	You	can	use	Startup	Application	Disabled	mode	to
recover	from	a	startup	application	which	takes	over	the
CPU	and	prevents	connections	to	the	target.

Safe	Mode Booting	into	this	mode	bypasses	the	normal	boot	programs
on	the	RT	target.	Instead,	it	boots	only	essential	services
required	for	updating	the	RT	target's	configuration	and
installing	software.	Safe	mode	is	useful	if	the	software	on
the	RT	target	becomes	corrupted,	as	it	bypasses	the
corrupted	software.	You	can	then	use	MAX	to	reinstall	the
software.

Uninstall
Mode

Booting	into	this	mode	removes	the	LabVIEW	Real-Time-
related	software	from	the	RT	target.	You	can	use	Uninstall
Mode	if	the	software	on	the	RT	target	becomes	corrupted,
as	this	mode	removes	the	corrupted	software.	You	can	use
MAX	to	reinstall	your	software.	This	mode	is	valid	only	for
RT	targets	with	floppy	drives.



Types	of	Systems
Booting	the	RT	target	into	the	LabVIEW	Real-Time	Module	depends	on
the	type	of	RT	target	you	have.
Common	ways	to	boot	into	LabVIEW	Real-Time	Module	include	using	a
floppy	disk,	a	USB	drive,	DIP	switches,	and	setting	the	Safe	Mode	boot
option	in	the	BIOS.	Refer	to	your	hardware	documentation	for	more
detailed	information	on	how	to	boot	your	system	into	LabVIEW	Real-Time
Module.	Refer	to	the	RT	Disk	Utilities	and	Desktop	PC	Utility	USB	Drive
topics	for	information	on	creating	utility	disks	and	USB	drives,	if
appropriate	for	your	system.



RT	Disk	Utilities
Notes

If	you	use	a	remote	system	that	does	not	have	a	floppy
drive,	refer	to	your	hardware	documentation	for	information
about	how	to	perform	these	tasks.	You	can	format	your	hard
drive	by	right-clicking	the	remote	system	in	the	configuration
tree	and	selecting	Format	Disk,	if	your	remote	system
supports	this	feature.
You	must	use	Windows	XP/2000	computers	to	create	the
disk	utilities.	If	your	system	uses	Windows	Vista,	you	must
create	a	Desktop	PC	Utility	USB	Drive	instead.

Use	the	Tools»RT	Disk	Utilities	menu	in	MAX	to	create	floppy	disks	for
your	remote	system.	If	you	have	multiple	versions	of	these	utilities,	MAX
prompts	you	to	select	the	appropriate	version.	You	can	create	the
following	disks:
Desktop	PC	Utility	USB	Drive
PXI	Format	Hard	Drive	Disk
PXI	Boot	Disk
PXI	Safe	Mode	Disk
Desktop	PC	Format	Hard	Drive	Disk
Desktop	PC	Boot	Disk
Desktop	PC	Safe	Mode	Disk
Launch	Settings	Reset	Disk
IP	Reset	Disk
Uninstall	Disk
All	disks	except	for	the	PXI	Boot	Disk	and	the	Desktop	PC	Boot	Disk	are
usually	used	for	troubleshooting	purposes.	The	boot	disks	are	necessary
to	use	the	LabVIEW	Real-Time	Module	with	a	Windows	operating
system.
You	must	define	the	boot	sequence	for	your	desktop	PC	or	PXI	controller
in	the	BIOS	settings	to	boot	from	a	floppy	disk.	If	this	BIOS	setting	is	set
to	boot	from	the	hard	drive	before	the	floppy	drive,	the	controller	boots



into	Windows.	Refer	to	your	hardware	documentation	for	more
information	about	BIOS	settings.
In	addition,	you	might	need	to	change	your	BIOS	settings	if	you	are
booting	your	remote	system	without	a	keyboard.	Refer	to	your	hardware
documentation	to	determine	whether	your	system	supports	this	option.	If
you	are	using	the	RT	Series	PXI	controller	and	it	does	not	appear	in
MAX,	try	the	following	techniques:

When	configuring	the	RT	Series	PXI	controller,	ensure	that	the
controller	is	located	on	the	same	subnet	of	your	network	as	the
host	PC.	If	you	are	unsure	of	your	network	configuration,	consult
your	network	administrator	for	assistance.
If	you	do	not	have	a	keyboard	connected	to	the	RT	Series	PXI
controller,	check	the	BIOS	settings	of	the	controller.	The	Halt	On
setting	must	be	set	to	All,	But	Keyboard	for	the	PXI	controller	to
boot	without	a	keyboard	connected.	You	can	find	the	Halt	On
setting	in	the	Standard	CMOS	Setup	options.	Refer	to	the	PXI
controller	documentation	for	information	about	BIOS	settings.



Desktop	PC	Utility	USB	Drive
The	Desktop	PC	Utility	USB	Drive	lets	you	perform	maintenance
operations	on	a	USB-capable	desktop	PC	with	LabVIEW	Real-Time
installed	on	its	hard	drive.

Notes
You	must	use	a	bootable	USB	device.
You	must	have	Administrator	privileges	on	the	host
computer	in	order	to	create	this	utility.

Complete	the	following	steps	to	create	the	Desktop	PC	Utility	USB	Drive
from	your	host	PC	or	PXI	system:

1.	 Launch	MAX	by	selecting	Programs»National
Instruments»Measurement	&	Automation	Explorer	from	the
Windows	Start	menu	on	the	host	PC.

2.	 Plug	a	USB	drive	into	a	USB	port.
Note		Close	all	applications	and	windows	that	access	the
USB	drive	you	want	to	use	as	the	Desktop	PC	Utility	USB
Drive.	The	USB	drive	must	not	be	in	use	by	any	other
processes.

3.	 Select	Tools»RT	Disk	Utilities»Create	Desktop	PC	Utility	USB
Drive.

4.	 Click	Yes	to	confirm	that	you	want	to	create	the	Desktop	PC	Utility
USB	Drive.

5.	 Select	the	version	of	the	utility	you	want	to	use	and	click	OK.
6.	 Select	the	USB	drive	you	want	to	format	as	a	Desktop	PC	Utility

USB	Drive.	Click	OK.
Caution		Any	data	on	the	USB	drive	will	be	overwritten.

7.	 If	necessary,	confirm	that	you	are	aware	that	this	operation
destroys	all	data	on	the	selected	USB	drive.

To	use	the	Desktop	PC	Utility	USB	drive,	plug	it	into	an	empty	USB	port
on	the	desktop	PC	you	use	as	the	remote	system.	Power	on	or	reset	the
remote	desktop	PC.

Note		You	must	set	the	BIOS	of	the	computer	on	which	you	want
to	use	the	USB	device	to	allow	booting	from	a	USB	drive.	Set	the



boot	sequence	to	search	for	boot	files	on	the	USB	drive	first.

The	Desktop	PC	Utility	USB	Drive	presents	six	menu	selections:
1.	 Boot	using	software	installed	on	the	hard-disk.	Boots	the

system	using	NI	Real-Time	software	installed	on	the	hard	drive.	If
there	is	no	NI	Real-Time	software	installed	on	the	hard	drive,	the
utility	boots	the	system	into	safe	mode	to	allow	software	to	be
installed.

2.	 Boot	into	safe	mode.
Boots	the	system	into	safe	mode.	This	selection	brings	up	the
minimal	set	of	services	necessary	to	configure	the	system's
network	settings	and	to	install	software	to	the	system.	This	mode
does	not	utilize	any	installed	software	on	the	hard	drive,	so	it	is
useful	as	a	recovery	mode	if	you	are	having	difficulty	booting	the
software	from	the	hard	drive.

3.	 Reset	network	configuration.
Clears	the	system's	IP	address,	subnet	mask,	gateway,	and	DNS
address.	When	the	target	is	rebooted,	it	will	automatically	acquire
an	IP	address	if	your	target	supports	automatic	IP	assignment.	If
your	target	has	an	IP	address	of	0.0.0.0,	you	must	reconfigure	its
network	settings.

4.	 Clear	password.
Clears	the	system's	password,	if	one	has	been	set.

5.	 Disable	LabVIEW	Real-Time	start-up	application.
If	there	is	a	LabVIEW	Real-Time	start-up	application	present,	this
selection	prevents	it	from	running	when	the	system	starts	up.
Once	the	application	has	been	disabled,	you	must	use	the
LabVIEW	Real-Time	development	environment	to	reenable	it.

6.	 Format	hard	disk.
Reformats	the	system's	hard	drive	to	allow	you	to	boot	NI	Real-
Time	software	directly	from	the	hard	drive.	This	operation	will
destroy	all	data	currently	on	the	hard	drive.	Targets	that	support
automatic	IP	address	assignment	will	be	assigned	an	IP	address.
For	targets	that	do	not	support	automatic	IP	address	assignment,
the	first	time	the	system	boots	from	the	hard	drive	after	it	has
been	formatted,	it	will	boot	into	safe	mode	with	an	IP	address	of
0.0.0.0.	You	can	then	configure	the	system's	network	settings	and
install	software	to	the	hard	drive.



PXI	Format	Hard	Drive	Disk
The	PXI	Format	Hard	Drive	Disk	reformats	the	C:	drive	of	the	remote
system,	deleting	all	data	on	that	system.	It	then	configures	the	hard	disk
to	boot	directly	into	the	real-time	operating	system,	which	allows	you	to
boot	into	the	LabVIEW	Real-Time	Module	if	LabVIEW	Real-Time	was	not
preinstalled.	All	other	operating	systems	and	data	are	deleted.
To	boot	your	PXI	system	into	either	Windows	or	LabVIEW	Real-Time,	use
a	PXI	Boot	Disk	when	you	want	to	boot	into	LabVIEW	Real-Time.	If	you
prefer	to	use	your	PXI	system	only	for	real-time	LabVIEW	Real-Time
applications,	use	the	PXI	Format	Hard	Drive	disk	once	to	enable	the
system	to	boot	into	LabVIEW	Real-Time	without	a	boot	floppy.

Note		You	must	use	Windows	XP/2000	computers	to	create	this
disk	utility.	If	your	system	uses	Windows	Vista,	you	must	create	a
Desktop	PC	Utility	USB	Drive	instead.



Creating	the	PXI	Format	Hard	Drive	Disk
Complete	the	following	steps	to	create	a	PXI	Format	Hard	Drive	Disk
from	your	host	PC	or	PXI	system:

1.	 Place	a	floppy	disk	in	the	drive	of	the	host	PC.	Any	data	on	the
floppy	disk	will	be	overwritten.

2.	 Launch	MAX	by	selecting	All	Programs»National
Instruments»Measurement	&	Automation	Explorer	from	the
Windows	Start	menu	on	the	host	PC.

3.	 Select	Tools»RT	Disk	Utilities»Create	PXI	Format	Hard	Drive
Disk.

4.	 The	PXI	Format	Hard	Drive	Disk	dialog	box	appears.	Click	Yes
to	make	the	boot	disk.	Follow	the	instructions	that	appear	on	your
screen.

5.	 Select	the	version	of	the	disk	utilities	you	want	to	use.
6.	 After	the	system	finishes	creating	the	boot	disk,	remove	the	floppy

disk	and	label	it	LabVIEW	RT	PXI	Format	Hard	Drive	Disk.



Using	the	PXI	Format	Hard	Drive	Disk
Insert	the	boot	disk	into	the	floppy	drive	of	the	PXI	controller	you	use	as
the	remote	system.	Power	on	or	reset	the	controller	to	format	the	hard
drive.

Note		The	hard	drive	must	be	formatted	FAT32	in	order	to	use	the
PXI	Format	Hard	Drive	Disk.



PXI	Boot	Disk
The	PXI	Boot	Disk	boots	a	PXI	controller	into	the	LabVIEW	Real-Time
Module.	You	must	have	this	disk	in	the	PXI	controller	floppy	drive	to	boot
into	LabVIEW	Real-Time	if	your	PXI	system	has	a	Windows	operating
system	installed.

Note		You	must	use	Windows	XP/2000	computers	to	create	this
disk	utility.	If	your	system	uses	Windows	Vista,	you	must	create	a
Desktop	PC	Utility	USB	Drive	instead.



Creating	the	PXI	Boot	Disk
Complete	the	following	steps	to	create	a	boot	disk	from	your	host	PC	or
PXI	system:

1.	 Place	a	floppy	disk	in	the	drive	of	the	host	PC.	Any	data	on	the
floppy	disk	will	be	overwritten.

2.	 Launch	MAX	by	selecting	All	Programs»National
Instruments»Measurement	&	Automation	Explorer	from	the
Windows	Start	menu	on	the	host	PC.

3.	 Select	Tools»RT	Disk	Utilities»Create	PXI	Boot	Disk.
4.	 The	PXI	Boot	Disk	dialog	box	appears.	Click	Yes	to	make	the

boot	disk.	Follow	the	instructions	that	appear	on	your	screen.
5.	 Select	the	version	of	the	disk	utilities	you	want	to	use.
6.	 After	the	system	finishes	creating	the	boot	disk,	remove	the	floppy

disk	and	label	it	LabVIEW	RT	PXI	Boot	Disk.



Using	the	PXI	Boot	Disk
Use	this	boot	disk	each	time	you	boot	your	PXI	system	into	LabVIEW
Real-Time.	Insert	the	boot	disk	into	the	floppy	drive	of	the	system	you	will
use	as	the	remote	system.	Power	on	or	reset	the	system	to	boot	into
LabVIEW	Real-Time.	When	the	PXI	system	is	booted	into	LabVIEW
Real-Time,	you	can	configure	the	remote	system.	Refer	to	your	PXI
documentation	for	more	information	about	configuring	your	desktop	PC.



PXI	Safe	Mode	Disk
The	PXI	Safe	Mode	Disk	bypasses	the	normal	boot	programs	on	the
controller.	Instead,	it	uses	programs	on	the	floppy	disk	to	boot	only
essential	services	required	for	updating	the	controller's	configuration	and
installing	software.	Safe	Mode	is	useful	if	the	software	on	the	controller
becomes	corrupted,	as	it	bypasses	the	corrupted	software.	You	can	then
use	MAX	to	reinstall	the	software.

Note		You	must	use	Windows	XP/2000	computers	to	create	this
disk	utility.	If	your	system	uses	Windows	Vista,	you	must	create	a
Desktop	PC	Utility	USB	Drive	instead.



Creating	the	PXI	Safe	Mode	Disk
Complete	the	following	steps	to	create	a	safe	mode	boot	disk	from	your
host	PC	or	PXI	system:

1.	 Place	a	floppy	disk	in	the	drive	of	the	host	PC.	Any	data	on	the
floppy	disk	will	be	overwritten.

2.	 Launch	MAX	by	selecting	All	Programs»National
Instruments»Measurement	&	Automation	Explorer	from	the
Windows	Start	menu	on	the	host	PC.

3.	 Select	Tools»RT	Disk	Utilities»Create	PXI	Safe	Mode	Disk.
4.	 The	PXI	Safe	Mode	Disk	dialog	box	appears.	Click	Yes	to	make

the	disk.	Follow	the	instructions	that	appear	on	your	screen.
5.	 Select	the	version	of	the	disk	utilities	you	want	to	use.
6.	 After	the	system	finishes	creating	the	boot	disk,	remove	the	floppy

disk	and	label	it	LabVIEW	RT	PXI	Safe	Mode	Disk.



Using	the	PXI	Safe	Mode	Disk
Complete	the	following	steps	to	boot	into	this	mode	if	your	system	has	a
floppy	drive:

1.	 Place	disk	into	the	PXI	system's	floppy	disk	drive.
2.	 Restart	the	system.
3.	 Remove	the	disk	from	the	RT	target	and	reboot	as	normal.

You	can	now	use	MAX	to	reconfigure	the	RT	target	and	reinstall	software.
Refer	to	your	PXI	documentation	for	more	information	about	configuring
your	PXI	controller.



Desktop	PC	Format	Hard	Drive	Disk
The	Desktop	PC	Format	Hard	Drive	Disk	reformats	the	C:	drive	of	the
remote	system,	deleting	all	data	on	that	system.	It	then	configures	the
hard	disk	to	boot	directly	into	the	real-time	operating	system,	which
allows	you	to	boot	into	the	LabVIEW	Real-Time	Module	if	LabVIEW	Real-
Time	was	not	preinstalled.	All	other	operating	systems	and	data	are
deleted.
To	boot	your	desktop	PC	system	into	either	Windows	or	LabVIEW	Real-
Time,	use	a	Desktop	PC	Boot	Disk	when	you	want	to	boot	into	LabVIEW
Real-Time.	If	you	prefer	to	use	your	desktop	PC	system	only	for	real-time
LabVIEW	Real-Time	applications,	use	the	Desktop	PC	Format	Hard
Drive	disk	once	to	enable	the	system	to	boot	into	LabVIEW	Real-Time
without	a	boot	floppy.

Note		You	must	use	Windows	XP/2000	computers	to	create	this
disk	utility.	If	your	system	uses	Windows	Vista,	you	must	create	a
Desktop	PC	Utility	USB	Drive	instead.



Creating	the	Desktop	PC	Format	Hard	Drive	Disk
Complete	the	following	steps	to	create	a	Desktop	PC	Format	Hard	Drive
Disk	from	your	host	PC	or	PXI	system:

1.	 Place	a	floppy	disk	in	the	drive	of	the	host	PC.	Any	data	on	the
floppy	disk	will	be	overwritten.

2.	 Launch	MAX	by	selecting	All	Programs»National
Instruments»Measurement	&	Automation	Explorer	from	the
Windows	Start	menu	on	the	host	PC.

3.	 Select	Tools»RT	Disk	Utilities»Create	Desktop	PC	Format
Hard	Drive	Disk.

4.	 The	Desktop	PC	Format	Hard	Drive	Disk	dialog	box	appears.
Click	Yes	to	make	the	boot	disk.	Follow	the	instructions	that
appear	on	your	screen.

5.	 Select	the	version	of	the	disk	utilities	you	want	to	use.
6.	 After	the	system	finishes	creating	the	boot	disk,	remove	the	floppy

disk	and	label	it	LabVIEW	RT	Desktop	PC	Format	Hard	Drive
Disk.



Using	the	Desktop	PC	Format	Hard	Drive	Disk
Insert	the	boot	disk	into	the	floppy	drive	of	the	remote	desktop	PC	you
use	as	the	remote	system.	Power	on	or	reset	the	remote	desktop	PC	to
format	the	hard	drive.

Note		The	hard	drive	must	be	formatted	FAT32	in	order	to	use	the
Desktop	PC	Format	Hard	Drive	Disk.



Desktop	PC	Boot	Disk
The	Desktop	PC	Boot	Disk	boots	a	desktop	PC	into	the	LabVIEW	Real-
Time	Module.	You	must	have	this	disk	in	the	desktop	PC	floppy	drive	to
boot	into	LabVIEW	Real-Time	if	your	system	has	a	Windows	operating
system	installed.

Note		You	must	use	Windows	XP/2000	computers	to	create	this
disk	utility.	If	your	system	uses	Windows	Vista,	you	must	create	a
Desktop	PC	Utility	USB	Drive	instead.



Creating	the	Desktop	PC	Boot	Disk
Complete	the	following	steps	to	create	a	boot	disk	from	your	host	PC	or
PXI	system:

1.	 Place	a	floppy	disk	in	the	drive	of	the	host	PC.	Any	data	on	the
floppy	disk	will	be	overwritten.

2.	 Launch	MAX	by	selecting	All	Programs»National
Instruments»Measurement	&	Automation	Explorer	from	the
Windows	Start	menu	on	the	host	PC.

3.	 Select	Tools»RT	Disk	Utilities»Create	Desktop	PC	Boot	Disk.
4.	 The	Desktop	PC	Boot	Disk	dialog	box	appears.	Click	Yes	to

make	the	boot	disk.	Follow	the	instructions	that	appear	on	your
screen.

5.	 Select	the	version	of	the	disk	utilities	you	want	to	use.
6.	 After	the	system	finishes	creating	the	boot	disk,	remove	the	floppy

disk	and	label	it	LabVIEW	RT	Desktop	PC	Boot	Disk.



Using	the	Desktop	PC	Boot	Disk
Use	this	boot	disk	each	time	you	boot	your	Windows	desktop	PC	into
LabVIEW	Real-Time.	Insert	the	boot	disk	into	the	floppy	drive	of	the
desktop	PC	you	will	use	as	the	remote	system.	Power	on	or	reset	the	PC
to	boot	into	LabVIEW	Real-Time.	When	the	remote	desktop	PC	is	booted
into	LabVIEW	Real-Time,	you	can	configure	the	remote	system.	Refer	to
your	PC	documentation	for	more	information	about	configuring	your
desktop	PC.



Desktop	PC	Safe	Mode	Disk
The	Desktop	PC	Safe	Mode	Disk	bypasses	the	normal	boot	programs	on
the	remote	desktop	PC.	Instead,	it	uses	programs	on	the	floppy	disk	to
boot	only	essential	services	required	for	updating	the	remote	desktop
PC's	configuration	and	installing	software.	Safe	Mode	is	useful	if	the
software	on	the	remote	desktop	PC	becomes	corrupted,	as	it	bypasses
the	corrupted	software.	You	can	then	use	MAX	to	reinstall	the	software.

Note		You	must	use	Windows	XP/2000	computers	to	create	this
disk	utility.	If	your	system	uses	Windows	Vista,	you	must	create	a
Desktop	PC	Utility	USB	Drive	instead.



Creating	the	Desktop	PC	Safe	Mode	Disk
Complete	the	following	steps	to	create	a	safe	mode	boot	disk	from	your
host	PC	or	PXI	system:

1.	 Place	a	floppy	disk	in	the	drive	of	the	host	PC.	Any	data	on	the
floppy	disk	will	be	overwritten.

2.	 Launch	MAX	by	selecting	All	Programs»National
Instruments»Measurement	&	Automation	Explorer	from	the
Windows	Start	menu	on	the	host	PC.

3.	 Select	Tools»RT	Disk	Utilities»Create	Desktop	PC	Safe	Mode
Disk.

4.	 The	Desktop	PC	Safe	Mode	Disk	dialog	box	appears.	Click	Yes
to	make	the	disk.	Follow	the	instructions	that	appear	on	your
screen.

5.	 Select	the	version	of	the	disk	utilities	you	want	to	use.
6.	 After	the	system	finishes	creating	the	boot	disk,	remove	the	floppy

disk	and	label	it	LabVIEW	RT	Desktop	PC	Safe	Mode	Disk.
Insert	the	boot	disk	into	the	floppy	drive	of	the	desktop	PC	you	use	as	the
remote	system.	Power	on	or	reset	the	remote	desktop	PC	to	boot	the
system	into	safe	mode.



Using	the	Desktop	PC	Safe	Mode	Disk
Complete	the	following	steps	to	boot	into	this	mode	if	your	system	has	a
floppy	drive:

1.	 Place	disk	in	the	system's	floppy	disk	drive.
2.	 Restart	the	system.
3.	 Remove	the	disk	from	the	RT	target	and	reboot	as	normal.

You	can	now	use	MAX	to	reconfigure	the	RT	target	and	reinstall	software.
Refer	to	your	remote	desktop	PC	documentation	for	more	information
about	configuring	a	remote	desktop	PC.



Launch	Settings	Reset	Disk
The	Launch	Settings	Reset	Disk	resets	the	system	so	that	the	LabVIEW
Real-Time	Module	does	not	start	any	user	applications	on	startup.	No
other	settings	are	affected.	Use	this	disk	if	a	runaway	user	application
has	caused	the	system	to	become	unresponsive	upon	startup.

Note		You	must	use	Windows	XP/2000	computers	to	create	this
disk	utility.	If	your	system	uses	Windows	Vista,	you	must	create	a
Desktop	PC	Utility	USB	Drive	instead.



Creating	the	Launch	Settings	Reset	Disk
Complete	the	following	steps	to	create	a	Launch	Settings	Reset	Disk
from	your	host	PC	or	PXI	system:

1.	 Place	a	floppy	disk	in	the	drive	of	the	host	PC.	Any	data	on	the
floppy	disk	will	be	overwritten.

2.	 Launch	MAX	by	selecting	All	Programs»National
Instruments»Measurement	&	Automation	Explorer	from	the
Windows	Start	menu	on	the	host	PC.

3.	 Select	Tools»RT	Disk	Utilities»Create	Launch	Settings	Reset
Disk.

4.	 The	Launch	Settings	Reset	Disk	dialog	box	appears.	Click	Yes
to	make	the	boot	disk.	Follow	the	instructions	that	appear	on	your
screen.

5.	 Select	the	version	of	the	disk	utilities	you	want	to	use.
6.	 After	the	system	finishes	creating	the	boot	disk,	remove	the	floppy

disk	and	label	it	LabVIEW	RT	Launch	Settings	Reset	Disk.



Using	the	Launch	Settings	Reset	Disk
Complete	the	following	steps	to	boot	into	Launch	Settings	Reset	mode
using	an	RT	target	with	a	floppy	drive:

1.	 Place	the	disk	in	the	RT	target's	floppy	drive.
2.	 Power	on	or	reset	the	remote	system	to	reset	the	launch	settings.
3.	 Remove	the	disk	from	the	RT	target	and	boot	as	normal.



IP	Reset	Disk
The	IP	Reset	Disk	resets	the	IP	network	settings	of	the	PXI	controller	or
remote	desktop	PC	to	the	factory	defaults,	0.0.0.0.	You	also	can	use	this
disk	to	clear	the	password	and	unlock	the	remote	system	if	the	system	is
locked	with	a	password.

Note		You	must	use	Windows	XP/2000	computers	to	create	this
disk	utility.	If	your	system	uses	Windows	Vista,	you	must	create	a
Desktop	PC	Utility	USB	Drive	instead.

Complete	the	following	steps	to	create	an	IP	Reset	Disk	from	your	host
PC	or	PXI	system:



Creating	the	IP	Reset	Disk
1.	 Place	a	floppy	disk	in	the	drive	of	the	host	PC.	Any	data	on	the

floppy	disk	will	be	overwritten.
2.	 Launch	MAX	by	selecting	All	Programs»National

Instruments»Measurement	&	Automation	Explorer	from	the
Windows	Start	menu	on	the	host	PC.

3.	 Select	Tools»RT	Disk	Utilities»Create	IP	Reset	Disk.
4.	 The	IP	Reset	Disk	dialog	box	appears.	Click	Yes	to	make	the

boot	disk.	Follow	the	instructions	that	appear	on	your	screen.
5.	 Select	the	version	of	the	disk	utilities	you	want	to	use.
6.	 After	the	system	finishes	creating	the	boot	disk,	remove	the	floppy

disk	and	label	it	LabVIEW	RT	IP	Reset	Disk.



Using	the	IP	Reset	Disk
Complete	the	following	steps	to	boot	into	IP	Reset	mode	using	an	RT
target	with	a	floppy	drive:

1.	 Place	the	IP	Reset	Disk	in	the	RT	target's	floppy	drive.
2.	 Power	on	or	reset	the	controller	to	reset	the	IP	settings	and

password.
3.	 Remove	the	disk	from	the	RT	target	and	boot	as	normal.

You	must	use	MAX	to	reconfigure	the	IP	address	before	you	can	connect
to	the	RT	target	using	LabVIEW.



Uninstall	Disk
The	Uninstall	Disk	removes	an	installation	of	the	LabVIEW	Real-Time
Module,	along	with	all	configuration	information,	such	as	IP	address.	Use
the	uninstall	disk	if	the	remote	system	becomes	unresponsive	and
prevents	you	from	installing	software	remotely.

Note		You	must	use	Windows	XP/2000	computers	to	create	this
disk	utility.	If	your	system	uses	Windows	Vista,	you	must	create	a
Desktop	PC	Utility	USB	Drive	instead.



Creating	the	Uninstall	Disk
Complete	the	following	steps	to	create	an	uninstall	disk	from	your	host
computer:

1.	 Place	a	floppy	disk	in	the	drive	of	the	host	PC.	Any	data	on	the
floppy	disk	will	be	overwritten.

2.	 Launch	MAX	by	selecting	All	Programs»National
Instruments»Measurement	&	Automation	Explorer	from	the
Windows	Start	menu	on	the	host	computer.

3.	 Select	Tools»RT	Disk	Utilities»Create	Uninstall	Disk.
4.	 The	Uninstall	Disk	dialog	box	appears.	Click	Yes	to	make	the

boot	disk.	Follow	the	instructions	that	appear	on	your	screen.
5.	 Select	the	version	of	the	disk	utilities	you	want	to	use.
6.	 After	the	system	finishes	creating	the	boot	disk,	remove	the	floppy

disk	and	label	it	LabVIEW	RT	Uninstall	Disk.



Using	the	Uninstall	Disk
Complete	the	following	steps	to	boot	into	this	mode:

1.	 Place	the	disk	in	the	RT	target's	floppy	drive.
2.	 Reboot	the	RT	target.
3.	 Remove	the	disk	from	the	RT	target	and	replace	it	with	a	boot

disk.
4.	 Reboot	the	RT	target	again.

You	must	now	use	MAX	to	reconfigure	the	RT	target	and	reinstall
software.



Making	Network	and	Non-Network	Connections
The	host	computer	communicates	with	the	remote	system	over	a
standard	Ethernet	connection.	If	the	host	computer	is	already	configured
on	a	network,	you	must	configure	your	remote	system	on	the	same
network.	If	neither	machine	is	connected	to	a	network,	you	must	connect
the	two	machines	directly	using	a	CAT-5	crossover	cable	or	hub.	You	can
use	the	direct	connection	to	configure	the	remote	system	from	the	host
computer	system.

Note		If	your	target	does	not	support	automatic	IP	address
assignment	and	you	want	to	make	a	direct	connection	using	a
CAT-5	crossover	cable,	you	must	first	disable	DHCP	on	your	host
computer.	Complete	the	following	steps	to	disable	DHCP:

1.	 From	the	Windows	Start	menu,	select	the	following,
depending	on	your	computer's	operating	system:

Control	Panel»Network	and	Internet»Network	and
Sharing	Center»Manage	network	connections	if
you	are	using	Windows	Vista
Control	Panel»Network	Connections	if	you	are
using	Windows	XP
Settings»Control	Panel»Network	and	Dial-up
Connections	if	you	are	using	Windows	2000

2.	 Right-click	the	network	connection	you	want	to	configure,
and	then	select	Properties.

3.	 On	the	General	tab,	click	Internet	Protocol	(TCP/IP),	and
then	select	Properties.	In	Windows	Vista,	select	Internet
Protocol	Version	4	(TCP/IPv4).

4.	 Click	Use	the	following	IP	address.	Enter	an	IP	address
for	your	host	computer.

For	targets	that	do	not	automatically	acquire	their	IP	addresses	from
DHCP,	both	the	host	computer	and	the	remote	system	must	reside	on	the
same	subnet	in	order	for	you	to	configure	the	remote	system	with	MAX.
You	can	develop	and	run	LabVIEW	Real-Time	Module	applications	when
the	remote	system	is	on	a	different	subnet	than	that	of	the	host	computer.
To	run	LabVIEW	Real-Time	applications	on	a	remote	system	that	resides
on	a	different	subnet,	assign	a	static	IP	address	to	the	controller	that



corresponds	to	the	subnet	where	the	remote	system	is	located.	Refer	to
Assigning	an	IP	Address	for	more	information	about	IP	addresses.



Using	MAX	to	Detect	Remote	Systems
Expand	Remote	Systems	in	the	Measurement	&	Automation	(MAX)
configuration	tree.	Previously	detected	remote	systems	appear
immediately	beneath	Remote	Systems	in	the	configuration	tree.	MAX
continues	to	search	for	newly	attached	remote	systems	on	the	local
subnet.	Detected	systems	will	be	added	to	the	list	after	a	short	delay.	All
detected	systems	appear	beneath	Remote	Systems	in	the	configuration
tree.	MAX	searches	for	new	remote	systems	every	time	you	launch	MAX
and	expand	Remote	Systems.	You	can	also	detect	newly	connected
remote	systems	by	selecting	View»Refresh	(F5)	to	scan	for	local	and
remote	devices.

Note		The	IP	address	of	your	remote	system	appears	as	the
default	remote	system	name	in	the	configuration	tree.	If	more	than
one	system	appears	in	Remote	Systems,	select	the	IP	address	of
the	system	you	want	to	configure.	Use	the	Network	Settings	tab
of	the	configuration	view	to	assign	a	host	name,	if	available,	to
your	remote	system.	MAX	then	uses	the	name	to	identify	the
device	in	the	configuration	tree.	(This	host	name	is	not	necessarily
a	DNS	host	name.	For	more	information	about	host	names,	refer
to	Configuring	Network	Settings.)	The	system	state	may	be
Unconfigured	if	your	target	does	not	support	automatic	IP
assignment	and	if	you	have	not	set	the	IP	address	for	the	target.	

For	more	information	about	setting	an	IP	address,	refer	to	IP
Settings	Information.



Configuring	Network	Settings
Complete	the	following	steps	to	configure	the	network	settings	of	your
networked	RT	Series	devices:

1.	 From	MAX,	expand	Remote	Systems	in	the	configuration	tree
and	select	your	remote	system.

2.	 Select	the	Network	Settings	tab.	If	this	is	the	first	time	that	you
have	started	the	controller,	the	setting	could	show	either	a
network	address,	an	automatic	private	IP	address	(169.254.x.x),	or
0.0.0.0,	depending	on	how	your	target	acquires	network
addresses.

3.	 Enter	a	host	name	in	the	Name	text	box.	Choose	a	name	that
makes	your	system	easy	to	identify.

Note		Your	system	may	already	have	a	named	assigned	to
it.	You	can	keep	this	name	or	enter	another	name.

Note		You	can	assign	a	remote	system	either	a	static	IP
address	or	automatically.	If	you	use	a	static	IP	address,
then	you	cannot	use	the	host	name	from	another	computer
to	contact	the	remote	system.	The	host	name	is	just	a	label
in	this	case.

If	you	configure	your	system	to	automatically	acquire	an	IP
address,	the	system	requests	an	IP	address	from	the
DHCP	server	when	the	system	starts	up.	When	it	assigns
the	IP	address,	the	DHCP	server	can	also	assign	a	host
name	based	on	a	requested	host	name	from	your	system.
If	everything	is	configured	correctly,	then	the	DHCP	server
adds	that	host	name	to	the	DNS	tables,	and	you	can	now
contact	this	host	with	its	host	name	using	DNS.	Because
this	host	name	request	is	part	of	the	DHCP	protocol,	it	only
works	with	DHCP.

Although	the	DHCP	specification	allows	for	a	remote
system	to	request	a	host	name	from	the	server,	it	does	not
require	that	the	DHCP	server	grant	this	request.	The	DHCP
server	can:



Grant	the	request.
Ignore	the	request	entirely.
Alter	the	host	name,	such	as	turning	a	requested
host	name	of	myhost	into	myhost_dynip123.

The	DHCP	server	has	no	feedback	mechanism.	The	only
way	to	find	out	the	assigned	host	name	is	to	do	a	reverse
DNS	lookup	on	the	IP	address	of	the	system.	(From	a
command	prompt,	type	nslookup	<ip	address>.)

Note		DHCP	for	FieldPoint	requires	LabVIEW	Real-Time
7.0	or	later.	DNS	name	assignment	for	FieldPoint	requires
LabVIEW	Real-Time	7.1	or	later.

4.	 On	the	Network	Settings	tab,	enter	the	Ethernet	parameters	you
want	to	assign	to	the	remote	system.	

You	can	either	assign	a	static	IP	address	or	have	the	system
retrieve	an	IP	address	automatically.	For	more	information,	refer
to	IP	Configuration.	For	more	information	on	setting	static	IP
addresses,	refer	to	Specifying	a	Static	IP	Address.	For	more
information	on	obtaining	an	IP	address	automatically,	refer	to
Assigning	an	IP	Address.	

IP	Address	and	Subnet	Mask	are	required	parameters.	Set
Gateway	and	DNS	Server	to	the	default	configuration,	0.0.0.0,	if
your	network	does	not	have	a	gateway	or	DNS	server.

5.	 If	you	are	running	a	PXI	system	and	if	you	do	not	have	a	static	IP
address,	select	Obtain	an	IP	address	automatically	in	the	IP
Settings	section	of	the	Network	Settings	tab	to	obtain	an	IP
address	automatically.	If	you	configured	your	device	to	use	a
static	IP	address,	skip	this	step.

6.	 Click	Apply	in	the	Network	Settings	tab.
7.	 Click	Yes	when	prompted	to	restart	the	remote	system.
8.	 Configure	locking	and	TCP/IP	halt,	if	desired.



IP	Configuration
Assigning	an	IP	Address
Specifying	a	Static	IP	Address
IP	Settings	Information
Halting	the	System	if	TCP/IP	Fails
Locking	System	Configuration



Assigning	an	IP	Address
You	can	connect	to	your	remote	system	either	by	connecting	it	and	your
host	computer	to	a	local	area	network	or	by	connecting	it	directly	to	your
host	computer	using	a	CAT-5	crossover	cable.	Either	way,	your	remote
system	must	have	an	IP	address	assigned	to	it.	You	can	either	attempt	to
obtain	an	IP	address	automatically	or	manually	specify	one.
Some	targets,	such	as	all	FieldPoint	FP-160x	RT	targets,	require	that	you
specify	a	static	IP	address,	as	they	do	not	support	automatic	IP	address
assignment.	You	may	also	need	to	specify	an	IP	address	if	your	remote
system	is	not	connected	to	a	network	and	you	want	to	make	a	direct
connection.	Refer	to	Specifying	a	Static	IP	Address	for	help	specifying	an
IP	address.
If	your	remote	system	is	on	a	network	that	has	a	DHCP	server,	you	may
be	able	to	automatically	obtain	an	IP	address	from	the	DHCP	server.	A
DHCP	server	allocates	an	IP	address	to	your	target	each	time	the	target
is	started.	You	do	not	need	to	specify	other	information	such	as	Subnet
Mask	if	you	select	the	Obtain	an	IP	address	automatically	option.	If
you	do	not	know	whether	your	network	has	a	DHCP	server,	check	with
your	network	administrator	for	assistance.	To	automatically	obtain	an	IP
address,	select	Obtain	an	IP	address	automatically,	then	click	Apply.
You	must	restart	the	remote	system	for	any	changes	to	take	effect.
Not	all	DHCP	servers	are	implemented	in	the	same	manner.	Therefore,
some	might	not	be	compatible	with	the	LabVIEW	Real-Time	Module.
After	you	select	Obtain	an	IP	address	automatically	and	restart	the	RT
target,	LabVIEW	Real-Time	tries	to	obtain	an	IP	address	from	the	DHCP
server.	If	this	operation	fails,	LabVIEW	Real-Time	automatically	restarts
the	RT	target	and	attempts	to	assign	an	automatic	private	IP	address
(169.254.x.x),	if	your	target	supports	this	feature.	Automatic	private	IP
addresses	are	network	addresses	intended	for	use	in	a	local	network
only.	After	three	failed	attempts,	LabVIEW	Real-Time	returns	to	the
default	configuration	with	IP	address	0.0.0.0.	In	this	case,	you	need	to
explicitly	specify	the	network	parameters.
In	addition,	when	you	use	a	DHCP	server,	the	server	allocates	an	IP
address	to	the	remote	system	each	time	you	boot	the	target.	The	new	IP
address	might	be	different	than	the	address	previously	assigned.	If	you
use	the	DHCP	server	to	assign	an	IP	address	to	your	target,	you	need	to



check	the	IP	address	using	MAX	each	time	you	target	LabVIEW	Real-
Time	to	the	target.	To	avoid	needing	to	check	the	IP	address	each	time,
specify	a	static	IP	address	for	the	target	instead	of	using	a	DHCP	server.



Specifying	a	Static	IP	Address
If	you	choose	to	specify	an	IP	address,	select	Use	the	following	IP
address	from	the	Network	Settings	tab,	fill	in	the	network	parameters
described	below	with	correct	values	for	your	network,	then	click	Apply.
You	must	restart	the	remote	system	for	any	changes	to	take	effect.

IP	Address—The	unique	address	of	a	device	on	your	network.
Each	IP	address	is	a	set	of	four	one-	to	three-digit	numbers.	Each
number	is	in	the	range	from	0	through	255	and	is	separated	by	a
period.	This	format	is	called	dotted	decimal	notation.	The	IP
address	224.102.13.24	is	an	example	of	dotted	decimal	notation.
Subnet	Mask—A	code	that	helps	the	network	device	determine
whether	another	device	is	on	the	same	network	or	a	different
network.	255.255.255.0	is	the	most	common	subnet	mask.
Gateway—The	IP	address	of	a	device	that	acts	as	a	gateway
server,	which	is	a	connection	between	two	networks.
DNS	Address—The	IP	address	of	a	network	device	that	stores
DNS	host	names	and	translates	them	into	IP	addresses.

Consult	with	your	network	administrator	before	specifying	these
parameters.	If	you	do	not	have	a	network	administrator	or	you	are	the
network	administrator,	refer	to	IP	Settings	Information	for	more	help.	If
you	are	uncertain	about	what	to	set,	click	Suggest	Values	to	have	MAX
attempt	to	detect	the	appropriate	settings.	Click	Refresh	to	revert	your
changes.



IP	Settings	Information
If	you	are	assembling	your	own	Ethernet	network,	you	can	choose	an	IP
address.	The	subnet	mask	determines	the	format	of	the	IP	address.	Use
the	same	subnet	mask	as	the	host	computer	when	you	configure	your
remote	system.	For	example,	if	your	subnet	mask	is	255.255.255.0,	the
first	three	numbers	in	every	IP	address	on	the	network	must	be	the	same.
If	your	subnet	mask	is	255.255.0.0,	only	the	first	two	numbers	in	the	IP
addresses	on	the	network	must	match.
For	either	subnet	mask,	you	can	use	numbers	between	1	and	254	for	the
last	number	of	the	IP	address.	(Do	not	use	numbers	0	and	255;	they	are
reserved.)	You	can	use	numbers	between	0	and	255	for	the	third	number
of	the	IP	address,	but	this	number	must	be	the	same	as	other	devices	on
your	network	if	your	subnet	mask	is	255.255.255.0.
If	you	are	setting	up	your	own	network	and	do	not	have	a	gateway	or
DNS	server,	set	these	values	to	the	default	configuration,	0.0.0.0.
To	find	out	the	network	settings	for	your	host	computer,	run	ipconfig.
To	run	ipconfig,	open	a	command	prompt	window,	type	ipconfig	at	the
prompt,	and	press	<Enter>.	If	you	need	more	information,	run	ipconfig
with	the	/all	option	by	typing	ipconfig	/all	to	see	all	the	settings	for	the
computer.	Make	sure	you	use	the	settings	for	the	correct	Ethernet
adapter	to	configure	your	remote	system.



Halting	the	System	if	TCP/IP	Fails
Use	the	Halt	system	if	TCP/IP	fails	checkbox	to	determine	how	the
LabVIEW	Real-Time	Module	and	the	controller	behave	when	there	is	a
TCP/IP	failure	while	the	controller	is	booting.
If	the	checkbox	is	not	checked,	LabVIEW	Real-Time	starts	and	runs	start-
up	applications	you	created,	even	if	it	cannot	automatically	obtain	an	IP
address,	or	if	TCP/IP	fails	for	any	other	reasons	when	you	start	the
system.	When	the	connection	becomes	available,	you	must	manually
restart	the	controller	in	order	to	connect	it	to	the	network.
If	TCP/IP	fails	and	the	checkbox	is	checked,	LabVIEW	Real-Time
attempts	to	obtain	an	automatic	IP	address	using	DHCP.	If	the	attempt	to
obtain	an	IP	address	fails,	LabVIEW	Real-Time	attempts	to	obtain	an
automatic	private	IP	address	(169.254.x.x),	if	your	target	supports	this
feature.	If	the	attempt	to	obtain	a	private	IP	address	also	fails	or	is	not
supported,	LabVIEW	Real-Time	will	reboot	the	target	to	try	again.	After
three	failed	attempts,	LabVIEW	Real-Time	resets	the	controller	to	IP
address	0.0.0.0.

Note		DHCP	failure	is	considered	a	TCP/IP	failure.



Advanced	Ethernet	Settings
Use	the	Advanced	Ethernet	Settings	dialog	box	to	configure	advanced
Ethernet	settings	for	an	RT	target.	Click	Advanced	Ethernet	Settings	on
the	Network	Settings	tab	to	access	these	settings.

Note		Use	caution	when	attempting	to	change	the	Ethernet
settings	of	an	RT	target.	Changing	the	Ethernet	settings	of	an	RT
target	can	affect	the	network	performance	of	the	target.

This	dialog	box	includes	the	following	components:
Ethernet	Devices	(by	MAC	Address)—Lists	by	media	access
control	(MAC)	address	all	the	Ethernet	devices	detected	in	the
system.	The	first	device	in	the	list	is	the	default	device.
Make	Primary—Makes	the	selected	device	the	primary	device.
The	previous	primary	device	is	disabled.	You	can	re-enable	the
previously	primary	device	unless	it	is	the	default	device.	The	button
is	disabled	if	the	selected	device	is	already	the	primary	device.
Mode—If	the	selected	device	is	the	primary	network	device,	Mode
is	TCP/IP	Network.	The	primary	device	can	only	be	used	for
TCP/IP	(DHCP	or	Static)	or	be	disabled.	For	devices	other	than	the
primary	device	or	the	default	device,	Mode	specifies	how	the
device	is	used.	The	menu	is	disabled	if	the	selected	device	is	the
primary	or	default	device.	You	can	reserve	other	network	devices
for	application-specific	purposes	by	selecting	other	modes,
including	Time-Triggered	and	EtherCAT,	if	supported.	When	you
reserve	a	device,	you	set	that	device	aside	for	an	application	that
takes	control	of	it	at	a	later	time.	It	is	not	configured	or	initialized	at
boot	time	like	devices	set	for	TCP/IP.
IP	Address—For	devices	other	than	the	primary	device	or	the
default	device,	specifies	the	IP	address	for	that	device.	The	fields
are	disabled	if	the	selected	device	is	the	primary	device	or	the
default	device	or	if	the	Mode	of	the	device	is	not	TCP/IP	Network.
If	the	selected	device	is	the	primary	device,	the	IP	address	is	the
primary	IP	address	of	the	target	as	specified	on	the	main	Network
Settings	tab.
Subnet	Mask—For	devices	other	than	the	primary	device	or	the
default	device,	specifies	the	subnet	mask	for	that	device.	The	fields
are	disabled	if	the	selected	device	is	the	primary	device	or	the



default	device	or	if	the	Mode	of	the	device	is	not	TCP/IP	Network.
If	the	selected	device	is	the	primary	device,	the	subnet	mask	is	the
primary	subnet	mask	of	the	target	as	specified	on	the	main
Network	Settings	tab.
Preferred	Media	Mode—For	devices	whose	Mode	is	set	to
TCP/IP	Network	(including	the	primary	device),	selects	the	mode
the	device	uses	to	communicate	on	the	wire.	The	menu	is
displayed	only	if	the	device's	Mode	is	TCP/IP	Network	and	shows
only	those	options	the	device	supports.

Note		The	remote	target	does	not	have	to	honor	this	setting.
The	actual	mode	used	by	the	remote	target	may	differ.

You	can	set	the	following	speed/duplex	items:
10 Sets	the	connection	speed	of	the	Ethernet	hardware	to

10	Mbps.
100 Sets	the	connection	speed	of	the	Ethernet	hardware	to

100	Mbps.
Gigabit Sets	the	connection	speed	of	the	Ethernet	hardware	to

1,000	Mbps,	or	1	gigabit	per	second	(Gbps)
Half The	RT	target	allows	one-way	communication	through

the	Ethernet	connection.	The	RT	target	can	send	data	or
receive	data,	but	not	simultaneously.

Full The	RT	target	allows	two-way	communication	through
the	Ethernet	connection.	The	RT	target	can	send	and
receive	data	simultaneously.
Note		Setting	the	duplex	of	RT	targets	from	full	to	half
can	increase	network	performance	for	some	targets.

Packet	Detection—For	devices	whose	mode	is	set	to	TCP/IP
Network	(including	the	primary	device),	selects	the	method	the
device	uses	to	detect	incoming	packets.	For	targets	that	support
the	Advanced	Ethernet	DDP	command,	only	the	actual	capabilities
of	the	driver	are	enabled.	For	targets	that	do	not	support	the
Advanced	Ethernet	DDP	command,	both	items	are	enabled
regardless	of	the	actual	capabilities	of	the	driver.	The	menu	is
disabled	if	the	device's	mode	is	not	TCP/IP	Network.



You	can	set	the	following	mode	settings	for	an	RT	target:
Interrupt The	operating	system	of	the	RT	target	waits	for	an

interrupt	that	signals	the	arrival	of	new	data	through	the
Ethernet	connection.	The	operating	system	then
retrieves	the	new	data.

Polling he	operating	system	of	the	RT	target	periodically
checks	for	the	arrival	of	new	data	through	the	Ethernet
connection.	If	new	data	is	available,	the	operating
system	retrieves	the	new	data.	You	must	set	the	polling
interval	if	you	select	the	polling	mode.

Polling	Interval—For	devices	that	are	set	to	use	polling	for	packet
detection,	specifies	how	often	the	driver	should	check	for	new
packets.	Permissible	values	range	from	1	to	10000	ms.	The	field	is
disabled	if	the	device	is	not	set	to	use	polling	for	packet	detection.
Maximum	Number	of	Sockets—Specifies	the	maximum	number
of	sockets	that	can	be	open	simultaneously	on	the	target.	Some
sockets	are	required	for	services	such	as	the	DDP	server,	the	FTP
server,	and	LabVIEW	itself,	so	the	number	specified	here	is	not	the
same	as	the	number	of	network	connections	the	user	can	make	to
the	system.	Permissible	values	range	from	20	to	65534	sockets.
IP	Fragment	Hold	Time—Specifies	how	many	seconds	IP
fragments	are	held	waiting	for	the	remaining	fragments	to	be
received	to	complete	the	packet.	Permissible	values	range	from	2
to	255	seconds.



Change	IP	(Offline)
Use	Change	IP	(Offline)	to	change	the	IP	address	of	your	remote
system	after	it	obtained	an	IP	address	different	from	its	current	IP
address.
MAX	automatically	detects	an	IP	address	change	for	targets	on	the	local
subnet.	If	the	IP	address	of	a	target	on	a	remote	subnet	changes,	you
can	use	this	setting	to	make	MAX	aware	of	the	change.
To	access	this	setting,	expand	Remote	Systems	in	the	MAX
configuration	tree.	Right-click	your	system	and	select	Change	IP
(Offline).



Configuring	System	Settings
You	can	set	two	system-level	settings	for	your	LabVIEW	Real-Time	target
—time	zone	and	locale.
Use	the	Time	zone	setting	to	configure	the	time	zone	in	which	the	target
resides.	You	can	use	this	setting	with	LabVIEW	time	and	date	VIs	to
provide	accurate	time	information,	relative	to	the	time	zone	setting.
Check	the	daylight	saving	time	checkbox	to	automatically	adjust	the
target's	clock	for	daylight	saving	time	changes,	if	this	feature	is	supported
by	the	target.
Use	the	Locale	setting	to	change	the	locale	of	strings	returned	from	the
remote	target.	Not	all	software	supports	this	setting,	which	is	disabled	if
not	supported	by	any	software	on	your	target.
You	can	view,	but	not	change,	four	system-level	items	in	the	System
Monitor	section:

Total	Disk	Space	displays	the	total	amount	of	disk	space	on	the
primary	drive,	for	example	C:,	on	this	target.
Free	Disk	Space	displays	the	amount	of	free	disk	space	on	the
primary	drive,	for	example	C:,	on	this	target.
Total	RAM	displays	the	total	amount	of	memory	on	this	target.
Free	RAM	displays	the	amount	of	free	memory	on	this	target.



Adding	or	Removing	Software
You	can	install	the	LabVIEW	Real-Time	Module	or	other	driver	software
on	the	remote	target	after	you	have	assigned	it	an	IP	address.
If	your	RT	target	has	LabVIEW	Real-Time	preinstalled,	you	may	still	need
to	download	additional	driver	software.	In	this	case,	the	state	of	your	RT
target	should	be	Connected-Running	on	the	Network	Settings	tab.
If	your	RT	target	has	a	Windows	operating	system	installed,	you	must
install	LabVIEW	Real-Time.	You	can	install	or	upgrade	LabVIEW	Real-
Time	or	other	driver	software	using	the	LabVIEW	Real-Time	Software
Wizard.
Complete	the	following	steps	to	launch	the	LabVIEW	Real-Time	Software
Wizard:

1.	 Expand	Remote	Systems	in	the	configuration	tree	and	then
expand	your	RT	target.

2.	 Select	the	Software	category.	Click	the	Add/Remove	Software
icon	on	the	toolbar	to	launch	the	LabVIEW	Real-Time	Software
Wizard.	If	your	RT	target	does	not	have	a	Software	category,	it
does	not	support	the	LabVIEW	Real-Time	software.

3.	 Use	the	LabVIEW	Real-Time	Software	Wizard	to	add,	remove,	or
update	the	software	on	your	remote	target.



Using	the	LabVIEW	Real-Time	Software	Wizard
Complete	the	following	steps	to	download	software	using	the	LabVIEW
Real-Time	Software	Wizard:

1.	 If	you	have	not	already	launched	the	LabVIEW	Real-Time
Software	Wizard,	complete	the	following	directions	to	do	so:

a.	 Expand	Remote	Systems	in	the	configuration	tree	and
then	expand	your	RT	target.

b.	 Select	Software.	Click	the	Add/Remove	Software	icon	on
the	toolbar	to	launch	the	LabVIEW	Real-Time	Software
Wizard.	If	your	target	does	not	have	a	Software	category,
then	it	does	not	support	the	LabVIEW	Real-Time	software.

2.	 Determine	what	you	want	to	do.	If	your	RT	target	uses
recommended	software	sets,	refer	to	Installing	Recommended
Software	Sets.	If	your	RT	target	uses	a	custom	software	selection,
refer	to	Installing	a	Custom	Software	Selection.



Installing	a	Recommended	Software	Set
Complete	the	following	steps	to	download	a	recommended	software	set
using	the	LabVIEW	Real-Time	Software	Wizard:

1.	 Determine	what	you	want	to	do,	as	follows:
	Select	the	software	you	want	to	install.	When	you	select

an	item,	the	right	side	presents	a	list	of	the	software
included	in	the	software	set	predefined	and	recommended
by	National	Instruments.

If	the	recommended	software	set	is	grayed	out,	the
software	set	cannot	be	installed	for	one	of	the	following
reasons:

Software	versions	required	by	the	recommended
software	set	are	not	present	on	the	host	computer.
You	can	select	Custom	software	installation	to
install	other	versions	of	the	software.
Software	is	missing	from	the	host	computer.	You	can
select	Custom	software	installation	to	install	other
software	or	exit	MAX	and	reinstall	your	driver
software.

	Select	Custom	software	installation	to	manually	select
the	features	you	want	to	install	on	your	target.

Note		If	you	select	Custom	software	installation
and	click	Next,	the	Features	page	appears.	If	you
select	to	install	components	from	this	page,	your
remote	target	will	no	longer	have	the	recommended
software	set	installed.	For	more	information,	refer	to
Installing	a	Custom	Software	Selection.

	Select	Uninstall	all	software	to	remove	all	software	from
your	remote	target.

2.	 Click	Next	to	move	to	the	confirmation	page	after	you	make	the
appropriate	selections.	This	page	lists	all	the	changes	that	are	to
be	made	to	the	remote	target.

3.	 Click	Next	to	continue,	if	you	are	satisfied	with	these	changes.
The	target	first	boots	into	install	mode,	if	necessary,	and	then
begins	installation.	During	the	installation,	a	progress	bar	tracks



the	removal	of	old	files	and	then	the	installation	of	new	files,	with
the	current	file	listed	above	the	progress	bar.	When	installation
completes,	the	wizard	reboots	your	remote	target.

4.	 Click	Finish	to	close	the	wizard.
The	installed	software	should	now	be	running	on	the	remote	target.



Updating	the	BIOS	Firmware
Click	Update	BIOS	to	update	the	real-time	BIOS	firmware	on	your
remote	target	if	there	is	a	newer	version	available.	Updating	the	real-time
BIOS	firmware	removes	all	existing	installed	software.



Installing	a	Custom	Software	Selection
Complete	the	following	steps	to	download	custom	software	features
using	the	LabVIEW	Real-Time	Software	Wizard:

1.	 Determine	what	you	want	to	do,	as	follows:
View	software	already	installed	to	your	target.

Note		Software	installed	by	MAX	3.0.x	or	earlier	will
not	appear	but	will	continue	to	work.	You	must	reinstall
your	software	in	order	for	it	to	appear	in	this	view.

View	software	available	to	install	to	your	target.
Click	Update	BIOS	to	update	the	real-time	BIOS	firmware
on	your	target	if	there	is	a	newer	version	available.
Updating	the	real-time	BIOS	firmware	removes	all	existing
installed	software.
Change	the	software	on	your	remote	target.	Click	its	icon
and	select	the	appropriate	option.	The	icon	changes	and
becomes	more	descriptive	when	the	software	in	the	list	is
selected.	You	can	select	from	the	following	options:
	Install—Selected	software	will	be	installed	to	your	target.

	Leave	installed—Selected	software	will	remain	installed
on	your	target.

	Newer	available—Selected	software	will	remain	installed
on	your	target,	but	a	newer	version	is	available	for
installation.	

	Reinstall—Selected	software	will	be	reinstalled	to	your
target.	Choose	this	option	also	if	you	want	to	change	the
installed	version.

	Uninstall—Selected	software	will	be	uninstalled	from
your	target.

	Leave	uninstalled—Selected	software	will	remain
uninstalled	on	your	target.



	Autoselect—Selects	all	software	for	install	or	uninstall.
When	you	select	an	item,	the	right	side	presents	a	more
detailed	view	of	that	particular	component,	including:

A	description.
Version	installed	on	the	remote	target.
Versions	available	on	the	local	host.	By	default	the
latest	version	is	selected	for	install.	If	you	change	the
version	in	the	drop-down	list,	you	can	install	or
reinstall	an	older	version	of	the	software.	If	the
software	is	a	child	component,	then	you	might	not
see	a	version	in	the	tree	or	a	version	drop-down.
An	icon	describing	the	state	of	the	selected	item	and
a	message	below	the	icon	describing	that	state,
including	installed,	not	installed,	selected	for
(re)install,	selected	for	uninstall,	or	installed	but	a
newer	version	exists	on	host.
Notes

If	the	action	you	selected	cannot	be	performed
because	of	dependencies,	a	Show
Dependent	Features	window	appears	to
explain	the	dependencies	and	provide	options
for	resolving	the	conflict.
On	some	targets,	such	as	the	PXI-814X	Series
Controller,	the	LabVIEW	Real-Time	component
must	be	installed	to	the	target	by	itself	prior	to
installing	other	driver	software.

2.	 Click	Next	to	move	to	the	confirmation	page	after	you	make	the
appropriate	selections.	This	page	lists	all	the	changes	that	are	to
be	made	to	the	remote	target.

3.	 Click	Next	to	continue,	if	you	are	satisfied	with	these	changes.
The	target	first	boots	into	install	mode,	if	necessary,	and	then
begins	installation.	During	the	installation,	a	progress	bar	tracks
the	removal	of	old	files	and	then	the	installation	of	new	files,	with
the	current	file	listed	above	the	progress	bar.	When	installation
completes,	the	wizard	reboots	your	remote	target.

4.	 Click	Finish	to	close	the	wizard.



The	installed	software	should	now	be	running	on	the	remote	target.



Locking	System	Configuration
After	you	configure	the	remote	system,	you	can	lock	the	system
configuration	with	a	password	to	prevent	others	on	your	network	from
changing	the	configuration,	if	your	device	supports	locking.

Note		Only	Network	Settings,	System	Settings,	the	LabVIEW
Real-Time	Software	Wizard,	and	some	VISA/PXI	settings	are
protected	with	the	Lock	setting.

In	addition,	a	host	computer	on	the	network	cannot	target	the	LabVIEW
Real-Time	Module	to	the	remote	system	without	a	password	unless	the
host	is	in	the	RT	Target:	Access	list	in	LabVIEW.	To	access	this	list	from
within	LabVIEW	8.0	or	later,	right-click	a	project	window	and	select
Properties.	In	LabVIEW	7.x	or	earlier,	select	the	Tools»RT	Target
Options	menu	item.
If	you	check	Password-protect	Resets	in	MAX	and	click	Apply	before
you	lock	your	remote	system,	your	users	will	be	prompted	for	a	password
when	trying	to	reboot	the	remote	system	from	the	network.
Complete	the	following	steps	to	lock	the	system	configuration:

1.	 Select	your	remote	system	in	the	configuration	tree	and	click
Lock	in	the	toolbar.	The	Locking	System	Configuration	dialog
box	appears.

2.	 Enter	and	confirm	a	password.
3.	 Click	OK	to	lock	the	system	configuration.	Your	system	is	locked	if

the	Lock	button	appears	pressed.
You	must	click	Lock	in	MAX	and	enter	the	correct	password	to	unlock	the
system	configuration.



Viewing	Error	Logs
Use	the	View	Error	Log	selection	to	view	remote	system	error	logs.	To
access	the	log	from	within	MAX,	right-click	your	remote	system	and
select	View	Error	Log.



Transferring	User	Files
Complete	the	following	steps	to	transfer	files	to	or	from	your	remote
system.

1.	 In	Remote	Systems,	right-click	your	target.
2.	 Select	File	Transfer	to	launch	the	File	Transfer	Utility.
3.	 Enter	your	Username	and	Password,	or	check	Anonymous

Login	if	your	system	is	not	password-protected,	and	click	OK.
Note		This	feature	may	not	be	available	on	some	targets.



Windows	Firewall
If	you	are	using	the	Windows	Firewall,	you	may	notice	the	following
behaviors	in	MAX:

Microsoft	Windows	XP	with	Service	Pack	1	(SP1)	installed	If
the	Microsoft	Windows	XP	Internet	Connection	Firewall	(ICF)	is
enabled,	you	cannot	discover	or	install	software	to	LabVIEW	Real-
Time	targets	unless	you	disable	the	ICF	before	browsing	to	these
devices.	Perform	the	following	steps	to	disable	the	Internet
Connection	Firewall:

1.	 From	your	desktop,	open	Network	Connections	by	selecting
Start»Control	Panel»Network	Connections.

2.	 Double-click	the	connection	you	want	to	modify.
3.	 Click	Properties.
4.	 On	the	Advanced	tab,	clear	the	Protect	my	computer	and

network	by	limiting	or	preventing	access	to	this
computer	from	the	Internet	checkbox.

Microsoft	Windows	XP	with	Service	Pack	2	(SP2)	or	later
installed,	or
Microsoft	Windows	Vista	
When	you	update	software	on	a	LabVIEW	Real-Time	target	while
the	Windows	Firewall	is	enabled,	a	dialog	box	may	prompt	you	to
allow	MAX	to	receive	information	over	the	network.	Select
Unblock	this	program	so	that	MAX	can	communicate	with	your
LabVIEW	Real-Time	target.

For	more	information	on	MAX	and	the	ICF	in	Windows	XP	SP1,	refer	to
the	NI	KnowledgeBase	document	2WTAMTPK.	For	more	information	on
Microsoft	Windows	XP	SP2	and	NI	products,	go	to	ni.com/info	and	enter
winxpsp2.	For	more	information	on	Microsoft	Windows	Vista	and	NI
products,	refer	to	ni.com/vista.

Note		You	must	be	logged	in	with	Administrator	privileges	to
enable	or	disable	the	ICF	or	Windows	Firewall.
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Device	Configuration
You	must	configure	any	National	Instruments	Real-Time-compatible
device	before	you	can	access	it	from	a	LabVIEW	Real-Time	Module
application	targeted	to	the	remote	system.
For	more	information	about	using	your	NI	products	in	MAX,	refer	to	your
product-specific	help,	located	on	the	Help»Help	Topics	menu	item.	You
can	also	access	NI	product	help	from	within	MAX	help,	which	you	can
launch	from	the	Help	menu	or	by	pressing	<F1>.	For	additional
information,	refer	to	the	documentation	you	received	with	your	device.

Note		For	help	configuring	Traditional	NI-DAQ	(Legacy)	modules,
refer	to	Traditional	NI-DAQ	(Legacy)	Module	Configuration.
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Traditional	NI-DAQ	(Legacy)	Module
Configuration
You	must	configure	any	National	Instruments	PXI	Traditional	NI-DAQ
(Legacy)	devices	before	you	can	access	them	from	a	LabVIEW	Real-
Time	Module	application	targeted	to	the	remote	system.	Complete	the
following	steps	to	configure	your	data	acquisition	modules:

1.	 Configure	your	RT	series	PXI	controller.	Refer	to	Configuring
Network	Settings	for	more	information.

2.	 Delete	the	C:\ni-rt\system\niconfig.daq	file	on	the	target.	This	file
contains	all	the	Traditional	NI-DAQ	(Legacy)	configuration
information.	The	system	rebuilds	it	when	you	restart	the	controller.
For	information	on	accessing	files	on	target	machines,	refer	to
Transferring	User	Files.

3.	 Restart	the	controller.
4.	 Test	the	DAQ	module.	If	you	are	using	SCXI,	you	must	place	this

DAQ	module	in	the	last	slot	of	the	PXI	chassis	(slot	8	for	the	PXI-
1010,	slot	4	for	the	PXI-1011).	To	test	the	device,	you	must	know
the	device	number:

a.	 In	MAX,	select	Tools»Traditional	NI-DAQ	(Legacy)
Configuration»Remote	DAQ	Configuration.	Enter	the	IP
address	for	your	remote	system	and	click	OK.

b.	 In	the	Remote	DAQ	Configuration	Window,	expand	the	list
of	Traditional	NI-DAQ	(Legacy)	devices	in	your	chassis.
The	DAQ	modules	and	their	device	numbers	appear.

c.	 To	test	the	DAQ	module,	refer	to	Using	RDA	to	test	Your
DAQ	Module.	You	can	also	download	and	run	a	VI	from
LabVIEW	Real-Time	that	uses	the	device.	For	E	Series
DAQ	devices,	you	can	download	and	run	a	self-diagnostic
VI.

5.	 To	configure	Traditional	NI-DAQ	(Legacy)	and	SCXI,	you	need	to
use	Remote	DAQ	Configuration.	In	MAX,	select
Tools»Traditional	NI	DAQ	(Legacy)	Configuration»Remote
DAQ	Configuration.	Enter	the	IP	address	for	your	remote	system
and	click	OK.

a.	 In	the	Remote	DAQ	Configuration	window,	select	SCXI
Chassis	and	click	Add.
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b.	 Select	SCXI	Chassis	and	click	Next.
c.	 Select	your	chassis	and	click	Next.
d.	 Enter	your	Chassis	ID	and	Chassis	Address.	Make	sure

that	the	chassis	ID	and	address	match	the	DIP	switch
settings	on	the	PXI-1010	chassis.	The	PXI-1011	chassis
has	no	dip	switches.

e.	 Check	the	Control	SCXI	with	Internal	Bus	box.	If	this
entry	is	grayed	out,	make	sure	you	have	the	proper
pxisys.ini	file	on	the	RT	Engine	in	C:\ni-rt\system	and	that
you	have	restarted	the	controller	after	replacing	it.	Also
make	sure	there	is	a	DAQ	Module	in	the	last	slot	of	the
chassis	and	that	the	SCXI	section	of	the	chassis	is
powered	on.	Click	Finish.

f.	 Restart	the	controller	to	ensure	that	the	new	niconfig.daq
file	is	loaded.	

If	you	are	using	SCXI,	refer	to	Configuring	SCXI	on	RT
Systems	on	ni.com/support	for	more	information	on
configuring	your	system.	Also	refer	to	the	SCXI
Troubleshooting	Resource	on	ni.com/support	for	rules	on
configuring	SCXI	systems.

6.	 To	test	your	SCXI	RT	system:
a.	 Follow	step	4	to	connect	your	controlling	DAQ	devices

through	RDA	and	create	virtual	channels	for	your	SCXI
modules.

b.	 Right-click	a	virtual	channel	in	Data	Neighborhood	and
select	Test.
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Using	RDA	to	Test	Your	Traditional	NI-DAQ
(Legacy)	Module
Perform	the	following	instructions	to	add	a	remote	device	and	test	your
Traditional	NI-DAQ	(Legacy)	Module	using	RDA:

1.	 Right-click	Devices	and	Interfaces»Traditional	NI-DAQ
(Legacy)	Devices,	and	select	Add	Device.

2.	 In	the	Add	Device	window,	select	the	Remote	Device	option,	and
click	Next.

3.	 In	the	Select	Remote	Computer	window,	enter	the	remote
computer	name	or	IP	address	in	the	Remote	Computer	Name/IP
Address	edit	box.	Or,	click	Browse	to	browse	the	network	for	the
computer	name.	Click	Next.

Note		Your	computer	may	not	recognize	a	remote	computer
name	starting	with	numbers	or	using	apostrophes.

4.	 Select	the	device	you	want	to	use	from	the	Remote	Configuration
device	list.	Click	Next.

5.	 Select	the	local	device	number	you	want	to	use.
6.	 Click	Finish.

Note		RT	Series	plug-in	devices	currently	do	not	support
NI-DAQ	Remote	Device	Access.

7.	 Your	device	should	now	appear	under	Devices	and	Interfaces.
Right-click	and	select	Properties	to	test	resources	or	run	test
panels	on	the	device.

8.	 Create	virtual	channels	for	your	RT	devices	in	the	same	manner
you	would	for	local	devices.	For	more	information	on	creating
virtual	channels,	refer	to	Creating	Virtual	Channels	in	the
Measurement	&	Automation	Explorer	Help	for	Traditional	NI-DAQ.
You	can	find	the	help	file	in	the	MAX	help	menu,	Help»Help
Topics»Traditional	NI-DAQ.


	MAX Remote Systems Help
	Related Documentation
	LabVIEW Real-Time Target Configuration
	LabVIEW Real-Time Target Configuration Tutorial
	Connecting to LabVIEW Real-Time Targets
	System States
	Booting Into the LabVIEW Real-Time Module
	RT Disk Utilities
	Desktop PC Utility USB Drive
	PXI Format Hard Drive Disk
	PXI Boot Disk
	PXI Safe Mode Disk
	Desktop PC Format Hard Drive Disk
	Desktop PC Boot Disk
	Desktop PC Safe Mode Disk
	Launch Settings Reset Disk
	IP Reset Disk
	Uninstall Disk

	Making Network and Non-Network Connections
	Using MAX to Detect Remote Systems
	Configuring Network Settings
	IP Configuration
	Assigning an IP Address
	Specifying a Static IP Address
	IP Settings Information
	Halting the System if TCP/IP Fails
	Advanced Ethernet Settings
	Change IP (Offline)


	Configuring System Settings
	Adding or Removing Software
	Using the LabVIEW Real-Time Software Wizard
	Installing a Recommended Software Set
	Installing a Custom Software Selection


	Locking System Configuration
	Viewing Error Logs
	Transferring User Files
	Windows Firewall
	Device Configuration
	Traditional NI-DAQ (Legacy) Module Configuration
	Using RDA to Test Your Traditional NI-DAQ (Legacy) Module





