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Conventions
This	help	file	uses	the	following	conventions:
» The	»	symbol	leads	you	through	nested	menu	items	and	dialog	box	options	to	a	final	action.	The

sequence	File»Page	Setup»Options	directs	you	to	pull	down	the	File	menu,	select	the	Page	Setup
item,	and	select	Options	from	the	last	dialog	box.

bold Bold	text	denotes	items	that	you	must	select	or	click	in	the	software,	such	as	menu	items	and	dialog
box	options.	Bold	text	also	denotes	parameter	names,	emphasis,	or	an	introduction	to	a	key	concept.

green Underlined	text	in	this	color	denotes	a	link	to	a	help	topic,	help	file,	or	Web	address.

italic Italic	text	denotes	variables	or	cross	references.	This	font	also	denotes	text	that	is	a	placeholder	for	a
word	or	value	that	you	must	supply.

monospace Text	in	this	font	denotes	text	or	characters	that	you	should	enter	from	the	keyboard,	sections	of	code,
programming	examples,	and	syntax	examples.	This	font	is	also	used	for	the	proper	names	of	disk
drives,	paths,	directories,	programs,	subprograms,	subroutines,	device	names,	functions,	operations,
variables,	filenames	and	extensions,	and	code	excerpts.



Glossary
Symbol Prefix Value

n nano 10	-9

µ micro 10	-6

m milli 10	-3

ASCII American	Standard	Code	for	Information	Interchange

DIO digital	input/output

EOI end	or	identify

EOS End-of-String

FIFO first-in-first-out

GPIB General	Purpose	Interface	Bus

hex hexadecimal

HS488 high-speed	IEEE	488	transfers

IEEE Institute	of	Electrical	and	Electronic	Engineers

LED light-emitting	diode

m meters

s seconds



GPIB	Analyzer	Overview
The	GPIB	analyzer	is	an	application	that	you	can	use	for	testing,	debugging,	and
analysis.	It	can	monitor,	capture,	and	participate	in	bus	activity	on	the	GPIB.	You
can	use	the	GPIB	analyzer	to	test	and	debug	your	own	applications	by
monitoring	and	capturing	GPIB	activity	while	your	application	is	running.	The
analyzer	also	has	tools	to	help	you	analyze	the	data	that	you	capture.	Analyzing
this	data	can	help	you	solve	many	of	the	difficulties	associated	with	GPIB
communication,	such	as	addressing	inconsistencies,	protocol	violations,	and
simple	bus	timeout	conditions.
The	GPIB	Analyzer	User	Manual	includes	a	tutorial	chapter	and	a	chapter
containing	examples	to	show	you	how	you	might	use	the	analyzer.	The	user
manual	is	available	on	your	NI-488.2	for	Windows	CD.	To	view	this	document
online,	insert	your	NI-488.2	for	Windows	CD.	When	the	NI-488.2	for	Windows
screen	appears,	select	the	Getting	Started	Documentation	option.	The	Getting
Started	Documentation	utility	helps	you	find	the	documentation	you	want	to
view.
For	detailed	information	about	using	the	GPIB	analyzer,	see	GPIB	Analyzer
Features.
See	also:
Capturing	Data	with	the	GPIB	Analyzer
Analyzing	Captured	Data	with	the	GPIB	Analyzer
Exiting	the	GPIB	Analyzer



Capturing	Data	with	the	GPIB	Analyzer
The	analyzer	can	capture	and	display	data,	including	any	combination	of	the
following	GPIB	events:	data	transfers,	command	transfers,	control	line
transitions,	handshake	line	transitions,	and	parallel	poll	responses.	You	can
participate	in	handshaking	or	do	a	nonintrusive	capture.
You	might	want	to	capture	and	display	data	based	on	a	specific	bus	event
without	knowing	when	the	event	might	occur.	In	this	case,	you	can	specify	a
trigger	condition	and	capture	any	number	of	events	before	and	after	the	trigger
condition	occurs.	The	capture	operation	proceeds	according	to	the	settings
configuration.
The	analyzer	can	perform	the	acceptor	handshake	while	capturing,	and	it	can
timestamp	captured	events.	The	number	of	recorded	capture	events	can	be
configured	to	be	between	10	and	99999999	and	is	limited	by	the	memory
available	on	your	computer.
Note	the	following	capabilities	concerning	captures:

You	can	switch	back	and	forth	between	Capture	and	Capture	&	Trigger
during	the	capture	without	losing	data.
The	GPIB	analyzer	timer	resolution	is	50	ns,	so	the	fastest	rate	of
capturing	GPIB	events	possible	is	one	GPIB	event	every	50	ns.
Multiple	capture	displays	can	be	viewed	simultaneously.



Analyzing	Captured	Data	with	the	GPIB	Analyzer
The	GPIB	analyzer	provides	several	features	to	help	you	analyze	data	that	you
have	captured:

Use	markers	for	highlighting	and	examining	specific	transactions	in	the
captured	data,	and	for	determining	elapsed	time	between	captured	events.
Use	the	flexible	pattern-search	utility	to	locate	specific	bus	patterns.
Store	captured	data	to	disk	for	later	review	in	the	capture	display.
Print	captured	data	to	a	selected	printer.

You	can	reload	previously	saved	capture	events	for	later	review	and	analysis.
You	can	even	have	multiple	capture	displays	open,	so	that	you	can	analyze
current	bus	activity	in	one	display	and	the	previously	captured	data	in	another
display.



Exiting	the	GPIB	Analyzer
Choose	File»Exit	to	close	the	GPIB	analyzer	application.	The	analyzer	prompts
you	to	save	any	capture	display	that	contains	unsaved	GPIB	events.	The	current
settings	for	capturing	and	triggering	are	saved	automatically,	and	they	are
automatically	loaded	the	next	time	you	start	the	GPIB	analyzer	application.



GPIB	Analyzer	Features
The	GPIB	analyzer,	created	with	the	National	Instruments	LabWindows/CVI
development	environment,	has	several	major	features.
Settings	configuration—Allows	configuration	of	capture	and	trigger	settings.
Action	window—Starts	and	stops	capturing	and/or	triggering.
Bus	Monitor	window—Displays	and	allows	you	to	modify	the	state	of	each	of
the	GPIB	data	and	control	lines.
Capture	Display	window—Displays	captured	GPIB	events.
Search	capability—Allows	searches	within	a	capture	display.
The	main	GPIB	analyzer	window	is	shown	below.	The	Action	and	Bus	Monitor
windows	are	always	open.
Click	areas	of	the	picture	to	see	detailed	information	about	each	menu,	button,
and	option	available	in	the	main	window.



Settings	Configuration
Capture	and	trigger	settings	can	be	configured	by	selecting	Change	Settings...
from	the	Settings	menu.	The	following	picture	shows	the	Settings	configuration
dialog	box.
Click	areas	of	the	picture	to	see	detailed	information	about	each	menu,	button,
and	option	available	in	the	Settings	dialog	box.

The	configured	settings	apply	only	to	active	capture	displays.	Note	that	the
settings	in	this	window	cannot	be	changed	unless	capturing	and	triggering	are
turned	off	(use	the	Action	window	to	turn	off	capturing	and	triggering).
See	also:
Configure	Capture	Settings
Configure	Trigger	Settings



Action	Window
The	Action	window	contains	controls	you	can	use	to	turn	capturing	and/or
triggering	on	and	off.	When	the	GPIB	analyzer	application	is	started,	capture	and
trigger	are	both	off.
The	Action	window,	shown	below,	is	always	open.	If	the	window	is	hidden,	use
Windows»Action	Window	to	bring	it	to	the	front.
Click	areas	of	the	picture	to	see	detailed	information	about	the	Action	window.

Note	that	you	can	switch	back	and	forth	between	Capture	and	Capture	&	Trigger
during	the	capture	without	losing	data.



Bus	Monitor	Window
The	Bus	Monitor	window	allows	you	to	monitor	and	control	each	of	the	16
GPIB	data	and	control	lines.	It	also	allows	you	to	accept	GPIB	data,	one	byte	at
a	time.	The	Bus	Monitor	window,	shown	below,	is	always	open.	If	the	Bus
Monitor	window	is	hidden,	use	Windows»Bus	Monitor	to	bring	it	to	the	front.
Click	areas	of	the	picture	below	to	see	detailed	information	about	each	button
and	option	available	in	the	Bus	Monitor	window.



Capture	Display	Window
The	Capture	Display	window	displays	captured	GPIB	events.	You	can	have
more	than	one	capture	display	open	at	one	time,	and	capture	displays	can	be
either	active	or	inactive.	Active	capture	displays	show	GPIB	events	as	they	are
being	captured.	Inactive	capture	displays	show	previously	captured	events,	so
that	they	are	unaffected	by	newly	captured	GPIB	events.
To	open	an	active	Capture	Display	window,	choose	New	Capture	Display	from
the	File	menu	in	the	main	window.	To	open	an	inactive	Capture	Display
window,	choose	Open	Capture	File...	from	the	File	menu	in	the	main	window.
To	switch	between	active	and	inactive	capture	modes,	you	can	click	the	Switch
to	Active	(Inactive)	Display	button	to	toggle	between	the	two	modes.	The
following	picture	shows	an	example	of	an	inactive	Capture	Display	window.
Click	areas	of	the	picture	to	see	detailed	information	about	each	menu,	button,
and	option	available	in	the	Capture	Display	window.



Search	Capability
The	Find...	and	Find	Next	buttons	in	the	capture	display	allow	you	to	search	for
specific	GPIB	data	and	control	line	patterns,	data	strings,	or	trigger	points	in	an
inactive	capture	display.
To	do	a	new	search,	click	the	Find...	button	in	an	inactive	capture	display	to
bring	up	a	Find	dialog	box	similar	to	the	one	shown	in	the	following	picture.	To
repeat	the	search,	click	the	Find	Next	button	in	the	inactive	capture	display.
Click	areas	of	the	picture	below	to	see	detailed	information	about	each	button
and	option	available	in	the	Find	dialog	box.

To	find	a	trigger	point	in	the	Capture	Display	window,	check	the	Find	Trigger
checkbox	and	then	click	the	Find	button.
To	find	a	particular	data	and	control	line	pattern,	set	the	pattern	of	the	data	lines
using	either	the	ASCII	or	Hex	edit	controls	or	the	D8	to	D1	spin	controls	(for
binary	values),	and	set	the	pattern	of	the	control	lines	using	the	EOI,	ATN,
SRQ,	REN,	IFC,	NRFD,	NDAC,	and	DAV	spin	controls.	Notice	that	the	spin
controls	allow	you	to	select	0	(unasserted),	1	(asserted),	or	x	(don't	care)	for	each
data	and	control	line.	When	the	data	and	control	lines	have	been	selected,	click
the	Find	button.



To	find	a	series	of	GPIB	data	and	control	line	patterns,	use	the	Insert	Above,
Insert	Below,	and	Delete	buttons	to	add	and	remove	entries	from	the	Find
String	list	box	until	it	contains	the	desired	series	of	GPIB	data	and	control	line
patterns.	Click	the	Find	button	to	conduct	the	search.



Exiting	the	GPIB	Analyzer
Choose	File»Exit	to	close	the	GPIB	analyzer	application.	The	analyzer	prompts
you	to	save	any	capture	display	that	contains	unsaved	GPIB	events.	The	current
settings	for	capturing	and	triggering	are	saved	automatically,	and	they	are
automatically	loaded	the	next	time	you	start	the	GPIB	analyzer	application.



View/Change	the	State	of	GPIB	Data	and	Control
Lines
You	can	view	or	change	the	state	of	the	GPIB	data	and	control	lines	from	within
the	Bus	Monitor	window.
The	state	of	the	GPIB	data	and	control	lines	is	displayed	on	the	row	of	LEDs	and
the	upper	ASCII	and	Hex	edit	controls.	You	can	alter	the	value	of	the	GPIB	data
and	control	lines	using	the	row	of	binary	switches	and	the	lower	ASCII	and	Hex
edit	controls.
You	can	enter	the	GPIB	data	value	as	an	ASCII	value	in	the	ASCII	edit	control,
a	hexadecimal	value	in	the	Hex	edit	control,	or	a	binary	value	in	the	8	to	1
binary	switches.	Note	that	the	GPIB	data	value	is	replicated	in	all	three
representations:	ASCII,	hexadecimal,	and	binary.
You	can	enter	the	GPIB	control	value	using	the	EOI,	ATN,	SRQ,	REN,	IFC,
NRFD,	NDAC,	and	DAV	binary	switches.	The	up	position	corresponds	to	the
assertion	of	the	line.
To	accept	a	byte	of	data	on	the	bus,	use	the	NRFD	and	NDAC	binary	switches
to	simulate	the	IEEE	488	handshake,	or	use	the	Accept	Byte	button,	which
automatically	toggles	NRFD	and	NDAC	in	the	correct	sequence.	The	Accept
Byte	button	is	enabled	by	clicking	the	Enable	Accept	Byte	button.
If	you	are	using	the	Bus	Monitor	to	assert	GPIB	lines,	do	not	use	the	NI-488.2
ibfind	or	ibdev	functions.	These	functions	will	unassert	the	lines	on	the	bus,	even
though	the	switches	in	the	Bus	Monitor	window	show	that	the	lines	are	asserted.
If	you	encounter	this	problem,	click	the	Unassert	Lines	button	and	avoid	using
the	ibfind	or	ibdev	functions.



Accept	a	Single	Byte
To	accept	a	single	byte	of	data	on	the	GPIB,	first	click	the	Enable	Accept	Byte
button	in	the	Bus	Monitor	window.	Then	click	the	Accept	Byte	button	in	the
Bus	Monitor	window.	This	action	automatically	toggles	the	NRFD	and	NDAC
lines	in	the	correct	IEEE	488	handshaking	sequence	to	accept	a	single	byte.	If
you	disable	the	Accept	Byte	feature,	you	can	control	the	NRFD	and	NDAC	lines
manually	using	the	binary	switches	in	the	Bus	Monitor	window.
If	you	try	to	accept	a	byte	when	no	GPIB	device	is	currently	trying	to	source	a
byte	(DAV	unasserted),	toggling	the	handshake	lines	or	clicking	Accept	Byte
has	no	effect.



Start	and	Stop	Capture	of	Data
To	begin	capturing	data,	complete	the	following	steps:

1.	 Configure	the	capture	settings	and	trigger	conditions	using
Settings»Change	Settings....

2.	 If	an	active	display	is	not	already	open,	open	a	new	Capture	Display
window	using	File»New	Capture	Display.

3.	 Bring	the	Action	window	to	the	front	using	Windows»Action	Window.
4.	 Click	the	Capture	or	Capture	&	Trigger	button	in	the	Action	window

to	begin	capturing	data.
To	stop	capturing	new	data,	click	the	Off	button	in	the	Action	window.



View	Previously	Captured	Data
To	open	a	Capture	Display	window	to	view	previously	saved	GPIB	events,
choose	File»Open	Capture	File....



Configure	Capture	Settings
Complete	the	following	steps	to	configure	the	capture	settings:

1.	 Click	the	Off	button	in	the	Action	window.	(Selecting	Windows»Action
Window	brings	the	Action	window	to	the	front.)

2.	 Open	the	Settings	dialog	box	by	choosing	Settings»Change	Settings....
3.	 Configure	the	capture	settings.	Refer	to	the	Settings	Configuration

section	for	details	on	all	the	capture	settings	you	can	configure.
4.	 When	you	are	finished	making	changes,	click	OK	in	the	Settings	dialog

box.
You	can	save	your	capture	settings	by	choosing	Settings»Save	Settings	As...
and	reload	them	by	choosing	Settings»Load	Settings....



Configure	Trigger	Settings
Complete	the	following	steps	to	configure	the	trigger	settings	for	your	capture:

1.	 Click	the	Off	button	in	the	Action	window.	(Selecting	Windows»Action
Window	brings	the	Action	window	to	the	front.)

2.	 Open	the	Settings	dialog	box	by	choosing	Settings»Change	Settings....
3.	 Configure	the	trigger	settings.	Refer	to	the	picture	in	the	Settings

Configuration	section	for	details	on	all	the	trigger	conditions	you	can
configure.

4.	 When	you	are	finished	making	changes,	click	OK	in	the	Settings	dialog
box.

You	can	save	your	trigger	settings	by	choosing	Settings»Save	Settings	As...	and
reload	them	by	choosing	Settings»Load	Settings....
To	use	the	configured	trigger	settings,	start	capture	using	the	Capture	&
Trigger	button	in	the	Action	window,	instead	of	the	Capture	button.



Timestamp	Capture	Events
Timestamping	shows	you	the	elapsed	time	between	GPIB	events	captured	by	the
GPIB	analyzer.	The	timestamp	information	appears	in	the	timestamp	column	of
the	capture	display.
To	enable	timestamping,	check	the	Enable	Timestamping	checkbox	in	the
Settings	dialog	box.



Do	a	Nonintrusive	Capture
To	prevent	the	GPIB	analyzer	from	participating	in	acceptor	handshaking,
uncheck	the	Participate	in	Acceptor	Handshake	checkbox	in	the	Settings
dialog	box.	If	this	checkbox	is	checked,	the	analyzer	participates	in	all
handshaking	on	the	GPIB.	You	might	want	to	select	this	checkbox	to	slow	down
the	GPIB	transfers	or	to	avoid	overflow	errors.



Avoid	Overflow	Errors
An	overflow	error	occurs	when	the	GPIB	analyzer	FIFO	hardware	buffer	fills	up
with	GPIB	events	faster	than	the	software	can	receive	them.	If	this	happens,	an
error	message	with	asterisks	and	the	word	"OVERFLOW"	appears	in	the	capture
display,	as	shown	in	the	following	figure.

If	an	overflow	error	occurs,	one	or	more	GPIB	events	have	been	lost.	You	can
usually	avoid	overflow	errors	by	making	one	of	the	following	changes:

Check	the	Participate	in	Acceptor	Handshake	checkbox	in	the	Settings
dialog	box	and	set	the	Handshaking	rate	to	Maximum.	This
configuration	causes	the	analyzer	to	hold	off	when	the	FIFO	is	almost
full.	It	prevents	high-speed	GPIB	data	transfers	when	the	FIFO	is	almost
full,	which	can	be	a	common	cause	of	overflow	errors.
Uncheck	the	Handshake	Line	Transitions	checkbox	in	the	Settings
dialog	box.	If	this	option	is	selected,	you	might	capture	up	to	six	times	as
many	GPIB	events	as	when	choosing	to	capture	only	data	and	command
transfers.	The	reason	for	this	is	that	when	you	enable	the	capture	of
handshake	line	transitions,	you	start	getting	GPIB	events	such	as	NDAC



and	NRFD ,	which	reflect	the	multiple	changes	that	occur	to	the	states	of
the	GPIB	handshake	lines	for	each	byte	transferred	on	the	GPIB.	This
high	volume	of	events	is	likely	to	cause	overflow	errors.
Uncheck	the	Enable	Timestamping	checkbox	in	the	Settings	dialog	box.
If	you	do	not	need	to	see	the	timestamping	information,	disabling	this
option	can	reduce	the	amount	of	data	transferred	from	the	FIFO	and
reduce	the	possibility	for	overflow	errors.
Uncheck	the	Control	Line	Transitions	checkbox	in	the	Settings	dialog
box.	Some	GPIB	devices	may	toggle	the	control	lines	incorrectly,	and
overflow	errors	could	result.
Close	all	active	capture	displays	while	capturing.	The	analyzer	captures
GPIB	events	more	efficiently	if	they	do	not	need	to	be	displayed
immediately.
Increase	the	Retain	up	to	_____	capture	events	value	in	the	Settings
dialog	box.	This	field	specifies	the	maximum	number	of	capture	events
retained	in	the	capture	buffer.



Save	and	Reload	Capture/Trigger	Settings
The	analyzer	uses	the	current	capture	and	trigger	settings	until	you	change	them
again	and	automatically	saves	them	when	you	exit	the	analyzer	program.	If	you
want	to	save	the	current	settings	for	later	use,	use	Settings»Save	Settings	As....
Whenever	possible,	use	the	.SET	extension	for	analyzer	settings	filenames.
To	load	a	file	of	previously	saved	settings,	use	Settings»Load	Settings....



View	the	Captured	Data
You	can	view	the	captured	GPIB	events	in	either	detailed	display	mode	or
summarized	display	mode.	With	detailed	display	mode,	captured	GPIB	events
are	shown	one	per	line.	In	summarized	display	mode,	multiple	events	are
combined	on	single	lines.	Line	transitions	are	displayed	on	separate	lines,	but
data	and	command	transfers	are	grouped	on	the	same	line.	In	either	display
mode,	lines	are	color	coded	based	on	the	type	of	event	captured.	The	following
table	shows	the	color	coding	scheme.
Color	Coding	in	the	Capture	Display
Type	of	Event Color

Data	transfers Blue

Command	transfers Green

Control	line	transitions Black

Handshake	line	transitions Black

Parallel	poll	responses Black

Trigger	event Dotted	box

Overflow White

Read	the	Timestamp	Column
Read	the	Mnemonics	Column



Read	the	Timestamp	Column
In	detailed	mode,	where	each	line	represents	a	single	capture	event,	the
timestamp	value	represents	the	time	elapsed	between	the	event	on	that	line	and
the	event	on	the	previous	line.	So,	if	you	want	to	determine	the	time	elapsed
between	the	capture	of	the	first	event	and	the	fifth	event,	add	up	the	timestamp
values	on	the	second,	third,	fourth,	and	fifth	lines.	Alternately,	you	can	switch	to
an	inactive	display	using	the	Switch	to	Inactive	Display	button	and	put	markers
on	the	first	and	last	event	of	interest,	then	use	the	From	and	To	fields	in	the
Markers	&	Statistics	group	box	to	have	the	GPIB	analyzer	calculate	a	Time
elapsed	value	for	you.
In	summarized	mode,	where	more	than	one	event	can	be	present	on	a	line,	the
timestamp	value	represents	the	time	elapsed	between	the	first	event	on	that	line
and	the	first	event	on	the	previous	line.
The	timestamp	column	in	the	capture	display	shows	the	timestamp	in	a	minute,
second,	millisecond,	microsecond,	and	nanosecond	notation.	If	the	timestamp
exceeds	60	minutes,	the	timestamp	is	shown	in	an	hour,	minute,	and	second
notation.	The	abbreviations	used	for	the	various	time	scales	are	listed	in	the
following	table.	The	smallest	recordable	timestamp	is	50	ns.
Timestamp	Abbreviations	in	the	Capture	Display	Window
Time	Unit Abbreviation

Nanoseconds ns

Microseconds µs

Milliseconds ms

Seconds s

Minutes mi

Hours hr



Read	the	Mnemonics	Column
Various	mnemonics	appear	in	the	right	column	of	the	capture	display	to	provide
a	quick	interpretation	of	the	captured	GPIB	events.	The	column	may	also	show
line	transitions.	If	the	line	name	is	followed	by	an	up	arrow	( ),	the	line
transitioned	from	unasserted	to	asserted.	If	the	line	name	is	followed	by	a	down
arrow	( ),	the	line	transitioned	from	asserted	to	unasserted.	Note	that	if	the
analyzer	is	capturing	handshake	line	transitions,	the	assertion	of	DAV	represents
a	GPIB	data	byte	or	command	byte.	For	a	detailed	list	of	the	mnemonics	and
their	meanings,	refer	to	Capture	Display	Mnemonics.



Print	and	Save
To	print	the	contents	of	an	inactive	Capture	Display	window,	use	File»Print....
You	can	print	the	entire	capture	display	or	limit	the	printing	to	captured	events
between	particular	markers.
Both	inactive	and	active	(if	capturing	is	turned	off)	capture	displays	can	be	saved
to	a	file.	To	save	the	data	in	a	Capture	Display	window,	use	File»Save	As....
Whenever	possible,	use	the	.CAP	extension	for	saving	capture	display	files.
Captured	data	is	saved	in	an	analyzer-specific	format	and	can	be	reopened	as	an
inactive	capture	display.
You	can	also	export	an	inactive	capture	display	as	an	ASCII	text	file	to	another
application,	such	as	a	word	processor.	Use	File»Export...	to	export	the	captured
data.	You	can	export	captured	data	as	text	in	both	detailed	and	summarized
formats.	You	cannot	import	the	ASCII	text	file	back	into	the	GPIB	analyzer.



Search	for	a	Capture	Event
To	search	for	a	specific	GPIB	event	within	a	capture	display	from	the	current
cursor	location,	complete	the	following	steps:

1.	 Switch	to	an	inactive	Capture	Display	window.
2.	 Click	the	Find...	button.
3.	 Enter	your	search	criteria	in	the	Find	dialog	box.

To	find	a	trigger	point	in	the	Capture	Display	window,	check	the	Find
Trigger	checkbox.
To	find	a	particular	data	and	control	line	pattern,	set	the	pattern	of	the
data	lines	using	either	the	ASCII	or	Hex	edit	controls	or	the	D8	to	D1
spin	controls	(for	binary	values),	and	set	the	pattern	of	the	control	lines
using	the	EOI,	ATN,	SRQ,	REN,	IFC,	NRFD,	NDAC,	and	DAV	spin
controls.	Notice	that	the	spin	controls	allow	you	to	select	0	(unasserted),
1	(asserted),	or	x	(don't	care)	for	each	data	and	control	line.
To	find	a	series	of	GPIB	data	and	control	line	patterns,	use	the	Insert
Above,	Insert	Below,	and	Delete	buttons	to	add	and	remove	entries
from	the	Find	String	list	box	until	it	contains	the	desired	series	of	GPIB
data	and	control	line	patterns.
Use	the	Search	Direction	switch	to	specify	the	direction	to	search	from
the	current	cursor	position	in	the	capture	display.

4.	 Click	the	Find	button	in	the	Find	dialog	box.	This	action	automatically
closes	the	Find	dialog	box	and	takes	you	from	the	current	cursor
position	to	the	first	GPIB	event	in	the	capture	display	that	matches	your
search	criteria.

To	find	the	next	occurrence,	click	the	Find	Next	button.



Mark	Capture	Events	to	Show	Statistics
Markers	are	allowed	only	in	inactive	capture	displays.	All	inactive	capture
displays	contain	at	least	two	markers:	Begin	and	End.	Single-clicking	places	the
cursor	in	a	capture	display.	Double-clicking	places	markers	in	a	capture	display
and	removes	placed	markers.	Markers	are	labeled	M0,	M1,	M2,	and	so	on,	as
they	are	created.
After	you	have	placed	your	markers,	you	can	use	the	From	and	To	controls	in
the	Markers	&	Statistics	group	box	to	examine	statistics	about	the	captured
data.
If	you	are	using	summarized	display	mode,	you	might	have	more	than	one
marker	for	each	line.	In	this	case,	the	letter	M	appears	in	the	marker	column.	You
can	click	the	M	several	times	to	see	each	marker	for	that	line.



Common	Questions
Why	can't	I	use	the	analyzer	to	monitor	a	GPIB	application	which	uses	the
NI-488.2	ibln	or	FindLstn	command?
You	can	use	the	analyzer	to	monitor	an	application	with	these	commands,	but
you	cannot	select	Participate	in	Acceptor	Handshaking	in	the	Settings	dialog
box	of	the	analyzer.	Selecting	this	feature	asserts/unasserts	the	NDAC	and
NRFD	lines	in	response	to	the	Talker's	assertion/unassertion	of	DAV	in	the	GPIB
handshake	sequence.	Therefore,	when	you	run	an	application	that	executes	a
FindLstn	or	ibln	command,	all	possible	GPIB	addresses	are	returned.
How	does	selecting	"Participate	in	Acceptor	Handshake"	in	the	Settings
dialog	box	affect	the	GPIB?
When	Participate	in	Acceptor	Handshake	is	selected,	the	analyzer	circuitry
behaves	like	a	GPIB	Listener	for	the	duration	of	the	capture	and	participates	in
acceptor	handshaking	on	the	GPIB.	You	can	use	this	feature	to	slow	down	GPIB
transfers	to	a	particular	rate	and	to	avoid	overflow	errors.
How	do	I	choose	a	handshake	rate?	What	does	"Maximum"	mean?
You	can	use	the	handshake	rate	to	slow	down	the	transfer	rate	on	the	GPIB	while
debugging	timing-related	problems.	Choosing	a	particular	handshake	rate
guarantees	that	the	transfer	rate	on	the	bus	will	be	less	than	or	equal	to	that	rate.
Choosing	the	Maximum	rate	causes	the	analyzer	to	respond	as	a	Listener	as	fast
as	it	can	without	causing	overflow	errors.
How	do	I	define	a	trigger	point	to	capture	a	command	byte	such	as	TA0?
In	the	Settings	dialog	box,	set	the	data	lines	of	the	trigger	condition	by	entering
either	the	ASCII	or	hex	equivalent	of	TA0	or	set	each	of	the	data	lines
independently	to	represent	TA0.	Set	the	ATN,	DAV,	and	NDAC	lines	to	1.	Set
NRFD	to	0.	The	remainder	of	the	control	lines	should	be	set	to	x.	This	state	of
the	handshake	lines	is	necessary	to	guarantee	that	valid	data	is	present	on	the
data	lines.
What	do	the	rows	of	lights	and	switches	in	the	Bus	Monitor	window
represent?
The	LEDs	represent	the	state	of	the	bus	lines	at	all	times.	The	toggle	switches
represent	the	assertion	of	lines	from	within	the	Bus	Monitor	window	of	the
analyzer.	So,	if	the	LED	for	a	particular	line	is	on,	and	the	switch	for	that	line	is



off	(down	position),	the	line	is	asserted,	but	not	by	the	Bus	Monitor.
What	is	the	difference	between	active	and	inactive	capture	displays?
Active	capture	displays	show	GPIB	events	as	they	are	being	captured.	In	other
words,	active	capture	displays	are	windows	into	the	single	capture	buffer	used	to
store	new	GPIB	events.	Inactive	capture	displays	show	previously	captured
GPIB	events	statically,	so	that	they	are	unaffected	by	newly	captured	GPIB
events.	You	must	make	the	capture	display	inactive	if	you	want	to	use	the	search
or	print	features.
What	do	the	"Capture	Settings"	in	the	Capture	Display	window	mean?
The	Capture	Settings	section	of	the	Capture	Display	window	shows	the	capture
settings	that	were	used	when	the	data	in	the	window	was	captured.	They	help
you	interpret	the	captured	data	in	the	Capture	Display	window.	They	are	not
necessarily	the	same	as	the	current	capture	settings.
How	do	I	use	the	timestamping	information	in	detailed	display	mode	and
summarized	display	mode?
In	detailed	display	mode,	where	each	line	can	correspond	to	only	one	capture
event,	the	timestamp	value	represents	the	time	elapsed	between	the	event	on	that
line	and	the	previous	event.	So,	if	you	want	to	determine	the	time	elapsed
between	the	capture	of	the	first	event	and	the	fifth	event,	add	up	the	timestamp
values	on	the	second,	third,	fourth,	and	fifth	lines.
In	summarized	display	mode,	where	more	than	one	event	can	be	present	on	a
line,	the	timestamp	value	represents	the	time	elapsed	between	the	first	event	on
that	line	and	the	first	event	on	the	previous	line.
How	can	I	prevent	overflow	errors?
For	detailed	information	about	avoiding	overflow	errors,	refer	to	the	Avoid
Overflow	Errors	section.



GPIB	Basics
The	ANSI/IEEE	Standard	488.1-1987,	also	known	as	GPIB	(General	Purpose
Interface	Bus),	describes	a	standard	interface	for	communication	between
instruments	and	controllers	from	various	vendors.	It	contains	information	about
electrical,	mechanical,	and	functional	specifications.	The	GPIB	is	a	digital,	8-bit
parallel	communications	interface	with	data	transfer	rates	of	1	Mbytes/s	and
above.	The	bus	supports	one	System	Controller,	usually	a	computer,	and	up	to	14
additional	instruments.	The	ANSI/IEEE	Standard	488.2-1987	extends	IEEE
488.1	by	defining	a	bus	communication	protocol,	a	common	set	of	data	codes
and	formats,	and	a	generic	set	of	common	device	commands.
Talkers,	Listeners,	and	Controllers
Controller-in-Charge	and	System	Controller
GPIB	Addressing
Data	and	Command	Messages
Handshaking
Managing	and	Controlling	the	GPIB
Setting	Up	and	Configuring	Your	System
Serial	Polling
Parallel	Polling
HS488	Transfers
Terminating	Data	Transmissions
GPIB	Commands



Talkers,	Listeners,	and	Controllers
GPIB	devices	can	be	Talkers,	Listeners,	or	Controllers.	A	Talker	sends	out	data
messages.	Listeners	receive	data	messages.	The	Controller,	usually	a	computer,
manages	the	flow	of	information	on	the	bus.	It	defines	the	communication	links
and	sends	GPIB	commands	to	devices.
Some	devices	are	capable	of	playing	more	than	one	role.	A	digital	voltmeter,	for
example,	can	be	a	Talker	and	a	Listener.	If	your	personal	computer	has	a
National	Instruments	GPIB	interface	board	and	the	NI-488.2	software	installed,
it	can	function	as	a	Talker,	Listener,	and	Controller.



Controller-In-Charge	and	System	Controller
You	can	have	multiple	Controllers	on	the	GPIB,	but	only	one	Controller	at	a
time	can	be	the	active	Controller,	or	Controller-In-Charge	(CIC).	The	CIC	can
either	be	an	active	or	inactive	(Standby)	Controller.	Control	can	pass	from	the
current	CIC	to	an	idle	Controller,	but	only	the	System	Controller,	usually	a	GPIB
interface	board,	can	make	itself	the	CIC.



GPIB	Addressing
All	devices	and	boards	connected	to	the	GPIB	must	be	assigned	a	unique	GPIB
address.	The	Controller	uses	the	addresses	to	identify	each	device	when	sending
or	receiving	data.	A	GPIB	address	is	made	up	of	two	parts:	a	primary	address
and	an	optional	secondary	address.	You	usually	set	the	address	using	switches	on
the	board	or	device.
The	primary	address	is	a	number	in	the	range	0	to	30.	The	GPIB	Controller	uses
the	primary	address	to	form	a	talk	or	listen	address	that	is	sent	over	the	GPIB
when	communicating	with	a	device.
A	talk	address	is	formed	by	setting	bit	6,	the	TA	(Talk	Active)	bit	of	the	GPIB
address.	A	listen	address	is	formed	by	setting	bit	5,	the	LA	(Listen	Active)	bit	of
the	GPIB	address.	For	example,	if	a	device	is	at	address	1,	the	Controller	sends
hex	41	(address	1	with	bit	6	set)	to	make	the	device	a	Talker.	Because	the
Controller	is	usually	at	primary	address	0,	it	sends	hex	20	(address	0	with	bit	5
set)	to	make	itself	a	Listener.	The	following	table	shows	the	configuration	of	the
GPIB	address	bits.

With	some	devices,	you	can	use	secondary	addressing.	A	secondary	address	is	a
number	in	the	range	hex	60	to	hex	7E.	When	secondary	addressing	is	in	use,	the
Controller	sends	the	primary	talk	or	listen	address	of	the	device,	followed	by	the
secondary	address	of	the	device.



Data	and	Command	Messages
Eight	data	lines,	DIO1	through	DIO8,	carry	both	data	messages	and	command
messages.	All	commands	and	most	data	use	the	7-bit	ASCII	or	ISO	code	set,	in
which	case	the	eighth	bit,	DIO8,	is	either	not	used	or	used	for	parity.	Command
messages	are	sent	with	the	ATN	line	asserted;	data	messages	are	sent	with	the
ATN	line	unasserted.



Handshaking
Three	hardware	handshake	lines	asynchronously	control	the	transfer	of	message
bytes	between	devices.	This	process	is	a	three-wire	interlocked	handshake,	and	it
guarantees	that	devices	send	and	receive	message	bytes	on	the	data	lines	without
transmission	errors.
Line Description

NRFD
(not	ready
for	data)

Listening	device	is	ready/not	ready	to	receive	a	data	byte.	This	line	is	driven	by	all	devices	when
receiving	commands,	but	only	by	Listeners	when	receiving	data	messages.	It	is	also	used	by	the
Talker	to	signal	high-speed	transfers	(HS488).

NDAC
(not	data
accepted)

Listening	device	has/has	not	accepted	a	message	byte.	This	line	is	driven	by	all	devices	when
receiving	commands,	but	only	by	Listeners	when	receiving	data	messages.

DAV	(data
valid)

Talking	device	indicates	signals	on	data	lines	are	stable	(valid)	data	and	can	be	accepted	safely	by
devices.	The	Controller	controls	DAV	when	sending	commands	and	the	Talker	controls	DAV	when
sending	data	messages.

The	handshaking	sequence	is	as	follows:
1.	 The	Talker	unasserts	DAV	and	then	monitors	the	NDAC	and	NRFD	lines

that	are	controlled	by	the	Listener.
2.	 The	Talker	places	a	byte	of	data	on	the	DIO	lines.
3.	 The	Talker	waits	for	NRFD	to	be	unasserted	by	the	Listener.
4.	 The	Talker	asserts	DAV.
5.	 The	Listener(s)	immediately	assert(s)	NRFD,	which	acknowledges	to	the

Talker	that	the	current	byte	is	being	processed.
6.	 Listener	accepts	the	current	byte	and	unasserts	NDAC.
7.	 The	Talker	unasserts	DAV.
8.	 The	Listener(s)	assert(s)	NDAC	in	preparation	for	the	next	byte.



Managing	and	Controlling	the	GPIB
Five	GPIB	hardware	lines	manage	the	flow	of	information	across	the	bus.	These
lines	are	referred	to	as	interface	management	lines	or	control	lines.
Line Description

ATN
(attention)

The	Controller-In-Charge	(CIC)	drives	this	line	to	indicate	the	type	of	message	present	on	the	data
lines.	ATN	is	asserted	when	the	message	is	a	command	from	the	CIC;	it	is	unasserted	when	the
message	is	a	data	byte	from	a	Talker.

IFC
(interface
clear)

The	System	Controller	drives	the	IFC	line	to	initialize	the	bus	and	make	itself	CIC.	When	IFC	is
asserted,	all	devices	return	to	a	known,	quiescent	state.

REN
(remote
enable)

The	System	Controller	drives	the	REN	line	to	place	devices	in	remote	or	local	program	mode.

SRQ
(service
request)

Any	device	can	assert	the	SRQ	line	to	asynchronously	request	service	from	the	Controller-In-Charge.
SRQ	remains	asserted	until	the	device	is	serial	polled.	The	CIC	should	monitor	the	SRQ	line,	poll	the
device,	and	determine	the	type	of	service	that	the	device	needs.

EOI	(end
or
identify)

If	a	device	uses	the	EOI	line	to	mark	the	end	of	a	data	message,	it	asserts	EOI	along	with	the	last	byte
of	data.	A	Listener	stops	reading	data	when	EOI	is	asserted.	The	Controller	also	asserts	the	EOI	line
when	it	conducts	a	parallel	poll.



Setting	Up	and	Configuring	Your	System
Devices	are	usually	connected	with	a	cable	assembly	consisting	of	a	shielded	24-
conductor	cable	with	both	a	plug	and	receptacle	connector	at	each	end.	With	this
design,	you	can	link	devices	in	a	linear	configuration,	a	star	configuration,	or	a
combination	of	the	two.	The	following	picture	shows	the	linear	and	star
configurations.



Controlling	More	Than	One	Board
Multiboard	drivers,	such	as	the	NI-488.2	driver	for	Windows,	can	control	more
than	one	interface	board.	The	following	picture	shows	an	example	of	a
multiboard	system	configuration.	gpib0	is	the	access	board	for	the	voltmeter,	and
gpib1	is	the	access	board	for	the	plotter	and	printer.	The	control	functions	of	the
devices	automatically	access	their	respective	boards.



Configuration	Requirements
To	achieve	the	high	data	transfer	rate	that	the	GPIB	was	designed	for,	you	must
limit	the	physical	distance	between	devices	and	the	number	of	devices	on	the
bus.	The	following	restrictions	are	typical:

A	maximum	separation	of	4	m	between	any	two	devices	and	an	average
separation	of	2	m	over	the	entire	bus.
A	maximum	total	cable	length	of	20	m.
A	maximum	of	15	devices	connected	to	each	bus,	with	at	least	two-thirds
powered	on.

For	high-speed	operation,	the	following	restrictions	apply:
All	devices	in	the	system	must	be	powered	on.
Cable	lengths	should	be	as	short	as	possible	up	to	a	maximum	of	15	m	of
cable	in	each	system.
At	least	one	equivalent	device	load	per	meter	of	cable.

If	you	want	to	exceed	these	limitations,	you	can	use	bus	extenders	to	increase	the
cable	length	or	expanders	to	increase	the	number	of	device	loads.	Extenders	and
expanders	are	available	from	National	Instruments.



Serial	Polling
You	can	use	serial	polling	to	obtain	specific	information	from	GPIB	devices
when	they	request	service.	When	the	GPIB	SRQ	line	is	asserted,	it	signals	the
Controller	that	a	service	request	is	pending.	The	Controller	must	then	determine
which	device	asserted	the	SRQ	line	and	respond	accordingly.
IEEE	488	devices	request	service	from	the	GPIB	Controller	by	asserting	the
GPIB	SRQ	line.	When	the	Controller	acknowledges	the	SRQ,	it	serial	polls	each
open	device	on	the	bus	to	determine	which	device	requested	service.	Any	device
requesting	service	returns	a	status	byte	with	bit	6	set	and	then	unasserts	the	SRQ
line.	Devices	not	requesting	service	return	a	status	byte	with	bit	6	cleared.
Manufacturers	of	IEEE	488	devices	use	lower	order	bits	to	communicate	the
reason	for	the	service	request	or	to	summarize	the	state	of	the	device.
In	addition	to	setting	bit	6	when	requesting	service,	IEEE	488.2	devices	also	use
two	other	bits	to	specify	their	status.	Bit	4,	the	Message	Available	bit	(MAV),	is
set	when	the	device	is	ready	to	send	previously	queried	data.	Bit	5,	the	Event
Status	bit	(ESB),	is	set	if	one	or	more	of	the	enabled	IEEE	488.2	events	occurs.
These	events	include	power-on,	user	request,	command	error,	execution	error,
device-dependent	error,	query	error,	request	control,	and	operation	complete.
The	device	can	assert	SRQ	when	ESB	or	MAV	is	set,	or	when	a	manufacturer-
defined	condition	occurs.
Serial	polling	obtains	specific	information	from	a	device.	When	you	serial	poll,
the	Controller	sends	a	special	command	message—Serial	Poll	Enable	(SPE)—to
the	device,	directing	it	to	return	its	serial	poll	status	byte.	The	SPE	message	sets
the	IEEE	488.1	serial	poll	mode	in	the	device,	so	when	the	device	is	addressed	to
talk,	it	returns	a	single	8-bit	status	byte.	This	serial	poll	status	byte	is	different
for	each	type	of	instrument;	except	for	one	bit,	you	must	refer	to	the	instrument
user	manual	for	information	on	the	other	bits.	Bit	6	(hex	40)	of	any	serial	poll
status	byte	indicates	whether	a	device	requested	service	by	asserting	the	SRQ
line.	The	device	uses	the	other	seven	bits	of	the	status	byte	to	specify	why	it
needs	attention.
After	the	Controller	reads	the	status	byte,	it	sends	another	command	message,
Serial	Poll	Disable	(SPD),	to	the	device.	The	SPD	message	terminates	the	serial
poll	mode,	thus	returning	the	device	to	its	normal	Talker/Listener	state.	Once	a
device	requesting	service	is	serial	polled,	it	usually	unasserts	the	SRQ	line.



When	a	serial	poll	is	conducted,	the	following	sequence	of	events	occurs:



Parallel	Polling
Although	parallel	polling	is	not	widely	used,	it	is	a	useful	method	for	obtaining
the	status	of	more	than	one	device	at	the	same	time.	The	advantage	of	a	parallel
poll	is	that	it	can	easily	check	up	to	eight	individual	devices	at	once.	In
comparison,	eight	separate	serial	polls	would	be	required	to	check	eight	devices
for	their	serial	poll	response	bytes.
You	can	implement	parallel	polling	with	either	NI-488	functions	or	NI-488.2
routines.	If	you	use	NI-488.2	routines	to	execute	parallel	polls,	you	do	not	need
extensive	knowledge	of	the	parallel	polling	messages.	However,	you	should	use
the	NI-488	functions	for	parallel	polling	when	the	GPIB	board	is	not	the
Controller	and	must	configure	itself	for	a	parallel	poll	and	set	its	own	individual
status	bit	(ist).
A	parallel	poll	is	an	exchange	of	messages	between	the	Controller	and	other
system	devices.	The	Controller	sends	the	IDY	message	true	to	the	other	devices;
each	device	responds	to	the	IDY	message	by	sending	one	PPR	message	(PPR1,
PPR2,	PPR3,	PPR4,	PPR5,	PPR6,	PPR7,	or	PPR8)	to	the	Controller.	Each
device	usually	sends	a	different	PPR	message.	Each	device	can	send	its	PPR
message	either	true	or	false.	Each	device	examines	its	local	ist	message	and	its
Sense	bit	(S)	to	determine	whether	it	will	send	its	PPR	message	true	or	false.	The
following	table	illustrates	how	the	ist	message	and	the	Sense	bit	affect	the	value
of	the	PPR	message.
ist	message Sense	Bit	(S) PPR	Message	Sent

0	(False) 0 True

0	(False) 1 False

1	(True) 0 False

1	(True) 1 True

The	ist	message	usually	reflects	a	bit	of	status	information	about	the	device.	For
example,	when	the	device	has	taken	a	measurement,	it	can	assert	its	local	ist
message.	The	Sense	bit	is	part	of	the	configuration	of	a	device.	Each	device	has
an	independent	Sense	bit.
The	meaning	of	the	PPR	message	and	the	local	ist	message	is	device	dependent.



Configuring	a	Device	for	Parallel	Polls
To	configure	a	device	to	respond	to	parallel	polls,	you	must	supply	the	device
with	two	pieces	of	data:

The	PPR	message	that	the	device	should	send	to	the	Controller	(PPR1,
PPR2,	.	.	,	or	PPR8).
The	value	of	the	Sense	bit	of	the	device.

You	can	configure	devices	locally	or	remotely.	You	locally	configure	(Parallel
Poll	function	subset	PP2)	a	device	by	setting	knobs	or	switches	on	the	front
panel	of	the	device	(or	by	physically	manipulating	the	device	in	some	other
way).	You	remotely	configure	(Parallel	Poll	function	subset	PP1)	a	device	by
sending	messages	across	the	GPIB	from	the	Controller	to	the	device.



Determining	the	PPE	Message
The	Parallel	Poll	Enable	(PPE)	message	contains	the	parallel	poll	configuration
data	for	a	device.	When	configuring	remotely,	the	PPE	message	is	always
preceded	by	the	Parallel	Poll	Configure	(PPC)	message.	The	following	table
shows	how	you	determine	the	value	of	DIO[7:1]	for	the	PPE	message.	As	with
all	commands,	the	DIO[8]	is	a	"don't	care"	bit.
Sense	Bit	(S) PPR	Message	to	Send PPE	Message	(hex)

0 PPR1 60

0 PPR2 61

0 PPR3 62

0 PPR4 63

0 PPR5 64

0 PPR6 65

0 PPR7 66

0 PPR8 67

1 PPR1 68

1 PPR2 69

1 PPR3 6A

1 PPR4 6B

1 PPR5 6C

1 PPR6 6D

1 PPR7 6E

1 PPR8 6F



HS488	Transfers
National	Instruments	has	designed	a	high-speed	data	transfer	protocol	for	IEEE
488	called	HS488.	This	protocol	increases	performance	for	GPIB	reads	and
writes	up	to	8	Mbytes/s,	depending	on	your	system.
HS488	is	a	superset	of	the	IEEE	488	standard;	thus,	you	can	mix	IEEE	488.1,
IEEE	488.2,	and	HS488	devices	in	the	same	system.	If	HS488	is	enabled,	the
TNT4882C	hardware	implements	high-speed	transfers	automatically	when
communicating	with	HS488	instruments.
The	following	picture	shows	a	typical	IEEE	488.1	data	transfer.	The	HS488
protocol	modifies	the	IEEE	488.1	Source	Handshake	and	Acceptor	Handshake
functions.	At	the	beginning	of	each	data	transfer,	the	HS488	source	and	acceptor
functions	determine	whether	all	active	Talkers	and	Listeners	are	capable	of
HS488	transfers.	If	the	addressed	devices	are	HS488	capable,	they	use	the
HS488	noninterlocked	handshake	protocol	for	that	data	transfer.	If	any	addressed
device	is	not	HS488	capable,	the	transfer	continues	using	the	standard	three-wire
handshake.

The	following	steps	describe	a	typical	sequence	of	events	in	an	HS488	data
transfer	in	which	the	Talker	and	Listener	are	both	HS488	capable.



1.	 The	Controller	addresses	devices	and	becomes	Standby	Controller	by
unasserting	ATN.

2.	 The	Listener	asserts	NDAC	and	NRFD.
3.	 The	Listener	unasserts	NRFD	as	it	becomes	ready	to	accept	a	byte.
4.	 After	allowing	time	for	the	Listener	to	detect	NRFD	unasserted,	the

Talker	indicates	that	it	is	capable	of	HS488	operation	by	sending	the
HSC	message.	To	send	the	HSC	message	true,	the	Talker	asserts	the
NRFD	signal.

5.	 After	allowing	time	for	the	Listener	to	respond	to	the	HSC	message,	the
Talker	sends	the	HSC	message	false.	To	send	the	HSC	message	false,	the
Talker	unasserts	the	NRFD	signal.

6.	 When	the	Talker	has	a	byte	ready	to	send,	it	drives	the	data	on	the	DIO
signal	lines,	allows	some	settling	time,	and	asserts	DAV.

7.	 The	Listener	unasserts	NDAC.	HS488	Listeners	do	not	assert	NRFD	as
IEEE	488.1	devices	would.	Because	of	this	behavior,	the	Talker
determines	that	the	addressed	Listener	is	capable	of	HS488	transfers.

8.	 The	Talker	unasserts	DAV	and	begins	to	drive	the	next	data	byte	on	the
GPIB.

9.	 After	allowing	some	settling	time,	the	Talker	asserts	DAV.
10.	 The	Listener	latches	the	byte	in	response	to	the	assertion	(falling)	edge

of	DAV.
11.	 After	allowing	some	hold	time,	the	Talker	unasserts	DAV	and	drives	the



next	data	byte	on	the	DIO	signal	lines.
12.	 Steps	9-11	are	repeated	for	each	data	byte.



System	Configuration
The	HS488	Acceptor	Handshake	and	Source	Handshake	interface	functions
depend	on	several	time	delays.	Some	of	these	delays	are	a	function	of	the	total
system	cable	length.
The	Controller	must	communicate	this	system	configuration	data	to	HS488
devices	after	the	system	powers	on.	The	Controller	configures	HS488	devices	by
sourcing	two	multiline	messages	while	ATN	is	true.	The	first	message	is	the	CFE
message.	The	Controller	sends	the	CFE	message	by	driving	a	bit	pattern	(1E
hex)	that	the	IEEE	488.1	standard	does	not	define	on	the	DIO	signal	lines.	The
CFE	message	enables	HS488	devices	to	interpret	the	SCG	message	that	follows.
The	second	message	is	a	Secondary	Command	Group	(SCG)	message	that
contains	the	configuration	data.	The	Secondary	command	has	the	bit	pattern	6n
hex,	where	n	is	the	meters	of	cable	in	the	system.



Terminating	Data	Transmissions
GPIB	data	transfers	are	terminated	either	when	the	GPIB	EOI	line	is	asserted
with	the	last	byte	of	a	transfer	or	when	a	preconfigured	end-of-string	(EOS)
character	is	transmitted.	By	default,	the	NI-488.2	driver	asserts	EOI	with	the	last
byte	of	writes,	and	the	EOS	modes	are	disabled.
If	EOT	mode	is	enabled,	the	NI-488.2	driver	asserts	the	GPIB	EOI	line	when	the
last	byte	of	a	write	is	sent	out	on	the	GPIB.	If	it	is	disabled,	the	EOI	line	is	not
asserted	with	the	last	byte	of	a	write.
EOS	mode	configuration	includes	the	following	information:

A	7-bit	or	8-bit	EOS	byte.
EOS	comparison	method.	This	method	indicates	whether	the	EOS	byte
has	seven	or	eight	significant	bits.	For	a	7-bit	EOS	byte,	the	eighth	bit	of
the	EOS	byte	is	ignored.
EOS	write	method.	If	this	method	is	enabled,	the	NI-488.2	driver
automatically	asserts	the	GPIB	EOI	line	when	the	EOS	byte	is	written	to
the	GPIB.	If	the	buffer	passed	into	an	ibwrt	call	contains	five	occurrences
of	the	EOS	byte,	the	EOI	line	is	asserted	as	each	of	the	five	EOS	bytes	are
written	to	the	GPIB.	If	an	ibwrt	buffer	does	not	contain	an	occurrence	of
the	EOS	byte,	the	EOI	line	is	not	asserted	(unless	the	EOT	mode	is
enabled,	in	which	case	the	EOI	line	is	asserted	with	the	last	byte	of	the
write).
EOS	read	method.	If	this	method	is	enabled,	the	NI-488.2	driver
terminates	ibrd,	ibrda,	and	ibrdf	calls	when	the	EOS	byte	is	detected	on
the	GPIB,	when	the	GPIB	EOI	line	is	asserted,	or	when	the	specified
count	is	reached.	If	the	EOS	read	method	is	disabled,	ibrd,	ibrda,	and
ibrdf	calls	terminate	only	when	the	GPIB	EOI	line	is	asserted	or	the
specified	count	has	been	read.

You	can	use	the	ibconfig	function	to	configure	the	software	to	inform	you
whether	the	GPIB	EOI	line	was	asserted	when	the	EOS	byte	was	read.	Use	the
IbcEndBitIsNormal	option	to	configure	the	software	to	report	only	the	END	bit
in	ibsta	when	the	GPIB	EOI	line	is	asserted.	By	default,	the	NI-488.2	driver
reports	END	in	ibsta	when	either	the	EOS	byte	is	read	in	or	the	EOI	line	is
asserted	during	a	read.



GPIB	Commands
GPIB	commands	are	used	to	manage	the	GPIB	interface	system.	They	include
commands	such	as	untalk	(UNT),	which	commands	all	GPIB	devices	to	stop
sourcing	data	bytes.	The	IEEE	488	standard	also	refers	to	GPIB	command	bytes
as	multiline	interface	messages.	The	IEEE	488	multiline	interface	messages	are
shown	in	the	following	table.
In	the	following	table,	the	first	group	of	columns	(hex	00-1F)	represents	the
primary	GPIB	commands.	The	next	group	of	columns	(hex	20-3F)	corresponds
to	listen	addresses	(MLA).	The	listen	address	of	a	device	is	formed	by	adding
hex	20	to	the	GPIB	primary	address.	The	next	group	of	columns	(hex	40-5F)
correspond	to	talk	addresses	(MTA).	The	talk	address	of	a	device	is	formed	by
adding	hex	40	to	the	GPIB	primary	address.	(You	may	need	to	stretch	this
window	to	see	the	table	correctly.)
Multiline	Interface	Command	Messages
Hex Oct Dec ASCII Msg Hex Oct Dec ASCII Msg

00 000 0 NUL 20 040 32 SP MLA0

01 001 1 SOH GTL 21 041 33 ! MLA1

02 002 2 STX 22 042 34 " MLA2

03 003 3 ETX 23 043 35 # MLA3

04 004 4 EOT SDC 24 044 36 $ MLA4

05 005 5 ENQ PPC 25 045 37 % MLA5

06 006 6 ACK 26 046 38 & MLA6

07 007 7 BEL 27 047 39 ' MLA7

08 010 8 BS GET 28 050 40 ( MLA8

09 011 9 HT TCT 29 051 41 ) MLA9

0A 012 10 LF 2A 052 42 * MLA10

0B 013 11 VT 2B 053 43 + MLA11

0C 014 12 FF 2C 054 44 , MLA12

0D 015 13 CR 2D 055 45 - MLA13

0E 016 14 SO 2E 056 46 . MLA14

0F 017 15 SI 2F 057 47 / MLA15

10 020 16 DLE 30 060 48 0 MLA16

11 021 17 DC1 LLO 31 061 49 1 MLA17

12 022 18 DC2 32 062 50 2 MLA18



13 023 19 DC3 33 063 51 3 MLA19

14 024 20 DC4 DCL 34 064 52 4 MLA20

15 025 21 NAK PPU 35 065 53 5 MLA21

16 026 22 SYN 36 066 54 6 MLA22

17 027 23 ETB 37 067 55 7 MLA23

18 030 24 CAN SPE 38 070 56 8 MLA24

19 031 25 EM SPD 39 071 57 9 MLA25

1A 032 26 SUB 3A 072 58 : MLA26

1B 033 27 ESC 3B 073 59 ; MLA27

1C 034 28 FS 3C 074 60 < MLA28

1D 035 29 GS 3D 075 61 = MLA29

1E 036 30 RS 3E 076 62 > MLA30

1F 037 31 US CFE 3F 077 63 ? UNL

40 100 64 @ MTA0 60 140 96 ` MSA0,PPE

41 101 65 A MTA1 61 141 97 a MSA1,PPE,CFG1

42 102 66 B MTA2 62 142 98 b MSA2,PPE,	CFG2

43 103 67 C MTA3 63 143 99 c MSA3,PPE,CFG3

44 104 68 D MTA4 64 144 100 d MSA4,PPE,CFG4

45 105 69 E MTA5 65 145 101 e MSA5,PPE,CFG5

46 106 70 F MTA6 66 146 102 f MSA6,PPE,CFG6

47 107 71 G MTA7 67 147 103 g MSA7,PPE,CFG7

48 110 72 H MTA8 68 150 104 h MSA8,PPE,CFG8

49 111 73 I MTA9 69 151 105 i MSA9,PPE,CFG9

4A 112 74 J MTA10 6A 152 106 j MSA10,PPE,CFG10

4B 113 75 K MTA11 6B 153 107 k MSA11,PPE,CFG11

4C 114 76 L MTA12 6C 154 108 l MSA12,PPE,CFG12

4D 115 77 M MTA13 6D 155 109 m MSA13,PPE,CFG13

4E 116 78 N MTA14 6E 156 110 n MSA14,PPE,CFG14

4F 117 79 O MTA15 6F 157 111 o MSA15,PPE,CFG15

50 120 80 P MTA16 70 160 112 p MSA16,PPD

51 121 81 Q MTA17 71 161 113 q MSA17,PPD

52 122 82 R MTA18 72 162 114 r MSA18,PPD

53 123 83 S MTA19 73 163 115 s MSA19,PPD



54 124 84 T MTA20 74 164 116 t MSA20,PPD

55 125 85 U MTA21 75 165 117 u MSA21,PPD

56 126 86 V MTA22 76 166 118 v MSA22,PPD

57 127 87 W MTA23 77 167 119 w MSA23,PPD

58 130 88 X MTA24 78 170 120 x MSA24,PPD

59 131 89 Y MTA25 79 171 121 y MSA25,PPD

5A 132 90 Z MTA26 7A 172 122 z MSA26,PPD

5B 133 91 [ MTA27 7B 173 123 { MSA27,PPD

5C 134 92 \ MTA28 7C 174 124 | MSA28,PPD

5D 135 93 ] MTA29 7D 175 125 } MSA29,PPD

5E 136 94 ^ MTA30 7E 176 126 ~ MSA30,PPD

5F 137 95 _ UNT 7F 177 127 DEL

Message	Definitions
CFE Configuration	Enable

CFG Configure

DCL Device	Clear

GET Group	Execute	Trigger

GTL Go	To	Local

LLO Local	Lockout

MLA My	Listen	Address

MSA My	Secondary	Address

MTA My	Talk	Address

PPC Parallel	Poll	Configure

PPD Parallel	Poll	Disable

PPE Parallel	Poll	Enable

PPU Parallel	Poll	Unconfigure

SDC Selected	Device	Clear

SPD Serial	Poll	Disable

SPE Serial	Poll	Enable

TCT Take	Control

UNL Unlisten

UNT Untalk
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Warranty
The	GPIB	hardware	is	warranted	against	defects	in	materials	and	workmanship
for	a	period	of	two	years	from	the	date	of	shipment,	as	evidenced	by	receipts	or
other	documentation.	National	Instruments	will,	at	its	option,	repair	or	replace
equipment	that	proves	to	be	defective	during	the	warranty	period.	This	warranty
includes	parts	and	labor.
The	media	on	which	you	receive	National	Instruments	software	are	warranted
not	to	fail	to	execute	programming	instructions,	due	to	defects	in	materials	and
workmanship,	for	a	period	of	90	days	from	date	of	shipment,	as	evidenced	by
receipts	or	other	documentation.	National	Instruments	will,	at	its	option,	repair
or	replace	software	media	that	do	not	execute	programming	instructions	if
National	Instruments	receives	notice	of	such	defects	during	the	warranty	period.
National	Instruments	does	not	warrant	that	the	operation	of	the	software	shall	be
uninterrupted	or	error	free.
A	Return	Material	Authorization	(RMA)	number	must	be	obtained	from	the
factory	and	clearly	marked	on	the	outside	of	the	package	before	any	equipment
will	be	accepted	for	warranty	work.	National	Instruments	will	pay	the	shipping
costs	of	returning	to	the	owner	parts	which	are	covered	by	warranty.
National	Instruments	believes	that	the	information	in	this	document	is	accurate.
The	document	has	been	carefully	reviewed	for	technical	accuracy.	In	the	event
that	technical	or	typographical	errors	exist,	National	Instruments	reserves	the
right	to	make	changes	to	subsequent	editions	of	this	document	without	prior
notice	to	holders	of	this	edition.	The	reader	should	consult	National	Instruments
if	errors	are	suspected.	In	no	event	shall	National	Instruments	be	liable	for	any
damages	arising	out	of	or	related	to	this	document	or	the	information	contained
in	it.
Except	as	specified	herein,	National	Instruments	makes	no	warranties,
express	or	implied,	and	specifically	disclaims	any	warranty	of
merchantability	or	fitness	for	a	particular	purpose.	Customer's	right	to
recover	damages	caused	by	fault	or	negligence	on	the	part	of	National
Instruments	shall	be	limited	to	the	amount	theretofore	paid	by	the
customer.	National	Instruments	will	not	be	liable	for	damages	resulting
from	loss	of	data,	profits,	use	of	products,	or	incidental	or	consequential
damages,	even	if	advised	of	the	possibility	thereof.	This	limitation	of	the
liability	of	National	Instruments	will	apply	regardless	of	the	form	of	action,



whether	in	contract	or	tort,	including	negligence.	Any	action	against	National
Instruments	must	be	brought	within	one	year	after	the	cause	of	action	accrues.
National	Instruments	shall	not	be	liable	for	any	delay	in	performance	due	to
causes	beyond	its	reasonable	control.	The	warranty	provided	herein	does	not
cover	damages,	defects,	malfunctions,	or	service	failures	caused	by	owner's
failure	to	follow	the	National	Instruments	installation,	operation,	or	maintenance
instructions;	owner's	modification	of	the	product;	owner's	abuse,	misuse,	or
negligent	acts;	and	power	failure	or	surges,	fire,	flood,	accident,	actions	of	third
parties,	or	other	events	outside	reasonable	control.



Copyright
Under	the	copyright	laws,	this	publication	may	not	be	reproduced	or	transmitted
in	any	form,	electronic	or	mechanical,	including	photocopying,	recording,
storing	in	an	information	retrieval	system,	or	translating,	in	whole	or	in	part,
without	the	prior	written	consent	of	National	Instruments	Corporation.



Trademarks
CVI™,	National	Instruments™,	NI-488.2™,	and	ni.com™	are	trademarks	of
National	Instruments	Corporation.
Product	and	company	names	mentioned	herein	are	trademarks	or	trade	names	of
their	respective	companies.



Patents
For	patents	covering	National	Instruments	products,	refer	to	the	appropriate
location:	Help»Patents	in	your	software,	the	patents.txt	file	on	your	CD,	or
ni.com/patents.

javascript:WWW(WWW_Patents)


WARNING	REGARDING	USE	OF	NATIONAL
INSTRUMENTS	PRODUCTS
(1)	National	Instruments	products	are	not	designed	with	components	and
testing	for	a	level	of	reliability	suitable	for	use	in	or	in	connection	with
surgical	implants	or	as	critical	components	in	any	life	support	systems
whose	failure	to	perform	can	reasonably	be	expected	to	cause	significant
injury	to	a	human.
(2)	In	any	application,	including	the	above,	reliability	of	operation	of	the
software	products	can	be	impaired	by	adverse	factors,	including	but	not
limited	to	fluctuations	in	electrical	power	supply,	computer	hardware
malfunctions,	computer	operating	system	software	fitness,	fitness	of
compilers	and	development	software	used	to	develop	an	application,
installation	errors,	software	and	hardware	compatibility	problems,
malfunctions	or	failures	of	electronic	monitoring	or	control	devices,
transient	failures	of	electronic	systems	(hardware	and/or	software),
unanticipated	uses	or	misuses,	or	errors	on	the	part	of	the	user	or
applications	designer	(adverse	factors	such	as	these	are	hereafter
collectively	termed	"system	failures").	Any	application	where	a	system
failure	would	create	a	risk	of	harm	to	property	or	persons	(including	the
risk	of	bodily	injury	and	death)	should	not	be	reliant	solely	upon	one	form
of	electronic	system	due	to	the	risk	of	system	failure.	To	avoid	damage,
injury,	or	death,	the	user	or	application	designer	must	take	reasonably
prudent	steps	to	protect	against	system	failures,	including	but	not	limited	to
back-up	or	shut	down	mechanisms.	Because	each	end-user	system	is
customized	and	differs	from	National	Instruments'	testing	platforms	and
because	a	user	or	application	designer	may	use	National	Instruments
products	in	combination	with	other	products	in	a	manner	not	evaluated	or
contemplated	by	National	Instruments,	the	user	or	application	designer	is
ultimately	responsible	for	verifying	and	validating	the	suitability	of	National
Instruments	products	whenever	National	Instruments	products	are
incorporated	in	a	system	or	application,	including,	without	limitation,	the
appropriate	design,	process	and	safety	level	of	such	system	or	application.



Technical	Support	and	Professional	Services
Visit	the	following	sections	of	the	National	Instruments	Web	site	at	ni.com	for
technical	support	and	professional	services:

Support—Online	technical	support	resources	include	the	following:
Self-Help	Resources—For	immediate	answers	and	solutions,	visit
our	extensive	library	of	technical	support	resources	available	in
English,	Japanese,	and	Spanish	at	ni.com/support.	These	resources
are	available	for	most	products	at	no	cost	to	registered	users	and
include	software	drivers	and	updates,	a	KnowledgeBase,	product
manuals,	step-by-step	troubleshooting	wizards,	hardware
schematics	and	conformity	documentation,	example	code,	tutorials
and	application	notes,	instrument	drivers,	discussion	forums,	a
measurement	glossary,	and	so	on.
Assisted	Support	Options—Contact	NI	engineers	and	other
measurement	and	automation	professionals	by	visiting	ni.com/ask.
Our	online	system	helps	you	define	your	question	and	connects
you	to	the	experts	by	phone,	discussion	forum,	or	email.

Training—Visit	ni.com/custed	for	self-paced	tutorials,	videos,	and
interactive	CDs.	You	also	can	register	for	instructor-led,	hands-on	courses
at	locations	around	the	world.
System	Integration—If	you	have	time	constraints,	limited	in-house
technical	resources,	or	other	project	challenges,	NI	Alliance	Program
members	can	help.	To	learn	more,	call	your	local	NI	office	or	visit
ni.com/alliance.
Declaration	of	Conformity	(DoC)—A	DoC	is	our	claim	of	compliance
with	the	Council	of	the	European	Communities	using	the	manufacturer​s
declaration	of	conformity.	This	system	affords	the	user	protection	for
electronic	compatibility	(EMC)	and	product	safety.	You	can	obtain	the
DoC	for	your	product	by	visiting	ni.com/hardref.nsf.
Calibration	Certificate—If	your	product	supports	calibration,	you	can
obtain	the	calibration	certificate	for	your	product	at	ni.com/calibration.

If	you	searched	ni.com	and	could	not	find	the	answers	you	need,	contact	your
local	office	or	NI	corporate	headquarters.	You	can	also	visit	the	Worldwide
Offices	section	of	ni.com/niglobal	to	access	the	branch	office	Web	sites,	which
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provide	up-to-date	contact	information,	support	phone	numbers,	email	addresses,
and	current	events.



Clicking	the	Capture	button	in	the	Action	window	causes	the	analyzer	to	begin
capturing	GPIB	events	into	the	active	capture	display.	Data	is	captured	according
to	the	current	capture	configuration	settings.	Triggering	is	not	enabled.



Clicking	the	Capture	&	Trigger	button	in	the	Action	window	causes	the
analyzer	to	begin	capturing	GPIB	events	into	the	active	capture	display	and	to
monitor	for	trigger	conditions.	Data	is	captured	according	to	the	current	capture
configuration	settings,	and	triggers	are	monitored	according	to	the	current	trigger
configuration.	The	capture	and	trigger	configuration	can	be	modified	using	the
settings	configuration	described	in	the	Settings	Configuration	section.



Capture	Display	Mnemonics
The	mnemonics	that	appear	in	the	capture	display	of	the	GPIB	analyzer	are
defined	below.
DAB GPIB	data	byte	captured	using	the	data	transfer	or	handshake	line	transition.

GPIB	command	bytes	captured	using	the	command	transfer	or	handshake	line
transition:
ACG Addressed	command	group.

CFE Configuration	enable.

DCL Device	clear.

GET Group	execute	trigger.

GTL Go	to	local.

LA0-LA30 Listen	addresses	0-30.

LLO Local	lock	out.

PPC Parallel	poll	configure.

PPU Parallel	poll	unconfigure.

SC0-SC30 Secondary	command	0-30.

SDC Selected	device	clear.

SPD Serial	poll	disable.

SPE Serial	poll	enable.

TCT Take	control.

TA0-TA30 Talk	addresses	0-30.

UCG Universal	command	group.

UNL Unlisten.

UNT Untalk.

GPIB	parallel	poll	responses	captured	using	the	parallel	poll	response	capture
stimulus:
PP-B Parallel	poll	is	beginning.

PP-E Parallel	poll	is	ending.

PP-R Parallel	poll	response	(occurs	between	PP-B	and	PP-E).



This	multiline	interface	message	is	a	proposed	extension	to	the	IEEE	488.1
specification	to	support	the	HS488	high-speed	protocol.



Branch	Offices
Office Telephone	Number

Australia 61	2	9672	8846

Austria 43	0	662	45	79	90	0

Belgium 32	0	2	757	00	20

Brazil 55	11	3262	3599

Canada	(Calgary) 403	274	9391

Canada	(Montreal) 514	288	5722

Canada	(Ottawa) 613	233	5949

Canada	(Québec) 514	694	8521

Canada	(Toronto) 905	785	0085

Canada	(Vancouver) 514	685	7530

China 86	21	6555	7838

Czech	Republic 42	02	2423	5774

Denmark 45	45	76	26	00

Finland 385	0	9	725	725	11

France 33	0	1	48	14	24	24

Germany 49	0	89	741	31	30

Greece 30	2	10	42	96	427

Hong	Kong 2645	3186

India 91	80	4190000

Israel 972	0	3	6393737

Italy 39	02	413091

Japan 81	3	5472	2970

Korea 82	02	3451	3400

Malaysia 603	9059	6711

Mexico 001	800	010	0793

Netherlands 31	0	348	433	466

New	Zealand 64	09	914	0488

Norway 47	0	32	27	73	00

Poland 48	0	22	3390	150

Portugal 351	210	311	210

Russia 7	095	238	7139

Singapore 65	6	226	5886

Slovenia 386	3	425	4200

South	Africa 27	0	11	805	8197

Spain 34	91	640	0085

Sweden 46	0	8	587	895	00



Switzerland 41	56	200	51	51

Taiwan 886	2	2528	7227

United	Kingdom 44	0	1635	523545

United	States	(Corporate) 512	683	0100



If	SC	appears	after	a	talk	or	listen	address,	it	is	a	secondary	address.	If	it	appears
after	a	parallel	poll	configure,	it	is	either	a	parallel	poll	enable	(PPE)	or	a	parallel
poll	disable	(PPD)	command.	If	it	appears	after	configuration	enable	(CFE),	it	is
the	cable	length	for	HS488.
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