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The	following	documents	contain	information	that	you	may	find	helpful	as
you	use	this	help	file:

LabVIEW	Help
LabWindows/CVI	Help
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Using	Help
Conventions
Navigating	Help
Searching	Help
Printing	Help	File	Topics



Conventions
This	help	file	uses	the	following	formatting	and	typographical
conventions:

» The	»	symbol	leads	you	through	nested	menu	items	and
dialog	box	options	to	a	final	action.	The	sequence	File»Page
Setup»Options	directs	you	to	pull	down	the	File	menu,
select	the	Page	Setup	item,	and	select	Options	from	the	last
dialog	box.
This	icon	denotes	a	note,	which	alerts	you	to	important
information.

bold Bold	text	denotes	items	that	you	must	select	or	click	in	the
software,	such	as	menu	items	and	dialog	box	options.	Bold
text	also	denotes	parameter	names.

green Underlined	text	in	this	color	denotes	a	link	to	a	help	topic,
help	file,	or	Web	address.

italic Italic	text	denotes	variables,	emphasis,	cross-references,	or
an	introduction	to	a	key	concept.	Italic	text	also	denotes	text
that	is	a	placeholder	for	a	word	or	value	that	you	must
supply.

monospace Text	in	this	font	denotes	text	or	characters	that	you	should
enter	from	the	keyboard,	sections	of	code,	programming
examples,	and	syntax	examples.	This	font	is	also	used	for
the	proper	names	of	disk	drives,	paths,	directories,
programs,	subprograms,	subroutines,	device	names,
functions,	operations,	variables,	filenames,	and	extensions.



Navigating	Help	(Windows	Only)
To	navigate	this	help	file,	use	the	Contents,	Index,	and	Search	tabs	to
the	left	of	this	window	or	use	the	following	toolbar	buttons	located	above
the	tabs:

Hide—Hides	the	navigation	pane	from	view.
Locate—Locates	the	currently	displayed	topic	in	the	Contents
tab,	allowing	you	to	view	related	topics.
Back—Displays	the	previously	viewed	topic.
Forward—Displays	the	topic	you	viewed	before	clicking	the
Back	button.
Options—Displays	a	list	of	commands	and	viewing	options	for
the	help	file.



Searching	Help	(Windows	Only)
Use	the	Search	tab	to	the	left	of	this	window	to	locate	content	in	this	help
file.	If	you	want	to	search	for	words	in	a	certain	order,	such	as	"related
documentation,"	add	quotation	marks	around	the	search	words	as	shown
in	the	example.	Searching	for	terms	on	the	Search	tab	allows	you	to
quickly	locate	specific	information	and	information	in	topics	that	are	not
included	on	the	Contents	tab.



Wildcards
You	also	can	search	using	asterisk	(*)	or	question	mark	(?)	wildcards.
Use	the	asterisk	wildcard	to	return	topics	that	contain	a	certain	string.	For
example,	a	search	for	"prog*"	lists	topics	that	contain	the	words
"program,"	"programmatically,"	"progress,"	and	so	on.
Use	the	question	mark	wildcard	as	a	substitute	for	a	single	character	in	a
search	term.	For	example,	"?ext"	lists	topics	that	contain	the	words
"next,"	"text,"	and	so	on.

Note		Wildcard	searching	will	not	work	on	Simplified	Chinese,
Traditional	Chinese,	Japanese,	and	Korean	systems.



Nested	Expressions
Use	nested	expressions	to	combine	searches	to	further	refine	a	search.
You	can	use	Boolean	expressions	and	wildcards	in	a	nested	expression.
For	example,	"example	AND	(program	OR	VI)"	lists	topics	that	contain
"example	program"	or	"example	VI."	You	cannot	nest	expressions	more
than	five	levels.



Boolean	Expressions
Click	the	 	button	to	add	Boolean	expressions	to	a	search.	The	following
Boolean	operators	are	available:

AND	(default)—Returns	topics	that	contain	both	search	terms.
You	do	not	need	to	specify	this	operator	unless	you	are	using
nested	expressions.
OR—Returns	topics	that	contain	either	the	first	or	second	term.
NOT—Returns	topics	that	contain	the	first	term	without	the
second	term.
NEAR—Returns	topics	that	contain	both	terms	within	eight	words
of	each	other.



Search	Options

Use	the	following	checkboxes	on	the	Search	tab	to	customize	a	search:
Search	previous	results—Narrows	the	results	from	a	search
that	returned	too	many	topics.	You	must	remove	the	checkmark
from	this	checkbox	to	search	all	topics.
Match	similar	words—Broadens	a	search	to	return	topics	that
contain	words	similar	to	the	search	terms.	For	example,	a	search
for	"program"	lists	topics	that	include	the	words	"programs,"
"programming,"	and	so	on.
Search	titles	only—Searches	only	in	the	titles	of	topics.



Printing	Help	File	Topics	(Windows	Only)
Complete	the	following	steps	to	print	an	entire	book	from	the	Contents
tab:

1.	 Right-click	the	book.
2.	 Select	Print	from	the	shortcut	menu	to	display	the	Print	Topics

dialog	box.
3.	 Select	the	Print	the	selected	heading	and	all	subtopics	option.

Note		Select	Print	the	selected	topic	if	you	want	to	print
the	single	topic	you	have	selected	in	the	Contents	tab.

4.	 Click	the	OK	button.



Printing	PDF	Documents
This	help	file	may	contain	links	to	PDF	documents.	To	print	PDF
documents,	click	the	print	button	located	on	the	Adobe	Acrobat	Viewer
toolbar.



System	Manager	Overview
Use	the	System	Manager	to	complete	the	following	tasks:

Create	shared	or	network	variables.
Monitor	shared	or	network	variables.
Create	and	monitor	processes.
Create	and	monitor	I/O	servers.
Manage	security.
Manage	aliases.
Start	and	stop	the	Shared	Variable	Engine.
Force	I/O	variable	values.
View	and	clear	scan	engine	faults.
View	and	set	scan	engine	modes.
Monitor	RT	target	resources.

Note		You	must	use	an	alternate	method	to	start	or	stop	the
Shared	Variable	Engine	on	Windows	Vista.

Select	Start»All	Programs»National	Instruments»Distributed	System
Manager	to	launch	the	System	Manager.	In	LabVIEW,	you	also	can
launch	the	System	Manager	by	selecting	Tools»Distributed	System
Manager.



System	Manager	Components
The	System	Manager	includes	the	following	components:

System	tree—Displays	all	available	objects	on	the	network.	The
system	tree	appears	as	the	primary	navigation	pane	in	the
System	Manager	workspace.
System	tree	object—Refers	to	all	types	of	objects	that	might
appear	in	the	system	tree.	System	tree	object	can	refer	to	a
system,	process,	variable,	or	additional	object	types	installed	with
modules	and	toolkits.
Watch	list—Monitors	a	single	variable	or	multiple	variables
contained	within	a	system	or	process.
Auto	View—Displays	the	Probe	view	for	any	system	tree	object
that	you	select.	If	you	select	multiple	objects,	this	view	displays	a
Watch	List	view	that	contains	all	of	the	selected	objects.
Probe	views—Display	information	and	configuration	options	for
the	following	components:

CPU/Memory
I/O	Variable
Process
Scan	Engine
Variable
Web	Server
Web	Service



File	Menu
The	File	menu	contains	items	for	managing	System	Manager
workspaces.	Workspaces	display	information	about	all	shared	or	network
variables	that	are	currently	deployed,	including	the	URL,	current	value,
data	type,	timestamp	information,	and	any	error	or	quality	messages.
Quality	messages	list	errors	and	other	conditions	that	apply	to	the
variable.

New	Workspace—Creates	a	new	workspace.	When	you	select
this	menu	item,	the	System	Manager	removes	all	variables	from
the	Watch	List	view	and	resets	the	workspace	layout.
Open	Workspace—Opens	a	saved	workspace.
Save	Workspace—Saves	the	current	workspace	with	the	.smw
extension.
Settings—Displays	the	Settings	dialog	box	where	you	can
customize	workspace	layout,	set	the	data	update	rate,	and
specify	the	System	Manager	to	save	its	workspace	between
sessions.



Actions	Menu
The	Actions	menu	contains	items	for	starting	and	stopping	the	Shared
Variable	Engine,	refreshing	your	workspace,	and	logging	into	a	system.

Log	In—Displays	the	NI	Security	Login	dialog	box.
Log	Out—Logs	out	of	the	session	configured	in	the	NI	Security
Login	dialog	box.
Configure	Security—Displays	the	NI	ACL	Configuration	dialog
box,	which	you	can	use	to	update	security	settings.
Start	Local	Shared	Variable	Engine—Restarts	the	Shared
Variable	Engine.

Note		You	must	use	an	alternate	method	to	start	the
Shared	Variable	Engine	on	Windows	Vista.

Stop	Local	Shared	Variable	Engine—Shuts	down	the	Shared
Variable	Engine.

Note		You	must	use	an	alternate	method	to	stop	the
Shared	Variable	Engine	on	Windows	Vista.

Alias	Manager—Displays	the	Alias	Manager	dialog	box,	which
you	can	use	to	configure	aliases	for	local	computers	and	IP
addresses.

The	Shared	Variable	Engine	uses	aliases	when	running
custom	I/O	servers	that	refer	to	other	variables	in	the
system.

Add	System	to	My	Systems—Displays	the	Add	Systems	to	My
Systems	dialog	box	that	allows	you	to	add	a	system	to	My
Systems	on	the	system	tree.



View	Menu
The	View	menu	contains	the	options	to	display	certain	windows	in	the
workspace	and	access	a	system	tree	object	that	does	not	appear	in	the
system	tree.

Auto	View—Displays	the	Probe	view	for	any	system	tree	object
that	you	select.	If	you	select	multiple	objects,	this	view	displays	a
Watch	List	that	contains	all	of	the	selected	objects.
Events—Displays	the	Events	view	for	any	systems	located
within	My	Systems	on	the	system	tree.
Probe	Location—Displays	the	Probe	Location	dialog	box	for	a
system,	process,	or	variable.	You	can	enter	the	location	of
objects	that	appear	in	the	system	tree,	as	well	as	those	that	do
not.
New	Watch	List—Creates	a	blank	Watch	List	view.	Drag	a
system	tree	object	into	this	view	to	add	it	to	the	Watch	List	view.
Refresh—Updates	the	contents	of	the	system	tree,	Watch	List
views,	and	Alarm	List	views.



Help	Menu
The	Help	menu	contains	items	to	explain	and	define	System	Manager
features	and	provide	System	Manager	documentation.

System	Manager	Overview—Displays	the	NI	Distributed
System	Manager	Help.	Use	this	help	file	for	information	about
creating	and	managing	shared	or	network	variables	and	other
system	tree	objects.

Note		Refer	to	the	LabVIEW	Help,	NI	Measurement	Studio
Help,	or	LabWindows/CVI	Help	for	more	information	about
using	variables	created	with	the	System	Manager	in	your
applications.

About	System	Manager—Displays	general	information	about
the	current	installation,	such	as	the	version	number.



Concepts
Use	this	book	to	learn	about	concepts	in	the	System	Manager.	Refer	to
the	How-To	book	for	step-by-step	instructions	for	using	the	System
Manager.

To	view	related	topics,	click	the	Locate	button,	shown	at	left,	in	the
toolbar	at	the	top	of	this	window.	The	NI	Distributed	System	Manager
Help	highlights	this	topic	in	the	Contents	tab	so	you	can	navigate	the
related	topics.



Systems
Systems	are	local	computers	or	LabVIEW	Real-Time	targets	available
through	the	System	Manager.	Systems	available	on	your	local
subnetwork	appear	by	default.	Select	Actions»Add	System	to	My
Systems	to	access	systems	outside	your	local	subnetwork	that	do	not
appear	in	the	system	tree.



Shortcut	Menu
Right-click	a	system	on	the	system	tree	to	display	the	following	options.

Add	to	My	Systems—Moves	a	selected	system	listed	in
Network	Items	to	My	Systems	on	the	system	tree.
Remove	From	My	Systems—Removes	a	selected	system	listed
in	My	Systems.
Watch	List—Creates	a	new	Watch	List	view	that	contains	the
single	variable	or	multiple	variables	contained	within	the	system
or	process	that	you	select.
Probe—Displays	the	Systems	Probe	view,	which	displays	the
location	address	for	the	selected	system.
Add	Process—Displays	the	Add	Process	dialog	box.



Processes
Processes	are	hierarchies	of	shared	or	network	variables	and	I/O
servers.	Processes	provide	a	logical	means	of	organizing	data.	For
example,	if	multiple,	independent	applications	run	on	one	server,	you	can
create	a	process	for	each	application.	Similarly,	if	you	have	a	very	large
application,	you	might	divide	the	application	into	discrete	subsystems	and
create	a	process	for	each	subsystem.	In	addition	to	organizing	data,	you
can	start	and	stop	each	process	independently,	which	allows	you	to	take
one	subsystem	offline	while	the	rest	of	the	application	continues	to	run.
When	you	stop	a	process,	the	values	of	variables	in	that	process	become
unavailable	and	do	not	update.
Use	the	System	Manager	to	create	processes	and	start	and	stop	existing
processes.



Shortcut	Menu

Right-click	a	process	on	the	system	tree	to	display	the	following	options.
Watch	List—Creates	a	new	Watch	List	view	that	displays	the
information	for	all	variables	contained	within	the	process	you
select.
Probe—Displays	the	Process	Probe	view	for	the	selected
process.
Add	Variable—Displays	the	Shared	Variable	Properties	dialog
box,	which	you	can	use	to	create	a	new	variable	within	the
selected	process.
Add	I/O	Server—Displays	the	Create	New	I/O	Server	dialog	box
to	create	an	I/O	server	and	add	it	to	the	Shared	Variable	Engine.
Stop	Process—Stops	the	selected	process	in	the	system	tree.
When	a	process	stops,	the	values	of	variables	in	that	process
become	unavailable	and	do	not	update.	You	must	have	sufficient
access	privileges	to	stop	a	process.
Start	Process—Starts	the	selected	process	in	the	system	tree.
Processes	automatically	start	when	you	create	them.	If	you	select
the	Stop	Process	item	to	stop	a	process,	you	can	use	Start
Process	to	restart	the	process.	You	must	have	sufficient	access
privileges	to	start	a	process.
Remove	Process—Removes	the	selected	process	in	the	system
tree.	You	must	have	sufficient	access	privileges	to	remove	a
process.



Shared	or	Network	Variables
LabVIEW	uses	the	term	shared	variable	and	Measurement	Studio	and
LabWindows™/CVI™	use	the	term	network	variable	to	describe	software
items	that	exist	on	a	network	and	can	communicate	between	programs,
applications,	remote	computers,	and	hardware	through	the	Shared
Variable	Engine	(SVE).	Variables	can	represent	a	value	or	an	I/O	point.
The	SVE	uses	the	NI	Publish-Subscribe	Protocol	(NI-PSP)	data	transfer
protocol	to	write	data	and	allow	users	to	read	live	data.	NI-PSP	is	a
proprietary	technology	that	provides	fast	and	reliable	data	transmission
for	large	and	small	applications	and	is	installed	as	a	service	on	the
computer	when	you	install	LabVIEW,	Measurement	Studio,	or
LabWindows/CVI.
Use	the	System	Manager	to	create,	modify,	or	delete	shared	or	network
variables.	You	also	can	monitor	shared	or	network	variables	using	the
Watch	List	view.



Shortcut	Menu
Right-click	a	variable	on	the	system	tree	to	display	the	following	options.

Watch	List—Creates	a	new	Watch	List	view	that	contains	the
selected	variable.
Probe—Displays	the	Variable	Probe	view	for	the	selected
system.
Edit	Variable—Displays	the	Shared	Variable	Properties	dialog
box,	which	you	can	use	to	configure	the	selected	variable.
Remove	Variable—Removes	the	selected	variable	from	the
owning	process.



I/O	Servers
An	I/O	server	is	an	application	that	communicates	with	and	manages
input	and	output	devices	such	as	programmable	logic	controllers	(PLCs),
remote	input/output	devices,	remote	Shared	Variable	Engines,	and	data
acquisition	(DAQ)	plug-in	devices.	These	I/O	servers	read	selected	input
items	and	write	to	the	selected	output	items	on	demand.



Shortcut	Menu
Right-click	an	I/O	server	on	the	system	tree	to	display	the	following
options.

Watch	List—Creates	a	new	Watch	List	view	that	contains	the
single	variable	or	multiple	variables	contained	within	the	selected
system	or	process.
Probe—Displays	the	I/O	Server	Probe	view	for	the	selected
system.
Edit	I/O	Server—Configures	the	selected	I/O	server.
Remove	I/O	Server—Removes	the	selected	I/O	server.



Shared	Variable	Engine
The	Shared	Variable	Engine	(SVE)	uses	the	NI	Publish-Subscribe
Protocol	(NI-PSP)	to	enable	the	data	transfer	of	shared	or	network
variables	through	a	network.	The	SVE	manages	the	use	and	connectivity
of	shared	or	network	variables	on	single	or	multiple	systems.



Stopping	Shared	Variable	Engine
Select	Actions»Stop	Local	Shared	Variable	Engine	to	shut	down	the
SVE.	You	can	create,	configure,	and	remove	variables	in	the	System
Manager	after	you	shut	down	the	SVE.	While	the	SVE	is	shut	down,
variable	values	do	not	update,	and	the	SVE	does	not	log	alarms	for
variables.

Note		You	must	use	an	alternate	method	to	stop	the	Shared
Variable	Engine	on	Windows	Vista.



Starting	Shared	Variable	Engine
Select	Actions»Start	Local	Shared	Variable	Engine	to	restart	the	SVE.
The	SVE	is	always	running	after	you	install	LabVIEW,	LabWindows/CVI,
or	Measurement	Studio	unless	you	select	Actions»Stop	Local	Shared
Variable	Engine	to	manually	shut	down	the	SVE.

Note		You	must	use	an	alternate	method	to	start	the	Shared
Variable	Engine	on	Windows	Vista.



How-To
This	book	contains	step-by-step	instructions	and	other	information	that
might	be	useful	as	you	use	the	System	Manager.	Refer	to	the	Concepts
book	to	learn	about	related	concepts	in	the	System	Manager.

To	view	related	topics,	click	the	Locate	button,	shown	at	left,	in	the
toolbar	at	the	top	of	this	window.	The	NI	Distributed	System	Manager
Help	highlights	this	topic	in	the	Contents	tab	so	you	can	navigate	the
related	topics.



Creating	Processes
You	can	create	processes	on	a	local	or	LabVIEW	Real-Time	target.
Complete	the	following	steps	to	create	a	process	with	the	System
Manager.

1.	 Right-click	a	system	in	the	system	tree.
2.	 Select	Add	Process	from	the	shortcut	menu	to	display	the	Add

Process	dialog	box.
3.	 Configure	the	process	in	the	Add	Process	dialog	box.	You	can

use	this	dialog	box	to	configure	the	process	name	and	whether
the	process	will	run	after	you	create	it.

After	you	create	a	process,	you	can	add	shared	or	network	variables	or
add	I/O	servers	to	that	process.



Creating,	Modifying,	or	Deleting	Shared	or
Network	Variables
You	can	create	shared	or	network	variables	within	processes	on	a	local
or	real-time	target.
Complete	the	following	steps	to	create	a	variable	with	the	System
Manager.

1.	 Select	an	existing	process	in	the	system	tree	or	create	a	new
process.

2.	 Right-click	the	process	and	select	Add	Variable	from	the	shortcut
menu	to	display	the	Shared	Variable	Properties	dialog	box.

3.	 Configure	the	variable	in	the	Shared	Variable	Properties	dialog
box.	You	can	use	this	dialog	box	to	configure	settings	such	as	the
variable	name,	data	type,	and	buffering.

You	now	can	use	the	variable	in	an	application.	When	the	process	is
running,	the	Watch	List	view	updates	to	include	information	about	the
variable	such	as	current	value,	timestamp,	and	quality	messages.	Quality
messages	list	errors	and	other	conditions	that	apply	to	the	variable.



Modifying	a	Shared	or	Network	Variable
Right-click	the	variable	in	the	system	tree	and	select	Edit	Variable	from
the	shortcut	menu	to	display	the	Shared	Variable	Properties	dialog	box.



Deleting	a	Shared	or	Network	Variable
Right-click	the	variable	in	the	system	tree	and	select	Remove	Variable
from	the	shortcut	menu.



Monitoring	Variables	with	the	Watch	List	View
The	Watch	List	view	displays	information	about	a	single	variable	or
multiple	variables	contained	within	a	system	or	process.	The	Watch	List
view	displays	the	variable	location,	current	value,	data	type,	timestamp,
access	(read/write)	status,	and	quality.	The	quality	indicates	errors	or
other	conditions	that	apply	to	the	variable.
You	also	can	use	the	Watch	List	view	to	display	the	Alarms	view.
Complete	the	following	steps	to	monitor	variables	using	the	Watch	List
view.

1.	 Right-click	a	system	tree	object,	which	includes	all	systems,
processes,	and	variables	available	in	the	system	tree.

2.	 Select	Watch	List	from	the	shortcut	menu	to	open	a	new	Watch
List	view.

3.	 To	customize	the	Watch	List	view,	right-click	anywhere	inside	the
Watch	List	view.

4.	 Select	Show	Columns	from	the	shortcut	menu	to	show	and	hide
any	of	the	information	columns	available	in	the	Watch	List	view.
You	also	can	reorder	the	columns	by	dragging	the	column
headings.

sysmandsc.chm::/alm_win.html


Observing	Trend	View	of	Variables
Use	the	Variable	Probe	view	in	the	System	Manager	to	monitor	the	value
of	a	variable	over	time	using	the	trend	view	graph.
Complete	the	following	steps	to	monitor	the	value	of	a	variable	over	time
using	the	trend	view	graph.

1.	 Right-click	a	variable	in	the	system	tree.
2.	 Select	Probe	from	the	shortcut	menu	to	open	a	new	Variable

Probe	view	for	the	selected	variable.
3.	 Place	a	checkmark	in	the	Show	Trend	checkbox	to	display	the

trend	view	graph.



Customizing	the	System	Manager	Workspace
The	System	Manager	allows	you	to	customize	the	workspace.	Most
System	Manager	views	appear	as	a	window	by	default.	You	can	dock
these	views	on	the	workspace	to	build	a	custom	work	environment.
Complete	the	following	steps	to	customize	the	System	Manager
workspace.

1.	 Open	a	new	view,	such	as	a	Watch	List	or	Event	Window	view.
2.	 Click	and	hold	the	top	bar	of	the	desired	view	window.
3.	 Drag	the	window	to	the	top,	bottom,	or	sides	of	the	System

Manager	workspace	to	dock	the	window.
Note		If	you	dock	multiple	views	in	an	area	of	the
workspace,	the	System	Manager	automatically	adds	tabs
to	allow	navigation	between	the	views.

4.	 To	undock	a	view	to	a	separate	window,	select	the	Restore
Down	button	 	in	the	top-right	of	the	view.

Note		Select	View»Auto	View	to	display	the	Variable
Details	view	for	the	selected	system	tree	object.	The
Variable	Details	view	appears	docked	by	default	when
you	select	Auto	View.

5.	 Select	File»Save	Workspace	to	save	the	workspace	as	a	.smw
file.

6.	 Select	File»Open	Workspace	and	navigate	to	a	.smw	file	to
restore	a	previously	customized	workspace.



Saving	and	Restoring	a	System	Manager
Workspace
When	you	customize	the	System	Manager	workspace,	you	can	save	the
customized	workspace	and	restore	it	in	a	later	System	Manager	session.
Complete	the	following	steps	to	save	and	restore	a	customized	System
Manager	workspace.

1.	 Customize	the	System	Manager	workspace.
2.	 Select	File»Save	Workspace	to	save	your	workspace	as	a	.smw

file.
3.	 To	restore	a	workspace	in	a	later	session,	select	File»Open

Workspace	and	navigate	to	the	.smw	file	you	want	to	restore.



Programmatically	Accessing	Published	Values
You	can	access	system	tree	objects	such	as	shared	or	network	variables
from	outside	the	System	Manager	environment.	Use	the	network	path	for
a	system	tree	object	to	access	that	object	from	another	environment.
The	network	path	to	shared	or	network	variables	consists	of	the	system
name,	the	name	of	the	process	in	which	the	shared	variable	resides,	and
the	shared	variable	name:	\\system\process\variable.	For	example,	the
network	path	\\system1\myprocess\myvariable	identifies	a	shared	variable
named	myvariable	in	the	process	named	myprocess	on	a	system	named
system1.
You	can	determine	the	network	path	using	the	Probe	view	for	any	system
tree	object.	The	Location	field	displays	the	network	path	for	the	selected
object.

Note		Refer	to	the	LabVIEW	Help,	NI	Measurement	Studio	Help,
or	LabWindows/CVI	Help	for	more	information	about	accessing
shared	or	network	variables	created	or	modified	with	the	System
Manager	from	other	applications.



Starting	or	Stopping	the	Shared	Variable	Engine
on	Windows	Vista
You	cannot	use	the	System	Manager	to	start	or	stop	the	Shared	Variable
Engine	(SVE)	on	Windows	Vista.	Use	the	Windows	Service	Manager	to
start	and	stop	the	SVE.	You	must	possess	administrator	privileges	to
perform	this	action	in	Vista.
Complete	the	following	steps	to	start	or	stop	the	SVE	using	the	Windows
Service	Manager.

1.	 Select	the	Start	Menu.
2.	 Enter	Services	in	the	search	field.
3.	 Select	Services	from	the	Programs	list	that	appears.	If

necessary,	enter	a	user	name	and	password	to	obtain
administrator	privileges.

4.	 In	the	Services	window,	right-click	National	Instruments
Variable	Engine	and	select	Start	or	Stop	from	the	shortcut
menu	to	activate	or	disable	the	SVE.



Forcing	I/O	Variable	Values	(NI	Scan	Engine)
You	can	use	an	I/O	variable	probe	to	force	I/O	variable	values.	Forcing
an	I/O	variable	causes	the	input	or	output	and	all	associated	aliases	of
the	variable	to	assume	the	forced	value	until	you	unforce	the	value.	If	an
input	from	hardware	returns	an	error,	and	the	associated	I/O	variable	is
forced,	System	Manager	does	not	display	the	error.	However,	if	the	error
results	in	a	fault,	LabVIEW	registers	the	fault.	If	an	output	returns	an
error,	System	Manager	displays	the	error.

Note		If	you	link	several	I/O	variables	in	a	chain	of	aliases	and
force	one	of	the	I/O	variables	in	the	chain,	the	forced	value	applies
to	all	I/O	variables	in	the	chain.
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Enabling	I/O	Variable	Forcing
Complete	the	following	steps	to	enable	and	disable	I/O	variable	forcing
on	a	target	with	the	NI	Scan	Engine	installed.

1.	 Click	a	scan-enabled	target	in	the	system	tree	to	display	a	target
probe	in	the	Auto	View.	You	also	can	right-click	a	target	and
select	Probe	to	display	a	target	probe	in	a	separate	window.

2.	 The	Scan	Engine	page	of	an	RT	target	probe	displays	the
Forcing	Enabled	LED	indicator,	which	indicates	whether	I/O
variable	forcing	is	enabled	on	the	controller.

3.	 Use	the	Enable	Forcing	button	to	enable	forcing.	Use	the
Disable	Forcing	button	to	disable	forcing	and	unforce	all	forced
I/O	variable	values.	Use	the	Clear	Forcing	button	to	clear	forcing
on	all	I/O	variables.

Note		If	you	disable	forcing	and	then	enable	forcing	again,	all
previously-forced	I/O	variables	return	to	their	last	forced	value,
unless	you	have	cleared	those	values	using	the	Clear	Forcing
button.
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Forcing	I/O	Variable	Values
Complete	the	following	steps	to	force	and	unforce	I/O	variable	values.

1.	 Click	an	I/O	variable	in	the	system	tree	to	display	an	I/O	variable
probe	in	the	Auto	View	or	right-click	an	I/O	variable	and	select
Probe	to	display	an	I/O	variable	probe	in	a	separate	window.

2.	 In	the	New	Value	section	of	the	I/O	variable	probe,	enter	or
select	the	new	value	for	the	I/O	variable.

3.	 Click	the	Force	button	to	force	the	I/O	variable	to	the	value	you
specified.

4.	 Click	the	Unforce	button	to	unforce	the	I/O	variable	value.
Note		Individual	I/O	variable	forcing	applies	only	if	forcing	is
enabled	on	the	target.	Use	the	Enable	Forcing	and	Disable
Forcing	buttons	to	enable	and	disable	forcing	on	the	target.



Batch	Forcing	I/O	Variable	Values
Complete	the	following	steps	to	perform	batch	forcing	on	a	set	of	I/O
variables.

1.	 Disable	forcing	on	the	target.
2.	 Force	each	I/O	variable	to	the	desired	value.
3.	 Enable	forcing	on	the	target.



Viewing	and	Setting	the	Scan	Engine	Mode	(NI
Scan	Engine)
You	can	use	the	Scan	Engine	page	of	a	target	probe	to	view	and	set	the
scan	engine	mode	of	a	target	with	the	NI	Scan	Engine	installed.
Complete	the	following	steps	to	view	and	set	the	scan	engine	mode.

1.	 Click	a	scan-enabled	target	in	the	system	tree	to	display	a	target
probe	in	the	Auto	View.	You	also	can	right-click	a	target	and
select	Probe	to	display	a	target	probe	in	a	separate	window.

2.	 The	Scan	Engine	page	of	a	target	probe	displays	scan	engine
modes	under	the	Scan	Engine	Enabled	LED	indicator	and
highlights	the	current	scan	engine	mode	with	a	green	LED
indicator.

3.	 Use	the	Change	to	Config	button	to	set	the	scan	engine	mode
to	Config	Mode	or	the	Change	to	Active	button	to	set	the	scan
engine	mode	to	Active	Mode.	You	cannot	enter	Active	Mode
directly	from	Fault	Mode.	You	must	first	clear	all	major	faults	on
the	target.

Note		Entering	Config	Mode	from	Fault	Mode	automatically
converts	all	major	faults	to	minor	faults.	You	cannot	enter	fault
mode	manually.	The	target	enters	fault	mode	only	when	a	major	or
unrecoverable	fault	occurs.
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Monitoring	RT	Target	Resources	(Real-Time
Module)
Use	the	CPU/Memory	page	of	an	RT	target	probe	to	monitor	the	CPU
and	memory	resources	of	an	RT	target.
Complete	the	following	steps	to	monitor	the	CPU	and	memory	resources
of	an	RT	target.

1.	 Click	an	RT	target	in	the	system	tree	to	display	a	target	probe	in
the	Auto	View.	You	also	can	right-click	a	target	and	select	Probe
to	display	a	target	probe	in	a	separate	window.

2.	 Click	the	CPU/Memory	tab	to	display	CPU	and	memory
statistics.

The	System	Manager	displays	a	CPU	chart	for	each	CPU	in	the	system,
labeled	by	CPU	index.	Each	graph	tracks	the	utilization	of	the	CPU,	as	a
percentage	of	capacity,	over	time.	For	each	CPU,	the	System	Manager
also	displays	the	percentage	of	total	CPU	utilization	devoted	to	each
priority	level,	as	well	as	the	percentage	devoted	to	interrupt	service
routines	(ISRs)	and	Timed	Structures.	The	System	Manager	also
displays	a	Memory	chart	that	tracks	memory	usage,	in	megabytes,	over
time.



Viewing	and	Clearing	Faults	(NI	Scan	Engine)
You	can	view	and	clear	faults	on	a	target	with	the	NI	Scan	Engine
installed.	Complete	the	following	steps	to	view	and	clear	faults.

1.	 Click	a	scan-enabled	target	in	the	system	tree	to	display	a	target
probe	in	the	Auto	View.	You	also	can	right-click	a	target	and
select	Probe	to	display	a	target	probe	in	a	separate	window.	The
Scan	Engine	page	of	the	target	probe	displays	the	faults	active
on	the	target	in	a	table	that	includes	the	fault	code	and
description.	The	Fault	Present	LED	indicator	appears	black
when	no	fault	is	present,	orange	when	only	minor	faults	are
present,	and	red	when	major	or	unrecoverable	faults	are	present.

2.	 Click	the	Clear	Faults	button	to	clear	all	faults	on	the	target.
3.	 To	ensure	that	you	successfully	cleared	all	faults	on	the	target,

check	the	Fault	Present	LED	indicator.
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Monitoring	and	Editing	Data	Item	Ranges
Complete	the	following	steps	to	monitor	and	edit	data	items	by	using	the
Probe	view	or	Auto	View.

Note		You	cannot	monitor	or	edit	extended	data	items	or	array
data	items	in	the	NI	System	Manager.

1.	 In	the	system	tree,	right-click	a	data	item	range	and	select	Probe
from	the	shortcut	menu	to	create	a	Probe	view.	The	Probe	view
displays	detailed	information	about	the	data	item	range.

2.	 In	the	Change	item	text	box,	enter	the	data	item	that	you	want	to
monitor	or	edit.

3.	 Click	the	Apply	button	to	display	the	value	of	the	data	item.
4.	 Enter	the	new	value	of	the	data	item	in	the	New	Value	section.
5.	 Click	the	Set	button	to	apply	the	new	value	to	the	data	item.
Note		You	also	can	click	the	Auto	View	to	display	the	detailed
information.



Monitoring	Data	Items	in	Data	Item	Ranges
Complete	the	following	steps	to	create	a	new	Watch	List	view	for	data
item	ranges	or	add	a	data	item	range	to	an	existing	Watch	List	view.

1.	 In	the	system	tree,	right-click	a	data	item	range	and	select	Watch
List	from	the	shortcut	menu.	The	System	Manager	displays	the
Add	Item	to	Watch	List	dialog	box.	You	also	can	drag	a	data
item	to	an	existing	Watch	List	view	to	display	this	dialog	box.

2.	 In	the	Items	from	range	text	box,	enter	the	data	item	to	monitor.
3.	 Click	the	OK	button	to	create	a	watch	list	for	the	data	item.
Note		You	can	create	a	Watch	List	view	for	multiple	data	item
ranges	or	multiple	system	tree	objects	that	include	data	item
ranges.	You	also	can	add	these	system	tree	objects	to	an	existing
Watch	List	view.	When	you	create	a	Watch	List	view	for	these
system	tree	objects	or	add	these	system	tree	objects	to	an	existing
Watch	List	view,	the	Add	Item	to	Watch	List	dialog	box	does	not
appear.	The	System	Manager	adds	the	first	data	items	of	the	data
item	ranges	by	default.
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Warranty
The	media	on	which	you	receive	National	Instruments	software	are
warranted	not	to	fail	to	execute	programming	instructions,	due	to	defects
in	materials	and	workmanship,	for	a	period	of	90	days	from	date	of
shipment,	as	evidenced	by	receipts	or	other	documentation.	National
Instruments	will,	at	its	option,	repair	or	replace	software	media	that	do	not
execute	programming	instructions	if	National	Instruments	receives	notice
of	such	defects	during	the	warranty	period.	National	Instruments	does	not
warrant	that	the	operation	of	the	software	shall	be	uninterrupted	or	error
free.
A	Return	Material	Authorization	(RMA)	number	must	be	obtained	from
the	factory	and	clearly	marked	on	the	outside	of	the	package	before	any
equipment	will	be	accepted	for	warranty	work.	National	Instruments	will
pay	the	shipping	costs	of	returning	to	the	owner	parts	which	are	covered
by	warranty.
National	Instruments	believes	that	the	information	in	this	document	is
accurate.	The	document	has	been	carefully	reviewed	for	technical
accuracy.	In	the	event	that	technical	or	typographical	errors	exist,
National	Instruments	reserves	the	right	to	make	changes	to	subsequent
editions	of	this	document	without	prior	notice	to	holders	of	this	edition.
The	reader	should	consult	National	Instruments	if	errors	are	suspected.
In	no	event	shall	National	Instruments	be	liable	for	any	damages	arising
out	of	or	related	to	this	document	or	the	information	contained	in	it.
EXCEPT	AS	SPECIFIED	HEREIN,	NATIONAL	INSTRUMENTS	MAKES
NO	WARRANTIES,	EXPRESS	OR	IMPLIED,	AND	SPECIFICALLY
DISCLAIMS	ANY	WARRANTY	OF	MERCHANTABILITY	OR	FITNESS
FOR	A	PARTICULAR	PURPOSE.	CUSTOMER'S	RIGHT	TO	RECOVER
DAMAGES	CAUSED	BY	FAULT	OR	NEGLIGENCE	ON	THE	PART	OF
NATIONAL	INSTRUMENTS	SHALL	BE	LIMITED	TO	THE	AMOUNT
THERETOFORE	PAID	BY	THE	CUSTOMER.	NATIONAL
INSTRUMENTS	WILL	NOT	BE	LIABLE	FOR	DAMAGES	RESULTING
FROM	LOSS	OF	DATA,	PROFITS,	USE	OF	PRODUCTS,	OR
INCIDENTAL	OR	CONSEQUENTIAL	DAMAGES,	EVEN	IF	ADVISED	OF
THE	POSSIBILITY	THEREOF.	This	limitation	of	the	liability	of	National
Instruments	will	apply	regardless	of	the	form	of	action,	whether	in
contract	or	tort,	including	negligence.	Any	action	against	National
Instruments	must	be	brought	within	one	year	after	the	cause	of	action



accrues.	National	Instruments	shall	not	be	liable	for	any	delay	in
performance	due	to	causes	beyond	its	reasonable	control.	The	warranty
provided	herein	does	not	cover	damages,	defects,	malfunctions,	or
service	failures	caused	by	owner's	failure	to	follow	the	National
Instruments	installation,	operation,	or	maintenance	instructions;	owner's
modification	of	the	product;	owner's	abuse,	misuse,	or	negligent	acts;
and	power	failure	or	surges,	fire,	flood,	accident,	actions	of	third	parties,
or	other	events	outside	reasonable	control.



Copyright
Under	the	copyright	laws,	this	publication	may	not	be	reproduced	or
transmitted	in	any	form,	electronic	or	mechanical,	including	photocopying,
recording,	storing	in	an	information	retrieval	system,	or	translating,	in
whole	or	in	part,	without	the	prior	written	consent	of	National	Instruments
Corporation.
In	regards	to	components	that	use	Citadel	5,	the	following	copyright
applies.	Copyright	©	1994	Hewlett-Packard	Company.	Permission	to	use,
copy,	modify,	distribute	and	sell	this	software	and	its	documentation	for
any	purpose	is	hereby	granted	without	fee,	provided	that	the	above
copyright	notice	appears	in	all	copies	and	that	both	that	copyright	notice
and	this	permission	notice	appear	in	supporting	documentation.	Hewlett-
Packard	Company	makes	no	representations	about	the	suitability	of	this
software	for	any	purpose.	It	is	provided	"as	is"	without	express	or	implied
warranty.
National	Instruments	respects	the	intellectual	property	of	others,	and	we
ask	our	users	to	do	the	same.	NI	software	is	protected	by	copyright	and
other	intellectual	property	laws.	Where	NI	software	may	be	used	to
reproduce	software	or	other	materials	belonging	to	others,	you	may	use
NI	software	only	to	reproduce	materials	that	you	may	reproduce	in
accordance	with	the	terms	of	any	applicable	license	or	other	legal
restriction.



Trademarks
National	Instruments,	NI,	ni.com,	and	LabVIEW	are	trademarks	of
National	Instruments	Corporation.	Refer	to	the	Terms	of	Use	section	on
ni.com/legal	for	more	information	about	National	Instruments	trademarks.
FireWire®	is	the	registered	trademark	of	Apple	Computer,	Inc.
Handle	Graphics®,	MATLAB®,	Real-Time	Workshop®,	Simulink®,
Stateflow®,	and	xPC	TargetBox®	are	registered	trademarks,	and
TargetBox™	and	Target	Language	Compiler™	are	trademarks	of	The
MathWorks,	Inc.
Tektronix®	and	Tek	are	registered	trademarks	of	Tektronix,	Inc.
The	Bluetooth®	word	mark	is	a	registered	trademark	owned	by	the
Bluetooth	SIG,	Inc.
Other	product	and	company	names	mentioned	herein	are	trademarks	or
trade	names	of	their	respective	companies.
Members	of	the	National	Instruments	Alliance	Partner	Program	are
business	entities	independent	from	National	Instruments	and	have	no
agency,	partnership,	or	joint-venture	relationship	with	National
Instruments.
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Patents
For	patents	covering	National	Instruments	products,	refer	to	the
appropriate	location:	Help»Patents	in	your	software,	the	patents.txt	file	on
your	media,	or	ni.com/patents.
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WARNING	REGARDING	USE	OF	NATIONAL
INSTRUMENTS	PRODUCTS
(1)	NATIONAL	INSTRUMENTS	PRODUCTS	ARE	NOT	DESIGNED
WITH	COMPONENTS	AND	TESTING	FOR	A	LEVEL	OF	RELIABILITY
SUITABLE	FOR	USE	IN	OR	IN	CONNECTION	WITH	SURGICAL
IMPLANTS	OR	AS	CRITICAL	COMPONENTS	IN	ANY	LIFE	SUPPORT
SYSTEMS	WHOSE	FAILURE	TO	PERFORM	CAN	REASONABLY	BE
EXPECTED	TO	CAUSE	SIGNIFICANT	INJURY	TO	A	HUMAN.
(2)	IN	ANY	APPLICATION,	INCLUDING	THE	ABOVE,	RELIABILITY	OF
OPERATION	OF	THE	SOFTWARE	PRODUCTS	CAN	BE	IMPAIRED	BY
ADVERSE	FACTORS,	INCLUDING	BUT	NOT	LIMITED	TO
FLUCTUATIONS	IN	ELECTRICAL	POWER	SUPPLY,	COMPUTER
HARDWARE	MALFUNCTIONS,	COMPUTER	OPERATING	SYSTEM
SOFTWARE	FITNESS,	FITNESS	OF	COMPILERS	AND
DEVELOPMENT	SOFTWARE	USED	TO	DEVELOP	AN	APPLICATION,
INSTALLATION	ERRORS,	SOFTWARE	AND	HARDWARE
COMPATIBILITY	PROBLEMS,	MALFUNCTIONS	OR	FAILURES	OF
ELECTRONIC	MONITORING	OR	CONTROL	DEVICES,	TRANSIENT
FAILURES	OF	ELECTRONIC	SYSTEMS	(HARDWARE	AND/OR
SOFTWARE),	UNANTICIPATED	USES	OR	MISUSES,	OR	ERRORS	ON
THE	PART	OF	THE	USER	OR	APPLICATIONS	DESIGNER	(ADVERSE
FACTORS	SUCH	AS	THESE	ARE	HEREAFTER	COLLECTIVELY
TERMED	"SYSTEM	FAILURES").	ANY	APPLICATION	WHERE	A
SYSTEM	FAILURE	WOULD	CREATE	A	RISK	OF	HARM	TO
PROPERTY	OR	PERSONS	(INCLUDING	THE	RISK	OF	BODILY
INJURY	AND	DEATH)	SHOULD	NOT	BE	RELIANT	SOLELY	UPON	ONE
FORM	OF	ELECTRONIC	SYSTEM	DUE	TO	THE	RISK	OF	SYSTEM
FAILURE.	TO	AVOID	DAMAGE,	INJURY,	OR	DEATH,	THE	USER	OR
APPLICATION	DESIGNER	MUST	TAKE	REASONABLY	PRUDENT
STEPS	TO	PROTECT	AGAINST	SYSTEM	FAILURES,	INCLUDING	BUT
NOT	LIMITED	TO	BACK-UP	OR	SHUT	DOWN	MECHANISMS.
BECAUSE	EACH	END-USER	SYSTEM	IS	CUSTOMIZED	AND
DIFFERS	FROM	NATIONAL	INSTRUMENTS'	TESTING	PLATFORMS
AND	BECAUSE	A	USER	OR	APPLICATION	DESIGNER	MAY	USE
NATIONAL	INSTRUMENTS	PRODUCTS	IN	COMBINATION	WITH
OTHER	PRODUCTS	IN	A	MANNER	NOT	EVALUATED	OR
CONTEMPLATED	BY	NATIONAL	INSTRUMENTS,	THE	USER	OR



APPLICATION	DESIGNER	IS	ULTIMATELY	RESPONSIBLE	FOR
VERIFYING	AND	VALIDATING	THE	SUITABILITY	OF	NATIONAL
INSTRUMENTS	PRODUCTS	WHENEVER	NATIONAL	INSTRUMENTS
PRODUCTS	ARE	INCORPORATED	IN	A	SYSTEM	OR	APPLICATION,
INCLUDING,	WITHOUT	LIMITATION,	THE	APPROPRIATE	DESIGN,
PROCESS	AND	SAFETY	LEVEL	OF	SUCH	SYSTEM	OR
APPLICATION.



Technical	Support	and	Professional	Services
Visit	the	following	sections	of	the	award-winning	National	Instruments
Web	site	at	ni.com	for	technical	support	and	professional	services:

Support—Technical	support	resources	at	ni.com/support	include
the	following:

Self-Help	Resources—For	answers	and	solutions,	visit
ni.com/support	for	software	drivers	and	updates,	a
searchable	KnowledgeBase,	product	manuals,	step-by-
step	troubleshooting	wizards,	thousands	of	example
programs,	tutorials,	application	notes,	instrument	drivers,
and	so	on.	Registered	users	also	receive	access	to	the	NI
Discussion	Forums	at	ni.com/forums.	NI	Applications
Engineers	make	sure	every	question	submitted	online
receives	an	answer.
Standard	Service	Program	Membership—This
program	entitles	members	to	direct	access	to	NI
Applications	Engineers	via	phone	and	email	for	one-to-
one	technical	support,	as	well	as	exclusive	access	to	on
demand	training	modules	via	the	Services	Resource
Center.	NI	offers	complementary	membership	for	a	full
year	after	purchase,	after	which	you	may	renew	to
continue	your	benefits.
For	information	about	other	technical	support	options	in
your	area,	visit	ni.com/services	or	contact	your	local	office
at	ni.com/contact.

Training	and	Certification—Visit	ni.com/training	for	self-paced
training,	eLearning	virtual	classrooms,	interactive	CDs,	and
Certification	program	information.	You	also	can	register	for
instructor-led,	hands-on	courses	at	locations	around	the	world.
System	Integration—If	you	have	time	constraints,	limited	in-
house	technical	resources,	or	other	project	challenges,	National
Instruments	Alliance	Partner	members	can	help.	To	learn	more,
call	your	local	NI	office	or	visit	ni.com/alliance.

If	you	searched	ni.com	and	could	not	find	the	answers	you	need,	contact
your	local	office	or	NI	corporate	headquarters.	You	also	can	visit	the
Worldwide	Offices	section	of	ni.com/niglobal	to	access	the	branch	office
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Web	sites,	which	provide	up-to-date	contact	information,	support	phone
numbers,	email	addresses,	and	current	events.



JavaScript	Disabled
The	HTML	file	you	are	trying	to	access	uses	JavaScript.
(Windows)	If	you	are	viewing	the	file	from	your	computer	or	from	a	CD
and	you	have	Internet	Explorer	4.0	or	later	installed,	JavaScript	is
enabled	by	default.	If	you	are	viewing	the	file	from	a	network,	such	as	on
an	intranet	or	on	the	Web,	or	if	you	do	not	have	Internet	Explorer	4.0	or
later	installed,	you	must	enable	JavaScript	to	view	the	file.



NI	ACL	Configuration	Dialog	Box
Installed	With:	NI	Distributed	System	Manager	(Windows)
Select	Actions»Configure	Security	in	the	System	Manager	to	display
this	dialog	box.	Use	this	dialog	box	to	update	the	security	settings	for	the
System	Manager.
This	dialog	box	includes	the	following	components:

User	or	group	names—Lists	the	users	or	groups	for	which	you
want	to	configure	security	settings.
Add—Displays	the	Add	New	Host/User	dialog	box,	which	you
can	use	to	add	users	or	groups	to	the	User	or	group	names	list.
Remove—Removes	the	selected	users	or	groups	from	the	User
or	group	names	list.
Permissions—Displays	the	permission	settings	for	the	currently
selected	user	or	group.
Grant—Grants	the	selected	user	or	group	access	to	the	selected
permission	in	the	Permissions	table.	If	you	do	not	specifically
grant	or	deny	a	user	permission,	by	default,	the	user	is	denied
that	permission.
Deny—Denies	the	selected	user	or	group	access	to	the	selected
permission	in	the	Permissions	table.	If	you	do	not	specifically
grant	or	deny	a	user	permission,	by	default,	the	user	is	denied
that	permission.

To	reset	security	settings	for	System	Manager,	remove	the	SysMan
ACL.acl	file	from	the	default	LabVIEW	Data	directory.



Alias	Manager	Dialog	Box
Installed	With:	NI	Distributed	System	Manager	(Windows)
Select	Actions»Alias	Manager	in	the	System	Manager	to	display	this
dialog	box.	Use	this	dialog	box	to	map	targets	to	IP	addresses.	(DSC
Module)	The	Shared	Variable	Engine	uses	aliases	when	running	custom
I/O	servers	that	refer	to	other	variables	in	the	system.
This	dialog	box	includes	the	following	components:

Add—Adds	an	alias	to	the	System	Manager.	You	must	specify	an
IP	address	to	create	an	alias.
Edit—Edits	the	name	or	IP	address	for	the	currently	selected
alias.
Remove—Deletes	an	alias	from	the	alias	list.
Import—Imports	aliases	saved	in	a	LabVIEW	.aliases	file.
LabVIEW	creates	the	file	automatically	when	you	create	a
LabVIEW	project.
Alias—Lists	the	aliases	you	create.



CPU/Memory	Probe	View
Installed	With:	NI	Scan	Engine
Select	an	RT	target	to	display	a	target	probe	in	the	Auto	View.	You	also
can	right-click	the	target	and	select	Probe	to	display	the	probe	in	a
separate	window.	Click	the	CPU/Memory	tab	of	an	RT	target	probe	to
display	this	view.	Use	this	view	to	monitor	CPU	and	memory	usage	on
the	target.
This	view	includes	the	following	components:

CPU	N	Usage	Chart	(%)—Tracks	utilization	of	CPU	N	over	time,
as	a	percentage	of	capacity.
Memory	Usage	Chart	(MB)—Tracks	target	memory	usage	over
time.
CPU	N	Statistics—Includes	current	CPU	usage	statistics
including	total	CPU	usage,	CPU	usage	by	priority	level,	and	CPU
usage	dedicated	to	Timed	Structures	and	interrupt	service
routines	(ISRs).	Each	value	represents	a	percentage	of	total
capacity.
Memory	Statistics—Displays	current	memory	usage	data.

Allocated—The	amount	of	memory,	in	MB,	currently
allocated	on	the	target.
Available—The	amount	of	memory,	in	MB,	currently
available	on	the	target.
Contiguous—The	largest	contiguous	block	of	available
memory	on	the	target,	in	MB.
Total—The	total	amount	of	memory	available	to	the
operating	system,	in	MB.
Usage—The	percentage	of	total	memory	currently
allocated	on	the	target.



I/O	Variable	Probe	View
Installed	With:	NI	Scan	Engine
Click	an	I/O	variable	in	the	system	tree	to	display	this	view	in	the	Auto
View.	You	also	can	right-click	an	I/O	variable	and	select	Probe	to	display
this	view	in	a	separate	window.
This	view	displays	the	location	of	an	I/O	variable	and	allows	you	to	view
or	customize	the	following	components:

Location—Specifies	the	location	of	the	item	you	want	to	probe.
To	probe	a	variable,	for	example,	enter	the	information	in	the
following	format:	//SystemName/Process/Variable.
Current	Value—Displays	the	current	value	of	the	selected
variable.
New	Value—Allows	you	to	enter	a	new	value	to	assign	to	the
variable.
Force—Forces	the	variable	to	assume	New	Value	until	you
unforce	the	variable	or	force	the	variable	to	assume	another	New
Value.
Unforce—Stops	forcing	the	variable	and	returns	control	of	the
I/O	value	to	the	scan	engine.
Set—Sets	the	value	in	the	New	Value	field	as	the	current	value.
Show	Trend—Displays	the	trend	view	graph	of	the	selected
variable.
Data	Type—Displays	the	data	type	of	the	selected	variable.
Timestamp—Displays	the	timestamp	of	the	selected	variable.
Quality—Displays	the	quality	of	the	selected	variable.	The	quality
indicates	errors	or	other	conditions	that	apply	to	the	variable.
Access	Type—Displays	the	supported	access	mode(s)	of	the
variable.	This	includes	Read-only,	Write-only,	or	Read/Write.
LabVIEW	modules	and	toolkits	you	have	installed	might	provide
additional	access	types.
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Process	Probe	View
Installed	With:	NI	Distributed	System	Manager	(Windows)
Right-click	a	process	and	select	Probe	from	the	shortcut	menu	to	display
this	view.	This	view	shows	the	status	of	the	selected	process	and	allows
you	to	start	or	stop	that	process.
This	view	includes	the	following	components:

Location—Displays	the	location	of	the	selected	process.
State—Displays	whether	the	process	is	online	or	offline,	or
displays	if	you	do	not	have	sufficient	access	privileges	to	modify
the	state.
Start	Process—Starts	the	selected	process.	You	must	have
sufficient	access	privileges	to	start	a	process.
Stop	Process—Stops	the	selected	process.	You	must	have
sufficient	access	privileges	to	stop	a	process.



Scan	Engine	Probe	View
Installed	With:	NI	Scan	Engine
Select	a	target	with	the	NI	Scan	Engine	installed	to	display	this	view	in
the	Auto	View.	You	also	can	right-click	the	target	and	select	Probe	to
display	this	view	in	a	separate	window.	Use	this	view	to	monitor	and
manage	the	scan	engine	running	on	the	target.
This	view	includes	the	following	components:

Forcing—Contains	information	and	options	related	to	I/O
variable	forcing.

Forcing	Enabled—Indicates	whether	I/O	variable	forcing
is	enabled	on	the	target.
Enable	Forcing—(Appears	when	forcing	is	disabled)
Enables	I/O	variable	forcing	on	the	target.	This	option	is
available	only	when	I/O	variable	forcing	is	disabled.
Disable	Forcing—Disables	forcing	for	all	I/O	variables
and	I/O	aliases	on	the	target.	Unless	you	clear	forcing,
the	previous	forced	value	returns	when	you	re-enable
forcing.	This	option	is	available	only	when	I/O	variable
forcing	is	enabled.
Clear	Forcing—Disables	forcing	and	clears	forcing
values	for	all	I/O	variables	and	I/O	aliases	on	the	target.

Faults—Contains	information	and	options	related	to	scan	engine
faults.

Fault	Present—Indicates	the	presence	of	faults	on	the
target.	The	LED	appears	black	when	no	fault	is	present,
orange	when	only	minor	faults	are	present,	and	red	when
major	or	unrecoverable	faults	are	present.
Clear	All	Faults—Clears	all	faults	on	the	target.	If	the
target	is	in	Fault	mode,	clearing	all	faults	returns	the
target	to	the	previous	mode	in	effect	before	entering	Fault
Mode.
Clear	Selected	Fault—Clears	the	fault	currently	selected
in	the	Fault	List.	If	no	fault	is	currently	selected,	no	action
occurs.
Fault	List—Lists	the	faults	active	on	the	target.
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Error	Code—The	error	code	associated	with	the
fault.
Highest	Level—The	highest	level	of	the	fault
since	last	cleared.
First	Occurrence—The	time	of	the	first
occurrence	of	the	fault	since	last	cleared.
Num	of	Occurrences—The	number	of
occurrences	of	the	fault	since	last	cleared.
Description—The	fault	description.

Scan	Engine	Mode—Contains	information	and	options	related	to
the	mode	of	the	NI	Scan	Engine	on	the	target.

Note		This	section	is	available	only	with	expansion	I/O
hardware.	This	section	is	not	available	if	only	local	I/O
drivers	are	installed	on	the	target.	Refer	to	the	I/O
hardware	documentation	for	information	about	hardware-
specific	mode	behavior.
Configuration—Indicates	whether	the	scan	engine	is	in
Configuration	mode.
Active—Indicates	whether	the	scan	engine	is	in	Active
mode.
Fault—Indicates	whether	the	scan	engine	is	in	Fault
mode.
I/O	Drivers—Lists	the	I/O	drivers	installed	on	the	target
that	interface	with	the	NI	Scan	Engine.
Change	to	Configuration—Switches	the	scan	engine	to
Configuration	mode.	If	the	target	was	previously	in	Fault
mode,	switching	to	Configuration	mode	automatically
changes	the	level	of	all	active	major	faults	to	minor.
Change	to	Active—Switches	the	scan	engine	to	Active
mode.	You	cannot	switch	directly	to	Active	mode	from
Fault	mode.	You	must	clear	all	major	faults	to	leave	Fault
mode	before	you	can	switch	to	Active	mode.

Refresh	Local	Modules—Scans	the	target	for	new	local	I/O
modules.	If	a	new	local	I/O	module	is	detected,	System	Manager
adds	the	new	I/O	module	under	the	target	in	the	system	tree.	If
you	remove	a	previously	detected	local	I/O	module	from	the
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target,	you	must	undeploy	the	module	from	the	LabVIEW	project
before	refreshing	can	remove	the	module	from	the	system	tree.



Variable	Probe	View
Installed	With:	NI	Distributed	System	Manager	(Windows)
Right-click	a	variable	and	select	Probe	from	the	shortcut	menu	to	display
this	view.	This	view	displays	the	location	of	the	selected	shared	or
network	variable	and	allows	you	to	view	or	customize	aspects	of	that
variable.
This	view	includes	the	following	components:

Location—Displays	the	location	of	the	selected	variable.
Current	Value—Displays	the	current	value	of	the	selected
variable.
New	Value—Allows	you	to	enter	a	new	value	to	assign	to	the
variable.
Set—Sets	the	value	in	the	New	Value	field	as	the	current	value.
Show	Trend—Displays	the	trend	view	graph	of	the	selected
variable.
Data	Type—Displays	the	data	type	of	the	selected	variable.
Timestamp—Displays	the	timestamp	of	the	selected	variable.
Quality—Displays	the	quality	of	the	selected	variable.	The	quality
indicates	errors	or	other	conditions	that	apply	to	the	variable.
Access	Type—Displays	the	supported	access	mode(s)	of	the
variable.	This	includes	Read-only,	Write-only,	or	Read/Write.
LabVIEW	modules	and	toolkits	you	have	installed	might	provide
additional	access	types.



Web	Server	Probe	View
Installed	With:	NI	Distributed	System	Manager	(Windows)
Right-click	a	Web	Server	and	select	Probe	from	the	shortcut	menu	to
display	this	view.	This	view	displays	Web	services	available	on	the	Web
Server.	You	can	pause,	resume,	restart,	delete,	or	reset	statistics	for	one
or	all	of	the	available	Web	services.	Refer	to	the	LabVIEW	Help	for
information	about	LabVIEW	Web	services	and	related	terminology.
This	view	includes	the	following	components:

Location—Displays	the	location	of	the	selected	Web	Server.
Deployed	Web	Services—Displays	a	listbox	of	all	Web	services
available	on	the	Web	Server.

Operations	on	selected—Displays	components	that
perform	operations	on	the	selected	Web	service.

Pause—Pauses	the	selected	Web	service.
Resume—Resumes	the	selected	Web	service.
Restart—Restarts	the	selected	Web	service.
Reset	Statistics—Resets	all	statistical	variables
for	the	selected	Web	service.
Delete—Removes	the	selected	Web	service	from
the	Web	Server.

Operations	on	all—Displays	components	that	perform
operations	on	all	Web	services	on	the	Web	Server.

Pause	All—Pauses	all	Web	services	on	the	Web	Server.
Resume	All—Resumes	all	Web	services	on	the	Web
Server.
Restart	All—Restarts	all	Web	services	on	the	Web
Server.
Reset	All	Statistics—Resets	statistical	variables	for	all
Web	services	on	the	Web	Server.



Web	Service	Probe	View
Installed	With:	NI	Distributed	System	Manager	(Windows)
Right-click	a	Web	service	and	select	Probe	from	the	shortcut	menu	to
display	this	view.	This	view	displays	the	state	of	the	selected	Web	service
and	allows	you	to	pause,	resume,	restart,	or	reset	statistics	for	the	Web
service.	You	also	can	send	HTTP	requests	to	the	Web	service	using
available	URL	mappings.	Refer	to	the	LabVIEW	Help	for	information
about	LabVIEW	Web	services	and	related	terminology.
This	view	includes	the	following	components:

Location—Displays	the	location	of	the	selected	Web	Service.
State—Displays	whether	the	Web	service	is	running	or	paused.
Pause—Pauses	the	selected	Web	service.
Resume—Resumes	the	selected	Web	service.
Restart—Restarts	the	selected	Web	service.
Reset	Statistics—Resets	all	statistical	variables	for	the	selected
Web	service.
URL	Mappings—Displays	a	listbox	of	available	URL	Mappings
for	the	selected	Web	service.

Run	Selected—Displays	the	Web	Server	URL	Mapping
view	for	the	selected	URL	mapping.
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Settings	Dialog	Box
Installed	With:	NI	Distributed	System	Manager
Select	File»Settings	to	display	this	dialog	box.	This	dialog	box	provides
options	to	customize	workspace	layout,	set	the	Data	Update	Rate,	and
specify	whether	the	System	Manager	saves	its	workspace	between
sessions.
This	dialog	box	includes	the	following	components:

Show	Value	Column—Displays	the	Value	column	in	the	System
Manager	tree.
Show	Type	Column—Displays	the	Type	column	in	the	System
Manager	tree.
Show	Access	Column—Displays	the	Access	column	in	the
System	Manager	tree.
Show	MXS	Column—Displays	the	MXS	column	in	the	System
Manager	tree.
Show	Location	Column—Displays	the	Location	column	in	the
System	Manager	tree.
Data	Update	Rate—Specifies	the	frequency	with	which	the
System	Manager	will	update	data.
Save	Workspace	Between	Sessions—Specifies	whether	to
save	any	workspace	customizations	when	you	close	your
session.



NI	Security	Login	Dialog	Box
Installed	With:	NI	Distributed	System	Manager	(Windows)
Select	Actions»Log	In	to	display	this	dialog	box.
Use	this	dialog	box	to	log	into	System	Manager	and	allow	configuration	of
components	on	protected	systems.	By	default,	System	Manager	does	not
require	you	to	log	in	when	configuring	components	such	as	systems	and
variables.	You	must	log	in	when	working	with	a	system	that	requires
authorization	before	you	can	modify	its	components.
This	dialog	box	contains	the	following	components:

User	name—Specifies	the	name	of	the	current	user.
Password—Specifies	the	password	for	the	current	user.
NI	domain—Specifies	the	domain	to	which	the	current	user
wants	to	log	in.



Add	System	to	My	Systems	Dialog	Box
Installed	With:	NI	Distributed	System	Manager	(Windows)
Select	Actions»Add	System	to	My	Systems	to	display	this	dialog	box.
This	dialog	box	allows	you	to	access	systems	outside	your	local
subnetwork	that	do	not	appear	in	the	system	tree.
This	dialog	box	includes	the	following	components:

System—Specifies	the	location	(\\examplesystem)	for	the	system
you	want	to	add.



Probe	Location	Dialog	Box
Installed	With:	NI	Distributed	System	Manager	(Windows)
Select	View»Probe	Location	to	display	this	dialog	box.	You	can	enter
the	location	of	system	tree	objects	that	appear	in	the	system	tree,	as	well
as	remote	locations	of	objects	that	do	not	appear	in	the	system	tree,	to
display	the	Probe	view	for	the	specified	system	tree	object.
This	dialog	box	includes	the	following	components:

Location—Specifies	the	location	of	the	item	you	want	to	probe.
To	probe	a	variable,	for	example,	enter	the	information	in	the
following	format:	//SystemName/Process/Variable.



Add	Process	Dialog	Box
Installed	With:	NI	Distributed	System	Manager	(Windows)
Right-click	a	system	on	the	system	tree	and	select	Add	Process	from
the	shortcut	menu	to	display	this	dialog	box.	Use	the	Add	Process	dialog
box	to	create	a	new	process	on	the	selected	system	in	the	system	tree.
This	dialog	box	includes	the	following	components:

Process	Name—Specifies	the	name	of	the	new	process.
Run—Specifies	whether	to	run	the	process	or	keep	it	offline
when	you	create	it.



Shared	Variable	Properties	Dialog	Box
Installed	With:	NI	Distributed	System	Manager	(Windows)
Right-click	a	process	in	the	system	tree	and	select	Add	Variable	from	the
shortcut	menu,	or	right-click	an	existing	shared	or	network	variable	in	the
system	tree	and	select	Edit	Variable	from	the	shortcut	menu	to	display
this	dialog	box.
Use	this	dialog	box	to	configure	a	new	shared	or	network	variable	or	edit
the	configuration	of	an	existing	variable.
Use	the	selections	in	the	left	pane	of	this	dialog	box	to	access	variable
configuration	options:

Variable—Determines	the	basic	configuration	of	the	variable,
including	the	data	type	and	variable	type.
Alarming—(DSC	Module)	Configures	alarming	options	for	the
shared	variable.
Description—	Specifies	a	description	for	the	shared	variable.
Logging—(DSC	Module)	Configures	logging	options	for	the
shared	variable.
Network—Configures	network	options	such	as	buffering	for	the
shared	variable.
Real-Time	FIFO—(RT	Module)	Enables	and	configures	the	real-
time	FIFO	of	a	shared	variable.
Scaling—Configures	scaling	options	for	the	shared	variable.
Update	Deadband—(DSC	Module)	Configures	the	deadband
options	for	the	shared	variable.
Initial	Value—(DSC	Module)	Configures	the	initial	value	for	the
shared	variable.
Security—(DSC	Module)	Configures	the	security	options	for	the
shared	variable.

LabVIEW	modules	and	toolkits	you	have	installed	might	provide
additional	shared	variable	types,	configuration	options,	and	limitations.
Refer	to	the	documentation	for	the	LabVIEW	module	or	toolkit	for	more
information.
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Create	New	I/O	Server	Dialog	Box
Installed	With:	NI	Distributed	System	Manager	(Windows)
Right-click	a	process	and	select	Add	I/O	Server	from	the	shortcut	menu
to	display	this	dialog	box.	Use	this	dialog	box	to	create	an	I/O	server.
(RT	Module)	You	can	create	Modbus	I/O	servers	and	ModbusSlave	I/O
servers.
This	dialog	box	includes	the	following	components:

I/O	Server	Type—Contains	a	list	of	I/O	servers	you	can	create.
Description—Displays	a	description	of	the	IP	generator	you
select	from	the	Select	IP	Generator	list.
Continue—Displays	the	Configuration	dialog	box	for	the
selected	I/O	server.



Branch	Offices
Office Telephone	Number
Australia 1800	300	800
Austria 43	662	457990-0
Belgium 32	(0)	2	757	0020
Brazil 55	11	3262	3599
Canada 800	433	3488
China 86	21	5050	9800
Czech	Republic 420	224	235	774
Denmark 45	45	76	26	00
Finland 358	(0)	9	725	72511
France 33	(0)	1	57	66	24	24
Germany 49	89	7413130
India 91	80	41190000
Israel 972	0	3	6393737
Italy 39	02	41309277
Japan 0120-527196	/	81	3	5472	2970
Korea 82	02	3451	3400
Lebanon 961	(0)	1	33	28	28
Malaysia 1800	887710
Mexico 01	800	010	0793
Netherlands 31	(0)	348	433	466
New	Zealand 0800	553	322
Norway 47	(0)	66	90	76	60
Poland 48	22	3390150
Portugal 351	210	311	210
Russia 7	495	783	6851
Singapore 1800	226	5886
Slovenia 386	3	425	42	00



South	Africa 27	0	11	805	8197
Spain 34	91	640	0085
Sweden 46	(0)	8	587	895	00
Switzerland 41	56	2005151
Taiwan 886	02	2377	2222
Thailand 662	278	6777
Turkey 90	212	279	3031
United	Kingdom 44	(0)	1635	523545
United	States	(Corporate) 512	683	0100
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