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Conventions
This	help	file	uses	the	following	formatting	and	typographical
conventions:
<	> Angle	brackets	that	contain	numbers	separated	by	an	ellipsis	represent	a	range	of	values

associated	with	a	bit	or	signal	name—for	example,	AO	<0..3>.

[	] Square	brackets	enclose	optional	items—for	example,	[response].

» The	»	symbol	leads	you	through	nested	menu	items	and	dialog	box	options	to	a	final
action.	The	sequence	File»Page	Setup»Options	directs	you	to	pull	down	the	File	menu,
select	the	Page	Setup	item,	and	select	Options	from	the	last	dialog	box.
This	icon	denotes	a	note,	which	alerts	you	to	important	information.

bold Bold	text	denotes	items	that	you	must	select	or	click	in	the	software,	such	as	menu	items
and	dialog	box	options.	Bold	text	also	denotes	parameter	names.

green Underlined	text	in	this	color	denotes	a	link	to	a	help	topic,	help	file,	or	Web	address.

italic Italic	text	denotes	variables,	emphasis,	cross	references,	or	an	introduction	to	a	key
concept.	Italic	text	also	denotes	text	that	is	a	placeholder	for	a	word	or	value	that	you	must
supply.

monospace Text	in	this	font	denotes	text	or	characters	that	you	should	enter	from	the	keyboard,
sections	of	code,	programming	examples,	and	syntax	examples.	This	font	is	also	used	for
the	proper	names	of	disk	drives,	paths,	directories,	programs,	subprograms,	subroutines,
device	names,	functions,	operations,	variables,	filenames,	and	extensions.



Navigating	Help	(Windows	Only)
To	navigate	this	help	file,	use	the	Contents,	Index,	and	Search
tabs	to	the	left	of	this	window	or	use	the	following	toolbar
buttons	located	above	the	tabs:

Hide—Hides	the	navigation	pane	from	view.
Locate—Locates	the	currently	displayed	topic	in	the
Contents	tab,	allowing	you	to	view	related	topics.
Back—Displays	the	previously	viewed	topic.
Forward—Displays	the	topic	you	viewed	before	clicking
the	Back	button.
Options—Displays	a	list	of	commands	and	viewing
options	for	the	help	file.



Searching	Help	(Windows	Only)
Use	the	Search	tab	to	the	left	of	this	window	to	locate	content
in	this	help	file.	If	you	want	to	search	for	words	in	a	certain
order,	such	as	"related	documentation,"	add	quotation	marks
around	the	search	words	as	shown	in	the	example.	Searching
for	terms	on	the	Search	tab	allows	you	to	quickly	locate	specific
information	and	information	in	topics	that	are	not	included	on
the	Contents	tab.



Wildcards
You	also	can	search	using	asterisk	(*)	or	question	mark	(?)
wildcards.	Use	the	asterisk	wildcard	to	return	topics	that	contain
a	certain	string.	For	example,	a	search	for	"prog*"	lists	topics
that	contain	the	words	"program,"	"programmatically,"
"progress,"	and	so	on.
Use	the	question	mark	wildcard	as	a	substitute	for	a	single
character	in	a	search	term.	For	example,	"?ext"	lists	topics	that
contain	the	words	"next,"	"text,"	and	so	on.

Note		Wildcard	searching	will	not	work	on	Simplified
Chinese,	Traditional	Chinese,	Japanese,	and	Korean
systems.



Nested	Expressions
Use	nested	expressions	to	combine	searches	to	further	refine	a
search.	You	can	use	Boolean	expressions	and	wildcards	in	a
nested	expression.	For	example,	"example	AND	(program	OR
VI)"	lists	topics	that	contain	"example	program"	or	"example	VI."
You	cannot	nest	expressions	more	than	five	levels.



Boolean	Expressions
Click	the	 	button	to	add	Boolean	expressions	to	a	search.	The
following	Boolean	operators	are	available:

AND	(default)—Returns	topics	that	contain	both	search
terms.	You	do	not	need	to	specify	this	operator	unless	you
are	using	nested	expressions.
OR—Returns	topics	that	contain	either	the	first	or	second
term.
NOT—Returns	topics	that	contain	the	first	term	without
the	second	term.
NEAR—Returns	topics	that	contain	both	terms	within
eight	words	of	each	other.



Search	Options

Use	the	following	checkboxes	on	the	Search	tab	to	customize	a
search:

Search	previous	results—Narrows	the	results	from	a
search	that	returned	too	many	topics.	You	must	remove
the	checkmark	from	this	checkbox	to	search	all	topics.
Match	similar	words—Broadens	a	search	to	return
topics	that	contain	words	similar	to	the	search	terms.	For
example,	a	search	for	"program"	lists	topics	that	include
the	words	"programs,"	"programming,"	and	so	on.
Search	titles	only—Searches	only	in	the	titles	of	topics.



Printing	Help	File	Topics	(Windows	Only)
Complete	the	following	steps	to	print	an	entire	book	from	the
Contents	tab:

1.	 Right-click	the	book.
2.	 Select	Print	from	the	shortcut	menu	to	display	the	Print

Topics	dialog	box.
3.	 Select	the	Print	the	selected	heading	and	all

subtopics	option.
Note		Select	Print	the	selected	topic	if	you	want
to	print	the	single	topic	you	have	selected	in	the
Contents	tab.

4.	 Click	the	OK	button.



Printing	PDF	Documents
This	help	file	may	contain	links	to	PDF	documents.	To	print	PDF
documents,	click	the	print	button	located	on	the	Adobe	Acrobat
Viewer	toolbar.



CAN	Cards
Windows	System
National	Instruments	hardware	for	the	Controller	Area	Network	(CAN)	is
used	by	both	NI-CAN	and	NI-DNET	(DeviceNet)	software.
CAN	cards	are	displayed	under	Devices	and	Interfaces	in	MAX.	All
cards	are	installed	automatically	and	are	displayed	when	MAX	refreshes
its	configuration.	You	can	refresh	MAX	by	pressing	<F5>.
Windows	automatically	assigns	the	resources	(interrupt	number	and
memory	range)	for	the	cards.



Testing	CAN	Cards
To	verify	installation	of	your	CAN	hardware,	right-click	on	the	CAN	card,
then	select	Self-test.	If	the	self	test	passes,	the	card	icon	shows	a
checkmark.	If	the	self	test	fails,	the	card	icon	shows	a	?	mark,	and	the
Test	Status	in	the	right	pane	describes	the	problem.
It	is	also	possible	to	test	all	CAN	cards	in	the	system	at	once	by	selecting
Tools»NI-DNET»Test	All	Local	Cards	in	the	main	menu.



Troubleshooting	Self	Test	Failures
The	following	sections	explain	common	error	messages	generated	by	the
Self	Test.
Application	In	Use
This	error	occurs	if	you	are	running	an	application	that	is	using	the	CAN
card.	The	self	test	aborts	to	avoid	adversely	affecting	your	application.
Before	running	the	self	test,	exit	all	applications	that	use	NI-CAN	or	NI-
DNET.	If	you	are	using	LabVIEW,	you	may	need	to	exit	LabVIEW	to
unload	the	driver.
Memory	Resource	Conflict
This	error	occurs	if	the	memory	resource	assigned	to	a	CAN	card
conflicts	with	the	memory	resources	being	used	by	other	devices	in	the
system.	Resource	conflicts	typically	occur	when	your	system	contains
legacy	boards	that	use	resources	not	properly	reserved	with	the	Device
Manager.	If	a	resource	conflict	exists,	write	down	the	memory	resource
that	caused	the	conflict	and	refer	to	the	documentation	for	your	Windows
operating	system	for	instructions	on	how	to	use	the	Device	Manager	to
reserve	memory	resources	for	legacy	boards.	After	the	conflict	has	been
resolved,	run	the	Self	Test	again.
Interrupt	Resource	Conflict
This	error	occurs	if	the	interrupt	resource	assigned	to	a	CAN	card
conflicts	with	the	interrupt	resources	being	used	by	other	devices	in	the
system.	Resource	conflicts	typically	occur	when	your	system	contains
legacy	boards	that	use	resources	not	properly	reserved	with	the	Device
Manager.	If	a	resource	conflict	exists,	write	down	the	interrupt	resource
that	caused	the	conflict	and	refer	to	the	documentation	for	your	Windows
operating	system	for	instructions	on	how	to	use	the	Device	Manager	to
reserve	interrupt	resources	for	legacy	boards.	After	the	conflict	has	been
resolved,	run	the	Self	Test	again.
NI-CAN	Software	Problem	Encountered
This	error	occurs	if	the	Self	Test	detects	that	it	is	unable	to	communicate
correctly	with	the	CAN	hardware	using	the	installed	NI-CAN	or	NI-DNET
software.	If	you	get	this	error,	shut	down	your	computer,	restart	it,	and	run



the	Self	Test	again.
If	the	error	continues	after	restart,	uninstall	NI-CAN	and	NI-DNET,	and
then	reinstall.
NI-CAN	Hardware	Problem	Encountered
This	error	occurs	if	the	Self	Test	detects	a	defect	in	the	CAN	hardware.	If
you	get	this	error,	write	down	the	numeric	code	shown	with	the	error,	and
contact	National	Instruments.



Configuring	CAN	Ports
The	physical	ports	of	each	CAN	card	are	listed	under	the	card's	name.	To
configure	software	properties	for	each	port,	right-click	on	the	port	and
select	Properties.
For	more	information	on	configuration,	refer	to	Port	Properties	Dialog
Box.
For	more	information	on	changing	the	representation	of	a	CAN	card	in
MAX	between	NI-CAN	and	NI-DNET,	refer	to	Protocol	Dialog	Box.



LabVIEW	Real-Time	(RT)	System
To	test	and	configure	CAN	cards	on	a	LabVIEW	RT	system,	use	the	RT
Hardware	Configuration	Utility	in	Tools»NI-DNET»RT	Hardware
Configuration.	The	card	and	port	configuration	in	this	utility	is	similar	to
Devices	and	Interfaces	under	Windows.	For	more	information,	refer	to
LabVIEW	RT	Configuration.



LabVIEW	Real-Time	(RT)	Configuration
LabVIEW	RT	combines	easy-to-use	LabVIEW	programming	with	the
power	of	real-time	systems.	When	you	use	a	National	Instruments	PXI
controller	as	a	LabVIEW	RT	system,	you	can	install	a	PXI	CAN	card	and
use	the	NI-CAN	and	NI-DNET	APIs	to	develop	real-time	applications.	For
example,	you	can	simulate	the	behavior	of	a	control	algorithm	within	a
CAN	device,	using	data	from	received	CAN	messages	to	generate
outgoing	CAN	messages	with	deterministic	response	times.



Hardware	Configuration
After	you	have	installed	your	PXI	CAN	cards	and	downloaded	the	NI-
CAN	and	NI-DNET	software	to	your	LabVIEW	RT	system,	you	need	to
verify	the	installation	and	assign	interface	names	to	CAN	ports.	In	the
MAX	Tools	menu,	select	NI-DNET»RT	Hardware	Configuration.
The	RT	Hardware	Configuration	tool	begins	with	a	dialog	that	requests
your	PXI	system	IP	address.	Enter	the	IP	address	from	your	original
Remote	Systems	configuration,	which	is	the	same	IP	address	that	you
use	within	LabVIEW.	After	a	connection	has	been	established
successfully,	subsequent	execution	of	the	RT	Hardware	Configuration
tool	uses	the	same	IP	address.	If	you	need	to	change	the	IP	address	to	a
different	PXI	system,	select	Server	Address	from	the	Network	menu.
Within	the	RT	Hardware	Configuration	tool,	if	you	do	not	see	the	installed
PXI	CAN	cards,	select	Refresh	from	the	View	menu.	To	perform	a	self-
test	for	all	PXI	CAN	cards,	select	Test	All	from	the	Test	menu.	The	status
for	each	card's	self-test	is	displayed	in	the	same	manner	as	the	MAX
Devices	and	Interfaces	branch	on	your	local	Windows	system.
To	assign	an	interface	name	to	each	CAN	port,	right-click	the	port	and
select	Properties.	The	resulting	properties	dialog	is	the	same	as	the	Port
Properties	Dialog	Box	on	your	local	Windows	system.



MAX	Report	Generation
Use	the	MAX	Report	Wizard	to	generate	a	report	of	the	NI-DNET
hardware	and	software	configuration	of	the	system.	The	report	includes
the	following	information.

Hardware	Information,	including	serial	number	and	board	type
Port	Properties,	including	interface	name,	location,	baud	rate,	and
interface	MAC	ID
Software	Version	Information

The	MAX	Report	Wizard	supports	both	local	and	remote	systems,	but	for
remote	systems	the	MAX	report	does	not	contain	the	Hardware
Information	or	the	Port	Properties.

mxHelp.chm::/maxmain/reportgen.html


Port	Properties	Dialog	Box
Use	this	dialog	box	to	configure	the	properties	for	a	port.



Interface
In	the	Properties	dialog,	you	assign	an	interface	name	to	the	port,	such
as	DNET0	or	DNET1.	The	interface	name	identifies	the	physical	port
within	NI-DNET	functions.
Interfaces	previously	assigned	to	other	physical	ports	are	marked	with	an
asterisk	in	the	list	box.	If	you	select	an	interface	used	by	another	port,	the
other	port	is	reassigned	to	the	first	unused	interface.



Baud	Rate
The	baud	rate	in	this	dialog	is	the	default	value	for	NI-DNET	Configurator
and	NI-DNET	Analyzer.
Use	the	Baud	Rate	drop-down	list	to	select	from	a	list	of	commonly	used
baud	rates.



Interface	MAC	ID
The	interface	MAC	ID	in	this	dialog	is	the	default	value	for	NI-DNET
Configurator.
Use	the	MAC	ID	drop-down	list	to	select	from	a	list	of	MAC	IDs.



Protocol	Dialog	Box
National	Instruments	hardware	for	Controller	Area	Network	(CAN)	is	used
by	both	NI-CAN	and	NI-DNET	(DeviceNet)	software.
You	can	view	each	CAN	card	in	MAX	with	either	DeviceNet	or	CAN
features.	To	change	the	view	of	a	CAN	card	in	MAX,	right-click	the	card
and	select	Protocol.	In	this	dialog,	you	can	select	either	DeviceNet	for
NI-DNET,	or	CAN	for	NI-CAN.
Use	of	NI-DNET	is	restricted	to	port	1	(top	port)	of	Series	1	CAN	cards.
The	Protocol	selection	is	not	available	for	Series	2	CAN	cards.	When	a
2-port	Series	1	CAN	card	is	selected	as	the	DeviceNet	protocol,	only	the
top	port	is	enabled.	For	more	information	on	hardware	in	CAN	kits	and
DeviceNet	kits,	refer	to	Chapter	2,	DeviceNet	Hardware	Overview,	in	the
NI-DNET	User	Manual.
When	you	right-click	a	port	in	MAX	and	select	Properties,	the	resulting
Interface	selection	uses	the	syntax	CANx	or	DNETx	based	on	your
protocol	selection.	Regardless	of	which	protocol	is	selected,	the	number
x	is	the	only	relevant	identifier	with	respect	to	NI-CAN	and	NI-DNET
functions.	For	example,	if	you	select	DNET0	as	an	interface	in	MAX,	you
can	run	an	NI-DNET	application	that	uses	DNET0,	then	you	can	run	an
NI-CAN	application	that	uses	CAN0.	Both	applications	refer	to	the	same
port	and	can	run	at	different	times,	but	not	simultaneously.



Introduction	to	NI-DNET	Configurator
NI-DNET	Configurator	is	a	powerful	DeviceNet	configuration	tool	with
Electronic	Data	Sheet	(EDS)	support.	It	replaces	the	previous
SimpleWho	utility.
NI-DNET	Configurator	can	search	a	DeviceNet	network	to	find
information	about	connected	devices,	load	the	related	EDS	files
automatically,	read	and	write	the	device	parameters,	and	change	a
device	MAC	ID.	The	configurator	also	helps	you	develop	DeviceNet
applications	by	providing	device	information.
For	more	information,	refer	to	the	following	sections:

Getting	Started—To	become	familiar	with	NI-DNET	Configurator,
complete	the	short	getting	started	tutorial.	To	develop	a	DeviceNet
application	right	away,	refer	to	6.	Develop	DeviceNet	Applications.
NI-DNET	Configurator	Environment—Refer	to	this	section	for
descriptions	of	the	windows,	menus,	and	toolbar.
Using	NI-DNET	Configurator—Refer	to	this	section	to	perform	a
specific	task	such	as	refreshing	the	device	list.
FAQ—Refer	to	this	section	for	answers	to	frequently	asked
questions.



1.	Launch	NI-DNET	Configurator
Complete	the	following	steps	to	launch	NI-DNET	Configurator:

1.	 Launch	Measurement	&	Automation	Explorer	(MAX).
2.	 In	MAX,	select	your	CAN	card	under	My	System»Devices	and

Interfaces.
3.	 Change	the	protocol	to	DeviceNet	by	right-clicking	the	CAN	card

and	selecting	Protocol.	(Refer	to	Protocol	Dialog	Box	for	more
information.)

4.	 Set	the	DeviceNet	interface	properties	by	right-clicking	the	port
and	selecting	Properties.	(Refer	to	Port	Properties	Dialog	Box	for
more	information.)

5.	 Launch	the	configurator	by	right-clicking	the	port	and	selecting
Configurator.

6.	 After	launch,	the	configurator	searches	all	devices	on	the	network
automatically.	A	message	box	tells	you	to	add	your	device	EDS
files.	Click	OK.	(Refer	to	What	is	EDS?	for	more	information.)

7.	 A	message	box	asks	you	whether	to	upload	or	download.	Click
Upload.	(Refer	to	Refresh	the	Device	List	for	more	information.)



2.	Add	the	EDS	Files
Complete	the	following	steps	to	add	EDS	files:

1.	 Launch	EDS	Manager	by	selecting	Tools»EDS	Manager.
2.	 Click	Add	an	EDS	file,	select	the	EDS	file,	and	click	OK.

3.	 Repeat	the	previous	step	to	add	multiple	EDS	files.
4.	 Close	EDS	Manager.
5.	 Select	Network»Refresh	the	Device	List	to	apply	the	newly

added	EDS	files.
6.	 A	message	box	asks	you	whether	to	upload	or	download.	Click

Upload.
Refer	to	What	is	EDS?	and	Manage	EDS	Files	for	more	information.



3.	Browse	the	Devices
You	now	can	browse	the	device	information.
In	the	DeviceNet	Network	window,	you	can	see	the	device	list.	Each	node
is	a	device;	the	root	node	is	the	interface	device.	For	example,	in	[03]
PRMxx,	[03]	is	the	device	MAC	ID	and	PRMxx	is	the	device	product
name.

Select	a	device	in	the	DeviceNet	Network	window,	and	you	can	see	the
device	information	in	the	Device	Information	window.

The	General	tab	shows	the	device	basic
information	and	related	EDS	file	information.
The	Parameters	tab	shows	the	parameter	list.
Select	a	parameter,	and	its	description	is	shown
in	Parameter	Information.
The	I/O	Data	tab	shows	the	device	supported
I/O	connection.	Select	an	I/O	connection,	and
its	description	is	shown	in	I/O	Information.

Refer	to	Configurator	Main	Window	and	Device	Information	Window	for
more	information.



4.	Read/Write	the	Parameters
Complete	the	following	steps	to	read	or	write	a	parameter:

1.	 Click	the	Parameters	tab	in	the	Device	Information	window.
2.	 Double-click	the	parameter.	A	View/Edit	Parameter	Value	dialog

appears.
3.	 Change	the	parameter	value	and	click	Edit.
4.	 Repeat	the	previous	two	steps	to	change	other	parameters.
5.	 Select	Device»Download	to	Device	to	download	the	changed

parameter	value	to	the	device.
6.	 To	upload	all	device	parameters,	select	Device»Upload	from

Device.
Refer	to	View/Edit	a	Parameter	Value,	Device	Information	Window,
Upload	from	Device,	and	Download	to	Device	for	more	information.



5.	Change	MAC	ID
A	MAC	ID	is	a	device	address	that	ranges	from	0	to	63.	You	may	need	to
change	a	device	MAC	ID	to	resolve	a	MAC	ID	conflict.
Complete	the	following	steps	to	change	a	device	MAC	ID:

1.	 Right-click	the	device	in	the	DeviceNet	Network	window	and
select	Change	MAC	ID.

2.	 Enter	the	new	MAC	ID	and	click	OK.
Refer	to	Change	MAC	ID	for	more	information.



6.	Develop	DeviceNet	Applications
NI-DNET	Configurator	can	help	you	develop	DeviceNet	applications	in
LabVIEW,	LabWindows/CVI,	C,	or	Basic.
The	two	typical	DeviceNet	applications	are	accessing	a	device	parameter
and	accessing	device	I/O	data,	described	in	the	following	tables.



Accessing	a	Device	Parameter
Purpose Function(s)	or	VI(s) Comment

Configure	and	open
an	Explicit	Messaging
object	to	access
parameters.

ncOpenDnetExplMsg	(Open
DeviceNet	Explicit	Messaging)

Needs	the	device	MAC	ID,	which	is	in	the
DeviceNet	Network	window.

Read	or	write	a
parameter.

ncGetDnetAttribute	(Get	DeviceNet
Attribute)	and	ncSetDnetAttribute
(Set	DeviceNet	Attribute)

Needs	the	parameter	class	ID,	instance
ID,	attribute	ID,	and	size,	which	are	in	the
Parameters	tab	of	the	Device
Information	window.

Decode	or	encode	a
parameter.

ncConvertFromDnetRead	(Convert
From	DeviceNet	Read)	and
ncConvertForDnetWrite	(Convert
For	DeviceNet	Write)

Needs	the	parameter	data	type,	which	is
in	the	Parameters	tab	of	the	Device
Information	window.

Refer	to	the	Get	Identity	Attributes	example	for	more	information.



Accessing	Device	I/O	Data
Purpose Function(s)	or	VI(s) Comment

Configure
and	open	an
I/O	object	to
access	I/O
data.

ncOpenDnetIO	(Open
DeviceNet	I/O)

Needs	the	device	MAC	ID,	I/O	connection	type,	and
input/output	length.	The	MAC	ID	is	in	the	DeviceNet
Network	window.	The	I/O	connection	type	and
input/output	length	are	in	the	I/O	Data	tab	of	the	Device
Information	window.

Read	input
data	or	write
output	data.

ncReadDnetIO	(Read
DeviceNet	I/O)	and
ncWriteDnetIO	(Write
DeviceNet	I/O)

Needs	the	input/output	length,	which	is	in	the	I/O	Data	tab
of	the	Device	Information	window.

Decode	the
input	data	or
encode	the
output	data.

ncConvertFromDnetRead
(Convert	From	DeviceNet
Read)	and
ncConvertForDnetWrite
(Convert	For	DeviceNet
Write).

You	can	get	the	decode/encode	hint	in	I/O	Data»I/O
Information	in	the	Device	Information	window.

Refer	to	the	Single	Device	example	for	more	information.
Refer	to	Configurator	Main	Window,	Device	Information	Window,	NI-
DNET	User	Manual,	and	NI-DNET	Programmer	Reference	Manual	for
more	information.



NI-DNET	Configurator	Main	Window
The	NI-DNET	Configurator	main	window	is	shown	below.

The	window	consists	of	five	parts:
Index Name Description
1 Menus Refer	to	Menus.

2 Toolbar Refer	to	Toolbar.

3 Status	Bar The	status	bar.

4 DeviceNet
Network
Window

Lists	all	the	DeviceNet	devices.	Each	node	is	a	device;	the	root	node	is	the
interface	device.	For	example,	in	[03]	PRMxx,	[03]	is	the	device	MAC	ID	and
PRMxx	is	the	device	product	name.

5 Device
Information
Window

Shows	the	device	general	information,	parameter	list,	and	I/O	connection
information.	Refer	to	Device	Information	Window	for	more	information.



Device	Information	Window
The	Device	Information	window	consists	of	three	tabs:	General,
Parameters,	and	I/O	Data.



General
The	General	tab	shows	the	device	basic	information	and	related	EDS	file
information.

Device	Information—Shows	the	device	identity	information,
catalog	number,	version	number,	and	serial	number.	Name
contains	the	product	name	and	product	code.	Vendor	contains	the
vendor	name	and	vendor	ID.	Type	contains	the	device	type	name
and	type	code.
EDS	Information—Shows	the	related	EDS	file	information.
(NULL)	is	shown	if	you	do	not	add	the	device	EDS	file.



Parameters
The	Parameters	tab	shows	the	parameter	list	and	parameter	description.
The	tab	is	empty	if	you	do	not	add	the	device	EDS	file.

Category—You	can	show	all	parameters	by	selecting	[All
Parameters]	or	a	subset	of	parameters	in	a	category	by	selecting
the	related	category.
Parameters—The	parameter	list.	You	can	view	or	edit	the	details
of	a	specific	parameter	value	by	double-clicking	it.

Parameter	List	Columns
Index Name Description
1 # The	parameter	index	defined	in	the	EDS	file.
2 Flag The	parameter	flags.	R	means	the	parameter	is

read-only.	S	means	the	parameter	supports
scaling.

3 Parameter The	parameter	name.
4 Value The	parameter	value.
5 Unit The	parameter	unit.
6 Type The	parameter	data	type.
7 Size The	parameter	size.
8 Class	ID Use	the	three	IDs	to	identify	the	parameter	in

the	device.	You	need	the	IDs	when	you	call
ncGetDnetAttribute()	and	Get	DeviceNet
Attribute.vi.

9 Instance
ID

10 Attribute
ID

Parameter	Information—The	selected	parameter	information
including	the	description,	value	range,	enumeration	meaning	list,
and	engineering	value	calculation	formula.



I/O	Data
Supported	I/O—Shows	the	device-supported	I/O	connection.
I/O	Information—The	selected	I/O	connection	information
including	the	description	and	Number	of	Significant	Bits.	For
example,	Number	of	Significant	Bits	=	2	means	that	bit	0	and	bit	1
are	valid	bits.	This	parameter	is	empty	if	you	do	not	add	the	device
EDS	file.

Supported	I/O	List	Columns
Index Name Description
1 IO	Type The	I/O	connection	type,	such	as	Strobe	and	Poll.
2 Input The	input	name	and	its	size.
3 Output The	output	name	and	its	size.

Refer	to	Configurator	Main	Window	for	more	information.



Menus
The	NI-DNET	Configurator	main	window	includes	the	following	menus:

File	Menu
Exit—Quit	the	application.
View	Menu
Toolbar—Show	or	hide	the	toolbar.
Status	Bar—Show	or	hide	the	status	bar.
Network	Menu
Refresh	the	Device	List—Search	all	connected	devices.
Upload	from	Network—Upload	all	device	parameters.
Download	to	Network—Download	all	device	parameters.
Device	Menu
Upload	from	Device—Upload	device	parameters.
Download	to	Device—Download	device	parameters.
Change	MAC	ID—Change	the	device	MAC	ID.
Open	EDS	File—Open	the	device	EDS	file.
Tools	Menu
EDS	Manager—Launch	EDS	Manager	to	add	or	delete	EDS	files.
Help	Menu
NI-DNET	Configurator	Help—Launch	the	help	file.	You	can	also
press	<F1>	to	access	the	help	file.
About	NI-DNET	Configurator—Launch	the	about	dialog.



Toolbar
The	NI-DNET	Configurator	main	window	toolbar	includes	the	following
buttons:

Network	Buttons
Refresh	the	Device	List—Search	all	connected	devices.
Upload	from	Network—Upload	all	device	parameters.
Download	to	Network—Download	all	device	parameters.

Device	Buttons
Upload	from	Device—Upload	device	parameters.
Download	to	Device—Download	device	parameters.
Change	MAC	ID—Change	the	device	MAC	ID.
Open	EDS	File—Open	the	device	EDS	file.

Tool	Buttons
EDS	Manager—Launch	EDS	Manager	to	add	or	delete	EDS
files.

Help	Buttons
NI-DNET	Configurator	Help—Launch	the	help	file.	You	can
also	press	<F1>	to	access	the	help	file.



Refresh	the	Device	List
If	you	connect	a	new	device	to	the	network	or	disconnect	a	device	from
the	network,	complete	the	following	steps	to	refresh	the	device	list:

1.	 Select	Network»Refresh	the	Device	List.
2.	 After	refreshing	successfully,	a	message	box	asks	you	whether	to

upload	or	download.	Select	one	of	the	following	options:
Click	Upload	to	upload	all	device	settings	from	the	network.
Refer	to	Upload	from	Network	for	more	information.
Click	Download	to	download	all	device	settings	to	the
network.	Refer	to	Download	to	Network	for	more
information.
Click	Cancel	to	cancel.



Upload	from	Network
You	can	upload	all	device	settings	from	the	network	by	selecting
Network»Upload	from	Network.
Refer	to	Upload	from	Device	for	more	information.



Download	to	Network
You	can	download	device	settings	to	the	network	by	selecting
Network»Download	to	Network.
Refer	to	Download	to	Device	for	more	information.



View/Edit	a	Parameter	Value
Complete	the	following	steps	to	view	or	edit	a	device	parameter:

1.	 Click	the	Parameters	tab	in	the	Device	Information	window.
2.	 Double-click	the	parameter.	A	View/Edit	Parameter	Value	dialog

appears.
3.	 To	edit	the	parameter	value,	change	the	value	(refer	to	the

following	table)	and	click	Edit.
To	view	the	parameter	value	details	but	not	edit	them,	click
Cancel	to	close	the	dialog.

Category Related	Data	Type(s) Comment
Boolean BOOL Click	the	True	or	False	radio	button.

If	the	parameter	supports	enumeration,	refer	to	Enumeration.

Integer SINT,	INT,	DINT,	LINT,
USINT,	UINT,	UDINT,
ULINT

Change	the	value	in	the	edit	control.	You	can	change	the	radix
to	view	or	edit	the	value	in	decimal	or	hex.

If	the	parameter	supports	enumeration,	refer	to	Enumeration.	If
the	parameter	supports	scaling,	refer	to	Scaling.

Float REAL,	LREAL Change	the	value	in	the	edit	control.

Bit-String BYTE,	WORD,
DWORD,	LWORD

A	list	of	check	boxes	show	the	bit	values.	Set	a	bit	by	checking
the	related	check	box.	Clear	a	bit	by	unchecking	the	related
check	box.

Visible
String

STRING,
SHORT_STRING

Change	the	value	in	the	edit	control.

Enumeration N/A Select	the	enumeration	value	in	the	combo	box.

Scaling N/A Change	the	engineering	value	in	the	edit	control.	Refer	to	What
is	Scaling?	for	more	information.

Note		Editing	a	parameter	value	does	not	automatically	change	it	in	the	device.	You	must
download	the	values	to	take	effect.	Refer	to	Download	to	Device	and	Download	to	Network	for
more	information.



Upload	from	Device
You	can	upload	device	settings	by	selecting	Device»Upload	from
Device.
NI-DNET	Configurator	uploads	all	parameters	from	the	device.
Refer	to	Upload	from	Network	for	more	information.



Download	to	Device
You	can	download	device	settings	by	selecting	Device»Download	to
Device.
NI-DNET	Configurator	downloads	all	modified	parameters	to	the	device.
Refer	to	View/Edit	a	Parameter	Value	and	Download	to	Network	for	more
information.



Change	MAC	ID
A	device	Media	Access	Control	Identifier	(MAC	ID)	represents	the	device
address	on	the	DeviceNet	network.	The	MAC	ID	range	is	0	to	63.	If
multiple	devices	use	the	same	MAC	ID,	only	one	device	can	work
properly.	To	resolve	a	MAC	ID	conflict,	you	must	change	the	device	MAC
ID.
Complete	the	following	steps	to	change	the	MAC	ID:

1.	 Select	Device»Change	MAC	ID.
2.	 Enter	the	new	MAC	ID	and	click	OK.	After	you	change	the	MAC

ID,	the	configurator	uploads	all	parameters	from	the	device.
Note		Some	devices	do	not	support	changing	the	MAC	ID	via	software.	In	this	case,	you	must
change	the	MAC	ID	via	a	hardware	switch.	Refer	to	the	device	manual	for	more	information.



Open	EDS	File
You	can	open	a	device	EDS	file	by	selecting	Device»Open	EDS	File.

Note		Do	not	change	the	EDS	file.	Use	EDS	Manager	to	replace	an	EDS	file	with	a	newer
version.



Manage	EDS	Files
You	can	launch	EDS	Manager	to	add	or	delete	EDS	files	by	selecting
Tools»EDS	Manager.



Show	EDS	Files
EDS	Manager	shows	all	added	EDS	files.	You	can	view	them	in	two
ways:

1.	 Sorted	by	Manufacturer—The	EDS	files	are	sorted	by
manufacturer	->	category	->	product	->	revision.

2.	 Sorted	by	Category—The	EDS	files	are	sorted	by	category	->
manufacturer	->	product	->	revision.



Add	EDS	Files
In	EDS	Manager,	complete	the	following	steps	to	add	EDS	files:

1.	 Click	Add	an	EDS	file	to	add	a	single	EDS	file.	Click	Add	a
directory	of	EDS	files	to	add	all	EDS	files	under	a	directory.

2.	 Select	the	file	or	directory	and	click	OK.
3.	 After	validating	the	added	EDS	files,	a	dialog	shows	the	results.

If	the	result	is	Succeed,	EDS	Manager	successfully	added	the
EDS	file.
If	the	result	is	Fail,	EDS	Manager	rejected	the	EDS	file.	You	can
see	the	failure	reason	in	the	Comment	column.



Delete	EDS	Files
In	EDS	Manager,	complete	the	following	steps	to	delete	EDS	files:

1.	 Select	the	EDS	files	to	delete.	You	can	select	all	EDS	files	by
clicking	Select	All.	You	can	unselect	all	EDS	files	by	clicking
Clear	All.

2.	 Click	Delete	the	selected	EDS	files.
Note		If	you	add	or	delete	EDS	files	in	EDS	Manager,	the	changes	do	not	take	effect	until	you
apply	them	by	selecting	Network»Refresh	the	Device	List.



What	is	EDS?
An	Electronic	Data	Sheet	(EDS)	is	a	text	file	defined	by	the	DeviceNet
specification.	An	EDS	file	provides	all	information	necessary	to	access
and	alter	a	device's	configurable	parameters.
You	can	use	a	DeviceNet	configuration	tool	such	as	NI-DNET
Configurator	to	configure	devices	with	EDS	files.
You	can	get	a	device	EDS	file	from	the	device	manufacturer	or	the	ODVA
official	Web	site.
If	you	add	EDS	files,	you	can	find	valuable	device	information	in	NI-DNET
Configurator	to	develop	DeviceNet	applications.
Refer	to	Device	Information	Window,	Manage	EDS	Files,	and	Develop
DeviceNet	Applications	for	more	information.

javascript:WWW(WWW_ODVA)


What	is	Scaling?
If	the	EDS	file	defines	the	scaling	factors	for	a	parameter,	NI-DNET
Configurator	represents	actual	UINT	and	INT	parameter	values	in	other
formats.	The	parameter	raw	value	is	the	actual	value,	and	the	new	form
is	the	engineering	value.
Use	the	following	formula	to	tell	the	engineering	value	from	the	actual
value:

If	a	parameter	supports	scaling:

The	parameter	flag	is	S.
You	can	see	the	formula	in	the	parameter	information.
You	can	edit	the	parameter	value	in	the	engineering	form.

Refer	to	Device	Information	Window	and	View/Edit	a	Parameter	Value	for
more	information.



Introduction	to	NI-DNET	Analyzer
NI-DNET	Analyzer	monitors	the	DeviceNet	network	and	interprets	the
captured	CAN	messages	according	to	the	DeviceNet	protocol.
The	analyzer	is	useful	for	troubleshooting	and	analyzing	DeviceNet
networks	and	systems.	You	can	see	the	messages	together	with	their
parameters.	The	CAN	message	timestamp	resolution	is	100	µs.	You	can
display	certain	types	of	messages	using	powerful	filters	and	find	options.
You	can	also	get	the	message	statistics.
For	more	information	about	NI-DNET	Analyzer,	refer	to	the	following
sections:

NI-DNET	Analyzer	Environment—Refer	to	this	section	for	a
description	of	the	environment	layout	and	an	introduction	to	the
windows,	menus,	and	toolbar.
Using	NI-DNET	Analyzer—Refer	to	this	section	to	perform	a
specific	task	such	as	configuring	filter	settings.
FAQ—Refer	to	this	section	for	answers	to	frequently	asked
questions.



NI-DNET	Analyzer	Main	Window
The	NI-DNET	Analyzer	main	window	is	shown	below.

The	window	consists	of	six	parts:
Index Name Description
1 Title

2 Menus Refer	to	Menus.

3 Toolbar Refer	to	Toolbar.

4 Packet	List	Window Refer	to	Packet	List	Window.

5 Detailed	Decoding	Results	Window Refer	to	Detailed	Decoding	Results	Window.

6 Status	Bar Refer	to	Status	Bar.



Packet	List	Window
The	Packet	List	window	lists	all	viewable	packets.	The	window	includes
the	following	fields:

Raw	Data
Time	Stamp—The	time	stamp	of	captured	packets.
Arb.	ID—Arbitration	ID,	from	0	to	0x7EF.
Data	(Hex)—Data	field	of	the	DeviceNet	packet	with	a
length	of	0	to	8	bytes.

Brief	Decoding	Results
Group—Group	ID,	from	1	to	4.
Msg.	ID—Message	ID,	from	0	to	15,	or	0x2C,	0x2D,	0x2E,
0x2F.
Src.	MAC—Source	MAC	ID,	from	0	to	63.	The	analyzer
uses		to	indicate	that	the	source	MAC	ID	is	not	available.
Dest.	MAC—Destination	MAC	ID,	from	0	to	63.	The
analyzer	uses		to	indicate	that	the	Destination	MAC	ID	is	not
available.
Description—Abbreviated	description	of	the	captured
packet	(for	example,	Dup	Req	(NF)	stands	for	Duplicate
MAC	ID	Check	Request	Message).
Refer	to	DeviceNet	Message	Descriptions	for	the
relationship	between	the	abbreviated	descriptions	and	their
full	descriptions.

Refer	to	View	Decoding	Results	for	the	details	of	related	operations.



Detailed	Decoding	Results	Window
The	Detailed	Decoding	Results	window	displays	detailed	decoding
results	of	a	selected	packet.	This	window	displays	the	following
information:

Raw	Data
Arbitration	ID
Data(Hex)

Refer	to	Packet	List	Window	for	more	information.
IDs

Group	ID
Message	ID
Source	MAC	ID
Destination	MAC	ID

Refer	to	Packet	List	Window	for	more	information.
Details

Description—The	full	description	of	the	captured	packet.
The	analyzer	shows	a	more	meaningful	description	instead
of	the	abbreviated	keywords	in	the	Packet	List	window.
Refer	to	DeviceNet	Message	Descriptions	for	all	packet
descriptions.
Fragmented

Yes—A	fragmented	message.
No—A	nonfragmented	message.
N/A—Fragmented	information	is	not	available.

Parameters—Type-specific	information.
For	example,	the	type-specific	information	of	a	duplicate
MAC	ID	check	message	includes	Physical	Port	Number,
Vendor	ID,	and	Serial	Number.

Refer	to	View	Decoding	Results	for	the	details	of	related	operations.



Menus
The	NI-DNET	Analyzer	main	window	includes	the	following	menus:

File	Menu
New—Create	a	new	document.
Open...—Open	an	existing	document.
Save	As...—Save	the	active	document	with	a	new	name.
Exit—Quit	the	application.
Edit	Menu
Find	Packet...—Find	specified	packets.
Clear	All—Clear	the	current	document.
View	Menu
Toolbar—Show	or	hide	the	toolbar.
Status	Bar—Show	or	hide	the	status	bar.
Statistics	Information—Show	statistics	information.
Capture	Menu
Start	Capture—Start	capture.
Stop	Capture—Stop	capture.
Settings	Menu
Network	Settings...—Configure	network	settings.
Display	Settings...—Configure	display	settings.
Filter	Settings...—Configure	filter	settings.
Help	Menu
NI-DNET	Analyzer	Help—Launch	the	help	file.
About	NI-DNET	Analyzer—Launch	the	about	dialog.



Toolbar
The	NI-DNET	Analyzer	main	window	toolbar	includes	the	following
buttons:

New—Close	the	current	document	and	create	a	new	empty	document.

Open...—Open	an	existing	log	file.

Save	As...—Save	the	current	document	to	a	specified	file.

Find	Packet...—Find	specified	packets.

Clear	All—Clear	the	current	document.

Start	Capture—Start	capture.

Stop	Capture—Stop	capture.

Network	Settings...—Configure	network	settings.

Display	Settings...—Configure	display	settings.

Filter	Settings...—Configure	filter	settings.

Statistics	Information—Show	statistics	information.

NI-DNET	Analyzer	Help—Launch	the	help	file.



Status	Bar
You	can	see	the	current	network	settings	in	the	status	bar.	Refer	to
Configure	Network	Settings	for	the	network	setting	details.



Launch	and	Exit	NI-DNET	Analyzer
Launch	NI-DNET	Analyzer
Complete	the	following	steps	to	launch	NI-DNET	Analyzer:

1.	 Launch	Measurement	&	Automation	Explorer	(MAX).
2.	 In	MAX,	select	your	CAN	card	under	My	System»Devices	and

Interfaces.
3.	 Right-click	the	CAN	card	and	select	Protocol	to	change	the

protocol	to	DeviceNet.	(Refer	to	Protocol	Dialog	Box	for	more
information.)

4.	 Right-click	the	port	and	select	Properties	to	set	the	DeviceNet
interface	properties.	(Refer	to	Port	Properties	Dialog	Box	for	more
information.)

5.	 Right-click	the	port	and	select	Analyzer	to	launch	the	analyzer.
6.	 The	analyzer	prompts	you	to	select	Monitor	the	Network	or

Open	an	Existing	Log	File.
If	you	select	Monitor	the	Network,	the	analyzer	starts	capture
automatically.

If	you	select	Open	an	Existing	Log	File,	you	can	specify	a	.dcap
file	to	load	previously	captured	data.



Exit	NI-DNET	Analyzer
Select	File»Exit	to	close	the	analyzer.

Note		When	the	analyzer	exits,	the	current	display	and	filter	settings	are	saved	automatically.
They	are	loaded	automatically	the	next	time	you	launch	the	analyzer.



Start	and	Stop	Capture
Start	Capture
Complete	the	following	steps	to	start	capture:

1.	 (Optional)	Configure	the	related	settings,	including:	Network
Settings,	Filter	Settings,	and	Display	Settings.

2.	 Select	Capture»Start	Capture	to	start	capture.



Stop	Capture
Select	Capture»Stop	Capture	to	stop	capture.



View	Decoding	Results
Brief	Decoding	Results
You	can	see	brief	decoding	results	in	the	Packet	List	window,	including:

Group	ID
Message	ID
Source	MAC	ID
Destination	MAC	ID
Abbreviated	description	of	captured	packet



Detailed	Decoding	Results
Complete	the	following	steps	to	view	detailed	decoding	results:

1.	 If	the	analyzer	is	capturing,	stop	capture.	Refer	to	Start	and	Stop
Capture	for	details.

2.	 Click	an	item	in	the	Packet	List	window	to	see	the	detailed
decoding	results	of	the	selected	packet	in	the	Detailed	Decoding
Results	window.



Save	and	Open	a	Log	File
Save
Complete	the	following	steps	to	save	the	current	document:

1.	 If	the	analyzer	is	capturing,	stop	capture.	Refer	to	Start	and	Stop
Capture	for	details.

2.	 Select	File»Save	As...	to	save	the	current	document.



Open	a	Log	File
Complete	the	following	steps	to	open	an	existing	log	file:

1.	 If	the	analyzer	is	capturing,	stop	capture.	Refer	to	Start	and	Stop
Capture	for	details.

2.	 Select	File»Open...	to	specify	a	log	file	to	open.



Find	a	Packet
The	analyzer	can	search	a	specific	packet	and	highlight	it	in	the	Packet
List	window.
Complete	the	following	steps	to	find	a	specific	packet:

1.	 If	the	analyzer	is	capturing,	stop	capture.	Refer	to	Start	and	Stop
Capture	for	details.

2.	 Select	Edit»Find	Packet....
3.	 Change	the	following	find	parameters	as	needed:

Find	by	Message	Type—Select	Message	Type	in	the
Category	combo	box	and	specify	a	message	type	in	the
Find	What	combo	box.
Find	by	Group	ID—Select	Group	ID	in	the	Category
combo	box	and	specify	a	group	ID	in	the	Find	What	combo
box.
Find	by	Message	ID—Select	Message	ID	in	the	Category
combo	box	and	specify	a	message	ID	in	the	Find	What
combo	box.
Find	by	Source	MAC	ID—Select	Source	MAC	ID	in	the
Category	combo	box	and	specify	a	source	MAC	ID	in	the
Find	What	combo	box.
Find	by	Destination	MAC	ID—Select	Destination	MAC	ID
in	the	Category	combo	box	and	specify	a	destination	MAC
ID	in	the	Find	What	combo	box.
Find	by	Arbitration	ID—Select	Arbitration	ID	in	the
Category	combo	box	and	enter	a	value	between	0	and
0x7EF	in	the	Find	What	combo	box.

4.	 Click	Find	Next.



View	Statistics	Information
Complete	the	following	steps	to	view	the	network	traffic	statistics
information:

1.	 If	the	analyzer	is	capturing,	stop	capture.	Refer	to	Start	and	Stop
Capture	for	details.

2.	 Select	View»Statistics	Information...	to	open	the	statistics
information	dialog.

3.	 Select	an	item	from	the	Category	combo	box	to	view	the
corresponding	statistics	information:

General	Information
Packet	Count—The	total	number	of	captured
packets.
Packets	Count	per	Millisecond—The	number	of
captured	packets	per	millisecond.
Average	Data	Length	in	Bytes—The	average
number	of	bytes	in	the	data	field.

Packet	Count	for	Each	Device
Sent—The	number	of	packets	sent	by	each	device	in
the	total	capture	time.
Received—The	number	of	packets	received	by	each
device	in	the	total	capture	time.

Packet	Count	for	Each	Message	Type
The	number	of	packets	of	each	message	type	in	the	total
capture	time.

4.	 Click	OK.



Configure	Network	Settings
Complete	the	following	steps	to	configure	the	network	settings:

1.	 If	the	analyzer	is	capturing,	stop	capture.	Refer	to	Start	and	Stop
Capture	for	details.

2.	 Select	Settings»Network	Settings...	to	open	the	network
settings	dialog.

3.	 Select	the	interface	name	of	your	National	Instruments	interface,
which	could	be:

Physical	interfaces,	from	CAN0	to	CAN63.
Virtual	interfacesi,	CAN256	or	CAN257.
Refer	to	What	is	Virtual	Interface?	for	details.

4.	 Select	the	baud	rate	your	DeviceNet	network	uses.	The
DeviceNet	specification	allows	either	125000,	250000,	or	500000
bps.

5.	 Click	OK.
Note		The	analyzer	uses	the	interface	name	and	baud	rate	assigned	in	MAX	as	default	network
settings.



Configure	Filter	Settings
You	can	use	the	filter	to	select	desired	packets	to	be	captured	or
displayed.
Complete	the	following	steps	to	configure	the	filter	settings:

1.	 If	the	analyzer	is	capturing,	stop	capture.	Refer	to	Start	and	Stop
Capture	for	details.

2.	 Select	Settings»Filter	Settings...	to	open	the	filter	settings
dialog.

3.	 Click	Enable	or	Disable	to	enable	or	disable	the	filter.
4.	 If	the	filter	is	enabled,	check	the	corresponding	check	boxes	on

each	filter	page	to	select	your	desired	packets.
5.	 Click	OK.

Note		If	the	filter	is	enabled	during	capture,	the	analyzer	discards	all	packets	that	do	not	match
the	filter.	After	capture,	you	can	change	filter	settings	to	view	more	desired	packets.	However,
all	original	captured	packets	are	still	retained	in	the	current	document.



Configure	Display	Settings
Complete	the	following	steps	to	configure	the	display	settings:

1.	 If	the	analyzer	is	capturing,	stop	capture.	Refer	to	Start	and	Stop
Capture	for	details.

2.	 Select	Settings»Display	Settings...	to	open	the	display	settings
dialog.

3.	 Configure	the	display	settings,	including:
Update	Rate—A	rate	at	which	the	UI	updates	(in
milliseconds).
You	can	select	a	value	from	an	enumerated	list,	including
1000	ms,	2000	ms,	and	5000	ms,	where	1000	ms	is	the
default	value.
Time	Stamp	Format—Time	stamp	of	captured	packets
listed	in	the	Packet	List	window,	either	absolute	or	relative
format.

Absolute—In	local	system	time	format.	An	example
is	shown	below.

Format 14:27:13.257.3
Value 14 27 13 257 3

Description
Hour Minute Second Millisecond 100*Microsecond
This	packet	is	captured	in	14:27:13.257.3	(local
time	zone).

Relative—In	seconds	since	the	first	packet	captured.
An	example	is	shown	below.

Format(Unit
:	Second)

285.2345

Description
This	packet	is	captured	285.2345
seconds	after	the	first	packet	was
captured.

4.	 Click	OK.



Create	a	New	Document
Close	the	current	document	and	create	a	new	empty	document.	The
analyzer	clears	the	contents	in	the	Packet	List	and	Detailed	Decoding
Results	windows.
Complete	the	following	steps	to	create	a	new	empty	document:

1.	 If	the	analyzer	is	capturing,	stop	capture.	Refer	to	Start	and	Stop
Capture	for	details.

2.	 Select	File»New.



Clear	the	Current	Document
Clear	the	current	document	contents.	The	analyzer	clears	the	contents	in
the	Packet	List	and	Detailed	Decoding	Results	windows.
Complete	the	following	steps	to	clear	the	current	document:

1.	 If	the	analyzer	is	capturing,	stop	capture.	Refer	to	Start	and	Stop
Capture	for	details.

2.	 Select	Edit»Clear	All.



What	is	Virtual	Interface?
NI-CAN	provides	a	virtual	CAN	card	with	two	interfaces,	CAN256	and
CAN257.	A	virtual	bus	connects	the	two	virtual	interfaces.	When	you
write	CAN	frames	to	one	virtual	interface,	the	other	virtual	interface
receives	those	frames.	This	feature	allows	you	to	read	and	write	CAN
data	in	the	same	manner	as	two	actual	CAN	interfaces	connected	by	an
actual	CAN	cable.



What	is	Message	Body	Format?
The	request	messages	transmitted	over	an	explicit	messaging
connection	should	conform	to	the	specific	format.	The	following	table
shows	the	format	of	a	nonfragmented	explicit	request.

7 6 5 4 3 2 1 0
Frag[0] XID MAC	ID

Class	ID

Instance	ID

Service	Data	(Optional)

Message	body	format	specifies	that	the	Class	ID	and	Instance	ID	are	8	or
16-bit	integers.	The	following	table	describes	the	message	body	format
values.

Value Meanings
DeviceNet(8/8) Class	ID	=	8	bit	integer.	Instance	ID	=	8	bit	integer.

DeviceNet(8/16) Class	ID	=	8	bit	integer.	Instance	ID	=	16	bit	integer.

DeviceNet(16/16) Class	ID	=	16	bit	integer.	Instance	ID	=	16	bit	integer.

DeviceNet(16/8) Class	ID	=	16	bit	integer.	Instance	ID	=	8	bit	integer.



DeviceNet	Message	Descriptions
Explicit	Message
Abbreviated	Description Full	Description
EM	GetAttrAll	Req(NF) Explicit	Request	Message—Get	All	Attributes

EM	GetAttrAll	Rsp(NF) Explicit	Response	Message—Get	All	Attributes

EM	SetAttrAll	Req(NF) Explicit	Request	Message—Set	All	Attributes

EM	SetAttrAll	Rsp(NF) Explicit	Response	Message—Set	All	Attributes

EM	Reset	Req(NF) Explicit	Request	Message—Reset

EM	Reset	Rsp(NF) Explicit	Response	Message—Reset

EM	Start	Req(NF) Explicit	Request	Message—Start

EM	Start	Rsp(NF) Explicit	Response	Message—Start

EM	Stop	Req(NF) Explicit	Request	Message—Stop

EM	Stop	Rsp(NF) Explicit	Response	Message—Stop

EM	Create	Req(NF) Explicit	Request	Message—Create

EM	Create	Rsp(NF) Explicit	Response	Message—Create

EM	Delete	Req(NF) Explicit	Request	Message—Delete

EM	Delete	Rsp(NF) Explicit	Response	Message—Delete

EM	Apply_Attr	Req(NF) Explicit	Request	Message—Apply	Attribute

EM	Apply_Attr	Rsp(NF) Explicit	Response	Message—Apply	Attribute

EM	GetAtSingle	Req(NF) Explicit	Request	Message—Get	Single	Attribute

EM	GetAtSingle	Rsp(NF) Explicit	Response	Message—Get	Single	Attribute

EM	SetAtSingle	Req(NF) Explicit	Request	Message—Set	Single	Attribute

EM	SetAtSingle	Rsp(NF) Explicit	Response	Message—Set	Single	Attribute

EM	FndNxObjIn	Req(NF) Explicit	Request	Message—Find	Next	Object	Instance

EM	FndNxObjIn	Rsp(NF) Explicit	Response	Message—Find	Next	Object	Instance

EM	Error	Rsp(NF) Explicit	Response	Message—Error

EM	Restore	Req(NF) Explicit	Request	Message—Restore

EM	Restore	Rsp(NF) Explicit	Response	Message—Restore

EM	Save	Req(NF) Explicit	Request	Message—Save

EM	Save	Rsp(NF) Explicit	Response	Message—Save

EM	NOP	Req(NF) Explicit	Request	Message—No	Operations

EM	NOP	Rsp(NF) Explicit	Response	Message—No	Operations

EM	GetMember	Req(NF) Explicit	Request	Message—Get	Member

EM	GetMember	Rsp(NF) Explicit	Response	Message—Get	Member

EM	SetMember	Req(NF) Explicit	Request	Message—Set	Member

EM	SetMember	Rsp(NF) Explicit	Response	Message—Set	Member

EM	InsertMmbr	Req(NF) Explicit	Request	Message—Insert	Member

EM	InsertMmbr	Rsp(NF) Explicit	Response	Message—Insert	Member



EM	RemoveMmbr	Req(NF) Explicit	Request	Message—Remove	Member

EM	RemoveMmbr	Rsp(NF) Explicit	Response	Message—Remove	Member

EM	Unknown	Srv	Req(NF) Explicit	Request	Message—Unknown	Service

EM	Unknown	Srv	Rsp(NF) Explicit	Response	Message—Unknown	Service



I/O	Message
Abbreviated	Description Full	Description
Mstr	Poll	Cmd Master	Poll	Command

Mstr	COS	Msg Master	Change	of	State	Message

Mstr	Cyclic	Msg Master	Cyclic	Message

Mstr	COS	Ack Master	Change	of	State	Acknowledge	Message

Mstr	Cyclic	Ack Master	Cyclic	Acknowledge	Message

Mstr	Bit-Strobe	Cmd Master	Bit-Strobe	Command	Message

Mstr	Poll	Cmd/COS	Msg Master	Poll	Command/Change	of	State	Message

Mstr	Poll	Cmd/Cyclic	Msg Master	Poll	Command/Cyclic	Message

Slv	Poll	Rsp Slave	Poll	Response

Slv	COS	Msg Slave	Change	of	State	Message

Slv	Cyclic	Msg Slave	Cyclic	Message

Slv	COS	Ack Slave	Change	of	State	Acknowledge	Message

Slv	Cyclic	Ack Slave	Cyclic	Acknowledge	Message

Slv	Bit-Strobe	Rsp Slave	Bit-Strobe	Response	Message

Slv	Poll	Rsp/Cyclic	Ack Slave	Poll	Response/Cyclic	Acknowledge	Message

Slv	Poll	Rsp/COS	Ack Slave	Poll	Response/Change	of	State	Acknowledge	Message



Unknown	Message
Abbreviated	Description Full	Description
Unknown Unknown	Message



Predefined	Message
Abbreviated	Description Full	Description
G3	UCMM	Open	Req(NF) Group3	Unconnected	Message—Open	Explicit	Messaging	Connection

Request

G3	UCMM	Open	Rsp(NF) Group3	Unconnected	Message—Open	Explicit	Messaging	Connection
Response

G3	UCMM	Close	Req(NF) Group3	Unconnected	Message—Close	Explicit	Messaging	Connection
Request

G3	UCMM	Close	Rsp(NF) Group3	Unconnected	Message—Close	Explicit	Messaging	Connection
Response

G3	UCMM	Error	Rsp(NF) Group3	Unconnected	Message—Error	Response

G3	UCMM	Unknown
Srv(NF)

Group3	Unconnected	Message—Unknown	Service

G2	UCMM	Allocate
Req(NF)

Group2	Unconnected	Message—Allocate	Request

G2	UCMM	Allocate
Rsp(NF)

Group2	Unconnected	Message—Allocate	Response

G2	UCMM	Release
Req(NF)

Group2	Unconnected	Message—Release	Request

G2	UCMM	Release
Rsp(NF)

Group2	Unconnected	Message—Release	Response

G2	UCMM	Error	Rsp(NF) Group2	Unconnected	Message—Error	Response

G2	UCMM	Unknown
Srv(NF)

Group2	Unconnected	Message—Unknown	Service

Dup	Req(NF) Duplicate	MAC	ID	Check	Request	Message

Dup	Rsp(NF) Duplicate	MAC	ID	Check	Response	Message

Heartbeat(NF) Device	Heartbeat	Message

ShutDown(NF) Device	Shutdown	Message



Offline	Message
Abbreviated	Description Full	Description

Offline	Ownership	Req(NF) Offline	Ownership	Request	Message

Offline	Ownership	Rsp(NF) Offline	Ownership	Response	Message

Offline	Identify	Req(NF) Offline	Identify	Communication	Faulted	Request	Message

Offline	Identify	Rsp(NF) Offline	Identify	Communication	Faulted	Response	Message

Offline	Who	Req(NF) Offline	Who	Communication	Faulted	Request	Message

Offline	Who	Rsp(NF) Offline	Who	Communication	Faulted	Response	Message

Offline	Change	MAC	ID	Req(NF) Offline	Change	MAC	ID	Communication	Faulted	Request	Message
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Warranty
The	CAN	and	DeviceNet	hardware	is	warranted	against	defects
in	materials	and	workmanship	for	a	period	of	one	year	from	the
date	of	shipment,	as	evidenced	by	receipts	or	other
documentation.	National	Instruments	will,	at	its	option,	repair	or
replace	equipment	that	proves	to	be	defective	during	the
warranty	period.	This	warranty	includes	parts	and	labor.
The	media	on	which	you	receive	National	Instruments	software
are	warranted	not	to	fail	to	execute	programming	instructions,
due	to	defects	in	materials	and	workmanship,	for	a	period	of	90
days	from	date	of	shipment,	as	evidenced	by	receipts	or	other
documentation.	National	Instruments	will,	at	its	option,	repair	or
replace	software	media	that	do	not	execute	programming
instructions	if	National	Instruments	receives	notice	of	such
defects	during	the	warranty	period.	National	Instruments	does
not	warrant	that	the	operation	of	the	software	shall	be
uninterrupted	or	error	free.
A	Return	Material	Authorization	(RMA)	number	must	be
obtained	from	the	factory	and	clearly	marked	on	the	outside	of
the	package	before	any	equipment	will	be	accepted	for
warranty	work.	National	Instruments	will	pay	the	shipping	costs
of	returning	to	the	owner	parts	which	are	covered	by	warranty.
National	Instruments	believes	that	the	information	in	this
document	is	accurate.	The	document	has	been	carefully
reviewed	for	technical	accuracy.	In	the	event	that	technical	or
typographical	errors	exist,	National	Instruments	reserves	the
right	to	make	changes	to	subsequent	editions	of	this	document
without	prior	notice	to	holders	of	this	edition.	The	reader	should
consult	National	Instruments	if	errors	are	suspected.	In	no
event	shall	National	Instruments	be	liable	for	any	damages
arising	out	of	or	related	to	this	document	or	the	information



contained	in	it.
EXCEPT	AS	SPECIFIED	HEREIN,	NATIONAL	INSTRUMENTS
MAKES	NO	WARRANTIES,	EXPRESS	OR	IMPLIED,	AND
SPECIFICALLY	DISCLAIMS	ANY	WARRANTY	OF
MERCHANTABILITY	OR	FITNESS	FOR	A	PARTICULAR
PURPOSE.	CUSTOMER'S	RIGHT	TO	RECOVER	DAMAGES
CAUSED	BY	FAULT	OR	NEGLIGENCE	ON	THE	PART	OF
NATIONAL	INSTRUMENTS	SHALL	BE	LIMITED	TO	THE
AMOUNT	THERETOFORE	PAID	BY	THE	CUSTOMER.
NATIONAL	INSTRUMENTS	WILL	NOT	BE	LIABLE	FOR
DAMAGES	RESULTING	FROM	LOSS	OF	DATA,	PROFITS,
USE	OF	PRODUCTS,	OR	INCIDENTAL	OR
CONSEQUENTIAL	DAMAGES,	EVEN	IF	ADVISED	OF	THE
POSSIBILITY	THEREOF.	This	limitation	of	the	liability	of
National	Instruments	will	apply	regardless	of	the	form	of	action,
whether	in	contract	or	tort,	including	negligence.	Any	action
against	National	Instruments	must	be	brought	within	one	year
after	the	cause	of	action	accrues.	National	Instruments	shall	not
be	liable	for	any	delay	in	performance	due	to	causes	beyond	its
reasonable	control.	The	warranty	provided	herein	does	not
cover	damages,	defects,	malfunctions,	or	service	failures
caused	by	owner's	failure	to	follow	the	National	Instruments
installation,	operation,	or	maintenance	instructions;	owner's
modification	of	the	product;	owner's	abuse,	misuse,	or	negligent
acts;	and	power	failure	or	surges,	fire,	flood,	accident,	actions
of	third	parties,	or	other	events	outside	reasonable	control.



Copyright
Under	the	copyright	laws,	this	publication	may	not	be
reproduced	or	transmitted	in	any	form,	electronic	or
mechanical,	including	photocopying,	recording,	storing	in	an
information	retrieval	system,	or	translating,	in	whole	or	in	part,
without	the	prior	written	consent	of	National	Instruments
Corporation.
National	Instruments	respects	the	intellectual	property	of
others,	and	we	ask	our	users	to	do	the	same.	NI	software	is
protected	by	copyright	and	other	intellectual	property	laws.
Where	NI	software	may	be	used	to	reproduce	software	or	other
materials	belonging	to	others,	you	may	use	NI	software	only	to
reproduce	materials	that	you	may	reproduce	in	accordance	with
the	terms	of	any	applicable	license	or	other	legal	restriction.



Trademarks
National	Instruments,	NI,	ni.com,	and	LabVIEW	are	trademarks
of	National	Instruments	Corporation.	Refer	to	the	Terms	of	Use
section	on	ni.com/legal	for	more	information	about	National
Instruments	trademarks.
FireWire®	is	the	registered	trademark	of	Apple	Computer,	Inc.
Handle	Graphics®,	MATLAB®,	Real-Time	Workshop®,
Simulink®,	Stateflow®,	and	xPC	TargetBox®	are	registered
trademarks,	and	TargetBox™	and	Target	Language	Compiler™
are	trademarks	of	The	MathWorks,	Inc.
Tektronix®	and	Tek	are	registered	trademarks	of	Tektronix,	Inc.
Other	product	and	company	names	mentioned	herein	are
trademarks	or	trade	names	of	their	respective	companies.
Members	of	the	National	Instruments	Alliance	Partner	Program
are	business	entities	independent	from	National	Instruments
and	have	no	agency,	partnership,	or	joint-venture	relationship
with	National	Instruments.

javascript:WWW(WWW_Trademark)


Patents
For	patents	covering	National	Instruments	products,	refer	to	the
appropriate	location:	Help»Patents	in	your	software,	the
patents.txt	file	on	your	CD,	or	ni.com/patents.

javascript:WWW(WWW_Patents)


WARNING	REGARDING	USE	OF	NATIONAL
INSTRUMENTS	PRODUCTS
(1)	NATIONAL	INSTRUMENTS	PRODUCTS	ARE	NOT
DESIGNED	WITH	COMPONENTS	AND	TESTING	FOR	A
LEVEL	OF	RELIABILITY	SUITABLE	FOR	USE	IN	OR	IN
CONNECTION	WITH	SURGICAL	IMPLANTS	OR	AS
CRITICAL	COMPONENTS	IN	ANY	LIFE	SUPPORT	SYSTEMS
WHOSE	FAILURE	TO	PERFORM	CAN	REASONABLY	BE
EXPECTED	TO	CAUSE	SIGNIFICANT	INJURY	TO	A	HUMAN.
(2)	IN	ANY	APPLICATION,	INCLUDING	THE	ABOVE,
RELIABILITY	OF	OPERATION	OF	THE	SOFTWARE
PRODUCTS	CAN	BE	IMPAIRED	BY	ADVERSE	FACTORS,
INCLUDING	BUT	NOT	LIMITED	TO	FLUCTUATIONS	IN
ELECTRICAL	POWER	SUPPLY,	COMPUTER	HARDWARE
MALFUNCTIONS,	COMPUTER	OPERATING	SYSTEM
SOFTWARE	FITNESS,	FITNESS	OF	COMPILERS	AND
DEVELOPMENT	SOFTWARE	USED	TO	DEVELOP	AN
APPLICATION,	INSTALLATION	ERRORS,	SOFTWARE	AND
HARDWARE	COMPATIBILITY	PROBLEMS,	MALFUNCTIONS
OR	FAILURES	OF	ELECTRONIC	MONITORING	OR
CONTROL	DEVICES,	TRANSIENT	FAILURES	OF
ELECTRONIC	SYSTEMS	(HARDWARE	AND/OR
SOFTWARE),	UNANTICIPATED	USES	OR	MISUSES,	OR
ERRORS	ON	THE	PART	OF	THE	USER	OR	APPLICATIONS
DESIGNER	(ADVERSE	FACTORS	SUCH	AS	THESE	ARE
HEREAFTER	COLLECTIVELY	TERMED	"SYSTEM
FAILURES").	ANY	APPLICATION	WHERE	A	SYSTEM
FAILURE	WOULD	CREATE	A	RISK	OF	HARM	TO	PROPERTY
OR	PERSONS	(INCLUDING	THE	RISK	OF	BODILY	INJURY
AND	DEATH)	SHOULD	NOT	BE	RELIANT	SOLELY	UPON
ONE	FORM	OF	ELECTRONIC	SYSTEM	DUE	TO	THE	RISK
OF	SYSTEM	FAILURE.	TO	AVOID	DAMAGE,	INJURY,	OR



DEATH,	THE	USER	OR	APPLICATION	DESIGNER	MUST
TAKE	REASONABLY	PRUDENT	STEPS	TO	PROTECT
AGAINST	SYSTEM	FAILURES,	INCLUDING	BUT	NOT
LIMITED	TO	BACK-UP	OR	SHUT	DOWN	MECHANISMS.
BECAUSE	EACH	END-USER	SYSTEM	IS	CUSTOMIZED	AND
DIFFERS	FROM	NATIONAL	INSTRUMENTS'	TESTING
PLATFORMS	AND	BECAUSE	A	USER	OR	APPLICATION
DESIGNER	MAY	USE	NATIONAL	INSTRUMENTS
PRODUCTS	IN	COMBINATION	WITH	OTHER	PRODUCTS	IN
A	MANNER	NOT	EVALUATED	OR	CONTEMPLATED	BY
NATIONAL	INSTRUMENTS,	THE	USER	OR	APPLICATION
DESIGNER	IS	ULTIMATELY	RESPONSIBLE	FOR	VERIFYING
AND	VALIDATING	THE	SUITABILITY	OF	NATIONAL
INSTRUMENTS	PRODUCTS	WHENEVER	NATIONAL
INSTRUMENTS	PRODUCTS	ARE	INCORPORATED	IN	A
SYSTEM	OR	APPLICATION,	INCLUDING,	WITHOUT
LIMITATION,	THE	APPROPRIATE	DESIGN,	PROCESS	AND
SAFETY	LEVEL	OF	SUCH	SYSTEM	OR	APPLICATION.



Technical	Support	and	Professional	Services
Visit	the	following	sections	of	the	National	Instruments	Web	site
at	ni.com	for	technical	support	and	professional	services:

Support—Online	technical	support	resources	at
ni.com/support	include	the	following:

Self-Help	Resources—For	answers	and	solutions,
visit	the	award-winning	National	Instruments	Web
site	for	software	drivers	and	updates,	a	searchable
KnowledgeBase,	product	manuals,	step-by-step
troubleshooting	wizards,	thousands	of	example
programs,	tutorials,	application	notes,	instrument
drivers,	and	so	on.
Free	Technical	Support—All	registered	users
receive	free	Basic	Service,	which	includes	access	to
hundreds	of	Applications	Engineers	worldwide	in	the
NI	Discussion	Forums	at	ni.com/forums.	National
Instruments	Applications	Engineers	make	sure	every
question	receives	an	answer.
For	information	about	other	technical	support	options
in	your	area,	visit	ni.com/services	or	contact	your	local
office	at	ni.com/contact.

Training	and	Certification—Visit	ni.com/training	for	self-
paced	training,	eLearning	virtual	classrooms,	interactive
CDs,	and	Certification	program	information.	You	also	can
register	for	instructor-led,	hands-on	courses	at	locations
around	the	world.
System	Integration—If	you	have	time	constraints,	limited
in-house	technical	resources,	or	other	project	challenges,
National	Instruments	Alliance	Partner	members	can	help.
To	learn	more,	call	your	local	NI	office	or	visit
ni.com/alliance.
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If	you	searched	ni.com	and	could	not	find	the	answers	you
need,	contact	your	local	office	or	NI	corporate	headquarters.
You	also	can	visit	the	Worldwide	Offices	section	of
ni.com/niglobal	to	access	the	branch	office	Web	sites,	which
provide	up-to-date	contact	information,	support	phone	numbers,
email	addresses,	and	current	events.
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Branch	Offices
Office Telephone	Number
Australia 1800	300	800
Austria 43	0	662	45	79	90	0
Belgium 32	0	2	757	00	20
Brazil 55	11	3262	3599
Canada 800	433	3488
China 86	21	6555	7838
Czech	Republic 420	224	235	774
Denmark 45	45	76	26	00
Finland 385	0	9	725	725	11
France 33	0	1	48	14	24	24
Germany 49	0	89	741	31	30
India 91	80	41190000
Israel 972	0	3	6393737
Italy 39	02	413091
Japan 81	3	5472	2970
Korea 82	02	3451	3400
Lebanon 961	0	1	33	28	28
Malaysia 1800	887710
Mexico 01	800	010	0793
Netherlands 31	0	348	433	466
New	Zealand 0800	553	322
Norway 47	0	66	90	76	60
Poland 48	22	3390150
Portugal 351	210	311	210



Russia 7	495	783	68	51
Singapore 1800	226	5886
Slovenia 386	3	425	42	00
South	Africa 27	0	11	805	8197
Spain 34	91	640	0085
Sweden 46	0	8	587	895	00
Switzerland 41	56	200	51	51
Taiwan 886	02	2377	2222
Thailand 662	278	6777
Turkey 90	212	279	3031
United	Kingdom 44	0	1635	523545
United	States	(Corporate) 512	683	0100
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