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The	Switch	Soft	Front	Panel	Help	provides	step-by-step	information
about	how	to	use	the	Switch	Soft	Front	Panel	(SFP)	to	test	the	basic
functionality	of	your	switch	module	and	troubleshoot	your	applications.
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Related	Documentation
The	following	documentation	contains	information	that	you	may	find
helpful	as	you	use	this	help	file:

NI	Switches	Help



Using	Help
Conventions
Navigating	Help
Searching	Help
Printing	Help	File	Topics



Conventions
This	help	file	uses	the	following	formatting	and	typographical
conventions:

» The	»	symbol	leads	you	through	nested	menu	items	and
dialog	box	options	to	a	final	action.	The	sequence	File»Page
Setup»Options	directs	you	to	pull	down	the	File	menu,
select	the	Page	Setup	item,	and	select	Options	from	the	last
dialog	box.
This	icon	denotes	a	note,	which	alerts	you	to	important
information.

bold Bold	text	denotes	items	that	you	must	select	or	click	in	the
software,	such	as	menu	items	and	dialog	box	options.	Bold
text	also	denotes	parameter	names.

green Underlined	text	in	this	color	denotes	a	link	to	a	help	topic,
help	file,	or	Web	address.

italic Italic	text	denotes	variables,	emphasis,	cross	references,	or
an	introduction	to	a	key	concept.	Italic	text	also	denotes	text
that	is	a	placeholder	for	a	word	or	value	that	you	must
supply.

monospace Text	in	this	font	denotes	text	or	characters	that	you	should
enter	from	the	keyboard,	sections	of	code,	programming
examples,	and	syntax	examples.	This	font	is	also	used	for
the	proper	names	of	disk	drives,	paths,	directories,
programs,	subprograms,	subroutines,	device	names,
functions,	operations,	variables,	filenames,	and	extensions.



Navigating	Help	(Windows	Only)
To	navigate	this	help	file,	use	the	Contents,	Index,	and	Search	tabs	to
the	left	of	this	window	or	use	the	following	toolbar	buttons	located	above
the	tabs:

Hide—Hides	the	navigation	pane	from	view.
Locate—Locates	the	currently	displayed	topic	in	the	Contents	tab,
allowing	you	to	view	related	topics.
Back—Displays	the	previously	viewed	topic.
Forward—Displays	the	topic	you	viewed	before	clicking	the	Back
button.
Options—Displays	a	list	of	commands	and	viewing	options	for	the
help	file.



Searching	Help	(Windows	Only)
Use	the	Search	tab	to	the	left	of	this	window	to	locate	content	in	this	help
file.	If	you	want	to	search	for	words	in	a	certain	order,	such	as	"related
documentation,"	add	quotation	marks	around	the	search	words	as	shown
in	the	example.	Searching	for	terms	on	the	Search	tab	allows	you	to
quickly	locate	specific	information	and	information	in	topics	that	are	not
included	on	the	Contents	tab.



Wildcards
You	also	can	search	using	asterisk	(*)	or	question	mark	(?)	wildcards.
Use	the	asterisk	wildcard	to	return	topics	that	contain	a	certain	string.	For
example,	a	search	for	"prog*"	lists	topics	that	contain	the	words
"program,"	"programmatically,"	"progress,"	and	so	on.
Use	the	question	mark	wildcard	as	a	substitute	for	a	single	character	in	a
search	term.	For	example,	"?ext"	lists	topics	that	contain	the	words
"next,"	"text,"	and	so	on.

Note		Wildcard	searching	will	not	work	on	Simplified	Chinese,
Traditional	Chinese,	Japanese,	and	Korean	systems.



Nested	Expressions
Use	nested	expressions	to	combine	searches	to	further	refine	a	search.
You	can	use	Boolean	expressions	and	wildcards	in	a	nested	expression.
For	example,	"example	AND	(program	OR	VI)"	lists	topics	that	contain
"example	program"	or	"example	VI."	You	cannot	nest	expressions	more
than	five	levels.



Boolean	Expressions
Click	the	 	button	to	add	Boolean	expressions	to	a	search.	The	following
Boolean	operators	are	available:

AND	(default)—Returns	topics	that	contain	both	search	terms.	You
do	not	need	to	specify	this	operator	unless	you	are	using	nested
expressions.
OR—Returns	topics	that	contain	either	the	first	or	second	term.
NOT—Returns	topics	that	contain	the	first	term	without	the	second
term.
NEAR—Returns	topics	that	contain	both	terms	within	eight	words
of	each	other.



Search	Options

Use	the	following	checkboxes	on	the	Search	tab	to	customize	a	search:
Search	previous	results—Narrows	the	results	from	a	search	that
returned	too	many	topics.	You	must	remove	the	checkmark	from
this	checkbox	to	search	all	topics.
Match	similar	words—Broadens	a	search	to	return	topics	that
contain	words	similar	to	the	search	terms.	For	example,	a	search
for	"program"	lists	topics	that	include	the	words	"programs,"
"programming,"	and	so	on.
Search	titles	only—Searches	only	in	the	titles	of	topics.



Printing	Help	File	Topics	(Windows	Only)
Complete	the	following	steps	to	print	an	entire	book	from	the	Contents
tab:

1.	 Right-click	the	book.
2.	 Select	Print	from	the	shortcut	menu	to	display	the	Print	Topics

dialog	box.
3.	 Select	the	Print	the	selected	heading	and	all	subtopics	option.

Note		Select	Print	the	selected	topic	if	you	want	to	print
the	single	topic	you	have	selected	in	the	Contents	tab.

4.	 Click	the	OK	button.



Printing	PDF	Documents
This	help	file	may	contain	links	to	PDF	documents.	To	print	PDF
documents,	click	the	print	button	located	on	the	Adobe	Acrobat	Viewer
toolbar.



Switch	Soft	Front	Panel
Use	the	Switch	Soft	Front	Panel	(SFP)	as	a	tool	to	test	the	basic
functionality	of	your	switch	device	and	troubleshoot	your	applications.
Because	the	Switch	SFP	enables	you	to	monitor	connections	on	a	switch
module	as	you	make	them,	the	Switch	SFP	is	also	a	powerful	debugging
tool.



Accessing	the	Switch	Soft	Front	Panel
You	can	access	the	Switch	SFP	from	within	Measurement	&	Automation
Explorer	(MAX)	or	from	the	Start	menu.	To	launch	the	Switch	SFP	from
the	Tools	menu	in	MAX	or	from	the	Start	menu,	NI-SWITCH	2.4	or	later
must	be	installed.

Note		The	Switch	SFP	does	not	support	switch	devices	used	with
the	LabVIEW	Real-Time	Module.

From	MAX
Right-click	on	the	switch	device,	and	select	Test	Panels.

or
Select	Tools»Soft	Front	Panels»NI-SWITCH	Soft	Front	Panel.

From	the	Start	Menu
Select	Start»All	Programs»National	Instruments»NI-SWITCH»NI-
SWITCH	Soft	Front	Panel.



The	Switch	Soft	Front	Panel	Toolbar
Controls
Active	Device—Lists	all	of	the	switch	devices	that	are	installed	on	your
system.	This	list	also	includes	simulated	switch	devices	created	in	MAX.	

Topology—Lists	all	of	the	topologies	associated	with	the	switch	device.



Icons
Select	the	Refresh	icon	to	refresh	the	views	of	the	Schematic	and
Relay	tabs	of	the	Switch	Device	window.
Select	the	Disconnect	All	icon	to	disconnect	all	existing
connections	on	the	switch	device.



Switch	Device	Window
The	Switch	Device	window	displays	information	about	the	active	switch
device	and	is	divided	into	the	following	access	tabs:

Schematic	tab
Relays	tab



The	Schematic	Tab
The	Schematic	tab	contains	a	graphical	representation,	or	schematic,	of
the	topology	of	the	switch	device.
Use	the	Schematic	tab	to	control	the	switch	device.	Simply	click	the
connections	on	the	Schematic	tab	to	make	connections	on	the	switch
device.	The	Switch	SFP	translates	these	clicks	into	the	appropriate
channel	connections	and	makes	driver	calls	to	execute	the	connections.
Additionally,	use	the	Schematic	tab	to	verify	the	connection	state	of	the
switch	device.

Note		When	a	scan	list	is	downloaded	and	the	active	switch	device
is	being	scanned,	the	Schematic	tab	is	not	operational	and	does
not	reflect	the	state	of	the	switch	hardware.

Depending	on	the	topology	you	select	in	the	Topology	listbox	on	the
Switch	SFP	toolbar,	one	of	four	topologies	is	displayed	in	the
Schematic	tab:

Matrix
Multiplexer
Single-Pole	Double-Throw
Single-Pole	Single-Throw



The	Matrix	Topology
A	matrix	is	a	flexible	topology	that	can	connect	multiple	inputs	to	multiple
outputs	organized	as	columns	and	rows.	You	can	connect	any	column	to
any	number	of	rows	and	any	row	to	any	number	of	columns.	Refer	to	the
NI	Switches	Help	for	more	information	about	matrix	topologies.
On	a	matrix	schematic,	row-column	cross-points	represent	potential
connections	on	the	switch	device.	For	visibility,	the	Switch	SFP	displays
each	connection	and	its	associated	connection	route	on	the	matrix
schematic	in	a	different	color.	For	a	channel	with	multiple	connections,
the	Switch	SFP	displays	all	of	the	connections	and	their	associated
connection	routes	in	the	same	color.	Refer	to	row	0	(r0)	of	the	schematic
below	for	an	example	of	a	matrix	channel	with	multiple	connections.

Note		You	can	resize	the	Switch	Device	window	to	see	more
channels.

Refer	to	the	schematic	below	for	an	example	of	the	NI	PXI-2532	in	the	1-
Wire	4×128	matrix	topology.



Make	a	Matrix	Connection
Click	a	row-column	cross-point	to	make	a	connection	on	the	matrix.	To
break	a	connection,	simply	click	the	connection	again.	The	Switch	SFP
makes	the	appropriate	connect/disconnect	calls	to	the	driver.



The	Multiplexer	Topology
A	multiplexer,	or	a	mux,	is	a	topology	in	which	you	can	connect	one	input
to	multiple	outputs	or	one	output	to	multiple	inputs.	Use	this	topology	to
connect	a	sequence	of	channels	to	a	common	line.	Refer	to	the	NI
Switches	Help	for	more	information	about	multiplexer	topologies.

Note		You	can	resize	the	Switch	Device	window	to	see	more
channels.

Refer	to	the	schematic	below	for	an	example	of	the	NI	PXI-2575	in	the	1-
Wire	196×1	mux	topology.



Make	a	Multiplexer	Connection
Click	the	end	of	the	pole	associated	with	the	channel	(left)	you	want	to
connect	to	the	com	channel	(right).	The	Switch	SFP	makes	the
appropriate	connect/disconnect	calls	to	the	driver.



The	Single-Pole	Double-Throw	Topology
The	single-pole	double-throw	(SPDT)	topology	is	composed	of	one-pole,
two-throw	relays.	Based	on	the	default	position	of	the	pole,	one	throw	is
considered	normally	open	(NO)	while	the	other	is	normally	closed	(NC).
Refer	to	the	NI	Switches	Help	for	more	information	about	SPDT
topologies.

Note		You	can	resize	the	Switch	Device	window	to	see	more	SPDT
relays.

Refer	to	the	schematic	below	for	an	example	of	the	NI	PXI-2566	in	the
16-SPDT	topology.



Make	an	SPDT	Connection
Click	on	an	individual	relay	to	make	an	SPDT	connection.	To	connect	no5
to	com5,	for	example,	simply	click	on	the	relay.	The	pole	connects	no5	to
com5,	and	the	Switch	SFP	makes	the	appropriate	connect/disconnect
calls	to	the	driver.



The	Single-Pole	Single-Throw	Topology
The	single-pole	single-throw	(SPST)	topology	is	composed	of	one-pole,
one-throw	relays.	Refer	to	the	NI	Switches	Help	for	more	information
about	SPST	relay	forms.

Note		You	can	resize	the	Switch	Device	window	to	see	more	SPST
relays.

Refer	to	the	schematic	below	for	an	example	of	the	NI	PXI-2564	in	the
16-SPST	topology.



Make	an	SPST	Connection
Click	on	an	individual	relay	to	make	an	SPST	connection.	The
Switch	SFP	translates	this	click	into	the	appropriate	channel	connection
and	makes	the	connect	call	to	the	driver.	To	connect	ch2	to	com2,	for
example,	click	on	the	relay.	The	pole	connects	ch2	to	com2.	To	break	a
connection,	simply	click	the	connection.	The	Switch	SFP	makes	the
appropriate	connect/disconnect	calls	to	the	driver.



The	Relays	Tab
The	Relays	tab	displays	the	name,	position,	and	count	of	each	relay	on
the	switch	device.	Use	the	relay	count	information	to	determine	if	the
relays	on	the	switch	device	are	approaching	their	life-time	expectancy
and	if	scheduled	maintenance	is	needed.	If	your	switch	device	does	not
support	relay	counts,	the	Relays	tab	displays	only	the	names	and	the
positions	of	the	relays.

Note		When	using	the	NI	USB-1359	to	control	a	switch,	the	Switch
SFP	optimizes	updates	to	the	relay	states	by	updating	only	the
relays	that	are	visible.	Relay	states	that	have	not	been	updated	are
displayed	in	blue.	Upon	update,	the	relay	states	are	changed	from
blue	to	black.

Visit	ni.com	and	search	by	the	switch	module	name	to	order	replacement
relays	for	your	switch	module.	For	relay	replacement	instructions,	refer	to
the	Relay	Replacement	section	for	your	switch	module	in	the	NI	Switches
Help.
The	figure	below	illustrates	the	relay	positions	and	counts	for	the	NI	PXI-
2566.





Creating	a	New	Window
Create	a	new	window	to	monitor	multiple	switch	devices	simultaneously.
You	can	create	a	new	window	for	the	same	device	or	different	devices
without	causing	changes	in	the	hardware.	To	open	multiple	instances	of
the	Switch	SFP,	select	File»New	Window.



Customizing	the	Switch	Soft	Front	Panel
You	can	customize	settings	and	operations	in	the	Switch	SFP.



Customizing	the	Refresh	Settings
Select	File»Options,	and	click	Automatic	Refresh	to	disable	the
automatic	refresh	settings	for	the	Schematic	and	Relay	tabs.	To	enable
the	refresh	settings,	click	Automatic	Refresh	again.	Type	in	a	delay
time,	in	milliseconds,	to	customize	the	delay	interval,	or	the	amount	of
time	that	must	elapse	before	the	Schematic	and	Relays	tabs	are
refreshed	with	the	latest	information	for	the	switch	device.



Customizing	Relay	Operations
Select	File»Options,	and	click	Enable	changing	relay	positions	to
customize	relay	operations.	With	the	Enable	changing	relay	positions
control	enabled,	you	can	change	the	relay	positions	of	the	switch	device
from	within	the	Relays	tab.



Relay	Maintenance
Expand	this	topic	for	information	about	relay	maintenance,	including
instructions	for	replacing	and	resetting	a	relay.



Determining	Relay	End-of-Life
Relay	use	affects,	and	relay	arcing	can	accelerate,	the	end-of-life	of	a
relay.	For	more	detailed	information	about	relay	life	and	arcing,	refer	to
the	NI	Switches	Help.	To	determine	the	expected	life	of	your	relay,	refer
to	the	specifications	document	for	your	switch	module.
To	determine	if	you	need	to	replace	a	relay,	monitor	the	relay	count	of
your	switch	module	in	the	Relays	Tab	of	the	Switch	Device	window.	If
you	have	switched	a	relay	beyond	its	expected	life	or	it	has	sustained
excessive	arcing,	refer	to	Replacing	a	Relay.



Replacing	a	Relay
Refer	to	the	Relay	Replacement	topic	for	your	switch	module	in	the
NI	Switches	Help	for	instructions	on	how	to	replace	a	relay.	After	you
replace	the	relay,	refer	to	Resetting	a	Relay	Count.



Resetting	a	Relay	Count
Caution		Because	the	Switch	SFP	disables	relay	count
synchronization	during	the	relay	count	reset	process,	counts	may
be	lost	for	any	relay	operation	performed	up	to	ten	minutes	prior	to
resetting	a	relay	count.

Complete	the	following	steps	to	reset	a	relay	count.
1.	 Select	File»Relay	Maintenance.	The	Relay	Maintenance	dialog

box	appears.
2.	 Select	the	relay	to	reset	from	the	Relay	Name	drop-down	list.
3.	 (Optional)	Record	the	Existing	Relay	Count	for	your	records.
4.	 Verify	the	relay	you	selected	for	reset,	and	click	OK	to	reset	the

relay	count	to	zero.	The	Switch	SFP	saves	the	new	relay	count	to
the	hardware	and	resets	the	active	device.



Restoring	a	Relay	Count
In	case	of	unintentional	relay	reset,	complete	the	following	steps	to
restore	a	previous	relay	count.

1.	 Repeat	steps	1	and	2	of	Resetting	a	Relay.
2.	 Verify	the	relay	you	selected	for	reset,	and	enable	Edit	Count.
3.	 Type	the	previous	count	in	New	Relay	Count	and	click	OK.	The

Switch	SFP	saves	the	relay	count	to	the	hardware	and	resets	the
active	device.



Remotely	Accessing	the	Switch	Soft	Front	Panel
Using	a	Browser
You	can	view	and	control	the	Switch	SFP	and	debug	switch	applications
remotely	using	a	Web	browser.	To	access	the	Switch	SFP	from	a	client
machine,	first	configure	the	Web	host	feature	on	the	server	machine.



Configuring	the	Server
Complete	the	following	steps	to	configure	the	Web	host	feature	on	the
server	machine.

1.	 Run	the	Switch	SFP	on	the	server.
2.	 Select	File»Options	to	display	the	Options	dialog	box.
3.	 Select	the	Web	Host	tab.
4.	 Click	the	Enable	Web	host	checkbox.
5.	 Replace	the	value	of	Listen	on	port	number	with	the	TCP	port

value	you	want	to	use.
Note		If	you	use	a	TCP	port	value	other	than	80,	you	must
specify	the	TCP	port	value	on	the	URL	that	refers	to	the
server	when	accessing	the	Switch	SFP	from	a	client
machine.	For	example,	if	your	TCP	port	value	is	8000,
specify	the	TCP	port	value	on	the	URL	as
http://ipaddress:8000/SwitchSoftFrontPanel.htm.

After	you	configure	the	server,	the	client	can	view	and	control	the	Switch
SFP.	If	you	want	to	disable	control	of	the	Switch	SFP	and	leave	only
viewing	capability	from	the	client,	right-click	anywhere	on	the	Switch	SFP
window	of	the	server	outside	of	the	access	tabs	(i.e.,	the	Schematic	or
Relay	tab),	and	select	Regain	Control	from	the	shortcut	menu.	Control
of	the	Switch	SFP	then	returns	to	the	server,	and	the	server	is	locked.
When	the	server	is	locked,	the	client	can	view	the	Switch	SFP	but	cannot
control	it.
To	unlock	the	server,	right-click	anywhere	on	the	Switch	SFP	window
outside	of	the	access	tabs,	and	select	Unlock	Control	from	the	shortcut
menu.	The	server	is	unlocked,	and	control	returns	to	the	client.



Remotely	Accessing	the	Switch	SFP
Complete	the	following	steps	to	view	and	control	the	Switch	SFP
remotely	using	a	browser	on	a	client	machine.

1.	 Launch	the	default	browser	on	the	client.
2.	 In	the	URL	of	the	browser,	enter	the	IP	address	or	computer	name

of	the	server	followed	by	SwitchSoftFrontPanel.htm,	for	example,
http://ipaddress/SwitchSoftFrontPanel.htm.	

Note		If	the	LabVIEW	Run-Time	Engine	is	not	installed	on	the
client,	entering	the	URL	prompts	you	for	installation.	You	can	install
the	LabVIEW	Run-Time	Engine	from	the	LabVIEW	CD	or	visit	the
National	Instruments	Web	site	to	download	the	latest	version.
Refer	to	the	LabVIEW	Help	for	more	information	about	the
LabVIEW	Run-Time	Engine.

To	close	your	connection	to	the	Switch	SFP	running	on	the	server,	click
the	close	glyph	on	the	browser	window.
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Additional	Considerations
Only	the	server	window	titled	Switch	Soft	Front	Panel	-	Web	Host	can

be	remotely	controlled.	You	cannot	remotely	control	new	windows
created	on	the	server.
The	File»New	Window	menu	item	does	not	launch	a	new	window	on

the	client.	Launch	separate	instances	of	the	Switch	SFP	on	separate
TCP	ports	to	view	multiple	windows.
Online	help	is	only	available	on	the	server	machine.



Hot	Keys	and	Keyboard	Shortcuts
The	table	below	lists	the	hot	keys	and	keyboard	shortcuts	you	can	use
with	Switch	SFP:

<F5> Refreshes	the	Schematic	and	Relays	tabs	of	the	Switch
Device	window

<F1>	 Displays	online	help
<Ctrl+N> Creates	a	new	window
<Ctrl+Q>	 Exits	Switch	SFP



Debugging	with	the	Switch	Soft	Front	Panel
When	you	launch	the	Switch	SFP	for	a	particular	switch	device,	the
current	connections	on	the	switch	device	are	displayed	in	the	Schematic
tab	of	the	Switch	Device	window.
By	default,	the	Switch	SFP	automatically	updates	all	changes	in	the
connection	state	of	the	switch	device.	If	an	application	changes	the	state
of	the	connections	on	the	switch	device,	and	you	have	enabled	the
Automatic	Refresh	option	in	the	Switch	SFP,	this	change	is	reflected	in
the	Schematic	tab.	For	example,	if	you	have	an	application	running	in
LabVIEW,	the	Switch	SFP	displays	the	connections	made	by	the
LabVIEW	application.



Important	Information
Warranty
Copyright
Trademarks
Patents
Warning	Regarding	Use	of	NI	Products



Warranty
The	media	on	which	you	receive	National	Instruments	software	are
warranted	not	to	fail	to	execute	programming	instructions,	due	to	defects
in	materials	and	workmanship,	for	a	period	of	90	days	from	date	of
shipment,	as	evidenced	by	receipts	or	other	documentation.	National
Instruments	will,	at	its	option,	repair	or	replace	software	media	that	do	not
execute	programming	instructions	if	National	Instruments	receives	notice
of	such	defects	during	the	warranty	period.	National	Instruments	does	not
warrant	that	the	operation	of	the	software	shall	be	uninterrupted	or	error
free.
A	Return	Material	Authorization	(RMA)	number	must	be	obtained	from
the	factory	and	clearly	marked	on	the	outside	of	the	package	before	any
equipment	will	be	accepted	for	warranty	work.	National	Instruments	will
pay	the	shipping	costs	of	returning	to	the	owner	parts	which	are	covered
by	warranty.
National	Instruments	believes	that	the	information	in	this	document	is
accurate.	The	document	has	been	carefully	reviewed	for	technical
accuracy.	In	the	event	that	technical	or	typographical	errors	exist,
National	Instruments	reserves	the	right	to	make	changes	to	subsequent
editions	of	this	document	without	prior	notice	to	holders	of	this	edition.
The	reader	should	consult	National	Instruments	if	errors	are	suspected.
In	no	event	shall	National	Instruments	be	liable	for	any	damages	arising
out	of	or	related	to	this	document	or	the	information	contained	in	it.
EXCEPT	AS	SPECIFIED	HEREIN,	NATIONAL	INSTRUMENTS	MAKES
NO	WARRANTIES,	EXPRESS	OR	IMPLIED,	AND	SPECIFICALLY
DISCLAIMS	ANY	WARRANTY	OF	MERCHANTABILITY	OR	FITNESS
FOR	A	PARTICULAR	PURPOSE.	CUSTOMER'S	RIGHT	TO	RECOVER
DAMAGES	CAUSED	BY	FAULT	OR	NEGLIGENCE	ON	THE	PART	OF
NATIONAL	INSTRUMENTS	SHALL	BE	LIMITED	TO	THE	AMOUNT
THERETOFORE	PAID	BY	THE	CUSTOMER.	NATIONAL
INSTRUMENTS	WILL	NOT	BE	LIABLE	FOR	DAMAGES	RESULTING
FROM	LOSS	OF	DATA,	PROFITS,	USE	OF	PRODUCTS,	OR
INCIDENTAL	OR	CONSEQUENTIAL	DAMAGES,	EVEN	IF	ADVISED	OF
THE	POSSIBILITY	THEREOF.	This	limitation	of	the	liability	of	National
Instruments	will	apply	regardless	of	the	form	of	action,	whether	in
contract	or	tort,	including	negligence.	Any	action	against	National
Instruments	must	be	brought	within	one	year	after	the	cause	of	action



accrues.	National	Instruments	shall	not	be	liable	for	any	delay	in
performance	due	to	causes	beyond	its	reasonable	control.	The	warranty
provided	herein	does	not	cover	damages,	defects,	malfunctions,	or
service	failures	caused	by	owner's	failure	to	follow	the	National
Instruments	installation,	operation,	or	maintenance	instructions;	owner's
modification	of	the	product;	owner's	abuse,	misuse,	or	negligent	acts;
and	power	failure	or	surges,	fire,	flood,	accident,	actions	of	third	parties,
or	other	events	outside	reasonable	control.



Copyright
Under	the	copyright	laws,	this	publication	may	not	be	reproduced	or
transmitted	in	any	form,	electronic	or	mechanical,	including	photocopying,
recording,	storing	in	an	information	retrieval	system,	or	translating,	in
whole	or	in	part,	without	the	prior	written	consent	of	National	Instruments
Corporation.
National	Instruments	respects	the	intellectual	property	of	others,	and	we
ask	our	users	to	do	the	same.	NI	software	is	protected	by	copyright	and
other	intellectual	property	laws.	Where	NI	software	may	be	used	to
reproduce	software	or	other	materials	belonging	to	others,	you	may	use
NI	software	only	to	reproduce	materials	that	you	may	reproduce	in
accordance	with	the	terms	of	any	applicable	license	or	other	legal
restriction.



Trademarks
National	Instruments,	NI,	ni.com,	and	LabVIEW	are	trademarks	of
National	Instruments	Corporation.	Refer	to	the	Terms	of	Use	section	on
ni.com/legal	for	more	information	about	National	Instruments	trademarks.
FireWire®	is	the	registered	trademark	of	Apple	Computer,	Inc.
Handle	Graphics®,	MATLAB®,	Real-Time	Workshop®,	Simulink®,	and
Stateflow®	are	registered	trademarks,	and	TargetBox™,	xPC
TargetBox™,	and	Target	Language	Compiler™	are	trademarks	of	The
MathWorks,	Inc.
Tektronix®	and	Tek	are	registered	trademarks	of	Tektronix,	Inc.
Other	product	and	company	names	mentioned	herein	are	trademarks	or
trade	names	of	their	respective	companies.
Members	of	the	National	Instruments	Alliance	Partner	Program	are
business	entities	independent	from	National	Instruments	and	have	no
agency,	partnership,	or	joint-venture	relationship	with	National
Instruments.
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Patents
For	patents	covering	National	Instruments	products,	refer	to	the
appropriate	location:	Help»Patents	in	your	software,	the	patents.txt	file	on
your	CD,	or	ni.com/patents.
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WARNING	REGARDING	USE	OF	NATIONAL
INSTRUMENTS	PRODUCTS
(1)	NATIONAL	INSTRUMENTS	PRODUCTS	ARE	NOT	DESIGNED
WITH	COMPONENTS	AND	TESTING	FOR	A	LEVEL	OF	RELIABILITY
SUITABLE	FOR	USE	IN	OR	IN	CONNECTION	WITH	SURGICAL
IMPLANTS	OR	AS	CRITICAL	COMPONENTS	IN	ANY	LIFE	SUPPORT
SYSTEMS	WHOSE	FAILURE	TO	PERFORM	CAN	REASONABLY	BE
EXPECTED	TO	CAUSE	SIGNIFICANT	INJURY	TO	A	HUMAN.
(2)	IN	ANY	APPLICATION,	INCLUDING	THE	ABOVE,	RELIABILITY	OF
OPERATION	OF	THE	SOFTWARE	PRODUCTS	CAN	BE	IMPAIRED	BY
ADVERSE	FACTORS,	INCLUDING	BUT	NOT	LIMITED	TO
FLUCTUATIONS	IN	ELECTRICAL	POWER	SUPPLY,	COMPUTER
HARDWARE	MALFUNCTIONS,	COMPUTER	OPERATING	SYSTEM
SOFTWARE	FITNESS,	FITNESS	OF	COMPILERS	AND
DEVELOPMENT	SOFTWARE	USED	TO	DEVELOP	AN	APPLICATION,
INSTALLATION	ERRORS,	SOFTWARE	AND	HARDWARE
COMPATIBILITY	PROBLEMS,	MALFUNCTIONS	OR	FAILURES	OF
ELECTRONIC	MONITORING	OR	CONTROL	DEVICES,	TRANSIENT
FAILURES	OF	ELECTRONIC	SYSTEMS	(HARDWARE	AND/OR
SOFTWARE),	UNANTICIPATED	USES	OR	MISUSES,	OR	ERRORS	ON
THE	PART	OF	THE	USER	OR	APPLICATIONS	DESIGNER	(ADVERSE
FACTORS	SUCH	AS	THESE	ARE	HEREAFTER	COLLECTIVELY
TERMED	"SYSTEM	FAILURES").	ANY	APPLICATION	WHERE	A
SYSTEM	FAILURE	WOULD	CREATE	A	RISK	OF	HARM	TO
PROPERTY	OR	PERSONS	(INCLUDING	THE	RISK	OF	BODILY
INJURY	AND	DEATH)	SHOULD	NOT	BE	RELIANT	SOLELY	UPON	ONE
FORM	OF	ELECTRONIC	SYSTEM	DUE	TO	THE	RISK	OF	SYSTEM
FAILURE.	TO	AVOID	DAMAGE,	INJURY,	OR	DEATH,	THE	USER	OR
APPLICATION	DESIGNER	MUST	TAKE	REASONABLY	PRUDENT
STEPS	TO	PROTECT	AGAINST	SYSTEM	FAILURES,	INCLUDING	BUT
NOT	LIMITED	TO	BACK-UP	OR	SHUT	DOWN	MECHANISMS.
BECAUSE	EACH	END-USER	SYSTEM	IS	CUSTOMIZED	AND
DIFFERS	FROM	NATIONAL	INSTRUMENTS'	TESTING	PLATFORMS
AND	BECAUSE	A	USER	OR	APPLICATION	DESIGNER	MAY	USE
NATIONAL	INSTRUMENTS	PRODUCTS	IN	COMBINATION	WITH
OTHER	PRODUCTS	IN	A	MANNER	NOT	EVALUATED	OR
CONTEMPLATED	BY	NATIONAL	INSTRUMENTS,	THE	USER	OR



APPLICATION	DESIGNER	IS	ULTIMATELY	RESPONSIBLE	FOR
VERIFYING	AND	VALIDATING	THE	SUITABILITY	OF	NATIONAL
INSTRUMENTS	PRODUCTS	WHENEVER	NATIONAL	INSTRUMENTS
PRODUCTS	ARE	INCORPORATED	IN	A	SYSTEM	OR	APPLICATION,
INCLUDING,	WITHOUT	LIMITATION,	THE	APPROPRIATE	DESIGN,
PROCESS	AND	SAFETY	LEVEL	OF	SUCH	SYSTEM	OR
APPLICATION.



Technical	Support	and	Professional	Services
Visit	the	following	sections	of	the	National	Instruments	Web	site	at	ni.com
for	technical	support	and	professional	services:

Support—Online	technical	support	resources	at	ni.com/support
include	the	following:

Self-Help	Resources—For	answers	and	solutions,	visit	the
award-winning	National	Instruments	Web	site	for	software
drivers	and	updates,	a	searchable	KnowledgeBase,	product
manuals,	step-by-step	troubleshooting	wizards,	thousands	of
example	programs,	tutorials,	application	notes,	instrument
drivers,	and	so	on.
Free	Technical	Support—All	registered	users	receive	free
Basic	Service,	which	includes	access	to	hundreds	of
Applications	Engineers	worldwide	in	the	NI	Developer
Exchange	at	ni.com/exchange.	National	Instruments
Applications	Engineers	make	sure	every	question	receives
an	answer.
For	information	about	other	technical	support	options	in	your
area,	visit	ni.com/services	or	contact	your	local	office	at
ni.com/contact.

Training	and	Certification—Visit	ni.com/training	for	self-paced
training,	eLearning	virtual	classrooms,	interactive	CDs,	and
Certification	program	information.	You	also	can	register	for
instructor-led,	hands-on	courses	at	locations	around	the	world.
System	Integration—If	you	have	time	constraints,	limited	in-house
technical	resources,	or	other	project	challenges,	National
Instruments	Alliance	Partner	members	can	help.	To	learn	more,
call	your	local	NI	office	or	visit	ni.com/alliance.

If	you	searched	ni.com	and	could	not	find	the	answers	you	need,	contact
your	local	office	or	NI	corporate	headquarters.	You	also	can	visit	the
Worldwide	Offices	section	of	ni.com/niglobal	to	access	the	branch	office
Web	sites,	which	provide	up-to-date	contact	information,	support	phone
numbers,	email	addresses,	and	current	events.
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Branch	Offices
Office Telephone	Number
Australia 1800	300	800
Austria 43	0	662	45	79	90	0
Belgium 32	0	2	757	00	20
Brazil 55	11	3262	3599
Canada 800	433	3488
China 86	21	6555	7838
Czech	Republic 420	224	235	774
Denmark 45	45	76	26	00
Finland 385	0	9	725	725	11
France 33	0	1	48	14	24	24
Germany 49	0	89	741	31	30
India 91	80	41190000
Israel 972	0	3	6393737
Italy 39	02	413091
Japan 81	3	5472	2970
Korea 82	02	3451	3400
Lebanon 961	0	1	33	28	28
Malaysia 1800	887710
Mexico 01	800	010	0793
Netherlands 31	0	348	433	466
New	Zealand 0800	553	322
Norway 47	0	66	90	76	60
Poland 48	22	3390150
Portugal 351	210	311	210
Russia 7	095	783	68	51
Singapore 1800	226	5886
Slovenia 386	3	425	4200



South	Africa 27	0	11	805	8197
Spain 34	91	640	0085
Sweden 46	0	8	587	895	00
Switzerland 41	56	200	51	51
Taiwan 886	02	2377	2222
Thailand 662	278	6777
United	Kingdom 44	0	1635	523545
United	States	(Corporate) 512	683	0100
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