
Conventions
This	help	file	uses	the	following	conventions:

» The	»	symbol	leads	you	through	nested	menu	items	and
dialog	box	options	to	a	final	action.	The	sequence	File»Page
Setup»Options	directs	you	to	pull	down	the	File	menu,
select	the	Page	Setup	item,	and	select	Options	from	the	last
dialog	box.
This	icon	denotes	a	tip,	which	alerts	you	to	advisory
information.
This	icon	denotes	a	note,	which	alerts	you	to	important
information.

bold Bold	text	denotes	items	that	you	must	select	or	click	on	in	the
software,	such	as	menu	items	and	dialog	box	options.	Bold
text	also	denotes	parameter	names,	emphasis,	or	an
introduction	to	a	key	concept.

green Underlined	text	in	this	color	denotes	a	link	to	a	help	topic,
help	file,	or	Web	address.

italic Italic	text	denotes	variables	or	cross	references.	This	font
also	denotes	text	that	is	a	placeholder	for	a	word	or	value
that	you	must	supply.

monospace Text	in	this	font	denotes	text	or	characters	that	you	should
enter	from	the	keyboard,	sections	of	code,	programming
examples,	and	syntax	examples.	This	font	is	also	used	for
the	proper	names	of	disk	drives,	paths,	directories,
programs,	subprograms,	subroutines,	device	names,
functions,	operations,	variables,	filenames,	and	extensions.



Importing	and	Exporting	Configuration	Files
Use	the	Configuration	Import	and	Export	Wizards	to	copy	configuration
data	to	or	from	a	system.	You	can	use	these	wizards	to:

Package	configuration	data	for	deployment	on	other	systems
Back	up	and	restore	your	system	configuration
Note		Some	products	do	not	support	these	wizards.	Refer	to	your
product's	documentation	for	more	information.



Using	the	Configuration	Import	Wizard
Use	the	Configuration	Import	Wizard	to	copy	saved	configuration	data
from	a	file	to	a	system.	To	start	the	Configuration	Import	Wizard,	select
the	File»Import	menu	option.
The	first	page	of	the	wizard	lists	the	installed	National	Instruments
products	that	support	the	wizard.	The	list	varies	depending	on	which
products	are	installed.	If	an	installed	product	does	not	appear	in	this	list,
an	updated	version	that	supports	the	wizard	may	be	available	on	the
National	Instruments	Web	site,	which	you	can	access	using	the
Tools»National	Instruments	Product	Updates	menu	selection.
You	must	have	the	corresponding	product	installed	for	the	configuration
data	that	you	are	importing.	For	example,	to	import	an	NI-DAQmx	task,
you	must	have	NI-DAQmx	installed.
You	can	import	to	the	local	system	or	to	a	remote	system.	If	you	import	to
a	remote	system,	the	wizard	sends	the	configuration	data	over	the
network	to	the	remote	system.	Importing	to	a	remote	system	requires	that
the	product	be	installed	on	both	local	and	remote	systems.	Some
products	may	also	require	that	identical	versions	of	the	product	be
installed	in	both	places.
You	can	specify	a	remote	system	using	the	supplied	drop-down	list	or	by
entering	an	IP	address.
The	second	page	of	the	wizard	shows	the	data	that	is	available	to	be
copied.	Select	the	data	for	copying	by	clicking	the	checkboxes	next	to	the
data	items.
The	second	wizard	page	also	shows	warnings	and	conflicts	for	the	data.
Warnings	and	conflicts	appear	to	the	right	of	the	data.
Some	warnings	allow	user	input.	For	example,	when	importing	device
configuration	data	to	a	system	that	has	multiple	compatible	devices,	a
warning	appears	that	allows	you	to	select	the	destination	device.	You	can
click	on	the	text	underlined	in	blue	to	see	a	drop-down	list	of	the	available
devices	from	which	to	choose.	The	configuration	data	of	the	selected
device	is	then	overwritten	when	you	import.



Using	the	Configuration	Export	Wizard
Use	the	Configuration	Export	Wizard	to	copy	configuration	data	from	a
system	to	a	file.	To	start	the	Configuration	Export	Wizard,	select	the
File»Export	menu	option.
The	first	page	of	the	wizard	lists	the	installed	National	Instruments
products	that	support	the	wizard.	The	list	varies	depending	on	which
products	are	installed.	If	an	installed	product	does	not	appear	in	this	list,
an	updated	version	that	supports	the	wizard	may	be	available	on	the
National	Instruments	Web	site,	which	you	can	access	using	the
Tools»National	Instruments	Product	Updates	menu	selection.
You	can	export	from	the	local	system	or	from	a	remote	system.	If	you
export	from	a	remote	system,	the	wizard	retrieves	configuration	data	from
the	remote	system	over	the	network	and	creates	an	export	file	on	the
local	system.	Exporting	from	a	remote	system	requires	that	the	product
be	installed	on	both	local	and	remote	systems.	Some	products	may	also
require	that	identical	versions	of	the	product	be	installed	in	both	places.
You	can	specify	a	remote	system	using	the	supplied	drop-down	list	or	by
entering	an	IP	address.
You	can	specify	the	file	type	using	the	supplied	drop-down	list.	The	list
will	vary	depending	on	which	products	are	installed.	Some	file	types	are
product-specific	and	can	only	hold	data	associated	with	a	specific
product.	The	file	type	"NI	configuration	export"	(.nce)	is	not	product-
specific	and	can	hold	data	associated	with	multiple	products.
The	second	page	of	the	wizard	shows	the	data	that	is	available	to	be
copied.	Select	the	data	you	want	to	copy	by	clicking	the	checkboxes	next
to	the	data	items.
Data	is	shown	on	the	second	wizard	page	only	if:

the	product	that	owns	the	data	supports	the	wizard
the	product	that	owns	the	data	supports	the	selected	file	type
the	product	that	owns	the	data	is	installed	on	the	selected	system
(in	the	remote	system	case)

Other	data	is	not	shown	on	the	second	wizard	page.
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Warranty
The	media	on	which	you	receive	National	Instruments	software	are
warranted	not	to	fail	to	execute	programming	instructions,	due	to	defects
in	materials	and	workmanship,	for	a	period	of	90	days	from	date	of
shipment,	as	evidenced	by	receipts	or	other	documentation.	National
Instruments	will,	at	its	option,	repair	or	replace	software	media	that	do	not
execute	programming	instructions	if	National	Instruments	receives	notice
of	such	defects	during	the	warranty	period.	National	Instruments	does	not
warrant	that	the	operation	of	the	software	shall	be	uninterrupted	or	error
free.
A	Return	Material	Authorization	(RMA)	number	must	be	obtained	from
the	factory	and	clearly	marked	on	the	outside	of	the	package	before	any
equipment	will	be	accepted	for	warranty	work.	National	Instruments	will
pay	the	shipping	costs	of	returning	to	the	owner	parts	which	are	covered
by	warranty.
National	Instruments	believes	that	the	information	in	this	document	is
accurate.	The	document	has	been	carefully	reviewed	for	technical
accuracy.	In	the	event	that	technical	or	typographical	errors	exist,
National	Instruments	reserves	the	right	to	make	changes	to	subsequent
editions	of	this	document	without	prior	notice	to	holders	of	this	edition.
The	reader	should	consult	National	Instruments	if	errors	are	suspected.
In	no	event	shall	National	Instruments	be	liable	for	any	damages	arising
out	of	or	related	to	this	document	or	the	information	contained	in	it.
Except	as	specified	herein,	National	Instruments	makes	no
warranties,	express	or	implied,	and	specifically	disclaims	any
warranty	of	merchantability	or	fitness	for	a	particular	purpose.
Customer's	right	to	recover	damages	caused	by	fault	or	negligence
on	the	part	of	National	Instruments	shall	be	limited	to	the	amount
theretofore	paid	by	the	customer.	National	Instruments	will	not	be
liable	for	damages	resulting	from	loss	of	data,	profits,	use	of
products,	or	incidental	or	consequential	damages,	even	if	advised
of	the	possibility	thereof.	This	limitation	of	the	liability	of	National
Instruments	will	apply	regardless	of	the	form	of	action,	whether	in
contract	or	tort,	including	negligence.	Any	action	against	National
Instruments	must	be	brought	within	one	year	after	the	cause	of	action
accrues.	National	Instruments	shall	not	be	liable	for	any	delay	in
performance	due	to	causes	beyond	its	reasonable	control.	The	warranty



provided	herein	does	not	cover	damages,	defects,	malfunctions,	or
service	failures	caused	by	owner's	failure	to	follow	the	National
Instruments	installation,	operation,	or	maintenance	instructions;	owner's
modification	of	the	product;	owner's	abuse,	misuse,	or	negligent	acts;
and	power	failure	or	surges,	fire,	flood,	accident,	actions	of	third	parties,
or	other	events	outside	reasonable	control.



Copyright
Under	the	copyright	laws,	this	publication	may	not	be	reproduced	or
transmitted	in	any	form,	electronic	or	mechanical,	including	photocopying,
recording,	storing	in	an	information	retrieval	system,	or	translating,	in
whole	or	in	part,	without	the	prior	written	consent	of	National	Instruments
Corporation.
This	product	includes	software	developed	by	the	Apache	Software
Foundation	(http://www.apache.org/).	Copyright	1999	The	Apache
Software	Foundation.	All	rights	reserved.

javascript:WWW(WWW_APACHE)


Trademarks
National	Instruments,	NI,	ni.com,	and	LabVIEW	are	trademarks	of
National	Instruments	Corporation.	Refer	to	the	Terms	of	Use	section	on
ni.com/legal	for	more	information	about	National	Instruments	trademarks.
FireWire®	is	the	registered	trademark	of	Apple	Computer,	Inc.
Handle	Graphics®,	MATLAB®,	Real-Time	Workshop®,	Simulink®,	and
Stateflow®	are	registered	trademarks,	and	TargetBox2™,	xPC
TargetBox2™,	and	Target	Language	Compiler™	are	trademarks	of	The
MathWorks,	Inc.
Tektronix®	and	Tek	are	registered	trademarks	of	Tektronix,	Inc.
Other	product	and	company	names	mentioned	herein	are	trademarks	or
trade	names	of	their	respective	companies.
Members	of	the	National	Instruments	Alliance	Partner	Program	are
business	entities	independent	from	National	Instruments	and	have	no
agency,	partnership,	or	joint-venture	relationship	with	National
Instruments.
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Patents
For	patents	covering	National	Instruments	products,	refer	to	the
appropriate	location:	Help»Patents	in	your	software,	the	patents.txt	file	on
your	CD,	or	ni.com/patents.

javascript:WWW(WWW_Patents)


WARNING	REGARDING	USE	OF	NATIONAL
INSTRUMENTS	PRODUCTS
(1)	National	Instruments	products	are	not	designed	with
components	and	testing	for	a	level	of	reliability	suitable	for	use	in	or
in	connection	with	surgical	implants	or	as	critical	components	in
any	life	support	systems	whose	failure	to	perform	can	reasonably
be	expected	to	cause	significant	injury	to	a	human.
(2)	In	any	application,	including	the	above,	reliability	of	operation	of
the	software	products	can	be	impaired	by	adverse	factors,	including
but	not	limited	to	fluctuations	in	electrical	power	supply,	computer
hardware	malfunctions,	computer	operating	system	software
fitness,	fitness	of	compilers	and	development	software	used	to
develop	an	application,	installation	errors,	software	and	hardware
compatibility	problems,	malfunctions	or	failures	of	electronic
monitoring	or	control	devices,	transient	failures	of	electronic
systems	(hardware	and/or	software),	unanticipated	uses	or
misuses,	or	errors	on	the	part	of	the	user	or	applications	designer
(adverse	factors	such	as	these	are	hereafter	collectively	termed
"system	failures").	Any	application	where	a	system	failure	would
create	a	risk	of	harm	to	property	or	persons	(including	the	risk	of
bodily	injury	and	death)	should	not	be	reliant	solely	upon	one	form
of	electronic	system	due	to	the	risk	of	system	failure.	To	avoid
damage,	injury,	or	death,	the	user	or	application	designer	must	take
reasonably	prudent	steps	to	protect	against	system	failures,
including	but	not	limited	to	back-up	or	shut	down	mechanisms.
Because	each	end-user	system	is	customized	and	differs	from
National	Instruments'	testing	platforms	and	because	a	user	or
application	designer	may	use	National	Instruments	products	in
combination	with	other	products	in	a	manner	not	evaluated	or
contemplated	by	National	Instruments,	the	user	or	application
designer	is	ultimately	responsible	for	verifying	and	validating	the
suitability	of	National	Instruments	products	whenever	National
Instruments	products	are	incorporated	in	a	system	or	application,
including,	without	limitation,	the	appropriate	design,	process	and
safety	level	of	such	system	or	application.



Technical	Support	and	Professional	Services
Visit	the	following	sections	of	the	National	Instruments	Web	site	at	ni.com
for	technical	support	and	professional	services:

Support—Online	technical	support	resources	at	ni.com/support
include	the	following:

Self-Help	Resources—For	answers	and	solutions,	visit	the
award-winning	National	Instruments	Web	site	for	software
drivers	and	updates,	a	searchable	KnowledgeBase,	product
manuals,	step-by-step	troubleshooting	wizards,	thousands	of
example	programs,	tutorials,	application	notes,	instrument
drivers,	and	so	on.
Free	Technical	Support—All	registered	users	receive	free
Basic	Service,	which	includes	access	to	hundreds	of
Applications	Engineers	worldwide	in	the	NI	Discussion
Forums	at	ni.com/forums.	National	Instruments	Applications
Engineers	make	sure	every	question	receives	an	answer.
For	information	about	other	technical	support	options	in	your
area,	visit	ni.com/services	or	contact	your	local	office	at
ni.com/contact.

Training	and	Certification—Visit	ni.com/training	for	self-paced
training,	eLearning	virtual	classrooms,	interactive	CDs,	and
Certification	program	information.	You	also	can	register	for
instructor-led,	hands-on	courses	at	locations	around	the	world.
System	Integration—If	you	have	time	constraints,	limited	in-house
technical	resources,	or	other	project	challenges,	National
Instruments	Alliance	Partner	members	can	help.	To	learn	more,
call	your	local	NI	office	or	visit	ni.com/alliance.

If	you	searched	ni.com	and	could	not	find	the	answers	you	need,	contact
your	local	office	or	NI	corporate	headquarters.	You	also	can	visit	the
Worldwide	Offices	section	of	ni.com/niglobal	to	access	the	branch	office
Web	sites,	which	provide	up-to-date	contact	information,	support	phone
numbers,	email	addresses,	and	current	events.
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Branch	Offices
Office Telephone	Number
Australia 1800	300	800
Austria 43	0	662	45	79	90	0
Belgium 32	0	2	757	00	20
Brazil 55	11	3262	3599
Canada 800	433	3488
China 86	21	6555	7838
Czech	Republic 420	224	235	774
Denmark 45	45	76	26	00
Finland 385	0	9	725	725	11
France 33	0	1	48	14	24	24
Germany 49	0	89	741	31	30
India 91	80	41190000
Israel 972	0	3	6393737
Italy 39	02	413091
Japan 81	3	5472	2970
Korea 82	02	3451	3400
Lebanon 961	0	1	33	28	28
Malaysia 1800	887710
Mexico 01	800	010	0793
Netherlands 31	0	348	433	466
New	Zealand 0800	553	322
Norway 47	0	66	90	76	60
Poland 48	22	3390150
Portugal 351	210	311	210
Russia 7	495	783	68	51
Singapore 1800	226	5886
Slovenia 386	3	425	42	00



South	Africa 27	0	11	805	8197
Spain 34	91	640	0085
Sweden 46	0	8	587	895	00
Switzerland 41	56	200	51	51
Taiwan 886	02	2377	2222
Thailand 662	278	6777
Turkey 90	212	279	3031
United	Kingdom 44	0	1635	523545
United	States	(Corporate) 512	683	0100


