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Conventions
This	help	file	uses	the	following	conventions:
» The	»	symbol	leads	you	through	nested	menu	items	and

dialog	box	options	to	a	final	action.	The	sequence	File»Page
Setup»Options	directs	you	to	pull	down	the	File	menu,
select	the	Page	Setup	item,	and	select	Options	from	the	last
dialog	box.
This	icon	denotes	a	tip,	which	alerts	you	to	advisory
information.
This	icon	denotes	a	note,	which	alerts	you	to	important
information.

bold Bold	text	denotes	items	that	you	must	select	or	click	on	in	the
software,	such	as	menu	items	and	dialog	box	options.	Bold
text	also	denotes	parameter	names,	emphasis,	or	an
introduction	to	a	key	concept.

green Underlined	text	in	this	color	denotes	a	link	to	a	help	topic,
help	file,	or	Web	address.

italic Italic	text	denotes	variables	or	cross	references.	This	font
also	denotes	text	that	is	a	placeholder	for	a	word	or	value
that	you	must	supply.

monospace Text	in	this	font	denotes	text	or	characters	that	you	should
enter	from	the	keyboard,	sections	of	code,	programming
examples,	and	syntax	examples.	This	font	is	also	used	for
the	proper	names	of	disk	drives,	paths,	directories,
programs,	subprograms,	subroutines,	device	names,
functions,	operations,	variables,	filenames	and	extensions,
and	code	excerpts.



Navigating	Help	(Windows	Only)
To	navigate	this	help	file,	use	the	Contents,	Index,	and	Search	tabs	to
the	left	of	this	window	or	use	the	following	toolbar	buttons	located	above
the	tabs:

Hide—Hides	the	navigation	pane	from	view.
Locate—Locates	the	currently	displayed	topic	in	the	Contents
tab,	allowing	you	to	view	related	topics.
Back—Displays	the	previously	viewed	topic.
Forward—Displays	the	topic	you	viewed	before	clicking	the
Back	button.
Options—Displays	a	list	of	commands	and	viewing	options	for
the	help	file.



Searching	Help	(Windows	Only)
Use	the	Search	tab	to	the	left	of	this	window	to	locate	content	in	this	help
file.	If	you	want	to	search	for	words	in	a	certain	order,	such	as	"related
documentation,"	add	quotation	marks	around	the	search	words	as	shown
in	the	example.	Searching	for	terms	on	the	Search	tab	allows	you	to
quickly	locate	specific	information	and	information	in	topics	that	are	not
included	on	the	Contents	tab.



Wildcards
You	also	can	search	using	asterisk	(*)	or	question	mark	(?)	wildcards.
Use	the	asterisk	wildcard	to	return	topics	that	contain	a	certain	string.	For
example,	a	search	for	"prog*"	lists	topics	that	contain	the	words
"program,"	"programmatically,"	"progress,"	and	so	on.
Use	the	question	mark	wildcard	as	a	substitute	for	a	single	character	in	a
search	term.	For	example,	"?ext"	lists	topics	that	contain	the	words
"next,"	"text,"	and	so	on.

Note		Wildcard	searching	will	not	work	on	Simplified	Chinese,
Traditional	Chinese,	Japanese,	and	Korean	systems.



Nested	Expressions
Use	nested	expressions	to	combine	searches	to	further	refine	a	search.
You	can	use	Boolean	expressions	and	wildcards	in	a	nested	expression.
For	example,	"example	AND	(program	OR	VI)"	lists	topics	that	contain
"example	program"	or	"example	VI."	You	cannot	nest	expressions	more
than	five	levels.



Boolean	Expressions
Click	the	 	button	to	add	Boolean	expressions	to	a	search.	The	following
Boolean	operators	are	available:

AND	(default)—Returns	topics	that	contain	both	search	terms.
You	do	not	need	to	specify	this	operator	unless	you	are	using
nested	expressions.
OR—Returns	topics	that	contain	either	the	first	or	second	term.
NOT—Returns	topics	that	contain	the	first	term	without	the
second	term.
NEAR—Returns	topics	that	contain	both	terms	within	eight	words
of	each	other.



Search	Options

Use	the	following	checkboxes	on	the	Search	tab	to	customize	a	search:
Search	previous	results—Narrows	the	results	from	a	search
that	returned	too	many	topics.	You	must	remove	the	checkmark
from	this	checkbox	to	search	all	topics.
Match	similar	words—Broadens	a	search	to	return	topics	that
contain	words	similar	to	the	search	terms.	For	example,	a	search
for	"program"	lists	topics	that	include	the	words	"programs,"
"programming,"	and	so	on.
Search	titles	only—Searches	only	in	the	titles	of	topics.



Printing	Help	File	Topics	(Windows	Only)
Complete	the	following	steps	to	print	an	entire	book	from	the	Contents
tab:

1.	 Right-click	the	book.
2.	 Select	Print	from	the	shortcut	menu	to	display	the	Print	Topics

dialog	box.
3.	 Select	the	Print	the	selected	heading	and	all	subtopics	option.

Note		Select	Print	the	selected	topic	if	you	want	to	print
the	single	topic	you	have	selected	in	the	Contents	tab.

4.	 Click	the	OK	button.



Printing	PDF	Documents
This	help	file	may	contain	links	to	PDF	documents.	To	print	PDF
documents,	click	the	print	button	located	on	the	Adobe	Acrobat	Viewer
toolbar.



Accessing	the	Classification	Training	Interface
You	can	access	the	NI	Classification	Training	Interface	from	the	Start
menu	if	the	NI	Vision	Development	Module	is	installed.	You	can	also
access	the	NI	Classification	Training	interface	from	within	NI	Vision
Assistant	or	NI	Vision	Builder	for	Automated	Inspection	(Vision	Builder
AI).



From	the	Start	Menu
To	launch	the	Classification	Training	Interface	from	the	Start	menu,
select
Start»All	Programs»National	Instruments»Vision»Classification	Training



From	Vision	Assistant
The	Classification	Training	Interface	opens	from	Vision	Assistant	in	a
wizard	to	guide	you	through	the	creation	of	a	new	template.	Complete	the
following	steps	to	launch	the	Classification	Training	Interface	wizard	in
Vision	Assistant:

1.	 Acquire	or	open	an	image	that	contains	a	sample	that	you	want
to	classify.	Refer	to	the	NI	Vision	Assistant	Help	for	information
about	acquiring	or	opening	images.

2.	 To	access	the	Classification	Setup	panel,	select
Identification»Classification	or	click	Classification	on	the
Identification	tab	of	the	Processing	Functions	palette.

3.	 Click	New	Classifier	File	on	the	Train	tab	of	the	Classification
Setup	panel	to	open	the	Classification	Training	Interface.



From	Vision	Builder	AI
The	Classification	Training	Interface	opens	from	Vision	Builder	AI	in	a
wizard	to	guide	you	through	the	creation	of	a	new	template.	Complete	the
following	steps	to	launch	the	Classification	Training	Interface	wizard	in
Vision	Builder	AI:

1.	 Acquire,	or	simulate	the	acquisition	of,	an	image	that	contains	a
sample	that	you	want	to	classify.	Refer	to	the	Vision	Builder	for
Automated	Inspection:	Configuration	Help	for	information	about
acquiring	images	or	simulating	acquisitions.

2.	 On	the	Identify	Parts	tab	of	the	Inspection	Steps	palette,	click
Classify	Objects.

3.	 Click	New	Classifier	File	on	the	Main	tab	of	the	Classification
Setup	panel	to	open	the	Classification	Training	Interface.



NI	Classification	Training	Interface	Tutorial
Through	the	Classification	Training	Interface	you	can	train	a	classifier	file
by	manually	classifying	sample	images	into	new	or	existing	classes.
Based	on	those	samples,	the	classifier	file	can	then	classify	unknown
samples	into	a	known	class.	This	tutorial	explains	how	to	train	and	test	a
classifier	file	using	a	set	of	example	images.
This	tutorial	includes	the	following	sections:

1.	 Opening	the	Example	Images
2.	 Creating	the	Bolt	Class
3.	 Testing	the	Bolt	Classifier
4.	 Creating	the	Motor	Class
5.	 Testing	the	Motor	Classifier
6.	 Editing	the	Classifier	File
7.	 Saving	the	Classifier	File



Opening	the	Example	Images
Complete	the	following	steps	to	open	the	set	of	example	images	in	the	NI
Classification	Training	Interface:

1.	 Launch	the	Classification	Training	Interface.
2.	 Select	File»Open	Images.
3.	 Complete	one	of	the	following	sets	of	steps	to	select	the	tutorial

images:
NI	Vision	and	Vision	Assistant

a.	 Navigate	to	<Vision>\Images\Classification	Tutorial,
where	<Vision>	is	the	location	to	which	you
installed	the	NI	Vision	Development	Module.

b.	 Select	the	following	images:
Tip		You	can	select	multiple	image	files	by
pressing	the	<Ctrl>	key	and	clicking	each
file.	Enable	the	Select	all	files	checkbox	to
open	all	listed	images	in	the	directory	you
specified.
Parts00.png
Parts01.png
Bolt00.png
Bolt01.png
Motor00.png
Motor01.png

c.	 Click	Open.
Vision	Builder	AI

a.	 Navigate	to	<Vision	Builder
AI>\DemoImg\Classification,	where	<Vision	Builder
AI>	is	the	location	to	which	you	installed	Vision
Builder	AI.

b.	 Select	the	following	images:
Tip		You	can	select	multiple	image	files	by
pressing	the	<Ctrl>	key	and	clicking	each
file.	Enable	the	Select	all	files	checkbox	to
open	all	listed	images	in	the	directory	you



specified.
Parts00.png
Parts01.png
Bolt00.png
Bolt01.png
Motor00.png
Motor01.png

c.	 Click	Open.



Creating	the	Bolt	Class
Complete	the	following	steps	to	create	the	bolt	class	and	train	the	bolt
classifier:

1.	 Use	the	navigation	buttons	to	locate	Parts00.png.
2.	 Set	the	correct	options	in	the	Preprocessing	tab.

a.	 For	the	Method	of	thresholding,	select	Clustering.
b.	 Select	Dark	Objects	from	the	Look	For	drop-down

menu.
3.	 Draw	an	ROI	around	the	bolt	in	the	image.

Tip		It	may	be	necessary	to	include	parts	of	other	objects
in	the	ROI	you	draw	around	the	bolt	to	successfully	contain
the	entire	bolt	in	the	ROI.	To	configure	the	classification
engine	to	classify	the	sample	of	the	bolt	correctly	even
though	the	ROI	contains	part	of	another	object,	enable	the
Reject	Objects	Touching	ROI	checkbox	on	the
Preprocessing	tab.

The	NI	Classification	Training	Interface	displays	the	objects	in	the
ROI	according	to	the	preprocessing	settings.	When	the
preprocessing	settings	are	configured	to	use	a	clustering	method
of	thresholding	and	to	look	for	dark	objects,	the	objects	in	the	ROI
are	blue.

4.	 Select	Add	New	Label	from	the	Class	Label	list.	Enter	Bolt	for
the	New	Label.

5.	 Click	OK.
6.	 Navigate	to	the	Parts01.png	file.
7.	 Draw	an	ROI	around	a	bolt	in	the	image.

8.	 Check	that	the	Class	Label	control	reads	Bolt	and	click	Add
Sample.

9.	 Select	the	Classify	tab,	and	click	Train	Classifier.



Testing	the	Bolt	Classifier
Complete	the	following	steps	to	verify	that	you	have	trained	the	bolt
classifier:

1.	 Select	the	Classify	tab.
2.	 Navigate	to	the	Bolt00.png	file.
3.	 Draw	an	ROI	around	the	bolt	in	the	image.

4.	 Verify	that	the	object	in	the	ROI	is	classified	correctly	by	checking
that	the	Assigned	Class	Label	indicator	reads	Bolt.	The
Classification	Score	is	1000	because	you	have	defined	only
one	class.

5.	 Navigate	to	the	Bolt01.png	file.
6.	 Draw	an	ROI	around	the	bolt	in	the	image.

7.	 Verify	that	the	sample	in	the	ROI	is	classified	correctly	by
checking	that	the	Assigned	Class	Label	indicator	reads	Bolt.



Creating	the	Motor	Class
Complete	the	following	steps	to	create	the	motor	class	and	train	the
motor	classifier:

1.	 Use	the	navigation	buttons	to	locate	Parts00.png.
2.	 Set	the	correct	options	in	the	Preprocessing	tab.

a.	 For	the	Method	of	thresholding,	select	Clustering.
b.	 Select	Dark	Objects	from	the	Look	For	drop-down

menu.
3.	 Draw	an	ROI	around	a	motor	in	the	image.

Tip		It	may	be	necessary	to	include	parts	of	other	objects
in	the	ROI	you	draw	around	the	motor	to	successfully
contain	the	entire	motor	in	the	ROI.	To	configure	the
classification	engine	to	classify	the	sample	of	the	motor
correctly	even	though	the	ROI	contains	part	of	another
object,	enable	the	Reject	Objects	Touching	ROI
checkbox	on	the	Preprocessing	tab.

The	NI	Classification	Training	Interface	displays	the	objects	in	the
ROI	according	to	the	preprocessing	settings.	When	the
preprocessing	settings	are	configured	to	use	a	clustering	method
of	thresholding	and	to	look	for	dark	objects,	the	objects	in	the	ROI
are	blue.

4.	 Select	the	Add	Samples	tab.
5.	 Select	Add	New	Label	from	the	Class	Label	list.	Enter	motor	for

the	New	Label.
6.	 Click	OK.
7.	 Navigate	to	the	Parts01.png	file.
8.	 Draw	an	ROI	around	a	motor	in	the	image.

9.	 Check	that	the	Class	Label	control	reads	motor	and	click	Add
Sample.

10.	 Select	the	Classify	tab,	and	click	Train	Classifier.



Testing	the	Motor	Classifier
Complete	the	following	steps	to	verify	that	you	have	trained	the	motor
classifier:

1.	 Select	the	Classify	tab.
2.	 Navigate	to	the	motor00.png	file.
3.	 Draw	an	ROI	around	the	motor	in	the	image.

4.	 Verify	that	the	object	in	the	ROI	is	classified	correctly	by	checking
that	the	Assigned	Class	Label	indicator	reads	motor.

5.	 Navigate	to	the	motor01.png	file.
6.	 Draw	an	ROI	around	the	motor	in	the	image.

7.	 Verify	that	the	sample	in	the	ROI	is	classified	correctly	by
checking	that	the	Assigned	Class	Label	indicator	reads	motor.



Editing	the	Classifier	File
Use	the	Edit	Classifier	tab	to	view	the	thumbnail	images	and	descriptive
information	about	the	samples	classified.
The	following	list	describes	the	function	of	each	control	in	the	Edit
Classifier	tab:

Classifier	File	Description—To	add	a	description	of	the
classifier	file,	select	the	Classifier	File	Description	textbox	and
type	the	description.
Relabel—To	relabel	a	sample,	select	a	sample	in	the	browser
and	click	Relabel.	If	you	relabel	a	sample	you	must	retrain	the
classifier.
Delete—To	delete	a	sample,	select	a	sample	in	the	browser	and
click	Delete.	If	you	delete	a	sample	you	must	retrain	the
classifier.
Browser	Display—The	browser	can	display	either	all	samples	or
only	samples	of	a	specified	class.

To	display	all	samples,	click	the	All	Trained	Samples
option	button.
To	display	samples	of	a	certain	class,	click	the	Samples
of	Class	option	button	and	select	the	class	you	want	to
display	from	the	list.	The	Samples	indicator	displays	the
number	of	samples	from	that	class.

The	Class	Population	histogram	displays	existing	classes	and
the	number	of	samples	for	each	class.	The	Total	#	of	Samples
indicator	displays	the	number	of	samples	you	have	identified	for
all	classes.



Saving	the	Classifier	File
Now	that	you	have	classified	several	objects,	you	are	ready	to	save	the
classifier	file.	Each	classifier	file	contains	the	current	state	of	the
classification	engine	options	as	well	as	the	samples	you	have	trained.

1.	 Use	the	navigation	buttons	to	scroll	through	the	images	you
classified	in	this	tutorial.	Review	each	image,	and	check	that	the
class	to	which	the	image	belongs	is	correct.	When	you	hover
your	mouse	over	the	thumbnail	image	in	the	Edit	Classifier	tab,
the	class	name	appears	in	the	lower	right	corner	below	the	image
window.

2.	 Relabel	any	images	that	are	not	correctly	labeled	by	selecting	the
image	from	the	browser	and	clicking	Relabel.	The	Relabel
Sample	dialog	opens.	Type	the	correct	label	for	the	image	in	the
New	Label	control.

3.	 Delete	any	unwanted	images	by	selecting	the	image	in	the
browser	and	clicking	Delete.

4.	 Select	File»Save	Classifier	File.
5.	 Enter	Tutorial.clf	in	File	Name	for	the	classifier	file,	and	then	click

Save.



Training	the	Classifier
Complete	the	following	steps	to	train	a	classifier	file	by	manually
classifying	a	sample	image	into	a	new	or	existing	class.

1.	 Select	File»Open	Images.
2.	 Navigate	to	the	image	that	you	want	to	use	as	a	sample,	then

click	OK.
Tip		You	can	select	all	of	the	files	in	a	folder	by	enabling
the	Select	All	Files	option,	or	you	can	select	multiple	files
by	holding	the	<Ctrl>	key	while	clicking	file	names.	When
you	select	an	image	from	the	list,	the	Preview	Image
window	displays	the	image,	file	type,	image	size,	and
image	type.	If	you	select	a	collection	of	images,	the
Preview	window	displays	all	images	in	a	sequence.	To
view	the	sequence	at	a	different	rate,	adjust	the	slide	to	the
right	of	the	Preview	Image	window.

3.	 If	you	open	multiple	images,	use	the	navigation	buttons	to	browse
to	a	specific	image.



Add	Samples	Tab
Use	the	Add	Samples	tab	to	apply	a	class	label	to	an	image	or	portion	of
an	image.	The	image	is	then	added	to	the	classifier	as	a	sample	of	the
applied	class.

1.	 If	the	image	contains	multiple	objects,	draw	an	ROI	around	the
object	you	want	to	add	as	a	sample.

2.	 Adjust	the	parameters	on	the	Preprocessing,	Engine	Options,
and	Particle	Classifier	Options	tabs,	as	necessary.

3.	 Assign	a	class	label	to	the	sample	using	one	of	the	following
methods:

To	assign	a	new	class	label,	select	Add	New	Label	from
the	Class	Label	list.	The	Enter	a	new	label	dialog	box
opens.	Type	the	label	name	and	click	OK.	The	new	class
is	assigned	to	the	sample.
To	assign	an	existing	class	label,	select	the	label	from	the
Class	Label	list.	Click	Add	Sample.	The	class	is
assigned	to	the	sample.



Classify	Tab
Click	Train	Classifier	to	train	the	classifier	engine.

Note		If	you	add	new	samples,	you	must	retrain	the	classifier.

Note		The	Class	Population	histogram	displays	existing	classes
and	the	number	of	samples	for	each	class.	The	Total	#	of
Samples	indicator	displays	the	number	of	samples	you	have
identified	for	all	classes.



Classifying	Particles
To	verify	that	the	classifier	engine	has	been	trained	correctly,	complete
the	following	steps:

1.	 Select	File»Open	Images.
2.	 Navigate	to	the	image	that	you	want	to	use	as	a	sample	and	click

Open.
Tip		You	can	select	all	of	the	files	in	a	folder	by	enabling
the	Select	All	Files	option,	or	you	can	select	multiple	files
by	holding	the	<Ctrl>	key	while	clicking	file	names.	When
you	select	an	image	from	the	list,	the	Preview	Image
window	displays	the	image,	file	type,	image	size,	and
image	type.	If	you	select	a	collection	of	images,	the
Preview	window	displays	all	images	in	a	sequence.	To
view	the	sequence	at	a	different	rate,	adjust	the	slide	to	the
right	of	the	Preview	Image	window.

3.	 If	you	open	multiple	images,	use	the	navigation	buttons	to	browse
to	a	specific	image.



Classify	Tab
1.	 Draw	an	ROI	around	the	object	you	want	to	classify.
2.	 Verify	that	the	classifier	engine	produces	the	desired	class	label,

classification	score,	and	identification	score.
The	assigned	class	label	for	the	sample	appears	in	the	Assigned
Class	Label	indicator.	The	Classification	Score	is	the	degree	of
certainty	that	a	sample	is	assigned	to	one	class	instead	of
another	class.	The	Identification	Score	is	the	degree	of
similarity	between	a	sample	and	members	of	the	class	to	which
the	sample	is	assigned.	The	Distances	chart	displays	the
distance	between	the	classified	sample	and	other	classes.



Editing	the	Classifier
Use	the	Edit	Classifier	tab	to	edit	the	image	samples	you	have	classified
in	the	NI	Classification	Training	Interface.

Tip		To	edit	multiple	samples,	select	each	sample	that	you	want	to
modify	by	clicking	on	it.	If	you	want	to	edit	multiple	samples
individually,	ensure	that	you	deselect	any	samples	that	you	do	not
want	to	modify	by	clicking	them.

The	following	list	describes	the	function	of	each	control	in	the	Edit
Classifier	tab:

Classifier	File	Description—To	add	a	description	of	the
classifier	file,	select	the	Classifier	File	Description	textbox	and
type	the	description.
Relabel—To	relabel	a	sample,	select	a	sample	in	the	browser
and	click	Relabel.	If	you	relabel	a	sample	you	must	retrain	the
classifier.
Delete—To	delete	a	sample,	select	a	sample	in	the	browser	and
click	Delete.	If	you	delete	a	sample	you	must	retrain	the
classifier.
Browser	Display—The	browser	can	display	either	all	samples	or
only	samples	of	a	specified	class.

To	display	all	samples,	click	the	All	Trained	Samples
option	button.
To	display	samples	of	a	certain	class,	click	the	Samples
of	Class	option	button	and	select	the	class	you	want	to
display	from	the	list.	The	Samples	indicator	displays	the
number	of	samples	from	that	class.

The	Class	Population	histogram	displays	existing	classes	and
the	number	of	samples	for	each	class.	The	Total	#	of	Samples
indicator	displays	the	number	of	samples	you	have	identified	for
all	classes.



Batch	Training
Use	Tools»Batch	Training	to	train	a	folder	of	images.	Complete	the
following	steps	to	train	a	folder	of	images:

1.	 Select	Tools»Batch	Training.
2.	 Click	 	Browse	to	open	the	Select	a	folder	of	images	dialog

box.
3.	 Locate	the	folder	that	contains	the	images	which	you	want	to

batch	process.	Click	Open	to	open	the	folder,	then	click	Current
Folder	to	set	the	folder	as	the	image	source.

Note		The	Batch	Training	tool	will	only	process	the
selected	folder,	and	will	ignore	the	contents	of	any
subfolders.

4.	 Click	Draw	ROI	and	draw	an	ROI	around	the	sample	that	you
want	to	train.	Ensure	that	the	ROI	will	encompass	the	sample	to
train	in	all	images	in	the	folder	and	click	OK.

Note		If	you	do	not	draw	an	ROI,	the	largest	sample	will	be
trained.

5.	 Choose	one	of	the	following	methods	to	specify	a	label	for	each
sample:

If	all	images	in	the	folder	are	of	the	same	class,	enable
the	Use	the	same	label	for	all	the	samples	option	and
enter	the	label	in	the	Class	Label	control.
If	the	images	are	not	of	the	same	class,	you	must	use	a
labels	file	to	specify	individual	labels	for	each	image.

a.	 Enable	the	Use	a	file	that	specifies	the	labels
of	the	samples	option.

b.	 Click	 	Browse	to	select	a	Labels	File	Path.
Each	line	of	a	labels	file	lists	an	image	name
followed	by	the	class	name	assigned	to	the
image.	A	delimiter	separates	the	image	name
from	its	label.

Note		If	an	image	is	not	listed	in	the	labels
file,	it	will	not	be	processed.

c.	 In	the	Delimiter	list,	choose	the	correct	delimiter



for	the	labels	file.	If	an	appropriate	delimiter	is	not
listed,	choose	User	Specified	in	the	Delimiter	list
and	type	the	appropriate	delimiter	into	the	User
Delimiter	field.

6.	 Click	Train	to	process	all	of	the	images	in	the	selected	folder.	The
training	process	both	trains	and	classifies	the	samples.
Once	processing	is	complete,	the	Batch	Results	dialog	box	will
open.



Batch	Classification
Use	Tools»Batch	Classify	to	classify	a	folder	of	images.	You	can	verify
the	accuracy	of	the	classification	by	providing	a	results	file	that	lists	the
actual	class	of	each	image.

Note		The	classifier	will	classify	images	based	on	the	classes	that
it	has	been	trained	to	recognize.	If	the	classifier	has	not	been
trained	to	recognize	a	class,	it	cannot	correctly	classify	images	of
that	class.

Complete	the	following	steps	to	classify	a	folder	of	images:
1.	 Select	Tools»Batch	Classify.
2.	 Click	 	Browse	to	open	the	Select	a	folder	of	images	dialog

box.
3.	 Locate	the	folder	that	contains	the	images	which	you	want	to

batch	process.	Click	Open	to	open	the	folder,	then	click	Current
Folder	to	set	the	folder	as	the	image	source.

Note		The	Batch	Classification	tool	will	only	process	the
selected	folder,	and	will	ignore	the	contents	of	any
subfolders.

4.	 Click	Draw	ROI	and	draw	an	ROI	around	the	sample	that	you
want	to	classify.	Ensure	that	the	ROI	will	encompass	the	object	to
classify	in	all	images	in	the	folder	and	click	OK.

5.	 If	you	want	to	check	the	accuracy	of	the	classification	against	a
results	file,	enable	the	Verify	Classification	option.	Complete	the
following	steps	to	specify	a	results	file:

a.	 Click	 	Browse	to	select	a	Results	File	Path.	Each
line	of	a	results	file	lists	an	image	name	followed	by	the
class	name	assigned	to	the	image.	A	delimiter	separates
the	image	name	from	its	label.

b.	 In	the	Delimiter	list,	choose	the	correct	delimiter	for	the
labels	file.	If	an	appropriate	delimiter	is	not	listed,	choose
User	Specified	in	the	Delimiter	list	and	type	the
appropriate	delimiter	into	the	User	Delimiter	field.

6.	 Click	Classify	to	classify	the	samples	in	all	the	images	in	the
folder.	Once	processing	is	complete,	the	Batch	Results	dialog
box	will	open.



Batch	Results
After	you	train	or	classify	a	folder	of	images,	the	Batch	Results	dialog
box	displays	the	results	of	the	batch	training.	The	results	are	displayed
on	five	tabs:	Classification	Results,	Scores	Histogram,	Class
Information,	Classification	Distribution,	and	Distance	Table.



Classification	Results	Tab
The	classification	results	are	displayed	in	a	chart	that	lists	the	following
results	for	each	file	trained	and	classified:

Label—If	you	trained	samples	without	specifying	a	label	file,	this
column	lists	the	class	you	manually	assigned	to	all	images.	If	you
classified	samples	without	specifying	a	results	file,	this	column
lists	the	class	assigned	to	each	sample	by	the	classifier.
Actual	Label—If	you	trained	samples	and	specified	a	label	file,
or	if	you	classified	samples	and	specified	a	results	file,	this
column	lists	the	class	assigned	to	each	image	in	the	label	or
results	file.
Assigned	Label—If	you	trained	samples	and	specified	a	label
file,	or	if	you	classified	samples	and	specified	a	results	file,	this
column	lists	the	label	assigned	to	each	image	by	the	classifier.
Classification	Score—Degree	of	certainty	that	a	sample	is
assigned	to	one	class	instead	of	other	classes.
Identification	Score—Degree	of	similarity	between	a	sample
and	members	of	the	class	to	which	the	sample	is	assigned.
Classification—The	classification	is	Good	if	the	sample	label
found	during	the	classification	process	matches	the	label
provided	by	the	user.	The	classification	is	Bad	if	the	sample	label
does	not	match.



Scores	Histogram	Tab
The	scores	histogram	displays	the	number	of	each	sample	classified	and
trained	for	each	score	value.
The	x-axis	can	represent	either	classification	scores	or	identification
scores.	The	Histogram	Mode	can	be	either	linear	or	cumulative.



Class	Information	Tab
The	accuracy	and	predictive	value	of	the	classification	are	displayed	in	a
chart	for	each	class.

Samples—Number	of	samples	belonging	to	the	class.
Standard	Deviation—Standard	deviation	from	the	mean	of	all
samples	in	the	class.
Accuracy	(sensitivity)—Probability	that	a	sample	is	classified
into	the	class	to	which	it	belongs.
Predictive	Value—Probability	that	a	sample	classified	into	a
given	class	belongs	to	that	class.



Classification	Distribution	Tab
The	classification	distribution	is	displayed	in	a	chart,	and	the	classifier
accuracy	is	calculated.	The	classification	distribution	is	a	matrix	that	gives
the	probability	that	a	sample	belonging	to	a	specific	class	will	be
classified	in	another	class.



Distance	Table	Tab
The	distance	table	displays	the	mean	distance	from	each	class	to	each
other	class.

Tip		You	can	also	display	this	dialog	by	choosing	Tools»Training
Summary.	Only	the	Class	Information,	Classification
Distribution,	and	Distance	Table	tabs	are	available.



Export	to	Excel	and	Save	Results
The	Export	to	Excel	and	Save	Results	buttons	appear	on	all	tabs.

Click	 	Export	to	Excel	to	export	the	contents	of	the	current
tab	to	a	Microsoft	Excel	spreadsheet.

Click	 	Save	Results	to	save	the	contents	of	the	current	tab	to
a	tab-delimited	text	file.



Configuring	the	Preprocessing	Settings
Use	the	settings	on	the	Preprocessing	tab	to	determine	how	you	want
the	classification	engine	to	calculate	the	threshold	value	it	uses	to
segment	particles	in	each	image.
Complete	the	following	steps	to	configure	the	preprocessing	settings:

1.	 Select	a	Method	for	thresholding.
Manual	Threshold—Manually	determine	the	threshold
range	for	the	ROI.
Clustering—The	classification	engine	sorts	the
histogram	of	the	image	within	a	discrete	number	of
classes	corresponding	to	the	number	of	phases
perceived	in	an	image.	Clustering	is	the	most	frequently
used	automatic	thresholding	method.
Entropy—The	classification	engine	detects	samples	that
are	present	in	minuscule	proportions	on	the	image.
Metric—The	classification	engine	calculates	a	value	for
each	threshold	that	is	determined	by	the	surfaces
representing	the	initial	gray	scale.
Moments—A	method	of	thresholding	used	for	images
that	have	poor	contrast.
Inter	Variance—A	method	of	thresholding	used	for
images	in	which	classes	are	not	too	disproportionate.	For
satisfactory	results,	the	smallest	class	must	be	at	least
5%	of	the	largest	one.

2.	 If	you	selected	Manual	Threshold	in	Method,	use	the	Min	and
Max	controls	or	the	slider	at	the	bottom	of	the	histogram	to	set
the	threshold	value.	If	you	select	an	automatic	threshold	method,
the	algorithm	calculates	the	threshold	value	and	updates	the
Threshold	Range.	You	can	specify	a	Lower	Limit	and	an	Upper
Limit	for	the	threshold	computed	by	the	automatic	method.

3.	 Select	a	type	of	object	to	search	for	from	the	Look	For	drop-
down	menu.	The	NI	Classifier	will	look	for	Bright	Objects,	Dark
Objects,	or	Gray	Objects.

4.	 Click	Reject	Objects	Touching	ROI	to	ignore	objects	that	are
touching	the	border	of	the	ROI	you	drew.



5.	 Use	the	Remove	Small	Objects	(#	of	Erosions)	box	to	select
the	number	of	erosions	you	want	the	classification	engine	to
perform	to	remove	small	objects	from	the	ROI.
As	you	manipulate	settings	on	the	Preprocessing	tab,	the	NI
Classification	Training	Interface	displays	thresholded	objects	in
blue.

Tip		If	the	samples	in	the	ROI	are	not	classified	as	you	expect
them	to	be,	experiment	with	settings	on	the	Engine	Options	and
Particle	Classifier	Options	tabs	to	improve	the	classification.



Configuring	the	Engine	Options
Use	the	Engine	Options	tab	to	indicate	the	Method	and	Metric	values
required	for	sample	classification.
Select	a	Method	on	the	Engine	Options	tab	to	configure	the	method	of
classification.

Nearest	Neighbor ​Most	direct	approach	to	classification.	In
nearest	neighbor	classification,	the	distance	of	an	input	feature
vector	of	unknown	class	to	another	class	is	defined	as	the
distance	to	the	closest	samples	that	are	used	to	represent	that
class.
K-Nearest	Neighbor ​More	tolerant	of	noise	compared	with
nearest	neighbor	classification.	In	K-nearest	neighbor
classification,	an	input	feature	vector	is	classified	into	a	class
based	on	a	voting	mechanism.	The	NI	Classifier	finds	K	nearest
samples	from	all	the	classes.	The	input	feature	vector	of
unknown	class	is	assigned	to	the	class	with	majority	of	the	votes
in	the	K	nearest	samples.
Minimum	Mean	Distance​Most	effective	in	applications	that	have
little	or	no	feature	pattern	variability	or	other	corruptive	influences.
In	minimum	mean	distance	classification,	an	input	feature	vector
of	unknown	class	is	classified	based	on	its	distance	to	each	class
center.

Select	a	Metric	on	the	Engine	Options	tab	to	configure	the	metric	used
in	the	classification	algorithm.

Maximum ​Most	sensitive	to	small	variations	between	samples.
Use	Maximum	when	you	need	to	classify	samples	with	very
small	differences	into	different	classes.
Sum ​Metric	used	in	most	classification	applications.	Sum	is	also
known	as	the	Manhattan	metric	or	Taxicab	metric.	This	is	the
default	Metric	value.
Euclidean​Least	sensitive	to	small	variations	between	samples.
Use	Euclidean	when	you	need	to	classify	samples	with	small
differences	into	the	same	class.

Tip		If	the	samples	in	the	ROI	are	not	classified	as	you	expect
them	to	be,	experiment	with	settings	on	the	Preprocessing	and



Particle	Classifier	Options	tabs	to	improve	the	classification.



Configuring	the	Particle	Classifier	Options
Use	the	Particle	Classifier	Options	tab	to	indicate	whether	the
classification	is	Scale	Dependent	or	Mirror	Dependent.

1.	 Enable	the	Scale	Dependent	option	if	you	want	to	distinguish
samples	of	different	sizes.

2.	 Enter	the	numeric	scale	factor	value	(between	0	and	1000)	in	the
Scale	Factor	control.	If	the	scale	factor	value	is	0,	the	samples
are	classified	independent	of	scale.

3.	 Enable	the	Mirror	Dependent	option	if	you	want	to	classify
mirrored	objects	in	separate	classes.

4.	 Enter	the	numeric	mirror	factor	value	(between	0	and	1000)	in	the
Mirror	Factor	control.	If	the	mirror	factor	value	is	0,	the	samples
are	classified	independent	of	mirror	symmetry.

Tip		If	the	samples	in	the	ROI	are	not	classified	as	you	expect
them	to	be,	experiment	with	settings	on	the	Preprocessing	and
Engine	Options	tabs	to	improve	the	classification.



Developing	Classification	Applications
Use	the	following	classification	examples	to	learn	how	to	use	the	NI
Classification	Training	Interface	to	create	classification	applications	in
LabVIEW,	LabWindows/CVI,	or	Microsoft	Visual	Basic:

LabVIEW	classification	example
LabWindows™/CVI™	classification	example
Microsoft	Visual	Basic	classification	example



Classification	Example	for	LabVIEW
You	can	use	the	classification	example	for	LabVIEW	to	classify	samples
using	the	file	you	created	with	the	NI	Classification	Training	Interface
Tutorial.
Complete	the	following	steps	to	use	the	classification	example	for
LabVIEW:

1.	 Navigate	to	<LabVIEW>\Examples\Vision\2.Functions\Classification
and	open	the	Classification	VI,	where	<LabVIEW>	is	the	location
to	which	you	installed	LabVIEW.

2.	 Run	the	VI.
3.	 Click	the	Browse	button	of	the	Classifier	File	Path	control	and

open	the	Tutorial.clf	file	you	created	upon	completing	the	NI
Classification	Training	Interface	Tutorial.

4.	 Click	Load	File.
5.	 Draw	an	ROI	around	the	sample	to	classify,	then	click	Classify.
6.	 Click	Return	to	exit	the	example.



Classification	Example	for	LabWindows/CVI
You	can	use	the	Classification	Example	for	LabWindows™/CVI™	to
classify	samples	using	the	file	you	created	with	the	NI	Classification
Training	Interface	Tutorial.



Opening	the	LabWindows/CVI	Classification	Example
The	location	of	the	example	depends	on	the	operating	system	and
version	of	LabWindows/CVI.	To	open	the	example,	choose	one	of	the
following	paths:

For	LabWindows/CVI	8.5,	navigate	to
<CVI>\Samples\Vision\2.Functions\Classification\Classification.prj,
where	<CVI>	is	the	location	to	which	you	installed
LabWindows/CVI.
For	LabWindows/CVI	8.5.1	on	Windows	Vista,	navigate	to
C:\Users\Public\Documents\National	Instruments\CVI\Samples\Vision\2.Functions\Classification\Classification.prj
For	LabWindows/CVI	8.5.1	on	Windows	XP/2000,	navigate	to
C:\Documents	and	Settings\All	Users\Documents\National	Instruments\CVI\Samples\Vision\2.Functions\Classification\Classification.prj



Using	the	LabWindows/CVI	Classification	Examples
Complete	the	following	steps	to	use	the	Classification	Example	for
LabWindows/CVI:

1.	 Click	Build»Configuration»Debug,	and	then	click	Run»Debug
Classification_dbg.exe	to	run	the	example.

2.	 Click	the	Browse	button	and	open	the	Tutorial.clf	file	you	created
upon	completing	the	NI	Classification	Training	Interface	Tutorial.

3.	 Click	Load	File,	select	one	of	the	image	files,	and	click	Load.
4.	 Draw	an	ROI	around	the	sample	to	classify,	then	click	Classify.
5.	 Click	Return	to	exit	the	example.



WARNING	REGARDING	USE	OF	NATIONAL
INSTRUMENTS	PRODUCTS
(1)	NATIONAL	INSTRUMENTS	PRODUCTS	ARE	NOT	DESIGNED
WITH	COMPONENTS	AND	TESTING	FOR	A	LEVEL	OF	RELIABILITY
SUITABLE	FOR	USE	IN	OR	IN	CONNECTION	WITH	SURGICAL
IMPLANTS	OR	AS	CRITICAL	COMPONENTS	IN	ANY	LIFE	SUPPORT
SYSTEMS	WHOSE	FAILURE	TO	PERFORM	CAN	REASONABLY	BE
EXPECTED	TO	CAUSE	SIGNIFICANT	INJURY	TO	A	HUMAN.
(2)	IN	ANY	APPLICATION,	INCLUDING	THE	ABOVE,	RELIABILITY	OF
OPERATION	OF	THE	SOFTWARE	PRODUCTS	CAN	BE	IMPAIRED	BY
ADVERSE	FACTORS,	INCLUDING	BUT	NOT	LIMITED	TO
FLUCTUATIONS	IN	ELECTRICAL	POWER	SUPPLY,	COMPUTER
HARDWARE	MALFUNCTIONS,	COMPUTER	OPERATING	SYSTEM
SOFTWARE	FITNESS,	FITNESS	OF	COMPILERS	AND
DEVELOPMENT	SOFTWARE	USED	TO	DEVELOP	AN	APPLICATION,
INSTALLATION	ERRORS,	SOFTWARE	AND	HARDWARE
COMPATIBILITY	PROBLEMS,	MALFUNCTIONS	OR	FAILURES	OF
ELECTRONIC	MONITORING	OR	CONTROL	DEVICES,	TRANSIENT
FAILURES	OF	ELECTRONIC	SYSTEMS	(HARDWARE	AND/OR
SOFTWARE),	UNANTICIPATED	USES	OR	MISUSES,	OR	ERRORS	ON
THE	PART	OF	THE	USER	OR	APPLICATIONS	DESIGNER	(ADVERSE
FACTORS	SUCH	AS	THESE	ARE	HEREAFTER	COLLECTIVELY
TERMED	"SYSTEM	FAILURES").	ANY	APPLICATION	WHERE	A
SYSTEM	FAILURE	WOULD	CREATE	A	RISK	OF	HARM	TO
PROPERTY	OR	PERSONS	(INCLUDING	THE	RISK	OF	BODILY
INJURY	AND	DEATH)	SHOULD	NOT	BE	RELIANT	SOLELY	UPON	ONE
FORM	OF	ELECTRONIC	SYSTEM	DUE	TO	THE	RISK	OF	SYSTEM
FAILURE.	TO	AVOID	DAMAGE,	INJURY,	OR	DEATH,	THE	USER	OR
APPLICATION	DESIGNER	MUST	TAKE	REASONABLY	PRUDENT
STEPS	TO	PROTECT	AGAINST	SYSTEM	FAILURES,	INCLUDING	BUT
NOT	LIMITED	TO	BACK-UP	OR	SHUT	DOWN	MECHANISMS.
BECAUSE	EACH	END-USER	SYSTEM	IS	CUSTOMIZED	AND
DIFFERS	FROM	NATIONAL	INSTRUMENTS'	TESTING	PLATFORMS
AND	BECAUSE	A	USER	OR	APPLICATION	DESIGNER	MAY	USE
NATIONAL	INSTRUMENTS	PRODUCTS	IN	COMBINATION	WITH
OTHER	PRODUCTS	IN	A	MANNER	NOT	EVALUATED	OR
CONTEMPLATED	BY	NATIONAL	INSTRUMENTS,	THE	USER	OR



APPLICATION	DESIGNER	IS	ULTIMATELY	RESPONSIBLE	FOR
VERIFYING	AND	VALIDATING	THE	SUITABILITY	OF	NATIONAL
INSTRUMENTS	PRODUCTS	WHENEVER	NATIONAL	INSTRUMENTS
PRODUCTS	ARE	INCORPORATED	IN	A	SYSTEM	OR	APPLICATION,
INCLUDING,	WITHOUT	LIMITATION,	THE	APPROPRIATE	DESIGN,
PROCESS	AND	SAFETY	LEVEL	OF	SUCH	SYSTEM	OR
APPLICATION.



Technical	Support	and	Professional	Services
Visit	the	following	sections	of	the	National	Instruments	Web	site	at	ni.com
for	technical	support	and	professional	services:

Support​Online	technical	support	resources	at	ni.com/support
include	the	following:

Self-Help	Resources​For	answers	and	solutions,	visit	the
award-winning	National	Instruments	Web	site	for	software
drivers	and	updates,	a	searchable	KnowledgeBase,
product	manuals,	step-by-step	troubleshooting	wizards,
thousands	of	example	programs,	tutorials,	application
notes,	instrument	drivers,	and	so	on.
Free	Technical	Support​All	registered	users	receive	free
Basic	Service,	which	includes	access	to	hundreds	of
Applications	Engineers	worldwide	in	the	NI	Developer
Exchange	at	ni.com/exchange.	National	Instruments
Applications	Engineers	make	sure	every	question
receives	an	answer.

Training	and	Certification​Visit	ni.com/training	for	self-paced
training,	eLearning	virtual	classrooms,	interactive	CDs,	and
Certification	program	information.	You	also	can	register	for
instructor-led,	hands-on	courses	at	locations	around	the	world.
System	Integration​If	you	have	time	constraints,	limited	in-house
technical	resources,	or	other	project	challenges,	NI	Alliance
Program	members	can	help.	To	learn	more,	call	your	local	NI
office	or	visit	ni.com/alliance.

If	you	searched	ni.com	and	could	not	find	the	answers	you	need,	contact
your	local	office	or	NI	corporate	headquarters.	You	also	can	visit	the
Worldwide	Offices	section	of	ni.com/niglobal	to	access	the	branch	office
Web	sites,	which	provide	up-to-date	contact	information,	support	phone
numbers,	email	addresses,	and	current	events.
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Navigating	Images
If	you	open	multiple	images	for	training,	you	can	use	the	toolbar	buttons
to	navigate	through	the	images.	Refer	to	the	following	button	descriptions
for	information	about	how	to	view	images.

Navigates	to	the	first	image	in	the	list	of	open	images.
Navigates	to	the	previous	image.
Navigates	to	the	next	image.
Navigates	to	the	last	image	in	the	list	of	open	images.



Classification	Example	for	Microsoft	Visual
Basic
You	can	use	the	classification	example	for	Microsoft	Visual	Basic	to
classify	samples	using	the	file	you	created	with	the	NI	Classification
Training	Interface	Tutorial.
Complete	the	following	steps	to	use	the	classification	example	for
Microsoft	Visual	Basic:

1.	 Open	the	example.
For	Microsoft	Visual	Basic	6.0,	navigate	to
<Vision>\Examples\MSVB\2.Functions\Classification,	where
<Vision>	is	the	location	to	which	you	installed	the	NI
Vision	Development	Module,	and	open	the
Classification.vbp	file.
For	Microsoft	Visual	Basic	.NET,	navigate	to
<Vision>\Examples\MSVB.NET\2.Functions\Classification,
where	<Vision>	is	the	location	to	which	you	installed	the
NI	Vision	Development	Module,	and	open	the
Classification.vbproj	file.

2.	 Run	the	example.
3.	 Click	the	Browse	button	and	open	the	Tutorial.clf	file	you	created

upon	completing	the	NI	Classification	Training	Interface	Tutorial.
4.	 Click	Load	File,	select	one	of	the	image	files,	and	click	Open.
5.	 Draw	an	ROI	around	the	sample	to	classify,	then	click	Classify.
6.	 Click	Return	to	exit	the	example.



Branch	Offices
Office Telephone	Number
Australia 1800	300	800
Austria 43	662	457990-0
Belgium 32	(0)	2	757	0020
Brazil 55	11	3262	3599
Canada 800	433	3488
China 86	21	5050	9800
Czech	Republic 420	224	235	774
Denmark 45	45	76	26	00
Finland 358	(0)	9	725	72511
France 33	(0)	1	57	66	24	24
Germany 49	89	7413130
India 91	80	41190000
Israel 972	0	3	6393737
Italy 39	02	41309277
Japan 0120-527196	/	81	3	5472	2970
Korea 82	02	3451	3400
Lebanon 961	(0)	1	33	28	28
Malaysia 1800	887710
Mexico 01	800	010	0793
Netherlands 31	(0)	348	433	466
New	Zealand 0800	553	322
Norway 47	(0)	66	90	76	60
Poland 48	22	3390150
Portugal 351	210	311	210
Russia 7	495	783	6851
Singapore 1800	226	5886
Slovenia 386	3	425	42	00



South	Africa 27	0	11	805	8197
Spain 34	91	640	0085
Sweden 46	(0)	8	587	895	00
Switzerland 41	56	2005151
Taiwan 886	02	2377	2222
Thailand 662	278	6777
Turkey 90	212	279	3031
United	Kingdom 44	(0)	1635	523545
United	States	(Corporate) 512	683	0100


