What's new
Design your Web site

Develop your Web site

Develop a data-driven Web site

Publish your Web site

Maintain your Web site

More new features in Office
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Keyboard shortcuts
You can quickly accomplish tasks you perform frequently by using shortcut
keys. The availability of shortcut keys in Microsoft FrontPage depends on
whether the command you want to use is available in the currently selected view.

Common Microsoft FrontPage tasks
Work with and manage Web pages
F8
Run the accessibility checker.
CTRL+N
Create a new Web page.
CTRL+O
Open a Web page.
CTRL+F4
Close a Web page.
CTRL+S
Save a Web page.
CTRL+P
Print a Web page.
F5
Refresh a Web page; refresh the Folder List.
CTRL+TAB
Switch between open Web pages.
CTRL+SHIFT+B
Preview a Web page in a Web browser.
ALT+F4
Quit Microsoft FrontPage.
CTRL+ SHIFT+8
Display nonprinting characters.
CTRL+ /
Display HTML tags in Design view.
CTRL+F
Find text or HTML on a Web page.
CTRL+H
Replace text or HTML on a Web page.
F7
Check spelling on a Web page.
SHIFT+F7
Look up a word in the thesaurus.
ESC

Cancel an action.
CTRL+Z or ALT+BACKSPACE
Undo an action.
CTRL+Y or SHIFT+ALT+BACKSPACE
Redo or repeat an action.
DELETE
Delete a Web page or folder in the Folder List or any dialog box.
BACKSPACE
Move up one level.
Access and use views
F12
Preview the current page in a Web browser.
CTRL+PAGE DOWN or CTRL+PAGE UP
Move between Code, Design, Split, and Preview views.
ALT+PAGE DOWN or ALT+PAGE UP
Move between Code and Design panes in Split view.
ALT+F1
Show or hide the Folder List.
UP ARROW
Move through hyperlink nodes in Hyperlinks view.
UP, DOWN, LEFT, or RIGHT ARROW
In Hyperlinks view, move through hyperlink nodes.
SHIFT+RIGHT ARROW
Expand the current node and move to the right in Hyperlinks view.
SHIFT+LEFT ARROW
Expand the current node and move to the left in Hyperlinks view.
Work with coding tools
CTRL+Q
Quick tag editor.
CTRL+F2
Insert temporary bookmark.
F2
Next temporary bookmark.
SHIFT+F2

Previous temporary bookmark.
CTRL+G
Go to line.
CTRL+L
AutoComplete.
CTRL+ENTER
Insert code snippet.
CTRL+>
Insert end tag.
CTRL+<
Insert start tag.
CTRL+/
Insert HTML comment.
CTRL+SPACEBAR
Complete word.
Format text and paragraphs
CTRL+SHIFT+F
Change the font.
CTRL+SHIFT+P
Change the font size.
CTRL+B
Apply bold formatting.
CTRL+U
Apply an underline.
CTRL+I
Apply italic formatting.
SHIFT+TAB
In the More Colors dialog box, activate the color picker.
Note SHIFT +TAB should activate, in order: Cancel, OK, Select,
Custom, Value, and then the color picker.
LEFT, RIGHT, BACK, or FORWARD ARROW KEY
Use the color picker (follow the instructions for the previous entry first).
CTRL+PLUS SIGN
Apply superscript formatting.
CTRL+MINUS SIGN

Apply subscript formatting.
CTRL+ SHIFT+C
Copy formatting.
CTRL+SHIFT+V
Paste formatting.
CTRL+SHIFT+Z or CTRL+SPACEBAR
Remove manual formatting.
CTRL+E
Center a paragraph.
CTRL+L
Left align a paragraph.
CTRL+R
Right align a paragraph.
CTRL+M
Indent a paragraph from the left.
CTRL+ SHIFT+M
Indent a paragraph from the right.
CTRL+ SHIFT+S
Apply a style.
CTRL+SHIFT+ N
Apply the Normal style.
CTRL+ALT+1
Apply the Heading 1 style.
CTRL+ALT+2
Apply the Heading 2 style.
CTRL+ALT+3
Apply the Heading 3 style.
CTRL+ALT+4
Apply the Heading 4 style.
CTRL+ALT+5
Apply the Heading 5 style.
CTRL+ALT+6
Apply the Heading 6 style.
CTRL+ SHIFT+L
Apply the List style.
Edit and move text and graphics
BACKSPACE

Delete one character to the left.
DELETE
Delete one character to the right.
CTRL+BACKSPACE
Delete one word to the left.
CTRL+DELETE
Delete one word to the right.
CTRL+C or CTRL+INSERT
Copy text or graphics.
CTRL+X or SHIFT+DELETE
Cut selected text to the Microsoft Office Clipboard.
CTRL+V or SHIFT+INSERT
Paste the Clipboard contents.
SHIFT+ENTER
Insert a line break.
CTRL+SHIFT+SPACEBAR
Insert a nonbreaking space.
Select text and graphics
SHIFT+RIGHT ARROW
Move one character to the right.
SHIFT+LEFT ARROW
Move one character to the left.
CTRL+SHIFT+RIGHT ARROW
Go to the end of a word.
CTRL+SHIFT +LEFT ARROW
Go to the beginning of a word.
SHIFT+END
Go to the end of a line.
SHIFT+HOME
Go to the beginning of a line.
SHIFT+UP ARROW
Move one line up.
SHIFT+DOWN ARROW
Move one line down.
CTRL+SHIFT+DOWN ARROW
Go to the end of a paragraph.
CTRL+SHIFT+UP ARROW

Go to the beginning of a paragraph.
SHIFT+PAGE DOWN
Move one screen down.
SHIFT+PAGE UP
Move one screen up.
CTRL+A
Select the entire page.
ALT+ENTER
Display the properties of a selection.
Work with tables, graphics, and hyperlinks
SHIFT+CTRL+ALT+T
Insert a table.
TAB
Select the next table cell's content.
SHIFT+TAB
Select the preceding table cell's content.
Hold down SHIFT and press LEFT or RIGHT ARROW repeatedly
With the insertion point in a cell, extend a selection to adjacent cells in a
row.
Hold down SHIFT and press UP or DOWN ARROW repeatedly
With the insertion point in the top or bottom cell of a column, select a
column.
CTRL +T
With the graphic selected, create an auto thumbnail.
CTRL+K
Create a hyperlink on a Web page.

Online Help
Access and work with the Help task pane and Help window
The Help pane is a task pane that provides access to all Microsoft Office Help
content. As a task pane, the Help pane appears as part of the active application.
The Help window displays topics and other Help content and appears as a
window next to, but separate from, the active application.

In the Help task pane
F1
Display the Help task pane.
F6
Switch between the Help task pane and the active application.
TAB
Select the next item in the Help task pane.
SHIFT+TAB
Select the previous item in the Help task pane.
ENTER
Perform the action for the selected item.
DOWN ARROW and UP ARROW
In a Table of Contents, select the next and previous item, respectively.
RIGHT ARROW and LEFT ARROW
In a table of contents, expand and collapse the selected item, respectively.
ALT+LEFT ARROW
Move back to the previous task pane.
ALT+RIGHT ARROW
Move forward to the next task pane.
CTRL+SPACEBAR
Open the menu of pane options.
CTRL+F1
Close and reopen the current task pane.
RIGHT ARROW
Expand a +/- list.
LEFT ARROW
Collapse a +/- list.

In the Help window
TAB
Select the next hidden text or hyperlink, or Show All or Hide All at the top
of a topic.
SHIFT+TAB
Select the previous hidden text or hyperlink, or the Browser View button at
the top of a Microsoft Office Online Web site article.
ENTER
Perform the action for the selected Show All, Hide All, hidden text, or
hyperlink.
ALT+LEFT ARROW
Move back to the previous Help topic.
ALT+RIGHT ARROW
Move forward to the next Help topic.
CTRL+P
Print the current Help topic.
UP ARROW AND DOWN ARROW
Scroll small amounts up and down, respectively, within the currently
displayed Help topic.
PAGE UP AND PAGE DOWN
Scroll larger amounts up and down, respectively, within the currently
displayed Help topic.
ALT+U
Change whether the Help window appears connected to (tiled) or separate
from (untiled) the active application.
SHIFT+F10
Display a menu of commands for the Help window; requires that the Help
window have active focus (click an item in the Help window).

Microsoft Office basics
Access and use windows
ALT+TAB
Switch to the next window.
ALT+SHIFT+TAB
Switch to the previous window.
CTRL+W or CTRL+F4
Close the active window.
F6
Move to a task pane from another pane in the program window (clockwise
direction). You may need to press F6 more than once.
Note If pressing F6 doesn't display the task pane you want, try pressing
ALT to place focus on the menu bar, and then pressing CTRL+TAB to
move to the task pane.
SHIFT+F6
Move to a pane from another pane in the program window
(counterclockwise direction).
CTRL+F6
When more than one window is open, switch to the next window.
CTRL+SHIFT+F6
Switch to the previous window.
Access and use menus and toolbars
F10 or ALT
Select the menu bar, or close an open menu and submenu at the same time.
TAB or SHIFT+TAB
When a toolbar is selected, select the next or previous button or menu on
the toolbar.
CTRL+TAB or CTRL+SHIFT+TAB
When a toolbar is selected, select the next or previous toolbar.
ENTER
Open the selected menu, or perform the action for the selected button or

command.
SHIFT+F10
Display the shortcut menu for the selected item.
ALT+SPACEBAR
Display the window shortcut menu (Control menu).
DOWN ARROW or UP ARROW
When a menu or submenu is open, select the next or previous command.
LEFT ARROW or RIGHT ARROW
Select the menu to the left or right. When a submenu is open, switch
between the main menu and the submenu.
HOME or END
Select the first or last command on the menu or submenu.
ESC
Close an open menu. When a submenu is open, close only the submenu.
SHIFT+DOWN ARROW
When a menu is selected, display the list of commands.
CTRL+DOWN ARROW
When a personalized menu is open, display the full set of commands.
Note You can use the keyboard to select any menu command on the menu bar.
Press ALT to select the menu bar. Press the letter that is underlined in the menu
name that contains the command you want. In the menu that appears, press the
letter underlined in the command name that you want.
Access and use task panes
F6
Move to a task pane from another pane in the program window. (You may
need to press F6 more than once.)
Note If pressing F6 doesn't display the task pane you want, try pressing
ALT to place focus on the menu bar, and then pressing CTRL+TAB to
move to the task pane.
CTRL+TAB
When a menu or toolbar is active, move to a task pane. (You may need to
press CTRL+TAB more than once.)
CTRL+F1
Open or close a task pane.

CTRL+SPACEBAR
Open a drop-down menu for the selected task pane.
TAB or SHIFT+TAB
When a task pane is active, select the next or previous option in the task
pane.
CTRL+DOWN ARROW
Display the full set of commands on the task pane menu.
DOWN ARROW or UP ARROW
Move among choices in a selected submenu; move among certain options
in a group of options.
SPACEBAR or ENTER
Open the selected menu, or perform the action assigned to the selected
button.
SHIFT+F10
Open a shortcut menu; open a drop-down menu for the selected gallery
item.
HOME or END
When a menu or submenu is visible, select the first or last command on the
menu or submenu.
PAGE UP or PAGE DOWN
Scroll up or down in the selected gallery list.
CTRL+HOME or CTRL+END
Move to the top or bottom of the selected gallery list.
Move and resize toolbars and task panes
1. Press ALT to select the menu bar.
2. Press CTRL+TAB repeatedly to select the toolbar or task pane you want.
3. Do one of the following:
Resize a toolbar
1. In the toolbar, press CTRL+SPACE to display the Toolbar Options
menu.
2. Select the Size command, and then press ENTER.
3. Use the arrow keys to resize the toolbar. Press CTRL+ the arrow keys
to resize one pixel at a time.

Move a toolbar
1. In the toolbar, press CTRL+SPACE to display the Toolbar Options
menu.
2. Select the Move command, and then press ENTER.
3. Use the arrow keys to position the toolbar. Press CTRL+ the arrow
keys to move one pixel at a time. To undock the toolbar, press DOWN
ARROW repeatedly. To dock the toolbar vertically on the left or right
side, press LEFT ARROW or RIGHT ARROW respectively when the
toolbar is all the way to the left or right side.
Resize a task pane
1. In the task pane, press CTRL+SPACE to display a menu of additional
commands.
2. Use the DOWN ARROW key to select the Size command, and then
press ENTER.
3. Use the arrow keys to resize the task pane. Use CTRL+ the arrow keys
to resize by one pixel at a time.
Move a task pane
1. In the task pane, press CTRL+SPACE to display a menu of additional
commands.
2. Use the DOWN ARROW key to select the Move command, and then
press ENTER.
3. Use the arrow keys to position the task pane. Use CTRL+ the arrow
keys to move one pixel at a time.
4. When you are finished moving or resizing, press ESC.
Access and use Open and Save As dialog boxes
The Open, Insert Picture, and Save As dialog boxes support standard dialog
box keyboard shortcuts. (To view standard shortcuts for dialog boxes, refer to
the Use Dialog Boxes and Use Edit Boxes Within Dialog Boxes sections in the
main Keyboard Shortcuts topic.) These dialog boxes also support the shortcuts
below.

ALT+1
Go to the previous folder .
ALT+2
Up One Level
button: Open the folder one level above the open folder.
ALT+3
Search the Web
button: Close the dialog box and open your Web search
page.
ALT+4
Delete
button: Delete the selected folder or file.
ALT+5
Create New Folder
button: Create a new folder.
ALT+6
Views
button: Switch among available folder views.
ALT+7 or ALT+L
Tools button: Show the Tools menu.
SHIFT+F10
Display a shortcut menu for a selected item such as a folder or file.
TAB
Move between options or areas in the dialog box.
F4 or ALT+I
Open the Look in list.
F5
Refresh the file list.
Access and use dialog boxes
TAB
Move to the next option or option group.
SHIFT+TAB
Move to the previous option or option group.
CTRL+TAB
Switch to the next tab in a dialog box.
CTRL+SHIFT+TAB
Switch to the previous tab in a dialog box.
Arrow keys
Move between options in an open drop-down list, or between options in a
group of options.
SPACEBAR

Perform the action assigned to the selected button; check or clear the
selected check box.
First letter of an option in a drop-down list
Open the list if it is closed and move to that option in the list.
ALT+ the letter underlined in an option
Select an option; select or clear a check box.
ALT+DOWN ARROW
Open a selected drop-down list
ESC
Close a selected drop-down list; cancel a command and close a dialog box.
ENTER
Perform the action assigned to a default button in a dialog box.
Access and use edit boxes within dialog boxes
An edit box is a blank box in which you type or paste an entry, such as your user
name or the path to a folder.
HOME
Move to the beginning of the entry.
END
Move to the end of the entry.
LEFT ARROW or RIGHT ARROW
Move one character to the left or right.
CTRL+LEFT ARROW
Move one word to the left.
CTRL+RIGHT ARROW
Move one word to the right.
SHIFT+LEFT ARROW
Select or unselect one character to the left.
SHIFT+RIGHT ARROW
Select or unselect one character to the right.
CTRL+SHIFT+LEFT ARROW
Select or unselect one word to the left.
CTRL+SHIFT+RIGHT ARROW
Select or unselect one word to the right.
SHIFT+HOME
Select from the insertion point to the beginning of the entry.
SHIFT+END

Select from the insertion point to the end of the entry.
Access and use smart tags
ALT+SHIFT+F10
Display the menu or message for a smart tag. If more than one smart tag is
present, switch to the next smart tag and display its menu or message.
DOWN ARROW
Select the next item in a smart tag menu.
UP ARROW
Select the previous item in a smart tag menu.
ENTER
Perform the action for the selected item in a smart tag menu.
ESC
Close the smart tag menu or message.
Tip
You can ask to be notified by a sound whenever a smart tag appears. To hear
audio cues, you must have a sound card. You must also have Microsoft Office
Sounds installed on your computer.
If you have access to the World Wide Web, you can download sounds from the
Microsoft Office Online Web site. On the Help menu, click Microsoft Office
Online and search for "Microsoft Office Sounds." After you've installed the
sound files, you need to select the Provide feedback with sound check box on
the General tab of the Options dialog box (Tools menu). When you select (or
clear) this check box, the setting affects all Office programs that support sound.
Access and use programming applications
ALT+F8
Display, edit, or run macros.
SHIFT+ALT+F11
Display the Microsoft Script Editor.
ALT+F11
Display the Microsoft Visual Basic Editor.
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Run an accessibility report
1. On the Tools menu, click Accessibility.
2. Specify the pages you want to check for accessibility issues.
How?
Open the page or site you want to check and then do one of the following:
To specify all pages in a Web site, under Check where, click All
pages.
To specify only the pages you have open, under Check where, click
Open page(s).
To specify pages from the Folder List, select the pages you want , and
then under Check where, click Selected pages.
If the Folder List is not available, click the arrow next to Toggle
Pane, and then click Folder List.
To specify the active page, under Check where, click Current page.
3. Specify the accessibility guidelines you want to check for conflicts.
4. Specify the types of items you want to include in the accessibility report.
How?
Do one or more of the following:
To include items that are considered errors, select the Errors check
box.
To include items that may need to be adjusted, select the Warnings
check box.
To add check boxes to the report to create a checklist you can use
while addressing the issues in the accessibility checker report, select
the Manual checklist check box.

5. Click Check.
The check may take some time to complete, depending on the number of
options you selected.
6. To move up or down in the list of issues, click Previous or Next.
Tip
The status bar of the dialog box displays the number of problems and the
number of pages checked.
7. To create a Web page that contains the results of the accessibility check,
click Generate HTML Report.
The page opens in Design view. You can print the report or save it as a Web
page.
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Accessibility features in FrontPage
Tools for designing accessible Web sites
Accessibility checker
Microsoft Office FrontPage 2003 features a new accessibility checker for Web
pages. By running the accessibility checker, you discover issues that are
identified as being in conflict with the World Wide Web Consortium (W3C) Web
Content Accessibility Guidelines (WCAG) or the accessibility guidelines for
Section 508 of the U.S. Rehabilitation Act. WCAG outlines priorities for making
Web sites accessible to people with disabilities. Section 508 outlines the U.S.
government accessibility standards for a wide range of information sources and
technologies. For more information about the FrontPage accessibility checker
features, see FrontPage Help.

Keyboard shortcuts
View all Keyboard shortcuts
Show or hide shortcut keys in ScreenTips
1. On the Tools menu, click Customize.
2. Click the Options tab.
3. Under Other, select or clear the Show ScreenTips on toolbars and Show
shortcut keys in ScreenTips check boxes.
Note Changing this setting affects all of your Microsoft Office programs.

Size options
Increase the size of toolbar buttons
1. On the Tools menu, click Customize.
2. Click the Options tab.
3. Select the Large icons check box.
Change the width of a drop-down list box on a toolbar
1. Make sure the toolbar you want to change is visible.
How?
1. On the View menu, point to Toolbars.
2. Do one of the following:
Click the toolbar you want to display.
To view more toolbars, click Customize. In the Customize dialog
box, click the Toolbars tab, and then select the check box for the
toolbar you want to display. Click Close.
2. On the Tools menu, click Customize.
3. With the Customize dialog box open, click the list box you want to
change — for example, the Font
or Font Size
box on the
Formatting toolbar.
4. Point to the left or right edge of the box. When the pointer changes to a
double-headed arrow, drag the edge of the box to change its width.
Scroll and zoom by using the Microsoft IntelliMouse or other pointing
device
Some mouse devices and other pointing devices, such as the Microsoft
IntelliMouse, have built-in scrolling and zooming capabilities. For more
information, see the instructions for your pointing device.

Toolbar and menu options
Add a button to a toolbar
1. Make sure the toolbar you want to change is visible.
How?

2.
3.
4.
5.
6.

1. On the View menu, point to Toolbars.
2. Do one of the following:
Click the toolbar you want to display.
To view more toolbars, click Customize. In the Customize dialog
box, click the Toolbars tab, and then select the check box for the
toolbar you want to display. Click Close.
Click the Toolbar Options arrow .
Point to Add or Remove Buttons, and then click Customize.
Click the Commands tab.
In the Categories box, click a category for the command you want the
button to perform.
Drag the command you want from the Commands box to the displayed
toolbar.
Create a custom toolbar

1.
2.
3.
4.
5.
6.
7.

On the Tools menu, click Customize.
Click the Toolbars tab.
Click New.
In the Toolbar name box, type the name you want, and then click OK.
Click the Commands tab.
Click a category in the Categories box.
Drag the command you want from the Commands box to the displayed
toolbar.
8. When you have added all the buttons and menus you want, click Close.
Group related buttons and menus on a toolbar

You can add a separator bar before the first and after the last item in a group to
distinguish the group from other buttons and menus on a toolbar.
1. Make sure the toolbar you want to change is visible.
How?
1. On the View menu, point to Toolbars.
2. Do one of the following:
Click the toolbar you want to display.
To view more toolbars, click Customize. In the Customize dialog
box, click the Toolbars tab, and then select the check box for the
toolbar you want to display. Click Close.
2. On the Tools menu, click Customize.
3. To add a separator bar, keep the Customize dialog box open, right-click the
button you want on the toolbar, and then click Begin a Group. A separator
bar is added to the left of the button on a horizontal toolbar, and above a
button on a vertical docked toolbar.
Note To remove a separator bar between two buttons, drag one button closer to
the other.

Color and sound options
Change the color of text by using the toolbar
1. Select the text you want to change.
2. Do one of the following:
To apply the color most recently used for text, click Font Color
the Formatting toolbar.
To apply a different color, click the arrow next to the Font Color
button, and then select the color you want.

on

Turn sounds on or off for buttons, menus, and other screen elements
1. Click the Microsoft Windows Start button, and then click Control Panel.
2. In Classic view, click Sounds and Audio Devices.
3. On the Sounds tab, in the Program events list, click the program event you
want.
4. In the Sounds box, click the sound you want to play whenever the selected
program event occurs.
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About checking Web pages for
accessibility
By checking your Web pages for accessibility issues and fixing them, you
improve the site visitor experience for people with disabilities.
In addition to many other types of accessibility concerns, people with disabilities
can have difficulty reading text or might not be able to use a keyboard or mouse.
By using the accessibility checker on Web pages you create or edit in Microsoft
FrontPage, you discover issues that are identified as being in conflict with the
World Wide Web Consortium (W3C) Web Content Accessibility Guidelines
(WCAG) or the accessibility guidelines for Section 508 of the U.S.
Rehabilitation Act. WCAG outlines priorities for making Web sites accessible to
people with disabilities. Section 508 outlines the U.S. government accessibility
standards for a wide range of information sources and technologies.
Issues that are in conflict with these guidelines can make it difficult or
impossible for people with disabilities to use your Web site. The accessibility
checker, which can be activated with a single key press, also works for pages
that are not part of a site. When you use the accessibility checker, you can also
add a checklist to the report that is generated. You can use this checklist to help
review and track the accessibility issues as you fix them. The report and optional
checklist can either be printed or saved as a Web page.
About guidelines used by the accessibility checker
When you use the accessibility checker, you use FrontPage to evaluate the
design and code of your pages according to the following standards:
Compliance with the WCAG The WCAG guidelines explain how to make
Web content accessible to people with disabilities. There are Priority 1 and
Priority 2 guidelines.
By not complying with Priority 1 guidelines, "One or more groups of users
will find it impossible to access information." An example of a Priority 1

issue is, "Provide a text equivalent for every non-text element (e.g., via
"alt", "longdesc", or in element content)." A non-text element is a graphic, a
Macromedia Flash animation, a Java applet, and so on.
By not complying with Priority 2 guidelines, "One or more groups of users
might find it difficult to access information." An example of a Priority 2
issue is, "When an appropriate markup language exists, use markup rather
than images to convey information."
Compliance with Section 508 This act requires access to electronic and
information technology used by U.S. Federal agencies. Section 508 guidelines
are not prioritized, but many are similar to the WCAG Priority 1 and 2
guidelines.
About the results of using the accessibility checker
When you use the accessibility checker on one or more pages, the results are
displayed in a dialog box. Each item is displayed on a separate line, and the
dialog box results indicate whether the problem is in conflict with a WCAG or a
Section 508 guideline. In addition, the dialog box displays a description of the
issue, a hyperlink to the online guidelines for that issue, and the line in the
HTML code for your page where the issue was identified. The following
example shows how the results are displayed:
Priority 1
WCAG 1.1
1. Error: Image is missing
a text equivalent (either
an alt="X" or longdesc="X").
Consider brief alternative
text that describes the
information that the image
conveys. You can use the
picture properties dialog to
add alternative text.

Because the issues appear in a list, they can be reviewed one at a time, printed,
or saved for a later review. By saving the results, which are stored as a Web
page, you can edit that page in FrontPage, or save it to a Web site or intranet site.

Automatically open the last Web site
1. On the Tools menu, click Options, and then click the General tab.
2. Select the Open last Web site automatically when FrontPage starts
check box.

Stop FrontPage from automatically
opening the last Web site
1. On the Tools menu, click Options.
2. Click the General tab.
3. Clear the Open last Web site automatically when FrontPage starts check
box.

Undo or redo an action
Microsoft FrontPage maintains a list of the last 30 actions and lets you undo
each, in sequence. Similarly, you can redo any of the last 30 actions that you've
undone by using the Undo command.
Do one or more of the following:
To undo the last action you performed, click Undo . If you click Undo
again, FrontPage will undo the action you performed before that, and so on.
To see a list of the most recent actions that you can undo, click the arrow
next to Undo , and then select the action or actions that you want to
undo.
To redo the last action you undid, click Redo .
To see a list of the most recent undone actions that you can redo, click the
arrow next to Redo , and then select the undone action or actions that
you want to redo.
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Troubleshoot unavailable commands
Certain commands are made unavailable by using specific authoring settings. To
make those commands available, you must modify the authoring settings.
How?
On the Tools menu, click Page Options, and then click the Authoring tab.
Unavailable commands and features
The following items are the commands or features that might become
unavailable because of authoring settings.
Menu commands
Unavailable
commands

Possible cause
One or more of the following is true:

Database

Your Web server administrator may have turned off
support for this feature.
The Open Database Connectivity (ODBC) component
might not be installed on the Web Server.
Dynamic HTML Effects is not available as a default menu
command.
You can add the Dynamic HTML Effects command to a
menu.

Dynamic HTML
Effects

How?
1. On the Tools menu, click Customize.

2. Click the Commands tab.
3. In the Categories list, click Format, and then in the
Commands list, click Dynamic HTML Effects.
4. Drag the command to the menu you want.
One of the following is true:
Import (on the
Packages
submenu)

Your Web site is not located on a server running
Windows SharePoint Services.
Your Web site is disk-based.

Interactive Button

On the Authoring tab, the JavaScript/JScript check box
is cleared.

Layer

On the Authoring tab, the JavaScript/JScript check box
is cleared.

Page Transition

On the Authoring tab, the CSS 1.0 (formatting) check
box is cleared.

Position

On the Authoring tab, either the CSS 1.0 (formatting) or
CSS 2.0 (positioning) check box is cleared.
One or both of the following is true:

Shared Borders

On the Authoring tab, the Shared Borders check box
is cleared.
You do not have a Web site open.

Style

On the Authoring tab, the CSS 1.0 (formatting) check

box is cleared.

Style Sheet Links

On the Authoring tab, the CSS 1.0 (formatting) check
box is cleared.

Task pane commands
Unavailable commands

Possible cause

Cell Properties and Borders, Cell Header and
Footer, and Cell Corners and Shadows (in the
Cell Formatting task pane)

You have selected a
standard table or cell, not a
layout table or cell.

Create (in the Conditional Formatting task pane)

You have not made a
selection in a data view.

Insert (in the Behaviors task pane)

On the Authoring tab, the
JavaScript/JScript check
box is cleared.

Dialog box options
Unavailable
commands

ActiveX Control

Possible cause
On the Authoring tab:
The ActiveX controls check box is cleared.
The SharePoint Services check box is selected.
Either Netscape Navigator or Both Internet
Explorer and Navigator is selected under
Browsers.
Note This feature is not available on a Web site located
on a server running Microsoft Windows SharePoint

Services.
Banner Ad Manager is not available as an option in the
Insert Web Component dialog box.
You can manually add the Banner Ad Manager
command to a menu.
Banner Ad
Manager

How?
1. On the Tools menu, click Customize.
2. Click the Commands tab.
3. In the Categories list, click Insert, and then in the
Commands list, click Banner Ad Manager.
4. Drag the command to the menu you want.

CSS1.0 (on the
Authoring tab)

On the Authoring tab, the CSS 2.0 (positioning) check
box is cleared.
One of the following is true:

Document Library
View

Your Web site is not located on a server running
SharePoint Team Services v1.0 from Microsoft.
On the Authoring tab, the SharePoint Services
check box is cleared.
Note To add a SharePoint list to a Web site on a server
running Windows SharePoint Services, use a list view or
data view Web Part.

Frames (missing
dialog box tab)

On the Authoring tab, the Frames check box is cleared.

Hover Button is not available as an option in the Insert
Web Component dialog box.
You can add the Hover Button command to a menu.
How?
Hover Button

1. On the Tools menu, click Customize.
2. Click the Commands tab.
3. In the Categories list, click Insert, and then in the
Commands list, click Hover Button.
4. Drag the command to the menu you want.
One of the following is true:

List View

Your Web site is not located on a server running
SharePoint Team Services v1.0 .
The SharePoint Services check box is cleared on
the Authoring tab.
Note To add a SharePoint list to a Web site on a server
running Windows SharePoint Services, use a list view or
data view Web Part.

Marquee

Either Netscape Navigator only or Both Internet
Explorer and Navigator is selected under Browsers.

PNG-8 and PNG-24

On the Authoring tab, the PNG graphics check box is
cleared.

Rules (missing

Your Web site is not located on a server running
SharePoint Team Services v1.0.

dialog box tab)

Note This feature is not available on a Web site located
on a server running Windows SharePoint Services.

Spreadsheets and
charts

On the Authoring tab, the ActiveX controls check box is
cleared.

Style button (on
various Properties
dialog boxes)

On the Authoring tab, either the CSS 1.0 (formatting) or
CSS 2.0 (positioning) check box is cleared.

Use background
picture

Either Netscape Navigator only or Both Internet
Explorer and Navigator is selected under Browsers.

Toolbar options
Unavailable commands
AutoShapes (on the
Drawing toolbar)

Possible cause
On the Authoring tab, the VML graphics (Office
drawing) check box is cleared.
The Dynamic HTML toolbar is not turned on by
default.

Dynamic HTML
(toolbar)

You can turn on the Dynamic HTML toolbar.
How?
On the View menu, point to Toolbars, and then click
DHTML Effects.

Unexpected action
Action

Possible cause

No downlevel image file is created
when you insert a drawing object.

On the Authoring tab, the Downlevel
image file check box is cleared.

Browser settings
The following table shows options and features that Microsoft FrontPage either
disables or makes unavailable depending on the browser settings you choose on
the Authoring tab. If you reselect a cleared check box, your browser settings
may change to Custom.
Browser settings

Unavailable commands

Browser: Microsoft
Internet Explorer only
All commands are available.
Versions: 5 or 6 and
later
Browser: Microsoft
Internet Explorer only

All commands are available.

Versions: 4.0 and later
Browser: Microsoft
Internet Explorer only

PNG graphics, CSS 2.0 (positioning)

Versions: 3.0 and later
Browser: Netscape
Navigator only

ActiveX controls, VBScript, in the Table Properties
Versions: 5.0 or 6.0 and dialog box: Use background picture
later

Browser: Netscape
Navigator only
Versions: 4.0 and later

ActiveX controls, VBScript, in the Table Properties
dialog box: Use background picture

Browser: Netscape
Navigator only

ActiveX controls, VBScript, CSS 1.0 (formatting),
CSS 2.0 (positioning), PNG graphics, in the Table
Versions: 3.0 and later Properties dialog box: Use background picture
Browsers: Both
Microsoft Internet
Explorer and Netscape
ActiveX controls, VBScript, in the Table Properties
Navigator
dialog box: Use background picture
Versions: 5.0 or 6.0 and
later
Browsers: Both
Microsoft Internet
Explorer and Netscape ActiveX controls, VBScript, in the Table Properties
dialog box: Use background picture
Navigator
Versions: 4.0 and later
Browsers: Both
Microsoft Internet
ActiveX controls, VBScript, CSS 1.0 (formatting),
Explorer and Netscape CSS 2.0 (positioning), PNG graphics, in the Table
Navigator
Properties dialog box: Use background picture
Versions: 3.0 and later

Rename a file or folder
1. In the Folder List, right-click the file or folder that you want to rename.
If the Folder List is hidden, on the View menu, click Folder List.
2. On the shortcut menu, click Rename.
3. Type a new name for the file or folder.
Important
When renaming a file, do not change or omit the file extension. For
example, if you rename a file named Index.asp to Index.htm it might render
the file as unusable.
You should always rename a file or folder in a Web site by using this
procedure. Microsoft FrontPage automatically repairs any hyperlinks to or
from the renamed file (or files in the renamed folder). If you rename a file
or folder using Microsoft Windows Explorer, hyperlinks to and from that
file (or files in that folder) will not be repaired automatically.
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Create a subfolder
1. In the Folder List, right-click the folder that you want to create a new
subfolder in, point to New on the shortcut menu, and then click Folder.
If the Folder List is hidden, on the View menu, click Folder List.
2. Do one of the following:
Create a standard subfolder
Type the name of the new subfolder, and then press ENTER.
Create a hidden subfolder
Type the name of the new hidden subfolder, preceding its name with an
underscore (for example, _database), and then press ENTER.
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Hide a Web page
If you do not want site visitors to see certain pages in a Web site, you can hide
these pages by placing them in the hidden folder _private. This folder is
contained in every FrontPage Web site based on FrontPage Server Extensions,
SharePoint Team Services v1.0 from Microsoft, or Microsoft Windows
SharePoint Services.
1. In the Folders List, select the files for the Web pages you want to hide.
How?
Hold down CTRL, and click the pages you want to select.
To display the Folders List, on the View menu, click Folder List.
2. Drag the selected file to the _private folder.
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Delete a file from a Web site
In the Folder List, click the file you want to delete, and then press
DELETE.
To display the Folder List, on the View menu, click Folder List.
Note When you delete a Web page from a Microsoft FrontPage Web site, it
deletes the file from your hard drive.
Tip
To select multiple pages, hold down CTRL, and click the pages you want to
select.
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About views
In Microsoft FrontPage, there are several different ways for you to look at the
content in your Web site to help you effectively design, publish, and manage it.
You can work with your Web pages in any of the following views:
Page view
You can choose from four different types of Page views, depending on your
specific needs and how you want to view and work with your pages.
Design view You can design and edit Web pages in the default Page view,
Design view. This view provides you with an approximated WYSIWIG
authoring experience, as you create your Web pages using the design tools.
Code view You can view, write, and edit the HTML tags yourself. With
the optimized code features in FrontPage, you can create clean HTML, and
it is easier for you to remove any code that you do not want.
Split view You can review and edit Web page content in a split screen
format that offers you simultaneous access to both the Code and Design
views.
Preview view You can approximate how the page will look in the Web
browser without having to save your page. Use this view to check small
changes that you are unsure whether you want to commit to.
Folders view
You can use Folders view to work with the files and folders directly, and to
organize the contents of your Web site. Similar to Microsoft Windows Explorer,
you can also create, delete, copy, and move folders in this view.
Remote Web Site view
You can use Remote Web site view to publish an entire Web site or to
selectively publish individual files. You can also synchronize files between two
or more locations— that is, make sure sites with the same content are up-to-date

with recent changes.
When you view folder contents in Remote Web site view, the files are marked
with icons and descriptive text indicating the publish status, such as Don't
Publish, Changed, Unchanged, New, and Conflict. You can filter the view to
show the folder contents, files to publish, files not to publish, and files in
conflict.
Reports view
Reports view allows you to analyze the contents of a Web site after running a
report query. You can calculate the total size of the files in your site, show which
files are not linked to other files, identify slow or outdated pages, group files by
task or person they're assigned to, and more.
Navigation view
Navigation view provides you with a hierarchical view of your Web pages. This
view enables you to arrange the pages in your site by clicking on a page and
moving it to a new location in the site.
Hyperlinks view
In FrontPage, Hyperlinks view shows the status of the hyperlinks in your Web
site in a list. This list includes both internal and external hyperlinks, and uses
icons to indicate whether the hyperlinks have been verified or are broken.
Tasks view
Tasks view displays all the tasks in your Web site in a column format and
provides current information about each task under various headings.

Switch views
On the View menu, click the view that you want to use.
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Troubleshoot views
I do not see the Folder List when I am in Page view.
On the View menu, click Folder List.
I do not see the Navigation Pane when I'm in Page view.
On the Standard toolbar, click Toggle Pane
click Navigation Pane.

to display the list, and then

My Folder List disappeared.
If the Folder List is hidden, on the View menu, click Folder List.
Why don't I see the HTML tab?
What was known as the HTML pane in earlier versions of Microsoft FrontPage,
is now referred to as Code view. To view your Web pages in Code view, do the
following:
In Page view, at the bottom of the document window, click Code .
Why don't I see the Normal tab?
What was known as the Normal pane in earlier versions of Microsoft FrontPage,
is now referred to as Design view. To view your Web pages in Design view, do
the following:
In Page view, at the bottom of the document window, click Design .
Where is the View bar on the left side of the document window?
In Microsoft Office FrontPage 2003, in order to provide users with more space
to create their Web pages, the View bar was removed. To see a list of views, do
the following:

On the View menu, click a view that you want to use.
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Print a Web page
Do one of the following:
Print the page as it looks in Design view
1. In Page view, at the bottom of the document window, click Design .
2. On the Standard toolbar, click Print .
Note Hyperlinks and pictures print as they appear in Design view.
Print the page as it looks in Code view
1. In Page view, at the bottom of the document window, click Code .
2. On the Standard toolbar, click Print .
Tip
To see how the page will look when printed, on the File menu, click Print
Preview. However, this preview is not exactly the same as the view from a Web
browser — print preview paginates and assigns page numbers, but Web browsers
do not.
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About creating and designing Web
pages
Some of the content in this topic may not be applicable to some languages.
Web pages are the basic documents of the World Wide Web. They can either be
part of a Web site, or they can stand alone. Many of the features in Microsoft
FrontPage are used when working with a Web site. There are also features in
FrontPage that will help you to both design and create your Web page.
To help you create professional-looking and well-designed Web pages,
FrontPage provides several page templates that you can use to quickly create
pages with a variety of layouts and functions. For example, you can use a
FrontPage template to create a user registration page, guest book, feedback form,
a page with a search form, and more.
You can use themes to create pages with a consistent design. A theme contains
unified design elements with a color scheme, including fonts, graphics,
backgrounds, navigation bars, horizontal lines, and other page elements.
If you prefer to design and lay out pages yourself, you can start with a blank
page, and then do one or more of the following:
Use frames, tables, layouts, or absolute positioning to precisely position
text and graphics on a page.
Add page elements, such as text, graphics, page banners, tables, forms,
hyperlinks, and so on.
Add dynamic elements such as Flash content, video, sound, or animated
GIFs.
Add content or functionality that can change, such as marquees, hit
counters, time stamps, page transitions, interactive buttons, and behaviors
that use Dynamic HTML (DHTML).
Format text by applying styles or using style sheets.
Set the background of your Web page with either color or pictures.
Create your own page templates by using dynamic Web templates, which
can include pages that contain page settings, formatting, and page elements.

You can also start with a graphical representation of your Web site, called a
tracing image. You can do this by creating a mock-up of a Web page image in a
graphics program and then use it as a visual guide to re-create or trace the Web
page design.

Editing in FrontPage
You do not need to know how to code in HTML to use FrontPage. While you
edit pages as you would in a word processor — typing and formatting text, and
adding graphics, tables, and other page elements — FrontPage adds the HTML
tags in the background. You simply edit your pages in Design view.
However, if you want to familiarize yourself with HTML or edit HTML code
directly, you can also use Code view, which displays the HTML code of a Web
page, or Split view, which displays both Code view and Design view
simultaneously.
If you are familiar with HTML, you can display the HTML tags in Code view
and you can write and edit the HTML tags yourself. With the create and maintain
optimized code options available in FrontPage, you can create clean HTML, and
easily remove any code that you do not want.
In FrontPage, you can use Extensible Markup Language (XML) to complement,
rather than replace, your HTML. You can view or edit files, apply standard
formatting to the structure of code in XML files, view the XML tree, and create
custom displays of XML data on Web pages. For example, you can create a Web
page that displays data from an XML file, format that data, and apply filtering,
sorting, and conditional formatting to display the data the way you want.

Turn support for FrontPage Web
components on or off
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. Do one of the following:
To turn support on or off for Web components that can make it easier
to create and design Web pages — such as a photo gallery — select or
clear the Author-time Web Components check box.
To turn support on or off for Web components that are available on
Web sites located on Web servers running FrontPage Server
Extensions from Microsoft, SharePoint Team Services from Microsoft,
or Microsoft Windows SharePoint Services, select or clear the
Browse-time Web Components check box.
Note When you turn on support for author-time Web components, support for
link bars and shared borders is not automatically turned on as well. To turn
support on or off for link bars or shared borders, select or clear the Navigation
or Shared Borders check box.
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About tracing images
You can create a mock-up of a Web page image in a graphics program and then
use it as a visual guide to re-create or trace the Web page design. This is called a
tracing image and it can be a JPEG, GIF, PNG, or BMP image. After you set a
tracing image, it appears in the background of the document window in Design
view. You can show or hide the image, set its opacity, and change its position.
You can view the tracing image only in Microsoft FrontPage. You cannot see the
tracing image when you view your site by using a Web browser.
After you set a tracing image, it is stored in a layer between the background
image and the editor in FrontPage. If the opacity of the tracing image is set to '0'
you will not be able to see it, but you will be able to see all the text and object
elements.
The X and Y coordinates of the tracing image correspond to the upper-left corner
of the document window. You can set the placement of the tracing image in
pixels by choosing the X (side to side) and Y (up or down) coordinates in the
Tracing Image dialog box. If your margins are set to a margin other then '0', the
tracing image will not take them into account as the tracing image placement is
always set relative to the upper-left corner of the document. The following
illustrations show how the X and Y coordinates determine the placement of the
tracing image.

When you save a Web page that contains a tracing image, you will be prompted
to save the tracing image as an embedded file in your Web site. Doing this will
not effect the appearance of your site in a browser. If you set a second tracing
image for a page, the first image disappears.
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Set a tracing image
1. In Page view, at the bottom of the document window, click Design .
2. On the View menu, point to Tracing Image, and then click Configure.
3. Locate and click the file you want to set as a tracing image, and then click
Insert.
4. In the X box, type or select the horizontal coordinates for the tracing image
in pixels.
5. In the Y box, type or select the vertical coordinates for the tracing image in
pixels.
6. Under Opacity, move the slider to set the opacity of the tracing image.

Show or hide a tracing image
In Page view, at the bottom of the document window, click Design .
On the View menu, point to Tracing Image, and then click Show Image.
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Open a Web page
Do one of the following:
Open a page from within the current Web site
In Folders view, double-click the page.
Open a page on a different Web site or in a local file system
Important Open files from a trusted source. Question messages, attachments or
files from unexpected sources. If a file has an unusual filename, timestamp,
extension, file size, or other property, do not open the file. Always scan files
with antivirus software before opening them. In the course of infecting a hard
drive or a Web server, some viruses may create files or overwrite existing ones.
If opened, these files may cause harm to your system. Make sure your server is
running up-to-date antivirus software. For more information, contact your Web
server administrator or Web site hosting company.
1. In Folders view, locate and click the file you want, and then click Open
Note If you open a Web page that is on a different Web site from the one you
have open, a new instance of Microsoft FrontPage will open.

.

Create a new Web page
Some of the content in this topic may not be applicable to some languages.
1. On the File menu, click New.
2. In the New task pane, under New page, do one of the following:
To create a Web page from a blank page, click Blank page.
To create a Web page from a dynamic Web template that you’ve
created, click From existing page, locate and click the template, and
then click Create new.
To create a Web page from a template included with Microsoft
FrontPage, click More page templates, click the tab for the type of
template you want, and then click a template.
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Save a Web page
Do one of the following:
Save a Web page to the current Web site
Do one of the following if you have:
Not saved the page
1. Click Save .
2. Locate and double-click the folder where you want to save the page.
3. In the File name box, type the file name of the page, and then click
Save.
Opened the page from the current Web site
Click Save

.

Opened the page from a location outside the current Web site
1. On the File menu, click Save As.
2. Locate and double-click the folder where you want to save the page.
3. In the File name box, type the file name of the page, and then click
Save.
Save a Web page to a different Web site
1.
2.
3.
4.

On the File menu, click Save As.
Locate and click the Web site where you want to save the page.
In the File name box, type the name of the page.
Click Save .
Save a Web page to a file system

1. On the File menu, click Save As.
2. Locate and click the location in the file system where you want to save the
page.
3. In the File name box, type the name of the page.
4. Click Save.
Save a Web page automatically before previewing it in the browser
1. On the File menu, point to Preview in Browser, and then click Edit
Browser List.
2. Click the Automatically save page before previewing check box.
Notes
If you have added graphics, ActiveX controls, sound files, or other objects
to the page, you will be prompted to save them to the same location as the
page.
To ensure that all site visitors can follow URLs regardless of their computer
language or operating system, you should use plain ASCII characters in the
URLs for your Web pages. On intranets, using non-ASCII characters in a
file name will work as long as the server and all clients share the same
system code page.

Stop loading a Web page
On the Standard toolbar, click Stop

.

Refresh a Web page or a view
To refresh a Web page or view, click Refresh

.
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Set Web page margins
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Right-click the page, and then click Page Properties on the shortcut menu.
Click the Advanced tab.
Do one or all of the following:
Set a top margin
1. In the Top Margin box, enter a value for a top margin in pixels.
2. In the Margin Height box, enter a value for the height of the margin
in pixels.
Set a left margin
1. In the Left Margin box, enter a value for a left margin in pixels.
2. In the Margin Width box, enter a value for the width of the margin in
pixels.
Set a bottom margin
1. In the Bottom Margin box, enter a value for a bottom margin in
pixels.
2. In the Margin Height box, enter a value for the height of the margin
in pixels.
Set a right margin
1. In the Right Margin box, enter a value for a right margin in pixels.
2. In the Margin Width box, enter a value for the width of the margin in
pixels.
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About layout tables and cells
Overview of layout tables and cells
With Microsoft Office FrontPage 2003, you can create professional-looking Web
page layouts by using layout tables and cells. A layout table is the framework
you create for the page layout. Layout cells are the regions within that
framework that contain the content in a page, including text, images, Web parts,
and other elements. Together, layout tables and cells represent horizontal and
vertical regions that users can add to Web pages, which can provide a
sophisticated visual structure for your content.
The following example displays a layout table and cells in the initial stages,
where the layout table is shown with a lighter background color and the cells are
shown as dark rectangles within the table.

The following example shows the same layout table and cells with content.

You can use the predefined layout tables that are available in the Layout Tables
and Cells task pane to help you get a quick start on a Web page. You can also
create your own custom layout table by drawing tables and cells. Additionally,
you can edit a Web page that contains layout tables and cells that you added by
using FrontPage or another Web authoring tool, including Macromedia
Dreamweaver.
You can draw a layout table that contains a cell along the top edge of the page to
hold a header graphic, a cell on the left edge of the page to hold a link bar, and
another cell to hold the main content of a Web page, that snaps to the right edge
of the page. You can create simple or complex layout tables, depending on your
requirements.
Working with layout tables and cells
You can draw a layout table and then add cells on your Web page by using the
layout tools, available in the Layout Tables and Cells task pane. You can select
a predefined layout table template, or you can create your own layout table and
adjust width and height settings, set the alignment, set the page margins, and
apply color and special borders.
When you click the border of a layout table or cell to activate it, labels
representing the column width and row height appear on each side. Each label
includes a drop-down arrow that you can click to view a list of options for
resizing a column or row.
The following example shows how a layout table or cell looks in FrontPage
when you have clicked the border to activate it.

You can also select one column or row in a table and enable it to automatically
expand to fill as much of a browser window as possible. The expanding cell
functionality is referred to as autostretch. When you click the arrow on the
column width or row height resize label, and then click Make Column
Autostretch or Make Row Autostretch, you make that cell an autostretch cell,

and the cell will automatically resize to fit the available space of a site visitor's
browser window.
About the Layout Tables and Cells task pane
The Layout Tables and Cells and Cell Formatting task panes are the primary
tools for working with layout tables and cells. You can accomplish the following
in these task panes:
Draw a layout table.
Insert a layout cell.
Set the width and height of a table or cell.
Adjust page margins.
Set the alignment of a layout table or cell.
Turn the layout tools on and off.
Select a predefined layout table.
Formatting layout cells
After you have added a layout table and the individual cells to make up the
structure of your Web page, you can begin adding details such as color, graphical
borders, drop shadows, and other decorative effects — including corners that
create a tab-like look on selected edges of a cell.
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Add or draw a layout table
1. On the Table menu, click Layout Tables and Cells.
2. In the Layout Tables and Cells task pane, do one of the following:
Add a layout table from the Table layout template list
Under Table layout, select a layout table from the list of templates.
Draw a layout table
1. Under New tables and cells, click Draw Layout Table .
2. Move the pointer to the leftmost corner of the document window, and
then drag to draw the table.
3. In the Layout Tables and Cells task pane, under Table properties, set
the properties that you want.
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Add a cell to a layout table
1. In the Layout Tables and Cells task pane, under New tables and cells,
click Draw Layout Cell .
2. On the layout table, drag the pointer to draw the cell.
3. Repeat steps 1 and 2 to add more cells.
Tip
To draw two or more cells, one after the other, click Draw Layout Cell
,
and press and hold CTRL while you drag the pointer.
4. To set properties for a selected cell, on the Layout Tables and Cells task
pane, click Cell Formatting and select the properties you want.
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Resize a layout table or cell
Do one of the following:
Resize a layout table or cell in small increments
1. Click the border of the layout table or cell.
2. Press and hold ALT, and then drag the border to resize it.
Resize a layout table or cell by using autostretch
1. In Page view, at the bottom of the document window, click Design .
2. To activate a layout table or cell, click the border.
3. On the column width or row height label, click the arrow to display the
drop-down menu, and then click Make Row Autostretch or Make
Column Autostretch.
Note You can apply autostretch to only one cell in a layout table. The
corresponding rows or columns in the layout table must be set at a fixed width or
height.
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Set properties for a layout table
1. In the document window, click the border of the layout table that you want
to set properties for.
2. In the Layout Tables and Cells task pane, under Table properties, select
the properties that you want.
Tip
To override the default margins of a Web page and let the layout table span to the
edges of the document window, set the margin properties to 0 (zero).
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Set the corner and shadow properties
for a layout cell
1. In the document window, click the border of the cell that you want to set the
corner and shadow properties for.
2. In the Layout Tables and Cells task pane, click Cell Formatting.
3. Click Cell Corners and Shadows, and then do one or more of the
following:
Change corner properties of a layout cell
Under Corners, do one or more of the following:
To add a custom image to a corner of a cell, click Use custom
image, and then click Browse to locate the graphic you want to
use.
To set width or height of a cell corner, in the Width and Height
boxes, type the value that you want in pixels.
To add color to a cell corner, click a color from the Color list.
To add color to the border of a cell corner, click a color from the
Border color list.
To apply a corner to the top, bottom, or both top and bottom sides
of a cell, under Apply, click the options that you want.
Change shadow properties of a layout cell
Under Shadows, do the following:
To set the width of a drop shadow for a cell, in the Width box,
type the value that you want in pixels.
To set the intensity of a drop shadow of a cell, in the Softness
box, type the value that you want in pixels.
To add color to a drop shadow of a cell, click a color from the
Color list.
To add color to a drop shadow of a cell border, click a color from
the Border color list.
To set the side on which a drop shadow falls, under Apply, click

the option that you want.
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Set the header and footer properties
for a layout cell
1. In the document window, click the border of the cell that you want to set the
header or footer properties for.
2. In the Layout Tables and Cells task pane, click Cell Formatting.
3. In the Cell Formatting task pane, click Cell Header and Footer, and then
do one or more of the following:
Set the header properties for a layout cell
Under Header, click Show header, and then do one or more of the
following:
To change the default, in the Height box, type a value that you want in
pixels.
To set the cell padding for the number of pixels between the cell
header and the cell boundaries, in the Padding box, type a value in
pixels.
To set the vertical alignment of a cell header, in the VAlign list, click
Top, Middle, or Bottom.
To set the background color of a cell header, click a color in the
BgColor list.
To set the thickness of a header cell border, in the Border width box,
type a value in pixels to indicate the width of the border you want.
To add color to a cell header border, click a color from the Border
color list.
Set the footer properties for a layout cell
Under Footer, click Show footer, and then do one or more of the
following:
To change the default, in the Height box, type a value that you want in
pixels.

To set the cell padding for the number of pixels between the cell footer
and the cell boundaries, in the Padding box, type a value in pixels.
To set the vertical alignment of a cell footer, in the VAlign list, click
Top, Middle, or Bottom.
To set the background color of a cell footer, click a color in the
BgColor list.
To set the thickness of a footer cell border, in the Border width box,
type a value in pixels to indicate the width of the border you want.
To add color to a cell footer border, click a color from the Border
color list.
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Set the layout and border properties
for a layout cell
1. In the document window, click the border of the cell that you want to set the
layout and border properties for.
2. In the Layout Tables and Cells task pane, click Cell Formatting.
3. In the Cell Formatting task pane, click Cell properties and borders, and
then do one or more of the following:
Set the layout properties for a layout cell
Under Layout cell properties, do one or more of the following:
To set the fixed width or height of a cell, in the Width and Height
boxes, type the value that you want in pixels.
To set the padding for the number of pixels between content in a cell
and the cell boundaries, in the Padding box, type a value in pixels.
To set the vertical alignment of a cell, in the VAlign list, select Top,
Middle, or Bottom.
To set the background color of a cell, click a color in the BgColor list.
Set the border properties for a layout cell
Under Borders, do one or more of the following:
To set the thickness of a cell border, in the Width box, type a value in
pixels to indicate the width of the border you want.
To add color to a cell border, click a color from the Color list.
Under Apply, click the button that indicates the type of border you
want to apply to the cell.
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Turn layout tools for layout tables on
or off
The layout tools in Microsoft FrontPage are turned off by default.
Do one of the following:
Turn the layout tools on
1. On the Table menu, click Layout Tables and Cells.
2. In the Layout Tables and Cells task pane, add a layout table.
When you add a layout table, the tools turn on automatically.
Turn the layout tools off
1. Click the border of a layout table or cell.
2. In the Layout Tables and Cells task pane, click Show Layout Tool

.

Tip
If you maintain a layout table or cell in a page with the layout tools turned off,
you can always turn the tools back on by clicking Show Layout Tool .
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Delete a layout table or cell
Do one of the following:
Delete a single layout cell
Click the border of the layout cell and then press DELETE.
Delete a layout table
Do one of the following:
If the layout tools are turned on and the entire layout table is activated,
press DELETE.
If the layout tools are turned off or the layout table is not activated, in the
Layout Tables and Cells task pane, click Show Layout Tool
to activate
it, and then press DELETE.
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About formatting text
You can format text in Microsoft FrontPage as you would using a word
processor — to add visual organization, emphasis, and structure. You can change
the font, size, style, color, spacing, and vertical position of text, and add effects
such as underlining. You can also control spacing and indentation, add bullets
and numbers, and set alignment.
You can apply formatting to either selected words, or an entire paragraph. A
general rule is that you can apply font properties such as font, size, color,
highlighting, and effects to selected text, and paragraph properties such as
alignment, bullets, numbering, shading, and borders to entire paragraphs. For
example, you can italicize a single word in a paragraph, but if you try to align
the word to the right, the entire paragraph will align right as well.
Formatting individual characters and words
Properties that you can apply to text include:
Font and font size.
Text formatting effects, which include italics, underline, bold, or
strikethrough.
Properties that increase or decrease the space between characters to expand
or condense your text.
Properties that raise or lower text from the other text on a line; for example,
to mark a word with a copyright symbol or to indicate a footnote. You can
also specify the number of points to raise or lower text.
Highlighting a word or an individual letter.
Formatting paragraphs
A paragraph is a block of text that is separated from another by a paragraph mark
. If lines of text are separated by line breaks , the text is considered to be one
paragraph. The paragraph marks and the line breaks are hidden characters

that can be displayed if needed.
Properties that you can apply to entire paragraphs include:
Spacing between lines in a paragraph.
Borders around text.
Line and paragraph indentation.
Numbered, bulleted, or multi-level lists.
Shading to an entire line or paragraph.
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Select text or graphics
Do one of the following:
Any amount of text
Drag over the text.
A word
Double-click the word.
A line of text
Point to the left of the line until the pointer changes to a right-pointing
arrow, and then click.
A paragraph
Point to the left of the paragraph until the pointer changes to a rightpointing arrow, and then double-click. Or triple-click anywhere in the
paragraph.
Multiple paragraphs
Point to the left of the paragraphs until the pointer changes to a rightpointing arrow, and then drag up or down.
A graphic
Click the graphic.

Format text
1. Select the text you want to format, right-click, and then click Font on the
shortcut menu.
2. Click the Font tab.
3. Select the properties you want.

Raise or lower text
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Select the text, right-click, and then click Font on the shortcut menu.
In the Font dialog box, click the Character Spacing tab.
In the Position box, click the arrow and select super to raise the text, or
sub to lower the text.
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Resize text quickly
1. In Page view, at the bottom of the document window, click Design .
2. Select the text you want to resize.
3. On the Formatting toolbar, click Increase Font Size
or Decrease Font
Size .
If the Formatting toolbar is hidden, on the View menu, point to Toolbars,
and then click Formatting.
Note The smallest font you can get by clicking Decrease Font Size
is 8
points, and the largest font you can get by clicking Increase Font Size
is 36
points.
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Set the spacing between characters
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Select the text, right-click, and then click Font on the shortcut menu.
Click the Character Spacing tab.
In the Spacing box, do one of the following:
To increase the space between characters, click Expanded.
To decrease the space between characters, click Condensed.
5. In the By box, enter a number, in pixels, to specify how much you want to
increase or decrease the space between characters.

Remove text formatting
1. In Page view, at the bottom of the document window, click Design .
2. Select the text that you want to remove formatting from.
3. On the Format menu, click Remove Formatting.

Show All

Troubleshoot text formatting
I want to set the spacing of individual letters within a word (kerning).
Kerning, which is the selective spacing between pairs of letters, is not supported
by Microsoft FrontPage. You can, however, expand or condense all the letters in
a word by doing the following:
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Select the text, right-click, and then click Font on the shortcut menu.
Click the Character Spacing tab.
In the Spacing box, do one of the following:
To increase the space between characters, click Expanded.
To decrease the space between characters, click Condensed.
5. In the By box, type or select a number to specify, in points, how much you
want to increase or decrease the space between characters.
I am unable to add plain bullets to my Web page.
If your page is using a theme, the Plain Bullets tab is unavailable from the
Bullets and Numbering dialog box because themes use their own type of
bullets.
To use Plain Bullets, you must remove the theme from the page.
How?
1.
2.
3.
4.

On the View menu, click Folders.
Select the pages that you want to remove the theme from.
On the Format menu, click Theme.
In the Themes task pane, under Web site default theme, click No
theme.

The collapsible lists I created do not collapse in some Web browsers.
Collapsible lists require ECMAScript as defined by the specification of the

European Computer Manufacturers Association, such as JScript or JavaScript, to
enable the showing and hiding of subitems in a list. In some Web browsers, site
visitors have the ablity to turn off ECMAScript. If a site visitor turns off the
ECMAScript functionality, collapsible lists will maintain an expanded state by
default.
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About pasting text, graphics, and
drawing objects
When you paste text, graphics, or drawing objects in Design view in Microsoft
FrontPage, the Paste Options
button appears near the pasted content.
When you click the Paste Options button, a list appears that lets you determine
the appearance of the content you are pasting. The available options depend on
the type of content you are pasting, the program you are pasting from, and the
format of the text where you are pasting.
Options for pasting text
Use Destination Styles Use this option to remove the styles copied from
the original document, and use the styles in the current FrontPage document
instead.
Example
If you copy Heading 2 text from a Microsoft Word document to a page in
FrontPage, selecting Use Destination Styles ensures that the FrontPage
Heading 2 style is applied. This is useful if Heading 2 is formatted
differently in the two programs and you want to use the FrontPage
formatting.
Keep Source Formatting Use this option to preserve the style formatting
of the source document, regardless of the styles in the current FrontPage
document.
Example
If you copy Heading 2 text from a Microsoft Word document to a page in
FrontPage, selecting Keep Source Formatting ensures that the Word
Heading 2 style is applied. This is useful if Heading 2 is formatted
differently in the two programs and you want to keep the Word formatting.

Keep Text Only Use this option to remove all formatting, and paste the
selection as plain text.
Example
In FrontPage, if you copy a sentence that uses Arial font and is boldfaced,
and paste it to another spot in the same document, selecting Keep Text
Only ensures that just the text is pasted and that the font and text formatting
are removed.
Treat as HTML Tags Use this option when you want FrontPage to render
rather than display HTML tags.
Example
If you copy an example of HTML code from a Web browser (for example,
<i>italic text</i>) to a page in FrontPage, selecting Treat as HTML Tags
ensures that the example code is rendered as italic text.
Options for pasting drawing objects or graphics
Keep Source Formatting Use this option to preserve the positioning
attributes that were applied to the drawing object in the source document.
Example
If you copy a right-aligned drawing object from a Microsoft Word
document to a page in FrontPage, selecting Keep Source Formatting
ensures that the original alignment is preserved.
Microsoft Office Drawing Object Use this option to paste a drawing
object without preserving the positioning attributes from the original
document.
Example
If you copy a right-aligned drawing object from a Microsoft Word
document to a page in FrontPage, selecting Microsoft Office Drawing

Object removes the code specifying the alignment of the drawing object.
Paste as an Image Tag Use this option to convert a pasted Microsoft
Office drawing object into a GIF file when the page is saved.
Example
If you copy a drawing object from a Microsoft Office document to a page in
FrontPage, VML code associated with the image is visible in Code view.
The Paste as an Image Tag option ensures the conversion of the element to
a GIF image.
Note You are prompted to save the newly created GIF file when you save
the Web page.
Resample Picture to Match Size Use this option to resize and resample
an image you paste into your Web page from an external source.
Example
If you copy a 100x100 pixel photograph from a Web site on the World
Wide Web, and you resize it to 50x50 pixels, you select this option to size
and resample the image in your Web page.
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Paste text and graphics
1. Select the text or graphic you want to move or copy, and then do one of the
following:
To move the item, click Cut
on the Standard toolbar.
To copy the item, click Copy
on the Standard toolbar.
2. In Page view, at the bottom of the destination document window, click
Design .
3. Position the insertion point where you want the text or graphic to appear.
4. On the Standard toolbar, click Paste .
5. To specify the formatting, style, and appearance of the content, click the
Paste Options
button that appears next to the pasted content, and then
select the option you want.
Note The paste options that are available depend on the type of content you are
pasting, the program you are pasting from, and the format of the text in the area
where you are pasting.
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Highlight or shade text with color
1. In Page view, at the bottom of the document window, click Design .
2. Do one or both of the following:
Highlight text with color
1. Select the letter, word, or block of text that you want to highlight with color.
2. On the Formatting toolbar, click the arrow for Highlight Color , and
then select the color you want.
Shade text with color
1. Select the text that you want to shade with color.
2. On the Format menu, click Borders and Shading.
3. Click the Shading tab and do one or more of the following:
Set a background color for the selected text
Select a color in the Background color box.
Set the color of the selected text
Select a color in the Foreground color box.
Note The shading applies to the entire line on which the selected text
appears. However, you can resize the colored background by clicking
on the background and then dragging the sizing handles.
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Add a border
1. In Page view, at the bottom of the document window, click Design .
2. Select the text that you want to add a border to.
3. Do one of the following:
Add a four-sided border
1.
2.
3.
4.
5.
6.

On the Format menu, click Borders and Shading.
On the Borders tab, under Setting, click the Box icon.
In the Style box, click a border style.
In the Color box, click a color.
In the Width box, enter a value in points.
To specify the distance between the text and its border, under
Padding, enter a value in points in the Top, Bottom, Left, and Right
boxes.
Add a custom border

1.
2.
3.
4.
5.
6.

On the Format menu, click Borders and Shading.
On the Borders tab, under Setting, click Custom.
In the Style box, click a border style.
In the Color box, click a color.
In the Width box, enter a value in points.
To apply the border to one or more sides, under Preview, click the
buttons that correspond to each side that you want to add a border.
7. To specify the distance between the text and its border, under
Padding, enter a value in points in the Top, Bottom, Left, and Right
boxes.

Set line or paragraph spacing
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Select one or more paragraphs.
On the Format menu, click Paragraph.
Under Spacing, set the properties that you want.

Note Some Web browsers will not display all of these line and paragraph
settings.
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Set paragraph or line indentation
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Select one or more paragraphs.
On the Format menu, click Paragraph.
Under Indentation, do one or more of the following:
To indent before the paragraph, in the Before text box, enter a value in
pixels.
To indent after the paragraph, in the After text box, enter a value in
pixels.
To indent the first line of text in the paragraph, in the Indent first line
box, enter a value in pixels.

Set paragraph alignment
1. In Page view, at the bottom of the document window, click Design .
2. Select the paragraph(s) you want to align.
3. On the Formatting toolbar, click one of the following:
Align Left
Center
Align Right
Justify
If the Formatting toolbar is hidden, on the View menu, point to Toolbars,
and then click Formatting.
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Add a line break within a paragraph
You can add a new line of text in a paragraph by adding a line break.
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Place the insertion point where you want to insert a line break.
On the Insert menu, click Break.
Click Normal line break.
Tip

To view line break and paragraph marks, click Show All

.

Insert a symbol
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point where you want to insert a symbol or special
character.
3. On the Insert menu, click Symbol.
4. Click the symbol or special character you want to insert, and then click
Insert.
5. Click Close.

About finding and replacing text and
code
You can quickly find and replace text or code in a single page or all pages of a
Web site. You can do so by using a variety of search criteria. For example, you
can specify which pages and what direction you want to search, as well as how
you want to search for text or code in those pages. If you frequently perform the
same search, you can save it as a query. The next time you want to perform that
search, you can open the query, instead of entering the search criteria again.
In addition to searching for instances of specific text or code, you can search for
a pattern of text or code by using regular expressions or HTML rules.

Regular Expressions
A regular expression is a pattern of text that describes one or more variations of
text or code that you want to find. A regular expression consists of specific
characters— for example, the letters "a" through "z"— and special characters
that describe the pattern of text— for example, an asterisk (*). For example, to
find all variations of "page" in your Web site, you can search for "page*." If you
do so, Microsoft FrontPage finds all instances of "page," "pages," "pager," and
any other words that begin with "page" in your Web site.

HTML Rules
You can use HTML rules in your searches and have advanced HTML tag and
attribute find and replace options. By using HTML rules in your search, you can
determine where and under what conditions to search your code. For example,
you can create an HTML rule to search text only inside a tag. Text outside of the
tag would be excluded from search results.
Microsoft FrontPage provides the following HTML rules:
With Attribute Finds the text or tag only if it is in a tag with an attribute. For
example, you can search for all instances of "Arial" and limit your search to only
those tags that include a specific attribute
Without Attribute Finds the text or tag only if it is in a tag without an
attribute. For example, you can search for all instances of "p" and limit your
search to only those tags that do not include a specific attribute.
Containing Finds the text or tag only if it is in another tag or text that you
specify. For example, you can search for all instances of the font <font> tag that
are nested in a bold <b> tag.
Not Containing Finds the text or tag only if it is not in another tag or text that
you specify. For example, you can search for all instances of the table <table>
tag that are not nested in another tag.
Inside Tag Finds the text or tag only if it is in a tag that you specify. For
example, you can search for all instances of the word "font" and all instances of
the font <font> tag will be in your search results.
Not Inside Tag Finds the text or tag only if it is not in a tag that you specify.
For example, you can search for all instances of the word "font" and instances of
the font <font> tag will not be in your search results.
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Find and replace text
Do one of the following:
Find text in a Web page
1. In Page view, do one of the following:
To find text within a Web page, at the bottom of the document
window, click Design .
To find text in the HTML code, at the bottom of the document
window, click Code .
2. Place the insertion point at the top of the page.
3. On the Edit menu, click Find.
4. On the Find tab, in the Find what box, type the text you want to search for.
To use regular expressions within your search, type them directly into the
Find what box. To select regular expressions from a list, click the arrow
next to the Find what box.
5. If you are searching in the current page, under Direction, select the
direction in which to search.
6. Under Advanced, do one or more of the following:
To find text only if it matches the case of the text you typed, select the
Match case check box.
To find text only if it matches a whole word, select the Find whole
word only check box.
To ignore the spaces and tabs between words and treat them each as a
single white space, click Ignore whitespace differences.
This feature is unavailable if the Regular expressions check box is
selected.
To find text in the HTML code, select the Find in source code check
box.
For example, you can search for text that is not visible or editable in
the page, such as the page title you set in page properties.

This feature is unavailable if you are searching in the current page.
7. Click Find Next.
Find text in a Web site
1. On the View menu, click Folders.
2. If you do not want to search all pages in the Web site, select the pages you
want to search.
How?
To select multiple, non-sequential pages, click the name of the first page
you want to select, and then hold down CTRL while clicking the names of
all the other pages you want to select.
3. On the Edit menu, click Find.
4. On the Find tab, in the Find what box, type the text you want to search for.
To use regular expressions within your search, type them directly into the
Find what box. To select regular expressions from a list, click the arrow
next to the Find what box.
5. Under Advanced, do one or more of the following:
To find text only if it matches the capitalization of the text you typed,
select the Match case check box.
To find text only if it matches a whole word, select the Find whole
word only check box.
To ignore the spaces and tabs between words and treat them each as a
single white space, click Ignore whitespace differences.
This feature is unavailable if you have selected the Regular
expressions check box.
To find text in the HTML code, select the Find in source code check
box.
For example, you can search for text that is not visible or editable in
the page, such as the page title you set in page properties.

6. Click Find in Site.
7. When Microsoft FrontPage lists the pages that contain the text you searched
for, double-click a page in the list.
The first instance of the text is highlighted.
8. Click Find Next to find the next occurrence.
9. Click Back to list to return to the list of pages.
Find and replace text in a Web page
1. In Page view, do one of the following:
To find text in your Web page, at the bottom of the document window,
click Design .
To find text in in your HTML code, at the bottom of the document
window, click Code .
2. Place the insertion point at the top of the page.
3. On the Edit menu, click Replace.
4. On the Replace tab, in the Find what box, type the text you want to search
for.
To use regular expressions within your search, type them directly into the
Find what box. To select regular expressions from a list, click the arrow
next to the Find what box.
5. In the Replace with box, type the replacement text.
6. If you are searching in the current page, under Direction, select the
direction that you want to search.
7. Under Advanced, do one or more of the following:
To find text only if it matches the capitalization of the text you typed,
select the Match case check box.
To find text only if it matches a whole word, select the Find whole
word only check box.
To ignore the spaces and tabs between words and treat them each as a
single white space, click Ignore whitespace differences.
This feature is unavailable if the Regular expressions check box is
selected.

To find text in the HTML code, select the Find in source code check
box.
For example, you can search for text that is not visible or editable in
the page, such as the page title you set in page properties.
8. Do one of the following:
To replace each occurence manually, click Find Next, and then click
Replace.
To replace all occurrences of the text in the page at one time, click
Replace All.
Find and replace text in a Web site
1. On the View menu, click Folders.
2. If you do not want to search every page in the Web site, select the pages
you want to search.
How?
To select multiple, non-sequential pages, click the name of the first
page you want to select, and then hold down CTRL while clicking the
file names of the other pages you want.
3. On the Edit menu, click Replace.
4. On the Replace tab, in the Find what box, type the text you want to search
for.
To use regular expressions within your search, type them directly into the
Find what box. To select regular expressions from a list, click the arrow
next to the Find what box.
5. In the Replace with box, type the replacement text.
6. Under Advanced, do one or more of the following:
To find text only if it matches the capitalization of the text you typed,
select the Match case check box.
To find text only if it matches a whole word, select the Find whole

word only check box.
To ignore the spaces and tabs between words and treat them each as a
single white space, click Ignore whitespace differences.
This feature is unavailable if the Regular expressions check box is
selected.
To find text in the HTML code, select the Find in source code check
box.
For example, you can search for text that is not visible or editable in
the page, such as the page title you set in page properties.
This feature is unavailable if you are searching in the current page.
7. Click Find in Site.
8. When Microsoft FrontPage lists the pages that contain the text you searched
for, double-click a page in the list.
The first instance of the text is highlighted.
9. Do one of the following:
To replace each occurence manually, click Find Next, and then click
Replace.
To replace all occurrences of the text in the page at one time, click
Replace All.
10. Click Back to list to return to the list of pages.
Tip
You can create new, or open previously created queries, using the Query options
found on all the tabs in the Find and Replace dialog box.

Find and replace HTML tags
1.
2.
3.
4.
5.

Place the insertion point at the top of the page.
On the Edit menu, click Find.
Select the HTML Tags tab.
In the Find tag box, type or select the tag you want to find.
In the Replace action list, click the action you want. If additional options
appear, type or select options that further define how you want to replace
the tags.
6. Under Search options, click the options that you want.
7. To find the next occurence of the tag, click Find Next.
8. Do one of the following:
To replace that occurence, click Replace.
To replace all occurences of the tag, click Replace All.

Regular expressions
You can perform sophisticated find and replace operations in Microsoft
FrontPage by using regular expressions. A regular expression is a pattern of
ordinary and special characters that describe one or more strings to find when
searching text or code. Regular expressions are useful when you do not know the
exact text or code you are looking for, or when you are looking for all
occurrences of strings of text or code with one or more similarities.
To use regular expressions, open the Find and Replace dialog box in FrontPage,
select the Regular expressions check box search option, and type a regular
expression pattern in the Find what box. You can access some of the more
common syntax characters using the Regular expressions arrow.
When you use regular expressions in your searches, there are specific rules that
control which combination of characters perform specific matches. Each regular
expression, or combination of regular expressions is referred to as syntax. You
can use multiple regular expressions in one syntax to precisely target your
search.
The regular expressions in FrontPage and the associated syntax are described in
the table that follows.
Expression

Any character

Syntax Description
Acts as a wild card to match any single printing or nonprinting character with the exception of the newline
(\n)character.
.

For example, the regular expression c.t matches the
strings cat, c t, cot, but not cost. In this example, the
period (.) is a wild card for a single character. It
appears between the letters 'c' and 't', so any single
character between the characters 'c' and 't' will match
the expression— even if it is a space.
Matches zero or more occurrences of a character that
precede the expression, matching as many characters

as possible.
The regular expression .* matches zero or more
occurrences of one character.
Maximal— zero
*
or more

For example, the regular expression b.*k matches
book, back, black, blank, and buck. In this example, we
combine the period (.) with the asterisk (*) to make one
syntax. The period (.) appears immediately before the
asterisk (*) expression. The asterisk (*) matches zero
or more occurrences of any character between 'b and
'k'. The period (.) acts as a wild card for the characters
between 'b' and 'k'. In this example, it means that any
character between 'b' and 'k' can be repeated.
Matches one or more occurrences of a character that
precede the expression, matching as many characters
as possible.
The regular expression .+ matches one or more
occurrence of one character.

Maximal— one
+
or more

For example, the regular expression bo+. matches bob,
book, and boot. In this example, we combine the
period (.) with the plus sign (+) to make one syntax.
The period (.) appears immediately after the plus sign
(+) expression. The plus sign (+) matches one or more
occurrences of the letter 'o'. The period (.) acts as a
wild card for the last character of each word, which, in
this example are 'b', 'k', and 't'.
Matches zero or more occurrences of a character that
precede the expression, matching as few characters as
possible.
The regular expression .@ means match zero or more
occurrences of one character.
For example, the regular expression a.@x matches 'abx'

Minimal— zero

or more

@

within 'abxbxb' and 'acx' within 'acxcxc'. In this
example, we combine the period (.) with the at sign
(@) to make one syntax. The period (.) appears
immediately before the at sign (@) expression. The at
sign (@) matches zero or more occurrences of any
character between 'a and 'x'. In this example, the period
(.) acts as a wild card for the characters 'b' and 'c'
between the characters 'a' and 'x'.
Matches one or more occurrences of a character that
precede the expression, matching as few characters as
possible.

Minimal— one
#
or more

For example, the regular expression si.#er matches
'sicker' or 'silkier'. In this example, we combine the
period (.) with the sharp sign (#) to make one syntax.
The period (.) appears immediately before the sharp
sign (#) expression. The sharp sign (#) matches one or
more occurrences of any character between 'si' and 'er'.
The period (.) acts as a wild card for the characters 'c'
and 'k' in the word sicker, and 'l', 'k', and 'i' in the word
silkier.
Matches any one of the characters within the brackets
([ ]). You can specify ranges of characters by using a
hyphen (-), as in [a-z].
Examples:

Set of
characters

[]

The regular expression c[aou]t matches cat, cot,
and cut, but not cet or cit.
The regular expression [0-9] means match any
digit.
You can specify multiple ranges of letters as well.
The regular expression [A-Za-z] means match all
upper and lower case letters.
Anchors the match to the beginning of a line.

Beginning of
line

^

For example, the regular expression ^When in matches
the any string that begins with "When in" and that also
appears at the beginning of a line, such as "When in the
course of human events" or "When in town, call me".
Whereas, this regular expression does not match "What
and when in the course of human events" if it appears
at the beginning of a line.
Anchors the match to the end of a line.

End of line

$

For example, the regular expression professional$
matches the end of the string "He is a professional" but
not the string "They are a group of professionals".
Anchors the match to the beginning of a file. Works
only when searching for text in source code or in text
files.

Beginning of
file

^^

For example, to match the first HTML tag at the
beginning of a file, use the following regular
expression: ^^<html>
Anchors the match to the end of a file. Works only
when searching for text in source code or in text files.

End of file

$$

For example, to match the last HTML tag at the end of
a file (with no spaces following the tag), use the
following regular expression: </html>$$
Indicates a choice between two items, thereby
matching the expression before or after the OR symbol
(|).

Or

|

For example, the regular expression(him|her)
matches the following occurrences:
"it belongs to him"
"it belongs to her"

but it does not match the line "it belongs to them."
Matches the character following the back slash ( \ ).
This allows you to find characters that are used in the
regular expression syntax, such as a left curly brace ({)
or a caret (^) or some other special character.
Escape special
\
character

For example, you can use \$ to match the dollar sign
character ($) rather than implementing the regular
expression to 'anchor to end of a line'. Similarly, you
can use the expression \. to match the period (.)
character rather than match any single character, which
is what the period (.) regular expression does.
Tags the text matched by the enclosed expression. You
can match another occurrence of the tagged text in a
Find expression or insert the tagged text in a Replace
expression using \N.
For example, suppose you are looking to find two
duplicate, consecutive words. To search, use the
following expression: {.#} \1

Tagged
expression

{}

With the assumption that the consecutive words are
separated by a single space, you'll want to add a space
between the right curly brace (}) and the back slash ( \
).
In this example, we combine the sharp sign (#) and the
period (.) with the curly braces ({}) to make one
syntax. In this expression, .# represents any
consecutive characters. Since this portion of the
expression is surrounded by curly braces ({}), the
consecutive characters will be tagged and can be
referred to as \1. This expression will find any
consecutive characters followed by a space, followed
by those exact same consecutive characters.
In a Find expression, \N matches the text matched by

the Nth tagged expression, where N is a number from 1
to 9.
In a Replace expression, \N inserts the text matched by
the Nth tagged expression where N is a number from 1
to 9. \0 inserts the text matched by the entire Find
expression.
For example, suppose you want to find two duplicate,
consecutive words and replace them with a single
word. To search, use the following expression: {.#} \l
Nth tagged
expression

\N

With the assumption that the consecutive words are
separated by a single space, you'll want to add a space
between the right curly brace (}) and the back slash ( \
). In this example, we combined the sharp sign (#) and
the period (.) with the curly braces ({}) to make one
syntax.
To replace, use the following expression: \l
\1 represents what was found in the first pair of curly
braces in the find string. By using \1 in the replace
action, you essentially replace the duplicate,
consecutive words with a single copy of the word.
Marks the beginning and end of a subexpression.

Group
expression

()

A subexpression is a regular expression that you
enclose in parenthesis ( ), such as the expression that
follows: (ha)+ In this example, we combine the plus
sign (+) with the parenthesis ( ) group expression to
make one syntax. The subexpression is (ha) because it
is encapsulated within the parenthesis ( ). When you
add the plus sign (+), the expression enables you to
find repeating pairs of letters. The plus sign (+)
represents one or more occurrences of 'ha'.
This expression matches the following occurrences

'haha' and 'hahaha'.
Prevents a match when x appears at this point in the
expression.
Prevent match

~x

For example, the regular expression real~(ity)
matches the "real" in "realty" and "really", but prevents
the match to "real" in "reality".
Matches a new line in Code view, or a <br> in Design
view.

Line break

\n

The syntax (\n), is a shorthand approach to enable you
to match all line breaks.
Matches a single tab character.
For example, if you want to find all single tabbed
characters at the beginning of a line, the regular
expression would look like the following:
^\t+

Tab

\t

In this example, we combine the caret (^) and the plus
sign (+) with the tab (\t) to make one syntax. The caret
(^) that precedes the single tab character expression,
anchors the match to all tabbed characters at the
beginning of the line. The plus sign (+) represents the
matching of one or more tab characters.
Matches any character that is not in the set of
characters that follows the caret (^).

Any one
character not in [^]
the set

For example, to match any character except those in
the range, use the caret (^) as the first character after
the opening bracket. The expression [^269A-Z] will
match any characters except 2, 6, 9, and any upper case
alphabetical characters.

Matches n occurrences of the expression that precedes
the caret (^).
Repeat
expression

^n

For example, with n equaling 4, the expression [09]^4 matches any 4-digit sequence. In this example,
we combine the set of characters ([ ]) syntax with the
repeat (^n) syntax to demonstrate a more realistic use
of regular expressions.
Matches the expression [a-zA-Z0-9].

Alphanumeric
character

:a

You can use the following expression: [a-zA-Z0-9] to
match one occurrence of a letter (upper case or lower
case) or number. Also known as alphanumeric
occurrences. You can use the shorthand expression :a
for all instances of [a-zA-Z0-9].
Matches any white spaces in code or text.

White space

Alphabetic
character

:b

For example, to match a single white space character at
the beginning of a line, use the following regular
expression:^:b
Matches the expression [a-zA-Z]When you use this
expression, it enables you to match all upper or lower
case letters.

:c
You can use the shorthand expression :c for all
instances of [a-zA-Z].
Matches the expression[0-9]This expression enables
you to match any digit.

Decimal digit

:d

For example, suppose you want to find a social
security number in a text file. The format for U.S.
social security numbers is 999-99-9999. :d^3-:d^2:d^4 or, by using [0-9], the same resulting expression:
[0-9]^3-[0-9]^2-[0-9]^4]

You can use the shorthand expression :d for all
instances of [0-9].
Matches the expression [0-9a-fA-F]+
Use a this expression when you want to match a
hexadecimal combination of any upper or lower case
letters between 'A' and 'F', and any numbers.

Hexadecimal
digit

:h

For example, suppose the pages in your Web site have
multiple different background colors and you want to
change the color of those pages to black, such as
000000. However, you do not know what the
hexadecimal numbers are for the existing colors. Use
the following regular expression to find all existing
hexadecimal numbers:
\#:h

You could use [0-9a-fA-F] to search, but in this
example we combine the back slash (\) and the sharp
sign (#) with the hexadecimal digit (:h) syntax. \#
matches a non-expression sharp sign (#) and :h
matches any sequence of hexadecimal characters.
To replace the existing hexadecimal numbers, type the
hexadecimal number of the background color that you
want: 000000
Matches the expression [a-zA-Z_$][a-zA-Z0-9_$]*
Identifier

:i

When working with code, if you want to match all
program identifiers, you can use the shorthand
expression :i to replace having to type the lengthy
expression above.
Matches the expression ([0-9]+\.[0-9]*)|([0-9]*\.
[0-9]+)|([0-9]+)

Rational

:n

If you want to match all whole numbers that contain a

number

decimal point, you can use the shorthand expression :n
to replace having to type the lengthy expression above.
Matches the expression ("[~"]*")|('[~']*')

Quoted string

:q

If you want to match all quotes surrounded by
quotation marks, you can use the shorthand expression
:q to replace having to type the lengthy expression
above.
Matches the expression [a-zA-Z]+

Alphabetic
string

:w

This syntax is a shorthand approach to enable you to
match one or more alphabetical characters, either lower
case or upper case.
Matches the expression [0-9]+

Decimal integer :z

This syntax is a shorthand approach to enable you
match any number from zero or more.
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Check spelling in a page or Web site
Do one or more of the following:
Check spelling on a page
1. In Page view, on the Standard toolbar, click Spelling

.

When Microsoft FrontPage finds an unrecognized word or a spelling error,
in the Spelling dialog box, the word is displayed in the Not in Dictionary
box.
2. Do one of the following:
To replace the word with a word from the Suggestions list, click the
suggested word, and then click Change.
To replace all instances of the word, click the suggested word, and
then click Change All.
To correct the word yourself, type the correct word in the Change To
box, and then click Change.
To correct all instances of the word, type the correct word in the
Change To box, and then click Change All.
If the unrecognized word is correctly spelled, click Ignore to ignore
this instance of the word.
To ignore all instances of this word, click Ignore All.
To add the unrecognized word to your custom dictionary, click Add.
Check spelling in a Web site
1. On the View menu, click Folders.
2. Do one of the following:

Run the spelling checker in an entire Web site
1.
2.
3.
4.

Click the top level site.
On the Standard toolbar, click Spelling .
Under Check spelling of, click Entire Web site.
To create a task list and add a task for each page with misspelled
words, select the Add a task for each page with misspellings check
box.
5. Click Start.
Run the spelling checker on selected pages within a Web site
1. Click the name of the first page, and then hold down CTRL while
clicking the names of all the other pages you want to check the
spelling on.
2. On the Standard toolbar, click Spelling .
3. Under Check spelling of, click Selected page(s).
4. To create a task list and add a task for each page with misspelled
words, select the Add a task for each page with misspellings check
box.
5. Click Start.
3. Do one of the following to correct the spelling of these words:
Correct misspelled words in each page
1. In the Spelling dialog box, double-click a page from the list of pages
that include the unrecognized or misspelled words in the Web site.
Microsoft FrontPage opens each page in Page view and prompts you
to address the unrecognized or misspelled words.
2. When you have reviewed all occurrences of the misspelled words in
each page, FrontPage prompts you to close the active page and then
move to the next page in the list.
Correct misspelled words by using a task list

If you selected the Add a task for each page with misspellings check box,
this generates a task list of pages with misspelled words. To access the task
list and begin correcting the misspelled words, do the following:
1. On the View menu, click Tasks.
2. In Tasks view, double-click the task labeled Fix misspelled words,
and then click Start Task.
3. Microsoft FrontPage opens the page in Page view and prompts you to
correct the misspelled words.
Check spelling automatically as you type
1. On the Tools menu, click Page Options.
2. On the General tab, select the Check spelling as you type check box.
3. To show or hide the wavy red lines beneath misspelled words, select or
clear the Hide spelling errors in all documents check box.

Look up words in the thesaurus
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Select or type a word that you want to look up in the thesaurus.
On the Tools menu, click Thesaurus.
Click the options you want.
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Troubleshoot spelling
I don't want the red wavy lines underneath certain words in my text.
Red wavy lines indicate that the automatic function to check spelling has been
turned on, and that Microsoft FrontPage is indicating spelling errors. If you want
to turn this function off, do the following:
1. On the Tools menu, click Page Options, and then click the General tab.
2. Do one of the following:
Check spelling automatically but don't show the red wavy lines
1. Select the Check spelling as you type check box.
2. Select the Hide spelling errors in all documents check box.
Completely turn off the automatic spelling checker
Clear the Check spelling as you type check box.
Note You can check spelling at any time by clicking Spelling
Standard toolbar.

on the

The spelling checker questions text that is correct.
When you use the spelling checker, it compares the words in your document
with those in its main dictionary. The main dictionary contains most common
words, but it might not include proper names, technical terms, acronyms, and so
on. To prevent the spelling checker from questioning such words in future
spelling checks, add these words to the personal dictionary by doing the
following:
1. On the Standard toolbar, click Spelling .
2. When the spelling checker questions a word, click Add.

The spelling checker didn't change every occurrence of a misspelled word.
If you check spelling all at once, you can click the Change All button in the
Spelling dialog box to change every occurrence of a misspelled word. If you
close the dialog box before checking the entire document, the spelling checker
will not correct errors in the unchecked portion.
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About lists
You can quickly add bullets or numbers to existing lines of text, or you can
automatically create bulleted and numbered lists as you type. If you're creating
bulleted lists for Web pages, you can use any graphical image or picture as a
bullet.
Bulleted list
You can create a bulleted list for presenting a list of unordered items — that is,
items that don't need to be numbered:
pineapples
watermelons
papayas
Custom bulleted list
You can use graphics as bullets, rather than using the standard default bullets
such as circles or squares.

Numbered list
To display a sequential list of items, create a numbered list. You can choose from
letters, numbers, or Roman numerals:
1. Do this first
2. Do this second
3. Do this third

Definition list
When you want to present a list of terms and definitions, add a definition list to
your page. Terms are usually displayed flush left, with indented definitions. The
exact formatting of the list depends on the Web browser that site visitors use.
Term A
This is the definition for Term A.
Term B
This is the definition for Term B.
Outline or multi-level list
You can create lists that have multiple nested levels and paragraphs, and you can
specify different list styles for each level. For example, an outline:
1. Chapter
1. Heading
1. Subheading
1. Topic
Paragraph
2. Topic
1. Detail
2. Detail
2. Heading
The list in the preceding example uses different numbering styles at each level.
If a heading has only one item below it, you can list the item without numbers.
Collapsible list
You can create a collapsible list from a multi-level bulleted or numbered list, or
from an outline. For example, a multi-level outline:

A collapsible list lets site visitors show or hide different levels of a list by
double-clicking a list item.
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Create a bulleted or numbered list
If you are using a theme, the Plain Bullets tab is unavailable.
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Place the insertion point where you want to create a list.
On the Format menu, click Bullets and Numbering.
Do one of the following:
Create a bulleted list

1. Click the Plain Bullets tab, click the box with the bullets you want to use,
and then click OK.
2. Type text next to the bullet, and then press ENTER.
3. To end the list, press ENTER again.
Create a bulleted list using pictures
1. Click the Picture Bullets tab, and then click Specify picture.
2. Locate and click the graphic file that you want to use as a bullet, click
Open, and then click OK.
3. Type text next to the bullet, and then press ENTER.
4. To end the list, press ENTER again.
Note When you save the Web page, if the graphic file you used for the custom
bullet is not in the current Web site, Microsoft FrontPage will prompt you to
save it to the current Web site in GIF or JPEG format.
Create a numbered list
1. Click the Numbers tab, click the style of numbers or letters you want to
use, and then click OK.
2. Type text next to the bullet, and then press ENTER.
3. To end the list, press ENTER again.

Show All

Add bullets or numbers to existing
text
If you are using a theme, the Plain Bullets tab is unavailable.
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Click the text that you want to add bullets to.
On the Format menu, click Bullets and Numbering.
Do one of the following:
Add plain bullets to text
Click the Plain Bullets tab, and then click the box with the bullets you want
to use.
Add picture bullets to text

1. Click the Picture Bullets tab, and then click Specify picture.
2. Locate and select the graphic file that you want to use as a bullet, and then
click Open.
Note When you save the Web page, if the graphic file you used for the custom
bullet is not in the current Web site, Microsoft FrontPage will prompt you to
save it to the current Web site in GIF or JPEG format.
Add numbers to text
Click the Numbers tab, and then click the style of numbers or letters you
want to use.
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Match the size of list bullets and
numbers to text
1. In Page view, at the bottom of the document window, click Design .
2. Select the text that you want to change the size of bullets or numbers for.
3. Check the size of the text in your list.
How?

4.
5.
6.
7.

1. On the Format menu, click Font.
2. In the Size box, the size of your text will be highlighted.
3. Click Cancel.
Right-click anywhere in the list, and then click List Properties on the
shortcut menu.
Click Style.
Click Format, and then click Font.
In the Font dialog box, under Size, select the new text size.

Create a definition list
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Place the insertion point where you want to create a list of definitions.
In the Style box
, click the arrow and then click Defined Term.
Type the first term in the list, and then press ENTER.
The next line is automatically formatted with the Definition style.

5. Type the term definition.
6. Press ENTER to continue to the next term.
The next line is automatically formatted with the Defined Term style.
7. Repeat steps 4 through 6 for each term and definition.
8. To end the list, press ENTER twice.

Create an outline or multi-level list
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point where you want to create an outline or multi-level
list.
3. On the Format menu, click Bullets and Numbering, and then click the
Numbers tab.
4. Click the box with the style of numbers or letters that you want to start
with, and then click OK.
5. For each item or line of text that you want in the outline or multi-level list,
regardless of its level, type the text, and then press ENTER.
6. When you have typed the last item, press ENTER twice to end the list.
7. To place each item on the correct level, do one of the following:
To move items down to the next consecutive level, select the items,
and then click Increase Indent
twice.
To format items as a paragraph on the current level (without bullets or
numbering), select the items, and then click Increase Indent
once.
To move items up to previous level(s), select the items, and then click
Decrease Indent
one or more times, as needed.
8. To apply numbering or lettering styles to the different levels, select an item
on a level or sublevel, right-click, and then click List Properties on the
shortcut menu.
9. On the Numbers tab, click the box with the style you want to use.
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Create a collapsible list
1. In Page view, at the bottom of the document window, click Design .
2. Create an outline or multi-level list.
3. To collapse low-level list items within a top-level list item, right-click on
the top-level list item, and then click List Properties on the shortcut menu.
4. Select the Enable Collapsible Outlines check box.
5. To display the list in a collapsed state when a site visitor first opens your
Web page in a Web browser, select the Initially Collapsed check box.
Notes
To ensure that the list you created collapses, click Preview , and then
click the top-level list item.
If your list contains many list items on the same level, each list item
— including the additional levels below it— will be collapsible if you
perform the steps in the preceding procedure. In addition, all levels below
the original one will be collapsible.
Collapsible lists are supported by Microsoft Internet Explorer 4.0 or later
and by other Web browsers that support Dynamic HTML.

Remove numbers or bullets from a
list
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Select the items in the list.
On the Format menu, click Bullets and Numbering.
Do one of the following:
If the list uses bullets, on the Plain Bullets tab, click the box with no
bullets.
If the list uses numbers or letters, on the Numbers tab, click the box
with no numbering.
If the list uses picture bullets, on the Picture Bullets tab, in the
Specify pictures box, clear the file name.
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About tables
A table is made up of rows and columns of cells into which you can insert text
and graphics.
You can customize your tables in a variety of ways to make them more attractive
and easy to read.
Work with rows and columns
You can create more cells in your table by splitting one cell into two or more
cells. You can also merge adjacent cells into one cell.
Once you have all the rows and columns you need in your table, you can set the
row heights and column widths the way you want them.
You can define the row heights and column widths to be a percentage of the
overall table size, a specific size in pixels, or set all rows and columns to be
spaced uniformly.
Copy and paste content
You can copy content from one cell to cells in adjacent rows or columns in your
table without having to cut and paste each time. For example, to copy the
contents of a cell in the first row of a table, you can select that cell and drag
across all the adjacent cells in the same row and then click a Fill command.
Control text and table layout
You can control how your table appears on the page by setting the table
alignment — tables can be aligned to the left, right, or center of the page. The
following table is centered on the Web page.

You can also control the height and width of the table by entering pixel and
percentage values. For example, you can set the width of the table to 80 percent
of the overall page width (or frame width, if the table is in a frame). If a site
visitor resizes the browser window, the page size and table change accordingly.
On pages that include a table and text, you can also specify whether you want
text to flow around the sides of the table.
By specifying the way text appears inside each cell, you can control how much
space there is between the border and text of a cell, and you can set the
horizontal and vertical alignment of text. In addition, table text can be formatted
like any other text — you can change the font style, size, color, and other
attributes.
Set border specifications
You can customize the way borders appear in your tables. For example, you
could change the thickness of the outer border of a table, set the border color for
the whole table, or set a different border color for individual cells. You can
choose one color for the border or, if you prefer a three-dimensional look, you
can choose two colors — a light color and a dark color.

Choose backgrounds
You can choose background colors and pictures for your tables. Background

colors can be used to shade specific columns or rows to add emphasis. You can
use background pictures to add visual appeal to your tables.
You can set background colors and pictures for certain cells, or you can set them
for the whole table.

Create captions and headers
You can add a caption above a table as a title, or below a table to summarize its
content for site visitors. You can also format the caption text.
To emphasize certain cells in your table, you can specify them as table headers.
For example, in the table below, the first row and first column contain labels.
They are formatted as table headers so that they stand out from the rest of the
table. By default, a table header is formatted as bold text. However, you can
modify the table header style and define additional properties for your table
headers, such as shading.

Note You can also create visually-structured Web pages by adding a layout table
from a list of predesigned layouts in the Layout Tables and Cells task pane, or
you can draw a layout to meet your customized needs.

Add a table
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Place the insertion point where you want to insert the table.
On the Table menu, point to Insert, and then click Table.
Set the properties that you want.

Note To make the properties that you specified the default for all new tables,
under Set, click the Set as default for new tables check box.
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Add a cell, row, or column to a table
1. In Page view, at the bottom of the document window, click Design .
2. Do one or more of the following:
Add a cell
1. Place the insertion point in the cell next to where you want to add a
cell.
2. On the Table menu, point to Insert, and then click Cell.
Add a row
1. Place the insertion point in the row above or below the row that you
want to add.
2. On the Table menu, point to Insert, and then click Rows or Columns.
3. Click Rows, and then type or select the number of rows you want to
add.
4. Under Location, specify if you want to place the row above or below
the selected row.
Add a column
1. Place the insertion point in the column next to where you want to add a
column.
2. On the Table menu, point to Insert, and then click Rows or Columns.
3. Click Columns, and then type or select the number of columns you
want to add.
4. Under Location, specify if you want to place the column to the right
or left of the selected column.

Set the properties of a cell
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point in the cell, right-click, and then click Cell
Properties on the shortcut menu.
3. Set the properties that you want.
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Add a caption to a table
1. In Page view, at the bottom of the document window, click Design .
2. Do one or more of the following:
Add a caption above a table
1. Place the insertion point anywhere in the table.
2. On the Table menu, point to Insert, and then click Caption.
3. Type the caption text.
Note By default, the caption appears at the top of the table.
Add a caption below a table
1. Place the insertion point anywhere in the table.
2. On the Table menu, point to Insert, and then click Caption.
3. Type the caption text.
Note By default, the caption appears at the top of the table.
4. Right-click on the caption, and then click Caption Properties on the
shortcut menu.
5. Click Bottom of table, and then click OK.
Align a table caption
Select the caption, and then, on the Formatting toolbar, click one of the
following:
Align Right
Align Left
Center
Justify

Delete a caption from a table
1. In Page view, at the bottom of the document window, click Design .
2. Select the caption and then press DELETE.
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Select a table, cell, row, or column
1. In Page view, at the bottom of the document window, click Design .
2. Do one or more of the following:
Select a table
1. Click anywhere on the table.
2. On the Table menu, point to Select, and click Table.
Select a cell
1. Place the insertion point in a cell.
2. On the Table menu, point to Select, and click Cell.
Tip
To select multiple cells, select the first cell as described in the procedure
above, press CTRL, and click each additional cell you want to select.
Select a row
1. Place the insertion point in a cell that's in the row you want to select.
2. On the Table menu, point to Select, and click Row.
Select a column
1. Place the insertion point in a cell that's in the column you want to select.
2. On the Table menu, point to Select, and click Column.

Show All

Resize a table, cell, row, or column
1. In Page view, at the bottom of the document window, click Design .
2. Do one of the following:
Resize a table
1. Right-click the table, and then click Table Properties on the shortcut menu.
2. To specify width, select the Specify width check box, select In pixels or In
percent, and type a value for the width of the table.
3. To specify height, select the Specify height check box, select In pixels or
In percent, and type a value for the height of the table.
Notes
If a table is sized in pixels, its size remains constant, regardless of the size
of the page that it is displayed on.
If a table is sized as a percentage of the browser window, its size changes
depending on the size of the window.
If height or width is not specified, the table is sized according to its content.
Resize a cell
1. Place the insertion point in the cell.
2. Right-click, and then click Cell Properties on the shortcut menu.
3. To specify width, select the Specify width check box, select In pixels or In
percent, and type a value for the width of the selected cell.
4. To specify height, select the Specify height check box, select In pixels or
In percent, and type a value for the height of the selected cell.
Resize a row
1.
2.
3.
4.

Place the insertion point in a cell that is in the row that you want to resize.
On the Table menu, point to Select and click Row.
Right-click the row, and then click Cell Properties on the shortcut menu.
To specify width, select the Specify width check box, select In pixels or In

percent, and type a value for the width of the row.
5. To specify height, select the Specify height check box, select In pixels or
In percent, and type a value for the height of the row.
Resize a column
1. Place the insertion point in a cell that is in the column that you want to
resize.
2. On the Table menu, point to Select and click Column.
3. Right-click the column, and then click Cell Properties on the shortcut
menu.
4. To specify width, select the Specify width check box, select In pixels or In
percent, and type a value for the width of the column.
5. To specify height, select the Specify height check box, select In pixels or
In percent, and type a value for the height of the column.
Note If the content (text, images, etc.) of a table or one of its elements is greater
(bigger, longer, wider, etc.) than the specified value, the table or its elements will
grow to accommodate that content.

Set the layout properties of a table
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the table, and then click Table Properties on the shortcut menu.
3. Under Layout, set the layout properties that you want.
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Set the background properties of a
table
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the table, and then click Table Properties on the shortcut menu.
3. Under Background, do one of the following:
Set the background color
In the Color list, select a color for the table background.
Set the background picture
1. Select the Use background picture check box.
2. Locate and click the file that you want, and then click Open.
Note A background picture in a table displays as a repeated tile unless you use a
cascading style sheet to change the display.
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Equalize the height and width of rows
and columns
If you have a table of varying row heights and column widths, you can equalize
the width or height of selected rows or columns.
1. In Page view, at the bottom of the document window, click Design .
2. Do one or both of the following:
Make rows the same height
1. Place the insertion point in a column where the rows are uneven.
2. On the Table menu, point to Select, and then click Column.
3. On the Tables toolbar, click Distribute Rows Evenly

.

If the Tables toolbar is hidden, on the View menu, point to Toolbars, and
then click Tables.
Make columns the same width
1. Place the insertion point in a row where the columns are uneven.
2. On the Table menu, point to Select, and then click Row.
3. On the Tables toolbar, click Distribute Columns Evenly

.

If the Tables toolbar is hidden, on the View menu, point to Toolbars, and
then click Tables.
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Copy content to cells in adjacent rows
or columns
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point in the cell with the content you want to copy.
3. Do one or both of the following:
Copy content from one cell to an adjacent row of cells
1. Select that cell, and then drag the cursor to the right across the adjacent
cells in the row.
2. On the Table menu, point to Fill, and then click Right.
Copy content from one cell to adjacent cells within a column
1. Select that cell, and then drag the cursor down over the adjacent cells within
the same column.
2. On the Table menu, point to Fill, and then click Down.

Set table headers
To emphasize certain cells in your table, such as the first row or column, you can
format the cells as table headers. By default, table headers appear in bold.
1. In Page view, at the bottom of the document window, click Design .
2. Select the cell, row, or column that you want to set as the table header.
3. Right-click the selection, and then click Cell Properties on the shortcut
menu.
4. Under Layout, select the Header cell check box.

Set the border properties of a table
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the table, and then click Table Properties on the shortcut menu.
3. Set the border properties that you want.

Insert a table in a cell
To insert a table in a cell that resides within an existing table, do the following:
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point in the cell where you want to insert a table.
3. On the Table menu, point to Insert, and then click Table.

Split a table
1. In Page view, at the bottom of the document window, click Design .
2. Click the row that you want to become the first row of the second table.
3. On the Table menu, click Split Table.
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Split or merge cells in a table
1. In Page view, at the bottom of the document window, click Design .
2. Do one or more of the following:
Split a cell into columns or rows
1. Right-click the cell that you want to split, and then click Split Cells on the
shortcut menu.
2. Click Split into columns or Split into rows.
3. In the Number of columns or Number of rows field, type the number of
columns or rows that you want to split the cell into.
Split cells into columns
1. Place the insertion point in a cell that's in the column you want to select.
2. On the Table menu, point to Select, and click Column.
3. Right-click the cells in the selected column, and then click Split Cells on
the shortcut menu.
4. Click Split into columns.
5. In the Number of columns field, type the number of columns that you want
to split the cell into.
Split cells into rows
1. Place the insertion point in a cell that's in the row you want to select.
2. On the Table menu, point to Select, and click Row.
3. Right-click the cells in the selected row, and then click Split Cells on the
shortcut menu.
4. Click Split into rows.
5. In the Number of rows field, type the number of rows that you want to
split the cell into.
Merge two or more adjacent cells
1. Select a row, column, or group of adjacent cells.

2. Right-click, and click Merge Cells on the shortcut menu.
Note This command is only available when two or more adjacent cells are
selected, and the selected cells form a rectangle.
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Delete a cell, row, or column from a
table
1. In Page view, at the bottom of the document window, click Design .
2. Do one of the following:
Delete a cell
1. Place the insertion point in the cell that you want to delete.
2. On the Table menu, point to Select, and then click Cell.
3. Right-click on the cell, and then click Delete Cells on the shortcut menu.
Delete a row
1. Place the insertion point in the row that you want to delete.
2. On the Table menu, point to Select, and then click Row.
3. Right-click on the row, and then click Delete Rows on the shortcut menu.
Delete a column
1. Place the insertion point in the column you want to delete.
2. On the Table menu, point to Select, and then click Column.
3. Right-click on the column, and then click Delete Columns on the shortcut
menu.

About converting text to a table
To convert text to a table, you must first decide how you will separate the text
that you want converted. This determines how it will fit into the rows and
columns of the table.
You can indicate what text will appear in a row, by separating the text into
paragraphs. You can indicate what text will appear in a column, by separating
the text with symbols that you specify, such as commas and periods.
For example, the following text is separated by using paragraph breaks to
indicate rows, and commas to indicate columns:
Name, City, Age
Jeff Smith, Redmond, 30
The text converts to:

Convert text to a table
1. In Page view, at the bottom of the document window, click Design .
2. In the document window, type separator characters where you want to
separate text into columns and rows.
For example, you can indicate what text will appear in a row, by separating
the text into paragraphs. You can also indicate what text will appear in a
column, by separating the text with symbols that you specify, such as
commas and periods.
3. Select the text that you want to convert to a table.
4. On the Table menu, point to Convert, and then click Text To Table.
5. In the Convert Text to Table dialog box, select the character you used to
separate the columns.

Convert a table to text
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Click anywhere in the table that you want to convert to text.
On the Table menu, point to Select, and then click Table.
On the Table menu, point to Convert, and then click Table To Text.

Note Each cell becomes a separate paragraph.

Delete a table
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Click anywhere on the table that you want to delete.
On the Table menu, point to Select, and then click Table.
Right-click the table, and then click Delete Cells on the shortcut menu.
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Troubleshoot tables
I set my table border to zero but it still shows up in Netscape Navigator.
Change your authoring settings so that your border properties work in both
Microsoft Internet Explorer and Netscape Navigator browsers. Do the following:
1.
2.
3.
4.

On the Tools menu, click Page Options.
Click the Authoring tab.
In the Browsers list, click Both Internet Explorer and Navigator.
In the Browser versions list, click 4.0 browsers and later.
My tables are different sizes in different browsers.

Do one of the following:
If you want your table to take up the same amount of space on the page, no
matter how big or small the Web browser window is, set the size of the
table, cell, row, and column in percentages rather than in pixels.
This will significantly change the layout of your table, as it will resize itself
to each browser window.
If you want your table size to remain constant, set the size of the table, cell,
row, and column in pixels rather than percentages.
Why don't my double borders show up in Netscape Navigator?
Microsoft Internet Explorer and Netscape Navigator display tables differently.
With colored borders, only a single color will render in Netscape, not the threedimensional looking double border.
The Use background picture option in Table Properties is unavailable.
Your Authoring compatibility options most likely include Netscape, which does
not support background pictures in tables.

To change your compatibility settings:
1. On the Tools menu, click Page Options.
2. Click the Authoring tab.
3. In the Browsers list, click either Custom or Microsoft Internet Explorer
Only.
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About frames
Some of the content in this topic may not be applicable to some languages.
A frames page is a type of Web page that, when displayed in the browser, has
multiple regions within it called frames. Each of these frames can display a
different Web page.
A frames page itself contains no visible content— it's just a container that
specifies which other Web pages to display in a frame and how to display them.
You create a frames page by using one of the frames page Web site templates in
Microsoft FrontPage. In each of these templates, the navigation between frames
is already set up for you.
For example, a frames page created by using the Banner and Contents frames
page template actually shows four pages simultaneously in the browser: the
frames page, which is the container, and the three pages shown in each of the
three frames. In the following example, when you click a hyperlink in the
contents frame on the left, the page pointed to by that hyperlink opens in the
main frame.

The frames page
The banner frame
The contents frame
The main frame
After you create the frames page from a template, all you need to do is set the
initial page you want shown in each frame. You can select an existing page or

create a new page. Then you can edit the page directly in its frame.
How frames pages are used
In frames pages based on the Banner and Contents frames page template, many
companies use the banner frame to show a corporate logo and the primary
departments.
Frames pages are often used for catalogs, lists of articles or information, or any
other kind of page where clicking a hyperlink in one frame shows a page in
another frame. Authors use frames pages because they contain built-in
navigation and present a consistent user interface.

A user clicks the link in the banner frame
A list appears in the contents frame; a user clicks the link in the contents frame
A page is displayed in the main frame
Controlling the appearance of frames
On any frames page, you can split a frame horizontally or vertically to create
two frames. You can either split it into evenly divided rows or columns, or you
can drag its border to specify a certain size for each frame. You can resize or
delete frames by selecting and dragging frame borders. You can also choose to

show or hide the borders between frames.

Split a frame
Resize a frame
Delete a frame
Show or hide frame borders
You can also control:
The amount of space between frames
The size of margins inside frames
Whether or not a frame can be resized by users in the browser
Whether or not scroll bars are shown in a frame
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Create a frames page
Some of the content in this topic may not be applicable to some languages.
1.
2.
3.
4.
5.

On the File menu, click New.
In the New task pane, under New page, click more page templates.
Click the Frames Pages tab.
Select a template to preview the layout, and then click OK.
Set the initial page to show in each frame.
How?
1. Click the frame whose initial page you want to set.
2. Do one of the following:
Select a page that is already created
In the frame, click Set Initial Page, and then select the page you
want to show.
Create a new page and set it as the initial page to show in that
frame
In the frame, click New Page. Microsoft FrontPage creates a new
page in the frame, and the new page is automatically set as the
initial page.
Tip

When you use frames pages and frames to organize your Web site, you should
not use shared borders or link bars. Using shared borders or link bars along with
frames will make your Web site confusing to navigate.
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Create a new frames page template
based on an existing one
Some of the content in this topic may not be applicable to some languages.
1.
2.
3.
4.
5.
6.
7.
8.
9.

10.

On the File menu, click New.
In the New task pane, under New page, click more page templates.
Click the Frames Pages tab.
Click the frames page template that you want to base your template on, and
then click OK.
Modify the frames page to create a custom template.
On the File menu, click Save As.
In the Save as type list, click FrontPage Template.
In the File name box, type the file name for your custom template, and then
click Save.
In the Save As Template dialog box, in the Title box, type the name you
want to use as a title for the template. This is the title displayed in the list of
templates on the Frames Pages tab in the Page Templates dialog box.
In the Description box, type text describing what the template does. This
text is shown in the Description area of the Frames Pages tab.
Tip

If you want to add the template to the current Web site to make it available to
other authors working on the same Web site, select the Save Template in
Current Web check box in the Save As Template dialog box. FrontPage creates
a Shared Templates folder in the current Web site and adds the new template to
it.

Edit the content of a frame
If you're editing a frames page in Page view, you can select the frame you want
to edit by clicking it; if the frame is too small for you to edit the page
conveniently, you can open the page for editing in a new, full-sized window.
1. In Page view, at the bottom of the document window, click Design .
2. Right-click anywhere on the page.
A dark blue border indicates the frame you are editing.
3. Click Open Page in New Window on the shortcut menu.
Note To return the page to its original size, on the File menu, click Close.
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Change the initial page shown in a
frame
1. In Page view, at the bottom of the document window, click Design .
2. Right-click in the frame, and then click Frame Properties on the shortcut
menu.
3. In the Initial page box, type the URL of the initial page you want to show.
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Change the target frame
1. In Page view, at the bottom of the document window, click Design .
2. Select the text or picture that you are using as a hyperlink, and then click
Insert Hyperlink .
3. In the Edit Hyperlink dialog box, click Target Frame, and then do one of
the following:
Choose a target frame within your frames page
In the Target Frame dialog box, the Current frames page area shows
a map of your frames page. Click in the frame you would like to set as
the target frame.
Choose a target frame either within your frames page or outside of it
In the Target Frame dialog box, the Common targets area gives you
several target frame options. Click one of the options to select a target
frame.
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Set the display properties of frames
Microsoft FrontPage provides the flexibility for you to set frames properties to
meet your individual needs.
In Page view, at the bottom of the document window, click Design , and
do one or more of the following:
Show or hide borders around frames

You can choose to show or hide the borders around the frames of your frames
page, depending on how you want your page to look.
1.
2.
3.
4.

Right-click anywhere in the frames page.
Click Frame Properties on the shortcut menu.
Under Options, click Frames Page.
Select or clear the Show borders check box.

Notes
When you choose to show or hide borders, this setting applies to all the
frames on your frames page.
If the Show borders check box is selected, the width of the borders is
determined by the setting in the Frame spacing box.
Set the spacing between frames

You can specify the amount of spacing between the outside edges of adjoining
frames.
1.
2.
3.
4.

Right-click anywhere in the frames page.
Click Frame Properties on the shortcut menu.
Under Options, click Frames Page.
Type the amount of spacing, in pixels, in the Frame spacing box. The
default for most Web browsers is two pixels.

Note If the Show borders check box is selected, the width of the borders is
determined by the setting in the Frame Spacing box.
Adjust the margins of a frame

You can set the distance between the content of a frame and the frame border.
1. Right-click in the frame.
2. Click Frame Properties on the shortcut menu.
3. Under Margins, adjust the Width and Height settings.
Note If the page shown in the frame also has margins, the margin size you set
for the frame itself is added to the margin size of the existing page. For example,
if you are using a page in a frame that was created previously and that had a
margin set at three, and you set your frame margins to two, your total frame
margin is now five.
Create invisible frames

You can design your page using frames so that the page doesn't appear to have
frames.
1.
2.
3.
4.
5.

Right-click in the frame.
Click Frames Properties on the shortcut menu.
Under Options, click Frames Page.
Clear the Show borders check box.
Set Frame spacing to zero (0).
Show or hide frames scroll bars

You can choose to show scroll bars on your individual frames as needed, never,
or all the time, depending on the content.
1. Right-click in the frame.
2. Click Frame Properties on the shortcut menu.
3. Under Options, in the Show scrollbars list, click If Needed, Never, or
Always.
Note If the frame is taller than it is wide, the scroll bars will scroll up and down.
If the frame is wider than it is tall, the scroll bars will scroll left and right.
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Set the properties for an inline frame
1. In Page view, at the bottom of the document window, click Design .
2. Select the inline frame you want to work with by moving the pointer to the
top border of the inline frame until it changes to a left-pointing arrow ,
and then click.
3. On the Format menu, click Properties.
4. In the Inline Frame Properties dialog, set one or more of the following (if
you don't want to use the default values):
Name Type the name of your inline frame.
Initial page Set or change the initial page of your inline frame.
Title Type the title of the inline frame.
Frame size Set the width or length of the frame in pixels or
percentages.
Margins Set the margins of the frame in pixels.
Alignment Set the position for the inline frame on the page.
Scrollbars Set your preferences for displaying scrollbars.
Alternate text Type the text that you want the browser to show in
the event that the browser does not support frames.
Show border Select this check box if you want a border drawn
around the inline frame.
Note Click the Style button (if it is available) to access other options
for formatting your frame by using cascading style sheets as an inline
style.

Rename a frame
Open the page for which you want to rename a frame and do the following:
1. In Page view, at the bottom of the document window, click Design .
2. Right-click anywhere in the frame you want to rename, and then click
Frame Properties on the shortcut menu.
3. In the Name box, type the new name for the frame.
Note If you rename a frame, any existing hyperlinks anywhere in your Web site
that point to the old frame name will no longer work. You must find each
occurrence of the hyperlink in your Web site, edit the hyperlink, and change the
Target frame box to the new frame name.
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Resize a frame
You can resize a frame by dragging its border or by specifying the exact setting
you want. Open the page for which you want to resize a frame and do the
following:
1. In Page view, at the bottom of the document window, click Design .
2. Right-click in the frame and click Frame Properties on the shortcut menu.
3. In the Frame size area, adjust the Width (or Column width) and Height
(or Row height) settings.
If the frame you are resizing is in the same row as another frame, the
Height box changes to Row Height. Changing the row height of the
current frame also changes the row height of every other frame in the
row.
The Width box also changes to Column Width if the frame is part of
a column, with similar effects.
4. Specify the frame size to be a fixed number of pixels, a percentage of the
size of the browser window, or sized in values relative to other frames in the
same row or column.
Notes
When you resize a frame while editing a frames page, adjacent frames
resize accordingly to fill the space.
Resizing a frame on a frames page has no effect on the content of any pages
shown in that frame; it merely changes how much or little of the page is
shown at one time in the frame.

Lock a frame
There may be times— perhaps due to design or content issues— when you do
not want site visitors to resize your frames when viewing your Web page in a
browser.
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Right-click in the frame.
Click Frame Properties on the shortcut menu.
Under Options, clear the Resizable in browser check box.
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Split a frame
Open the frames page you want to modify and do the following.
In Page view, at the bottom of the document window, click Design .
Split a frame by dragging its border
Press and hold down CTRL and drag any frame border.
Split a frame into two evenly divided columns or rows
1. Select the frame you want to split by clicking it.
2. On the Frames menu, click Split Frame, and then select the appropriate
option.
Note When you split a frame, the original content is preserved in the original
frame, and a new frame is created.

Delete a frame from a frames page
When you delete a frame from a frames page, the page shown in that frame is
deleted, but the remaining content of the frames page is not. Whatever page was
in the deleted frame disappears from that frames page but is still in your Web site
folders. After you delete a frame, the remaining frames expand to fill the space
left by the frame you removed.
1. In Page view, at the bottom of the document window, click Design .
2. Select the frame you want to delete by clicking it.
3. On the Frames menu, click Delete Frame.
Note If the frames page contains only one frame, you cannot delete that frame.
The page shown in that frame will occupy the entire browser window when
viewed by a visitor to your site.

Save a frames page
1. In Page view, at the bottom of the document window, click Design .
2. On the File menu, click Save As.
The Save As dialog box displays a preview showing the layout of the
frames page. Because you are saving the frames page, all areas should have
the dark blue box highlights indicating that this is what you are saving.
3. In the File name box, type a file name for the highlighted frames page.
4. Navigate to the location where you want to save the page.
5. Click Save.
Notes
After you click Save, the Save As dialog box automatically opens again
and asks you to save the page shown in the frame just saved. This occurs
for each page shown in the current frames page.
The title shown in the title bar of the browser is the title of the frames page
itself, not the title of the page displayed in the frame.
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Save a page shown in a frame
To save a page that is shown in a frame, open the frames page you want to work
with, and then do the following:
1. In Page view, at the bottom of the document window, click Design .
2. Click to select the frame showing the page you want to save, and then on
the Frames menu, click Save Page As.
The Save As dialog box displays a thumbnail showing the layout of the
frames page. A dark blue box indicates the current page that will be saved
in the highlighted frame.
3. In the File name box, type or select the appropriate file name for the page
shown in the selected frame in the thumbnail.
4. In the Save as type list, click the type of Web page you want to save.
5. Navigate to the location where you want to save the page.
6. Click Save.
Note The title that is shown in the title bar of the browser is the title of the
frames page itself, not the title of the page displayed in the frame.
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About inline frames
Inline frames are similar to frames pages except that the inline frame and its
contents are embedded on an existing Web page. Anything that you can put on a
regular page you can put in an inline frame. You can customize inline frames in
the same ways as regular frames and also enable scroll bars.
One of the advantages of using inline frames is that you don't need to create a
separate frames page in order to have embedded content.
You can use inline frames in a variety of ways:
To insert a contract for your site visitor to fill out
To give examples of what other Web pages look like
As a container for a form
As a scrolling box with products and prices
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Add an inline frame to a page
1. In Page view, at the bottom of the document window, click Design
2. On the Insert menu, click Inline Frame.
3. Set the initial page of the inline frame.

.

How?
Do one of the following:
Select a page that is already created
In the frame, click Set Initial Page and then select the page you want
to show.
Create a new page and set it as the initial page to show in that frame
In the frame, click New Page. Microsoft FrontPage creates a new page
in the frame, and the new page is automatically set as the initial page.
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Modify the "no frames" message on a
frames page
Some older browsers cannot show frames pages. Instead, they show a "no
frames" message when a site visitor opens a frames page on your Web site. You
can customize this message by doing the following.
1. In Page view, at the bottom of the document window, click No Frames
2. Modify the message to say what you want.

.

Tip
You can include in the message pictures, tables, forms, or anything else that you
can put on a page.
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Save a Web page with an inline frame
Open the frames page you want to work with, and then do the following:
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
On the File menu, click Save As.
Microsoft FrontPage prompts you to save the page the inline frame is on.
Click OK.
Note If your initial page has not yet been saved, FrontPage prompts you to
save the actual inline frame and its contents.

Enable or disable frames for browser
compatibility
You can choose to enable or disable frames, depending on whether or not a
browser supports frames.
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. Select or clear the Frames check box to enable or disable frames and
frames pages.
Note If you disable frames, or if you target a Web site for compatibility with a
browser that doesn't support frames, the commands for inserting or using frames
will be unavailable on menus in Microsoft FrontPage when you are creating your
Web pages.
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Troubleshoot frames
Some of the content in this topic may not be applicable to some languages.
My hyperlink is opening a page in the wrong frame.
On frames pages that you create by using frames page templates in Microsoft
FrontPage, the target frames are already set up for you. You can override the
target frame for a single hyperlink, or change the default target frame for all
hyperlinks on a page.
1. Open the frames page that contains the hyperlink.
2. In Page view, at the bottom of the document window, click Design .
3. Select the hyperlink, and then click Insert Hyperlink
4. Do one or both of the following:

.

Change the target frame for a single link
1. In the Edit Hyperlink dialog box, click Target Frame.
2. In the Target Frame dialog box, click the frame where you want the
page to open.
The Current frames page area shows a diagram of the frames on the
page.
Change the default target frame for all hyperlinks on the page
1. In the Edit Hyperlink dialog box, click Target Frame.
2. In the Target Frame dialog box, click the frame where you want the
page to open.
The Current frames page area shows a diagram of the frames on the
page.

3. To designate the target frame you selected as the default target frame
for all the hyperlinks on the page, select the Set as page default check
box.
When I click a hyperlink, I want the page to open in a new browser
window.
On frames pages that you create by using templates in Microsoft FrontPage, the
target frames are already set up for you. You can change the default target frame
so that when a site visitor clicks on a hyperlink, a new browser window opens.
1.
2.
3.
4.

Open the frames page that contains the hyperlink.
In Page view, at the bottom of the document window, click Design .
Select the hyperlink, and then click Insert Hyperlink .
In the Edit Hyperlink dialog box, click Target Frame to change the target
frame from the default.
5. In the Target Frame dialog box, under Common targets, select New
Window.
I can't see all my documents listed on the page tabs.
If you have created so many files that not all of them are visible on the page tabs,
you will need to do one of the following:
To make one more tab to the left visible, click .
To make one more tab to the right visible, click .
I want to edit the HTML code of a nested frames page.
When you are editing a nested frames page, you can also edit the HTML code,
but you must first open that page in a new window.
1. In Page view, at the bottom of the document window, click Design .
2. Right-click anywhere on the page, and then click Open Page in New
Window on the shortcut menu.
3. At the bottom of the document window, click Code to edit the HTML
code of the page.

Microsoft FrontPage won't let me open a frames page template.
Support for frames might be turned off. To check your authoring settings, do the
following:
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
On the Tools menu, click Page Options.
Click the Authoring tab.
Check to make sure that the check box next to Frames is selected.
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About styles
A style is a set of formatting characteristics identified by a unique name. Styles
enable you to quickly format a whole group of page elements in one simple task.
You can apply styles to most page elements in Microsoft FrontPage, including
text (individual characters or entire paragraphs), graphics, and tables.
About built-in and user-defined styles
With FrontPage, you can choose from a group of built-in styles, or you can
create your own user-defined styles. Built-in styles are frequently used
formatting options available by default in the Style box. User-defined styles can
be modifications to built-in styles, or class selectors that you create.
You can access both built-in and user-defined styles from the same style list
when you're editing a page.
Using styles with page elements
You can choose from several categories of styles.
Paragraph-level styles A paragraph-level style is usually applied to start
and end paragraph tags (<p>) and can affect any text contained between
those tags. In addition, a paragraph-level style can also be applied to other
tags, such as <div>.
Examples
The item below represents a paragraph-level style with the addition of a
border around text.

The graphic below represents a paragraph-level style with the addition of a
border around an image.

Character-level styles
within a paragraph.

A character-level style applies to just the text

Example
The text shown in the example below has three words in bold and
red — the result of a character-level style being applied.

Page element styles Some page elements have a Style button on their
properties dialog box. Those styles allow you to add styles specific to that
particular page element.
Example
The table in the following example has a blue outset border, which is the
result of a style being added through the table property options.

Note If you apply a user-defined style to a page element that is already
formatted with a standard HTML tag, both formatting characteristics are used.
For example, if you select a paragraph styled as Heading 1, and then apply a
user-defined style named .redbg that adds a red border, you get the standard
Heading 1 formatting (Times New Roman, Bold, 24 pt, and left-aligned)
surrounded by a red border.
The class name of the user-defined style is appended to the end of the HTML tag
in the Style box, listing the new style as Heading2.redbg.
About cascading style sheets
A Cascading Style Sheet (CSS) is used to apply consistent style information
across multiple Web pages. A CSS contains style definitions that describe the
styles you want to apply to pages or page elements. Each style definition consists
of a selector followed by the properties and values for that selector.
The following are examples of style definitions defined in a CSS:
H1 { font-size: x-large; color: green }
H2 { font-size: large; color: blue }
.note { font-size: small }
#footer { font-family: serif }

In the example, H1 and H2 are selectors that modify the formatting properties of
standard HTML tags. The selectors' properties and values are contained within
the curly braces { } — font-size is a property, and x-large is the value of the
font-size property. You can specify multiple properties for a selector by
separating each with a semi-colon ( ; ). In the example, .note is a class selector,
and #footer is an ID selector.
FrontPage primarily deals with two types of cascading style sheets — embedded
and external — although a third type, inline, is occasionally used.
Embedded cascading style sheet When you create or modify a style to
be used on a single page, FrontPage creates a cascading style sheet for you.
Called an embedded cascading style sheet, it is a collection of code stored

between HTML <STYLE> tags between the <HEAD> tags of the page.
Any style you create for that page is stored in the embedded style sheet as a
class selector.
External cascading style sheet External cascading style sheets are the
most useful because they can be attached to multiple Web pages. You can
apply the same styles consistently across an entire Web site.
If you decide to change a style, you need only make one change — in the
external cascading style sheet — and the pages in your Web site will reflect
the change. Typically, an external style sheet uses the .css file name
extension, such as Mystyles.css.
Inline cascading style sheet A third type of cascading style sheet, inline,
contains user-defined styles that are applied to a single page element. This
type of cascading style sheet is usually created when you add styles using
the Style button on a page element's Properties dialog box.
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Add a style to a cascading style sheet
1. In Page view, do one of the following:
To add a style to an external cascading style sheet (CSS), open the .css
file.
External CSS files have a .css extension.
To add a style to an embedded CSS, open the Web page that contains
the CSS.
2. On the Format menu, click Style, and then click New.
3. In the Name (selector) box, enter a name for the new style.
Do not type spaces in the style name.
4. In the Style type box, select whether the style will be a Paragraph or
Character style.
5. Click Format, and then specify the formatting characteristics for the new
style:
To set font properties — such as the font family or color, or character
spacing — click Font.
To set alignment, indentation, or spacing, click Paragraph.
To set borders and shading, click Border.
To set the style of bullets or numbering, click Numbering.
To set positioning properties — such as wrapping style, location, or zorder (an element's position in the layers of the page) — click
Position.
6. Select the options you want.
7. You have to attach a CSS to a document before the styles will be available

for that document.
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Apply a style
Do one or more of the following:
1. In Page view, at the bottom of the document window, click Design .
2. Do one of the following:
Apply a style to text
1. Select the text or paragraph that you want to apply a style to.
2. On the Formatting toolbar, in the Style box
, click the built-in
or user-defined character or paragraph style you want.
Notes
Character styles are shown in the Style box by a small, underlined
letter a in front of the style name. Use character styles when you
select part, but not all, of a paragraph.
Only one built-in character style is installed with Microsoft
FrontPage (shown in the Style box as Default Character Style
and preceded by a small, underlined letter a). The Default
Character Style removes formatting applied by user-defined
character styles.
Paragraph styles are identified by a paragraph symbol (for built-in
styles) or the absence of a character or symbol (for user-defined
styles) in front of the style name.
Apply a style to a page element
1. Click the page element.
2. On the Format menu, click Properties.
3. Click the Style button.

4. Do one of the following:
To apply a style from the embedded cascading style sheet (CSS)
for the page, click the Class box, and then click a selection in the
list of available class selectors.
To apply a style from an external CSS, type the name of the style
in the Class box.
To apply an ID selector, type the name of the selector in the ID
box.
To create an inline CSS, click Format, and then click Font,
Paragraph, Border, Numbering, or Position to specify the
formatting characteristics.
Note If the dialog box does not have a Style button, you can apply a
style to a page element by using the Style box. To do so, on the
Formatting toolbar, click the Style box
and then click the
built-in or user-defined style you want to apply.
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Remove a style from a cascading style
sheet
1. In Page view, do one of the following:
To remove a style from an external cascading style sheet (CSS), open
the .css file that contains the style.
External CSS files have a .css extension.
To remove a style from an embedded CSS, open the Web page that
contains the style.
2. On the Format menu, click Style.
3. In the List box, select User-defined styles.
4. In the Style box, select the user-defined style you want to delete, or the
built-in style from which you want to remove custom formatting
characteristics.
5. Click Delete.
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Copy inline styles for text
1. Select the characters or paragraphs that have the formatting you want to
copy.
To copy the formatting of an entire paragraph, make sure the selection
includes the paragraph mark.
How?
To see the paragraph marks, on the Standard toolbar, click Show All
.
2. On the Standard toolbar, click Format Painter
select the text to which you want to apply the formatting.

, and then
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About positioning page elements
Positioning is how you place elements, such as text and graphics, on a page. You
can place elements in front of or behind other elements, or group them together.
Types of positioning
You can position page elements in the following ways:
Absolute positioning
You can use absolute positioning to place an element at an exact location on a
page. An element placed using absolute positioning remains at a fixed location
relative to the top-left corner of the page. It floats on top of, or sits behind, text
or other page elements.
You can place the element by dragging it to the location you want, or you can
specify coordinates, which are relative to the upper-left corner of the page or
frame the element is in, as shown in the example below.

The x- and y-coordinates of a page element
The position of the page element in Microsoft FrontPage
The position of the page element in a Web browser
If an absolutely positioned element is placed in a position box, the coordinates
are relative to the upper-left corner of the position box, rather than the page.
You can specify the coordinates of the page element relative to the upper-left
corner of its container, in pixels. You can also specify the dimensions of a
position box by using the following units:
Pixels (px)
Font size (em)

X-height of the font (ex)
Inches (in)
Centimeters (cm)
Millimeters (mm)
Points (pt), where one point is equal to 1/72 of an inch
Percentage of the page height or width (%)
For example, you can set a position box to be the same width as the page (set
Width to 100%), and 20 pixels high (set Height to 20 px).
When viewed at different screen resolutions, the element might not be placed as
you intended, although the element still appears at the pixel coordinates you
specified. When the screen resolution changes, so does the layout, since other
page elements such as text are displayed differently.
Note Adding page elements by using absolute positioning with DHTML may
cause either the DHTML effect or the absolutely positioned element to behave
unexpectedly.
Relative positioning
Use relative positioning to place page elements inline with text. Regardless of
the changes you make to the page above or below this point, the layout of the
relatively positioned element remains intact. You can use relative positioning for
animation and DHTML effects.
Floating
You can create a floating page element that lets other elements, such as text,
wrap around it. A floating element is removed from the flow of text, and is
aligned left or right. You can also specify the height and width of the floating
area of the element. For example, the figure below shows how text flows around
a paragraph that floats to the right, creating a sidebar of text that is aligned to the
right of the page regardless of the layout of text around it.

Stacking

You can use positioning to overlap elements. The z-order refers to an element's
position in a stack of elements, which includes the page itself. The main page
layer is zero; a positive z-order means that the element is in front of the main
layer, and a negative number means the item is behind it. Using a negative
number, you can even position elements "underneath" the page layer.

Working with positioned elements
After you position your page elements, you can work with them in the following
ways:
Selecting a positioned element
You can select some page elements by clicking them directly or by using the
menu commands. Many types of page elements, such as graphics, form fields,
and other objects, are indicated with an anchor icon when you show all
nonprinting characters. The anchor is displayed in the text flow where you
originally inserted the element. To select the object, you select the corresponding
anchor icon.
Grouping page elements
You can combine the types of positioning to achieve a variety of results, such as
to keep a group of page elements together as a unit. For example, you can add a
position box to a page, and inside the box, add multiple page elements using
absolute positioning to lay them out. The result is a position box that is
positioned with respect to the text flow on the page, but the layout of the
elements inside the box is always preserved, regardless of any changes you make
to the rest of the page. Even when the window is resized, the layout of the
elements inside the position box remains the same.

Grouping page elements
Layout of grouped elements is preserved, even when the Web browser window
is resized

Ensuring that positioned items are displayed properly
To view the properties of a page element, position the mouse pointer over it. The
properties are displayed as a ScreenTip.
Page layout can vary when viewed at different screen resolutions, even though
an absolutely positioned element always appears at the same coordinates you
specify. To ensure the page is displayed well to all site visitors, you should test it
at different screen resolutions.
Note Positioning works with Web browsers that support cascading style sheets
(CSS) 2.0, such as Microsoft Internet Explorer 4.0 and later, and Netscape
Navigator 4.0 and later. When viewed in earlier browser versions, positioned
content is aligned left, and is located inline with the text rather than uniquely
positioned.
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Position a page element
1. In Page view, at the bottom of the document window, click Design .
2. Select the page element you want.
3. On the Format menu, click Position.
4. Specify the type of positioning you want.
To fix the position box at the insertion point — relative
positioning — under Positioning style, click Relative.
To enable the position box to be placed precisely on the
page — absolute positioning — under Positioning style, click
Absolute.
5. Specify any additional settings that are relevant to the position of the
element.
How?
To set pixel coordinates, under Location and size, specify a value in
the Left and Top boxes.
Under Wrapping style, specify how you want the page elements to
wrap around the position box.
To specify the z-order, which is the element's position in the layers of
the page, specify a value in the Z-Order box. A positive value means
that the element is in front of the main text-flow layer (layer 0), and a
negative value means the item is behind it.
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Group page elements
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point where you want to put a position box, and then
press ENTER to insert a new blank line.
3. Select the blank line, making sure to include the paragraph marker.
If the paragraph markers are not visible, on the Standard toolbar, click
Show All

.

4. On the Format menu, click Position.
5. Do one of the following:
To fix the position box at the insertion point — relative
positioning — under Positioning style, click Relative, and then click
OK.
To enable the position box to be placed precisely on the
page — absolute positioning — under Positioning style, click
Absolute, and then click OK.
6. Click inside the position box, and then insert a page element — for
example, a graphic.
7. Click the page element that is inside the position box.
8. On the Format menu, click Position, and then click Absolute.
9. Repeat steps 6 through 8 for each page element you want to place in the
position box.
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About cascading style sheet
compatibility
When you design your Web site by using Microsoft FrontPage, you can enable
compatibility with an array of different browsers and technologies, among which
are cascading style sheet (CSS) features.
If you design a Web site for compatibility with a Web browser that doesn't
support CSS, some options that use CSS are unavailable on menus when you
author your Web pages. This is to prevent you from accidentally using features
that won't be compatible with the Web browsers used by your site visitors.
Because FrontPage uses CSS to implement some style features, some menu
items will be unavailable when support for CSS is turned off.
Some of these options are:
On the Insert menu, the Layer command is unavailable.
On the Format menu, these commands are unavailable: Style, Style Sheet
Links, Borders and Shading, and Position.
In the Font dialog box, some font effects on the Font tab and the Spacing
and Position options on the Character Spacing tab are unavailable.
In the Page Templates dialog box, the Style Sheet tab is unavailable.
In the Paragraph dialog box, the Indentation and Spacing options are
unavailable.
In the Layers task pane, all of the options are unavailable.
In the Theme task pane, you can view thumbnail images of the themes, but
you cannot apply a theme to your page.
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Create a cascading style sheet
Some of the content in this topic may not be applicable to some languages.
Do one of the following:
Create an external cascading style sheet (CSS)
1. On the File menu, click New.
2. In the New task pane, under New page, click More page templates.
3. On the Style Sheets tab, click the type of CSS you want to create.
Microsoft FrontPage creates a new page with a .css file name extension and
opens it for editing. Before you can link the .css file to a Web page, you
must save it.
Create an embedded CSS
To create an embedded CSS, you must define a style that you want to include in
it.
1. In Page view, at the bottom of the document window, click Design .
2. On the Format menu, click Style.
3. Click New, and then in the Name (selector) box, type the name of the new
style.
4. Under Style Type, choose whether the style will be a Paragraph or
Character style.
5. Click Format, and then specify the formatting characteristics for the new
style.
Note When you apply a style directly to an item using the Style button on its
Properties dialog box, the style is applied directly to the element, creating what
is called an inline cascading style sheet (CSS).
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Edit a cascading style sheet
1. In Page view, do one of the following:
To edit an external cascading style sheet (CSS), open the .css file.
To edit an embedded CSS, open the Web page that contains it.
2. On the Format menu, click Style.
3. In the List box, do one of the following:
To edit a custom style you created, click User-defined styles.
To edit a style for a standard HTML tag, click HTML tags.
4. In the Styles box, double-click the style.
5. Do one or more of the following:
To change the style type for the style, click Paragraph or Character
in the Style type box.
To change formatting characteristics for the style, click Format, click
the type of formatting attributes you want to change, and then select
the options you want.
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Link to an external cascading style
sheet
1. In Page view, at the bottom of the document window, click Design .
2. On the Format menu, click Style Sheet Links, and then click Add.
3. Locate and click the .css file for the external cascading style sheet (CSS),
and then click OK.
4. Do one of the following:
To link the external CSS to only the current page, click Selected
page(s).
To link the external CSS to all pages in the current Web site, click All
Pages.
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Remove a link to an external
cascading style sheet
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
On the Format menu, click Style Sheet Links.
In the URL list, click the name of the external cascading style sheet (CSS).
Do one of the following:
To remove the link to the external CSS from only the current page,
click Selected page(s).
To remove the link to the external CSS from all pages in the current
Web site, click All Pages.
5. Click Remove.
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Turn support for cascading style
sheets on or off
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. Do one or more of the following:
To turn support for commands that use cascading style sheets (CSS)
version 1.0 on or off, select or clear the CSS 1.0 (formatting) check
box.
CSS 1.0 enables you to add attributes to a tag, such as increasing the
space before or after a paragraph.
To turn support for commands that use CSS version 2.0 on or off,
select or clear the CSS 2.0 (positioning) check box.
CSS 2.0 enables pixel-precise positioning and grouping of page
elements.
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About themes
Some of the content in this topic may not be applicable to some languages.
A theme is a unified set of design elements and color schemes that you can apply
to your Web pages to give them a professional look. Using a theme is a quick
and easy way to make sure your Web pages are visually consistent and
appealing. Microsoft FrontPage includes many complete themes that you can use
right away. You can also change those themes or create new ones.
You can apply a theme to one or more pages or to an entire Web site. If you
apply a theme to all pages in a Web site, it becomes the default theme for that
Web site. When you create new pages, the default theme is applied
automatically. If you change or remove the default theme, the change is applied
to the entire Web site.
The following example shows a plain Web page, and then shows how the same
page would look with different themes applied:

A plain Web page.
The same page with three different themes applied.
A theme affects all aspects of a page's appearance:

Colors A theme's color scheme specifies the color of body text, headings,
hyperlinks, page banner text, link bar labels, table borders, and the page
background. You can use normal or vivid colors.
Graphics Several page elements contain graphics, such as the background
picture, the page banner, bullets, navigation buttons, and horizontal lines. You
can use standard or active graphics. The active graphic set uses interactive
buttons, instead of plain buttons, on link bars.
Styles A theme uses its own font styles and sizes for body text and headings.

Creating and customizing themes
You can create a new theme, or customize colors, graphics, and font styles for
existing themes, and save those changes as a new theme.
Choosing colors
You can choose the colors that are used in a theme. You can choose a color from
one of the FrontPage color palettes, or you can define your own custom colors.
You can also change colors in an existing theme. For example, in the Artsy
theme, active hyperlinks are green — you could change them to red. You can
also change the colors of other page and text elements, such as body and heading
text, banner text, link bar labels, table borders, and the background. In addition,
each theme has two color sets — normal and vivid. You can specify the colors to
use for both sets.
Choosing graphics
You can choose graphics to use when you create a new theme. For example, you
could use a picture you created as the background for your new theme.
You can also change graphical elements in existing themes, such as the page
banner, bullets, and navigation buttons. In addition, you can specify the font to
use for graphical elements that are displayed with text.
Each theme has two sets of graphics — normal and active. You can specify the
graphics to use for either set. The active graphic set uses animated page
elements, such as Interactive Buttons instead of plain buttons on link bars.
Note Active graphics are not available for some theme items.
Choosing styles
In FrontPage, all font styles are applied using cascading style sheets (CSS). You
can choose font styles for a new theme that you create, or customize styles in
existing themes. For example, in the Capsules theme, you could change the font

for the body and heading styles from Arial to Times New Roman. To change the
font displayed on a graphical element (for example, the font used on page
banners), you must change the graphic.
Using templates
A page that has a theme applied to it can be saved as a template. Any pages
created by using the template will either use the Web site's default theme or a
specific theme, depending on how the theme was applied to the original page.
For example, you create a template from a page that has a theme applied to it,
then you create pages in a Web site whose default theme is Artsy. If the page
template used the Web site default theme, new pages will use the Artsy theme. If
the page template used a specific theme, new pages will use that theme.
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Create a new theme
1.
2.
3.
4.

On the Format menu, click Theme.
In the Theme task pane, at the bottom, click Create new theme.
Set the properties that you want.
Click Save As, type a name for the new theme, and then click OK.
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Apply a theme
1. In Page view, at the bottom of the document window, click Design .
2. Do one of the following:
Apply a theme to the current page
1. On the Format menu, click Theme.
2. In the Theme task pane, click the theme you want.
Note After you apply a theme to the current page, the page no longer uses
the default theme setting of the Web site (if there is one). Therefore, any
theme changes you apply to the Web site will not affect this page.
Apply a theme to selected pages
1. In Folders view, select the pages you want.
How?
On the View menu, click Folders, and then on the Web Site tab,
select multiple pages by holding down the CTRL key and
clicking the pages you want.
2. On the Format menu, click Theme.
3. In the Theme task pane, click the theme you want to apply.
Note If you apply theme settings to individual pages, these pages no longer
use the default theme setting of the Web site (if there is one). Therefore, any
theme changes you apply to the Web site will not affect these pages.
Apply a theme to a Web site
1. On the Format menu, click Theme.
2. In the Theme task pane, point to the thumbnail for the theme you want
to apply, and then click the arrow.

3. Click Apply as default theme.
Note When you apply a theme to an entire Web site, Microsoft FrontPage
will display a warning indicating that you are setting the default theme for
that site.
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Change the graphics used in a theme
1. On the Format menu, click Theme.
2. In the Theme task pane, point to the thumbnail for the theme you want to
change, and then click the arrow.
3. Click Customize, and then click Graphics.
4. In the Item list, select the graphical element you want to change.
5. Next to Theme graphic set, specify whether you want to change graphics
in the normal or active set.
6. Locate and select the picture or pictures you want to use, and then click
Open.
If the graphical element you selected displays text, the options on the Font
tab will be available and you can change the font.
7. Repeat steps 4 through 6 for each graphical element you want to change.
You can choose not to have a graphic defined for any element by removing
the text from the edit box.
8. Click OK and then click Save as.
9. Type a new name for the theme (unless you have changed a custom theme),
and then click OK.
Note When you modify a preset theme, you must save your changes as a
new theme.
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Change the styles used in a theme
1. On the Format menu, click Theme.
2. In the Theme task pane, point to the thumbnail for the theme you want to
change, and then click the arrow.
3. Click Customize, and then click Text.
4. In the Item box, click the item for which you want to change the style.
5. Under Font, click the font you want to use.
To view other options for changing the theme's style, click More Text
Styles.
6. Repeat steps 4 and 5 for each item you want to change.
7. Click OK and then click Save as.
8. Type a new name for the theme (unless you have changed a custom theme),
and then click OK.
Note When you modify a preset theme, you must save your changes as a
new theme.
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Change the color scheme of a theme
1. In Page view, at the bottom of the document window, click Design .
2. On the Format menu, click Theme.
3. In the Theme task pane, point to the thumbnail for the theme you want to
change, and then click the arrow.
4. Click Customize, and then click Colors.
5. Next to Theme color set, specify whether you want to change colors in the
normal or vivid color set.
6. Do one of the following:
Choose a preset color scheme
Select the color scheme you want to use, and then click OK.
Create a new color scheme
Create a custom color scheme you want to use, and then click OK.
7. Click Save As to save the changed theme.
8. Type a new name for the theme (unless you have modified a custom
theme), and then click OK.
Note When you change a preset theme, you must save your changes as a
new theme.
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Change the color of a theme element
1. On the Format menu, click Theme.
2. In the Theme task pane, point to the thumbnail for the theme you want to
change, and then click the arrow.
3. Click Customize, and then click Colors.
4. Next to Theme color set, specify whether you want to change colors in the
normal or vivid color set.
5. Click the Custom tab and do one of the following:
Choose an existing color
1.
2.
3.
4.

In the Item list, click the item you want to change the color for.
In the Color list, specify the color you want to use.
Repeat these steps for each item you want to change the color for.
Click OK.
Define a custom color

1. In the Item list, click the item you want to change the color for.
2. Click the Color list, and then click More Colors.
3. Do one of the following:
Select a color from a browser-safe palette
Click a color, and then click OK.
Specify a hexadecimal value
Type the value in the Value box (for example, type HEX=
{FF,33,00}), and then click OK.
Select a color on the screen
Click Select, use the Eyedropper

to click the color, and then

click OK.
For example, to use a color from a picture on an open page, click
a color on the picture.
Create a color average of the colors in a particular region on the
screen
Click Select, use the Eyedropper
to draw a box on the screen
to specify the region, and then click OK.
Select a different color, or specify a combination for huesaturation-luminosity or red-green-blue
1. Click Custom.
2. Under Custom Colors, click a blank box.
3. Define a color by entering a combination of values or by selecting
a color from the color matrix.
4. Click Add to Custom Colors, and then click OK three times to
return to the Customize Theme dialog box.
6. Click Save As to save the changed theme.
7. Type a new name for the theme (unless you have modified a custom
theme), and then click OK.
Note When you modify a preset theme, you must save your changes to a
new theme; you cannot overwrite a preset theme.
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Remove a theme
Do one of the following:
Remove a theme from the current page
1. In Page view, at the bottom of the document window, click Design .
2. On the Format menu, click Theme.
3. In the Theme task pane, point to No theme, click the arrow, and then click
Apply to selected page(s).
Remove a theme from selected pages in a Web site
1. In Folders view, select the pages you want.
How?
On the View menu, click Folders, and then on the Web Site tab, select
multiple pages by holding down the CTRL key and clicking the pages
you want to select.
2. On the Format menu, click Theme.
3. In the Theme task pane, point to No theme, click the arrow, and then click
Apply to selected page(s).
Remove a theme from all pages in a Web site
1. On the Format menu, click Theme.
2. In the Theme task pane, point to No theme, click the arrow, and then click
Apply as default theme.
Note When you remove a theme from all pages in a Web site, only those pages
that were using the default theme are affected. If certain pages use a different
theme, you must remove each of their themes individually.
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About adding a background to your
Web page
You can use color, and pictures to create a more interesting background for your
Web pages.
Color
Whenever you select a color for a page, Microsoft FrontPage displays color
palettes appropriate for your page. Color palettes include standard colors, which
are those colors in the 16-color (Web-safe) palette, and document colors, which
are those colors that the current page already specifies.
If the palettes do not display the color you want, you can create a custom color
that you can use for backgrounds, fonts, and so on. Any custom colors you
define are saved and will be available the next time you use FrontPage.
Pictures
You can set a background picture for a page, and all page elements, such as text
and graphics, that will appear on top of the background picture. You can use
pictures from a Web site, a file system, the World Wide Web, or clip art.
Watermarks
Watermarks are non-scrolling text or pictures that appear behind the other page
elements that you place on a Web page.
Note Not all Web browsers support watermarks.
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Add a background picture to a Web
page
1.
2.
3.
4.
5.

In Page view, at the bottom of the document window, click Design .
Right-click the page, and then click Page Properties on the shortcut menu.
Click the Formatting tab.
Select the Background picture check box, and then click Browse.
Locate and click the file that contains the background picture you want, and
then click Open.
6. If you want to add the picture as a watermark, select the Make it a
watermark check box.
Note If the current page uses a theme, this feature is unavailable.
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Change the background color of a
Web page
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Right-click the page, and then click Page Properties on the shortcut menu.
Click the Formatting tab.
Under Colors, click the color you want in the Background list.

Note If the current page uses a theme, this feature is unavailable.

Remove a background picture from a
Web page
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Right-click the page, and then click Page Properties on the shortcut menu.
Click the Formatting tab.
Clear the Background picture check box.

Create a page transition effect
1.
2.
3.
4.
5.

In Page view, at the bottom of the document window, click Design .
On the Format menu, click Page Transition.
To set the transition effect, click the event in the Event box.
In the Transition effect box, click the type of transition effect you want.
In the Duration box, type the amount of time (in seconds) that you want
the transition effect to last.
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Copy an animation effect
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point next to the element with the effect.
3. Click Format Painter
, and then click the page element that
you want to copy the animation effect to.
Note The Format Painter will copy other attributes besides the Dynamic
HTML (DHTML) animation effect. For example, if you copy the formatting of a
bold paragraph that flies in from the left, and apply it to another paragraph, the
new paragraph will also have these attributes.

Change an animation effect on a page
element
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point next to the animated page element that you want to
change.
3. On the DHTML effects toolbar, do one or more of the following:
To change the event, in the On list, click an event that you want to
start the effect.
To change the effect, in the Apply list, click the effect that you want.
To change the settings for the effect, in the box next to the Apply box,
click the setting you want for the effect.
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Add a horizontal line
You can use a horizontal line to separate text or to add an accent. After you add a
horizontal line, you can modify its properties to change its width, height,
alignment, and color.
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Place the insertion point where you want to insert a line.
On the Insert menu, click Horizontal Line.
To modify the appearance of the horizontal line, double-click the horizontal
line, and then do one or more of the following:
To increase or decrease the width of the line, enter a different pixel or
pecentage value in the Width box, and then click Percent of window
or Pixels, depending on the type of value you entered.
To increase or decrease the height of the line, enter a different pixel
value in the Height box.
To align the line left, center, or right on the page, under Alignment,
click the alignment option you want.
To add color to the line, click a color in the Color list.
If you want the line to appear solid, select the Solid line (no shading)
check box.
5. To apply a custom style or other formatting to the line, click Style, and then
select the options you want.
Note If you apply a theme to a Web page by using a version of Microsoft
FrontPage earlier than Office FrontPage 2003, you can change only the
alignment of a line graphic that is part of a theme.

Add an animation effect to a page
element
1. Select the element that you want to add an animation effect to.
2. On the DHTML Effects toolbar, in the On box, click the event that you
want to start the effect.
If the DHTML Effects toolbar is hidden, on the View menu, point to
Toolbars, click Customize, and then select the DHTML Effects check
box.
3. In the Apply box, click the effect you want.
4. In the box next to the Apply box, click the setting you want for the effect.

Delete a banner ad
This procedure applies only to a banner ad that you created by using the Banner
Ad Manager in an earlier version of Microsoft FrontPage.
1. In Page view, at the bottom of the document window, click Design .
2. Click the banner ad, and then press DELETE.
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Set the properties of a banner ad
This procedure applies only to a banner ad that you created by using the Banner
Ad Manager in an earlier version of Microsoft FrontPage.
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the banner ad, and then click Banner Ad Manager Properties
on the shortcut menu.
3. Do any of the following:
In the Width box, type the width of the banner ad in pixels or
percentage.
In the Height box, type the height of the banner ad in plxels or
percentage.
In the Transition effect list, click the effect you want to use when the
banner ad switches from one picture to another.
In the Show each picture for (seconds) box, type a value that
specifies how many seconds to show each picture.
In the Link to box, type the URL of the Web page or file you want to
open when a site visitor clicks the banner ad.
To select pictures to display in the banner ad, click Add, and then
locate and click the file you want.
The list in the Pictures to display box shows the pictures you've
added and the sequence in which the pictures will be displayed.
To move a picture up in the display sequence, click the URL of the
picture in the list, and then click Move Up.
To move a picture down in the display sequence, click the URL of the
picture in the list, and then click Move Down.
To remove a picture from the banner ad, click the URL of the picture
in the list, and then click Remove.

Add a marquee
1. In Page view, at the bottom of the document window, click Design .
2. Click where you want to add the marquee, and then type and select that
text.
3. On the Insert menu, click Web Component.
4. Under Component type, click Dynamic Effects.
5. Under Choose an effect, double-click Marquee.
6. Set the properties that you want for the marquee.

Set the properties of a marquee
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the marquee that you want to set properties for, and then click
Marquee Properties on the shortcut menu.
3. Set the properties that you want.

Delete a marquee
1. In Page view, at the bottom of the document window, click Design .
2. Click the marquee, and then press DELETE.

Remove an animation effect
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point next to the page element that you want to remove
the animation effect from.
3. On the DHTML Effects toolbar, click Remove Effect.

Create a watermark
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the page you want to add a watermark to, click Page Properties
on the shortcut menu, and then click the Formatting tab.
3. Under Background, select Background picture, and then select the Make
it a watermark check box.
4. Locate and click the graphic file you want.
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Troubleshoot dynamic page elements
When I attempt to add a marquee from the Insert Web Components
dialog, the marquee option is unavailable.
To use the Marquee option, you must set your Authoring compatibility settings
to Microsoft Internet Explorer only. Do the following:
1. On the Tools menu, click Page Options.
2. Click the Authoring tab.
3. In the Browsers list, click Microsoft Internet Explorer only, and then
click OK.
Why don't I see the Hover Button option in the Insert Web Component
dialog box?
The Hover Button option is no longer available in the Insert Web Component
dialog box. Either use Interactive Buttons to add dynamic buttons to your Web
page, or add the Hover Button command to a menu by doing the following:
1. On the Tools menu, click Customize.
2. Click the Commands tab.
3. In the Categories list, click Insert, and then in the Commands list, click
Hover Button.
4. Drag the command to the menu you want.
The Included Content Web component is grayed out when I attempt to
embed a Web page in another Web page
To embed a Web page in another Web page, both pages must be part of the same
Web site. Additionally, you must make the Author-time Web components
available, and then the Included Content Web component will become available
in the Insert Web Components dialog.
To make the Author-time Web components available, do the following:

1. On the Tools menu, click Page Options.
2. Click the Authoring tab, and then select the Author-time Web
Components check box.
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About working with HTML
Hypertext Markup Language (HTML) is a standard for creating pages for the
World Wide Web. HTML uses special markers, called tags, that indicate how
Web browsers should display page elements such as text and graphics.
You can edit or format HTML code using tools available in Code or Design
views. Design view is a WYSIWIG view where you can work with HTML tags
indirectly.
When you edit a Web page in Design view, or in the design pane in Split view,
you can show or hide HTML tag markers that indicate the start and end of
underlying HTML tags.
Editing HTML
Microsoft FrontPage provides a variety of features that help you edit HTML
more easily.
IntelliSense provides you with a list of available choices when you're
adding tags or attributes.
The Quick Tag Selector enables you to select entire tags, or the contents of
tags, without having to switch to Code view.
All of the standard editing commands are also available for editing code.
For example, you can Copy, Cut, Paste, Find, and Replace while editing
your Web page.
The properties of HTML tags are displayed so you can change them
yourself.
Line numbering helps you to locate and move between specific lines of
code.
Formatting HTML
HTML formatting defines how the code is structured on the page. The basic
formatting techniques — line breaks, white space, and indentation — make
HTML easier to read and edit.

You can specify these settings in FrontPage and set the font color and size
uniquely for tags, attributes, values, and scripts. You can also specify settings to
keep the format of the original code, or to apply new format settings to pages
you edit.

Insert HTML while working in
Design view
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Place the insertion point where you want to insert HTML code.
Press CTRL+Q and click Insert HTML.
In the Quick Tag Editor, type the HTML that you want.
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Show or hide tags in Design view
1. In Page view, at the bottom of the document window, click Design .
2. On the View menu, click Reveal Tags.
Tip
If you move the pointer over an HTML tag in Design view, Microsoft
FrontPage displays a ScreenTip that shows the entire text of that tag,
including its attributes and values.

Complete text automatically as you
type
1. On the Tools menu, click Page Options, and then click the IntelliSense
tab.
2. Under Auto Insert, specify the settings you want.

Change properties for an individual
HTML tag
1. In Page view, at the bottom of the document window, click Code .
2. Right-click inside the tag, and then click Tag Properties on the shortcut
menu.
Microsoft FrontPage displays the properties dialog box for the HTML tag.
For example, if you click in a table tag, FrontPage displays the Table
Properties dialog box.
Note Properties for some tags might be unavailable in Code view. If the
appropriate property information isn't available, the Modify Style dialog box
will be displayed.
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About working with XML
Extensible Markup Language (XML) is the universal format for data on the
World Wide Web. XML allows developers to easily describe and deliver rich,
structured data in a standard, consistent way. XML does not replace HTML;
rather, it is a complementary format.
By using Microsoft FrontPage, you can view or edit XML files, apply standard
formatting to the structure of code in XML files, view the XML tree, and create
custom displays of XML data on Web pages. For example, you can create a Web
page that displays data from an XML file, format that data by using the
formatting commands on the Formatting toolbar, and apply filtering, sorting,
and conditional formatting to display the data how you want.
When you work with XML files directly, it's important that the files contain well
formed XML. Since the rules governing the syntax of XML tags are stricter than
those for HTML, if an XML file is missing a tag or an attribute, the file will not
render correctly. For this reason, you can use FrontPage to apply XML
formatting rules in files containing XML.
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Apply XML formatting rules
1. In Page view, at the bottom of the document window, click Code .
2. Right-click anywhere on the page.
3. Click Apply XML Formatting Rules.
Important XML formatting rules will apply ending tags in a file even if it is
formatted to exclude them.
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About code snippets
A code snippet is a fragment of code or text that you can define and reuse many
times. Microsoft FrontPage provides several pre-defined code snippets, and you
can also create your own. You can associate a keyword to the code snippet for
quick access and insertion.
Using code snippets can save you time. For example, if you frequently type
blocks of JavaScript, you might start by inserting the following pre-defined code
snippet:
<script language="JavaScript">
<!-//-->
</script>

The preceding example contains start and end tags, HTML comment delimiters
which hide the script from browsers that may erroneously display the code
instead of rendering it, and an empty line in which to type the actual script.
Some additional ideas for code snippets include:
CSS style blocks
Frequently typed content
hexadecimal color values
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Create a code snippet
1. On the Tools menu, click Page Options, and then click the Code Snippets
tab.
2. Click Add.
3. In the Keyword box, type the keyword to associate with the code snippet.
4. In the Description box, type a friendly name for the code snippet.
5. In the Text box, type the content of your code snippet.
6. Click OK.
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Insert a code snippet
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Code .
Place the insertion point where you want to insert the code snippet.
Press CTRL+ENTER.
Type the keyword of the code snippet you want to insert, and then press
ENTER.
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Edit a code snippet
1. On the Tools menu, click Page Options, and then click the Code Snippets
tab.
2. Cick the code snippet you want to edit, and then click Modify.
3. Edit the keyword, description, or content of the code snippet.
4. Click OK.
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Delete a code snippet
1. On the Tools menu, click Page Options, and then click the Code Snippets
tab.
2. Click the code snippet you want to delete.
3. Click Remove.

Turn line numbering on or off for
code
1. On the Tools menu, click Page Options.
2. On the General tab, under Code View Options, select or clear the Line
numbers check box.

Go to a specific line of code
1. In Page view, at the bottom of the document window, click Code .
2. Right-click anywhere on the page, and then click Go To Line on the
shortcut menu.
3. In the Enter line number box, type the line number you want to go to.

Specify color-coding settings for code
1. On the Tools menu, click Page Options.
2. Click the Color Coding tab.
3. For each element you want to specify color-coding settings for, click the
arrow in the color box, and then select the color you want. To specify a
custom color, click More Colors.
Note To reset the color coding to the default settings for Microsoft FrontPage,
click Reset Colors.
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Specify automatic formatting settings
for code
Do one of the following:
Define formatting settings according to the current page
1. On the Tools menu, click Page Options, and then click the Code
Formatting tab.
2. Under Formatting, click Base on current page.
Specify formatting settings for new pages
1. On the Tools menu, click Page Options, and then click the Code
Formatting tab.
2. Under Formatting, select the options you want.
For example, if you want all tags to appear as lowercase instead of
uppercase, select Tag names are lowercase.
3. Under Tags, select the tag attributes you want.
For example, if you want to show only opening paragraph tags (but not
closing paragraph tags), select p, and make sure the Omit end tag check
box is selected.
Important Each tag has unique attributes.
Reset formatting settings for new pages
1. On the Tools menu, click Page Options.
2. Click the Code Formatting tab.
3. Click Reset.
Note When you open a page with existing code, Microsoft FrontPage preserves
the code formatting of that page by default. The FrontPage formatting settings

will be applied only to new content that you add.

About the Quick Tag tools
The Quick Tag Selector and the Quick Tag Editor make it easier for you to select
and edit tags and attributes.
Quick Tag Selector
The Quick Tag Selector is a toolbar at the top of the document window. It is
available in Code, Design, and Split views.
When you place the insertion point anywhere on a page, the Quick Tag Selector
displays a tag selector showing the underlying HTML tag for that area. For
example, if the insertion point is in a table cell, the <td> tag selector appears in
the Quick Tag Selector.
When you move the pointer over the tag selector, an arrow appears on the
selector. You can click this arrow to display the edit and selection options for
that tag. Those options include:
Select Tag Selects the start and end tags and the content of those tags.
Select Tag Contents Selects only the content of the start and end tags.
Remove Tag Removes the start and end tags, but leaves the content of
those tags.
Tag Properties Opens the properties dialog box for the tag.
There are other options on the Quick Tag Selector as well. These options — Edit
Tag, Insert HTML, Wrap Tag — open the Quick Tag Editor.
Quick Tag Editor
By using the Quick Tag Editor, you can quickly edit a tag. You can open the
Quick Tag Editor by clicking the tag selector for a tag in the Quick Tag Selector,
and then clicking any of the following options:
Edit Tag Enables editing of the current tag, including attributes and other
aspects of the tag. You can also use Edit Tag to change the type of tag or to
add additional tags.

Insert HTML Adds HTML to the page.
Wrap Tag Wraps a tag that you specify around an existing tag. The
original tag becomes nested inside the tag you specify.
In addition, IntelliSense features are available in the Quick Tag Editor. For
example, if you type part of a tag, IntelliSense will complete the tag for you if
this feature is enabled.
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Select a tag quickly
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point in the tag you want.
3. At the top of the document window, on the Quick Tag Selector toolbar,
point to the selector for the tag that you want, and then click the arrow next
to that selector.
If the Quick Tag Selector is not visible, click Quick Tag Selector on the
View menu.
4. Do one of the following:
To select the start and end tag and the content of those tags, click
Select Tag.
To select only the content of the start and end tag, click Select Tag
Contents.
Tip
You can also quickly select the start and end tag, and the content of those tags,
while working in Code view. To do so, place the insertion point in the tag, and
then press CTRL+SHIFT+;.

Edit a tag quickly
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point in the tag you want to edit.
3. At the top of the document window, on the Quick Tag Selector toolbar,
point to the selector for the tag that you want, and then click the arrow next
to that selector.
If the Quick Tag Selector is not visible, click Quick Tag Selector on the
View menu.
4. Do one of the following:
To edit the tag, including its attributes, click Edit Tag, and then make
your edits in the Quick Tag Editor.
To open the properties dialog box for the selected tag, click Tag
Properties.

Delete a tag quickly
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point in the tag you want to delete.
3. At the top of the document window, on the Quick Tag Selector toolbar,
point to the selector for the tag that you want, and then click the arrow next
to that selector.
If the Quick Tag Selector is not visible, click Quick Tag Selector on the
View menu.
4. To remove the start and end tag, but leave the content of those tags, click
Remove Tag.
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About working with scripts
Although Microsoft FrontPage contains the Microsoft Script Editor, you can use
script editing tools that enable you to easily create and edit scripts directly in
Code view.
Editing scripts
With IntelliSense, you can easily create or edit scripts in a number of languages,
including ECMAScript as defined by the specification of the European
Computer Manufacturers Association, such as JScript or JavaScript, and Visual
Basic Scripting Edition (VBScript). You can quickly fill in valid variables,
functions, or parameter information.
You can also display line numbers, which makes it easier to identify errors when
you debug your scripts.
Formatting scripts
Script elements, such as script identifiers, keywords, numbers, operators, and
strings are represented in different colors. You can either use the default colors
or specify your own settings.
Script color coding will only occur within a properly closed block of script. If a
script block is opened but not closed, then all text following the opened script
block will use the normal color setting to help you quickly see that a closing tag
is required.
Note FrontPage does not currently support server-side scripting, CGI, ASP.NET,
or Visual Basic .NET.
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About Behaviors
Behaviors in Microsoft FrontPage are scripting options that enable you to
quickly add interactivity or increased functionality to text or other elements of
your Web page.
A Behavior is a combination of an event and an action that you want to occur
when a site visitor interacts with a Web page or an element of a page.
You can customize built-in FrontPage Behaviors by using a task pane.

Events
An event is a condition that causes a Web browser to trigger a script. For
example, moving the pointer over a graphic or clicking a link can trigger an
event.
Event names usually reflect how they are activated. For example, the
onMouseOver event is triggered when the mouse pointer moves over a page
element. Likewise, the onMouseClick event is activated when the user clicks a
page element.

Actions
An action is an instruction that executes when an event occurs. Actions are
functions — prewritten blocks of script code — that perform a specific task,
such as swapping an image or opening a browser window.
After you attach a script to a page element (using the Behaviors task pane), the
browser "calls" the action that is triggered by the event.
Each action requires a set of properties and parameters in order to do a task. In
FrontPage, you can view or edit the properties for each action using the
Behaviors task pane.
Note Most Behaviors work with Microsoft Internet Explorer 4.0 or later, and
Netscape Navigator 4.0 or later. Some Behaviors, such as Check Plug-in,

Change Property, and Control Flash, require Internet Explorer 5 or later, and
Netscape Navigator 6.0 or later.

Define a Behavior for an element
1. In Page view, at the bottom of the document window, click Design .
2. On the Format menu, click Behaviors.
3. On the page, select the page element — for example, text or a
graphic — you want to work with.
4. In the Behaviors task pane, click Insert, and then click the action you
want.
5. In the dialog box that appears, select the options you want, and then click
OK.
6. To select the event, under Events, click the default event, and then click the
event you want.
7. Depending on the action you choose, select any additional options that
define the event for the action.
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About IntelliSense
IntelliSense refers to the Code view functionality that provides auto-completion
of commands, as well as context-sensitive lists that contain code and scripting
elements.
For example, when you type the HTML delimiter <, you can have IntelliSense
automatically display a list of tags.
With IntelliSense, you can edit scripts in a number of languages, including
ECMAScript as defined by the specification of the European Computer
Manufacturers Association, such as JScript or JavaScript, and Visual Basic
Scripting Edition (VBScript). You can quickly fill in valid variables, functions,
or parameter information. IntelliSense also provides context-sensitive lists for
HTML tags and attributes.
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Turn IntelliSense options on or off
Do one of the following:
Show or hide the IntelliSense list
1. In Page view, at the bottom of the document window, click Code .
2. Place the insertion point where you want to add code by using the
IntelliSense list.
Type some of the code you want to add, and then press CTRL+L.
A list appears with appropriate choices for the context. For example, if the
insertion point is after <script language= Microsoft FrontPage displays a
list of the script languages you can use.
3. If you want to hide the IntelliSense list, press ESC.
Show or hide the IntelliSense list automatically
1. On the Tools menu, click Page Options, and then click the IntelliSense
tab.
2. Under Auto Popup, do one or more of the following:
To specify whether you want FrontPage to display a list of tags or
attributes after you begin typing, select or clear the HTML statement
completion check box.
To specify whether you want FrontPage to display a list of variables or
function names after you begin typing, select or clear the Scripting
statement completion check box.
To specify whether you want FrontPage to display the declaration for a
function after you begin typing, select or clear the Script parameter
information check box.
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IntelliSense options
IntelliSense provides an array of coding options in Code view.
Microsoft FrontPage provides the following IntelliSense commands, which you
can set to appear automatically:
Option

Description
Simplifies the completion of HTML statements and script
statements.

List
For example, typing an object and a scope operator (such as
Members window.) displays a list of appropriate elements (such as the event
open), enabling you to complete the string:
window.open

Simplifies the determination of the correct parameters to add to the
script.
For example, after window.open, you can type an opening
parenthesis:

Parameter
Info
window.open(

A list of appropriate parameters appears, guiding you in the choices
you have for completing the string:
window.open([url],[name],[features],[replace])

Simplifies the completion of code as you type.
For example, you can type part of a start tag:
<tab

Complete

Word

By pressing CTRL+SPACE, the rest of the tag appears:
<table

The closing tag delimiter is not added, so you can continue to add
tag attributes.
Simplifies the insertion of code snippets as you type.
View
Code
Snippets

For example, to begin writing a script, you could invoke the script
block, which is a standard code snippet:
<script language="JavaScript">
<!-//-->
</script>
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About adding Flash-based content
Macromedia Flash is a vector graphic animation technology. Web developers use
Flash to produce movies, animation, presentations, and more. Flash-based
content works on cross-platform browsers, which means that site visitors can
play it by using almost any Web browser, such as Microsoft Internet Explorer or
Netscape Navigator.
You can add Flash-based content to enhance and update your Web site. You can
add multiple types of Flash-based content, such as short movie strips, repetitive
audio-enhanced animations, previously-recorded educational presentations or
courses, and more.
You can embed Flash-based content directly in a Web page, so that it downloads
automatically when a site visitor opens the page. You can also add a link in your
Web page to the location of Flash-based content. This enables site visitors to
decide whether or not they want to download it.
In Microsoft FrontPage, you can set options to scale and align Flash-based
content and set background colors for it. Additionally, you can set options for
automatic playback, such as playing a short animation once when the site visitor
first loads the page or looping the content to play continuously.
Note You must have the Macromedia Flash Player plug-in installed in order to
preview the Flash-based content you add. Additionally, site visitors must have it
installed in order to play such content.

Add Flash-based content
1. In Page view, at the bottom of the document window, click Design .
2. On the Insert menu, point to Picture, and then click Movie in Flash
Format.
3. Locate and click the Macromedia Flash file, and then click Insert.
Notes
To view the animated content, in Page view, at the bottom of the document
window, click Preview .
You can also add Flash-based content by dragging a file to your Web page
from either the Folder List in Microsoft FrontPage or Microsoft Windows
Explorer.
You can also link to a Flash file by adding a hyperlink in your Web page.
To view Flash-based content, site visitors must have the Macromedia Flash
Player installed.

Set properties for Flash-based content
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the Macromedia Flash-based content, and then click Movie in
Flash Format Properties on the shortcut menu.
3. Set the properties that you want.

Delete Flash-based content
1. In Page view, at the bottom of the document window, click Design .
2. Click the Macromedia Flash-based content, and then press DELETE.

About adding sounds
Sounds can add another dimension to your Microsoft FrontPage Web site. For
example, if your company has an audio jingle, you can add it to the home page
of your Web site and configure it to play when a site visitor browses to it.
With FrontPage, you can embed an audio file and set properties to play when site
visitors open the page. You can set the properties to play the sound file
continuously, or to play it a specified number of times. Another way to add
sound to your Web page is to provide a hyperlink to the audio file from your
page and let site visitors decide if they want to play the sound. When site visitors
click that link, the appropriate audio player opens and plays the sound file.
You can add many types of audio file to your Web page, including the following:
Wave files (*.wav)
Midi sequencer files (*.mid)
RealAudio files (*.ram; *.ra)
AIFF sound files (*.aif; *.aifc; *.aiff)
AU sound files (*.au; *.snd)
Moving Picture Experts Group (*.mpeg), MPEG Audio-Layer 3 files
(*.mp3)
Microsoft Active Streaming files (.*asf)

Add a sound
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the page, and then click Page Properties on the shortcut menu.
3. On the General tab, under Background sound, locate and click the sound
file you want, and then click Open.
4. Do one of the following:
To play the sound continuously, select the Forever check box.
To play the sound a fixed number of times, clear the Forever check
box, and then select or type the number of times you want the sound to
play in the Loop box.
Note This feature is not supported by all Web browsers.

Delete a sound
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the page, and then click Page Properties on the shortcut menu.
3. On the General tab, under Background sound, delete the text in the
Location box.
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About adding video
You can make your Web site more dynamic by adding video to it. By using
Microsoft FrontPage, you can embed a video directly in a Web page so that it
downloads automatically when a site visitor opens the page. You can also add a
link in your Web page to the location of a video file. This enables site visitors to
decide whether or not they want to download it. You can also use FrontPage to
set options for video playback. For example, you can play the video once when
the site visitor first opens the page, loop the video and play it continuously, or
only play the video when a site visitor rests the pointer over a link.
Before you add a video, you should consider the issue of bandwidth. It is
considered good practice to inform your site visitors of the size of a video file.
Additionally, when you add video to a Web page, make sure the video is in a
format that site visitors can play back with most video players.
Some of the most popular video file formats that you can embed or link to are:
Windows Video files (*.avi) Audio and video files for use with Microsoft
Windows Media Player.
Windows Media files (*.asf) Streaming file format for use with Windows
Media Player. This file format can also include audio, scripts, ActiveX
controls, and HTML documents.
RealAudio files (*.ram; *.ra) Streaming file format for use with
RealNetworks RealAudio Player. Provides optimization for low- to
medium-speed connections.
Moving Picture Experts Group (*.mpeg) This family of standards is
used for coding audio-visual information — movies, video, music in a
digitally compressed format. MPEG files are generally much smaller than
most video formats, but provide the same quality.
Apple QuickTime (*.mov; *.qt) QuickTime is technology that is built
into the Apple Macintosh operating system and is used by most Macintosh
applications that include video or animation. Microsoft Windows-based
computers can also play files in QuickTime format, but they require a
special QuickTime plug-in.

Add a video
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Position the insertion point where you want to insert a video.
On the Insert menu, point to Picture, and then click Video.
Locate and click the video file, and then click Open.

Notes
To view the video, in Page view, at the bottom of the document window,
click Preview .
Some Web browsers do not support video.

Set playback options for a video
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the video, and then click Picture Properties on the shortcut
menu.
3. Do one or more of the following:
To play the video whenever the page loads, under Repeat, click On
file open.
To play the video whenever a site visitor moves the pointer device
over the video, under Repeat, click On mouse over.
To specify the number of times you want the video to play, under
Start, type a number in the Loop box, or select the Forever check box
for continuous play.
To set a delay between playbacks, under Start, type or select the delay
time in the Loop delay box.
Note To view the video, in Page view, at the bottom of the document window,
click Preview .

Delete a video
1. In Page view, at the bottom of the document window, click Design .
2. Click the video, and then press DELETE.
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About creating a Web site
A Web site is a group of related Web pages that is hosted by an HTTP server on
the World Wide Web. Most Web sites provide a home page to site visitors as a
starting point. The home page is interconnected with other pages by using
hyperlinks and a navigational structure.
You can create a Web site that is either disk-based or server-based. A disk-based
Web site is one that is hosted on a local computer. A server-based Web site is
hosted by a Web server, such as Microsoft Internet Information Server (IIS), or a
virtual server network.
To help you create a Web site more quickly, you can use the Microsoft
FrontPage templates and wizards. When you use one of these tools, FrontPage
does most of the structural work for you, leaving you free to concentrate on the
content of the site. You can use templates and wizards to help you create
anything from a bare bones Web page to a complex, multi-page, interactive Web
site.
The basic steps for creating a FrontPage Web site, include the following:
1. Obtain a Web site hosting account or URL from a hosting service, such as
an Internet service provider (ISP) or a Web Presence Provider (WPP).
2. Create your Web site structure using the templates and wizards.
3. Add your own personalized content.
4. Publish your Web site to the public on the World Wide Web.
With administrator permissions, a Web site hosting account, and connectivity to
a server running Microsoft Windows SharePoint Services, you can create a
SharePoint site and then customize it using Microsoft FrontPage.
A Web site can contain one or more subsites. A subsite is a Web site that is
nested inside another Web site. A Web site that contains subsites is called a toplevel site. If you think of a Web site as a directory containing a set of folders, a
subsite is a subfolder containing a stand-alone Web site.
Subsites have independent administration, authoring, and browsing permissions.

Therefore, you can display restricted information or information that is pertinent
to only one group of site visitors on a subsite.
You can convert folders under a top-level Web site to subsites. Likewise, you can
convert a subsite to a subfolder. However, many of the Web site settings can be
lost during this process, including, but not limited to hyperlinks in navigation
bars and tasks associated with these pages. These features are lost because the
navigation structure and tasks are stored per Web site. Additionally, the larger
the contents of the Web site, the longer it takes to convert the Web site to a
subfolder or a subfolder to a Web site.

Create a Web site
1. On the File menu, click New.
2. In the New task pane, under New Web site, click the type of Web site that
you want to create.
3. Click the Web site template that you want.
4. Locate and click the location where you want to publish your site, and then
click Open.
Notes
You can either publish your site to a local directory or folder on your
hard disk or network, or publish it to the Internet where your account
is located.
If you create a SharePoint site, you must publish it to a server running
Microsoft SharePoint Services.
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Create a subsite
Do one of the following:
Convert an existing folder into a subsite
1. In the Folder List, right-click the folder that you want to create a subsite in,
point to New, and then click Subsite.
2. Click the Web site template that you want.
3. Under Options, select the Add to current Web site check box.
Create a new subsite by using a template
1. On the File menu, click New.
2. In the New task pane, under New Web site, click the type of Web site that
you want to create.
3. Click the Web site template that you want.
4. Under Options, select the Add to current Web site check box.
Notes
You can either publish your site to a local directory or folder on your hard
disk or network, or publish it to the Internet where your account is located.
If you create a SharePoint site, you must publish it to a server running
Microsoft SharePoint Services.

Open a Web site
1. On the File menu, click Open Site.
2. In the Look In box, locate and click the Web site that you want to open.
3. Click Open.
Note If you already have a Web site open, each subsequent Web site will open
in a new Microsoft FrontPage window.

Rename a Web site
1. On the Tools menu, click Site Settings.
2. Click the General tab.
3. In the Web name box, type a new name for the Web site.
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Import a Web site, folder, or file
1. Open the Web site that you want to import a Web site, folder, or file into.
2. On the File menu, click Import.
3. Do one of the following:
Import a file from your local computer or network
1. Click Add File.
2. Locate and click the file that you want to import, and then click Open.
3. To import additional files, repeat steps 1 and 2.
Import a folder from your local computer or network
1. Click Add folder.
2. Locate and click the folder that you want to import, and then click
Open.
Import a Web site from a Web server
1. Click From Site.
2. Click HTTP.
3. Locate and click the starting page of the Web site that you want to
import, and then click Open.
The starting page can be any page in the Web site, not just the home
page.
4. To import a Web site that uses Secure Sockets Layer (SSL) for
encrypted transactions, select the Encrypted connection required
(SSL) check box.
5. To finish importing a Web site, click Next, and then follow the
instructions in the Import Web Site Wizard.
Note If you import a disk-based Web site into another disk-based Web site,
Microsoft FrontPage only adds the files and folders to the site. It does not

import the file or folder as a new subsite.
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About page banners
By using a page banner, you can quickly add titles to your Web pages. If you
have applied a theme to the active page, page banners use the same styles and
graphics as the theme. Otherwise, the page banner just displays text, which you
can format.
Before you can use page banners, you must set up your Web site's navigation
structure in Navigation view. A page banner is not visible on a page unless the
page is included in the navigation structure. Page banners use the page titles
from Navigation view; if you change this title for a page, its page banner label
will also change.
After you add a page banner to a page, you can change the text that is displayed
on it, and you can specify whether to display a graphic or just text. The page
banner picture that is displayed is the banner that is associated with the theme for
that particular page.

Delete a page banner
1. In Page view, at the bottom of the document window, click Design .
2. Click the page banner, and then press DELETE.
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About page templates
A page template is a pre-designed page that can contain page settings,
formatting, and page elements. Microsoft FrontPage provides several default
page templates, or you can create your own, so that you can create pages for
your Web site quickly and consistently. Templates are very useful in a multipleauthor environment because they help authors create pages the same way. For
example, if all your pages always have a company logo and description at the
top of the page, you can create a template with those elements. You could then
use your template when you create a new page, and the logo and description will
automatically display on the page.
When you create a page template, a copy of the template is stored on the hard
drive of every Web site author who opens that Web site.
If you work in a multiple authoring environment, you can create your own
custom templates and share them with other authors working on the same Web
site. Anyone who opens the Web site can then create new pages based on your
shared templates, which are listed along with the default templates. For example,
you might want all of the pages in a Web site to link to a specific cascading style
sheet. You could create a template containing a link to the style sheet, and then
share that template with anyone working on the Web site. Instead of adding style
sheet links manually to new pages, you can create new pages that already
contain the links just by using the shared template.
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Create a Web page template
Some of the content in this topic may not be applicable to some languages.
1. On the File menu, click New.
2. In the New task pane, under New page, do one of the following:
To create a Web page template from a blank page, click Blank page.
To create a Web page template from an existing page, click From
existing page, locate and click the file for the page, and then click
Create new.
To create a Web page template by changing an existing template, click
More page templates, click the tab containing the template you want,
and then double-click the template.
3. Change the page to include the settings and elements that you want in the
template.
4. On the File menu, click Save As.
5. In the Save as type list, click FrontPage Template.

About Dynamic Web Templates
By using Dynamic Web Templates, you can create HTML pages that share the
same layout. In addition to providing a shared layout, you can make some
regions in a template available for editing while preventing changes to other
regions in that template. This means that you can allow others to add and edit
content, yet still preserve the layout of the pages and the template itself.
You can use any number of Dynamic Web Templates in a Web site and you can
attach a Dynamic Web Template to as many pages as you like. You can also save
Dynamic Web Template (.dwt) files to any location. If you choose to detach a
Dynamic Web Template from one or more pages in a site, you do not remove the
content from those pages. You remove only the formatting provided by the
template.
In earlier versions of Microsoft FrontPage, you might have used shared borders
to create a region on a Web page that was common to one or more pages in a
Web site. You can now use Dynamic Web Templates instead. Unlike shared
borders, pages that are attached to Dynamic Web Templates share an entire
layout, and they offer much more control over which parts of your pages are
available for editing.

Add editable regions to a Dynamic
Web Template
1. Open the Dynamic Web Template (.dwt) file.
2. In Page view, at the bottom of the document window, click Design .
3. Select only the areas in the template where you want to allow other Web
authors to edit the attached Web page(s).
4. Right-click a selection, and then click Manage Editable Regions.
5. In the Region name box, type a name for the editable region. For example:
Header, Body, or Footer.
6. Click Add.
7. Repeat steps 2 through 6 for each new editable region you want to add, and
then click Close.
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Attach a Dynamic Web Template
Do one of the following:
Attach a Dynamic Web Template
1. Open the Web page you want to attach a Dynamic Web Template to.
To attach the Dynamic Web Template to more than one page, select the
pages you want.
How?
In the Folder List, hold down CTRL and click each page you want.
If the Folder List is hidden, click Folder List on the View menu.
2. On the Format menu, point to Dynamic Web Template, and then click
Attach Dynamic Web Template.
3. Locate and click the Dynamic Web Template you want to attach, and then
click Open.
If the body of a selected Web page contains content, the Choose Editable
Regions for Content dialog box appears. The dialog box displays the
default settings for mapping content from the body of the Web page to
editable regions specified by the Dynamic Web Template. The Old column
lists content in the body of the Web page. The New column lists editable
regions specified by the template.
In the Choose Editable Regions for Content dialog box, do one of the
following:
To move all of the content in the body of the Web page to the default
editable region, click OK. If the default editable region contains
content, that content is replaced with the content in the Web page.
To move all of the content in the body of the Web page to a specific
editable region, click (Body), and then click Modify. In the New

Region list, click the editable region you want to move the content to.
If you click (none), the content is removed from the Web page.
To maintain all of the content and structure of the Web page, click
Skip Current Page. The template is not attached to the page.
Attach a different Dynamic Web Template
1. Open the Web page you want to attach a different Dynamic Web Template
to.
To attach the Dynamic Web Template to more than one page, select the
pages you want.
How?
In the Folder List, hold down CTRL and click each page you want.
If the Folder List is hidden, click Folder List on the View menu.
2. On the Format menu, point to Dynamic Web Template, and then click
Attach Dynamic Web Template.
3. Locate and click the Dynamic Web Template you want to attach, and then
click Open.
If the selected Web page contains editable regions specified by the Dynamic
Web Template previously attached to it, the Choose Editable Regions for
Content dialog box appears. The dialog box displays the default settings
for mapping content from the editable regions specified by the previous
template to editable regions specified by the new template. The Old column
lists editable regions specified by the previous template. The New column
lists editable regions specified by the new template.
In the Choose Editable Regions for Content dialog box, do one of the
following:
To move all of the content in the body of the Web page to the default
editable region, click OK. If the default editable region contains
content, that content is replaced with the content in the page.
To move content from an editable region specified by the previous

template to a specific editable region specified by the new template,
click the region in the Old column, and then click Modify. In the New
Region list, click the editable region you want to move the content to.
If the editable region in the new template contains content, that content
is replaced with the content in the page.
To maintain all of the content and structure of the Web page, click
Skip Current Page. The template is not attached to the page.

Create a Dynamic Web Template
1. Create or open an HTML document.
2. On the File menu, click Save As.
3. In the Save as type list, click Dynamic Web Template, and then click
Save.
4. Create the basic contents and structure of the template in the *.dwt file, and
then click Save.

Detach files from a Dynamic Web
Template
1. In the Folder List, select the file(s) that you want to detach from the
Dynamic Web Template.
To select multiple files, press CTRL and hold, and then click the files that
you want to detach.
2. On the Format menu, point to Dynamic Web Template, and then click
Detach from Dynamic Web Template.
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Manually update attached Web pages
Important If there is a conflict among the Dynamic Web Template and
attached pages, when you attempt to update the attached pages, Microsoft
FrontPage will prompt you to resolve the conflict.
Update Web pages from within the attached Dynamic Web Template
With the Dynamic Web Template open, on the Format menu, point to
Dynamic Web Template, and then click one of the following:
Update All Pages
Update Attached Pages
Update a selected page in the Folder List
1. In the Folder List, click the page that you want to update.
2. On the Format menu, point to Dynamic Web Template, and then click
Update Selected Page.

Open a Dynamic Web Template from
within an attached page
In the Folder List, double-click the Dynamic Web Template file (with the
.dwt file name extension) that you want.
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Rename or Remove the editable
regions of a Dynamic Web Template
1. Open the Dynamic Web Template (*.dwt) file.
2. In the document window, right-click the editable region that you want to
rename or remove, and then click Manage Editable Regions.
You can identify editable regions by the boxed areas on the page that
include a tab containing the name of each region.
3.

Rename an editable region
In the Region name box, type the new name, click Rename, and then
click Close.
Remove an editable region

Click Remove, and then click Close.
4. On the File menu, click Save.
5. Click Yes.
Note If the Dynamic Web Template that you edited hosts attached files,
Microsoft FrontPage will prompt you to update those files.

Edit a shared border
This procedure applies to shared borders that you created by using an earlier
version of Microsoft FrontPage.
1. Open a page that uses the shared border you want to edit.
2. In Page view, at the bottom of the document window, click Design .
3. Click inside the shared border region, which is outlined with a dashed line.
When you click the area, the outline changes to a solid line.
4. Make your changes to the content inside the shared border region. For
example, type or delete text, or add a picture.
5. Click Save . Your changes will appear on all pages that share the border.

About authoring modes
Authoring modes enable you to turn support on or off for groups of features or
for one feature at a time.
By using authoring modes in Microsoft FrontPage, you can design your Web
pages for compatibility with specific browsers and technologies, as well as
control the types of code that are added to your pages.
By designing your pages for browser compatibility, you can help ensure that
your site visitors have a better experience browsing your Web site. By having
control over the types of code that FrontPage adds to your pages, you can edit
your pages more easily in Code view.
When you choose an authoring mode, the authoring mode appears in the lower
right portion of the status bar. It is important to note the authoring mode you are
using, because some FrontPage features are unavailable in specific authoring
modes.
Note If you choose a specific authoring mode, menu commands that are not
supported will be unavailable as long as you are in that authoring mode.

About optimizing code
By using the code optimization settings in Microsoft FrontPage, you can reduce
the amount of non-standard HTML or other code in your Web pages. This can
make it easier to edit pages in Code view. It can also help you reduce the file
sizes of your pages and help site visitors open your pages more quickly.
You can optimize your code when you author your pages, when you publish
them to your Web site, or both. If you choose to optimize your code when
authoring your Web pages, FrontPage removes specific types of code from those
pages when you edit them. For example, if you open a Web page you created by
using Microsoft Word, FrontPage removes Word-specific code from that page.
If you choose to optimize your code when publishing your Web pages,
FrontPage removes specific types of code from those pages only when you
publish them to your remote Web site. It maintains that code in the pages on the
local site. This means that you can continue to see the code when you're editing
the pages in the local site, but you and your site visitors cannot see the code in
copies of the pages on the remote site.
You can enable FrontPage to remove these types of code:
Style information generated by Microsoft Word
Vector Markup Language (VML) graphics generated by the Microsoft
Office Drawing Tools
Meta tags added by other programs, including Generator and ProgID tags
Cell formatting attributes
Tracing image attributes
Comments for scripts, Dynamic Web Templates, or HTML
HTML tags that do not contain content
HTML leading white space or all HTML white space
In addition, you can enable FrontPage to merge tags applied to adjacent page
elements. For example, if you encounter side-by-side <b> tags in code, such as
<b>Example </b><b>1</b>, you can have FrontPage remove the redundant
adjacent tags, resulting in the cleaner code <b>Example 1</b>.

Some code optimization settings are designed specifically for authoring Web
pages, while others are designed specifically for publishing pages. Therefore,
some settings may not be available for both authoring and publishing pages.

Specify authoring mode settings
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. In the FrontPage and SharePoint technologies list, select the authoring
mode you want.
Note When you turn on support for author-time Web components, support for
link bars and shared borders is not automatically turned on as well. To turn
support on or off for link bars or shared borders, select or clear the Navigation
or Shared Borders check box.

Turn settings on or off for optimizing
HTML
1. In Page view, at the bottom of the document window, click Design .
2. On the Tools menu, click Optimize HTML.
3. Select the settings that you want.
Note If you select the All HTML comments check box or the Dynamic Web
Templates comments check box, Microsoft FrontPage removes any dynamic
Web template code for that page when you optimize HTML. Therefore, any
content the page shares with the dynamic Web template will no longer be visible
to site visitors.

Turn settings on or off for optimizing
published HTML
Before you can optimize HTML when publishing a page, you must set up a
remote Web site.
1. In Remote Web Site view, on the Web Site tab, click Optimize Published
HTML.
2. On the Optimize HTML tab, select When publishing, optimize HTML
by removing the following elements.
3. Select the settings that you want.
Notes
Microsoft FrontPage does not apply these settings to Web pages that you
have already published to your Web site. To apply the settings to a page,
publish that page to your site.
You can optimize HTML when you publish from the local Web site to the
remote site, but not from the remote site to the local site.
If you select the All HTML comments check box or the Dynamic Web
Templates comments check box, FrontPage removes any dynamic Web
template code for that page when you optimize HTML. Therefore, any
content the page shares with the dynamic Web template will no longer be
visible to site visitors.
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Turn support for frames on or off
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. To turn support for frames on or off, select or clear the Frames check box.

Turn support on or off for features
that require FrontPage Server
Extensions
If your Web site is located on a server running FrontPage Server Extensions
from Microsoft, you can turn support on or off for features that are compatible
with your Web server:
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. Select or clear the Browse-time Web Components check box.
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Turn support for VML graphics on or
off
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. To turn support for Vector Markup Language (VML) on or off, select or
clear the VML graphics (Office drawing) check box.
Note When you turn on support for VML graphics, support for downlevel
image files— graphic formats that are compatible with browsers that do not
support VML— is automatically turned on as well. To turn support for
downlevel image files on or off, select or clear the Downlevel image file check
box.

Turn support for Active Server Pages
on or off
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. Select or clear the Active Server Pages check box.
Note If you turn off support for Active Server Pages, some menu commands
may be unavailable, and you may be unable to edit some Web pages.
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Turn support for ActiveX controls on
or off
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. To turn support for ActiveX controls on or off, select or clear the ActiveX
controls check box.
Note If you specify browser compatibility settings that favor Netscape
Navigator, ActiveX controls are disabled by default. If you override the default
and enable ActiveX controls, your Web site might not be displayed properly, or
it might contain errors.
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Turn support for Java applets on or
off
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. To turn support for Java applets on or off, select or clear the Java applets
check box.
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Turn support for scripts on or off
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. Do one of the following:
To turn support for Microsoft Visual Basic Scripting Edition
(VBScript) on or off, select or clear the VBScript check box.
To turn support on or off for ECMAScript as defined by the
specification of the European Computer Manufacturers Association,
such as JScript or JavaScript, select or clear the JavaScript/JScript
check box.
Note If you specify in the Browsers list that your Web site should be
compatible with Netscape Navigator only (and select any browser version), or
Both Internet Explorer and Navigator, support for VBScript is turned off by
default. If you select VBScript anyway, your site visitors might encounter script
errors.

Turn support for program-specific
meta tags on or off
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. Select or clear the Generator and ProgID tags check box.
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Turn support for shared borders on
or off
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. To turn support for shared borders on or off, select or clear the Shared
Borders check box.
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About hyperlinks
A hyperlink is a link from one Web page or file to another, including a picture or
multimedia file, or to an e-mail address or program. When a site visitor clicks
the hyperlink, the destination is displayed in a Web browser, opened, or ran,
depending on the type of the destination.
For example, a hyperlink to a page displays the page in the Web browser, and a
hyperlink to an Audio Video Interleave (AVI) file opens the file in a media
player.
Ways to use hyperlinks
To navigate to a file or Web page on a network, intranet, or Internet
To navigate to a file or Web page that you plan to create in the future
To designate a picture as a hyperlink to a destination
To send an e-mail message
To start a file transfer, such as downloading a file or sending a file by FTP
To go to a bookmark
After you create a hyperlink, follow it to verify that it goes to the destination
page, file, e-mail address, program, or bookmark you intended. When a site
visitor points to text or a picture that contains a hyperlink, the pointer depicts a
hand , indicating that the user can click the item. Microsoft FrontPage follows
hyperlinks and displays them in different ways depending on the destination:
The destination is a Web page FrontPage opens the page for editing in
Page view.
The destination is a bookmark FrontPage opens the page and scrolls
down to the bookmark.
The destination is a file FrontPage opens the file in its associate editor.
For example, FrontPage opens a text file in Notepad.
The destination is not in the current Web site FrontPage opens a copy
of the destination Web page or file.

How URLs work
When you create a hyperlink, its destination is encoded as a Uniform Resource
Locator (URL) .
A URL is an address that specifies a protocol (such as HTTP or FTP), and it
contains a Web server or network location, path, and file name, as shown in the
following table:
Example
Description
http://
Protocol
www.example.com Web server
office/productinfo/ Path
default.htm
File name

Absolute and relative URLS
An absolute URL contains a full address, including the protocol, the Web
server, the path, and the file name.
A relative URL has one or more missing parts of the address. The missing
information is taken from the page that contains the URL. For example, if
the protocol and Web server are missing, the Web browser uses the protocol
and domain of the current page.
It is common for pages in a Web site to use relative URLs that contain only a
partial path and file name. If the files are moved to another server, any
hyperlinks will continue to work as long as the relative positions of the pages
remain unchanged. For example, a hyperlink on Products.htm points to a page
named Apple.htm in a folder named Food; if both pages are moved to a folder
named Food on a different server, the URL in the hyperlink will still be correct.
Using text or pictures as hyperlinks
You can create a hyperlink to be text or a picture.
A text hyperlink is a word or phrase that you assign a destination URL.
A picture hyperlink is a picture that you assign a destination URL in one of two
ways:

You can allocate the entire picture to be a default hyperlink. In this case, the
site visitor can click any part of the picture to display its destination. For
example, a button is a picture with a default hyperlink.
You can assign the picture to one or more hotspots, which are hyperlink
regions on the picture. A picture that contains hotspots is called an image
map. For example, an image map can be a picture that represents different
parts of a Web site (such as the home page, a catalog page, and so on). The
site visitor clicks a certain area of the image map to display the
corresponding page.
How hyperlinks are displayed
Web browsers usually underline text hyperlinks and display them in a different
color. For example, this is how a hyperlink might look.
Hyperlinks on a picture are not always visible. However, a site visitor can tell
that a picture has a hyperlink by positioning the mouse pointer over it. The
mouse pointer changes appearance, usually to a pointing hand . For example,
position your mouse pointer over the following button:

To emphasize a hyperlink even more, you can also add Dynamic HTML
(DHTML) effects or animation to hyperlinks, as shown in the following
illustration:

A hyperlink should also provide a visual cue about where it leads; for example,
you could use the hyperlinks below to lead to a Web site's home page:
Home Page

Setting colors for hyperlinks
You can choose the colors that a Web browser will use for displaying hyperlinks.
If you use standard HTML attributes, you can select three colors to use for a

hyperlink, depending on its status:
Hyperlink A hyperlink that has not been selected
Active hyperlink A hyperlink that is currently selected
Visited hyperlink A hyperlink that has already been followed
Note If you use Cascading Style Sheets (CSS), you can also control the color
the hyperlink shows when the site visitor rests the pointer over it. CSS can also
add other attributes to your hyperlinks. See the FrontPage Styles topics for more
information.
Using bookmarks
A bookmark is a location or selected text on a page that you have marked.
You can use bookmarks as a destination for a hyperlink. For example, if you
want to display a certain section of a page to the site visitor, add a hyperlink with
the bookmark as its destination. When the site visitor clicks the hyperlink, the
relevant part of the page is displayed rather than the top of the page.
You can also use one or more bookmarks to find locations on a page. For
example, add a bookmark to each main heading on a page. When you are editing
the page, you can quickly find each section by going to the corresponding
bookmark.
If you bookmark a location (rather than text), the bookmark is indicated in
FrontPage by . If you bookmark text, the text displays with a dashed underline.
Managing hyperlinks

Renaming and moving files in your Web site
When you rename a file in your Web site, Microsoft FrontPage checks to see
whether there are any hyperlinks to the file. If there are, FrontPage updates the
hyperlinks with the new file name. When you move a file in your Web site (for
example, to a folder or subfolder), FrontPage automatically updates any
hyperlinks to that file with its new location.

Testing and repairing broken hyperlinks
Before you publish a Web site, you should always test all hyperlinks. If your
Web site contains a broken hyperlink (one that has an invalid destination URL),
when the site visitor clicks the hyperlink the Web browser displays an error
message. The cause might be as simple as a mistyped URL or a URL that points
to a page that you deleted from your Web site. If the destination is another page
on the World Wide Web, the page might have been moved or deleted.

Show All

Create a hyperlink
In Page view, at the bottom of the document window, click Design , and
then do one of the following:
Create a hyperlink to an existing page or file
1. Select the text or the picture that you want to use as the hyperlink.
If you do not select text or a picture, the destination URL is displayed as the
hyperlink text.
2. On the Standard toolbar, click Insert Hyperlink
3. Under Link to, click Existing File or Web Page.
4. Select the page or file you want to use as a destination.

.

Create a hyperlink to a new page
1. Select the text or the picture that you want to use as the hyperlink.
If you do not select text or a picture, the destination URL is displayed as the
hyperlink text.
2. On the Standard toolbar, click Insert Hyperlink
3. Under Link to, click Create New Document.

.

4. In the Name of new document box, type the name of the file you want to
create and link to.
If you want to create a document in a different location, under Full Path,
click Change, browse to the location where you want to create the file, and
then click OK.
5. Under When to edit, specify whether you want to edit the file now or later.
Create a hyperlink to a page or file on the World Wide Web

1. Select the text or the picture that you want to use as the hyperlink.
If you do not select text or a picture, the destination URL is displayed as the
hyperlink text.
2. On the Standard toolbar, click Insert Hyperlink
.
3. Under Link to, click Existing File or Web Page, and then click Browse
the Web .
4. In your Web browser, browse to the page that you want to link to, and then
press ALT+TAB to switch back to Microsoft FrontPage. The location of the
page you visited is displayed in the Address box.
Create a hyperlink to an e-mail address
1. Select the text or the picture that you want to use as the hyperlink.
If you do not select text or a picture, the destination URL is displayed as the
hyperlink text.
2. On the Standard toolbar, click Insert Hyperlink
.
3. Under Link to, click E-mail Address.
4. Type the e-mail address you want in the E-mail address box, or select an email address in the Recently used e-mail addresses box.
5. In the Subject box, type the subject of the e-mail message.
Note Some Web browsers and e-mail programs may not recognize the
subject line.
Create a hyperlink to a bookmark
1. Select the text or the picture that you want to use as the hyperlink.
If you do not select text or a picture, the destination URL is displayed as the
hyperlink text.
2. On the Standard toolbar, click Insert Hyperlink
.
3. Under Link to, click Existing File or Web Page.
4. Select the page that contains the bookmark, and then click Bookmark.

5. Under Select an existing place in the document, click the bookmark you
want to use as the destination, and then click OK.
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Edit a hyperlink
Change the text of a hyperlink
1. In Page view, at the bottom of the document window, click Design .
2. Select the hyperlink text, and type the new text.
Change the destination of a hyperlink
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the hyperlink, and click Hyperlink Properties on the shortcut
menu.
3. In the Address box, enter the hyperlink destination you want.
Change the target frame
1. In Page view, at the bottom of the document window, click Design .
2. Select the text or picture that you are using as a hyperlink, and then click
Insert Hyperlink .
3. In the Edit Hyperlink dialog box, click Target Frame, and then do one of
the following:
Choose a target frame within your frames page
In the Target Frame dialog box, the Current frames page area shows
a map of your frames page. Click in the frame you would like to set as
the target frame.
Choose a target frame either within your frames page or outside of it
In the Target Frame dialog box, the Common targets area gives you
several target frame options. Click one of the options to select a target
frame.

Show All

Add font effects to a hyperlink
You can add effects to hyperlinks so that when a site visitor positions the pointer
over the hyperlink, its font changes. For example, you can set the hyperlink to
change to a larger, bold, red font. However, when you set font effects, you set
them for all hyperlinks on the page, rather than for individual hyperlinks.
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the page, click Page Properties on the shortcut menu, and then
click the Advanced tab.
3. Under Styles, select the Enable hyperlink rollover effects check box.
4. Click Rollover Style.
5. Set the rollover properties for hyperlinks on the current page.
Notes
You cannot add effects to a hyperlink if the page uses a theme.
Hyperlink rollover styles use Dynamic HTML (DHTML), so some Web
browsers may not support this feature.
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Set hyperlink colors
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Right-click the page, and then click Page Properties on the shortcut menu.
Click the Formatting tab.
Under Colors, in the Hyperlink, Visited hyperlink, and Active hyperlink
boxes, select the colors you want to use.

Note If the page uses a theme, some of these settings may not be available.

Set the ScreenTip for a hyperlink
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Select the hyperlink, and then click Insert Hyperlink .
Click ScreenTip.
Type the text you want to appear when a site visitor rests the mouse pointer
over the hyperlink, and click OK.
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Remove a hyperlink
In Page view, at the bottom of the document window, click Design , and
do one of the following:
Delete the hyperlink completely, including the hyperlink text
Select the hyperlink and press DELETE.
Preserve the hyperlink text but delete the hyperlink associated with it
1. Select the hyperlink and click Insert Hyperlink
2. Click Remove Link.

.
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Create a bookmark on a Web page
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Select the text to which you want to assign a bookmark.
On the Insert menu, click Bookmark.
Under Bookmark name, type or select the name of the bookmark (spaces
are allowed).

Note If you bookmark a location (rather than text), the bookmark is indicated in
FrontPage by . If you bookmark text, the text displays with a dashed underline.
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Go to a bookmark on a Web page
1. In Page view, at the bottom of the document window, click Design .
2. On the Insert menu, click Bookmark.
3. In the Other bookmarks on this page box, click the bookmark you want to
find.
4. Click Goto.
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Add a temporary bookmark to code
1. In Page view, at the bottom of the document window, click Code .
2. Place the insertion point where you want to insert the temporary bookmark.
3. Press CTRL+F2.
Tip
When working with a Web page that contains several temporary bookmarks,
press F2 to jump ahead to the next temporary bookmark, or press SHIFT+F2 to
jump back to the previous temporary bookmark.

Remove a bookmark
1. In Page view, at the bottom of the document window, click Design .
2. On the Insert menu, click Bookmark.
3. In the Other bookmarks on this page box, click the bookmark you want to
delete.
4. Click Goto.
5. Click Clear.
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Troubleshoot hyperlinks
My hyperlink goes to a wrong destination.
This can be caused by one of following:
The destination may have been entered incorrectly Make sure the
hyperlink destination is correct.
The original destination may have moved to a different location Use
your Internet browser to locate the destination to ensure that it still exists.
Nothing happens when I click a hyperlink.
This can happen when the text you believe is a hyperlink only looks like a
hyperlink. To make sure the text is a hyperlink, do the following:
1. Select the text, and then click Insert Hyperlink .
2. In the Address box, confirm that there is a valid URL.
When I click a hyperlink, it returns a 404 error message.
This can be caused by one of the following:
The destination may have moved or may no longer exist Verify that the
file exists by viewing the destination file with your Internet Web browser (if
the file is on the Internet), or with Microsoft Windows Explorer (if the file
is on your hard drive or a network).
You may not have access to the destination If the destination file is on
the Internet, make sure you have a connection to the Internet.
There may be a technical problem If you believe that the file you are
linking to exists, and that you have permission to link to it, try deleting your
temporary Internet files.
How?
1. Open Internet Explorer.

2. On the Tools menu, click Internet Options.
3. Under Temporary Internet Files, click Delete Files.
When I click a hyperlink, it returns a 403 error message.
You may be trying to link to a page or directory that does not have anonymous
browsing permissions.
If the destination is on a network, contact your network administrator to
ensure that you have access to the destination file.
My hyperlink goes to the wrong frame.
This is often caused by incorrectly setting up the target frame for your hyperlink.
To change the target frame, do the following:
1. In Page view, at the bottom of the document window, click Design .
2. Click the hyperlink, and then click Insert Hyperlink .
3. In the Insert Hyperlink dialog box, click Target Frame and then do one
of the following:
Choose a target frame within your frames page
In the Target Frame dialog box, the Current frames page area shows
a map of your frames page. Click the frame you would like to set as
the target frame.
Choose a target frame outside your frames page (in a new window)
In the Target Frame dialog box, under Common targets, click New
Window.
My screen tip doesn't appear when I hover on my hyperlink.
Microsoft FrontPage uses the title attribute to specify the screen tip for a
hyperlink. Some Web browsers do not support the title attribute.
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About creating a navigation structure
When you design your Web site, one of the most important considerations is
providing a logical navigation structure, allowing site visitors to find the content
they want quickly and easily. You want to ensure that site visitors always know
where they are in the site, and provide them with the proper context for the
content they are reading.
Microsoft FrontPage includes the following methods to help you add a
navigation structure to your Web site:
Link bars
A link bar is a set of hyperlinks that enable site visitors to navigate to the pages
in your Web site. You place link bars in a prominent and consistent location on
each page, and they act as a map to the pages you designate. You can create link
bars with either graphic or text hyperlinks.
When you create your Web site, you can either create link bars that you specify
the links for, or add a link bar that is based on the navigation structure of your
site. FrontPage maintains the link bars you create; if you move or add a page,
FrontPage updates the link bar accordingly.
You can format your link bars in the following ways:
You can place link bars horizontally or vertically on a page.
You can add more than one link bar to each page, for example to navigate to
different page levels.
You can change the style of a link bar that uses buttons instead of text.
The types of link bars that you can add to your Web site include the following:
Link bars based on a navigation structure
After you have designed your Web site and determined a hierarchical and logical
flow for the content, you can add a link bar based on that navigation structure.
The structure determines which hyperlinks you will assign to the link bar, and

the node labels determine the labels for those hyperlinks.
The following example shows the structure of a Web site in Navigation view
and an explanation of the relationships among the pages in the site:

Home page The first page that is added to a navigation structure is typically
named Default.htm or Index.htm, and is indicated by the home page icon
. In the preceding example, Home is the home page.
Global level pages These pages are at the same level as — but do not
include — the home page. In the preceding example, the global level page is
Contacts.
Parent level pages These pages are located directly above another page or
pages, including pages that are directly connected to the parent level page on the
same level (with the exception of the Home page). In the preceding example, the
parent level page for What's New is Home.
Child level pages One or more pages that are located directly below a parent
level page. In the preceding example, Home has three child level pages (What's
New, Products, and Services), Contacts has one child level page (Jobs), and
Products has two child level pages (Search and Ordering).
Same level pages Pages that are on the same level in the hierarchical structure
and share the same parent level page. In the preceding example, What's New,
Products, and Services are same level pages; Search and Ordering are also
same level pages.
Back and next pages In the preceding example, if you add a link bar that
includes back and next links to the Products page, the next link directs the site
visitor to Services and the back link directs the site visitor to What's New.
When you add a link bar that includes back and next links, FrontPage relies on
the navigation structure of the Web site to automatically set up those links. You
can add hyperlinks to the home page and to the parent level page of the active
page by using the link bar properties dialog box. Additionally, in Navigation
view, you can create links to external Web pages.

Custom link bars
When you add a custom link bar, you can link to any of the pages within your
Web site, as well as to external pages. You can set the link bar up in any way that
you want, you can add back and next links, and you can add and remove pages
from it at any time.
Table of contents
You can configure FrontPage to automatically generate a table of contents based
on the categories that you assign to your pages. For users of FrontPage client
software that connect to servers running FrontPage Server Extensions or
SharePoint Team Services v1.0 from Microsoft, you can configure FrontPage to
automatically generate a table of contents based on the navigation structure of
your Web site. While the actual links do not display in FrontPage, they do in the
Web browser. This functionality is not available if you connect to a server that is
running Microsoft Windows SharePoint Services.
When you create a site map, you select the categories that you want and create a
Table of Contents, and this makes up the list of all the pages belonging to those
categories. For example, if you sell appliances, your site map might have
columns of hyperlinks for Large Appliances, Small Appliances, and Customer
Service. You can create this kind of site map by using categories.

You can format your table of contents — for example, change the heading font
size — and you can also set it so that FrontPage automatically recalculates the
table of contents whenever you edit a page in your Web site.
Site maps

For a personal or small Web site, you can create a site map with a list of
hyperlinks to all the Web site's pages, by using the Table of Contents Web
component.
For a corporate presence or large Web site, a site map typically contains lists of
hyperlinks to pages in different subsites, categories, or other groups organized
under logical headings. For example, if you sell appliances, your site map might
have columns of hyperlinks for Large Appliances, Small Appliances, and
Customer Service. You can create this kind of site map by using categories.

Represents the categories that you have assigned to specific pages
Represents the pages that you have assigned to a certain category
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Create a navigation structure
1. On the View menu, click Navigation, and do one or more of the following:
Add an existing page
In the Folder List, click the page that you want, and then drag it to a
location in the navigation structure.
If the Folder List is hidden, on the View menu, click Folder List.
Add a new page under an existing page
In the navigation structure, right-click the page, point to New, and then
click Page on the shortcut menu.
Move a page
In the navigation structure, drag the page to another location within the
structure.
Remove a page
In the navigation structure, right-click the page, and then click Delete
on the shortcut menu.
2. To save your edits without switching views, right-click the document
window background, and then click Apply Changes on the shortcut menu.

Customize Navigation view
If you create a navigation structure in Navigation view, you can customize how
that structure is displayed.
To

Do This
Right-click the view background, point to
Zoom on the shortcut menu, and then click
Zoom in or out
the percentage that you want to zoom in or
out.
Automatically size a large
Right-click the view background, point to
navigation structure to fit into the Zoom on the shortcut menu, and then click
view
Size to Fit.
Right-click the view background, and then
Change the orientation of how the
click Portrait/Landscape on the shortcut
structure is displayed
menu.
Expand all of the subtrees (the
pages below a parent page) so that Right-click the view background, and then
you can see the entire navigation click Expand All on the shortcut menu.
structure
Right-click any page in the subtree, and
Show or hide only the pages in a
then click View Subtree Only on the
subtree
shortcut menu.
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Add a link bar to a Web page
1.
2.
3.
4.
5.

Open your Web site in Page view.
Place the insertion point where you want to add the link bar.
On the Insert menu, click Navigation.
In the Component type list, click Link Bars.
Do one of the following:
Add a link bar with custom links

1. In the Choose a bar type list, click Bar with custom links, and then click
Next.
2. Click the link bar style that you want to use for this link bar.
3. Click Next.
4. Click the page orientation that you want, and then click Finish.
5. Do one of the following:
Add a new link bar
1.
2.
3.
4.

Click Create new.
Type a name for the new link bar, and then click OK.
Click Add link.
In the Text to display box, type the text that you want to appear on the
link bar, and then click OK.
5. Locate and click the page that you want the custom link bar to link to.
6. Repeat steps 3 through 5 for each link that you want to add to the link
bar.
7. To set the order for how you want site visitors to view the links on the
link bar, click the Move up or Move down button.
Add an existing link bar
Under Choose existing, click the name of the link bar that you want to
use, and then click OK.
Add a link bar with back and next links

1. In the Choose a bar type list, click Bar with back and next links, and
then click Next.
2. Click the link bar style that you want to use for this link bar.
3. Click Next.
4. Click the page orientation that you want, and then click Finish.
5. Do one of the following:
Create a new link bar
1.
2.
3.
4.

Click Create new.
Type a name for the new link bar, and then click OK.
Click Add link.
In the Text to display box, type the text (such as back or next) that
you want to appear on the link bar.
5. Locate and click the page that you want to link to from the custom link
bar, and then click OK.
6. Repeat steps 3 through 5 for each link that you want to add to the link
bar.
7. To set the order for how you want site visitors to view the links on the
link bar, click the Move up or Move down button.
Note Depending on where it is in the list, you can link to an external page
by using the Back or Next link on the link bar. However, you cannot add
the same link bar to a page that is not in the active Web site.
Use an existing link bar
In the Choose existing box, click the name of the link bar that you
want to use, and then click OK.
Add a link bar based on the navigation structure
Note To add a link bar based on the navigation structure, you must have already
created the navigation structure for your Web site in Navigation view.
1. In the Choose a bar type list, click Bar based on navigation structure,
and then click Next.
2. Click the link bar style that you want to use for this link bar.
3. Click Next.

4. Click the page orientation that you want, and then click Finish.
5. Under Hyperlinks to add to page, click the hyperlink options for the link
bar that you want to add, and then click OK.
Tip
When performing this procedure, consider the level of the page that you are
adding the link bar to. For example, if you are adding a link bar to your
home page, choose either Child pages under Home or Child level to link
to the pages at a level beneath the home page.
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Add a hyperlink to a link bar
Do one of the following:
Add a hyperlink based on the navigation structure
1. In Navigation view, right-click the page in the structure that you want to
add a hyperlink to, and then click Add Existing Page on the shortcut menu.
2. Locate and click the file you want to link to, and then click OK.
3. To save the changes, right-click the background in Navigation view, and
then click Apply Changes on the shortcut menu.
Add a hyperlink to a custom link bar
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Double-click the link bar.
Click Add link.
Locate and click the file you want to link to and then click OK.
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Edit a link bar
Do one or both of the following:
Edit a link on a link bar that is based on the navigation structure
Do one of the following:
Change hyperlink options
1. In Page view, at the bottom of the document window, click Design .
2. Double-click the link bar.
3. Under Hyperlinks to add to page, click the hyperlink options that you
want to display, and then click OK.
Note If you specify hyperlinks that are not in the navigation tree, a
link bar will not be displayed on the page.
Exclude a page
1. In Navigation view, right-click the page that you want to exclude.
2. Click Included in Link Bars on the shortcut menu.
Note All child-level pages under the excluded page will also be excluded
by default. If you do not want this setting to affect a child-level page, rightclick the child-level page, and then click Included in Link Bars on the
shortcut menu.
Edit a link on a custom link bar or a link bar with back and next links
1. In Page view, double-click the link bar.
2. Do one or more of the following:
To add more links to the link bar, click Add link.
To delete a link from a link bar, click the link, and then click Remove
link.
To change the URL or the display text of a link, click Modify link.

To change the order of the links on a link bar, in the Links list, click
the link, and then click Move up or Move down.
For link bars with back and next links, moving the links up or down
affects how the links are ordered in relation to one another on the link
bar.
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Change the style of a link bar
Do one of the following:
Change the format of a link bar that uses text
1. In Page view, at the bottom of the document window, click Design .
2. Click the link bar.
3. On the Format menu, click Font, and then select the options you want.
Change the format of a graphical link bar
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Double-click the link bar.
Click the Style tab.
Click the link bar style that you want to use for this link bar.
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Change the label for hyperlinks in a
link bar
Do one of the following:
Change labels for a link bar with custom hyperlinks
1. In Navigation view, right-click the page label that you want to change the
display text for.
2. Click Rename.
3. Type the new display text on the page label, and then press ENTER.
Change labels for a link bar with hyperlinks based on a navigation
structure
1. On the Tools menu, click Site Settings.
2. Click the Navigation Tab.
3. Type the label in the appropriate box.

Change the orientation of a link bar
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Double-click the link bar.
Click the Style tab.
Under Orientation and appearance, click the orientation that you want.

Print the navigation structure
1. On the View menu, click Navigation.
2. On the File menu, click Print.
3. Set the printing options, such as the printer name and number of copies that
you want, and then click OK.
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Delete a link bar
1. In Page view, at the bottom of the document window, click Design .
2. Click the link bar, and then press DELETE.
Note If you delete a link bar from a shared border, the link bar will be deleted
from all pages using that shared border.
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Troubleshoot creating a navigation
structure
The back and next links do not link to the pages in my Web site in the
order that I want.
You can reset the order of the hyperlinks on either a link bar based on a
navigation structure or a custom link bar. To change a link bar based on a
navigation structure, switch to Navigation view, and then drag each yellow node
to the location you want. To change a custom link bar, do the following:
1.
2.
3.
4.

Double-click the link bar.
Click the hyperlink that you want to move.
Click Move up or Move down.
To reset the order of additional hyperlinks on the link bar, repeat steps 2 and
3.
The links I added to a link bar are not rendering correctly.

If you add link bars in a shared border, you must add the pages in Navigation
view to ensure that they are displayed correctly.
A link bar is relative to each page, therefore if you use a link bar inside a shared
border, it might be useful when you view it from one page, but when you view
the link bar from a different page, the hyperlinks may not map correctly. Since a
link bar inside a shared border has the same settings for all pages using the
shared border, you must be careful how you set up the link bar.
FrontPage is not generating a table of contents based on the navigation
structure of my Web site.
You must be connected to a server running FrontPage Server Extensions from
Microsoft or SharePoint Team Services v1.0 from Microsoft. This functionality
is not available if you connect to a server that is running Microsoft Windows
SharePoint Services.
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Create a table of contents or site map
Do one of the following:
Create a table of contents based on the navigation structure
Important This functionality is not available if you connect to a server that is
running Microsoft Windows SharePoint Services.
1. In Page view, place the insertion point where you want to create a table of
contents.
2. On the Insert menu, click Web Component.
3. In the Component type list, click Table of Contents.
4. In the Choose a table of contents list, click For This Web Site, and then
click Finish.
5. In the Page URL for starting point of table box, locate and click the page
that you want to use as the starting point for the table of contents.
The starting point determines which pages are leftmost in the table of
contents. Pages pointed to by hyperlinks on the starting page will be
indented one level in the table of contents.
6. In the Heading font size list, select the font size you want.
Create a table of contents or site map based on categories
1. Assign each page that you want to appear in your table of contents or site
map to a category.
How?
1. In the Folder List, right-click the page that you want to assign to a
category, and then click Properties on the shortcut menu.
2. Click the Workgroup tab.
3. In the Available Categories list, click the category that you want to
assign the page to.

If you want to create a new category, click Categories, type the name
of the new category, click Add, and then click OK.
4. To assign a page to more than one category, repeat steps 1 through 3
for each page.
2. In Page view, place the insertion point where you want to add the first
category of pages in the table of contents or site map, type a heading, and
then press ENTER.
3. On the Insert menu, click Web Component.
4. In the Component type list, click Table of Contents.
5. In the Choose a table of contents list, click Based on Page Category, and
then click Finish.
6. In the Choose categories to list files by box, select the check box next to
each page category of that you want to include in your table of contents or
site map.
7. In the Sort files by box, do one of the following:
To sort the list alphabetically, select Document title.
To sort the list by file dates, select Date last modified.
8. Under Include the following information, do one or more of the
following:
To include the file modification date, select the Date the file was last
modified check box.
To include comments that have been added to each page in the list,
select the Comments added to the file check box.
9. Repeat these steps for each additional page category that you want to
include in your table of contents or site map.
Note To view the text on the links, on the File menu, point to Preview in
Browser, and then click the Web browser that you want.
Tip
If you are creating a table of contents or site map on the same page as the
starting point, the heading of the table of contents will be a hyperlink to the same
page. For example, if you create a table of contents on the page Index.htm, and
the starting point is Index.htm (the same page), the heading of the table will be a
hyperlink to Index.htm. If you want to exclude such a circular hyperlink as the
heading of a table of contents or site map, click None in the Heading font size

box.

Show All

About hit counters
A hit counter tallies and displays the number of times a page has been visited.
You can add a hit counter to your home page so that you and site visitors can see
how many times your Web site has been visited, as in the following example.
You are visitor:
Microsoft FrontPage provides several styles of counters, but you can supply your
own number graphics by creating a custom picture in GIF format. The picture
must include the numbers zero (0) to nine (9), evenly spaced.
After you add a hit counter to a page, you can reset the counter to any number.
For example, you test a Web site after you publish it to make sure that it is
working properly, and then you find that the hit counter has been incremented by
your own visits. You can reset the counter to zero to start it over.
Note You must publish your Web site to a Web server that has the FrontPage
Server Extensions, SharePoint Team Services v1.0 from Microsoft, or Microsoft
Windows SharePoint Services 2.0 installed. Ask your Web server administrator
or Internet service provider (ISP) whether one of these technologies is installed
on your Web server.
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Add a hit counter
1.
2.
3.
4.
5.

In Page view, at the bottom of the document window, click Design .
Place the insertion point where you want the hit counter.
On the Insert menu, click Web Component.
Under Component type, click Hit Counter.
Do one of the following:
Choose an existing counter style
Under Choose a counter style, double-click one of the of the counter
styles.
Use a custom picture as a counter style
1. Under Choose a counter style, double-click any of the counter styles.
2. In the Hit Counter Properties dialog box, select Custom Picture.
3. Type the relative location of the GIF file.
For example, if the GIF is located in your images folder, the relative
path would be /images/yourgif.gif.
Note The file must be in GIF format.

6. To set the counter to a specific number, select the Reset counter to box,
and then type the number.
7. To display a fixed number of digits in the hit counter, select the Fixed
number of digits box, and then type the number.
For example, to display 005 rather than 5, select this option and type 3.
Note To add a hit counter to your Web site, your site must be located on a Web
server running Microsoft FrontPage 2002 Server Extensions, SharePoint Team
Services v1.0, or Microsoft Windows SharePoint Services. Ask your Web server
administrator or Internet service provider (ISP) whether your server is running
these technologies.
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Reset a hit counter
1. In Page view, at the bottom of the document window, click Design .
2. Double-click the hit counter.
3. Select the Reset counter to check box, and then type a number in the box.

Add a time stamp to a Web page
A time stamp will display either the time or the date, or both, that the page was
created or last changed. For example, a time stamp lets site visitors know
whether the information on your site has changed since their last visit.
1.
2.
3.
4.
5.

In Page view, at the bottom of the document window, click Design .
Place the insertion point where you want to add a time stamp.
On the Insert menu, click Date and Time.
Specify the type of time stamp to display.
Specify a format for the date and for the time.
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Show or hide highlighting of dynamic
elements
If you add a Dynamic HTML (DHTML) effect to a page element, you can show
or hide a blue background and border for the effect in Design view.
To show or hide the highlighting effect, on the Dynamic HTML Effects
toolbar, click Highlight DHTML Effects

.

If the DHTML Effects toolbar is hidden, on the View menu, point to
Toolbars, and then click DHTML Effects.

About Web components in FrontPage
By using Web Components in Microsoft FrontPage, you can add a wide variety
of features to your Web site, ranging from hit counters that register the number
of visitors to a page, to photo galleries that display a collection of graphics.
You can choose from two types of Web components: author-time components or
browse-time components.
Author-time components are tools that can make it easier to create and design
Web pages. They are available in FrontPage. If you want to add an author-time
component to your site — such as a photo gallery or link bar — you do not need
to install specific software or a specific server technology on the Web server that
hosts your site.
Browse-time components are available on Web sites located on Web servers
running FrontPage Server Extensions from Microsoft, SharePoint Team Services
from Microsoft, or Microsoft Windows SharePoint Services.
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Web components that may not be
supported
You can insert many different Web components in Microsoft FrontPage by using
the Insert Web Component dialog box. The dialog box provides options for the
following items.
Options in the Insert Web Component dialog box
Dynamic Effects
Marquee Makes text scroll horizontally across the screen.
Interactive Button Inserts a graphical button that contains text. The button
changes when a site visitor points to it.
Web Search
Current Web Inserts a search form that searches the contents of the active Web
site. This component requires FrontPage 2002 Server Extensions from Microsoft
or SharePoint Team Services v1.0 from Microsoft.
Full-Text Search Enables a full-text search of your Web site. This component
requires Windows SharePoint Services. Full-text search must be enabled on the
server.
Spreadsheets and charts
Office Spreadsheet Displays data in an interactive spreadsheet.
Office Chart Displays data in an interactive chart.
Office PivotTable Displays data in an interactive PivotTable list.
Hit Counter

Each Hit Counter option inserts a hit counter that tallies and displays the number
of times the page has been visited. Choose from the following color
combinations:
Gold digits on black background
Black digits on white background, comic style font
Orange digits on black background
Black digits on white background, block style font
Green digits on black background
Photo Gallery
Horizontal Layout Inserts a horizontal arrangement of photos.
Montage Layout Inserts a montage layout of photos.
Slide Show Inserts a slide show layout of photos.
Vertical Layout Inserts a vertical arrangement of photos.
Included Content
Substitution Inserts a component that shows the author, description, last
changed date, or URL.
Page Inserts a component that displays the contents of one page on another
page.
Page Based on Schedule Inserts a component that displays the contents of
another page on the active page at specified times. This component requires
FrontPage 2002 Server Extensions from Microsoft or SharePoint Team Services
v1.0 from Microsoft.
Picture Based on Schedule Inserts a component that displays a picture on the
active page at specified times. This component requires FrontPage 2002 Server
Extensions or SharePoint Team Services v1.0.
Page Banner Inserts a page banner that is displayed as a graphical title based
on the page theme or as text.

Link Bars
Bar with custom links Inserts a bar of hyperlinks that point to pages within the
active site or to external links. This component requires FrontPage 2002 Server
Extensions from Microsoft, SharePoint Team Services v1.0 from Microsoft, or
Microsoft Windows SharePoint Services.
Bar with back and next links Inserts a bar of hyperlinks that point to a
sequence of pages within the active site.
Bar based on navigation structure Inserts a link bar or a back and next link
bar based on the navigation structure of the site.
Table of Contents
For This Web Site Inserts a table of contents for the active Web site. This
component requires FrontPage 2002 Server Extensions from Microsoft or
SharePoint Team Services v1.0 from Microsoft.
Based on Page Category Inserts a table of contents for the active Web site
based on chosen categories.
Top Ten List
Visited Pages Inserts a component that shows the top 10 most visited pages in
the active site. This component requires FrontPage 2002 Server Extensions from
Microsoft, SharePoint Team Services v1.0 from Microsoft or Microsoft
Windows SharePoint Services.
Referring Domains Inserts a component that shows the top 10 referring
domains for the active site. This component requires FrontPage 2002 Server
Extensions, SharePoint Team Services v1.0, or Windows SharePoint Services.
Referring URLs Inserts a component that shows the top 10 referring domains
for the active site. This component requires the FrontPage 2002 Server
Extensions, SharePoint Team Services v1.0, or Windows SharePoint Services.
Search Strings Inserts a component that shows the top 10 search strings used
in search engines to find the active site. This component requires FrontPage

2002 Server Extensions, SharePoint Team Services v1.0, or Windows SharePoint
Services.
Visiting Users Inserts a component that shows the top 10 most frequent site
visitors for the active site. This component requires FrontPage 2002 Server
Extensions, SharePoint Team Services v1.0, or Windows SharePoint Services.
Operating Systems Inserts a component that shows the top 10 most popular
operating systems of site visitors. This component requires FrontPage 2002
Server Extensions, SharePoint Team Services v1.0, or Windows SharePoint
Services.
Browser Inserts a component that shows the top ten most popular Web
browsers used to view the active site. This component requires FrontPage 2002
Server Extensions, SharePoint Team Services v1.0, or Windows SharePoint
Services.
List View
Basic table Inserts a list view containing a column for each field you choose
and a new row for each item in the list. This component requires SharePoint
Team Services v1.0 from Microsoft.
Repeating form Inserts a list view in a repeating form style that shows the title
for an item in the list and the other fields on separate lines below the title. This
layout is repeated for each item in the list. This component requires SharePoint
Team Services v1.0.
Repeating form (centered) Inserts a list view in a centered, repeating form
style that shows the title for an item in the list and the other fields on separate
lines below the title. This layout is repeated for each item in the list, and all the
information is center-aligned. This component requires SharePoint Team
Services v1.0.
Repeating form with border Inserts a list view in a repeating form with table
borders. It shows the title for an item in the list and the other fields on separate
lines below the title. This layout is repeated for each item in the list, and each
item appears in its own table cell. This component requires SharePoint Team
Services v1.0.

Two-column repeating form with border Inserts a list view that shows a twocolumn bordered table with each list item in its own table cell. This component
requires SharePoint Team Services v1.0.
Comma separated Inserts a list view that shows the titles for items in the list
with all the other field values separated by commas underneath the titles. This
component requires SharePoint Team Services v1.0.
Two-column comma separated Inserts a list view that shows a two-column
view of the titles for items in the list with all the other field values separated by
commas underneath the titles. This component requires SharePoint Team
Services v1.0.
Bulleted list of titles Inserts a list view that shows a bulleted list of the titles
for all the items in the list. This component requires SharePoint Team Services
v1.0.
Numbered list of titles Inserts a list view that shows a numbered list of the
titles for all the items in the list. This component requires SharePoint Team
Services v1.0.
Plain list of titles Inserts a list view that shows the titles for all the items in the
list, each on a separate line. This component requires SharePoint Team Services
v1.0.
Horizontal list of titles Inserts a list view that shows the titles for all the items
in the list separated by commas on a single line. This component requires
SharePoint Team Services v1.0.
Dropdown menu of titles Inserts a list view that shows a drop-down menu that
contains the titles for all the items in the list. This component requires
SharePoint Team Services v1.0.
Page component Inserts a list view that shows a bulleted list of the titles for all
the items in the list inside a box. This component requires SharePoint Team
Services v1.0.
History list Inserts a list view that shows the creation date for an item in the
list, the title of the item, and the other fields on separate lines below the title.
This layout is repeated for each item in the list, and items are shown in

chronological order. All the information is center-aligned. This component
requires SharePoint Team Services v1.0.
Document Library View
Basic table Inserts a document library view that contains a column for each
field you choose and a new row for each item in the list. This component
requires SharePoint Team Services v1.0 from Microsoft.
Repeating form Inserts a document library view in a repeating form style that
shows the title for an item in the list and the other fields on separate lines below
the title. This layout is repeated for each item in the list. This component
requires SharePoint Team Services v1.0.
Repeating form (centered) Inserts a document library view in a centered,
repeating form style that shows the title for an item in the list and the other fields
on separate lines below the title. This layout is repeated for each item in the list,
and all the information is center-aligned. This component requires SharePoint
Team Services v1.0.
Repeating form with border Inserts a document library view in a repeating
form with table borders. It shows the title for an item in the list and the other
fields on separate lines underneath the title. This layout is repeated for each item
in the list, and each item appears in its own table cell. This component requires
SharePoint Team Services v1.0.
Two-column repeating form with border Inserts a document library view that
shows a two-column bordered table with each list item in its own table cell. This
component requires SharePoint Team Services v1.0.
Comma separated Inserts a document library view that shows the titles for
items in the list with all the other field values separated by commas below the
titles. This component requires SharePoint Team Services v1.0.
Two-column comma separated Inserts a document library view that shows a
two-column view of the titles for items in the list with all the other field values
separated by commas below the titles. This component requires SharePoint Team
Services v1.0.

Bulleted list of titles Inserts a document library view that shows a bulleted list
of the titles for all the items in the list. This component requires SharePoint
Team Services v1.0.
Numbered list of titles Inserts a document library view that shows a numbered
list of the titles for all the items in the list. This component requires SharePoint
Team Services v1.0.
Plain list of titles Inserts a document library view that shows the titles for all
the items in the list, each on a separate line. This component requires SharePoint
Team Services v1.0.
Horizontal list of titles Inserts a document library view that shows the titles
for all the items in the list separated by commas on a single line. This component
requires SharePoint Team Services v1.0.
Dropdown menu of titles Inserts a document library view that shows a dropdown menu that contains the titles for all the items in the list. This component
requires SharePoint Team Services v1.0.
Page component Inserts a document library view that shows a bulleted list of
the titles for all the items in the list inside a box. This component requires
SharePoint Team Services v1.0.
History list Inserts a document library view that shows the creation date for an
item in the list, the title of the item, and the other fields on separate lines below
the title. This layout is repeated for each item in the list, and items are shown in
chronological order. All the information is center-aligned. This component
requires SharePoint Team Services v1.0.
MSN Mapping Components
Link to a map Inserts a link that takes site visitors to the MSN Maps &
Directions Web site to view a dynamic map with the location already marked.
Static map Inserts a static map from MSN Maps & Directions for a specific
location.
MSN Components

Search the Web with MSN Inserts a component on your page that enables site
visitors to search the Web by using MSN.
Stock quote Inserts a component on your page that enables site visitors to look
up stock quotes.
MSNBC Components
Business Headlines from MSNBC Inserts an MSNBC component that
displays MSNBC business headlines on your page.
Living and travel headlines from MSNBC Inserts an MSNBC component
that displays MSNBC living and travel headlines on your page.
News Headlines from MSNBC Inserts an MSNBC component that will
display MSNBC news headlines on your page.
Sports Headlines from MSNBC Inserts an MSNBC component that will
display MSNBC sports headlines on your page.
Technology Headlines from MSNBC Inserts an MSNBC component that will
display MSNBC technology headlines on your page.
Weather forecast from MSNBC Inserts an MSNBC component that will
display MSNBC weather headlines on your page.
Additional Components
Visual InterDev Navigation Bar Inserts a Visual InterDev Navigation Bar.
This component requires FrontPage 2002 Server Extensions from Microsoft or
SharePoint Team Services v1.0 from Microsoft.
Advanced Controls
HTML Inserts HTML content that will not be modified by FrontPage.
Java Applet Inserts a Java applet.
Plug-In Inserts a plug-in.

Confirmation Field Displays the information that a site visitor enters on a
form.
ActiveX Control Inserts a Microsoft ActiveX control.
Design-Time Control Inserts a design-time control.
Movie in Flash Format Inserts a movie in Macromedia Flash format.
Publish scenarios for servers running SharePoint Services

From a server running SharePoint Team Services v1.0 from
Microsoft to a server that is not running SharePoint Team
Services v1.0
Some components will not work on the destination site. To enable them, you
must publish them to a server running SharePoint Team Services v1.0.

From a server running SharePoint Team Services v1.0 to another
server running SharePoint Team Services v1.0
FrontPage cannot move SharePoint Services list data or schemas, even when
published between two servers running SharePoint Team Services v1.0. To
publish, use Microsoft FrontPage 2002 with Microsoft Office XP Service Pack 1
or later.

From a server running SharePoint Team Services v1.0 to a server
that is running Microsoft Windows SharePoint Services
FrontPage cannot move SharePoint Services list data or schemas from a server
running SharePoint Team Services v1.0 to a server running Windows SharePoint
Services. To do this, you must use the smigrate.exe utility. See Windows
SharePoint Services Help for more information.

From a server running Windows SharePoint Services to a server
that is not running Windows SharePoint Services

Certain components require a server running Windows SharePoint Services and
cannot be published. You must insert components that are compatible with the
remote server.

From a server running Windows SharePoint Services to another
server running Windows SharePoint Services
FrontPage cannot move SharePoint Services list data or schemas from a server
running Windows SharePoint Services to another server running Windows
SharePoint Services. To do this, you must use the smigrate.exe utility. See
Windows SharePoint Services Help for more information.
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About Java applets
A Java applet is a small software program written in the Java programming
language, a programming language used primarily on the World Wide Web. By
adding a Java applet to a Web page, you can add special effects, interactivity,
and more. For example, you might add an interactive game or a window for
entering or viewing information on a Web server.
A Java applet is stored in a separate file that you can reference in a Web page.
Although you cannot create a Java applet by using Microsoft FrontPage, you can
use FrontPage to create or edit the HTML code that references a file for a Java
applet.
If you open a Web page in Design view, and that page contains a reference to a
Java applet, an icon representing the applet
appears on the page. The icon
does not appear when you open the Web page in a Web browser or when you
print the Web page.
Although some Java applets are self-contained and work correctly in any
location on a Web page, other Java applets are dependent on the structure of a
page. If you copy or move such an applet to another Web page — or to another
location on a Web page — the Java applet might not work correctly or it might
return an error when a site visitor opens the page in a Web browser.
Because some Web browsers provide settings for disabling or limiting the
functionality of Java applets, an applet may or may not work correctly for all of
your site visitors.
Important Security vulnerabilities in external files or controls may extend to
Web pages that use those items. For example, external style sheets (files with a
.css extension), script files (files with a .js extension), custom ASP.NET controls,
or other items, may pose a security risk. Be sure your style sheets, add-ins,
themes, executables, scripts, controls, or other files come from trusted sources.

Add a Java applet
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
On the Insert menu, click Web Component.
In the Component type list, click Advanced Controls.
In the Choose a control list, double-click Java Applet.

5. In the Applet source box, type the name of the Java applet source file.
Java applet source files usually have a .class filename extension.
6. Select any other options you want.
Important Security vulnerabilities in external files or controls may extend to
Web pages that use those items. For example, external style sheets (files with a
.css extension), script files (files with a .js extension), custom ASP.NET controls,
or other items, may pose a security risk. Be sure your style sheets, add-ins,
themes, executables, scripts, controls, or other files come from trusted sources.
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Set the properties of a Java applet
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the Java applet, and then click Java Applet Properties on the
shortcut menu.
3. Do any of the following:
In the Message for browsers without Java support box, type the
HTML or plain text that will be displayed in place of the Java applet
on Web browsers that do not support Java applets.
Under Applet parameters, specify any parameter names and values
(if required) you want.
Because Java does not provide a mechanism for displaying the valid
properties and values for a given applet, consult the documentation
that comes with the Java applet, and then specify the correct parameter
names and legal values for each parameter.
Under Layout and Size, specify the alignment, horizontal and vertical
spacing, and width and height (in pixels) for the Java applet.
Note If you want to specify cascading style sheet properties as an inline style
for the Java applet, click Style and then select the options you want.
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Create a message to display in place
of Java applets in browsers
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the Java applet, and then click Java Applet Properties on the
shortcut menu.
3. In the Message for browsers without Java support box, type HTML or
plain text to display in place of the Java applet on Web browsers that do not
support Java applets, or that are configured not to display Java applets.

Delete a Java applet
1. In Page view, at the bottom of the document window, click Design .
2. Click the Java applet, and then press DELETE.
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About plug-ins
A plug-in is one of a set of software modules that integrate into Web browsers to
offer a range of interactive and multimedia capabilities.
Some plug-ins occupy a space on a Web page, as in the case of certain MPEG
video players. Those plug-ins may have a display area as well as video controls
for playing, pausing, or rewinding, for example.
Other plug-ins, like some MIDI players, don't occupy any space on a Web page.
Plug-ins such as these may, for example, begin playing music as soon as you
load a Web page, but have no "on" or "off" buttons.
Many developers create their own plug-ins to enable software to run in a Web
browser. Because developers may follow different conventions when designing
plug-ins, some plug-ins might behave differently, depending on browser types
and versions.
Important Security vulnerabilities in external files or controls may extend to
Web pages that use those items. For example, external style sheets (files with a
.css extension), script files (files with a .js extension), custom ASP.NET controls,
or other items, may pose a security risk. Be sure your style sheets, add-ins,
themes, executables, scripts, controls, or other files come from trusted sources.

Add a plug-in
1.
2.
3.
4.
5.

In Page view, at the bottom of the document window, click Design .
On the Insert menu, click Web Component.
In the Component type list, click Advanced Controls.
In the Choose a control list, double-click Plug-In.
In the Data source box, type the URL of the file for the plug-in to load, or
click Browse to locate the file.
6. Select any other options you want.
Important Security vulnerabilities in external files or controls may extend to
Web pages that use those items. For example, external style sheets (files with a
.css extension), script files (files with a .js extension), custom ASP.NET controls,
or other items, may pose a security risk. Be sure your style sheets, add-ins,
themes, executables, scripts, controls, or other files come from trusted sources.
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Set the properties of a plug-in
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the plug-in, and then click Plug-In Properties on the shortcut
menu.
3. Do any of the following:
In the Data source box, type the URL of the file for the plug-in to
load.
In the Message for browsers without plug-in support, type an
HTML or plain text message. This will be shown in place of the plugin on Web browsers that don't support plug-ins.
In the Height and Width boxes, type (in pixels) the height and width
of the plug-in.
Select or clear the Hide plug-in check box to show or hide the plug-in
when the page is viewed in a Web browser.
Under Layout, specify the alignment, border thickness, and horizontal
and vertical spacing for the plug-in.
4. If you want to specify cascading style sheet properties as an inline style for
the plug-in, click Style, and then select the options you want.
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Create a message to display in place
of plug-ins in browsers
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the plug-in, and then click Plug-In Properties on the shortcut
menu.
3. In the Message for browsers without plug-in support box, type HTML or
plain text to display in place of the plug-in on Web browsers that do not
support plug-ins, or that are configured not to display plug-ins.
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Hide a plug-in
To hide a plug-in when a site visitor views the page in a Web browser, do the
following:
1. In Page view, right-click the plug-in that you want, and then click Plug-In
Properties on the shortcut menu.
2. Select the Hide plug-in check box, and then click OK.

Delete a plug-in
1. In Page view, at the bottom of the document window, click Design .
2. Click the plug-in, and then press DELETE.

About advanced controls
By using advanced controls in Microsoft FrontPage, you can add functionality to
a Web site. You can choose from two types of ActiveX advanced controls.
Browse-time controls, are available to site visitors when they are viewing a page
in a Web browser. Design-time controls (DTCs) are available when you are
creating a Web page in FrontPage.
Some advanced controls may not be suitable, or simply will not work, on a Web
page. Originally used as tools by software developers, advanced controls
prevented the need to rewrite commonly used pieces of code. Controls designed
explicitly for software creation will not work in FrontPage or on the World Wide
Web.
Browse-time controls
ActiveX browse-time controls run when a Web page containing the control is
loaded in Microsoft Internet Explorer. Some ActiveX controls are installed as
part of Microsoft Windows 95 or later, and many are installed along with certain
types of software. ActiveX controls can execute a wide range of behaviors,
which may include displaying calendars or stock tickers.
Design-time controls
DTCs are a special type of ActiveX control that you can use in FrontPage. For
example, software developers sometimes write DTCs to use in creating content
on a Web page during design time. When that Web page is browsed, a site visitor
sees only the output of the advanced control, which is usually text.
Note Security vulnerabilities in external files or controls may extend to Web
pages that use those items. For example, external style sheets (files with a .css
extension), script files (files with a .js extension), custom ASP.NET controls, or
other items, may pose a security risk. Be sure your style sheets, add-ins, themes,
executables, scripts, controls, or other files come from trusted sources.

About adding and removing
advanced controls from FrontPage
Whenever you download, register, or install an advanced control on your
computer, it is automatically added to the list of available advanced controls in
Microsoft FrontPage. Similarly, when you remove an advanced control from
your computer, it is automatically removed from that list.
You can specify which advanced controls you want to be available in FrontPage
by adding or removing them from the list of advanced controls.This can be
helpful because some of the advanced controls on your computer may not be
suitable, or simply will not work, on a Web page. By removing them from the
list you can help ensure that you don't use an inappropriate advanced control
when you're designing a Web page.
Important Security vulnerabilities in external files or controls may extend to
Web pages that use those items. For example, external style sheets (files with a
.css extension), script files (files with a .js extension), custom ASP.NET controls,
or other items, may pose a security risk. Be sure your style sheets, add-ins,
themes, executables, scripts, controls, or other files come from trusted sources.
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Add an advanced control
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
On the Insert menu, click Web Component.
In the Component type list, click Advanced Controls.
In the Choose a control list, do one of the following:
To add a design-time control, click Design time control.
If the Design time control option is unavailable, no design-time
controls are installed on your computer.
To add an ActiveX control, click ActiveX control

5. Click Next.
6. Click the advanced control you want, and then click Finish.
Notes
Security vulnerabilities in external files or controls may extend to Web
pages that use those items. For example, external style sheets (files with a
.css extension), script files (files with a .js extension), custom ASP.NET
controls, or other items, may pose a security risk. Be sure your style sheets,
add-ins, themes, executables, scripts, controls, or other files come from
trusted sources.
Design-time controls (DTCs) that rely on data bindings may not function
properly, or may have limited functionality, in Microsoft FrontPage.
Consult the documentation for the DTC to determine if you can use it
properly in FrontPage.

Add or remove an advanced control
from FrontPage
1. On the Insert menu, click Web Component.
2. In the Component type list, click Advanced Controls.
3. In the Choose a control list, do one of the following:
To add or remove a design-time control, click Design-Time Control.
If the Design-Time Control option is unavailable, no design-time
controls are installed on your computer.
To add or remove an ActiveX control, click ActiveX Control.
4. Click Next.
5. Click Customize.
6. In the Control list, select or clear the check box next to the advanced
control you want to add or remove.
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Set the properties of an advanced
control
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the advanced control, and then do one of the following on the
shortcut menu:
If the advanced control is a design-time control (DTC), click DesignTime Control Properties.
If the advanced control is an ActiveX control, click ActiveX Control
Properties.
3. Click the Object Tag tab, and then do any of the following:
To specify a name for the advanced control, type a name in the Name
box.
To specify the alignment of the advanced control, click a value in the
Alignment list.
To specify the border thickness (in pixels) of the advanced control,
type a value (in pixels) in the Border thickness box.
To specify the horizontal spacing (in pixels) of the advanced control,
type a value in the Horizontal spacing box.
To specify the vertical spacing (in pixels) of the advanced control, type
a value in the Vertical spacing box.
To specify the width (in pixels) of the advanced control, type a value
in the Width box.
To specify the height (in pixels) of the advanced control, type a value
in the Height box.
To specify alternative text that will be displayed in Web browsers
without ActiveX support, type the text in the HTML box.

To specify a network or Internet location from which the control can
be automatically installed, type the path in the Code Source box.
4. Click the Parameters tab, and then do one of the following:
To add a parameter, click Add, select the options you want, and then
click OK.
To modify a parameter, click Modify, select the options you want, and
then click OK.
To remove a parameter, click Remove, select the options you want,
and then click OK.
5. If additional properties are available for the advanced control, set any
additional properties you want. Because an advanced control may have
unique properties, see the documentation for the advanced control to learn
about its specific properties.

Delete an advanced control
1. In Page view, at the bottom of the document window, click Design .
2. Select the advanced control, and then press DELETE.
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Specify the script language for
design-time controls
1. In Page view, at the bottom of the document window, click Design .
2. On the File menu, click Properties, and then click the Advanced tab.
3. Do one of the following:
Select server script languages
Under Design-time control scripting, in the Server list, select the
type of script you want to use. Select Inherit from Web site if you
want to use the default scripting language for the current Web site.
Select client script languages
Under Design-time control scripting, in the Client list, select the type
of script you want to use. Select Inherit from Web site if you want to
use the default scripting language for the current Web site.
Note If a given design-time control (DTC) specifies which scripting language
the control writes, the control settings will override the setting you choose here.

Specify the script platform for designtime controls
1. In Page view, at the bottom of the document window, click Design .
2. On the File menu, click Properties, and then click the Advanced tab.
3. Under Design-time control scripting, in the Platform list, select Client
(IE 4.0 DHTML) to execute script on the client, or Server (ASP) to
execute script on the server.
Notes
Depending on how they were designed, not all design-time controls (DTCs)
will be affected by the Design-time control scripting setting.
If a given DTC specifies whether the control executes script on the server
or the client, the control settings will override the setting you choose here.
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About previewing Web pages
By using Microsoft FrontPage, you can simulate how Web pages will look in
different Web browsers and window sizes. This can help you design and develop
your pages according to preferences of your site visitors. You can preview Web
pages in the following ways:
Designing pages
While you're designing a Web page, it's often difficult to know what portion of
the page will be visible to site visitors who have different screen resolutions or
window sizes. You can simulate many of these in Page view by using page size
settings, which can help you determine what portion of a page will be visible to
the site visitor.

A page in Page view
The same page in Page view with a page size setting turned on
Previewing pages
By using Preview view, you can quickly determine whether the page you are
designing will appear as expected in a Web browser. Because you can use
Preview view without having to save your Web page— whereas using Preview
in Browser requires you to save your changes— Preview view is often more
useful for previewing design ideas that you're not yet ready to commit to.

A page in Design view
The same page in Preview view
Browsing pages
For the most accurate simulation of how a Web page will appear to site visitors,
save or publish it, and then preview it by using one or more Web browsers.
Preview by using a single browser
If your site visitors exclusively use one type of browser, you might want to limit
your preview of pages to that particular browser. Even when you preview pages
by using one browser, you can open the browser at different window sizes to
provide an example of how the page could appear to site visitors who have
different screen resolutions, or who size their browser windows differently.
The window sizes you can choose match standard screen resolutions of
640×480, 800×600, and 1024×768. FrontPage automatically selects the value
that matches your current screen resolution, as well as available lower values.
Window sizes that are greater than your current screen resolution are
unavailable.
Preview by using multiple browsers
FrontPage recognizes, by default, some Web browsers such as Netscape
Navigator and Microsoft Internet Explorer. Each time you start FrontPage, it
checks for recently installed browsers and adds any new browsers that it
recognizes to the browser preview list. If more than one browser is installed on
your computer, you can open your Web page in any or all of those browsers. You
can also choose to open all available browsers to a specific window size.

Before you can preview a Web page in a browser, you must first save it. You can
either save the page manually each time you want to preview the page, or you
can save the page automatically each time you preview the page.
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Add a page size setting in Page view
1. In Page view, at the bottom of the document window, click Design or
Preview .
2. On the View menu, point to Page Size, and then click Modify Page Sizes.
3. Click Add.
4. In the Width box, type the width in pixels.
5. In the Height box, type the height in pixels.
6. In the Description box, type a description of the window size.
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Add a Web browser to the browser
preview list
1. On the File menu, point to Preview in Browser, and then click Edit
Browser List.
2. Click Add.
3. In the Name box, type the name of the Web browser as you want it to
appear in the browser preview list.
4. In the Command box, type the name and path of the .exe file for the Web
browser, or click Browse to locate the file.
5. Click OK.
6. Under Additional window sizes, select the check boxes next to the values
that represent the window sizes you want to enable.
Note The default window sizes match standard Microsoft Windows screen
resolutions of 640×480, 800×600, and 1024×768. Microsoft FrontPage
automatically selects the value that matches your current screen resolution and
available lower values. Window sizes that are greater than your current screen
resolution are unavailable.
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Change the page size in Page view
1. In Page view, at the bottom of the document window, click Design or
Preview .
2. On the View menu, point to Page Size, and then do one of the following:
To limit the page size to specific dimensions, click the size you want.
Dashed lines appear and indicate which vertical sections of the page
will appear in each screen for that size. If the window size has fewer
pixels than your window size, gray areas appear next to the page and
indicate the horizontal layout of the page for that size.
To maximize the page, click Current Page Size.
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Change a page size setting in Page
view
1. In Page view, at the bottom of the document window, click Design or
Preview .
2. On the View menu, point to Page Size, and then click Modify Page Sizes.
3. In the list, click the page size you want to change, and then click Modify.
4. Type a new width or height, in pixels, or a description of the window size.

Delete a page size setting in Page view
1. In Page view, at the bottom of the document window, click Design or
Preview .
2. On the View menu, point to Page Size, and then click Modify Page Sizes.
3. In the list, click the page size you want to delete, and then click Remove.

Specify support for features that
require specific browsers
1. On the Tools menu, click Page Options, and then click the Authoring tab.
2. In the Browsers list, click a browser type.
3. In the Browser versions list, click a browser version.
Note Some options may be unavailable, depending on the option you selected in
the FrontPage and SharePoint technologies list.

Turn support on or off for features
that require SharePoint Services
If your Web site is located on a server running Microsoft SharePoint Services
(SharePoint Team Services v1.0 from Microsoft or Microsoft Windows
SharePoint Services), you can turn support on or off for features that are
compatible with your Web server:
1. With a Web site open, on the Tools menu, click Page Options, and then
click the Authoring tab.
2. Under FrontPage and SharePoint technologies, select or clear the
SharePoint Services check box.

Automatically save a page before
previewing
1. On the File menu, point to Preview in Browser, and then click Edit
Browser List.
2. Select the Automatically save page before previewing check box.

Preview a page in one or more
browsers
1. In Page view, at the bottom of the document window, click Design .
2. On the File menu, point to Preview in Browser, and then do one of the
following:
To open your page in a single Web browser, click the browser you
want.
If the options include several entries for the same browser, the numeric
values next to the browser name indicate the window sizes at which
the browser will open if you click that option.
To open your page in all available browsers and at the default window
sizes of those browsers, click Preview in Multiple Browsers.
This option is only available if you have more than one browser
configured in Microsoft FrontPage.
To open your page in all available browsers and to a specific window
size, click the option you want, if any other options are available.
Notes
The available options may include browser names only, depending on
whether you have specified that you want the Edit Browser List to show
additional window sizes.
Before you can preview your Web page in any browser, you must first save
the page.
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About publishing files and folders
Overview of publishing a Web site
When you publish a Web site, you are copying all of the files and folders that
make up the site from one source location to a particular destination. In
Microsoft FrontPage, you publish your site when you want to make it available
for site visitors, when you want to make a backup copy of your site, or when you
want to update a published site with new content.
Generally, you create files and folders for your Web site on your computer.
When you are ready to let site visitors see your site on the World Wide Web or
on your organization's intranet, you publish them where site visitors can view the
Web pages by using a Web browser.
There may be times when you want to make a copy of your Web site and then
save it to a particular location on your hard disk or on a network drive. The
publishing feature in FrontPage is a convenient way to make a backup copy.
When you update your Web site with new files or folders, FrontPage uses
specific terms to distinguish between the source site and the destination site. A
local Web site is the source Web site open in FrontPage, and a remote Web site is
the destination site you are publishing to.
Using Remote Web Site view to publish
Remote Web Site view lets you publish in both directions, moving files easily
between local and remote locations. This can be most helpful when you are
updating a site you have already published.
Remote Web Site view displays icons, with descriptive text, in both the local
and remote Web site panes to indicate the publish status of your files.
You can use Remote Web Site view to publish your files to any location. You
can publish your site to an extended Web server, to Web servers that support File
Transfer Protocol (FTP) or Web-based Distributed Authoring and Versioning
(WebDAV), or to a location on your file system.

Deciding where to publish
Publish files and folders to an extended Web server
In Microsoft FrontPage, an extended Web server is one that is running FrontPage
2000 Server Extensions from Microsoft or later, Microsoft Windows SharePoint
Services, or SharePoint Team Services v1.0 from Microsoft. There are several
benefits to publishing to a Web server that is running the FrontPage Server
Extensions or Windows SharePoint Services. Your Web site will have enhanced
functionality when it is published, allowing you to use form handlers and hit
counters. FrontPage will also maintain your files and hyperlinks each time you
publish the Web site.
Important When publishing or synchronizing between Web sites based on
SharePoint Services, certain elements, including list data, schemas, and Web
Parts, will not be transferred.
Publish files and folders to a server that supports WebDAV or FTP
You can publish files and folders in your Web site to servers that support Webbased Distributed Authoring and Versioning (WebDAV) or File Transfer
Protocol (FTP). Multiple users can use Microsoft FrontPage and Macromedia
Dreamweaver to edit the same site over FTP. It's important to note, however, that
the source control functionality in FrontPage is turned off by default.
FrontPage also supports passive FTP. Passive FTP allows you to publish files
and folders from the local Web site to the remote Web site by using a different
port each time.
When you use Remote Web Site view to publish your files or folders to a server
that supports FTP or WebDAV, you must know the server name as well as your
user name and password. If you are unsure about your user name, password, or
server location, contact your Internet service provider (ISP) or Web site
administrator.
Publish files and folders to a file system
You can publish the files and folders in your Web site to a folder on your local

file system or to a UNC path. For example, you can make a backup copy of your
entire Web site by publishing it to a new disk-based location, such as C:\Backup.
Publishing files and folders rather than just copying them ensures that they will
maintain their structure and that the Microsoft FrontPage components on your
Web pages will work.
Choosing the files to publish
By default, all files are marked for publishing. By using Remote Web Site view
in Microsoft FrontPage, you can choose which files will be published and which
will be held back. There are some files that you should not republish. For
example, if your Web site has a guest book, republishing the guest book file will
cause it to be replaced by a blank one. Other examples include pages with a hit
counter or discussion Web sites.
Synchronizing files between sites
In collaborative work environments, multiple authors may update both the local
and remote Web sites. Microsoft FrontPage will compare the files in the local
Web site to the published files in the remote Web site.
The following points highlight scenarios in which local and remote versions of
files require that you synchronize them:
An author publishes to a staging server to test the files before making them
visible to the public.
An author changes a file directly on the remote site, leaving the local
version of that file out of date.
Two authors, one working on a local version of the Web site and one
working directly on the remote Web site, update their respective versions of
the same file.
Two authors, working with copies of the same Web site on their own
computers, make changes to the same sets of files, and both want to publish
to the remote site.
If FrontPage detects a newer version of a file on your local Web site, it will
begin a synchronization to update both the local and remote Web sites, unless
you specify otherwise. You can also choose to publish from the remote Web site

to your local Web site.
Security When you synchronize files using the Remote Web Site view, files on
the remote site will be downloaded to the local site. If malicious files were
placed on the remote site, the local site may be at risk. Be sure that only trusted
users have access to the remote site before you attempt to synchronize files.
Managing the files on the Web server
If your Internet service provider (ISP) or system administrator has given you a
size limit on the Web server, file management is a necessity. Periodically
deleting unused or old files can keep the size of your Web site down.
Because Microsoft FrontPage automatically synchronizes the files on your local
drive, you must first delete or move the files or folders on your local Web site.
Once you have published your Web site, FrontPage will prompt you about
deleting the same files on the Web server.
If your Web server uses the FrontPage Server Extensions from Microsoft or
Microsoft Windows SharePoint Services, FrontPage can also match other actions
on the Web server — such as moving or renaming files — the next time you
publish your Web site. FrontPage will update your link bars, shared borders, and
hyperlinks on the Web server to match the actions you performed on the local
Web site.
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Publish files and folders to an
extended Web server
In Microsoft FrontPage, an extended Web server is one that is running FrontPage
2000 Server Extensions from Microsoft or later, Microsoft Windows SharePoint
Services, or SharePoint Team Services v1.0 from Microsoft.
Set the remote Web site properties
1. On the View menu, click Remote Web Site.
2. At the top of the document window, click Remote Web Site Properties.
3. On the Remote Web Site tab, under Remote Web server type, click
FrontPage or SharePoint Services.
4. In the Remote Web site location box, type the Internet address, including
the protocol, of the remote Web site that you want to publish folders and
files to — for example, http://www.example.com — or click Browse to
locate the site.
5. Do any of the following:
To use Secure Sockets Layer (SSL), click Encryption connection
required (SSL).
To use SSL connections on your Web server, the server must be
configured with a security certificate from a recognized certificate
authority. If the server does not support SSL, clear this check box.
Otherwise, you will not be able to publish folders and files to the
remote Web site. If you are not sure whether your Web site supports
SSL, check with your Web server administrator or Internet service
provider (ISP).
To remove specific types of code from Web pages as they are being
published, on the Optimize HTML tab, select the options you want.
To change the default options for publishing, on the Publishing tab,
select the options you want.
6. Click OK.

Mark files that you do not want to publish
In the Local Web site pane, right-click each file that you do not want to
publish, and then click Don't Publish on the shortcut menu.
Important If your Web site contains a Microsoft Windows SharePoint Services
document library, list, or survey, it is recommended that you author your Web
site directly on a server that is running Windows SharePoint Services.
Publish files and folders to a file system
1. Under the Remote Web site pane, under Publish all changed pages, click
Local to remote.
2. Click Publish Web site.
Note If you stop a publish in progress, files that have already been published
will remain on the remote Web site.
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Publish files and folders to a file
system
Set the remote Web site properties
1. On the View menu, click Remote Web Site.
2. At the top of the document window, click Remote Web Site Properties.
3. On the Remote Web Site tab, under Remote Web server type, click File
System.
4. In the Remote Web site location box, type the address of the remote Web
site that you want to publish folders and files to — for example, C:\My Web
Sites\Web Site 1 if the location is on your computer or
\\MyNetworkShare\My Web Site if the location is on a file server — or
click Browse to locate the site.
5. Do any of the following:
To remove specific types of code from Web pages as they are being
published, on the Optimize HTML tab, select the options you want.
To change the default options for publishing, on the Publishing tab,
select the options you want.
6. Click OK.
Mark files that you do not want to publish
In the Local Web site pane, right-click each file that you do not want to
publish, and then click Don't Publish on the shortcut menu.
Publish files and folders to a file system
1. Under the Remote Web site pane, under Publish all changed pages, click
Local to remote.
2. Click Publish Web site.
Note If you stop a publish in progress, files that have already been published
will remain on the remote Web site.
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Publish files and folders to an FTP
server
To publish files and folders in a Web site to a Web server that supports File
Transfer Protocol (FTP), you must open and save a copy of the site to your
computer, edit the files and folders in that copy, and then publish the updated
files and folders to the server.
Do the following:
Set the remote Web site properties
1.
2.
3.
4.

5.

6.

7.

8.

On the View menu, click Remote Web Site.
At the top of the document window, click Remote Web Site Properties.
On the Remote Web Site tab, under Remote Web server type, click FTP.
In the Remote Web site location box, type the address, including the FTP
protocol, of the remote Web site that you want to publish folders and files
to — for example, ftp://example.com — or click Browse to locate the site.
If you want to view a specific folder when you connect to the site, in the
FTP directory box, type the path to the folder — for example,
www/images.
If the server that hosts the remote Web site uses a different port each time
you publish files and folders to the site, select the Use Passive FTP check
box.
Do any of the following:
To remove specific types of code from Web pages as they are being
published, on the Optimize HTML tab, select the options you want.
To change the default options for publishing, on the Publishing tab,
select the options you want.
Click OK.
Verify and add file name extensions to transfer as ASCII

1. On the Tools menu, click Options.
2. Click the FTP tab.

3. If the file name extension for the type of file you plan to publish is not in
the list, under New Extension, type the file name extension, and then click
Add.
Note If the file name extension for a file type does not appear in the list,
Microsoft FrontPage publishes files of that type in binary format.
Mark files that you do not want to publish
In the Local Web site pane, right-click each file that you do not want to
publish, and then click Don't Publish on the shortcut menu.
Publish files and folders to Web server that supports FTP
1. Under the Remote Web site pane, under Publish all changed pages, click
Local to remote.
2. Click Publish Web site.
Note If you stop a publish in progress, files that have already been published
will remain on the remote Web site.
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Publish files and folders to a
WebDAV server
To publish files and folders in a Web site to a Web server that supports Webbased Distributed Authoring and Versioning (WebDAV), you must open and
save a copy of the site to your computer, edit the files and folders in that copy,
and then publish the updated files and folders to the server.
Do the following:
Set the remote Web site properties
1. On the View menu, click Remote Web Site.
2. At the top of the document window, click Remote Web Site Properties.
3. On the Remote Web Site tab, under Remote Web server type, click
WebDAV.
4. In the Remote Web site location box, type the Internet address, including
the protocol, of the remote Web site that you want to publish folders and
files to — for example, http://www.example.com — or click Browse to
locate the site.
5. Do any of the following:
To use Secure Sockets Layer (SSL), click Encryption connection
required (SSL).
To use SSL connections on your Web server, the server must be
configured with a security certificate from a recognized certificate
authority. If the server does not support SSL, clear this check box.
Otherwise, you will not be able to publish folders and files to the
remote Web site. If you are not sure whether your Web site supports
SSL, check with your Web server administrator or Internet service
provider (ISP).
To remove specific types of code from Web pages as they are being
published, on the Optimize HTML tab, select the options you want.
To change the default options for publishing, on the Publishing tab,

select the options you want.
6. Click OK.
Mark files that you do not want to publish
In the Local Web site pane, right-click each file that you do not want to
publish, and then click Don't Publish on the shortcut menu.
Publish files and folders to a Web server that supports WebDAV
1. Under the Remote Web site pane, under Publish all changed pages, click
Local to remote.
2. Click Publish Web site.
Note If you stop a publish in progress, files that have already been published
will remain on the remote Web site.

Publish files from a remote Web site
to a local Web site
1. On the View menu, click Remote Web Site.
2. In the Local Web site pane, right-click each file that you do not want to
publish, and then click Don't Publish on the shortcut menu.
3. Under the Remote Web site pane, under Publish all changed pages, click
Remote to local.
4. Click Publish Web site.
Note If you cancel a publish in progress, files that have already been published
will remain on the destination Web server.

Set a remote Web site location
1. On the View menu, click Remote Web site.
2. At the top of the document window, click Remote Web Site Properties.
3. Under Remote Web server type, click the type of Web server that you
want to publish your Web site to.
4. By the Remote Web site location box, click Browse.
5. Locate and click the remote Web site location that you want, and then click
Open.

Synchronize between a local and a
remote Web site
Security When you synchronize files using the Remote Web Site view, files on
the remote site will be downloaded to the local site. If malicious files were
placed on the remote site, the local site may be at risk. Be sure that only trusted
users have access to the remote site before you attempt to synchronize files.
1. On the View menu, click Remote Web Site.
2. Do one or both of the following:
In the Local Web site pane, right-click each file that you do not want
to publish, and then click Don't Publish on the shortcut menu.
In the Remote Web site pane, right-click each file that you do not
want to publish, and then click Don't Publish on the shortcut menu.
3. Under the Remote Web site pane, under Publish all changed pages, click
Synchronize.
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Identify and resolve errors on a page
Do one or both of the following:
Identify and resolve Web component errors
1. On the View menu, point to Reports, point to Problems, and then click
Component Errors.
2. To open a page to edit it, double-click the row in the report that corresponds
to the page.
Identify and resolve hyperlink errors
1. On the View menu, point to Reports, point to Problems, and then click
Hyperlinks.
2. To edit the hyperlink, double-click the row in the report that corresponds to
the hyperlink.

Delete a published file or folder
1. On the View menu, click Remote Web Site.
2. In the Remote Web site pane, click the file you want to delete.
The Remote Web site pane indicates the files that you have published.
3. Above the Remote Web site pane on the right, click

.

Note When you delete a file or folder from the remote Web site, it still exists on
your local computer unless you click above the Local Web site pane on the
left, to delete it completely from the local Web site.
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Troubleshoot publishing files and
folders
After I publish my Web site, some components don't work.
You may have published to a Web server that does not have the most recent
version of the FrontPage Server Extensions from Microsoft or Microsoft
Windows SharePoint Services. Without the server extensions, certain features
will not work, such as most form handlers and hit counters.
Check with your Internet service provider (ISP) or Web site administrator to find
out if the Web server you are publishing to has the server extensions or Windows
SharePoint Services installed.
I want to publish a file that I originally set as Don't Publish.
The Don't Publish command is a toggle. To publish a file that is currently set to
Don't Publish, do the following:
In the Folder List, right-click the file you want, and then click Don't
Publish on the shortcut menu.
If the Folder List is hidden, on the View menu, click Folder List.
I republished a Web site with a guest book that contained comments from
site visitors, and now the guest book pages are blank.
You should always publish your Web site before you republish certain files that
contain Web components, such as guest book forms, hit counters, or discussion
Web sites. If you have created and published a Web site that includes a guest
book, and then later update your Web site and republish all of your files, your
guest book will be replaced by a blank one.

Export a file from a Web site
1. In Folders view, click the file that you want to export.
2. On the File menu, click Export.
3. Locate and click the destination Web site or folder that you want to export
the file to, and then click Save.
4. To export additional files, repeat all three steps for each file.
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About reports
Reports in Microsoft FrontPage enable you to gather, analyze, and summarize
Web site statistics in a variety of ways.
Site Summary
Site Summary reports display an overview of your Web site's vital statistics, such
as the number and sizes of files and pictures, number and types of hyperlinks,
and more.
Files
Files reports display an overview of the age of files, who is working on them,
when they were modified or added to your Web site, and more.
Shared Content
Shared Content reports display information about the features of your Web site
that work on groups of pages, such as themes, styles, dynamic Web templates,
and shared borders.
Problems
Problems reports display problems with your Web site, including broken links,
component errors, files that take too long to download, and more.
Workflow
Workflow reports indicate the status of the files and assignments in your Web
site, including the review status, who the file is assigned to, whether it's checked
out using source control, and more.
Usage
Usage reports display information about the visits to your Web site, including

page hits, browsers used by site visitors, referring URLs, and more. Usage
reports are available only for top-level sites and subsites hosted on Web servers
running Microsoft Windows SharePoint Services, SharePoint Team Services
v1.0 from Microsoft, or FrontPage 2002 Server Extensions from Microsoft.
Usage processing must also be turned on for the Web server. Additionally, if the
site is based on Windows SharePoint Services, you must have administrator
privileges.

View a report
Open the Web site for which you want to view a report.
On the View menu, point to Reports, and then select one of the following
types of reports:
Files Shows file status information.
Shared Content Shows the use of style application.
Problems Shows site maintenance problem reports.
Workflow Shows workflow status reports.
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Apply or remove filters in reports
You can filter Web site data and display only the information that is relevant to
you in Reports. By filtering the data, you can display only those rows that satisfy
the conditions specified in the column. You can filter the following types of
reports in Microsoft FrontPage: Files, Shared Content, Problems, and Workflow.
Apply a filter
Open an existing Web site in FrontPage, and do the following:
1. On the View menu, point to Reports, click the report type, and then click
the report you want to filter.
2. On the column label, click
and select the condition you want to filter for
from the list.
Tip The filter settings are saved when you close the Web site. If you can't find
files in a new report, you may have filters applied from a previous session.
Remove a filter
To remove filters from a report, do the following:
Right-click anywhere on the report and click Remove Filters on the
shortcut menu.
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Save or copy a Web site report
When you generate reports in Microsoft FrontPage, you can save or copy the
data to HTML or into other Microsoft applications, such as Microsoft Excel.
This is useful for archiving report data or for sharing it with others. You can save
or copy report data from the following types of reports: Files, Shared Content,
Problems, and Workflow.
Save Web site report data
Open an existing Web site in FrontPage, and do the following:
1. On the View menu, point to Reports, point to the report type, and then
click the report you want to run.
2. On the File menu, click Save As.
3. Select the location where you want to save the file.
4. You can accept the default names for the file name and page title, or create
new ones by doing the following:
To change the file name, type a new name in the File name text box.
To change the page title, click Change title and type the new page
title.
5. Click Save.
Copy Web site report data
Open an existing Web site in FrontPage, and do the following:
1. On the View menu, point to Reports, point to the report type, and then
click the report you want to run.
2. Right-click anywhere in the report, and then click Copy Report.
3. Open another Microsoft Office program, such as Microsoft Excel, rightclick a cell in the worksheet or document, and click Paste.

Specify settings to indicate slow pages
Microsoft FrontPage defines a slow page as one that takes 30 seconds or longer
to load using a 56 kilobits per second (Kbps) modem.
To change the way a slow page is defined, do the following:
1. On the Tools menu, click Options, and then click the Reports View tab.
2. In the Assume connection speed of box, select the connection speed of
your target audience.
3. In the "Slow pages" take at least box, type or select the number of
seconds that define a slow page at the assumed connection speed.
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Specify the range for recent and older
files
Microsoft FrontPage defines a recent file as one that has been created within the
last 30 days, and defines an older file as one that that hasn't been modified in the
last 72 days.
Define recent files
1. On the Tools menu, click Options, and then click the Reports View tab.
2. In the "Recent" files are less than box, type or select the number of days.
Define older files
1. On the Tools menu, click Options, and then click the Reports View tab.
2. In the "Older" files are more than box, type or select the number of days.

Show or hide gridlines in reports
Open an existing Web site in Microsoft FrontPage, and do the following:
1. On the Tools menu, click Options, and then click the Reports View tab.
2. Select or clear the Display gridlines when viewing reports check box.

View Web server information
On the Tools menu, click Site Settings, and then click the General tab.
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Troubleshoot reports
Why are some images or other files in my Web site not represented in my
Site Summary reports?
The Site Summary report does not, by default, display a summary of information
for hidden files and folders. If your Web site contains files located in hidden
folders, and you want those files to be included in this report, do the following:
1. On the Tools menu, click Site Settings, then click the Advanced tab.
2. Select the Show hidden files and folders check box.
Why am I not able to run a report that provides usage information about
my Web site?
Usage reports are available only for top-level sites and subsites that are hosted
on Web servers running SharePoint Team Services v1.0 from Microsoft,
Microsoft Windows SharePoint Services, or FrontPage 2002 Server Extensions
from Microsoft. Usage processing must also be turned on for the Web server.
Additionally, if the site is based on a server running Windows SharePoint
Services, you must have administrator privileges for that server.
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Convert a Web site or subsite to a
subfolder
Warning When you convert a Web site or subsite to a subfolder, many of the
Web site settings can be lost, including hyperlinks in navigation bars and tasks
associated with the pages.
1. In Folders view, right-click the Web site or subsite that you want to convert
to a subfolder.
2. Click Convert to Folder on the shortcut menu.
Note The larger the contents of the Web site or subsite, the longer it takes to
convert it to a folder.
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Convert a subfolder to a Web site
Warning When you convert a subfolder to a Web site or subsite, many of the
Web site settings can be lost, including hyperlinks in navigation bars and tasks
associated with the pages.
1. In the Folder List, right-click the subfolder you want to convert to a Web
site.
If the Folder List is hidden, on the View menu, click Folder List.
2. Click Convert to Web on the shortcut menu.
Note The larger the contents of the subfolder, the longer it takes to convert it to
a Web site.

Delete a Web site or subsite
1. In the Folder List, right-click the Web site or subsite, and then click Delete
on the shortcut menu.
If the Folder List is hidden, on the View menu, click Folder List.
2. To confirm the deletion, click Yes.
Note You cannot delete a subsite unless you have administrative permissions on
the top-level site.

About categories
You can use categories in Microsoft FrontPage to organize files that are located
in separate folders into logical groups. For example, you could classify all of the
travel-related files in your Web site into a category titled Travel. You can either
use the built-in categories in FrontPage, or create your own custom categories.
You can also use categories to group your hidden files.
Once you have arranged your files into categories, you can then query them. By
filtering on the category names, you can display only the files that you want to
view.
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Categorize hidden files
In order to categorize files, you must open a Web site.
1. Show hidden files and folders.
How
1. On the Tools menu, click Site Settings.
2. Click the Advanced tab, and then select the Show hidden files and
folders check box.
2. On the View menu, point to Reports, point to Workflow, and then click
Categories.
3. Do one of the following:
Categorize a single hidden file
1. Right-click the file, and then click Properties on the shortcut menu.
2. Click the Workgroup tab.
3. In the Available Categories box, select the check boxes for the
categories that apply to the file.
Categorize a group of hidden files
1. Press and hold down CTRL, and then click the files that you want.
2. Right-click one of the selected files, and then click Properties on the
shortcut menu.
3. Click the Workgroup tab.
4. In the Available Categories box, select the check boxes for the
categories that apply to the files.
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Categorize files
In order to categorize files, you must open a Web site.
1. On the View menu, point to Reports, point to Workflow, and then click
Categories.
2. Do one of the following:
Categorize a single file
1. Right-click the file, and then click Properties on the shortcut menu.
2. Click the Workgroup tab.
3. In the Available Categories box, select the check boxes for the
categories that apply to the file.
Categorize a group of files
1.
2.
3.
4.

Press and hold down CTRL, and then click the files that you want.
Right-click the files, and then click Properties on the shortcut menu.
Click the Workgroup tab.
In the Available Categories box, select the check boxes for the
categories that apply to the files.

Add or remove a category
1. On the View menu, point to Reports, point to Files, and then click All
Files.
2. Right-click any file, click Properties on the shortcut menu, and then click
the Workgroup tab.
3. Click Categories, and then do one of the following:
To add a new category, type a name in the New category box, and
then click Add.
To remove a category, select it, and then click Remove.
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Create a task
Do one of the following:
Create a task on a Web page or site
1. On the View menu, click Tasks.
2. On the Edit menu, point to Tasks, and then click Add Task.
3. In the Task name box, type the name of the task.
4. Specify the settings that you want for this task:
In the Assigned to box, type or select the name of the person or
workgroup that you want to assign the task to.
In the Description box, type a description of the task.
Under Priority, click a priority that meets your expectations for the
task.
Create a task and associate it with a file on a Web site
You can assign a task to any type of file on a Web site; however, you can only
assign a task to one file at a time.
1. In the Folder List, click the file that you want to associate a task with.
If the Folder List is hidden, on the View menu, click Folder List.
2. On the Standard toolbar, click the arrow next to Create a new normal
page
.
3. Click Task.
4. In the Task name box, type the name of the task.
5. Specify the settings that you want for this task:
In the Assigned to box, type or select the name of the person or

workgroup that you want to assign the task to.
Next to Associated with, verify that the file name you want to
associate the task with is listed.
In the Description box, type a description of the task.
Under Priority, click a priority that meets your expectations for the
task.
Tip
You can create a task in Page view while editing a page, and the task is
automatically associated with that page. The name of the file associated with a
task, if any, is displayed in the Associated with field in the New Task dialog
box.

About tasks
You can track work items on your Web site by assigning tasks to people or to
workgroups. You can also add a description of the work item directly to the task.
You can associate these tasks with any file on your Web site — including a Web
page, a picture, a sound file, or another Microsoft Office System document.
By using Tasks view, you can monitor the most recent information about each
task. Each task has the following properties:
Status— Completed or in progress
Task— The task name
Assigned To— User name or workgroup
Priority— High, medium, or low
Associated With— The name of the file the task is associated with, if any
Modified Date— The last time the file was modified
Description— A description of the work that needs to be done
You can sort tasks by any of these properties.
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Change the status of a task
Do one of the following:
Start working on a task
1. On the View menu, click Tasks.
2. Do one of the following:
To start working on a task that is not associated with a file, right-click
the task, and then click Edit Task on the shortcut menu.
To start working on a task that is associated with a file, right-click the
task, and then click Start Task on the shortcut menu.
Notes
When you start a task that is associated with a Web page, Microsoft
FrontPage opens that page in Page view.
When you start a task that is associated with another type of file, the
file is opened in its associated editor. For example, Microsoft Office
Word 2003 is the associated editor for .doc files.
Mark a task as completed
To mark a task as completed in Task view
1. On the View menu, click Tasks.
2. Right-click the task you want to mark as completed, and then click Mark
Complete on the shortcut menu.
Mark a task as completed while editing an associated Web page
When you start a task that is associated with editing a Web page, the first
time you save the page in Page view, Microsoft FrontPage prompts you to
mark the task as completed. Click Yes.

Delete a task
1. On the View menu, click Tasks.
2. Right-click the task you want to delete, and then click Delete Task on the
shortcut menu.
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About reducing the download time of
your site
Adding graphic, audio, and video files to your Web site adds to the download
time for site visitors when they access your site. It is important to take into
consideration the size, type, and number of files that you want to add to your
site.
Reducing the download time of graphics
Resize and resample the graphic
Resizing a graphic changes attribute values for the HTML tag that tells a Web
browser how to display the graphic; the actual graphic file is not changed. If you
only resize the graphic, it will be displayed in a smaller area on a site visitor's
screen, but its file size and the download time are unchanged.
To decrease the file size of a graphic and its download time, you will need to
resample the graphic after resizing it.
Resampling a graphic changes its pixel size to match its current display size.
When you resample the graphic after resizing it, the file size is reduced to match
the smaller size.
Lower the quality setting for JPEG files
As you lower the quality setting, file compression increases and file size
decreases.
Lower the resolution of a high-resolution graphic
If you have a high-resolution graphic, make a copy of the graphic, open it in a
graphics program, and then make modifications to lower the resolution. You can
then reinsert the graphic in your Web page in its lower resolution format.

Display a low-resolution version of a graphic while downloading
In a graphics program, create a low-resolution version of a graphic. To do this,
open your file in a graphics editing program and reduce the color depth (number
of colors) in the graphic. The fewer colors you specify for the low-resolution
version of the graphic, the faster it will be displayed in a Web browser. Because
the low-resolution graphic is intended as a placeholder for the high-resolution
graphic, you should not change the height or width of the graphic.
Then, set Microsoft FrontPage to display this low-resolution version of your
graphic while the original is being downloaded. This gives the site visitor
something to look at while the page is loading.
Create a thumbnail
A thumbnail is a small version of the graphic that downloads quickly. By looking
at a thumbnail, site visitors can determine whether they want to download the
full-size version of the graphic. Use the AutoThumbnail feature, which
automatically creates a thumbnail with a hyperlink to the original, larger sized
graphic.
Display ALT text
Alternative text (ALT text) is displayed in place of a graphic while it is
downloading and lets site visitors know what they are waiting to see.
Reducing the download time of audio
Reuse sounds You can reduce audio file size by looping or reusing sounds.
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About using graphics
You can use graphics on your Web pages to display information, artwork,
photos, drawing objects, theme elements, or a company logo. In addition to
being decorative, graphics can be useful for items such as navigational buttons,
hot spots, and image maps. Microsoft FrontPage also gives you a variety of ways
to lay out the graphics on your Web pages.

Graphic used as a background
Banner graphic
Company logo
Graphical bullets
Link bar with graphic navigation buttons
Graphical horizontal line
Choose a file format
When you are ready to add graphics to your Web pages, you must determine
how you should format them. A graphics file in its natural state is too large to
download quickly over the Web, so you must reduce the size of the file by
compressing it.
The standard file formats for Web pages are GIF, JPEG, and more recently PNG.
There are many factors that determine which file format you will use for each

graphic. The best format depends on the type of graphic you're working with, the
size of the file, how small you want the graphic file to appear, and the way you
want the image to download.
GIF Graphics in GIF format are best when used with images that contain
only a few distinct colors, such as line drawings and black and white
images.
One of the advantages to GIF compression format is that you can interlace
it to improve the browser download experience. An interlaced GIF appears
first with poor resolution and then improves until the entire image arrives.
This allows the viewer to get an idea of what the graphic will look like
while they are waiting for the graphic to appear.
Another useful aspect of graphics in GIF format is that you can make the
background of a GIF transparent, so you see the background color of the
browser window you're in.
JPEG JPEG format is commonly used for photo-realistic graphics
containing thousands or millions of colors. Graphics in JPEG format are
useful because you can control the file compression by changing the
graphic quality. The lower you set the quality, the higher the file
compression will be. As a result, the file size is decreased.
Graphics in JPEG format permit a greater degree of compression than the
GIF format alternative, enabling quicker downloading times for larger
graphics. However, a browser can only download a graphic in JPEG format
linearly, from the top row to the bottom row.
PNG PNG format is an alternative to GIF and JPEG that supports
transparency for graphics containing thousands or millions of colors. Some
Web browsers cannot display graphics in PNG format without a special
plug-in. The following are the types of PNG formats that you can choose:
PNG-8 format is similar to GIF but it offers better 8-bit color support.
It efficiently compresses solid areas of color while preserving sharp
detail, such as that in line art, logos, or illustrations with type. This
format is not very common and it is not supported by all browsers.
PNG-24 format is also similar to GIF and it supports 24-bit color. Like
JPEG format, PNG-24 preserves the broad range and subtle variations

in brightness and hue found in photographs. Like the GIF and PNG-8
formats, PNG-24 preserves sharp detail, such as that in line art, logos,
or illustrations with type. This format is not very common and it is not
supported by all browsers.
Other types of file formats
You can also add graphics in the following file formats:
BMP The native bitmap format of the Microsoft Windows environment is a
picture made from a series of small dots and it supports images up to 24 bits.
WMF Microsoft Windows Metafile format supports bitmapped, vector, and
Encapsulated PostScript (EPS) data.
Add an animated GIF
An animated GIF is a type of graphic that you can use to create movement or
animation by combining several sequential images into a single GIF file. You
can create an animated GIF in a graphics program, and you can find animated
GIFs on the World Wide Web. You can then add them to your Web site.
The animation in this example plays once when the page is opened.
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Add a graphic to a Web page
You can add a graphic to your Web page from a variety of sources.
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point where you want to add a graphic.
3. Do one of the following:
Add a graphic from a file
1. On the Insert menu, point to Picture, and then click From File.
2. Locate the file you want to add, and then click Insert.
Add clip art from the Clip Organizer
1. On the Insert menu, point to Picture, and then click Clip Art.
2. In the Clip Art task pane, in the Search for box, type a word or phrase that
describes the clip you want.
If you want to limit your search to a specific clip art collection or file type,
do the following:
In the Search in list, clear the check boxes next to the collections you
do not want to search.
In the Results should be list, select the file types you want.
3. Click Go.
4. In the search results list, click the graphic you want to add.
Add a graphic from a scanner
1.
2.
3.
4.

On the Insert menu, point to Picture, and click From Scanner or Camera.
Under Device, click the device you want to add a graphic from.
Click the resolution that you want.
Do one of the following:
To add the graphic in its original form, click Insert.

To adjust the properties of the graphic, click Custom Insert, and then
select the graphics you want to add.
Add a graphic from a digital camera
1.
2.
3.
4.

On the Insert menu, point to Picture, and click From Scanner or Camera.
Under Device, click the device you want to add a graphic from.
Click Custom Insert.
Select the graphic that you want to add and then click Get Pictures.
Tip
To select more than one graphic, hold down CTRL and select the graphics
you want.

Notes
When you save the page, Microsoft FrontPage prompts you to save
embedded files to your Web site. Unless you specify otherwise, graphics
that use 256 or fewer distinct colors are automatically converted to GIF,
while all other graphics are converted to JPEG.
You can choose not to save the graphic to your Web site by clicking Set
Action in the Save Embedded Files dialog box, which appears when you
save a page. For local files, a reference to the graphic is created on your
page. However, if the graphic is removed from that location, you will no
longer see the graphic on your own page.
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Change a graphic to a different
format
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the graphic, and then click Change Picture File Type on the
shortcut menu.
3. Click the file format that you want.
4. Under Settings, select the options that you want.
For a GIF, you can specify whether to allow a transparent color and
whether the graphic is interlaced.
For a JPEG, you can specify the quality and number of progressive
passes. The lower the quality you set, the more the graphic will be
compressed. The number of progressive passes refers to the number of
passes that a Web browser will take in order to resolve a graphic as it
downloads.
Note Some Web browsers do not support progressive passes.
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Set the default settings of a GIF or
JPEG file
When you paste a graphic other than a GIF or JPEG into a page and then save it,
Microsoft FrontPage automatically attempts to convert the graphic to a GIF if it
has 256 bits of color or less, or to a JPEG if it has more than 256 bits of color.
To set the default settings for these file types, do the following:
1. On the Tools menu, click Page Options, and then click the Picture tab.
2. To define the way a file type is converted by default, click File Type
Settings, and then select the options you want.
3. Specify the default settings that you want.
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Change the properties of a graphic
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the graphic, and then click Change Picture File Type on the
shortcut menu.
If the graphic has one or more hot spots, right-click an area of the graphic
that is not a hot spot.
3. Change the properties for one of the following:
The graphic is in JPEG format
1. Under Settings, clear the Use image as is check box.
2. To specify the quality of the JPEG, enter a value from 1 to 100 in the
Quality box. This allows you to produce a smaller size file of the
graphic, thereby lowering the quality of the graphic.
3. In the Progressive passes box, enter the number of progressive passes
you want Web browsers to make.
Some Web browsers do not support progressive passes.
The graphic is in GIF format
To specify whether the graphic should be interlaced, under Settings,
select or clear the Interlaced check box.
To remove the transparency, if a transparent color has been set, clear
the Transparent check box.
Note If you want to change the properties of a PNG graphic, you must use a
graphics editing program.

Associate a file type with a program
By associating a file type with a program, you specify which program you want
to use when opening a specific type of file from within FrontPage. Note that the
setting you choose does not apply to your Microsoft Windows settings.
1. On the Tools menu, click Options.
2. Click the Configure Editors tab.
3. In the Extensions list, click the file name extension for the file type you
want to associate with a program.
If the file name extension doesn't appear in the list, click New Extension
, type the file name extension you want to add, and then click OK.
4. In the Editors list, click the program you want to associate with the file
type.
If the program doesn't appear in the list, click New Editor
program, and then click OK.
5. Click Make Default.

, select the
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Add text that describes a graphic
Alternative text can display for graphics, depending on the browser, when the
graphic is downloading, when it can't be found, or when a site visitor moves the
pointer over it.
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the graphic, click Picture Properties on the shortcut menu, and
then click the General tab.
3. Under Alternative representations, in the Text box, type the alternative
text for the graphic.

Specify a low-resolution version of a
graphic
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the graphic, click Picture Properties on the shortcut menu, and
then click the General tab.
3. Under Alternative representations, in the Low-Res box, type the file
name for the low-resolution graphic, or click Browse to locate it.
Note Some Web browsers do not recognize the low-resolution attribute when
rendering graphics.
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Troubleshoot graphics
I can't crop part of a photo gallery graphic.
Microsoft FrontPage can only crop photo gallery images down to a certain size.
If you find that your graphic is too large, you can insert it onto a blank page,
crop it like you would any other graphic, and then resave and reinsert it into your
photo gallery.
When I double-click a graphic to edit it in another editor, "No picture
editor is configured" appears.
You must first choose the picture editor you want to use to edit your graphics.
You will need to choose one for each type of graphic you want to edit. To choose
the picture editor, do the following:
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the graphic, point to Open With, and click Choose Program
on the shortcut menu.
3. Under Choose the program you want to use to open this file, click the
graphics editor that you want for this file type, and then click OK.
If you do not see the graphics editor you want in the list, click Browse for
more, locate and click the one you want, and then click Open.
Note You cannot specify a graphics editor for animated GIFs that is
different from the one you set for GIFs.
The graphic I inserted is not displaying in my Web site.
This can be caused by one of the following:
You acquired this graphic from another Web site
When you add a graphic to a Web page and then save it, you are prompted
to save that graphic to the Web site that contains that Web page. If you

acquired this graphic from a shared location or another site, and you didn't
save it to a folder in your site, the path to it will be broken if that graphic is
removed from the shared location or Web site, and it will not display on
your Web page.
You need to publish the image or the folder to where all other
graphics are located on your Web server
If you have a graphic that you are using for a Web page located in a local
folder, when you publish that Web page, you also need to publish the folder
where all the graphics are or all your graphics will appear to be broken.
When I click a hot spot, it returns a 404 error message.
This can be caused by one of the following:
The destination may have moved or may no longer exist Verify that
the file exists by viewing the destination file in your Internet Web browser
(if the file is on the Internet), or by using Microsoft Windows Explorer (if
the file is on your hard drive or a network).
You may not have access to the destination If the destination file is on
the Internet, make sure you have a connection to the Internet.
There may be a technical problem If you believe that the file you are
linking to exists and that you have permission to link to it, try deleting your
temporary Internet files.
How?
1. Open Microsoft Internet Explorer.
2. On the Tools menu, click Internet Options.
3. Under Temporary Internet Files, click Delete Files.
When I click a hot spot, it returns a 403 error message.
You may be trying to link to a page or directory that does not have anonymous
browsing permissions.
If the destination is on a network, contact your network administrator to
ensure that you have access to the destination file.

When I am resizing a graphic in percentages, the Keep aspect ratio check
box appears dimmed.
Microsoft FrontPage bases the percentage width or height of a graphic on a
portion of the browser window (or table cell) and the aspect ratio is not
preserved. If you want to preserve the aspect ratio, you must resize the graphic
by entering the width and height size in pixels.
I am unable to copy a photograph from my scanner or digital camera to the
photo gallery.
Some cameras and scanners require that you first install hardware drivers on the
computer that you will connect the camera or scanner to. See the instructions
from the manufacturer of your scanner or camera to determine if you need to do
this.
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About changing the appearance of
graphics
You can use Microsoft FrontPage to change graphics in the following ways:
Crop
By cropping a graphic, you can remove areas of the graphic that you don't want
to use. Cropping also lets you change the proportions of the graphic; for
example, you can crop a graphic so that it is shorter.
Original graphic Cropped graphic

Add text
You can add text on top of a graphic. The text you add will not affect the size of
the graphic file in your Web site.
Original graphic Graphic with text

Change brightness and contrast
You can increase or decrease the brightness of a graphic, as well as increase or
decrease the contrast of color in a graphic; for example, to sharpen a graphic.
More brightness

Less brightness

More contrast Less contrast

Apply a grayscale

You can convert a graphic to black and white (grayscale).
Grayscale

Add or remove borders
You can add a beveled border to a graphic to give it a raised, three-dimensional
appearance. This feature is useful if you want to use the graphic as a button. You
can also add a 1,2,3, or 4-sided border around a graphic and pick its style and
color.
Note If the graphic has a default hyperlink, the border will have the colors that
you specified for hyperlinks.
Beveled border Regular border

Set a transparent color
You can select one color in a graphic to be transparent, and then wherever that
color appears, the background will show through. Each graphic can have only
one transparent color. If you select a transparent color for a graphic that already
has one specified, the original transparent color will no longer be transparent.
Original graphic Transparent color

Rotate and flip
You can rotate a graphic 90 degrees clockwise or counterclockwise. You can also
flip a graphic horizontally (which turns the graphic upside down) or vertically
(which makes a mirror image).
Rotate left Rotate right
Flip horizontally Flip vertically

Show All

Add or remove a border from a
graphic
Do one of the following:
Add a border to a graphic
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the graphic, and then click Picture Properties on the shortcut
menu.
3. Under Layout, in the Border thickness box, type or select a value to
indicate the width of the border in pixels.
4. To specify the style of the border, click Style, click Format, click Border,
and then select the options you want.
Notes
If the graphic has a default hyperlink, the border will have the colors that
you specified for hyperlinks.
You cannot change a beveled border around a graphic.
Remove a border from a graphic
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the graphic, and then click Picture Properties on the shortcut
menu.
3. Under Layout, in the Border thickness box, type 0 to indicate zero pixels.
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Change the border around a graphic
1.
2.
3.
4.
5.
6.

In Page view, at the bottom of the document window, click Design .
Right-click the graphic, and click Picture Properties on the shortcut menu.
Under Layout, select the options you want.
Click Style.
Click Format, and then click Border.
Select the options you want.

Notes
You cannot change a beveled border around a graphic.
If the graphic has a default hyperlink, the border will have the colors that
you specified for hyperlinks.
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Add text to a graphic
1. In Page view, at the bottom of the document window, click Design .
2. Click the graphic to which you want to add text.
3. On the Pictures toolbar, click Text .
If the Pictures toolbar is hidden, right-click the graphic, and click Show
Pictures Toolbar on the shortcut menu.
4. Type the text you want.
5. On the Format menu, click Font, and then select the formatting options
you want.
6. You can also do one or more of the following:
To resize a text box, drag the handles on the text box border.
To move a text box, drag the border of the text box to a new location.
Tip
If the graphic is not in GIF format, Microsoft FrontPage will convert it. If you do
not want the graphic converted to GIF format, you can add the text to the graphic
by using a graphics editing program and then save the graphic file to your Web
site.
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Add a graphic background to text
1. In Page view, at the bottom of the document window, click Design .
2. Select the paragraphs that you want to add a background to.
3. On the Format menu, click Borders and Shading, and then click the
Shading tab.
4. Under Patterns, in the Background picture box, type the location of the
graphic you want to use.
5. Set the properties for the background graphic.
How?
Do one or more of the following:
In the Vertical position and Horizontal position boxes, specify how
you want to align the graphic.
In the Repeat box, specify how you want to tile the graphic.
For example, to tile the graphic horizontally, click repeat-x. To tile the
graphic vertically, click repeat-y.
In the Attachment box, specify whether the background graphic
should be fixed relative to the browser window, or whether it should
scroll with the document.

Crop a graphic
By cropping a graphic, you can remove areas of the graphic that you don't want
to use.
1. In Page view, at the bottom of the document window, click Design .
2. Click the graphic.
3. On the Pictures toolbar, click Crop .
If the Pictures toolbar is hidden, right-click the graphic, and then click
Show Pictures Toolbar on the shortcut menu.
4. Drag the handles of the cropping box to resize and include the part of the
graphic that you want to keep.
5. Click Crop
again to remove the area outside of the cropping box.

Rotate or flip a graphic
1. In Page view, at the bottom of the document window, click Design .
2. Click the graphic.
If you want to rotate or flip the background graphic, you do not need to
make a selection.
3. On the Pictures toolbar, do any one of the following:
If the Pictures toolbar is hidden, right-click the graphic, and click Show
Pictures Toolbar on the shortcut menu.
To rotate a graphic 90 degrees counterclockwise, on the Pictures
toolbar, click Rotate Left 90º
degrees clockwise, click Rotate Right 90º

. To rotate a graphic 90
.

To flip a graphic upside down, click Flip Vertical
flip a graphic to create a mirror image, click Flip Horizontal
.

. To
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Align a graphic
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the graphic, and then click Picture Properties on the shortcut
menu.
3. Click the Appearance tab, and then do one of the following:
Under Wrapping Style, click the option you want.
Under Layout, in the Alignment box, click an option to specify how
you want the graphic to be aligned on the page.
4. Under Layout, in the Horizontal spacing box, type or select the number of
pixels you want on the left and right sides of the graphic.
5. Under Layout, in the Vertical spacing box, type or select the number of
pixels you want on the top and bottom sides of the graphic.
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Resize a graphic
In Page view, at the bottom of the document window, click Design , and then
do one of the following:
Resize a graphic by using pixel and percent values
1. Right-click the graphic, and then click Picture Properties on the shortcut
menu.
2. Under Size, select the Specify size check box.
3. In the Height and Width boxes, type or select the pixel or percent values
you want.
4. To specify whether you want to adjust the aspect ratio of the graphic after
you resize it, select or clear the Keep aspect ratio check box.
5. To resample the graphic according to its new size, in the lower-right corner
of the graphic, click Picture Actions , and then select Resample Picture
to Match Size.
Resize a graphic directly
Click the graphic, and then drag a sizing handle to a new position.

Convert a graphic to grayscale
1. In Page view, at the bottom of the document window, click Design .
2. Click the graphic.
If you want to convert a background graphic to grayscale, you do not need
to make a selection.
3. On the Pictures toolbar, click Color

, and then click Grayscale.

If the Pictures toolbar is hidden, right-click the graphic, and click Show
Pictures Toolbar on the shortcut menu.

Change the contrast or brightness of
a graphic
1. In Page view, at the bottom of the document window, click Design .
2. Click the graphic.
If you want to change the contrast of a background graphic, you do not
need to make a selection.
3. On the Pictures toolbar, do one or both of the following:
If the Pictures toolbar is hidden, right-click the graphic, and then click
Show Pictures Toolbar on the shortcut menu.
To change the color contrast of a graphic, click More Contrast
or Less Contrast
.
To change the brightness of a graphic, click More Brightness
or Less Brightness

.

Wash out the color of a graphic
1. In Page view, at the bottom of the page, click Design .
2. Click the graphic.
If you want to wash out background graphic, you do not need to make a
selection.
3. On the Pictures toolbar, click Color

, and then click Wash Out.

Note If the Pictures toolbar is hidden, right-click the graphic, and click Show
Pictures Toolbar on the shortcut menu.
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Make a color in a graphic transparent
1. In Page view, at the bottom of the document window, click Design .
2. Click the graphic.
3. On the Pictures toolbar, click Set Transparent Color

.

If the Pictures toolbar is hidden, right-click the graphic, and click Show
Pictures Toolbar on the shortcut menu.
4. Click the color in the graphic that you want to make transparent.
Tip
If the graphic is not in GIF format, Microsoft FrontPage will convert it to
that format. If you do not want the graphic converted to GIF format, you
can edit it in a graphics editing program and save it to your Web site.

Undo changes to a graphic
You can undo changes you have made to a graphic since you last saved or added
it to a Web page.
1. In Page view, at the bottom of the document window, click Design .
2. Click the graphic.
If you want to restore the background graphic, you do not need to make a
selection.
3. On the Pictures toolbar, click Restore

.

Note If the Pictures toolbar is hidden, right-click the graphic, and click Show
Pictures Toolbar on the shortcut menu.

About Interactive Buttons
You don't need to be an imaging or coding expert to add functional buttons to
your Web pages. Microsoft FrontPage makes it easy for you to add buttons to
your Web pages that resemble buttons you would expect from an advanced
graphics-editing tool.
You can change the appearance of these buttons without any code editing. You
can change settings, such as add button text, select button and background
colors, and define a hyperlink for a button. You can also specify the font style,
size, and color for all states of the button including the original, hover, and
pressed states. You can set the horizontal and vertical alignment, as well as
change the size and proportions of the button.
After you add a button, you can link it to another page in the current Web site, a
site on the World Wide Web, or an e-mail address.
When you add an interactive button, FrontPage creates image files that make up
the button. When you save your Web pages, FrontPage will prompt you to also
save the button image files.
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Add an Interactive Button
1.
2.
3.
4.
5.
6.
7.

In Page view, at the bottom of the document window, click Design .
Place the insertion point where you want to add the button.
On the Insert menu, click Interactive Button.
On the Button tab, in the Buttons list, click a button style.
In the Text box, type the text that you want to appear on the button.
Next to the Link box, click Browse.
Locate and click the file, URL, or e-mail address that you want the button
to link to, and then click OK.

Note When you save the Web page, Microsoft FrontPage will prompt you to
save the images associated with the button.

Delete an Interactive Button
1. In Page view, at the bottom of the document window, click Design .
2. Click the button, and press DELETE.
Note When you delete a button, the files associated with that button are not
deleted. You must delete the button files from the Folder List.
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Set the properties of an Interactive
Button
1. Right-click the Interactive Button that you want to set the properties for,
and then click Button Properties on the shortcut menu.
2. Do one or more of the following:
Set the text
On the Button tab, in the Text box, type the text that you want to appear on
the button.
Set the font
On the Font tab, select the font properties that you want.
Set the destination
On the Button tab, in the Link box, locate and click the file, URL, or email address that you want the button to link to, and then click OK.
Set the button background
On the Image tab, do one of the following:
To match the background of the button to a Web page with a solid
background, click Make the button a JPEG image and use this
background color, click the arrow on the list, and then click a color that
matches your Web page.
To match the background of the button to a Web page with a varied
background, click Make the button a GIF image and use a transparent
background.
Set the size

On the Image tab, do one or both of the following:
To set the height and width of a button, in the Height and Width boxes,
type or select the pixel values that you want.
To maintain the aspect ratio of the button, select the Maintain proportions
check box.
Set the behavior
On the Image tab, do one or more of the following:
To display the button differently when a site visitor rests the mouse pointer
on it, select the Create hover image check box.
To display the button differently when a site visitor clicks it, select the
Create pressed image check box.
To load the images for the hover and clicked states of the button as the rest
of the page loads, select the Preload button images check box.

Add a picture to a hover button
This procedure applies only to a hover button that you created by using an earlier
version of Microsoft FrontPage.
You can add a picture as the background of a hover button, as the hover effect, or
both.
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the hover button, and then click Hover Button Properties on
the shortcut menu.
3. Click Custom.
4. Next to the Button box, click Browse.
5. Locate and click the picture file, and then click Open.
6. To return to the Hover Button Properties dialog box, click OK.
7. In the Width and Height boxes, type the width and height of the picture in
pixels, and then click OK.
The size of the picture should match the size of the hover button.

Add a sound to a hover button
This procedure applies only to a hover button that you created by using an earlier
version of Microsoft FrontPage.
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the hover button that you want to add a sound effect to, and then
click Hover Button Properties on the shortcut menu.
3. Click Custom.
4. In the Play sound area, do one of the following:
To play the sound effect when a site visitor clicks the hover button,
click Browse next to the On click box, locate and click the sound file,
and then click Open.
To play the sound effect when a site visitor points to the hover button,
click Browse next to the On hover box, locate and click the sound
file, and then click Open.
Note Because hover buttons are actually Java applets, you can only use .au
format sound files for sound effects; you cannot use .midi or .wav files.
Furthermore, the .au files must be in 8-bit, 8000 Hz, mono, u-law format.

Set the properties of a hover button
This procedure applies only to a hover button that you created by using an earlier
version of Microsoft FrontPage.
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the hover button you want to set the properties for, and then
click Hover Button Properties on the shortcut menu.
3. Select the properties you want.

Delete a hover button
1. In Page view, at the bottom of the document window, click Design .
2. Click the button, and press DELETE.
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About photo galleries
A photo gallery is a Web page that contains a collection of photos arranged in a
specific layout. Microsoft FrontPage provides four different layouts that you can
use to arrange your graphics.

In addition to creating an individual photo gallery, you can create your own Web
site "photo album" by first creating two or more galleries, and then adding a link
bar that connects them all. Each page can have a different layout.
Adding and removing photos
When you create a gallery, you can add as many photos as you want. You can
also add or remove photos at any time.
You can add photos from a variety of sources:
Your computer or local Web site
The World Wide Web
The Microsoft Clip Organizer
A scanner
A digital camera
Editing a specific photo
FrontPage offers you several ways to edit your photos after you have added them
to the photo gallery:
Size You can change the width or height of the photo. You can also
choose to maintain the aspect ratio, so your photo does not become
distorted.

Original Resized

Orientation You can rotate or flip the photo:
Original

Rotated right 90 degrees Rotated left 90 degrees

Flipped vertically Flipped horizontally

Crop You can crop the photo and display only the portions you want.
Original Cropped

Reset After making changes to the photo, you can click Reset to return
the photo to its original state.
Captions and descriptions
Below each photo in a photo gallery there is space for a caption and description.
You can select the font style, color, and size of the caption. You can create the
caption and description when you create the gallery, or you can change or
remove it later.
Thumbnails
When you create a photo gallery using one of the four layouts, a thumbnail of
each photo is automatically created. You have the opportunity to set or change
the size of the thumbnail at any time.

Original graphic Thumbnail of the graphic
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Create a photo gallery
1.
2.
3.
4.
5.
6.
7.
8.

In Page view, at the bottom of the document window, click Design .
Place the insertion point where you want to add a photo gallery.
On the Insert menu, click Web Component.
In the Component type list, click Photo Gallery.
In the Choose a Photo Gallery Option list, click the layout you want.
Click Finish.
To add a photo to the photo gallery, click Add.
Do one of the following:
Add a picture from a file
1. Click Pictures from Files.
2. Locate and click the file you want, and then click Open.
Add a picture from a scanner
1.
2.
3.
4.

Click Pictures from Scanner or Cameras.
Under Device, click the device you want to add a graphic from.
Click the resolution that you want.
Do one of the following:
To add the graphic in its original form, click Insert.
To adjust the properties of the graphic, click Custom Insert, and
then select the graphics you want to add.
Add a picture from a digital camera

1.
2.
3.
4.

Click Pictures from Scanner or Cameras.
Under Device, click the device you want to add a graphic from.
Click Custom Insert.
Select the graphic that you want to add and then click Get Pictures.
Tip
To select more than one graphic, hold down CTRL and select the

graphics you want.
9. To rearrange the order of the photos, select the name of the photo, and click
Move Up or Move Down.
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Add a photo to a photo gallery
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Double-click the photo gallery where you want to add a photo.
Click the Pictures tab, and then click Add.
Do one of the following:
Add a picture from a file
1. Click Pictures from Files.
2. Locate and click the file you want, and then click Open.
Add a picture from a scanner
1.
2.
3.
4.

Click Pictures from Scanner or Cameras.
Under Device, click the device you want to add a graphic from.
Click the resolution that you want.
Do one of the following:
To add the graphic in its original form, click Insert.
To adjust the properties of the graphic, click Custom Insert, and
then select the graphics you want to add.
Add a picture from a digital camera

1.
2.
3.
4.

Click Pictures from Scanner or Cameras.
Under Device, click the device you want to add a graphic from.
Click Custom Insert.
Select the graphic that you want to add and then click Get Pictures.
Tip

To select more than one graphic, hold down CTRL and select the
graphics you want.
5. To rearrange the order of the photos, select the name of the photo, and then
click Move Up or Move Down.
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Edit a photo in a photo gallery
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Double-click the photo gallery.
Select the name of the photo you want to edit.
Click Edit, and do one or more of the following:
Change the size of the photo
1. Under Picture Size, specify a width and a height for the photo in
pixels.
Rotate or flip the photo
Under Rotate Picture, do one or more of the following:
To rotate the photo 90 degrees counterclockwise, click Rotate Left
.
To rotate the photo 90 degrees clockwise, click Rotate Right
.
To turn the photo upside down, click Flip Vertical
To create a mirror image, click Flip Horizontal

.
.

Crop the photo
1. Under Crop Picture, click Crop.
A cropping box appears on the photo.
2. Click and drag the handles to resize the box.
3. Click Crop again to remove the area outside of the cropping box.
Note If you want to return the photo to its original state, click Reset.
Tip

To edit the photo before or after the one you just edited, click Previous or Next.

Change the layout of a photo gallery
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Double-click the photo gallery, and then click the Layout tab.
Choose a layout from the list.
Type or select a number in the Number of pictures per row box.
Note The Slide Show Layout and Montage Layout galleries do not use
columns and rows to display the graphics, and therefore, you do not need to
specify a number.

Change a caption or description in a
photo gallery
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Double-click the photo gallery.
Click the name of the photo you want to change.
Do one or both of the following:
In the Caption box, type the new caption.
In the Description box, type the new description.

Remove a photo from a photo gallery
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Double-click the photo gallery.
In the Photo Gallery Properties dialog box, click the Pictures tab.
Click the photo, and then click Remove.

About hot spots and image maps
A hot spot can be a shape or text on a graphic that is also a hyperlink. When a
site visitor clicks the shape or the text, the destination of the hyperlink displays
in a Web browser. In Microsoft FrontPage, hot spots can be shaped as rectangles,
circles, or polygons.
A graphic with one or more hot spots is called an image map. An image map
usually gives cues about where site visitors should click.
For example, if you have a Web page about your company, it might include a
picture of your product that contains a hot spot for each particular aspect of that
product. When site visitors click an area of the product, a page is displayed
describing that aspect of the product in detail.

The areas of the graphic that don't have hot spots can be assigned a default
hyperlink; when site visitors click anywhere outside a hot spot, they will be
directed to the destination you set for the graphic's default hyperlink.
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Add a hot spot to a graphic
1. In Page view, at the bottom of the document window, click Design .
2. Click the graphic that you want to add a hot spot to.
3. Do one of the following:
Add a hot spot to a graphic
1. On the Pictures toolbar, click Rectangular Hotspot
, or Polygonal Hotspot .

, Circular Hotspot

If the Pictures toolbar is hidden, right-click the graphic, and then click
Show Pictures Toolbar on the shortcut menu.
2. On the graphic, drag to draw a rectangle, circle, or polygon. When you
release the mouse button, the Insert Hyperlink dialog box opens.
3. Locate the file you want to link to, and then click OK.
Notes
To draw a polygon, click to place each corner of the polygon, and then
double-click to finish it.
Add a text hot spot to a graphic
1. On the Pictures toolbar, click Text

.

If the Pictures toolbar is hidden, right-click the graphic, and then click
Show Pictures Toolbar on the shortcut menu.
2. In the box, type the text you want.
3. Do one or both of the following:
To move the text box, drag the border of the text box to a new location.
To resize the text box, drag the handles on the text box border.
4. Double-click an edge of the text box.
5. Locate the file you want to link to, and then click OK.
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Change or delete a hot spot
1. In Page view, at the bottom of the document window, click Design .
2. Click the graphic to view the hot spot.
3. Do one or more of the following to change the destination of the hot spot:
Edit the URL of a hot spot Double-click the hot spot, and select the
destination.
Resize the hot spot Drag the selection handles to new positions.
Delete a hot spot Click the hot spot, and then press DELETE.
Move the hot spot Drag the borders to a new location.
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Highlight the hot spots on a graphic
You can highlight hot spots on a graphic. For example, you might use this
feature if it's hard for you to see the hot spot outlines that are superimposed on
the graphic.
1. In Page view, at the bottom of the document window, click Design .
2. Click the graphic.
3. On the Pictures toolbar, click Highlight Hotspots .
If the Pictures toolbar is hidden, right-click the graphic, and then click
Show Pictures Toolbar on the shortcut menu.
4. To display the graphic without highlighting, click Highlight Hotspots
again.
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Create a thumbnail
1. In Page view, at the bottom of the document window, click Design .
2. Click the graphic.
3. On the Pictures toolbar, click Auto Thumbnail

.

If the Pictures toolbar is hidden, right-click the graphic, and then click
Show Pictures Toolbar on the shortcut menu.
Microsoft FrontPage creates a thumbnail graphic and a hyperlink to the
original full-size graphic.
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Set the properties for thumbnails
1. In Page view, at the bottom of the document window, click Design .
2. On the Tools menu, click Page Options, and then click the Auto
Thumbnail tab.
3. Do one or more of the following:
To specify the size, in the Set box, click the option you want, and then
in the Pixels box, type or select the value in pixels.
To specify the border size, select the Border thickness, and then in the
Pixels box, enter the value in pixels.
To bevel the edges of the graphic, click the Beveled edge check box.
If you have also specified a border thickness, the thumbnail will have a
beveled edge inside of a border.
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Resize a thumbnail in a photo gallery
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Double-click the photo gallery.
Click the thumbnail photo that you want to resize.
Under Thumbnail size, specify a new width and height in pixels.

Move a drawing object forward or
backward
1. Select the drawing object that you want to move.
Note If the object is hidden beneath other objects, select any object, and
then press TAB until the object you want is selected.
2. On the Drawing toolbar, do one of the following:
To bring an object one layer closer to the front, click Draw, point to
Order, and then click Bring Forward.
To bring an object to the front, click Draw, point to Order, and then
click Bring to Front.
To send an object one layer closer to the back, click Draw, point to
Order, and then click Send Backward.
To send an object to the back, click Draw, point to Order, and then
click Send to Back.
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Set default styles for drawing objects
You can use the properties of an existing AutoShape drawing object to set
formatting attributes that will apply to all new drawing objects in Microsoft
FrontPage.
Right-click the drawing object that has the attributes you want to use as the
default, and then click Set AutoShape Defaults on the shortcut menu.

About drawing objects
You can add drawing objects to a Web page, and then resize, rotate, flip, color,
add text, specify line styles and shadow styles, and combine objects to make
more complex shapes. AutoShapes are drawing objects, located on the Drawing
toolbar, that include rectangles and circles, plus a variety of lines, block arrows,
flowchart symbols, stars and banners, and callouts. You can also add objects
from the Clip Organizer.
When you add text to a drawing object, the text becomes part of the object, and
if you rotate or flip the object, the text rotates or flips with it.
All drawing objects have adjustment handles that you can use to adjust the
appearance of the drawing object.
As you add drawing objects to your Web page, they stack automatically into
individual layers. You can see the stacking order when objects overlap, such as
the top of one object covering a portion of one or more objects beneath it.
You can move individual drawing objects or groups of objects in a stack. For
example, you can move objects up or down within a stack one layer at a time, or
you can move them backward or forward (top or bottom) in one move.
Text boxes are like drawing objects. You can format them to include color, fills,
and borders.

Draw a line
1. In Page view, at the bottom of the document window, click Design .
2. On the Drawing toolbar, click Line

.

If the Drawing toolbar is hidden, on the View menu, point to Toolbars, and
then click Drawing.
3. Drag to draw the line, and do one of the following:
If you want to draw a straight line, hold down SHIFT as you drag.
To constrain the line to draw at 15-degree angles from its starting
point, hold down SHIFT as you drag.
To lengthen the line in opposite directions from the first end point,
hold down CTRL as you drag.
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Format a line
1. To change the color or style of a line, select the line, and then do one or
both of the following:
Change the color or pattern of a line
1. On the Drawing toolbar, click the arrow next to Line Color (Auto)
.
2. Do one of the following:
Select a standard color
Under Standard Colors, select a color.
Select from more colors
Click More Line Colors and click the color you want.
Mix custom colors
Click More Line Colors and click Custom, then create the color you
want.
Select a pattern with color
1. Click Patterned Lines.
2. Select a pattern, and then select colors for the foreground and
background.
Change the style of a line
1. On the Drawing toolbar, click Line Style
2. Do one of the following:
Click the style you want.

.

Click More Lines, and then choose the attributes you want for your
line style.
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About WordArt
WordArt is a gallery of text styles that you can add to your Web page to create a
decorative effect. For example, you can create shadowed, skewed, rotated, and
stretched text, as well as text that has been fitted to predefined shapes. These are
called text effects.
A text effect, as shown below, is a type of drawing object. Therefore, you can
use the Drawing toolbar to change a text effect — for example, to fill a text
effect with a picture or pattern.
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Add or remove WordArt
1. In Page view, at the bottom of the document window, click Design .
2. Do one of the following:
Add WordArt
1. On the Drawing toolbar, click Insert WordArt

.

If the Drawing toolbar is hidden, on the View menu, point to Toolbars, and
then click Drawing.
2. Select a WordArt style and then click OK.
3. In the Edit WordArt Text dialog box, type the text you want.
Change the text in WordArt
1. Double-click the WordArt you want to change.
2. In the Edit WordArt Text dialog box, change the text, and then click OK.
Delete WordArt
Select the WordArt you want to remove and press DELETE.
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Add a page banner
Important By default, a page banner displays the page title as displayed in
Navigation view. Therefore, before you can use page banners, you must set up
the navigation structure of your Web site in Navigation view.
1. In Page view, place the insertion point where you want to add a page
banner.
2. On the Insert menu, click Page Banner.
3. Do one of the following:
Display the page banner as text
1. In the Page Banner Properties dialog box, click Text .
2. In the Page banner text box, type the text you want to display in the
page banner, and click OK.
3. Right-click the page banner, and then click Font on the shortcut menu.
4. Set the properties that you want.
Display the page banner text as a picture
To use a picture, your page must use a theme.
1. In the Page Banner Properties dialog box, click Picture.
2. In the Page banner text box, type the text you want to display in the
page banner, and click OK.
Note The page banner picture that displays is the banner that is associated
with the theme for this page.
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Change a page banner
1. In Page view, at the bottom of the document window, click Design .
2. Double-click the page banner.
3. Change the properties of the page banner.
Note When you change the text displayed on a page banner, the title of the page
in Navigation view is also changed.

Add a comment
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Place the insertion point where you want to add a comment.
On the Insert menu, click Comment.
Type the comment.

Note A comment has the same attributes as the current paragraph style, but is
displayed in a different color. Although comments can be viewed while editing a
page, they are not visible in the Web browser of a site visitor who has browsed to
the page. However, they are visible if the site visitor wants to view the source of
your page, so use caution when writing comments.

Edit a comment on a Web page
1. In Page view, at the bottom of the document window, click Design .
2. Double-click and edit the comment.
Note Site visitors are not able to see your comments when they view your Web
page in a Web browser. However, they will see them if they view the source
code, so use caution when writing comments.
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Send a copy of a Web page as an email message
To use this feature, you must have Microsoft Outlook or another mail program
compatible with the Messaging Application Programming Interface (MAPI)
installed on your computer.
Important The recipient of an e-mail message may not receive an attachment
depending on the attachment file type. For example, program file type (.exe)
attachments are blocked by Microsoft Outlook. The security level of file types is,
in some cases, set by the e-mail server administrator. Make sure to provide an
alternative method for recipients to access the attachment.
1. On the File menu, click Send.
Microsoft FrontPage starts your default e-mail program, and then opens a
new message with the active page attached.
2. Select recipients for the e-mail message, and then type a subject.
3. Send the message.
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Add an Office Spreadsheet
component
Security Use caution when you are adding ActiveX controls to your Web page.
ActiveX controls may be designed in such a way that their use could pose a
security risk. We recommend that you use controls from trusted sources only.
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point where you want to add a Microsoft Office
Spreadsheet component.
3. On the Insert menu, click Web Component.
4. In the Component type list, click Spreadsheets and charts.
5. In the Choose a control list, click Office Spreadsheet.
6. Click Finish.
7. If you want to learn more about designing and using an Office Spreadsheet
component, see Microsoft Office Spreadsheet Component Help. To open
Microsoft Office Spreadsheet Component Help, click Help
on the
spreadsheet toolbar.
Note To enter or display data in an Office Spreadsheet component, your site
visitors must use Microsoft Internet Explorer 5.01 with Service Pack 2 (SP2) or
later and they must have the Microsoft Office Web Components installed on
their computers.
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Add an Office PivotTable component
Security Use caution when you are adding ActiveX controls to your Web page.
ActiveX controls may be designed in such a way that their use could pose a
security risk. We recommend that you use controls from trusted sources only.
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point where you want to add a Microsoft Office
PivotTable component.
3. On the Insert menu, click Web Component.
4. In the Component type list, click Spreadsheets and charts.
5. In the Choose a control list, click Office PivotTable.
6. Click Finish.
7. In the document window, double-click Click here to connect to data.
8. Select the options you want.
9. If you want to learn more about designing and using an Office PivotTable
component, see Microsoft Office PivotTable Component Help. To open
Microsoft Office PivotTable Component Help, click Help
on the
PivotTable toolbar.
Note To enter or display data in an Office PivotTable component, your site
visitors must use Microsoft Internet Explorer 5.01 with Service Pack 2 (SP2) or
later and they must have the Microsoft Office Web Components installed on
their computers.
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Add an Office Chart component
Security Use caution when you are adding ActiveX controls to your Web page.
ActiveX controls may be designed in such a way that their use could pose a
security risk. We recommend that you use controls from trusted sources only.
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point where you want to add a Microsoft Office Chart
component.
3. On the Insert menu, click Web Component.
4. In the Component type list, click Spreadsheets and charts.
5. In the Choose a control list, click Office Chart.
6. Click Finish.
7. On the Data Source tab, do one of the following:
To display new data that you enter, click Data typed into a data
sheet, and then click Data Sheet to enter the data.
To display data from an existing database, click Data from a database
table or query, and then click Connection to select options for a
database connection.
To display data from an Office Spreadsheet or Office PivotTable
component on the same Web page, click Data from the following
Web page item, and then click the component you want.
This option is available only if an Office Spreadsheet or Office
PivotTable component is on the page.
8. Select any additional options you want.
9. If you want to learn more about designing and using an Office Chart, see
Microsoft Office Chart Component Help. To open Microsoft Office Chart
Component Help, right-click inside the Office Chart, and then click Help
on the shortcut menu.
Note To enter or display data in an Office Chart, your site visitors must use
Microsoft Internet Explorer 5.01 with Service Pack 2 (SP2) or later and they
must have the Microsoft Office Web Components installed on their computers.
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About Office Web Components
You can add interactive spreadsheets, charts, graphs, and PivotTables to your
Web pages by using Microsoft Office Web Components. Office Web
Components are Microsoft ActiveX controls that display data from a workbook,
database, or other data source that you specify. When the data in that data source
changes, the component displays those changes. This helps to ensure that both
you and your site visitors can view and interact with data that is up-to-date.
Security Use caution when you are adding ActiveX controls to your Web page.
ActiveX controls may be designed in such a way that their use could pose a
security risk. We recommend that you use controls from trusted sources only.
Office Web Components include the following types of components:
Office Chart This component can be a line or bar graph, a pie chart, or other
type of chart that you specify. It can display data that you enter into a datasheet,
existing data from database tables and queries, or existing data from an Office
PivotTable or Office Spreadsheet component on the same Web page as the chart.
You can use an Office Chart component to make it easy for your site visitors to
compare data and identify patterns and trends in that data.
Office PivotTable This component is an interactive table that combines and
compares data in a series of rows and columns. It can display data from any of
several types of databases, including relational databases and spreadsheet
databases such as Microsoft Excel lists. You can use an Office PivotTable
component to enable your site visitors to expand and collapse rows and columns
to see different summaries of the data and to display details about specific data.
Office Spreadsheet This component displays columns and rows of cells that
contain related information. It can display data from an Excel workbook, text
and other types of files, any of several types of databases, including relational
databases such as a Microsoft SQL Server database, and data provider services.
You and your site visitors can enter data directly into the cells, sort and apply
filters to the data, and change the formatting of the data. Your site visitors can
also perform calculations on the data by using formulas and functions.

By default, site visitors can both view and interact with data in any type of
Office Web Component. However, you can specify protection settings for a
component. These settings determine whether site visitors can only view the data
in the component or both view and interact with that data.

Support for Office Web Components
Regardless of the protection settings you specify, your site visitors must have
certain programs installed on their computers before they can view or interact
with data in Office Web Components. Site visitors must use Microsoft Internet
Explorer 5.01 with Service Pack 2 (SP2) or later to open a Web page containing
components. In addition, site visitors must install the Office Web Components
on their computers. By default, the Office Web Components are installed with
any of the Microsoft Office 2003 programs. They can also be installed
separately, from a location that you provide.
If site visitors install only the Office Web Components, and they do so by using
an installation location and a license package that you provide, site visitors can
both view and interact with data in components. If they install only the Office
Web Components and they do not have access to a license package, site visitors
can only view the data in components. If site visitors do not install the Office
Web Components or an Office 2003 program, they cannot view or interact with
components.
For information about providing an installation location or license package for
the Office Web Components, see the Microsoft Office 2003 Resource Kit.
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About customizing forms and views
for SharePoint Services
When you use Microsoft FrontPage to add a list, survey, or library to your Web
site based on Microsoft SharePoint Services, pages containing forms and views
are also added. Forms and views are what your site visitors use to add, edit, or
delete items from the lists, surveys, and libraries.
There are multiple customizations you can make to these forms and views
depending on which version of SharePoint Services you are using:
About customizing SharePoint Team Services v1.0 from Microsoft
Basic customizations
Change the order of the fields.
Remove fields from the form or view.
Replace one field with another from the same list, survey, or library.
Change text formatting of fields, such as font size and color.
Modify table formatting, such as adding or removing rows and columns or
merging cells.
Add custom content, such as text or a picture.
Advanced customizations
By using FrontPage to edit views based on SharePoint Team Services v1.0, you
can enable layout customization view to provide greater control over the
customization of the view, which is displayed as a Web component.
By using layout customization view, you can see where fields are placed in a
view or form of a list, library, or survey. This provides a way to control how data
appears in a view and how fields appear on a form. In a view, where the same set
of fields is repeated for every item in a list, the modifications you make in the set
of fields appear for every item in the list.

Note Once you have modified a view or form with the layout customization
view in FrontPage, you can no longer edit the view or form by using a Web
browser. However, you can continue to maintain the customized version in
FrontPage.
About customizing Microsoft Windows SharePoint Services
Basic customizations
Change the order of the fields.
Remove fields from the form or view.
Replace one field with another from the same list, survey, or library.
Change text formatting of fields, such as font size and color.
Modify table formatting, such as adding or removing rows and columns or
merging cells.
Add custom content, such as text or a picture.
Advanced customizations
By using FrontPage to edit views in Windows SharePoint Services, which are
Web Parts, you can control several elements of the appearance of the views.
These elements include whether the list is displayed with a fixed or percentage
width, whether the Web Part uses a right-to-left or left-to-right language
direction, and advanced options, such as whether you want to allow site visitors
to be able to minimize the list on the Web page.
Because views in Windows SharePoint Services are Web Parts, you can use
other Web Part features. For example, you can create Web Part connections
between SharePoint list views and other Web Parts. By connecting the Form
Web Part to the Announcements list, for example, you can enable your site
visitors to perform additional filtering on the announcements in the list by using
an interface that is similar to a search box.
In addition, you can convert a view to a Data View Web Part by using
FrontPage. This enables additional formatting options, such as conditional
formatting. By using conditional formatting, you set a condition or conditions
for the data in your list view. If those conditions are met, specific formatting is
applied to the records that are displayed. For example, you could specify
conditional formatting that enables all records that were last updated by you to

appear in bold, red text, or to show a photo of you next to the appropriate
records.
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About using Data Views and Web site
templates based on SharePoint
Services
If your Web site is located on a Web server running Microsoft Windows
SharePoint Services, you can add data features and custom design and page
elements to your site by using Microsoft Office FrontPage 2003. Some features,
such as Data Views and specific Web site templates are available only if your
site is based on Windows SharePoint Services.

Data Views
If your Web site is located on a Web server running Windows SharePoint
Services, you can add Data Views that extract data from a variety of available
data sources — for example, Extensible Markup Language (XML) files, Web
services, SharePoint lists, and OLE DB–compliant databases such as SQL
Server, DB2, and Oracle — and create custom views of that data on a Web page.
When you add a Data View to a page, you can customize the view by using the
Formatting toolbar or, for more advanced customizations, the Data View
Details task pane.
Windows SharePoint Services, which is built on the Microsoft .NET Framework,
provides the component-based platform required for FrontPage data-driven
functionality. For this reason, you cannot add Data Views to a Web site that is
not based on Windows SharePoint Services.

Site templates
Web site templates enable you to create a Web site quickly by generating
predesigned pages complete with formatting and design elements. When you
design your Web site by using templates based on Microsoft Windows
SharePoint Services, you can add a wide array of features and technologies
based on SharePoint lists, libraries, surveys, and Web Parts – including Data
Views. In addition, you can customize your site by using FrontPage.
With the exception of the Team Site template, which is available in both
SharePoint Team Services v1.0 and Windows SharePoint Services, the following
templates are available only if your Web site is located on a server running
Windows SharePoint Services.
Team Site By using this template, you can create a Web site to organize
and share information with others. The Team Site template includes a
document library and SharePoint lists such as Announcements, Events,
Contacts, and Quick Links. This template is available for both SharePoint
Team Services v1.0 and Windows SharePoint Services.
Blank Site By using this template, you can create a Web site based on
Windows SharePoint Services that contains a blank home page. By using
FrontPage, you can add interactive lists or any other Windows SharePoint
Services features to the Web site.
Document Workspace By using this template, you can create a Web site
based on Windows SharePoint Services that enables colleagues to work
together on documents. Document Workspace provides a document
library for storing the primary document and supporting files, a Tasks list
for assigning to-do items, and a Links list for resources related to the
document.
Basic Meeting Workspace By using this template, you can create a Web
site based on Windows SharePoint Services that contains the necessary
SharePoint lists to plan, organize, and track a meeting. Basic Meeting
Workspace contains Objectives, Attendees, and Agenda lists.
Blank Meeting Workspace By using this template, you can create a

Meeting Workspace without predefined SharePoint lists or libraries. By
using FrontPage, you can add interactive lists or any other Windows
SharePoint Services features to the Web site.
Decision Meeting Workspace By using this template, you can create a
Meeting Workspace where you can review documents and record decisions.
The Decision Meeting Workspace template contains the following
SharePoint lists and libraries: Objectives, Attendees, Agenda, document
libraries, Tasks, and Decisions.
Social Meeting Workspace By using this template, you can create a
Meeting Workspace that enables you to plan social events. Social Meeting
Workspace contains the following SharePoint lists, libraries, and Web
Parts: Discussion board, picture library, Attendees, directions, weather,
image/logo, and Things to Bring.

Administration features for
SharePoint Services
For information about tools to help you administer your Web site based on
Microsoft Windows SharePoint Services or SharePoint Team Services v1.0 from
Microsoft, do the following:
1. In a Web browser, open a page from your SharePoint site that contains a
SharePoint link bar.
2. Click Help on the link bar.

About support for SharePoint
Services
When you design your Web site by using Microsoft FrontPage, you can turn
support on or off for features that require SharePoint Services (SharePoint Team
Services v1.0 from Microsoft or Microsoft Windows SharePoint Services).
The following Web components are available in FrontPage only if you turn on
support for SharePoint Services:
Web Search
Top 10 List
List View
Document Library View
Note List View and Document Library View Web components are available
only for Web sites based on SharePoint Team Services v1.0. To create views of
interactive lists and document libraries for Web sites based on Windows
SharePoint Services, you can use Web Parts.
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Troubleshoot SharePoint lists and
libraries
For a Web site on a server running SharePoint Team Services v1.0 from
Microsoft
I can no longer edit a page by using my Web browser.
If you use layout customization view to make changes to a page, you must use
Microsoft FrontPage to make any further customizations to the page.
I cannot edit the properties of a list form in layout customization view.
You must open a list form in live data view to change the properties of the form.
Note Changing from layout customization view to live data view resets the
layout of the form to the default layout and formatting.
The commands in the Insert Web Component dialog box for creating a
new list, document library, or survey are not available.
Verify that you are opening the Web site on a Web server that is running
SharePoint Team Services v1.0.
The file I want to use as a template in a document library is not available.
The template must be in the active Web site. Do the following:
1.
2.
3.
4.

On the File menu, click Import, and then click Add file.
Locate and click the template file, and then click Open.
Click OK.
In Folders View, right-click the document library folder, and click
Properties.
5. On the Settings tab, select the Use a template for new documents check
box, and then click Browse to find the file you imported in step 1.

When Microsoft Office 2003 users work with my document library, I want
them to see a list of folders and files, not a Web page, in the Open and Save
dialog boxes.
To turn WebView off for all the document libraries in your Web site, do the
following:
1. On the Tools menu, click Site Settings.
2. On the Advanced tab, clear the Display a web page view of available
document libraries to Office users who open from or save to the web
check box.
When I create a rule for a document library, I get a message saying that a
service is needed.
Some services on the Web server may need to be enabled. If you create a rule
that involves keeping track of time or sending e-mail (for example, set
documents to expire after six months, and send e-mail notification to the creator
of the document one week prior to expiration), the Web server that stores your
Web site must have the following services enabled:
SharePoint Team Services v1.0 timer service
SMTP mail service
Contact your Internet service provider (ISP) or Web server administrator to
ensure that these services are running properly.
I updated document properties that should have triggered a rule to take
effect, but it looks like the rule didn't work.
You may need to refresh the page or property for the change to take effect.
Press F5, or click OK in the active dialog box and then reopen the dialog
box to see the changes.
Site visitors report that they can't get to a list, document library, or survey,
yet I can see the folder for it in Folders view.
The default view may have been deleted. Do one of the following:

Set an existing page as the default view
1. In Folders view, right-click the document library folder, list folder, or
survey folder, and click Properties.
2. Click the Supporting Files tab, and in the Default view page box, select
the page you want.
Create a new view to use as the default
1. In Page view, at the bottom of the document window, click Design .
2. Place the pointer on the page where you want to add the view.
3. On the Insert menu, click Web Component.
4. In the Component type box, click List View to create a view of a list or
survey, or click Document Library View to create a view of a document
library, and in the Choose a view style box, click a layout for the view.
5. Click Finish.
6. If the view is of a list or survey, in the Choose a list box, select the list or
survey, and then click OK.
If the view is of a document library, in the Choose a document library
box, select the document library, and click OK.
7. To add commands that enable users to add and edit items, click Options,
and in the Toolbar type box, click Full toolbar.
Note You can make other custom settings for this view in the List View
Properties or Document Library View Properties dialog box.
8. Click OK, and on the File menu, click Save to save the page.
9. In Folders view, right-click the document library folder, list folder, or
survey folder, and click Properties.
10. Click the Supporting Files tab, and in the Default view page box, select

the page you saved in step 7.
Microsoft FrontPage changed the name of my list, document library, or
survey.
The name of the list, document library, or survey may include characters that
cannot be used in URLs. If the name includes a character that cannot be used in
a URL, FrontPage substitutes a new name for the list folder, document library
folder, or survey folder. The name change affects the folder only. The name
displayed on Web pages and link bars is the name that includes the non-URL
characters.
Site visitors get an error message when they go to a page to add or edit
items in a list, document library, or survey.
There might be more than one list form on the page. A Web page can have only
one form for a list, document library, or survey. Create a separate page for each
form.
The default value for a Multiple lines of text field disappeared.
Someone may have edited the field using a Web browser. If a Multiple lines of
text field is edited in a Web browser (for example, changing the name of the
field or changing how many lines of text the field can hold), the default value is
deleted. Reenter the default value by making changes to the field in Microsoft
FrontPage.
For a Web site on a server running Microsoft Windows SharePoint
Services
I can't apply a theme by using the Web browser after Microsoft FrontPage
has been used to apply a theme.
If you apply a theme to selected pages in your Web site by using FrontPage, the
theme for those pages will not be updated later if you try to apply another theme
by using the Web browser. The Apply theme to site option, on the Site Settings
page in a Windows SharePoint Services site, only applies themes to pages that
have not had themes applied by using FrontPage.

I can no longer run document library rules.
The document library rules feature is available only on servers running
SharePoint Team Services v1.0 from Microsoft. If your site has been upgraded to
Windows SharePoint Services, you will be unable to run document library rules.
I can no longer edit a page by using my Web browser.
If you use Microsoft FrontPage to make certain changes to a Web page based on
Windows SharePoint Services, you might be unable to make further
customizations to the page by using a Web browser.
For example, if you move a Web Part on default.aspx outside a Web Part Zone
by using FrontPage, you will not be able to move that Web Part again by using
the Modify My Page option in the browser. You must use FrontPage instead.
When Microsoft Office 2003 users work with my document library, I want
them to see a list of folders and files, not a Web page, in the Open and Save
dialog boxes.
You can turn WebView off for all the document libraries in your Web site. Do
the following:
1. On the Tools menu, click Site Settings.
2. On the Advanced tab, clear the Display a web page view of available
document libraries to Office users who open from or save to the web
check box.
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About collecting data using forms
After you decide what form fields to put on your form, the next step is to set
rules for the ways you want your site visitors to enter data in the fields. These
data entry rules, also called validation, make sure that a site visitor fills out the
form correctly. For example, you can set up an order form for your products, but
unless the customer's name, address, and payment information are correctly
entered, he or she won't be able to complete the order.
Setting rules for how site visitors enter data in forms
Types of rules you can set for your form fields:
Text box validation
You can specify the type of data, as well as other criteria, to allow for text
boxes and text areas. For example, to collect a member number or a serial
number, set up a text box to accept only numbers and disallow the use all
other characters as appropriate. You can also require a fixed number of
characters so that a site visitor does not omit a number or letter by mistake.
Option button validation
You can require a selection to be made from a group of option buttons. For
example, if your form has two option buttons, Yes and No, and a site visitor
tries to submit the form without making a selection, a message is displayed.
Drop-down box validation
You can require a site visitor to make a choice from a drop-down box, set
the minimum and maximum number of choices to allow, and disallow the
first choice from being selected. For example, you can disallow the first
item from being selected if it is an instruction, such as "Select an item."
Handling information you collect from the form

After setting up the data entry rules, you need to decide how you want the form
results to be handled. After a site visitor submits the form, you must collect the
data that he or she entered— the form results— so you can view them, display
them to the visitor, or work with them as needed.
When a site visitor submits a form in the browser, the values of each of the form
fields between the <form> and </form> tags are sent to a form handler. For
example, if the form field is a text box, the value sent to the form handler is the
text entered in the text box. Microsoft FrontPage provides several form handlers,
which take the form results and perform various actions.
Save the results to a database
Each time a site visitor submits a form, FrontPage saves the information to
a database. For example, if you use a form to collect contact information,
you can save the results directly to your customer database. You can save
results to an existing database or FrontPage can create one for you.
Save the results to a text, HTML, or XML file
Each time a site visitor submits a form, FrontPage attaches the results to a
file. You can then open the file and view the results. For example, you can
set up a guest book for your Web site and choose to save the results to an
HTML file. You can create a link to the file so that site visitors can see what
others have written. In the case of saving form results to an XML file, you
can use the results in FrontPage, or export the results into any application
that understands XML, such as Microsoft Office Excel 2003.
Send the results in e-mail
Each time a site visitor submits a form, FrontPage sends you an e-mail
message containing the results of that form.
You can also choose to use your custom scripts to handle the form results.
Notes
If you use any of the form handlers rather than a custom script, the
FrontPage Server Extensions from Microsoft or Microsoft Windows

SharePoint Services must be installed on the server where your Web site is
located.
To save form results to XML, your form must be located on a server
running Windows SharePoint Services.
Security
Cross-site scripting is a security vulnerability that could affect many Web
sites and site visitors. The vulnerability is the result of coding mistakes in
Web applications. For more information about cross-site scripting and how
to protect your Web site and site visitors, see information about the crosssite scripting security vulnerability on the Microsoft TechNet Web site.
Use this feature with caution. Sensitive or confidential information could be
revealed to other users.
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Specify what user information to
collect from a form
You can specify the information you want to gather about your site visitors and
their computers from the form they fill out.
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the form, and then click Form Properties on the shortcut menu.
3. Click Options, and then click the Saved Fields tab.
4. The names of all the fields in your form are listed in the Form fields to
save list.
5. Do one or more of the following:
Select any field that you do not want saved in the form results, and
then press DELETE.
To save the date or time the form was submitted with the form results,
select formats from the Date format and Time format lists.
Under Additional information to save, select any additional types of
information you want to save in the form results.
Note To test the functionality of your form, you must first publish your Web site
to a Web server that is running FrontPage Server Extensions, SharePoint Team
Services v1.0 from Microsoft, or Microsoft Windows SharePoint Services 2.0.
Ask your Web server administrator or Internet service provider (ISP) whether
your server is running one of these technologies.

Create a form
Some of the content in this topic may not be applicable to some languages.
When you insert a form, Microsoft FrontPage inserts a rectangular area outlined
with a dashed line that contains a Submit and a Reset button. Inside this
rectangular area, you can add text and form fields, such as text boxes, option
buttons, check boxes, drop-down boxes, and push buttons.
1. In Page view, at the bottom of the document window, click Design .
2. On the Insert menu, point to Form, and then select the fields you want to
add to your form.
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Add a text box to a form
1. In Page view, at the bottom of the document window, click Design .
2. Do one or both of the following:
Add a text box
1. Click in the form where you want to place the text box.
If you are inserting a form field but have not already created a form,
Microsoft FrontPage automatically creates a form area and inserts the
field inside that form area. The form area appears as a dashed line
when you are editing the page.
2. On the Insert menu, point to Form, and then click Textbox.
3. Type the label for the text box directly on the form.
Set the properties for a text box
1. Double-click the text box.
2. In the Name box, type a name to identify the text box.
For your form to work correctly, you need to use a unique name for
this form field.
3. If you want text to appear in the text box when a site visitor first opens
the form, type the text in the Initial value box.
4. In the Width in characters box, type a number indicating how many
characters wide you want the box to be.
5. Next to Password field, click Yes to ensure that characters in this text
box do not display on the screen.
Security Specifying this option does not encrypt data that is typed in
this text box.

Click the Style button to access other options for formatting your form using
cascading style sheets as an inline style.
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Add a check box to a form
1. In Page view, at the bottom of the document window, click Design .
2. Do one or both of the following:
Add a check box
1. Click in the form where you want to place the check box.
If you are inserting a form field but have not already created a form,
Microsoft FrontPage automatically creates a form area and inserts the
field inside that form area. The form area appears as a dashed line
when you are editing the page.
2. On the Insert menu, point to Form, and then click Checkbox.
3. On the form, beside the check box, type the label.
You can give the site visitor the ability to select the check box by
clicking the check box label.
How?
1. Select the text and the check box.
2. On the Insert menu, point to Form, and then click Label.
Set the properties of a check box
1. Double-click the check box.
2. In the Name box, type a name to identify the check box.
For your form to work correctly, you need to use a unique name for
this form field.
3. In the Value box, type the value to associate with this field.
When the check box is selected, this value is returned with the form

results, and is displayed on the default confirmation page. If the check
box has not been selected, the group name is included, but the value is
blank.
4. Click Checked if you want the check box to be selected by default
when a site visitor first opens the form.
5. Click the Style button to access other options for formatting your form
using cascading style sheets as an inline style.
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Add a drop-down box to a form
In Page view, at the bottom of the document window, click Design .
Add a drop-down box
1. Click in the form where you want to place the drop-down box.
If you are inserting a form field but have not already created a form,
Microsoft FrontPage automatically creates a form area and inserts the field
inside that form area. The form area appears as a dashed line when you are
editing the page.
2. On the Insert menu, point to Form, and then click Drop-down box.
3. Type the label beside or above the drop-down box on the form.
Set the properties of a drop-down box
1. Double-click the drop-down box.
2. In the Name box, type a name to identify the drop-down box.
For your form to work correctly, you need to use a unique name for this
form field.
3. Click Add to add the choices you want to display in the drop-down box.
4. In the Choice box, type an option you want to display in the drop-down
box.
If you want the value for this choice to be different from the text displayed
in the drop-down box itself, select Specify value, and then type the value in
the box.
For example, a choice in the menu could be John, but the value returned in
the form results could be me.
5. Click Selected under Initial State if you want the choice to be selected by
default when a site visitor first opens the form.

6. Click OK.
7. Repeat steps 3 through 6 for each choice you want to add.
8. To change the order in which choices are displayed, click a choice in the
list, and then click the Move Up or Move Down button.
9. In the Height box, type how many lines of text you want to show in the
drop-down box.
For example, if the drop-down box has three options, you can set the height
to 3 so that all choices are visible.
10. Click Yes under Allow multiple selections if you want to allow multiple
selections in the drop-down box. If you click No, the site visitor will be able
to make one choice only.
11. Click the Style button to access other options for formatting your form
using cascading style sheets as an inline style.
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Add an option button to a form
1. In Page view, at the bottom of the document window, click Design .
2. For each option button you want to add to a form (or a group of option
buttons), do one or both of the following:
Add an option button
1. Click in the form where you want to place the option button.
If you are inserting a form field but have not already created a form,
Microsoft FrontPage automatically creates a form area and inserts the
field inside that form area. The form area appears as a dashed line
when you are editing the page.
2. On the Insert menu, point to Form, and then click Option Button.
3. Type the label for the option button directly on the form, next to the
option button.
You can specify whether site visitors select the option by clicking
the button or its label.
How?
1. Select the text and the option button.
2. On the Insert menu, point to Form, and then click Label.
Set the properties of an option button
1. Double-click the option button.
2. In the Group name box, type a name to identify the group to which
this option button belongs.
For your form to work correctly, you need to use a unique name for
this form field.
3. In the Value box, type the value to associate with this field.

If this option button is selected, this value is returned with the form
results, and is displayed on the default confirmation page.
4. Beside Initial state, click Selected if you want the option button to be
selected by default when a site visitor first opens the form.
5. Click the Style button to access other options for formatting your form
using cascading style sheets as an inline style.
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Add a submit button to a form
1. In Page view, at the bottom of the document window, click Design .
2. Do the following:
Add a submit button
1. Click in the form where you want to place the submit button (push
button).
If you are inserting a form field but have not already created a form,
Microsoft FrontPage automatically creates a form area and inserts the
field inside that form area. The form area appears as a dashed line
when you are editing the page.
2. On the Insert menu, point to Form, and then click Push Button.
Set the properties of a submit button
1. Double-click the button.
2. In the Name box, type a name to identify the button.
For your form to work correctly, you need to use a unique name for
this form field.
3. Beside Button type click Submit.
4. By default, the button label text changes to Submit. You can type a
different button label in the Value/label box.
5. Click the Style button to access other options for formatting your form
using cascading style sheets as an inline style.
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Add a reset button to a form
1. In Page view, at the bottom of the document window, click Design .
2. Do the following:
Add a reset button
1. Click in the form where you want to place the reset button (push
button).
If you are inserting a form field but have not already created a form,
Microsoft FrontPage automatically creates a form area and inserts the
field inside that form area. The form area appears as a dashed line
when you are editing the page.
2. On the Insert menu, point to Form, and then click Push Button.
Set the properties of a reset button
1. Double-click the button.
2. In the Name box, type a name to identify the button.
For your form to work correctly, you need to use a unique name for
this form field.
3. Beside Button type click Reset.
4. By default, the button label text changes to Reset. You can type a
different button label in the Value/label box.
5. Click the Style button to access other options for formatting your form
using cascading style sheets as an inline style.
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Add a push button to a form
1. In Page view, at the bottom of the document window, click Design .
2. Do one or both of the following:
Add a push button
1. Click in the form where you want to place the push button.
If you are inserting a form field but have not already created a form,
Microsoft FrontPage automatically creates a form area and inserts the
field inside that form area. The form area appears as a dashed line
when you are editing the page.
2. On the Insert menu, point to Form, and then click Push Button.
Set the properties of a push button
1. Double-click the push button.
2. In the Name box, type a name to identify the button in the form
results.
For your form to work correctly, you need to use a unique name for
this form field.
3. In the Value/label box, type the text that will appear on the button.
4. In the Button type box, select Normal.
5. Click the Style button to access other options for formatting your form
using cascading style sheets as an inline style.
6. Click the Code button to view the HTML of your page so that you
can write a script for your button to give it an action.
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Add a text area to a form
1. In Page view, at the bottom of the document window, click Design .
2. Do one or both of the following:
Add a text area
1. Click in the form where you want to place the text area.
If you are inserting a form field but have not already created a form,
Microsoft FrontPage automatically creates a form area and inserts the
field inside that form area. The form area appears as a dashed line
when you are editing the page.
2. On the Insert menu, point to Form, and then click Text Area.
3. Type the label for the text area directly on the form.
Set the properties of a text area
1. Double-click the text area.
2. In the Name box, type a name to identify the text area.
For your form to work correctly, you need to use a unique name for
this form field.
3. If you want text to appear in the text area when a site visitor first opens
the form, type the text in the Initial value box.
4. In the Width in characters box, type a number indicating how many
characters wide you want the text area to be.
5. In the Number of lines box, type a number indicating how many lines
of text high you want the text area to be.
6. Click the Style button to access other options for formatting your form
using cascading style sheets as an inline style.
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Add a group box to a form
1. In Page view, at the bottom of the document window, click Design .
2. Do one or both of the following:
Add a group box
1. Click in the form where you want to place the group box.
If you are inserting a form field but have not already created a form,
Microsoft FrontPage automatically creates a form area and inserts the
field inside that form area. The form area appears as a dashed line
when you are editing the page.
2. On the Insert menu, point to Form, and then click Group Box.
Set the properties of a group box
1. Right-click in the group box, and then click Group Box Properties on
the shortcut menu.
2. In the Label box, type the name of the label for your group box.
3. In the Align box, select the alignment you want for your group box
label.
4. Click the Style button to access other options for formatting your form
using cascading style sheets as an inline style.
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Add an advanced button to a form
1. In Page view, at the bottom of the document window, click Design .
2. Do the following:
Add an advanced button
1. Click in the form where you want to place the advanced button.
If you are inserting a form field but have not already created a form,
Microsoft FrontPage automatically creates a form area and inserts the
field inside that form area. The form area appears as a dashed line
when you are editing the page.
2. On the Insert menu, point to Form, and then click Advanced Button.
Set the properties of an advanced button
1. Right-click on the button, and then click Advanced Button
Properties on the shortcut menu.
2. In the Name box, type a name.
For your form to work correctly, you need to use a unique name for
this form field.
3. In the Value box, type the value that is to be sent to the form handler.
4. In the Button Type box, select the type of button you want to use.
If you select Normal, you will need to write a script for the button to
have a function.
5. In the Button Size area, select, in characters, the width and height of
the button.
6. Click the Style button to access other options for formatting your form
using cascading style sheets as an inline style.
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Add a picture as a submit button to a
form
1. In Page view, at the bottom of the document window, click Design .
2. Do one or both of the following:
Add a picture as a submit button
1. Click in the form where you want to place the submit button.
If you are inserting a form field but have not already created a form,
Microsoft FrontPage automatically creates a form area and inserts the
field inside that form area. The form area appears as a dashed line
when you are editing the page.
2. On the Insert menu, point to Form, and then click Picture.
Set the properties of the picture submit button
1. Right-click the picture, and then click Form Field Properties on the
shortcut menu.
2. On the Form Field tab, in the Name box, type a name to identify the
picture.
For your form to work correctly, you need to use a unique name for
this form field.
3. On the Appearance tab, click the Style button to access other options
for formatting your form using cascading style sheets as an inline
style.
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Add a file upload control to a form
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point where you want to add the file upload control.
3. On the Insert menu, point to Form, and then click File Upload.
4. In the Destination Folder dialog box, click Create New Folder, and then
type the name of the folder.
5. Press ENTER, and then click OK.
6. Set the properties of the folder where uploaded files are stored.
How?
1. In the Folder List, right-click the folder, and then click Properties on
the shortcut menu.
2. Clear the Allow scripts to be run check box.
3. Select Allow anonymous upload to this directory.
4. Select Allow uploaded files to overwrite existing file names if you
want existing files to be overwritten.
5. Click OK.
Notes
To use the file upload control, your Web site must be located on a Web
server running Microsoft FrontPage 2002 Server Extensions, SharePoint
Team Services v1.0 from Microsoft, or Microsoft Windows SharePoint
Services. Ask your Web server administrator or Internet service provider
(ISP) whether your server is running these technologies.
Site visitors must use Microsoft Internet Explorer 4.0 or later or Netscape
Navigator 2.0 or later to upload files by using the file upload control.

Add a hidden field to a form
To add hidden fields to a form, follow these steps:
1.
2.
3.
4.
5.
6.

Open the page that contains the form.
In Page view, at the bottom of the document window, click Design .
Right-click a form field, and then click Form Properties.
In the Form Properties dialog box, click Advanced.
Click Add.
In the Name box, type the name of the new hidden field.
For your form to work correctly, you need to use a unique name for this
form field.

7. In the Value box, type the value that is to be sent to the form handler.
Note You do not need to enter a value if you are using hidden fields to
store information (for example, from one page to another in a multi-page
form), or to collect additional data from your site visitors (for example, a
login name or a timestamp).
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Delete a field from a form
You can delete fields from a form as needed. Every field— with the exception of
a hidden field— can be deleted in the same way.
1. In Page view, at the bottom of the document window, click Design .
2. Do one or both of the following:
Delete a field that is not hidden
Click the field you want to delete, and then press DELETE.
Delete a field that is hidden
1. Right-click the form, and then click Form Properties on the shortcut
menu.
2. Click Advanced.
3. Select the hidden field from the list, and then click Remove.

Disable automatic form functionality
for form fields
By default, when you insert a form field outside of a form area, Microsoft
FrontPage creates a form area with Submit and Reset buttons, and then inserts
the field inside the form.
If you want to use form fields with scripts rather than inside forms, you need to
first disable this feature by doing the following:
1. On the Tools menu, click Page Options.
2. On the General tab, clear the Automatically enclose form fields within a
form box to disable automatic forms.
Now you can write a script to use with your form fields and not have to use the
FrontPage automatic form area.

Set the tab order in a form
1. In Page view, at the bottom of the document window, click Design .
2. Double-click a field to edit its properties.
3. In the Tab order box, type a number (1 - 999) indicating the tab order for
the selected field.
If you specify the same number for two or more fields, the field that is first
on the page will come first in the tab order. To remove the field from the tab
order, type -1.
4. Repeat this procedure for each field for which you want to set the tab order.
Note Only Microsoft Internet Explorer 4.0 and later support a custom tab order.
Other Web browsers and earlier versions of Internet Explorer use the default tab
order.
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Set a keyboard shortcut for a field in
a form
Once you have inserted a form, do the following:
1. In Page view, at the bottom of the document window, click Design .
2.
3.
4.
5.
6.

Type text next to the field to create a label for it.
Select the text and the field.
On the Insert menu, point to Form, and then click Label.
Select a letter in the field's label to use as the shortcut.
Click Underline .

Notes
This feature is enabled only in Web browsers that support Dynamic HTML
(DHTML), such as Microsoft Internet Explorer 4.0 or later.
Use a unique letter for each shortcut. You may need to rename a field, or
choose another letter in the label, to ensure each shortcut is associated with
a unique letter.
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Troubleshoot forms
When I click the submit button, nothing happens.
Make sure you specified a form handler
1. Right-click the form, and then click Form Properties on the shortcut menu.
2. From here you can configure your form to send information to:
A file in a specified folder
An e-mail address
A database (one that already exists or that Microsoft FrontPage creates
for you)
A custom script you write to specify how to save your form results
Make sure the button is set as a submit button
1. Double-click the submit button.
2. Make sure that Button type is set as Submit, and not Normal or Reset.
When I click the submit button, all the text I typed inside the form
disappears.
Verify that your submit button is not set as a reset button.
1. Double-click the submit button.
2. Make sure that Button type is set as Submit, and not Reset.
How do I get the results I saved to a file on my server?
Open the Web site, and then open the _private folder.

This is the default folder where form results are sent. If you configured your
form to save to a different folder, open that folder.
Security When you are configuring your form results to be saved to a file, it is
best to keep the default folder that FrontPage sets up for you, _private, which is
a hidden folder that site visitors cannot open.
I keep getting an error message that tells me to contact my Webmaster.
Do one or more of the following:
Verify that your form is configured correctly
1. Do one of the following (depending on what kind of form it is):
Right-click the form, and then click Form Properties on the shortcut
menu.
Double-click the form.
2. Check the settings, as appropriate.
Check the server technology your Internet Service Provider is using
Contact your Web host or Internet service provider (ISP) and verify that
either FrontPage Server Extensions from Microsoft or SharePoint Services
(SharePoint Team Services v1.0 from Microsoft or Microsoft Windows
SharePoint Services) is installed on the server.
My form fields won't display
Check the server technology your Internet Service Provider is using
Contact your Web host or Internet service provider (ISP) and verify that
either FrontPage Server Extensions from Microsoft or SharePoint Services
(SharePoint Team Services v1.0 from Microsoft or Microsoft Windows
SharePoint Services) is installed on the server.

Are your form fields contained within a form?
When you want to create a form, Microsoft FrontPage inserts a rectangular area
outlined with a dashed line where you can add text and form fields. If your form
fields are not inside this rectangular area, they won't work.
To move a form field that is outside the rectangular area, click it, and then
drag it inside the dashed line.
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About working with data
By using Microsoft FrontPage to author your Web site, you can add data from a
variety of data sources. The tools you use to add data to your Web site depend on
the types of available data sources, the operating system running on your Web
server, and the server technology.
You can create a data-enabled Active Server Pages (ASP) or ASP.NET site or a
data-driven Web site.
About activating your Web site with data by using ASP or ASP.NET
Web sites based on ASP or ASP.NET can use desktop-based or server-based data
sources — such as Microsoft Office Access 2003.
You can run either the Database Results Wizard or the Database Interface
Wizard to create Web pages that display interactive views of desktop-based or
server-based data by using ASP code or ASP.NET controls, depending on which
technology is available on your Web server. Contact your Web server
administrator or Internet service provider (ISP) for more information.
About using the Database Results Wizard
By using the Database Results Wizard, you can connect to a database, create a
query, apply filtering and sorting to the results, and display the data on a Web
page that contains an optional search form for site visitors to use. You can also
use the wizard to create a new Microsoft Access database, use a built-in sample
database, connect to a database you created previously on your Web site, or
connect to a database on another server that you have permission to access. You
can connect to Microsoft Access, Microsoft SQL Server, and Oracle databases.
About using the Database Interface Wizard
By using the Database Interface Wizard, you can create Web pages where you or
your site visitors — depending on the settings you specify — can edit, delete, or
add new records to a database by using a Web browser. You can connect to

Microsoft Access, Microsoft SQL Server, and Oracle databases.
Server requirements for working with data on Web sites based on ASP or
ASP.NET
To use ASP, the following technologies are required on your Web server:
Microsoft Windows 2000, Microsoft Windows Server 2003, or Windows
XP Professional
Microsoft Internet Information Services (IIS) 5.0 (or later)
Active Server Pages (ASP) with Microsoft ActiveX Data Objects (ADO)
FrontPage Server Extensions from Microsoft or SharePoint Team Services
v1.0 from Microsoft
To use ASP.NET, the following technologies are required on your Web server:
Windows 2000, Windows XP Professional, or Microsoft Windows
Server 2003
Microsoft Internet Information Services (IIS) 6.0 (or later)
ASP.NET
About activating your Web site with the data-driven features of Windows
SharePoint Services
Microsoft Windows SharePoint Services, which is built on the Microsoft .NET
Framework, provides the component-based platform required for FrontPage
data-driven functionality.
When you work with a site based on Windows SharePoint Services, you can
access a wide range of data sources, including desktop-based and server-based
databases, Extensible Markup Language (XML) files, Web services, and
SharePoint lists. When you create a data-driven Web site, you select data sources
from a data source catalog and use Data View Web Parts to present data. Data
View Web Parts render data by using Extensible Stylesheet Language
Transformation (XSLT).
Server requirements for working with data on Windows SharePoint
Services

To use Microsoft Windows SharePoint Services, the following technologies are
required on your Web server:
Microsoft Windows Server 2003, Standard Edition, Enterprise Edition,
Datacenter Edition, or Web Edition
Microsoft Internet Information Services (IIS) 6.0 in IIS 6.0 worker process
isolation mode
ASP.NET

Reducing security risks with the
Database Results and Interface
wizards
Connecting to a database offers many benefits to Web site builders, but it also
poses security risks. When a site visitor views, searches, or otherwise interacts
with the information in a database, the site visitor, as an anonymous user, is
essentially being allowed to run code inside the database or Web server.
Security risks such as these can be reduced through careful Web page design and
database configuration. Microsoft FrontPage creates pages and regions that
reduce security risks, but database configuration is a key to helping safeguard
your data.
The following information is provided as an introduction to database security to
assist you in working to help protect the pages and sites you create by using the
Database Interface Wizard and Database Results Wizard.

Disable detailed error messages
If there is a problem connecting to the database or retrieving information, some
servers display information about the error so it can be fixed. This information
can assist malicious individuals in attacks on your database. FrontPage Database
Interface pages and Database Results regions do not display this information
automatically.

Use a restricted account for accessing the database
By enabling and password-protecting several accounts that access your database,
you can help to prevent users without permissions from gaining access to the
database and to limit the access of those with permission to the minimum control
they need.
Not all databases support this feature, but you should use it for those that do. Set

up a special account for the Web page with strict control over allowable actions.
Never use administrator access for this account. The following table shows
sufficient permissions for each of the different pages.
If you are using:
The account needs these permissions:
A database results region or page Read
A submission form
Write
Editor
Read, Write, Delete (records only if possible)

Choose a unique password
Protect the database editing pages by using a different username and password
from those used for the database or for other resources. If the editor password
gets compromised, then your other resources will still be safe.

Carefully design and construct your database
Specify data types and field sizes. This limits both the ability to form malicious
requests and how much text a malicious user can enter.

Disable, delete, or control access to stored procedures and built-in
macros
Some databases contain built-in macros to delete tables or even entire databases.
Make sure a malicious user cannot use them either.

Do not use HTML in database columns
Do not display or allow HTML in any database columns. Although the Database
Results Wizard enables you to allow HTML in database columns, this feature
should only be used in a trusted environment.
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Using the Database Interface Wizard
with ASP
Important The following procedures will not work on a Web site located on a
server running Microsoft Windows SharePoint Services.
By using the Database Interface Wizard on a Web site hosted on a server running
Active Server Pages (ASP), you can create Web pages to add, edit, or delete
database records. You can also specify a password to help protect those pages.
Security Use this feature with caution. Sensitive or confidential information
could be revealed to others, such as other authors of your Web site, or site
visitors on the Internet or your intranet.
Start the Database Interface Wizard
1. On the File menu, click New.
2. On the New task pane, under New Web site, click More Web site
templates.
3. Double-click Database Interface Wizard.
Specify ASP as the server technology and a database connection
1. In the FrontPage has detected that your page will display best using
area, make sure to select the check box for ASP, so that your pages will
work correctly on a Web site located on a server running ASP.
2. Specify the database connection you want.
Select the table or view and where it will be stored
1. In the Select the table or view you would like to use for this database
connection list, click the table or view you want.
2. In the Specify a location for the new files box, type a path to a folder in
the active Web site to store the pages for adding, deleting, and editing

database records.
Specify the database columns and form fields
Under Edit form field type list, you can add, modify, delete, or change the
order of the database columns and the corresponding form fields used to
edit or update those fields.
Notes
If you clicked Create a new Microsoft Access database within your Web
site on the first page of the wizard, the page to specify columns and fields
will appear sooner in the wizard.
Some options might be unavailable. For example, if you clicked Use an
existing database connection on the first page of the wizard, the option to
add new columns is unavailable.
Specify the pages to create
Select the pages you want the wizard to create for you.
Notes
When you select the pages you want the wizard to create for you, if you
select either the Submission Form or the Database Editor check box, you
can create pages to add, edit, and delete records. Likewise, if you select the
Don't password protect my submission form or my database editor
with a username and password check box, any site visitor can add, edit,
or delete database records.
Even if you do password protect this page, there are still security risks.
Refer to FrontPage Help to learn more about database and security best
practices.
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Using the Database Interface Wizard
with ASP.NET
Important The following procedures will not work on a Web site located on a
server running Microsoft Windows SharePoint Services.
By using the Database Interface Wizard on a Web site hosted on a server running
ASP.NET, you can create Web pages to add, edit, or delete database records. You
can specify a password to help protect those pages.
Security Use this feature with caution. Sensitive or confidential information
could be revealed to others, such as other authors of your Web site, or site
visitors on the Internet or your intranet.
Start the Database Interface Wizard
1. On the File menu, click New.
2. On the New task pane, under New Web site, click More Web site
templates.
3. Double-click Database Interface Wizard.
Specify ASP.NET as the server technology and a database connection
1. In the FrontPage has detected that your page will display best using
area, make sure to select the check box for ASP.NET, so that your pages
will work correctly on a Web site located on a server running ASP.NET.
2. Specify the database connection you want.
Select the table or view and where it will be stored
1. In the Select the table or view you would like to use for this database
connection list, click the table or view you want.
2. In the Specify a location for the new files box, type a path to a folder in
the active Web site to store the pages for adding, deleting, and editing

database records.
Specify the database columns and form fields
Under Edit form field type list, you can add, modify, delete, or change the
order of the database columns and the corresponding form fields used to
edit or update those fields.
Notes
If you clicked Create a new Microsoft Access database within your Web
site on the first page of the wizard, the page to specify columns and fields
will appear sooner in the wizard.
Some options might be unavailable. For example, if you clicked Use an
existing database connection on the first page of the wizard, the option to
add new columns is unavailable.
Specify the pages to create
Select the pages you want the wizard to create for you.
Notes
When you select the pages you want the wizard to create for you, if you
select either the Submission Form or the Database Editor check box, you
can create pages to add, edit, and delete records. Likewise, if you select the
Don't password protect my submission form or my database editor
with a username and password check box, any site visitor can add, edit,
or delete database records.
Even if you do password protect this page, there are still security risks.
Refer to FrontPage Help to learn more about database and security best
practices.
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Using the Database Results Wizard
with ASP
Important The following procedures will not work on a Web site located on a
server running Microsoft Windows SharePoint Services.
By using the Database Results Wizard on a Web site hosted on a server running
Active Server Pages (ASP), you can create Web pages to view and search
database records.
Security Use this feature with caution. Sensitive or confidential information
could be revealed to others, such as other authors of your Web site, or site
visitors on the Internet or your intranet.
Start the Database Results Wizard
On the Insert menu, point to Database, and then click Results.
Specify ASP as the server technology and the database connection
1. In the FrontPage has detected that your page will display best using
area, make sure to select the check box for ASP, so that your pages will
work correctly on a Web site located on a server running ASP.
2. Specify the database connection you want.
Specify the record source
Do one of the following:
To select the table or view you want, click Record Source.
To create a custom query, click Custom Query, and then click Edit.
Specify the fields to be displayed on the database results page

You can do one or more of the following:
To exclude fields from appearing in the database results region or to change
the order in which they appear, click Edit List.
To filter, limit, or sort the database results, to set up a search form, or to
provide default values for the search, click More Options.
Specify the formatting options for the database results region
You can format the database results region as a table, a list, or a drop-down
list.
Specify whether to display all records together or to split them into groups
You can do the following:
If you specified to display the records as a table or a list on the previous
page of the wizard, you can specify whether to display all of the records
together or to split them into groups of records with buttons to move
forward or backward through the records.
Additionally, if you specified that you wanted to use a field as a search field
in the previous page of the wizard, you can specify here that you want to
add a search form to your page.
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Using the Database Results Wizard
with ASP.NET
Important The following procedures will not work on a Web site located on a
server running Microsoft Windows SharePoint Services.
By using the Database Results Wizard on a Web site hosted on a server running
ASP.NET, you can create Web pages to view and search database records.
Security Use this feature with caution. Sensitive or confidential information
could be revealed to others, such as other authors of your Web site, or site
visitors on the Internet or your intranet.
Start the Database Results Wizard
On the Insert menu, point to Database, and then click Results.
Specify ASP.NET as the server technology and the database connection
1. In the FrontPage has detected that your page will display best using
area, make sure to select the check box for ASP.NET, so that your pages
will work correctly on a Web site located on a server running ASP.NET.
2. Specify the database connection you want.
Specify the record source
Do one of the following:
To select the table or view you want, click Record Source.
To create a custom query, click Custom Query, and then click Edit.
Specify the fields to be displayed on the database results page
You can do one or both of the following:

To exclude fields from appearing in the database results region or to change
the order in which they appear, click Edit List.
To filter, limit, or sort the database results, to set up a search form, or to
provide default values for the search, click More Options.
Specify the formatting options for the database results region
You can format the database results region as a data grid.
Specify whether to display all records together or to split them into groups
You can do the following:
You can specify whether to display all of the records together or to split
them into groups of records with buttons to move forward or backward
through the records.
Additionally, if you specified that you wanted to use a field as a search field
in the previous page of the wizard, you can specify here that you want to
add a search form to your page.
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Troubleshoot database integration
with ASP or ASP.NET
My Web page loads when I click Preview in Browser, but no data shows.
Your Web site might be hosted on an incorrectly configured Web server
A Web site based on ASP or ASP.NET can display interactive views of desktopbased or server-based data by using ASP code or ASP.NET controls.
To use ASP, the following technologies are required on your Web server:
Microsoft Windows 2000, Windows Server 2003, or Windows XP
Professional
Active Server Pages (ASP) with Microsoft ActiveX Data Objects (ADO)
FrontPage 2000 Server Extensions from Microsoft (or later) or SharePoint
Team Services v1.0 from Microsoft
Microsoft Internet Information Services (IIS) 5.0 (or later)
To use ASP.NET, the following technologies are required on your Web server:
Windows 2000, Windows Server 2003, or Windows XP Professional
ASP.NET
FrontPage 2000 Server Extensions (or later) or SharePoint Team Services
v1.0
Internet Information Services (IIS) 6.0 (or later)
Contact your Web server administrator or Internet service provider (ISP) for
more information.

Your Web site location starts with C:\ instead of http://
To display interactive views of data based on ASP or ASP.NET, a Web site must
be hosted on a server that uses the HTTP protocol. When you open or create a
Web site to be used with a database, verify the following:
If you've already created a Web site When you open the site in
Microsoft FrontPage, check to see that the location specified at the top of
the Folder List begins with http://. An example of a valid location is
http://www.example.com/subsite1.
If the location appears to be a path to a local or network location— such as
C:\Documents and Settings\User\My Documents\My Web Sites\Subsite1
— you'll need to create a Web site at a location that uses the HTTP
protocol. A Web site on a local or network drive is not a valid location to
display database-enabled pages.
If you need to create a Web site In the New dialog box, under Specify
the location of the new Web, the location you type must start with http://.
An example of a valid location is http://www.example.com/subsite1.
Do not use a local or network location— such as C:\Documents and
Settings\User\My Documents\My Web Sites\Subsite1. Instead, create a
Web site at a location that uses the HTTP protocol. A Web site on a local or
network drive is not a valid location to display database-enabled pages.
Your database page might not be saved with the correct extension
To display the contents of a database results region on your Web page, the file
must have an extension of .asp for Web sites running Active Server Pages (ASP)
or .aspx for Web sites running ASP.NET. A standard .htm or .html extension is
not valid.
My database-enabled page won't load when I click Preview in Browser.
If you see the error message "HTTP Error 403 (403.1 Forbidden: Execute Access
Forbidden)" in your browser window, the folder storing your file is not activated
to allow scripts to run.

1. In the Folder List, right-click the folder your page is stored in.
2. Select the Allow scripts to be run check box.
I can't run the Database Results Wizard because Database is unavailable
on the Insert menu.
There are several reasons why Database on the Insert menu might be
unavailable.
You're using a Web site based on Microsoft Windows SharePoint Services
Web sites located on servers running on Windows SharePoint Services use
a different set of features to display data. To display data on a Web site
based on Windows SharePoint Services, click the Data menu, and then
click Insert Data View.
You're using a disk-based Web site
When you open the site in Microsoft FrontPage, check to see that the
location specified at the top of the Folder List begins with http://. An
example of a valid location is http://www.example.com/subsite1.
If the location appears to be a path to a local or network location— such as
C:\Documents and Settings\User\My Documents\My Web Sites\Subsite1
— you'll need to create a Web site at a location that uses the HTTP
protocol. A Web site on a local or network drive is not a valid location to
display database-enabled pages.
Your authoring settings do not allow Active Server Pages (ASP)
1. On the Tools menu, click Page Options.
2. Click the Authoring tab.
3. In the FrontPage and SharePoint Technologies area, select the Active
Server Pages check box.
Your authoring settings do not allow Author-time Web Components

1. On the Tools menu, click Page Options.
2. Click the Authoring tab.
3. Select the Author-time Web Components check box.
You're not working in a Web site
Check to make sure that you opened a server-based Web site and not just a new
page outside of a Web site.
Your Web site might be hosted on an incorrectly configured Web server
Database integration features of Microsoft FrontPage work when your Web site
is hosted on or published to a Web server configured with one of the following:
A Web site based on ASP or ASP.NET can display interactive views of desktopbased or server-based data by using ASP code or ASP.NET controls.
To use ASP, the following technologies are required on your Web server:
Microsoft Windows 2000, Windows Server 2003, or Windows XP
Professional
Active Server Pages (ASP) with Microsoft ActiveX Data Objects (ADO)
FrontPage 2000 Server Extensions from Microsoft (or later) or SharePoint
Team Services v1.0 from Microsoft
Microsoft Internet Information Services (IIS) 5.0 (or later)
To use ASP.NET, the following technologies are required on your Web server:
Windows 2000, Windows Server 2003, or Windows XP Professional
ASP.NET
FrontPage 2000 Server Extensions (or later) or SharePoint Team Services
v1.0

Internet Information Services (IIS) 6.0 (or later)
Contact your Web server administrator or Internet service provider (ISP) for
more information.
I can run the Database Results Wizard but can't finish it because of errors.
If the server encounters an error when trying to retrieve a record source on the
second page of the Database Results Wizard, you might be attempting to access
a password-protected database without proper authentication.
To add a username and password, do the following:
1. On the Tools menu, click Site Settings, and then click the Database tab.
2. Click the database connection you want, and then click Modify.
The Database Connection Properties dialog box appears.
3. Click Advanced.
The Advanced Connections Properties dialog box appears.
4. Under Authorization, type the correct username and password.
The OK button is unavailable when I add a database connection.
In the New Database Connection dialog box, after you click an option, click
Browse to specify a URL for the database.
If you do not click Browse and then specify a URL, you will not be able to
complete the task and return to the Database tab in the Site Settings dialog box.
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About working with Web Parts
A Web Part is a modular unit of information that contains Web-based content
and is the building block of a Web Part Page. A Web Part is made up of several
component files that store the data and information necessary to render the Web
Part.
When you add Web Parts to your page by using Microsoft FrontPage, you have
more control over how they appear than you would by working with them in a
Web browser. You can also create connections between Web Parts so that when
you perform an action in one Web Part, it changes the contents of another Web
Part.
About Web Part connections
In Web sites located on Web servers running Microsoft Windows SharePoint
Services, the types of data sources that you can use include Extensible Markup
Language (XML) files, Web services, and SharePoint lists. Connecting sets of
data from different data sources usually requires advanced programming skills,
but by connecting Web Parts, you can pass data between them and synchronize
their behavior.
For example, you can connect a List View Web Part, which contains a column
with a hyperlink data type, to an Image Web Part, which contains a picture of an
employee. Each time you select a row in the List View Web Part, you can see the
picture of the employee displayed in the Image Web Part.
Although you can establish a Web Part connection by using the Web browser, by
using FrontPage, you can extend the functionality of Web Part connections. For
example, you can use the Form Web Part to filter the data in another Web Part,
or you can establish connections between Web Parts on two Web Part Pages in
the same top-level Web site.
About the Form Web Part
By using the Form Web part in FrontPage, you can extend the functionality of

Web Part connections by enabling site visitors to enter data through familiar
form interfaces, which pass data into a Web Part connection.
For example, by using FrontPage to connect the Form Web Part to another Web
Part capable of filtering through a Web Part connection, such as the List View
Web Part, you can enable your site visitors to filter the data in the list by using
an interface that is similar to a search box.
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Add a Web Part to a Web page
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Place the insertion point where you want a new Web Part.
On the View menu, click Task Pane.
On the menu of task pane options, click Web Parts.

5. Click New Web Part Zone.
Adding a Web Part zone is useful if you're working with a Web Part Page
that you will edit later by using a Web browser. Data Views work best when
added inside a Web Part zone.
6. If the Web Part you want is not available, do one of the following:
Browse for a Web Part
At the top of the Web Parts task pane, click the arrow, and then click
Browse.
Click Team Web Site Gallery to look for Web Parts in the active
site.
Click Virtual Server Gallery to find a Web Part that is part of
your virtual server.
Click Online Gallery to find a Web Part in the online library.
Search for a Web Part
At the top of the Web Parts task pane, click the arrow, and then click
Search.
Import a Web Part
At the top of the Web Parts task pane, click the arrow, and then click
Import.
Note If you cannot find the Web Part you want, the administrator of the

top-level Web site might have removed or changed the title of it. To locate
the Web Part, contact the administrator of the top-level site.
7. In the Web Part List, click the Web Part you want, and then drag it to the
page or to the Web Part zone, if you added one.

Add a Form Web Part
1. In Page view, at the bottom of the document window, click Design .
2. Place the insertion point where you want a new Web Part.
3. On the Insert menu, point to Form, and then click Form Web Part.
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Web Part connections
By connecting Web Parts, you can synchronize their behavior and manage data
in dynamic and interesting ways.
By using the Web Part Connections Wizard in Microsoft FrontPage, you can
complete a Web Part connection between Web Parts on the same page or on two
different pages in your site.
For example, you can connect a Web Part that displays employee data to a Web
Part that displays images. Each time you select a row of data in the employee
data Web Part that contains a column with a picture of that employee, you can
see the picture displayed in the other Web Part.

A Web Part connection is a way to pass data from one Web Part to
another Web Part and synchronize their behavior.
One Web Part provides the data.
Data can be lists, rows, cells, or parameter values.
The other Web Part gets the data.

Decide what data sources you want to work with
In some cases, the data you want is in an application data source that is external
to your site. By using the FrontPage Data Source Catalog, you can access a wide
range of data sources, including desktop-based and server-based databases,
Extensible Markup Language (XML) files, Web services, and SharePoint lists.

Types of Web Part connections
There are many ways to combine and connect Web Parts on a Web Part Page.
Typically, you will make several of these Web Part connections on your Web
Part Page. The following scenarios describe common types of data connections
between Web Parts. Think of these scenarios as basic building blocks for Web
Part connections.
Master/Detail
You have a master list of data, and you need to display detailed information
related to this master list.

Commonly accessed employee data, such as ID, name, and job title, is
displayed in a Web Part.
To look up employee details, you select a row.
The data in the row is passed to another Web Part.
In the other Web Part, all the employee details are displayed in a form
view.
Summary/Detail
You have a summary list of data, and you need to display the detailed
information that produces the summary data.

Year-to-date compensation information is displayed in a Web Part.
You select the the summary information about your accumulated
vacation time and sick days.
The summary information is passed to another Web Part.
In the Web Part that displays weekly data, you verify the weeks when
you recorded those days to refresh your memory or confirm their accuracy.
Parent/Child
You display a list of data (the parent), and for each row there is one or more
related rows (the children) that you want to display in another list.

A list of the most recent customer orders is displayed in a Web Part.
You click the row containing the order you want to examine.
The data from the row is passed to another Web Part.
In the other Web Part, all the line items for that order are displayed.

Search and filter
You want to enter data, such as search or filter criteria, in one Web Part to
display results in another Web Part.

In a Web Part, you enter book information, such as title, author, and
subject, to try to find the book or set of books.
You click Submit.
The search criteria is passed to another Web Part.
The other Web Part displays one or more books that match your
search criteria.
Calculations
Although you can often calculate data inside a Web Part, sometimes you may
want to combine two Web Parts to make your calculations more flexible.

You enter mortgage numbers into a Web Part.
You click Go.

The mortgage numbers are passed to another Web Part.
The other Web Part computes the mortgage and displays the monthly
payment schedule.
Alternate data views
Viewing your data in several different ways can help you to understand
implications, trends, and relationships. You can pass lists, rows, and cells (or
fields and parameters) from one Web Part and display the data in an alternate
view.
An example of a list
You want to display all company employees in a hierarchy chart.

The Web Part displays the employee ID, employee name, job title, and
manager ID of everyone who works for your company.
Because you are using all the data, no selection is required.
The data is passed to another Web Part.
The other Web Part displays the working relationships between
employees and can display alternate views of this hierarchy.

An example of a row
You want to view a row of demographic data in a chart, such as a pie chart or bar
graph.

A Web Part displays demographic data such as age, income, and
heritage.
You select a row of demographic data.
The data is passed to another Web Part.
The other Web Part displays the row of data in a pie chart and
alternatively a bar graph.
An example of a cell
You want to track the overall progress of a fund-raising drive.

In a Web Part, each member of a group enters the amount of money
they have raised.
The current total is displayed in a total field.
The total field is passed to another Web Part.
You check your group's overall progress in the other Web Part.
Data enhancement
You want to augment basic data about people and places to make it more
interesting, appealing, and useful.

A Web Part displays information you need to keep track of business
associates, such as name, address, and perhaps a photo.
You select a contact.
A row of data is passed to another Web Part.
You see a photo of the contact displayed in another Web Part and
locate their business address in a Web Part that shows a map.

Create a connection between two Web
Parts
Open a page that contains one or more Web Parts, and then do the following:
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the Web Part you want to create a connection from, and then
click Web Part Connections.
3. In the Web Part Connections Wizard, under Choose the action on the
source Web Part to use for this connection, in the list, click the action
you want.
The options in the list will vary depending on the type of Web Part you are
working with.
4. Click Next.
5. Specify the location of the Web Part you want to connect to by doing one of
the following:
To create a connection to a Web Part on the current page, click
Connect to a Web Part on this page.
To create a connection to a Web Part on another page in the Web site,
click Connect to a Web Part on another page in this Web.
6. Click Next.
7. In the Target Web Part list, click the Web Part you want to create a
connection to.
8. In the Target Action list, click the action you want.
9. Click Next.
10. In the Columns from Web Part list, click the name of the column you
want.
11. In the Columns in Web Part list, click the column you want, and then click
Next.
12. Click Finish.

Change the connection between Web
Parts
Open a page that contains a Web Part connection, and then do the following:
1. In Page view, at the bottom of the document window, click Design .
2. Right-click a Web Part that is connected to another Web Part.
3. In the Web Part Connections dialog box, select the Web Part connection
you want to change.
4. Click Modify.
5. Follow the instructions in the Web Part Connections Wizard.
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Remove the connection between two
Web Parts
Do one of the following:
Remove the connection between Web Parts in the same page
1. Open the Web page that contains the connected Web Parts.
2. In Page view, at the bottom of the document window, click Design .
3. Right-click one of the Web Parts, and then click Web Part Connections on
the shortcut menu.
4. Click the Web Part connection you want to remove, and then click Remove.
5. On the File menu, click Save.
Remove the connection between Web Parts in different pages
1. Open the Web page containing the Web Part that provides data to the
connected Web Part.
2. In Page view, at the bottom of the document window, click Design .
3. Right-click a Web Part, and then click Web Part Connections on the
shortcut menu.
4. Click the Web Part connection you want to remove, and then click Remove.
5. On the File menu, click Save.
The page that contains the other Web Part opens.
6. Switch to the page that contains the other Web Part.
7. On the File menu, click Save.
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About Data Views
By using Microsoft FrontPage, you can add Data View Web Parts— known as
Data Views— to your Web site that display data by using Extensible Stylesheet
Language Transformations (XSLTs).
When you use FrontPage to create or edit a data-driven Web site running on
Microsoft Windows SharePoint Services, you can add Data Views that can
extract data from a variety of available data sources, such as Extensible Markup
Language (XML) files, Web services, SharePoint lists, and OLE DB–compliant
databases such as SQL Server, DB2, and Oracle.
You can also customize Data Views to create custom displays of your data in
WYSIWYG format by using the Formatting toolbar. You can also perform
more advanced customizations by using the Data View Details task pane:
Style Choose a formatting style from a gallery of predesigned list view
styles. You can also add a toolbar for site visitors to perform custom
filtering on the list.
Filter Specify criteria to display a subset of the data in the Data View.
Sort & group Display items in a particular order and optionally group
them on a Web page beneath collapsible headings.
Conditional Formatting Set conditions for the data in your Data View.
Windows SharePoint Services, which is built on the Microsoft .NET Framework,
provides the component-based platform required for FrontPage data-driven
functionality.

Add a Data View
1. In Page view, at the bottom of the document window, click Design .
2. On the Data menu, click Insert Data View.
3. In the Data Source Catalog task pane, under the heading you want, click a
data source.
If the heading is collapsed, click to expand it.
4. Place your pointer over the data source you want, and then click the arrow
next to it.
5. On the shortcut menu, click Insert Data View.
6. In the Data View Details task pane, set the properties you want.

Group data in a Data View
1.
2.
3.
4.

Open a page that contains a Data View.
In Page view, at the bottom of the document window, click Design .
In the Data View Details task pane, click Sort & group.
In the Available fields list, click the fields you want, and then click Add.

5. Under Sort Properties, click Ascending or Descending.
6. Under Group Properties, click Show group header.
7. Do one of the following:
To show expanded or collapsed headings for site visitors, click
Expand group by default or Collapse group by default.
To show a footer at the end of each group that repeats the group title,
click Show group footer.
To hide the details for each group, click Hide group details.
To show all grouped items, even if the total exceeds the specified
number of items displayed, click Keep group items together.

Add a toolbar to a Data View
1.
2.
3.
4.

Open a page that contains a Data View.
In Page view, at the bottom of the document window, click Design .
In the Data View Details task pane, click Style.
On the Options tab, select the check box for Show toolbar with options
for.
5. To select the options you want on the toolbar, do the following:
To enable site visitors to filter the list by using one of the available
fields, click Filter.
To enable site visitors to sort the list by using one of the available
fields, click Sort.
To enable site visitors to group the list under collapsible headers, click
Group.

Remove a toolbar from a Data View
1.
2.
3.
4.

Open a page that contains a Data View.
In Page view, at the bottom of the document window, click Design .
In the Data View Details task pane, click Style.
On the Options tab, clear the check box for Show toolbar with options
for.

Change the layout of a Data View
Web Part
1.
2.
3.
4.

Open a page that contains a Data View.
In Page view, at the bottom of the document window, click Design .
In the Data View Details task pane, click Style.
On the General tab, in the HTML view styles list, select the view style you
want.
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Add or remove conditional
formatting for a Data View
1. In Page view, at the bottom of the document window, click Design .
2. In a Data View, specify the page element or field that you want to show or
hide based on the conditioning you specify.
How?
Do one of the following:
Select a field in the data view When you apply conditional
formatting, the field will show, hide, or display custom formatting for
the rows in your data view that match the conditions you specify.
Add text next to a field in the data view When you apply
conditional formatting, the text will show, hide, or display custom
formatting for the rows in your data view that match the conditions
you specify.
Insert an image next to a field in the data view When you apply
conditional formatting, the image will show, hide, or display custom
formatting for the rows in your data view that match the condition you
specify.
3. In the Conditional Formatting task pane, click Create, and then specify
the action you want.
4. Do one of the following:
To show content based on the conditions you specify, click Show
Content.
To hide content based on the conditions you specify, click Hide
Content.
To apply formatting based on the conditions you specify, click Apply
formatting.
5. Specify the conditions you want.
How?
1. In the Conditional Formatting task pane, click Create, and then click

2.
3.
4.
5.
6.
7.

Show Content.
In the Condition Criteria dialog box, click Click here to add a new
clause.
Click the Field name box for the active row, and then select the field
that contains the values you want.
Click the Comparison box, and then select the type of comparison
you want.
Click the Value box, and then type or select the option you want.
Click Advanced if you want to edit the XSL for the condition.
If you selected Apply Formatting in step 4 of the main procedure,
specify the formatting you want.
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Change the filters applied to a Data
View
1.
2.
3.
4.

Open a page that contains a Data View.
In Page view, at the bottom of the document window, click Design .
In the Data View Details task pane, click Filter.
In the Filter Criteria dialog box, do one or more of the following:
Add a new clause
1. Click Click here to add a new clause.
2. Click the Field name box for the active row, and then select the field
that contains the values you want.
3. Click the Comparison box, and then select the type of comparison
you want.
4. Click the Value box, and then type or select the option you want.
5. Click Advanced if you want to edit the XPath predicate for the filter
query. The Advanced button is only available if your data source is an
XML file.
Edit a clause
1. Click an existing clause.
2. Click the Field name box for the active row, and then select the field
that contains the values you want.
3. Click the Comparison box, and then select the type of comparison
you want.
4. Click the Value box, and then type or select the option you want.
5. Click Advanced if you want to edit the XPath predicate for the filter
query.
Delete a clause
Click the clause you want, and then press DELETE.

5. Click OK.

Change the text that appears for a
Data View with no records
1.
2.
3.
4.
5.

Open a page that contains a Data View.
In Page view, at the bottom of the document window, click Design .
In the Data View Details task pane, click Style.
Click the Options tab.
In the Text to display if no matching items are found box, type the
message you want.

Remove sorting options from a Data
View
1.
2.
3.
4.

In Page view, at the bottom of the document window, click Design .
Place the insertion point in a Data View.
On the Data View Details task pane, click Sort & Group.
In the Sort and Group dialog box, under Sort Order, select the field you
want.
5. Press DELETE.

Show or hide conditional formatting
criteria for a Data View
1. Open a page that contains a Data View with conditional formatting applied.
2. In Page view, at the bottom of the document window, click Design .
3. In the Conditional Formatting task pane, under Existing Conditions,
move the pointer over the condition you want, and then click the arrow that
appears.
4. Do one of the following:
To show all similar fields or page elements when the condition is set to
Show content when, click Show: All.
To hide all similar fields or page elements when the condition is set to
Show content when, click Show: None.
To hide all similar fields or page elements when the condition is set to
Hide content when, click Hide: All.
To show all similar fields or page elements when the condition is set to
Hide content when, click Hide: None.
To apply formatting to all similar fields or page elements when the
condition is set to Apply style when, click Apply: All.
To remove formatting from all similar fields or page elements when
the condition is set to Apply style when, click Apply: None.

Sort data in a Data View Web Part
1.
2.
3.
4.

Open a page that contains a Data View.
In Page view, at the bottom of the document window, click Design .
In the Data View Details task pane, click Sort & group.
In the Available fields list, select the fields you want, and then click Add.

5. Under Sort Properties, click Ascending or Descending.
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About using an existing database
Important The following procedures will not work on a Web site located on a
server running Microsoft Windows SharePoint Services.
If the Use an existing database connection option is unavailable in the active
Web site, do one the following:
If you want to use the Database Interface Wizard in a new site
1.
2.
3.
4.

Click Cancel to close the Database Interface Wizard.
On the Tools menu, click Site Settings. On the Database tab, click Add.
Configure the database connection that you want.
With the current site still open, run the Database Interface Wizard,
making sure to select the Add to current Web site option. The Use an
existing database connection option will be activated.

If you want to use the Database Interface Wizard to manage a database in
an existing site
1. On the Tools menu, click Site Settings. On the Database tab, click Add.
2. Configure the database connection that you want.
3. With the current site still open, run the Database Interface Wizard,
making sure to select the Add to current Web site option. The Use an
existing database connection option will be activated.

Filter data in a Data View
1.
2.
3.
4.
5.

Open a page that contains a Data View.
In Page view, at the bottom of the document window, click Design .
In the Data View Details task pane, click Filter.
In the Filter Criteria dialog box, click Click here to add a new clause.
Click the Field name box for the active row, and then select the field that
contains the values you want.
6. Click the Comparison box, and then select the type of comparison you
want.
7. Click the Value box, and then type or select the option you want.
8. Click Advanced if you want to edit the XPath predicate for the filter query.
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About working with data sources
When you work with a Web site based on Microsoft Windows SharePoint
Services, you can access a wide range of data sources, including desktop-based
and server-based databases, Extensible Markup Language (XML) files, Web
services, and SharePoint lists. You can connect to Microsoft Access, Microsoft
SQL Server, and Oracle databases. You can maintain the data sources available
to your Web site by using the Data Source Catalog task pane.
You can familiarize yourself with the data source structure and even step through
individual records by using the Data View Details task pane. If you want to
work with a data source, you can add data from it to a Web page by using a Data
View Web Part.
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Add a data source to the data source
catalog
1. In Page view, do the following:
2. On the Data Source Catalog task pane, click to expand the heading for the
type of data source you want to add.
3. Do one or more of the following:
Add a new SharePoint list
1.
2.
3.
4.

Under SharePoint Lists, click Create new SharePoint List.
Select the list you want.
In the Specify the name for the new list box, type a name for the list.
Click OK.
Add a new SharePoint library

1. Under SharePoint Libraries, click Create new Document Library.
2. Select the library you want.
3. In the Specify the name for the new document library box, type a
name for the library.
4. Click OK.
Add a new database connection
1. Under Database Connections, click Add to Catalog.
2. Click Configure Database Connection.
3. In the Server Name box, specify the server name where the database
is stored.
4. Under Authentication, specify the authentication method to use when
accessing the server.
5. Follow the steps in the wizard to create a database connection.

Add a new XML file
1. Under XML Files, click Add to Catalog.
2. In the Location box, type the path of the XML file.
3. Click OK.
If the specified XML file doesn't exist in your Web site, Microsoft
FrontPage will prompt you to import the file into the active Web site.
Add a new server-side script
1. Under Server-side Scripts, click Add to Catalog.
2. In the Data Source Properties dialog box, type the path into the URL
box, select whether to run the script on a Get or a Post by using the
Method option, and click the Add button to add the parameters to use
when running the script from a Web page.
Add a new XML Web service
1. Under XML Web Services, click Add to Catalog.
2. In the Service description location box, type the URL for the Web
service.
3. Click Connect Now.

Change the properties of a data
source
1. In Page view, at the bottom of the document window, click Design .
2. In the Data Source Catalog task pane, click to expand the heading for the
type of data source you want to change.
3. Click a data source, and then click Properties.
4. Select the properties you want.
The properties will vary according to the type of data source you select.
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About Web packages
Web packages are bundled collections of files that you import or export for use
in a Web site. Web packages can contain Web pages, templates, Web
components, themes, graphics, style sheets, and other elements.
Microsoft FrontPage includes predesigned Web package solutions, which are
self-contained, data-driven Web sites based on Microsoft Windows SharePoint
Services. You can also create Web packages by using files within your existing
site.
You can use the predesigned Web package solutions as a starting point for
creating a News and Reviews site or a Web Log. You can also deploy the
solutions to extend the functionality of an existing site based on Windows
SharePoint Services.
Predesigned Web package solutions
FrontPage contains two predesigned Web package solutions.
News and Reviews site By using the News and Reviews site, you can
deploy a data-driven news Web site, enabled by Windows SharePoint
Services, that supports reviews, discussions, and other interactive Web site
features.
Web Log By using the Web Log solution, you can deploy a data-driven
Web log, enabled by Windows SharePoint Services, that supports Web log
search, discussion comments for each log entry, favorite links, and other
reporting features.
About custom Web packages
When you create a Web package, you can identify dependencies — files required
by the packaged files — and add them automatically.
For example, you can create a Dynamic Web Template for your Web site and
then attach it to several pages in your site. You can apply a theme that you've

customized to those pages, and then you can add graphics that you've created by
using a graphics editing tool. You can then use Web packages to export those
files — including the Dynamic Web Template, the themes, and the custom
graphics — to a single file that you can import to another Web site or make
available for other FrontPage users to import.
Security
Avoid adding Universal Data Connection (UDC) files to a Web package. A
UDC file is an XML file, stored in the _fpdatasources folder, that contains
configuration information for a data source. UDC files can contain
passwords in plain text.
Avoid packaging SharePoint document or picture libraries that contain files.
When other users import the Web package, those files will be added to their
Web site.
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Add a Web package solution
1. On the File menu, click New.
2. In the New task pane, under New Web site, click Web package solutions.
3. Click the Web package solution that you want, and do one of the following:
To deploy the Web package on a server that is running Microsoft
Windows SharePoint Services, type the URL in the Specify the
location of the new Web site box, or click Browse.
To add the Web package solution to the current Web site, click Add to
current Web site.
4. To add the Web package to a Web site that uses Secure Sockets Layer (SSL)
for encrypted transactions, select the Encrypted connection required
(SSL) check box.
5. Click OK.
6. In the Items from Web package to import box, clear the check boxes for
the items you do not want.
Note If you clear check boxes for essential files, your Web package
solution will not work.
7. Click Import.
8. In the Security Warning dialog box, do one of the following:
Click Yes to continue importing the Web package.
Click No to cancel the import.
Click More Info to view the security certificate for the Web package.
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Export a Web package
1. On the Tools menu, point to Packages, and then click Export.
2. In the Files in Web site box, click the files or folders that you want to add
to a Web package, and then click Add.
3. Identify the dependencies, which are additional files that the selected files
require in order to work properly.
How?
1. If the Dependency checking list is not available, click Show
Dependencies.
2. In the Dependency checking list, do one of the following:
To show all dependent files, click Check all dependencies.
To show all dependent files except pages linked by hyperlinks or
external files such as external cascading style sheets, click Check
all dependencies, except hyperlinks.
To hide dependent files, click Do not show dependencies.
4. Click Add.
Any dependent files are added according to the setting you chose in the
previous step.
5. Click Properties, and then do the following:
In the Title box, type a name for the Web package.
In the Description box, type a description of the Web package.
In the Author box, type the name you want other users to see when
they view the properties for the Web package.
In the Company box, type the name of your company, if necessary.
Note The properties provide information to users before they import the
Web package. You must add this information before you save the package.

6. Click OK.
7. In the File name box, edit the default name for the Web package, browse to
the location where you want to save the Web package, and then click Save.

Help secure your packaged data
If your Web site is located on a server running FrontPage Server Extensions
from Microsoft, SharePoint Team Services v1.0 from Microsoft, or Microsoft
Windows SharePoint Services, take the following precautions:
Avoid adding Universal Data Connection (UDC) files to a Web package. A
UDC file is an XML file, stored in the _fpdatasources folder, that contains
configuration information for a data source. UDC files can contain
passwords in plain text.
Avoid packaging SharePoint document or picture libraries that contain files.
When other users import the Web package, those files will be added to their
Web site.
Import Web packages only from trusted sources. If you import a Web
package that contains malicious files, your site may be at risk.

Import a Web package
1. On the Tools menu, point to Packages, and then click Import.
2. Locate and click the Web package you want, and then click Open.
3. In the Destination box, edit the path to specify a folder name in your Web
site.
4. In the Items from Web package to import box, clear the check boxes for
the items you do not want.
5. Click Import.
6. In the Security Warning dialog box, do one of the following:
Click Yes to continue importing the Web package.
Click No to cancel the import.
Click More Info to view the security certificate for the Web package.
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Troubleshoot Web packages
I am unable to import a Web package.
Web packages cannot be imported into the following locations:
A Web site on a server running SharePoint Team Services v1.0 from
Microsoft
A disk-based Web site
Note You can export Web packages from a disk-based Web site.
When I click Web Package solutions, a dialog box with standard Web site
templates appears.
The Packages tab will not be displayed in the Web Site Templates dialog box if
the SharePoint Services check box is cleared on the Authoring tab in the Page
Options dialog box.
Some dependent files were not added when I exported a Web package.
Before you export a Web package, make sure to specify a dependency checking
option that enables you to identify all required files for the Web package. In the
Dependency checking list in the Export Web Package dialog box, click Check
all dependencies or Check all dependencies, except hyperlinks.
I checked dependencies before I exported my Web package, but my
cascading style sheet still was not added to the package.
The Check all dependencies, except hyperlinks option on the Dependency
checking list also excludes cascading style sheet files. To include cascading
style sheets when you export a Web package, click Check all dependencies.
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About security best practices
The following suggestions are designed to help you make educated choices
when working to reduce the security risks associated with running a Web site.
Best practices for managing files
Install the latest security patches and updates to your Web server. Notify
your site visitors of this practice as well.
When you are configuring your form results to be saved to a file, it is best
to keep the default folder that Microsoft FrontPage sets up for you,
_private. The _private folder cannot be browsed on Web servers running
FrontPage Server Extensions from Microsoft, SharePoint Team Services
v1.0 from Microsoft, or Microsoft Windows SharePoint Services.
Note Web servers running other technologies might not recognize this
folder as non-browsable. Use caution when publishing files by using File
Transfer Protocol (FTP) or Web-based Distributed Authoring and
Versioning (WebDAV), since the _private folder will not be recognized as
non-browsable on the remote server.
When you synchronize files by using Remote Web Site view, files on the
remote Web site will be downloaded to the local site. If malicious files were
placed on the remote Web site, the local Web site may be at risk. Be sure
that only trusted users have access to the remote site before you attempt to
synchronize files.
Security vulnerabilities in external files or controls may extend to Web
pages that use those items. For example, external cascading style sheets
(files with a .css extension), script files (files with a .js extension), custom
ASP.NET controls, or other items may pose a security risk. Be sure your
style sheets, add-ins, themes, executable files, scripts, controls, and other
files come from trusted sources.
Files that pose a threat to your server, or to the computers of Web site
visitors, may be uploaded intentionally (by malicious users) or

unknowingly (by trusted users). Make sure your server is running up-todate antivirus software and limit upload capability to trusted users. For
more details, contact your Web server administrator or Web site hosting
company.
Best practices for Web server security
Make sure to use a trusted Web site hosting company. To host e-commerce
solutions or SSL connections, a hosting service must possess a digital
certificate, which is issued by a third-party certificate authority. If you can't
verify the integrity of the server owner or hosting service, do not host your
Web site there.
Financial transactions require a reliable e-commerce solution hosted on a
Web server configured with Secure Sockets Layer (SSL) technology. If you
want to create an e-commerce solution, contact your Web server
administrator or Web site hosting company for more information.
Cross-site scripting is a security vulnerability that could affect many Web
sites and Web users. The vulnerability is the result of coding mistakes in
Web applications. For more information, visit the Microsoft Developer
Network (MSDN) Web site.
Identify the potential for SQL injection attacks when you process user input
that forms part of a SQL command. SQL injection is the act of passing
additional (malicious) SQL code into an application which is typically
appended to the legitimate SQL code contained within the application. If
your authentication scheme is based on validating users against a SQL
database, for example, if you're using Forms authentication against
Microsoft SQL Server, you must guard against SQL injection attacks. For
more information, visit the Microsoft Developer Network (MSDN) Web
site.
Be sure to use proper security settings on your Web site and to grant access
only to trusted users.
Be sure that your password is not readable by others. For example, do not
store it where it is readable as plain text, such as in a macro or the HTML or
other code of a page or file in the site. Do not send a password on the

Internet unless you use the SSL protocol, which encrypts data. You can tell
when a Web address uses SSL because the address starts with "https"
instead of "http."
A Web site certificate is a verification, issued by an independent
certification authority, that confirms the identity of a Web site. By using a
Web site certificate in your site, you can help prevent unauthorized people
from seeing the information that is sent to or from your site.
Best practices for passwords
Avoid using hard-coded passwords for pages in your site. If you must hardcode a password, store it in a folder that is not browsable by site visitors,
such as _private.
When you need to create passwords, use strong passwords. Strong
passwords combine uppercase and lowercase letters, numbers, and symbols,
and should not contain patterns, themes, or words found in a dictionary.
Change your password frequently; for example, every one to three months.
Notify your site visitors of this practice as well.
When you connect to a data source, be sure that your password is not
readable by others. For example, do not store it where it is readable as plain
text, such as in a macro or the HTML or other code of a page or file in the
site. Do not send a password on the Internet unless you use the Secure
Sockets Layer (SSL) protocol, which encrypts data. You can tell when a
Web address uses SSL because the address starts with "https" instead of
"http."
Best practices for using Web packages
If your Web site is located on a server running FrontPage Server Extensions
from Microsoft, SharePoint Team Services v1.0 from Microsoft, or Microsoft
Windows SharePoint Services, take the following precautions:
Avoid adding Universal Data Connection (UDC) files to a Web package. A
UDC file is an XML file, stored in the _fpdatasources folder, that contains
configuration information for a data source. UDC files can contain

passwords in plain text.
Avoid packaging SharePoint document or picture libraries that contain files.
When other users import the Web package, those files will be added to their
Web site.
Best practices for using cookies
Use HTTP-only cookies. To mitigate the risk of a third party accessing the
data stored in cookies on your site visitors' computers, the HTTP-only
attribute specifies that a cookie is not accessible through script. By using
HTTP-only cookies in your site, you can help reduce the possibility that
sensitive information contained in the cookie can be sent to a hacker's
computer or Web site with script.
Note Microsoft Internet Explorer 6 Service Pack 1 (SP1) supports the
HTTP-only attribute.
By posting links for your site visitors to download critical updates and patches
as well as the latest versions of the Web browsers that they use, you can help
ensure that your site visitors are using a more secure version of the Web browser
of their choice.
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About macros
If you perform a task repeatedly in Microsoft FrontPage, you can automate the
task with a macro. A macro is a series of commands and functions, stored in a
Microsoft Visual Basic module, that you can run whenever you need to perform
the task.
For example, you can use macros to create new pages and apply templates to
them.
The Visual Basic Editor is a program designed to make writing and editing
macro code easy to learn for beginners, and it provides plenty of Help. You don't
have to learn how to program or use the Visual Basic language to create a macro.
By using the Visual Basic Editor, you can create new macros, edit existing
macros, or copy macros from one module to another or between different pages.
You can also rename macros or modules that store macros.
After you create a macro, you can run it by choosing it from a list in the Macro
dialog box. To make a macro run whenever you click a particular button, you
can assign the macro to a toolbar button.
Security Use caution when running executable files or code in macros or
applications. Executable files or code can be used to carry out actions that might
compromise the security of your computer and data.
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Create a macro
1. On the Tools menu, point to Macro, and then click Macros.
2. In the Macro name box, type a name for the macro, and then click Create.
Macro names cannot contain spaces or punctuation marks, but you can use
underscores. For example, you can use Macro1 or Macro_1, but not Macro
1.
3. In the Visual Basic Editor, type or copy your code into the module window.
4. If you want to run the macro from the module window, press F5.
5. When you're finished creating your macro, click Close and Return to
Microsoft FrontPage on the File menu.

Edit a macro
1. On the Tools menu, point to Macro, and then click Macros.
2. Click the macro, and then click Edit.

Run a macro
1. On the Tools menu, point to Macro, and then click Macros.
2. Click the macro, and then click Run.
Security Use caution when running executable files or code in macros or
applications. Executable files or code can be used to carry out actions that might
compromise the security of your computer and data.

Debug a macro
1. On the Tools menu, point to Macro, and then click Macros.
2. Click the macro, and then click Step Into.
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About add-ins
Add-ins are supplemental programs that extend the capabilities of Microsoft
FrontPage by adding custom commands and specialized features. You can obtain
add-ins from the Microsoft Office Online Web site, third-party vendors, or you
can write your own custom add-in programs by using Microsoft Visual Basic for
Applications.
To conserve memory and increase the speed of FrontPage, it's a good idea to
unload add-in programs you don't use often. When you unload an add-in, its
features and commands are removed from FrontPage, but the add-in file itself
remains on your computer for easy reloading.
Developers can use Component Object Model (COM) add-ins, which provide
additional functionality in a variety of programming languages, including
Microsoft Visual Basic, Microsoft Visual C++, and Microsoft Visual J++. As a
developer, you'll find information about designing COM add-ins in Visual Basic
Help. While you are developing and testing, you can load or unload a COM addin in FrontPage before you have a working installation program for your add-in.
Note Do not confuse add-ins with plug-ins. A plug-in is one of a set of software
modules that integrate into Web browsers to offer a range of interactive and
multimedia capabilities.
Security Security vulnerabilities in external files or controls may extend to Web
pages that use those items. For example, external style sheets (files with a .css
extension), script files (files with a .js extension), custom ASP.NET controls, or
other items, may pose a security risk. Be sure your style sheets, add-ins, themes,
executables, scripts, controls, or other files come from trusted sources.
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Add or remove an add-in
An add-in is a small program that provides additional commands and features to
Microsoft FrontPage.
1. On the Tools menu, click Add-Ins.
2. Do one of the following:
Add an add-in
1. In the Add-Ins available box, select the check box next to the add-in
you want, and then click OK.
If the add-in you want does not appear in the Add-Ins available box,
click Add, locate and click the file for the add-in, and then click OK.
2. If necessary, follow the instructions in the setup program for the addin.
Remove an add-in
If you want to remove the add-in from memory and keep it in the AddIns available list, clear the check box next to the add-in.
If you want to remove the add-in from memory and from the Add-Ins
available list, click the add-in, and then click Remove. The next time
you start FrontPage, the add-in will be removed.
Note This procedure does not remove the add-in from your hard disk. To
remove it from your hard disk, you must uninstall the add-in.
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Check the spelling of different
languages
Important To check the spelling of different languages, you must install the
Microsoft Office 2003 Multilingual User Interface Pack or Microsoft
Office 2003 Proofing Tools for the languages you want to use in a Web site. In
addition, you must enable support for each language through Microsoft Office
Language Settings.
Set the spelling language for text
1. Select the text that you want to mark as a specific language.
2. On the Tools menu, click Set Language.
3. In the Mark selected text as list, click the language that you want, and then
click OK.
Set the spelling language for a Web page
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the page, click Page Properties on the shortcut menu, and then
click the Language tab.
3. In the Mark current document as list, click the language for the page, and
then click OK.
Set the default spelling language for a Web site
1. On the Tools menu, click Page Options.
2. On the General tab, in the Default spelling language list, click the default
spelling language for the current site.

Set the language of a page
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the page, click Page Properties on the shortcut menu, and then
click the Language tab.
3. In the Mark current document as list, click the language for the page.
Note Setting the language of a page enables Microsoft FrontPage to
automatically load the correct spelling dictionary. For FrontPage to load the
correct spelling dictionary, you must first install the Microsoft Office 2003
Multilingual User Interface Pack or the Microsoft Office 2003 Proofing Tools
for the languages you use on a page.

Encode a text file
Warning Depending on the content type, if you reload or save the text file as a
different encoding, you can lose the contents of the file.
1. On the File menu, click Open.
2. Locate and click the text file that you want, and then click Open.
Before you encode a text file, it is recommended that you save a backup
copy.
3. Right-click the document window, and then click Encoding on the shortcut
menu.
4. Do one of the following:
To reload the file, in the Reload the current file as box, click a
different encoding, and then click Reload.
To save the file, in the Save current file as list, click the encoding you
want , and then click Save As.

Encode an XML file
Warning Depending on the content type, if you reload or save the XML file as
a different encoding, you can lose the contents of the file.
1. On the File menu, click Open.
2. Locate and click the XML file that you want, and then click Open.
Before you encode an XML file, it is recommended that you save a backup
copy.
3. Right-click the document window, and then click Encoding on the shortcut
menu.
4. Do one of the following:
To reload the file, in the Reload the current file as box, click a
different encoding, and then click Reload.
To save the file, in the Save current file as list, click the encoding you
want, and then click Save As.

Set the default page encoding for a
Web site
1. On the Tools menu, click Site Settings, and then click the Language tab.
2. In the Default page encoding list, click the page encoding that you want as
a default setting for the active Web site.
3. If you do not want Microsoft FrontPage to verify that the encoding matches
your keyboard settings, select the Ignore the keyboard when deciding the
encoding of new pages check box.
Warning Setting the default page encoding to <none> is not recommended
because users would have to set the page encoding for each individual new page.
Otherwise, special characters not contained in the basic ASCII character set,
such as the euro character, might not display correctly.
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Set the encoding language for saving
or loading a page
1. In Page view, at the bottom of the document window, click Design .
2. Right-click the page, click Page Properties on the shortcut menu, and then
click the Language tab.
3. Under HTML encoding, do the following:
In the Save the document as list, click the encoding that you want to
save the active page in.
If the active page is not displaying correctly, in the Reload the
current document as list, click the encoding that you want to load the
active page in.
Warning If the active page displays incorrectly, the file may become corrupt if
you save the page over the original version.
Tips
For pages containing more than one language, you can use Unicode. This
encoding contains the basic Roman character set, plus characters from
languages throughout the world. Unicode corresponds to the Multilingual
(UTF-8) option.
To display the euro character correctly, you must set your page encoding to
either, US/Western European or Unicode.
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Find and replace special right-to-left
characters
This feature is available only if you have enabled support for right-to-left
languages by using Microsoft Office Language Settings. If you have enabled this
type of support, you can find and replace right-to-left text that contains
diacritics, kashidas, and alef hamzas.
1. On the Edit menu, click Replace.
2. In the Find what box, type the right-to-left text including characters such
as kashidas, alef hamzas, or diacritics, and then press CTRL+right SHIFT.
Make sure you press the SHIFT key on the right side of your keyboard.
3. In the Replace with box, type the replacement right-to-left text, and then
press CTRL+right SHIFT.
4. Under Search options, select the options you want.
To match right-to-left text with characters, under Advanced, select one or
more of the check boxes, including Match diacritics, Match kashida, and
Match alef hamza.
5. Do one of the following:
Find and replace right-to-left text in the current Web page
Do one of the following:
To manually replace each occurrence of text in the current page, click
Find Next, and then click Replace.
To replace all occurrences of text in the current page at one time, click
Replace All.
Find and replace right-to-left text in a Web site
1. Do one of the following:

To search for text in only those pages that are currently open,
click Find.
To search for text in only selected pages or in all pages of a Web
site, click Find in Site.
When you search for text in the pages of a Web site, Microsoft
FrontPage displays a list that contains occurrences of the text you
searched for.
2. To go to the first occurrence of the text in the Web site, selected pages,
or open pages, double-click a page in that list.
Notes
For the Arabic language, FrontPage supports finding and replacing
diacritics, alef hamzas, and kashidas.
For the Hebrew language, FrontPage supports finding and replacing
diacritics.
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absolute URL
The full Internet address of a page or other resource on the World Wide
Web. An absolute URL includes a protocol, such as "http," a network
location, and an optional path and file name. For example,
http://www.example.com/ is an absolute URL.
accessibility
The quality of a system incorporating hardware or software that makes it
usable by people with one or more physical disabilities, such as restricted
mobility, blindness, or deafness.
active hyperlink
A hyperlink that a site visitor is clicking in a Web browser. For example, a
hyperlink is active between the time a site visitor presses and releases the
mouse button, when clicking that hyperlink.
Active Server Page (ASP)
A server-side scripting technology for creating dynamic, interactive Web
applications. An ASP file is a document that contains scripts that are run by
an ASP-compatible Web server. After running those scripts, the Web server
sends the resulting pages and files to the Web browser.
active Web page
In FrontPage, the Web page that is currently open.
active Web site
In FrontPage, the Web site that is currently open.
ActiveX
A set of technologies that allows software components to interact with one
another in a networked environment, regardless of the language in which
the components were created. ActiveX is used primarily to develop
interactive content for the World Wide Web, although it can be used in

desktop and other programs.
ActiveX controls
Reusable software components that incorporate ActiveX technology.
ActiveX controls can be embedded in Web pages to produce animation and
other multimedia effects, interactive objects, and sophisticated programs.
They can be written in a variety of programming languages, including C,
C++, Java, and Visual Basic.
ActiveX Data Objects (ADO)
A data access interface that allows client programs to access and manipulate
data in a file- or server-based database.
ADO
See ActiveX Data Objects
Advanced Streaming Format (ASF)
A streaming file format for use with Windows Media Player. This file
format can include audio, scripts, ActiveX controls, and HTML documents.
ASF-format files have an .asf file name extension.
American Standard Code for Information Interchange (ASCII)
A coding scheme using 7 or 8 bits that assigns numeric values to 255
characters, including letters, numerals, punctuation marks, control
characters, and other symbols. ASCII is a standard for transmitting data
between different types of hardware and software systems, and it is built
into all personal computers.
anchor
See bookmark
animated GIF
A file containing a series of GIF-format graphics that are displayed in rapid
sequence, giving the appearance of a moving picture.
anonymous FTP
The ability to access a remote computer system, by using the File Transfer
Protocol (FTP), on which one does not have an account. Users have
restricted access rights with anonymous FTP and usually can only list, view,
or copy files to or from a public directory on the remote system. To help
maintain security, many FTP sites do not permit anonymous FTP access.
anti-aliasing
The smoothing of jagged edges in graphical elements and text. Antialiasing softens jagged lines or curves by shading adjacent pixels.
Apple QuickTime
See QuickTime
applet

See Java applet
article
A message or posting in a discussion group or an Internet newsgroup. An
article can be a response to another article. An article is also called a post.
ASCII
See American Standard Code for Information Interchange.
ASF
See Advanced Streaming Format
ASP
See Active Server Page
ASP.NET
A set of technologies in the Microsoft .NET Framework for developing
Web programs and XML Web services. Web servers that are compatible
with ASP.NET can host Web services and run Web programs. Because
ASP.NET can create HTML, XML, and other types of documents when
processing programs and services, site visitors can display the results in a
Web browser. ASP.NET programs and services can be written in any .NETcompatible language, including Visual C# .NET.
ASP.NET controls
Components that run on an ASP.NET-compatible server and encapsulate
user-interface and other related functionality. They are used in ASP.NET
pages and in ASP.NET code classes.
aspect ratio
In computer displays and graphics, the ratio of the width of a picture or
picture area to its height. For example, an aspect ratio of 2:1 indicates that
the picture is twice as wide as it is high. The aspect ratio is an important
factor in maintaining correct proportions when a picture is incorporated into
another document, such as a Web page.
Audio Video Interleave (AVI)
A multimedia file format for use with Windows Media Player. This file
format can include sound and video, and it adheres to the Resource
Interchange File Format (RIFF) specification. AVI-format files have an .avi
file name extension.
authentication
The process of verifying that an entity or object is who or what it claims to
be. For example, a user name and password may be used to authenticate a
user.
authentication database
A database on a server that verifies that an entity or object is who or what it

claims to be. For example, an authentication database can match user names
to passwords.
autostretch
In FrontPage, an option for setting all or part of a layout table to a fixed
width. After setting part of a layout table to a fixed width, the other part of
the layout table automatically stretches to adjust to the size of the Web
browser window. See also layout table, layout cell.
AVI
See Audio Video Interleave
B
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background sound
An audio file associated with a Web page. When a site visitor opens the
page in a Web browser, the audio file plays either continuously or the
number of times that the code in the Web page specifies.
banner
See page banner
base location, base URL
A URL that you can specify for a Web page in order to convert all relative
URLs on that page to absolute URLs. A base URL should end with either a
file name, such as http://www.example.com/sample.htm, or a trailing slash,
such as http://www.example.com/subdir/.
Behaviors
Scripting options that add interactivity or increased functionality to text or
other elements in a Web page.
bevel
A three-dimensional edge effect applied to the border of a graphic.
bitmap (BMP)
A picture consisting of a series of small dots, much like a grid with certain
squares filled in to form shapes and lines. Bitmap is a standard graphics file
format on Windows-based computers. It supports 24-bit color and can be
saved for Windows or OS/2 systems. BMP-format files typically have a
.bmp file name extension.
bookmark
A named location on a Web page that can be the target of a hyperlink. A
bookmark can be applied to a string of characters or exist on a page

separately from any text. Bookmarks allow you to link to a specific section
of a target page. A bookmark is also called an anchor.
broken hyperlink
A hyperlink that points to an incorrect URL or a missing page or file.
browser
See Web browser
browser-safe palette
A color table containing only 216 of a possible 256 colors, used to precisely
match and display colors in graphics. The remaining 40 colors are omitted
because they can display differently, depending on the color-quality settings
of the computers that display them.
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cascading style sheet (CSS)
An HTML specification developed by the World Wide Web Consortium
that defines how authors of Web pages can attach style sheets to Web pages.
Styles sheets define the appearance and formatting of content on Web pages
and allow you to have more control over how content displays in Web
browsers.
category
In FrontPage, a classification for labeling and grouping Web pages and files
by common criteria, such as page contents, file types, or similar distinction.
cell padding
The amount of space, in pixels, between the contents and inside edges of a
table cell.
cell spacing
The amount of space, in pixels, between cells in a table. Cell spacing is the
thickness of the walls surrounding each cell.
certificate
A digitally signed document that is issued by a certification authority on
behalf of a user, a computer, or a service. Certificates help to ensure that no
other Web site can assume the identity of a site. This helps make sensitive
online transactions, such as shopping, more secure by preventing
unauthorized access to information sent to or from a site.
CGI
See Common Gateway Interface

character encoding
A one-to-one mapping between a set of characters and a set of numbers.
Character encodings allow Web browsers to interpret the characters in a
Web page and display those characters correctly.
character set
A group of alphabetic, numeric, and other characters needed to display text
in a specific language.
child Web site
See subsite
class selector
In cascading style sheets, a name identifying a user-defined style.
Depending on how it's defined, a class selector can be used with a single
type of tag or with any HTML tag inside the BODY element.
client
On a network or the Internet, a computer that accesses shared network
resources provided by another computer. See also server.
client-side image map
An image map that directly encodes in a Web page the destination URL of
each hot spot in that image map. Client-side image maps do not require
processing from a server when a site visitor follows the hyperlinks in the
image map.
client-side program
On the Internet, a program that is run on a client computer rather than on a
server computer.
code snippet
In FrontPage, one or more lines of HTML or other code that you can save
and use again.
Code view
In FrontPage, a view that displays the HTML and other code of a Web page
or a file.
comment
In FrontPage, text that you can view in Page view, but that does not appear
in a Web browser. Comment text appears purple in Page view and is used to
insert notes to authors and editors during the development of the page.
Although comment text does not appear in a Web browser, site visitors can
view it by viewing the source HTML of the page.
Common Gateway Interface (CGI)
A standard method of extending Web server functionality by running
programs or scripts on a Web server in response to Web browser requests. A

common use of CGI is in form processing, where the Web browser sends
form data to a CGI script on the server, and then the script integrates the
data with a database and returns the results as a Web page.
component
In FrontPage, a built-in object that is evaluated and run when you save a
Web page or, in some cases, when a site visitor browses to the page.
Components in FrontPage include search forms, which allow site visitors to
search for text in a Web site, and form handlers, which gather information
from a form.
compression
The process of reducing the size of a file by changing its format so that it
requires less storage space or takes less time to transfer. See also
decompression.
confirmation page
A Web page confirming that data entered into a form has been successfully
submitted by a site visitor.
CSS
See cascading style sheet
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DAO
See Data Access Objects
Data Access Objects (DAO)
A data access interface that communicates with Microsoft Jet and ODBCcompliant data sources to connect to, retrieve, manipulate, and update data
and database structures.
data connection
A connection that specifies the name, type, location, and, optionally, other
information about a database file or server.
data source
A stored set of information. A data source might be a database, an XML
file, a Web service, or a list on a Windows SharePoint Services Web site.
data validation
A set of rules that you can apply to form fields and other types of fields to
restrict the type of information site visitors can enter into those fields.
Data View

In FrontPage, a customizable display of data that can be populated by a
variety of data sources.
database
A file or server containing records of information that are organized and
presented to serve a specific purpose, such as the facilitation of searching,
sorting, and combining data. Databases can be published on the World
Wide Web to let site visitors search for information or add new information
to the database.
database results region
In FrontPage, an area on a Web page that can be dynamically populated
with the results of a database query when a site visitor opens the page in a
Web browser.
DAV
See Web-based Distributed Authoring and Versioning (WebDAV)
decompression
The process of reversing the procedure that is run by compression software.
During decompression, the compressed data returns to its original file size
and format so it can be accessed or played. See also compression.
default hyperlink
In an image map, the hyperlink that site visitors follow when they click an
area of the graphic where there are no hot spots.
Design view
In FrontPage, a view that displays an approximated WYSIWYG version of
a Web page. You can use Design view to insert text, forms, graphics,
components, and other items in a page.
design-time control
An ActiveX control that is used while designing or editing a Web page.
Design-time controls are installed on the client computer. See also ActiveX.
DHTML
See Dynamic HTML
discussion group
A Web site that supports interactive discussions between site visitors.
Visitors submit topics or responses by entering and then submitting text in a
form. Visitors can search the group by using a search form or access articles
by using a table of contents.
domain name
An address of a network connection that identifies the owner of that
address, such as server.organization.type. For example, www.microsoft.com
identifies a Web server at Microsoft Corporation, which is a commercial

organization. See also network location.
Dynamic HTML (DHTML)
An extension of HTML that allows you to add interactivity and graphical
interest to Web pages. Web pages that use DHTML can change and update
dynamically in response to site visitor actions, without being downloaded
from a server after every action.
Dynamic Web Template
An HTML file to which you can attach other HTML files that share the
same layout. When you update a Dynamic Web Template, all pages that are
based on that template are also updated. Dynamic Web Templates have a
.dwt file name extension.
E
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e-mail
An abbreviation for electronic mail. The exchange of text messages and file
attachments between computers over a communications network, such as a
network or the Internet.
embedded files
In FrontPage, graphics, sounds, and other types of multimedia files that
have been inserted in a Web page. When you save the page, you are
prompted to save the embedded files with the page.
embedded style sheet
A cascading style sheet that is part of a Web page. Styles in an embedded
style sheet can be applied only to the page containing the style sheet and
either extend or override styles defined in any external style sheet that the
page links to. An embedded style sheet is stored in a STYLE tag in a Web
page.
Encapsulated PostScript (EPS)
An extension of the PostScript graphics file format developed by Adobe
Systems Incorporated. EPS format is a high-resolution format that is
optimized for printing by PostScript printers. If an EPS-format graphic is
printed by any other type of printer, an alternate, lower-resolution version
of the graphic is printed. EPS-format files have an .eps file name extension.
encoding
See character encoding
encryption

The process of encoding data to prevent unauthorized access, especially
during transmission over the Internet or a network.
EPS
See Encapsulated PostScript
executable folder
A folder in a Web site from which scripts and executable programs can be
run. Server administrators may prohibit the use of executable folders.
Extensible Markup Language (XML)
A subset of Standard Generalized Markup Language (SGML), a language
for creating customized data structures that allow for the definition,
transmission, validation, and interpretation of data between programs,
servers, and organizations.
Extensible Stylesheet Language (XSL)
An XML-based language for creating style sheets that transform XML
documents to other types of documents, such as HTML, and that define the
format or presentation of the data in the resulting document.
Extensible Stylesheet Language Transformations (XSLT)
A language for transforming XML documents into other XML documents.
It is a subset of Extensible Stylesheet Language (XSL).
external hyperlink
A hyperlink pointing to a page or file that is not part of the active Web site.
external style sheet
A cascading style sheet (CSS) in a file with a .css file name extension. The
.css file contains style rules in valid CSS syntax, without any surrounding
HTML tags. By defining styles in one or more external style sheets and
linking them to pages in your Web site, you ensure a consistent appearance
throughout those pages. If you change a style in the external style sheet, the
change will be reflected in all of the pages linked to that style sheet.
F
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file
A named collection of information that is stored on a computer. Also, an
Internet protocol (file://) that refers to files on a disk or network.
file name extension
The characters that follow a period in a file name and indicate the file’s
format or type. For example, the file Image.gif uses the .gif file name

extension, which indicates that the file is a GIF-format graphic.
file server
A computer running on a network that stores files and provides access to
them. A file server is also called a server. See also Web server.
File Transfer Protocol (FTP)
A protocol for copying files to and from remote computer systems on a
network or the Internet. FTP sites are frequently used on the Internet for
making files and folders publicly available.
file type
The format of a file, commonly indicated by its file name extension.
filter
A set of criteria applied to data in order to display only a subset of that data
or to sort that data.
firewall
A combination of hardware and software that helps secure a network or
computer system. A firewall can help prevent unauthorized access to a
protected network, while enabling the protected network to access networks
outside of the firewall.
Flash
A vector graphic animation technology, by Macromedia, Inc., for creating
movies, animations, presentations, and more. Flash content can play on any
type of computer, if the Flash plug-in is installed on that computer. See also
plug-in.
folder
A named storage area on a computer containing files and other folders.
Folders view
In FrontPage, the view of a Web site that shows how the content of the Web
site is organized. Similar to Windows Explorer, you can create, delete, copy,
and move folders in Folders view.
followed hyperlink
A hyperlink on a Web page that a site visitor has activated by using a mouse
device, keyboard, or other type of device.
form
A set of data-entry fields on a Web page. The data is sent to the server when
a site visitor completes and submits the form.
form field
A data-entry field in a form. A site visitor supplies information in a field by
either typing text or selecting an option.
form handler

A program on a server that runs when a site visitor submits a form.
frame
An area of a Web browser window defined by a frames page. A frame
appears in a Web browser as one of a number of different areas in which
pages can be displayed. A frame may be scrollable and resizable, and may
have a border.
frames page
A page that divides a Web browser's window into different areas, called
frames, which independently display different Web pages. A frames page is
also called a frameset.
frameset
See frames page
FrontPage Server Extensions
A set of programs and scripts that support authoring in FrontPage and
extend the functionality of a Web server. The FrontPage Server Extensions
are available for Internet Information Services (IIS) and other Windowsbased Web servers, as well as UNIX-based Web servers.
FTP
See File Transfer Protocol
function
An action or operation performed by a script. A function may return a value
or other result.
G
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gateway script
See Common Gateway Interface
GIF
See Graphics Interchange Format
graphic
An image or picture file that can be inserted in a Web page.
Graphics Interchange Format (GIF)
A raster graphics file format commonly used to display indexed-color
graphics on the World Wide Web. GIF is a compressed format, which is
designed to minimize file transfer time over the Internet. GIF-format files
have a .gif file name extension. See also interlaced GIF.
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heading
A paragraph style that displays text in a font that is larger than normal text.
The size of text in a heading relates to its level: Heading 1 is the largest,
Heading 2 is the next largest, and so on.
hexadecimal
A base-16 number system represented by the digits 0 through 9 and the
uppercase or lowercase letters A (equivalent to decimal 10) through F
(equivalent to decimal 15). Hexadecimal values are commonly used in
HTML code to identify colors.
hidden field
A form field that is invisible to a site visitor but supplies data to a form
handler.
hidden folder
In FrontPage, a folder with an underscore (_) at the beginning of its name
— for example, _hidden. A hidden folder typically contains supporting files
for a Web site. You can specify whether you want to show or hide these
folders in the Folder List and some views.
hit
In Web site usage reports, a value indicating the number of times a Web
page or file has been accessed. See also visit.
home page
The entry page for a set of Web pages and other files in a Web site. The
home page opens by default when a site visitor browses to a site by using a
Web browser.
host
See server
hot spot
An area in a graphic that contains a hyperlink. A graphic with one or more
hot spots is called an image map. See also image map.
HTML
See Hypertext Markup Language
HTML attribute
A value used within an HTML tag to assign additional properties to the
element being defined.
HTML tag
A text string enclosed in angle brackets (<>) that specifies a page element's

type, format, and appearance.
HTTP
See Hypertext Transfer Protocol
HTTPS
See Hypertext Transfer Protocol Secure
hyperlink
A pointer from text, a graphic, or other page element to a Web page or file.
On the World Wide Web, hyperlinks are the primary way to browse
between Web pages and Web sites. A hyperlink is also called a link.
Hyperlinks view
In FrontPage, a view that shows the status of the hyperlinks in a Web site.
The list includes both internal and external hyperlinks, and graphically
indicates when a hyperlink is intact or broken.
Hypertext Markup Language (HTML)
The standard markup language for documents on the World Wide Web.
HTML is a subset of Standard Generalized Markup Language (SGML). It
uses tags to indicate how Web browsers should display page elements such
as text and graphics, and how Web browsers should respond to actions such
as the activation of a link by a key press or mouse click.
Hypertext Transfer Protocol (HTTP)
A protocol that allows Web browsers to retrieve Web pages and information
from servers on the World Wide Web.
Hypertext Transfer Protocol Secure (HTTPS)
A protocol that allows Web browsers to retrieve Web pages and information
more securely from servers on the World Wide Web. HTTPS provides for
the encryption and transmission of information through a special port.
I
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ID selector
In a cascading style sheet style definition (or style rule), a selector that is
used to define a style for an individual page element, usually as an inline
style.
image map
A graphic containing one or more invisible regions, called hot spots, that
link to a page or file.
image tracing

In FrontPage, the process of using a graphical mock-up of a Web page as a
visual guide for tracing, thereby creating, the Web page design.
initial page
The page that initially appears in a frame when a site visitor browses to a
frames page containing that frame.
inline style
A cascading style sheet rule whose properties and values apply only to a
specific element on a Web page, such as a table or a graphic. The style sheet
rule is part of the HTML tag for that element.
interlaced GIF
A picture in Graphics Interchange Format (GIF) format that gradually
displays in a Web browser, showing increasingly detailed versions of the
picture until the entire file has finished downloading.
internal hyperlink
In FrontPage, a hyperlink pointing to any Web page or file in the active
Web site.
internal Web site
A Web site created within an organization and available only on the intranet
for that organization. An internal Web site is accessible only to members of
that organization.
Internet
The worldwide collection of computers, networks and gateways that use
TCP/IP protocols to communicate with one another.
Internet address
A unique address that identifies the location of a page, file, or other type of
resource on the Internet. An Internet address typically includes four
elements: the protocol for accessing the resource, such as http://; the server
type; the server name, which is often the name of the organization that
maintains the resource; and, a suffix, which typically identifies the type of
organization that maintains the resource. An Internet address is also called a
Uniform Resource Locator.
Internet Protocol (IP)
A TCP/IP protocol that divides data into packets, routes packets from a
sender to a destination network and station, and reassembles the packets
into the original data.
Internet Server Application Programming Interface (ISAPI)
An application programming interface designed specifically for Web
servers running Internet Information Server (IIS). When a Web browser
sends or requests information from a Web server, ISAPI processes the

information by running scripts and other processes, and then submits the
information to the Web server. ISAPI then retrieves the results from the
Web server and sends them to the browser as a Web page.
Internet service provider (ISP)
A business that supplies Internet connectivity services to individuals,
businesses, and other organizations.
intranet
A network within an organization that uses Internet technologies and
protocols but is available only to certain people, such as employees of a
company. An intranet is also called a private network.
IP
See Internet Protocol
IP address
An abbreviation for Internet Protocol address. A standard for identifying a
computer that is connected to the Internet. An IP address is four groups of
numbers from 0 through 255, each separated by a period— for example,
123.432.154.12
ISAPI
See Internet Server Application Programming Interface
ISP
See Internet Service Provider
J
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Java
An object-oriented programming language developed by Sun
Microsystems, Incorporated. Programs written in Java are platformindependent, which means they can run on any type of computer.
Java applet
A program written in the Java programming language that can be included
in an HTML page. Java applets can be downloaded and run by a Web
browser capable of interpreting Java, such as Internet Explorer or Netscape
Navigator.
Java Virtual Machine
A program that runs Java applets and programs. The Java Virtual Machine
is included with most Web browsers.
JavaScript

A scripting language that can be used to add functionality to or enhance the
look of a Web page or a Web site. JavaScript scripts can run on any type of
client or server computer.
Joint Photographic Experts Group (JPEG)
A raster graphics file format for displaying high-resolution color graphics
on the World Wide Web. JPEG graphics apply a user-specified compression
scheme that can significantly reduce the file sizes of photo-realistic color
graphics. A higher level of compression results in lower quality, whereas a
lower level of compression results in higher quality. JPEG-format files have
a .jpg file name extension. See also progressive JPEG.
JPEG
See Joint Photographic Experts Group
L
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layer
A container in a Web page that holds page elements, such as text and
graphics. You can overlap, nest, and show or hide layers on a page. You can
also animate layers by using Behaviors, which add script to any tag in a
page.
layout cell
A cell in a layout table.
layout table
A predefined layout that defines the structure of a Web page as a table. A
layout table can also include formatting such as rounded corners, borders,
and visual effects. See also autostretch.
link
See hyperlink
link bar
In FrontPage, a collection of graphical or textual buttons containing
hyperlinks to Web pages.
list members
Valid code elements, such as properties, methods, and events, for a specific
object reference.
live Web site
A Web site that has been published to a Web server and can be browsed by
site visitors. See also staging Web site.

local Web site
When publishing files from one location to another by using FrontPage, the
Web site that is currently active, or open, in FrontPage. See also remote
Web site.
loop
The process of playing a sound repeatedly a specific number of times or
endlessly.
M
Back to top
Macromedia Flash
See Flash
mailto
The Internet protocol for sending electronic mail.
META tag
An HTML tag in the HEAD portion of a Web page. META tags contain
information about a page, such as the character encoding for the page.
MIME (Multipurpose Internet Mail Extensions) type
A method used by Web browsers to associate files of a certain type with
programs that display files of that type.
Moving Picture Experts Group (MPEG)
A family of standards for coding audio-visual information, such as movies,
video, and music, in a digitally compressed format. MPEG files are
typically smaller than most video formats, but provide the same quality.
MPEG-format files have an .mpeg or an .mpg file name extension.
MPEG
See Moving Pictures Experts Group
multi-hosting
The ability of a Web server to support more than one Internet address and
more than one home page. Multi-hosting is also called multi-homing.
N
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name-value pair
The name of a form field and the value of the field when the form is
submitted. Each field in a form can have one or more name-value pairs and

the form itself can have one or more name-value pairs.
navigation bar
See link bar
Navigation view
In FrontPage, the view for creating, displaying, printing, and changing the
navigational structure of a Web site. Navigation view includes a folder-like
view, where you can drag and drop Web pages in the navigational structure
of a Web site.
network location
In a URL, a unique name that identifies an Internet server. A network
location has two or more parts, separated by periods— for example,
www.example.com. Also called host name and Internet address.
news
The Internet protocol (news://) for retrieving files from an Internet
newsgroup.
NTLM
(NT LanMan) The Windows NT Challenge/Response authentication
protocol. This protocol uses encryption to help protect the security of
passwords during transmission.
O
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ODBC
See Open Database Connectivity
OLE
A program-integration technology for transferring and sharing information
between programs. OLE lets an author invoke different editor components
to create a document that embeds or links to another document.
Open Database Connectivity (ODBC)
A standard method of sharing data between databases and programs. ODBC
drivers use standard Structured Query Language (SQL) to gain access to
external data.
optimized HTML
HTML code that doesn’t contain unnecessary formatting or tags. By using
FrontPage, you can optimize the HTML in your Web pages when you
publish them to a Web site.

P
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page banner
A section of a Web page containing a graphical element and text, such as
the page title. Page banners typically appear at the top of a Web page.
page template
A predesigned Web page that you can customize. Page templates might
include layout tables, styles, formatting, graphics, or other page elements.
page title
Descriptive text that identifies a page. A page title appears in the title bar of
the Web browser window when a page is open.
Page view
In FrontPage, the view for creating and designing Web pages.
parent Web site
In a hierarchical structure, the Web site that contains the active site.
parent-level page
In FrontPage, a page in a Web site that is part of the navigational structure
of the site and links to one or more pages on the child level of the site. See
also link bar, Web site structure.
password
The string of characters entered by a user to verify his or her identity to the
network. The system compares the code against a stored list of authorized
passwords and users. If the code is legitimate, the system allows the user
access at whatever security level has been approved for the owner of the
password. Ideally a password is a combination of text, numbers, and
punctuation or other characters that cannot be guessed at or easily cracked
by intruders.
path
The portion of a URL that identifies the folders containing a file. For
example, in the URL http://www.example.com/hello/world/top.htm, the
path is /hello/world/.
PC Paintbrush (PCX)
A graphics file format that compresses the graphic's data with RLE-type
compression, used by early versions of Windows Paintbrush. PCX-format
files are a type of bitmap graphic and they have a .pcx file name extension.
PCD
See Photo CD
PCX

See PC Paintbrush
Photo CD (PCD)
A graphics file format developed by Eastman Kodak Company. Photo CDformat files have a .pcd file name extension.
picture
See graphic
plug-in
A program that allows Web browsers to access and execute files that are
embedded in HTML documents and are in formats that browsers typically
would not recognize, such as many video and audio formats. For example,
the Windows Media Player plug-in allows Internet Explorer to play movies
in the browser window.
PNG
See Portable Network Graphics
Point-to-Point Protocol (PPP)
An Internet standard for transmitting data over serial links between
computers.
port
One of the network input/output channels of a computer running TCP/IP.
On the World Wide Web, the port usually refers to the port number a server
is running on. A single computer can have many Web servers running on it,
but only one server can be running on each port. The default port for Web
servers is 80.
Portable Network Graphics (PNG)
A file format for compressed bitmap graphics, similar to the GIF format.
PNG supports variable transparency of images (alpha channels) and control
of image brightness on different computers (gamma correction). PNGformat files have a .png file name extension.
PPP
See Point-to-Point Protocol
Preview view
In FrontPage, a view for viewing Web pages as they will appear in a Web
browser.
progressive JPEG
An enhancement to the JPEG graphics file format that gradually displays a
photo-realistic graphic in a Web browser, showing increasingly detailed
versions of the graphic until the entire file downloads. Although similar to
the interlaced GIF format, the progressive JPEG format retains high quality,
24-bit color and offers the same compression as standard JPEG format. See

also interlaced GIF.
protocol
A set of rules and standards that allow computers to communicate.
proxy server
A computer that acts as a gateway between a network protected by a
firewall and other networks. For example, a proxy server passes a request
for an Internet address from a Web browser in the protected network to an
outside server and then returns the results.
publish
The process of making a Web site available on the World Wide Web or an
intranet by copying its pages and files to a Web server that is connected to
the Internet or network.
Q
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Quick Tag Editor
In FrontPage, a window that allows you to insert, wrap, and edit HTML
tags.
Quick Tag Selector
In FrontPage, a toolbar in the document window that allows you to select
specific sets of HTML tags.
QuickTime
A multimedia technology that is built into the Apple Macintosh operating
system. Macintosh programs that support audio and video content use
QuickTime technology to play that content. A Microsoft Windows-based
computer can also play QuickTime files, if the QuickTime plug-in is
installed on that computer.
R
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raster graphics
Images created as a collection of small, independent dots, called pixels,
which are arranged in rows and columns. See also vector graphics.
RDBMS
See relational database management system
record

In a database, a group of related fields of information that are treated as a
single unit. Records are the logical equivalents of rows in a table. In
FrontPage, a group of records is referred to as a recordset.
referring domain
On the Internet and intranets, the address of a network location from which
site visitors follow a hyperlink to another Web site.
registered user
A Web site visitor whose name and password has been recorded within the
Web site.
relational database management system (RDBMS)
A database system that organizes data into related rows and columns as
specified by a relational model. Microsoft SQL Server and Oracle are
examples of relational database management systems.
relative URL
The Internet address of a Web page or other World Wide Web resource
relative to the Internet address of the active page. A relative URL gives the
path from the active page to the destination page or resource.
remote Web site
When publishing files from one location to another by using FrontPage, the
Web site on the destination server. See also local Web site.
Remote Web Site view
In FrontPage, a view for publishing folders and files in a Web site to a Web
server. You can also synchronize, or merge changes between, files in two or
more locations when you publish them.
Reports view
In FrontPage, a view for analyzing the contents of a Web site. For example,
you can calculate the total size of the files in your site, and identify slow or
outdated pages.
resample
The process of changing the pixel dimensions of a graphic after changing
its size. A graphic can be resampled down, which decreases the number of
pixels in it, or resampled up, which increases the number of pixels in the
graphic by matching the color values of the existing pixels.
S
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script

A type of computer code that sends a set of instructions to a program, such
as a Web browser. A script is run directly by a program that can interpret
the language in which the script is written. On the World Wide Web, scripts
are commonly used to customize or add interactivity to Web pages.
Secure Sockets Layer (SSL)
A standard, developed by Netscape Communications, for encrypting
information and transmitting it over the Internet more securely.
selector
In a cascading style sheet style definition (or style rule), the HTML element
linked to a particular set of style properties and values.
separator character
A character that indicates where you want new rows or columns to begin
when you convert text to a table.
server
On a network, a computer that provides access to files and other resources
that are also part of the network. On the World Wide Web, a computer that
hosts Web pages and responds to requests from Web browsers.
server-side image map
An image map that passes the coordinates of the mouse pointer to a CGI
handler routine on the server. Server-side image maps require the Web
server to compute the target URL of the hyperlink based on the mouse
pointer coordinates. See also image map.
SGML
See Standard Generalized Markup Language
shared border
In FrontPage, a region of a Web page that is common to one or more pages
in a Web site. A shared border may be a region at the top or bottom of a
page (similar to a page header or footer), at the left, or at the right. Use
shared borders to place the same content on multiple pages in one step,
rather than editing each page.
slow page
A Web page that requires an inordinate amount of time to open in a Web
browser.
Split view
In FrontPage, a view that combines Code and Design views by displaying
each view in a separate pane of the document window. One pane displays
the source code of the Web page and the other pane displays an
approximated WYSIWYG view of that page.
SQL

See Structured Query Language
SSL
See Secure Sockets Layer
staging Web site
A Web site that is maintained on a private file or Web server. Staging sites
allow authors and workgroups to change and review Web pages or files
before publishing those pages or files to the World Wide Web or a company
intranet. See also live Web site.
Standard Generalized Markup Language (SGML)
A language for organizing and tagging elements and data in a document.
SGML itself does not specify any particular formatting; rather, it specifies
the rules for tagging elements. Tags can then be interpreted to format
elements in different ways.
Structured Query Language (SQL)
A database query and programming language widely used for accessing,
querying, updating, and managing data in relational database systems. By
using SQL, you can retrieve data from a database, create databases and
database objects, add data, modify existing data, and perform other, more
complex functions. With SQL, you can also change the server
configuration, modify database or session settings, and control data and
access statements.
style
A set of formatting characteristics for text or other page elements. See also
cascading style sheet.
subsite
A named subdirectory of a Web site that is also a complete site.
synchronize
When publishing files by using FrontPage, the process of identifying
differences between two or more versions of a file and resolving those
differences by merging the content into a single version of the file.
T
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table
One or more columns and rows of cells that organize the layout of a page or
arrange data systematically.
tag

See HTML tag
Tagged Image File Format (TIFF)
A high-resolution, tag-based file format commonly used for the scanning,
storage, and interchange of gray-scale graphics. TIFF-format files have a
.tiff or .tif file name extension.
Targa (TGA)
A photorealistic, raster graphics file format developed by Truevision
Incorporated and designed for systems that have a Truevision display
adapter. TGA-format files have a .tga file name extension.
target frame
The name of a frame in which the target of a hyperlink is displayed.
Typically, a hyperlink from one frame on a frames page will supply as its
target frame another frame on the frames page. See also frame, frames page.
Tasks view
In FrontPage, a view that lists both the tasks required and the tasks you
choose to track when completing or maintaining a Web site.
TCP
See Transmission Control Protocol
template
A set of predesigned text formatting, graphics, and layout settings for a Web
page or site. After you create a page or site by using a template, you can
customize it. See also Dynamic Web Template.
TGA
See Targa
theme
In FrontPage, a set of color schemes, graphics, and other page elements that
you can apply to one or more pages in a Web site.
thread
In e-mail and Internet newsgroups conversations, a series of messages and
replies that are related to a specific subject.
thumbnail
A small representation of a picture on a Web page, usually containing a
hyperlink to a full-size version of the graphic.
TIFF
See Tagged Image File Format
top-level Web site
The uppermost folder in a hierarchy of Web site folders. A top-level Web
site can be hosted on a Web server, a virtual server network, or a local
computer hard disk. A top-level Web site is also called a root Web site. See

also subsite.
Transmission Control Protocol (TCP)
Internet networking software that controls the transmission of packets of
data over the Internet. Among its tasks, TCP checks for lost packets,
arranges the data from multiple packets into the correct order, and requests
that missing or damaged packets be sent again. Computers must run TCP to
communicate with Web servers.
TWAIN
Developed by a consortium of imaging hardware and software
manufacturers, TWAIN is a cross-platform interface for sharing graphics
between computers and TWAIN-compliant scanners, digital cameras, and
still-frame video capture boards.
U
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Uniform Resource Locator (URL)
See Internet address
UNIX
A multi-user, multitasking operating system that exists in various forms and
implementations, typically used on proprietary computer workstations.
Many Web servers run on UNIX systems.
V
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VB
See Visual Basic
VBA
See Visual Basic for Applications
VBScript
See Visual Basic Scripting Edition
vector graphics
Images generated from mathematical descriptions that determine the
position, length, and direction in which lines are drawn. Vector graphics are
collections of lines rather than patterns of individual dots or pixels. See also
raster graphics.
Vector Markup Language (VML)

An XML-based language for creating two-dimensional vector graphics in
an HTML or XML document. VML uses XML tags and cascading style
sheets to create and place graphics, such as circles and squares, in a
document, such as a Web page. These graphics can include color and can be
edited in several graphics programs.
virtual server
A collection of file and other hosting services that appears to be a separate
server, but is not associated with a specific server. Each virtual server has
its own domain name and IP address and appears as an individual Web site.
A Web server that supports virtual servers is called a multi-hosting Web
server.
visit
In Web site usage reports, a value that indicates that a site visitor has
accessed your Web site and viewed one or more files before following a
hyperlink to another site or closing the browser. See also hit.
visited hyperlink
See followed hyperlink
Visual Basic
An object-oriented programming language. Visual Basic was developed by
Microsoft for building Windows-based programs.
Visual Basic for Applications (VBA)
A subset of the Microsoft Visual Basic programming language. VBA is
used for programmatically accessing Windows programs and is supported
by several Microsoft Office programs, including FrontPage.
Visual Basic Scripting Edition (VBScript)
A scripting language that can be used to add functionality to a Web page or
a Web site, or to enhance the look of one. VBScript is optimized for Webrelated programming, and it is a subset of the Microsoft Visual Basic
programming language.
VML
See Vector Markup Language
W
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W3C
See World Wide Web Consortium
watermark

A graphic that appears on the background of a Web page. Unlike
background pictures, watermarks do not scroll with the other elements on a
Web page.
Web browser
A program that interprets HTML files, formats them into Web pages, and
displays them. You can use a Web browser to jump from one Web page to
another by following hyperlinks, to download files from the Internet to your
computer, and to play audio or video files that are embedded in a Web page.
Web Part
A modular unit of information that contains Web-based content and is the
building block of a Web Part Page. A Web Part is made up of several
component files that store the data and information necessary to render the
Web Part.
Web site
A set of associated Web pages, graphics, documents, multimedia, and other
related files that are stored in a shared directory on a Web server.
Web site structure
In FrontPage, the set of relationships between the pages in a Web site. See
also link bar, Navigation view.
Web-based Distributed Authoring and Versioning (WebDAV)
An application protocol related to HTTP 1.1 that allows authors, using
different computers, to publish and manage files on the World Wide Web.
WebDAV provides support for storing various types of information about a
file, such as the author of a file. By using this information, you can both
view and change information about the content of a file and its properties,
without overwriting changes that someone else might have made to that
file.
WebDAV
See Web-based Distributed Authoring and Versioning
well-formed XML document
An XML file in which there is only one root element and all the elements,
delimited by start- and end-tags, nest properly within each other and are
syntactically correct.
Windows Metafile Format (WMF)
A vector graphics file format for Windows-based computers. This format is
typically used when working with graphics in a word processing program,
such as Microsoft Word. WMF-format files have a .wmf file name
extension.
WMF

See Windows Metafile Format
World Wide Web
The graphical, multimedia portion of the Internet. The most common files
on the World Wide Web are HTML documents, which are also known as
Web pages. Each Web page, as well as other types of files, on the World
Wide Web has an address, called a Uniform Resource Locator (URL),
which uniquely identifies it.
World Wide Web Consortium (W3C)
A consortium of commercial and educational institutions that oversees
research and promotes standards in all areas related to the World Wide Web.
WYSIWYG
An acronym for "What You See Is What You Get." With a WYSIWYG
view, you can see how your Web page or document will appear in the final
product. You can also directly edit the text, graphics, and other elements in
a document while using a WISYWIG view.
X
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XML
See Extensible Markup Language
XSL
See Extensible Stylesheet Language
XSLT
See Extensible Stylesheet Language Transformation

Design your Web site
What's new home
Microsoft Office FrontPage 2003 has an improved design environment, new
layout and design tools, templates, and improved themes— all created to help
you realize your Web site vision without requiring any knowledge of HTML.

Improved work environment and larger design area
FrontPage 2003 centralizes all of the Web design features and gives you a
panoramic view of your entire Web site, making site and page design easier than
ever. The larger design area also reduces scrolling.

Layout tables and cells
You can create professional-looking Web page layouts by using layout tables and
cells. A layout table is the framework you create for your page. Layout cells are
regions within that framework that contain the content in a page, including text,
images, Web parts, and other elements. You can select from a list of predefined
layouts or you can draw your own— and you can try a variety of layouts before
you make your final decision.
The layout table tools are located in an easily accessible task pane. You can use
the tools to apply additional formatting, such as rounded corners, borders,
autostretch, and other visual effects.

Image Tracing
When you use image tracing, you create a mock-up image of a Web page in a
graphics program and then use it as a visual guide to create or trace the Web
page design in FrontPage. You can show or hide the image, set its opacity, and
change its position.

Dynamic Web Templates
You can quickly create HTML pages that share the same layout by attaching
Dynamic Web Templates to them. You can specify that certain regions within a
template are available for editing, while all of the other regions remain protected.
This means that you can allow others to add and edit content, yet preserve the
layout of the pages and the template itself.
You can use any number of Dynamic Web Templates in a Web site, and you can
attach a Dynamic Web Template to as many pages as you like. You can also save
Dynamic Web Template (.dwt) files to any location. If you choose to detach a
Dynamic Web Template from one or more pages in a site, you do not remove the
content from those pages. You remove only the formatting provided by the
template.

Page rulers and layout grid
Precision design and placement is a snap with helpful positioning guides, such as
page rulers and the background layout grid. You can customize the rulers or the
grid by choosing a unit of measurement, line styles and colors, and spacing
options.

Design-time layers
In FrontPage 2003, layers can contain HTML elements, such as text and
graphics. In the Layers task pane, you can view an itemized list of all the layers
on your Web page. You can overlap, nest, and show or hide layers on a page.
You can also animate layers by using the Behaviors task pane, which enables
you to add Dynamic HTML (DHTML) script to any element on a Web page.

Improved themes
FrontPage 2003 uses cascading style sheets rather than HTML to apply themes,
so your files are smaller, more transparent, and easier to control and modify.
Additionally, pages with HTML themes applied in previous versions retain their
settings in FrontPage 2003.
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Develop your Web site
What's new home
Microsoft Office FrontPage 2003 has an improved authoring environment, new
graphic features, powerful coding tools to help you apply and increase your
knowledge of various coding languages, and tools to help you create interactive
scripts. In addition, FrontPage 2003 generates efficient and clean HTML and
gives you more control over the code.
Web page views
You can work with your Web pages in any of the following Page views:
Design view Design and edit Web pages in Design view. This view provides
an approximated WYSIWIG authoring experience as you create your Web pages
by using the design tools.
Code view View, write, and edit the HTML tags yourself. With the optimized
code features in FrontPage 2003, you can create clean HTML, and it is easier for
you to remove any code that you do not want.
Split view Review and edit Web page content in a split-screen format that
offers you simultaneous access to both the Code and Design views.
Preview view Approximate how the page will look in the Web browser
without having to save your page. Use this view to check changes you make as
you create your Web page.
Graphics tools

Improved graphic support
Working with graphics from other programs is easier than ever. New interfaces
clearly explain the default behaviors when you import images into your Web site
and what behavior to expect while you edit those images. This gives you more
control over how images are displayed and saved.

Multiple-editor configuration
Choose which editor to use for different types of content. For example, if you
have a number of GIF format files, some of which are photos and some of which
are diagrams, you can edit the photos in Adobe PhotoShop and work with the
diagrams in Microsoft Office Visio 2003.

Macromedia Flash support
To enhance and update your FrontPage Web site, you can now add Macromedia
Flash content, including movies, repetitive audio-enhanced animations, and
previously recorded presentations or courses. You can set options for automatic
playback, such as playing a short animation one time when the site visitor first
loads the page or looping the content to play continuously.
Scripting and coding tools

Behaviors
Behaviors are scripting options that enable you to quickly add interactivity or
increased functionality to text or other elements of your Web page. For example,
you can add a behavior to an image so that it displays differently when a site
visitor moves the pointer over it. You can also view and edit the scripts
associated with the current page by viewing a list in the Behaviors task pane.

Interactive Buttons
You can add professional-looking buttons to your Web page by selecting them
from a list. After you select a button, add button text, choose the font and button
color, define a link, and set the image and text settings for original, hover, and
pressed states.

Quick Tag Tools
Use the Quick Tag Selector to quickly select any tag in your Web page. Use the
Quick Tag Editor to insert, wrap, and edit HTML tags.
Professional coding tools

IntelliSense
FrontPage 2003 now provides IntelliSense technology in Code view to reduce
errors in code. IntelliSense includes statement completion and shows the
parameters available for the code you're writing, just as you would see in
Microsoft Visual Studio. IntelliSense is available for HTML, Extensible
Stylesheet Language (XSL), ECMAScript as defined by the specification of the
European Computer Manufacturers Association— such as JScript or JavaScript
— Microsoft Visual Basic Scripting Edition (VBScript), and ASP.NET.

Typing aids
FrontPage 2003 offers a number of helpful tools to speed up the code-writing
process, including word wrap, line numbers, automatic indentation, tag
completion, bookmarks, and advanced code selection.

Code snippets
In FrontPage, code snippets are one or more lines of HTML or other code that
you can save and use again. You can store blocks of code and insert them in
pages from a library of code snippets. Code snippets can contain anything you
can insert in Code view— HTML, CSS, and so forth.

ASP.NET controls
ASP.NET is a set of technologies in the Microsoft .NET Framework for
developing Web programs and XML Web services. With FrontPage 2003, you
can now preview, reposition, and resize ASP.NET controls. IntelliSense support
for scripting helps you to hook up, tailor, or even create new ASP.NET intrinsic
controls.
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Develop a data-driven Web site
What's new home
Microsoft Office FrontPage 2003 extends the power of your Web site to connect
with people and information in new ways. Use Microsoft Windows Server 2003
with Microsoft Windows SharePoint Services to connect to, edit, and present
live data from a variety of data sources— including Windows SharePoint
Services data, XML, Web services, or OLE DB data sources— to build rich,
interactive data-driven Web sites in a WYSIWIG editor.
Data sources

Data Source catalog
FrontPage 2003 lets you easily insert data views into your Web page. The
catalog contains data sources that are already part of your Web site— such as
lists in Web sites based on Windows SharePoint Services and any XML files in
the Web site— and it allows you to configure any other data sources that you
want to work with in WYSIWYG format. Supported data sources include:
Windows SharePoint Services data
XML files
Web services or URLs that return XML
OLE DB data sources

Data Source Details view
The Data Source Details view in FrontPage 2003 allows you to see the data
structure of a data source and even walk through individual records. If you are
unfamiliar with the data source, you can see its structure and contents before
inserting a view into a page.
Web Parts

Web Part pages and zones
With the Web Parts task pane, you can add one or more Web Parts to a page.
When you connect Web Parts, changes to data or formatting in one Web Part are
reflected in the others. This allows you to create sophisticated master detail
views of your data, where the site visitor can select categories from one Web
Part and see the details for that category in another. You can also define Web
Part zones that site visitors can add Web Parts to by using a Web browser.

Data View Web Part
You can use the Data View Web Part to author data views on live data, directly
in FrontPage 2003 Design view. When you insert a data view, you are actually
adding a Data View Web Part to your page. This Web Part is transparent in both
Design and Code views and looks just like regular FrontPage content, but you
can manipulate the data in a new, WYSIWIG way. You can format the data by
using the standard formatting tools. This formatting is automatically applied to
all of the data points at the same level of the XML tree (or in that column of the
database). No special controls are required to format the data. You simply select
the text and apply formatting just as you would format regular HTML text.
When you format your data, FrontPage authors an Extensible Stylesheet
Language Transformation (XSLT) to apply that formatting to your page. The
XSLT is presented directly inline in the HTML file and can be edited in the Code
or Split views in FrontPage 2003.

Customized Data Views
In FrontPage 2003, you can quickly change the overall look of data— either by
manually formatting the data or by applying a prebuilt Data View style.
Applying a style preserves any applicable manual formatting you have already
done, and you can apply additional manual formatting after you specify the style.
You can also customize the Data View to suit your needs.
Web packages
FrontPage helps you to package Web solutions and distribute and share them
with others. You can use the Web Packages template to package a portion of
your Web site based on Microsoft Windows SharePoint Services into a module
that others can add to their sites. For example, you can package a service
solution that is specific to a certain type of business. You can then convert that
functionality into a convenient single file format (a cabinet file with an .fwp file
name extension).
When you export or import Web packages from Web sites based on Microsoft
Windows SharePoint Services, FrontPage 2003 makes sure that all dependent
files are included, so the deployed package works seamlessly on the new Web
site.
XML support
You can use Extensible Markup Language (XML) to complement, rather than
replace, your use of HTML. You can view or edit files, apply standard
formatting to the structure of code in XML files, view the XML structure, and
create custom displays of XML data on Web pages. For example, you can use
FrontPage to create a Web page that displays data from an XML file, and then
you can apply filtering, sorting, and conditional formatting to display the data
the way you want.

Publish your Web site
What's new home

Remote Web site view
The new Remote Web Site view in Microsoft Office FrontPage 2003 helps you
publish entire Web sites and individual files and folders to any location— an
extended Web server, a Web server that supports the File Transfer Protocol
(FTP) or Web-based Distributed Authoring and Versioning (WebDAV), or a
location in your file system.
Remote Web Site view displays the files in both the local Web site and the
remote Web site. Icons and descriptive text indicate the status of your files and
folders, and the synchronization feature helps ensure that you don't overwrite
any files or folders accidentally.

Connecting to remote Web sites
The new remote Web site dialog box allows you to specify connection settings,
and it helps you to manage connection types and protocols— including Secure
Sockets Layer (SSL) or passive FTP.

Publish to FTP and WebDAV servers
Work with others by using the new site-building tools found in FrontPage 2003.
File locking is provided on WebDAV servers using WebDAV file locking. On
FTP servers, file locking is supported through the use of .lck files. These files are
fully compatible with those used by Macromedia Dreamweaver, so you can work
with Dreamweaver users on an FTP server without accidentally overwriting each
other's changes.
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Maintain your Web site
What's new home
Microsoft Office FrontPage 2003 offers new compatibility and HTML tools to
help you maintain your site.
Compatibility tools

Browser and resolution reconciliation
Target specific browsers or resolutions, or see how your site will look in various
combinations of browsers and resolutions— including simultaneous previewing
of multiple browsers.

Accessibility checking
Use the Accessibility Checker to select the guidelines (including U.S.
government Section 508 guidelines) you want to follow in your Web site.
Suggestions to improve accessibility are shown in a list, and you can jump back
and forth between that list and your site to address the issues.
HTML tools

Smart find and replace
FrontPage 2003 provides basic find and replace functionality, as well as a rules
engine for HTML searches. You can quickly search and replace attributes or tags
across your entire site or on specific pages. You can save your queries for later
use and you can share them with other authors. This allows you to update your
Web site quickly with great accuracy.

Edit text files
FrontPage 2003 allows you to edit file types other than HTML directly within
FrontPage. You can open and edit text files, files that contain ECMAScript as
defined by the specification of the European Computer Manufacturers
Association— such as JScript or JavaScript— XML files, and XSLTs. Text files
are formatted as plain text, while script files, XML files, and XSLT files are
displayed with code formatting applied. In addition, when you edit XML and
XSLT files, the XML View toolbar provides additional options for formatting
your code.

Optimize HTML
You can generate clean HTML code in files and folders on either your local Web
site or when you publish pages to your remote Web site. This means that you can
reduce the size of a page by removing unnecessary formatting and tags. Web
designers use white space to make HTML more attractive to view, but it is not
required for the page to function correctly. You can remove empty tags, white
space, redundant tags, unused and empty style definitions, and even certain tags
that you specify.

More new features in Office
What's new home

New look for Office
Microsoft Office 2003 has a new look that's open and energetic! New and
improved task panes include Getting Started, New Page or Web, Help, and
Search Results.

Microsoft Office Online
Microsoft Office Online is better integrated in all Microsoft Office programs so
that you can take full advantage of what the site has to offer while you work.
You can visit Microsoft Office Online directly from within your Web browser, or
you can use the links provided in various Microsoft Office FrontPage 2003 task
panes and menus to access articles, tips, clip art, templates, online training,
downloads, and services that enhance how you work with Office programs. The
site is updated regularly with new content based on direct feedback and specific
requests from you and others who use Office.

Improving quality for the customer
Microsoft strives to improve the quality, reliability, and performance of
Microsoft software and services. The Customer Experience Improvement
Program allows Microsoft to collect information about your hardware
configuration and how you use Microsoft Office programs and services in order
to identify trends and usage patterns. Participation is optional, and data
collection is completely anonymous. Additionally, error reporting and error
messages have been improved so that you are provided with the easiest approach
to reporting errors and the most helpful information about alerts at the time you
encounter a problem. Finally, with an Internet connection, you can give
Microsoft feedback about an Office program, Help content, or Microsoft Office
Online content. Microsoft is continually adding and improving content based on
your feedback.

