Welcome to

Kvaser TRX
a light weight IDE for developing t programs for
Kvaser devices
This help file describes the Kvaser TRX light weight IDE, which you can
use to develop t programs for supported Kvaser devices.
For information about writing t programs, please see the Kvaser
t programming language manual, which can be found under the Help
menu in Kvaser TRX or on Kvaser.com!

Getting started with t program development in TRX

When you start TRX the first time, your editor will have a single tab
labeled <New>. As a first program, try entering:
on start {
printf("Hello World!\n");
}

This a very basic program that reacts on an on start event and prints
Hello World! in the Device Output. It is the actual device that sends the
"Hello World!" to the computer where TRX reads.
Now compile the t program by going to Run->Compile in the menu bar, or
by pressing F9. To be able to compile you first have to save the
t program. TRX will prompt you for this, it will also prompt you to save a
project file. Pick suitable names and save. Note that the project overview
panel to the right of the editor is automatically updated when you
compile.
Next, connect a t program capable Kvaser device. You can see that TRX
can use your device if the combobox just under the menu bar has the
name of your Kvaser device listed.

To test the t program, just go to Run->Download, this will download the
t program to the device. Next step will be to actually run the program.
Run->Run will start he application, and hopefully you will see the printf
printout in the Device Output window Device Output panel below the
editor. (NB: If you don't see such a panel it may have been hidden by
accident. If so, then go to Window->Toggle Lower Pane or press F7 to
toggle its visibility!)
If everything worked, you are now ready to develop more advanced
t programs! Good luck!
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Program overview

In this chapter you will find an overview of the TRX user interface and
features.

Contents:
The menu bar
Program preferences
Project options
.txe file viewer
Envvar viewer
The toolbar
The code editor
The project overview
The output panel

The menu bar

The menu bar at the top of the program lets you access the following
features:
File: In addition to basic file operations (create new, open, save, and
close t program files), the TRX Preferences are accessed through
this menu.
Search: Use this menu for Find and Find Next, or use the short-cuts
Ctrl+F and F3 respectively.
Project: This menu lets you create, open and save projects, as well
as inspecting the compiled .txe file, and manage Project Options.
Run: In addition to running and stopping the program, this menu is
used to Compile the t program, to Download it to the device, and for
telling the device to Go Online and Go Offline.
Window: Use this menu to toggle the visiblity of the output pane
below the editor and of the Environment Variables window, or use
the short-cuts F8 and F9 respectively.
Help: In addition to this help, this menu gives you easy access to the
Kvaser t Language Manual, the Kvaser CANlib Help, and to the
About window where you will find the TRX version number and a link
to the Kvaser website, should you need to contact support.
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Program preferences

This window is used to set the following program prefences:
Environment settings - set up the paths to:
Compiler (scc.exe)
Database Editor (dbe.exe)
Kvaser CANlib SDK Help (canlib.chm)
File associations - decide whether these files should be associated
with TRX:
Kvaser t Projects (.tprj)
Kvaser t Programs (.t)
Compiled t Programs (.txe)
IDE settings - decide if the IDE should:
use autocompletion of commands in the editor
display error messages from running tprograms in Device output
display debug messages from connected device in Device
output (requires firmware with debugging enabled)

Related topics
Getting started
Program overview
Project options
Environment variables/Envvars

Keyboard short-cuts

Project options

This window is used to set different options for the project compiler.
The following options are available:
Verbose Output: When set, the compiler will print more information
to the build log.
Include Source Code: When set, the compiler will include the
source code of the t program in the compiled .txe-file. The included
source can then be inspected from the View .txe window, accessible
from the Project menu.
Encrypt program: When set, compiler will encrypt the program
using an asymmetric key. If no Custom Key is provided, the compiler
will generate one at compile time.
Default Slot: This list lets you select which of the four available slots
to use as default when downloading the t program to a device.
Comment: This text field lets you enter an optional description of the
project.

Related topics
Getting started
Program overview
Inspecting the .txe-file
Preferences

Keyboard short-cuts

Envvar viewer

This window is used for inspecting "environment variables" or Envvars,
which in the context of t programs are special variables that are shared
between the programs running on a device. By using the CANlib script
API, the envvars can also be accessed from a computer connected to a
device running a t program.
To start tracking an envvar in the Envvar viewer, add it to the watch list by
typing its name in the box at the top and press "Add Envvar". Press
"Refresh" to update the values and states of the tracked envvars. If you
check the "Auto Refresh" box TRX will keep the tracked envvars up to
date automatically refreshing at regular intervals. If you select an envvar
from the list, a field will appear at the bottom of the window where you
can edit the value of that envvar, or remove it from the watch list.
For more information about how to use envvars, please refer to the
Kvaser t Language Manual, available in the Help menu.
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.txe file viewer

This window is used to view information read from the compiled .txe file.
Under the Details tab information such as File Size in bytes, the
Compilation Date, the Compiler Version used, and the descriptive
Comment added under Project Options. If the project was compiled with
source code included, the code can be viewed under the Source tab. If
the program was compiled with encryption enabled, the view will be filled
with giberish until the user has pressed the button labeled Decryption...
and entered the correct key. See Project Options for further details.

Related topics
Getting started
Program overview
Preferences
Project options
Keyboard short-cuts

The toolbar

The toolbar allows quick access to some of the most commonly used
features:

These buttons are used to create a new t program file, and to save the or
close the t program file in the active tab. Alternatively you can use the
short-cuts Ctrl + N and Ctrl + S to create a new t program file and to save
the file in the active tab.

These buttons are used to undo and redo actions in the editor
Alternatively you can use the short-cuts Ctrl + Z and Shift + Ctrl + Z.

This list shows the connected devices and associated channels. Use it to
select a device and a default channel for the t program. Press the rescan
button to reinitialize Canlib and scan for new/removed devices.

Press this button to Compile, Go Online, Download and Run the
t program on the selected Kvaser device with a single click.
Press again to Stop execution.
This button shows the on-/offline status of the selected device, and can
be clicked to switch between online and offline.

Related topics
The menu bar
Keyboard short-cuts

The code editor

If you have many t programs open at once, each is given its own tab.
Select which t program to work on by clicking the corresponding tab. For
convenience, the editor offers syntax highlighting and displays rownumbers in the left hand margin. To make navigating long programs
easier, code blocks can be folded by pressing the small '-' in the margin.
Folded block instead have a '+' in the margin; pressing this unfolds the
block. If the editor still feels cramped after you have folded away the code
blocks you don't want to focus on right now, try hiding the Device Output
by going to Window->Toggle Lower Pane or pressing F7 to toggle its
visibility!

Related topics
The menu bar
The toolbar
The project overview
The output panel
Keyboard short-cuts

The project overview

The project overview panel is situated to the right of the editor. This panel
provides a schematic overview of the project file tree. Everytime you the
project, the .t files are parsed, and any included files are added to file
tree.
Right clicking in the panel brings up a menu which lets you Add or
Remove Databases and access the Project Options. If you right click on
a file in the tree, you are also given the option to Open the file for editing.
Program files (*.t) are opened in the TRX editor, whereas databases
*.dbc are opened in the external Kvaser Database Editor, provided that
the path to dbe.exe has been set up in the Preferences.

Related topics
Project options
The code editor

Lower panel
The lower panel is used to display device output, build messages, and for
communicating with a running t program by sending key events. If the
editor feels cramped, try hiding the lower panel by going to Window>Toggle Lower Pane or by pressing F7 to toggle its visibility!

Device Output

This tab is used for listening to the output from the running t programs.
Each output is printed on a single line, and has an associated Number
(#), Slot and Time. The slot is either System or the number of the slot
occupied by the t program that issued the printf command.
The buttons above the output view have the following functionality:

Use this button to Subscribe and Unsubscribe to Error Messages,
execution errors reported by the running t program. Subscription can also
be toggled under Preferences.
Use these buttons to toggle Autoscroll and Clear Device Output. When
Autoscroll is on, TRX will always scroll down to the latest message.
The devices can run up to four programs concurrently, each in a different
slot. This drop-down menu lets you Select which of the active slots to

listen to, making the Device Output less cluttered. Please note that each
TRX session can only run and control one t program at a time. To run
more than one t program, each has to be started separately, either from
their own TRX session, from the command line, or auto-started on the
device.

Build Log

This tab shows the output from the compiler, including the full compiler
command. Compile time errors are highlighted in red. On clicking an error
message the editor will jump to the line of code where the problem was
detected. For detailed output, activate Verbose Output in the Project
Compiler Options.

Sending events

The t programs can be made to react to Key Events. Send button can be
used to send single characters entered in the input box to the running
t program, that will be interpreted as Key Events. Ticking the checkbox to
the left of the input box tells TRX to forward all key presses to the
t program, without the need for pressing Send. This is useful for
interactively controlling the flow of the t programs.

Related topics
Project Compiler Options
The menu bar
The toolbar
The editor

List of keyboard short-cuts
File operations:
Ctrl + N: New t program
Ctrl + O: Open t program
Ctrl + S: Save t program
Editing:
Ctrl + Z: Undo edit
Shift + Ctrl + Z: Redo edit
Ctrl + X: Cut text
Ctrl + C: Copy text
Ctrl + V: Paste text
Ctrl + A: Select all text in editor
Ctrl + F: Find string in editor
F3: Find next instance of search string
F9: Compile project
Other:
Ctrl + P: Open Program Preferences
F1: Open this help
F7: Toggle visibility of lower pane
F8: Toggle visibility of Envvar viewer
Ctrl + Q: Quit TRX
Related topics
The menu bar
The toolbar

Further resources
The following documents are accessible from the Help menu in TRX:
The Kvaser t Language Manual: This manual contains detailed
information about the t programming language.
The Kvaser CANlib SDK Help: This help contains details about the
Kvaser CANlib functionality and API.
For further information and support, see the Kvaser website:
www.kvaser.com
There you will find the latest versions of our drivers and SDK, as well as
information about Kvaser products, developer blogs, support and
documentation.
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