Introducing FTP
Hummingbird FTP lets you connect to a remote FTP server and transfer
files between computers. FTP is supported only under TCP/IP transports.
You cannot use this application with DECnet or IPX/SPX.
A server implementation of the FTP protocol must be running on the
remote computer to permit FTP communication. The remote computer is
the FTP server (host); the PC running the Hummingbird FTP application
is the FTP client.
FTP can transfer files in two different formats:
ASCII (for text files)
Binary (for image and executable files)
You can transfer files in three ways:
choose commands from the FTP menus
type commands in the FTP command line window
drag and drop the files from the remote FTP server window to the
local FTP client window
The Hummingbird FTP application also lets you:
Save any configuration settings you make from the FTP menus to an
FTP settings file. You can then connect to a host using the settings
file.
Connect to multiple FTP servers during a single FTP session.
Create automated Hummingbird Basic scripts using FTP API scripting
commands in the Hummingbird Basic scripting tool. For example, you
can create a Hummingbird Basic script that connects to an FTP
server, transfers designated files, then disconnects from the FTP
server.
Related Topics
Creating a Settings File
Using the Hummingbird Basic Scripting Tool
Creating an OLE Script

Connecting Using the FTP Dialog Box
You can open a single connection or multiple connections to perform
server-to-server transfers.
To connect using the FTP dialog box:
1. On the Connection menu, click Open.
2. Specify the FTP server to which you want to connect, for example,
ftp.hcl.com.

By default, FTP displays the name of the last server to which you
connected in the Server Name box. To specify another FTP server,
type its name or IP address in the Server Name box, or select a
server from the drop-down list box.
See your system administrator if you do not know the name of the
FTP server.
3. In the appropriate boxes, type your user name and password for
the FTP server you specified.
Select the Anonymous FTP check box if the FTP server is a valid
anonymous site on the Internet. The word Anonymous
automatically appears in the User Name box. Type your Internet email address in the Password box. If you have already supplied
FTP with your e-mail address, it automatically appears in the
Password box.
Note:

You cannot use Anonymous FTP if you use the Secure Shell option. The
Secure Shell option appears if you have the Hummingbird Connectivity
Security Pack installed.

4. Type your account in the Account box if the FTP server requires
one.
5. To specify your initial directory on the remote system, type the
path in the Initial Directory box.

The form your directory takes depends upon the remote system.
For example, a UNIX system uses the form /usr/mydir; a PC
system uses the form \usr\mydir. You can also specify a
directory name in the form mydir. If the path and/or directory you
specify does not exist or is inaccessible, the initial directory does
not change.
6. In the Default Sys. list box, click the type of FTP server you
specified in Step 2 above. You can set the default system to UNIX,
VMS, DOS, OS/2, NT, MVS, VM/CMS, VM/VPS, VOS, or Other to
perform this step if your FTP server identifies its system type.
7. Select the Force Default System Type check box to set the system
type if the server does not identify its system type or if it is not
supported by FTP.
Note:

Problems can occur if the server identifies itself as a particular system type but
does not exactly follow the conventions of that system (for instance, because
of differing international date and time formats). In this case, you can force the
system type to another type, such as Other.

8. If you want to use a secure connection, select the Secure Shell
check box. For more information, see the topic “Using FTP with
Connectivity Secure Shell” in this help.
Note:

The Secure Shell option is available only if you have the Hummingbird
Connectivity Security Pack installed. You cannot use Anonymous FTP if you
use the Secure Shell option.

9. In the command box, type the name of the command file, or click
Browse to search for it.
10. Click Open.
Related Topics
Transferring Files Among Multiple Servers
Connection Settings Dialog Box
Connecting Using the Command Line Window
Connecting Using Secure Shell

Creating Secure Shell-Enabled FTP Profiles

Connecting Using the Command Line Window
You can open a connection to an FTP server using the command line
window.
To connect using the command line window:
1. On the Window menu, click New Command Line Window.
2. Type Open and specify the name or IP address of the FTP server to
which you want to connect, for example: Open
ftp.hummingbird.com.
3. After connecting successfully, specify your user name and password
when prompted.
Note:

If you have trouble opening a connection, verify that the server name or IP address
is correct. If you still cannot connect, verify that the FTP server machine is up and
running.

Related Topics
Connecting Using the FTP Dialog Box
Connection Settings Dialog Box

Starting FTP from the Command Line Window
You can use the FTP command line window to automate the process of
connecting to FTP servers by including your current connection
selections in the settings file.
To start FTP from the command line window, type the following command
in the Windows Run dialog box:

home\accessories\ftp settings.fs
where:
home is the directory in which you installed your Hummingbird
Product. The default directory is C:\program
files\hummingbird\connectivity\version, whereversion
is the version number of your Hummingbird product.
settings.fs is the FTP settings file you want to use

Creating a Customized FTP Shortcut
You can use the command line window to set up a custom FTP shortcut
that automatically starts FTP, connects to the FTP server(s), and loads a
specific FTP settings file.
To create a customized FTP shortcut:
1. In Windows Explorer, click the program folder to which you want to
create a shortcut.
2. On the File menu, select New and click Shortcut.
3. In the Command line box, type home\accessories\ftp
settings.fs:

where:
home is the directory in which you installed your Hummingbird
Product. The default directory is C:\program
files\hummingbird\connectivity\version,
whereversion is the version number of your Hummingbird
product.
settings.fs is the FTP settings file you want to use.
4. Click Next.
5. Type the name of your shortcut, then click Finish.
Related Topics
Creating a Settings File

Disconnecting From an FTP Server (Host)
Click Close on the Connection menu to disconnect from an FTP server.

FTP command line window instructions
Use the close command to disconnect from an FTP server. The close
command does not terminate the FTP application. When you finish using
the FTP application, type quit or exit to disconnect from any FTP
server(s) and close FTP.

Troubleshooting FTP Connections
If you are running FTP and have difficulty opening a connection, try the
following:
Verify that the server name or address is correct. If you specified the
server name and it did not work, try specifying its IP address instead.
Addresses are specified in dot notation as follows:
value.value.value.value

If this format works and specifying a server name does not, the
server name is not being translated to the correct address.
See your system administrator to verify that the remote host is
responding and running a server implementation of FTP.
You can use the FTP command line window for troubleshooting
purposes. When you are using the FTP command line window, the
command that you use depends upon whether you are performing
a local operation (on the PC) or an FTP server operation.
Note:

For troubleshooting purposes, the FTP protocol logs commands and replies to
a trace file if you select the Trace FTP Protocol Commands and Replies check
box on the Connection tab of the Preferences dialog box. When a trace file is
created, the default file name is server.flg, where server is the name of
your particular server. You can create your own log file by typing its name in
the Override Default Trace File box.

Related Topic
Preferences Dialog Box (Connection Tab)

Connecting Using Secure Shell
If you purchase and install Connectivity Secure Shell, the Hummingbird
SSH-2 client, you gain the option of securing your FTP session with
Secure Shell.
Securing an FTP session requires that you create an FTP session profile
in FTP that specifies Secure Shell as the security method. In order for
Connectivity Secure Shell to establish a Secure Shell tunnel to the target
host of the FTP session, it also requires you to specify certain connection
parameters including:
host address
user name
authentication method
authentication method parameters such as a password or key
When you configure an FTP profile to use Secure Shell, all parameters
used to establish the Secure Shell tunnel are stored in the FTP profile.

Using Tunnel Profiles to Secure FTP Sessions
Instead of specifying the connection parameters explicitly when you
create a Secure Shell-enabled FTP session profile, you also have the
option of specifying these parameters by associating a tunnel profile with
your FTP profile. Tunnel profiles contain all the connection parameters
needed to establish the Secure Shell tunnel to the remote host.
You can also do a combination of both. That is, in the FTP profile, you
can specify a tunnel profile from which to load the necessary parameters.
Then, in the same FTP profile, you can specify and save parameters that
override some of those loaded from the specified tunnel profile.
When you launch a Secure Shell-enabled FTP session, Hummingbird
FTP uses a combination of the original parameters in the tunnel profile
and the Secure Shell parameter overrides stored in the FTP session
profile.
Related Topics
Creating Secure Shell-Enabled FTP Profiles
Connecting Using the FTP Dialog Box

Creating Secure Shell-Enabled FTP Profiles
FTP profiles are saved session configurations. Typically, they contain the
settings to connect to an FTP server on a remote machine to and from
which you want to transfer files. In the case of Secure Shell-enabled FTP
profiles, however, you must provide the parameters to establish a Secure
Shell tunnel to the target host.
To create a Secure Shell-enabled FTP profile:
1. Using the Start menu, start Classic FTP.
2. In the Open Connection dialog box, type the server address, user
name and password.
3. Select Secure Shell.

At this point, you have provided the minimum requirements to
establish a Secure Shell tunnel to the remote host. This
configuration supports password authentication only. If you want to
configure different authentication methods, or want to use a tunnel
profile, proceed with the next step. Otherwise, click Open.
4. Click Configure. The Secure Shell Configuration dialog box opens.
5. To specify a tunnel profile, do one of the following. Otherwise,
proceed to the next step.
Type the name of the tunnel profile (profilename.csp) into
the CSS Tunnel Profile box.
Click Browse to access the Connectivity Secure Shell Open
Tunnel dialog box which lets you select from a list of your tunnel
profiles. Then click Open.
Click Create to access the Connectivity Secure Shell Add New
Tunnel dialog box, which lets you create a new tunnel profile
with default settings.
Note:

Every time you select a new tunnel profile, change the name of a tunnel
profile, or click Reload, all override values you have specified in the FTP
profile are reset.

6. To configure the authentication method, click Config and press F1

help. Otherwise proceed to the next step.
Note:

If you specified a tunnel profile, any changes you make to the Authentication
Methods here will be saved in the FTP profile as overrides of the
authentication parameters specified in the tunnel profile. The tunnel profile will
not be altered.

7. In the Secure Shell Configuration dialog box, click OK.
8. The Open Connection dialog box now displays the parameters as
you configured them in the previous two steps.
Note:

Some parameters may have no specified value depending on your previous
configurations.

You now have the option of modifying any connection parameter.
Note:

If you specified a tunnel profile, any changes you make to the connection
parameters will be saved in the FTP profile as overrides of the equivalent
parameters specified in the tunnel profile. The tunnel profile will not be altered.

9. Click OK. The FTP profile is saved. You can now use it to launch a
secure FTP session.
Related Topics
Connecting Using Secure Shell
Connecting Using the FTP Dialog Box

Transferring Files Using the Get Command (File
Menu)
The Get command on the File menu lets you copy files from the FTP
server to your PC.
To transfer files using the Get command:
1. In the FTP server directory window, select the file(s) that you want to
copy to your PC.
2. On the Options menu, select the file-transfer type. Select ASCII
Transfer for text files, Binary Transfer for image files, or Auto to have
FTP detect the file-transfer type.
3. On the File menu, click Get.
4. In the To box, type the destination. If the directory, file name, and path
contain spaces, put quotation marks around them.
5. Click OK.
If you do not specify a name for the local copy, or if you are copying
multiple files, FTP uses the file names as they appear on the FTP server.
If you do not specify a path, FTP uses the current directory on your PC.
Note:

You can also use the standard Windows Explorer drag and drop feature to transfer files.

Related Topics
Transferring Files Using the Put Command (File Menu)
Working with Multiple Files

Transferring Files Using the Put Command (File
Menu)
You can transfer files from your PC to the FTP server (host) by using the
Put command on the File menu.
To transfer files using the Put command:
1. Open the PC directory window by selecting New Client Window on
the Window menu.
2. In the PC directory window, select the file(s) that you want to copy to
the FTP server.
3. On the Options menu, select the file-transfer type. Select Binary
Transfer for image files, ASCII Transfer for text files, or Auto to have
FTP detect the file-transfer type.
4. On the File menu, click Put.
5. In the To box, type the destination.
6. Click OK.
If you do not specify a name for the FTP server copy, or if you are
copying multiple files, FTP uses the source file names. If you do not
specify a path for the FTP server copy, FTP uses the current directory.
Note:

You can also use the standard Windows Explorer drag-and-drop feature to transfer files.

Related Topics
Transferring Files Using the Get Command (File Menu)
Working with Multiple Files

Moving Files
Click Rename on the File menu to move files.

FTP command line window instructions
You can move files by renaming them or by changing the path
specification. Use the ren command to move a file between directories
on the FTP server; use the lren command to move a file between
directories on your PC. You can also use the get, put, mget, and mput
commands.
Related Topics
Renaming Files

Working with Multiple Files
You can transfer multiple files using the standard Windows conventions
for selecting and moving multiple files.

FTP command line window instructions
You can perform certain operations with more than one file at a time by
using wildcard characters in the file specification. Use the standard DOS
wildcard characters ? (question mark) and * (asterisk) for local file
specifications; use the wildcard characters of the host computer for
remote file specifications. The commands that let you work with multiple
files are:
ldel

mput

mget

mrecv

mhosttohost

Transferring Files Among Multiple Servers
You can open multiple connections to servers and transfer files.
To transfer files between multiple servers:
1. Open any additional connections.
2. Select the files you want to transfer.
3. On the Options menu, select the file-transfer type. Select Binary
Transfer for image files, ASCII Transfer for text files, or Auto to have
FTP detect the file-transfer type.
4. On the File menu, click Server to Server Transfer.
5. From the Destination Connection drop-down list box, select a
destination connection.
6. In the From box, type the source location of the file.
7. In the To box, type the destination of the file.
8. Click OK.
Related Topics
Connecting Using the FTP Dialog Box
Connecting Using the Command Line Window

Setting the Type of File to be Transferred
FTP transfers files in one of two formats: ASCII (for text files) or Binary
(to transfer an exact copy of a binary file). By default, the transfer type is
set to Auto. Auto attempts to detect the type of file you are transferring.
To set the file-transfer type, select the appropriate transfer format (ASCII,
Binary, Auto) on the Options menu.

FTP command line window instructions
To specify the desired file-transfer type:
for ascii format, type ascii or type a
for binary format, type binary or type i
for auto format, type auto
Related Topics
Transferring Files Using the Get Command (File Menu)
Transferring Files Using the Put Command (File Menu)
File Menu

Using FTP Prompt Commands
FTP prompt commands are commands that you type on the FTP
command line window. To open a command line window, click New
Command Line Window on the Window menu.
You can group these commands into two categories of file operations:
Local file operations are operations that you perform on your PC,
such as deleting a file.
Remote file operations are operations that you perform on the FTP
server.
Local operations and remote operations require different commands.
Most of the functionality provided by these commands is available on the
FTP menus.
Related Topics
Local File Operations
Remote File Operations

Send Arbitrary FTP Protocol Command
The Send Arbitrary FTP Protocol Command on the File menu sends FTP
protocol commands to the remote FTP server only. For example, you
may want to send commands to change the timeout values on the FTP
server or change file permissions on UNIX FTP servers. These
commands are not part of the standard FTP protocol and vary from
server to server. You can choose the server that receives the commands
by selecting an item in the Combination list box.
In the Command box, type the command you want to send. When you
click Send, FTP sends this command to the FTP server you specified. It
then displays all server-generated messages or replies to the sent
command in the Server Reply box. If you want FTP to automatically
refresh the directory windows after you send the command, select the
Refresh the Server and Client Windows after Send check box. This box is
not selected by default.
The command syntax varies depending upon the remote FTP server.
Type help in the Command box to get a listing of the commands
available for the server. For more details on a particular command, type
help followed by the command name.

FTP command line window instructions
The quote command lets you send arbitrary FTP protocol commands to
the remote FTP host computer. The syntax for this command is:

quote command
where command is the command you want to send to the host. The
command syntax varies depending on your FTP host. Consult the FTP
server online Help for details.

Viewing a File
You can view a file using the application associated with its file extension.
To view a file:
1. Select the file.
2. On the File menu, click View File.
If you cannot view a file by its association, you can create an association
in Windows Explorer or using FTP. This association is between a file and
an application, so that the application starts when you open the file.
To create an association using FTP:
1. On the Options menu, click Preferences.
2. On the General tab, select the Viewer box, then type an application
name and extension, for example: notepad.exe.
If there is no association, the default FTP viewer attempts to open the
file. If you select a remote file, FTP transfers the file to the defined
temporary directory. If you do not have a temporary directory defined, you
receive an error message. If the file is executable, FTP attempts to start it
from the temporary directory. If the temporary directory does not include
all necessary files to run the program, an error message appears.

Removing a Directory
To remove a directory:
1. Select the directory.
2. On the File menu, click Remove Directory. The Remove Directory
window opens.
3. Click OK to confirm that you want to remove the directory and all of its
contents.

FTP command line window instructions
Use the lrmdir command to remove an empty directory from your PC
and the rmdir/xrmdir command (from the command line window only)
to remove an empty directory from the FTP server. To remove a directory
tree on a PC from the command line window, use the ldeltree
command; you can use the deltree command for a remote server.

Listing the Contents of a Directory
To list the contents of a directory in either the remote or local window,
double-click that directory.

FTP command line window instructions
You can list the contents of a directory by using the ls, lls, or dir
commands.
Use the ls command to list the contents of a directory on the FTP server.
Use the dir command to list the contents of a remote directory to the
window or to save the output to a local file. Use the lls command to list
the contents of the current working directory of your PC or of another
directory on the same drive.
If you are experiencing difficulty with large files shown on servers in
foreign countries, you may need to change the parsing method.
To list the contents of a directory on another drive, you must change the
working drive with the drive command before using lls. First type
drive, then type lls.
Related Topics
Configuring an Alternate Parsing Method
Changing the Working Directory

Changing the Working Directory
To change the working directory or subdirectory:
1. On the File menu, click Change Directory.
2. In the Name box, type the new path name.
3. Click OK.

FTP command line window instructions
Following the following procedure to change the working directory or
subdirectory using FTP command line window instructions:
1. Identify the current working directory.

To identify the current working directory on your PC, use the lcd
command. To identify the current working directory on the FTP
server, use the pwd/xpwd command.
2. Change the current working drive.
If you want to change to a different drive on the remote server (for
example, from C:\ to D:\), use either the cd or cwd command.
3. Change the working directory.
To change the working directory on your PC, use the lcd
command. To change the working directory on the FTP server, use
the cd, cwd, or parent/xparent commands.
Command Syntax
lmkdir
mkdir/xmkdir
lcd
pwd/xpwd
cd
cwd
parent

Changing PC Drives
To change the current drive, click the Drive drop-down list box and select
the desired drive.

FTP command line window instructions
To change the current working drive, use the drive command prompt, for
example: drive d:.

Creating a Directory
To create a directory or subdirectory:
1. On the File menu, click Create Directory.
2. In the Name box, type the name of the directory you want to create;
include the path, if necessary.
3. Click OK.

FTP command line window instructions
Use the lmkdir command to make a new directory on your PC; use the
mkdir/xmkdir command to make a new directory on the FTP server.

Naming Files

Invalid file names
Most FTP server systems follow naming conventions different from those
used in DOS, FAT, or VFAT. FTP server file names often start with a
period (.) or include characters such as a period in the file name. When
you try to copy these files to your PC, FTP creates valid FAT file names if
the Create Valid Local Filenames check box is selected on the General
tab of the Preferences dialog box. This applies only to FAT drives.

Case sensitivity and the FTP command line window
When you use the put or send commands, you may need to change the
case of the local PC files.

Renaming Files
To rename a file:
1. Select the file to rename.
2. On the File menu, click Rename.
3. In the Rename dialog box, type the new name of the file and the path
in the To box.

If a file was not selected before clicking Rename, you can type the
original name of the file and the path in the From box.
4. Click OK.

FTP command line window instructions
Use the lren command to rename a file on your PC and the ren
command to rename a file on the FTP server.

Printing Text Files
To print text files:
1. Select the file you want to print, or type the path and name of the file
in the Print box.
2. On the File menu, click Print.
3. Select either the Client File or Server File option.
Note:

FTP automatically selects the correct option if you omit this step.

4. Click OK.
Related Topic
Print Setup Dialog Box

Creating a Settings File
An FTP settings file contains all the settings chosen from FTP menus. It
also includes the current position of directory windows in the FTP
window. If you connect to one or more FTP servers and save a settings
file, the settings file saves the current connection information. If you have
specific settings you use for a particular FTP server, you can save them
in a settings file, which you can reload the next time you connect to that
FTP server.
FTP settings files use the .fs extension. By default, they reside in the
user directory.
To load a specific settings file, either click Open on the File menu or
specify the settings file from the command line window.
To create a settings file:
1. On the File menu, click New. This creates a new FTP (.fs) settings
file or loads a default settings file if one exists.
2. On the Connection menu, click Open.
3. Specify the information required to connect to the desired FTP server,
then click Open.
4. Choose all the necessary settings for this connection from the FTP
menus.
5. On the File menu, click Save As.
6. In the Save As dialog box, type a name for the file in the File Name
box.
7. Click Save.
Related Topics
Connecting Using the FTP Dialog Box
Starting FTP from the Command Line Window

Using the Hummingbird Basic Scripting Tool
Hummingbird Basic lets you create scripts that automate routine tasks. In
addition to the Hummingbird Basic Language, a set of FTP API functions
can be incorporated into a script to access and control FTP.
To access the Hummingbird Basic scripting tool:
1. On the Tools menu, click Load Hummingbird Basic Script File.
2. Select a file and click Open to access the Hummingbird Basic
scripting tool.

OR
Click New to write a new Hummingbird Basic script file.
You can also debug and run a script using the scripting tool. The scripting
tool differs from Hummingbird Basic Workbench in that only one file can
be open at a time. If Hummingbird Basic is installed, refer to
Hummingbird Basic Help for more information.
Related Topic
Creating an OLE Script

Creating an OLE Script
You can code OLE automation containers to implement all the features
and functions of FTP in another application that uses OLE features, such
as Hummingbird Basic. You can work with FTP session objects to call
functions such as connecting to a host and transferring files from host to
host. You can use any tool that supports OLE automation control, such
as Visual C++ and Visual Basic.
To access the scripting tool, select Load Hummingbird Basic Script File
on the Tools menu.
To create OLE tasks:
1. Create the main FTP Engine Object. For example:

Dim FtpEngine As Object
Set FtpEngine = CreateObject("HclFtp.Engine")
All objects support a dual interface. This lets you fully use the FTP
OLE features.
2. Retrieve an FTP Sessions collection. For example:
Dim FtpSessions As Object
Set FtpSessions = FtpEngine.Sessions
This lets you set such things as local drives and access
permissions.
3. Create the FTP session object. For example:
Dim FtpSession1 As Object
Set FtpSession1 = FtpSessions.NewSession

4. Set properties, such as server name, user name, and user
account. For example:
FtpSession1.ServerName="ftp.com"
5. Call the session method, such as Connect to Host, User Log in,
and Get. For example:
FtpSession1.UserLogin

Loading an FTP Command Script File
The FTP application uses the FTP command script file as a batch file to
execute and perform specific tasks.
To load an FTP command script file:
1. On the Tools menu, click Load FTP Command Script File.
2. Select the file you want, or type the name of the FTP Command Script
File in the File name box.
3. Click Open.

Configuring an Alternate Parsing Method
You can configure FTP to use an alternate parsing method for the
directory host listing. This is important for users listing and transferring
extremely large files internationally.
Note:

This procedure works with UNIX hosts only.

FTP does not create the ftp.ini file. You need to create the file
yourself using a text editor. In the text editor, type settings, then save the
file in the user directory as ftp.ini.
To configure an alternate parsing method:
1. Open the ftp.ini file.
2. Under settings, type AlternateParse=1.
3. On the File menu, click Save.

Configuring FTP to Work Around System
Problems
You can configure FTP to work around specific operating system
problems.

PASV Warning
OS/2 and VMS machines have known problems with operations if FTP
uses the PASV command. FTP warns users of these problems when
connecting.
Note:

The ftp.ini file is not created by FTP. You need to create the file yourself using the Windows
Notepad application. In Notepad, type [settings], then save the file in the user directory as
ftp.ini.

To disable the PASV warning:
1. Open the ftp.ini file.
2. Under settings, type DisablePASVWarning=1.
3. On the File menu, click Save.
Note:

This procedure works for OS/2 and VMS machines only. You can also disable the PASV mode
by clearing the Use PASV Mode check box in the Connection Settings dialog box before making
a connection to the server.

Protocol errors
A broken FTP server sends incorrect FTP protocol replies to system
commands.
To avoid protocol errors:
1. Open the ftp.inifile.
2. Under settings, type ForDGOnly=1.
3. On the File menu, click Save.

End of File characters
You can force FTP to treat Ctrl-Z characters in any ASCII file transferred
to a server as the End of File (EOF) character, even if the Ctrl-Z
character is in the middle of a file.
To treat Ctrl-Z as EOF:
1. Open the ftp.ini file.
2. Under settings, type TreatCtrlZAsEOF=1.
3. On the File menu, click Save.
Note:

This procedure works only with ASCII files and can be used in conjunction with the Strip Ctrl-Z
from the End of Files Sent to Server check box on the Connection tab of the Preferences dialog
box.

Using Other as the Default System Type
When you select Other from the Default Sys. drop-down list box in the
Open Connection dialog box, all files and directories on the server are
shown, even if FTP is unable to recognize the system type. This is useful
when the FTP server does not identify its system type or when the
system type it uses is not supported.
Other is also useful if the server declares its system type but does not
follow those conventions. When you select Other, then select the Force
Default System Type check box, FTP displays a list of all the files and
directories found in the current directory on the server.
In this case, FTP displays the file and directory names but no other
details. You cannot determine the nature of a listed item until you attempt
to perform either a file or directory operation on that item. If you try to
perform a file function on an item, such as using the drag-and-drop
method for your PC, FTP attempts to treat it as if it were a file. If the item
is not a file, the FTP server displays an error message, indicating that the
item is not a plain file. If the item is a file, the action is performed.
Similarly, an error message appears if you try to perform a directory
function on a file, such as double-clicking to open it. If the item is a
directory, double-clicking opens it and its contents are shown. You can
move up a level in the hierarchy by selecting the parent directory item.

Local File Operations
For more information on the use and syntax of a specific FTP prompt
command, click the command in the list below. The description includes
the command syntax. Parameters in italics are optional and should be
included only when appropriate. If you leave out a parameter when you
type a command, FTP prompts you for the required information.
cls

lls

drive

lmkdir

exit

lren

help

lrmdir

lcd

open

ldel

quit

ldeltree

These are the only commands that FTP recognizes regardless of an
open FTP connection to a server.
Note:

Local paths follow the same conventions as NTFS, HPFS, CDFS, POSIX, or DOS. Paths on the
FTP server can follow different conventions, depending upon the system.

Remote File Operations
For more information on the use and syntax of a specific FTP prompt
command, click the command in the list below. The description includes
the command syntax. Parameters in italics are optional and should be
included only when appropriate. If you leave out a parameter when you
type a command, FTP prompts you for the required information.
account

mkdir

append

mput

ascii

mrecv

auto

parent

binary

put

cd

puttree

close

pwd

cwd

quote

del

receive

deltree

remotehelp

dir

ren

get

rmdir

gettree

select

hosttohost

send

hosttohostappend show
hosttohosttree

status

ls

system

mdelete

type

mget

user

mhosttohost

FTP does not recognize these commands without an open FTP
connection.
Note:

Local paths follow the same conventions as NTFS, HPFS, CDFS, POSIX, or DOS. Paths on the
FTP server can follow different conventions, depending upon the system.

General Accessibility
Hummingbird products are accessible to all users. Wherever possible,
our software adheres to Microsoft Windows interface standards and
contains a comprehensive set of accessibility features.
Access Keys All menus have associated access keys (mnemonics) that
let you use the keyboard, rather than a mouse, to navigate the user
interface (UI). These access keys appear as underlined letters in the
names of most UI items. (If this is not the case, press Alt to reveal them.)
To open any menu, press Alt and then press the key that corresponds
with the underlined letter in the menu name. For example, to access the
File menu in any Hummingbird application, press Alt+F.
Once you have opened a menu, you can access an item on the menu by
pressing the underlined letter in the menu item name, or you can use the
arrow keys to navigate the menu list.
Keyboard Shortcuts Some often-used menu options also have shortcut
(accelerator) keys. The shortcut key for an item appears beside it on the
menu.
Directional Arrows Use the directional arrows on the keyboard to
navigate through menu items or to scroll vertically and horizontally. You
can also use the directional arrows to navigate through multiple options.
For example, if you have a series of radio buttons, you can use the arrow
keys to navigate the possible selections.
Tab Key Sequence To navigate through a dialog box, press the Tab key.
Selected items appear with a dotted border. You can also press Shift+Tab
to go back to a previous selection within the dialog box.
Spacebar Press the Spacebar to select or clear check boxes, or to
select buttons in a dialog box.
Esc Press the Esc key to close a dialog box without implementing any
new settings.
Enter Press the Enter key to select the highlighted item or to close a
dialog box and apply the new settings. You can also press the Enter key
to close all About boxes.

ToolTips ToolTips appear for all functional icons. This feature lets users
use Screen Reviewers to make interface information available through
synthesized speech or through a refreshable Braille display.

Microsoft Accessibility Options
Microsoft Windows environments contain accessibility options that let you
change how you interact with the software. These options can add
sound, increase the magnification, and create sticky keys.
To enable/disable Accessibility options:
1. In Control Panel, double-click Accessibility Options.
2. In the Accessibility Options dialog box, select or clear the option
check boxes on the various tabs as required, and click Apply.
3. Click OK.
If you installed the Microsoft Accessibility components for your Windows
system, you can find additional accessibility tools under Accessibility on
the Start menu.

Technical Support
You can contact the Hummingbird Technical Support department Monday
to Friday between 8:00 a.m. and 8:00 p.m. Eastern Time.
Hummingbird Ltd.
1 Sparks Avenue, Toronto, Ontario, Canada M2H 2W1
Canada and the USA
Technical Support: 1-800-486-0095
General Enquiry: 1-877-FLY-HUMM

International
+1-416-496-2200
+1-416-496-2200

Main: +1-416-496-2200
Fax: +1-416-496-2207
E-mail: support@hummingbird.com
FTP: ftp.hummingbird.com
Web Support: support.hummingbird.com/customer
Web Site: www.hummingbird.com

Connection Settings Dialog Box
To access
This dialog box lets you specify various connection settings.
E-Mail Address—Most anonymous FTP servers expect your e-mail
information as the password. After completing this box, this address
automatically appears in the Password box of the Open dialog box when
you click Anonymous FTP. You can edit your e-mail address when
opening a connection.
Server Port—This is the server port number used for connections. You
can type any value in the range 0 through 65535 in this box. The default
value is port 21.
Use PASV Mode—Determines whether the FTP client (the PC running
FTP) or the remote FTP server actively attempts to establish the data
connection. If this check box is selected, the FTP client actively attempts
to establish the data connection, and the FTP server becomes passive.
Otherwise, the FTP server is active and the FTP client is passive. By
default, this check box is selected: this permits the server to send
information bypassing simple firewalls.
To view the current FTP status (using PASV mode or not), click
Information on the Connection menu.
Note:

If you have problems connecting to the FTP server, your network may prohibit incoming
connections. To overcome this problem, select the Use PASV Mode check box and try to
connect again.

When PASV mode is selected, FTP does not work properly with some
IBM mainframe and OS/2 FTP servers. Because PASV mode is selected
by default, clear this check box in the Connection Settings dialog box
before attempting to make any connections to these types of FTP
servers. In these cases, FTP prompts you to disable or enable PASV
mode at connection time.
Some FTP servers are unable to become passive. In these cases, see
your network administrator.
Use Firewall—When you select the Use Firewall check box, the input
boxes in the Firewall area are available. The login information you supply

defines your access to the firewall node on the way to an external
connection (not the login information of the remote node). Normally,
firewall computers act as an intermediary between the client and the
server for added security from Internet intruders.
The corresponding options in the Firewall Type area support the following
types of firewall protection for FTP connections:
SITE
Server
Name

Firewall server name, user name, and password are required. FTP logs the user into the
firewall and establishes the remote connection using the FTP SITE command
remote_host.

USER
After Login

Firewall server name, user name, and password are required. FTP logs the user into the
firewall and establishes the remote connection using the FTP USER command
remote_user@remote_host.

USER
Without
Login

Firewall server name is required, and user name and password are ignored. FTP does
not log the user into the firewall; it establishes the remote connection using the FTP
USER command remote_user@remote_host.

Proxy
OPEN

Firewall server name is required, and user name and password are ignored. FTP sends
OPEN remote_host to the firewall when it connects.

Proxy
Firewall server name is required, and user name and password are ignored. FTP sends
CONNECT CONNECT remote_host to the firewall when it connects.

Preferences Dialog Box (Connection Tab)
To access
You can set the following preferences on the Connection tab in the
Preferences dialog box:
Connection—Specify the name or IP address of the remote host to
which you want to set connection preferences. Select a host name from
this drop-down list box or type the name or IP address in the box.
Write Ctrl-Z at the End of Files Sent to Server—Select this check box
to insert CTRL-Z at the end of all ASCII files transferred to the FTP
server. This helps you to easily detect the end of the file. This check box
is not selected by default.
Strip Ctrl-Z from the End of Files Sent to Server—Select this check
box to remove the last CTRL-Z from the end of a file when it is being
uploaded.
When this check box is selected, the Write Ctrl-Z at the End of Files Sent
to Server check box is cleared, and its state is ignored.
Drop Extensions of Files Sent to Mainframe Servers—Select this
check box to avoid sending the file extensions and version numbers of
files sent to or from mainframe servers. For example, IBM mainframes as
well as VM, VM/CMS, VM/VPS, MVS, and TANDEM operating systems.
This check box is not selected by default.
Drop Version Numbers of Files Received from VMS Servers—Select
this check box to avoid receiving version numbers and semicolons in the
file names of received VMS files. This check box is not selected by
default.
Drop Account Qualifier of Files Received from VOS Servers—Select
this check box to drop the file qualifier of files received from Harris VOS
machines. The account qualifier is all of the text up to and including the
asterisk (*) in the VOS file name. For example, label123*file drops
the account qualifier label123*.
Follow Symbolic Links on UNIX Servers—Select this check box to
instruct FTP to follow symbolic links to remote directories. This check box

is selected by default. If it takes a long time to list files, clear this check
box.
Note:

It may take some time to scan the remote system.

Cache Graphical Server Window Files and Directories—Select this
check box to instruct FTP to load the listings for graphical server window
files and directories from cache memory instead of querying the server
again.
Use Directory Listing Options for UNIX Servers—Select this check
box to instruct the FTP client to use directory listing options to retrieve the
file listings for UNIX servers. For UNIX servers that do not use directory
listing options, clear this check box.
Use Only Filenames When Sending Files to UNIX Servers—Select
this check box to use only the file name, instead of the full path name,
when transferring a file. This check box is not selected by default.
Trace FTP Protocol Commands and Replies—Select this check box to
record FTP protocol commands and replies in a log file. The connection
name is used to create the log file name. You can read and review this
file for troubleshooting purposes. FTP uses options for listing UNIX
server files. Clear this check box if you are experiencing problems with
the graphical window.
Override Default Trace File—You can create a log file name of your
own in this box if you do not want FTP to create the trace file from the
connection name.
Keep Connection Alive—Select this check box to override the
automatic timeout specified by FTP servers and to keep the connection
open indefinitely.
Keep Alive Every (Secs.)—Type a value for the number of seconds after
which FTP sends the commands to keep the connection open.
Use Patterns for AUTO Transfer—Select this option if you want to
specify naming patterns that will be used to transfer files between the
FTP server and the PC. For example, s*.txt indicates that all .txt
files that begin with the letter "s" will be transferred. This option is valid
only if you have set the file transfer type to Auto which means that FTP

automatically detects the appropriate transfer type (Binary or ASCII) for
the type of file being transferred.

File Menu
The File menu contains the following commands:
New—Creates a new FTP (.fs) settings file.
Open—Loads an existing FTP settings file.
Close—Exits the current FTP settings file.
Save—Saves the current FTP settings to an FTP settings file. By default,
settings files are saved in the user directory. FTP uses the .fs file
extension automatically.
Save As—Saves a new or existing FTP settings file under a new file
name. By default, FTP settings files reside in the user directory. You can
save the file to a different directory by selecting another directory in the
Save As dialog box. FTP uses the .fs file extension automatically. Click
OK to save the file.
Save As Defaults—Saves all the settings you made in an FTP session
to a file named default.fs in the user directory. Those settings are
reloaded automatically the next time you run FTP.
Get—Copies files from the FTP server to your PC.
Put—Copies files from your PC to the FTP server.
Server to Server Transfer—Transfers selected files from one server and
directory to the selected FTP server.
Delete—Deletes one or more files.
Rename—Renames a file or directory.
Send Arbitrary FTP Protocol Command—Sends only FTP protocol
commands to the remote FTP server.
View File—Displays the selected file by running the application specified
in the Preferences dialog box.
When you double-click a file, FTP attempts to open the file with its
associated application. If this does not work, it opens the file with the
viewer specified in the Preferences dialog box.

Print—Sends text files to the default printer.
Print Setup—Specifies the printer to use and various printing options.
Change Directory—Changes the working directory.
Create Directory—Adds a subdirectory in the currently selected
directory.
Remove Directory—Deletes a directory and any associated
subdirectories.
Exit—Closes your current session with any FTP servers and exits FTP.
Related Topics
Changing the Working Directory
Send Arbitrary FTP Protocol Command
Transferring Files Using the Get Command (File Menu)
Transferring Files Using the Put Command (File Menu)

Print Setup Dialog Box
To access
The Print Setup command on the File menu specifies what printer to use
and various related printing options:
Printer—Select the printer you want to use from the list of installed
printers.
Properties—Specify advanced printer options such as encapsulated
postscript file output, header printing, margins, and scaling in the Options
dialog box.
Paper—Select the correct paper size and paper source supported by
your printer.
Orientation—Specify the page orientation. If you select Portrait, the
printed page is taller than it is wider; if you select Landscape, the printed
page is wider than it is taller.
Network—Connects to a network printer (optional).

