AutoCAD Map 3D Tutorials >
Introducing AutoCAD Map 3D 2009

e These tutorials provide an overview of the product and hands-on
exercises to help you learn many aspects of AutoCAD Map 3D.

e The AutoCAD Map 3D tutorials are also available in PDF format. &

Topics in this section

e What You Can Do With AutoCAD Map 3D 2009

e Basic Product Concepts

e Getting Ready to Use the Tutorials
e Taking a Quick Tour of AutoCAD Map 3D

e Getting Started
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What You Can Do With AutoCAD Map 3D 2009

AutoCAD Map 3D is the leading engineering GIS platform for creating and
managing geospatial data. AutoCAD Map 3D bridges CAD and GIS by
providing direct access to data, regardless of how it is stored, and by enabling
the use of AutoCAD® tools for maintaining a broad variety of geospatial
information. Using Open Source FDO Data Access Technology, AutoCAD Map
3D natively accesses geospatial data stored in relational databases, files, and
web-based services, providing easy management of large geospatial data sets
while streamlining entire workflows.

The topics in this section describe what you can accomplish with AutoCAD Map
3D.

Topics in this section

e Combine map objects

e Create and edit map objects

e Use map-related data

e Format map objects

e Manage map data
e Perform analysis on maps

e Publish maps
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Combine map objects

The Autodesk Feature Data Objects (FDO) Data Access Technology helps you
work seamlessly on a variety of geospatial and non-spatial databases and file
formats natively, without the need for translation and risk of data loss. These
data sources may contain a single feature type, such as parcels or street
centerlines, or may contain a complex data model with multiple features and
attribute tables. AutoCAD Map 3D automatically resolves differences in scale
and coordinate systems.

You can add the following types of items:
e AutoCAD drawing objects

e Geospatial features stored in a relational database, such as Microsoft®
SQL Server, Oracle® Spatial, and MySQL

e Features stored in a geospatial data file format, such as an ESRI® SHP
or Autodesk® SDF file

e Features stored in middleware, such as ESRI® ArcSDE®

e Raster images, including DEM surfaces that show elevation
e Web-based maps from WFS (Web Feature Service) sites

e Web-based images from WMS (Web Map Service) sites

e Attribute or point data stored in a spreadsheet or database that can be
linked to drawing objects

e Data from third-party providers, leveraging the power of Open Source
You can add add geospatial data using the following techniques:

e Drag and drop file-based sources into your map.



e Use the Data Connect dialog box to connect to any non-DWG data
source and add the feature classes you want.

e Use data-based queries to add a subset of data from the data source to
your map.

You can add add objects from AutoCAD drawings using the following
techniques:

e Use data-based queries to add objects from a drawing (find all objects on
a particular layer, all objects of a certain size, all objects with certain
properties).

e Define areas to add (draw a selection window).

e Add specific drawing layers.
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Create and edit map objects

Use several methods to create and edit objects:

e Use the full set of AutoCAD editing tools and commands to add or
change map objects from different object sources without converting the
data. You can use these commands on drawing objects and FDO data.

e Use the Data Table to change values for GIS feature data.
e Use the Data View to edit attribute data values for drawing objects.

Your changes immediately update your map. For both drawing objects and GIS
features, you can choose whether to update the original data stores with your
changes.
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Use map-related data

Use attribute data as the basis of queries and display it as text in your map.
For drawing objects, you can do the following:

e Import attribute data.

e Attach drawing objects with links to external data.

e Link database entries to the data already associated with drawing
objects.

e Create and manage attribute data within AutoCAD Map 3D using Data
View.

e Display attribute data on your map as text.
For geospatial feature data, you can do the following:
e Join an attribute data store to an existing feature class.

e Create and manage attribute data within AutoCAD Map 3D using Data
Table.

e Display attribute data on your map as text.

e Examine and publish map metadata.
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Format map objects

Change the way objects in the map appear, without changing the objects
themselves:

e Assign visual properties to object groups, or to objects that match certain
criteria.

e Use themes to vary visual properties based on attribute values.

e Save display layer definitions (which include styling information and
pointers to the data source) for re-use.

e Use special formatting options for raster images to show hillshade,
contours, and more.
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Manage map data

Manage the structure of data and move data from one format to another:

Use Schema Editor to create new schemas.
Add and delete features and properties in existing schemas.

Use Data Connect to create a new data store from within AutoCAD Map
3D.

Use Bulk Copy to copy data from one data store to another.

Export DWG data to a variety of geospatial data formats, including
Oracle, ArcSDE, SDF, and SHP.

Export your entire map to DWG format.
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Perform analysis on maps

Use the following methods to analyze data:

Sort, filter, and edit information about map items in a tabular format.

Locate specific coordinate points and measure the geodetic distance
between points.

Visually communicate relative values and scale with themed displays.

Temporarily join data from external data stores to features in your map
and use that data to theme the features.

Create contour maps to help you analyze 3D terrain.

Use raster-based theming to analyze elevation, slope, and aspect, drape
map data over surfaces and view the data in 3D, and more.

Create buffer zones based on feature properties and select objects based
on their proximity to a buffer. Save the buffer as its own feature class,
for future re-use.
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Publish maps

In addition to printing your maps on a plotter, you can do the following:

e Use map books to divide a large map into tiles, which are rendered on
separate pages. You can include a legend, title, and other information on
each page.

e Produce maps with insets using map books.

e Create comma-separated reports as text files, listing information about
objects in attached drawing files. You can import the report files into a
spreadsheet, database, or document.

e Use Autodesk MapGuide® technology to post maps and map books on
the web or on an intranet. The way that you send maps to this platform
varies, depending on whether you use the current version of Autodesk
MapGuide, MapGuide Open Source, or Autodesk MapGuide versions
6.5 and earlier.

e Save maps in Autodesk DWF format to use with Autodesk Design
Review (the latest version of the DWF Viewer), and distribute or post
the results on the web or on an intranet. You can create map books in
DWF format.

As long as you have assigned a coordinate system to all the maps in your
DWEF file, the publishing operation automatically converts the coordinate
information to latitude/longitude coordinates. Autodesk Design Review
2008 can automatically navigate to a specific location when you enter
coordinates, and displays coordinates of any location in the map when
you move your mouse over that location. When your computer is
integrated with a GPS device that uses the NMEA 0183 protocol, field
workers can center the map to the coordinates provided by the integrated



GPS device on your system, and display the “my coordinates” icon
within the map.

Create a static web page from your map.

Use eTransmit to package all the files your map uses and send them to
another AutoCAD Map 3D user.
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You must understand the following concepts before you begin using AutoCAD
Map 3D. If you are an experienced AutoCAD user, some of these concepts may
be familiar to you.

Topics in this section
e Map files and display maps
e Source files and mabp files

e Drawing objects and geospatial features
e Importing/exporting data vs. connecting to data stores
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Map files and display maps

A map file is a drawing that connects to all the sources for your map: geospatial
features, drawing objects, raster images, and attribute data.

Each map file can contain multiple display maps (for printing or for online
distribution), in which you can selectively hide or show items in your map. Maps
exist only as conceptual structures, and are not separate entities or files.

You can apply styles to the items in a display map, based on data, layers, and
other criteria. Changes that you make to the appearance of items in a map do not
affect the actual data in your map file.
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Source files and map files

One map file can use multiple sources. For example, you might attach a DWG
file to your map file, query in one or two of its layers, and add them as Display
Manager layers. Then, you might connect to a SHP file that becomes another
layer in your display map, or add features from a geospatial database. The map
file remembers all the connections and which objects you’ve added to the map
file.

The relationship between the sources and the map file is dynamic. If the data in
the source file changes, those changes are updated in your map file. When you
change the objects in your map file, you can save those changes back to their
original sources.

For drawing objects, you can lock the source drawings so no one else can use
them, and you can use save set options to control whether your changes are
saved back to the original drawings or affect the current map only.

For geospatial features, you can set an option to save changes to the original
source automatically, or you can work offline and update the feature source

when you finish editing. Check out a feature to lock it for other users (if the
feature source supports this) and check it back in to make it available again.

Please send us your comment about this page



javascript:doComments('./html/ac.cmtdialog.htm');

AutoCAD Map 3D Tutorials > Introducing AutoCAD Map 3D 2009 > Basic
Product Concepts >

Drawing objects and geospatial features

Objects in maps fall mainly into two categories: drawing objects and geospatial
features. Drawing objects come from AutoCAD drawings and geospatial
features from a centralized data store (like an Oracle database) or a spatial data
file (like a SHP or SDF file).

Some AutoCAD Map 3D functions are more useful for one object type than for
another. For example, the drawing cleanup feature eliminates extraneous lines in
DWG files, but drawing cleanup does not work on a geospatial feature.

Some functions use different commands, depending on the object type. The
following table explains the functions available for the two data types:

ELTEpEhl Description DWG objects only | Description
features only

Connecting to Geospatial Attaching source Attach a DWG

features features DWG files file to your
appear in map and then
your map as use a query to
soon as you include objects
connect to from the DWG
their data file in your
stores and map. Only
add them to objects that
your map. match the
Check out criteria in your
the feature to query are

edit it and added to the



Data Table

Schema Editor

check it back
in to update it
in its source.
Stay
connected to
the data store
while you
work, or
work offline.
If your data
store
supports
versioning,
you can
manage
versions.

Add and edit
feature data.
You can
perform a
join to add
external data
sources to
feature
classes, but
you can edit
only the
direct
connection to
that data and
not the joined
data.

Data View

Group Classifying
features by Objects
criteria.

map. The set of
source DWG
files attached
to your map is
called a
drawing set.
You can save
the current
drawing set
and set options
for it.

View and edit
data stored in
an external
database table
and linked to
drawing
objects.

Group objects
by their
properties or
data.



Publish to
Autodesk
MapGuide

Save data in
other formats

View data before

adding it to your
map

Publish web-
based maps
containing
both
geospatial
features and
drawing
objects to a
server
platform.

Save features
from a
geospatial
database in a
spatial data
file, such as
SDF, and
save a layer

from Display

Manager for
re-use. Use

Bulk Copy to
copy a
feature class
from one
data format
to another.
Export
geospatial
data to DWG
format.

N/A

Export to Autodesk
MapGuide version

6.5 and earlier

Export data in
other formats

Quick View
drawings

Export drawing
objects to a file
that can be
used by a
server
platform.
(Geospatial
features are not
exported.)

Export to a
variety of
drawing and
geospatial data
formats.

Display
attached DWG
files without
querying any



Buffers

Correct data
errors

Metadata

Versioning;
Check-in and
check-out

Create zones
based on
properties
and analyze
objects based
on their
proximity to
the buffer.
Save the
buffer as its
own feature
class for
future re-use.

Topology

N/A Rubber Sheet, Map
Trim, and Drawing
Cleanup

N/A Transform

View Drawing Statistics
metadata

about the

geospatial

data sources

in your map.

Manage
versions (for
data stores
that support
them) and
check out

Drawing
Maintenance

objects into
your map.

Set up
geometric
relationships
for GIS
analysis
functions, such
as network
tracing, buffer
analysis,
overlays, and
more.

Correct
drawing errors.

Move, rotate,
and scale a
drawing object
or objects.

View
information
about the
active source
DWG files in
your map.

Index your
DWG files for
quick
searching and
lock or unlock
objects.



data to lock it
while you
use it.
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Importing/exporting data vs. connecting to data stores

When you add data to your map (geospatial features, drawing objects, or
attribute data), the link to that data is "live." If you are connected to the data
store and it is updated, the related item in your map is also updated. If you
change the data in your map, you can update the data in the data store.

However, when you import data you get a "snapshot" of the data at the time you
import it. If the data changes after that, you will not see any changes in your map
unless you import the data again. There is no way to update imported data in its
source. Similarly, when you export data, you export the current data only. The
connection to the live data is lost.
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Getting Ready to Use the Tutorials

These AutoCAD Map 3D tutorials cover the following:

Getting started: Take a quick tour of the application. Create a new map
file, assign a coordinate system, connect to data, style features, and save
your work.

Building a map: Learn all the basics of creating a map from start to
finish. Use multiple sources, design themes and composite styles to
change the appearance of objects, create new features and edit them, and
publish your finished map.

Analyzing Data Using Styles, Joins, and Buffers: Add a surface and style
it using a theme and contour lines to show elevation. Join an external
database to a feature and create a style using both sets of data. Create a
buffer zone that highlights areas within 1000 feet of a river and identify
parcels that lie within that zone. Export comma-separated data to use in a
report to the owners of those parcels.

Managing Data From Different Sources: Export drawing objects to
Autodesk SDF format, and then connect to the resulting SDF file to add
it as a layer in another map. Use Bulk Copy to copy the SDF data to SHP
format. Import the SDF data to convert it back to drawing layers.

Styling, Splitting, and Using Joined Data with Polygon Features:
Connect to geospatial data for parcel polygons. Join a data source to the
parcels to add assessor data. Add a new calculated property that uses
native and joined properties. Split a parcel into two uneven pieces using
the Split command and assign attributes to each resulting parcel using
Split/Merge rules.

Topics in this section



Preparing your sample data
Saving your tutorial maps
Setting up the tutorial window

Choosing a workspace
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Preparing your sample data

When you installed AutoCAD Map 3D, the tutorial sample data was installed on
your computer in the \Program Files\AutoCAD Map 3D 2009\Help\Map 3D
Tutorials folder. You will need that sample data to use the tutorials.

Copy the Map 3D Tutorials folder to My Documents. That way, if you change
the sample files, the original versions remain unchanged and can be used again
and again.

To make a copy of the sample data

1.

In Windows Explorer, navigate to the\Program Files\AutoCAD Map 3D
2009\Help folder.

Right-click the Map 3D Tutorials folder and click Copy.

Navigate to your My Documents folder.

Note The location of My Documents varies, depending on your operating
system. For Microsoft Windows XP, it is usually C:\MyDocuments. For
Microsoft Vista, it may be C:\Documents and Settings\Administrator\My
Documents\Map 3D Tutorials.

Paste the Map 3D Tutorials folder into My Documents.

A new folder is displayed in My Documents, for example C:\My
Documents\Map 3D Tutorials.

Add the location to the Favorites list in Windows Explorer, or make a
note of it.
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Saving your tutorial maps

You can create a folder for any map files you create or change as you use the
tutorials.

To create a folder for your tutorial map files
1. Open Windows Explorer.

2. Navigate to the C:\My Documents folder.

Note The location of My Documents varies, depending on your operating
system. For Microsoft Windows XP, it is usually C:\MyDocuments. For
Microsoft Vista, it may be C:\Documents and Settings\Administrator\My
Documents\Map 3D Tutorials.

3. Click File menu » New Folder.

4. Change the name of the new folder to My AutoCAD Map 3D Tutorial
Data.
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Setting up the tutorial window

Resize the window that displays the tutorial instructions so you can see it while
you work.

To resize the tutorial window

1. To display the tutorials, in AutoCAD Map 3D, click Help menu »
Tutorials.
e
2. In the tutorials window, click __H9¢ | to hide the pane that contains the
Contents, Index, and Search tabs.

A : : : :
Use BEE to go to either the next or previous pages in the exercises.
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Choosing a workspace

The tutorials assume that you are using the Map 3D for Geospatial workspace
unless otherwise noted. This is the default workspace. If you change to a
different workspace, switch to the Map 3D for Geospatial workspace for the
tutorials.

To change to the Map 3D for Geospatial workspace
1. Click View menu » Menu/Toolbar Layout.

2. Select the Map 3D for Geospatial workspace.
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Taking a Quick Tour of AutoCAD Map 3D

Start by becoming familiar with the AutoCAD Map 3D window:
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The AutoCAD Map 3D window

To display the AutoCAD Map 3D window
1. Before you begin the tutorial, see Getting Ready to Use the Tutorials.
2. On the desktop or the Start menu, start AutoCAD Map 3D.



3. In AutoCAD Map 3D, click File menu » Open. Navigate to the folder in

My Documents where you copied the sample files.

Open SampleMap.dwg.

An alert may tell you that an undefined drive alias is referenced. If so,
click Define and follow the steps below. If not, proceed to the “Menus
and Workspaces” topic.

To define a drive alias

e The alias you need to define is already selected. Click in the
Actual Path field and click Browse.

e Navigate to the folder where you copied the sample files. Open
that folder and click OK. (Be careful to select the Map 3D
Tutorials sub-folder, not the parent My Documents folder.)

e Click Add, and then click Close.

The sample data location is now mapped to your drive alias. After
this, you can open the sample data without defining any further
aliases.

Topics in this section

Menus and Workspaces

Toolbars
Task Pane

Properties palette

Status bars

Layout tabs

Dynamic input
Shortcut menus
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Menus and Workspaces

In AutoCAD Map 3D, all the commands related to a particular task are on the
same menu. For example, commands related to new objects are on the Create
menu, commands related to editing are on the Modify menu, and commands
related to analysis are on the Analyze menu.

Commands on the menus vary, depending on which workspace you are using.
One workspace is customized for working with geospatial data; one is for
drawings; and one is for users of previous versions of AutoCAD Map 3D.

You can customize any workspace to include the toolbars and menus you like,
specify the contents of each toolbar and menu, keyboard shortcuts, and how the
mouse buttons behave.

To specify a workspace
1. Click View menu » Menu/Toolbar Layout.
2. Select the workspace most appropriate for your work.

e If you work mainly with geospatial data, select Map 3D For
Geospatial.

The tutorials assume that you use the Map 3D For Geospatial
workspace unless otherwise noted.

e If you work mainly with Autodesk drawings, select Map 3D For
Drawings.

e Users of previous versions may prefer Map Classic.
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Toolbars

The toolbars in AutoCAD Map 3D provide access to AutoCAD functions and
AutoCAD Map 3D functions:
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AutoCAD drawing tools
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Task Pane

The Task Pane gives you quick access to frequently used features, and groups
these features into task-related views.

Switch between Display Manager,
Map Explorer, and Map Books

_Ei Current Map: m - :l
[ e ]
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= = ¥ Mop Bose u
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- 2
1 E
The Task Pane

There are three tabs:

e Display Manager, where you manage features stored in data stores
(databases, geospatial data files, and raster files), attach drawing files,
and change the appearance of features. Each geospatial feature class is a
layer in Display Manager. You can add drawing layers as well.

e Map Explorer, where you view the elements of your map project, such
as the files you connected to as sources, queries you used and saved,
templates for linking drawing objects to data, and so on. Use this view to
query in objects from attached drawings and view the data for any
object.

e Map Book, where you divide a large map into "tiles," which are each



rendered on a separate page. You can publish map books in a variety of
formats, both for printing and for online display.

Use these techniques when for the Task Pane

To switch between views, click the tabs on the Task Pane.

To see options for the current Task Pane tab, click an icon in the menu
area at the top of the Task Pane.

To hide the Task Pane, click its Minimize button. Hold your cursor over
the Task Pane title bar to see the Minimize button. To display the Task
Pane after hiding it, move your cursor over the title bar.

To make the Task Pane a floating palette, grab its title bar and drag it to
the desired location. Drag the title bar to a window edge to dock it again.
Note To minimize the Task Pane each time you move your cursor away
from it, right-click the Task Pane title bar and turn on Auto-hide.

To close the Task Pane, click the X in its top right corner. To open it,
click View menu » Task Pane.

Please send us your comment about this page



javascript:doComments('./html/ac.cmtdialog.htm');

AutoCAD Map 3D Tutorials > Introducing AutoCAD Map 3D 2009 > Taking a
Quick Tour of AutoCAD Map 3D >

Properties palette

View the properties of the selected drawing object in the Properties palette.
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The Properties palette

To use the Properties palette to style drawing objects
1. In the SampleMap.dwg file, select a road.
2. Right-click the road and click Properties.
The Properties palette is displayed.

3. Click the Design tab if it is not already displayed.

The roads are objects in an AutoCAD drawing. Notice that the current
selection is defined as a Polyline. You can use the Properties palette to
change some aspects of a drawing object’s appearance.

e To change the way the currently-selected road segment is



displayed, click in the Color field and then click the down arrow
to select a color. If you are asked whether to add this object to the
save set, click No.

With your cursor positioned in the map, press Esc to see the
results.

e To change the color for all roads, click Setup menu » AutoCAD
Layer. Click in the Color field for layer 0, which contains the
roads, select a color, and click OK.

The color of all the roads changes to the color you selected.

To use the Style Editor to style geospatial features

1.
2.
3.

In the SampleMap.dwg file, select the Parcels layer in Display Manager.

Click a parcel in the map.

If the Properties palette is not still open, right-click the parcel and select
Properties.

Click the Display tab.

The styling information for the parcels does not appear on the Properties
palette because the parcels are stored in an SDF file—they are geospatial
features, not drawing objects.

To change the color of the parcels, click the Style button in the Task
Pane menu area.

e Click in the Style field in the middle of the Style Editor window.

e Select a different Foreground color and click OK.

¢ Close the Style Editor by clicking the X in its top right corner.
The changes are displayed in your map.

Please send us your comment about this page



javascript:doComments('./html/ac.cmtdialog.htm');

AutoCAD Map 3D Tutorials > Introducing AutoCAD Map 3D 2009 > Taking a
Quick Tour of AutoCAD Map 3D >

Status bars

The area at the bottom of the application window displays status information and
includes some controls for changing the view.

[ onine. J1 I 20] = 30| Verical Exaggeration: |1x | ~ | Command |2 [View Scale 1:]589158] '|E’||v‘
s ey - L > 1)< (o]« [+ ] e[RRI SIQ O P - O

The status bars

The controls on the left side of the uppermost status bar show the following:
e Online/offline switch
e Two-dimensional/three-dimensional buttons

e The vertical exaggeration setting (Click the down arrow to select a
different setting.)

e Command (Displays the command line window.)

The controls on the right side of the uppermost status bar show the following:
e Warnings (View warnings by clicking the icon.)
e The current view scale (Change this by clicking the down arrow.)

e Whether styling is linked to zooming (Toggle this by clicking the lock
icon.)

e Autodesk Trusted DWG (This indicates that the drawing is a DWG,
DWT, or DWS file that was created with Autodesk applications or
Real DWG™-based applications that are trusted by Autodesk.)

e Drawing Status bar menu (Click the arrow to see choices.)



The controls on the left side of the lower status bar show the following:
e Current cursor coordinates
e AutoCAD tools
The controls on the right side of the lower status bar show the following:
e Model/layout buttons (View model and display space and add layouts.)
e AutoCAD viewing tools
e Workspace switching

e Toolbar/Window Position locking (Toggle the locked status of toolbars
and windows.)

e Application status bar menu (Click the arrow to see choices.)
e Clean Screen (Toggle the display of all tool areas.)

Instructions for the current command will replace some status bar items, and
some items will appear only while an operation is in progress, for example,
publishing or plotting.
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Layout tabs

Most of the time you work in model space, where you create your map on a 1:1
scale. You can create multiple paper space layouts, where you can place a title
block, include several views of the same item, and include notes. Switch
between model space and layout spaces using the tabs at the bottom of the
application window.

4 A[F M Layoutl 4 Layout?

Model and Layout tabs

By default, each map has one Model tab and two Layout tabs. Create more
Layout tabs if you need them.

To display and hide the Model and Layout tabs

1. At the bottom of the application window, right-click E(the Model Space
icon).
2. Click Display Layout and Model Tabs.

To hide the tabs again, right-click a tab and click Hide Layout And
Model Tabs.
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AutoCAD Map 3D Tutorials > Introducing AutoCAD Map 3D 2009 > Taking a
Quick Tour of AutoCAD Map 3D >

Dynamic input

For experienced AutoCAD users, the command-line interface is a shortcut for
creating objects and specifying properties. In AutoCAD Map 3D, you can use
the command prompt (dynamic input) within the map area.

| Specify center point for circle or |£I| RS ||24.7131
3p

2P

Ttr (tan tan radius)

An example of dynamic input

Keep the following rules in mind:

e Some commands require that you specify vectors with your cursor.
When you finish doing this, press Esc.

e Some commands require that you select an object. Click the object and
press Enter.

e Some commands have multiple input fields. Press the Tab key to move
from one to another.

e When the down arrow icon & appears in a prompt, press the down arrow
on your keyboard to see a list of options for that command. Press the
down arrow again to move between options, and then press Enter to
select the highlighted one.

To use dynamic input

1. Position your cursor over an empty space in the map.



2. Enter circle and press Enter.
3. Respond to the prompts to draw a circle.
e For the circle’s center point, click somewhere in the map.

e For the radius of the circle, enter 500 and press Enter.
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Shortcut menus

Each item in AutoCAD Map 3D has a custom menu that contains commands
available for that item at the current time.



Current Map:

B4E & [

Data Style Table Groups Tools

==x=xa Roads
e

- Attached Drg

Raster

Parcels

]- Map Explorer 1 Display Manager

- Map Base
F Default

L City_Boun —

1| n

| MapBook

[‘,T;] Edit Connection...
& Edit Style...
f Show Data Table

@ Zoom to Extents

E‘;! Refresh Layer

v Make Layer Selectable

.éL,. Check In Features

<£>;.-. Select Checked Out Features

Q}; Mew Feature from Geometry

@ CQuery to Filter Data..,

%'_'ﬁ Create a Join...

ﬂ—_'ﬁ Create a Calculation...

H Save Layer...

' Export Layer Data to SDF...
#£ Remove Layer

Create New Polygon Parcels

Create Mew MultiPolygon Parcels

Yiew Metadata...

=8 Cut
Copy

@ Paste

Help

An example of a shortcut menu in Display Manager

To use a shortcut menu, do either of the following

e Right-click an item in the map.

e Right-click an item in the Task Pane.
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Getting Started

This lesson provides an overview of the basic tasks needed for creating maps.

You will use the Display Manager to bring in a file containing road data, change
the way the roads are displayed, and then save your work. In about fifteen
minutes, you will have a complete map.

Topics in this section

e (Creating a New Map
e Use Data Connect to Add Data to Your Map

e Style a Feature
e Where You Are Now
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Creating a New Map

Create a new map file using a standard template. Assign a coordinate system,
which will be used for any new data you add to your map.

To create a new map

1.
2.

Before you begin this tutorial, see Getting Ready to Use the Tutorials.

From your desktop or the Start menu, start AutoCAD Map 3D (if it isn't
already running).

In AutoCAD Map 3D, click File menu » New.

In the Select Template dialog box, select map2d.dwt and click Open.

-~

Mame =

| PTWTemplates
| SheetSets
@acad.dwt
oam) acad3D.dwt
acad -Mamed Plot Styl...
@acad -Mamed Plot Styl...
acadisu:u.dwt [
@acadisuBD.du‘u‘t
o) acadIS0 -Named Plot ...
lgin) acadIS0 -Named Plot ...
‘et map2d.dwt
@mapEdisu.dwt

made.dwt

e man3dicn.chut

n,

Select map2d.dwt

This file is an AutoCAD template that is set up to work with two-
dimensional maps in AutoCAD Map 3D.



5. Assign a coordinate system for your map.
¢ In the Task Pane, click the Map Explorer tab.

e In Map Explorer, right-click Current Drawing and click
Coordinate System.

x
8 & o
Data Schema Table Tools Remove ]
El--@ Current Drawing [Drawingl . cheaal |
o -|c=) Drawings User Login...
;g_ EIB Query Library User Admin...
1] ~.[F Current Query User Info...
=% =
a =55 Object Classes -
£ L [?) Undefined Classes Coneinate System...
Eml |5 Data Sources Track Coordinates
§ B Tgpologies View Metadata...
E_ -5 Link Templates Options...
Help
1 T

Set the coordinate system from the Task Pane.

e In the Assign Global Coordinate System dialog box, for Code,
enter CA-I . (Enter uppercase letters CA, hyphen, uppercase letter

L)

[L' Assign Global Coordinate System =™
Curment Drawing
Code: CAd

| Select Coordinate System. . |

Description:  MADZ7 Calfomia State Planes, Zone 1(401), US Foot

Source Drawings
Code:

Select Coordinate System...

Description:

Mumber of selected source drawings: 0 [ Select Drawings... ]

oK | | Cancel || Hep |




Specify the code for your coordinate system.

Note To find the code for a particular coordinate system, click
Select Coordinate System in this dialog box and select a
coordinate system by category. Use the Properties button to see
information about different coordinate systems until you find the
one for your map.

e Click OK.
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Use Data Connect to Add Data to Your Map

Use Display Manager to bring in a file containing road data.

To add data to your map

1. In the Task Pane, switch to Display Manager.

2. In the Display Manager menu area, click Data » Connect To Data.

F x
2 Current Map: Default - o
* o
] =|
£ E =N
2 5% pyry—
8| [ %Y NewMap... ||
=] #|
E. [ =2 Mew Group
o E-r?}: Mew Text Layer...
E ‘ Load Layer...
[ |8 Bulk Copy...
i !
E I_ Add Drawing Data 3 E
é- [=%
=t
8
1 K

Use the Data menu in the Task Pane to add any kind of data to a map.

The Data Connect window is displayed.

3. Under Data Connections By Provider (on the left side), click Add SHP
Connection.

4. Click the file icon next to Source File Or Folder (on the right side).

5. Navigate to the sample data folder and select Roads.shp. Click Open.




6. Click Connect to add the road SHP file as a data source.

Bl ¥ X

Data Connect

Data Connections by Provider

%y Add ArcSDE Connection

£y Add MySQL Connection

£y Add ODBC Connection

£ Add Oracle Connection

[ Add Raster Image or Surface C
[ Add SDF Connection

[ Add SHP Connection

75 Add SQL Server Connection
@@ Add WFS Connection

@ Add WMS Connection

| 1 | F

Data Connect help [El Learn more
05Geo FDO Provider for SHP

Read/write access to spatial and attribute data in an ESRI SHP file,

'_CEI-r'Ir'I ection name:
SHP_1

Source file or folder:
CaMy DocumentsiMap 30 Tuterials\Roads.shp @

To add a feature, first connect to its source.

7. In the Data Connect window, under Add Data To Map, select Roads and
click Add to Map.

Available sources in this connection. Select Items to add to the map as lay

5 Edit Coordinate Systems | [ Refresh

Schema Coordinate System
Default
@ Roads CA-I

< |

T

| »

ik Addto Map -

Select an item and examine its coordinate system.

8. Close the Data Connect dialog box by clicking the X at the top of the
window.




Please send us your comment about this page



javascript:doComments('./html/ac.cmtdialog.htm');

AutoCAD Map 3D Tutorials > Introducing AutoCAD Map 3D 2009 > Getting
Started >

Style a Feature

Change the appearance of the roads.

To style the roads

1. In Display Manager, select the layer labeled "Roads" and click Style in
the menu area.

E Current Map: o i(l
E —
g [E |
P B E =
& Data Table Groups Tools
]
8 § - Roads
&
& b Map Base
E O Default
s
LE]
=
: :
=t
L
—I K

Select the Roads layer and click Style.

The Style Editor window is displayed over your map.

2. In the Style Editor window, click ] for Style and select a thickness,
color, and pattern for the roads. Click OK.



x
I Style Editor help 1]
G| ScaleRanges for Layer Default:Roads
‘{]Add a Scale Range | m Duplicate ~ §§ Delete | Q Up & Do
From Te Preview: Line
» R -
Line Style for 0 - Infinity Scale Range
& NewTheme.. |9JAddaRule [0} Duplicste  $€ Delete 8@ Deletesdl |G up 1
Thematic Rules Style Legend Label | Feature Label |
o o — o o
Style Line =
[7] Apply styles to the line
Create composite lines
8 Units (Device space): Centimeters -
3
§ Thickness: 005 -~
o}
K Coler: B 145,105,175 ¥
Patern. =0 0|0 = = = = -
Preview
[ Resmt | [ ok ][ canen |

You can select a thickness, color, and pattern for the lines in the Style Line dialog box.

3. Click the X at the top of the Style Editor window to close it.

4. Save your work.

e (Click File menu » Save.

e Specify a name and location for your map.

Notice that map files use the file extension .dwg, just as
AutoCAD drawings do. Both file types use the same basic file

format.

e (lick Save.
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Where You Are Now

In the map, you can see the styled roads.
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AutoCAD Map 3D Tutorials >
Tutorial: Building a Map

Topics in this section

e About This Tutorial

e Lesson 1: Use Multiple Sources

e Lesson 2: Style Map Features

e Lesson 3: Change the Display by Zoom Level

e Lesson 4: Create Map Features

e Lesson 5: Find Objects

e Lesson 6: Edit Objects

e Lesson 7: Create a Legend

e Lesson 8: Publish Your Map

e Lesson 9: Branching Out - Finding Data Sources
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About This Tutorial

The lessons in this tutorial take you through the entire workflow of building and
publishing a map. You will use real data from the city of Redding, California. As
you work through the tutorial, you will do the following:

Start a map project by connecting to all the data stores needed by your
map. Data stores can include geospatial databases, spatial data files, such
as Shape (SHP) and SDF files, AutoCAD drawings (DWG files), and
raster images. Connecting to a data store makes the information in that
data store available to your map.

Style the objects in your map so you can easily identify them. Styles can
help you provide complex information quickly and intuitively. For
example, themed styles can show population density, water depth, or the
relative height of geographic features.

Edit objects in your map. In AutoCAD Map 3D, you can check out and
edit any type of object—geometry in a drawing file, a schema in an
ESRI SHP file, or geospatial data stored in an Oracle database—using
AutoCAD commands. You can then save the changes back into their
original format. You can also use the Data Table to change the properties
of geospatial data.

Publish the resulting map for display on a website. In this tutorial, you
publish to DWF format (for use with Autodesk Design Review). You can
also publish or export to Autodesk MapGuide, save your map as a static
web page, or package all the files needed to edit the file and transmit
them to another AutoCAD Map 3D user.
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Lesson 1: Use Multiple Sources

In the first set of lessons, you practice connecting to data from a variety of
sources.

Topics in this section

Exercise 1: Drag and drop a source file

Exercise 2: Attach a drawing file

Exercise 3: Query in data from the drawing

Exercise 4: Use Data Connect

Exercise 5: Add a raster image
Exercise 6: Display the raster image behind other features
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Exercise 1: Drag and drop a source file

Start by creating a new map file and adding the city boundaries of Redding to it.

To create a map and add a source file

1. Before you begin this tutorial, see Getting Ready to Use the Tutorials.
2. Create a new map file.

e Click File menu » New.

e Select the map2d.dwt template.

e Click Open.
3. Set the coordinate system for the map.

e Switch to Map Explorer in the Task Pane.

e Right-click Current Drawing and click Coordinate System.
e Enter CA-I and click OK.

4. Add the city boundaries to your map by dragging and dropping a source
file to Display Manager.

e Switch to Display Manager in the Task Pane.

e Use Windows Explorer to navigate to the folder in My Documents
where you copied the sample files.
Note The location of My Documents varies, depending on your
operating system. For Microsoft Windows XP, it is usually
C:\MyDocuments. For Microsoft Vista, it may be C:\Documents
and Settings\Administrator\My Documents\Map 3D Tutorials.



e Resize the AutoCAD Map 3D window and your sample data
folder window so you can see both of them at the same time.

e Drag and drop the City_Boundary.sdf file onto the lower area of
the Display Manager, just above the Map Base layer.

@\J" .« Map 3D... » b |‘ g Current Map: I B
TR — . = -
‘ Organize = o ]
LIS
Mame Date modifier * i Data Style Table G%I?ups 'E:I‘.
L Jp2K 2/22/2008 21 =
|| Assessor.mdb 2/6/2008 6:42 —_.-5.-—'—"! Map Base
@ Azcessor_Parcels.sdf 216/, il ,_%
TR e -—‘Tﬁ%u‘sz 2 g - e
Counties.dwg 2/10/2007 10: R
|| Counties.DWE 1/30/2008 7:4 i
Counties.dwl 1/30/2008 741 — :§ u
Counties.dwl2 1/30/2008 74 o a
|| DigitalGlobe_Munich.e... 1/25/2008 8:2 g E
__| DigitalGlobe_Munich.e... 1/14/2008 10:
DWGMap.dwg 2/10/2007 10: —l E
DWaMap_09.dwg 2/6/2008 6:46
|| ENTERPRISE.dem 5/30/2002 1:2
__| Munich_dtrm.dem 2/6/2008 6:49
@ Parcels.sdf 3/4/2006 12:4
RFDMIMNG DATASFT.AL..  1/73/7007 2.3 7
1 | m | 3
1 350 KB M Computer

Drag and drop the city boundary file to Display Manager.

The Redding city boundaries appear in your map.

5. Click File menu > Save. In your tutorials folder, name the file
BuildMap1.dwg and click OK.

To continue this tutorial, go to Exercise 2: Attach a drawing file.
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Exercise 2: Attach a drawing file

You can use Display Manager to attach an AutoCAD drawing file.

Note This exercise uses the BuildMap1.dwg map you created in the previous
exercise.

To attach an AutoCAD drawing file

1. If you have not already done so, copy the \Program Files\AutoCAD Map
3D 2009\Help\Map 3D Tutorials folder to My Documents.
Note The location of My Documents varies, depending on your operating
system. For Microsoft Windows XP, it is usually C:\MyDocuments. For
Microsoft Vista, it may be C:\Documents and Settings\Administrator\My
Documents\Map 3D Tutorials.

2. In the BuildMap1.dwg file, in the Task Pane, click the Display Manager
tab.

3. Click Data » Add Drawing Data » Attach Source Drawings.



Current Map: -

= 2, [

E E?} Connect to Data...
= ‘.ﬂ Mew Map...

u—j Mew Group
- E?} Mew Text Layer...

Bl z X

Load Layer...
£8 Bulk Copy...

i Topology...
1] Drawing Layer...
|£| Raster Image...

_[ Map Book IMapE}cpIorer ]Displa}rMan...

3 Query Current Drawing...
,i]'@-'_, Query Source Drawing...
Eﬁ' Query Topology...

10 Attach Source Drawings...

Use Display Manager to attach a drawing file.

. In the Define/Modify Drawing Set dialog box, click Attach.

. Navigate to the folder in My Documents where you copied the sample
files and select Counties.dwg.

Note The location of My Documents varies, depending on your operating
system. For Microsoft Windows XP, it is usually C:\MyDocuments. For
Microsoft Vista, it may be C:\Documents and Settings\Administrator\My
Documents\Map 3D Tutorials.

. Click Add and then click OK.

. In the Define/Modify Drawing Set dialog box, click OK to attach the
drawing file to your map.

When you attach a drawing, it is not listed in Display Manager and it
does not appear in your map. You must “query in” objects from the
drawing to use in your map. You will do that in the next exercise.

. Click File menu » Save to save your work.



To continue this tutorial, go to Exercise 3: Query in data from the drawing.
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 1: Use
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Exercise 3: Query in data from the drawing

The drawing file you attached is a map of California with polygons defined for
each county. Since the city of Redding is in Shasta County, you will add the
Shasta County boundaries to your map. You can query in data based on location,
properties, or data. In this case, query by the name of the county, which is stored
as object data.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.
To query in drawing data

1. In the BuildMap1.dwg file, in Display Manager, click Data » Add
Drawing Data » Query Source Drawing.

2. In the Define Query Of Attached Drawings dialog box, under Query
Type, click Data.

3. In the Data Condition dialog box, select the Object Data option.

4. In the Object Data Fields list, select NAME
Note Do not change the Tables setting.

5. Leave Operator set to = . For Value, enter Shasta.



Data Condition =™
(") Object Class @ Object Data
(") Object Properties () Attribute

(") Database Link

Tables:

col6_did -

Ohbject Data Fields:

AREA
CO06_D00_
CO06_D00_|
COUNTY
LSAD
LSAD_TRANS
MNAME
FERIMETER
STATE

Expression
Operatar: Value:

= - |Shasta |

[ ok | | Cancd | [ Hep |

Define the data condition for the query.

The query is case-sensitive. Be sure to enter it as shown.

6. Click OK in the Data Condition dialog box, and then click OK again to
execute the query.

7. Click View menu » Extents.

The Shasta county boundaries are now displayed in the map, and an
Attached Drawing Element layer is displayed in Display Manager.

8. Click File menu » Save to save your work.

Note You may see an alert as you work through the remainder of the tutorial,
warning you that the association between queried objects in the current and
attached drawings will not be retained once the current drawing file is closed.
This message reminds you to save back any changes you make to the original

drawing file. Since you will not edit the Shasta County drawing in this tutorial,
you can safely ignore the alert.



To continue this tutorial, go to Exercise 4: Use Data Connect.
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Exercise 4: Use Data Connect

Use Data Connect to connect your map to a file containing parcel data.

Use the Data Connect dialog box to attach any non-DWG data source: database
formats, such as ArcSDE, Oracle, or SQL Server; an ODBC source, such as
Microsoft Access; a raster file; web-based sources such as WMS or WFS; or
spatial data files, such as SDF and SHP.

Data Connect displays information about all attached non-DWG data sources,
even if you didn’t use Data Connect to attach them. For example, the SDF file
you dragged and dropped into your map is listed in the Data Connect dialog box.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To use Data Connect

1. If you have not already done so, copy the \Program Files\AutoCAD Map
3D 2009\Help\Map 3D Tutorials folder to My Documents.
Note The location of My Documents varies, depending on your operating
system. For Microsoft Windows XP, it is usually C:\MyDocuments. For
Microsoft Vista, it may be C:\Documents and Settings\Administrator\My
Documents\Map 3D Tutorials.

2. In the BuildMap1.dwg file, in Display Manager, click Data » Connect to
Data.

3. Under Data Connections By Provider, select Add SDF Connection.
4. Click the file icon next to Source File.

5. Navigate to the folder in My Documents where you copied the sample
files and select Parcels.sdf. Click Open.



6. Click Connect to add the parcel data file as a data source.

7. Under Add Data To Map, select Parcels.

The coordinate system for this feature class is displayed next to its name.
If this information was incorrect, you could click the current coordinate
system listing to see a down arrow and select a different coordinate
system.

Note Do this only if you know the original coordinate system for the
feature—do not change the coordinate system to match your map.
AutoCAD Map 3D converts each feature from its own coordinate system
into your current map’s coordinate system automatically. If you change
the coordinate system, the conversion may not be correct.

8. Click Add To Map.

b4 3
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In the Data Connect dialog box, connect to a data provider and then select the feature
class you want.

When you click Add To Mabp, a layer called Parcels is displayed in the
list in the Display Manager. A layer can be styled, saved, displayed, or
hidden, independent of other layers in your map.

9. Click File menu » Save to save your work.



To continue this tutorial, go to Exercise 5: Add a raster image.
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Exercise 5: Add a raster image

Photographs and other images formed of pixels are called raster images, while
images formed of lines and arcs are called vector images. Bring in an aerial
photograph to display behind the objects in your map. Real-world elements in
the raster image line up with the geometry in your map and make it easier for the
viewer to get a visual orientation.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To add a raster image

1. If you have not already done so, copy the \Program Files\AutoCAD Map
3D 2009\Help\Map 3D Tutorials folder to My Documents.

Note The location of My Documents varies, depending on your operating
system. For Microsoft Windows XP, it is usually C:\MyDocuments. For
Microsoft Vista, it may be C:\Documents and Settings\Administrator\My
Documents\Map 3D Tutorials.

2. In the BuildMap1.dwg file, the Data Connect window should still be
displayed. If it is not, open Display Manager. Click Data » Connect To
Data.

3. Under Data Connections By Provider, select Add Raster Image Or
Surface Connection.

4. Click the folder button next to Source File Or Folder.

5. Navigate to the folder in My Documents where you copied the sample
files, find the folder containing the JPEG 2000 raster files (originally
called JP2K), and select it. Click OK.



6. Click Connect to add the folder as a data source.

7. Under Add Data To Map, select the the j-05, j-07, 1-05, and 1-07 items.

The folder contains multiple JPEG 2000 files, each of which covers a
small area of the city of Redding.
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If your folder contains multiple images, select the ones you want.

8. Set the coordinate systems for the images.
¢ Click Edit Coordinate Systems.

¢ In the Global Coordinate System dialog box, click in the blank
field in the row labeled “Default” and click Edit.

e For Category, select USA, California.
e Under Coordinate Systems In Category, click CA-I.



e Click OK in both dialog boxes, to return to the Data Connect
dialog box.

All the images now show CA-I as their coordinate systems.

9. Select Combine Into One Layer, so you can style the raster images as a
single item in Display Manager.

10. Enter a name for the layer, for example, ReddingRasterImages.

11. Click Add To Map.

To see the results
1. Close the Data Connect dialog box.

2. Right-click the new raster layer and click Zoom To Extents.

fLEM _Lessonl ExGStart.dwg o [=] 3]

Current Map: |Default - &3
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Data Style Table Groups Tools

Display Manager
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Map Explorer
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- #ap Sare

E Default

To continue this tutorial, go to Exercise 6: Display the raster image behind other
features.




Please send us vour comment about this page



javascript:doComments('./html/ac.cmtdialog.htm');

AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 1: Use
Multiple Sources >

Exercise 6: Display the raster image behind other features

You want the raster image to provide context for the parcels in your map, but
right now it is hiding the parcels. Move the raster behind the parcels and set
transparency for the parcels so you can see the raster image.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To display the raster image behind other features

1. In the BuildMap1.dwg file, in the Display Manager menu bar, make sure
the fourth item reads Draw Order. If it reads Groups, click it and change
it to Draw Order.

S i) = it

Data Style Table |Groupg E_ Layers by Group

£ Draw Order

2. Drag the new raster layer just below the Parcels layer.

The list of layers is the draw order (Z-order) for your map. The item at
the top of the list is also at the top of the map’s Z-order. Dragging the
raster image below the Parcels layer places it behind that layer in your
map.

To see the raster layer behind the parcels, make the city boundary layer
white and make the parcels semi-transparent.

3. In Display Manager, select the City_Boundary layer.

4. Click Style to see the Style Editor.

Note If the Style Editor is docked, move your cursor over it to display it.
It may be docked at the left side of the application window.



5. In the Style Editor, in the Polygon Style For 0 - Infinity: Scale Range
section, click the Style entry.

6. Change the Foreground Color to white and click OK.

7. Without closing the Style Editor, select the Parcels layer in Display
Manager.

The Data Connect dialog box updates to show the values for the Parcels
layer.

8. In the Style Editor, click the Style entry again.

9. Move the Foreground Transparency slider to 50% and click OK.

Close the Style Editor. Right-click the Parcels layer and click Zoom To
Extents to see the results.

10. Save your map.

Where you are now

You have assembled all the raw materials for your map. The aerial photograph
provides context. The geometry from the DWG drawing shows the county
boundaries, and the SDF files add the city boundary and parcel outlines.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map >
Lesson 2: Style Map Features

In the Getting Started lesson, you changed the style for the roads in your map by
changing the color, thickness, and pattern for the lines representing roads.

In this lesson, you use themed styles to give the viewer an immediate sense of
the value of each parcel.

Topics in this section

e Exercise 1: Create a theme for the parcels layer

e Exercise 2: Define the theme
e Exercise 3: Add labels

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 2: Style Map
Features >

Exercise 1: Create a theme for the parcels layer

A theme uses a range of colors to represent an analogous range of values. You
can also use theming to show relative area, population density, water depth, or
height of geographic features.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To style the parcels layer with a theme
1. Open your finished map from the previous lesson.
e Click File menu » Open.
e Locate BuildMapl.dwg.
e Select it, and click Open.

2. Create a theme for the parcel layer.

A theme is a display style. Styles for geospatial features are assigned by
layer.

¢ In Display Manager, select the Parcels layer and click Style.
Note If the Style Editor is docked, move your cursor over it to
display it. It may be docked at the left side of the application
window.

¢ In the Style Editor, under Polygon Style For O - Infinity Scale
Range, click New Theme.
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Click New Theme to define a theme for the Parcels layer.

To continue this tutorial, go to Exercise 2: Define the theme.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 2: Style Map
Features >

Exercise 2: Define the theme

Tie the theme definition to the value of the parcels: lighter colors will represent
parcels with lower values and darker colors will represent parcels with higher
values. The parcel value is the "condition" used to determine the color of the
parcel in the map.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To define the theme

1. In the Theme Polygons dialog box, under Create Thematic Rules Based
On A Property, click the down arrow next to Property and select
LAND_VALUE. Leave the minimum value, maximum value, and
distribution settings as they are.
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Use the Theme Polygons dialog box to design your theme.

. Under Theme The Polygons, click (] next to the illustration of the Style
Range.

. Set Foreground transparency to 50% so you can continue to see the
raster image below the parcels.

. For Foreground Color Range, select colors from the color boxes under
From and To.

. Experiment with line thickness and color, if you like.
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Set transparency, colors, and line attributes for the theme.

6. Click OK.

To continue this tutorial, go to Exercise 3: Add labels.
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 2: Style Map
Features >

Exercise 3: Add labels

Add a label for each parcel, based on its land value.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To add labels

1. In the Style Editor, select Create Feature Labels and click () next to the
picture of the Label Ramp.
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Select the property whose data will be displayed in the labels.

. In the Style Label dialog box, for Property To Display, select
LAND_VALUE. Leave the other settings at their current values for now.

. Click OK to close the Style Label dialog box. Click OK again to apply
the theme to your map.

. Close the Style Editor so you can see your map again.

. Use the Zoom Window tool to zoom in so you can see the labels.
Tip The smaller you draw the zoom window, the larger the magnification

will be.



6. Save your map.

Where you are now

Themed parcels with labels

In the map, the parcels are colored to represent their relative values, which are
displayed as labels on each parcel.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map >
Lesson 3: Change the Display by Zoom Level

Use styles to make objects display differently, depending on the viewer's zoom
level. In this example, when the viewer is zoomed in, roads are dark gray with a
dashed yellow centerline. When the viewer zooms out, the roads display as solid
black. When the viewer zooms out far enough, roads are not displayed at all.

Topics in this section

e Exercise 1: Add roads to your map

e Exercise 2: Create a composite road style

e Exercise 3: View styles at different zoom levels

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 3: Change the

Display by Zoom Level >

Exercise 1: Add roads to your map

Add roads to your map and assign several styles to them, with each style
displaying at a different zoom level.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To add roads to your map

1.

If you have not already done so, copy the \Program Files\AutoCAD Map
3D 2009\Help\Map 3D Tutorials folder to My Documents.

Note The location of My Documents varies, depending on your operating
system. For Microsoft Windows XP, it is usually C:\MyDocuments. For
Microsoft Vista, it may be C:\Documents and Settings\Administrator\My
Documents\Map 3D Tutorials.

Open your finished map from the previous lesson.

e Click File » Open.
e Locate BuildMapl.dwg.
e Select the map, and click Open.

In the Task Pane, switch to Display Manager .

In the menu area, click Order and change it to Groups.

Use Windows Explorer to navigate to the folder in My Documents where
you copied the sample files.

Resize the AutoCAD Map 3D window and the sample data folder



window so you can see both of them at the same time.

8. Drag and drop the Roads.shp file to the lower area of Display Manager,
just above the Parcels layer.

To continue this tutorial, go to Exercise 2: Create a composite road style.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 3: Change the
Display by Zoom Level >

Exercise 2: Create a composite road style

Create a composite style to combine two line styles to form a realistic-looking
road style. The composite style is displayed when you zoom in to a certain scale
range in your map, but a simpler style is displayed when you zoom out.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To create a composite style

1. In Display Manager, select the Roads layer and click Style.

Note If the Style Editor is docked, move your cursor over it to display it.
It may be docked at the left side of the application window.

2. In the Style Editor, click the Style field.

3. In the Style Line dialog box, click Create Composite Lines.
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Use the Create Composite Lines link to combine line styles.

For Thickness, select 0.2, and for Color select a dark gray.

Click New to create the second part of the line style.

Create a
composite
line
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The Build Up Composite Styles area displays the styles you added up to now.

6. Select a bright yellow for Color and a dotted option for Pattern.

Notice that the preview now displays a dark gray line with a dashed
yellow line inside it.

A composite line for roads

7. Click OK.

Now define scale ranges and assign styles to them. Each scale range
represents the zoom levels at which a style is displayed. When you are
zoomed between the levels of a range, the style for that range is
displayed.

8. In the Scale Ranges area at the top of the Style Editor, click the word



“Infinity” and enter 30000 to replace it.

The composite style you just created appears for this range.

Set up zoom levels
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Far each zoom level, create a line style

Set up zoom levels and assign a style to each one.

9. Define a scale range and specify a solid line style for it.
When the zoom level is within this range, the roads will be displayed as

solid lines.

e Click Add A Scale Range.

Set the range to go from 30000 to 50000.

Reset the style to a single line.

Change the color to black.

Click the Style field in the bottom area of the Style Editor.



e Select a solid pattern (at the top of the list).
e Set the line thickness to .05.
e Click OK.

10. Define another scale range so that no styling is applied to the roads when
you zoom out to a distant view.

¢ Click Add A Scale Range again.
e Set the new range to go from 50000 to infinity.
e Click the Style field in the bottom area of the Style Editor.

e Clear the Apply Styles To The Line check box at the top of the
Style Line dialog box.

e Click OK.

The style for this scale range is now None. When you zoom out to a
distant view, you won’t see the roads.

11. Close the Style Editor.
12. Save the file.

To continue this tutorial, go to Exercise 3: View styles at different zoom levels.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 3: Change the
Display by Zoom Level >

Exercise 3: View styles at different zoom levels

Zoom to different scales in your map to see the different line styles.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To see the styles at different zoom levels

1. In the BuildMap1.dwg file, use the Zoom Window tool to zoom in so
you can see the labels and the composite lines.

Tip The smaller you draw the zoom window, the larger the magnification
will be.

2. Zoom out to see thinner black lines for the roads.
3. Zoom out even farther until the roads are not displayed.

4. Save your map.

Where you are now



At a scale of 1:10000, the roads display the composite style.

In the map, the roads are themed to display appropriately at different zoom
levels.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map >

Lesson 4: Create Map Features

Use the powerful editing abilities of AutoCAD to draw new features.

Topics in this section

e Exercise 1: Draw a new parcel

e Exercise 2: Add information about the new parcel

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 4: Create Map
Features >

Exercise 1: Draw a new parcel

When you draw a new feature, it is automatically added to the layer from which

it was created. The source for that layer is updated to include the feature you
added.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To create a new feature
1. If it is not still open, open your map from the previous lesson.
e Click File menu » Open.
e Locate the BuildMap1.dwg file.
e Select it, and click Open.

In the Task Pane, switch to Display Manager .

Right-click the Parcels layer.

Click Zoom to Extents.

A L R

Right-click the Parcels layer again and click Create » Create New
Polygon Parcels.
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Create a new feature on an existing layer.

Click a starting point in the map for the new parcel.

Click an area on the border of the city.

Click three more points to define the beginning of the parcel and its first
three sides.

Press the down arrow on your keyboard to see a menu of choices in the
dynamic input line.

Press the down arrow again until a dot is displayed next to Close,
showing that it is selected.



Specify next point or (& <0

Arc

® Close
Length
Undo

Use dynamic input to draw the parcel.

10. Press Enter to close the polygon.

11. Select Exit from the dynamic input menu to complete the command.

The parcel is complete and the Data Table is displayed.

Note If the Data Table is docked, move your cursor over it to display it. If
the Data Table does not display automatically, select the Parcels layer in
Display Manager and click Table.

To continue this tutorial, go to Exercise 2: Add information about the new
parcel.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 4: Create Map
Features >

Exercise 2: Add information about the new parcel

In the Data Table, add information about this parcel.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To add information about the new parcel
1. Click in the new blank row in the Data Table.

2. Fill in the data fields for this parcel.

Look at the other entries to see what a logical entry would be for each
column.

3. Right-click the parcel in the map and click Check-in Feature.

The original data source is updated with your changes.

4. Save your map.

Where you are now

32636 -999009 Mot_Assigned Easement 0135 5801.408
32637 -999009 Mot_Assigned Easement 0031 1368554
32638 -999009 Mot_Assigned Easement 0.028 1199.819
32639 <MNull> <MNull> <MNull> <MNull> <MNull>
32640 <MNull> <MNull> <MNull> <MNull> <MNull>
= 32641 <MNull> <MNull> <MNull> <MNull> <Null> [ ]
'r—r: b:z7 <Mull> 12345 Maple St. Easernent 5.29] <Null= 7
E 1 | 1] k
K Row 32642 of 32642 | 0 Selected  Search to Select Options -

A new Data Table entry



You have added a new parcel and updated the parcel data to reflect your
changes.
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map >
Lesson 5: Find Objects

Use the Data Table to find objects that match certain criteria. Then, use the Data
Table to zoom in to that area of your map.
Topics in this section

e Exercise 1: Display the Data Table
e Exercise 2: Filter the Data Table

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 5: Find
Objects >

Exercise 1: Display the Data Table

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

Display the Data Table for any layer.

To display the Data Table
1. If it is not still open, open your finished map from the previous lesson.
e Click File menu » Open.
e Locate the BuildMap1.dwg file.
e Select it and click Open.

2. In the Task Pane, switch to Display Manager.

3. In Display Manager, select the Parcels layer and click Table.

4. If the Data Table is docked against the left side of the application
window, move your cursor over it to see its contents.

To continue this tutorial, go to Exercise 2: Filter the Data Table.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 5: Find
Objects >

Exercise 2: Filter the Data Table

Filter the Data Table to show a subset of parcels—in this case, only parcels on
Villa Drive.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To filter the Data Table

1. In the Data Table, in the Filter By list, select the STNAME field and
enter VILLA DR into the field.

The field is case-sensitive, so be sure to enter all capital letters. Do not
spell out the word “Drive.”

2. Click Apply Filter to show only parcels on Villa Drive.
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Select a parcel and choose Zoom To
from the Options list

Use the Data Table to filter the parcels you see.

Make sure Auto-Zoom is on.

This button is a darker color when it is on; otherwise, it is the same color
as the window.

Click in a parcel’s dark-gray, left-most field to select that parcel.

Note You may need to scroll the Data Table to the left to see the left-most
fields.

AutoCAD Map 3D scrolls to the selected parcel and displays it to the
right of the Data Table.

Make a note of the number in the Autogenerated_SDF_ID field, because
you will need to use it again later.

Close the Data Table.

Note You can do a more sophisticated search by clicking Edit menu »
Search. That option lets you query a layer with a Boolean condition—for
example, ACRES > 1 to find parcels that are larger than an acre. The
map then shows only the objects that match your query.



7. Save your map, but leave it open for the next lesson.

Where you are now

You used the Data Table to zoom to a parcel.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map >
Lesson 6: Edit Objects

Edit objects and then update their original data stores.

Topics in this section

e Exercise 1: Check out and edit a feature

e Exercise 2: Update information for the edited feature

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 6: Edit
Objects >

Exercise 1: Check out and edit a feature

If AutoCAD Map 3D is set to check in your changes automatically, the source
file will update while you edit. This might result in inadvertent changes to the
data store. The safest way to edit geospatial data is to turn off automatic update
feature before you edit a feature. Once you make your changes, check the feature
in to update the data store with your changes and make the feature available to
others again.

When you edit a feature, that feature is automatically checked out and locked for
editing by anyone else (if the data format supports such locking). Other people
can view the feature source, but they cannot change it until you check it back in.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To edit an object

1. If you closed your finished map from the previous lesson, re-open it and
display the Data Table for the Parcels layer.

e Click File » Open.

Locate the BuildMap1.dwg file.

Select it, and click Open.

In the Display Manager, click the Parcels layer and click Table.

Zoom to a parcel on Villa Drive.



The parcel is checked out automatically and displays grips.
2. To turn off the automatic update option, click Edit menu and make sure
there is no check mark next to Update Edits Automatically.

3. Use the grips to change the size and shape of the parcel, just as you
would any AutoCAD polygon.

4. When you finish, click Edit menu » Check-In.

To continue this tutorial, go to Exercise 2: Update information for the edited
feature.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 6: Edit
Objects >

Exercise 2: Update information for the edited feature

Use the Data Table to find the entry for the parcel you edited, and change its
information. When you edit a feature (whether in the map or in the Data Table),
you automatically check it out. Check in the feature to update its source with
your changes.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To edit the feature information

1. Redisplay the Data Table for the Parcels layer.

Select the Parcels layer and click Table, or right-click the Parcels layer
and click Show Data Table.

2. In the Data Table, select Autogenerated_SDF_ID from the Filter By list
and enter the parcel ID number you noted earlier (the one you just

edited).
3. Click Apply Filter to filter the list and see the parcel entry.
4. Change the area of the parcel and close the Data Table.

5. To update the information in the data source, Click Edit menu » Check-
In.

The information is now available to other users.

6. Save your map.

Where you are now

You edited a parcel and updated its data to reflect your changes. You checked in



the feature to update the source file.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map >
Lesson 7: Create a Legend

Create a legend that lists the layers in your map, using a color key that identifies
each one. The legend is an object that you drop into place on your map.

Fine-tune the legend to show only the layers you want, in the order in which you
want them (even if this order is different from your draw order).
Topics in this section

e Exercise 1: Insert a legend object

e Exercise 2: Change the order of items in the legend

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 7: Create a
Legend >

Exercise 1: Insert a legend object

Insert a legend anywhere on your map.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To insert a legend in your map
1. If it is not still open, open your finished map from the previous lesson.
e Click File » Open.
e Locate the BuildMap1.dwg file.
e Select it, and click Open.

2. In the Task Pane, switch to Display Manager.

3. Select the Parcels layer, right-click and click Zoom To Extents.
4. Click Tools » Create Legend.
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Use the Tools menu in Display Manager to create a legend.

5. In your map, find a blank area for the legend.

6. Click where you want the legend to appear.

Notice that each layer listed in Display Manager is displayed in the
legend automatically, with its identifying color. The items are listed in
the order in which they appear in Display Manager.

7. Save your map.

Where you are now

You added a legend to your map.

To continue this tutorial, go to Exercise 2: Change the order of items in the
legend.




Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 7: Create a
Legend >

Exercise 2: Change the order of items in the legend

The legend reflects the organizational order in your map. You can move items in
Display Manager to change their order in your legend. You can also turn layers
off to prevent them from appearing in the legend.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To change the order of items in the legend

1. In the Display Manager menu area, click Groups » Draw Order.

Notice that the option name changes to Order, to show that you are now
viewing by draw order.

2. Drag an item to a different position.
The change in your legend is not visible yet.

The parcel layer has multiple entries (one for each level in the theme that
you created for it). Notice that the legend also includes the Map Base
layer, which doesn’t belong in a legend.




The default legend includes the Map Base layer.

3. In Display Manager, clear the check box for the Map Base layer.
4. Click Tools » Update Legend.

5. Save your map.

Where you are now

You removed the reference to the Map Base layer from the legend, and the
legend now reflects the new organizational order.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map >
Lesson 8: Publish Your Map

Publish a georeferenced map in DWF format, for eventual display on the Web or
on an intranet. DWF (Design Web Format™) is an open, secure file format
developed by Autodesk for sharing engineering design data. DWF files are
highly compressed, so they are smaller and quickly transmitted and viewed. This
format can include object data or feature attributes, as well as the graphical
elements of your map.

As long as you have assigned a coordinate system to all the model-space maps in
your DWF file, the publishing operation will automatically convert the
coordinate information to latitude/longitude coordinates. Autodesk Design
Review 2008 can automatically navigate to a specific location when you enter
coordinates, and displays coordinates of any location in the map when you move
your mouse over that location. When your computer is integrated with a GPS
device that uses the NMEA 0183 protocol, field workers can center the map to
the coordinates provided by the integrated GPS device on your system, and
display the “my coordinates” icon within the map.

Files in DWF format can be displayed using Autodesk® Design Review. For
product information and a download link for this product, refer to the Autodesk
Design Review page on the Autodesk website. Autodesk Design Review is the
latest version of the Autodesk® DWF Viewer, and includes the ability to
measure, mark up, stamp, review, convert, and aggregate DWF content.

Topics in this section

e Exercise 1: Specify attributes to include
e Exercise 2: Publish to DWF

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 8: Publish
Your Map >

Exercise 1: Specify attributes to include

Set DWF publishing options that specify the attribute information to publish
with your map.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To set publishing options
1. Open your finished map from the previous lesson.
e Click File menu » Open.
e Locate the BuildMap1.dwg file.
e Select it, and click Open.
2. Click File menu » More Plotting Options » DWF Publishing Options.
3. In the Map Information dialog box, select Publish Map Information.

4. In the Map Information dialog box, expand the items in the list and
select the Roads and Parcels items.
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You can include and exclude information at any level.
Notice that when you select Roads, everything under Roads is
automatically selected.

5. To publish the information to an XML file, click the file icon and specify
a location for the published file. Click Save.

The XML file will be used by the DWF Publish operation.
6. Click OK.

To continue this tutorial, go to Exercise 2: Publish to DWF.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 8: Publish
Your Map >

Exercise 2: Publish to DWF

Publishing to DWF is like printing to a file. You must set up plotting parameters
just as you would if you were printing to a physical plotter. You apply those
settings to your layout, which is like a plotting template. You display a layout tab
for your map to activate the layout.

Each view of your map (which initially includes model space and two default
layout spaces) is considered a sheet in your map sheet set. Learn more about
sheet sets in the Help.

Use the Publish dialog box to specify the sheets to publish and whether to
publish to a plotter or a file.

Note This exercise uses the BuildMap1.dwg map you created and modified in the
previous exercises.

To publish to DWF
1. Save your map.
You cannot plot or publish without saving first.
2. Click File menu > Plot.
3. In the Plot dialog box, select a Printer/Plotter.

4. Click Apply To Layout, and then click Cancel.

Printer/plotter settings are applied to your publishing job without
sending the job to a plotter or printer.

5. If Model and Layout tabs are not displayed just below your map, right-
click & in the status area at the bottom of the application window and
click Display Model And Layout Tabs.



6. Click the Layout 1 tab.
7. Click File menu » More Plotting Options » Publish To DWF.

8. In the Publish dialog box, in the Sheets To Publish list, make sure that
only the sheets you want are selected.

For example, if another map is open, its model and layout views will
appear in the list. The default Layout2 view of the current map also
appears. Select any undesired entries (such as Layout2) and click
Remove Sheets.

9. Under Publish To, click DWF File.

10. Click Publish Options and click Layer Information (under DWF Data
Options). On the pull-down menu in this field, click Include.

This specifies that each layer in your map will be published to a separate
layer in DWF. In Design Review, you can turn the display of these layers
on and off independently.

11. Click OK to close the Publish Options dialog box.
12. In the Publish dialog box, click Publish (at the bottom of the window).
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Set up the sheets to publish and select a publishing format.

13. Specify a location and a name for the published file and click Select.




14. If you are prompted to save the sheet list, click No.

15. You may see a message telling you that the job is processing in the
background. Click OK to dismiss the message.

The files needed by Autodesk Design Review are published to the file
you specified. Monitor the progress of the publishing operation by
holding your cursor over the animated icon in the lower-right corner.

ISﬁ QIE “El’j.@} ﬁ“Ev DE
When the job is complete, click the link in the bubble that appears in the

bottom, right-hand corner of the window to view any warnings or errors.
Close the window when you are done.

Where you are now

You have published your map to a DWF file, which can be displayed in
Autodesk Design Review.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map >
Lesson 9: Branching Out - Finding Data Sources

As you go on to create your own maps, you will want to add data to enhance
them. For example, you may want surface rasters with elevation data for your
area, or generic vector symbols showing parks, hydrants, or other items.

The Autodesk geodata portal has access to multiple data providers. In this
lesson, you’ll explore the geodata portal and look at some sample data provided
with AutoCAD Map 3D by the data providers who have partnered with
Autodesk.

Topics in this section

e Exercise 1: Exploring the Data Portal - DigitalGlobe®

e Exercise 2: Exploring the Data Portal - NAVTEQ™

e Exercise 3: Exploring the Data Portal - Intermap™

e Exercise 4: Trying Out the Sample Data

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 9: Branching
Out - Finding Data Sources >

Exercise 1: Exploring the Data Portal - DigitalGlobe®

In this exercise, you’ll visit the geodata portal and view the data available from
DigitalGlobe®.

To explore the DigitalGlobe data

1. In your browser, go to http://www.autodesk.com/geodata.

2. On the geodata site, click Go Now for DigitalGlobe.

3. Click the image of the Verrazano Narrows Bridge in Brooklyn, New
York to see the high-resolution satellite photo.



http://www.autodesk.com/geodata

DigitalGlobe® has an exhaustive library of high-quality Earth imagery available for
purchase.

. To try out some of DigitalGlobe’s data, click Download Your Free Trial
and follow the directions on the screen.

Once you've installed DigitalGlobe and you start AutoCAD Map 3D,
you should see a new ImageConnect menu on the menu bar.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 9: Branching
Out - Finding Data Sources >

Exercise 2: Exploring the Data Portal - NAVTEQ™

In this exercise, you’ll view the data available from NAVTEQ™.

To explore the NAVTEQ data

1. Close the DigitalGlobe® window and display the Geospatial Solutions
page in your browser window.

If you are not already at the Geospatial Solutions page, in your browser,
go to http://www.autodesk.com/geodata.

2. On the Geospatial Solutions page, click Go Now for NAVTEQ.

3. Click the image of the city of Redding, California, to see the digital map.
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NAVTEQ™ street geometry includes street networks, block address ranges, a Point of
Interest (POI) database, administrative area boundaries, railroads, hydrological data, and
land use information.


http://www.autodesk.com/geodata

4. To try out some of NAVTEQ’s data, click Download Free Sample and
follow the directions on the screen.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 9: Branching
Out - Finding Data Sources >

Exercise 3: Exploring the Data Portal - Intermap™

In this exercise, you’ll view the data available from .

To explore the Intermap data

1. Close the NAVTEQ™ window and display the Geospatial Solutions
page in your browser window.

If you are not already at the Geospatial Solutions page, in your browser,
go to http://www.autodesk.com/geodata.

2. On the Geospatial Solutions page, click Go Now for Intermap.

3. Click the Digital Elevation Models image to see information about DEM
topographic layers.

Intermap™ provides digital surface models, digital terrain models, orthorectified radar
images, and color orthorectified radar images.


http://www.autodesk.com/geodata

4. Close the browser windows.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Building a Map > Lesson 9: Branching
Out - Finding Data Sources >

Exercise 4: Trying Out the Sample Data

Sample data from each of these providers is included with AutoCAD Map 3D. In
this exercise, you’ll add some of this data to a map of the city of Munich,
Germany

To work with the sample data
1. Create a new map.
e (Click File menu » New.
e In the Open dialog box, select the map2d.dwt template.

e In Map Explorer, right-click Current Drawing and click
Coordinate System.

¢ In the Assign Global Coordinate System dialog box, for Code, set
the coordinate system to LL.84 and click OK.

2. Connect to a surface graphic.
e In Display Manager, click Data » Connect To Data.

¢ In the Data Connect dialog box, under Data Connections By
Provider, click Add Raster Image or Surface Connection.

e (Click the file icon next to Source File Or Folder.

e In the Open dialog box, navigate to the Intermap
Munich_dtm.dem raster file.

e Select the file and click Open.

¢ In the Data Connect dialog box, click Connect.



¢ In the Data Connect dialog box, select the image and click Add
To Map.

3. Style the surface image.
¢ In Display Manager, select the surface layer.

¢ On the status bar at the bottom of the application window, click
the down arrow next to Vertical Exaggeration.

¢ Increase the vertical exaggeration to 25x.

¢ In Display Manager, with the surface layer still selected, click
Style.

e In the Style Editor, click the down arrow in the Style cell and
select Theme.

¢ In the Theme dialog box, select Palette and select the Contour
Palette.

e Click OK, then click Apply and close the Style Editor.
4. Connect to a satellite image of Munich.

e If the Data Connect window isn’t displayed, in Display Manager,
click Data » Connect To Data.

e In the Data Connect dialog box, under Data Connections By
Provider, click Add Raster Image or Surface Connection.

e (lick the file icon next to Source File Or Folder.

¢ In the Open dialog box, navigate to the DigitalGlobe munich.ecw
raster file.

e Select the file and click Open.
¢ In the Data Connect dialog box, click Connect.

¢ In the Data Connect dialog box, select the image and click Add
To Map.

5. Style the satellite image.

¢ In Display Manager, right-click the image layer and click Zoom



To Extents.

In Display Manager, with the image layer still selected, click
Style.

In the Style Editor, click Transparent.

Click Select and select a dark gray color in the raster image to be
transparent.

6. Connect to a Navteq SHP file to add points representing restaurants.

In Display Manager, click Data » Connect To Data.

In the Data Connect dialog box, under Data Connections By
Provider, click Add SHP Connection.

In the Data Connect dialog box, click the file icon next to Source
File Or Folder.

In the Open dialog box, navigate to the Navteq Restrnts.shp file.
Select the file and click Open.
In the Data Connect dialog box, click Connect.

Select Restrnts and click Add To Map.

7. Style the points to use symbols.

In Display Manager, select the Restrnts layer and click Style.
In the Style Editor, click () in the Style cell.
In the Style Point dialog box, click () next to Symbol.

In the Select A Symbol dialog box, click () next to Symbol
Library and open the Map - Points of Interest.dwg file.

Select the Restaurant symbol.

If you want, in the Style Editor, change the Fill Color and Edge
Color of the points so you can see them better.

Click OK and close the Style Editor.



Where you are now

You explored the geodata portal and used sample data from Autodesk’s partner
providers to create a map of Munich using a surface with elevation, a satellite
photo, and symbols representing restaurants.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials >
Tutorial: Analyzing Data Using Styles, Joins, and Buffers

Topics in this section

e About the Analyzing Tutorial
e Lesson 1: Analyzing Data Visually, Using Surfaces

e Lesson 2: Analyzing Data With External Information Using Joins

e Lesson 3: Analyzing Data by Proximity Using Buffers
e Lesson 4: Creating a report

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and

Buffers >

About the Analyzing Tutorial

Use AutoCAD Map 3D to analyze data in many ways. This tutorial demonstrates
three of them:

Analyze data visually, using surfaces.

Connect to a surface (DEM) image and style it using a theme to show
relative elevation. Then, connect to a file that shows parcel information
and make the parcels semi-transparent so you can see the raster image
below them. The elevation theme of the raster helps you see the
elevation of the parcels.

Analyze data with external information sources, using joins.

Join a Microsoft Access database to the parcels layer in the map to see
information about the parcel owners. Using joins, you combine data
sources temporarily, without altering the original data stores. Use the
combined data as though it were a single data source—for example, style
a layer based on its joined data, even though the joined data is not part of
the original layer data store. Create calculated fields using native and
joined data.

Analyze data by proximity, using buffers.

Define a buffer around a street in Redding to see which parcels lie within
a construction zone. Select the parcels that adjoin the buffer and save
them separately so you can notify their owners, using the owner
information you joined to the parcels.

Export relevant data to a comma-separated file that you can import into
Microsoft Excel or Access. Use that data to create a report to send to the
owners.



Please send us vour comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers >

Lesson 1: Analyzing Data Visually, Using Surfaces

Use the Data Connect dialog box to connect to a DEM file and style it to show
the elevation information it contains.

Topics in this section

e Exercise 1: Prepare your map file

e [Exercise 2: Add a surface to view elevation data

e Exercise 3: Add a layer on top of the surface

e Exercise 4: Drape a parcel layer on top of the surface

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers > Lesson 1: Analyzing Data Visually, Using Surfaces >

Exercise 1: Prepare your mabp file

Create a new map file and assign a coordinate system. Color the map
background white so you can better distinguish features when you use color to
style them. All maps you create from now on will use the new background color.

To create a new map file

1. If you have not already done so, copy the sample files for the tutorials to
a directory on your hard drive.

2. Start AutoCAD Map 3D and create a new map using the map2d.dwt
template.

3. Assign a coordinate system to the new map.
e Switch the Task Pane to Map Explorer.

e Right-click the Current Drawing entry and click Coordinate
System.
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Set the coordinate system for the map in Map Explorer.

e Specify the CA-I coordinate system.

4. Click File menu » Save. In your tutorials folder, name the file
AnalyzeMap1.dwg and click OK.

To change the map background color

—_

. Click Setup menu » AutoCAD Options.
. In the Options dialog box, click the Display tab.

. On the Display tab, in the Window Elements area, click Colors.

. Under Interface Element, select Uniform Background.

2
3
4. Under Context, select 2D Model Space.
5
6. Under Color, select White.

7

. Click Apply & Close, and then click OK.

To continue this tutorial, go to Exercise 2: Add a surface to view elevation data.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers > Lesson 1: Analyzing Data Visually, Using Surfaces >

Exercise 2: Add a surface to view elevation data

A surface is a raster file that contains elevation information. Use theming to
make the surface reflect its elevation.

Note This exercise uses the AnalyzeMap1.dwg map you created in the previous
exercise.

To add a surface to the map
1. Switch the Task Pane to the Display Manager.
2. In the Display Manager, click Data » Connect To Data.

3. In the Data Connect dialog box, under Data Connections By Provider,
click Add Raster Image Or Surface Connection and click = next to
Source File Or Folder.

4. In the Open dialog box, browse to the ENTERPRISE.dem file, select it,
and click Open.

This file should be in the location where you copied the sample data.
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Connect to the surface file in the Data Connect dialog box.

5. In the Data Connect dialog box, click Connect.

Note The coordinate system for the DEM file is UTM27-10. AutoCAD
Map 3D automatically converts the data from that coordinate system to
the one specified for your map.

6. Select the box for the DEM under Add Data To Map and click Add To
Map.

7. Close the Data Connect dialog box to see the surface in your map.

To style the surface

1. In Display Manager, select the ENTERPRISE layer, which contains the
surface.

P4

2. Click 5wk,
3. Create a palette for the theme.

¢ In the Style Editor, under Raster Style For O - Infinity Scale
Range, click the down arrow in the Style entry and select Theme
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Click the first Style entry and select Theme.

In the Theme dialog box, under Specify A Theme, click Palette
and select USGS National Map Palette.
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Select the USGS National Map palette as the theme for the surface.

e Click OK and then click Apply. Close the Style Editor.

4. Add exaggeration to show the differences in elevation more
dramatically.

¢ In the status bar below your map, click the down arrow next to
Vertical Exaggeration.

e Select 25x from the list.
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Set the Vertical Exaggeration to 25x.

5. Add contour lines to create a topographic map.

Each contour line connects points of equal elevation on the surface. The
lines identify the elevation at a specific location on the surface, which
can help the viewer clarify and analyze the 3D surface terrain.

e In Display Manager, right-click the surface layer and click Create
Contour Layer.
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In Display Manager, right-click the surface layer to create contours.

In the Generate Contour dialog box, in the Contour Elevation
Interval list, select 20.

Leave the Units set to Meters.

In the Major Contour Every list, select 4. This makes every fourth
contour line bold.

Select Label The Elevation. This labels the major (bold) contour
lines only.

For Create Contour As, select polyline.
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Mew contour layer name:
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The Generate Contour dialog box should look like this.

e Click OK.

Note To label the intervening contour lines, use the Style Editor to change the
style for the new contour layer (not the surface layer itself). Select the contour
layer in Display Manager and click Style. In the Style Editor, click the down
arrow next to the Feature Label entry for "IsMajor=False," select Elevation as
the Property for the label, and click OK. You can also use this method to change
the color or style for the contour lines.

To continue this tutorial, go to Exercise 3: Add a layer on top of the surface.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers > Lesson 1: Analyzing Data Visually, Using Surfaces >

Exercise 3: Add a layer on top of the surface

When you add a vector feature to a map containing a 3D surface and then
display the map in 3D, AutoCAD Map 3D automatically drapes the vector on the
3D surface.

Note This exercise uses the AnalyzeMap1.dwg map you created and modified in
the previous exercises.

To add roads to the map
1. In Display Manager, click Data » Connect To Data.

2. In the Data Connect dialog box, under Data Connections By Provider,
select Add SHP Connection.

3. Click [2] next to the Source File field and navigate to the folder where
you copied the sample files.

4. In the Open dialog box, select ROADS.SHP and click Open.
5. In the Data Connect dialog box, click Connect.

6. In the Data Connect dialog box, select the Roads layer under Add Data
To Map and click Add To Map.

7. Close the Data Connect dialog box.

To style the roads in the map
1. In Display Manager, select the Roads layer and click Style.
2. In the Style Editor, click the Style entry.
3. In the Style Line dialog box, change the road color to dark gray.



4. Select a dashed pattern for the lines.

Apply styles to the line
Creste composite lines

Inits (Device space): Centimeters -
Thickness: —0 -
Color; B 175,175,175 *
Pattern: — —arma— T
Preview

Select a dark gray, dashed pattern for the roads.

5. Click OK and close the Style Editor.




Your map now contains the styled surface and road layers.

To continue this tutorial, go to Exercise 4: Drape a parcel layer on top of the
surface.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers > Lesson 1: Analyzing Data Visually, Using Surfaces >

Exercise 4: Drape a parcel layer on top of the surface

Now, add a layer that displays parcels in one part of the city of Redding. This
layer contains size, value, and address information about the parcels. It does not
contain information about the owners. You will join to a data source that
contains that information later.

You will make the parcels semi-transparent so you can see the other features
underneath.

Note This exercise uses the AnalyzeMap1.dwg map you created and modified in
the previous exercises.

To add the parcel layer to the map
1. In Display Manager, click Data » Connect To Data.

2. In the Data Connect dialog box, under Data Connections By Provider,
click Add SDF Connection.

3. Click [Elnext to the Source File field and navigate to the folder where
you copied the sample files.

In the Open dialog box, select Assessor_Parcels.SDF and click Open.
In the Data Connect dialog box, click Connect.
Select the Parcels layer under Add Data To Map and click Add To Map.

Close the Data Connect window.

®© N o Uk

In Display Manager, select the Parcels layer and click Table.

Information associated with the parcels is displayed, but the information
does not include owner-related data.
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Data associated with the parcel layer is displayed.

9. Close the Data Table.

To style the parcels in the map

1. In Display Manager, select the Parcels layer and click Style.
2. In the Style Editor, click the color in the Style entry.

3. In the Style Polygon dialog box, change the Foreground Transparency

setting to 50%.

4. Change the Foreground Color to a light shade.
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Change the foreground transparency for the parcel layer.

5. Click OK and close the Style Editor.

The parcel layer is draped over the surface. Because it is transparent, you
can see the surface underneath.

Where you are now

You added a surface that contains elevation information, and you used that
information to create a theme that varies color by elevation. You added contour
lines to identify the elevation levels. You draped a layer of data over the surface
and made it transparent so you could evaluate its elevation based on the surface
below.



The styled surface helps you evaluate parcel elevation.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers >

Lesson 2: Analyzing Data With External Information
Using Joins

Join the parcels layer to a Microsoft Access database that contains owner
information.

To connect to an Access database from AutoCAD Map 3D, you must first set up
an ODBC connection for that database using a control panel in Windows. Then,
connect to this source using Data Connect, just as you connected to the physical
data sources in your map. The database source contains a field that you can
match to a field in the Parcels layer, so you can join the data to the parcels and
style or analyze all the resulting data seamlessly.

Topics in this section

e Exercise 1: Set up an ODBC connection for an Access database

e Exercise 2: Connect to the Access database

e Exercise 3: Join the data from the ODBC source to the layer containing
the parcels

e Exercise 4: Use the joined data for calculated fields and styles

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and

Buffers > Lesson 2: Analyzing Data With External Information Using Joins >

Exercise 1: Set up an ODBC connection for an Access
database

Set up an ODBC connection for the Access database using the Administrative
Tools control panel in Windows.

Note This exercise uses the AnalyzeMap1.dwg map you created and modified in
the previous exercises.

To set up an ODBC connection for the Access database

1.

From your Windows desktop, click Start menu » Settings » Control
Panel and open the Administrative Tools control panel.

In the Administrative Tools window, double-click Data Sources
(ODBC).

In the ODBC Data Source Administrator dialog box, click Add.

In the Create New Data Source dialog box, click Microsoft Access
Driver (*.mdb) and click Finish.

In the ODBC Microsoft Access Setup dialog box, for Data Source
Name, enter Parcel_Owners.

Enter a description, for example, "Parcel owner information."



ODBC Microsoft Access Setup [ | 3]

Data Source Mame:  Parcel_Owners 0K
Description: Parcel owner information
Cancel
e
Database:
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System Database

@ Mone

(") Database:
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Optionsz:>

Name the data source.

7. Under Database, click Select.

8. In the Select Database dialog box, navigate to the sample files and select
the Assessor.mdb file.

Select Databaze

Diatabase Name Directories:
Azzessormdb o \map 3d tutorials
- B =
[=r My Documerts -
E= Map 30 Tutorials
05 Jp2K [F] Read Only
_ | [E] Exclusive
List Fileg of Type: Cirives:
Azcess Databases Tm - =l -

Specify the database for this data source.

9. Click OK in the Select Database, ODBC Microsoft Access Setup, and
ODBC Data Source Administrator dialog boxes.

10. Close the Administrative Tools control panel.



To continue this tutorial, go to Exercise 2: Connect to the Access database.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers > Lesson 2: Analyzing Data With External Information Using Joins >

Exercise 2: Connect to the Access database

Specify the new connection in Data Connect. You don't need to add any specific
feature class layers from the ODBC source to the map. All the information
becomes available to AutoCAD Map 3D automatically when you connect to the
ODBC source.

Note This exercise uses the AnalyzeMap1.dwg map you created and modified in
the previous exercises.

To connect to the Access database from AutoCAD Map 3D

1. In Display Manager in AutoCAD Map 3D, click Data » Connect To
Data.

2. In the Data Connect dialog box, under Data Connections By Provider,
click Add ODBC Connection.

3. Click the button next to the Source field under Add A New Connection.

4. In the Open dialog box, select Parcel_Owners from the list of Data
Source Names and click Select.
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Connect to the ODBC data source the same way you did to the surface and SDF data
sources.

5. Click Connect.

6. In the User Name & Password dialog box, click Login without entering
anything in the fields. (This database has not been set up for user name
and password protection.)

Do not add any layers to your map. AutoCAD Map 3D sees all non-
spatial data automatically after you connect to its source.

7. Close the Data Connect window without adding anything to your map.

To continue this tutorial, go to Exercise 3: Join the data from the ODBC source
to the layer containing the parcels.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers > Lesson 2: Analyzing Data With External Information Using Joins >

Exercise 3: Join the data from the ODBC source to the
layer containing the parcels

After you connect to an external data source, you can join it to a layer in your
map using the Data Table (as long as the two data sources share a common
property). You can see the results of the join immediately.

Note This exercise uses the AnalyzeMap1.dwg map you created and modified in
the previous exercises.
To join the ODBC parcel data to the geospatial parcel layer

1. In Display Manager, select the Parcels layer and click Table.

2. At the bottom of the Data Table, click Options, and click Create a Join.

In the Create A Join dialog box, the Primary Table Initiating The Join
entry is automatically displayed.

3. For Table (Or Feature Class) To Join To, select the
ODBC_1:Fdo:Assessor layer.

4. For This Column From The Left Table, select APN.

The entry for the corresponding Matches This Column From The Right
Table is automatically displayed.

5. Click OK to display all the data in the Data Table.
6. Scroll to the right to see the owner information.

To continue this tutorial, go to Exercise 4: Use the joined data for calculated
fields and styles.




Please send us vour comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers > Lesson 2: Analyzing Data With External Information Using Joins >

Exercise 4: Use the joined data for calculated fields and
styles

Now that you have joined owner data to the parcels layer, you can use the joined
information to create a calculated field and determine your styles.

Note This exercise uses the AnalyzeMap1.dwg map you created and modified in
the previous exercises.
To create a calculated field using joined data

1. At the bottom of the Data Table, click Options, and click Create A
Calculation.

2. In the Create A Calculation window, enter a name for the calculated
field, for example “AcresByArea.”

3. Click Property to see a list of properties for the current layer. Select
ACRES.

4. Click the operator for “divided by” (the slash character).

5. Hover over the [ value ] marker that is inserted to see a tooltip with
choices. Click Enter a Property. Select AREA.

6. Click Validate to make sure the expression is a valid calculation.

7. When you see “The expression is valid,” click OK to create the
calculated field.

Scroll to the right in the Data Table to see the new field (just to the left
of the joined fields). It is gray, to indicate that it is a calculated field and
cannot be edited. However, you can use it for styling.

You can display information differently at different zoom levels in AutoCAD



Map 3D, so you can create a style that displays owner names (from the joined
data source) on the parcel layer at a high zoom level, but not at a lower one.

To create a style using the joined data

1. In Display Manager, select the Parcels layer and click Style.

2. Click the [-Jbutton in the field under Feature Label.

3. For Property To Display, select AssessorfOWNERLASTNAME.
4. Click OK.
5

. Click Add a Scale Range so that you have two scale ranges, both the
same.

6. Set the bounds of the first scale range to 0 to 10000 and the second to
10000 to Infinity.

7. Select the second scale range (10000 to Infinity).
8. Click [ in the Feature Label field.

9. Clear the check box for Create A Label (at the top of the dialog box) and
then click OK.

10. Close the Style Editor.
11. Save your map file.

The new Parcels style will display the owner's name when the view is zoomed to
10000 or closer. The labels are not displayed when you zoom out further than
that.

Where you are now

You joined information from a Microsoft Access database to a layer containing
parcels. Using the combined data, you created a calculated field and a style that
displays parcel owner information at high zoom levels, but does not display
these labels at lower zoom levels.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers >

Lesson 3: Analyzing Data by Proximity Using Buffers

Create a buffer that specifies an area within 100 feet of a particular street and use
it to see which parcels will be affected by a construction project. Save the
affected parcel data to a separate SDF file.

Compare the two sets of parcels—the original set of Redding parcels and those
that lie within the construction zone—by attaching both SDF data sources to
your map as separate layers and styling them differently.

Topics in this section

e Exercise 1: Create a buffer representing a construction zone

e Exercise 2: Select the parcels within the construction-zone buffer
e Exercise 3: Export the construction-zone parcels to an SDF file

e Exercise 4: Compare the two parcel layers

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers > Lesson 3: Analyzing Data by Proximity Using Buffers >

Exercise 1: Create a buffer representing a construction
zone

Start by creating the buffer.

Note This exercise uses the AnalyzeMap1.dwg map you created and modified in
the previous exercises.

To create the buffer
1. If your map is not still open, click File menu » Open and open it.

2. In Display Manager, clear the check boxes next to the surface and
contour layers to hide those layers and see the rest of the process more
easily.

3. Right-click the Parcels layer and click Zoom To Extents.

4. Click Analyze menu » Buffer.

v

In the Buffer Features dialog box, set the buffer distance to 100 feet and
click Merge All Buffers.

Click Select Features.
Click a road in your map that runs through the parcel area.

Press Enter to return to the dialog box.

e NP

Click OK.
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The buffer is created as a separate layer in your map.

To continue this tutorial, go to Exercise 2: Select the parcels within the

construction-zone buffer.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers > Lesson 3: Analyzing Data by Proximity Using Buffers >

Exercise 2: Select the parcels within the construction-
zone buffer

Use the buffer in a query to determine which parcels are within the construction
zone represented by that buffer. Then, export those parcels to an SDF file for
future use.

Note This exercise uses the AnalyzeMap1.dwg map you created and modified in
the previous exercises.

To find the parcels in the construction zone

1. In Display Manager, right-click the Parcels layer and click Query To
Filter Data.

2. In the Create Query dialog box, click Zoom Extents to zoom the drawing
window to the extents of the parcels layer.

3. In the Create Query dialog box, click Locate on Map and select
Touching Any Part Of » Polygon.

4. In the Enter Location Boundary prompt, click Select.
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Click Select in the prompt. Click the buffer to select it as the location condition.

5. In the prompt "Select object," click the buffer polygon.
6. In the Create Query dialog box, click OK.

AutoCAD Map 3D filters the parcels to show only those that match the buffer
query you just defined.



|

|

|

» :
el |

]
| |
| ;

Only the parcels that match the filter criteria are displayed in the map.

To continue this tutorial, go to Exercise 3: Export the construction-zone parcels
to an SDF file.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers > Lesson 3: Analyzing Data by Proximity Using Buffers >

Exercise 3: Export the construction-zone parcels to an
SDF file

The map now displays only the parcels that lie within 100 feet of the road under
construction. Select these parcels and save them to an SDF file so you can easily
use this information again.

Note This exercise uses the AnalyzeMap1.dwg map you created and modified in
the previous exercises.

To export the filtered parcels to an SDF file
1. Right-click the Parcels layer in Display Manager.
2. Click Export Layer Data to SDF.
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Right-click the parcels layer to export it.

3. Specify a name and location for the file and click Save.

For example, name this file ConstructionParcels to distinguish it from
the other parcel file.

To continue this tutorial, go to Exercise 4: Compare the two parcel layers.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and

Buffers > Lesson 3: Analyzing Data by Proximity Using Buffers >
Exercise 4: Compare the two parcel layers

Remove the filtered parcel layer and connect to both the original and filtered
parcels as separate layers.

Note This exercise uses the AnalyzeMap1.dwg map you created and modified in
the previous exercises.

To compare the two parcel layers

1.

In Display Manager, right-click the Parcels layer and click Remove
Layer.

In Display Manager, click Data and click Connect to Data.

In the Data Connect dialog box, connect to the SDF file you just created,
which contains only the parcels that lie within the construction zone.
Add this data to your map.

Leave the Data Connect window open, but move it to one side so you
can see the Task Pane.

In Display Manager, select the new Parcels layer, and then click its
name. Enter a new name, for example, ConstructionParcels.

In the Data Connect dialog box, connect to the file that contains the
original set of parcels. Add this data to your map and close the Data
Connect dialog box.

The new layer is called Parcels in the Display Manager.

In Display Manager, right-click the original parcels layer (Parcels) and
click Edit Style.

In the Style Editor, set this parcel layer to be semi-transparent (50%



10.

11.
12.

13.

transparency) and a light green color. Leave the Style Editor open.
Click the construction-zone parcel layer (ConstructionParcels).

In the Style Editor, set this parcel layer to be opaque (0% transparency)
and a medium brown color. Close the Style Editor.

In Display Manager, re-display the surface raster image by selecting its
box and the box for the contour layer.

In Display Manager, clear the check box for the buffer layer.
In Display Manager, click Groups and click Draw Order.

The name changes to Order and you can set the draw order of the layers
in your map.

Make sure the draw order looks like this:
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Click Groups and click Draw Order to change the name of the button to Order. Use
Order to change how layers overlay each other.

Where you are now



Your map now displays the raster image, overlaid with the roads, the original parcel layer, and the
construction-zone parcels.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and
Buffers >

Lesson 4: Creating a report

Export the Data Table information for the construction-zone parcel layer to a
comma-separated file, which will include the joined owner data.

Topics in this section

e Exercise 1: Export the data to CSV for use in a report.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Analyzing Data Using Styles, Joins, and

Buffers > Lesson 4: Creating a report >

Exercise 1: Export the data to CSV for use in a report.

Display the Data Table for the construction-zone parcels. Export the data to a
comma-separated file. You can use the data in any way you like, for example, in
a report or to create a mailing list for the owners of the construction-zone

parcels.

Note This exercise uses the AnalyzeMap1.dwg map you created and modified in

the previous exercises.

To export the construction-zone parcel data

1. In Display Manager, select the construction-zone parcel layer and click

Table.

2. In the Data Table, right-click the left-most column and click Select All.

3. Click Options (at the bottom of the table) and click Export.

0197
0.138246262984...

0.053753737015...
0.227
0192
0192

I

Export

of 15 | 15 Selected

Search to Select

Select All
Select Mone

Zoom To
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Help

Options -

Export property information from the Data Table.

4. Specify a name and location for the file and click Save.



5. Save and close your map file.

Where you are now

You exported information from the Data Table as a comma-separated file that
can be used to generate a report.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials >
Tutorial: Managing Data From Different Sources

Topics in this section

e About the Managing Data Tutorial

e Lesson 1: Converting Drawing Layers to Feature Classes
e Lesson 2: Using the Resulting SDF Files

e Lesson 3: Moving SDF Data to a Different Geospatial Format
e Lesson 4: Importing SDF Files as DWG Layers

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources >

About the Managing Data Tutorial

An AutoCAD Map 3D map can contain DWG objects you query in from
drawing files, as well as features from multiple geospatial data sources, such as
Oracle database stores and SDF files. Once you add data to your map, you can
convert it from one data format to another. For example, you can do the
following:

e Make DWG data available in a geospatial format for other organizations.
e Move your own organization's data into a geospatial environment.
e Bring geospatial data into a drawing file.

e Use options that are available only for drawing data or only for
geospatial data, and then return the data to its native format.

For example, you can import geospatial data to convert it to DWG
format and then use drawing cleanup commands (which are not available
for geospatial data). You can convert DWG data to geospatial format and
use the split/merge commands to assign attribute data to the split or
merged features. These commands are not available for drawing objects.

e Save a map in DWG format so AutoCAD users (without access to
AutoCAD Map 3D) can make changes to map data.

Select the appropriate method to move data into or out of a map:

Attach a drawing to your map and If you change the objects, you can
then query in the objects to use. update the original drawing or not.

Connect to geospatial (FDO) data. You can maintain a live connection



Import data into your map,
automatically converting it to DWG
format. Importing inserts a
"snapshot" of the data. You can
import from a variety of geospatial
sources.

Export drawing objects to a variety
of formats. No geospatial features
are exported, but you can save all
the features and objects in your map
to AutoCAD DWG format and then
export it.

Use Bulk Copy to convert geospatial
data to another geospatial format.

Export your map or individual
drawing layers to the Autodesk SDF
format, or to SHP, ArcSDE, or
Oracle, and then use Bulk Copy to
move it to other formats.

to the data, or work offline and
update your data store when you
finish.

Use this option when you don’t
want to affect the original data store,
and you don’t want changes in that
data store to change your map.

The original data is unchanged.

The original geospatial data source
is unchanged.

The original DWG data is
unchanged.

Converting Drawing Layers to Feature Classes

In an AutoCAD drawing, you can use layers to organize information. For
example, you might have separate AutoCAD layers for roads, parcels, and so on.
Geospatial data stores use schemas for this purpose. In a schema, each feature
class might serve the same purpose as a drawing layer.

SDF is a proprietary Autodesk format. It supports a schema that can include
multiple feature classes within a single file, the same way that a single drawing
can include multiple drawing layers. In this tutorial, you will create an SDF file
with a schema whose feature classes reflect the layer structure of a drawing file.
Each layer in the drawing file becomes a feature class in the SDF file. when you



export it.

The Export dialog box has a mapping option that lets you assign each layer to a
target feature class and convert object data to geospatial attribute data. Once you
set up the mapping, you can save your settings as a profile, allowing you to use
the settings over and over again.

Using the Resulting SDF File

Once the data is stored in the SDF file, you can connect to that SDF data store
and add the features to a map as Display Manager layers.

One advantage of geospatial data stores is the ease with which you can control
attribute data (called “properties” for feature classes). In this tutorial, you will
add a “constrained” property to a feature class in the SDF schema.

A constrained property can have only one of a set of predefined values, or only
values within a particular range. For example, you can define a Zoning property
whose values can be only Residential, Commercial, or Public.

Moving SDF Data to a Different Geospatial Format

Once data is in a geospatial format, you can use Bulk Copy to move it to a
different geospatial format. For example, you can copy SDF data to a set of SHP
files.

Converting the Data to DWG Format

If needed, you can re-import your changes in DWG format. If you create a
template file specifying the original layers for the data, you can place each
feature class into its appropriate drawing layer. Once you import the data into a
drawing layer, it uses the layer’s styling information, rather than the styling you
applied to the Display Manager layer.
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources >

Lesson 1: Converting Drawing Layers to Feature Classes

The Autodesk SDF format supports a schema that can include multiple feature
classes within a single file. In this tutorial, you will create an SDF file with a
schema whose feature classes reflect the layer structure of a drawing file. Each
layer in the drawing file becomes a feature class in the SDF file. Each feature
class has properties that match the object data fields for the original layer.

Converting drawing layers to feature classes involves the following steps:
e Examine the original drawing layers.
e Examine the original object data.

e Export the drawing layers to the new SDF file.

Topics in this section

e Exercise 1: Examine the original drawing layers

e Exercise 2: Examine the object data
e Exercise 3: Export the drawing layers to SDF - Select the layers

e Exercise 4: Export the drawing layers to SDF - Map object data to
feature class properties

e Exercise 5: Export the drawing layers to SDF - Map drawing properties
to feature class properties

e Exercise 6: Export the drawing layers to SDF - Set Export Options

Please send us your comment about this page
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Exercise 1: Examine the original drawing layers

You will create an SDF file with a schema whose feature classes reflect the layer
structure of a drawing file. Examine the original drawing layers, so you can
check the resulting SDF file to see if it is structured correctly.

To examine the drawing layers

1. If you have not already done so, copy the sample files for the tutorials to
a directory on your hard drive. See Getting Ready to Use the Tutorials.

2. Start AutoCAD Map 3D.

3. Click File menu » Open and open the sample map called
DWGMap_09.dwg.



The DWGMap_09.dwg drawing has multiple drawing layers.

4. Click Setup menu » AutoCAD Layer to see the drawing layer
information.
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To continue this tutorial, go to Exercise 2: Examine the object data

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources > Lesson 1: Converting Drawing Layers to Feature Classes >

Exercise 2: Examine the object data

The drawing layers in your DWG file will become the feature classes in the new
schema. The properties for each feature class are determined by the object data
properties in the drawing. Use the Properties palette to see the object data.

Note This exercise uses the DwgMap_09.dwg map file you opened in the
previous exercise.

To view the object data fields
1. In the map, zoom in close enough to see individual objects.
2. Select one of the pink polylines in the map.
3. Right-click the polyline and click Properties.
4

. Notice that the color for these polylines is BYLAYER. Check the lower
area of the Design tab of the Properties palette to see the object data.

The pink polylines represent parcels and have object data related to
address, area, value, and so on.



You may see different information, depending on which polyline you selected.

Polyline

Color O BylLayer

Layer Parcels

Linetype ByLayer
Linetype scale |1.0000

Plot style ByColor
Lineweight ByLayer
Hyperlink

Thickness 0.0000

Material ByLayer

Wertex 1

Vertex X 18793028564

Vertex ¥ 4632758012

Start segment... [0,0000

End segment ... |0.0000

Global width  |0.0000

Elevation 0.0000

Area 528729635

Length 1247 8984

Closed Yes
Disabled

Linetype gene...

ACRES 1.2140

ADDRESS 4777

APM 115450020000
AREA 528729630
IMP_VALUE 229300
LAMD_VALUE 150000
MET_VALUE 372300

STMAME FERRIMGTOM CT

J Design

Object Class

|

Display

Press Esc to deselect the polyline.

Pan, if necessary, to see the red lines in the upper left-hand corner of the
map.

With the Properties palette still open, select a red line.




The red line represents a waterline. Notice that the color for this line is
not BYLAYER. Within the layer, color has been used to indicate a
particular type of waterline. In this case it indicates size. Red waterlines
are between 26 and 48 inches in diameter.

8. Deselect the red line and pan to the lower right side of the drawing.

9. Select a green line.

The green line is also a waterline, but it is a different size. Green
waterlines are between 13 and 24 inches in diameter. Blue waterlines are
between 1 and 12 inches in diameter.

10. Press Esc to ensure that no objects are selected.

To continue this tutorial, go to Exercise 3: Export the drawing layers to SDF -
Select the layers

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources > Lesson 1: Converting Drawing Layers to Feature Classes >

Exercise 3: Export the drawing layers to SDF - Select the
layers

In this exercise, you’ll export the drawing layers from the original DWG file to a
new SDF file. The original drawing layers become geospatial features with
properties that reflect the object data and AutoCAD properties.

The Export dialog box has a mapping option that lets you assign each layer to a
target feature class and convert object data and properties to geospatial attribute
data. Once you set up the mapping, you can save your settings as a profile,
allowing you to use the settings over and over again.

You cannot maintain styling information when you export drawing objects to
SDF, but you can include object attributes. When you export the Waterline layer,
you will map the Color attribute to a SIZE property.

The Export dialog box has three tabs. The following exercises describe the steps
to take on each tab.

Note This exercise uses the DWGMap_09.dwg map file you opened and modified
in the previous exercises.

To select the layers to export to SDF
1. Click File menu » Convert DWG To » Autodesk SDF.
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2. In the Save dialog box, specify a location and a name for the new SDF
file and click OK.

Make a note of the file name and location, so you can connect to this file
later.

3. In the Export dialog box, on the Selection tab, click Select All.

To continue this tutorial, go to Exercise 4: Export the drawing layers to SDF -
Map object data to feature class properties.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources > Lesson 1: Converting Drawing Layers to Feature Classes >

Exercise 4: Export the drawing layers to SDF - Map
object data to feature class properties

The Feature Class tab lets you map the properties for each layer to its resulting
feature class in the SDF file. You can specify some attributes as shared
properties: all feature classes will have these properties. For example,
Lineweight and Linestyle would apply to every feature class. You can specify
other attributes as specific to a particular feature class. For example, Address
would apply to Parcels only.

Note This exercise uses the DWGMap_09.dwg map file you opened and modified
in the previous exercises.

To specify the properties for the SDF feature classes

1. In the Export dialog box, on the Feature Class tab, click Create Multiple
Classes Based On A Drawing Object and, for Drawing Object To Use,
select Layer.



(") Create a single class from all selected objects

(@) Create multiple classes based on a drawing object

Drawing object to use:

| Select Attributes ... |

L' Export - C:AAMyDWGConversion.sdf

Selection  Feature Class | Options |
Choose how to anganize the selected drawing objects

Ohbject to Feature Class Mapping

Layer

Select properties and attributes to export to all feature

classes

-

Drawing Object

Feature Class

Geometry

0 0 Point+Line+Polygon
Parcelz Parcelz Point+Line+Pohrgon
Roads Reoads Point+Line+Pohrgon
Waterlines Waterlines Point+Line+Pohygon

[7] Show schema names

Saved profiles

Load... ] [ Save... ]

i|learn more

Cumrent profile:

| oK

| | cancel | | Hep

Automatic selection

The table in the dialog box updates to show the layer names and feature class names that

will be used.

Deselect layer O.

Click Select Attributes.

Attributes you specify here will be assigned to all the feature classes in
the SDF file, so select only attributes that are appropriate for all of them.
For example, you can select general properties, which include things like
Lineweight, but not object data properties, which are specific to each

feature class.



4. In the Select Attributes dialog box, expand the Object Properties item
and the AcDbEntity and General items.

5. Check the box for the Lineweight and Linetype items and click OK.

&

E spreszion;

ez Properties [ | K.
[z Object Data
=¥ = Object Properties
=A% AcDbErlity
F-[Eze 30 Yisualization
= g General
[]# Class Name
[] & Colar
[ @ Layer
& Linetype
[]# Linetype scale
[ & Plat shyle
& Lineweight
[] # Hyperlink
#-[ &=l 3050LID
15l INSFRT [V]

Cancel

Help

6. In the Export dialog box, under Feature Class in the grid area, click the
cell for the first layer, Parcels.

Al button appears at the right side of the grid cell.

7. Click E]for the Parcels Feature Class cell.

8. In the Feature Class Property Mapping - Parcels dialog box, click Select
Attributes.

9. Expand the Object Data item and check Parcels.

Now the resulting Parcels feature class will have the object data fields
for the Parcels layer, but not for any other layer.

10. Click OK twice to return to the Feature Class tab.

11. Click in the Geometry cell for Parcels and change the entry to Polygon.

12. Repeat steps 6 through 11 for the remaining two feature classes, using
the following table as a guideline.




Drawing Feature Class | Geometry
Property

Roads Roads Line

Waterlines Waterlines Line

To continue this tutorial, go to Exercise 5: Export the drawing layers to SDF -
Map drawing properties to feature class properties.
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources > Lesson 1: Converting Drawing Layers to Feature Classes >

Exercise 5: Export the drawing layers to SDF - Map
drawing properties to feature class properties

The Feature Class tab lets you map AutoCAD drawing properties to properties in
the SDF feature classes as well. If you have used color, lineweight, or line type
to represent object characteristics, you can map these properties to the
characteristics they represent. In this drawing, color is mapped to a waterline
size. You can map each waterline color to a feature property.

Note This exercise uses the DWGMap_09.dwg map file you opened and modified
in the previous exercises.

To map drawing properties to feature class properties

1. On the Feature Class tab of the Export dialog box, click in the Feature
Class cell for Waterlines.

2. Click [,

3. In the Feature Class Property Mapping - Waterlines dialog box, click
Select Attributes.

4. Expand the Properties item at the top of the list.

5. Select COLOR and click OK.

6. In the Feature Class Property Mapping - Waterlines dialog box, in the
Feature Class Properties cell for COLOR, enter Size.

7. Click the .COLOR cell to see the E] button.

8. Click [
9. In the New Property Data Type dialog box, change the Data Type to



String and click OK.

10. In the Property Value Mapping dialog box, select the box for each color
(on the left side of the dialog box).

11. Classify the waterline sizes as Small, Medium and Large. Use this table
as a guideline:

Red Large
Green Medium
Blue Small

12. Click OK twice to return to the Export dialog box.
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To continue this tutorial, go to Exercise 6: Export the drawing layers to SDF -




Set Export Options.
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Sources > Lesson 1: Converting Drawing Layers to Feature Classes >

Exercise 6: Export the drawing layers to SDF - Set
Export Options

As the final step in the export operation, set the export options.

Note This exercise uses the DWGMap_09.dwg map file you opened and modified
in the previous exercises.

To specify options for the export operation

1. In the Export dialog box, on the Options tab, select Treat Closed
Polylines As Polygons.

2. Under Saved Profiles, click Save.
3. Specify a location and name for these export settings and click Save.

4. In the Export dialog box, click OK to export the data.

The Export Progress dialog box displays the status of the export
operation.

5. Close the map file.

Where you are now

You exported DWG layers to Autodesk SDF format, creating feature classes that
reflect the layers and object data in your original drawing file.

To continue this tutorial, go to Lesson 2: Using the Resulting SDF Files.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources >

Lesson 2: Using the Resulting SDF Files

Connect to the SDF file you created and edit the objects in the map as geospatial
features. (If you imported the SDF file instead of connecting to it, the data would
come back in as drawing objects instead of geospatial data.)

You can also add properties to the feature classes in your SDF file. In this lesson,
you’ll add a constrained property. Constrained properties can have only the
values you specify: values within a particular range or within a list you specify.

This lesson involves the following steps:
e C(reate a new map.
e Connect to the new SDF data.

e Add a new property.

Topics in this section

e Exercise 1: Create a new map

e Exercise 2: Connect to the New SDF Data

e Exercise 3: Edit the schema

e Exercise 4. Add a property

e Exercise 5: Populating the new property with values

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources > Lesson 2: Using the Resulting SDF Files >

Exercise 1: Create a new map

Create a new mabp file.

To create a new map file
1. Create a new map using the map2d.dwt template.
2. Assign a coordinate system to the new map.
e Switch the Task Pane to Map Explorer.

e Right-click the Current Drawing entry and click Coordinate
System.

e Specify the CA-I coordinate system.

Help

x
S o
Data Schema Table Tools Remove EN
|
2R~ Current Drawing N
5 -{E5) Drawings _
k= =53 Query Library; User Admin...
o :
i ..[3 Current Q) User Info...
E_ E'E Object Classe Coordinate System...
] 5 @ Sl Ty Track Coordinates
/-5 Data Sources :
“é -3 Topologies ‘u"lwf.r Metadata...
E_ |53 Link Templat Options...

[T

Set the coordinate system for a new map from Map Explorer.

3. Click File menu » Save and name and save your file.



To continue this tutorial, go to Exercise 2: Connect to the New SDF Data.
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources > Lesson 2: Using the Resulting SDF Files >

Exercise 2: Connect to the New SDF Data

Connect to the SDF file you created.

Note This exercise uses the map you created in the previous exercise, and the
SDF file you saved in Lesson 1: Converting Drawing Layers to Feature Classes.

To connect to the new SDF file

1. In Display Manager, click Data » Connect To Data.

Task Pane
Current Map: -

= =i

[Data) E?} Connect to Data...

‘.ﬂ Mew Map...

u—j Mew Group

&, Mew Text Layer...
Load Layer...

g Bulk Copy...

Al

] Display Manager .

Map Explorer

Add Drawing Data [

—_—

Switch to Display Manager to connect to data.

2. In the Data Connect dialog box, under Data Connections By Provider,
click Add SDF Connection.

3. Click next to Source File under Add A New Connection.

4. Open the SDF file you created in the last exercise.



Data Connections by Provider

Data Connect

£y Add ArcSDE Connection

£y Add MySQL Connection

Efy Add ODBC Connection

£y Add Oracle Connection

[ Add Raster Image or Surface C
[y Add SDF Connection

[ Add SHP Connection

Efy Add SQL Server Connection
@y Add WFS Connection

@ Add WMS Connection

4| T | 3

Data Connect help
05Geo FDO Provider for SDF

|l] Learn more

Read/write access to Autodesk's spatial database format, a file-

based personal gecdatabase that supports multiple
features/attributes, spatial indexing, and file-locking.

SDF_1

Source file:

C:\My Documents\Map 3D Tutorials\DWGToSDF.sdf

Connect to the SDF file you just created.

5. Click Connect.

6. Select all the feature classes.




SDF

SDF_1 (C:\My DocumentsiMap 30 Tutonials\DwGtoSDF sdf)

Available sources in this connection, Select Items to add to the map as

5 Edit Coordinate Systems | [ Refresh

Schema Coordinate System

Schemal
@ Parcels CA-1
@ Roads  CAI
@ Waterlines CA-I

m |

P

fdh Add to Map ~

Map Coordinate System
CA-T

MADZ27 California State Planes, Zone I[401), US Foot
Foot

Each layer from your original map is listed as a separate feature class.
7. Click Add To Map.

8. Close the Data Connect window.

To continue this tutorial, go to Exercise 3: Edit the schema.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources > Lesson 2: Using the Resulting SDF Files >

Exercise 3: Edit the schema

In this lesson, you will examine the feature classes you created. You’ll view the
attribute data in the Data Table (geospatial features do not appear in the Layer
Properties Manager—it is just for drawing objects). Then, you’ll add a feature
class property using the Schema Editor.

Note This exercise uses the map you created in the first exercise, with the
modifications you made in the previous exercise.

To examine the attribute data

1. In Display Manager, select the Waterlines layer and click Table.

Note In this example, the Data Table was undocked by dragging it away
from the edge of the window.
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The general properties and the object data specific to Waterlines appear in the Data
Table.

2. In the Data Table, examine the properties for the Waterlines layer.

The color properties have been translated to a new Size property.
3. Close the Data Table.
To continue this tutorial, go to Exercise 4: Add a property.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources > Lesson 2: Using the Resulting SDF Files >

Exercise 4: Add a property

A set of feature classes and their properties is called a schema. The schema can
specify constraints that determine which objects you can add to a particular
feature class. For example, to add an object to the Roads feature class, that
object might need to be a line. Properties are like attributes—they are
characteristics of all objects in the feature class. For example, a Roads feature
class property might specify the number of lanes it has, or its speed limit.

You cannot change the schemas for all data source types, but you can edit the
schemas for SDF files. In this lesson, edit an SDF schema to add a property to
the Roads feature class.

In this exercise you will add new properties that are constrained, so that only
certain values are valid for them.

Note This exercise uses the map you created and modified in the previous
exercises.

Adding a property that is constrained to a range of values

You can specify that only values within a particular range are valid. You can
include or exclude each extreme of the range: the lowest possible value and the
highest. For example, you can make a range 1 to 100 inclusive, or any value
between 1 and 100, but not 1 or 100, or any combination.

To add a property to the Roads feature class that is constrained by range
1. Switch the Task Pane to Map Explorer.
2. Select the SDF data source at the top of the pane.
3. Click Schema » Edit Schema.
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Edit the SDF schema.

. In the Schema Editor, expand the schema tree on the left to see the three
feature classes.

. Select the Roads feature class.

. Click New Property at the top of the window.

Property1 appears on the left, under the existing properties.

. Specify the characteristics of the new property using the information
shown below:



Logical Property
Mame:
Lanes
Type:
Data -
Description:
The number of lanes for this road r
Siystem generated:
fes i@ MNo
Data Attributes
Unigue False Max Value Included
|dentifier False The maximum value is included in the
Dats Type Single constraint rmange.
Default Value
Read only False
Mullable True
Constraint Type  Range
Minimum Value 1
Min Value Includer True
Maximum Value 5
True [=]

Create a new property with these values. The last four fields appear after setting the
Constraint Type.

This creates a property that represents the number of lanes for a road.
The value must be a whole number between 1 and 5. There is no default
value for this property.

By setting Min Value Included and Max Value Included to true, the
highest and lowest values in the range are acceptable entries.

8. Click Apply.

The "Property1" entry on the left is updated to show the new name.
9. Click OK to close the Schema Editor.

To continue this tutorial, go to Exercise 5: Populating the new property with
values.
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources > Lesson 2: Using the Resulting SDF Files >

Exercise 5: Populating the new property with values

After you add a property to a feature class, you must enter the values for that
property for each feature in the feature class.

Note This exercise uses the map you created and modified in the previous
exercises.

To populate the new properties with data
1. Select the Roads entry in Map Explorer and click Table.
2. In the Data Table, scroll all the way to the right to see the new property.

3. Enter the number of lanes for a few roads.
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384 <N (inclusive).
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% o = [?] Press F1 for more help
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=
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If you enter a value that is outside the allowable range, a warning is displayed.

4. Close the Data Table.

Where you are now

You connected to the SDF file you created earlier and added a new property to
its schema. You entered values for the new property in the Data Table.

To continue this tutorial, go to Lesson 3: Moving SDF Data to a Different
Geospatial Format.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources >

Lesson 3: Moving SDF Data to a Different Geospatial
Format

Use Bulk Copy to move the Roads data in your map from the SDF format it
currently uses to ESRI SHP format. The information will be stored in a set of
new SHP files in a folder that you create. The layers in your map are geospatial
features, so you can use Bulk Copy to move the data to any other geospatial data
format.

Note This exercise uses the map you created with the map2d.dwt template and
modified in the previous lesson.

Topics in this section

e Exercise 1: Connect to a new SHP file folder

e Exercise 2: Use Bulk Copy to move an SDF layer to SHP format

Please send us your comment about this page
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Exercise 1: Connect to a new SHP file folder

Create a new, empty folder to contain the SHP files. In order to convert and copy
data to the SHP format, you must be connected to this folder. You use Data
Connect to establish connections to data stores, even when you don’t add
anything to the map from the data store.

Note This exercise uses the map you opened in the first lesson, with the
modifications you made in the previous exercises.

To create and connect to the folder

1. Use Windows Explorer to navigate to the location where you copied
your sample tutorial files.

Create a folder for the SHP files.
In AutoCAD Map 3D, switch the Task Pane to Display Manager.
Click Data » Connect To Data.

A R

On the left side of the Data Connect dialog box, click Add SHP
Connection.

6. On the right side of the Data Connect dialog box, click the folder icon
(not the file icon). Select the folder you just created and click OK.
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Click the folder icon next to Source File Or Folder.

Click Connect and close the Data Connect window without adding
anything to your map.

To continue this tutorial, go to Exercise 2: Use Bulk Copy to move an SDF layer
to SHP format.

Please send us your comment about this page
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Exercise 2: Use Bulk Copy to move an SDF layer to SHP
format

Copy the Roads layer from SDF format to SHP format using the Bulk Copy
feature.

Note This exercise uses the map you opened in the first lesson, with the
modifications you made in the previous exercises.

To copy the Roads layer to SHP format
1. In Map Explorer, select the SDF_1 schema.
2. Click Tools » Bulk Copy.
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Use Bulk Copy to convert data from one geospatial format to another.

3. On the left side of the Bulk Copy dialog box, select the SDF_1
connection and check the Roads feature.



On the right side of the Bulk Copy window, select the SHP_1
connection.

Select the Roads entry on the right.

Under Ignore The Following Errors During The Copy Process, select all
the items.

Click Copy Now.

Note If you see messages indicating that some property names are too
long, shorten them (as shown in the illustration below) and click Copy
Now again.
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Unmatched data or geometric type errors , :
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Coordinate system

[ Continue Bulk Copy | | Cancel Bulk Copy |

[SChBL:Z:'EF’Di”T[ Save . | | CopyNow || Close || Hep |

Copy the Roads data from SDF format to SHP format.

On the Continue Bulk Copy message, click Continue Bulk Copy.
The data from the SDF Roads layer is copied to the new SHP file.

Click OK on the Bulk Copy Results message and close the Bulk Copy



dialog box.

Where you are now

You copied the data from your SDF layers to SHP format.

To continue this tutorial, go to Lesson 4: Importing SDF Files as DWG Layers.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Tutorial: Managing Data From Different
Sources >

Lesson 4: Importing SDF Files as DWG Layers

You moved some DWG data to SDF format and from there to SHP format, so
you can distribute it to people who use geospatial data.

You may need to move the data back into DWG format. For example, if other
people change the data, you can re-import it so you have the latest version.
When you import SHP or SDF files, they are added to your map as drawing
objects, not as geospatial data.

Topics in this section

e Exercise 1: Create a template for the imported material

e Exercise 2: Import the SDF layers

e Exercise 3: Use Display Layers to Assign Object Properties

Please send us your comment about this page
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Exercise 1: Create a template for the imported material

When you import the SDF file into a map, you convert the data to DWG objects.
(If you connected to the SDF file, the objects would remain in SDF data format.)

In order to maintain the formatting of the original DWG objects that you
exported to SDF, you must create a template that duplicates that formatting. The
template specifies the layers for the SDF feature classes.

Note This exercise uses the DwgMap_09.dwg map file you opened in the first
exercise.

To create a template for the imported material
1. Open the original DWG file you exported to SDF.
e Click File menu » Open.
e Select the sample map called DWGMap_09.dwg
2. Click File menu » Save As.

3. Save the drawing as a template (.dwt) file called
DWGImportTemplate.dwt.

When prompted, enter a description of the template and leave the other
settings set to their default values.

4. In the new template file, delete all the drawing objects so that the
drawing is empty.

Click Edit menu » Select All, and then press the Delete key.

5. Save the template drawing file.

6. Create a new map using the DWGImportTemplate.dwt template.



e (Click File menu » New.
e Select the DWGImportTemplate.dwt template.
e Click Open.

You don’t need to assign a coordinate system to this new map, because
that information is specified by the template.

To continue this tutorial, go to Exercise 2: Import the SDF layers

Please send us your comment about this page
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Exercise 2: Import the SDF layers

When you connected to the SDF file you created earlier in this tutorial, you
brought in its data as geospatial features, and each feature class was a separate
Display Manager layer. However, in this lesson you will import the SDF data as
drawing objects, and each feature class will become a separate drawing layer.

Note This exercise uses the map you created with the DWGImportTemplate.dwt
template and the SDF file you created in Lesson 1: Converting Drawing Layers
to Feature Classes.

To import SDF layers
1. Click File menu » Create DWG From » Autodesk SDF.
2. Navigate to the SDF file you created, select it, and click OK.
3. In the Import dialog box, check Import Polygons As Closed Polylines.
4. Map the incoming feature classes to the layers in the template.

e Click in the Drawing Layer cell for the first feature class
(Parcels).

e Click the down arrow that appears and select the Parcels drawing
layer.
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Be sure to select the correct drawing layer.

e Repeat the mapping process for the other two layers.
5. Map the Size property to object data.

¢ Click in the Data cell for Waterlines.
e Click the [-J button that appears.

¢ In the Attribute Data dialog box, click Create Object Data.

e For Object Data Table To Use, select Waterlines (not
(Schemal_Waterlines).

e (Click Select Fields.

¢ In the Object Data Mapping dialog box, check Size and, under
Target Fields, enter Size in the corresponding cell.

¢ (Click OK to exit the three dialog boxes.



If you are asked to confirm your actions, click Yes.
6. Click View menu » Extents to see the data in your map.
You can now work with the objects as you would any DWG data.

To continue this tutorial, go to Exercise 3: Use Display Layers to Assign Object
Properties

Please send us your comment about this page
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Exercise 3: Use Display Layers to Assign Object
Properties

You can create display layers for each drawing layer in your new drawing. In
addition, you can create separate display layers for each waterline size. By
displaying a single display layer at a time, you can select the various sets of
objects and assign the proper colors to them.

Note This exercise uses the map you created with the DWGImportTemplate.dwt
template, with the modifications you made in the previous exercise.

To use display layers to assign object properties
1. Create a display layer for the Parcels layer.

e In Display Manager, click Data » Add Drawing Data » Query
Current Drawing.

¢ In the Define Query Of Current Drawing dialog box, click
Property.

¢ In the Property Condition dialog box, select Layer and set the
Value equal to Parcels.

e Click OK to close each dialog box.

e In Display Manager, select the default display layer name
(Current Drawing Element) and change it to Parcels.

2. Repeat the procedures in step 1 to create a display layer for Roads.

Select the Roads layer and name the display layer Roads.

3. Repeat the procedures in step 1 to create a display layer for Waterlines.



Select the Waterlines layer and name the display layer Waterlines.

4. Create a new display layer for waterlines whose Size property is set to

Large.

In Display Manager, click Data » Add Drawing Data » Query
Current Drawing.

In the Define Query Of Current Drawing dialog box, click Data.
In the Data Condition dialog box, select Object Data.

For Tables, select Waterlines.

Select Size.

For Value, enter Large.

Click OK to close each dialog box.

In Display Manager, select the default display layer name
(Current Drawing Element) and change it to Large.

5. Repeat step 4 for the remaining sizes (Medium and Small).

6. Change the color of the Large waterline objects.

Turn off all the display layers except for Large.

To turn off a display layer, clear its check box.

Click View menu » Extents.

Drag a selection box around all the objects that are displayed.
Right-click one of the selected objects and click Properties.

In the Properties window, change the Color from ByLayer to Red.

Press Esc to deselect the objects.

7. Repeat step 6 for the Medium and Small layers, making Medium objects
green and Small objects blue.

8. Turn on all the display elements to see the results.

While AutoCAD users will not be able to see the display layers (because
AutoCAD doesn’t have Display Manager), the layer and object



properties are stored with the AutoCAD layers and objects and will be
visible.

Where you are now

You imported an SDF file as DWG objects and styled them as they originally
appeared.

Please send us your comment about this page
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Topics in this section

e About the Styling, Splitting, and Using Joined Data with Polygon
Features Tutorial

e Lesson 1: Connecting to Parcel Data

e Lesson 2: Splitting a Polygon Feature
e Lesson 3: Using Joined Data to Create Calculated Properties

e Lesson 4: Theming Polygon Features
e Lesson 5: Publishing Your Styled Map to MapGuide
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About the Styling, Splitting, and Using Joined Data with
Polygon Features Tutorial

AutoCAD Map 3D has options that are specifically designed for geospatial
features with polygon geometry. For example, you can use a special expression
to find the area of a polygon feature; you can split a single polygon feature into
two or more new features; you can merge two or more polygons into a single
feature; and you can create rules for assigning properties to polygon features
after you split or merge them.

In this tutorial, you will connect to geospatial data for parcel polygons. You will
split a parcel into two uneven new parcels and assign attributes to each resulting
parcel using Split/Merge rules.

You will join a data source to the parcels to add assessor data. You will create a
new property called “ValueByArea.” This is a calculated property that represents
the area of each parcel divided by the parcel’s value.

You’ll export the parcel layer to create a new data store that contains the joined
and calculated data as part of its native schema.

Connecting to the new data store, you’ll create a theme based on an expression
that references the calculated property.

Finally, you’ll publish your map to MapGuide, so others can view it on a
website.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Styling, Splitting, and Using Joined Data with
Polygon Features >

Lesson 1: Connecting to Parcel Data

In this lesson, you will connect to parcel data from the city of Redding,
California.

Topics in this section

e Exercise 1: Create a new map

e Exercise 2: Bring in the parcel data

Please send us your comment about this page
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Exercise 1: Create a new map

Create a new mabp file.

To create a new map file
1. Click File menu » New and select the map2d.dwt template.
2. Assign a coordinate system to the new map.
e Switch the Task Pane to Map Explorer.

e Right-click the Current Drawing entry and click Coordinate
System.

e Specify the CA-I coordinate system.

x
8 & o
Data Schema Table Tools Remove ER
I
S ] Current Drawing S
QB Bnifins User Login...
5 =155 Query Library] ser Admin...
o g
o ..[3 Current Q) User Info...
E_ =-{E3 Object Classe Coordinate System...
L e i
— E%:] U;deﬁnec Track Coordinates
ata Sources
= B T logi Yiew Metadata...
= opologies .
= [ Link Templat Options...
g Help
] e

Set the coordinate system for a new map from Map Explorer.

To continue this tutorial, go to Exercise 2: Bring in the parcel data.
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Exercise 2: Bring in the parcel data

Now, add a layer that displays parcels within the city of Redding. This layer
contains size, value, and address information about the parcels.

Note This exercise uses the map you created in the previous exercise.

To add the parcel layer to the map

1.
2.

In Display Manager, click Data » Connect To Data.

In the Data Connect dialog box, under Data Connections By Provider,
click Add SDF Connection.

Click the file icon next to the Source File field and navigate to the folder
containing the sample files.

Select Assessor_Parcels.SDF and click Open.
In the Data Connect dialog box, click Connect.

In the Data Connect dialog box, select the Parcels layer under Add Data
To Map and click Add To Map.

Close the Data Connect window.

To see the data associated with this layer, select the Parcels layer in
Display Manager and click Table.
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Scroll to the right to see all the columns of parcel data.

9. Close the Data Table.

Where you are now

You connected to a data store containing parcel information. You viewed the
geometry in your map and the attribute data in the Data Table.

To continue this tutorial, go to Lesson 2: Splitting a Polygon Feature.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Styling, Splitting, and Using Joined Data with
Polygon Features >

Lesson 2: Splitting a Polygon Feature

You can define rules that determine how properties are assigned after you split a
single feature into multiple pieces or merge multiple features into one. In this
lesson, you’ll define split/merge rules for the Parcels feature. Then, you will split
a parcel into two uneven pieces and use the rules you defined to assign
properties to each resulting parcel.

Topics in this section

e Exercise 1: Define Split/Merge Rules

e Exercise 2: Find the parcel to split

e Exercise 3: Split the parcel
e [Exercise 4: Examine the results

Please send us your comment about this page
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Exercise 1: Define Split/Merge Rules

You can use the AutoCAD Trim and Break commands to split polygons.
However, the Split command has many advantages over those methods. A split
always results in a valid feature, and has special logic to deal with attributes
automatically.

With Split, you can set rules for the assignment of properties when you split and
merge geospatial features. You can use expressions for these rules.

For example, if you are splitting a parcel, you can specify that the land value of
the resulting parcels be based on a calculation that you define. There are also
choices for automatic calculations, such as assigning the average value of all
merged features to the resulting feature, or dividing the value of a feature evenly
among all its split features.

Note This exercise uses the map you created and modified in the previous
exercises.

To create split/merge rules

1. To display the Data Table, in Display Manager, select the Parcels layer
and click Table in the Task Pane.

2. In the Data Table, click Options (at the bottom of the window) and select
Set Split And Merge Rules.
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Each property of the Parcels feature is listed under Feature Properties on
the left. Two properties (Geom and FeatID) are generated by the data
store, so you cannot set rules for them. If you select them, you can see
the rules that the data store uses to create them.

. In the Split And Merge Rules dialog box, click the ADDRESS property.

. For the Split Rule, specify Empty.

If you split this parcel, you must specify the address number for each
new parcel that is created.

. For the Merge Rule, specify First Selected.

If you merge multiple parcels into one, the new parcel will use the
address number of the first parcel you select for the merge.

. Specify rules for other properties, using the table below as a guide.

ACRES

Proportional
Based On

Area2D

Sum



(Geom)

APN

Copy

First Selected

AREA

Proportional
Based On
Area2D
(Geom)

Sum

IMP_VALUE

Proportional
Based On
Area2D
(Geom)

Sum

LAND_VALUE

Proportional
Based On
Area2D
(Geom)

Sum

NET_VALUE

Proportional
Based On
Area2D
(Geom)

Sum

PRIMARY_INDEX

Empty

First Selected

STNAME

Copy

First Selected

For a complete description of the split/merge rule options, see Using
Expressions In Split/Merge Rules.

7. Click OK.

To continue this tutorial, go to Exercise 2: Find the parcel to split.

Please send us your comment about this page
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Exercise 2: Find the parcel to split

You can use the Data Table to find a particular parcel and zoom into it so you
can split it.

Note This exercise uses the map you created and modified in the previous
exercises.

To find the parcel to split

1. If the Data Table is not open, click the Parcels layer in Display Manager
and click Table.

2. In the Data Table window, make sure Auto-Zoom is on.

When Auto-Zoom is on, it is a different color than the window

background . When it is off, it is the same color as the

window background.

Click Search To Select (at the bottom of the window).

In the Search To Select window, click Property and select STNAME.
Click = (the equals sign in the toolstrip).

Place your cursor over the text that says “value.”

In the tooltip that displays, click Get Values From A List.

©® N o Uk~ W

Click the green arrow next to STNAME in the properties list to see the
street names for the Parcels feature.
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The properties list appears when you click the green arrow. Your selection replaces the
selected value.

9. Click Antigua Drive and click Insert Value.
Click Next if you don’t see Antigua in the list.

10. Click Validate (at the bottom of the window) to make sure the expression
is valid.

11. When you see “The expression is valid,” click OK.

12. Click the heading for the STNAME column to sort the parcel records by
street name.

In the Data Table, the entries for parcels on Antigua Drive are

highlighted. The map is zoomed to that street, and the parcels are
selected in the map as well.

To continue this tutorial, go to Exercise 3: Split the parcel.

Please send us your comment about this page
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Exercise 3: Split the parcel

You will interactively divide a parcel into two unequal closed polylines.

Note This exercise uses the map you created and modified in the previous
exercises.

To divide one parcel into two new parcels

1.

In the Data Table, click the leftmost column for one parcel on Antigua
Drive.

Make a note of the address, so you can compare your results later.

When you click the leftmost column, you select that entry in the Data
Table and automatically zoom to that parcel in your map.

Hide the Data Table so you can see the parcel more easily. Right-click
the Data Table title bar and click ¥ (Auto-Hide) in the Data Table title
bar.

Click Modify menu » Split.

At the first prompt, “Create new or multipart,” click New.

You will split this parcel in two pieces. If you were creating more pieces,
you would select Multipart.

At the second prompt, “Generate new feature ID or use existing,” click
New.

This option auto-generates a unique identifier for the new parcel.

At the third prompt, “Would you like to draw or select the line for the
split,” click Draw.

Draw the line for the parcel split and press Enter.



When you specify the last point and press Enter, the parcel is split.

To continue this tutorial, go to Exercise 4: Examine the results.

Please send us your comment about this page
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Exercise 4: Examine the results

When you examine the results of your split in the Data Table, you will see that

the properties of the two resulting parcels are calculated automatically, using the
rules you specified.

The theme for the Parcels layer updates to show the new parcels appropriately,

reflecting the new values. The labels on the two new parcels update as well.

Note This exercise uses the map you created and modified in the previous

exercises.

To examine the results of the split

1. In the Data Table, examine the attribute values for the new parcels.

The Data Table now shows two parcels on Antigua Drive.
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The values have been updated, including the calculated property you created.

2. Right-click each new parcel and click Check In Feature.

Where you are now

You set up rules for splitting parcels and allocating property values to the




resulting parcels. You used the Split command to divide one parcel into two
uneven pieces. You examined the results in the Data Table.

To continue this tutorial, go to Lesson 3: Using Joined Data to Create Calculated
Properties.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Styling, Splitting, and Using Joined Data with
Polygon Features >

Lesson 3: Using Joined Data to Create Calculated
Properties

You will join the parcel data to an assessor database to add information about the
owners and values of the parcels.It does not contain information about the
owners. You will join the Parcels layer to a Microsoft Access database that
contains owner information.

To connect to an Access database from AutoCAD Map 3D, you must first set up
an ODBC connection for that database using a control panel in Windows. Then,
connect to this source using Data Connect, just as you connected to the physical
data sources in your map. The database source contains a field that you can
match to a property in the Parcels layer, so you can join the data to the parcels.
Using the combined data, you will create a calculated property that is stored in
the map but is not saved back to the original data stores. This property is not
available in either original data source alone. It requires a join and a calculation
to create it.

Topics in this section

e Exercise 1: Set up an ODBC connection for a Microsoft Access database

e Exercise 2: Connect to the Microsoft Access database
e Exercise 3: Join the ODBC data to the Parcels layer

e Exercise 4: Save the properties to a new data store

e Exercise 5: Create a calculated property

Please send us your comment about this page
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Properties >
Exercise 1: Set up an ODBC connection for a Microsoft
Access database

Set up an ODBC connection for the Microsoft Access database using the
Administrative Tools control panel in Windows.

Note If you created an ODBC connection in the tutorial, “Analyzing Data Using
Styles, Joins, and Buffers,” you do not need to do so again. You can skip to the
next exercise.

To set up an ODBC connection for the Access database

1. From your Windows desktop, click Start menu » Settings » Control
Panel and open the Administrative Tools control panel.

2. In the Administrative Tools window, double-click Data Sources
(ODBC).

3. In the ODBC Data Source Administrator dialog box, click Add.

4. In the Create New Data Source dialog box, click Microsoft Access
Driver (*.mdb) and click Finish.

5. In the ODBC Microsoft Access Setup dialog box, for Data Source
Name, enter Parcel_Owners.

6. Enter a description, for example, “Parcel owner information.”
7. Under Database, click Select.

8. In the Select Database dialog box, navigate to the sample files and select
the Assessor.mdb file.
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Specify the database for this data source.
9. Click OK in the Select Database, ODBC Microsoft Access Setup, and
ODBC Data Source Administrator dialog boxes.

10. Close the Administrative Tools control panel.

To continue this tutorial, go to Exercise 2: Connect to the Microsoft Access
database.

Please send us your comment about this page
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Exercise 2: Connect to the Microsoft Access database

Specify the new connection in the Data Connect window. You don't need to add
any specific feature class layers from the ODBC source to the map. All the
information becomes available to AutoCAD Map 3D automatically when you
connect to the ODBC source.

Note This exercise uses the map you created and modified in the previous
exercises.

To connect to the Access database from AutoCAD Map 3D

1. In Display Manager in AutoCAD Map 3D, click Data » Connect To
Data.

2. Under Data Connections By Provider, click Add ODBC Connection.

3. Click E] next to the Source field under Add A New Connection.

4. Select Parcel Owners from the list of Data Source Names and click
Select.
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5. Click Connect.

6. When you see the User Name & Password dialog box, click Login
without entering anything in the fields. (This database has not been set
up for user name and password protection.)

Do not add any layers to your map. AutoCAD Map 3D has access to all
non-spatial data automatically when you connect to its source.

7. Close the Data Connect window without adding anything to your map.

To continue this tutorial, go to Exercise 3: Join the ODBC data to the Parcels
layer.

Please send us your comment about this page
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Exercise 3: Join the ODBC data to the Parcels layer

After you connect to an external data source, you can join it to a layer in your
map using the Data Table (as long as the two data sources share a common
property). You can see the results of the join immediately.

Note This exercise uses the map you created and modified in the previous
exercises.

To join the ODBC parcel data to the geospatial parcel layer

1.
2.
3.

In Display Manager, select the Parcels layer and click Table.
At the bottom of the Data Table, click Options, and click Create a Join.

In the Create A Join dialog box, the Primary Table Initiating The Join
entry reads SDF_1:Schemal:Parcels. For Table (Or Feature Class) To
Join To, select the ODBC_1:Fdo:Assessor layer.

For This Column From The Left Table, select APN.

For Matches This Column From The Right Table, select APN (if it is not
selected automatically).

Click OK to display all the data in the Data Table.

Scroll to the right to see the owner information.

Note The joined data values for the new parcel you created with the Split
command are not accurate. The database that contains the joined data
does not know about the change to the parcel, so it cannot provide the
proper new data for it. You must update the original data store
independently to enter the data for the split parcels.



To continue this tutorial, go to Exercise 4: Save the properties to a new data
store.

Please send us your comment about this page
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Exercise 4: Save the properties to a new data store

The Parcels layer now displays joined data. However, if you examine this data in
the Data Table, you will see that it is gray. This reflects the fact that the joined
data is not part of the original data store and cannot be edited or used in a
calculated property.

However, you can save the layer out to a new data store, which will make the
joined properties available as native properties in the future.

Note This exercise uses the map you created and modified in the previous
exercises.

To save the original and joined properties to a new data store

1. In Display Manager, right-click the Parcels layer and click Export Layer
Data To SDF.
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2. Specify a location and name for the SDF file and click Save.
3. Create a new mabp.

e Click File menu » New.

e Select the map2d.dwt template.
4. Assign a coordinate system to the new map.

e Switch the Task Pane to Map Explorer.

e Right-click the Current Drawing entry and click Coordinate
System.

e Specify the CA-I coordinate system.
5. Connect to the new SDF file.

e In Display Manager, click Data » Connect To Data.



¢ In the Data Connect dialog box, under Data Connections By
Provider, click Add SDF Connection.

e Click the file icon next to the Source File field and navigate to the

new SDF file.

e Select the new SDF file and click Open.

e Click Connect.

e Select the Parcels layer under Add Data To Map and click Add To

Map.

6. Right-click the Parcels layer from the new SDF file and click Table.

7. In the Data Table, scroll to the right.

The joined properties are no longer gray. They are native properties of

the new SDF file.
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To continue this tutorial, go to Exercise 5: Create a calculated property.

Please send us your comment about this page
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Exercise 5: Create a calculated property

Now that you have joined owner data to the Parcels layer and saved the result to
a new data store, you can use the combined information to create a calculated
property. The calculated property is the result of an expression: in this case, the
last sales price divided by the area.

Note YOu must be connected to the data store that contains the data for the
calculation in order to create or manage calculations.

Note This exercise uses the map you created and modified in the previous
exercises.

To create a calculated property using joined data

1. At the bottom of the Data Table, click Options, and click Create A
Calculation.

2. In the Create A Calculation dialog box, name the calculated property
“ValueByArea.”

3. Click Properties. Select Assessor| LAST SALES PRICE.
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4. Click the operator for “divided by” (the slash character).
5. Click Geometric » Area2D.



10.

This option calculates the area of a polygon.

Hold your cursor inside the parentheses, where you see the text
“geometry property.” On the tooltip that displays, click Enter A
Property.

From the Properties list, select Geom.

Every spatial feature has a geometry property that you can use to
calculate area or length.

Click Validate to make sure the expression is a valid calculation.

When you see “The expression is valid,” click OK to create the
calculated property and return to the Data Table.

Scroll to the right in the Data Table to see the new field. It is gray, to
indicate that it is a calculated property and cannot be edited.

Close the Data Table.

Where you are now

You joined information from a Microsoft Access database to a layer containing
parcels. You saved the layer out to a new SDF file, making all its data available
in the future. You used the new data source to create a calculated property.

To continue this tutorial, go to Lesson 4: Theming Polygon Features.

Please send us your comment about this page
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Lesson 4: Theming Polygon Features

You can use the new calculated property you created as the basis for a theme that
styles parcels according to their value by area.

Topics in this section

e Exercise 1: Creating a theme

e Exercise 2: Add labels that use an expression

Please send us your comment about this page
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Exercise 1: Creating a theme

A theme varies the display of individual features based on data values. For
example, if you theme by parcel value, less expensive parcels might be a lighter
color while more expensive ones are a darker shade.

In this exercise, you’ll create a theme based on the calculated property you
defined for ValueByArea.

Note This exercise uses the map you created and modified in the previous
exercises.

To create a theme using a calculated property
1. In Display Manager, select the Parcels layer and click Style.
2. In the Style Editor, click New Theme.
3. In the Theme Polygons dialog box, for Property, select ValueByArea.
4

. For Distribution, select Jenks (Natural Breaks).

The Jenks distribution method groups ranges of features at their natural
breaks so that features with similar values are grouped together. This
method shows the natural groupings in the data, rather than creating
arbitrary breaking points.

5. Under Theme The Polygons, click [Jnext to Style Range and set the
foreground color range to any two colors.
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6. Click OK twice to return to the Style

Editor.

Leave the Style Editor open for the next exercise.

To continue this tutorial, go to Exercise 2: Add labels that use an expression.

Please send us your comment about this page
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Exercise 2: Add labels that use an expression

You can label each parcel with text that is determined by an expression. In this
exercise, you will create a label for each parcel that displays the parcel address
on two lines.

The Style Editor should still be open from the previous exercise.

Note This exercise uses the map you created and modified in the previous
exercises.

To add labels using expressions

1. In the Style Editor, click the entry under Feature Label for the first rule
in the theme.

Because you are theming the Parcels feature, you have one entry for
each theme rule.

2. In the Style and Label Editor, click Property To Display, scroll down to
the bottom of the list, and click Expression.
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To create the two-line label, enter Concat (ADDRESS, Concat
('\n', STNAME))

The Concat operator combines multiple properties and uses the '\n'
argument to insert a line break.

Validate the expression.
Click OK in the Style and Label Editor.

In the Style Editor, click the entry under Feature Label for the second



rule in the theme.

7. In the Style and Label Editor, click Property To Display, scroll down to
the bottom of the list, and click the Concat expression you created
earlier. Click OK twice.

Once you create an expression for a label, you can select it from the
Property To Display list. You don’t need to re-create it each time.

8. Repeat steps 5 and 6 for each entry in the theme for which you want
labels.

9. Close the Style Editor to see the changes.

Where you are now

You themed the Parcels layer, using a calculated property as the basis for the
theme. You added labels whose content was determined by an expression.

To continue this tutorial, go to Lesson 5: Publishing Your Styled Map to
MapGuide

Please send us your comment about this page
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AutoCAD Map 3D Tutorials > Styling, Splitting, and Using Joined Data with
Polygon Features >

Lesson 5: Publishing Your Styled Map to MapGuide

When you publish a styled map to MapGuide, all queries, filters, labels, and
calculated properties are saved to a .layer file and transferred to MapGuide.

From within AutoCAD Map 3D, you can preview the published information just
as it will appear on the website.

Topics in this section

e Exercise 1: Publish to MapGuide

Please send us your comment about this page
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Exercise 1: Publish to MapGuide

When you publish to Autodesk MapGuide, you create a web page containing a
picture of your map. You will need rights to a MapGuide 2009 Server, which
supports the new templates used in this exerciese. You must have credentials and
write rights in order to do this exercise.

Note This exercise uses the map you created and modified in the previous
exercises.

To publish to MapGuide
1. Save the map.

2. Click File menu » More Plotting Options » Publish to Autodesk
MapGuide.

3. In the Publish To MapGuide dialog box, specify the URL for the target
website.

If the site requires a password, a Connect to Site dialog box is displayed.
Enter your user name and password.

4. Select a folder for the published files.

To create a new folder, right-click the parent folder and click New
Folder.

5. Check both options (for overwriting existing resources and previewing
the results).

6. Click Publish.

Once the publish operation is complete, the results appear in a browser
window.
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7. To view the published map again later, click File menu » More Plotting
Options » Publish to Autodesk MapGuide and connect to the website.
Then right-click the map to view and click Open In Web Browser.
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Note You can use tooltips to display information when the viewer holds the cursor
over a particular area. Within Autodesk MapGuide Studio, you can create
tooltips that display attribute values on the MapGuide web page when the viewer
hovers over a parcel. For more information, see the Autodesk MapGuide Help.

Where you are now

You published your map to Autodesk MapGuide, complete with joined data,
calculated properties, styling, and attribute data. You viewed the resulting web
page from within AutoCAD Map 3D.

Please send us your comment about this page
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AutoCAD Map 3D Tutorials >
Glossary

attribute data

Tabular data that describes the characteristics of a feature, for example, the
number of lanes and pavement-type belonging to a road feature. See also
external data, object data, property.

AutoCAD layer

A layer in AutoCAD is a logical grouping of data. Layers are like
transparent acetate overlays on a drawing. An AutoCAD layer differs from
a map layer in Display Manager. A Display Manager layer references a
feature source or a drawing source, contains styling and theming
information, and optionally has a collection of scale ranges. See also layer,
drawing layer, feature layer, or surface layer.

buffer

A zone of a specific radius created around a selected feature. Used to select
features within a specific distance of another feature. In AutoCAD Map 3D,
you can define buffers for drawing topologies and for features, but you
define them differently.

COGO

Short for Coordinate Geometry. COGO inquiry commands extract
geometric information from drawing objects such as lines, curves, closed
polylines, and polygons. This information is useful if you want to verify the
accuracy of your data, or send the data to the field. Inquiry commands are
specific to drawing objects. They don’t work on features.

contour lines

A line that connects points of the same elevation or value relative to a
specified reference datum. The lines can help you determine the elevation at



a specific location on a surface, help clarify and analyze the 3D surface
terrain, and help with tasks such as navigation.

coordinate system
See global coordinate system.

Data Connect

AutoCAD Map 3D window where you can access a data store and add
specific data to your map. Display the Data Connect window by clicking
Data in Map Exploreror Display Manager (in the Task Pane).

data provider
Used by Data Connect to connect to geospatial data stores.

data store

A collection of feature classes contained in a single data storage location.
The data store contains feature classes defined within one or more schemas.
Data stores can be files, such as an SDF file, or databases, such as an Oracle
Spatial database.

Data Table

In AutoCAD Map 3D, the feature-based grid where you can view and edit
attributes of selected spatial features, perform searches, and work with
selection sets.

DEM

Digital Elevation Model. A file that contains a representation of surface
terrain. The surface is stored as a grid in which each cell can have any one
of several different meanings, such as elevation, color, density, and so on.

digitize
To convert existing data from paper maps, aerial photos, or raster images

into digital form by tracing the maps on a digitizer. Object locations are
recorded as X,Y coordinates.

Display Manager
A tab in the Task Pane that handles the styling and theming of features in
your map.

display map



All the settings for a specific map, such as the data to include, the
appearance of each layer, and the legend definition. A display map can
include objects from attached drawings, raster images, and features stored
in data stores, such as Oracle databases, SDF or SHP files, and ArcSDE.
One map can include multiple display maps.

draping
The process of overlaying a set of features or a raster image on a surface so
that the features or the image reflect the underlying terrain.

drawing layer

A layer in Display Manager that contains drawing objects from a DWG file.
See also AutoCAD layer, feature layer, layer, or surface layer.

drawing set
The set of source drawings attached to a map.

drawing source

In Autodesk Map, a drawing (DWG) file and also its associated
information, such as attached drawing files, drawing-based feature classes,
linked template data, and topologies. Compare with feature source.

drive alias

In AutoCAD Map 3D, the mechanism that points to the folder where
attached DWG files are stored.

DWF

Design Web Format. An Autodesk file format for sharing two-dimensional,
three-dimensional, and spatially-enabled design data on the Web.

external data

The attribute data linked to a map object but contained in a database or file
outside the map file. See also object data, property.

FDO

Feature Data Objects. An Autodesk software standard and general purpose
API for accessing features and geospatial data regardless of the underlying
data store. See also feature class.

feature



An abstraction of a natural or man-made real world object. A spatial feature
has one or more geometric properties. For example, a road feature might be
represented by a line, and a hydrant might be represented by a point. A non-
spatial feature does not have geometry, but can be related to a spatial
feature that does. For example, a road feature may contain a sidewalk
feature that is defined as not containing any geometry. See also attribute

feature class

A schema element that describes a type of real-world object. It includes a
class name and property definitions. Commonly used to refer to a set of
features of a particular class, for example, the feature class "roads" or the
feature class "hydrants." See also FDO, schema.

feature layer

A layer in Display Manager containing features from a single feature class
in a spatial data source. Feature layers are added to your map using Data
Connect. See also AutoCAD layer, drawing layer, layer, or surface layer.

feature source

Any source of feature data that has been connected to a map. Compare with
drawing source.

field

A specific category of information in a data file, such as Address or
Diameter.

geometry (Oracle Spatial database)
The representation of a spatial feature.

GIS (Geographic Information System)

A computerized decision support system that integrates geographic data,
attribute data, and other spatially referenced data. A GIS is used to capture,
store, retrieve, analyze, and display spatial data.

global coordinate system

A method that converts the earth’s spherical coordinates representing
latitude and longitude into an AutoCAD Map 3D map Cartesian coordinate
system, and accounts for the curvature of the earth’s surface with a



projection. A coordinate system is usually defined by a projection, an
ellipsoid definition, a datum definition, one or more standard parallels, and
a central meridian.

join
A relationship that is established between attribute data and feature sources
for the purposes of creating a new view of the data or for ad-hoc analysis.

label
Text placed on or near a map feature that describes or identifies it.

layer

A resource that references a feature class or a drawing source that you add
using Display Manager. The layer contains styling and theming
information, and optionally a collection of scale ranges. See also AutoCAD
layer, drawing layer, feature layer, or surface layer.

lock

To make all or part of a disk file read-only so that it cannot be modified by
other users on a network. Object locking applies to objects that are being
edited by another user. File locking applies to entire files, for example when
an AutoCAD user wants to open a file while the file is being edited in
AutoCAD Map 3D.

logical operator

A symbol such as And, Or, Not, =, >, >=, <, and <= used to define logical
relationships.

map

A collection of layers displayed within a consistent coordinate system and
extents. See also layer.

map book
A collection of map tiles that you publish as separate pages. You can
specify the layout and properties for your map book on the Map Book tab
of the Task Pane.

Map Explorer
The Task Pane tab where you manage your mapping resources.



map query

A set of conditions that specify the selection of drawing objects from source
drawings. These conditions can be based on the location or properties of an
object or on data stored in the drawing or in a linked database table.

mpolygon

A polygon object. A polygon differs from a closed polyline in that it stores
information about its inner and outer boundaries.

object data

The attribute data attached to a drawing object and stored in the drawing
file. Compare with external data.

polygon
A closed area that stores information about its inner and outer boundaries,
and about other polygons nested in it or grouped with it. In a polygon
topology, the polygon can be enclosed by any lines or arcs in the drawing.
In addition, AutoCAD Map 3D supports a polygon object, sometimes called

an mpolygon or mapping polygon.

property
A single attribute of a feature class. A feature class is described by one or
more property definitions. For example, a Road feature class may have
properties called Name, NumberLanes, or Location. See also attribute data,
feature.

publish
To generate output from a map.

query
A set of criteria for specifying the selection of objects or records. For
example, a layer-based query can display only the objects on the layers that
contain state and district boundaries.

raster

Images containing individual dots (called pixels or cells) with color values,
arranged in a rectangular, evenly spaced array. Aerial photographs and
satellite images are examples of raster images used in mapping. Compare
with vector.




resolution
In a raster image, the density of pixels-per-inch (PPI) or dots-per-inch
(DPI).

save set

Objects that were created or modified in the current drawing and are
marked to be saved back to source drawings.

scale

The ratio of the distance on a paper map to the distance on the ground. If a
paper map has a scale of 1:100,000 (also represented as 1/100000), then a
distance of 1 unit on the paper map corresponds to 100,000 units on the
ground. On a digital map, scale represents the scale of the map from which
the digital map was derived.

scale threshold

Levels at which a map display changes. You can define different style s at
different scale thresholds. For example, turn on the display of road names
only when the drawing scale factor is below 1:5000.

schema

The metadata that provides a logical description of multiple feature classes
and the relationships between them.

SDF 2

A previous version of the SDF file format that was the native file format for
Autodesk MapGuide (the last release was Autodesk MapGuide 6.5). Each
SDF 2 file generally contained one feature or type of data, for example
points, lines, polygons, or text.

SDF 3

Spatial Data File. The current version of the SDF format that is the native
format for the Autodesk MapGuide technology (Autodesk MapGuide
Enterprise 2007 and MapGuide Open Source). Each SDF 3 file can contain
multiple feature classes or types of data stored in tables with attributes and
geometry.

sheet
An individual named object in a sheet set that can be published. A sheet



references a layout.

sheet set
A named collection of sheets and sheet subsets for publishing.

sheet subset

A named collection of sheets within a sheet set. An individual sheet can be
a member of only a single subset.

sheet template

A drawing file that defines a title block and a layout for use in sheets. A
sheet template can be specified for sheet sets and sheet subsets.

source drawing

A drawing file attached to another drawing. The set of all source drawings
attached to a drawing is called the drawing set. Use a query to retrieve
selected objects from multiple source drawings.

spatial

A generic term used to reference the mathematical concept of n-
dimensional data.

spatial data

Information about the location and shape of geographic features, and the
relationships between those features.

spatial database
A database containing information indexed by location.

style

Settings that specify how to display the objects in a Display Manager layer.
For example, you can style color, linetype, linewidth, and scale.

surface layer

A layer in Display Manager containing features from a raster image that
contains elevation information. Surface layers are added to your map using
Data Connect. See also See also AutoCAD layer, drawing layer, feature

layer.
table




A set of data arranged in records (rows) and fields (columns). When a table
is displayed in a grid, records are displayed in horizontal rows and fields are
displayed in vertical columns. Each field value in the table is displayed in a
cell.

Task Pane

AutoCAD Map 3D window that displays information about the current
drawing. The Task Pane contains three tabs: Map Explorer, Display
Manager, and Map Book. The Map Explorer tab lists attached source
drawings, databases, queries, and link templates. The Display Manager tab
controls display layers and their style s. The Map Book tab displays the
map books available for publishing, and lets you create new map books.
You can resize the Task Pane and place it where you want.

theme

A style that varies the appearance of an element in a layer based on the
value of a specific property. For example, instead of coloring lakes blue,
you could vary the shade of blue based on the depth of the lake. Instead of
choosing one line width for all roads, you could vary the line width based
on number of lanes.

vector

A mathematical calculation of an object with precise direction and length.
Vector data is stored as X,Y coordinates that form points, lines, and areas.
Compare with raster.

viewport (paper space)

A view of model space from a layout.

workspace

Contains the commands and tools for specific tasks. The Map 3D For
Geospatial workspace is tailored for working with spatial features while
Map 3D For Drawings is optimized for working with drawing objects.

To change your workspace, click View menu » Menu/Toolbar Layout.
Click a workspace.

zoom

To change the display magnification so that it focuses on progressively
smaller areas (when you zoom in) or larger areas (when you zoom out) of



an image.

zoom extents

To magnify a drawing based on its extents so that the view shows the
largest possible view of all spatial objects.
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