
Welcome	to	AMCap



Presentation

AMCap	is	a	small	yet	fully	functional	video	capture	and	preview	application
compatible	with	Microsoft	DirectShow	(formerly	ActiveMovie,	hence	the
name).	It	is	based	on	the	sample	AMCap	source	code	from	the	Microsoft
DirectX	9	SDK.	This	custom	version	adds	many	new	features	including:

DV	camcorder	playback	and	recording

improved	MPEG-2	playback	and	recording

improved	analog	TV	tuner	support

still	capture	in	BMP,	JPEG	and	PNG	formats

optional	real-time	compression	(Windows	Media	or	any	installed
CODECs)

remember	video	input,	standard,	size	and	many	other	options	from
previous	session

full	screen	mode

support	for	multi-monitor	and	deinterlacing	(using	VMR9)

caption	bar	and	menu	on/off

always	on	top	feature

The	VMR-9	option	enables	multi-monitor	support,	zooming,	aspect	ratio	and
deinterlacing	features	(Microsoft	DirectX	9.0	required.)

	



Limitations	of	the	demo	version

The	demonstration	version	will	stop	after	about	15	minutes	of	preview	or	capture
and	still	capture	is	limited	to	3	snapshots	per	session.

	



How	to	obtain	the	unlimited	version?

If	after	testing,	you	are	satisfied	with	this	version	of	AMCap	and	you	wish	to
obtain	the	fully	functional	version,	please	register	at	the	URL	below.

https://www.regnow.com/softsell/nph-softsell.cgi?item=4076-4

The	version	of	AMCap	that	you	receive	right	away	after	your	registration	is	fully
functional	and	does	not	have	the	limitations	mentioned	above.
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Keyboard	Shortcuts

Application	control

Keys Actions
Ctrl+C Starts	a	video	capture
Ctrl+I Displays	on-screen	information	if	a	crossbar	is	available

(VMR9	only)
Ctrl+L	/	Enter Makes	a	still	capture
Ctrl+S Saved	captured	video
Ctrl+Z Toggles	the	zoom	(VMR9	only)
Alt+Enter Toggles	full-screen	mode
F1 Opens	the	help	file
F9	/	mouse	wheel Decreases	the	application	volume
F10	/	mouse	wheel Increases	the	application	volume
F11 Toggles	menu	bar	and	caption	on	and	off
F12 Toggles	"always	on	top"	state
0	..	9 Selects	a	TV	program
Del	/	Backspace Cancels	last	typed	program	digit
PgDn	/	Browser
Backward

Selects	previous	TV	program

PgUp	/	Browser
Forward

Selects	next	TV	program

- Selects	previous	video	input	(if	many)
+ Selects	next	video	input	(if	many)
Esc Stops	current	capture
Spacebar Pauses	or	plays	the	live	preview

	

Device	control

Keys Actions
Ctrl+A	/	Media	Pause Pause
Ctrl+F	/	Media	Fast	Forward Fast-Forward
Ctrl+P	/	Media	Play Play
Ctrl+R	/	Media	Record Record



Ctrl+T	/	Media	Stop Stop
Ctrl+W	/	Media	Rewind Rewind
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Still	Capture

AMCap	makes	it	very	easy	to	capture	still	pictures	from	a	supported	video
capture	source	(usually	a	webcam),	once	the	program	is	configured,	just	hit	the
Enter	key	and	a	still	picture	is	saved	to	your	hard	drive.	Follow	the	3	steps	below
to	get	started.

	

1.	Select	the	device	and	enable	preview

select	the	video	capture	source	(e.g.	your	webcam)	from	which	you
want	to	make	still	captures	in	the	Devices	menu.	This	is	not	needed
if	you	only	have	one	source.

make	sure	the	Preview	mode	is	enabled	in	the	Options	>	Preview
menu	(this	now	is	the	default).

	

2.	Configure	the	resolution

if	your	capture	source	features	a	Still	pin,	for	high-resolution	still
captures,	click	Options	>	Still	Capture	Pin...	to	configure	the
resolution	of	the	still	pictures	(see	notes).	This	feature	also	allows
you	to	use	the	trigger	on	the	device	to	capture	stills.

if	your	capture	source	does	not	have	such	a	feature,	the	resolution	of
the	still	pictures	is	the	same	as	for	video	capture.	In	that	case,	you
can	configure	it	from	the	Options	>	Video	Capture	Pin...	menu.

	

3.	Capture	and	save	still	pictures

press	Enter	or	Ctrl+L	to	make	a	still	capture



if	this	is	your	very	first	capture,	a	Still	Capture	property	page	will
show.	Configure	the	folder	and	filename,	select	a	file	format	(JPG
recommended)	and	click	OK.	If	you	don't	do	that	configuration,	no
picture	will	be	saved	and	you	will	be	prompted	with	this	page	again
when	you	attempt	to	capture	another	still.

you	can	now	make	as	many	still	captures	as	you	wish	you	just	by
pressing	the	Enter	key.

you	can	click	the	File	>	Open	Folder	>	Still	Capture...	menu	to
open	the	folder	where	the	still	captures	are	stored.

	

	

Notes:

the	GdiPlus.dll	library	is	required	for	still	capture	to	work.	On	Windows
Millennium,	98	and	2000,	you	need	to	download	the	redistributable	file
available	here	(scroll	down	and	click	the	GDI+	link)	or	here	and	copy	it
to	the	AMCap	installation	folder.	On	Windows	XP	and	later,	this	file	is
preinstalled	and	you	don't	have	anything	to	do.

in	this	version	of	AMCap,	the	still	capture	feature	is	always	available	and
active	(but	in	overlay	mode),	so	you	don't	have	anything	to	do	to	enable	it
anymore.

with	some	older	webcam	models	and	drivers,	the	use	of	the	Still	pin	may
be	unreliable	and	possibly	lead	to	blue	screens	(BSOD).	In	that	case,	clear
the	option	Use	Still	pin	instead	of	Capture	pin	when	available	in
Capture	>	Setup...	>	Still	Capture	tab	and	use	the	Options	>	Video
Capture	Pin...	menu	to	configure	the	resolution	of	the	stills.

if	you	need	the	stills	to	be	captured	to	the	clipboard	instead	of	a	file,	you
can	toggle	the	Capture	>	Still	Capture	>	Copy	to	clipboard	menu
option	at	any	time.

if	you	want	to	make	still	captures	at	regular	intervals	or	hands-free,	you
can	use	the	Capture	>	Still	Capture	>	Delayed	Snap	menu,	configure
an	interval	and	click	Start.

http://www.microsoft.com/downloads/details.aspx?FamilyId=A55B6B43-E24F-4EA3-A93E-40C0EC4F68E5&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=6a63ab9c-df12-4d41-933c-be590feaa05a&DisplayLang=en


	

	

See	also

Video	Capture
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Video	Preview

Previewing	video	in	AMCap	is	the	easiest	way	for	you	to	try	your	webcam	or
any	video	capture	source	(a	TV	tuner,	a	video	capture	card	or	device,	a	DV
camcorder,	etc.)	If	you	only	have	one	webcam	as	a	video	capture	source,	you
should	actually	have	nothing	to	configure	but	the	video	preview	size.

	

1.	Select	the	video	source	and	set	video	parameters

select	the	video	capture	source	(e.g.	your	webcam)	from	which	you
want	to	capture	video	in	the	Devices	menu.	This	is	not	needed	if	you
only	have	one	source.

in	the	case	of	an	analog	video	capture	source,	adjust	the	video
standard	from	the	Options	>	Video	Capture	Filter...	menu.

if	your	video	capture	source	provides	hardware	compression,	you
may	tick	the	Options	>	MPEG2	menu	for	better	preview	and
capture	performances.	(MPEG2	is	usually	only	supported	by	some
tuner	and	video	capture	cards.)

if	the	video	capture	source	has	multiple	inputs,	select	the	right	input
from	the	Options	>	Crossbar	Video	Input	menu.

	

2.	Select	the	audio	source	(optional)

If	you	want	to	listen	to	audio	as	well:

select	the	audio	capture	source	in	the	Devices	menu.

select	the	right	audio	input	in	the	Options	>	Audio	Input	menu.

if	an	Options	>	Crossbar	Audio	Input	menu	is	available,	make
sure	the	right	audio	input	is	selected.



or

tick	the	Capture	audio	from	video	source	option	in	the	Devices
menu	if	the	video	capture	source	also	provides	audio	(e.g.	a	TV
tuner	or	a	DV	camcorder.)	In	this	case,	the	possibly	selected	audio
source	is	ignored.

	

3.	Enable	the	preview	and	change	the	preview	size

tick	the	Options	>	Preview	menu	if	it	is	not	already	ticked.

click	the	Options	>	Video	Preview	Pin...	menu	to	change	the
preview	size.	If	this	menu	is	not	available,	click	the	Options	>
Video	Capture	Pin...	menu	instead.

	

If	your	video	capture	source	is	an	analog	TV	tuner,	please	check	Watching	TV
for	more	details	and	to	learn	how	to	configure	the	TV	programs.

	

	

See	also

Keyboard	Shortcuts

Still	Capture

Video	Capture

Watching	TV
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Video	Capture



Getting	started

When	you	use	AMCap	for	the	first	time,	it	is	recommended	that	you	go	to	the
setup	once	to	configure	general	options:	click	Capture	>	Setup...	then	review	all
the	options	(not	only	for	video	capture).

The	Video	Capture	tab	holds	most	options	to	enable	and	to	manage	video
capture.	You	have	at	least	to	choose	whether	you	want	to	capture	to	a	pre-
allocated	file	(recommended	for	slow	PCs)	or	to	unallocated	files,	then	configure
the	folder	and	the	filename.

If	you	choose	to	capture	to	a	pre-allocated	file,	select	a	filename	then	click	the
Allocate...	button	to	create	the	optimized	file.

By	default,	captured	video	will	be	uncompressed.	The	benefit	is	that	you	get	the
best	picture	quality	and	you	can	choose	to	compress	the	file	at	a	later	time	with
the	best	possible	results.	You	can	also	choose	to	make	real-time	compression	(if
you	have	a	PC	powerful	enough).	To	enable	and	to	control	compression,	click
the	Compression	tab	and	adjust	the	options.

Click	OK	to	validate.

	

	



Capturing	video

1.	Select	the	video	source	and	enable	preview

select	the	video	capture	source	(e.g.	your	webcam)	from	which	you
want	to	capture	video	in	the	Devices	menu.	This	is	not	needed	if	you
only	have	one	source.

tick	the	Options	>	Preview	menu	if	it	is	not	already	ticked.	Please
note	that	preview	is	not	required	at	all	but	it	will	be	needed	most	of
the	time	to	control	what	is	actually	captured.

	

2.	Select	the	audio	source	and	enable	audio	capture	(optional)

If	you	want	to	capture	audio	as	well:

tick	the	Capture	>	Capture	Audio	option.

select	the	audio	capture	source	(e.g.	your	sound	card)	in	the	Devices
menu	(see	notes).

if	an	Options	>	Crossbar	Audio	Input	menu	is	available,	make
sure	the	tuner	audio	input	is	selected.

select	the	right	audio	input	in	the	Options	>	Audio	Input	menu.

or

tick	the	Capture	audio	from	video	source	option	in	the	Devices
menu	if	the	video	capture	source	also	provides	audio	(e.g.	a	TV
tuner	or	a	DV	camcorder.)	In	this	case,	the	possibly	selected	audio
source	is	ignored.

	

3.	Capture	and	save	video



click	Capture	>	Start	Capture	then	OK,	or	simply	hit	Ctrl+C	to
start	the	capture.

stop	the	capture	using	the	Capture	>	Stop	Capture	menu	or	hit	the
ESC	key.

if	you	configured	AMCap	to	capture	to	a	pre-allocated	file	(in
Capture	>	Setup...	>	Video	Capture	tab),	click	the	File	>	Save
Captured	Video...	menu	to	export	the	video	you	just	captured	and
before	making	a	new	capture.

you	can	click	the	File	>	Open	Folder	>	Video	Capture...	menu	to
open	the	folder	where	the	video	files	are	stored.

	

	

Notes:

exporting	the	video	from	the	pre-allocated	file	may	be	a	long	and	boring
process	so	if	you	have	a	fast	PC,	you	may	prefer	to	configure	AMCap	to
capture	to	unallocated	time-stamped	files.	That	latter	option	will	create	a
new	file	every	time	you	start	a	capture.

if	you	want	to	capture	video	using	the	Windows	Media	9	(WMV9)
compression,	you	will	have	to	download	and	to	install	the	redistributable
Windows	Media	Format	component.	You	can	download	the	file	by
clicking	the	Help	>	Redistributable	Components	>	Windows	Media
Format	menu.

	

	

See	also

Keyboard	Shortcuts

Video	Preview



Still	Capture
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Watching	TV

When	an	analog	TV	tuner	is	installed	in	your	system,	AMCap	can	work	as	an
advanced	TV	set.	All	you	have	to	do	is	configure	the	TV	programs	once	and	you
are	set.

	



Getting	Started

The	initial	configuration	of	the	TV	programs	is	needed	to	easily	select	and
navigate	from	program	to	program	like	a	TV	set.	This	needs	to	be	completed
only	once	but	you	can	redo	it	at	will.	Follow	the	next	few	steps	to	configure	the
programs:

Select	the	TV	tuner	to	use	in	the	Devices	menu.

Click	the	Options	>	TV	Programs	menu.

In	the	TV	Programs	dialog	box,	click	the	Scan...	button.

In	the	TV	Program	Scanner	dialog	box,	select	the	video	standard
of	the	TV	programs	available	in	your	area	(e.g.	NTSC	in	Japan	and
the	USA,	SECAM	L	in	France,	PAL	in	most	parts	of	Europe,	etc.)	in
the	Standard	drop-down	list.

Click	the	Start	button	to	initiate	the	detection	of	the	available	TV
programs.	A	progress	bar	lets	you	know	the	advancement	of	the
scanning.

Click	the	Close	button	to	go	back	to	the	TV	Programs	dialog	box
once	the	scanning	is	stopped	and	the	TV	programs	are	found.

Note:	you	can	select	another	video	standard	and	start	a	new	scan	in	case	you	are
near	some	boundaries	and	you	receive	foreign	programs	in	your	area.	The
programs	found	in	every	scan	are	added	at	the	end	of	the	current	list	and	won't
replace	the	current	programs.

Now	that	you	have	a	list	of	the	available	TV	programs,	you	can:

rearrange	the	order	of	the	programs	using	the	Move	Up	and	Move
Down	buttons.

delete	duplicate	programs	or	programs	with	poor	quality	using	the
Delete	button.

edit	the	programs	using	the	Edit	button	to	give	them	a	name.

Click	OK	to	save	the	current	list	of	programs.



	

	



Watching	TV

1.	Select	the	video	source	and	set	video	parameters

select	the	video	capture	source	(e.g.	a	TV	tuner	card)	from	which
you	want	to	watch	TV	in	the	Devices	menu.	This	is	not	needed	if
you	only	have	one	source.

if	an	Options	>	Crossbar	Video	Input	menu	is	available,	make	sure
that	the	tuner	video	input	is	selected.	It	is	also	recommended	to	tick
Select	Related	Input	in	that	same	menu	to	automatically	switch	to
the	right	audio	input.

if	your	video	capture	source	provides	hardware	compression,	you
may	tick	the	Options	>	MPEG2	menu	for	better	preview	and
capture	performances.

	

2.	Select	the	audio	source	(optional)

If	the	MPEG2	option	is	not	enabled	or	not	supported	by	the	video	capture
source,	you	may	have	to	do	the	following	steps:

select	the	audio	capture	source	corresponding	to	your	tuner	card	in
the	Devices	menu.

select	the	right	audio	input	in	the	Options	>	Audio	Input	menu.

if	an	Options	>	Crossbar	Audio	Input	menu	is	available,	make
sure	the	tuner	audio	input	is	selected.

	

3.	Watch	live	TV

If	you	already	completed	the	steps	from	the	Getting	Started	section	above	to
configure	the	programs,	you	are	ready	otherwise	now	is	the	right	time	to
configure	the	programs.



To	watch	a	program,	first	make	sure	the	Preview	mode	is	enabled:

tick	the	Options	>	Preview	menu	if	it	is	not	already	ticked.

Now	you	can	use	either	the	keyboard	or	possibly	some	mouse	buttons	or
the	keys	of	a	compatible	remote	control	unit	to	change	the	current	program:

press	the	0	to	9	keys	on	the	numeric	keypad	or	on	the	remote	control
unit	to	type	the	number	of	the	program	to	switch	to.

press	the	Page	Up	or	Page	Down	keys	on	the	keyboard	to
respectively	select	the	next	or	the	previous	program.	You	can	do	the
same	from	a	compatible	remote	control	unit,	using	the	Next
Program	and	Previous	Program	keys.

press	the	Browser	Backward	or	Browser	Forward	keys	on	the
keyboard	(these	keys	are	sometimes	mapped	to	some	mouse	buttons
as	well)	to	respectively	select	the	next	or	the	previous	program.

you	can	possibly	control	the	volume	level	of	the	application,	by
using	the	F9	(down)	and	F10	(up)	keys	or	the	mouse	wheel.

	

	

Note:

you	have	to	enable	the	Video	Mixing	Renderer	(VMR)	feature	if	you	want
the	name	of	the	programs	(or	the	channel	numbers	if	no	name	is
configured)	to	show	on-screen	when	you	switch	from	one	program	to
another.	You	enable	the	VMR	from	the	Capture	>	Setup...	menu	>
Options	tab	>	Video	renderer	drop-down	list.

	

	

See	also



Keyboard	Shortcuts

Video	Capture

Video	Preview
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Frequently	Asked	Questions

For	the	most	up-to-date	list	of	questions	please	take	a	look	at
http://noeld.com/amfaq.htm	

1.	I	captured	a	video	using	AMCap	but	when	I	try	to	process	it	in	RegiStax	I
get	a	"Failed	to	decompress	AVI	frame"	message.	Is	it	possible	to	capture
uncompressed	video	with	AMCap?

This	message	is	not	directly	related	to	AMCap.	By	default	AMCap
captures	uncompressed	video.	This	message	usually	means	that	the	.avi
file	is	too	large	and	exceeds	1GB	in	size.	In	RegiStax,	try	to	uncheck	as
many	frames	as	needed	from	the	end	of	the	list	and	try	again	or	use
Windows	Movie	Maker	or	another	video	editor	to	trim	the	file.	Please
visit	the	RegiStax	website	if	you	need	further	assistance	with	this
program.

2.	I	just	installed	a	webcam	but	it	won't	work.	When	I	enable	preview,	I
only	get	a	green	or	a	black	screen	or	I	simply	get	a	message	that	I	don't	have
a	video	capture	hardware	installed	or	"Cannot	add	vidcap	to	filtergraph,
hr=0x80040275".	How	do	I	get	my	webcam	to	work?

As	usual,	there	may	be	a	lot	of	reasons	including	the	worse	one,	a	failing
device.	On	the	other	hand,	you	can	often	fix	such	an	issue	with	one	or
more	of	the	following	steps:

first	off	make	sure	that	your	computer	and	Windows	meet	the
requirements	of	your	webcam	(see	the	user	manual	or	the
manufacturer's	website)

unplug	your	webcam,	reboot	your	system,	plug	your	webcam	and	try
again

unplug	all	other	USB	devices	connected	to	your	PC	and	try	again.	If
that	works,	plug	back	the	USB	devices	one	by	one	to	identify	which

http://noeld.com/amfaq.htm
http://registax.astronomy.net/


one	is	conflicting.

unplug	your	webcam	and	fully	uninstall	the	current	drivers	from
Control	Panel	>	Add	or	Remove	Programs	icon.	Reboot	your
system	then	try	to	reinstall	the	drivers.	Only	plug	the	webcam	after
installation	is	complete	and	possibly	rebooting	(but	if	told	to	do
otherwise.)

check	whether	new	drivers	are	available	for	your	webcam	on	the
manufacturer's	website	and	possibly	install	them

try	my	Webcam	Diagnostics	assistant	and	see	what	errors	(if	any)
are	reported

For	issues	related	to	preview,	you	may	also	try	to:

install	the	latest	DirectX	runtime	from	Windows	Update

install	the	latest	version	of	the	drivers	of	your	graphic	card	available
on	the	manufacturer's	website

3.	When	I	make	captures	there	is	no	sound	recorded.	How	do	I	enable	audio
capture?

Here	are	the	most	common	options	and	features	to	configure:

In	AMCap:

click	the	Devices	menu	and	make	sure	a	sound	card	or	a
webcam	microphone	is	ticked

in	Capture	menu,	tick	Capture	Audio

In	the	system:

double-click	the	Volume	icon	near	the	clock	on	the	taskbar	(the
icon	looks	like	a	speaker,	it	may	be	hidden	in	that	case	you
have	to	enabled	it	from	the	Control	Panel)

in	Volume	Control	applet,	click	Options	>	Properties	menu

http://omega/programs.asp?cat=video#camdiag
http://windowsupdate.microsoft.com/


select	the	Mixer	device	if	you	have	many

click	Recording

make	sure	Microphone	or	Line	In	(or	any	other	audio	input
from	which	you	want	to	capture)	is	ticked

click	OK

in	Recording	Control	applet,	tick	the	Select	box	of	the	audio
input	from	which	you	want	to	capture	audio

adjust	the	Volume	level	of	that	input

4.	The	preview	is	mirrored	or	flipped.	How	do	I	fix	this?

This	is	either	due	to	the	chosen	Color	Space	/	Compression	or	an	issue	with
the	driver	of	the	video	capture	source.	You	can	try	the	following	steps:

click	Options	>	Video	Capture	Pin...	and	choose	another
Color	Space	/	Compression

Try	to	reinstall	the	drivers	of	your	video	capture	source
(possibly	your	graphic	card)

install	the	latest	version	of	the	drivers	of	the	video	capture
source	from	the	manufacturer's	website

Alternatively,	you	may	use	the	View	>	Flip	View	menu.

5.	There	is	no	sound	at	all	during	the	preview.	How	do	I	fix	this?

First	make	sure	that	the	right	audio	device	is	ticked	in	the	Devices
menu.

Click	the	Options	>	Audio	Capture	Filter...	menu

Under	Pin	Line,	select	the	appropriate	input	(if	there	are	many)	then
tick	Enable

Adjust	the	volume	with	the	Pin	Line	Input	Mix	slider



Click	OK	to	apply	the	new	settings

Note:	you	can	also	adjust	the	audio	properties	from	the	Volume	applet	(in
the	notification	area,	formerly	the	system	tray)	Options	>	Properties	menu
>	Recording	option	(see	FAQ	#3).

6.	When	I	try	to	preview	during	a	recording,	I	get	an	error	"0x80070057"?
What	does	that	mean?

The	error	code	simply	means	invalid	parameter.	It	does	not	give	much	clue
about	what	fails.	This	can	be	due	to	the	capture	driver	or	the	graphic	drivers
or	an	incompatibility	in	the	current	settings.	Try	these	few	steps:

first	restart	your	system	and	make	a	new	test,	if	the	problem	persists
try	the	other	steps	below

clear	Capture	>	Still	>	Enable

clear	View	(or	Window)	>	VMR9	>	Enable

clear	Options	>	MPEG-2	if	your	capture	source	is	not	MPEG-2

Try	again.	If	the	problem	persists,	visit	the	websites	of	the	manufacturers	of
both	your	capture	source	and	your	display	card	and	check	if	updated	drivers
are	available.	If	some	new	drivers	are	available,	restart	your	system	and	try
to	install	them.

If	you	are	not	using	the	latest	update	of	DirectX,	you	may	also	consider
installing	it	from	Windows	or	Microsoft	Update.

7.	I	get	an	error	(possibly	0x80070057)	when	I	click	View	>	Flip	View	>	Flip,
Mirror	or	Rotate	and	the	view	is	not	flipped	or	mirrored?	What	can	I	do	to
flip	the	view?

The	error	code	simply	means	invalid	(or	unsupported)	parameter.	The
driver	of	your	video	source	may	not	support	flipping	and	mirroring,	this	is
not	a	required	feature.	Try	using	the	VMR9	instead:	click	View	>	VMR9	>
Enable.

http://windowsupdate.microsoft.com/


8.	What	is	VMR9	and	what	are	the	requirements?

VMR9	means	Video	Mixing	Renderer	version	9.	It	is	an	optimized	and
enhanced	video	renderer	provided	with	DirectX	9.0	and	later.	If	the	option
is	grayed	out	in	the	View	menu,	you	need	to	install	the	latest	DirectX	9.0
runtime	available	from	the	Windows	or	Microsoft	Update	website.

9.	The	files	I	captured	do	not	play	after	a	certain	size	on	my	Windows	98
system.	What	are	the	file	size	limits?

The	file	size	limit	does	not	only	depend	on	the	installed	Windows	system
but	also	on	the	file	system	which	is	either	FAT16,	FAT32	or	NTFS.	The	size
may	also	be	limited	by	the	underlying	capture	technology.	The	common	file
size	limits	are	like	this:

File	system File	size	limit
FAT16	(Windows	9x/ME) 2GB	-	1	byte
FAT16	(Windows	NT	and	later) 4GB	-	1	byte
FAT32 4GB	-	1	byte
NTFS 2TB	-	1	byte

10.	Whenever	I	try	and	select	Still	capture	mode	(or	Preview	with	selecting
Still	capture	enabled),	I	get	the	following	message:	"CreateGrabber:
CoCreateInstance	failed,	hr=0x80040154".	What	does	that	mean	and	how
do	I	get	still	capture	to	work?

The	error	means	that	the	Sample	Grabber,	a	software	component	used	to
make	the	still	captures,	is	not	installed	or	registered	in	your	system.	This
usually	means	that	the	version	of	DirectX	installed	on	your	PC	is	outdated.
To	fix	this	issue,	go	to	the	Windows	or	Microsoft	Update	website	and	install
the	latest	version	of	DirectX.

11.	The	preview	is	in	black	and	white.	How	do	I	turn	the	color	mode	on?

http://windowsupdate.microsoft.com/
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There	may	be	different	reasons	for	a	B/W	display:

If	you	have	a	video	capture	card	that	supports	different	standards
like	PAL	or	NTSC,	make	sure	that	it	is	set	to	the	correct	mode	for
the	input	signal.	To	change	it,	go	to	Options	>	Video	Capture
Filter...	and	set	the	Video	Standard	(PAL	in	Europe,	SECAM	in
France,	NTSC	in	US	and	Japan,	etc.)

If	you	changed	many	settings	and	you	cannot	remember	which	ones,
you	can	simply	delete	the	AMCap.ini	file	after	closing	the	program.
If	B/W	preview	remains	after	the	program	is	restarted,	make	sure
that	the	brightness	and	contrast	levels	are	correct.	To	do	so,	click	the
Options	>	Video	Capture	Filter...	menu	and	adjust	the
brightness/contrast	levels.	If	you	have	a	Restore	Factory	Defaults
button,	just	click	it.	Also	if	a	Black	and	White	checkbox	is
available,	clear	it	if	it	is	ticked.

Finally	check	whether	the	latest	version	of	the	drivers	of	your	video
capture	source	is	installed	in	your	system,	some	drivers	simply	don't
restore	or	don't	report	the	default	settings	correctly.

12.	I'd	like	to	capture	some	video	in	PAL	60Hz	at	30fps	but	AMCap	does
not	allow	me	to	set	a	frame	rate	above	25fps.	Is	there	a	workaround?

By	default,	PAL	is	a	video	standard	at	50Hz	and	25	frames	per	second	(fps).
To	capture	at	30	fps,	you	have	to	select	PAL_60	in	the	Video	Standard
drop-down	list	from	the	Options	>	Video	Capture	Filter...	menu.	You	can
then	go	to	Options	>	Video	Capture	Pin...	and	set	Frame	Rate	to	30.	If
PAL_60	is	not	available	in	the	list,	the	driver	of	your	video	capture	source
or	the	hardware	itself	may	not	support	it.

13.	I	get	the	following	error	on	startup:	"STIRegisterApplication:	could	not
instantiate	IStillImage,	hr=0x80040154".	I	press	OK	and	everything	runs
fine.	How	do	I	fix	this?

You	are	most	probably	using	a	Windows	version	that	does	not	support	STI
(e.g.	Windows	2000	and	older).	To	avoid	the	message	at	startup,	clear



Capture	>	Still	>	Register	for	STI	Events.

14.	What	is	the	"capture	file"?	What	file	do	I	have	to	select?

The	capture	file	is	a	single	working	file	that	is	not	fragmented	and	that	will
be	used	by	the	program	and	the	underlying	system	(DirectShow)	to
temporarily	store	the	captured	video.	After	every	capture,	you	can	save	the
actual	video	by	using	the	File	>	Save	Capture	Video...	menu.

By	default,	the	capture	file	is	called	capture.avi	and	is	located	in	the	root	of
your	primary	hard	drive,	in	other	words	it	usually	is	c:\capture.avi.	This
must	be	a	new	file,	don't	select	an	existing	file	otherwise	it	will	be
overwritten	during	the	capture	or	the	file	allocation.

15.	When	I	enabled	the	Windows	Media	9	Series	compression	and	I	attempt
to	capture	a	video	file,	I	always	get	the	following	error:	"Cannot	set	output
file,	hr=0x80040154".	What	does	that	error	mean	and	how	do	I	fix	it?

The	error	means	that	DirectShow	is	unable	to	locate	the	required	Windows
Media	ASF	Writer	Filter.	This	component	is	not	installed	by	default	by	the
system	and	is	only	available	as	a	redistributable	component	as	part	of	the
Windows	Media	Format	installer.	You	can	download	the	installer	here	or
click	Help	>	Redistributable	Components	>	Windows	Media	Format	in
AMCap.

16.	While	installing	my	webcam,	a	message	popped	up	and	told	me	that	the
drivers	did	not	pass	the	Windows	Logo	testing	and	now	AMCap	says	that
no	video	capture	source	is	installed.	What's	wrong	and	how	do	I	possibly	fix
this	issue?

Drivers	that	pass	the	Windows	Logo	testing	are	tested	and	then	digitally
signed	by	Microsoft,	this	ensures	that	the	drivers	meet	the	quality	and
stability	requirements.	Unsigned	drivers	don't	usually	mean	that	they	are
poor	or	unreliable,	that	just	means	that	they	were	not	tested	by	Microsoft.
Because	unstable	drivers	may	lead	the	system	to	crash	and	give	blue

http://omega/dl.asp?path=wmfdist95.exe


screens	(BSOD),	the	newest	64-bit	editions	of	Windows	may	require	signed
drivers	to	ensure	overall	stability.

In	general,	it	is	recommended	that	you	visit	the	website	of	the	manufacturer
to	get	the	latest	signed	drivers	for	your	devices.	Only	install	unsigned
drivers	if	you	don't	have	a	better	choice.

When	installing	unsigned	drivers,	a	dialog	box	pops	up	with	a	message	like
this:

Hardware	Installation

<your	webcam	driver>

has	not	passed	Windows	Logo	testing	to	verify	its	compatibility	with	Windows	XP	(...)

This	dialog	has	two	buttons:	Continue	Anyway	and	STOP	Installation.	If
you	hit	the	STOP	Installation	button	or	press	the	Enter	key,	the	drivers
won't	install,	this	is	probably	what	happened	in	your	case.

If	the	manufacturer	does	not	have	signed	drivers,	complete	the	following
steps	to	make	sure	that	your	system	is	not	configured	to	never	install
unsigned	driver	software	by	default:

Click	Start

right-click	My	Computer

click	Properties

click	the	Hardware	tab

click	the	Driver	Signing	button

tick	Warn	and	Make	this	action	the	system	default

click	OK	twice	to	close	the	property	pages

You	will	now	be	warned	when	installing	unsigned	drivers	but	this	won't
prevent	you	from	installing	them.	Once	you	did	this,	run	the	drivers
installation	again.	When	the	Hardware	Installation	dialog	box	pops	up
again,	click	Continue	Anyway	to	complete	the	drivers	installation.



Copyright	©	Noël	DANJOU.	All	rights	reserved.



Copyright	Information

Information	in	this	document,	including	URL	and	other	Internet	Web	site
references,	is	subject	to	change	without	notice.

Without	limiting	the	rights	under	copyright,	no	part	of	this	document	may	be
reproduced,	stored	in	or	introduced	into	a	retrieval	system,	or	transmitted	in	any
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otherwise),	or	for	any	purpose,	without	the	express	written	permission	of	the
author.
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