
Getting	Started	with	the	Control	Design
Assistant
June	2008,	371245B–01
This	help	file	contains	exercises	to	teach	you	how	to	load	and	save
models,	perform	analysis	on	systems,	and	design	controllers	using	the
LabVIEW	Control	Design	Assistant.	You	can	learn	how	to	complete	the
following	procedures:

Launch	the	LabVIEW	Control	Design	Assistant	in	the	LabVIEW
SignalExpress	environment
Load	models	and	view	model	information
Perform	pole-zero,	time	domain,	and	frequency	domain	analysis
on	systems
Design	and	verify	controllers
Save	models	to	file

The	exercises	in	this	help	file	take	a	short	amount	of	time	to	complete.
However,	each	section	of	this	help	file	builds	upon	previous	sections	so
you	should	complete	each	exercise	in	order.
©	2004–2008	National	Instruments	Corporation.	All	rights	reserved.
Next:	Control	Design	Assistant	Related	Documentation
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Control	Design	Assistant	Related
Documentation
The	following	documents	contain	information	that	you	might	find	helpful
as	you	use	the	LabVIEW	Control	Design	Assistant.

Note		You	must	install	LabVIEW	and	the	LabVIEW	Control	Design
and	Simulation	Module	to	access	the	following	manuals.
LabVIEW	Control	Design	User	Manual—Use	this	manual	to	learn
more	about	the	main	steps	in	the	control	design	process	and	how
to	develop	a	control	design	system	using	the	LabVIEW	Control
Design	and	Simulation	Module.	Access	this	manual	by	navigating
to	the	labview\manuals	directory	and	double-clicking
CD_User_Manual.pdf.
Getting	Started	with	LabVIEW—Use	this	manual	as	a	tutorial	to
familiarize	yourself	with	the	LabVIEW	graphical	programming
environment	and	the	basic	LabVIEW	features	you	use	to	build
data	acquisition	and	instrument	control	applications.	Access	this
manual	by	navigating	to	the	labview\manuals	directory	and	double-
clicking	LV_Getting_Started.pdf.
LabVIEW	Fundamentals—Use	this	manual	to	learn	about
LabVIEW	programming	concepts,	techniques,	features,	VIs,	and
functions	you	can	use	to	create	test	and	measurement,	data
acquisition,	instrument	control,	datalogging,	measurement
analysis,	and	report	generation	applications.	Access	this	manual
by	navigating	to	the	labview\manuals	directory	and	double-clicking
LV_Fundamentals.pdf.
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Before	You	Begin
System	Requirements
The	LabVIEW	Control	Design	Assistant	requires	a	minimum	of	256	MB	of
RAM	and	a	Pentium	III	or	later	or	Celeron	866	MHz	or	equivalent
processor.	National	Instruments	recommends	512	MB	of	RAM	and	a
Pentium	4/M	or	equivalent	processor.
You	can	install	the	Control	Design	Assistant	without	installing	LabVIEW
on	the	host	computer.	However,	to	convert	projects	created	with	the
Control	Design	Assistant	into	LabVIEW	block	diagrams,	you	must	install
and	be	a	properly	licensed	user	of	the	LabVIEW	8.6	or	later	Full	or
Professional	Development	System.
Refer	to	Activating	Your	Software	for	information	about	activating	this
software.
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Printing	the	Help	File
You	can	print	this	help	file	if	you	want	to	refer	to	a	printed	copy	while
completing	the	exercises.	Complete	the	following	steps	to	print	this	help
file.

1.	 Click	the	Contents	tab	of	the	LabVIEW	SignalExpress	Help	to
display	the	contents.

2.	 Expand	the	Getting	Started	book.
3.	 Right-click	the	Getting	Started	with	the	Control	Design

Assistant	book	and	select	Print	from	the	shortcut	menu	to	open
the	Print	Topics	dialog	box.

4.	 Select	Print	the	selected	heading	and	all	subtopics.
5.	 Click	the	OK	button.

Previous:	Control	Design	Assistant
Related	Documentation
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1.	Launching	the	Control	Design	Assistant
You	can	use	the	LabVIEW	Control	Design	Assistant	to	develop
mathematical	models	that	describe	a	physical	system,	analyze	the
models	to	learn	about	their	dynamic	characteristics,	and	create
controllers	to	achieve	desired	dynamic	characteristics.	In	the	following
exercises,	you	will	load	and	analyze	a	model	and	create	a	controller	that
improves	the	stability	of	the	closed-loop	system.
Complete	the	following	steps	to	launch	the	Control	Design	Assistant	in
the	default	configuration	if	you	have	not	done	so	already.

1.	 Launch	the	Control	Design	Assistant	by	selecting	Start»All
Programs»National	Instruments»LabVIEW	Control	Design
Assistant»LabVIEW	Control	Design	Assistant.	The	Control
Design	Assistant	launches	within	the	LabVIEW	SignalExpress
environment.

To	launch	the	Control	Design	Assistant	from	LabVIEW,	select
Tools»Control	Design	and	Simulation»Launch	Control
Design	Assistant.

2.	 The	LabVIEW	SignalExpress	environment	opens	in	the	default
configuration.	The	Project	View	is	the	blank	white	rectangle	on
the	left	side	of	the	LabVIEW	SignalExpress	environment.	The
Data	View	is	the	green	coordinate	grid	on	the	black	background
in	the	middle	of	the	LabVIEW	SignalExpress	environment.	The
context	help	window	is	the	window	on	the	right	side	of	the
LabVIEW	SignalExpress	environment	that	displays	the	How	do	I
get	help?	and	Context	Help	topics.

3.	 If	the	graph	does	not	appear	in	the	Data	View,	select	View»Data
View	to	display	the	Data	View.

4.	 If	the	context	help	window	does	not	appear,	select	Help»Context
Help	to	display	the	context	help	window.

Previous:	Before	You	Begin Next:	2.	Loading	Models
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2.	Loading	Models
You	can	use	the	LabVIEW	Control	Design	Assistant	to	load	linear	time-
invariant,	or	.lti,	files	into	the	LabVIEW	SignalExpress	environment.	A	.lti
file	stores	control	design	linear	time-invariant	models.
Complete	the	following	steps	to	load	a	sample	model	in	the	LabVIEW
SignalExpress	environment.

1.	 Click	the	Add	Step	button,	shown	below,	to	open	the	Add	Step
menu.

A	step	is	a	configurable	function	that	acquires,	generates,
analyzes,	loads,	or	stores	signals	and	system	data.	Steps
process	input	data	and	produce	output	data.	You	can	configure
the	operation	of	steps	by	specifying	values	in	the	configuration
view,	or	Step	Setup	tab,	for	each	step.	You	create	projects	by
adding	steps	to	the	Project	View.

2.	 Select	Control	Design»Import/Export	Model»Load	Control
Design	Model	to	add	a	Load	Control	Design	Model	step	to	the
Project	View.	The	Step	Setup	tab	for	the	Load	Control	Design
Model	step	appears.

Tip		When	you	move	the	cursor	over	a	step	in	the	Add
Step	menu,	a	description	of	that	step	appears	in	the	help
window	at	the	bottom	of	the	Add	Step	menu.

3.	 In	the	Step	Setup	tab,	click	the	Browse	button,	shown	below,
next	to	the	File	name	text	box	and	navigate	to	the	National
Instruments\Control	Design	Assistant\Examples	directory.

4.	 Double-click	the	cdmodel.lti	data	file	to	load	the	model.

The	cdmodel.lti	file	contains	an	open-loop	model.
5.	 Click	Record	0	in	the	Information	in	file	table.

The	Information	in	file	table	displays	information	about	the
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loaded	model.	For	example,	the	model	in	the	cdmodel.lti	file	is	a
zero-pole-gain	SISO	model.

6.	 Click	the	Data	View	tab	to	display	the	Data	View.
7.	 In	the	Project	View,	right-click	the	Imported:	0	output	and	select

Rename	from	the	shortcut	menu	to	give	the	signal	a	more
intuitive	name.	Change	the	name	of	this	output	to	Model	Data.

You	can	create	a	probe	to	obtain	information	about	a	signal.	In
the	Project	View,	right-click	the	Model	Data	output	and	select
Probe	from	the	shortcut	menu	to	create	the	probe.	Notice	that
the	probe	displays	information	about	the	output,	including	which
step	you	used	to	generate	the	output.	Close	the	probe.

8.	 Click	the	Model	Data	output	of	the	Load	Control	Design	Model
step	and	drag	it	from	the	Project	View	to	the	Data	View	to	display
a	diagram	of	the	model.

9.	 Right-click	the	Data	View	and	select	Model	Type»State-Space
from	the	shortcut	menu	to	view	the	model	as	a	state-space
model.	Right-click	the	Data	View	again	and	select	Model
Type»Zeros	and	Poles	to	view	the	model	as	a	zero-pole-gain
model.

Note		Changing	the	model	type	in	this	way	does	not
convert	the	model	type	as	the	Type	Conversion	step	does.
Only	the	display	changes	to	show	the	model	as	a	different
type.

10.	 Select	File»Save	Project	As	and	save	this	project	as	My	Sample
Project.seproj	to	an	easily	accessible	location.	A	.seproj	file	is	a
LabVIEW	SignalExpress	project,	which	refers	to	the	LabVIEW
SignalExpress	environment	in	which	the	Control	Design	Assistant
resides.

Previous:	1.	Launching	the	Control
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3.	Performing	a	Pole-Zero	Analysis
You	can	use	the	LabVIEW	Control	Design	Assistant	to	analyze	models	to
learn	about	the	dynamic	characteristics	of	a	system.
Complete	the	following	steps	to	analyze	the	poles	and	zeros	of	the
model.

1.	 Right-click	the	empty	white	area	of	the	Project	View	and	select
Control	Design»Model	Analysis»Pole-Zero	Analysis	from	the
shortcut	menu	to	add	a	Pole-Zero	Analysis	step.

Note		In	the	Project	View,	a	blue	arrow	indicates	an	output
of	a	step.	A	red	arrow	indicates	the	input	of	a	step.	The
blue	and	red	arrows	are	shown	below.
		step	output

		step	input

2.	 Click	the	Input	Data	tab	on	the	Step	Setup	tab	and	verify	that
Model	Data,	the	loaded	model,	is	the	input	in	the	Model	pull-
down	menu.	You	can	use	any	outputs	from	previous	steps	in	the
project	as	inputs	for	later	steps.

3.	 Click	the	Pole-Zero	Analysis	tab	and	notice	that	the	Stability
control	indicates	the	system	is	stable.

4.	 Remove	the	checkmarks	from	the	Autoscale	Real	Axis	(X)	and
Autoscale	Imaginary	Axis	(Y)	checkboxes.

5.	 Select	0.5	at	the	top	of	the	Imaginary	axis	of	the	Pole-Zero	Map
graph	and	enter	1.0	to	change	the	axis	on	the	graph.

6.	 Select	–0.5	at	the	bottom	of	the	Imaginary	axis	of	the	Pole-Zero
Map	graph	and	enter	–1.0	to	display	the	entire	unit	circle	of	the
model.

Notice	that	the	poles	of	the	model	are	less	than	1	and	within	the
unit	circle.	The	numerical	values	of	the	zeros	and	poles	locations
appear	in	the	Zeros	and	Poles	tables.
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4.	Performing	a	Time	Domain	Analysis
Complete	the	following	steps	to	analyze	the	time	domain	response	of	the
model.

1.	 From	the	LabVIEW	SignalExpress	menu	bar,	select	Add
Step»Control	Design»Model	Analysis»Time	Domain	Analysis
to	add	a	Time	Domain	Analysis	step.

Notice	that	the	Step	Setup	tab	changes	from	displaying	the
configuration	view	of	the	Pole-Zero	Analysis	step	to	displaying
the	configuration	view	of	the	Time	Domain	Analysis	step.

2.	 On	the	Configuration	tab	of	the	Step	Setup	tab,	verify	that	Step
is	the	type	of	analysis	in	the	Time	Analysis	pull-down	menu.

3.	 Click	the	Parametric	Data	tab	to	view	the	row	of	parametric	data,
which	indicates	system	characteristics	such	as	peak	time	and
settling	time.

4.	 Click	the	Data	View	tab	to	view	the	Data	View.
5.	 In	the	Project	View,	right-click	the	Signal0	output	and	select

Rename	from	the	shortcut	menu.	Change	the	name	of	this	output
to	Step	Response.

Tip		When	you	move	the	cursor	over	a	renamed	input	or
output	in	the	Project	View,	a	dialog	bubble	appears	with
both	the	new	name	and	the	original	name	of	the	input	or
output.	You	also	can	use	this	bubble	to	view	the	entire
name	of	the	input	or	output	if	the	width	of	the	Project	View
is	too	small	to	view	the	full	name.

6.	 Click	the	Step	Response	output	of	the	Time	Domain	Analysis
step	and	drag	it	from	the	Project	View	to	the	Data	View	to	display
the	step	response	on	the	graph.

Previous:	3.	Performing	a	Pole-
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5.	Performing	a	Frequency	Domain	Analysis
Complete	the	following	steps	to	analyze	the	frequency	response	of	the
model.

1.	 In	the	Project	View,	right-click	the	Time	Domain	Analysis	step	and
select	Insert	After»Control	Design»Model
Analysis»Frequency	Domain	Analysis	from	the	shortcut	menu
to	add	a	Frequency	Domain	Analysis	step	after	the	Time	Domain
Analysis	step.

2.	 On	the	Configuration	tab	of	the	Step	Setup	tab,	verify	that
Bode	is	the	type	of	analysis	in	the	Analysis	Type	pull-down
menu.

3.	 Verify	that	Hz	is	the	unit	of	frequency	selected	in	the	Frequency
Unit	pull-down	menu.

4.	 Click	the	Frequency	Analysis	tab	to	view	the	analysis	data	of
the	model.

5.	 Click	the	Data	View	tab	to	view	the	Data	View.
6.	 In	the	Project	View,	right-click	the	Magnitude0	output	and	select

Rename	from	the	shortcut	menu.	Change	the	name	of	this	output
to	Bode	Magnitude.

7.	 Rename	the	Phase0	output	to	Bode	Phase.
8.	 Click	the	Bode	Magnitude	output	of	the	Frequency	Domain

Analysis	step	and	drag	it	from	the	Project	View	to	the	Data	View
to	display	the	Bode	Magnitude	plot	in	the	Data	View.	You	can
repeat	this	step	with	the	Bode	Phase	output.

Note		You	can	remove	displays	from	the	Data	View	by
right-clicking	the	display	that	you	want	to	remove	and
selecting	Data	View»Remove	Display	from	the	shortcut
menu.

9.	 Right-click	the	Bode	Magnitude	graph	and	select	X
Scale»Logarithmic	from	the	shortcut	menu	to	change	the	X
scale	to	logarithmic	format.	You	can	repeat	this	step	with	the
Bode	Phase	graph.

Previous:	4.	Performing	a	Time	Domain
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6.	Designing	Controllers
You	can	use	the	LabVIEW	Control	Design	Assistant	to	create	controllers
to	achieve	desired	dynamic	characteristics	in	a	system.
Complete	the	following	steps	to	use	the	PID	Synthesis	step	to	design	a
controller	for	the	model	to	cause	the	model	to	stabilize	faster.

1.	 In	the	Project	View,	right-click	the	Frequency	Domain	Analysis
step	and	select	Insert	After»Control	Design»Controller
Design»PID	Synthesis	from	the	shortcut	menu	to	add	a	PID
Synthesis	step	after	the	Frequency	Domain	Analysis	step.

2.	 On	the	Controller	Synthesis	tab	of	the	Step	Setup	tab,	verify
that	a	checkmark	is	placed	in	the	Gain	checkbox.

3.	 Set	the	scale	control	to	5.
Note		You	also	can	enter	5	in	the	Gain	numeric	control
under	the	scale.

4.	 Place	a	checkmark	in	the	Integral(s)	checkbox	and	enter	0.02	in
the	Integral(s)	numeric	control.

5.	 Click	the	Model	Output	tab	to	view	a	diagram	of	the	model.

Notice	that	Closed	Loop	(r-y)	is	one	of	the	systems	that	the	PID
Synthesis	step	creates.	Configuring	the	PID	Synthesis	step
creates	a	controller	that	changes	the	system	to	a	closed-loop
system.	The	Step	Response	graph	displays	the	response	of	the
closed-loop	system.

6.	 Click	the	Data	View	tab	to	view	the	Data	View.
7.	 Right-click	the	diagram	of	the	Model	Data	output	in	the	Data

View	and	select	Add	Display»Right	from	the	shortcut	menu	to
add	a	new	display.

8.	 Click	the	Closed	Loop	Model	output	of	the	PID	Synthesis	step
and	drag	it	from	the	Project	View	to	the	added	display	in	the	Data
View	to	display	information	about	the	model,	including	its	name,
type,	and	structure.

Previous:	5.	Performing	a	Frequency	Domain
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7.	Verifying	Controllers
Complete	the	following	steps	to	use	the	Time	Domain	Analysis	step	to
verify	the	controller	for	the	model.

1.	 Click	the	Add	Step	button	to	open	the	Add	Step	menu.
2.	 Select	Control	Design»Model	Analysis»Time	Domain

Analysis	to	add	a	Time	Domain	Analysis	step	to	the	Project
View.

3.	 On	the	Input	Data	tab	of	the	Step	Setup	tab,	select	Closed
Loop	Model	from	the	Model	pull-down	menu	to	analyze	the
Closed	Loop	Model	input	from	the	PID	Synthesis	step.

4.	 On	the	Configuration	tab,	verify	that	Step	is	the	type	of	analysis
in	the	Time	Analysis	pull-down	menu.

The	Step	Response	graph	displays	the	same	response	data	as
the	Step	Response	graph	in	the	Step	Setup	tab	of	the	PID
Synthesis	step.

5.	 Click	the	Parametric	Data	tab	to	view	the	parametric	data.

The	settling	time	and	the	rise	time	are	lower	for	this	closed-loop
model	than	for	the	previous	open-loop	model	in	the	first	Time
Domain	Analysis	step.	These	lower	settling	and	rise	times
indicate	that	the	system	stabilizes	faster.

6.	 Click	the	Data	View	tab	to	view	the	Data	View.
7.	 In	the	Project	View,	right-click	the	Signal0	output	in	the	Project

View	and	select	Rename	from	the	shortcut	menu.	Change	the
name	of	this	output	to	Controlled	Response.

8.	 Click	the	Controlled	Response	output	of	the	Time	Domain
Analysis	step	and	drag	it	from	the	Project	View	to	the	Step
Response	graph	in	the	Data	View	to	display	the	analysis	data	on
the	same	graph	as	the	Step	Response	output.

Notice	that	the	Controlled	Response	output	shows	faster
settling	and	rise	times	than	the	Step	Response	output.

Previous:	6.	Designing	Controllers Next:	8.	Saving	Models
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8.	Saving	Models
Complete	the	following	steps	to	save	the	closed-loop	model.

1.	 Click	the	Add	Step	button	to	open	the	Add	Step	menu.
2.	 Select	Control	Design»Import/Export	Model»Save	Control

Design	Model	to	add	a	Save	Control	Design	Model	step	to	the
Project	View.

3.	 Click	the	Browse	button	next	to	the	File	name	text	box	and
navigate	to	the	directory	in	which	you	want	the	LabVIEW	Control
Design	Assistant	to	save	the	model.

4.	 Enter	closedloopmodel.lti	in	the	File	name	text	box	and	click	the
OK	button.

5.	 Select	Closed	Loop	Model	from	the	Model	pull-down	menu.

The	Control	Design	Assistant	saves	the	closed-loop	model	as
closedloopmodel.lti	in	this	directory	each	time	you	run	this	project.
The	Information	in	file	table	displays	information	about	the
saved	model.	You	also	can	use	this	saved	model	in	LabVIEW.

6.	 Click	the	Data	View	tab	to	view	the	Data	View.
7.	 Run	the	project	once	by	clicking	the	down	arrow	next	to	the	Run

button,	shown	below,	on	the	LabVIEW	SignalExpress	toolbar	and
selecting	Run	Once	from	the	shortcut	menu.

The	steps	in	a	project	do	not	execute	until	you	run	the	project.
8.	 Verify	that	closedloopmodel.lti	is	saved	in	the	directory	that	you

specified.	You	now	have	a	saved,	accurate	model	of	the	closed-
loop	system.	You	can	use	the	Load	Model	step	to	load	this	model
to	a	project.

9.	 Select	File»Save	Project	to	save	the	project.
Previous:	7.	Verifying
Controllers
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Extending	Control	Design	Assistant	Projects
with	LabVIEW
In	this	help	file,	you	learned	how	to	complete	the	following	procedures:

Launch	the	LabVIEW	Control	Design	Assistant	in	the	LabVIEW
SignalExpress	environment
Load	models	and	view	model	information
Perform	pole-zero,	time	domain,	and	frequency	domain	analysis
on	systems
Design	and	verify	controllers
Save	models	to	file

Not	only	can	you	use	LabVIEW	SignalExpress	projects	with	the	Control
Design	Assistant,	but	you	also	can	extend	the	projects	to	interact	with	the
LabVIEW	environment.
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Converting	to	Block	Diagrams
Without	prior	knowledge	about	programming	in	LabVIEW,	you	can	use
the	Control	Design	Assistant	to	analyze	models	that	describe	a	physical
system	and	synthesize	controllers	to	achieve	desired	dynamic
characteristics.	The	LabVIEW	Control	Design	and	Simulation	Module
also	provides	LabVIEW	VIs	that	you	can	use	to	complete	the	entire
control	design	process.
You	can	use	LabVIEW	to	convert	Control	Design	Assistant	projects	to
LabVIEW	block	diagrams	to	continue	developing	an	application.	You	first
can	use	the	interactive	tools	in	the	Control	Design	Assistant	to	analyze
models	and	design	controllers.	You	then	can	convert	the	sequence	into	a
LabVIEW	block	diagram	to	enhance	the	capabilities	of	the	application.
The	Control	Design	Assistant	converts	projects	into	block	diagrams	using
the	VIs	that	ship	with	the	Control	Design	and	Simulation	Module.	The
Control	Design	steps	in	the	Add	Step	menu	do	not	convert	into	Express
VIs.
Unlike	creating	a	project	with	the	Control	Design	Assistant,	creating	a
LabVIEW	application	using	the	Control	Design	VIs	requires	basic
knowledge	about	programming	in	LabVIEW.	Refer	to	the	LabVIEW
Fundamentals	manual	and	the	Getting	Started	with	LabVIEW	manual	for
more	information	about	the	LabVIEW	programming	environment.	In
LabVIEW,	access	these	manuals	by	clicking	the	corresponding	links	in
the	Getting	Started	window.	Refer	to	the	LabVIEW	Help	for	more
information	about	LabVIEW	VIs	and	functions.	In	LabVIEW,	access	this
help	file	by	selecting	Help»Search	the	LabVIEW	Help.

expresswb.chm::/Convert_Step_to_LV.html
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Sweeping
The	Sweep	step	repeatedly	performs	measurements	with	different
parameter	values.	The	Control	Design	Assistant	converts	the	Sweep	step
into	a	For	Loop	in	a	LabVIEW	block	diagram.	The	Control	Design	steps	in
the	Add	Step	menu	can	exist	within	a	sweep,	but	they	do	not	provide
parameters	that	you	can	use	within	a	sweep.
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Using	User-Defined	Steps
You	can	build	a	user-defined	VI	to	use	in	a	Run	LabVIEW	VI	step.	The
Run	LabVIEW	VI	step	runs	a	VI	in	the	LabVIEW	SignalExpress
environment.	When	you	import	a	LabVIEW	VI,	the	Control	Design
Assistant	maps	the	inputs	of	the	VI	as	parameters	and	the	outputs	of	the
VI	as	outputs	by	default.
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Further	Examples
The	Control	Design	Assistant	provides	several	other	example	projects
that	demonstrate	more	capabilities	of	the	Control	Design	Assistant.
These	projects	are	located	in	the	National	Instruments\Control	Design
Assistant\Examples	directory.	You	can	modify	an	example	project	to	fit	an
application,	or	you	can	copy	and	paste	from	one	or	more	examples	into	a
project	that	you	create.
You	can	find	the	solution	project,	My	Sample	Project	Solution.seproj,	to	the
exercises	in	this	help	file,	as	well	as	an	example	of	the	closed-loop	model
you	created,	closedloopmodel.lti,	in	the	National	Instruments\Control	Design
Assistant\Examples	directory.
Previous:	8.	Saving	Models


