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Conventions
This	help	file	uses	the	following	conventions:

<	> Angle	brackets	that	contain	numbers	separated	by	an	ellipsis
represent	a	range	of	values	associated	with	a	bit	or	signal
name—for	example,	DBIO<3..0>.

» The	»	symbol	leads	you	through	nested	menu	items	and
dialog	box	options	to	a	final	action.	The	sequence	File»Page
Setup»Options	directs	you	to	pull	down	the	File	menu,
select	the	Page	Setup	item,	and	select	Options	from	the	last
dialog	box.
This	icon	denotes	a	note,	which	alerts	you	to	important
information.
This	icon	denotes	a	caution,	which	advises	you	of
precautions	to	take	to	avoid	injury,	data	loss,	or	a	system
crash.

bold Bold	text	denotes	items	that	you	must	select	or	click	on	in	the
software,	such	as	menu	items	and	dialog	box	options.	Bold
text	also	denotes	parameter	names,	emphasis,	or	an
introduction	to	a	key	concept.

dark	red Text	in	this	color	denotes	a	caution.
green Underlined	text	in	this	color	denotes	a	link	to	a	help	topic,

help	file,	or	Web	address.
italic Italic	text	denotes	variables	or	cross	references.	This	font

also	denotes	text	that	is	a	placeholder	for	a	word	or	value
that	you	must	supply.

monospace Text	in	this	font	denotes	text	or	characters	that	you	should
enter	from	the	keyboard,	sections	of	code,	programming
examples,	and	syntax	examples.	This	font	is	also	used	for
the	proper	names	of	disk	drives,	paths,	directories,
programs,	subprograms,	subroutines,	device	names,
functions,	operations,	variables,	filenames	and	extensions,
and	code	excerpts.



IVI	Soft	Front	Panels	Help	Overview
The	following	three	types	of	help	are	available	in	IVI	Soft	Front	Panels:

Tip	strips	help	appears	when	your	cursor	pauses	over	a	user
interface	control	or	item.		You	can	turn	this	feature	on	or	off	by
selecting	Help»Show	Tip	Strips	Help.
Pop-up	context	help	appears	in	the	Pop-up	Help	window	when
your	cursor	pauses	over	a	user	interface	control	or	item.
Information	in	the	window	describes	the	function	or	action
associated	with	the	underlying	control.	You	can	turn	this	feature	on
or	off	by	selecting	Help»Show	Context	Help.
Online	help	for	IVI	Soft	Front	Panels	appears	when	you	select
Help»Online	Reference.



Printing
By	default,	you	can	print	the	front	panels	for	IVI	Soft	Front	Panels-Scope.
If	your	printer	supports	postscript	or	color	printing,	you	can	modify	lines	in
IVI	Soft	Front	Panels—Scope.ini	file	to	enable	postscript	or	color	printing
when	you	print	the	IVI	Soft	Front	Panels	front	panel.	The	IVI	Soft	Front
Panels—Scope.ini	file	exists	in	your	IVI	Soft	Front	Panels	directory.	After
you	change	information	in	the	IVI	Soft	Front	Panels—Scope.ini	file,	you
must	restart	IVI	Soft	Front	Panels	for	the	changes	to	take	effect.
You	can	edit	the	IVI	Soft	Front	Panels-Scope.ini	file	with	any	word
processing	or	text	editing	software,	such	as	Notepad.	For	example,	to
enable	postscript	printing	in	the	IVI	Soft	Front	Panels-Scope,	you	can
open	IVI	Soft	Front	Panels-Scope.ini	in	Notepad	and	change	the	postscript
printing	setting	to	True,	as	follows:
postScriptPrinting=True
If	you	enable	postscript	printing	and	your	printer	does	not	support
postscript	printing,	your	printer	prints	a	single	line	of	postscript	code.
By	default,	color	and	grayscale	printing	are	disabled.	To	enable	color	or
grayscale	printing,	change	the	color/grayscale	printing	setting	in	the	IVI
Soft	Front	Panels-Scope.ini	file,	as	follows:
colorPrinting=True
If	you	disable	grayscale	printing,	you	conserve	toner.

Note		To	affect	the	printing	options	described	above,	you	must
modify	the	lines	exactly	as	shown.

Caution	Do	not	modify	any	other	lines	in	the	IVI	Soft	Front	Panels-
Scope.ini	files.	Doing	so	will	cause	IVI	Soft	Front	Panels-Scope	to
operate	incorrectly.



Saving	and	Restoring	Settings
IVI	Soft	Front	Panels	saves	the	front	panel	and	instrument	settings	of	all
instruments	in	files	that	you	can	restore	at	any	time.	You	can	also	create
settings	files	so	that	you	can	restore	settings	that	you	need	repeatedly.



Saving	Settings	Automatically
IVI	Soft	Front	Panels	saves	the	settings	for	your	front	panel	and
instrumentation	every	time	you	exit	from	an	instrument.	IVI	Soft	Front
Panels	automatically	names	this	settings	file	last.xxx,	where	xxx	is	the
abbreviation	of	the	instrument.	For	example,	when	you	exit	IVI	Soft	Front
Panels—Scope,	the	last	settings	are	saved	in	the	last.sco	file.	It	maintains
the	last.sco	in	the	IVI	Soft	Front	Panels	folder.



Saving	Settings	Manually
You	can	save	settings	at	any	time	by	completing	the	following	steps:

1.	 Select	Edit»Save	Settings...
2.	 Name	your	settings	file.
3.	 Click	OK.



Restoring	Settings
You	can	restore	the	settings	from	a	previously	saved	settings	file	by
completing	the	following:

1.	 Select	Edit»Load	Settings....
2.	 Find	the	settings	file	you	want	and	click	OK.	The	saved	instrument

settings	are	applied.
Note		When	you	restore	settings	for	IVI	Soft	Front	Panels—DC
Power	Supply,	click	OK,	then	click	Apply.	The	settings	are	not
applied	to	the	instrument	until	you	click	Apply.	See	Apply	for	more
information	about	applying	settings	to	an	instrument.
Similarly,	when	you	restore	settings	for	IVI	Soft	Front	Panels—FG,
click	OK,	then	click	On.	The	settings	are	not	all	applied	to	the
instrument	until	you	click	On.	See	On	for	more	information	about
enabling	waveform	generation.



Restoring	Default	Settings
You	can	restore	default	settings	for	any	IVI	Soft	Front	Panels	instrument
by	selecting	Edit»Reset	Settings.	IVI	Soft	Front	Panels	applies	the
settings	from	the	default	.xxx	file	for	that	instrument,	where	the	xxx	is	the
abbreviation	of	the	instrument.



IVI	Soft	Front	Panels—DMM	Overview
Combined	with	an	IviDMM	class​compliant	instrument,	IVI	Soft	Front
Panels—DMM	transforms	your	PC	into	a	fully	featured	digital	multimeter
with	features	rivaling	desktop	models.	IVI	Soft	Front	Panels—DMM
display	controls	and	operation	faithfully	emulate	benchtop	digital
multimeters	so	that	you	can	take	maximum	advantage	of	your	previous
instrument	experience,	with	minimal	training	time,	to	use	PC​based
instruments.
Related	Topic
Working	with	IVI	Soft	Front	Panels—DMM



IVI	Soft	Front	Panels—DMM	Features
Combined	with	an	IviDMM	class-compliant	instrument,	IVI	Soft	Front
Panels—DMM	transforms	your	PC	into	a	fully	featured	digital	multimeter
with	features	rivaling	desktop	models.	IVI	Soft	Front	Panels—DMM
display	controls	and	operation	faithfully	emulate	benchtop	digital
multimeters	so	that	you	can	take	maximum	advantage	of	your	previous
instrument	experience,	with	minimal	training	time,	to	use	PC-based
instruments.
IVI	Soft	Front	Panels—DMM	includes	the	following	features:

Seven	measurement	modes:	Volts	DC,	Volts	AC,	DC	Current,	AC
Current,	2–Wire	Resistance,	4–Wire	Resistance,	and	Temperature.
Relative	measurement	capability.
Ability	to	log	data	to	an	ASCII	file.
Up	to	ten	measurement	ranges,	including	Auto	Range.
Fast	real-time	display.
Ability	to	save	and	recall	instrument	settings.



Tour	of	Front	Panel	and	Menus
The	following	figure	is	the	front	panel	of	IVI	Soft	Front	Panels—DMM.
You	can	scroll	over	regions	of	the	figure	and	click	areas	of	interest
for	more	in-depth	information.

Menus Display Buttons	and	Controls 	
File Measurement	Display Range	Selector Math	Buttons
Edit 	 Mode	Selector Log
Utility 	 Run Resolution
Help 	 Single 	



File
Exit Closes	IVI	Soft	Front	Panels—DMM.



Edit
General
Settings

Opens	the	DMM	Settings	dialog	box.	Refer	to	IVI	Soft
Front	Panels—DMM	Settings	for	details.

Temperature
Settings

Opens	the	DMM	Temperature	Settings	dialog	box.	Refer
to	DMM	Temperature	Settings	for	details.

Load
Settings

Restores	the	configuration	saved	in	a	settings	file.

Save
Settings

Saves	the	current	configuration	to	a	settings	file.

Reset
Settings

Resets	IVI	Soft	Front	Panels—DMM	to	its	factory	default
settings.

Refer	to	Saving	and	Restoring	Settings	for	more	information	about
options	in	the	Edit	menu.



Utility
Self-Test Performs	self-test	on	the	instrument.	This	operation	may	take

several	minutes.
Reset Resets	the	instrument.
Error
Query

Queries	the	errors	occurred.



Help
You	can	choose	the	following	items	in	the	Help	menu.	

Show
Context
Help

Context	Help	appears	in	the	Pop​up	Help	window	when
your	mouse	pointer	pauses	over	a	user	interface	control	or
item.	Information	in	the	Pop​up	window	describes	the
function	or	action	associated	with	the	underlying	control.

Show	Tip
Strips	Help

Tip	Strips	Help	appears	when	your	mouse	pointer	pauses
over	a	user	interface	control	or	item.	Information	in	the	tip
strips	window	briefly	describes	the	function	or	action
associated	with	the	underlying	control.

Online
Reference

Shows	the	online	help.

About	IVI
Soft	Front
Panels​DMM

Displays	the	About	dialog	box.



Measurement	Display
Displays	measurements.	The	bar	graph	appears	below	the	digital	display.
The	Range	Selector	controls	what	percentage	of	the	full	scale	graph
appears	in	the	display.	When	you	select	AutoRange,	the	bar	graph	shows
a	percentage	of	the	next-highest	power	of	10.
	



Range	Selector
The	range	selector	determines	the	range	of	measurements	IVI	Soft	Front
Panels—DMM	makes.	This	range	differs	for	each	measurement	mode.
+OVER	or	​OVER	appears	in	the	measurement	display,	if	the
measurement	exceeds	the	range.
AutoRange	mode	selects	the	range	that	best	matches	the	input	signal.



Mode	Selector
IVI	Soft	Front	Panels—DMM	has	7	measurement	modes:

Volts	DC							 Measures	DC	component	of	a	voltage	signal.
Volts	AC Measures	AC	component	of	a	voltage	signal.
Current	DC Measures	DC	component	of	a	current	source.
Current	AC Measures	AC	component	of	a	current	source.
Ohms Measures	resistance.
4–Wire	Ohms Measures	resistance	using	the	4-wire	method.
Temperature Measures	temperature.

Select	Edit»Temperature	Settings	to	configure	the	temperature
settings.



Run
Starts	and	stops	continuous	DMM	measurements.



Single
Performs	a	single	measurement.



Math	Buttons
Null Starts	relative	mode.	IVI	Soft	Front	Panels—DMM	makes	all

subsequent	measurements	relative	to	the	measurement	it
makes	when	you	click	Null.

Max/Min Displays	the	maximum	and	minimum	values	that	occur	after
you	click	Max/Min	button.

dB Compresses	a	large	range	of	measurements	into	a	much
smaller	scope	by	expressing	DC	or	AC	voltage	in	decibels.
The	relationship	between	dB	and	voltage	is	defined	by	the
following	equation:

																				Vin
dB	=	20	log	--------
																				Vref

where:	Vin	is	the	DC	or	AC	signal.	Vref	is	the	specified	voltage
reference	level.	This	value	is	specified	in	the	"dB,	%Ref"	field
in	the	DMM	Settings—Math	dialog	box.

dBm Shows	decibels	above	or	below	a	1mW	reference.	With	a
user-defined	reference	impedance,	IVI	Soft	Front	Panels	-
DMM	reads	0	dBm	when	the	voltage	needed	to	dissipate
1mW	through	the	reference	impedance	is	applied.	The
reference	impedance	(dBm	Zref)	is	entered	under	the	Math
tab	of	the	settings	window.	The	relationship	between	dBm,	a
reference	impedance,	and	the	voltage	is	defined	by	the
following	equation:

																								(Vin2	/	Zref)
dBm	=	10	log	----------------------
																														1mW

where:	Vin	is	the	DC	or	AC	input	signal.	Zref	is	the	specified
reference	impedance.	This	value	is	specified	in	the	"dBm	Zref"
field	in	the	DMM	Settings—Math	dialog	box.

mX+B Enables	the	mX+B	calculation	on	all	readings.		The	Mx+B
operation	allows	you	to	manipulate	normal	display	readings



(X)	mathematically	according	to	the	following	equation:

Y	=	MX	+	B

where:	X	is	the	normal	display	reading.	M	and	B	are	user-
defined	constants	for	multiplier	and	offset.	Y	is	the	displayed
result.	These	values	are	specified	in	the	"Mx+B	Scaling"	field
in	the	DMM	Settings—Math	dialog	box.

% Selects	the	percentage	calculation.	IVI	Soft	Front	Panels-
DMM	expresses	the	displayed	reading	as	a	percent	deviation
from	the	reference	value	entered	in	the	DMM-Math	Settings
dialog	box.	The	percentage	calculation	is	performed	as
follows:

																					Input	-	Ref
Percent	=	---------------------	x	100%
																										Ref

where:	Input	is	the	normal	display	reading.	Ref	is	the	user
entered	constant.	Percent	is	the	displayed	result.	Ref	value
is	specified	in	the	"dB,	%Ref"	field	in	the	DMM	Settings—Math
dialog	box.	



Log
Enables	data	logging.	To	configure	the	datalog	file	and	log	interval,	select
Edit»General	Settings.	Refer	to	Logging	Measurements	to	Disk	for
more	details.



Resolution
A	ring	control	in	the	DMM	front	panel	display	where	you	set	measurement
resolution	in	absolute	units.



Working	with	IVI	Soft	Front	Panels—DMM
Click	on	the	following	topics	for	information	about	configuring	IVI	Soft
Front	Panels—DMM	software	and	using	IVI	Soft	Front	Panels—DMM	to
make	a	measurement	and	log	measurements	data	to	disk.
Configuring	General	Settings
DMM	Settings—Math
DMM	Settings—Datalogging
DMM—Temperature	Settings
Measuring	Voltage
Measuring	Current
Measuring	Resistance
Measuring	Temperature
Logging	Measurements	to	Disk
Making	Relative	Measurements



DMM	Settings—General
Click	the	other	tabs	in	this	figure	for	more	information.

To	configure	IVI	Soft	Front	Panels—DMM,	select	Edit»General	Settings.

Instrument Selects	the	IVI	instrument	that	you	use	with	IVI	Soft
Front	Panels—DMM.	Only	logical	names	that	you	have
configured	successfully	in	MAX	appear	in	this	list.

Minimum
Measurement
Interval

Select	a	minimum	interval	between	measurements.	Use
this	control	to	introduce	a	time	delay	between
measurements.

Auto	Zero Enables/disables	Auto	Zero	for	the	instrument.	When	the
auto-zero	mode	is	enabled,	the	DMM	internally
disconnects	the	input	signal	and	takes	a	Zero	Reading.
The	DMM	then	subtracts	the	Zero	Reading	from	the
measurement.	Auto	Zero	prevents	offset	voltages
present	in	the	instrument's	input	circuitry	from	affecting
measurement	accuracy.	This	control	is	dimmed	if	the
instrument	does	not	support	this	feature.

Power	Line
Frequency

Sets	the	power	line	frequency	for	the	area	where	you
are	making	your	measurements.	IVI	Soft	Front	Panels—
DMM	uses	this	selection	to	best	reduce	measurement



inaccuracies	due	to	line	noise	and	interference	from
sources	such	as	nearby	AC-powered	equipment	and
overhead	lighting.	The	Auto	Zero	control	is	dimmed	if	the
instrument	does	not	support	this	feature.



DMM	Settings—Math
Click	the	other	tabs	in	this	figure	for	more	information.

To	configure	IVI	Soft	Front	Panels—DMM,	select	Edit»General	Settings.
To	activate	these	calculations,	click	the	Math	buttons	on	the	front	panel.

MX	+	B Manipulates	normal	display	readings	(X)	mathematically
according	to	the	calculation	Y	=	MX	+	B.
X	is	the	normal	display	reading.	Multiplier	(M)	is	the	constant
you	define	for	multiplier,	B	is	the	constant	you	define	for
offset,	and	Y	is	the	result	that	displays.

dB,	%Ref The	reference	value	used	for	decibels	(dB)	and	percent
calculations.

dBm	Zref The	reference	value	used	for	dBm	calculations.
When	you	click	the	dBm	calculation	button	in	the	front	panel,
IVI	Soft	Front	Panels—DMM	calculates	power	in	dBm	using
the	input	voltage	reading	and	the	Zref	value	you	specify.	The
relationship	between	dBm,	a	reference	impedance,	and	the
voltage	is	defined	by	the	following	equation:
																									(Vin^2	/	Zref)
dBm	=	10	log	----------------------



																														1mW
Vin	is	the	DC	or	AC	dBm	input	signal,	and	Zref	is	the
specified	reference	impedance.



DMM	Settings—Datalogging
Click	the	other	tabs	in	this	figure	for	more	information.

To	configure	IVI	Soft	Front	Panels—DMM,	select	Edit»General	Settings.
To	enable	data	logging,	you	must	click	Log	in	the	front	panel.

Datalog
File

Displays	the	current	filename.	To	change	the	current
datalog	file,	click	Change.

Log
Interval

Specifies	the	time	interval	between	log	entries.

User
Name

Sets	the	user	name	to	write	to	the	log	file	for	identification.

Comments Sets	the	comments	to	write	to	the	log	file.



DMM	Temperature	Settings
To	configure	IVI	Soft	Front	Panels—DMM	temperature	settings,	select
Edit»Temperature	Settings.

Note		The	Temperature	Settings	menu	is	enabled	only	when	the
temperature	measurement	is	supported	by	the	instrument.
The	Temperature	Setting	dialog	box	displays	differently	depending
on	which	Transducer	Type	control	is	selected.	The	following
figures	show	all	the	Temperature	Setting	dialog	boxes	for	the
Transducer	Type	Thermocouple,	Thermistor,	2​Wire/4​Wire	RTD,
respectively.

	

	



Transducer
Type

Specifies	the	type	of	temperature	sensor.

Thermocouple
Type

Specifies	the	type	of	cold-junction	sensor,	if	you	are
measuring	from	a	thermocouple.

Ref	Junc	Type Specifies	the	type	of	reference	junction	used	in	the
reference	junction	compensation	of	a	thermocouple
measurement.

Ref	Junc
Temp

Specifies	the	external	junction	temperature	in	Celsius,	if
you	are	using	the	fixed	reference	junction.

Thermistor
Res

Specifies	the	resistance	of	the	thermistor	in	Ohms,	if
you	are	measuring	temperature	from	a	resistance.

RTD	Alpha
Value

Specifies	the	alpha	parameter	for	a	resistance
temperature	device	(RTD),	if	you	are	measuring
temperature	from	an	RTD.

RTD	Res Specifies	the	R	parameter	(resistance)	for	an	RTD,	if
you	are	measuring	temperature	from	a	resistance.



Making	a	Measurement	with	IVI	Soft	Front
Panels—DMM
Complete	the	following	steps	to	make	a	measurement	with	IVI	Soft	Front
Panels—DMM:

1.	 Connect	a	signal	to	the	specified	channel	input	of	your	IviDMM
instrument.

2.	 On	the	front	panel,	click	Single.	IVI	Soft	Front	Panels—DMM
displays	a	single	measurement	in	the	measurement	display.	If	the
signal	seems	incorrect,	make	sure	the	instrument	is	connected
properly.

3.	 Click	Run.	IVI	Soft	Front	Panels—DMM	continuously	acquires
and	displays	measurements	in	the	measurement	display.

4.	 If	the	display	shows	+OVER	or	​OVER,	make	sure	the	input	signal
has	not	exceeded	the	range	selected	on	the	front	panel.

5.	 Click	Run	again	to	stop	acquisition.
Signal	Options:
Voltage
Current
Resistance
Temperature



Measuring	Voltage
IVI	Soft	Front	Panels—DMM	measures	AC	and	DC	voltage	with
your	IviDMM	instrument.	Complete	the	following	steps	to	measure
voltage:

1.	 Connect	a	signal	to	the	specified	channel	of	your	IviDMM
instrument.	

2.	 Click	Volts	AC	or	Volts	DC		in	the	front	panel.
3.	 Click	Run.	IVI	Soft	Front	Panels—DMM	continuously	acquires

and	displays	voltage	measurements	in	the	Measurement	display.
Or	click	Single,	IVI	Soft	Front	Panels—DMM	acquires	and
displays	a	voltage	measurement	in	the	Measurement	display.

4.	 If	the	display	shows	+OVER	or	​OVER,	make	sure	the	input	signal
has	not	exceeded	the	range	selected	on	the	front	panel.

Other	Signal	Options:
Current
Resistance
Temperature



Measuring	Current
IVI	Soft	Front	Panels—DMM	measures	AC	and	DC	current	with	your
IviDMM	instrument.	Complete	the	following	steps	to	measure	current:

1.	 Connect	a	signal	to	the	specified	channel	of	your	IviDMM
instrument.

2.	 Click	Current	AC	or	Current	DC	on	the	front	panel.
3.	 Click	Run.	IVI	Soft	Front	Panels—DMM	continuously	acquires

and	displays	current	measurements	in	the	Measurement	display.
Or	click	Single,	IVI	Soft	Front	Panels—DMM	acquires	and
displays	a	current	measurement	in	the	Measurement	display.

4.	 If	the	display	shows	+OVER	or	​OVER,	make	sure	the	input	signal
has	not	exceeded	the	range	selected	on	the	front	panel.

Other	Signal	Options:
Voltage
Resistance
Temperature



Measuring	Resistance
IVI	Soft	Front	Panels—DMM	measures	resistance	with	your	IviDMM
instrument.	Complete	the	following	steps	to	measure	resistance:

1.	 Connect	a	signal	to	the	specified	channel	of	your	IviDMM
instrument.

2.	 Click	2​Wire	Ohms	or	4​Wire	Ohms	on	the	front	panel.
3.	 Click	Run.	IVI	Soft	Front	Panels—DMM	continuously	acquires

and	displays	resistance	measurements	in	the	Measurement
display.	Or	click	Single,	IVI	Soft	Front	Panels—DMM	acquires
and	displays	a	resistance	measurement	in	the	Measurement
display.

4.	 If	the	display	shows	+OVER	or	​OVER,	make	sure	the	input	signal
has	not	exceeded	the	range	selected	on	the	front	panel.

Other	Signal	Options:
Voltage
Current
Temperature



Measuring	Temperature
IVI	Soft	Front	Panels—DMM	requires	a	thermocouple,	or	a	thermistor,	or
a	2​Wire	RTD,	or	a	4​Wire	RTD	sensor	to	make	precision	temperature
measurements.
Complete	the	following	steps	to	measure	temperature:

1.	 Connect	a	precision	temperature	sensor	to	the	specified	channel
input	of	your	IviDMM	instrument.

2.	 Select	Edit»Temperature	Settings....	Refer	to	the	topic	DMM—
Temperature	Settings	for	more	information	about	configuring
temperature.

3.	 Select	the	temperature	sensor	type	from	the	list	in	the	Transducer
Type	field.

4.	 If	you	are	using	a	thermocouple,	select	the	thermocouple	type	in
the	Thermocouple	Type	field.	Next,	select	the	type	of	reference
junction	from	the	drop-down	menu	in	the	Ref	Junc	Type	field.	If
the	reference	junction	type	selected	is	Fixed,	specify	the	external
reference	junction	temperature	in	the	Ref	Junc	Temp	field.

5.	 If	you	are	using	a	thermistor,	specify	the	resistance	of	the
thermistor	in	the	Thermistor	Res	field.

6.	 If	you	are	using	an	RTD	sensor,	specify	the	alpha	parameter	for	a
resistance	temperature	device	in	the	RTD	Alpha	Value	field	and
the	R	parameter	(resistance)	for	a	resistance	temperature	device
in	the	RTD	Res	field.	

7.	 Click	OK.
8.	 Click	Temperature	in	the	front	panel.
9.	 Click	Run.	IVI	Soft	Front	Panels—DMM	continuously	acquires

and	displays	temperature	measurements	in	the	Measurement
display.	Or	click	Single.	IVI	Soft	Front	Panels—DMM	acquires
and	displays	a	temperature	measurement	in	the	Measurement
display.

10.	 If	the	display	shows	+OVER	or	-OVER,	make	sure	the	input	signal
has	not	exceeded	the	range	selected	on	the	front	panel.

Other	Signal	Options:
Voltage



Current
Resistance



Logging	Measurements	to	Disk
Complete	the	following	steps	to	log	IVI	Soft	Front	Panels—DMM
measurements	to	an	ASCII	text	file:

1.	 Select	Edit»General	Settings.	Click	the	Logging	tab.	For	more
information,	refer	to	DMM	Settings—Datalogging.

2.	 Click	Change	to	browse	the	files.
3.	 Select	a	file	that	you	want	to	log	data	to.	Click	OK.
4.	 Specify	the	hours,	minutes,	and	seconds	to	use	for	the	Log

Interval.	This	rate	does	not	have	to	match	the	DMM	update	rate.
5.	 Click	OK.
6.	 Click	Run	on	the	front	panel	of	IVI	Soft	Front	Panels—DMM	to

start	data	acquisition.
7.	 Click	Log	on	the	front	panel	of	IVI	Soft	Front	Panels—DMM	to

start	data	logging.
Note		When	the	Run	button	is	enabled,	data	is	logged	to	an	ASCII
text	file	only.



Making	Relative	Measurements
With	IVI	Soft	Front	Panels—DMM,	you	can	make	measurements	relative
to	a	reference	measurement.	Complete	the	following	steps	to	make	such
measurements:

1.	 Set	up	IVI	Soft	Front	Panels—DMM	to	acquire	a	signal.	Refer	to
Making	a	Measurement	with	IVI	Soft	Front	Panels—DMM	for
details.

2.	 Click	Null	on	the	front	panel.
IVI	Soft	Front	Panels—DMM	then	makes	all	measurements	relative	to	the
measurement	made	at	the	moment	you	clicked	Null.	Click	Null	again	to
disable	relative	measurements.



IVI	Soft	Front	Panels—FG	Overview
Combined	with	an	IviFGen	class​compliant	instrument,	IVI	Soft	Front
Panels—FG	transforms	your	PC	into	a	fully	featured	function	generator
with	features	that	rival	desktop	models.	IVI	Soft	Front	Panels—FG
display	controls	and	operation	faithfully	emulate	benchtop	function
generators	so	you	can	take	maximum	advantage	of	your	previous
instrument	experience,	with	minimal	training	time,	to	use	PC​based
instruments.
Related	Topic
Working	with	IVI	Soft	Front	Panels—FG



IVI	Soft	Front	Panels—FG	Features
Combined	with	an	IviFGen	class–compliant	instrument,	IVI	Soft	Front
Panels—FG	transforms	your	PC	into	a	fully	featured	function	generator
with	features	that	rival	desktop	models.	IVI	Soft	Front	Panels—FG
display	controls	and	operation	faithfully	emulate	benchtop	function
generators	so	you	can	take	maximum	advantage	of	your	previous
instrument	experience,	with	minimal	training	time,	to	use	PC–based
instruments.
With	IVI	Soft	Front	Panels—FG,	you	can	generate	six	standard
waveforms:	sine,	square,	triangle,	ramp	up,	ramp	down,	and	DC.	As	with
all	IVI	Soft	Front	Panels	Instruments,	you	can	load	and	save	instrument
settings.



Tour	of	Function	Generator	Front	Panel	and
Menus
The	following	figure	shows	the	front	panel	of	IVI	Soft	Front	Panels—FG.
You	can	scroll	over	regions	of	the	figure	and	click	areas	of	interest
for	more	in-depth	information.

Menus Display Buttons Controls
File Display

Window
Range	Selector Frequency	Knob

Edit 	 Function
Selector

Waveform	Modifier
Controls

Controls 	 On 	
Utility
Help 	 	



File
Exit Closes	IVI	Soft	Front	Panels—FG.



Edit
General
Settings

Opens	the	FG	Settings	dialog	box.	Refer	to	IVI	Soft	Front
Panels—FG	Settings	for	details.

Load
Settings

Restores	the	configuration	saved	in	a	settings	file.

Save
Settings

Saves	the	current	configuration	to	a	settings	file.

Reset
Settings

Resets	IVI	Soft	Front	Panels—FG	to	its	factory	default
settings.

Refer	to	Saving	and	Restoring	IVI	Soft	Front	Panels	Settings	for	more
information	about	options	in	the	Edit	menu.



Controls
Frequency Increases/decreases	frequency.
Amplitude Increases/decreases	amplitude.
Offset Increases/decreases	offset.



Utility
Self–
Test

Performs	self-test	on	the	instrument.	This	operation	may	take
several	minutes.

Reset Resets	the	instrument.
Error
Query

Queries	the	errors	occurred.



Help
You	can	choose	the	following	items	in	the	Help	menu.	

Show
Context
Help

Context	Help	appears	in	the	Pop​up	Help	window	when	your
mouse	pointer	pauses	over	a	user	interface	control	or	item.
Information	in	the	Pop​up	window	describes	the	function	or
action	associated	with	the	underlying	control.

Show	Tip
Strips
Help

Tip	Strips	Help	appears	when	your	mouse	pointer	pauses
over	a	user	interface	control	or	item.	Information	in	the	tip
strips	window	briefly	describes	the	function	or	action
associated	with	the	underlying	control.

Online
Reference

Shows	the	online	help.

About	IVI
Soft	Front
Panels—
FG

Displays	the	About	dialog	box.



Display	Window
Shows	the	waveform	frequency.	The	range	and	frequency	settings
determine	this	value.
To	adjust	the	frequency,	you	can	click	the	display	and	type	in	a	frequency
value	directly.	You	also	can	adjust	the	frequency	with	the	Frequency	knob
or	the	up/down	arrows	to	the	left	of	the	display.	Also,	you	can	enter	a
frequency	value	directly	when	you	double–click	the	display.
	



Range	Selector
Selects	the	frequency	range	of	IVI	Soft	Front	Panels—FG.	The	following
formulas	specify	the	range	of	frequencies	covered	by	each	range:
Minimum	Frequency	=	0.1	×	Range	Setting
Maximum	Frequency	=	1.0	×	Range	Setting



Function	Selector
Selects	the	waveform	that	IVI	Soft	Front	Panels—FG	generates.	In	order
from	left	to	right,	the	waveform	buttons	are	as	follows:

Sine	Wave Selects	the	sine	wave	function.
Square	Wave Selects	the	square	wave	function.
Triangle	Wave Selects	the	triangle	wave	function.
Ramp	Up
Exponential

Selects	the	ramp	up	exponential	function.

Ramp	Down
Exponential

Selects	the	ramp	down	exponential	function.

DC Selects	a	DC	waveform.



On
Click	On	to	start	the	waveform	generation.	If	you	click	On	during
waveform	generation,	IVI	Soft	Front	Panels—FG	stops	generating	the
waveform.	Also,	enabling	On	allows	IVI	Soft	Front	Panels—FG	to	apply
the	Amplitude,	DC	Offset,	Duty	Cycle,	Ref	Clock	Source,	Output
Impedance	settings	to	the	instrument.



Frequency	Knob
Controls	the	frequency	of	the	waveform,	within	the	range	you	select	with
the	range	selector.	Use	the	Fine	knob	to	further	fine-tune	the	frequency.



Waveform	Modifier	Controls
Provides	additional	control	over	the	generated	waveform.

Duty
Cycle

Adjusts	the	duty	cycle	of	the	square	wave.	Duty	cycle	is	the
upward	cycle	time	expressed	as	a	percentage	of	the	entire
cycle.

Note		This	control	is	enabled	only	when	the	square
waveform	function	is	selected	by	the	Function
Selector	in	the	Front	Panel.

Offset Adjusts	the	DC	offset	of	the	waveform.
Offset	is	expressed	as	a	voltage	added	to	the	output
waveform	of	the	current	waveform	amplitude.

Note		This	control	might	exceed	the	output	limits	of
your	device,	in	which	case	IVI	Soft	Front	Panels—FG
clips	the	output	signal.	When	this	occurs,	a	CLIP
indicator	appears.

Amplitude Adjusts	the	peak	amplitude	of	the	signal.

Note		This	control	might	exceed	the	output	limits	of
your	device,	in	which	case	IVI	Soft	Front	Panels—FG
clips	the	output	signal.	When	this	occurs,	a	CLIP
indicator	appears.



Working	with	IVI	Soft	Front	Panels—FG
This	topic	introduces	how	to	configure	IVI	Soft	Front	Panels—FG
software	and	use	IVI	Soft	Front	Panels—FG	to	generate	a	waveform.
Configuring	IVI	Soft	Front	Panels—FG
Generating	a	Waveform	with	IVI	Soft	Front	Panel—FG



Configuring	IVI	Soft	Front	Panels—FG
To	configure	IVI	Soft	Front	Panels—FG,	select	Edit»General	Settings.

Instrument Selects	the	instrument	to	use.	Only	logical	names	which
you	successfully	configured	in	the	MAX	appear	in	this	list.

Channel Selects	the	output	channel	used	by	IVI	Soft	Front	Panels—
FG.

Reference
Clock

Specifies	the	source	of	the	reference	clock.

Output
Impedance

Specifies	the	output	impedance.



Generating	a	Waveform	with	IVI	Soft	Front
Panels—FG
Complete	the	following	steps	to	generate	a	waveform	with	IVI	Soft	Front
Panels—FG:

1.	 Connect	a	device	or	oscilloscope	to	the	output	channel	of	your
IviFGen	Instrument.	Refer	to	the	user	manual	of	your	instrument
for	details.

2.	 Configure	FG	Settings.
3.	 Click	On	on	the	front	panel.	IVI	Soft	Front	Panels—FG

continuously	generates	an	analog	waveform	at	the	output.
4.	 Click	On	again	to	stop	waveform	generation.



IVI	Soft	Front	Panels—DC	Power	Supply
Overview
Combined	with	an	IviDCPwr	class​compliant	instrument,	IVI	Soft	Front
Panels—DC	Power	Supply	transforms	your	PC	into	a	fully	featured	DC
power	supply	with	features	rivaling	desktop	models.	IVI	Soft	Front	Panels
—DC	Power	Supply	display	controls	and	operation	faithfully	emulate	DC
power	supply	so	that	you	can	take	maximum	advantage	of	your	previous
instrument	experience,	with	minimal	training	time,	to	use	PC​based
instruments.
Related	Topic
Working	with	IVI	Soft	Front	Panels—DC	Power	Supply



IVI	Soft	Front	Panels—DC	Power	Supply
Features
You	use	IVI	Soft	Front	Panels—DC	Power	Supply	to	control	any	DC
Power	Supply	with	an	IviDCPwr​compliant-specific	driver.	Features
include	the	following	items:

DC	power	signal	generation.
Real-time	voltage	and	current	measurement	display.
Voltage	and	current	limit	controls.
Over-voltage	and	over-current	indicators.



Tour	of	Front	Panel	and	Menus
The	following	figure	shows	the	front	panel	of	IVI	Soft	Front	Panels—DC
Power	Supply.	You	can	scroll	over	regions	of	the	figure	and	click
areas	of	interest	for	more	in-depth	information.

Menu Buttons Controls/Indicators
File Apply Measurement	Display
Edit Output	On/Off Voltage	Level
Utility Voltage	Limit
Help Current	Limit

OVP	Enabled
Over	Current	Behavior



File
Exit Closes	IVI	Soft	Front	Panels—DC	Power	Supply.



Edit
General
Settings

Allows	you	to	configure	the	IVI	instrument	and	channel.

Load
Settings

Restores	IVI	Soft	Front	Panels—DC	Power	Supply	to	the
configuration	that	you	saved	in	a	settings	file.

Save
Settings

Saves	the	current	IVI	Soft	Front	Panels—DC	Power	Supply
configuration	in	a	settings	file.

Reset
Settings

Restores	IVI	Soft	Front	Panels—DC	Power	Supply	to	its
default	settings.

Refer	to	Saving	and	Restoring	IVI	Soft	Front	Panels	Settings	for	more
information	about	options	in	the	Edit	menu.



Utility
Self-Test Performs	self-test	on	the	instrument.	This	operation	may	take

several	minutes.
Reset Resets	the	instrument.
Error
Query

Queries	the	errors	occurred.



Help
You	can	choose	the	following	items	in	the	Help	menu.

Show	Tip
Strips	Help

Tip	Strips	Help	appears	when	your	mouse	pointer	pauses
over	a	user	interface	control	or	item.	Information	in	the	tip
strips	window	briefly	describes	the	function	or	action
associated	with	the	underlying	control.

Show
Context
Help

Context	Help	appears	in	the	Pop-up	Help	window	when
your	mouse	pointer	pauses	over	a	user	interface	control	or
item.	Information	in	the	Pop-up	window	describes	the
function	or	action	associated	with	the	underlying	control.

Online
Reference

Shows	the	online	help.

About	IVI
Soft	Front
Panels—
DC	Power
Supply

Displays	the	About	dialog	box.



Apply
Applies	changes	to	the	instrument	that	you	made	with	the	front	panel
controls.



Output	On/Off
Enables/Disables	signal	generation	of	the	DC	Power	Supply.



Measurement	Display
Shows	real-time	voltage	and	current	measurements,	if	your	instrument
supports	these	outputs.	If	not,	the	display	shows	your	current	settings.
"OVP"	indicates	that	the	over-voltage	protection	circuitry	has	tripped.
"OCP"	indicates	that	the	over-current	protection	circuitry	has	tripped.
"CV"	indicates	that	the	power	supply's	output	signal	reaches	the	voltage
level	before	it	reaches	the	current	limit,	"CC"	indicates	that	the	power
supply's	output	signal	reaches	the	current	limit	before	it	reaches	the
voltage	level,	"Unregulated"	indicates	that	the	power	supply's	output
signal	reaches	neither	the	voltage	level	nor	the	current	limit.



Voltage	(V)
Specifies	the	DC	level	of	the	generated	signal.	The	units	are	volts.



Voltage	Limit	(V)
Specifies	the	peak	instantaneous	voltage	that	the	power	supply	allows.
The	units	are	volts.



Current	Limit	(A)
Specifies	the	peak	instantaneous	current	that	the	power	supply	allows.
The	units	are	amperes.



OVP	Enabled
Specifies	whether	the	power	supply	provides	over-voltage	protection.
When	you	select	this	control,	the	power	supply	disconnects	the	output	if
the	output	voltage	exceeds	the	voltage	you	specify	with	the	Voltage	Limit
control.	When	you	deselect	this	control,	the	power	supply	limits	the
output	voltage	to	the	voltage	that	you	specify	with	the	Voltage	Limit
control.



Over	Current	Behavior
Selects	the	behavior	of	the	DC	power	supply	when	an	over	current
condition	is	reached.
The	options	are	the	following:

Regulate Lower	the	voltage	so	that	the	current	limit	is	not	exceeded.
Trip Disconnect	the	output	of	the	DC	power	supply.



Working	with	IVI	Soft	Front	Panels—DC	Power
Supply
Click	the	following	links	to	find	out	how	to	configure	IVI	Soft	Front	Panels
—DC	Power	Supply	software,	use	IVI	Soft	Front	Panels—DC	Power
Supply	to	generate	a	DC	power	signal	and	configure	limits	and
Over​Voltage/Current	Protection.
Configuring	IVI	Soft	Front	Panels—DC	Power	Supply
Generate	a	DC	Power	Signal
Configuring	Limits	and	Over​Voltage/Current	Protection



Configuring	IVI	Soft	Front	Panels—DC	Power
Supply
When	you	launch	IVI	Soft	Front	Panels—DC	Power	Supply,	the	panel
always	launches	in	a	Power	off	state.	Other	settings	automatically
assume	the	settings	of	your	previous	IVI	Soft	Front	Panels—DC	Power
Supply	session.	You	must	configure	IVI	Soft	Front	Panels—DC	Power
Supply	before	you	use	it.	Complete	the	following	steps	to	configure	IVI
Soft	Front	Panels—DC	Power	Supply:

1.	 Connect	a	load	to	one	of	the	output	channels	of	your	power
supply.

2.	 Configure	IVI	Soft	Front	Panels—DC	Power	Supply.
a.	 Select	Edit»General	Settings

.
b.	 Select	the	IVI	logical	name	of	the	instrument	that	you	want

to	use.	If	you	have	not	already	configured	a	logical	name,
you	need	to	do	so	first	in	MAX.	Refer	to	Measurement	&
Automation	Explorer	Help	for	MAX.

c.	 Select	the	channel	you	want	to	use.

d.	 Click	OK	to	use	these	settings.
3.	 Configure	voltage	level,	voltage	limit,	current	limit,	OVP	enabled,

and	over	current	behavior	controls	on	the	front	panel.
4.	 Click	Apply	to	apply	controls'	settings	to	the	instrument.

ms-its:ivi_max.chm::/MAX_overview.html


Generating	a	DC	Power	Signal
To	generate	a	DC	Power	signal,	complete	the	following	steps	in	the
Power	Supply	front	panel:

1.	 Enter	a	voltage	in	the	Voltage	control.
2.	 Click	Apply	to	commit	to	the	change.	If	a	red	error	button	appears

in	the	display	window,	clicking	the	error	button	displays	the	error
cause.	Adjust	the	voltage	level	if	necessary.

3.	 Click	Output	to	enable	the	power	supply.



Configuring	Limits	and	Over​Voltage/Current
Protection
To	configure	Limits	and	Over​Voltage/Current	Protection,	complete	the
following	steps	in	the	Power	Supply	front	panel:

1.	 Enter	a	voltage	limit	in	the	Voltage	Limit	control.
2.	 Enter	a	current	limit	in	the	Current	Limit	control.
3.	 Check	the	OVP	Enabled	control	if	you	want	to	enable	Over-

Voltage	protection.
4.	 Select	a	Over​Current	behavior	with	the	Over	Current	Behavior

control.
5.	 Click	Apply	to	commit	to	the	changes.	If	a	red	error	button

appears	in	the	display	window,	clicking	the	error	button	displays
the	error	cause.

6.	 Click	Output	to	enable	the	power	supply.



IVI	Soft	Front	Panels—Scope	Overview
Combined	with	an	IviScope	class​compliant	instrument,	IVI	Soft	Front
Panels—Scope	transforms	your	PC	into	a	fully	featured	oscilloscope	with
features	rivaling	desktop	models.	IVI	Soft	Front	Panels—Scope	display
controls	and	operation	faithfully	emulate	benchtop	oscilloscope	so	that
you	can	take	maximum	advantage	of	your	previous	instrument
experience,	with	minimal	training	time,	to	use	PC-based	instruments.
Related	Topic
Working	with	IVI	Soft	Front	Panels—Scope



IVI	Soft	Front	Panels—Scope	Features
Combined	with	an	IviScope	class-compliant	instrument,	IVI	Soft	Front
Panels—Scope	transforms	your	PC	into	a	fully	featured	oscilloscope	with
features	rivaling	desktop	models.	The	display	controls	and	operation
faithfully	emulate	benchtop	oscilloscopes	so	you	can	take	maximum
advantage	of	your	previous	instrument	experience,	with	minimal	training,
to	use	PC​based	instruments.
Display	Features

User​adjustable	trigger	cursor
Zoom
Two	cursors	for	precise	measurements
X​Y	plot	mode

Other	Features
Auto	Setup
19	waveform	measurement	functions
Save	waveforms	on	disk	for	transfer	to	other	applications
Annotate	saved	waveforms
Recall	and	display	saved	waveforms
Save	and	recall	instrument	settings	on	disk
Hard	copy	output	of	screen



Tour	of	Front	Panel	and	Menus
The	following	figure	is	the	front	panel	of	IVI	Soft	Front	Panels—Scope.
You	can	scroll	over	regions	of	the	figure	and	click	areas	of	interest
for	more	in-depth	information.

Menus Displays Controls
File Status Vertical	Position

Sliders
Channel
Selector

Channel
Settings

Edit Graphics
Display

Main	Control	Bar Timebase
Control

Trigger
Settings

Controls Measurement Maximize/Minimize Cursor
Settings

Zoom
Controls

Measure
Utility
Help

Note			Each	time	you	launch	IVI	Soft	Front	Panels—Scope,	the
window	returns	to	its	previous	position	and	size.

Printing	the	Front	Panel	Display



File
Load
Waveforms

Loads	a	waveform	from	an	ASCII	text	file	to	one	of	the
reference	channels.	Refer	to	Viewing	Saved	Waveforms
and	Comparing	Saved	and	New	Waveforms	for	more
information.

Save
Waveforms

Saves	one	or	more	waveforms	to	disk	as	an	ASCII	text	file.
Refer	to	Saving	Waveforms	to	Disk	for	more	information.

Printer
Setup

Configures	printer	properties.

Print	Panel
Display

Prints	the	IVI	Soft	Front	Panels—Scope	graphics	display.

Exit Closes	IVI	Soft	Front	Panels—Scope.



Edit
General	Settings Selects	the	Scope	Settings	dialog	box.	See

Scope	Settings	for	more	details.
Channel	Settings Selects	the	Scope	Channel	Settings	dialog

box.	See	Scope	Channel	Settings	for	more
details.

Copy	Channel	to	Ref	1,
Copy	Channel	to	Ref	2

Copies	the	waveform	from	the	currently
selected	channel	and	stores	it	in	either	the	Ref
1	or	Ref	2	buffer.

Load	Settings Restores	IVI	Soft	Front	Panels—Scope	to	a
configuration	that	you	saved	in	a	settings	file.

Save	Settings Saves	the	current	IVI	Soft	Front	Panels—
Scope	configuration	in	a	settings	file.

Reset	Settings Restores	IVI	Soft	Front	Panels—Scope	to	its
default	settings.

Refer	to	Saving	and	Restoring	Settings	for	more	information	about
options	in	the	Edit	menu.



Controls
Timebase Adjusts	the	time	base	control.
Volts	per
Division

Selects	the	vertical	sensitivity.	The	units	are	in
volts/division.

Vertical
Position

Adjusts	the	vertical	position	of	the	trace.

Trigger Adjusts	the	trigger	control.
Zoom Adjusts	the	current	zoom	magnification	level.



Measure
Use	this	menu	to	measure	waveforms.	For	more	information,	refer	to
Using	the	Measurement	Display.



Utility
Self-Test Performs	self-test	on	the	instrument.	This	operation	may	take

several	minutes.
Reset Resets	the	instrument.
Error
Query

Queries	the	errors	occurred.



Help
You	can	choose	the	following	items	in	the	Help	menu.	

Show
Context
Help

Context	Help	appears	in	the	Pop​up	Help	window	when	your
mouse	pointer	pauses	over	a	user	interface	control	or	item.
Information	in	the	Pop​up	window	describes	the	function	or
action	associated	with	the	underlying	control.

Show	Tip
Strips
Help

Tip	Strips	Help	appears	when	your	mouse	pointer	pauses
over	a	user	interface	control	or	item.	Information	in	the	tip
strips	window	briefly	describes	the	function	or	action
associated	with	the	underlying	control.

Online
Reference

Shows	the	online	help.

About	IVI
Soft	Front
Panels—
Scope

Displays	the	About	dialog	box.



Status	Display
Shows	vital	information	about	the	current	state	of	IVI	Soft	Front	Panels—
Scope.	The	top	two	lines	indicate	the	vertical	sensitivity	and	offset	for	the
first	four	selected	channels.	The	third	line	gives	the	current	state	of	the
instrument	(running	or	stopped),	the	Timebase,	the	current	Sample	Rate,
the	Trigger	Level,	and	the	Waveform	Size.



State	of	the	Instrument
Indicates	that	the	instrument	currently	is	acquiring	data	(running)	or	idle
(stopped).



Sample	Rate
The	rate	in	samples	per	second	at	which	IVI	Soft	Front	Panels—Scope
acquires	data.	IVI	Soft	Front	Panels—Scope	calculates	this	value	based
on	the	sample	rate	of	your	instrument,	the	buffer	size,	and	the	timebase
setting.



Timebase	Control
Changes	the	timebase	setting.	The	timebase	setting	determines	the	x-
axis	time	scale	in	units	of	seconds/division	in	the	status	display.	A	shorter
time	period	appears	in	the	graphics	display	as	you	turn	the	knob
clockwise.



Trigger	Level
The	voltage	threshold	that	IVI	Soft	Front	Panels—Scope	uses	in
conjunction	with	the	slope	setting	to	indicate	when	to	acquire	data.



Waveform	Size
The	number	of	samples	in	the	acquired	waveform.



Graphics	Display
Displays	waveforms	and	controls	cursors	for	making	individual	cursor
measurements.	You	can	move	cursors	horizontally	by	clicking	them	and
dragging	them	along	the	time	axis.	You	can	move	the	trigger	cursor
horizontally	and	vertically	to	choose	the	trigger	position.
You	can	alter	the	vertical	position	of	a	waveform	by	clicking	and	dragging
the	vertical	position	slider	that	corresponds	in	color	to	the	waveform	that
you	want	to	alter.
To	control	the	appearance	of	the	graphics	display,	use	the	Display	tab	of
the	IVI	Soft	Front	Panels—Scope	Settings	dialog	box.



Measurement	Display
Displays	both	waveform	and	cursor	measurements.
Related	Topic
Using	the	Measurement	Display



Vertical	Position	Sliders
Colored	arrows	to	the	right	of	the	graphics	display	adjust	the	voltage
offset	of	each	channel.	The	second	line	of	the	status	display	shows	the
vertical	offset	for	each	channel.



Main	Control	Bar
The	Main	Control	bar	contains	the	Run,	Single,	Auto	Setup,	Mode,	and
Select	controls.

Run Starts	or	stops	continuous	data	acquisition.
Single Acquires	a	single	sweep	acquisition.
Auto
Setup

Configures	the	scope	for	the	best	timebase,	volts	per	division,
and	trigger	setting	for	each	channel	selected	with	the	channel
selector.

Mode Toggles	the	scope	between	V–T	(volts	versus	time)	mode	and
X–Y	mode.

Select Choose	which	objects	you	select	on	the	graph.	Then	the
measurements	that	display	below	the	graph	are	derived	only
from	the	region	or	point(s)	that	you	have	selected.

Cursor	Mode—Allows	you	to	move	cursors,	including	the
trigger	cursor.
Plot	Mode—Allows	you	to	select	a	section	of	a	waveform.
IVI	Soft	Front	Panels—Scope	uses	this	section	for
measurement	calculations	and	saves	this	portion	to	disk,
if	you	choose	"Save	selection	only"	when	you	save	a
waveform.

When	you	choose	Plot	mode	of	the	Select	control,	a	portion	of
the	graph	turns	green.	To	increase	or	decrease	the	width	of	this
selection	area,	click	and	drag	one	of	the	edges	of	the	green
band.



Maximize/Minimize	Graphics	Display
Toggles	the	mode	of	display	to	Maximize	or	Minimize.	A	maximized
display	fills	the	entire	IVI	Soft	Front	Panels—Scope	window.



Channel	Selector
Acquired
Channels

Selects	analog	input	channels	on	your	instrument.

Ref	1,
Ref	2

Displays	the	contents	of	the	reference	channels.	Refer	to
Viewing	Saved	Waveforms	or	Comparing	Saved	and	New
Waveforms	for	more	details.

Derived
Channels

Displays	the	results	of	the	waveform	math	calculation.	Refer
to	Using	the	Waveform	Math	Channels	for	more	details.



Cursor	Settings
Controls	two	cursors,	C1	and	C2	that	appear	on	the	dialog	box.	You	can
change	the	cursor	type	in	the	Display	tab	of	the	IVI	Soft	Front	Panels-
Scope	Settings	dialog	box.

C1,C2 Selects	the	plot	associated	with	each	cursor.
Sel Selects	the	active	cursor	with	C1,	or	C2,	or	trigger	cursor.	You

can	move	the	active	cursor	with	the	arrow	buttons	below	this
control.

Arrows Move	the	active	cursor	to	the	left	or	right	for	C1	or	C2	and
left/right/up/down	for	trigger	cursor,	one	point	at	a	time,	for
precise	cursor	positioning.	For	more	information	about	cursors,
refer	to	Using	Cursors	to	Make	Waveform	Measurements.



Channel	Settings
Controls	each	of	the	IVI	Soft	Front	Panels—Scope	channels.	You	can	set
vertical	position	and	volts	per	division.	The	following	list	describes	each
component:

Top
Arrows

Scrolls	through	all	channels	selected	in	the	channel	selector
and	selects	the	active	channel.

Volts/div Selects	the	vertical	sensitivity.	The	units	are	in	volts/division.
V
Position

Adjusts	the	vertical	position	of	the	trace.

Coupling Sets	the	input	coupling	to	AC	or	DC.



Trigger	Settings
Controls	the	trigger	conditions	under	which	IVI	Soft	Front	Panels—Scope
acquires	a	signal.		To	set	the	trigger	holdoff	value,	refer	to	the	Acquire	tab
in	the	IVI	Soft	Front	Panels	Scope	general	settings	dialog	box.

Src Selects	the	analog	or	digital	channel	that	you	want	to	use	as	a
trigger	source.

Note		Only	those	trigger	sources	that	the	current
instrument	supports	appear	in	this	control.
Immed—The	oscilloscope	does	not	wait	for	a	trigger	of
any	kind.
Ext—The	oscilloscope	waits	for	a	trigger	on	an	external
trigger	input.
Ch	x—The	oscilloscope	waits	for	a	trigger	on	the
acquisition	channel	x.
AC—The	oscilloscope	waits	for	a	trigger	on	the	AC	line.
GET—The	oscilloscope	waits	until	it	receives	a	GPIB
Group	Execute	Trigger	(GET).
TTLx	—The	oscilloscope	waits	until	it	receives	a	trigger	on
the	PXI	TTLx	line	(for	PXI	instruments)	or	the	VXI	TTLx
line	(for	VXI	instruments).
ECLx—The	oscilloscope	waits	for	a	trigger	on	the	ECL	line
x.
Star—The	oscilloscope	waits	for	a	trigger	on	the	PXI	star
bus.
RTSIx—The	oscilloscope	waits	for	a	trigger	on	the	RTSI
line	x.

Slope Selects	the	slope	(rising	or	falling)	required	to	meet	the	trigger
condition.

Set
50%

Sets	the	vertical	trigger	position	to	halfway	between	the	min	and
max	values	of	the	trigger	channel's	input	signal.	For	instance,	if	a
5V	amplitude	sine	wave	with	1V	offset	(max	value	is	6V,	min
value	is	-4V)	is	connected	to	the	trigger	channel,	the	Set	50%
button	sets	the	vertical	trigger	position	to	1V	((6	-	4)	/	2)).

Note		On	External	(Ext)	channels,	clicking	this	button	sets



the	trigger	level	to	0	V.



Zoom	Controls
Controls	the	current	zoom	magnification.	

Scroll
Bar

Scrolls	along	the	X-	or	time	axis.	To	use	the	scroll	bar	to	increase
the	zoom	factor,	click	the	zoom	hotspot	on	the	edge	of	the	scroll
bar,	which	turns	red	when	active,	and	drag	it	left	or	right	or	slide
the	scroll	bar	to	the	far	left	or	far	right.

Zoom Increases	the	zoom	factor	by	two.
Full
Scale

Autoscales	the	x-axis	to	display	the	entire	waveform.

You	can	use	these	controls	in	conjunction	with	the	Timebase	control	to
display	waveforms	in	more	detail.



Working	with	IVI	Soft	Front	Panels—Scope
This	topic	introduces	how	to	configure	IVI	Soft	Front	Panels—Scope
software,	acquire	data	using	IVI	Soft	Front	Panels—Scope	and	save
waveform.
Configuring	Scope	Settings—Acquire
Configuring	Scope	Channel	Settings—Acquire
Configuring	Reference	Channels—Color
Acquiring	Data
Printing	the	Front	Panel	Display
Saving	Waveforms	to	Disk
Viewing	Saved	Waveforms
Comparing	Saved	and	New	Waveforms
Using	Waveform	Math	Channels
Using	Cursors	to	Make	Waveform	Measurements
Using	the	Measurement	Display



Configuring	General	Settings
Expand	this	book	to	view	topics	related	to	configuring	general	settings.



Scope	Settings	-	Acquire
Click	other	tabs	in	this	figure	for	more	information	about	those
settings.

To	configure	IVI	Soft	Front	Panels—Scope	General	Settings,	select
Edit»General	Settings.

Instrument Selects	an	IVI	instrument	to	use	with	IVI	Soft	Front
Panels​Scope.	Only	logical	names	that	you	have	configured
successfully	in	the	MAX	appear	in	this	list.

Acquisition
Type

Specifies	how	the	oscilloscope	acquires	data	and	fills
waveform	record.

Trigger
Holdoff

Specifies	the	length	of	time	the	oscilloscope	waits	after	it
detects	a	trigger	before	the	enabling	the	trigger	subsystem
to	detect	another	trigger.



Scope	Settings—Display
Click	the	other	tabs	in	this	figure	for	information	about	those
settings.

To	configure	IVI	Soft	Front	Panels—Scope	graphics	display,	select
Edit»General	Settings.

Point	Style Sets	the	point	style	for	the	waveforms	displayed	on	the
front	panel.

Cursor
Style

Sets	the	type	of	cursor	that	appears	in	the	front	panel
display.

Foreground
Color

Sets	the	color	of	the	text	and	grid	lines	of	the	graphics
display	and	status	display.

Background
Color

Sets	the	background	color	of	the	graphics	display.

Stack	Plots
with	Auto

Stacks	plots	vertically	when	you	select	Auto	Setup,	so
that	no	overlap	occurs.		This	feature	takes	effect	only



Setup when	the	instrument	does	not	support	Auto	Setup	feature
and	IVI	Soft	Front	Panels—Scope	performs	the	Auto
Setup	by	the	software.



Configuring	Channel	Scope	Settings
Expand	this	book	to	view	topics	related	to	configuring	channel	scope
settings.



Scope	Channel	Settings—Acquire
Click	the	other	tabs	in	this	figure	for	information	about	those
settings.

To	configure	IVI	Soft	Front	Panels—Scope	Channel	Acquire	Settings,
select	Edit»Channel	Settings.

Channel
Name

Displays	the	name	for	the	corresponding	oscilloscope
channel.

Color Selects	the	color	of	the	plot	and	status	information	on	the
front	panel.

Input
Impedance

Specifies	the	oscilloscope	channel's	input	impedance	in
Ohms.

Probe
Attenuation

Specifies	an	initial	scale	value	which	applies	to	the	signal.
For	example,	if	you	use	a	10X	probe	on	channel	one,	set
the	attenuation	value	to	ten.	Each	channel	can	have	a
different	attenuation	factor.



Scope	Channel	Settings—Math
Click	the	other	tabs	in	this	figure	for	information	about	those
settings.

To	configure	IVI	Soft	Front	Panel—Scope	Math	Channel,	select
Edit»Channel	Settings.
In	this	screen,	you	can	configure	one	or	more	math	channels.	Each	math
channel	is	defined	by	a	mathematical	expression	in	terms	of	channel
names.



Examples
Ch	12	+	Ch	2	+	5
(Ch	1	+	log(Math	1))	/	2	+	pi
Available	operators	and	functions	are:

abs(x) Absolute
Value

Returns	the	absolute	value	of	x.

acos(x) Inverse
Cosine

Computes	the	inverse	cosine	of	x	in	radians.

acosh(x) Inverse
Hyperbolic
Cosine

Computes	the	inverse	hyperbolic	cosine	of	x
in	radians.

asin(x) Inverse	Sine Computes	the	inverse	sine	of	x	in	radians.
asinh(x) Inverse

Hyperbolic
Sine

Computes	the	inverse	hyperbolic	sine	of	x	in
radians.

atan(x) Inverse
Tangent

Computes	the	inverse	tangent	of	x	in
radians.

atanh(x) Inverse
Hyperbolic
Tangent

Computes	the	inverse	hyperbolic	tangent	of	x
in	radians.

ceil(x) Round	to
+Infinity

Rounds	x	to	the	next	higher	integer	(smallest
int3	x).

cos(x) Cosine Computes	the	cosine	of	x	in	radians.
cosh(x) Hyperbolic

Cosine
Computes	the	hyperbolic	cosine	of	x	in
radians.

cot(x) Cotangent Computes	the	cotangent	of	x	in	radians
(1/tan(x)).

csc(x) Cosecant Computes	the	cosecant	of	x	in	radians
(1/sin(x)).

exp(x) Exponential Computes	the	value	of	e	raised	to	the	x
power.

expm1(x) Exponential Computes	the	value	of	e	raised	to	the	x



(Arg)	-	1 power	minus	one	(ex-1).
floor(x) Round	to	-

Infinity
Truncates	x	to	the	next	lower	integer.

getexp(x) Mantissa	&
Exponent

Returns	the	exponent	of	x.

getmanint(x) Mantissa	&
Exponent

Returns	the	mantissa	of	x.

intrz(x) Round
Toward	0

Rounds	x	to	the	nearest	integer	between	x
and	zero.

ln(x) Natural
Logarithm

Computes	the	natural	logarithm	of	x	(to	the
base	e).

lnp1(x) Natural
Logarithm
(Arg	+1)

Computes	the	natural	logarithm	of	(x	+	1).

log(x) Logarithm
Base	10

Computes	the	logarithm	of	x	(to	the	base	of
10).

log2(x) Logarithm
Base	2

Computes	the	logarithm	of	x	(to	the	base	2).

rand(	) Random
Number

Produces	a	floating-point	number	between	0
and	1	exclusively.

rem(x,y) Remainder Same	as	mod	except	quotient	is	rounded	to
the	nearest	integer.

sec(x) Secant Computes	the	secant	of	x	radians	(1/cos(x)).
sign(x) Sign Returns	1	if	x	is	greater	than	0,	returns	0	if	x

is	equal	to	0,	and	returns	-1	if	x	is	less	than
0.

sin(x) Sine Computes	the	sine	of	x	radians.
sinc(x) Sinc Computes	the	sine	of	x	divided	by	x	radians

(sin(x)/x).
sinh(x) Hyperbolic

Sine
Computes	the	hyperbolic	sine	of	x	in	radians.

sqrt(x) Square	Root Computes	the	square	root	of	x.
tan(x) Tangent Computes	the	tangent	of	x	in	radians.



tanh(x) Hyperbolic
Tangent

Computes	the	hyperbolic	tangent	of	x	in
radians.

x^y xy Computes	the	value	of	x	raised	to	the	y
power.

pi pi returns	pi	=	3.14159263538929



Configuring	Reference	Channels—Color
Click	the	other	tabs	in	this	figure	for	information	about	those
settings.

To	configure	the	IVI	Soft	Front	Panels—Scope	Reference	Channel
Settings,	select	Edit»Channel	Settings.	Select	the	color	for	Ref	1	and
Ref	2	channels.	Click	OK.



Acquiring	Data
Complete	the	following	steps	to	acquire	data	with	IVI	Soft	Front	Panels—
Scope:

1.	 Connect	the	signal	to	one	of	the	channels	of	your	instrument.
Refer	to	your	instrument	user	manual	for	more	information.

2.	 Configure	Scope	General	Settings	and	Scope	Channel	Settings.
3.	 Click	the	appropriate	channel	buttons	(Ch	1,	Ch	2,	and	so	on)	in

the	channel	selector	of	the	front	panel.
4.	 Click	Auto	Setup.
5.	 Adjust	the	Timebase	knob,	if	necessary.
6.	 To	change	the	trigger	channel,	select	a	new	channel	with	the

Trigger	source	selector	and	click	Auto	Setup	again.



Printing	the	Front	Panel	Display
IVI	Soft	Front	Panels—Scope	can	print	to	any	standard	printer	connected
to	your	computer	either	directly	or	over	a	network.	Select	File»Print
Display	to	print	out	the	IVI	Soft	Front	Panels—Scope	front	panel.



Saving	Waveforms	to	Disk

Complete	the	following	steps	to	save	to	disk	any	waveforms	currently	in
memory:

1.	 Select	File»Save	Waveform	to	open	the	dialog	box	shown	above.
2.	 By	default,	all	waveforms	of	the	enabled	channel	are	selected.

Deselect	the	waveforms	you	do	not	want	to	save.	Name	and
comment	the	waveforms.	Click	OK.

3.	 Enter	the	name	of	the	file	to	store	the	waveforms.	Click	OK.
IVI	Soft	Front	Panels—Scope	stores	the	waveforms	to	disk	as	an	ASCII
text	file.
Related	Topics
Viewing	Saved	Waveforms
Comparing	Saved	and	New	Waveforms



Viewing	Saved	Waveforms

To	use	a	saved	waveform,	you	must	load	it	into	one	of	two	memory
locations	or	reference	buffers	by	completing	the	following	steps:

1.	 Select	File»Load	Waveform.
2.	 Select	the	text	file	in	which	the	waveforms	are	stored.
3.	 Click	OK.	The	dialog	box	shown	above	opens.
4.	 Select	the	column	of	the	waveform	to	load.
5.	 Choose	the	reference	channel	for	the	waveform.
6.	 Click	OK.
7.	 Click	Ref	1	and/or	Ref	2	in	the	channel	selector	of	the	front	panel

to	display	the	waveforms.
Waveforms	in	the	Ref	1	and	Ref	2	channels	are	known	as	reference
waveforms.	The	current	reference	waveforms	remain	in	memory	until	you
replace	them	with	other	saved	waveforms	or	until	you	exit	from	IVI	Soft
Front	Panels—Scope.
Related	Topics
Saving	Waveforms	to	Disk
Comparing	Saved	and	New	Waveforms



Comparing	Saved	and	New	Waveforms
Complete	the	following	steps	to	compare	one	or	two	reference
waveforms	with	newly	acquired	waveforms:

1.	 Load	one	or	two	waveforms	from	an	ASCII	text	file.	Refer	to
Viewing	Saved	Waveforms	for	more	information.	You	also	can
copy	a	waveform	from	one	of	the	existing	channels.	To	select	the
waveform	to	copy,	select	the	channel	using	the	arrow	buttons	in
the	channel	settings	group	of	the	front	panel	or	the	vertical
position	slider	for	that	channel.	Next,	select	Edit»Copy	Channel
to	Ref	1	or	Edit»Copy	Channel	to	Ref	2	to	copy	the	active
waveform	to	the	reference	channel.

2.	 Click	Ref	1	or	Ref	2	in	the	channel	selector	to	display	the
reference	waveforms.

3.	 Adjust	the	vertical	position	sliders	or	other	controls	in	the	channel
settings	group	and	notice	the	effects	on	the	reference	waveforms.

4.	 Adjust	the	Timebase	knob	and	the	x-axis	position	slide	control	to
view	parts	of	the	waveform.



Using	Waveform	Math	Channels
To	perform	mathematical	operations	on	incoming	signals,	use	the	math
channel	and	complete	the	following	steps:

1.	 Select	Edit»Channel	Settings.
2.	 Click	the	Math	tab.
3.	 Enter	a	mathematical	expression	in	terms	of	channel

names.	For	more	information,	refer	to	Scope	Channel	Settings—
Math.

4.	 Click	the	math	channel	in	the	channel	selector	group	of	the	front
panel	to	display	the	result.



Using	Cursors	to	Make	Waveform
Measurements
Complete	the	following	steps	to	make	precise	measurements	using	the
two	cursors	on	the	IVI	Soft	Front	Panels—Scope	display:

1.	 Set	up	IVI	Soft	Front	Panels—Scope	to	display	one	or	more
waveforms.	Refer	to	Acquiring	Data	for	more	information.

2.	 Turn	on	the	cursor	display	by	clicking	the	cursor	button	in	the
cursor	settings	group	of	the	front	panel.

3.	 In	the	same	group,	set	cursor	1	(C1)	and	cursor	2	(C2)	to
channels	that	have	displayed	waveforms.

4.	 Move	the	cursors	to	the	right	of	the	display	by	clicking	on	them
and	dragging	them.	You	can	also	use	the	arrow	keys	below	the
Cursors	control	to	move	the	cursor	along	one	point	at	a	time.

Related	Topic
Using	the	Measurement	Display



Using	the	Measurement	Display
IVI	Soft	Front	Panels—Scope	has	sophisticated	waveform	measurement
capability	in	the	measurement	display	of	the	front	panel.	Complete	the
following	steps	to	control	the	measurements	that	appear	in	the
measurement	display:

1.	 Select	Measure»Channel»Measurement.
2.	 Enable	the	channel	by	selecting	it	in	the	channel	selector.
Note		To	ensure	accurate	waveform	measurements,	use	the
following	guidelines:

The	waveform	must	lie	completely	within	the	top	and	bottom
confines	of	the	display.	Adjust	the	Volts/Division	and/or
Vertical	Offset	controls	appropriately.
If	you	are	measuring	frequency	or	period,	at	least	four
complete	periods	of	the	waveform	must	appear	in	the
graphics	display.	Adjust	the	Timebase	control	appropriately.
Remember	that	IVI	Soft	Front	Panels—Scope	detects	when
a	measurement	is	being	clipped	or	when	there	is	not	enough
data	being	acquired	to	make	valid	frequency	or	period
measurements.	In	these	cases,	+Over,	-Over,	or	?		appears
in	the	display	in	place	of	the	usual	numeric	information.



Measurements
Mean Average	value	of	the	signal.
RMS Root	Mean	Square	(RMS)	or	AC	component	of	the	signal.
Max Maximum	sampled	voltage	value.
Min Minimum	sampled	voltage	value.
Pk-Pk Maximum	voltage	swing	(Max	–	Min).
High The	value	that	best	represents	the	active	or	high	position

of	the	signal.
Low The	value	that	best	represents	the	inactive	or	low	position

in	the	signal.
Amplitude Signal	amplitude	(High	–	Low).
Overshoot The	amount	by	which	the	maximum	value	exceeds	the

High	value	(Max	–	High).
Undershoot The	amount	by	which	the	minimum	value	is	lower	than	the

Low	value	(Low	–	Min).
Frequency The	frequency	of	the	signal	in	Hz.	To	give	an	accurate

frequency	measurement,	the	display	must	show	at	least
four	complete	cycles.

Period The	period	of	the	signal	in	seconds.	To	give	an	accurate
period	measurement,	the	display	must	show	at	least	four
complete	cycles.

Rise	Time The	time	required	to	rise	from	10	percent	amplitude	to	90
percent	amplitude.

Fall	Time The	time	required	to	fall	from	90	percent	amplitude	to	10
percent	amplitude.

Positive
Width

The	average	period	of	time	between	the	rising	edge	and
the	next	falling	edge,	measured	at	50	percent	signal
amplitude.

Negative
Width

The	average	period	of	time	between	the	falling	edge	and
the	next	rising	edge,	measured	at	50	percent	signal
amplitude.

Positive The	percentage	of	time	that	the	signal	is	in	a	high	signal



Duty	Cycle state.	(Positive	Width	×	100	%)	/	Period.
Negative
Duty	Cycle

The	percentage	of	time	that	the	signal	is	in	a	low	signal
state.	(Negative	Width	×	100	%)	/	Period.

Slew	Rate The	rate	at	which	the	signal	changes	in	volts/seconds
between	the	90	percent	and	10	percent	levels.	(90%
amplitude	–	10%	amplitude)/Rise	Time.

Related	Topic
Using	Cursors	to	Make	Waveform	Measurements



IVI	Soft	Front	Panels—Switch	Overview
Combined	with	an	IviSwtch	class​compliant	instrument,	IVI	Soft	Front
Panels—Switch	transforms	your	PC	into	a	fully	featured	switch	with
features	rivaling	desktop	models.	IVI	Soft	Front	Panels—Switch	display
controls	and	operation	faithfully	emulate	benchtop	switch	so	that	you	can
take	maximum	advantage	of	your	previous	instrument	experience,	with
minimal	training	time,	to	use	PC​based	instruments.
Related	Topic
Working	with	IVI	Soft	Front	Panels—Switch



IVI	Soft	Front	Panels—Switch	Features
You	use	IVI	Soft	Front	Panels—Switch	to	make	and	break	connections
on	any	Switch	with	an	IviSwtch​compliant	specific	driver.	IVI	Soft	Front
Panels—Switch	includes	the	following	features:

Connects/disconnects	channels	on	any	switch
Displays	maximum	voltage,	current,	and	power	limits	for	a
particular	channel



Tour	of	Front	Panel	and	Menus
The	following	figure	shows	the	front	panel	of	IVI	Soft	Front	Panels—
Switch.	You	can	scroll	over	regions	of	the	figure	and	click	areas	of
interest	for	more	in-depth	information.

Menus Controls/Indicators
File Instrument	Selector Channel	Selection	Group
Edit Connection	List Status	Display
Utility
Help



File
Exit Closes	IVI	Soft	Front	Panels—Switch.



Edit
Load
Settings

Restores	IVI	Soft	Front	Panels—Switch	to	the	configuration
you	have	saved	in	a	settings	file.

Save
Settings

Saves	the	current	IVI	Soft	Front	Panels—Switch
configuration	in	a	settings	file.

Reset
Settings

Restores	IVI	Soft	Front	Panels—Switch	to	its	default	settings.

Refer	to	Saving	and	Restoring	Settings	for	more	information	about
options	in	the	Edit	menu.



Utility
Self–
Test

Performs	self–test	on	the	instrument.	This	operation	may
take	several	minutes.

Reset Resets	the	instrument.
Error
Query

Queries	the	errors	occurred.



Help
You	can	choose	the	following	items	in	the	Help	menu.	

Show	Tip
Strips
Help

Tip	Strips	Help	appears	when	your	mouse	pointer	pauses
over	a	user	interface	control	or	item.	Information	in	the	tip
strips	window	briefly	describes	the	function	or	action
associated	with	the	underlying	control.

Show
Context
Help

Context	Help	appears	in	the	Pop-up	Help	window	when	your
mouse	pointer	pauses	over	a	user	interface	control	or	item.
Information	in	the	Pop-up	window	describes	the	function	or
action	associated	with	the	underlying	control.

Online
Reference

Shows	the	online	help.

About	IVI
Soft	Front
Panels—
Switch

Displays	the	About	dialog	box.



Instrument	Selector
Allows	you	to	select	the	IVI	instrument	you	want	to	use.	Use	MAX	to
configure	the	logical	name	to	the	IviSwtch	class.	Refer	to	National
Instruments	IVI	Driver	Help»Configuring	Your	System	for	more
information	about	configuring	a	logical	name.



Connection	List
Shows	all	existing	connections.	To	disconnect	an	existing	connection,
click	the	connection	in	the	connection	list	and	click	the	Disconnect
button.	To	disconnect	all	existing	connection,	click	the	Disconnect	ALL
button.



Channel	Selection	Group
Allows	you	to	choose	two	channels	to	connect.	To	connect	two	channels,
select	two	valid	channels	and	click	Connect.



Status	Display
Displays	the	following	information:

Connection	path	of	the	selected	connection
Channel	information	such	as	maximum	current,	voltage	and	power
capacity
Information	on	why	two	channels	cannot	be	connected
Any	error	information



Working	with	IVI	Soft	Front	Panels—Switch
This	topic	introduces	how	to	make	connections	with	IVI	Soft	Front	Panels
—Switch	software.
Making	Connections



Making	Connections
Complete	the	following	steps	to	make	signal	connections:

1.	 Connect	signals	to	two	or	more	channels	on	your	switch
instrument.

2.	 Select	an	IVI	instrument	to	use	with	IVI	Soft	Front	Panels—
Switch.	Only	logical	names	that	you	have	configured	successfully
in	MAX	appear	in	the	IVI	Instrument	list.	Refer	to:

3.	 Select	two	channels	that	you	want	to	connect	in	the	Channel
Selection	Group.

4.	 Click	Connect	to	connect	the	two	channels.
5.	 Click	the	connection	in	the	Connection	List	to	view	information

about	the	connection.
To	view	information	about	a	particular	connection,	click	the	connection	in
the	Connection	List.	IVI	Soft	Front	Panels—Switch	displays	information
such	as	the	connection	path	and	the	maximum	allowable	voltage,
current,	and	power	levels	for	each	channel.
To	disconnect	a	signal	connection,	click	the	connection	in	the	Connection
List	and	then	click	Disconnect.
To	exit	IVI	Soft	Front	Panels—Switch,	select	Exit	from	the	File	menu.



Important	Information
Warranty
Copyright
Trademarks
Patents
Warning	Regarding	Use	of	NI	Products



Warranty
The	media	on	which	you	receive	National	Instruments	software	are
warranted	not	to	fail	to	execute	programming	instructions,	due	to	defects
in	materials	and	workmanship,	for	a	period	of	90	days	from	date	of
shipment,	as	evidenced	by	receipts	or	other	documentation.	National
Instruments	will,	at	its	option,	repair	or	replace	software	media	that	do	not
execute	programming	instructions	if	National	Instruments	receives	notice
of	such	defects	during	the	warranty	period.	National	Instruments	does	not
warrant	that	the	operation	of	the	software	shall	be	uninterrupted	or	error
free.
A	Return	Material	Authorization	(RMA)	number	must	be	obtained	from
the	factory	and	clearly	marked	on	the	outside	of	the	package	before	any
equipment	will	be	accepted	for	warranty	work.	National	Instruments	will
pay	the	shipping	costs	of	returning	to	the	owner	parts	which	are	covered
by	warranty.
National	Instruments	believes	that	the	information	in	this	document	is
accurate.	The	document	has	been	carefully	reviewed	for	technical
accuracy.	In	the	event	that	technical	or	typographical	errors	exist,
National	Instruments	reserves	the	right	to	make	changes	to	subsequent
editions	of	this	document	without	prior	notice	to	holders	of	this	edition.
The	reader	should	consult	National	Instruments	if	errors	are	suspected.
In	no	event	shall	National	Instruments	be	liable	for	any	damages	arising
out	of	or	related	to	this	document	or	the	information	contained	in	it.
EXCEPT	AS	SPECIFIED	HEREIN,	NATIONAL	INSTRUMENTS	MAKES
NO	WARRANTIES,	EXPRESS	OR	IMPLIED,	AND	SPECIFICALLY
DISCLAIMS	ANY	WARRANTY	OF	MERCHANTABILITY	OR	FITNESS
FOR	A	PARTICULAR	PURPOSE.	CUSTOMER'S	RIGHT	TO	RECOVER
DAMAGES	CAUSED	BY	FAULT	OR	NEGLIGENCE	ON	THE	PART	OF
NATIONAL	INSTRUMENTS	SHALL	BE	LIMITED	TO	THE	AMOUNT
THERETOFORE	PAID	BY	THE	CUSTOMER.	NATIONAL
INSTRUMENTS	WILL	NOT	BE	LIABLE	FOR	DAMAGES	RESULTING
FROM	LOSS	OF	DATA,	PROFITS,	USE	OF	PRODUCTS,	OR
INCIDENTAL	OR	CONSEQUENTIAL	DAMAGES,	EVEN	IF	ADVISED	OF
THE	POSSIBILITY	THEREOF.	This	limitation	of	the	liability	of	National
Instruments	will	apply	regardless	of	the	form	of	action,	whether	in
contract	or	tort,	including	negligence.	Any	action	against	National
Instruments	must	be	brought	within	one	year	after	the	cause	of	action



accrues.	National	Instruments	shall	not	be	liable	for	any	delay	in
performance	due	to	causes	beyond	its	reasonable	control.	The	warranty
provided	herein	does	not	cover	damages,	defects,	malfunctions,	or
service	failures	caused	by	owner's	failure	to	follow	the	National
Instruments	installation,	operation,	or	maintenance	instructions;	owner's
modification	of	the	product;	owner's	abuse,	misuse,	or	negligent	acts;
and	power	failure	or	surges,	fire,	flood,	accident,	actions	of	third	parties,
or	other	events	outside	reasonable	control.



Copyright
Under	the	copyright	laws,	this	publication	may	not	be	reproduced	or
transmitted	in	any	form,	electronic	or	mechanical,	including	photocopying,
recording,	storing	in	an	information	retrieval	system,	or	translating,	in
whole	or	in	part,	without	the	prior	written	consent	of	National	Instruments
Corporation.
National	Instruments	respects	the	intellectual	property	of	others,	and	we
ask	our	users	to	do	the	same.	NI	software	is	protected	by	copyright	and
other	intellectual	property	laws.	Where	NI	software	may	be	used	to
reproduce	software	or	other	materials	belonging	to	others,	you	may	use
NI	software	only	to	reproduce	materials	that	you	may	reproduce	in
accordance	with	the	terms	of	any	applicable	license	or	other	legal
restriction.



Trademarks
National	Instruments,	NI,	ni.com,	and	LabVIEW	are	trademarks	of
National	Instruments	Corporation.	Refer	to	the	Terms	of	Use	section	on
ni.com/legal	for	more	information	about	National	Instruments	trademarks.
FireWire®	is	the	registered	trademark	of	Apple	Computer,	Inc.
Handle	Graphics®,	MATLAB®,	Real-Time	Workshop®,	Simulink®,
Stateflow®,	and	xPC	TargetBox®	are	registered	trademarks,	and
TargetBox™	and	Target	Language	Compiler™	are	trademarks	of	The
MathWorks,	Inc.
Tektronix®	and	Tek	are	registered	trademarks	of	Tektronix,	Inc.
Other	product	and	company	names	mentioned	herein	are	trademarks	or
trade	names	of	their	respective	companies.
Members	of	the	National	Instruments	Alliance	Partner	Program	are
business	entities	independent	from	National	Instruments	and	have	no
agency,	partnership,	or	joint-venture	relationship	with	National
Instruments.

javascript:WWW(WWW_Trademark)


Patents
For	patents	covering	National	Instruments	products,	refer	to	the
appropriate	location:	Help»Patents	in	your	software,	the	patents.txt	file	on
your	CD,	or	ni.com/patents.

javascript:WWW(WWW_Patents)


WARNING	REGARDING	USE	OF	NATIONAL
INSTRUMENTS	PRODUCTS
(1)	NATIONAL	INSTRUMENTS	PRODUCTS	ARE	NOT	DESIGNED
WITH	COMPONENTS	AND	TESTING	FOR	A	LEVEL	OF	RELIABILITY
SUITABLE	FOR	USE	IN	OR	IN	CONNECTION	WITH	SURGICAL
IMPLANTS	OR	AS	CRITICAL	COMPONENTS	IN	ANY	LIFE	SUPPORT
SYSTEMS	WHOSE	FAILURE	TO	PERFORM	CAN	REASONABLY	BE
EXPECTED	TO	CAUSE	SIGNIFICANT	INJURY	TO	A	HUMAN.
(2)	IN	ANY	APPLICATION,	INCLUDING	THE	ABOVE,	RELIABILITY	OF
OPERATION	OF	THE	SOFTWARE	PRODUCTS	CAN	BE	IMPAIRED	BY
ADVERSE	FACTORS,	INCLUDING	BUT	NOT	LIMITED	TO
FLUCTUATIONS	IN	ELECTRICAL	POWER	SUPPLY,	COMPUTER
HARDWARE	MALFUNCTIONS,	COMPUTER	OPERATING	SYSTEM
SOFTWARE	FITNESS,	FITNESS	OF	COMPILERS	AND
DEVELOPMENT	SOFTWARE	USED	TO	DEVELOP	AN	APPLICATION,
INSTALLATION	ERRORS,	SOFTWARE	AND	HARDWARE
COMPATIBILITY	PROBLEMS,	MALFUNCTIONS	OR	FAILURES	OF
ELECTRONIC	MONITORING	OR	CONTROL	DEVICES,	TRANSIENT
FAILURES	OF	ELECTRONIC	SYSTEMS	(HARDWARE	AND/OR
SOFTWARE),	UNANTICIPATED	USES	OR	MISUSES,	OR	ERRORS	ON
THE	PART	OF	THE	USER	OR	APPLICATIONS	DESIGNER	(ADVERSE
FACTORS	SUCH	AS	THESE	ARE	HEREAFTER	COLLECTIVELY
TERMED	"SYSTEM	FAILURES").	ANY	APPLICATION	WHERE	A
SYSTEM	FAILURE	WOULD	CREATE	A	RISK	OF	HARM	TO
PROPERTY	OR	PERSONS	(INCLUDING	THE	RISK	OF	BODILY
INJURY	AND	DEATH)	SHOULD	NOT	BE	RELIANT	SOLELY	UPON	ONE
FORM	OF	ELECTRONIC	SYSTEM	DUE	TO	THE	RISK	OF	SYSTEM
FAILURE.	TO	AVOID	DAMAGE,	INJURY,	OR	DEATH,	THE	USER	OR
APPLICATION	DESIGNER	MUST	TAKE	REASONABLY	PRUDENT
STEPS	TO	PROTECT	AGAINST	SYSTEM	FAILURES,	INCLUDING	BUT
NOT	LIMITED	TO	BACK-UP	OR	SHUT	DOWN	MECHANISMS.
BECAUSE	EACH	END-USER	SYSTEM	IS	CUSTOMIZED	AND
DIFFERS	FROM	NATIONAL	INSTRUMENTS'	TESTING	PLATFORMS
AND	BECAUSE	A	USER	OR	APPLICATION	DESIGNER	MAY	USE
NATIONAL	INSTRUMENTS	PRODUCTS	IN	COMBINATION	WITH
OTHER	PRODUCTS	IN	A	MANNER	NOT	EVALUATED	OR
CONTEMPLATED	BY	NATIONAL	INSTRUMENTS,	THE	USER	OR



APPLICATION	DESIGNER	IS	ULTIMATELY	RESPONSIBLE	FOR
VERIFYING	AND	VALIDATING	THE	SUITABILITY	OF	NATIONAL
INSTRUMENTS	PRODUCTS	WHENEVER	NATIONAL	INSTRUMENTS
PRODUCTS	ARE	INCORPORATED	IN	A	SYSTEM	OR	APPLICATION,
INCLUDING,	WITHOUT	LIMITATION,	THE	APPROPRIATE	DESIGN,
PROCESS	AND	SAFETY	LEVEL	OF	SUCH	SYSTEM	OR
APPLICATION.



Technical	Support	and	Professional	Services
Visit	the	following	sections	of	the	National	Instruments	Web	site	at	ni.com
for	technical	support	and	professional	services:

Support—Online	technical	support	resources	at	ni.com/support
include	the	following:

Self-Help	Resources—For	answers	and	solutions,	visit	the
award-winning	National	Instruments	Web	site	for	software
drivers	and	updates,	a	searchable	KnowledgeBase,	product
manuals,	step-by-step	troubleshooting	wizards,	thousands	of
example	programs,	tutorials,	application	notes,	instrument
drivers,	and	so	on.
Free	Technical	Support—All	registered	users	receive	free
Basic	Service,	which	includes	access	to	hundreds	of
Applications	Engineers	worldwide	in	the	NI	Discussion
Forums	at	forums.ni.com.	National	Instruments	Applications
Engineers	make	sure	every	question	receives	an	answer.
For	information	about	other	technical	support	options	in	your
area,	visit	ni.com/services	or	contact	your	local	office	at
ni.com/contact.

Training	and	Certification—Visit	ni.com/training	for	self-paced
training,	eLearning	virtual	classrooms,	interactive	CDs,	and
Certification	program	information.	You	also	can	register	for
instructor-led,	hands-on	courses	at	locations	around	the	world.
System	Integration—If	you	have	time	constraints,	limited	in-house
technical	resources,	or	other	project	challenges,	National
Instruments	Alliance	Partner	members	can	help.	To	learn	more,
call	your	local	NI	office	or	visit	ni.com/alliance.

If	you	searched	ni.com	and	could	not	find	the	answers	you	need,	contact
your	local	office	or	NI	corporate	headquarters.	You	also	can	visit	the
Worldwide	Offices	section	of	ni.com/niglobal	to	access	the	branch	office
Web	sites,	which	provide	up-to-date	contact	information,	support	phone
numbers,	email	addresses,	and	current	events.
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Branch	Offices
Office Telephone	Number
Australia 1800	300	800
Austria 43	0	662	45	79	90	0
Belgium 32	0	2	757	00	20
Brazil 55	11	3262	3599
Canada 800	433	3488
China 86	21	6555	7838
Czech	Republic 420	224	235	774
Denmark 45	45	76	26	00
Finland 385	0	9	725	725	11
France 33	0	1	48	14	24	24
Germany 49	0	89	741	31	30
India 91	80	41190000
Israel 972	0	3	6393737
Italy 39	02	413091
Japan 81	3	5472	2970
Korea 82	02	3451	3400
Lebanon 961	0	1	33	28	28
Malaysia 1800	887710
Mexico 01	800	010	0793
Netherlands 31	0	348	433	466
New	Zealand 0800	553	322
Norway 47	0	66	90	76	60
Poland 48	22	3390150
Portugal 351	210	311	210
Russia 7	095	783	68	51
Singapore 1800	226	5886
Slovenia 386	3	425	4200



South	Africa 27	0	11	805	8197
Spain 34	91	640	0085
Sweden 46	0	8	587	895	00
Switzerland 41	56	200	51	51
Taiwan 886	02	2377	2222
Thailand 662	278	6777
United	Kingdom 44	0	1635	523545
United	States	(Corporate) 512	683	0100
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