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Since	C#	Add-In	transforms	UML	model	to	C#	source	code	or	C#	source	code
to	UML	model,	you	can	achieve	high	productivity	and	quality	improvement	as
adopting	C#	code	generation	and	reverse	engineering	to	the	tool	easily	and
quickly.
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This	chapter	contains	a	general	overview	of	C#	Add-In:	functions	and
configuration	procedures.

C#	Add-In	Functions

C#	Add-In	Configurations
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C#	Add-In	provides	the	following	functions.

C#	Profile

C#	profile	is	provided	to	allow	visual	modeling	of	C#	concepts	such	as	package,
class,	interface,	using,	modifier	and	so	on	in		StarUML(tm).	Include	the	C#
profile	when	you	start	your	StarUML(tm)	project,	in	order	to	apply	the	features
of	the	C#	language	in	your	software	modeling.

.NET	BCL	Model	Framework

C#	Add-In	provides	the	ECMA-334	Standard	Library	in	the	Model	Framework
format.

C#	Reverse	Engineering

C#	Add-In	provides	the	reverse	engineering	function	that	generates
StarUML(tm)	models	by	analyzing	C#	codes.

C#	Code	Generation

C#	Add-In	provides	the	forward	engineering	function	that	generates	C#	codes
by	analyzing	StarUML(tm)	models.

Note

The	scope	of	application	for	C#	Add-In	is	C#	codes	based	on	ECMA-334
(C#	Language	Specification	v1.2).
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Once	C#	Add-In	is	installed,	it	is	enabled	for	use	in	StarUML(tm)	by	default.
Installed	Add-Ins	can	be	enabled	or	disabled	through	Add-In	Manager	in
StarUML(tm).	If	an	Add-In	is	disabled,	no	main	menu	and	popup	menu	items
related	to	it	are	displayed,	and	no	StarUML(tm)	events	are	relayed	to	it.

Procedure	for	Enabling	C#	Add-In	:

1. Select	the	[Tools]	->	[Add-In	Manager...]	menu	in	StarUML(tm).

2.
At	the	Add-In	Manager	dialog	box,	check	the	"C#	Add-In"	checkbox	in

the	Add-In	list.

3. Click	the	[OK]	button	to	close	the	dialog	box.

	
Procedure	for	Disabling	C#	Add-In	:

1. Select	the	[Tools]	->	[Add-In	Manager...]	menu	in	StarUML(tm).

2.
At	the	Add-In	Manager	dialog	box,	uncheck	the	"C#	Add-In"	checkbox	in

the	Add-In	list.

3. Click	the	[OK]	button	to	close	the	dialog	box.
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This	chapter	describes	C#	profile:	configuration	procedures	and	definitions.

Including	C#	Profile

Excluding	C#	Profile

C#	Profile	Definition	List
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C#	profile	must	be	included	in	the	project	in	order	to	utilize	the	Stereotypes,
TagDefinitions,	and	DataTypes	defined	in	C#	profile.

Procedure	for	Including	C#	Profile:

1. Select	the	[Model]->[Profiles...]	menu.

2.
At	the	Profile	Manager	window,	select	"C#	Profile"	from	the	"Available

profiles"	list	on	the	left.

3.
Click	the	[Include]	button	or	hit	Alt-I	to	move	"C#	Profile"	to	the

"Included	profiles"	list.

4. Click	the	[Close]	button	to	close	the	Profile	Manager	window.

5. C#	profile	is	included	in	the	current	project.

Note

Opening	a	project	with	C#	profile	on	another	StarUML(tm)	system	that
does	not	have	C#	profile	installed	may	result	in	loss	of	extension



information	of	model	elements	(Stereotype,	Tagged	Value,	etc).
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C#	profile	can	be	excluded	from	the	current	project.	Once	C#	profile	is
excluded,	Stereotypes,	TagDefinitions	and	DataTypes	defined	in	the	profile
cannot	be	used	in	the	project.

Procedure	for	Excluding	C#	Profile	:

1. Select	the	[Model]	->	[Profile...]	menu.

2.
At	the	Profile	Manager	window,	select	"C#	Profile"	from	the	"Included

profiles"	list	on	the	right.

3.
Click	the	[Exclude]	button	or	hit	Alt-E	to	remove	"C#	Profile"	from	the

"Included	profiles"	list.

4. Click	the	[Close]	button	to	close	the	Profile	Manager	window.

5. C#	profile	is	excluded	from	the	current	project.

Note

Re-including	C#	profile	after	excluding	it	does	not	restore	the	previously



edited	tagged	values	of	the	model	elements.
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Stereotype

C#	profile	contains	definitions	for	the	following	stereotypes.

Sterotype
Target
Element Description

<<CSharpSourceFile>>Component Source	file	with	C#	code
<<DotNetAssembly>> Component File	with	compiled	C#	source	code
<<CSharpDelegate>> Class C#	Delegate	indicator
<<CSharpStruct>> Class C#	Struct	indicator
<<CSharpEvent>> Operation C#	Event	indicator
<<CSharpProperty>> Operation C#	Property	indicator
<<CSharpOperator>> Operation C#	Operator	indicator
<<CSharpIndexer>> Operation C#	Indexer	indicator

TagDefinition

C#	profile	contains	definitions	for	the	following	tag	definitions.

TagDefinition Type Target	Element Description

CSharpOverride BooleanOperation

An	instance	method
declared	by	using	an
override	modifier	is
called	"redefinition
method".	A
redefinition	method
redefines	an
inherited	virtual
method	that	has	the
same	signature.

CSharpVirtual BooleanOperation

If	a	declaration
contains	a	virtual
limiter,	the	method
is	called	"virtual
method".	If	there	is
no	virtual	modifier,



the	method	is	called
non-virtual	method.

CSharpExplicit BooleanOperation

The	explicit
keyword	is	used	for
declaring	explicit
user	definition
format	conversion
operators.

CSharpExtern BooleanOperation

Using	the	extern
limiter	in	the
method	declaration
indicates	that	the
method	is
manipulated
externally.

CSharpSetter BooleanOperation Property	accessors
include	execution
lines	related	to
importing	properties
(reading	or
calculating)	and
configuring
properties	(writing).
An	access
declaration	may
include	the	get
accessor,	the	set
accessor,	or	both.

CSharpGetter BooleanOperation

CSharpAdd BooleanOperation These	are
declarations	of
accessors	that	are
used	for	adding	or
removing	event
processors	in	the
client	code.
Accessor	functions
are	add	and
remove.

CSharpRemove BooleanOperation



CSharpConstructorInitializer String Operation

This	defines	other
instance	generators
that	will	be	called
before	executing	the
lines	in	the	instance
generator.

CSharpImplicit BooleanOperation

The	implicit
keyword	is	used	for
declaring	implicit
user	definition
format	conversion
operators..

CSharpUnsafe Boolean
Class,	Operation,
Attribute,
AssociationEnd

The	unsafe	keyword
indicates	unsafe
contexts.

CSharpNew BooleanClass,	Operation

The	new	modifier	is
used	for	explicitly
hiding	the	members
inherited	from	the
basic	classes.

CSharpStatic BooleanClass,	Operation,Attribute

The	static	modifier
is	used	for	declaring
not	specific	objects
but	static	members
that	belong	to
specific	formats.

CSharpConst BooleanAttribute

The	const	keyword
is	used	for	editing
declarations	of	data
members	or	local
variables.

CSharpVolatile BooleanAttribute,AssociationEnd

The	volatile
keyword	indicates
that	the	data
member	can	be
edited	in	the
program	by	threads
run	by	the	operating



system,	hardware,	or
both	at	the	same
time.

CSharpInternal BooleanClass,	Operation,Enumeration

The	internal
keyword	is	an
access	modifier	for
formats	and	format
members.	Internal
members	can	be
accessed	within	the
same	assembly	file
only.

CSharpBasetype String Enumeration

	
Each	enumeration
format	includes	an
integer	type	format
called	internal
format	of	the
enumeration	format.
This	internal	format
must	be	able	to
express	all
enumeration	values
defined	in	the
enumeration.

CShapEnumLiteralValue String EnumerationLiteral

	
Each	enumeration
member	contains	a
constant	value.	The
format	of	this	value
is	the	internal
format	of	the
enumeration.

CSharpDimension Integer
Parameter,
Attribute,
AssociationEnd

	
This	is	the	array
dimension	of	the
object	declared.



CSharpParameter Boolean Parameter

	
Parameter	arrays	are
parameters	declared
by	using	the
params
	
modifier.	If	the
parameter	array	is
included	in	the
format	parameter
list,
it	must	be	located	at
the	end	of	the
parameter	list	and	it
has	to	be	in
1-dimension	array
format.

DataTypes

C#	profile	contains	definitions	for	the	following	basic	C#	data	types.
	
bool

decimal

sbyte

byte

short

ushort

int

uint



long

ulong

char

float

double

object

string

void

	
	



.NET	BCL	Framework Top		Previous		Next

The	.NET	BCL	(Base	Class	Libraries)	Framework	is	the	C#	development
platform	model	included	in	C#	2	Standard	Edition.	In	StarUML(tm),	a	Model
Framework	refers	to	a	software	model	that	expresses	a	Class	Library	or
application	frameworks	such	as	MFC,	VCL,	and	JFC.	Using	a	framework	with
the	project	greatly	increases	the	convenience	of	the	user	for	modeling	software
that	depends	on	a	certain	class	library	or	application	framework.

Using	the	.NET	BCL	Framework
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Procedure	for	Importing	the	.NET	BCL	Framework	:

1. Select	the	[File]	->	[Import]	->	[Framework...]	menu.

2. At	the	[Import	Framework]	dialog,	select	the	.NET	BCL	Frameworkfrom	the	list	and	click	the	[OK]	button.
	

	

3.

The	Select	Element	dialog	box	will	appear	to	determine	in	which	element
the	.NET	BCL	framework	will	be	located.	Select	an	element	(package,
model,	subsystem	or	project)	to	contain	the	framework	and	then	click	the
[OK]	button.
	



	
4. The	framework	is	included	in	the	selected	element.

	Note

Importing	a	framework	does	not	store	the	framework	elements	in	the
project.	Since	framework	units	are	referenced	by	the	project,	the
framework	unit	files	must	be	present	when	opening	the	project.
To	delete	the	imported	frameworks,	remove	the	respective	framework
units.
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This	chapter	discusses	procedures	for	configuring	the	C#	Add-In	environment
and	describes	the	option	items	in	detail.

Code	Generation	Option	Configuration

Reverse	Engineering	Option	Configuration
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Code	Generation	Option	([Tools]	->	[Options...])	is	the	group	of	option	items
for	code	generation	by	C#	Add-In.	This	category	includes	the	[General],	[Code
Generation],	[Code	Style],	and	[File	Header]	sub-categories.

General

Option	Item Default Description
Generate	codes
even	when	there	is
no	profile

False
Specifies	whether	to	generate	codes	even	when	C#
profile	is	not	loaded	in	the	project	(not
recommended).

Code	Generation

Option	Item Default Description
Generate	1	file	each
for	Class,	Struct,
Interface,	and	Enum

True Specifies	whether	to	generate	1	file	each	for	1
member	(Class,	Struct,	Interface,	and	Enum).

Generate	unnamed False
Generates	unnamed	AssociationEnd	as	a
reference	type	field	for	C#	member.	In	this	case,



AssociationEnd the	field	identifier	is	indicated	as
"UnspecifiedType"	with	a	number	at	the	end.

Generate	C#	Doc False Specifies	whether	to	generate	modeling	element
documentation	as	C#	Doc.

Generate	empty	C#
Doc False

If	checked,	C#	Doc	is	generated	even	when	the
modeling	element	documentation	does	not	have
any	values	(empty).

Code	Style

Option	Item Default Description
Insert	tabs	as
spaces False Uses	space	instead	of	tab	for	indentation.

Tab	width 4 Specifies	the	number	of	spaces	to	be	used	when
inserting	tabs	as	spaces.

Place	the	opening
curly	brace	in	the
new	line

False Places	the	opening	curly	brace	"{"	in	the	new	line.

File	Header

Option	Item Default Description

File	Header
Comments

	
See

description

	
Adds	the	comments	in	the	beginning	of	the

source	file.

(Default)

//

//

//	Generated	by	StarUML(tm)	C#	Add-In

//

//	@@	Project	:	@p

//	@@	File	Name	:	@f

//	@@	Date	:	@d



//	@@	Author	:	@a

//

//
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Reverse	Engineering	Option	Configuration	([Tools]	->	[Options...])	is	the
group	of	reverse	engineering	option	items	for	C#	Add-In.	This	category
includes	the	[Model	Generation],	[Diagram]	and	[View]	sub-categories.

Model	Generation

Option	Item Default Description
Generate	public
member True Specifies	whether	to	generate	class	and	interface

members	with	public	visibility.
Generate	internal
member True Specifies	whether	to	generate	class	and	interface

members	with	internal	visibility.
Generate	protected
member True Specifies	whether	to	generate	class	and	interface

members	with	protected	visibility.
Generate	private
member True Specifies	whether	to	generate	class	and	interface

members	with	private	visibility.
Omit	initial	value	for
fields False Does	not	include	the	field	initial	value	in	the

Attribute	model	information.



Generate	C#	Doc	as
documentation False

it	as	documentation	information.	C#	Doc	of	each
method	is	analyzed	for	tag	information	and
entered	as	documentation	information	for	each
parameter	of	the	operation	model.

Generate	fields	as
Association False

Analyzes	the	field	information	in	the	source	code
to	establish	association	relationships	with	the
respective	field	type	models.	If	unchecked,	field
information	is	generated	as	attribute	for	the
respective	class	model.

Diagram

Option	Item Default Description

Generate	Overview
diagram True

Specifies	whether	to	generate	the	Overview
diagram	for	the	generated	model.	If	unchecked,
the	following	diagram	and	view	options	are
ignored.

Fit	the	diagram
area	to	the
generated	view
area

False Enlarges	the	Overview	diagram	to	fit	the
generated	view	area.

Diagram	name Overview
of	%s

Specifies	the	Overview	diagram	name.	The
package	name	can	be	included
in	the	diagram	name	by	using	%s	(e.g.	Overview
of	%s).

View

Option	Item Default Description
Suppress	the
Attribute
compartment	of
Class

False
Suppresses	the	Attribute	compartment	of	the
Class	View	when	generating	the	Overview
diagram.

Suppress	the
Operation	area	of
Class

False
Suppresses	the	Operation	compartment	of	the
Class	View	when	generating	the	Overview
diagram.

Hide	operation
signature False Hides	the	operation	signature	when	generating

the	Overview	diagram.



	
Generate
Generalization	and
Realization
views	only	for
relations

False

Generates	generalization	and	realization	views
only	for	relations	when
generating	the	Overview	diagram.	When	used
appropriately	with	other	view
options,	this	option	is	very	useful	for	drawing	the
inheritance	relations	of	overall	classes	and
interfaces	within	the	package.
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This	chapter	discusses	the	procedures	for	using	C#	reverse	engineering	and	the
concepts	of	reverse	engineering.

C#	Reverse	Engineering

Reverse	Engineering	Option	Configuration
	
	



C#	Reverse	Engineering Top		Previous		Next

	

Procedure	for	Reverse	Engineering	:

1.
In	StarUML(tm),	select	the	[Tools]	->	[C#]	->	[Reverse	Engineering...]

menu.

2.
At	the	[Select	Source	Code]	page	in	the	[C#	Reverse	Engineering]
dialog	box,	select	a	source	and	click	[Add].	Click	[Next]	once	you	have
completed	adding	the	target	sources	for	reverse	engineering.
	

	

3. At	the	[Select	the	Package	to	contain	result]	page,	select	a	package	tocontain	the	output	results	from	the	package	tree	and	click	[Next].
	



	

4. At	the	[Option	Setup]	page,	select	the	reverse	engineering	options	andclick	[Run].	Reverse	engineering	will	start	now.
	



	

5. The	[Reverse	Engineering]	page	will	show	the	reverse	engineeringprogress	status	and	return	reverse	engineering	failure	or	success	results.
	



Note

If	C#	reverse	engineering	is	executed	without	including	C#	profile,	the
following	dialog	box	will	appear	asking	whether	you	want	to	include	C#
profile.	Select	"Yes(Y)"	to	continue	the	reverse	engineering	process.
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Reverse	Engineering	Option	Setup	Screen

This	is	the	screen	for	configuring	the	options	required	for	C#	reverse
engineering.

Model	Generation

Model	Generation	includes	various	options	for	model	generation.
Item Description
Generate	C#
doc	to	model
documentation

Specifies	whether	to	generate	C#	Document	as	StarUML(tm)
model	documentation.

Omit	field
initial	values Specifies	whether	to	omit	the	initial	values	for	C#	fields.

public Specifies	whether	to	generate	elements	with	public	access



modifiers.

package Specifies	whether	to	generate	elements	with	package	access
modifiers.

protected Specifies	whether	to	generate	elements	with	protected	access
modifiers.

private Specifies	whether	to	generate	elements	with	private	access
modifiers.

Reference	Field	Creation

Reference	Field	Creation	specifies	generation	methods	for	reference	fields	when
generating	models.
Item Description
Generate	the
field	to	the
Attributes

Specifies	whether	to	generate	C#	fields	as	StarUML(tm)	model
attributes.

Generate	the
field	to	the
Associations

Specifies	whether	to	generate	C#	fields	as	StarUML(tm)	model
associations.

Diagram

Diagram	specifies	diagram	generation	and	the	default	generation	names.
Item Description
Create
Overview
diagram

Specifies	whether	to	generate	Overview	diagram	when
generating	model.

The	name	of
Diagram

Specifies	names	for	Overview	diagram	generation.	The	string	%s
is	automatically	replaced	by	the	package	name.

View

View	specifies	view-related	options	after	model	generation.
Item Description
Suppress	the
Attribute
compartment

Suppresses	the	attribute	area	of	class	models.

Suppress	the



Operation
compartment

Suppresses	the	operation	area	of	the	class	models.

Hide
operation
signature

Specifies	whether	to	display	all	signatures	for	operation
elements.

Generate
generalization
and
realization
views	only

Specifies	whether	to	generate	generalization	and	realization
views	only	for	the	models	generated.
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This	chapter	discusses	the	procedures	for	using	C#	code	generation	and	the
concepts	of	forward	engineering.

C#	Code	Generation

Code	Generation	Option	Configuration
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Procedure	for	Code	Generation	:

1. In	StarUML(tm),	select	the	[Tools]	->	[C#]	->	[Generate	code...]	menu.

2. At	the	[Select	Package	Starting	Location]	page	in	the	[Generatecode...]	dialog	box,	select	a	package	and	click	[Next].
	

	

3. At	the	[Select	the	code	generation	element]	page,	select	the	elementsand	click	[Next].
	



	

4. At	the	[Select	Output	Directory]	page,	select	a	directory	to	save	theoutput	sources	and	click	[Next].
	



	

5. At	the	[Option	Setup]	page,	select	options	and	click	[Next].	Reverseengineering	will	start	now.
	



	

6. The	[Code	Generation]	page	will	show	the	code	generation	progressstatus	and	return	code	generation	failure	or	success	results.
	



Note

The	following	error	will	occur	if	C#	code	generation	is	executed	without
including	C#	profile.	Please	ensure	that	C#	profile	is	included	in	the
project	before	executing	code	generation.
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Code	Generation	Option	Setup	Screen

This	is	the	screen	for	configuring	the	options	required	for	code	generation.

Generation	Options

Generation	options	are	model-related	options	for	code	generation.
Item Description
Generate	one	file
for	each	element Specifies	whether	to	generate	one	file	for	each	element.

Generate
unnamed
AssociationEnd

Specifies	whether	to	generate	code	for	unnamed
AssociationEnds.

Generate
documentation	as
C#	Doc

Specifies	whether	to	generate	StarUML(tm)	model
documentation	as	C#	Doc.



Generate	empty
C#	Doc

Specifies	whether	to	generate	empty	StarUML(tm)
documentation.

Code	Style	Options

Code	Style	options	are	text-related	options	for	code	generation.
Item Description
Place	the
opening	curly
brace	in	the	new
line

Places	the	opening	curly	brace	"{"	in	the	new	line.

Insert	tab	as
space Uses	space	instead	of	tab	for	indentation.

Tab	width Specifies	the	number	of	spaces	to	be	used	when	inserting	tabs
as	spaces.

File	Header	Comments

File	Header	Comments	defines	the	comments	for	each	file	head
Item Description

File	header
comments

Contains	the	comments	to	be	inserted	in	the	beginning	of	the
source	file.	As	described	in	the	"header	comments
description"	section,	the	'@'	symbol	and	alphanumeric
characters	can	be	used	to	insert	specific	values	here.
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The	following	are	frequently	asked	questions	and	answers	for	using	C#	Add-In.
	

1. What	are	the	C#	Language	versions	supported	by	C#	Add-In?

2. I	get	a	"C#	Profile	is	not	loaded"	warning	window	when	generating	code.What	does	this	mean?

	
1.What	are	the	C#	Language	versions	supported	by	C#	Add-In?
	
C#	Add-In	supports	C#	Language	Specification	version	1.2,	which	is	the
most	widely	used	version.	C#	Add-In	also	supports	the	ECMA-334
standard.
	

	

2. I	get	a	"C#	Profile	is	not	loaded"	warning	window	when	generatingcode.	What	does	this	mean?
	
C#	Profile	must	be	included	in	order	to	use	the	C#	code	generation
function.	Including	C#	Profile
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